安装

示例 参见 过程 其它
安装

该章节包括以下主题的信息:
  • 安装说明
  • 同时安装
  • 许可
  • 安装的系统要求
  • 安装日志
  • 开始安装
  • 显示已安装的软件
  • 修改或更新已安装的产品
  • 修复已安装产品
  • 启动卸载
  • 安装更新与支持包
  • 自动安装支持包
  • 安装和卸载移植工具
  • 安装和卸载 TIA 项目服务器


安装说明

内容 有关虚拟系统中安装（私有云） 自动安装 在安装期间使用相同的 TIA Portal 产品版本 安装的目标目录 WinCC 安装的安全设置 使用防病毒程序 与 V12 SP1 和 V13 的兼容性 有关 TIA Portal 的常见问题与解答
安装说明

内容

在线帮助中未包含的信息和有关产品特性的重要信息。

有关虚拟系统中安装（私有云）

有关在虚拟系统（私有云）中 TIA Portal 的安装方式，请参见安装数据介质中“Documents\Readme\<语言目录>”目录下的操作指南。单击“TIAPortalCloudConnectorHowTo<语言 ID>.pdf”，打开该 PDF 文档。

自动安装

在产品 DVD 上的“Documents\Readme\<语言目录>”目录下提供有关于自动安装的说明。

在安装期间使用相同的 TIA Portal 产品版本

安装不同的 TIA Portal 产品时，请确保使用相同的服务包和更新版本进行安装。例如，如果已安装 STEP 7 V13 SP1，则还必须安装 WinCC V13 SP1。与此同时，所有产品都必须安装服务包和更新。请勿启动 TIA Portal，直至所有产品完成升级。

相关服务包，可从 Internet 上下载：西门子工业在线支持网站。

安装的目标目录

在安装路径中，请勿使用任何 UNICODE 字符（如，中文字符）。

安装 TIA Portal 产品后，安装路径不能更改。

WinCC 安装的安全设置

安装 WinCC 时，操作系统中的安全设置将发生变更。安装期间会列出这些安全设置。

用户必须确认安全设置发生的更改。

如果安装后对操作系统进行了更改，安装 TIA Portal 可能会更改安全设置。

可通过按以下方式安装 TIA Portal 恢复安全设置：
“开始 > 所有程序 > Siemens Automation > 安全控制器 > 恢复设置”(Start > All Programs > Siemens Automation > Security Controller > Restore settings)。

使用防病毒程序

在安装过程中，需要对已安装的文件进行读写访问。有些防病毒程序可能会阻止对这些文件进行访问。因此，需要对这些防病毒程序进行组态，从而允许访问 TIA Portal 安装文件。

与 V12 SP1 和 V13 的兼容性

通过将先前版本中的空项目安装在 ..\<INSTALLDIR>\Sample Projects 下的安装目录中，允许以兼容性模式打开最新的 TIA Portal。必须使用完全访问权限将这些项目复制到本地目录中，才能使用它们。有关此部分的详细信息，请参见 FAQ ID 82169157。

有关 TIA Portal 的常见问题与解答

有关 TIA Portal 的常见问题与解答，敬请访问常见问题与解答。


同时安装

WinCC V16 和其它 SIMATIC HMI 产品的同时安装 同时使用
同时安装

WinCC V16 和其它 SIMATIC HMI 产品的同时安装

不允许同时安装 WinCC V16 与 WinCC Flexible 2008 SP5 之前版本的 WinCC Flexible。

不允许同时安装 WinCC V16 Comfort/Advanced 与 WinCC V7.3 之前版本的 WinCC。

安装以下版本的 WinCC V16 时，不允许同时安装 WinCC V7.3、WinCC V7.4 或 WinCC V7.5：

  • WinCC V16 Professional

  • WinCC V16 Runtime Professional

同时使用

安装后如果软件名称或许可密钥中出现术语“Combo”，则表示根据“一般条款和条件”第 4.3 部分（另请参见安装程序文本），可使用以下产品/版本：

  • 许可证为“STEP 7 Professional Combo”：STEP 7 (STEP 7 Professional 2006 - STEP 7 Professional V16) 的之前版本

  • 许可证为“WinCC V16 Comfort Combo”：WinCC flexible 2008 Standard

  • 许可证为“WinCC V16 Advanced Combo”：WinCC flexible 2008 Advanced


许可

许可

该章节包括以下主题的信息:
  • 许可证注意事项
  • STEP 7 和 WinCC 授权
  • 处理许可证和许可密钥
  • HMI 设备的许可方式
  • 对基于 PC 的 HMI 设备上的 WinCC Runtime 进行授权
  • 授权 WinCC Runtime Professional Asian
  • 不带 STEP 7 许可证的 PC-CP


许可证注意事项

许可的可用性 Automation License Manager 的提供方式 使用 Automation License Manager
关于系统要求的说明 开始安装 显示已安装的软件 修改或更新已安装的产品 修复已安装产品 启动卸载 安装日志
许可证注意事项

许可的可用性

TIA Portal 的产品许可证通常位于安装数据介质中，并在 TIA Portal 的安装过程中由 Automation License Manager 自动传输。

卸载 TIA Portal 之前，必须转移和备份仍需要的许可证。为此，可使用 Automation License Manager。

Automation License Manager 的提供方式

Automation License Manager 包含在安装数据介质中，并在安装过程中自动传输。

即便卸载了 TIA Portal，Automation License Manager 仍会安装在系统上。

使用 Automation License Manager

Automation License Manager 是一款 Siemens AG 产品，用于处理许可密钥（许可的技术表示）。

需要许可密钥来进行操作的软件产品（如 TIA Portal），可通过 Automation License Manager 自动注册所需的许可密钥。如果 Automation License Manager 为此软件提供了有效的许可密钥，可以根据与许可密钥相关的许可使用条款来使用此软件。

说明

关于如何通过 Automation License Manager 管理许可的更多信息，请参见 Automation License Manager 随附的文档。


STEP 7 和 WinCC 授权

简介 许可证 许可密钥对旧版本 STEP 7 的有效性 许可密钥对旧版本 WinCC 的有效性 许可证对 WinCC 选件的有效性 未使用有效的许可密钥启动 仿真的许可证要求 TIA Portal 云连接程序的许可证
处理许可证和许可密钥
STEP 7 和 WinCC 授权

简介

要对以下 STEP 7 版本进行授权许可时，需使用 License Key：

  • STEP 7 Basic

  • STEP 7 Professional

可以在安装完成后使用 Automation License Manager 为 STEP 7 安装对应的 License Key。

下列软件需要 WinCC 的 License Key：

  • WinCC 工程组态系统

  • WinCC Runtime

  • WinCC 工程组态系统的选件

  • WinCC Runtime 系统的选件

使用 Automation License Manager 安装后，便会传送 WinCC 和 WinCC 插件的许可证。

说明

此外，被许可方应确认微软公司或其子公司的软件 (SW) 包含授权的软件。至此，被许可方同意受约束并遵守 Microsoft SQL Server 和最终用户间附加许可证协议中的条款和条件

许可证

提供以下许可证和相应 License Keys：

  • STEP 7 Basic

  • STEP 7 Professional

  • STEP 7 Professional Combo

  • WinCC Basic

  • WinCC Comfort

  • WinCC Comfort Combo

  • WinCC Advanced

  • WinCC Advanced Combo

  • WinCC Professional

  • WinCC Professional Combo

  • WinCC Unified Comfort Engineering

  • WinCC Unified PC Engineering

  • WinCC RT Advanced

  • WinCC RT Professional

  • WinCC Unified PC

许可密钥对旧版本 STEP 7 的有效性

如果 STEP 7 Professional 和 STEP 7 Professional Combo V15.x 具有有效的 License Key，则操作旧版本 STEP 7 不受任何限制。下表提供了更多相关的详细信息：

版本

许可证

适用于

STEP 7 Basic V16.x

STEP 7 Basic

  • STEP 7 Basic V16.x

  • STEP 7 Basic V15.x

  • STEP 7 Basic V14.x

  • STEP 7 Basic V13.x

  • STEP 7 Basic V12.x

  • STEP 7 Basic V11.x

  • STEP 7 Basic V10.5

STEP 7 Professional V16.x

STEP 7 Professional

  • STEP 7 Professional V16.x

  • STEP 7 Professional V15.x

  • STEP 7 Professional V14.x

  • STEP 7 Professional V13.x

  • STEP 7 Professional V12.x

  • STEP 7 Professional V11.x

  • STEP 7 Basic V14.x

  • STEP 7 Basic V13.x

  • STEP 7 Basic V12.x

  • STEP 7 Basic V11.x

  • STEP 7 Basic V10.5

STEP 7 Professional V16.x

STEP 7 Professional Combo

  • STEP 7 Professional V16.x

  • STEP 7 Professional V15.x

  • STEP 7 Professional V14.x

  • STEP 7 Professional V13.x

  • STEP 7 Professional V12.x

  • STEP 7 Professional V11.x

  • STEP 7 Basic V14.x

  • STEP 7 Basic V13.x

  • STEP 7 Basic V12.x

  • STEP 7 Basic V11.x

  • STEP 7 Basic V10.5

  • STEP 7 V5.6

  • STEP 7 V5.5

  • STEP 7 V5.4

  • STEP 7 Professional 2017

  • STEP 7 Professional 2010

  • STEP 7 Professional 2006

许可密钥对旧版本 WinCC 的有效性

如果具有有效的 WinCC V16.x License Key，还可以不受限制地操作旧版本 WinCC。

更多详细信息，请参见下表：

WinCC 工程组态系统

版本

许可证

适用于

WinCC Basic V16.x

WinCC Basic

  • WinCC Basic V11.x

  • WinCC Basic V12.x

  • WinCC Basic V13.x

  • WinCC Basic V14.x

  • WinCC Basic V15.x

  • WinCC Basic V16.x

WinCC Comfort/Advanced V16.x

WinCC Comfort

  • WInCC Basic V11.x

  • WinCC Comfort V10.x

  • WinCC Comfort V11.x

  • WinCC Basic, Comfort V12.x

  • WinCC Basic, Comfort V13.x

  • WinCC Basic, Comfort V14.x

  • WinCC Basic, Comfort V15.x

  • WinCC Basic, Comfort V16.x

WinCC Comfort Combo

  • WinCC flexible Compact，Standard >= 2005

  • WInCC Basic V11.x

  • WinCC Comfort V10.x

  • WinCC Comfort V11.x

  • WinCC Basic, Comfort V12.x

  • WinCC Basic, Comfort V13.x

  • WinCC Basic, Comfort V14.x

  • WinCC Basic, Comfort V15.x

  • WinCC Basic, Comfort V16.x

WinCC Advanced

  • WInCC Basic V11.x

  • WinCC Comfort, Advanced V10.x

  • WinCC Comfort, Advanced V11.x

  • WinCC Basic, Comfort, Advanced V12.x

  • WinCC Basic, Comfort, Advanced V13.x

  • WinCC Basic, Comfort, Advanced V14.x

  • WinCC Basic, Comfort, Advanced V15.x

  • WinCC Basic, Comfort, Advanced V16.x

  • WinCC Unified Comfort V16.x

  • WinCC Unified PC V16.x

WinCC Advanced Combo

  • WinCC flexible Compact，Standard，Advanced >= 2005

  • WInCC Basic V11.x

  • WinCC Comfort, Advanced V10.x

  • WinCC Comfort, Advanced V11.x

  • WinCC Basic, Comfort, Advanced V12.x

  • WinCC Basic, Comfort, Advanced V13.x

  • WinCC Basic, Comfort, Advanced V14.x

  • WinCC Basic, Comfort, Advanced V15.x

  • WinCC Basic, Comfort, Advanced V16.x

  • WinCC Unified Comfort V16.x

  • WinCC Unified PC V16.x

WinCC Professional V16.x

WinCC Professional (512)

WinCC Professional (4096)

WinCC Professional (max.)

  • WinCC Comfort, Advanced, Professional V10.x

  • WinCC Comfort, Advanced, Professional V11.x

  • WinCC Basic, Comfort, Advanced, Professional V12.x

  • WinCC Basic, Comfort, Advanced, Professional V13.x

  • WinCC Basic, Comfort, Advanced, Professional V14.x

  • WinCC Basic, Comfort, Advanced, Professional V15.x

  • WinCC Basic, Comfort, Advanced, Professional V16.x

  • WinCC Unified Comfort V16.x

  • WinCC Unified PC V16.x

WinCC Professional (512) Combo

WinCC Professional (4096) Combo

WinCC Professional (max.) Combo

  • WinCC flexible Compact，Standard，Advanced >= 2008 SP3

  • WinCC SCADA V7.0 SP3 ES

  • WinCC Comfort, Advanced, Professional V10.x

  • WinCC Comfort, Advanced, Professional V11.x

  • WinCC Basic, Comfort, Advanced, Professional V12.x

  • WinCC Basic, Comfort, Advanced, Professional V13.x

  • WinCC Basic, Comfort, Advanced, Professional V14.x

  • WinCC Basic, Comfort, Advanced, Professional V15.x

  • WinCC Basic, Comfort, Advanced, Professional V16.x

  • WinCC Unified Comfort V16.x

  • WinCC Unified PC V16.x

WinCC Unified Comfort V16.x

WinCC Unified Comfort ES

  • WInCC Basic V11.x

  • WinCC Comfort V10.x

  • WinCC Comfort V11.x

  • WinCC Basic, Comfort V12.x

  • WinCC Basic, Comfort V13.x

  • WinCC Basic, Comfort V14.x

  • WinCC Basic, Comfort V15.x

  • WinCC Basic, Comfort V16.x

  • WinCC Unified Comfort V16.x

WinCC Unified PC V16.x

WinCC Unified PC (10k) ES

  • WinCC Basic V11.x

  • WinCC Comfort, Advanced V10.x

  • WinCC Comfort, Advanced V11.x

  • WinCC Basic, Comfort, Advanced V12.x

  • WinCC Basic, Comfort, Advanced V13.x

  • WinCC Basic, Comfort, Advanced V14.x

  • WinCC Basic, Comfort, Advanced V15.x

  • WinCC Basic, Comfort, Advanced V16.x

  • WinCC Unified PC V16.x

WinCC Unified PC (100k) ES

WinCC Unified PC (max.) ES

  • WinCC Comfort, Advanced, Professional V10.x

  • WinCC Comfort, Advanced, Professional V11.x

  • WinCC Basic, Comfort, Advanced, Professional V12.x

  • WinCC Basic, Comfort, Advanced, Professional V13.x

  • WinCC Basic, Comfort, Advanced, Professional V14.x

  • WinCC Basic, Comfort, Advanced, Professional V15.x

  • WinCC Basic, Comfort, Advanced, Professional V16.x

  • WinCC Unified PC V16.x

WinCC Runtime

版本

许可证

适用于

WinCC RT Advanced V16.x

WinCC RT Advanced (128)

WinCC RT Advanced (512)

WinCC RT Advanced (2048)

WinCC RT Advanced (4096)

WinCC RT Advanced (8192)

WinCC RT Advanced (16384)

  • WinCC RT Advanced V11.x

  • WinCC RT Advanced V12.x

  • WinCC RT Advanced V13.x

  • WinCC RT Advanced V14.x

  • WinCC RT Advanced V15.x

  • WinCC RT Advanced V16.x

WinCC RT Professional V16.x

WinCC RT Professional (128)

WinCC RT Professional (512)

WinCC RT Professional (2048)

WinCC RT Professional (4096)

WinCC RT Professional (8192)

WinCC RT Professional (65536)

WinCC RT Professional (102400)

WinCC RT Professional (153600)

WinCC RT Professional (262144)

  • WinCC RT Professional V11.x

  • WinCC RT Professional V12.x

  • WinCC RT Professional V13.x

  • WinCC RT Professional V14.x

  • WinCC RT Professional V15.x

  • WinCC RT Professional V16.x

WinCC Unified PC V16.x

WinCC Unified PC (150) RT

WinCC Unified PC (500) RT

WinCC Unified PC (1k) RT

WinCC Unified PC (2,5k) RT

WinCC Unified PC (5k) RT

WinCC Unified PC (10k) RT

WinCC Unified PC (50k) RT

WinCC Unified PC (100k) RT

WinCC Unified PC (max.) RT

  • WinCC Unified PC V16.x

许可证对 WinCC 选件的有效性

WinCC 选件的 License Keys 通常不限版本。WinCC 选件 V16.x 可使用 V11、V12、V13、V14 和 V15 版本的 License Keys ，反之亦然。

未使用有效的许可密钥启动

如果启动 TIA Portal 时不具备有效 License Key ，则系统将提醒当前运行在未授权模式下。您将有一次机会可以激活 Trial License。但是，该试用许可证有一个仅 21 天的有效期。

当 Trial License 到期后，会发生下列情况：

  • 当前 PC 上从未获得 TIA Portal 的许可：

    • 基于许可的操作不能在 TIA Portal 中执行。

  • 当前 PC 中已获得 TIA Portal 的许可：

    • 非授权模式下每隔 10 分钟就会出现一个警告窗口提醒用户确认，每次执行需要许可证的操作时也会出现这样一个警告窗口提醒用户确认。

仿真的许可证要求

当使用菜单命令“在线 > 仿真”(Online > Simulation) 在 STEP 7 中启动仿真时，无需额外的许可证。

如果满足以下条件，仿真还要求用户具有已安装 STEP 7 版本的相应许可证。

  • 工程师站连接到 PLC。

  • 与 PLC 的连接已组态且处于活动状态。

如果在 WinCC 中使用菜单命令“在线 > 仿真 > 使用变量仿真器”(Online > Simulation> With tag simulator)来启动仿真，则无需用于 WinCC Runtime 或许可选件的许可证。

如果满足下列条件，同样需要适当的许可证来仿真 WinCC Runtime 和许可选件：

  • 工程师站连接到 PLC。

  • 与 PLC 的连接已组态且处于活动状态。

  • 使用菜单命令“在线 > 仿真”(Online > Simulation) 启动仿真。

TIA Portal 云连接程序的许可证

要使用 TIA Portal 云连接程序，TIA Portal 云连接程序中指定为“用户设备”的每台设备上都需要具有有效的 License Key。在此类设备上安装 TIA Portal 时，也需要该 License Key。对于那些用作“远程设备”的设备而言，无需 License Key。


处理许可证和许可密钥

简介 试用许可证 为 STEP 7 安装许可密钥 为 WinCC 安装许可密钥 将许可密钥传送到 HMI 设备中 卸载许可密钥 修改工程组态系统的数据介质 备份设备的备份（备份/恢复） 时区更改后许可证无效 损坏的许可证 Microsoft SQL Server
STEP 7 和 WinCC 授权
处理许可证和许可密钥

简介

每种情况需要一个有效的 License Key，以使用 STEP 7 Basic、STEP 7 Professional、WinCC Engineering System 以及 WinCC Engineering System 和 WinCC Runtime 的选件。

注意

复制操作会导致许可密钥损坏

License Key 不能复制。防拷贝保护将阻止复制 License Keys 遭复制。如果尝试复制 License Key，则将导致许可密钥损坏。

试用许可证

如果启动 TIA Portal 时不具备有效 License Key，则系统将提醒当前运行在未授权模式下。此时，可激活一次试用许可证。试用许可证将在 21 天后到期。

当试用许可证到期后，可能发生以下状况：

  • 当前 PC 上从未获得 TIA Portal 的许可：

    TIA Portal 无法启动。

  • 当前 PC 中已获得 TIA Portal 的许可：

    可启动 TIA Portal。每隔 10 分钟，将出现一个非授权模式的提示窗口，必须对其进行确认。

为 STEP 7 安装许可密钥

在安装 STEP 7 Basic 时，将自动安装 License Key。在安装 STEP 7 Professional 时，将在安装结束时提示您使用 Automation License Manager 将许可证从提供的存储介质传送到您的 PC 上。

如果想要安装额外的 License Keys，则必须使用 Automation License Manager 执行该操作。

在传送许可证时，相关的 License Key 将从 License Keys 存储位置上删除。

说明

完成安装后，始终保留 License Keys 的原始存储位置。

为 WinCC 安装许可密钥

在安装 WinCC Basic 时，将自动安装 License Key。在安装 WinCC Professional 时，将在安装结束时提示您使用 Automation License Manager 将许可证从提供的存储介质传送到您的 PC 上。

需要额外的 License Keys 来使用 WinCC Runtime 或通过菜单命令“在线 > 仿真 > 启动” (Online > Simulation > Start) 在 Engineering-PC 中进行仿真。为此需要使用 Automation License Manager。

在传送许可证时，相关的 License Key 将从 License Keys 存储位置上删除。

说明

完成安装后，始终保留 License Keys 的原始存储位置。

将许可密钥传送到 HMI 设备中

必须将“License Keys”传送到 HMI 设备来操作 WinCC。

在下列情况下需要将 License Key 传送到 HMI 设备：

  • 操作 WinCC Runtime

  • 使用 WinCC Runtime 的插件

将许可证传送到 HMI 设备时，相关 License Key 将 License Keys 存储位置删除。

如果您不再需要许可证或需要备份数据，必须从操作员面板传送 License Keys。之后可以在其它 PC 或 HMI 设备上使用该许可证。

卸载许可密钥

请始终使用 Automation License Manager 卸载许可密钥 License Keys。以下情况需要卸载 License Key：

  • 备份数据时。

  • 不再需要许可证时。

可以在其它 PC 中使用有效许可证。

修改工程组态系统的数据介质

修改工程组态系统的数据介质，会损坏 License Key。要执行该操作，请在修改前打开 Automation License Manager 并将待卸载的 License Key 备份至其它存储位置。

注意

PC 中的许可密钥损坏

首先，如果执行下列操作之一，请卸载所有 License Keys：

  • 格式化硬盘

  • 压缩硬盘

  • 恢复硬盘

  • 启动移动固定块的优化程序

  • 安装新操作系统

请仔细阅读 Automation License Manager 的说明（“开始 > Simatic 自动化 > 文档”(Start > Simatic Automation > Documentation)）。请遵守所有警告和注意事项。

备份设备的备份（备份/恢复）

在 HMI 设备中备份数据时，将在 HMI 设备中移除 License Keys。为此，可打开 Automation License Manager 并将已卸载的许可密钥 License Key 备份到其它存储位置。

注意

非基于 PC 的 HMI 设备中许可密钥损坏

在以下 HMI 设备中，执行备份/恢复操作将导致所传送的许可密钥损坏：

  • 270 系列

  • 370 系列

开始执行恢复操作前，请执行以下操作：

  • 使用 Automation License Manager 和 ProSave，检查 HMI 设备中是否有 License Keys。

  • 传送 HMI 设备中的既有 License Keys。

    恢复执行完成后，将 License Keys 传回 HMI 设备。

时区更改后许可证无效

如果按照下列方法更改了 PC 的时区，已安装的许可证将不再工作：从基于整点的时区更改为不基于整点的时区

为了避免这种不便，请在安装 License Keys 时的时区设置下使用 Automation License Manager 卸载 License Key。

示例：要在时区“GMT +3:30”中，使用时区为“GMT +3:00”的 HMI 设备。

  1. 卸载时区设置为“GMT +3:00”的 License Key。

  2. 在您的 PC 中相应地更改时区设置。

  3. 安装 License Key。

此方式不适用于试用许可证。

损坏的许可证

下列情况下许可证损坏：

  • 如果无法继续访问存储区的 License Key。

  • 如果 License Key 在传送到目标驱动器的过程中丢失。

说明

将系统日期重新设置为更早的时间会导致所有许可证无效。

可以使用 Automation License Manager 修复损坏的许可证。为此，可使用 Automation License Manager 的“恢复”功能或“恢复向导”。请联系客户支持人员恢复许可证。更多详细信息，敬请访问 Internet：http://support.automation.siemens.com

说明

即使许可证丢失或损坏，仍然可以无故障地操作运行系统。系统将不断地提醒您当前正在未经授权的模式下工作。

Microsoft SQL Server

使用 Microsoft SQL Server 服务器时，需要具有许可证。该许可证包含在已安装且具有相应许可证的 WinCC 中。

WinCC 安装包中包含的具有许可证的 SQL Server 只能与 WinCC 一同使用。

用于以下用途时，需要具有其它许可证。例如：

  • 用于自定义的数据库

  • 用于第三方应用

  • 使用 WinCC 中未包含的 SQL 访问机制。

卸载

卸载 WinCC 后，必须卸载“WinCC”SQL Sever 实例。为此，可在“控制面板 > 程序”(Control Panel > Programs) 中，选择条目“Microsoft SQL Server 20..”并进行卸载。


HMI 设备的许可方式

许可密钥 有关使用许可证的说明 非授权模式
HMI 设备的许可方式

不基于 PC 的 HMI 设备具备运行系统许可证。运行系统工作不需要 License Key。

不基于 PC 的 HMI 设备的插件可能需要许可证。相应许可证的 License Key 始终激活一个插件来使用。

许可密钥

要授予不基于 PC 的 HMI 设备 License Keys，需要“SIMATIC HMI 许可证管理器面板插件”插件。

WinCC 安装程序默认会安装此插件。可以在自动化许可证管理器中使用“编辑 > 连接目标系统 > 连接 HMI 设备”(Edit > Connect Target System > Connect HMI Device) 菜单命令打开许可证管理器面板插件。

如果未安装 WinCC，则需要安装 ProSave 7.2 或更高版本。

有关使用许可证的说明

  • 有关许可证处理的更多信息，请参见自动化许可证管理器的帮助文件。

  • 启动许可前，请验证 HMI 设备上安装的操作系统的当前版本（或更高版本）。如有必要，请使用 ProSave 更新操作系统。

  • 此外，被许可方应确认微软公司或其子公司的软件 (SW) 包含授权的软件。至此，被许可方同意受约束并遵守 Microsoft SQL Server 和最终用户间附加许可证协议中的条款和条件

非授权模式

运行系统插件可在没有有效许可证的情况下短时间内无限制使用。每隔 10 分钟，将出现一个非授权模式的提示窗口，必须对其进行确认。


对基于 PC 的 HMI 设备上的 WinCC Runtime 进行授权

许可密钥 有关使用许可证的说明 非授权模式
对基于 PC 的 HMI 设备上的 WinCC Runtime 进行授权

许可密钥

在基于 PC 的 HMI 设备中，以下组件需要许可密钥：

  • 带有 128 个变量的 WinCC Runtime。

  • WinCC 插件

在安装 WinCC 的过程中，可安装 WinCC Runtime 的许可密钥。使用自动化许可证管理器安装后，便会传送 WinCC 插件的许可证。

说明

仅有 WinCC Runtime V15.1 许可证证书才授权运行 WinCC Runtime V15.1

需要适当的新许可证对 WinCC Runtime 进行授权。

通过升级到 WinCC Runtime V15.1，可对 WinCC flexible 2008 和 WinCC V7 的运行系统许可证进行升级。

只有当存在符合软件中列出版本的有效许可证证书时，才能实现软件的生产性运行。

有关使用许可证的说明

  • 将较旧版本升级到版本 V15 时，需要新的 WinCC Runtime Professional 许可证。

  • 此外，被许可方应确认微软公司或其子公司的软件 (SW) 包含授权的软件。至此，被许可方同意遵守 Microsoft SQL Server 和最终用户间附加许可证协议中的条款和条件，并履行相同的义务。

非授权模式

WinCC Runtime 和运行系统插件可无许可证自由使用。每隔 10 分钟，将出现一个非授权模式的提示窗口，必须对其进行确认。


授权 WinCC Runtime Professional Asian

简介 对 Asian Runtime Professional 使用加密狗 仿真亚洲语言的 WinCC 项目
授权 WinCC Runtime Professional Asian

简介

如果正在使用亚洲语言版本的 WinCC Runtime Professional，则还需要一个加密狗来验证所需的许可证。 该加密狗以经过认证的 U 盘的形式提供，里面包含 WinCC Runtime Professional Asian 所需的许可证密钥。 许可证密钥存储在经过认证的 USB 闪存驱动器中。

下列亚洲语言受到加密狗的保护：

  • 简体中文

  • 繁体中文

  • 日语

  • 韩语

对 Asian Runtime Professional 使用加密狗

为了成功地授权亚洲语言的 WinCC 项目，需要使用“自动化许可证管理器”将所需许可证密钥从经过认证的 U 盘传送到 HMI 设备。 将 USB 插入 HMI 设备的 USB 端口。 在运行期间 U 盘作为加密狗。 在运行期间加密狗必须始终插在 USB 端口中。

如果在运行期间拔下加密狗，WinCC Runtime 会切换到演示模式。

针对亚洲市场提供的 U 盘经过认证，可以在生产中永久使用。 因此，无法将内容传送或复制到另一个磁盘或 USB 介质中。 如果经过认证的 U 盘丢失或损坏，则需要一个新的经过认证的 U 盘。

仿真亚洲语言的 WinCC 项目

随后还需要经过认证的 U 盘作为仿真的加密狗。 如果没有加密狗，则仿真会以演示模式运行。


不带 STEP 7 许可证的 PC-CP

PC-CP 上的 STEP 7 的功能 信息系统 升级为 STEP 7 Professional 的功能范围
不带 STEP 7 许可证的 PC-CP

PC-CP 上的 STEP 7 的功能

PC-CP 上所安装的 STEP 7 是完整版本的 STEP 7，但不带许可证。该版本仅支持对以下组件进行组态和诊断：

  • PC 站上的 PC-CP 和应用程序（OPC 服务器）

  • SCALANCE X 交换机

  • SCALANCE W / SCALANCE M 路由器

  • SCALANCE S 安全模块

  • PROFINET IO 设备和 PROFIBUS DP 从站

  • IE/PB LINK PN IO, IWLAN/PB LINK PN IO

  • 读码器 (RFID) 和光学阅读器 (MV)

SIMATIC 站和 WinAC 组件仅在网络和拓扑视图中可用（在设备视图中不可用）。不支持编程功能。

信息系统

在 STEP 7 中的 PC-CP 信息系统中，详细介绍了 STEP 7 的所有功能。因此应注意，这些功能仅限于上文所列设备组的组态。

升级为 STEP 7 Professional 的功能范围

PC-CP 上安装的 STEP 7 具有工程师站上可用的所有 STEP 7 功能，但功能使用存在限制。

在安装许可证之后，可随时升级使用 STEP 7 的所有功能，而无需进行全新安装。一旦安装了许可证，则可以继续使用之前在 PC-CP 上由 STEP 7 所创建的所有项目，而不受任何限制。


安装的系统要求

安装的系统要求

该章节包括以下主题的信息:
  • 关于系统要求的说明
  • 软件和硬件的基本要求
  • 产品特定的特性


关于系统要求的说明

各款产品的系统要求 显示 PDF 文件 显示欢迎页面 Windows 7 和 Windows Server 2008 R2：无效证书验证 在 Windows 7 中安装时的注意事项 Windows 10：字符集
许可证注意事项 开始安装 显示已安装的软件 修改或更新已安装的产品 修复已安装产品 启动卸载
关于系统要求的说明

各款产品的系统要求

系统要求随待安装品的不同而不同。因此，您应当检查具体产品的系统要求。

如果要安装多个产品，请确保您的系统满足其中的最高要求。

显示 PDF 文件

为能够阅读所提供的 PDF 文件，需要使用与 PDF 1.7 兼容的 PDF 阅读器，例如 Adobe (R) Reader V9。

显示欢迎页面

要体验 TIA Portal 之旅，需安装 Adobe (R) Flash Player V9 或更高版本。

Windows 7 和 Windows Server 2008 R2：无效证书验证

在 Windows 7 和 Windows Server 2008 R2 操作系统中，用于签名的新证书可能无法得到验证。

如果您无法在线更新证书存储区，产品文件的签名将显示为无效。在这种情况下，请在离线系统上更新 Microsoft 提供的根证书。为此，请按照 FAQ 109748887 中的说明进行操作。

在 Windows 7 中安装时的注意事项

TIA Portal 只能运行在支持安全 HASH 算法“SHA-2”的 Windows 系统中。安全更新 (KB 3033929) 安装后，Windows 7 采用仅支持“SHA-2”算法。因此，需确保系统上安装有最新的 Windows 安全更新。

Windows 10：字符集

Windows 10 更新版本 1809 之后，Windows 系统可使用管理员权限为所有用户安装字符集（在快捷菜单中选择“为所有用户安装”(Install for all users) 命令），也可为特定用户安装字符集。要使用 WinCC 字符集而无任何限制并加载到操作员面板中，则必需使用以管理员权限安装字符集。

请注意，字符集视图中的“安装”(Install) 按钮仅可用于特定用户安装。


软件和硬件的基本要求

安装时的系统要求 建议的 PC 硬件 支持的虚拟平台 支持的安全程序
许可证注意事项 开始安装 检查更新包和支持包的可用性并进行安装 显示已安装的软件 修改或更新已安装的产品 修复已安装产品 启动卸载
软件和硬件的基本要求

安装时的系统要求

下表列出了安装时需满足的软件和硬件最低要求：

硬件/软件

要求

处理器

Intel® Core™ i3-6100U，2.30 GHz

RAM

8 GB

硬盘

S-ATA，至少配备 20 GB 可用空间

网络

100 Mbps 或更高

屏幕分辨率

1024 x 768

操作系统 *

Windows 7（64 位）***

  • Windows 7 Home Premium SP1 **

  • Windows 7 Professional SP1

  • Windows 7 Enterprise SP1

  • Windows 7 Ultimate SP1

Windows 10（64 位）

  • Windows 10 Home Version 1809 **

  • Windows 10 Home Version 1903 **

  • Windows 10 Professional Version 1809

  • Windows 10 Professional Version 1903

  • Windows 10 Enterprise Version 1809

  • Windows 10 Enterprise Version 1903

  • Windows 10 IoT Enterprise 2015 LTSB

  • Windows 10 IoT Enterprise 2016 LTSB

  • Windows 10 IoT Enterprise 2019 LTSC

Windows Server（64 位）

  • Windows Server 2012 R2 StdE（完全安装）

  • Windows Server 2016 Standard（完全安装）

  • Windows Server 2019 Standard（完全安装）

* 包括截止到 Microsoft 2019 年 8 月安全公告摘要 (MS19-Aug) 的所有安全更新。有关操作系统的详细信息，请参见 Microsoft Windows 或 Microsoft 网站上的帮助。

** 仅适用于基本版

*** 不适用于 STEP7 Professional - WinCC Professional

说明

停止扩展支持 Windows 7

请注意，Windows 7 扩展支持结束后，Microsoft 将不再提供安全更新或为运行有 Windows 7 的 PC 提供支持。但该软件仍可安装。

某些协议可能还支持其它 Windows 版本。更多信息，请参见项目特定要求或使用兼容性工具进行兼容性检查。兼容性工具可从 Internet 中下载：https://support.industry.siemens.com/kompatool/pages/main/index.jsf?。

建议的 PC 硬件

下表列出了建议的硬件需求：

硬件/软件 | 要求
计算机 | SIMATIC FIELD PG M5 Advanced 或更高版本（或类似的 PC）
处理器 | Intel® Core™ i5-6440EQ（最高 3.4 GHz）
RAM | 16 GB 或更多（对于大型项目，为 32 GB）
硬盘 | SSD，配备至少 50 GB 的存储空间
程序段 | 1 GB（多用户）
监视 | 15.6" 全高清显示器（1920 x 1080 或更高）

支持的虚拟平台

可在虚拟机上安装“SIMATIC STEP 7”和“SIMATIC WinCC”软件包。为此，请选择使用以下指定版本或更新版本的虚拟机系统：

  • VMware vSphere Hypervisor (ESXi) 6.5 或更高版本

  • VMware Workstation 15.0.2 或更高版本

  • VMware Player 15.0.2 或更高版本

  • Microsoft Hyper-V Server 2016 或更高版本

对于这些虚拟系统，建议使用以下操作系统作为主机操作系统：

操作系统 | VMware vSphere Hypervisor (ESXi) | VMware Workstation | VMware Player | Microsoft Hyper-V
Windows Server 2016 Standard（完全安装） | - | - | - | √
Windows Server 2019 Standard（完全安装） | - | - | - | √
Windows 7 Professional SP1 | √ | √ | √ | -
Windows 7 Enterprise SP1 | √ | √ | √ | -
Windows 7 Ultimate SP1 | √ | √ | √ | -
Windows 10 Professional Version 1809 和 1903 | √ | √ | √ | -
Windows 10 Enterprise Version 1809 和 1903 | √ | √ | √ | -
Windows 10 (IoT) Enterprise 2015 LTSB | √ | √ | √ | -
Windows 10 (IoT) Enterprise 2016 LTSB | √ | √ | √ | -
Windows 10 IoT Enterprise 2019 LTSC | √ | √ | √ | -
√：可用作主机操作系统 -：不可用作主机操作系统

在所选虚拟系统中进行安装时，建议使用以下访客操作系统：

操作系统 | VMware vSphere Hypervisor (ESXi) | VMware Workstation | VMware Player | Microsoft Hyper-V
Windows Server 2012 R2 StdE（完全安装） | - | - | - | √
Windows Server 2016 Standard（完全安装） | - | - | - | √
Windows Server 2019 Standard（完全安装） | - | - | - | √
Windows 7 Professional SP1 | √ | √ | √ | √
Windows 7 Enterprise SP1 | √ | √ | √ | √
Windows 7 Ultimate SP1 | √ | √ | √ | √
Windows 10 Professional Version 1809 和 1903 | √ | √ | √ | √
Windows 10 Enterprise Version 1809 和 1903 | √ | √ | √ | √
Windows 10 (IoT) Enterprise 2015 LTSB | √ | √ | √ | √
Windows 10 (IoT) Enterprise 2016 LTSB | √ | √ | √ | √
Windows 10 IoT Enterprise 2019 LTSC | √ | √ | √ | √
√：可用作访客操作系统 -：不可用作访客操作系统

说明

  • 对于相应的各种 TIA 产品，主机操作系统的硬件要求都相同。

  • 工厂操作员必须确保主机操作系统可以使用足够的系统资源。

  • 使用 HyperV 服务器和 ESXi 时，建议使用经制造商认证的硬件产品。

  • 使用 Microsoft Hyper-V 时，无法显示可访问的站。

支持的安全程序

以下安全程序与“SIMATIC STEP 7 Basic”和“SIMATIC WinCC”相兼容：

  • 防病毒程序：

    • Symantec Endpoint Protection 14

    • Trend Micro Office Scan 12.0

    • McAfee Endpoint Security (ENS) 10.5

    • Kaspersky Endpoint Security 11.1

    • Windows Defender

    • Qihoo 360 "Safe Guard 11.5" + "Virus Scanner"

    说明

    请确保病毒扫描程序及其数据库始终最新。

    上一次病毒库的更新日期为 2019 年 9 月 2 日。

  • 加密软件：

    • Microsoft Bitlocker

  • 基于主机的入侵检测系统：

    • McAfee Application Control 8.0


产品特定的特性

产品特定的特性

该章节包括以下主题的信息:
  • WinCC Runtime Professional 的安装
  • 删除 SQL 实例
  • 有关安装 TIA Portal Teamcenter Gateway 的注意事项


WinCC Runtime Professional 的安装

域和工作组中的安装 在网络服务器上运行 Windows 计算机名称 激活远程通信
WinCC Runtime Professional 的安装

域和工作组中的安装

通常允许 WinCC 在域或工作组中操作。

但需注意，域的组策略和限制条件可能会影响安装过程。如果出现这种情况，请在安装 Microsoft Message Queuing、Microsoft SQL Server 和 WinCC 之前将计算机从域中删除。以管理员权限登录本地机器。执行安装。在成功安装之后，可以将 WinCC 计算机恢复至域中。如果域的组策略和域的约束没有阻碍安装，则在安装过程中无需将计算机从域中删除。

请注意，域的组策略和域的约束也可能会影响相关操作。如果无法避免这些约束，则运行工作组中的 WinCC 计算机。

必要时咨询域管理员。

在网络服务器上运行

不支持在网络服务器（如，域控制器、文件服务器、名称实用程序服务器、软件防火墙、介质服务器、交换服务器）上，运行 WinCC Runtime Professional。

Windows 计算机名称

安装完 WinCC 之后，请勿更改 Windows 计算机名称。

如果更改了 Windows 计算机名称，则必须卸载 SQL 服务器然后重新进行安装。

计算机名称中不允许使用以下字符：

  • . , ; : ! ? " ' ^ ´ ` ~ _

  • + = / \ ¦ @ * # $ % & § °

  • ( ) [ ] { } < >

  • 空格

分配 Windows 计算机名称时请遵循以下建议：

  • 只能使用大写字母。

  • 第一个字符必须为字母。

  • 计算机名称的前 12 个字符必须唯一。

激活远程通信

在 WinCC 系统上，安装后默认禁用对话框“Simatic Shell”中的远程通信。对于以下应用，必须激活所涉及计算机的远程通信：

  • 将 Runtime 加载到另一个 PC 上

  • 客户端至服务器通信

  • 冗余系统

  • WinCC 选件“WebNavigator”

    如果 WebNavigator 客户端与 WebNavigator 服务器未在同一计算机上运行，则必须激活远程通信。

要启用远程访问，请按以下步骤操作：

  1. 使用 Simatic Shell 的快捷菜单打开 Windows 资源管理器中的通信设置。

  2. 激活“远程通信”(Remote communication) 选项。

  3. 在网络中组态加密通信：选择预共享密钥和端口。

  4. 选择网络适配器和（如有必要）多播设置。


删除 SQL 实例

内容 卸载 SQL 实例
删除 SQL 实例

内容

安装 WinCC V16 时，将安装一个新的 WINCC SQL 2016 SP2 实例。

如果已安装有 WinCC Runtime Professional 版本，则需执行以下操作

  • 先安装 WinCC Runtime Professional V16，或者

  • 在安装 WinCC Professional V16 前，先卸载 SQL Server 上“WINCC”的旧实例。

说明

删除 WinCC Runtime Professional 或 WinCC Professional 时，不会删除 SQL 服务器中的实例。

卸载 SQL 实例

以下步骤显示了 Microsoft SQL Server 2008 R2 实例的卸载示例：

  1. 打开“控制面板”(Control Panel)。

  2. 单击“删除程序”(Remove program)。

  3. 在已安装程序列表中选择“Microsoft SQL Server 2008 R2”，或单击“删除/更改”(Remove/change)。

  4. 在“SQL Server 2008 R2”对话框中，单击“Remove”。

  5. 在“Setup Support Rules”对话框中，单击“OK”。

  6. 在“Select Instance”对话框中，选择“WINCC”实例，然后单击“Next”。

  7. 在“Select Features”对话框中，单击“Select All”然后单击“Next”。

  8. 在“Removal Rules”对话框中，单击“Next”。

  9. 在“Ready to Remove”对话框中，单击“Remove”。

  10. 完成删除操作后，单击“Complete”对话框中的“Close”。

卸载 SQL Server 2005 或 SQL Server 2014 实例的步骤与此类似。


有关安装 TIA Portal Teamcenter Gateway 的注意事项

简介 安装要求 安装 TIA Portal Teamcenter Gateway - 数据模型 安装过程中，TIA Portal 的版本相同 安装路径 防病毒程序
有关安装 TIA Portal Teamcenter Gateway 的注意事项

简介

可通过以下方式安装 TIA Portal Teamcenter Gateway：

  • 随 TIA Portal 一同安装

    说明

    安装服务器时，需要具有管理员权限。

安装要求

计算机上必须：

  • 安装有 Teamcenter Rich Application Client（下文中称为“RAC”）或 Teamcenter Client Communication System (TCCS) 版本 V11.2 或更高版本。

    说明

    如果 TCCS 安装为“单机版”，则还需安装“Microsoft Visual C++ 2013 – Redistributable”。这样，可确保 TIA Portal 与 TIA Portal Teamcenter Gateway 之间建立有连接。

  • FCC/FMS (FileClientCache/FileManagementSystem) 与“Teamcenter Server 11.2 或更高版本”之间存在连接

    说明

    • 重新安装或重启后，需检查 FCC/FMS (FileClientCache/FileManagementSystem) 与“Teamcenter Server 11.2 或更高版本”之间是否存在连接。

    • 重新安装或重启后，检查注册表项。有关检查注册表项的更多信息，请参见“　TIA Portal Teamcenter Gateway”在线帮助中的“安装与卸载 TIA Portal Teamcenter Gateway > 检查 of TIA Portal Teamcenter Gateway 的安装”部分。

    • 重新安装或重启后，需检查是否可在 Teamcenter 中保存条目类型以及是否可将数据集添加到元素修订版中。有关保存元素类型的更多信息，请参见“TIA Portal Teamcenter Gateway”在线帮助中“通过 TIA Portal Teamcenter Gateway 管理 TIA Portal 项目”章节的“在 Teamcenter 中将 TIA Portal 项目另存为一个新条目”部分。

    • 重新安装或重启后，检查是否可从 Teamcenter Rich Application Client 向 Teamcenter 服务器传送数据。

  • Teamcenter 服务器上安装有所提供的 Teamcenter 数据模型（含多个文件）。

安装 TIA Portal Teamcenter Gateway - 数据模型

安装所提供的 TIA Portal Teamcenter Gateway 数据模型时，需使用“系统管理器”(Environment Manager)。

有关安装的说明，请参见产品 DVD 中的目录“\Support\Teamcenter_11\ServerSetupDocument\”。

安装过程中，TIA Portal 的版本相同

安装不同的 TIA Portal 产品时，请确保安装时所用的服务包和更新版本相同。

例如，如果安装有 TIA Portal V14 或更高版本，则还需安装 TIA Portal Teamcenter Gateway V14 或更高版本。

安装路径

在安装路径中，请勿使用任何 UNICODE 字符（如，中文字符）。

防病毒程序

在安装过程中，需要对安装的文件进行读写访问。有些防病毒程序可能会阻止对这些文件进行访问。因此，建议在安装 TIA Portal Teamcenter Gateway 时禁用防病毒程序，并在安装后重新启用。


安装日志

安装日志的功能 安装日志存储位置 Setup_Report（CAB 文件）
许可证注意事项 开始安装 检查更新包和支持包的可用性并进行安装 显示已安装的软件 修改或更新已安装的产品 修复已安装产品 启动卸载
安装日志

安装日志的功能

下列安装进程的过程被记录到文件中：

  • 正在安装产品

  • 修改或更新已安装的产品

  • 修复现有安装

  • 正在卸载产品

如果在安装过程中出现错误或发出警告，则可以借助日志文件对这些情况进行评估。 可以自行完成或联系产品技术支持人员。

安装日志存储位置

该日志文件是最新的文件，该文件的扩展名为“.log”，文件名以“SIA”开头。

日志文件的位置存储在环境变量“%autinstlog%”中。 可以在 Windows 资源管理器的地址栏中输入该环境变量以打开包含日志文件的文件夹。 或者，可以在命令行中输入“CD %autinstlog%”导航到相应的目录。

存储位置取决于操作系统，例如英文版 Windows 为“C:\ProgramData\Siemens\Automation\Logfiles\Setup”。

Setup_Report（CAB 文件）

为了能够更方便地为产品技术支持人员提供全部所需文件，一个包含了安装日志和所有其它所需文件的存档文件将以 CAB 格式保存。 可以在“%autinstlog%\Reports\Setup_report.cab”处找到该日志。 如果需要获取安装帮助，请把该 CAB 文件发送到产品技术支持人员。 通过该信息，产品技术支持人员可以确定是否正确执行了安装。 在早期安装过程中生成的 CAB 文件保存在“报告”目录中时带有日期 ID。


开始安装

简介 要求 操作步骤 结果
安装日志 关于系统要求的说明 许可证注意事项 显示已安装的软件 修改或更新已安装的产品 修复已安装产品 启动卸载
开始安装

简介

软件包通过安装程序自动安装。将安装介质插入驱动器后，安装程序便会立即启动。

要求

  • PG/PC 的硬件和软件满足系统要求。

  • 具有计算机的管理员权限。

  • 关闭所有正在运行的程序。

操作步骤

要安装软件包，请按以下步骤操作：

  1. 将安装介质插入相应的驱动器。

    安装程序将自动启动，除非在 PG/PC 上禁用了自动启动功能。

  2. 如果安装程序没有自动启动，则可通过双击“Start.exe”文件手动启动。

    将打开选择安装语言的对话框。

  3. 选择将在安装程序对话框中显示的语言。

  4. 要阅读有关产品和安装的信息，请单击“阅读说明”(Read Notes) 或“安装说明”(Installation Notes) 按钮。

    将打开包含相关说明的帮助文件。

  5. 读取产品说明后，关闭帮助文件并单击“下一步”(Next)。

    将打开选择产品语言的对话框。

  6. 选择产品的用户界面语言，然后单击“下一步”(Next)。

    说明

    始终将“英语”(English) 作为基本产品语言安装。

    将打开选择产品组态的对话框。

  7. 选择要安装的产品：

    • 如需以最小配置安装程序，则单击“最小”(Minimal) 按钮。

    • 如需以典型配置安装程序，则单击“典型”(Typical) 按钮。

    • 如需自主选择待安装的产品，则单击“用户自定义”(User-defined) 按钮。然后选择需要安装的产品对应的复选框。

  8. 如果要在桌面上创建快捷方式，请选中“创建桌面快捷方式”(Create desktop shortcut) 复选框。

  9. 如需更改安装的目标目录，则单击“浏览”(Browse) 按钮。

    说明

    请注意以下事项：

    • 安装路径的长度不得超过 89 个字符。

    • 如果无需安装软件包中的其它待安装产品，则可仅更改安装路径。

    • 选择一个受管理员权限保护的目录作为目标目录以提高安全性。

  10. 单击“下一步”(Next)。

    将打开许可条款对话框。

  11. 要继续安装，请阅读并接受所有许可协议，并单击“下一步”。

    如果在安装 TIA Portal 时需要更改安全和权限设置，则会打开安全设置对话框。

  12. 要继续安装，则需接受对安全和权限设置的更改，并单击“下一步” (Next)。

    下一对话框将显示安装设置概览。

  13. 检查所选的安装设置。如需进行更改，则单击“上一步”(Back)，直至到达需更改的对话框处。完成所需更改之后，通过单击“下一步”(Next) 按钮返回概述部分。

  14. 单击“安装”(Install)。

    安装随即启动。

    说明

    如果安装过程中未找到许可密钥，则可将其传送到 PC 中。如果跳过许可密钥传送，稍后可通过 Automation License Manager 进行注册。

    安装后，将收到一条消息，指示安装是否成功。

  15. 可能需要重新启动计算机。在这种情况下，请选择“是，立即重启计算机。”(Yes, restart my computer now.)。然后单击“重启”(Restart)。

  16. 如果计算机未重启，则单击“退出”(Exit)。

结果

在您的计算机上安装了 TIA Portal 和您订购的产品和许可以及 Automation License Manager。


显示已安装的软件

步骤
关于系统要求的说明 许可证注意事项 开始安装 修改或更新已安装的产品 修复已安装产品 启动卸载 安装日志
显示已安装的软件

可以随时了解安装了哪些软件。 此外，还将显示有关已安装软件的更多信息。

步骤

要显示已安装软件的概览，请执行以下步骤：

  1. 在“帮助”(Help) 菜单中单击“已安装的软件”(Installed software)。

    “已安装的软件”(Installed software) 对话框随即打开。 将在对话框中看到已安装的软件产品。 展开此条目以查看每种情况下安装的版本。

  2. 如果想显示已安装的自动化软件的其它信息，请单击“有关已安装软件的详细信息”(Detailed information about installed software) 对话框中的链接。

    将打开“详细信息”(Detailed information) 对话框。

  3. 在浏览区中选择需要了解更多信息的主题。


修改或更新已安装的产品

要求 步骤 结果
关于系统要求的说明 许可证注意事项 开始安装 显示已安装的软件 修复已安装产品 启动卸载 安装日志
修改或更新已安装的产品

具有通过安装程序修改已安装的产品或更新到新版本的选项。

TIA Portal 早期版本的专有知识保护块无法随着项目自动升级。请在升级 TIA Portal 之前移除块的专有知识保护。之后，再使用新版本的 TIA Portal 设置专有知识保护。更多详细信息，请参见信息系统。

要求

  • PG/PC 的硬件和软件满足系统要求。

  • 具有计算机的管理员权限。

  • 关闭所有正在运行的程序。

步骤

要修改或更新已安装的产品，请执行以下步骤：

  1. 将安装介质插入相应的驱动器。

    安装程序将自动启动，除非在 PG/PC 上禁用了自动启动功能。

  2. 如果安装程序没有自动启动，则可通过双击“Start.exe”文件手动启动。

    将打开选择安装语言的对话框。

  3. 选择希望用来显示安装程序对话框的语言。

  4. 要阅读关于产品和安装的信息，请单击“阅读说明”(Read Notes) 或“安装说明”(Installation Notes) 按钮。

    将打开包含相关说明的帮助文件。

  5. 阅读说明后，关闭帮助文件并单击“下一步”(Next) 按钮。

    将打开选择安装版本的对话框。

  6. 选择“修改/升级”(Modify/Upgrade) 选项按钮并单击“下一步”(Next) 按钮。

    将打开选择产品语言的对话框。

  7. 选中要安装的产品语言的复选框。可以通过取消选择相应的复选框来删除之前安装的产品语言。

    说明

    注意，无法删除产品语言“英语”(English)。

  8. 单击“下一步”(Next) 按钮。

    将打开选择产品组态的对话框。

  9. 选中要安装的组件的复选框。可以通过清除相应的复选框来删除之前安装的组件。

  10. 单击“下一步”(Next) 按钮。

    说明

    注意，不能更改目标目录，这是因为正在修改现有安装。

    如果在安装 TIA Portal 时需要更改安全和权限设置，则会打开安全设置对话框。

  11. 要继续安装，请接受对安全和权限设置的更改，并单击“下一步”(Next) 按钮。

    下一对话框将显示安装设置概览。

  12. 单击“修改”(Modify) 按钮。

    这将启动附加组件的安装。

    说明

    安装后，将收到一条消息，指示现有安装是否成功更改。

  13. 可能需要重新启动计算机。在这种情况下，请选择“是，立即重启计算机。”(Yes, restart my computer now.) 选项按钮。然后单击“重启”(Restart)。

  14. 如果计算机未重启，则单击“退出”(Exit)。

结果

已修改了计算机上的现有安装。


修复已安装产品

要求 步骤 结果
关于系统要求的说明 许可证注意事项 开始安装 显示已安装的软件 修改或更新已安装的产品 启动卸载 安装日志
修复已安装产品

具有通过安装程序完全重新安装已安装产品进行修复的选项。

要求

  • PG/PC 的硬件和软件满足系统要求。

  • 具有计算机的管理员权限。

  • 关闭所有正在运行的程序。

步骤

要修复已安装的产品，请执行以下步骤：

  1. 将安装介质插入相应的驱动器。

    安装程序将自动启动，除非在 PG/PC 上禁用了自动启动功能。

  2. 如果安装程序没有自动启动，则可通过双击“Start.exe”文件手动启动。

    将打开选择安装语言的对话框。

  3. 选择希望用来显示安装程序对话框的语言。

  4. 要阅读关于产品和安装的信息，请单击“阅读说明”(Read Notes) 或“安装说明”(Installation Notes) 按钮。

    将打开包含相关说明的帮助文件。

  5. 阅读说明后，关闭帮助文件并单击“下一步”(Next) 按钮。

    将打开选择安装版本的对话框。

  6. 选择“修复”(Repair) 选项按钮，并单击“下一步”(Next) 按钮。

    下一对话框将显示安装设置概览。

  7. 单击“修复”(Repair) 按钮。

    将启动对现有安装的修复。

    说明

    安装后，将收到一条消息，指示现有安装是否成功修复。

  8. 可能需要重新启动计算机。 在这种情况下，请选择“是，立即重启计算机。”(Yes, restart my computer now.) 选项按钮。 然后单击“重启”(Restart)。

  9. 如果计算机未重启，则单击“退出”(Exit)。

结果

重新安装了已安装产品。


启动卸载

简介 通过控制面板删除所选组件 使用安装介质删除产品
安装日志 关于系统要求的说明 许可证注意事项 开始安装 显示已安装的软件 修改或更新已安装的产品 修复已安装产品
启动卸载

简介

可通过安装程序自动删除软件包。安装程序启动后，便会引导您逐步完成整个删除步骤。

可以选择两种方式进行删除：

  • 通过控制面板删除所选组件

  • 使用安装介质删除产品

说明

删除软件包时，不会自动删除 Automation License Manager，因为它要用于管理 Siemens AG 所提供的多种产品的许可密钥。

通过控制面板删除所选组件

要删除所选软件包，请按以下步骤操作：

  1. 打开“控制面板”(Control Panel)。

  2. 单击“程序和功能”(Programs and Features)。

    包含已安装程序列表的对话框随即打开。

  3. 选择要删除的软件包并单击“卸载”(Uninstall) 按钮。

    将打开选择安装语言的对话框。

  4. 选择要显示安装程序对话框的语言，并单击“下一步”(Next)。

    将打开一个对话框，供用户选择要删除的产品。

  5. 选中待删除产品的复选框，并单击“下一步”(Next)。

    下一对话框将显示安装设置概览。

  6. 检查包含了要删除的产品的列表。如果要进行任何更改，请单击“上一步”(Back) 按钮。

  7. 单击“卸载”(Uninstall) 按钮。

    开始删除。

  8. 可能需要重新启动计算机。在这种情况下，请选择“是，立即重启计算机。”(Yes, restart my computer now.) 选项按钮。然后单击“重启”(Restart)。

  9. 如果计算机未重启，则单击“退出”(Exit)。

使用安装介质删除产品

要删除所有软件包，请按以下步骤操作：

  1. 将安装介质插入相应的驱动器。

    安装程序将自动启动，除非在 PG/PC 上禁用了自动启动功能。

  2. 如果安装程序没有自动启动，则可通过双击“Start.exe”文件手动启动。

    将打开选择安装语言的对话框。

  3. 选择要用于显示安装程序对话框的语言。

  4. 要阅读有关产品和安装的信息，请单击“阅读产品信息”(Read product information) 或“阅读安装说明”(Read installation notes) 按钮。

    将打开包含相关说明的帮助文件。

  5. 阅读说明后，关闭帮助文件并单击“下一步”(Next) 按钮。

    将打开选择安装版本的对话框。

  6. 选择“卸载”(Uninstall) 选项按钮，然后单击“下一步”(Next) 按钮。

    下一对话框将显示安装设置概览。

  7. 单击“卸载”(Uninstall) 按钮。

    开始删除。

  8. 可能需要重新启动计算机。在这种情况下，请选择“是，立即重启计算机。”(Yes, restart my computer now.) 选项按钮。然后单击“重启”(Restart)。

  9. 如果计算机未重启，则单击“退出”(Exit)。


安装更新与支持包

安装更新与支持包

该章节包括以下主题的信息:
  • 检查更新包和支持包的可用性并进行安装
  • 使用公司内部服务器


检查更新包和支持包的可用性并进行安装

禁用或激活自动搜索软件更新包功能 手动搜索软件更新包 设置服务器 单独下载和安装软件更新包 同时下载和安装多个支持包 安装支持包的另一种方式
安装日志
检查更新包和支持包的可用性并进行安装

默认情况下，TIA Portal 会自动检查是否有新的软件更新包或支持包可用，例如硬件支持包 (HSP)。计算机在每次重启都后会自动搜索更新包，然后是每 24 小时循环进行搜索。用户可随时禁用自动搜索功能或重新激活该功能，也可手动搜索更新包。

如果找到更新包，就可以下载并安装。

说明

支持 TIA Portal V13 或更高版本的更新包和支持包。

禁用或激活自动搜索软件更新包功能

要禁用或重新激活自动搜索软件更新包功能，请按以下步骤操作：

  1. 在“选项”(Options) 菜单中，选择“设置”(Settings) 命令。

    “设置”(Settings) 窗口将显示在工作区内。

  2. 在区域导航中选择“常规 > 软件更新”(General > Software Updates) 组。

  3. 如果要取消激活软件更新的自动搜索功能，则需取消选择复选框“每天检查更新”(Check for updates daily)。

  4. 如果要重新激活软件更新的自动搜索功能，则需选中复选框“每天检查更新”(Check for updates daily)。

手动搜索软件更新包

如果想手动搜索软件更新包，请按以下步骤操作：

  1. 在“帮助”(Help) 菜单中单击“已安装的软件”(Installed software)。

    “已安装的软件”(Installed software) 对话框随即打开。

  2. 单击“检查更新”(Check for updates)。

    将打开“TIA Updater”对话框并显示可用的更新。

或者：

  1. 在“选项”(Options) 菜单中，选择“设置”(Settings) 命令。

    “设置”(Settings) 窗口将显示在工作区内。

  2. 在区域导航中选择“常规 > 软件更新”(General > Software Updates) 组。

  3. 单击“现在检查更新”(Check for updates now)。

    将打开“TIA Updater”对话框并显示可用的更新。

或者：

  1. 通过“开始 > 所有程序 > Siemens Automation > Totally Integrated Automation UPDATER”(Start > All Programs > Siemens Automation > Totally Integrated Automation UPDATER)，打开 TIA Updater。

  2. 单击“检查更新”(Check for updates)。

    将显示可用更新。

设置服务器

设置服务器时，需考虑是否要从 TIA Automation 更新服务器或企业服务器中下载更新和/或支持包。为此，请执行以下操作步骤：

  1. 打开 TIA Updater。

  2. 在“检查更新时所用的服务器”(Server used to check for updates) 区域内显示的对话框中，单击“选项”(Options) 并选择“TIA Automation 软件更新服务器”(TIA Automation Software Update Server)。
    该软件将搜索该制造商服务器上可用的更新。

或者：

  1. 打开 TIA Updater。

  2. 在“检查更新时所用的服务器”(Server used to check for updates) 区域内显示的对话框中，单击“选项”(Options) 并选择“企业服务器”(Corporate server)。

  3. 输入管理员提供的服务器 URL 地址。URL 必须以 https://[服务器 URL]/[文件目录路径] 的形式或 https://[服务器 IP 地址]/[目录路径] 的形式输入。如果不确定所用格式，则可联系管理员！
    该软件将公司服务器中查找可用的更新。

  4. 检查生产线的名称，并在必要时进行更改。系统默认设置的生产线每次为“ProductionLine1”。
    因生产线的目的不同，为不同用户提供的生产线更新/支持包也不同。如果公司只使用一条生产线，则请保留该生产线的指定条目。
    有关创建项目和操作生产线的详细信息，请参见 TIA Updater Corporate Configuration Tool 帮助信息。

用户可随时设置一个不同的服务器进行更新搜索，但在下载过程中，会禁用这一设置更改。切换服务器后，将显示所有下载的更新和支持包，即使这些更新或支持包未包含在当时设置的服务器中。

单独下载和安装软件更新包

要下载和安装可用的软件更新包和支持包，请按以下步骤操作：

  1. 如果 TIA Updater 未显示，请按以下一种方式打开：

    • 如果已通过自动搜索功能找到更新，用户将在 Windows 任务栏的信息区收到消息，并且在信息区将显示 TIA Updater 的图标。单击该消息或图标，打开 TIA Updater。

    • 在“帮助”(Help) 菜单中单击“已安装的软件”(Installed software)，然后单击“检查更新”(Check for updates)。

    • 在 Windows“开始”(Start) 菜单中，单击“开始 > 所有程序 > Siemens Automation > Automation Software Updater”(Start > All Programs > Siemens Automation > Automation Software Updater)。

  2. 在要安装的更新包或支持包行中单击“下载”(Download)。

    即会下载更新包或支持包。相关“安装”(Install) 按钮在下载过程完成后随即激活。

    说明

    请注意以下事项：

    1. 可同时启动多个下载过程。

    2. 在下载过程中，可注销或关闭计算机。在这种情况下，用户登录系统后，下载过程将立即在后台继续进行。

    3. 在某些情况下，会显示指向外部网页的链接，而不是显示“下载”(Download) 按钮。此时，可从相关站点下载软件更新程序手动完成安装。

  3. 如果 TIA Portal 仍保持打开状态，则将其关闭。

  4. 在 TIA Updater 中，单击待安装软件包的“安装”(Install) 按钮。

    即会显示安装对话框。

    说明

    请注意以下事项：

    1. 不能同时安装多个更新。

    2. 不要在安装时注销且不要关闭计算机。这可避免计算机上存在不一致的软件版本。

  5. 单击“下一步”(Next)。

    安装选定产品。

同时下载和安装多个支持包

要同时下载和安装多个支持包，请执行以下操作步骤：

  1. 激活所需行。为此，可采用以下几种方式：

    • 要下载并安装所有显示的支持包，需激活该列标题中的复选标记。

    • 要下载和安装多个支持包，可选择第一个所需的支持包，然后在按下 <Ctrl> 键的同时选择所需的其它所有支持包。之后，在其中一个所选行中设置复选标记。

    • 要一次性下载和安装多个支持包，可选择第一个所需的支持包，然后在按下 <Shift> 键的同时选择最后一个所需的支持包。

  2. 单击“下载并安装”(Download and Install)。

  3. 下载后，在显示的对话框中单击“下一步”(Next)，开始安装。此时，将显示一个对话框，显示当前的安装状况。

说明

仅能下载和安装无出口限制的支持包。

安装支持包的另一种方式

可使用其它方式安装支持包。为此，请执行以下操作步骤：

  1. 在 TIA Portal 的“选项”(Options) 菜单中单击“支持包”(Support packages)。

    将打开“详细信息”(Detailed information) 对话框。此表列出了在设置中选择为支持包存储位置的目录中的所有支持包。

  2. 如果要安装表中未列出的支持包，可以选择以下方法：

    • 如果计算机中已包含相应支持软件包，则可选择“从文件系统添加”(Add from file system)，将其添加到列表中。

    • 如果从 Internet 上的“服务与支持”页面添加支持包，首先应选择“从 Internet 下载”(Download from the Internet)，下载该支持包。然后从文件系统添加该支持包。

  3. 选择要安装的支持包。

  4. 单击“安装”(Install)。

  5. 关闭并重启 TIA Portal。


使用公司内部服务器

使用公司内部服务器

该章节包括以下主题的信息:
  • 企业服务器的性能和优势
  • 组态企业服务器进行更新
  • 在企业服务器上提供更新


企业服务器的性能和优势

简介 组态服务器并创建项目 使用服务器
企业服务器的性能和优势

简介

使用企业服务器，可以将所选更新/支持包放置在本地服务器上并提供用户使用，如不同的生产线。其优势在于，用户无需访问 Internet，但可通过内网、外部硬盘等安装更新。由于用户无需直接访问 Internet，针对通过 Internet 攻击公司内部网络的木马病毒和恶意软件的防护程度显著提升。

组态服务器并创建项目

在第一阶段，由服务器管理员组态企业服务器并使用 TIA Updater Corporate Configuration Tool 部署更新/支持包。此外，还可创建不同生产线的项目，之后用户即可通过这些项目接收到所需的更新。用户需要具有对服务器区域的访问权限、指定生产线名称并了解有关存储目录的信息。

有关创建项目和操作生产线的详细信息，请参见 TIA Updater Corporate Configuration Tool 帮助信息。

使用服务器

通过 TIA Updater，用户可以下载和安装相关的更新和支持包。可同时启动多个下载操作。更新/支持包的安装必须逐一完成。


组态企业服务器进行更新

简介 要求 安装 Web 服务器角色 (IIS) 创建 Web 站点 激活虚拟目录 添加并组态 MIME 类型 激活 BITS-IIS 服务器扩展 创建一个服务器自签证书 创建 SSL 连接 验证 SSL 连接 组态 SSL 设置 将更新分发到不同区域
组态企业服务器进行更新

简介

要在中央位置提供更新与支持包，需组态一个企业服务器。为此，可使用 Microsoft Server Manager。

以下是使用 TIA Updater Corporate Configuration Tool（使用 Microsoft Server 2016 操作系统）创建和组态服务器所需步骤的示例。此说明中未包含可能需要在公司内进行的进一步设置。

说明

请注意，开始菜单的结构和程序的程序位置可能会有所不同，具体取决于操作系统。

有关组态和操作 Server Manager 的更多详细信息，请参见 Microsoft 帮助。

要求

必须具有管理员权限。

安装 Web 服务器角色 (IIS)

要安装指定的 Web 服务器角色，请按以下步骤操作：

  1. 打开“开始”(start) 菜单，然后选择“Server Manager”。

  2. 单击仪表板中的“添加角色和功能特性”(Add roles and features)。

  3. 使用“添加角色和功能特性”(Add roles and features) 向导添加 Web 服务器角色。
    在启动向导之前，系统将验证是否已经为管理员指定了复杂密码、是否组态相应的网络设置，以及是否已安装有最新的 Windows 安全更新。

  4. 选择“基于角色或基于功能特性安装”(Role-based or feature-based installation) 作为安装类型，然后单击“下一步”(Next)。

  5. 选择目标服务器，然后单击“下一步”(Next)。

  6. 请注意，系统将默认安装预选择的角色，然后再选择附加角色“网络服务器 (IIS)”(Web Server (IIS))。

  7. 单击“添加功能特性”(Add features)，然后单击“下一步”(Next)。随即显示网络服务器的功能特性。

  8. 单击“角色服务”(Role Service)，并确保选中以下功能特性：

    “Web 服务器”(Web server) 区域

    • 默认文档

    • 目录浏览

    • HTTP 错误

    • 静态内容

    “健康与诊断”(Health and diagnostics) 区域

    • HTTP 日志记录

    • 请求监视

    “性能特点”(Performance features) 区域

    • 静态内容精简信息

    “安全”(Security) 区域

    • 请求过滤

    “应用程序开发功能”(Application Development Features) 区域

    • .NET Extensibility 3.5

    • .NET Extensibility 4.6

    • ASP.NET 3.5

    • ASP.NET 4.6

    • ISAPI Extensions

    • ISAPI Filters

  9. 单击“下一步”(Next)。

  10. 检查在“确认安装选择”(Confirm installation selection) 对话框中的选择，并单击“安装”(Install)。

“IIS”已添加到面板中，可进行进一步组态。

创建 Web 站点

  1. 在导航区域中，单击“IIS”，然后邮件单击“服务器”(Servers) 区域并选择“Internet 信息服务 (IIS) 管理器”(Internet Information Services (IIS) Manager)。

  2. 在“连接”(Connections) 区域中，单击“站点”(Sites) 后单击“默认的 Web 站点”(Default Web site)。

  3. 单击右键并选择选项“添加虚拟目录...”(Add Virtual Directory...)。

  4. 在打开的对话框中，在“别名”(Alias) 字段中输入将显示的名称，如“TIAPortalUpdates”。

  5. 在“物理路径”(Physical path) 字段中，输入该 Web 站点所在的文件夹路径或单击浏览按钮 (...)，在文件系统中搜索该文件夹。

  6. 单击“测试设置...”(Test Settings...)，检查设置是否正确。

  7. 单击“确定”(OK)。

激活虚拟目录

  1. 在“连接 > 站点 > 默认 Web 站点”(Connections > Sites > Default Web site) 区域中，选择所创建的虚拟目录。在“功能特性”(Features) 视图中，双击条目“浏览目录”(Browse directory)。

  2. 在“动作”(Actoins) 区域中，单击“启用”(Enable)。

添加并组态 MIME 类型

  1. 在“连接”(Connections) 区域中，选择所创建的 Web 站点。

  2. 在“功能特性”(Features) 视图中，双击“MIME 类型”(MIME type)。

  3. 在“动作”(Actoins) 区域中，单击“添加”(Add)。

  4. 在“添加 MIME 类型”(Add MIME type) 对话框的“文件名扩展”(File name extension) 文本框中，输入 .*。

  5. 在“MIME 类型”(MIME type) 文本字段中，输入“all/files”。

  6. 单击“确定”(OK)。

激活 BITS-IIS 服务器扩展

  1. 切换到 IIS 管理器内的虚拟目录中。

  2. 在虚拟目录的“功能特性”(Features) 视图中，双击“BITS 上传”(BITS-Uploads)。

  3. 选择复选框“允许客户端上传文件”(Allow clients to upload files)，并单击“应用”(Apply)。

创建一个服务器自签证书

  1. 在“连接”(Connections) 区域中，浏览到待管理的层级中。

  2. 在“功能特性”(Features) 视图中，双击“服务器证书”(Server Certificates)。

  3. 在“动作”(Actoins) 区域中，单击“创建自签证书”(Create Self-Signed Certificate)。

  4. 在“创建自签证书”(Create Self-Signed certificate) 对话框内的“指定证书的友好名称”(Specify a friendly name for the certificate) 字段中，输入证书的显示名称并单击“确定”(OK) 按钮。

创建 SSL 连接

  1. 在“连接”(Connections) 区域中展开“站点”(Sites) 条目，并单击待添加连接的站点。

  2. 在“动作”(Actoins) 区域中，单击“连接”(Bindings)。

  3. 在“站点连接”(Site Bindings) 对话框中，单击“添加”(Add)。

  4. 在“添加站点连接”(Add Site Binding) 对话框的“类型”(Type)、“https”和“SSL 证书”(SSL certificate) 中选择创建的证书，然后单击“确定”(OK)。

验证 SSL 连接

  1. 在“动作”(Actions) 区域的“浏览 Web 站定”(Browse website) 中，单击之前创建的连接。
    由于自签证书由用户计算机创建，因此会在 Internet Explorer 中打开一个错误页面。

  2. 单击“继续连接该 Web 站点（不建议）”(Continue to this website (not recommended))。
    将证书添加到“信任的 Root 证书授权”证书存储器中后，该消息不再显示。

组态 SSL 设置

  1. 在“功能特性”(Features) 视图中，双击“SSL 设置”(SSL settings)。

  2. 在“SSL 设置”(SSL Settings) 对话框的“客户端证书”(Client certificates) 区域中，执行以下某项操作：

    • 即使客户端包含有证书，但不接受任何客户端证书，选择“忽略”(Ignore)。

    • 如果接受客户端证书，则选择“接受”(Accept)。

    • 如果要求客户端证书，则选择“要求”(Require)。要使用“要求客户端证书”(Require client certificates) 选项，“要求 SSL”(Require SSL) 选项必须激活。

  3. 在“动作”(Actoins) 区域中，单击“应用”(Apply)。

将更新分发到不同区域

不同区域需要不同更新或支持包时，需执行以下操作：此时，建议使用多个服务器提供不同的更新和支持包。为此，请执行以下操作步骤：

  1. 按照上述要求设置不同的企业服务器。

或

  1. 安装 Web 服务器角色。

  2. 设置多个 Web 站点。
    请确保为每个 Web 服务器指定的名称和物理路径唯一，不会引起冲突。

  3. 为各个 Web 服务器或 Web 站点设置上述功能特性。

此时，可将不同区域所需的更新和支持包存储到不同目录中。


在企业服务器上提供更新

简介 要求 从 TIA Automation 软件更新服务器中，添加更新。 取消下载过程 删除企业服务器上的更新 服务器选项
企业服务器的性能和优势 组态企业服务器进行更新
在企业服务器上提供更新

简介

在 TIA Updater Corporate Configuration Tool 中，可以设置一个企业服务器，存储可用的更新/支持包并提供给用户使用。

要求

必须具有管理员权限。

由于企业服务器需要运行 BITS IIS 服务并运行 IIS 服务器，因此仅能在 Microsoft 服务器操作系统上对其进行设置。

从 TIA Automation 软件更新服务器中，添加更新。

要从 TIA Automation 软件更新服务器添加更新，请按以下步骤操作：

  1. 打开 TIA Updater Corporate Configuration Tool。
    显示所有可用的更新。

  2. 在显示的对话中，单击“添加更新”(Add update) 按钮并选择“添加 TIA Automation 软件更新服务器”(Add TIA Automation Software Update Server) 复选框。

  3. 在“从 TIA Automation 软件更新服务器添加更新”(Add update from TIA Automation Software Update Server) 对话框中，选择所需的更新（软件和支持包）并单击“添加”(Add)。
    如果更新已经位于企业服务器中，则灰显，且无法进行加载。在下载过程，对话框中将显示当前状态和剩余时间。

取消下载过程

要取消该过程，请按以下步骤操作：

  1. 单击“取消下载”(Cancel Download)。

  2. 在显示的对话框中，单击“是”(Yes) 进行确认。
    更新的下载过程将取消并从列表中删除。

删除企业服务器上的更新

要删除更新，请按以下步骤操作：

  1. 选择所需更新，单击“删除”(Remove)。

  2. 在显示的对话框中，单击“是”(Yes) 进行确认。
    选定的更新将从列表中删除。

服务器选项

在“TIA Automation 软件更新服务器”(TIA Automation Software Update Server) 对话框中，单击“设置”(Settings) 确定以下选项：

  1. 在“服务器路径”(Server path) 中，指定下载保存的文件夹。在此，可选择一个本地驱动器，也可以选择一个网络驱动器。

    说明

    直接在服务器上进行操作时，目标目录与该服务器中的更新目录相同。所有更改将直接应用。但我们不建议采用这一操作方式，这是因为这将导致与当前的下载过程发生冲突。

    在此，建议使用其它计算机，这样，可选择其它任何目录作为目标目录。之后，还必须将该目录中的所有内容都复制到更新目录中，并确保与当前的下载过程无冲突。

  2. 如果需要服务器在后台运行，则可选择复选框“服务器始终在后台运行（在菜单栏中显示图标）”(Always run server in background (icon is shown in the taskbar))。

  3. 单击“确定”(OK)，确认输入。


自动安装支持包

自动安装支持包

该章节包括以下主题的信息:
  • 自动安装支持包
  • 安装过程的返回值
  • 日志文件


自动安装支持包

简介 要求 操作步骤
安装过程的返回值 日志文件
自动安装支持包

简介

在 V15.1 及以上版本中，可在命令行中使用“支持包安装程序”，自动安装或升级所有的支持包；包括与所安装 TIA Portal 版本（如，isp.15_1）相兼容的 HSP（硬件支持包）。

要求

  • PG/PC 的硬件和软件满足系统要求。

  • 具有计算机的管理员权限。

  • 所有正在运行的程序都已关闭

操作步骤

要在命令行中使用相应选项直接启动安装过程，请执行以下操作步骤：

  1. 使用“开始 > 运行 > cmd”(Start > Run > cmd)，打开 Windows 命令提示窗口。

  2. 切换到包含“Siemens.Automation.SupportPackageInstaller.exe”文件的目录中。该目录是所安装 TIA Portal 的安装目录。

  3. 在命令提示窗口中，输入以下命令：
    %Installation directory% > Siemens.Automation.SupportPackageInstaller.exe <支持包 (HSP) 的存储目录> [-l <日志文件名称>] [-warnaserror]

<支持包存储目录>
包含支持包文件 (*.isp) 的强制目录。该目录可以为本地文件夹，也可以是一个远程共享文件夹。

-l <日志文件的存储位置>
该参数为可选参数，用于指定日志文件的存储路径。如果未指定，则在 binary 目录中创建日志文件。但用户需要对该存储文件夹具有写入权限。

-warnaserror
该参数为可选参数，用于指定将通常报告为警告的所有消息均报告为错误。如果 HSP 不满足所需条件，则命令行中将输出一个相应的返回值/中止值，同时跳过受影响的 HSP。

-?
该参数为可选参数，用于显示相关的帮助消息。

说明

  • 如果存储目录或日志文件名中包含空格，则需使用引号括起该名称。

  • 系统仅支持位于存储路径根目录中支持包，而不考虑其子目录。即，*.isp 文件必须位于存储目录的根目录中。


安装过程的返回值

重要说明
自动安装支持包 日志文件
安装过程的返回值

重要说明

下表列出了相应的返回值及其说明：

代码 | 说明
0 | 安装成功。
1 | 安装成功，需要重新启动。
-1 | 安装失败。
-2 | 安装失败：TIA Portal 仍在运行。
-3 | 安装失败：另一个安装过程正在运行。
-4 | 安装失败：用户权限不足。安装需要具有管理员权限。
-6 | 安装失败：存储空间不足。
-7 | 安装失败：启动安装过程前，需要重新启动。


日志文件

日志文件的内容
自动安装支持包 安装过程的返回值
日志文件

日志文件的内容

日志文件中包含所有安装过程的详细信息。如果日志文件已存在，将增补相应内容。每个日志文件都创建有标题和页脚。用户可在日志文件中查找所需信息。

以下事件将生成一个条目：

  • 在安装过程中，存储目录中包含有支持包且可用，但由于产品确实无法安装。日志文件中的条目将指示，产品安装是缺失的产品名称及版本号。

  • 未成功安装的支持包。

  • 已成功安装的支持包。

每个条目中都将记录 HSP 的文件名和文件扩展名。


安装和卸载移植工具

安装和卸载移植工具

该章节包括以下主题的信息:
  • 系统要求
  • 安装移植工具
  • 卸载移植工具


系统要求

移植工具的系统要求
系统要求

移植工具的系统要求

以下系统要求适用于使用移植工具的情况：

  • 必须安装用于创建源项目的所有产品。支持以下产品：

    • STEP 7 V5.4 SP5 及以上版本

    • 包含最新更新程序的 WinCC V7.5

    • WinCC Flexible 2008 SP2 及以上版本

    • 以上列出了可从 STEP 7 V5.4 和 WinCC 产品移植的项目

    • STEP 7 Distributed Safety V5.4 SP5

    • F-Configuration Pack V5.4 SP5 直至 V5.5 SP12

    • SINUMERIK STARTER 和 Startdrives

    • SIMOTION SCOUT V4.4 及以上版本

      要在相应的 SCOUT TIA 版本中移植 SIMOTION SCOUT 项目，则需使用 SCOUT Migration Tool PlugIn。

  • 安装用于处理 STEP 7 项目的所有选件包。例如，需要源项目中使用的设备的所有 HSP。

  • 已安装有 Microsoft .Net Framework 4.6.2。如果 Microsoft .Net Framework 尚未安装，则需使用移植工具安装所需版本。


安装移植工具

移植工具分布 步骤
安装移植工具

移植工具分布

可以在 TIA Portal 的安装 DVD 上的“Support”目录中找到移植工具。此外，还可从西门子工业在线支持网站下载。对于某些产品（如 SIMATIC Failsafe 或 SIMOTION），移植工具还要求具有其它插件。这些插件也可以从西门子工业在线支持网站页面下载，或者从对应产品的安装 DVD 进行安装。

通常，在没有 TIA Portal 的情况下安装移植工具。因为 TIA Portal 本身集成有移植功能，无需单独安装移植工具。

步骤

要安装移植工具，可进行如下操作：

  1. 从西门子工业在线支持网站下载安装文件，或者使用 TIA Portal 的安装 DVD 上的“Support”目录中提供的安装文件执行安装。

  2. 运行安装文件。

    将打开移植工具的安装程序。

  3. 首先，选择安装程序显示的语言并单击“下一步”(Next)。

    将显示选择软件语言的页面。

  4. 由于只提供了英语版本的移植工具，因此无法选择其它安装语言。所以，单击“下一步”(Next) 执行下一步骤。

    将显示选择产品的页面。

  5. 移植工具仅包含一个软件组件。所以已选择移植工具。单击“下一步”(Next)。

    将显示确认授权条款页面。

  6. 单击许可条款列表中的条目，阅读许可条款和安全信息。如果同意许可条款，则选择复选框“我接受许可协议中的所有条款”(I accept all terms of the listed license agreement(s)) 和“我确认已阅读并理解安全操作产品相关的安全信息”(I confirm that I have read and understood the security information on the safe operation of the products)。

  7. 之后，单击“下一步”(Next)。

    将显示安装概览。

  8. 单击“安装”(Install)。

    根据所显示设置执行安装。

    移植工具安装后，需要重新启动计算机。


卸载移植工具

步骤
卸载移植工具

可使用“控制面板”(Control Panel) 删除移植工具。

步骤

要删除移植工具，请执行以下步骤：

  1. 打开控制面板

  2. 在“控制面板”中，双击“程序和功能”。

    “卸载或更改程序”(Uninstall or change a program) 对话框随即打开。

  3. 在“卸载或更改程序”(Uninstall or change a program) 对话框中，选择移植程序条目，然后单击“卸载”(Uninstall)。

    将显示安全提示对话框。

  4. 单击“是”(Yes) 确认该提示。

    安装程序随即启动。

  5. 选择安装语言，然后单击“下一步”(Next)。

  6. 选择待卸载的移植工具，然后单击“下一步”(Next)。

  7. 单击“卸载”(Uninstall)。

    将删除移植工具。

  8. 单击“退出”(Exit)，关闭安装程序。


安装和卸载 TIA 项目服务器

安装和卸载 TIA 项目服务器

该章节包括以下主题的信息:
  • 有关安装项目服务器的注意事项
  • 安装项目服务器
  • 卸载项目服务器


有关安装项目服务器的注意事项

简介 多用户服务器随 TIA Portal 一同安装 单独安装多用户服务器 安装过程中，TIA Portal 的版本相同 安装路径 安装新版本的多用户服务器 防病毒程序 支持的虚拟平台
安装项目服务器 卸载项目服务器
有关安装项目服务器的注意事项

简介

安装多用户服务器以使用 Multiuser Engineering 功能。

可通过以下几种方式安装多用户服务器：

  • 与 TIA Portal 一同安装

  • 通过单独的安装过程，不随 TIA Portal 一同安装。

说明

安装服务器时，需要具有管理员权限。

多用户服务器随 TIA Portal 一同安装

多用户服务器通常与以下 TIA Portal 产品一同安装：

  • SIMATIC STEP 7 Basic

  • SIMATIC STEP 7 Professional

  • SIMATIC WinCC Basic

  • SIMATIC WinCC Comfort/Advanced

  • SIMATIC WinCC Professional

通常，系统默认在选择产品时激活多用户服务器，并与 TIA Portal 一同安装。安装 TIA Portal 的过程中检查设置。在“选项”(Options) 目录中选择该产品时，可查看安装多用户服务器时的特定默认设置。通过选择或清除选项，可指定多用户服务器是否随 TIA Portal 一同安装。

单独安装多用户服务器

多用户服务器也可独立安装。

在产品 DVD 光盘的“Documents\Readme\<语言目录>”目录中，还提供有关于自动安装的说明信息。

安装过程中，TIA Portal 的版本相同

在各种客户端安装不同的 TIA Portal 产品时，请确保安装时所用软件产品的版本均相同。

例如，如果安装的 STEP 7 Professional、WinCC Advanced 和 Safety 以及多用户服务器的版本为 Vx.y，则其它所有 Team Engineering 设备都需安装该软件的相同版本。

与此同时，所有产品都必须安装服务包和更新。

安装路径

在安装路径中，请勿使用任何 UNICODE 字符（如，中文字符）。

安装新版本的多用户服务器

请确保先安装新版本的多用户服务器，然后再卸载旧版本的多用户服务器。

这样，可确保新服务器可延续使用该服务器的用户授权。如果安装新版本之前将所有现有的多用户服务器全部删除，则用户设置将丢失，必需重新创建。

防病毒程序

在安装过程中，需要对安装的文件进行读写访问。有些防病毒程序可能会阻止对这些文件进行访问。因此，建议在安装多用户服务器时禁用防病毒程序，而在安装之后重新启用。

支持的虚拟平台

也可在虚拟机中安装多用户服务器以及 TIA Portal。

为此，请选择使用以下指定版本或更新版本的虚拟机系统：

  • VMware vSphere Hypervisor (ESXi) 6.5

  • VMware Workstation 12.5.7

  • VMware Player 12.5.7

  • Microsoft Hyper-V Server 2016

虚拟平台的安装要求与 TIA Portal 相同。


安装项目服务器

简介 安装规则 安装要求 项目服务器随 TIA Portal 一同安装 结果 单独安装项目服务器 结果
有关安装项目服务器的注意事项 卸载项目服务器
安装项目服务器

简介

项目服务器可随 TIA Portal 一同安装，也可单独安装。如果项目服务器随 TIA Portal 一同安装，则所安装项目服务器的版本通常与 TIA Portal 的版本相同。

在产品 DVD 光盘的“Documents\Readme\<语言目录>”目录中，还提供有关于自动安装的说明信息。

说明

卸载前先安装新版本

请确保先安装新版本的项目服务器，然后再卸载旧版本的项目服务器。

这样，可确保新服务器可延续使用该服务器的用户授权。如果安装新版本之前将所有现有的项目服务器完全删除，则用户设置将丢失，必须重新创建。

安装规则

在一台计算机上，可安装不同版本的项目服务器，并使用 TIA Portal 的不同项目版本。

可使用的项目版本：

项目服务器的版本 | TIA Portal 的版本
Server V16 | V16、V15.1、V15 和 V14
Server V15.1 | V15.1、V15 和 V14
Server V15 | V15 和 V14
Server V14 | V14

请注意，TIA Portal 和项目服务器的每个版本仅具有该版本所包含的功能。

在 Multiuser Engineering 中，无法对项目版本进行升级。

安装要求

项目服务器的安装要求与 TIA Portal 的相同。

项目服务器随 TIA Portal 一同安装

请按以下步骤操作：

  1. 请注意所选软件包的相关安装要求。

  2. 将安装介质插入相应的驱动器，然后启动指定产品的安装程序。

  3. 选择首选设置，然后单击“安装”(Install) 按钮。

  4. 请确保选择产品中包含有项目服务器，并遵循安装对话框中的相关说明。

结果

项目服务器随 TIA Portal 一同安装在计算机上。

单独安装项目服务器

请按以下步骤操作：

  1. 请注意项目服务器的安装要求。

  2. 双击自解压 .exe 文件“TIA_Portal_Multiuser_Server_V<x.y>.exe”，启动安装程序，单独安装项目服务器。这些文件位于相应产品 DVD 光盘的“Support”目录中。

  3. 选择首选设置，然后单击“安装”(Install) 按钮。

  4. 遵循安装对话框中的操作说明。

结果

项目服务器已安装在计算机上。


卸载项目服务器

简介 卸载要求 卸载项目服务器 结果
有关安装项目服务器的注意事项 安装项目服务器
卸载项目服务器

简介

可通过“控制面板”(Control Panel) 卸载项目服务器。

说明

卸载前先安装新版本

请确保先安装新版本的项目服务器，然后再卸载旧版本的项目服务器。

这样，可确保新服务器可延续使用该服务器的用户授权。如果安装新版本之前将所有现有的项目服务器完全删除，则用户设置将丢失，必须重新创建。

卸载要求

项目服务器已安装在计算机上。

卸载项目服务器

请按以下步骤执行卸载：

  1. 打开“控制面板”(Control Panel)。

  2. 在“控制面板”(Control Panel) 中，单击“卸载程序”(Uninstall a program)。

    “卸载或更改程序”(Uninstall or change a program) 对话框随即打开。

  3. 在“卸载或更改程序”(Uninstall or change a program) 对话框中，右键单击“项目服务器”(Project server) 条目，然后单击“卸载”(Uninstall)。

    将显示一条安全提示信息。

  4. 单击“是”(Yes) 确认该提示。

结果

项目服务器已从计算机中卸载。