自述

示例 参见 过程 其它
自述

该章节包括以下主题的信息:
  • TIA Portal 相关说明
  • STEP 7
  • WinCC
  • SIMOCODE ES
  • Safety
  • SIMATICS 安全运动系统 (S7-1500, S7-1500T)
  • SIMATIC Energy Suite 自述文件
  • 建立自动化自述
  • Startdrive
  • SINUMERIK
  • SIMOTION SCOUT TIA
  • SINAMICS DCC
  • TIA Portal Version Control Interface


TIA Portal 相关说明

TIA Portal 相关说明

该章节包括以下主题的信息:
  • 常规注意事项
  • 关于库的说明
  • 关于存储卡的说明
  • 在虚拟系统中使用 TIA Portal 的注意事项（私有云）
  • 有关使用 TIA Portal Teamcenter Gateway 的注意事项
  • Multiuser Engineering 使用说明


常规注意事项

在线支持网站中 TIA Portal 相关信息 诊断和反馈数据的收集 启动 TIA Portal Windows 7 / Windows Server 2008 R2：证书验证无效 TIA Portal 中亚洲字符的显示 安装新的 .Net 版本或 .Net 服务包 运行 TIA Portal 使用自动同步的网络驱动器 小数位的输入 打开软件组件缺失的项目
常规注意事项

本自述文件中的信息优先于其它文档中的说明。

请仔细阅读以下说明，其中包括了有关安装与应用的重要信息。安装前，请阅读这些说明。

在线支持网站中 TIA Portal 相关信息

有关 TIA Portal 重要技术信息和解决方案的简要介绍，敬请访问西门子工业在线支持网站。

Internet 链接：西门子工业在线支持网站中的 TIA Portal

西门子工业在线支持网站中服务和支持的全部信息：

Internet 链接：西门子工业在线支持网站中的服务和支持：

在此，可通过订阅新闻快报，获得有关产品的最新信息。

诊断和反馈数据的收集

我们会收集和处理统计使用和诊断数据（如，TIA Portal 编辑器或功能的使用频率），以确保 TIA Portal 使用安全和版本最新、对故障进行检测/诊断和修复，以及对产品性能进行改进。

使用和诊断数据最初存储在用户计算机本地，用户可读取并查看。存储位置：“...\ProgramData\Siemens\Automation\TelemetryConnector”。（注：Windows 管理员可设置该目录，因此可见。）

之后，这些使用和诊断数据将通过安全通信传输到西门子，实施以上用途。

启动 TIA Portal

启动 TIA Portal 时，Windows 将尝试更新“windowsupdate.com”的证书吊销列表 (CRL)。

如果 Internet 无法访问且存在多个 DNS 服务器，则可能会发生超时错误并延时 TIA Portal 启动。

Windows 7 / Windows Server 2008 R2：证书验证无效

在 Windows 7 和 Windows Server 2008 R2 操作系统中，用于签名的新证书可能无法验证。

如果证书中心无法在线更新，则产品文件的签名将显示为无效。此时，需在离线系统中更新 Microsoft 的 Root 证书。为此，请遵循 FAQ 109748887 中的操作说明。

TIA Portal 中亚洲字符的显示

如果在另外一个亚洲版操作系统中安装中文版 TIA Portal，则 TIA Portal 中的文本可能无法正确显示。要在 TIA Portal 中正确查看文本，请打开 Windows 控制面板并选择“非 Unicode 程序的语言”(Language for non-Unicode programs) 下的“英语”(English)。但请注意，这可能会导致其它程序发生示问题。

安装新的 .Net 版本或 .Net 服务包

  • 在 PG/PC 上安装新的 .Net 版本或 .Net 服务包之前，需要先关闭 TIA Portal。

  • 安装成功新的 .Net 版本或新的 .Net 服务包后，重新启动 TIA Portal。

运行 TIA Portal

  • 如果上次使用的项目列表中的项目位于未连接的网络驱动器上，则打开“项目”(Project) 菜单时可能发生延时现象。

  • 插入 CPU 时，如果同时打开了项目编辑器，则可能需要等待一段时间。如果是在新创建的项目中插入第一个 CPU，则此过程通常需要更长时间。为了正确地继续执行，插入 CPU 之前应关闭项目文本编辑器。

  • 如果 Windows 7 中某个功能的运行时间过长（如，装载 CPU），则可能显示报警“应用程序无响应”(Application is not responding)。若出现这种情况，请等候直到正确完成该功能。

  • 如果安装有支持 IntelliPoint 功能的 Microsoft 鼠标，则可能导致组件与标题栏的按钮发生重叠。在这种情况下，请卸载 Microsoft 的 IntelliPoint 软件。

  • 使用 NVIDIA 显卡时启用“虚拟桌面”(Virtual Desktop) 选项可能会出现问题。在这种情况下，请禁用 NVIDIA 图形驱动程序的“nView 虚拟桌面管理器”(nView virtual desktop manager)。

使用自动同步的网络驱动器

一个 TIA Portal 项目中包含的多个文件都保存在同一个目录中。如果待存储的项目在网络驱动器上或在云目录中（如 Dropbox、Syncplicity 或 GoogleDrive）自动同步，则在发生部分同步或异步进行时，会导致数据丢失。为此，我们不建议直接在同步的网络驱动器或在云目录中对 TIA Portal 项目进行编辑。同步前通常需关闭 TIA Portal 项目，并确保项目目录中的所有目录和文件全部同步。使用 TIA Portal 时，建议禁用自动同步功能。并按照以下方式进行同步：使用当前（本地）的项目数据替换网络驱动器或云目录中的项目数据。

小数位的输入

Windows 中某些语言设置可能导致以逗号表示小数位的输入值无法识别（如，输入“1,23”，导致系统错误）。因此，请使用国际标准格式 ("1.23")。

打开软件组件缺失的项目

如果项目因软件组件缺失而无法在 TIA Portal 中打开，则可从西门子工业在线支持网站中下载该软件并安装为试用版。之后，即可打开该项目。请注意，试用版软件只能使用有限的时间。


关于库的说明

内容 复制库元素
关于库的说明

内容

在线帮助中未包含的信息和有关产品特性的重要信息。

复制库元素

如果主模块与类型同名，那么在使用“复制”(Copy) 操作时，将会覆盖项目中相应的对象。请注意，此时并不会显示系统提示。当主模块与类型不同名时，也是如此，但主模块中的对象与类型同名。


关于存储卡的说明

内容 SIMATIC 存储卡 存在打开的强制作业时的行为 对 USB 卡读卡器中存储卡的访问保护 卸下/插入存储卡
关于存储卡的说明

内容

在线帮助中未包含的信息和有关产品特性的重要信息。

SIMATIC 存储卡

西门子事先已对 SIMATIC 存储卡进行了格式化和设置，使其可用于 S7-1200 和 S7-1500 模块。请勿覆盖该卡中设定的格式，否则将无法使用。因此不允许使用 Windows 工具进行格式化。

存在打开的强制作业时的行为

请注意，即使已将新项目加载到 SIMATIC 存储卡中，仍然会保留激活的强制作业。因此，从 CPU 上取下 SIMATIC 存储卡之前以及使用新项目覆盖 PC 中的 SIMATIC 存储卡之前，应先删除激活的强制作业。如果使用包含未知内容的 SIMATIC 存储卡，应在下一次下载之前先格式化此卡。

对 USB 卡读卡器中存储卡的访问保护

更改 S7-1500 CPU 在线访问和工程组态的安全机制后，会更改存储卡上的数据存储器。为此，从 USB 读卡器中插入的存储卡中读取项目数据时，该版本的 STEP 7 无法判断所组态保护等级的密码。更改操作可能会影响 S7-1200/1500 系列 CPU 的存储卡。因此，可采用一些物理防护措施对这些设备的存储卡上的重要项目数据进行保护。

说明

此限制与设备的在线访问或程序块的专有技术保护无关。

卸下/插入存储卡

卸下或插入存储卡后，请始终对 CPU 执行存储器复位，以将 CPU 恢复到正常状态。


在虚拟系统中使用 TIA Portal 的注意事项（私有云）

内容 在虚拟环境（私有云）中使用 TIA Portal 的操作说明 环境变量“TiaUserSettingsPath”和“TiaDefaultProjectPath” 有关使用 HTTPS 通信协议时的自签名证书
在虚拟系统中使用 TIA Portal 的注意事项（私有云）

内容

在线帮助中未包含的信息和有关产品特性的重要信息。

在虚拟环境（私有云）中使用 TIA Portal 的操作说明

有关如何在虚拟系统（私有云）中使用 TIA Portal 的操作说明，请参见安装光盘“Documents\Readme\<语言目录>”目录中的相关文档。单击“TIAPortalCloudConnectorHowTo<语言 ID>.pdf”，打开该 PDF 文档。

TIA Portal Cloud Connector 可用于 Windows 7（64 位）和 Windows 10（64 位）操作系统中。

环境变量“TiaUserSettingsPath”和“TiaDefaultProjectPath”

环境变量“TiaUserSettingsPath”和“TiaDefaultProjectPath”可用于设置与系统默认值不同的用户位置和项目设置。例如，将用户和项目设置保存在一个中央位置处。

有关在虚拟系统（私有云）中使用 TIA Portal 的更多信息，请参见操作说明中的“使用环境变量”部分。

有关使用 HTTPS 通信协议时的自签名证书

Microsoft 会定期检查 Windows 证书中心内的证书是否来源可信任。并将不受信来源的证书删除。因此，需确保自签名证书已使用安全证书进行签名。


有关使用 TIA Portal Teamcenter Gateway 的注意事项

内容 安装 TIAPortalTeamcenterGateway 使用 TIAPortalTeamcenterGateway 安装 TIA Portal Teamcenter Gateway - 数据模型 有关更新现有 TIA Portal Teamcenter Gateway - 数据模型 有关 Teamcenter 的注意事项 有关 TCCS (Teamcenter Client Communication System) 的注意事项 有关 UTF-8 的注意事项 有关“云计算”的注意事项 有关使用 TIA Portal Teamcenter Gateway 的基本信息 连接 Teamcenter Teamcenter 版本信息 设置 TIA Portal Teamcenter Gateway 的缓存路径 在 WinCC Professional 仿真运行时执行 TIA Portal Teamcenter Gateway 相关操作
有关使用 TIA Portal Teamcenter Gateway 的注意事项

内容

在线帮助中未包含的信息和有关产品特性的重要信息。

安装 TIAPortalTeamcenterGateway

有关 TIA Portal Teamcenter Gateway 的安装指南，请参见 TIA Portal Teamcenter Gateway 在线帮助中的“安装与卸载 TIA Portal Teamcenter Gateway”。

使用 TIAPortalTeamcenterGateway

安装 TIA Portal Teamcenter Gateway 后，可访问 TIA Portal V14 及更高版本中的 TIA Portal Teamcenter Gateway 功能。

安装 TIA Portal Teamcenter Gateway - 数据模型

有关 TIA Portal Teamcenter Gateway 数据模型的安装说明，请参见安装数据介质 STEP 7/WinCC DVD2 中的“\Support\Teamcenter_11\ServerSetupDocument\”目录。打开 PDF 文档“Datamodel_Installation_enUS"”。TIA Portal Teamcenter Gateway - 数据模型的安装指南仅为英文版。

有关更新现有 TIA Portal Teamcenter Gateway - 数据模型

  • 更新现有的 TIA Portal Teamcenter Gateway 数据模型后，重新启动 TIA Portal。

  • 在 TIA Portal Teamcenter Gateway V15 和 V15.1 中，未对现有的 TIA Portal Teamcenter Gateway 数据模型进行更改，也未对 Teamcenter 进行更改。

有关 Teamcenter 的注意事项

要使用 TIA Portal Teamcenter Gateway，PG/PC 上需安装有 Teamcenter Rich Application Client (RAC) 或 Teamcenter Client Communication System (TCCS) V11.2 及以上版本。

有关 TCCS (Teamcenter Client Communication System) 的注意事项

如果安装 TCCS (Teamcenter Client Communication System) 时采用“单机”安装方式，则还需安装“Microsoft Visual C++ 2013 – Redistributable”。

有关 UTF-8 的注意事项

要在 TIA Portal 中显示 Teamcenter 中的非英文字符集数据（如，亚洲语言），则需使用 Unicode 字符集。

有关“云计算”的注意事项

如果在云（如，虚拟机）中运行 TIA Portal，则需将该系统集成到 Teamcenter 环境中。TIA Portal Teamcenter Gateway 不支持通过远程连接进行直接集成。

有关使用 TIA Portal Teamcenter Gateway 的基本信息

在 TIA Portal Teamcenter Gateway V15 及以上版本中，TIA Portal 项目和全局库支持 Teamcenter 操作“Teamcenter > 导出...”(Teamcenter > Export...)。

通过该操作，可创建一个当前项目的副本，其中不含任何 Teamcenter 信息。如需脱离 Teamcenter 单独操作，则可执行该操作而非“另存为”(Save as)。这是因为，“另存为”指令将在项目中保留相关的 Teamcenter 信息。

连接 Teamcenter

在 TIA Portal Teamcenter Gateway V15.1 更新 3 及以上版本中，TIA Portal 可通过 HTTP 和 HTTPS 与 Teamcenter 建立连接。

Teamcenter 版本信息

要使用 TIA Portal Teamcenter Gateway V15.1 或 TIA Portal Teamcenter Gateway V16 和 Teamcenter V11.6，则需安装有 Teamcenter V11.6.0.5 或更高版本。在 Teamcenter V11.6.0.5 及以上版本中，性能改进可无缝兼容 Teamcenter V11.6。

在 TIA Portal Teamcenter Gateway V16 及以上版本中，可使用 Teamcenter V12.2.0.0.0。

设置 TIA Portal Teamcenter Gateway 的缓存路径

系统默认，将“选项 > 设置 > 常规 > Teamcenter Gateway”(Options > Settings > General > Teamcenter Gateway) 中“TIA Portal Teamcenter Gateway 缓存路径”(TIA Portal Teamcenter Gateway Cache Path) 区域内输入的值作为“TIA Portal Teamcenter Gateway 缓存路径”。

系统默认将该值用作项目的目录路径。

如果更改““TIA Portal Teamcenter Gateway 缓存路径”中的值，则 Teamcenter Gateway 将检查系统默认输入值的有效性并进行更改。

说明

缺省值不得为空。

在 WinCC Professional 仿真运行时执行 TIA Portal Teamcenter Gateway 相关操作

在启动 WinCC Professional 操作的过程中，请勿执行诸如“检入”或“取消检出”等 Teamcenter Gateway 操作。


Multiuser Engineering 使用说明

内容 名称更改 项目服务器的 Microsoft 系统账户 启动项目服务器时的错误消息 本地会话中的主动监控作业和强制作业 使用带“保持本地会话”选项的本地会话 使用不同版本的 TIA Portal 使用 Multiuser Commissioning
西门子工业在线支持网站中的 TIA Portal 常见问题与解答 (ID 109739926)
Multiuser Engineering 使用说明

内容

在线技术支持中未包含的信息和有关 Multiuser Engineering 产品特性以及项目服务器的重要信息。

安装项目服务器后，可在 TIA Portal 中使用“Multiuser Engineering”、“”Multiuser Commissioning和“Exclusive Engineering” 功能。

名称更改

在 TIA Portal V16 版本中，对 Multiuser Engineering 系统中的以下名称进行了更改：

之前的名称 | TIA Portal V16 及以上版本中的新名称
多用户服务器 | TIA 项目服务器
本地多用户服务器 | 本地项目服务器
多用户服务器项目 | 服务器项目
多用户网络配置文件 | 网络配置文件

项目服务器可用于 Multiuser Engineering，也可用于 Multiuser Commissioning 和 Exclusive Engineering 。

项目服务器 V16 和多用户服务器 V15.1 兼容，无任何功能限制。

在该版本中，服务器的功能保持不变。

项目服务器 V16 与多用户服务器 V14 向下兼容。

项目服务器的 Microsoft 系统账户

安装项目服务器时，将在项目服务器上创建一个 Microsoft 系统账号。Microsoft 会定期更改该账号的密码。

如果该账户的密码过期，则需更改此密码并重新启动项目服务器。

启动项目服务器时的错误消息

如果在安装项目服务器的过程中或安装后显示一条错误消息，指示项目服务器的服务无法启动，则建议执行以下操作步骤：

  1. 打开 Windows 事件视图，检查是否存在错误编号为“1069”的条目。

  2. 如果存在，则提供如下方法信息。

    Internet 链接：西门子工业在线支持网站中的 TIA Portal

  3. 或直接联系客户服务支持中心。

    客户技术支持 Internet 链接：常见问题与解答 (ID 109739926)

本地会话中的主动监控作业和强制作业

在本地会话中签入或更新前必须关闭主动监控作业和强制作业。监控作业或强制作业处于激活状态时，无法在本地会话中签入或更新。

使用带“保持本地会话”选项的本地会话

如果签入后选择了“保持本地会话”(Keep local session) 选项，则即使其内容相同，本地会话中的所有签入对象都为过时状态。

使用不同版本的 TIA Portal

由 TIA Portal V<x.y> 版本创建的本地会话只能使用该版本进行操作。

示例：在版本为 V16 项目中由 TIA Portal V16 创建的本地会话，使用旧版本的 TIA Portal 无法编辑。

使用 Multiuser Commissioning

  • 使用 Multiuser Commissioning 时，每次下载到 CPU 之后，系统都将为该服务器项目创建一个新的修订版。但在本地会话中对无法标记的对象进行编辑时，不会创建新的修订版。在检入过程中，对无法标记的对象的更改将丢失，而这些更改不会下载到 CPU 中。

  • 在调试模式下，通过菜单命令“下载到设备 > 硬件配置”(Download to device > Hardware configuration) 从项目树中下载到设备时，通常会显示一个对话框，指示 CPU 与服务器项目中的数据不同。

  • 在调试模式下操作时，仅完整支持 S7-1500 CPU。使用 S7-300/400 CPU 时，调试模式下通常会显示一个对话，指示 CPU 与服务器项目中的数据不同。这是因为，S7-300/400 CPU 不支持同步。为了避免显示该消息，应在管理工具中禁用选项“加载前检查数据的不一致（建议）”(Check for data mismatch before loading (recommended))。