工艺功能

示例 参见 过程 其它
工艺功能

该章节包括以下主题的信息:
  • 关于 S7-1500 运动控制的注意事项 (S7-1500, S7-1500T)
  • 关于附加工艺功能的注意事项 (S7-1500)
  • 有关工艺功能的说明 (S7-1200)
  • 有关工艺功能的说明 (S7-300, S7-400)
  • SIMATIC STEP 7 Easy Motion Control
  • SIMATIC STEP 7 PID Professional


关于 S7-1500 运动控制的注意事项 (S7-1500, S7-1500T)

示例 参见 过程 其它
工艺报警 900-902 升级 TIA Portal 版本 V16 中的项目 通过“MC_Home”回原点时的模数循环计数器行为 使用“DX_TEL_SyncOp”数据类型进行跨 PLC 同步操作 在引导轴和虚拟跟随轴上手动组态延迟时间 跟随误差的计算 通过动态调整进行用户转换的性能 (S7-1500T) 通过运动系统跟踪进行记录时，CPU 的最大带宽是有限的 (S7-1500T) 路径运动和同步“点对点”运动（sPTP 运动）间的混合 (S7-1500T) 更改同步“点对点”运动（sPTP 运动）的超驰 (S7-1500T) 使用运动系统运动混合 (S7-1500T) 在工艺版本 V5.0 中使用“MC_TrackConveyorBelt”运动控制指令 (S7-1500T)
关于 S7-1500 运动控制的注意事项
S7-1500, S7-1500T

工艺报警 900-902

与记录的行为相反，接收到的引导值经检测为无效值，工艺报警 900 和 901 作为报警响应。工艺报警 902 不具有报警响应。

工艺报警 900 和 901 显示在诊断缓冲区中。

编号 | 响应 | 错误位 | 警告位 | 重新启动 | 诊断缓冲区 | 报警文本
900 | 设置无效引导值 | X2 | - | - | √ | 引导值无效。
901 | 设置无效引导值 | X2 | - | - | √ | 数据传输错误。
902 | 无响应 | - | X2 | - | - | 引导值精度有限。

可以通过“MC_Reset”作业“Restart” = FALSE 确认工艺报警 900。不需要重启。

工艺报警 900 显示下列报警文本：

报警文本 | 解决方案
引导值无效。 | 设置更高的容差时间 (<TO>.Parameter.ToleranceTimeExternalLeadingValueInvalid)。 检查互连组件的连接。确保不存在通信干扰。 确保相关 CPU 处于 RUN 操作状态。

工艺报警 901 显示下列报警文本：

报警文本 |  | 解决方案
数据传输错误 |  |
 | 版本无效 | 检查通信。
 | 模数起始值无效
 | 模数长度无效
 | 生命迹象错误
 | 位置无效 | 检查其它 CPU 上引导轴的引导值。
 | 速度无效
 | 加速度无效

升级 TIA Portal 版本 V16 中的项目

由于 TIA Portal 版本 V16 更改了项目存储格式，因此必须对现有项目进行转换。根据项目大小的不同，转换可能要花费较长时间。转换的总持续时间从几分钟到超过一小时不等。

通过“MC_Home”回原点时的模数循环计数器行为

与记录的行为相反，在通过“Mode” = 1、12 直接相对回原点，通过“Mode” = 6 进行绝对值编码器校准（相对），以及通过“Mode” = 0 直接绝对回原点期间，模数循环计数器会做出响应。通过下列模式进行回原点和绝对编码器校准期间，模数循环的计数器值会发生变化：

动作 | 说明
通过“Mode” = 6 进行绝对值校准 | 模数值是当前位置和新位置之间的最短距离。模数循环计数值可能保持不变、加 1 或减 1，具体取决于距离。
通过“Mode” = 1、12 直接相对回原点 | 模数值是当前位置和新位置之间的最短距离。模数循环计数值可能保持不变、加 1 或减 1，具体取决于距离。

使用“DX_TEL_SyncOp”数据类型进行跨 PLC 同步操作

在传输区起始地址为跨 PLC 同步操作创建数据类型为“DX_TEL_SyncOp”的输出和输入变量。如果无法分配数据类型“DX_TEL_SyncOp”，则通过上一次编译将其删除。

编译期间，未使用的数据类型会被删除。要恢复“DX_TEL_SyncOp”数据类型，需添加 V5.0 工艺对象。使用完 PLC 变量中的数据类型后，可再次删除工艺对象

在引导轴和虚拟跟随轴上手动组态延迟时间

如果在引导值设置中延长了引导轴的延迟时间，则引导轴代理处的外推时间会缩短，或引导轴代理处分配的引导值的插值时间会延长。这能够减少引导值的加速度和延迟相位外推产生的误差。

如果引导轴代理处的延迟时间延长，则外推时间会延长或插值时间会缩短。

跟随误差的计算

跟随误差是设定位置与实际位置之间的差值，以驱动装置上轴的连接为基准。与记录的行为相反，从控制器到驱动装置以及从驱动装置到控制器的设定值传输时间不在跟随误差的范围内。因此，跟随误差的值不等于控制器中可用的设定值减去现有的实际位置所得的差值。

通过动态调整进行用户转换的性能 (S7-1500T)

在工艺版本 V5.0 中，进行用户转换时 MC-Interpolator [OB92] 的运行时间更长。随着 MC-Interpolator [OB92] 运行时间的增加，较低优先级的组织块的运行时间会延长。

通过运动系统跟踪进行记录时，CPU 的最大带宽是有限的 (S7-1500T)

如果超出最大带宽，则无法通过运动系统跟踪记录和评估记录的所有信号。

考虑 CPU 的系统限制（最多 16 个信号）

对于不同的对象，需要以下信号：

对象 | 使用的信号
TCP 和运动系统（取决于运动系统） | 4-8
TCP（取决于运动系统） | 2-4
OCS 1（取决于运动系统） | 2-6
OCS 2（取决于运动系统） | 2-6
OCS 3（取决于运动系统） | 2-6

在“工艺对象 > 运动系统跟踪 > 组态 > 记录”(Technology object > Kinematics trace > Configuration > Records) 下禁用活动信号。

路径运动和同步“点对点”运动（sPTP 运动）间的混合 (S7-1500T)

使用从路径运动到 sPTP 运动的混合时，可能不会明显缩短任何混合或混合分段。

使用从路径运动到 sPTP 运动的混合时，路径动态设置越高越好。

  • 加加速度

  • 加速度

更改同步“点对点”运动（sPTP 运动）的超驰 (S7-1500T)

更改超驰时，工具中心点 (TCP) 的运动路径可能使 sPTP 运动发生更改。

如果要保留 TCP 的运动轮廓，请在对超驰进行最小幅度更改的情况下操作运动系统。

使用运动系统运动混合 (S7-1500T)

混合期间，运动系统轴可能发生动态超驰。

在工艺版本 V5.0 中使用“MC_TrackConveyorBelt”运动控制指令 (S7-1500T)

工艺版本 V5.0 中无法使用“MC_TrackConveyorBelt”运动控制指令。


关于附加工艺功能的注意事项 (S7-1500)

示例 参见 过程 其它
TIA Portal Openness 中工艺对象的参数 在 S7‑1500 上使用 S_USSI PtP 模块与 CM 1243-5 PROFIBUS 主站配合使用 在 CPU 1500 V1.7 上使用 PID_Temp
关于附加工艺功能的注意事项
S7-1500

TIA Portal Openness 中工艺对象的参数

有关可用的工艺对象参数列表，敬请访问 Internet 中的产品信息“TIA Portal Openness 中工艺对象的参数”。

在 S7‑1500 上使用 S_USSI

在 S7‑1500 上使用分布式 I/O ET 200S 1SI 的指令 S_USSI 时，请注意以下事项。

即使出错，参数 ANZ 的值也显示为 0。

如果使用 S_USSI 指令时 CPU 切换到停止状态，请检查参数 ANZ 中列出的所有可能错误。

PtP 模块与 CM 1243-5 PROFIBUS 主站配合使用

将 PtP 模块 CM PtP RS232 BA、CM PtP RS422/485 BA、CM PtP RS232 HF、CM PtP RS422/485 HF 以及 CM PtP 与固件版本低于 V1.3.4 的 CM 1243-5 PROFIBUS 主站配合使用时，必须在各指令的背景数据块中进行以下设置：

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240

在 CPU 1500 V1.7 上使用 PID_Temp

在固件版本 V1.7 的 CPU 1500 上使用 PID_Temp 时，请注意以下事项：

  • 在 CPU 1500 V1.7 上不得使用 PID_Temp 中的集成死区。

    不得更改关联参数 Retain.CtrlParams.Heat.DeadZone 和 Retain.CtrlParams.Cool.DeadZone 的预设值 0.0。

  • 如果已激活制冷并采用 PID 参数切换的闭环控制器（Config.ActivateCooling = TRUE，Config.AdvancedCooling = TRUE）在开始“预调节制冷”时（Mode = 1，Heat.EnableTuning = FALSE，Cool.EnableTuning = TRUE）激活制冷输出（PidOutputSum < 0.0，OutputCool <> 0.0），控制器将中止运行并提示出现错误 ErrorBits = 16#0040_0000。

    • 这种情况下，请使用“精确调节制冷”（Mode = 2，Heat.EnableTuning = FALSE，Cool.EnableTuning = TRUE）

    或者

    • 在开始预调节之前，通过将手动值设置为大于 0.0 切换到手动模式（Mode = 4，ManualValue ≥ 0.0）。

自固件版本 V1.8 起，这两条限制不再适用。


有关工艺功能的说明 (S7-1200)

示例 参见 过程 其它
组态时自动应用驱动装置或编码器值（离线） ErrorID 16#820D PtP 模块与 CM 1243-5 PROFIBUS 主站配合使用
有关工艺功能的说明
S7-1200

组态时自动应用驱动装置或编码器值（离线）

通过 HSP 连接 SINAMICS V90 PN 时，并非所有组态参数都会自动应用。在工艺对象的组态中，禁用“组态时自动应用驱动装置值（离线）”(Automatically apply drive values during configuration (offline)) 并手动应用驱动装置和编码器的组态参数。

ErrorID 16#820D

ErrorID | ErrorInfo | 说明 | 解决方案
16#820D |  | 工艺对象正在重启
 | 16#0001 | - | 使用“MC_Reset”指令确认错误并重启作业（如有必要）

PtP 模块与 CM 1243-5 PROFIBUS 主站配合使用

将 PtP 模块 CM PtP RS232 BA、CM PtP RS422/485 BA、CM PtP RS232 HF、CM PtP RS422/485 HF 以及 CM PtP 与固件版本低于 V1.3.4 的 CM 1243-5 PROFIBUS 主站配合使用时，必须在各指令的背景数据块中进行以下设置：

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240


有关工艺功能的说明 (S7-300, S7-400)

示例 参见 过程 其它
FM x51 和 FM x52 的参数分配 对 FM x50-1、FM x51 和 FM x52 编程 IM 174 移植
有关工艺功能的说明
S7-300, S7-400

FM x51 和 FM x52 的参数分配

与在线帮助中的信息不同，如果用户更改测量系统，则先前输入的参数值不会转换到新测量系统。

对 FM x50-1、FM x51 和 FM x52 编程

指令在线帮助的参数表中指定的“初始值”与用户编程的软件接口中的“默认值”相对应。

IM 174 移植

移植具有 IM 174 的项目期间，IM 174 的参数分配将设置为默认值。 移植完成后，务必重新为 IM 174 设置参数。