WinCC

示例 参见 过程 其它
WinCC

该章节包括以下主题的信息:
  • 安全性信息
  • 数据保护
  • 使用注意事项
  • 移植
  • 工程系统
  • 系统范围的函数
  • 编译和装载
  • 运行系统
  • HMI 设备
  • 插件


安全性信息

安全性信息 密码 集成的 Web 服务器 通过以太网通信 使用 SSL 3.0 网络设置
安全性信息

安全性信息

Siemens 为其产品及解决方案提供了工业安全功能，以支持工厂、系统、机器和网络的安全运行。

为了防止工厂、系统、机器和网络受到网络攻击，需要实施并持续维护先进且全面的工业安全保护机制。Siemens 的产品和解决方案仅构成此类概念的其中一个要素。

客户负责防止其工厂、系统、机器和网络受到未经授权的访问。只有在必要时并采取适当安全措施（例如，使用防火墙和网络分段）的情况下，才能将系统、机器和组件连接到企业网络或 Internet。

此外，应考虑遵循 Siemens 有关相应安全措施的指南。更多有关工业安全的信息，请访问

http://www.siemens.com/industrialsecurity

Siemens 不断对产品和解决方案进行开发和完善以提高安全性。Siemens 强烈建议您及时更新产品并始终使用最新产品版本。如果使用的产品版本不再受支持，或者未能应用最新的更新程序，客户遭受网络攻击的风险会增加。

要及时了解有关产品更新的信息，请订阅 Siemens 工业安全 RSS 源，网址为

http://www.siemens.com/industrialsecurity

密码

在 WinCC 中，默认情况下设置了多个密码。出于安全方面的原因，您应该更改这些密码。

  • 对于版本 12 的 HMI 设备，Sm@rtServer 和集成 Web 服务器的默认密码为“100”。对于安装了版本 V13 的 HMI 设备，未预设默认密码。

  • 对于用户“管理员”(Administrator)，其默认密码是“administrator”。

集成的 Web 服务器

即使取消激活“HTML 页面”(HTML pages) 选项，PC 仍能够在运行时访问 HTML 页面。安装程序始终在 PC 上安装 Web 服务器的标准页面。分配管理员密码以防止对页面进行未授权访问。

通过以太网通信

在基于以太网的通信中，最终用户自己负责数据网络的安全。不能保证设备在所有情况下都能正常运行；例如，遭受蓄意攻击就会导致设备过载。

使用 SSL 3.0

出于安全方面的原因，不建议在精智面板或者 Runtime Advanced 中使用 SSL 3.0 协议。默认情况下在精智面板上会禁用 SSL 3.0 协议。但如果您希望激活并使用 SSL 3.0，请在 Internet Explorer 中或者“Start Center > Settings”中选中以下选项：Internet Options > Advanced > Use SSL 3.0。

对于 RT Advanced，可以在 Internet Explorer 中或者在“控制面板”(Control Panel) 的“Internet 选项 > 高级”(Internet Options > Advanced) 下，通过取消激活“使用 SSL 3.0”(Use SSL 3.0) 选项来禁止使用 SSL 3.0。

网络设置

下表列出了为分析网络安全性和配置外部防火墙而为每个产品设置的网络设置：

WinCC Professional（不含仿真）
名称 | 端口号 | 传输协议 | 方向 | 功能 | 说明
ALM | 4410* | TCP | 入站，出站 | 许可证服务 | 该服务提供了软件许可的完整功能，供 Automation License Manager 以及所有与许可相关的软件产品使用。
HMI 加载 | 1033 | TCP | 出站 | HMI 加载 (RT Basic) | 该服务用于将映像和组态数据传送到基本面板。
HMI 加载 | 2308 | TCP | 出站 | HMI 加载 (RT Advanced) | 该服务用于将映像和组态数据传送到面板。
RPC | ** | UDP | 入站，出站 | 客户端/服务器和 ES 通信 (CCAgent) | 该服务可用于 WinCC Professional 和 WinCC Runtime Professional。
* 可由用户组态更改的默认端口 ** 端口是自动分配的

用于基本面板的 WinCC 仿真
名称 | 端口号 | 传输协议 | 方向 | 功能 | 说明
HMI 加载 | 1033 | TCP | 入站 | HMI 加载 (RT Basic) | 该服务用于将映像和组态数据传送到基本面板。
EtherNet/IP | 44818 | TCP | 出站 | 以太网/IP 通道 | 以太网/IP 协议用于连接 Allen Bradley PLC。
 | 2222 | UDP | 入站 | 以太网/IP 通道 | 以太网/IP 协议用于连接 Allen Bradley PLC。
Modbus TCP | 502 | TCP | 出站 | Modbus TCP 通道 | Modbus TCP 协议用于连接 Schneider PLC。
RFC 1006 | 102 | TCP | 出站 | S7 通道 | 通过以太网/PROFINET 与 S7 控制器进行通信
Mitsubishi MC | 5002 | TCP | 出站 | Mitsubishi MC 通道 | Mitsubishi 协议用于连接 Mitsubishi PLC。

用于面板和 Runtime Advanced 的 WinCC 仿真
名称 | 端口号 | 传输协议 | 方向 | 功能 | 说明
DCP | --- | 以太网 | 出站 | PROFINET | DCP 协议（发现和基本组态协议）被 PROFINET 采用，可提供用于定位和组态 PROFINET 设备的基本功能。
LLDP | --- | 以太网 | 入站，出站 | PROFINET | PROFINET 采用 LLDP 协议（链路层发现协议）进行拓扑检测。
SMTP | 25 | TCP | 出站 | SMTP 通信 | WinCC Runtime Advanced 使用该服务发送电子邮件。
HTTP | 80* | TCP | 入站 | HTTP 通道服务器 HTML 页面 | 仅当 HTTP 通道服务器或 HTML 页面已激活时，Web 服务器才可用。根据自动选择的设置，使用的端口可能会有所不同。
RFC 1006 | 102 | TCP | 出站 | S7 通道 | 通过以太网/PROFINET 与 S7 控制器进行通信
NTP | 123 | UDP | 出站 | 时间同步 | NTP 协议（网络时间协议）用于在基于 IP 的网络内进行时间同步。
SNMP | 161 | UDP | 出站 | PROFINET | STEP 7 可以通过 SNMP 客户端功能读取 PROFINET 设备的状态信息。
HMI 加载 | 2308 | TCP | 出站 | HMI 加载 (RT Advanced) | 该服务用于将映像和组态数据传送到面板。
HTTPS | 443* | TCP | 入站 | HTTP 通道服务器 HTML 页面 | 仅当 HTTP 通道服务器或 HTML 页面已激活时，使用 HTTPS 协议的 Web 服务器才可用。基于自动选择的设置，使用的端口可能会有所不同。
VNC 服务器 | 5900* | TCP | 入站 | Sm@rtServer | 只有激活 Sm@rtService 时该服务才可用。
 | 5800* | TCP | 入站 | Sm@rtServer | 只有激活 Sm@rtService 时该服务才可用。
VNC 客户端 | 5500 | TCP | 出站 | Sm@rtServer | 只有激活 Sm@rtService 时该服务才可用。
* 可由用户组态更改的默认端口

WinCC Simulation for Runtime Professional
名称 | 端口号 | 传输协议 | 方向 | 功能 | 说明
RPC | ** | UDP | 入站，出站 | 客户端/服务器和 ES 通信 (CCAgent) | 该服务可用于 WinCC Professional 和 WinCC RT Professional。
RPC | ** | UDP | 入站，出站 | 客户端/服务器通信 (CCEServer/CCEClient) | 该服务可用于 WinCC Runtime Professional。
HTTP | 80 | TCP | 入站，出站 | 客户端/服务器通信 (CCEServer/CCEClient) | 该服务可用于 WinCC Runtime Professional。
RFC 1006 | 102 | TCP | 出站 | S7 通道 | 通过以太网/PROFINET 与 S7 控制器进行通信
OPC UA | 4840 | TCP | 入站 | OPC UA 服务器 | 对于通过 OPC UA 的主要通信，需要此服务。在安装过程中可激活和组态此服务。
OPC UA 发现 | 52601 | TCP | 入站 | OPC UA 服务器 | 此服务提供了所安装的 OPC 服务器的相关信息。该服务通过 OPC UA 服务器进行安装和组态。
DCOM | 135 | TCP | 入站 | OPC 服务器 | 此服务是 Windows 操作系统的一部分。由于通过 OPC (DA) 实现的通信基于 DCOM，因此需要使用此服务才能初始化 OPC (DA) 连接。
DCOM | ** | TCP | 入站 | OPC 服务器 | 通过 OPC (DA) 实现的通信基于 DCOM，且使用系统分配的非指定端口。在使用 OPC (DA) 和创建防火墙规则时，应考虑到这一点。
HTTP | 80 | TCP | 入站 | OPC 服务器 | 对于通过 OPC XML 的主要通信，需要此服务。在安装过程中可激活和组态此服务。
NetBIOS | 137 | UDP | 入站 | OPC 服务器 | 此服务是 Windows 操作系统的一部分。例如，需要通过 OPC-Scout 访问此服务才能浏览。
NetBIOS | 138 | UDP | 入站 | OPC 服务器 | 此服务是 Windows 操作系统的一部分。例如，需要通过 OPC-Scout 访问此服务才能浏览。
SNMP | 161 | UDP | 出站 | SNMP OPC 服务器 | 例如，此服务供 SNMP OPC 服务器用于更改或查询网络驱动器上的数据。
SNMP 陷阱 | 162 | UDP | 入站 | SNMP OPC 服务器 | 例如，此服务供 SNMP OPC 服务器用于查询网络驱动器中的事件。
** 端口是自动分配的

用于面板和 Runtime Advanced 的 PROFINET 协议
名称 | 端口号 | 传输协议 | 方向 | 功能 | 说明
DCP | --- | 以太网 | 出站 | 可访问订阅方列表， PROFINET 发现和组态 | DCP 协议（发现和基本组态协议）被 PROFINET 采用，可提供用于定位和组态 PROFINET 设备的基本功能。
LLDP | --- | 以太网 | 入站，出站 | PROFINET 链路层发现协议 | PROFINET 采用 LLDP 协议（链路层发现协议）进行拓扑检测。
MRP | --- | 以太网 | 出站 | PROFINET 介质冗余 | MRP 协议（介质冗余协议）使用环形拓扑实现对冗余传输路径的控制。
PROFINET IO 数据 | --- | 以太网 | 入站，出站 | PROFINET 周期性 IO 数据传送 | 面板将周期性数据交换用于直接键和 LED。
ARP | --- | 以太网 | 入站，出站 | 名称地址解析 | 该协议用于解析网络名称和分配 IP 地址。
PROFINET 上下文管理器 | 34964 | UDP | 入站，出站 | 无 PROFINET 连接的 RPC | PROFINET 上下文管理器可提供终点映射器以建立应用关联 (PROFINET AR)。

用于面板和 WinCC Runtime Advanced 的通信连接
名称 | 端口号 | 传输协议 | 方向 | 功能 | 说明
Telnet | 23 | TCP | 入站 | Telnet | 该服务可用于维护。
SMTP | 25 | TCP | 出站 | SendEMail | Windows CE/PC Runtime 使用该服务发送电子邮件。
HTTP | 80* | TCP | 入站 | 超文本传输协议 | HTTP 协议用于与 HMI Web 服务器通信。
RFC 1006 | 102 | TCP | 出站 | S7 通道 | 通过以太网/PROFINET 与 S7 控制器进行通信。
NTP | 123 | UDP | 出站 | 时间同步 | NTP 协议（网络时间协议）用于在基于 IP 的网络内进行时间同步。
DCOM*** | 135 | TCP | 入站 | OPC 服务器 | 该服务是 Microsoft Windows 操作系统的组件。通过 OPC (DA) 实现的通信基于 DCOM。因此，需要使用此服务才能初始化 OPC (DA) 连接。
DCOM*** | ** | TCP | 入站 | OPC 服务器 | 通过 OPC (DA) 实现的通信基于 DCOM，且使用系统分配的非指定端口。在使用 OPC (DA) 和创建防火墙规则时，应考虑到这一点。
TCP/IP 上的 NetBIOS | 137 | UDP | 出站 | 使用远程文件共享 | 注册/登录到远程服务器。
TCP/IP 上的 NetBIOS | 138 | UDP | 出站 | 使用远程文件共享 | 注册/登录到远程服务器。
SNMP | 161 | UDP | 出站 | 简单网络管理协议 | STEP 7 可以通过 SNMP 客户端功能读取 PROFINET 设备的状态信息。
HTTPS | 443* | TCP | 入站 | 安全超文本传输协议 | HTTP 协议用于通过安全套接层 (SSL) 与 HMI Web 服务器通信。
Modbus TCP | 502* | TCP | 出站 | Modbus TCP 通道 | Modbus TCP 协议用于连接 Schneider PLC。
Mitsubishi MC | 1025* | TCP | 出站 | Mitsubishi MC 通道 | Mitsubishi 协议用于连接 Mitsubishi PLC。
打印 | 1032 | TCP | 出站 | 打印 | 在控制面板上打印（通过以太网）。
HMI 加载 | 2308 | TCP | 出站 | 传送 | 该服务用于将映像和组态数据传送到面板。在精智面板上，已将该服务替换为 V13 及更高版本的 DeviceManager 和 SCS。该服务用于将组态数据传送到 WinCC Runtime Advanced。
HMI 加载 | 50523 | TCP | 出站 | 传送 | 当端口 2308 不可用时使用该端口。 该服务用于将映像和组态数据传送到面板。在精智面板上，已将该服务替换为 V13 及更高版本的 DeviceManager 和 SCS。 该服务用于将组态数据传送到 WinCC Runtime Advanced。
ALM | 4410* | TCP | 入站，出站 | 应用程序许可证管理器 | RT Advanced 的该项服务为软件许可证提供完整功能，由自动化许可证管理器使用。
OPC UA | 4870* | TCP | 入站 | OPC UA 服务器 | 对于通过 OPC UA 的通信，需要该服务。
HMI 加载 | 5001 | TCP | 出站 | 设备管理器 | 该服务用于将映像和运行系统传送数据到面板。
HMI 加载 | 5002 | TCP | 出站 | SCS（系统组态服务器） | 该服务用于将组态数据传送到面板。
VNC 客户端 | 5500 | TCP | 出站 | Sm@rtServer | VNC 客户端连接
VNC 服务器 | 5800* | TCP | 入站 | Sm@rtServer | VNC 服务器连接 HTTP
 | 5900* | TCP | 入站 | Sm@rtServer | VNC 服务器连接
SIMATIC Logon | 16389* | TCP | 出站 | UMAC（针对访问控制的用户管理） | 注册/登录到远程服务器。
Allen Bradley Ethernet IP | 44818 | TCP | 出站 | 以太网/IP 通道 | 以太网/IP 协议用于连接 Allen Bradley PLC。
预留 | 49152 ... 65535 | TCP/UDP | 出站 |  | 动态端口范围用于，例如，连接到远程文件共享。
* 可由用户组态更改的默认端口 ** 端口是自动分配的。 *** 仅受 WinCC Runtime Advanced 支持。


数据保护

数据保护

西门子遵守数据保护准则，特别是数据最少化要求（从设计着手保护隐私）。这对于此 SIMATIC 产品意味着：产品不处理/保存任何个人信息，但技术功能数据除外（例如时间戳）。如果用户将该数据与其它数据（例如排班计划）链接或者将个人信息保存在同一载体（例如硬盘）上并由此在处理过程中建立个人参考，则用户须确保符合数据保护准则。


使用注意事项

内容 升级后的响应变化 安装路径 使用标准用户权限 屏幕键盘 (RT Advanced) 设备更改 – 字符设置 (RT Professional) 模拟中的文本 (RT Professional) 采用用户定义周期时的在线增量加载 (RT Professional) 通过 S7USB 传送许可证 在 64 位操作系统中将许可证传送至面板 PostScript 字体 带有变量触发器的任务
使用注意事项

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

升级后的响应变化

与前一个版本相比，新版本的 WinCC 包含一些新增功能和改进之处。因此升级后，新版本在名称或对属性和函数的响应方面可能会稍有不同。与之前的版本不同，还可更改新创建对象的标准属性。

这些响应差异可能会导致编译项目时出错。

安装路径

如果在旧版本中安装仿真，则安装期间无法调节安装路径。

使用标准用户权限

如果在 Windows 7 中使用标准用户权限，则不能禁用“用户账户控制 (UAC)”(User Account Control (UAC))。

Windows 7 中默认启用了“用户账户控制”。

有关“用户账户控制”的更多信息，请参见 Windows 7 的在线帮助。

屏幕键盘 (RT Advanced)

打开 TIA Portal 后便不能再使用屏幕键盘。

若要在 Windows 系统中使用屏幕键盘，请使用以下命令：“开始 > 所有程序 > 附件 > 轻松访问 > 屏幕键盘”(Start > All Programs > Accessories > Ease of Access > On-screen keyboard)。

设备更改 – 字符设置 (RT Professional)

如果使用多种不同的项目语言在画面对象的多语言文本中组态不同字体，则将 HMI 设备从面板更换到基于 PC 的运行系统后，应对画面进行检查。更换设备时，组态的字体可能会发生更改。

模拟中的文本 (RT Professional)

如果在仿真时使用的运行系统语言和安装的产品语言不一致，则使用安装的产品语言显示系统文本。根据操作系统和安装的产品语言，该语言可能是英文或中文。

如果想在模拟中使用相关语言查看所有日语、韩语或繁体中文文本，首先应该安装 WinCC 而不进行模拟。然后安装包含所需语言的 WinCC Runtime Professional。

采用用户定义周期时的在线增量加载 (RT Professional)

如果在“周期”编辑器中组态了新的自定义周期，则在加载项目时选择“加载 > 软件（全部编译）”(Load > Software (compile all)) 命令。无法进行在线增量加载。

通过 S7USB 传送许可证

总是需要运行 WinCC，才能通过 S7USB 将许可证传送到面板。

在 64 位操作系统中将许可证传送至面板

如果运行的是 64 位操作系统，但在自动化许可证管理器中“编辑 > 连接目标系统 > 连接 HMI 设备”(Edit > Connect target systems > Connect HMI device) 菜单命令不可用，则打开命令行输入并以管理员权限运行以下命令：

"%WINDIR%\system32\RegSvr32.exe" "%CommonProgramFiles%\siemens\AlmPanelPlugin\ALMPanelParam.dll"

PostScript 字体

TIA Portal 只能使用包含 TrueType 数据的字体。不支持 PostScript 字体和包含 PostScript 数据的 OpenType 字体。

带有变量触发器的任务

写入内部变量时，执行带有变量触发器的任务，即使内部变量值不变也是如此。


移植

内容 移植使用 WinCC V7 创建的项目 移植具有 ProTool 对象的集成项目 进度条
移植

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

移植使用 WinCC V7 创建的项目

移植的前提条件是，此项目已由 WinCC V7 更新 3 及以上版本处理。

移植具有 ProTool 对象的集成项目

如果移植集成在 STEP 7 中的 WinCC flexible 项目，并且输出错误消息“STEP 7 中缺少 PROTOOL 选项包”(PROTOOL option package(s) missing in STEP 7)，则意味着您安装了 WinCC flexible 2008 SP3 或更高版本。而且，项目仍会包含使用 ProTool 组态的对象。不要使用 WinCC flexible 打开项目。要移植项目，请按照以下步骤进行操作：

  1. 在 SIMATIC Manager 中打开项目。

  2. 执行“文件”(File) 菜单中的“另存为”(Save as) 命令。

  3. 在“项目另存为”(Save project as) 对话框中启用“重组”(With reorganization) 选项。

  4. 单击“确定”(OK)。

  5. 将项目复制回原始计算机。

  6. 重新开始移植。

进度条

进度条上显示的值为 100% 时，说明软件仍在运行剩余任务（如，关闭引用）。在这种状态下，软件不会响应用户输入。


工程系统

工程系统

该章节包括以下主题的信息:
  • 画面和画面对象
  • 变量和连接
  • 报警系统和报警显示
  • 系统函数和脚本
  • 报表
  • 配方
  • 用户管理
  • 通信


画面和画面对象

内容 HMI 设备更换后的画面对象 画面对象的分组 带有多种不同可视化属性的画面对象 组对象的动态化 (RT Professional) 面板的动态化 (RT Professional) 文本字段、列表和报警文本中的字符数 WinCC 中的透明度（自 V13 起） 在 HTML 浏览器中显示 SIMOTION PLC 网站 显示组态与 HMI 设备上显示内容之间的差异 GRAPH 概览 (RT Professional) 使用“IEC 定时器”类型的 UDT 更新面板 带可见性动画的更高级别控制 系统诊断视图：“HMI 访问权”(HMI access) 访问保护 窗口对象标题中的字体（面板和 Runtime Advanced） 升级后图形列表中的无效图形类型 (Runtime Professional) 面板中的多语言图形 在 PLC 代码视图中的网络更改 (RT Professional) 我的控件 动画支持的数据类型
画面和画面对象

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

HMI 设备更换后的画面对象

将设备升级到新的 HMI 设备版本后，应对项目中包含的画面进行检查。由于采用新外观并改善了操作性，因此符号 I/O 字段的文本可能并不完全清晰可辨，并且可能被操作员控件隐藏。

画面对象的分组

在 WinCC 中对画面对象进行分组时，嵌套过深会导致 WinCC 出现性能问题。

带有多种不同可视化属性的画面对象

使用带有多种不同可视化属性的画面对象（如，许多不同样式）时，将降低运行系统的性能并占用更多的存储器空间。例如，避免使用很多不同的转角半径：0 像素、1 像素、2 像素、3 像素等。

组对象的动态化 (RT Professional)

对包含多个嵌套的分组来说（组中的组、组中的面板、面板中的组等），只有最外面的组和最里面的对象的事件可用于通过系统函数实现动态化。较低级别组或较低级别面板的事件中组态的系统函数不会执行。

该组中某个对象组的同步运动动画组态可能会在运行系统中未按预期方式执行。检查运行系统中的执行顺序，必要时调整组态。

面板的动态化 (RT Professional)

使用用户数据类型连接来动态化面板实例不在计划内，但是可以在某些情况下使用辅助变量来实现。有关该内容的信息，请参见 FAQ 109766634。

文本字段、列表和报警文本中的字符数

画面对象文本可使用的字符数不是固定的。输入文本数据时会考虑控制指令和格式，最大字符数将相应减少。

WinCC 中的透明度（自 V13 起）

运行系统中可正常显示透明图形。这适用于所有精智面板和版本 13.0 或更高版本的 WinCC Runtime Advanced。
要在图形视图或图形 I/O 域中使用透明效果，必须将“填充图案”(Fill pattern) 属性设置为“透明”(Transparent)，并且必须禁用“使用透明色”(Use transparent color) 属性。

在 HTML 浏览器中显示 SIMOTION PLC 网站

如果 SIMOTION PLC 网站未正确显示在 HTML 浏览器中，请在网站 URL 后插入“"/basic"”，从而在基本模式下显示这些网站。

显示组态与 HMI 设备上显示内容之间的差异

由于显示组态，画面对象中组态文本的显示可能与 HMI 设备上的显示不同。如果组态中使用的是自动调整大小选项，请检查 HMI 设备上每种语言的显示。

如果通过“按内容调整对象大小”(Fit object to contents) 选项组态的文本无法全部显示，则会在 HMI 设备上稍微缩减这些文本。如果这种缩减造成文本显示失真，请禁用“按内容调整对象大小”(Fit object to contents) 选项并通过添加空格来扩展文本。也可加增加对象宽度或针对该文本使用缩写规则。

GRAPH 概览 (RT Professional)

升级至 V14 时，“单击”(Click) 事件所触发的 C 函数签名将发生更改。之前版本中的 propertyName 参数已删除。升级后，可访问此参数的函数将显示为故障状态。

使用“IEC 定时器”类型的 UDT 更新面板

“ST”元素自动从使用“IEC 定时器”数据类型的用户定义的 PLC 数据类型 (UDT) 中移除。将包含这些 UDT 的面板调整为不含 ST 元素的新版 UDT。

有关此内容的详细说明，请参见 SIMATIC 在线客户支持网站中的 FAQ 条目 ID“109740393”：

带可见性动画的更高级别控制

对于带可见性动画的基于表的控制，其更高级别组态可在使用装有 Windows CE/Embedded Compact 的设备进行触摸操作时导致问题。

系统诊断视图：“HMI 访问权”(HMI access) 访问保护

将“HMI 访问权”(HMI access) 访问保护与 SIMATIC S7-1200 PLC 结合使用时，仅可确保自固件版本 V4.1 起能够正确显示诊断数据。

窗口对象标题中的字体（面板和 Runtime Advanced）

在设备“运行系统”(Runtime) 设置中配置的字体不会用于报警窗口、系统诊断窗口以及对话框标题。

升级后图形列表中的无效图形类型 (Runtime Professional)

将项目升级为 TIA Portal 版本 V16 时，如果图形列表中存在无效图形类型，会产生编译错误，此类错误在 V14 中显示为警告。

为避免编译期间出现错误消息，必要时可更正图形列表中的图形类型。

面板中的多语言图形

在面板中，将图形插入画面对象。此图形将在所有指定的项目语言中使用。

如果使用快捷菜单命令“编辑”(Edit)，通过“集中编辑图形”(Edit graphic centrally) 选项打开该图形，则在外部编辑器（如 MS Paint）中进行编辑和保存后，该图形仅针对当前设置的项目语言进行更改。相应图形的更改在使用该图形的所有对象中均可见。

在 PLC 代码视图中的网络更改 (RT Professional)

ProDiag 报警待决时，PLC 代码视图中的网络更改将在运行系统中更新。

为正确显示 PLC 代码视图中的网络更改以进行标准分析，必须再次触发消息。

我的控件

“我的控件”可能未在工程组态系统中正确显示。但用户可对其进行组态且不受任何限制。运行系统中的表示和可操作性也没有任何限制。如果该控件基于 OCX 技术，则建议切换为 .Net。

动画支持的数据类型

允许将整型值和布尔值作为某一映像内的动画数据类型。


变量和连接

内容 多路复用变量（精简面板） 带有符号寻址功能和“Char 数组”数据类型的变量 (RT Professional) “String”类型的变量的长度规格 (RT Professional) 用于连接 SIMOTION PLC 的“String”类型的变量（面板、RT Advanced） “盒 ID 变量”下的变量（移动面板） WinCC 中的数组元素 使用 64 位数据类型 非冗余模式下的 R/H 系统中的 PLC 系统诊断
变量和连接

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

多路复用变量（精简面板）

如果要在精简系列面板中使用一个外部变量对变量进行多路复用，则 PLC 需要在运行系统的第一个读取周期内读取该地址。读取的地址值在第二个读取周期前一直可用。

带有符号寻址功能和“Char 数组”数据类型的变量 (RT Professional)

进行符号寻址的“WString”数据类型的变量，不适用于 RT Professional 和 SIMATIC S7-1200 V3 数据通信。

“String”类型的变量的长度规格 (RT Professional)

“String”类型的内部 HMI 变量的长度规格对“变量”编辑器没有影响。例如，如果要限制输入字段或输出字段的变量长度，请使用 VB 脚本或 C 脚本限制长度。

用于连接 SIMOTION PLC 的“String”类型的变量（面板、RT Advanced）

SIMOTION 控制器的字符串变量长度不得超过 210 个字符。

可以在工程组态系统中创建一个超过 210 个字符的字符串选项卡。但是，上述变量不会写入运行系统。将显示一条消息，说明变量已超出限值。

此时，要调整字符串变量的长度。

“盒 ID 变量”下的变量（移动面板）

通过“运行系统设置 > 常规”(Runtime Settings > General) 在“盒 ID 变量”(Tag box ID) 下组态的变量仅适用于只读模式。

例如，可能未将任何值写入该变量，不过其可在脚本中进行读取或输出到画面中。

WinCC 中的数组元素

如果将 HMI 变量与 STEP 7 数据块中起始下限值不是 0 的数组相连接，数组元素将以下限值 0 映射到 WinCC 中。

为了避免在访问各个数组元素时重新计算 STEP 7 索引和 WinCC 索引之间的关系，STEP 7 中数组的下限值应当从 0 开始。

使用 64 位数据类型

使用 64 位数据类型会导致准确性略有下降，因为这类数据在 HMI 通道中被映射到双精度数据类型。因此，整型数据类型会显示有小数点。

非冗余模式下的 R/H 系统中的 PLC 系统诊断

在 R/H 系统中对两个 PLC 和两个相应连接进行组态。如果 R/H 系统不处于冗余模式，则可能发生连接的系统诊断视图对于同一 PLC 显示不同的诊断状态符号。


报警系统和报警显示

内容 报警日志中的 Boolean 变量 PLC 报警 运行系统中的控制器报警 (WinCC Professional) 使用集成连接复制项目
报警系统和报警显示

内容

在线帮助中未包含的信息和产品特征的重要信息。

报警日志中的 Boolean 变量

布尔型变量在报警日志中被识别为 0 和 -1。如果要使用通过报警日志中的布尔型变量进行控制的文本列表，则需要将对应值 -1 的条目添加到相应的文本列表中。

PLC 报警

只有在此 FB 中存在背景数据块时，PLC 报警才会显示在 HMI 设备的“报警”(Alarms) 编辑器中。

运行系统中的控制器报警 (WinCC Professional)

如果将项目由版本 V13 SP1 或 V13 SP2 升级为 V14、V14 SP1、V15、V15.1、V16，需要编译项目并将其载入到控制器和 HMI 设备中。否则，控制器报警会在报警视图中显示为被划掉。

使用集成连接复制项目

如果使用集成连接（HMI 设备和控制器之间）将设备从项目复制到全球库中，并将其插入到新项目中，则有关控制器报警的信息会在 HMI 设备上丢失。要避免信息丢失，请首先复制所有控制器，之后才可将所有 HMI 设备复制到新项目中。


系统函数和脚本

内容 服务项目的脚本 (RT Professional) 脚本调试程序仿真 用户自定义函数的触发变量 (RT Professional) 面板中的用户自定义函数 位处理系统函数（移动面板和 RT Advanced） 不再使用的属性（精致面板和 RT Advanced） 向 VBScript 传送参数（面板和 RT Advanced） 通过用户定义函数提供趋势视图 参数的最大数量（面板和 RT Advanced） “ShowLogonDialog”系统函数（面板和 RT Advanced）
Debug Err
系统函数和脚本

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

服务项目的脚本 (RT Professional)

因为在服务项目中交互式用户通常不登录，所以，C 脚本和 VB 脚本在下列情况下会出现问题：

  • 脚本需要进行交互操作时，例如，操作员输入。

  • 脚本显示消息框时。

在服务模式下，没有为 C 脚本提供公共数据区域。因此，不能在“计划任务”和“画面”之间交换全局 C 变量。

脚本调试程序仿真

要通过 TIA Portal 启动“脚本调试程序仿真”，注册表项
HKEY_CLASSES_ROOT\CLSID\{834128A2-51F4-11D0-8F20-00805F2CD064}\LocalServer32 必须包含“字符串”类型的条目“（标准）”，其中包含标准脚本调试程序“devenv.exe”的完整路径。调试程序可连接到未使用此注册表项就已在运行的仿真。

用户自定义函数的触发变量 (RT Professional)

如果在画面中组态了 HMI 或 PLC 用户数据类型，则无法在新建或更改的用户自定义用户函数中将该用户数据类型的元素用作触发变量。

面板中的用户自定义函数

如果要使用用户自定义函数访问面板中的变量，则无法动态组合变量名称。

位处理系统函数（移动面板和 RT Advanced）

由于事件的原因无法对位数组进行操作。系统函数，例如 InvertBit、SetBit 等，不得包含位数组中的任何元素作为参数。

不再使用的属性（精致面板和 RT Advanced）

WinCC V13 中引入了多种全新的视觉属性并统一了多个现有属性。

在对对象属性的修订过程中，WinCC V13 不再支持使用早期版本 WinCC 的 VB 脚本中可以使用的一些属性。使用不再受支持的属性的脚本仍然有效，但脚本中的相关调用不起作用。只有设备版本为 V13.0 的精致面板和 RT Advanced 存在这些限制。

下表显示了不再使用的画面对象的属性：

属性 | 画面对象
BorderBrightColor3D | 滚动条
BorderColor | 文本字段、I/O 字段、符号 I/O 字段和 日期/时间字段
BorderInnerWidth3D | 滚动条
BorderOuterWidth3D | 滚动条
BorderShadeColor3D | 滚动条
BorderStyle3D | 文本字段、I/O 字段、按钮、符号 I/O 字段、图形 I/O 字段、日期/时间字段、棒图、开关
BorderWidth | 文本字段、符号 I/O 字段
CenterColor | 量表
DialColor | 量表
EdgeStyle | 文本字段、I/O 字段

向 VBScript 传送参数（面板和 RT Advanced）

在 WinCC 中，可以定义是否传送 VB 脚本“ByRef”（参数地址）或“ByVal”（参数的值）的参数。

仅 VB 脚本的内部变量可以使用 "ByRef" (Call by Reference) 传送参数地址。无论是否将参数定义为“ByRef”或“ByVal”，通过 HMI 变量，始终能够传送参数的值。

通过用户定义函数提供趋势视图

使用 VBS 函数读取日志值，以在趋势视图中进行显示时，必须确保时间戳之间的差值大于零。

参数的最大数量（面板和 RT Advanced）

对于“sub”类型，全局函数的最大参数数量为 8，对于“func”类型，最大参数数量为 7。

“ShowLogonDialog”系统函数（面板和 RT Advanced）

对于面板和 Runtime Advanced，不应为变量的“值更改”事件组态“ShowLogonDialog”系统函数。


报表

内容 打印报表（面板）
报表

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

打印报表（面板）

打印过程中可裁掉位于报表边缘的对象，具体视所用打印机而定。

请确保报表的尺寸合适。


配方

内容 配方同步（精简面板、面板、精智面板和 RT Advanced）
配方

内容

在线帮助中未包含的信息和产品功能的重要信息。

配方同步（精简面板、面板、精智面板和 RT Advanced）

将数据记录值发送到控制器时，仅当在“常规 > 同步 > 设置”(General > Synchronization > Settings) 下为配方选择了“手动传送各个修改过的值（交互模式）”(Manual transfer of individual modified values (teach-in mode)) 选项时，才对值进行验证。


用户管理

内容 UMAC 域用户
用户管理

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

UMAC 域用户

在 WinCC V16.0 中，尽可使用 UMAC 用户，无 UMAC 域用户。


通信

内容 建立与 WinCC Runtime Advanced 的连接 非集成连接的连接更改 与 Mitsubishi PLC 的连接中断 自签名证书 (RT Professional) “DTL”数据类型的精度 可用 HMI 连接数的限值 PROFINET IO 与面板 HMI 设备一起使用 RT Advanced 通过 Station Manager (SIMATIC NET) 与 S7-1200 通信 在 HMI 设备的控制面板中更改 PLC 的 IP 设置和设备名称（精简面板） “在控制面板中设置 PLC 的 IP 协议集（地址）”与 SIMATIC S7-1200 V1（精简面板） 通过 PROFIBUS DP 建立连接 切换连接 Runtime Professional 与 SIMATIC S7-1200 之间的通信 Station Manager 中的 RT Advanced 冗余项目中的原始数据通信 (RT Professional) 到 SIMATIC S7-1500 软件 PLC 的非集成连接 (RT Advanced) HMI 设备在 IO 设备和 DP 从站操作模式下的传输区 通过 HMI 设备获取诊断数据 PROFIenergy 通信 SmartClient 连接数
通信

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

建立与 WinCC Runtime Advanced 的连接

请确保工程组态系统中组态的设备版本与安装的运行系统版本匹配；否则，加载项目时通信将无法建立或发生延迟。

如果设备版本与安装的运行系统版本不匹配，您可以采取以下措施：

  1. 更改工程组态系统中组态的设备版本。

  2. 安装与组态的设备版本相对应的 WinCC Runtime Advanced 版本。

非集成连接的连接更改

如果要更改从一个非集成连接到另一个非集成连接间的通信，例如从 Omron 到 Mitsubishi，则必须确保新的连接同样支持变量的数据类型。

与 Mitsubishi PLC 的连接中断

多次连接中断后，可能会造成 Mitsubishi PLC 的所有连接资源都被占用，并且无法再建立连接。我们建议您检查控制器的 PLC 程序中的这些连接资源并再次启用它们。

自签名证书 (RT Professional)

不再支持自签名证书。

如果在服务器侧检测到自签名证书，则会通过之前分配的 PSK 密钥（预共享密钥）进行身份验证。如果通信伙伴的 PSK 密钥不匹配，则不会建立通信。

“DTL”数据类型的精度

“DTL”数据类型支持精确到纳秒级的时间信息。由于面板对时间信息的支持只能到毫秒级，因此使用区域指针时将出现以下限制：

  • 区域指针“日期/时间”
    对于面板到 PLC 的时间信息传送，最小时间单位为 1 毫秒。“DTL”数据类型中微秒到纳秒的取值范围将用零填充。

  • 区域指针“日期/时间 PLC”
    对于 PLC 到面板的时间信息传送，微秒到纳秒的范围将被忽略。面板中将继续处理毫秒级和更低精度的时间信息。

可用 HMI 连接数的限值

设备编译期间将显示一条错误消息，指示“设备和网络”编辑器中 HMI 连接的组态无效。原因可能是超出了 HMI 设备或 PLC 可用的最大连接数。

请检查可用的最大连接数。请查阅所用设备的设备手册。

PROFINET IO 与面板 HMI 设备一起使用

使用 PROFINET IO 将 HMI 设备的直接键和 LED 连接到 PLC 时，可以在 HW Config 中进行组态时定义输入和输出的地址区域的偏移量。

将能够使用 PROFINET IO 的 S7-400 CPU 与下面列出的一种 HMI 设备一起使用时，以下限制适用：

输入的地址区域的起始位置的偏移不能大于输出的地址区域的起始位置的偏移。

该限制针对以下 HMI 设备：

  • Mobile Panel 177

要组态地址参数，在 HW Config 中打开配有 400 系列 CPU 的 PLC。在 HW Config 的工作站窗口中，选择通过 PROFINET IO 连接的 HMI 设备。在工作站窗口底部的详细视图中显示包含 HMI 设备属性的表格。在表格中选择包含 HMI 设备地址的行，然后使用快捷菜单打开对象属性。

在“对象属性”(Object properties) 对话框中启用“地址”(Addresses) 选项卡。在“输入 > 起始地址”(Inputs > Start) 下组态输入的偏移量。在“输出 > 起始地址”(Outputs > Start) 下组态输出的偏移量。

RT Advanced 通过 Station Manager (SIMATIC NET) 与 S7-1200 通信

当 SIMATIC S7-1200 与装有 WinCC RT Advanced 的 PC 之间通过路由器进行通信时，PC 存在以下限制：

  • Windows 7：只能通过安装的 SIMATIC NET 8.1 实现

使用 Station Manager 时，这些限制同样适用。通过 Runtime Advanced 的 Station Manager 实现的连接总是按路由的连接处理。

在 HMI 设备的控制面板中更改 PLC 的 IP 设置和设备名称（精简面板）

在 HMI 设备的“Service and Commissoning > IP-Adaptation”菜单中打开控制面板。如果要更改 PLC 的 IP 设置或者设备名称，请注意以下内容：

在工程组态系统中，您需要事先在 PLC 的巡视窗口中的“属性 > 常规 > PROFINET 接口 > 以太网地址”(Properties > General > PROFINET interface > Ethernet addresses) 下选择以下选项：

  • “使用不同方法设置 IP 地址”(Set IP address using a different method)

  • “使用不同方法设置 PROFINET 的设备名称”(Set PROFINET device name using a different method)

“在控制面板中设置 PLC 的 IP 协议集（地址）”与 SIMATIC S7-1200 V1（精简面板）

“在控制面板中设置 PLC 的 IP 协议集（地址）”功能未经批准，不能用于以下 PLC：

  • SIMATIC S7-1200 V1

通过 PROFIBUS DP 建立连接

如果通过 PROFIBUS DP 实现的 PLC 和 HMI 设备之间的连接发生中断并重新建立连接，则通信网络中的所有其它 PROFIBUS DP 连接在个别情况下会发生中断和重新建立连接。

在重新连接工作站之前，切断离线工作站的电源。

切换连接

连接从 HMI 设备切换到 SIMATIC S7-300/400、SIMATIC S7-1500 或 SIMATIC S7-1200 控制器时可能会发生中断。

请注意 SIMATIC S7-1500 或 SIMATIC S7-1200 PLC 中的以下设置：

  • 变量的绝对寻址

  • 必须选择“禁用 PUT-GET 通信”(Disable PUT-GET communication) 选项

  • 不得设置“全面保护”保护等级

Runtime Professional 与 SIMATIC S7-1200 之间的通信

在生产环境中，WinCC Runtime Professional 与 SIMATIC S7-1200 之间的通信仅限于单站系统。

Station Manager 中的 RT Advanced

如果 RT Advanced 和 WinAC RTX 使用 PC 的同一个通信处理器，则无法与 SIMATIC S7-1200 和 SIMATIC S7-1500 进行 HMI 通信。

冗余项目中的原始数据通信 (RT Professional)

由于无法组态冗余伙伴服务器的连接参数，因此诸如 Simatic.NET、命名连接和各种通信块（如 BSEND/BRCV）只能在有限范围内用于冗余组态的 PC 站。

到 SIMATIC S7-1500 软件 PLC 的非集成连接 (RT Advanced)

WinCC 不支持 HMI 设备和 SIMATIC S7-1500 软件 PLC 间的非集成连接。

HMI 设备在 IO 设备和 DP 从站操作模式下的传输区

如果您已经为 HMI 设备激活了“IO 设备”或者“DP 从站”操作模式，则在 HMI 设备属性中无需添加或删除传输区。如果您意外删除或添加了传输区，请断开再重新连接控制器。

通过 HMI 设备获取诊断数据

与信息系统中的模块和设备的诊断图标说明不同，在此处为 HMI 设备指定了以下图标的含义：

图标 | 含义
 | 无诊断数据可用。

PROFIenergy 通信

要建立 PROFIenergy 通信，请联系客户支持。

SmartClient 连接数

尽管精简面板支持无限数量的 SmartClient 连接，仍建议最多组态两个连接。任何其它连接都会影响性能。


系统范围的函数

内容 使用设备代理中的系统诊断 使用以前版本项目数据初始化设备代理 库文本的导入和导出
系统范围的函数

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

使用设备代理中的系统诊断

要使用 IPE 设备代理中的系统诊断功能（如系统诊断视图），可插入 PLC 报警作为设备代理的内容。

使用以前版本项目数据初始化设备代理

设备代理无法通过带服务包版本的项目中相关完整版项目的数据进行初始化。
请将源项目升级到服务包版本，之后才能使用该源项目中的数据在目标项目中初始化设备代理。

库文本的导入和导出

导入和导出库文本时不支持以下对象：

  • 导入：配方、配方元素、配方数据记录、HMI 报警、文本列表条目、画面、报告。

  • 导出：文本列表条目、画面、报告。

  • 库类型“画面”的导入和导出。


编译和装载

内容 编译和加载 检查地址参数 将数据下载到 PLC 时的错误消息 设备版本 13.0 或更高版本的精智面板：加载项目时备份数据 显示传送警报中的字符 减小项目大小
Microsoft KB3083806
编译和装载

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

编译和加载

如果编译期间产生了内部错误或警告，则使用 HMI 设备快捷菜单中的“编译”>“软件（全部重建）”命令来编译整个项目。

启动项目的生产操作之前，使用 HMI 设备快捷菜单中的“编译”>“软件（全部重建）”命令编译整个项目。

如果在项目中使用连接到控制变量的 HMI 变量，则使用快捷菜单中的“编译 > 软件”(Compile > Software) 命令对所有修改的块进行编译，然后再编译 HMI 设备。

检查地址参数

当通过快捷菜单中的命令“编译 > 硬件和软件（仅更改）”(Compile > Hardware and software (changes only)) 编译项目树中的 HMI 设备时，将不会检查 HMI 设备的地址参数，例如 IP 地址。如果要确保同样也检查地址参数，则需要在工具栏的“设备和网络”(Devices & networks) 编辑器中使用“编译”(Compile) 按钮编译 HMI 设备。

将数据下载到 PLC 时的错误消息

面板和 PLC 已连接且正在相互通信。

如果将数据从面板下载到 PLC 时访问变量，则在面板上将显示一条错误消息。

设备版本 13.0 或更高版本的精智面板：加载项目时备份数据

如果设备版本 13.0 或更高版本的精智面板传送中断，WinCC 将自动确保无数据丢失并仅当传送完成后才删除 HMI 设备上的现有数据。

显示传送警报中的字符

在对设备版本 V12 或更低版本的 HMI 设备执行传送操作期间，如果没有正确显示传送警报中的字符，请检查 Windows 的区域和语言设置。在“非 Unicode 程序的语言”(Language for non-Unicode programs) 下设置相应的语言。

减小项目大小

编译 HMI 设备时，出现报警通知您项目大小接近相应 HMI 设备的系统限制。此时，需执行软件的完整编译以减小项目大小。为此，使用“编译 > 软件（重建所有）”(Compile > Software (rebuild all)) 命令。


运行系统

运行系统

该章节包括以下主题的信息:
  • 在运行系统中操作的注意事项
  • 在运行系统中的面板操作的注意事项
  • 在 Runtime Advanced 中操作的注意事项
  • Runtime Professional 的操作注意事项
  • Runtime Unified 的操作注意事项


在运行系统中操作的注意事项

内容 运行系统中的焦点 语言特性 - 屏幕键盘的布局 变量值超过最大长度 空报警文本 日志初始化的持续期间（面板，RT Advanced） 大量的日志将延迟运行系统的终止（第二代精简面板） SmartServer 反应迟钝 结束 Sm@rtServer 上的屏幕保护程序 防止电源故障期间文件损坏 HMI 设备上的可变字体
在运行系统中操作的注意事项

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

运行系统中的焦点

如果已在版本 12.0.0 及更早版本的 HMI 设备中组态低对比度组合的焦点颜色和边框颜色，则在更改 TIA Portal 的设备版本后的运行时可能无法识别焦点。更改这两种颜色之一。

语言特性 - 屏幕键盘的布局

切换到屏幕键盘布局未安装的运行系统语言时，键盘布局不会发生变化。

在这种情况下，键盘的语言设置保持为最近有效的语言，或使用 Windows 默认键盘布局的语言设置。

变量值超过最大长度

通过 I/O 字段在字符串变量中输入字符串。如果字符串超过组态的变量数，则会将此字符串缩短到组态的长度。

空报警文本

运行系统正在运行项目。该项目保存在网络驱动器上。

网络驱动器连接中断时，运行系统会尝试从网络驱动器加载报警文本。

连接断开时，报警窗口或报警视图保持空白状态。

为避免此情况，可将项目复制到本地驱动器，然后再在运行系统中启动该项目。

日志初始化的持续期间（面板，RT Advanced）

可能需要最长 5 分钟的时间来初始化某些存储介质上的日志。成功完成初始化后马上会通过一个系统事件进行确认。如果运行系统启动时没有用于日志的存储介质，则该系统事件的出现也可能需要最长 5 分钟的时间。

大量的日志将延迟运行系统的终止（第二代精简面板）

如果使用大量的日志，运行系统的终止将持续较长的时间。对于大量的循环日志，可以使用分段日志。

SmartServer 反应迟钝

Windows 7 中，下列程序的启动和响应可能会十分缓慢：

  • HMI TouchInputPC

  • SmartServer：登录对话框中的 <Ctrl+Alt+Del> 快捷方式

延时由于 Internet 证书验证的回调而造成。

解决方法：

可在产品 DVD 的Support\Windows\CRL_Check 或 CD_RT\ Support\Windows7\CRL_Check\
下找到以下文件：

  • DisableCRLCheck_LocalSystem.cmd

  • DisableCRLCheck_CurrentUser.cmd

  1. 使用管理员权限运行“DisableCRLCheck_LocalSystem.cmd”文件。从文件的快捷菜单中选择命令“以管理员身份运行”(Run as administrator)。

  2. 重启 PC。

如果问题依旧，请按下列步骤执行：

  1. 双击文件并使用用户权限运行“DisableCRLCheck_CurrentUser.cmd”文件。

  2. 重启 PC。

    说明

    所有用户或 PC 的证书验证回调均被禁用。要恢复原始状态，请按下列步骤执行：

    • RestoreDefaults_LocalSystem.cmd

    • RestoreDefaults_CurrentUser.cmd

    可以在产品 DVD 的下列目录找到文件：

    • Support\Windows\CRL_Check or CD_RT\Support\Windows7\CRL_Check\

结束 Sm@rtServer 上的屏幕保护程序

服务器 HMI 设备上的 Sm@rtServer 激活屏幕保护程序时，需要具有 Sm@rtClient 客户端的写入权限才能终止服务器 HMI 设备上的屏幕保护程序。

防止电源故障期间文件损坏

如果在 WinCC 系统激活的情况下 Windows 系统出现电源故障，文件可能损坏。使用 NTFS 文件系统可提供更高的安全性。

只有在使用不间断电源 (UPS) 时，才能确保持续、安全的操作。

HMI 设备上的可变字体

自版本 1709 起，Windows 10 支持可变字体（“OpenType Font Variations”）。也可以在工程组态系统中使用可变字体的变体。运行系统中的实际显示情况取决于 HMI 设备和安装条件：

  • 精简面板、精智面板：不支持可变字体。始终显示基本版本。

  • Runtime Advanced、Runtime Professional：如果使用 Windows 10 版本 1709 及以上版本作为操作系统，并且通过管理员权限安装了字体，则支持可变字体。


在运行系统中的面板操作的注意事项

内容 在运行系统中使用鼠标滚轮 PLC 存储卡上的备份（精简面板） 面板数据存储和 S7-1500F（精简面板） “面板数据存储”功能（精简面板） 文件扩展名“.ttx”的字体 使用 USB 进行大量数据传输 修改面板的 IP 地址和设备名称
在运行系统中的面板操作的注意事项

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

在运行系统中使用鼠标滚轮

所有面板均不支持在运行系统中使用鼠标滚轮

PLC 存储卡上的备份（精简面板）

在 PLC 的存储卡上创建备份文件“A.psb”。创建备份时可能会发生错误，例如连接中断。
这会在 PLC 存储卡上创建一个损坏的文件。此文件具有前缀 "~$"。
如果要使用名称“A.psb”再次保存备份，则需要删除前缀为“~$”的文件。

面板数据存储和 S7-1500F（精简面板）

如果密码保护级别为“完全访问，包括故障安全”(Full access incl. fail-safe)，与 S7-1500F 一同使用时，精简系列面板不支持“面板数据存储”(PDS) 功能。

“面板数据存储”功能（精简面板）

仅 SIMATIC S7-1200 固件版本 V4.0 及以上版本和 SIMATIC S7-1500，精简系列面板才支持“面板数据存储”(PDS) 功能。要支持 PDS 功能，面板必须与 CPU 直接相连而不可通过 CP 相连。

文件扩展名“.ttx”的字体

文件扩展名“.ttx”的字体适用于所有面板和 Runtime Advanced，可正确显示在所有设备中，例如，“WinCC_flexible_smart”字体。

使用 USB 进行大量数据传输

如果已在组态 PC 上安装了 Windows 10，则“USB”传输通道不可用。

该限制针对以下设备和工具：

  • 基本面板：KP300 Basic、KP400 Basic、TP1500 Basic

  • 移动面板：170 系列和 270 系列

  • WinCC 工程组态系统

  • “ProSave”维护工具

说明

如果在组态 PC 上安装了 Windows 7，则“USB”传输通道保持可用状态。

解决方案

使用其它传输通道来传输项目数据，例如“工业以太网”或“PROFIBUS DP”通道。

修改面板的 IP 地址和设备名称

在精智面板上，甚至可以在运行期间修改 IP 地址和设备名称。

在精简面板上，无法在运行期间修改 IP 地址和设备名称。


在 Runtime Advanced 中操作的注意事项

内容 启动运行系统 用于启动 Runtime Advanced 的授权 Windows 10 计算机的屏幕保护程序 平板模式下的 Windows 10 在运行系统中使用 .Net 控件 禁用自动检查软件更新 通过 OPC 访问数组变量
在 Runtime Advanced 中操作的注意事项

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

启动运行系统

只能通过工程组态系统启动 WinCC Runtime V16。仅可仿真其它版本的 WinCC Runtime。

用于启动 Runtime Advanced 的授权

在运行 Windows 操作系统的计算机上，仅当启动运行系统的用户是“Siemens TIA 工程师”(Siemens TIA Engineer) 组的成员且拥有相应权限时，才能启动 WinCC Runtime Advanced。

Windows 10 计算机的屏幕保护程序

对于 Windows 10 计算机，在输出“错误”类别警报时激活的屏幕保护程序不再终止。

平板模式下的 Windows 10

不建议在平板模式下使用 Windows 10。

当在 Windows 10 中以平板模式运行应用程序时，例如Runtime Advanced、Sinumerik Operate 等，这些应用程序将在启动后最小化。

在运行系统中使用 .Net 控件

如果将 .Net 控件作为“自定义 .Net 控件”组合到项目中，则必须将属于这些控件的文件复制到 WinCC Runtime 的安装目录中，也就是复制到“C:\ProgramFiles\Siemens\Automation\WinCC RT Advanced”。否则，将无法在运行系统中加载这些控件。

禁用自动检查软件更新

如果 PC 上同时安装了工程系统和运行系统，操作员可以获得软件更新通知。为使工程系统在多站系统中稳定运行，所有 PC 上都必须安装同一软件版本。

可以禁用自动检查软件更新，从而提高性能。

要禁用自动检查软件更新，请转至“设置 > 常规 > 软件更新”(Settings > General > Software updates) 并取消激活“每日检查更新”(Check for updates daily) 选项。

通过 OPC 访问数组变量

如果将 WinCC Runtime Advanced 用作 OPC UA 服务器，则仅当激活了“OPC UA Server Array index range access”设置时才支持读取数组变量。

仅当 OPC UA 客户端支持设置“Write array elements without IndexRange”时才能写入数组变量。


Runtime Professional 的操作注意事项

内容 操作系统中的用户授权 锁定快捷键 取消停靠的工具栏 服务器与客户机之间的连接故障 服务器与客户机之间的连接故障 启动 WinCC Runtime Professional 设置 SQL 服务器的服务 WinCC Runtime Professional 中的“报告系统错误” WinCC 接口和 64 位操作系统 WinCCViewer RT 中的动态图形 运行系统专业版：在未连接到组态 PC 的情况下加载项目 系统诊断中与 S7-1200 的连接 禁用自动检查软件更新 在线增量加载功能的限制 PDF 格式报表中的画面对象 Windows 10 更新后运行系统中的项目 日志存储空间要求
Runtime Professional 的操作注意事项

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

操作系统中的用户授权

  1. 必须将所有用户都添加到“SIMATIC HMI”用户组。这也适用于要远程打开 WinCC 项目的用户。

  2. 项目存储文件夹必须有 NTFS 授权，“SIMATIC HMI”有完全访问权限并且“SIMATIC HMI Viewer”有读取权限。所有从属对象都必须继承该授权。

锁定快捷键

如果要在 Windows 系统中锁定快捷键，则必须在操作系统的管理工具中更改组策略。

有关此内容的详细说明，请参见以下 SIMATIC 在线客户支持网站中的 FAQ 条目 ID“44027453”：

Internet：WinCC FAQ 44027453

取消停靠的工具栏

如果对 Windows 任务栏使用设置“始终在前端”，则可在运行系统中将取消停靠的工具栏隐藏于 Windows 任务栏之后。要再次显示工具栏，请按以下步骤操作：

  1. 在任务栏的快捷菜单中选择“属性”(Properties) 命令。

  2. 禁用“将任务栏保持在其它窗口的前端”(Keep taskbar on top of other windows)。

服务器与客户机之间的连接故障

如果服务器与客户机之间的连接有故障，检查 PG/PC 接口的设置。TCP/IP(Auto) 不应用于“所用接口参数分配”(Interface Parameter Assignment Used)。而应使用固定 IP 地址。

服务器与客户机之间的连接故障

如果计算机用作装有工程组态系统的服务器且客户机无法连接到服务器，则应检查服务器上设置的发布。

  1. 退出服务器上的运行系统。

  2. 在服务器桌面上的网络环境快捷菜单中，选择“查找计算机...”(Find computer...) 命令。

  3. 输入要查找的计算机的服务器名称。

  4. 打开找到的计算机以查看共享目录。

  5. 删除所有以“WinCC_Project_HMI”开头的发布。有关此内容的详细信息，请参见操作系统文档。

这一故障是由“另存为...”(Save as...) 命令以及启动新项目的运行系统共同作用的结果。可使用“另存为...”(Save as...) 命令复制项目副本以进行备份。但应继续使用原始项目。

启动 WinCC Runtime Professional

如果在一台计算机上运行工程系统和运行系统，则只应通过 TIA Portal 启动或结束在工程系统中打开的项目的运行系统或仿真。不应使用其它选项，例如任务栏信息区域中的符号。

在客户端上组态自动启动时，会要求您为每个已注册的服务器项目输入登录名和密码。要为每个服务器分配登陆名，必须通过“应用”(Apply) 按钮确认相应项目路径的输入。也意味着，必须为冗余或替代项目输入两次登录名和密码。

设置 SQL 服务器的服务

为了保证在用于 WinCC 和 WinCC Runtime 时 SQL 服务器的各项功能均可正常工作，您需要检查 SQL 服务器的设置。

  1. 在“开始”(Start) 菜单中，单击“Programme > Microsoft SQL Server 2014 > Configuration Tools > SQL Server 2014 Configuration Manager”。

  2. 在项目树中单击“SQL Server Services”。

  3. 检查服务“SQL Server (WinCC)”、“SQL Server (WINCCPLUSMIG)”和“SQL Server Browser”。
    必须为“Start Mode”输入“Automatic”。
    必须为“SQL Server (WinCC)”的“LocalSystem”输入“Log On As”。
    必须为“LOCALSERVICE”输入“SQL Server Browser”。
    必要时可更改设置。

  4. 在项目树中单击“SQL Server Network Configuration”。

  5. 单击“Protocols for WinCC”。

  6. 检查“TCP/IP”协议。必须在“Status”中输入“Enabled”。必要时更改设置。

WinCC Runtime Professional 中的“报告系统错误”

在 WinCC Runtime Professional 中，“报告系统错误”功能只能用于 S7-300 或 S7-400。在报警视图中，对于每个诊断类型，任何时候只能显示一个报警。将不会显示同一诊断类型的其它错误的报警。

WinCC 接口和 64 位操作系统

WinCC Runtime Professional 的开放式接口原生不支持 64 位系统。受此影响的主要有 Runtime API、VBS 和 WinCC OleDB 供应程序。为了将 WinCC 接口与 64 位操作系统结合使用，请注意以下事项：
- 不可以直接通过双击来启动 VB 脚本。必须在“syswow64\wscript.exe”下明确使用 32 位版本。
- 使用 WinCC API 的 .NET 应用程序必须明确编译为 32 位应用程序，不要使用“AnyCPU”，而是“x86”。
- 不要将 C++ 应用程序编译为 64 位应用程序。

WinCCViewer RT 中的动态图形

如果使用图形集中的动态图形，例如与脚本建立关联，则这些图形不会在 WinCCViewer RT 中更新。

在“运行系统设置 > 图形设置”(Runtime Settings > Graphic Settings) 下，选择“用户自定义”(User-defined) 选项。

运行系统专业版：在未连接到组态 PC 的情况下加载项目

在操作员站上加载项目之前，请备份“用户管理”(User administration) 和“配方数据”(Recipe data) 等数据。

  1. 默认情况下将覆盖用户管理数据。

    因此，可使用系统函数“ExportUserManagement”在项目中组态两个按钮，用于导出和导入用户管理数据。只有在 Runtime 中对用户视图进行更改时才需要导出该数据。

  2. 在“加载预览”(Load preview) 对话框中，指定加载项目时是否覆盖配方数据。

    在配方视图中，可使用操作员控件“导出日志”(Export log) 和“导入日志”(Import log) 保存配方数据。

注意，Runtime 中使用的是最近导入或加载的数据。

系统诊断中与 S7-1200 的连接

使用系统诊断时，只有 WinCC Runtime Professional HMI 系统可与 S7-1200（最高版本为 V3）相连。

禁用自动检查软件更新

如果 PC 上同时安装了工程系统和运行系统，操作员可以获得软件更新通知。为使工程系统在多站系统中稳定运行，所有 PC 上都必须安装同一软件版本。

可以禁用自动检查软件更新，从而提高性能。

要禁用自动检查软件更新，请转至“设置 > 常规 > 软件更新”(Settings > General > Software updates) 并清除“每日检查更新”(Check daily for updates) 复选框。

在线增量加载功能的限制

更换设计时，项目的在线增量加载功能将丢失。此时，TIA Portal 将不会输出任何错误消息。

PDF 格式报表中的画面对象

在运行系统中生成的 PDF 文件格式报告中的画面对象质量取决于所用 PDF 打印机驱动程序。

Windows 10 更新后运行系统中的项目

已在搭载 WinCC Professional V15 和 WinCC Professional RT V15 的两台 PC 上安装 Windows 10 版本 1709。已在运行系统 PC 上将 Windows 10 更新到版本 1803。在 Windows 10 更新之后，可能再也无法在运行系统中手动打开从工程系统 PC 上加载的项目。

解决方法：将 WinCC SQL 实例的服务启动类型手动设置为“自动（延迟启动）”(Automatic (Delayed Start)) 并重启系统。

日志存储空间要求

要计算所有分段及个别分段的报警存储空间要求，需要每秒接收的平均报警数量信息。最大存储空间要求应考虑大约 4000 字节大小的报警所需的空间。适用于以下规则：
存储空间要求 = 报警数/s * 4000 字节 * 60 s/min * 60 min/h * 24 h/天 * 31 天/月 * y 个月。

以每秒一个报警为例：

  • 2 个月中所有分段的最大大小约为 20 GB

  • 对于每个分段，每天大约为 330 MB

要计算所有分段及个别分段的数据日志存储空间要求，需要每秒记录的值个数以及过程值的平均长度相关信息。适用于以下规则：
存储空间要求 = 日志值个数/s * 字节数 * 60 s/min * 60 min/h * 24 h/天 * 31 天/月 * y 个月

以每秒 750 个日志值为例：

  • 对于 16 字节的过程值，所需的存储空间大约为 60 GB

  • 对于 6 字节的过程值，所需的存储空间大约为 22 GB


HMI 设备

HMI 设备

该章节包括以下主题的信息:
  • 有关 HMI 设备的说明


有关 HMI 设备的说明

内容 不受支持的 HMI 设备（TIA Portal V15 及以上版本） 不受支持的 HMI 设备（TIA Portal V15.1 及以上版本） 不受支持的 HMI 设备（TIA Portal V16 及以上版本） 多键操作 HMI 设备具有较大的通信负载 使用以太网接口的 TS 适配器 使用真实的 PLC 连接进行仿真 精简面板的仿真 第二代基本面板 使用 Windows CE 5.0 或以上版本操作系统的 HMI 设备 在精简系列面板的控制面板中进行连接切换 打印报警（移动面板） 在 KTP 400 PN、KTP 700 PN 和 KTP 900 PN 上使用 DHCP 移动面板 Sm@rtServer 与移动面板 第二代基本面板的仿真 安装字体 DH485 连接中断 VB“CDate”函数（精智面板） 删除浏览器缓存（面板）
PI Mobile
有关 HMI 设备的说明

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

不受支持的 HMI 设备（TIA Portal V15 及以上版本）

TIA Portal V15 及以上版本不再支持版本为 11.x 的 HMI 设备。

TIA Portal V15 及以上版本不再支持以下 HMI 设备：

  • WinAC MP 177、WinAC MP 277、WinAC MP 377

  • 面板：70 系列、170 系列和 270 系列 OP 和 TP

  • 多功能面板：170 系列、270 系列和 370 系列多功能面板

要在 TIA Portal V15 中使用其他设备，例如已经在版本 11.x 中组态的精简、紧凑或移动面板，请更改相关设备的设备版本。

安装目录中的存储结构也不再包含 11.0 的数据。相比以前的版本，有助于减少 TIA Portal 安装包的大小。

不受支持的 HMI 设备（TIA Portal V15.1 及以上版本）

在 TIA Portal V15.1 及以上版本中，不再支持以下 HMI 设备：

  • WinCC Runtime Advanced V11

不受支持的 HMI 设备（TIA Portal V16 及以上版本）

在 TIA Portal V15.1 及以上版本中，不再支持以下 HMI 设备：

  • 设备版本为 12.x 的移动面板

  • 设备版本为 12.x 的精智面板

  • 设备版本为 13.x 的 KP1500 Comfort

  • 设备版本为 13.x 的 TP1500 Comfort

  • 设备版本为 13.x 的 TP1900 Comfort

  • 设备版本为 13.x 的 TP2200 Comfort

多键操作

多键操作可能会触发意外的动作：

  • 使用按键设备时，同时按下的功能键不得超过两个。

  • 使用触摸屏设备、标准 PC 或平板 PC 时，一次只能按下一个功能键。

HMI 设备具有较大的通信负载

如果给面板分配了许多到 PLC 或其它 HMI 设备的连接，则应启用 S7 诊断。否则，面板将有过载的风险。

使用以太网接口的 TS 适配器

如果 HMI 设备通过以太网和 TS 适配器进行连接，则不能将其重置为出厂设备。

使用真实的 PLC 连接进行仿真

仿真使用的访问点与工程组态系统的设置无关，只能在控制面板中使用“设置 PG/PC 接口”(Setting PG/PC Interface) 工具进行更改。如果一启动仿真 PLC 连接就终止并显示报警消息 140001，则应该通过“设置 PG/PC 接口”(Setting PG/PC Interface) 检查仿真使用的访问点。

  1. 在 Windows“控制面板”(Control Panel) 中双击“设置 PC/PG 接口”(Setting PG/PC Interface)。将打开一个对话框。

  2. 在“应用程序的访问点”区域选择"S7ONLINE"作为 HMI 的标准访问点。

  3. 在“已使用的接口参数分配”区域选择该接口。

  4. 单击“确定”(OK) 退出“设置 PG/PC 接口”(Set PG/PC Interface) 对话框。

精简面板的仿真

在报警文本中使用输出字段来输出外部变量。输出字段的内容在仿真期间始终显示为“0”。

第二代基本面板

第二代精简面板支持 Sm@rtServer 选项。

如果未使用 USB 集线器，请选择 USB 端口 USB_X60.1 作为存储路径。

使用 Windows CE 5.0 或以上版本操作系统的 HMI 设备

由于客户端-服务器通信安全设置已经改变，HMI 设备（客户端）和 PC（服务器）之间的时间差不得超过 1 天。例如，如果将 HMI 设备中的配方数据备份到网络驱动器上，应确保 PC（服务器）和 HMI 设备（客户端）上设置的时间正确。

在精简系列面板的控制面板中进行连接切换

如果使用“覆盖受保护的连接信息”功能，则存在以下限制：

在精简系列面板的控制面板中，不能将无任何防护等级的 PLC 的连接切换为“全面保护”等级的 PLC。

打印报警（移动面板）

如果选择内部存储器/闪存作为“存储位置”，不能以 PDF 或 HTML 格式打印报警。要以 PDF 或 HTML 格式打印报警，选择 SD 存储卡或 U 盘作为存储位置。

在 KTP 400 PN、KTP 700 PN 和 KTP 900 PN 上使用 DHCP

对于 KTP 400 PN、KTP 700 PN 和 KTP 900 PN 设备，建议您不要使用 DHCP。

在个别情况下，设备可能无法再启动。如果出现此类情况，请拔掉网线并重启设备。成功启动后，会分配固定 IP 地址。

移动面板

可通过 TIA Portal V16 组态设备版本为 V15 的第二代移动面板。但编译的项目无法下载到这些设备中。

若要在 TIA Portal V16 中使用第二代移动面板，必须将设备版本升级至 V15.1 及以上版本。

Sm@rtServer 与移动面板

只有在面板中禁用 Sm@rtServer，才能保证通过 PROFIsafe 进行的操作是安全的。

如果没有安全功能，建议您不要在设备上使用 Sm@rtServer。

第二代基本面板的仿真

仿真第二代基本面板时，应启用图形卡的 3D 硬件加速。

安装字体

如果在装有 ProSave 的面板上安装了新字体，则需要重新启动面板。运行系统启动过程的持续时间取决于字体的数量和大小。

DH485 连接中断

如果通过精智面板将以太网电缆连接到 HMI 面板的“PN_X1”连接器，则可能中断 DH485 连接。

Comfort Redesign/PRO 面板的解决方案：在 HMI 面板上运行 DH485 项目时，请使用连接器“PN_X3（千兆位）”进行以太网通信。

VB“CDate”函数（精智面板）

只能在以下 HMI 设备上使用带有静态参数的 VB“CDate”函数：

  • TP1200 Comfort Pro

  • TP1500 Comfort Pro / V2

  • TP1900 Comfort Pro / V2

  • TP2200 Comfort Pro / V2

删除浏览器缓存（面板）

若发现在 HTML 浏览器中加载网页速度过慢，这可能是由浏览器缓存引起的。在运行系统中执行以下 VBS 函数即可删除浏览器缓存。也可以在任务调度程序中将 VBS 函数组态为定期任务。

将以下程序代码复制到剪贴板。

Sub T7_DeleteBrowserCache()

' delete Browsercache filled temporary objects

Dim fso, nFileIndex,sFileName, nFileAttr, folder

On Error Resume Next

' Variable to show script is active

SmartTags("DeleteBrowserCacheActive") = True

folder = "\flash\simatic\Browsercache\data7\"

' Windows CE

Set fso = CreateObject("FileCtl.FileSystem")

' Get first item that matches path

sFileName = fso.Dir(folder & "*.*")

nFileIndex = 0

'Get the rest of matches

Do While sFileName <> ""

nFileAttr = fso.GetAttr(folder & sFileName)

If (nFileAttr And 16) <> 0 Then

fso.Kill("\flash\simatic\Browsercache\data7\"&sFileName&"\*.*")

If Err.Number <>0 Then

Err.Clear

End If

End If

nFileIndex = nFileIndex + 1

sFileName = fso.Dir

Loop

Set fso = Nothing

SmartTags("DeleteBrowserCacheActive") = False

End Sub


插件

插件

该章节包括以下主题的信息:
  • Sm@rtServer
  • 审计
  • DataMonitor
  • WebNavigator
  • WebUX
  • 冗余
  • SIMATIC 信息服务器


Sm@rtServer

内容 在 Windows 10 中打开 SmartClient *.sac 文件
Sm@rtServer

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

在 Windows 10 中打开 SmartClient *.sac 文件

使用可执行文件 SmartClient.exe 以 *.sac 格式保存当前 SmartServer 连接的数据。要在 Windows 10 中自动打开以这种方式生成的文件，必须通过 SmartClient.exe 中的选择按钮和对话框手动打开一次带 SmartClient.exe 的 *.sac 文件。


审计

内容 WinCC Audit Viewer 7.2 更新
审计

内容

在线帮助中未包含的信息和产品特征的重要信息。

WinCC Audit Viewer 7.2 更新

WinCC Audit Viewer 7.2 提供了手动安装的更新，可以选择安装。

可以通过运行产品 DVD 支持目录中的“AuditViewer_V72_00_Upd1.exe”文件来安装 WinCC Audit Viewer 7.2 更新。


DataMonitor

内容 卸载 WinCC Runtime 装有 Windows 7 的 PC 上的 Excel-Workbook 通道诊断视图 Web 部件的时区
DataMonitor

内容

在线帮助中不再包含的信息和产品功能的重要信息。

卸载 WinCC Runtime

如果还要在卸载 WinCC Runtime Professional 之后使用 DataMonitor，则必须如下所述执行安装修复：

  1. 打开“控制面板”(Control Panel)。

  2. 双击“添加/删除程序”(Add/Remove Programs)。

  3. 在已安装程序列表中选择“SIMATIC WinCC/DataMonitor 客户端”(SIMATIC WinCC/DataMonitor client)

  4. 单击“更改/删除”(Change/Remove) 按钮。

  5. 在 WinCC/DataMonitor 安装程序中选择“修复”(Repair) 设置。

装有 Windows 7 的 PC 上的 Excel-Workbook

如果在装有 Windows 7 的 PC 上操作 Excel-Workbook ，则需要禁用“Aero Glass”显示模式。

通道诊断视图

WinCC DataMonitor 选件不支持“通道诊断视图”对象：

Web 部件的时区

在 Web 中心内的特定时区中创建并组态 Web 部件时，时区会存储在 Web 中心内。

如果操作系统中的时区发生了改变，就可能会导致 Web 部件中的时间显示错误。


WebNavigator

内容 卸载 WinCC Runtime 病毒扫描程序 Trend Micro OfficeScan ProDiag 概览，GRAPH 概览和 PLC 代码视图 WinCC WebNavigator 中不允许的字符 通道诊断 输出 WebNavigator 画面时的延迟
WebNavigator

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

卸载 WinCC Runtime

如果还要在卸载 WinCC Runtime Professional 之后使用 WebNavigator，则必须如下所述执行安装修复：

  1. 打开“控制面板”(Control Panel)。

  2. 双击“添加/删除程序”(Add/Remove Programs)。

  3. 在已安装程序列表中选择“SIMATIC WinCC/WebNavigator 客户端”(SIMATIC WinCC/WebNavigator client)

  4. 单击“更改/删除”(Change/Remove) 按钮。

  5. 在 WinCC/WebNavigator 安装程序中选择“修复”(Repair) 设置。

病毒扫描程序 Trend Micro OfficeScan

建议不要将病毒扫描程序 Trend Micro OfficeScan 与 WebNavigator 结合使用，因为此病毒扫描程序可能对画面加载时间产生不良影响。

ProDiag 概览，GRAPH 概览和 PLC 代码视图

WinCC 选件 Web Navigator 不支持 WinCC 对象“GRAPH 概览”、“ProDiag 概览”和“PLC 代码视图”。

WinCC WebNavigator 中不允许的字符

请在画面名称和项目名称中使用 ASCII 字符集中的字符。请勿使用任何特殊字符或国家/地区专用字符。

通道诊断

WinCC WebNavigator 选件不支持“通道诊断”对象。

输出 WebNavigator 画面时的延迟

由于 Web 服务器技术的原因，可能会延迟在运行系统中输出更新后的 WebNavigator 画面。


WebUX

内容 自动登陆
WebUX

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

自动登陆

如果不再需要自动登录，必须删除相应浏览器的浏览记录。


冗余

内容 冗余系统组态中的名称
冗余

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

冗余系统组态中的名称

仅 HMI 设备的计算机名称与冗余系统的组态有关。可以在其操作系统中设置 HMI 设备的计算机名称。项目树中 HMI 设备的名称仅用于标识项目中的 HMI 设备。


SIMATIC 信息服务器

内容 在同一个 PC 上安装 SIMATIC Information Server 和 WinCC Runtime Professional
SIMATIC 信息服务器

内容

在线帮助中未包含的信息和有关产品功能的重要信息。

在同一个 PC 上安装 SIMATIC Information Server 和 WinCC Runtime Professional

要在同一个 PC 上安装 SIMATIC Information Server 和 WinCC Runtime Professional，请按照以下安装顺序进行操作：

  1. 安装 WinCC Runtime Professional。

  2. 安装信息服务器。

如果未按照上述安装顺序进行操作，则可能会出现连接问题。