Installation

Beispiele Siehe auch Verlauf Extras
Installation

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hinweise zur Installation
  • Parallelinstallationen
  • Lizenzierung
  • Systemvoraussetzungen für die Installation
  • Installationsprotokoll
  • Installation starten
  • Installierte Software anzeigen
  • Installierte Produkte modifizieren oder hochrüsten
  • Installierte Produkte reparieren
  • Deinstallation starten
  • Updates und Support Packages installieren
  • Support Packages automatisiert installieren
  • Migrations-Tool installieren und deinstallieren
  • TIA Projekt-Server installieren und deinstallieren


Hinweise zur Installation

Inhalt Installation in einer virtuellen Umgebung (Private Cloud) Automatisierte Installation Verwendung gleicher Versionen der TIA Portal Produkte bei der Installation Zielverzeichnis der Installation Sicherheitseinstellungen bei der Installation von WinCC Verwendung von Virenscannern Kompatibilität mit V12 SP1 und V13 FAQs zum TIA Portal
Hinweise zur Installation

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Installation in einer virtuellen Umgebung (Private Cloud)

Eine Anleitung zur Installation des TIA Portals in einer virtuellen Umgebung (Private Cloud) finden Sie auf dem Installationsdatenträger im Verzeichnis "Documents\Readme\<Sprachverzeichnis>". Öffnen Sie hier das PDF-Dokument "TIAPortalCloudConnectorHowTo<Sprachkennung>.pdf".

Automatisierte Installation

Eine Beschreibung zur automatisierten Installation finden Sie auf der Produkt-DVD im Verzeichnis "Documents\Readme\<Sprachverzeichnis>".

Verwendung gleicher Versionen der TIA Portal Produkte bei der Installation

Achten Sie bei der Installation von verschiedenen TIA Portal Produkten darauf, dass Sie für die Installation die gleichen Stände der Service Packs und Updates verwenden. Wenn Sie also z. B. bei STEP 7 V13 das SP1 installiert haben, dann müssen Sie auch für WinCC V13 das SP1 installieren. Die Installation der Service Packs und Updates muss für alle Produkte zu einem gemeinsamen Zeitpunkt erfolgen. Starten Sie das TIA Portal nicht, bevor Sie nicht alle Produkte hochgerüstet haben.

Die Servicepacks können Sie im Internet unter Siemens Industry Online Support herunterladen.

Zielverzeichnis der Installation

Verwenden Sie keine UNICODE-Zeichen (z. B. chinesische Schriftzeichen) im Installationspfad.

Der Installationspfad kann nach der Installation von einem der TIA Portal-Produkte nicht mehr geändert werden.

Sicherheitseinstellungen bei der Installation von WinCC

Wenn Sie WinCC installieren, werden in Ihrem Betriebssystem Sicherheitseinstellungen verändert. Diese Sicherheitseinstellungen werden während der Installation aufgelistet.

Die Änderungen der Sicherheitseinstellungen müssen Sie bestätigen.

Wenn Sie nach der Installation an Ihrem Betriebssystem Änderungen vornehmen, können dadurch die Änderungen der Sicherheitseinstellungen durch die Installation des TIA Portals verändert werden.

Die Änderungen der Sicherheitseinstellungen durch die Installation des TIA Portals können Sie folgenderweise wiederherstellen:
"Start > Alle Programme > Siemens Automation > Security Controller > Einstellungen wiederherstellen“.

Verwendung von Virenscannern

Während der Installation ist es notwendig, dass auf bereits installierte Dateien lesend und schreibend zugegriffen werden kann. Einige Virenscanner verhindern dies. Konfigurieren Sie Ihren Virenscanner für die Installation des TIA Portals daher so, dass ein Zugriff auf diese Dateien möglich ist.

Kompatibilität mit V12 SP1 und V13

In das Installationsverzeichnis unter ..\<INSTALLDIR>\SampleProjects werden leere Projekte der Vorgängerversionen installiert, damit das aktuelle TIA Portal im Kompatibilitätsmodus geöffnet werden kann. Diese Projekte müssen in ein lokales Verzeichnis mit Vollzugriff kopiert werden, bevor sie verwendet werden können. Weitergehende Informationen finden Sie unter FAQ ID 82169157.

FAQs zum TIA Portal

FAQs zum TIA Portal finden Sie unter FAQs.


Parallelinstallationen

Parallelinstallation von WinCC V16 und anderen SIMATIC HMI Produkten Parallele Nutzung
Parallelinstallationen

Parallelinstallation von WinCC V16 und anderen SIMATIC HMI Produkten

Die parallele Installation von WinCC V16 mit Versionen von WinCC flexible vor WinCC flexible 2008 SP5 ist nicht zulässig.

Die parallele Installation von WinCC V16 Comfort/Advanced mit Versionen von WinCC vor WinCC V7.3 ist nicht zulässig.

Die parallele Installation von WinCC V16 mit WinCC V7.3, WinCC V7.4 oder WinCC V7.5 ist nicht zulässig für:

  • WinCC V16 Professional

  • WinCC V16 Runtime Professional

Parallele Nutzung

Sollte die Software im Namen oder der Licence-Key nach der Installation den Zusatz "Combo" tragen, ist Ihnen gemäß Ziffer 4.3 der Allgemeinen Bedingungen (siehe auch Setup-Text) die Nutzung folgender Produkte/Versionen erlaubt:

  • Mit der Lizenz "STEP 7 Professional Combo": ältere Versionen von STEP 7 (STEP 7 Professional 2006 - STEP 7 Professional V16)

  • Mit der Lizenz "WinCC V16 Comfort Combo": WinCC flexible 2008 Standard

  • Mit der Lizenz "WinCC V16 Advanced Combo": WinCC flexible 2008 Advanced


Lizenzierung

Lizenzierung

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hinweise zu Lizenzen
  • Lizenzierung von STEP 7 und WinCC
  • Umgang mit Lizenzen und License Keys
  • Lizenzierung von Bediengeräten
  • Lizenzierung von WinCC Runtime auf PC-basierten Bediengeräten
  • Lizenzierung WinCC Runtime Professional asiatisch
  • STEP 7 ohne Lizenz für PC-CP


Hinweise zu Lizenzen

Bereitstellung der Lizenzen Bereitstellung des Automation License Managers Arbeiten mit dem Automation License Manager
Hinweise zu den Systemvoraussetzungen Installation starten Installierte Software anzeigen Installierte Produkte modifizieren oder hochrüsten Installierte Produkte reparieren Deinstallation starten Installationsprotokoll
Hinweise zu Lizenzen

Bereitstellung der Lizenzen

Die Lizenzen für die Produkte des TIA Portals werden in der Regel auf einem Installationsdatenträger ausgeliefert und über den Automation License Manager während des Installationsprozesses des TIA Portals automatisch übertragen.

Bevor Sie das TIA Portal deinstallieren, müssen Sie noch benötigte Lizenzen transferieren und sichern. Verwenden Sie dazu den Automation License Manager.

Bereitstellung des Automation License Managers

Der Automation License Manager wird auf dem Installationsdatenträger mitgeliefert und während des Installationsprozesses automatisch übertragen.

Wenn Sie das TIA Portal deinstallieren, bleibt der Automation License Manager weiterhin auf Ihrem System installiert.

Arbeiten mit dem Automation License Manager

Der Automation License Manager ist ein Produkt der Siemens AG und wird zur Handhabung von License Keys (technische Repräsentanten von Lizenzen) eingesetzt.

Software-Produkte, für deren Betrieb License Keys notwendig sind, wie z. B. das TIA Portal, melden den Bedarf an License Keys automatisch beim Automation License Manager an. Wenn der Automation License Manager für diese Software einen gültigen License Key findet, so kann die Software entsprechend der mit diesem License Key verbundenen Lizenz-Nutzungsbedingungen verwendet werden.

Hinweis

Weiterführende Informationen, wie Sie mit dem Automation License Manager Ihre Lizenzen verwalten können, finden Sie in der mit dem Automation License Manager mitgelieferten Dokumentation.


Lizenzierung von STEP 7 und WinCC

Einführung Lizenzen Gültigkeit der License Keys für ältere Versionen von STEP 7 Gültigkeit der License Keys für ältere Versionen von WinCC Gültigkeit der Lizenzen für WinCC Optionen Starten ohne gültigen License Key Lizenzbedarf bei Simulation Lizenzen für den TIA Portal Cloud Connector
Umgang mit Lizenzen und License Keys
Lizenzierung von STEP 7 und WinCC

Einführung

Für die Lizenzierung der folgenden Editionen von STEP 7 benötigen Sie einen License Key:

  • STEP 7 Basic

  • STEP 7 Professional

Sie können den entsprechenden License Key für STEP 7 nach der Installation mit dem Automation License Manager übertragen.

In WinCC benötigen Sie für Folgendes einen License Key:

  • WinCC Engineering System

  • WinCC Runtime

  • Optionen für WinCC Engineering System

  • Optionen für WinCC Runtime System

Lizenzen für WinCC und die WinCC Optionen übertragen Sie nach der Installation mit dem Automation License Manager.

Hinweis

Der Lizenznehmer bestätigt weiterhin, dass die Software (SW) von der Microsoft Corporation oder Tochtergesellschaften lizenzierte Software beinhaltet. Hiermit stimmt der Lizenznehmer zu, an die Geschäftsbedingungen des beigefügten Lizenzvertrags zwischen Microsoft SQL Server und Endabnehmer gebunden zu sein und diese zu erfüllen.

Lizenzen

Folgende Lizenzen mit den entsprechenden License Keys stehen Ihnen zur Verfügung:

  • STEP 7 Basic

  • STEP 7 Professional

  • STEP 7 Professional Combo

  • WinCC Basic

  • WinCC Comfort

  • WinCC Comfort Combo

  • WinCC Advanced

  • WinCC Advanced Combo

  • WinCC Professional

  • WinCC Professional Combo

  • WinCC Unified Comfort Engineering

  • WinCC Unified PC Engineering

  • WinCC RT Advanced

  • WinCC RT Professional

  • WinCC Unified PC

Gültigkeit der License Keys für ältere Versionen von STEP 7

Mit einem gültigen License Key für die V15.x von STEP 7 Professional und STEP 7 Professional Combo können auch ältere Versionen von STEP 7 ohne Einschränkungen betrieben werden. Genauere Informationen dazu entnehmen Sie der nachfolgenden Tabelle:

Edition

Lizenz

Gültig für

STEP 7 Basic V16.x

STEP 7 Basic

  • STEP 7 Basic V16.x

  • STEP 7 Basic V15.x

  • STEP 7 Basic V14.x

  • STEP 7 Basic V13.x

  • STEP 7 Basic V12.x

  • STEP 7 Basic V11.x

  • STEP 7 Basic V10.5

STEP 7 Professional V16.x

STEP 7 Professional

  • STEP 7 Professional V16.x

  • STEP 7 Professional V15.x

  • STEP 7 Professional V14.x

  • STEP 7 Professional V13.x

  • STEP 7 Professional V12.x

  • STEP 7 Professional V11.x

  • STEP 7 Basic V14.x

  • STEP 7 Basic V13.x

  • STEP 7 Basic V12.x

  • STEP 7 Basic V11.x

  • STEP 7 Basic V10.5

STEP 7 Professional V16.x

STEP 7 Professional Combo

  • STEP 7 Professional V16.x

  • STEP 7 Professional V15.x

  • STEP 7 Professional V14.x

  • STEP 7 Professional V13.x

  • STEP 7 Professional V12.x

  • STEP 7 Professional V11.x

  • STEP 7 Basic V14.x

  • STEP 7 Basic V13.x

  • STEP 7 Basic V12.x

  • STEP 7 Basic V11.x

  • STEP 7 Basic V10.5

  • STEP 7 V5.6

  • STEP 7 V5.5

  • STEP 7 V5.4

  • STEP 7 Professional 2017

  • STEP 7 Professional 2010

  • STEP 7 Professional 2006

Gültigkeit der License Keys für ältere Versionen von WinCC

Mit einem gültigen License Key für WinCC V16.x können auch ältere Versionen von WinCC ohne Einschränkungen betrieben werden.

Genauere Informationen entnehmen Sie der nachfolgender Tabelle:

WinCC Engineering System

Edition

Lizenz

Gültig für

WinCC Basic V16.x

WinCC Basic

  • WinCC Basic V11.x

  • WinCC Basic V12.x

  • WinCC Basic V13.x

  • WinCC Basic V14.x

  • WinCC Basic V15.x

  • WinCC Basic V16.x

WinCC Comfort/Advanced V16.x

WinCC Comfort

  • WInCC Basic V11.x

  • WinCC Comfort V10.x

  • WinCC Comfort V11.x

  • WinCC Basic, Comfort V12.x

  • WinCC Basic, Comfort V13.x

  • WinCC Basic, Comfort V14.x

  • WinCC Basic, Comfort V15.x

  • WinCC Basic, Comfort V16.x

WinCC Comfort Combo

  • WinCC flexible Compact, Standard >= 2005

  • WInCC Basic V11.x

  • WinCC Comfort V10.x

  • WinCC Comfort V11.x

  • WinCC Basic, Comfort V12.x

  • WinCC Basic, Comfort V13.x

  • WinCC Basic, Comfort V14.x

  • WinCC Basic, Comfort V15.x

  • WinCC Basic, Comfort V16.x

WinCC Advanced

  • WInCC Basic V11.x

  • WinCC Comfort, Advanced V10.x

  • WinCC Comfort, Advanced V11.x

  • WinCC Basic, Comfort, Advanced V12.x

  • WinCC Basic, Comfort, Advanced V13.x

  • WinCC Basic, Comfort, Advanced V14.x

  • WinCC Basic, Comfort, Advanced V15.x

  • WinCC Basic, Comfort, Advanced V16.x

  • WinCC Unified Comfort V16.x

  • WinCC Unified PC V16.x

WinCC Advanced Combo

  • WinCC flexible Compact, Standard, Advanced >= 2005

  • WInCC Basic V11.x

  • WinCC Comfort, Advanced V10.x

  • WinCC Comfort, Advanced V11.x

  • WinCC Basic, Comfort, Advanced V12.x

  • WinCC Basic, Comfort, Advanced V13.x

  • WinCC Basic, Comfort, Advanced V14.x

  • WinCC Basic, Comfort, Advanced V15.x

  • WinCC Basic, Comfort, Advanced V16.x

  • WinCC Unified Comfort V16.x

  • WinCC Unified PC V16.x

WinCC Professional V16.x

WinCC Professional (512)

WinCC Professional (4096)

WinCC Professional (max.)

  • WinCC Comfort, Advanced, Professional V10.x

  • WinCC Comfort, Advanced, Professional V11.x

  • WinCC Basic, Comfort, Advanced, Professional V12.x

  • WinCC Basic, Comfort, Advanced, Professional V13.x

  • WinCC Basic, Comfort, Advanced, Professional V14.x

  • WinCC Basic, Comfort, Advanced, Professional V15.x

  • WinCC Basic, Comfort, Advanced, Professional V16.x

  • WinCC Unified Comfort V16.x

  • WinCC Unified PC V16.x

WinCC Professional (512) Combo

WinCC Professional (4096) Combo

WinCC Professional (max.) Combo

  • WinCC flexible Compact, Standard, Advanced >= 2008 SP3

  • WinCC SCADA V7.0 SP3 ES

  • WinCC Comfort, Advanced, Professional V10.x

  • WinCC Comfort, Advanced, Professional V11.x

  • WinCC Basic, Comfort, Advanced, Professional V12.x

  • WinCC Basic, Comfort, Advanced, Professional V13.x

  • WinCC Basic, Comfort, Advanced, Professional V14.x

  • WinCC Basic, Comfort, Advanced, Professional V15.x

  • WinCC Basic, Comfort, Advanced, Professional V16.x

  • WinCC Unified Comfort V16.x

  • WinCC Unified PC V16.x

WinCC Unified Comfort V16.x

WinCC Unified Comfort ES

  • WInCC Basic V11.x

  • WinCC Comfort V10.x

  • WinCC Comfort V11.x

  • WinCC Basic, Comfort V12.x

  • WinCC Basic, Comfort V13.x

  • WinCC Basic, Comfort V14.x

  • WinCC Basic, Comfort V15.x

  • WinCC Basic, Comfort V16.x

  • WinCC Unified Comfort V16.x

WinCC Unified PC V16.x

WinCC Unified PC (10k) ES

  • WinCC Basic V11.x

  • WinCC Comfort, Advanced V10.x

  • WinCC Comfort, Advanced V11.x

  • WinCC Basic, Comfort, Advanced V12.x

  • WinCC Basic, Comfort, Advanced V13.x

  • WinCC Basic, Comfort, Advanced V14.x

  • WinCC Basic, Comfort, Advanced V15.x

  • WinCC Basic, Comfort, Advanced V16.x

  • WinCC Unified PC V16.x

WinCC Unified PC (100k) ES

WinCC Unified PC (max.) ES

  • WinCC Comfort, Advanced, Professional V10.x

  • WinCC Comfort, Advanced, Professional V11.x

  • WinCC Basic, Comfort, Advanced, Professional V12.x

  • WinCC Basic, Comfort, Advanced, Professional V13.x

  • WinCC Basic, Comfort, Advanced, Professional V14.x

  • WinCC Basic, Comfort, Advanced, Professional V15.x

  • WinCC Basic, Comfort, Advanced, Professional V16.x

  • WinCC Unified PC V16.x

WinCC Runtime

Edition

Lizenz

Gültig für

WinCC RT Advanced V16.x

WinCC RT Advanced (128)

WinCC RT Advanced (512)

WinCC RT Advanced (2048)

WinCC RT Advanced (4096)

WinCC RT Advanced (8192)

WinCC RT Advanced (16384)

  • WinCC RT Advanced V11.x

  • WinCC RT Advanced V12.x

  • WinCC RT Advanced V13.x

  • WinCC RT Advanced V14.x

  • WinCC RT Advanced V15.x

  • WinCC RT Advanced V16.x

WinCC RT Professional V16.x

WinCC RT Professional (128)

WinCC RT Professional (512)

WinCC RT Professional (2048)

WinCC RT Professional (4096)

WinCC RT Professional (8192)

WinCC RT Professional (65536)

WinCC RT Professional (102400)

WinCC RT Professional (153600)

WinCC RT Professional (262144)

  • WinCC RT Professional V11.x

  • WinCC RT Professional V12.x

  • WinCC RT Professional V13.x

  • WinCC RT Professional V14.x

  • WinCC RT Professional V15.x

  • WinCC RT Professional V16.x

WinCC Unified PC V16.x

WinCC Unified PC (150) RT

WinCC Unified PC (500) RT

WinCC Unified PC (1k) RT

WinCC Unified PC (2,5k) RT

WinCC Unified PC (5k) RT

WinCC Unified PC (10k) RT

WinCC Unified PC (50k) RT

WinCC Unified PC (100k) RT

WinCC Unified PC (max.) RT

  • WinCC Unified PC V16.x

Gültigkeit der Lizenzen für WinCC Optionen

WinCC Optionen besitzen in der Regel versionsunabhängige License Keys. Sie können WinCC Optionen V16.x mit V11, V12, V13, V14 und V15 License Keys verwenden und umgekehrt.

Starten ohne gültigen License Key

Wenn Sie das TIA Portal ohne gültigen License Key starten, weist Sie das System mit einer Meldung auf den nicht lizenzierten Modus hin. Sie haben die Möglichkeit, einmalig eine Trial License zu aktivieren. Diese hat jedoch nur eine begrenzte Gültigkeit und läuft nach 21 Tagen ab.

Wenn die Trial License abgelaufen ist, können folgende Fälle auftreten:

  • Auf dem betreffenden PC war das TIA Portal noch nie lizenziert:

    • Im TIA Portal lassen sich keine lizenzpflichtigen Aktionen mehr durchführen.

  • Auf dem betreffenden PC war das TIA Portal bereits lizenziert:

    • Der nicht lizenzierte Modus wird alle 10 Minuten und bei jeder lizenzpflichtigen Aktion durch ein quittierpflichtiges Fenster angezeigt.

Lizenzbedarf bei Simulation

Wenn Sie in STEP 7 die Simulation über den Menübefehl "Online > Simulation" starten, benötigen Sie keine weiteren Lizenzen.

Wenn folgende Bedingungen erfüllt sind, benötigen Sie auch bei der Simulation die entsprechenden Lizenzen für von Ihnen installierte Edition von STEP 7:

  • Die Engineering Station ist mit einer PLC verbunden.

  • Die Verbindung zur PLC ist projektiert und aktiv.

Wenn Sie in WinCC die Simulation über den Menübefehl "Online > Simulation > Mit Variablen-Simulator" starten, benötigen Sie keine Lizenzen für WinCC Runtime oder für lizenzpflichtige Optionen.

Wenn folgende Bedingungen erfüllt sind, benötigen Sie auch bei der Simulation die entsprechenden Lizenzen für WinCC Runtime und für lizenzpflichtige Optionen:

  • Die Engineering Station ist mit einer PLC verbunden.

  • Die Verbindung zur PLC ist projektiert und aktiv.

  • Sie starten den Simulator über den Menübefehl "Online > Simulation > starten".

Lizenzen für den TIA Portal Cloud Connector

Für das Arbeiten mit dem TIA Portal Cloud Connector benötigen Sie auf jedem Gerät, das Sie im TIA Portal Cloud Connector als "Benutzergerät" festlegen, einen gültigen License Key. Der License Key ist auch dann erforderlich, falls auf diesem Gerät das TIA Portal installiert ist. Für Geräte, die Sie als "Remotegerät" verwenden, ist kein License Key erforderlich.


Umgang mit Lizenzen und License Keys

Einleitung Trial-Lizenz Installation von License Keys für STEP 7 Installation von License Keys für WinCC Übertragen von License Keys auf Bediengeräte Deinstallation von License Keys Modifikation an den Datenträgern des Engineering Systems Datensicherung von Bediengeräten (Backup/Restore) Ungültige Lizenz nach Zeitzonenwechsel Defekte Lizenz Microsoft SQL Server
Lizenzierung von STEP 7 und WinCC
Umgang mit Lizenzen und License Keys

Einleitung

Zur Nutzung von STEP 7 Basic, STEP 7 Professional sowie WinCC Engineering System, Optionen für WinCC Engineering System und WinCC Runtime benötigen Sie jeweils einen gültigen License Key.

Achtung

Zerstörung von License Keys durch Kopieren

Ein License Key ist nicht kopierbar. Das verwendete Kopierschutzverfahren verhindert das Kopieren der License Keys. Beim Versuch, einen License Key zu kopieren, wird dieser zerstört!

Trial-Lizenz

Wenn Sie das TIA Portal ohne gültigen License Key starten, weist Sie das System mit einer Meldung auf den nicht lizenzierten Modus hin. Sie haben die Möglichkeit, einmalig eine Trial-Lizenz zu aktivieren. Die Trial-Lizenz läuft nach 21 Tagen ab.

Wenn die Trial-Lizenz abgelaufen ist, können folgende Fälle auftreten:

  • Auf dem betreffenden PC war das TIA Portal noch nie lizenziert.

    Das TIA Portal lässt sich nicht mehr starten.

  • Auf dem betreffenden PC war das TIA Portal bereits lizenziert.

    Das TIA Portal lässt sich starten. Der nicht lizenzierte Modus wird alle 10 Minuten durch ein quittierpflichtiges Fenster angezeigt.

Installation von License Keys für STEP 7

Bei der Installation von STEP 7 Basic wird der benötigte License Key vom Setup automatisch mit installiert. Bei der Installation von STEP 7 Professional werden Sie am Ende des Setups aufgefordert, die Lizenz mithilfe des Automation License Manager vom mitgelieferten Datenträger auf Ihren PC zu übertragen.

Falls Sie zusätzliche License Keys installieren möchten, müssen Sie dazu den Automation License Manager nutzen.

Wenn Sie eine Lizenz installieren, wird der zugehörige License Key vom Ablageort der License Keys entfernt.

Hinweis

Behalten Sie nach der Installation auf jeden Fall den Original-Ablageort der License Keys.

Installation von License Keys für WinCC

Bei der Installation von WinCC Basic wird der benötigte License Key vom Setup automatisch mit installiert. Bei der Installation von WinCC Professional werden Sie am Ende des Setups aufgefordert, die Lizenz mithilfe des Automation License Manager vom mitgelieferten Datenträger auf Ihren PC zu übertragen.

Zur Nutzung von WinCC Runtime oder der Simulation auf dem Engineering-PC über den Menübefehl "Online > Simulation > starten" benötigen Sie zusätzliche License Keys. Sie müssen dazu den Automation License Manager nutzen.

Wenn Sie eine Lizenz installieren, wird der zugehörige License Key vom Ablageort der License Keys entfernt.

Hinweis

Behalten Sie nach der Installation auf jeden Fall den Original-Ablageort der License Keys.

Übertragen von License Keys auf Bediengeräte

Für den Betrieb von WinCC müssen Sie die License Keys auf das Bediengerät übertragen.

Sie übertragen einen License Key in folgenden Fällen auf das Bediengerät:

  • Zur Nutzung vom WinCC Runtime

  • Zur Nutzung von Optionen von WinCC Runtime

Wenn Sie eine Lizenz auf ein Bediengerät übertragen, wird der zugehörige License Key vom Ablageort der License Keys entfernt.

Wenn Sie die Lizenz nicht mehr benötigen oder Daten sichern möchten, müssen Sie die License Keys vom Bediengerät übertragen. Sie können diese Lizenz an einem anderen PC oder Bediengerät verwenden.

Deinstallation von License Keys

Die Deinstallation von License Keys erfolgt immer mit dem Automation License Manager. Sie deinstallieren einen License Key in folgenden Fällen:

  • Wenn Sie Daten sichern.

  • Wenn Sie die Lizenz nicht mehr benötigen.

Sie können eine gültige Lizenz auch an einem anderen PC verwenden.

Modifikation an den Datenträgern des Engineering Systems

Durch Modifikationen der Datenträger des Engineering Systems kann der License Key zerstört werden. Rufen Sie vor derartigen Modifikationen den Automation License Manager auf und sichern Sie den zu deinstallierenden License Key auf einen anderen Ablageort.

Achtung

Zerstörung von License Keys auf PCs

Deinstallieren Sie zuerst alle License Keys, wenn einer der folgenden Fälle zutrifft:

  • Formatieren der Festplatte

  • Komprimieren der Festplatte

  • Restaurieren der Festplatte

  • Starten eines Optimierungsprogramms, das feste Blöcke verschiebt

  • Installation eines neuen Betriebssystems

Lesen Sie die Beschreibung zu Automation License Manager ("Start > Siemens Automation > Dokumentation"). Beachten Sie alle Warnhinweise und Hinweise.

Datensicherung von Bediengeräten (Backup/Restore)

Zur Datensicherung am Bediengerät deinstallieren Sie die License Keys am Bediengerät. Rufen Sie dazu den Automation License Manager auf und sichern Sie den zu deinstallierenden License Key auf einen anderen Ablageort.

Achtung

Zerstörung von License Keys auf nicht PC-basierten Bediengeräten

Bei folgenden Bediengeräten werden übertragene License Keys durch Backup-/Restore-Vorgänge zerstört:

  • 270er Reihe

  • 370er Reihe

Bevor Sie mit Wiederherstellen beginnen, führen Sie Folgendes aus:

  • Überprüfen Sie mit dem Automation License Manager und ProSave, ob auf dem Bediengerät License Keys vorhanden sind.

  • Übertragen Sie die vorhandenen License Keys vom Bediengerät

    Nach dem Wiederherstellen übertragen Sie die License Keys wieder auf das Bediengerät.

Ungültige Lizenz nach Zeitzonenwechsel

Die installierten Lizenzen funktionieren nicht mehr, wenn Sie auf einem PC die Zeitzone folgendermaßen umstellen: Von einer auf die volle Stunde bezogenen Zeitzone auf eine Zeitzone, die sich nicht auf eine volle Stunde bezieht.

Um dieses Verhalten zu umgehen, deinstallieren Sie den License Key mit dem Automation License Manager mit einer Zeitzoneneinstellung, die bei der Installation des License Keys eingestellt war.

Beispiel: Sie möchten das Bediengerät aus der Zeitzone "GMT +3:00" in der Zeitzone "GMT +3:30" einsetzen.

  1. Deinstallieren Sie den License Key mit der Zeitzoneneinstellung "GMT +3:00".

  2. Ändern Sie die Zeitzoneneinstellungen entsprechend auf Ihrem PC.

  3. Installieren Sie den License Key.

Das Verhalten betrifft nicht die Trial License.

Defekte Lizenz

Eine Lizenz ist in folgenden Fällen defekt:

  • Wenn der License Key auf dem Ablageort nicht mehr zugänglich ist.

  • Wenn der License Key beim Übertragen auf das Ziellaufwerk verschwindet.

Hinweis

Wenn Sie das Systemdatum auf einen früheren Zeitpunkt zurücksetzen, werden alle Lizenzen defekt.

Sie können die defekte Lizenz mithilfe von Automation License Manager reparieren lassen. Benutzen Sie dazu die Funktion "Wiederherstellen" bzw. den "Wiederherstellen-Assistenten" des Automation License Manager. Für die Wiederherstellung nehmen Sie Kontakt mit dem Customer Support auf. Nähere Hinweise hierzu finden Sie im Internet unter: http://support.automation.siemens.com

Hinweis

Ein störungsfreier Betrieb von Runtime ist auch bei fehlender bzw. defekter Lizenz sichergestellt. In kurzen Zeitabständen weist Sie das System mit einer Meldung auf den nicht lizenzierten Modus hin.

Microsoft SQL Server

Für die Nutzung der Datenbank Microsoft SQL Server ist eine Lizenz erforderlich. Diese Lizenz liegt bei einer Iizenzrechtlich ordnungsgemäßen Installation von WinCC vor.

Der mit der Installation von WinCC lizenzierte SQL Server dart nur in Verbindung mit WinCC eingesetzt werden.

Der Einsatz für andere Zwecke erfordert eine zusätzliche Lizenz. Dazu gehören z. B.:

  • Einsatz für eigene Datenbanken

  • Einsatz für Fremdapplikationen

  • Einsatz von SQL Zugriffsmechanismen, die nicht über WinCC zur Verfügung gestellt werden

Deinstallation

Nach der Deinstallation von WinCC müssen Sie die SQL Server-Instanz "WinCC" deinstallieren. Wählen Sie unter “Systemsteuerung > Software" den Eintrag "Microsott SQL Server 20..” zur Deinstallation.


Lizenzierung von Bediengeräten

License Key Hinweise zum Umgang mit Lizenzen Nicht lizenzierter Modus
Lizenzierung von Bediengeräten

Nicht PC-basierte Bediengeräte werden mit Runtime-Lizenzen ausgestattet. Ein License Key für den Runtimebetrieb ist nicht erforderlich.

Zu einer Option für nicht PC-basierte Bediengeräte kann eine Lizenz erforderlich sein. Der License Key der jeweiligen Lizenz schaltet jeweils eine Option zur Nutzung frei.

License Key

Um nicht PC-basierte Bediengeräte mit License Keys lizenzieren zu können, ist das Add-On "SIMATIC HMI License Manager Panel Plugin" notwendig.

Das WinCC Setup installiert standardmäßig dieses Add-On. Das License Manager Panel Plugin öffnen Sie im Automation License Manager über den Menübefehl "Bearbeiten > Zielsystem verbinden > Bediengerät verbinden".

Wenn WinCC nicht installiert ist, ist eine Installation von ProSave 7.2 oder höher notwendig.

Hinweise zum Umgang mit Lizenzen

  • Weitere Informationen zur Handhabung der Lizenzen finden Sie in der Hilfe des Automation License Manager.

  • Vergewissern Sie sich, bevor Sie mit Lizenzierung beginnen, dass das Bediengerät mindestens mit einem aktuellen Stand des Betriebssystems ausgestattet ist. Gegebenenfalls aktualisieren Sie das Betriebssystem mit ProSave.

  • Der Lizenznehmer bestätigt weiterhin, dass die Software (SW) von der Microsoft Corporation oder Tochtergesellschaften lizenzierte Software beinhaltet. Hiermit stimmt der Lizenznehmer zu, an die Geschäftsbedingungen des beigefügten Lizenzvertrags zwischen Microsoft SQL Server und Endabnehmer gebunden zu sein und diese zu erfüllen.

Nicht lizenzierter Modus

Die Runtime-Optionen sind ohne gültige Lizenz vorübergehend ohne Einschränkung der Funktionalität nutzbar. Der nicht lizenzierte Modus wird alle 10 Minuten durch ein quittierpflichtiges Fenster angezeigt.


Lizenzierung von WinCC Runtime auf PC-basierten Bediengeräten

License Key Hinweise zum Umgang mit Lizenzen Nicht lizenzierter Modus
Lizenzierung von WinCC Runtime auf PC-basierten Bediengeräten

License Key

Bei PC-basierten Bediengeräten benötigen Sie für Folgendes einen License Key:

  • WinCC Runtime, z. B. mit 128 Variablen

  • WinCC Optionen

Sie können den License Key für WinCC Runtime gleich bei der Installation von WinCC mitübertragen. Lizenzen für die WinCC Optionen übertragen Sie nach der Installation mit dem Automation Licence Manager.

Hinweis

Nur das Certificate of License für WinCC Runtime V15.1 berechtigt zum Betrieb von WinCC Runtime V15.1.

Um WinCC Runtime zu lizenzieren, benötigen Sie die entsprechende, neue Lizenz.

Die Runtime-Lizenzen von WinCC flexible 2008 und von WinCC V7 können Sie mit einem Upgrade auf WinCC Runtime V15.1 hochrüsten.

Nur mit einem gültigen Certificate of License, entsprechend der darin genannten Version, ist der produktive Betrieb der Software zulässig.

Hinweise zum Umgang mit Lizenzen

  • Wenn Sie von einer älteren Version auf die Version V15 hochrüsten, benötigen Sie neue Lizenzen für WinCC Runtime Professional.

  • Der Lizenznehmer bestätigt weiterhin, dass die Software (SW) von der Microsoft Corporation oder Tochtergesellschaften lizenzierte Software beinhaltet. Hiermit stimmt der Lizenznehmer zu, an die Geschäftsbedingungen des beigefügten Lizenzvertrages zwischen Microsoft SQL Server und Endabnehmer gebunden zu sein und diese zu erfüllen.

Nicht lizenzierter Modus

WinCC Runtime und die Runtime-Optionen sind ohne gültige Lizenz uneingeschränkt nutzbar. Der nicht lizenzierte Modus wird alle 10 Minuten durch ein quittierpflichtiges Fenster angezeigt.


Lizenzierung WinCC Runtime Professional asiatisch

Einleitung Einsatz des Dongle für eine asiatische Runtime Professional Simulation eines WinCC-Projekts in einer asiatischen Sprache
Lizenzierung WinCC Runtime Professional asiatisch

Einleitung

Wenn Sie WinCC Runtime Professional in einer asiatischen Sprache verwenden, wird für die Gültigkeitsprüfung der erforderlichen Lizenz zusätzlich ein Dongle eingesetzt. Der Dongle wird in Form eines zertifizierten USB-Sticks zusammen mit dem erforderlichen Licence Key für WinCC Runtime Professional asiatisch ausgeliefert. Der License Key ist auf dem zertifizierten USB-Stick gespeichert.

Folgende asiatischen Sprachen sind durch einen Dongle geschützt:

  • Chinesisch vereinfacht

  • Chinesisch traditionell

  • Japanisch

  • Koreanisch

Einsatz des Dongle für eine asiatische Runtime Professional

Um ein WinCC-Projekt in einer asiatischen Sprache erfolgreich zu lizenzieren, übertragen Sie den erforderlichen License Key mithilfe des "Automation License Manager" von dem zertifizierten USB-Stick auf das Bediengerät. Stecken Sie den USB-Stick in den USB-Anschluss des Bediengeräts. Der USB-Stick wirkt während Runtime als Dongle. Der Dongle muss in Runtime immer im USB-Anschluss gesteckt bleiben.

Wenn Sie den Dongle in Runtime entfernen, wechselt WinCC Runtime in den Demo-Modus.

Die für die asiatischen Märkte gelieferten USB-Sticks sind für den Dauereinsatz in Produktionsanlagen zertifiziert. Den Inhalt können Sie daher nicht auf einen anderen USB-Datenträger kopieren oder transferieren. Bei Verlust oder Defekt eines zertifizierten USB-Sticks benötigen Sie einen neuen, zertifizierten USB-Stick.

Simulation eines WinCC-Projekts in einer asiatischen Sprache

Für die Simulation benötigen Sie dann ebenfalls einen zertifizierten USB-Stick als Dongle. Wenn kein Dongle verfügbar ist, läuft die Simulation im Demo-Modus.


STEP 7 ohne Lizenz für PC-CP

Funktionen von STEP 7 für PC-CP Informationssystem Auf Funktionsumfang von STEP 7 Professional hochrüsten
STEP 7 ohne Lizenz für PC-CP

Funktionen von STEP 7 für PC-CP

STEP 7 für PC-CP ist eine vollständige STEP 7Version, die ohne Lizenz installiert wurde. In dieser Version stehen Ihnen nur Konfigurations- und Diagnose-Möglichkeiten für folgende Komponenten zur Verfügung:

  • PC-CPs und Applikationen (OPC-Server) für PC-Stationen

  • Switches SCALANCE X

  • Router SCALANCE W / SCALANCE M

  • Security-Module SCALANCE S

  • PROFINET IO-Devices und PROFIBUS DP-Slaves

  • IE/PB LINK PN IO, IWLAN/PB LINK PN IO

  • Reader (RFID) und optische Lesegeräte (MV)

SIMATIC-Stationen und WinAC-Komponenten stehen nur in der Netz- und Topologie-Ansicht zur Verfügung (keine Geräte-Ansicht). Programmierfunktionen stehen nicht zur Verfügung.

Informationssystem

Das in der STEP 7-Version für PC-CP vorhandene Informationssystem beschreibt den vollen Funktionsumfang von STEP 7. Beachten Sie daher die Beschränkung auf die Funktionen zur Konfiguration der zuvor genannten Gerätegruppen.

Auf Funktionsumfang von STEP 7 Professional hochrüsten

Mit der Installation von STEP 7 für PC-CP ist bereits der volle Funktionsumfang von STEP 7 auf Ihrer Engineering-Station vorhanden, aber nur eingeschränkt nutzbar.

Durch eine nachträgliche Lizenzinstallation können Sie jederzeit auf die volle Funktionalität von STEP 7 Professional hochrüsten. Eine erneute Installation ist nicht erforderlich. Zuvor in STEP 7 für PC-CP angelegte Projekte können nach der Installation einer Lizenz ohne Einschränkung weiterverwendet werden.


Systemvoraussetzungen für die Installation

Systemvoraussetzungen für die Installation

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hinweise zu den Systemvoraussetzungen
  • Allgemeine Software- und Hardwarevoraussetzungen
  • Produktspezifische Besonderheiten


Hinweise zu den Systemvoraussetzungen

Systemvoraussetzungen für einzelne Produkte Anzeigen von PDF-Dateien Anzeigen der Welcome Tour Windows 7 und Windows Server 2008 R2: Ungültige Zertifikatsvalidierung Hinweis für Installationen unter Windows 7 Windows 10: Zeichensätze
Hinweise zu Lizenzen Installation starten Installierte Software anzeigen Installierte Produkte modifizieren oder hochrüsten Installierte Produkte reparieren Deinstallation starten
Hinweise zu den Systemvoraussetzungen

Systemvoraussetzungen für einzelne Produkte

Je nachdem, welche Produkte Sie installieren möchten, gelten unterschiedliche Systemvoraussetzungen. Beachten Sie daher die individuellen Systemvoraussetzungen Ihrer Produkte.

Möchten Sie mehrere Produkte installieren, berücksichtigen Sie bitte die Systemvoraussetzungen des Produkts mit den höchsten Anforderungen.

Anzeigen von PDF-Dateien

Um mitgelieferte PDF-Dateien zu lesen, benötigen Sie einen PDF Reader, der das PDF-Format 1.7 unterstützt, z. B. Adobe (R) Reader Version 9.

Anzeigen der Welcome Tour

Um die Welcome Tour zum TIA Portal zu starten, benötigen Sie den Adobe (R) Flashplayer ab Version 9.

Windows 7 und Windows Server 2008 R2: Ungültige Zertifikatsvalidierung

Die neuen, zur Signierung verwendeten Zertifikate werden auf den Betriebssystemen Windows 7 und Windows Server 2008 R2 möglicherweise nicht validiert.

Wenn Sie keine Möglichkeit haben, den Zertifikatsspeicher online zu aktualisieren, wird gegebenenfalls die Signatur der Produktdateien als ungültig angezeigt. Aktualisieren Sie in diesem Fall auf den Offline-Systemen die von Microsoft bereitgestellten Root Zertifikate. Folgen Sie dafür den Anweisungen im FAQ 109748887.

Hinweis für Installationen unter Windows 7

Das TIA Portal ist nur auf Windows-Systemen lauffähig, die den sicheren Hash-Algorithmus "SHA-2" unterstützen. Die Unterstützung von "SHA-2" unter Windows 7 ist erst nach der Installation eines Sicherheitsupdates (KB 3033929) gegeben. Stellen Sie daher sicher, dass die neuesten Sicherheitsupdates für Windows auf Ihrem System installiert sind.

Windows 10: Zeichensätze

Seit Windows 10 Update Version 1809 bietet Windows die Möglichkeit, Zeichensätze entweder mit Administratorrechten für jeden Benutzer (Befehl "Für alle Benutzer installieren" im Kontextmenü) oder benutzerspezifisch zu installieren. Um in WinCC Zeichensätze uneingeschränkt nutzen und auf ein Bediengerät laden zu können, müssen Zeichensätze immer mit Administratorrechten installiert werden.

Bitte beachten Sie, dass die Schaltfläche "Installieren" in der Ansicht eines Zeichensatzes nur eine benutzerspezifische Installation durchführt.


Allgemeine Software- und Hardwarevoraussetzungen

Voraussetzungen für die Installation Empfohlene PC-Hardware Unterstützte Virtualisierungsplattformen Unterstützte Sicherheitsprogramme
Hinweise zu Lizenzen Installation starten Verfügbarkeit von Updates und Support Packages prüfen und installieren Installierte Software anzeigen Installierte Produkte modifizieren oder hochrüsten Installierte Produkte reparieren Deinstallation starten
Allgemeine Software- und Hardwarevoraussetzungen

Voraussetzungen für die Installation

Die folgende Tabelle zeigt die minimalen Software- und Hardwarevoraussetzungen, die für die Installation mindestens erfüllt sein müssen:

Hardware/Software

Voraussetzung

Prozessor

Intel® Core™ i3-6100U, 2.30 GHz

RAM

8 GB

Festplatte

S-ATA mit mindestens 20 GB verfügbarem Speicherplatz

Netzwerk

Ab 100 Mbit

Bildschirmauflösung

1024 x 768

Betriebssysteme *

Windows 7 (64 Bit) ***

  • Windows 7 Home Premium SP1 **

  • Windows 7 Professional SP1

  • Windows 7 Enterprise SP1

  • Windows 7 Ultimate SP1

Windows 10 (64 Bit)

  • Windows 10 Home Version 1809 **

  • Windows 10 Home Version 1903 **

  • Windows 10 Professional Version 1809

  • Windows 10 Professional Version 1903

  • Windows 10 Enterprise Version 1809

  • Windows 10 Enterprise Version 1903

  • Windows 10 IoT Enterprise 2015 LTSB

  • Windows 10 IoT Enterprise 2016 LTSB

  • Windows 10 IoT Enterprise 2019 LTSC

Windows Server (64 Bit)

  • Windows Server 2012 R2 StdE (Vollinstallation)

  • Windows Server 2016 Standard (Vollinstallation)

  • Windows Server 2019 Standard (Vollinstallation)

* Inklusive aller Security Updates bis zum Microsoft Security Bulletin Summary für August 2019 (MS19-Aug). Weitere Informationen zu den Betriebssystemen finden Sie in der Hilfe zu Microsoft Windows oder auf der Homepage von Microsoft.

** Nur für Basic-Editionen

*** Nicht für STEP7 Professional - WinCC Professional

Hinweis

Auslauf des Extended Support Zeitraums für Windows 7

Beachten Sie den Auslauf des Extended Support Zeitraums für Windows 7. Microsoft stellt nach Beendigung der Unterstützung für Windows 7 keine Sicherheitsaktualisierungen oder Support mehr für PCs bereit, auf denen Windows 7 ausgeführt wird. Die Software kann aber trotzdem installiert werden.

Möglicherweise unterstützen bestimmte Produkte weitere Versionen von Windows. Weitere Informationen dazu finden Sie bei den produktspezifschen Systemvoraussetzungen oder Sie überprüfen die Kompatibiltät mit dem Kompatibilitäts-Tool. Das Kompatibilitäts-Tool finden Sie im Internet unter https://support.industry.siemens.com/kompatool/pages/main/index.jsf?.

Empfohlene PC-Hardware

Die folgende Tabelle zeigt die empfohlenen Hardwarevoraussetzungen:

Hardware/Software | Voraussetzung
Rechner | Ab SIMATIC FIELD PG M5 Advanced (oder vergleichbarer PC)
Prozessor | Intel® Core™ i5-6440EQ (bis zu 3.4 GHz)
RAM | 16 GB oder mehr (für große Projekte 32 GB)
Festplatte | SSD mit mindestens 50 GB verfügbarem Speicherplatz
Netzwerk | 1 GBit (für Multiuser)
Bildschirm | 15,6" Full HD Display (1920 x 1080 oder größer)

Unterstützte Virtualisierungsplattformen

Sie können die Softwarepakete "SIMATIC STEP 7" und "SIMATIC WinCC" in einer virtuellen Maschine installieren. Verwenden Sie dazu eine der folgenden Virtualisierungsplattformen in der angegebenen oder einer neueren Version:

  • VMware vSphere Hypervisor (ESXi) 6.5 oder höher

  • VMware Workstation 15.0.2 oder höher

  • VMware Player 15.0.2 oder höher

  • Microsoft Hyper-V Server 2016 oder höher

Für diese Virtualisierungsplattformen werden die folgende Betriebssysteme als Host-Betriebssystem empfohlen:

Betriebssystem | VMware vSphere Hypervisor (ESXi) | VMware Workstation | VMware Player | Microsoft Hyper-V
Windows Server 2016 Standard (Vollinstallation) | - | - | - | x
Windows Server 2019 Standard (Vollinstallation) | - | - | - | x
Windows 7 Professional SP1 | x | x | x | -
Windows 7 Enterprise SP1 | x | x | x | -
Windows 7 Ultimate SP1 | x | x | x | -
Windows 10 Professional Version 1809 und 1903 | x | x | x | -
Windows 10 Enterprise Version 1809 und 1903 | x | x | x | -
Windows 10 (IoT) Enterprise 2015 LTSB | x | x | x | -
Windows 10 (IoT) Enterprise 2016 LTSB | x | x | x | -
Windows 10 (IoT) Enterprise 2019 LTSC | x | x | x | -
x: als Host-Betriebssystem verwendbar -: nicht als Host-Betriebssystem verwendbar

Innerhalb der gewählten Virtualisierungsplattform werden die folgenden Gast-Betriebssysteme empfohlen:

Betriebssystem | VMware vSphere Hypervisor (ESXi) | VMware Workstation | VMware Player | Microsoft Hyper-V
Windows Server 2012 R2 StdE (Volinstallation) | - | - | - | x
Windows Server 2016 Standard (Vollinstallation) | - | - | - | x
Windows Server 2019 Standard (Vollinstallation) | - | - | - | x
Windows 7 Professional SP1 | x | x | x | x
Windows 7 Enterprise SP1 | x | x | x | x
Windows 7 Ultimate SP1 | x | x | x | x
Windows 10 Professional Version 1809 und 1903 | x | x | x | x
Windows 10 Enterprise Version 1809 und 1903 | x | x | x | x
Windows 10 (IoT) Enterprise 2015 LTSB | x | x | x | x
Windows 10 (IoT) Enterprise 2016 LTSB | x | x | x | x
Windows 10 (IoT) Enterprise 2019 LTSC | x | x | x | x
x: als Gast-Betriebssystem verwendbar -: nicht als Gast-Betriebssystem verwendbar

Hinweis

  • Für die Gast-Betriebssysteme gelten dieselben Hardware-Anforderungen wie für die jeweiligen TIA-Produkte selbst.

  • Der Betreiber der Anlage muss dafür Sorgen, dass den Gast-Betriebssystemen ausreichend Systemressourcen zur Verfügung gestellt werden.

  • Für den Einsatz von HyperV-Server und ESXi wird die von den Herstellern zertifizierte Hardware empfohlen.

  • Bei der Verwendung von Microsoft Hyper-V ist das Anzeigen der erreichbaren Teilnehmer nicht möglich.

Unterstützte Sicherheitsprogramme

Folgende Sicherheitsprogramme sind kompatibel zu "SIMATIC STEP 7 und "SIMATIC WinCC":

  • Virenscanner:

    • Symantec Endpoint Protection 14

    • Trend Micro Office Scan 12.0

    • McAfee Endpoint Security (ENS) 10.5

    • Kaspersky Endpoint Security 11.1

    • Windows Defender

    • Qihoo 360 "Safe Guard 11.5" + "Virus Scanner"

    Hinweis

    Achten Sie darauf, dass Ihr Virenscanner und dessen Datenbanken immer auf dem aktuellen Stand sind.

    Die letzte Aktualisierung der Viren-Pattern erfolgte am 02.09.2019.

  • Verschlüsselungssoftware:

    • Microsoft Bitlocker

  • Host-basiertes Intrusion Detection System:

    • McAfee Application Control 8.0


Produktspezifische Besonderheiten

Produktspezifische Besonderheiten

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Installation von WinCC Runtime Professional
  • Deinstallation einer SQL-Instanz
  • Hinweise zur Installation des TIA Portal Teamcenter Gateway


Installation von WinCC Runtime Professional

Installation in Domänen und Arbeitsgruppen Betrieb auf einem Netzwerk Server Windows Rechnername Remote-Kommunikation aktivieren
Installation von WinCC Runtime Professional

Installation in Domänen und Arbeitsgruppen

WinCC ist grundsätzlich für den Betrieb in einer Domäne oder Arbeitsgruppe freigegeben.

Beachten Sie jedoch, dass Domänen-Gruppenrichtlinien und Einschränkungen der Domäne die Installation behindern können. Entfernen Sie in diesem Fall den Rechner vor der Installation von Microsoft Message Queuing, Microsoft SQL Server und WinCC aus der Domäne. Melden Sie sich an dem betreffenden Rechner lokal mit Administratorrechten an. Führen Sie die Installation durch. Nach der erfolgreichen Installation können Sie den WinCC-Rechner wieder in die Domäne aufnehmen. Wenn die Domänen-Gruppenrichtlinien und Einschränkungen der Domäne die Installation nicht behindern, muss der Rechner während der Installation nicht aus der Domäne entfernt werden.

Beachten Sie, dass Domänen-Gruppenrichtlinien und Einschränkungen der Domäne auch den Betrieb behindern können. Wenn Sie diese Einschränkungen nicht aufheben können, betreiben Sie die WinCC-Rechner in einer Arbeitsgruppe.

Wenden Sie sich gegebenenfalls an den Domänen-Administrator.

Betrieb auf einem Netzwerk Server

Der Betrieb von WinCC Runtime Professional auf einem Netzwerk Server (z. B. Domain Controller, File-Server, Namensdienst-Server, Router, Software Firewall, Media Server, Exchange Server) ist nicht zulässig.

Windows Rechnername

Ändern Sie den Windows Rechnernamen nach der WinCC-Installation nicht.

Wenn Sie den Windows Rechnernamen ändern, müssen Sie den SQL-Server deinstallieren und neu installieren.

Folgende Zeichen sind im Rechnernamen nicht zulässig:

  • . , ; : ! ? " ' ^ ´ ` ~ _

  • + = / \ ¦ @ * # $ % & § °

  • ( ) [ ] { } < >

  • Leerzeichen

Bei der Vergabe der Windows Rechnernamen beachten Sie Folgendes:

  • Nur Großschreibung darf verwendet werden.

  • Erstes Zeichen muss ein Buchstabe sein.

  • Die ersten 12 Zeichen des Rechnernamens müssen eindeutig sein.

Remote-Kommunikation aktivieren

Auf WinCC-Systemen ist die Remote-Kommunikation im Dialog "Simatic Shell" nach der Installation standardmäßig deaktiviert. Für folgende Anwendungsfälle müssen Sie die Remote-Kommunikation für die beteiligten Rechner aktivieren:

  • Laden der Runtime auf einen anderen PC

  • Client-Server-Kommunikation

  • Redundantes System

  • WinCC-Option "WebNavigator"

    Wenn der WebNavigator-Client nicht auf dem gleichen Rechner läuft wie der WebNavigator-Server, muss die Remote-Kommunikation aktiviert sein.

Um den Remote-Zugriff zu ermöglichen, gehen Sie folgendermaßen vor:

  1. Öffnen Sie im Windows Explorer über das Kontextmenü von Simatic Shell die Kommunikationseinstellungen.

  2. Aktivieren Sie die Option "Remote Kommunikation".

  3. Konfigurieren Sie die verschlüsselte Kommunikation im Netzwerk: Wählen Sie den PSK-Schlüssel und den Port.

  4. Wählen Sie den Netzwerkadapter sowie gegebenenfalls die Multicast-Einstellungen.


Deinstallation einer SQL-Instanz

Inhalt Deinstallation einer SQL-Instanz
Deinstallation einer SQL-Instanz

Inhalt

Mit der Installation von WinCC V16 wird eine neue WINCC SQL 2016 SP2 Instanz installiert.

Wenn Sie bereits eine Version von WinCC Runtime Professional installiert hatten, müssen Sie vor der Installation von WinCC Professional V16 entweder

  • zuerst WinCC Runtime Professional V16 installieren, oder

  • ältere Instanzen "WINCC" des SQL Servers deinstallieren.

Hinweis

Durch eine Deinstallation von WinCC Runtime Professional oder von WinCC Professional wird die Instanz des SQL-Servers nicht deinstalliert.

Deinstallation einer SQL-Instanz

Die folgende Vorgehensweise zeigt beispielhaft die Deinstallation der Instanz von Microsoft SQL Server 2008 R2.

  1. Öffnen Sie die Systemsteuerung.

  2. Klicken Sie auf Programm deinstallieren.

  3. Wählen Sie in der Lister der installierten Programme "Microsoft SQL Server 2008 R2" und klicken Sie auf "Deinstallieren/ändern".

  4. Klicken Sie im Dialog "SQL Server 2008 R2" auf "Remove".

  5. Klicken Sie im Dialog "Setup Support Rules" auf "OK".

  6. Wählen Sie im Dialog "Select Instance" die Instanz "WINCC" und klicken Sie auf "Next".

  7. Klicken Sie im Dialog "Select Features" auf "Select All" und anschließend auf "Next".

  8. Klicken Sie im Dialog "Removal Rules" auf "Next".

  9. Klicken Sie im Dialog "Ready to Remove" auf "Remove".

  10. Klicken Sie nach Abschluss der Deinstallation im Dialog "Complete" auf "Close"

Die Vorgehensweise zur Deinstallation einer Instanz des SQL Server 2005 oder des SQL Server 2014 ist vergleichbar.


Hinweise zur Installation des TIA Portal Teamcenter Gateway

Einführung Voraussetzungen für die Installation Installation des TIA Portal Teamcenter Gateway - Datenmodells Gleiche TIA Portal-Versionen bei der Installation Installationspfad Virenscanner
Hinweise zur Installation des TIA Portal Teamcenter Gateway

Einführung

Sie können das TIA Portal Teamcenter Gateway wie folgt installieren:

  • Zusammen mit der Installation des TIA Portals

    Hinweis

    Für die Serverinstallation werden Administratorrechte benötigt.

Voraussetzungen für die Installation

Auf Ihrem Computer muss/müssen

  • Teamcenter Rich Application Client (nachfolgend "RAC" genannt) oder Teamcenter Client Communication System (TCCS) Version 11.2 oder höher installiert sein.

    Hinweis

    Wenn Sie die Installation von TCCS als "Standalone"-Installation durchgeführt haben, müssen Sie auch "Microsoft Visual C++ 2013 – Redistributable" installieren. Damit stellen Sie sicher, dass Sie eine Verbindung zwischen dem TIA Portal und TIA Portal Teamcenter Gateway möglich ist.

  • eine Verbindung von FCC/FMS (FileClientCache/FileManagementSystem) zum "Teamcenter Server 11.2 oder höher" bestehen.

    Hinweis

    • Prüfen Sie nach einer Nachinstallation oder einem Neustart, ob eine Verbindung von FCC/FMS (FileClientCache/FileManagementSystem) zum "Teamcenter Server 11.2 oder höher" besteht.

    • Prüfen Sie nach einer Nachinstallation oder einem Neustart die Registrierungsschlüssel. Weitere Informationen zur Überprüfung der Registrieungsschlüssel finden Sie in der Online-Hilfe "TIA Portal Teamcenter Gateway" im Abschnitt "TIA Portal Teamcenter Gateway installieren und deinstallieren" > "TIA Portal Teamcenter Gateway Installation prüfen".

    • Prüfen Sie nach einer Nachinstallation oder einem Neustart, ob Sie einen Elementtypen in Teamcenter speichern können und ob Sie der Element-Revision ein Dataset hinzufügen können. Weitere Informationen zum Speichern von Elementtypen finden Sie in der Online-Hilfe "TIA Portal Teamcenter Gateway" im Kapitel "TIA Portal-Projekte mit dem TIA Portal Teamcenter Gateway verwalten" im Abschnitt "TIA Portal-Projekt als neues Element in Teamcenter speichern".

    • Prüfen Sie nach einer Nachinstallation oder einem Neustart, ob ein Dateitransfer vom Teamcenter Rich Application Client zum Teamcenter Server möglich ist.

  • Auf dem Teamcenter Server, muss das mitgelieferte Datenmodell, bestehend aus mehreren Dateien, installiert sein.

Installation des TIA Portal Teamcenter Gateway - Datenmodells

Die Installation des mitgelieferten TIA Portal Teamcenter Gateway - Datenmodells muss mit dem "Environment Manager" erfolgen.

Die Beschreibung zur Installation finden Sie auf der Produkt-DVD im Verzeichnis "\Support\Teamcenter_11\ServerSetupDocument\".

Gleiche TIA Portal-Versionen bei der Installation

Achten Sie bei der Installation von verschiedenen TIA Portal-Produkten darauf, dass Sie für die Installation die gleichen Stände der Service Packs und Updates verwenden.

Wenn Sie also z. B. TIA Portal V14 oder höher installiert haben, müssen Sie auch das TIA Portal Teamcenter Gateway V14 oder höher installieren.

Installationspfad

Verwenden Sie keine Unicode-Zeichen (z. B. chinesische Schriftzeichen) im Installationspfad.

Virenscanner

Während der Installation ist es notwendig, dass auf bereits installierte Dateien lesend und schreibend zugegriffen werden kann. Einige Virenscanner verhindern dies. Daher wird empfohlen, während der Installation des TIA Portal Teamcenter Gateway den Virenscanner zu deaktivieren und erst danach wieder zu aktivieren.


Installationsprotokoll

Funktion des Installationsprotokolls Ablageort der Installationsprotokolle Setup_Report (CAB-Datei)
Hinweise zu Lizenzen Installation starten Verfügbarkeit von Updates und Support Packages prüfen und installieren Installierte Software anzeigen Installierte Produkte modifizieren oder hochrüsten Installierte Produkte reparieren Deinstallation starten
Installationsprotokoll

Funktion des Installationsprotokolls

Während folgender Installationsprozesse werden die Fortschritte in einer Datei protokolliert:

  • Produkte installieren

  • Bereits installierte Produkte modifizieren oder hochrüsten

  • Eine bereits vorhandene Installation reparieren

  • Produkte deinstallieren

Wenn während des Installationsprozesses Fehler auftreten oder Warnungen ausgegeben werden, können diese mithilfe der Protokolldatei ausgewertet werden. Dies können Sie entweder selbst tun oder Sie wenden sich an den Produkt-Support.

Ablageort der Installationsprotokolle

Die Protokolldatei ist die neueste Datei mit der Dateinamenerweiterung ".log", deren Name mit "SIA" beginnt.

Der Ablageort der Protokolldatei ist in der Umgebungsvariablen "%autinstlog%" gespeichert. Diese Umgebungsvariable können Sie in die Adressleiste des Windows Explorers eingeben, um den Ordner mit den Protokolldateien zu öffnen. Alternativ können Sie mit "CD %autinstlog%" über die Kommandozeile zum entsprechenden Verzeichnis navigieren.

Der Ablageort ist abhängig vom Betriebssystem, z. B. "C:\Programdata\Siemens\Automation\Logfiles\Setup" in englischem Windows.

Setup_Report (CAB-Datei)

Damit Sie alle notwendigen Dateien an den Produkt-Support liefern können, wird zusätzlich eine Archiv-Datei im CAB-Format abgelegt, die das Installationsprotokoll und alle anderen benötigten Dateien enthält. Dieses Archiv finden Sie unter "%autinstlog%\Reports\Setup_report.cab". Übermitteln Sie diese CAB-Datei dem Produkt-Support, wenn Sie Unterstützung bei der Installation benötigen. Damit kann der Produkt-Support schnell feststellen, ob die Installation einwandfrei durchgelaufen ist. CAB-Dateien, die bei früheren Installationsprozessen erzeugt wurden, werden mit einer Datumskennung im Verzeichnis "Reports" gespeichert.


Installation starten

Einführung Voraussetzung Vorgehen Ergebnis
Installationsprotokoll Hinweise zu den Systemvoraussetzungen Hinweise zu Lizenzen Installierte Software anzeigen Installierte Produkte modifizieren oder hochrüsten Installierte Produkte reparieren Deinstallation starten
Installation starten

Einführung

Die Installation der Softwarepakete wird durch ein Setup-Programm automatisch durchführt. Das Setup-Programm startet nach dem Einlegen des Installationsdatenträgers in das entsprechende Laufwerk.

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um die Softwarepakete zu installieren, gehen Sie folgendermaßen vor:

  1. Legen Sie den Installationsdatenträger in das entsprechende Laufwerk ein.

    Das Setup-Programm startet automatisch, falls der Autostart auf dem PG/PC nicht deaktiviert ist.

  2. Wenn das Setup-Programm nicht automatisch startet, starten Sie es manuell durch Doppelklick auf die Datei "Start.exe".

    Der Dialog zur Auswahl der Setup-Sprache wird geöffnet.

  3. Wählen Sie die Sprache, in der Sie die Dialoge des Setup-Programms angezeigt bekommen möchten.

  4. Um die Produkt- und Installationshinweise zu lesen, klicken Sie auf die Schaltfläche "Hinweise lesen" bzw. "Installationshinweise".

    Die entsprechende Hilfedatei mit den Hinweisen wird geöffnet.

  5. Wenn Sie die Hinweise gelesen haben, schließen Sie die Hilfedatei und klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zur Auswahl der Produktsprachen wird geöffnet.

  6. Wählen Sie die Sprachen für die Produktoberfläche und klicken Sie auf die Schaltfläche "Weiter".

    Hinweis

    Die Produktsprache "Englisch" wird als Basis immer installiert.

    Der Dialog zur Auswahl der Produktkonfiguration wird geöffnet.

  7. Wählen Sie die Produkte, die Sie installieren möchten:

    • Wenn Sie das Programm mit einer minimalen Programmzusammenstellung installieren möchten, klicken Sie auf die Schaltfläche "Minimal".

    • Wenn Sie das Programm mit produkttypischen Programmzusammenstellungen installieren möchten, klicken Sie auf die Schaltfläche "Typisch".

    • Wenn Sie selbst auswählen möchten, welche Produkte installiert werden sollen, klicken Sie auf die Schaltfläche "Benutzerdefiniert". Aktivieren Sie anschließend die Optionskästchen für die Produkte, die Sie installieren möchten.

  8. Wenn eine Verknüpfung auf dem Desktop angelegt werden soll, aktivieren Sie das Optionskästchen "Desktop-Verknüpfung anlegen".

  9. Klicken Sie auf die Schaltfläche "Durchsuchen", wenn Sie das Zielverzeichnis für die Installation ändern möchten.

    Hinweis

    Beachten Sie die folgenden Hinweise:

    • Die Länge des Installationspfades darf 89 Zeichen nicht überschreiten.

    • Sie können den Installationspfad nur ändern, wenn noch kein Produkt des Software-Pakets installiert ist, das Sie installieren möchten.

    • Um die Sicherheit zu erhöhen, wählen Sie als Zielverzeichnis ein Verzeichnis, das durch Administratorrechten geschützt ist.

  10. Klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zu den Lizenzbedingungen wird geöffnet.

  11. Um die Installation fortzusetzen, lesen und akzeptieren Sie alle Lizenzvereinbarungen und klicken Sie auf "Weiter".

    Für den Fall, dass für die Installation des TIA Portals Sicherheits- und Rechteeinstellungen geändert werden müssen, wird der Dialog zu den Sicherheitseinstellungen geöffnet.

  12. Um die Installation fortzusetzen, akzeptieren Sie die Änderungen der Sicherheits- und Rechteeinstellungen und klicken Sie auf die Schaltfläche "Weiter".

    Im nächsten Dialog wird eine Übersicht der Installationseinstellungen angezeigt.

  13. Überprüfen Sie die gewählten Installationseinstellungen. Wenn Sie Änderungen vornehmen möchten, klicken Sie auf die Schaltfläche "Zurück", bis Sie die zu ändernde Stelle im Dialog erreicht haben. Wenn Sie die gewünschten Änderungen vorgenommen haben, kehren Sie mit "Weiter" wieder zur Übersicht zurück.

  14. Klicken Sie auf die Schaltfläche "Installieren".

    Die Installation wird gestartet.

    Hinweis

    Wenn während der Installation kein License Key gefunden wird, erhalten Sie die Möglichkeit diesen auf Ihren PC zu übertragen. Wenn Sie den Lizenztransfer überspringen, können Sie dies später mit dem Automation License Manager nachholen.

    Nach der Installation erhalten Sie eine Meldung darüber, ob die Installation erfolgreich durchgeführt wurde.

  15. Möglicherweise muss der Computer neu gestartet werden. Aktivieren Sie dann das Optionsfeld "Ja, Computer jetzt neu starten". Klicken Sie anschließend auf die Schaltfläche "Neu starten".

  16. Wenn der Computer nicht neu gestartet werden muss, klicken Sie auf die Schaltfläche "Beenden".

Ergebnis

Auf Ihrem Computer wurden das TIA Portal zusammen mit den erworbenen Produkten und Lizenzen und der Automation License Manager installiert.


Installierte Software anzeigen

Vorgehen
Hinweise zu den Systemvoraussetzungen Hinweise zu Lizenzen Installation starten Installierte Produkte modifizieren oder hochrüsten Installierte Produkte reparieren Deinstallation starten Installationsprotokoll
Installierte Software anzeigen

Sie können sich jederzeit darüber informieren, welche Software installiert ist. Zusätzlich können Sie sich weitere Informationen zur installierten Software anzeigen lassen.

Vorgehen

Um eine Übersicht über die installierte Software aufzurufen, gehen Sie folgendermaßen vor:

  1. Klicken Sie im Menü "Hilfe" auf "Installierte Software".

    Der Dialog "Installierte Software" wird geöffnet. Innerhalb des Dialogs sehen Sie die installierten Software-Produkte. Klappen Sie die Einträge auf, um die jeweils installierte Version zu sehen.

  2. Wenn Sie sich weitere Informationen zu der installierten Automatisierungssoftware anzeigen lassen möchten, klicken Sie auf den Link innerhalb des Dialogs "Weitere Informationen zu installierter Software".

    Der Dialog "Detailinformation" wird geöffnet.

  3. Wählen Sie in der Bereichsnavigation das Thema, zu dem Sie sich weitere Informationen ansehen möchten.


Installierte Produkte modifizieren oder hochrüsten

Voraussetzung Vorgehen Ergebnis
Hinweise zu den Systemvoraussetzungen Hinweise zu Lizenzen Installation starten Installierte Software anzeigen Installierte Produkte reparieren Deinstallation starten Installationsprotokoll
Installierte Produkte modifizieren oder hochrüsten

Sie haben die Möglichkeit, installierte Produkte über das Setup-Programm zu ändern oder auf eine neue Version hochzurüsten (Update).

Bausteine mit Know-how-Schutz aus früheren Versionen des TIA Portals werden nicht automatisch mit dem Projekt hochgerüstet. Entfernen Sie den Know-how-Schutz der Bausteine, bevor Sie das TIA Portal aktualisieren. Richten Sie den Know-how-Schutz anschließend mit der aktuellen Version des TIA Portals wieder ein. Weitere Informationen finden Sie im Informationssystem.

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um installierte Produkte zu ändern oder hochzurüsten, gehen Sie folgendermaßen vor:

  1. Legen Sie den Installationsdatenträger in das entsprechende Laufwerk ein.

    Das Setup-Programm startet automatisch, falls der Autostart auf dem PG/PC nicht deaktiviert ist.

  2. Wenn das Setup-Programm nicht automatisch startet, starten Sie es manuell durch Doppelklick auf die Datei "Start.exe".

    Der Dialog zur Auswahl der Setup-Sprache wird geöffnet.

  3. Wählen Sie die Sprache, in der Sie die Dialoge des Setup-Programms angezeigt bekommen möchten

  4. Um die Produkt- und Installationshinweise zu lesen, klicken Sie auf die Schaltfläche "Hinweise lesen" bzw. "Installationshinweise".

    Die entsprechende Hilfedatei mit den Hinweisen wird geöffnet.

  5. Wenn Sie die Hinweise gelesen haben, schließen Sie die Hilfedatei und klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zur Auswahl der Installationsvariante wird geöffnet.

  6. Aktivieren Sie das Optionsfeld "Modifizieren/Hochrüsten" und klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zur Auswahl der Produktsprachen wird geöffnet.

  7. Aktivieren Sie die Optionskästchen der Produktsprachen, die Sie installieren möchten. Bereits installierte Produktsprachen können Sie durch Deaktivieren der entsprechenden Optionskästchen deinstallieren.

    Hinweis

    Beachten Sie, dass Sie die Produktsprache "Englisch" nicht deinstallieren können.

  8. Klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zur Auswahl der Produktkonfiguration wird geöffnet.

  9. Aktivieren Sie die Optionskästchen der Bestandteile, die Sie installieren möchten. Bereits installierte Bestandteile können Sie durch Deaktivieren der entsprechenden Optionskästchen deinstallieren.

  10. Klicken Sie auf die Schaltfläche "Weiter".

    Hinweis

    Beachten Sie, dass Sie das Zielverzeichnis nicht ändern können, da die vorhandene Installation verändert wird.

    Für den Fall, dass für die Installation des TIA Portals Sicherheits- und Rechteeinstellungen geändert werden müssen, wird der Dialog zu den Sicherheitseinstellungen geöffnet.

  11. Um die Installation fortzusetzen, akzeptieren Sie die Änderungen der Sicherheits- und Rechteeinstellungen und klicken Sie auf die Schaltfläche "Weiter".

    Im nächsten Dialog wird eine Übersicht der Installationseinstellungen angezeigt.

  12. Klicken Sie auf die Schaltfläche "Modifizieren".

    Die Installation der zusätzlichen Bestandteile wird gestartet.

    Hinweis

    Nach der Installation erhalten Sie eine Meldung darüber, ob die bestehende Installation erfolgreich geändert wurde.

  13. Möglicherweise muss der Computer neu gestartet werden. Aktivieren Sie dann das Optionsfeld "Ja, Computer jetzt neu starten". Klicken Sie anschließend auf die Schaltfläche "Neu starten".

  14. Wenn der Computer nicht neu gestartet werden muss, klicken Sie auf die Schaltfläche "Beenden".

Ergebnis

Auf Ihrem Computer wurde die bestehende Installation geändert.


Installierte Produkte reparieren

Voraussetzung Vorgehen Ergebnis
Hinweise zu den Systemvoraussetzungen Hinweise zu Lizenzen Installation starten Installierte Software anzeigen Installierte Produkte modifizieren oder hochrüsten Deinstallation starten Installationsprotokoll
Installierte Produkte reparieren

Sie haben die Möglichkeit, installierte Produkte mithilfe des Setup-Programms durch eine vollständige Reinstallation zu reparieren.

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um installierte Produkte zu reparieren, gehen Sie folgendermaßen vor:

  1. Legen Sie den Installationsdatenträger in das entsprechende Laufwerk ein.

    Das Setup-Programm startet automatisch, falls der Autostart auf dem PG/PC nicht deaktiviert ist.

  2. Wenn das Setup-Programm nicht automatisch startet, starten Sie es manuell durch Doppelklick auf die Datei "Start.exe".

    Der Dialog zur Auswahl der Setup-Sprache wird geöffnet.

  3. Wählen Sie die Sprache, in der Sie die Dialoge des Setup-Programms angezeigt bekommen möchten

  4. Um die Produkt- und Installationshinweise zu lesen, klicken Sie auf die Schaltfläche "Hinweise lesen" bzw. "Installationshinweise".

    Die entsprechende Hilfedatei mit den Hinweisen wird geöffnet.

  5. Wenn Sie die Hinweise gelesen haben, schließen Sie die Hilfedatei und klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zur Auswahl der Installationsvariante wird geöffnet.

  6. Aktivieren Sie das Optionsfeld "Reparieren" und klicken Sie auf die Schaltfläche "Weiter".

    Im nächsten Dialog wird eine Übersicht der Installationseinstellungen angezeigt.

  7. Klicken Sie auf die Schaltfläche "Reparieren".

    Das Reparieren der bestehenden Installation wird gestartet.

    Hinweis

    Nach der Installation erhalten Sie eine Meldung darüber, ob die installierten Produkte erfolgreich repariert wurden.

  8. Möglicherweise muss der Computer neu gestartet werden. Aktivieren Sie dann das Optionsfeld "Ja, Computer jetzt neu starten". Klicken Sie anschließend auf die Schaltfläche "Neu starten".

  9. Wenn der Computer nicht neu gestartet werden muss, klicken Sie auf die Schaltfläche "Beenden".

Ergebnis

Die installierten Produkte wurden erneut installiert.


Deinstallation starten

Einführung Deinstallation von ausgewählten Komponenten über die Systemsteuerung Deinstallation eines Produkts mithilfe des Installationsdatenträgers
Installationsprotokoll Hinweise zu den Systemvoraussetzungen Hinweise zu Lizenzen Installation starten Installierte Software anzeigen Installierte Produkte modifizieren oder hochrüsten Installierte Produkte reparieren
Deinstallation starten

Einführung

Die Deinstallation der Softwarepakete wird durch ein Setup-Programm automatisch durchgeführt. Nach seiner Ausführung führt Sie das Setup-Programm Schritt für Schritt durch den gesamten Vorgang der Deinstallation.

Sie haben zwei Möglichkeiten für die Deinstallation:

  • Deinstallation von ausgewählten Komponenten über die Systemsteuerung

  • Deinstallation eines Produkts mithilfe des Installationsdatenträgers

Hinweis

Der Automation License Manager wird mit der Deinstallation der Softwarepakete nicht automatisch entfernt, da dieser für die Verwaltung der License Keys mehrerer Produkte der Siemens AG eingesetzt wird.

Deinstallation von ausgewählten Komponenten über die Systemsteuerung

Um ausgewählte Softwarepakete zu deinstallieren, gehen Sie folgendermaßen vor:

  1. Öffnen Sie die Systemsteuerung.

  2. Klicken Sie unter "Programme" auf "Programm deinstallieren".

    Ein Dialog mit der Liste der installierten Programmen wird geöffnet.

  3. Wählen Sie die zu deinstallierenden Softwarepakete und klicken Sie auf die Schaltfläche "Deinstallieren".

    Der Dialog zur Auswahl der Setup-Sprache wird geöffnet.

  4. Wählen Sie die Sprache, in der Sie die Dialoge des Setup-Programms angezeigt bekommen möchten, und klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zur Auswahl der Produkte, die Sie deinstallieren möchten, wird geöffnet.

  5. Aktivieren Sie die Optionskästchen für die Produkte, die Sie deinstallieren möchten, und klicken Sie auf die Schaltfläche "Weiter".

    Im nächsten Dialog wird eine Übersicht der Installationseinstellungen angezeigt.

  6. Überprüfen Sie die Liste mit den Produkten, die deinstalliert werden. Wenn Sie Änderungen vornehmen möchten, klicken Sie auf die Schaltfläche "Zurück".

  7. Klicken Sie auf die Schaltfläche "Deinstallieren".

    Die Deinstallation wird gestartet.

  8. Möglicherweise muss der Computer neu gestartet werden. Aktivieren Sie dann das Optionsfeld "Ja, Computer jetzt neu starten". Klicken Sie anschließend auf die Schaltfläche "Neu starten".

  9. Wenn der Computer nicht neu gestartet werden muss, klicken Sie auf die Schaltfläche "Beenden".

Deinstallation eines Produkts mithilfe des Installationsdatenträgers

Um alle Softwarepakete zu deinstallieren, gehen Sie folgendermaßen vor:

  1. Legen Sie den Installationsdatenträger in das entsprechende Laufwerk ein.

    Das Setup-Programm startet automatisch, falls der Autostart auf dem PG/PC nicht deaktiviert ist.

  2. Wenn das Setup-Programm nicht automatisch startet, starten Sie es manuell durch Doppelklick auf die Datei "Start.exe".

    Der Dialog zur Auswahl der Setup-Sprache wird geöffnet.

  3. Wählen Sie die Sprache, in der Sie die Dialoge des Setup-Programms angezeigt bekommen möchten.

  4. Um die Produkt- und Installationshinweise zu lesen, klicken Sie auf die Schaltfläche "Produktinformation lesen" bzw. "Installationshinweise lesen".

    Die entsprechende Hilfedatei mit den Hinweisen wird geöffnet.

  5. Wenn Sie die Hinweise gelesen haben, schließen Sie die Hilfedatei und klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zur Auswahl der Installationsvariante wird geöffnet.

  6. Aktivieren Sie das Optionsfeld "Deinstallieren" und klicken Sie auf die Schaltfläche "Weiter".

    Im nächsten Dialog wird eine Übersicht der Installationseinstellungen angezeigt.

  7. Klicken Sie auf die Schaltfläche "Deinstallieren".

    Die Deinstallation wird gestartet.

  8. Möglicherweise muss der Computer neu gestartet werden. Aktivieren Sie dann das Optionsfeld "Ja, Computer jetzt neu starten". Klicken Sie anschließend auf die Schaltfläche "Neu starten".

  9. Wenn der Computer nicht neu gestartet werden muss, klicken Sie auf die Schaltfläche "Beenden".


Updates und Support Packages installieren

Updates und Support Packages installieren

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Verfügbarkeit von Updates und Support Packages prüfen und installieren
  • Arbeiten mit einem unternehmenseigenen Server


Verfügbarkeit von Updates und Support Packages prüfen und installieren

Automatische Suche nach Software Updates deaktivieren oder aktivieren Manuell nach Software Updates suchen Server einstellen Software Updates separat herunterladen und installieren Mehrere Support Packages in einem Schritt herunterladen und installieren Alternative Vorgehensweise für die Installation von Support Packages
Installationsprotokoll
Verfügbarkeit von Updates und Support Packages prüfen und installieren

Per Voreinstellung prüft das TIA Portal automatisch, ob neue Software Updates oder Support Packages verfügbar sind, z. B. Hardware Support Packages (HSPs). Die automatische Suche nach Updates findet nach jedem Neustart des Rechners und danach zyklisch alle 24 Stunden statt. Sie können die automatische Suche jederzeit deaktivieren bzw. erneut aktivieren. Zusätzlich können Sie manuell nach Updates suchen.

Falls Updates gefunden werden, können Sie diese herunterladen und installieren.

Hinweis

Es werden Updates und Support Packages ab TIA Portal V13 unterstützt.

Automatische Suche nach Software Updates deaktivieren oder aktivieren

Um die automatische Suche nach Software Updates zu deaktivieren oder erneut zu aktivieren, gehen Sie folgendermaßen vor:

  1. Wählen Sie im Menü "Extras" den Befehl "Einstellungen".

    Das Fenster "Einstellungen" wird im Arbeitsbereich angezeigt.

  2. Wählen Sie in der Bereichsnavigation die Gruppe "Allgemein > Software Updates".

  3. Deaktivieren Sie das Optionskästchen "Täglich nach Updates suchen", wenn Sie die automatische Suche nach Software Updates deaktivieren möchten.

  4. Aktivieren Sie das Optionskästchen "Täglich nach Updates suchen", wenn Sie die automatische Suche nach Software Updates erneut aktivieren möchten.

Manuell nach Software Updates suchen

Wenn Sie manuell nach Software Updates suchen möchten, gehen Sie folgendermaßen vor:

  1. Klicken Sie im Menü "Hilfe" auf "Installierte Software".

    Der Dialog "Installierte Software" wird geöffnet.

  2. Klicken Sie auf "Nach Updates suchen".

    Der TIA Updater wird geöffnet und die verfügbaren Updates werden angezeigt.

Oder:

  1. Wählen Sie im Menü "Extras" den Befehl "Einstellungen".

    Das Fenster "Einstellungen" wird im Arbeitsbereich angezeigt.

  2. Wählen Sie in der Bereichsnavigation die Gruppe "Allgemein > Software Updates".

  3. Klicken Sie auf "Jetzt nach Updates suchen".

    Der TIA Updater wird geöffnet und die verfügbaren Updates werden angezeigt.

Oder:

  1. Öffnen Sie den TIA Updater über "Start > Alle Programme > Siemens Automation > Totally Integrated Automation UPDATER".

  2. Klicken Sie auf "Nach Updates suchen".

    Die verfügbaren Updates werden angezeigt.

Server einstellen

Abhängig davon, ob Sie die Updates bzw. Support Packages vom TIA Automation Update Server oder von einem unternehmenseigenen Server herunterladen möchten, müssen Sie den entsprechenden Server einstellen. Gehen Sie dazu folgendermaßen vor:

  1. Öffnen Sie den TIA Updater.

  2. Klicken Sie auf "Einstellungen" und wählen Sie im aufgeblendeten Dialog im Bereich "Server auf dem nach Updates gesucht werden soll" die Option "TIA Automation Software Update Server".
    Die Software sucht auf dem Server des Herstellers nach verfügbaren Updates.

Oder:

  1. Öffnen Sie den TIA Updater.

  2. Klicken Sie auf "Einstellungen" und wählen Sie im aufgeblendeten Dialog im Bereich "Server auf dem nach Updates gesucht werden soll" die Option "Unternehmenseigener Server".

  3. Geben Sie die Server-URL ein, die Sie von Ihrem Administrator bekommen haben. Die URL muss entweder im Format https://[URL des Servers]/[Pfad auf Ablageverzeichnis] oder im Format https://[IP-Adresse des Servers]/[Pfad auf Ablageverzeichnis] eingegeben werden. Sollten Sie sich nicht sicher sein, welches Format verwendet wird, wenden Sie sich an Ihren Administrator!
    Die Software sucht auf dem Server Ihres Unternehmens nach verfügbaren Updates.

  4. Prüfen Sie den Namen der Fertigungsline und ändern Sie diesen bei Bedarf. Standardmäßig ist "ProductionLine1" eingestellt.
    Fertigungslinien dienen dazu, um verschiedenen Anwendern gezielt bestimmte Updates/Support Packages bereitzustellen. Wenn Ihr Unternehmen nicht mit verschiedenen Fertigungslinien arbeitet, behalten Sie den vorgegebenen Eintrag bei.
    Ausführliche Informationen zum Erstellen von Projekten und Arbeiten mit Fertigungslinien entnehmen Sie der Hilfe zum TIA Updater Corporate Configuration Tool.

Sie können die Optionen, auf welchem Server nach Updates gesucht werden soll, jederzeit umstellen. Während eines Download-Vorgangs ist die Umstellung jedoch blockiert. Nach der Umstellung des Servers werden alle bereits heruntergeladenen Updates und Support Packages angezeigt, auch wenn sie auf dem aktuell eingestellten Server nicht verfügbar sind.

Software Updates separat herunterladen und installieren

Um verfügbare Software Updates und Support Packages herunterzuladen und zu installieren, gehen Sie folgendermaßen vor:

  1. Falls der TIA Updater nicht angezeigt wird, öffnen Sie ihn über einen der folgenden Wege:

    • Wenn die automatische Suche Updates gefunden hat, erhalten Sie eine Benachrichtigung im Infobereich der Taskleiste von Windows und das Symbol für den TIA Updater wird im Infobereich angezeigt. Klicken Sie entweder auf die Benachrichtigung oder auf das Symbol, um den TIA Updater zu öffnen.

    • Klicken Sie im Menü "Hilfe" auf "Installierte Software" und anschließend auf "Nach Updates suchen".

    • Klicken Sie im Startmenü von Windows auf "Start > Alle Programme > Siemens Automation > Automation Software Updater".

  2. Klicken Sie in der Zeile des Updates oder Support Packages, das Sie installieren möchten, auf "Download".

    Das Update oder Support Package wird heruntergeladen. Sobald der Download-Vorgang beendet ist, wird die zugehörige Schaltfläche "Installieren" aktiv.

    Hinweis

    Beachten Sie folgende Hinweise:

    1. Sie können gleichzeitig mehrere Download-Vorgänge anstoßen.

    2. Während eines laufenden Download-Vorgangs können Sie sich abmelden oder den Rechner auch herunterfahren. Der Download-Vorgang wird in diesen Fällen im Hintergrund fortgesetzt, sobald Sie sich erneut anmelden.

    3. In einigen Fällen wird statt der Schaltfläche "Download" ein Link auf eine externe Web-Seite angezeigt. Laden Sie das Software Update dann von dieser Seite herunter und installieren Sie es manuell.

  3. Schließen Sie das TIA Portal, falls es noch geöffnet ist.

  4. Klicken Sie im TIA Updater auf die Schaltfläche "Installieren" des Software-Pakets, das Sie installieren möchten.

    Der Installationsdialog wird angezeigt.

    Hinweis

    Beachten Sie folgende Hinweise:

    1. Die Installation mehrerer Updates zur gleichen Zeit ist nicht möglich.

    2. Melden Sie sich während einer Installation nicht ab und fahren Sie den Rechner nicht herunter. Dadurch vermeiden Sie inkonsistente Stände der Software auf Ihrem Rechner.

  5. Klicken Sie auf "Weiter".

    Das ausgewählte Produkt wird installiert.

Mehrere Support Packages in einem Schritt herunterladen und installieren

Um verfügbare Support Packages in einem Schritt herunterzuladen und zu installieren, gehen Sie folgendermaßen vor:

  1. Aktivieren Sie die gewünschten Zeilen. Hierzu haben Sie mehrere Möglichkeiten:

    • Um alle angezeigten Support Packages herunterzuladen und zu installieren, aktivieren Sie das Häkchen im Titel der Liste.

    • Um mehrere Support Packages herunterzuladen und zu installieren, markieren Sie das erste gewünschte Support Package, halten die <Ctrl>-Taste gedrückt und markieren Sie dann alle weiteren gewünschten Support Packages. Setzen Sie dann das Häkchen in eine der markierten Zeilen.

    • Um mehrere Support Packages in einer bestimmten Reihenfolge herunterzuladen und zu installieren, markieren Sie das erste gewünschte Support Package, halten die <Shift>-Taste gedrückt und markieren Sie dann das letzte gewünschte Support Package.

  2. Klicken Sie auf die Schaltfläche "Herunterladen und installieren".

  3. Klicken Sie nach dem Herunterladen im aufgeblendeten Dialog auf "Weiter", um die Installation zu starten. Danach wird ein Dialog angezeigt, der Sie über den Fortschritt der Installation informiert.

Hinweis

Es können nur Support Packages heruntergeladen und installiert werden, die keinen Exporteinschränkungen unterliegen.

Alternative Vorgehensweise für die Installation von Support Packages

Für die Installation eines Support Packages steht Ihnen eine zusätzliche Vorgehensweise zur Verfügung. Gehen Sie dazu folgendermaßen vor:

  1. Klicken Sie im TIA Portal im Menü "Extras" auf "Support Packages".

    Der Dialog "Detailinformation" wird geöffnet. In einer Tabelle werden alle Support Packages aus dem Verzeichnis aufgelistet, das Sie als Speicherort für Support Packages in den Einstellungen festgelegt haben.

  2. Falls Sie ein Support Package installieren möchten, das in der Liste nicht aufgeführt wird, haben Sie folgende Möglichkeiten:

    • Wenn sich das Support Package bereits auf Ihrem Computer befindet, können Sie es über "Aus dem Dateisystem hinzufügen" in die Liste aufnehmen.

    • Wenn Sie ein Support Package von der "Service & Support"-Seite im Internet hinzufügen möchten, laden Sie es zunächst mit "Aus dem Internet laden" herunter. Anschließend können Sie es aus dem Dateisystem hinzufügen.

  3. Selektieren Sie das Support Package, das Sie installieren möchten.

  4. Klicken Sie auf "Installieren".

  5. Beenden Sie das TIA Portal und starten Sie es erneut.


Arbeiten mit einem unternehmenseigenen Server

Arbeiten mit einem unternehmenseigenen Server

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Eigenschaften und Vorteile eines unternehmenseigenen Servers
  • Unternehmenseigenen Server für Updates konfigurieren
  • Updates auf einem unternehmenseigenen Server bereitstellen


Eigenschaften und Vorteile eines unternehmenseigenen Servers

Einleitung Konfigurieren des Servers und Erstellen von Projekten Arbeiten mit dem Server
Eigenschaften und Vorteile eines unternehmenseigenen Servers

Einleitung

Mithilfe eines unternehmenseigenen Servers können Sie ausgewählte Updates/Support Packages auf einem lokalen Server ablegen und den Anwendern zur Verfügung stellen, z. B. für unterschiedliche Fertigungslinien. Dies hat den Vorteil, dass die Anwender nicht auf das Internet zugreifen müssen, sondern die Updates über das Intranet, eine externe Festplatte etc. installieren können. Da die Anwender keinen direkten Zugriff ins Internet benötigen, wird der Schutz vor Trojanern oder schädlicher Software, die Kontakt aus dem internen Firmennetzwerk ins Internet aufnimmt, deutlich erhöht.

Konfigurieren des Servers und Erstellen von Projekten

In der ersten Phase wird der unternehmenseigene Server durch einen Server-Administrator konfiguriert, und mittels TIA Updater Corporate Configuration Tool werden die Updates/Support Packages bereitgestellt. Zusätzlich können Projekte für verschiedene Fertigungslinien erstellt werden, über die der Anwender die von ihm benötigten Updates erhalten kann. Die Anwender müssen Zugriff auf den Serverbereich und den Namen der Fertigungslinie haben und über das Ablageverzeichnis in Kenntnis gesetzt werden.

Ausführliche Informationen zum Erstellen von Projekten und Arbeiten mit Fertigungslinien entnehmen Sie der Hilfe zum TIA Updater Corporate Configuration Tool.

Arbeiten mit dem Server

Mit dem TIA Updater können die Anwender die bereitgestellten und für sie relevanten Updates/Support Packages herunterladen und installieren. Es können gleichzeitig mehrere Download-Vorgänge angestoßen werden; die Installation der Updates/Support Packages muss jedoch hintereinander erfolgen.


Unternehmenseigenen Server für Updates konfigurieren

Einfühung Voraussetzung Webserverrolle (IIS) installieren Website erstellen Virtuelles Verzeichnis aktivieren MIME-Typ hinzufügen und konfigurieren BITS-IIS-Servererweiterung aktivieren Selbstsigniertes Serverzertifikat erstellen SSL-Bindung erstellen SSL-Bindung verifizieren SSL-Einstellungen konfigurieren Updates auf unterschiedliche Bereiche verteilen
Unternehmenseigenen Server für Updates konfigurieren

Einfühung

Um den Anwendern zentral die verfügbaren Updates und Support Packages zur Verfügung zu stellen, müssen Sie einen unternehmenseigenen Server konfigurieren. Verwenden Sie hierzu den Microsoft Server Manager.

Nachfolgend sind beispielhaft die Schritte beschrieben, die zum Erstellen und Konfigurieren des Servers zur Nutzung des TIA Updater Corporate Configuration Tools (mit dem Betriebssystem Microsoft Server 2016) notwendig sind. Weitere Einstellungen, die evtl. zum Betrieb in Ihrem Unternehmen notwendig sind, sind nicht Bestandteil dieser Beschreibung!

Hinweis

Bitte beachten Sie, dass der Aufbau des Startmenüs und der Ablageort der Programme unter den verschiedenen Betriebssystemen unterschiedlich sein kann.

Genaue Informationen zur Konfiguration und Bedienung des Server Managers finden Sie in der Microsoft-Hilfe.

Voraussetzung

Sie müssen Administratorrechte besitzen.

Webserverrolle (IIS) installieren

Um die notwendige Webserverrolle zu installieren, gehen Sie folgendermaßen vor:

  1. Öffnen Sie das Startmenü und wählen Sie "Server Manager" aus.

  2. Klicken Sie im Dashboard auf "Rollen und Features hinzufügen".

  3. Verwenden Sie den Assistenten "Rollen und Features hinzufügen", um die Webserverrolle hinzuzufügen.
    Vor dem Start des Assistenten wird verifiziert, dass der Administrator ein komplexes Passwort vergeben hat, dass die Netzwerkeinstellungen entsprechend konfiguriert sind und dass die neusten Windows Sicherheits-Updates installiert sind.

  4. Wählen Sie als Installationstyp "Rollenbasierte oder featurebasierte Installation" und klicken Sie auf "Weiter".

  5. Wählen Sie dann den Ziel-Server aus und klicken Sie auf "Weiter".

  6. Beachten Sie die vorausgewählten Rollen, die standardmäßig installiert werden, und wählen Sie dann die zusätzliche Rolle "Webserver (IIS)" aus.

  7. Klicken Sie auf "Features hinzufügen" und dann auf "Weiter". Die Features für den Web Server werden angezeigt.

  8. Klicken Sie auf "Role 'Services" und prüfen Sie, dass die folgenden Features ausgewählt sind, bzw. wählen Sie diese aus:

    Bereich "Webserver"

    • Standarddokument

    • Verzeichnis durchsuchen

    • HTTP-Fehler

    • Statischer Inhalt

    Bereich "Systemzustand und Diagnose"

    • HTTP-Protokollierung

    • Anforderungsüberwachung

    Bereich "Leistung"

    • Komprimierung statischer Inhalte

    Bereich "Sicherheit"

    • Anforderungsfilterung

    Bereich "Anwendungsentwicklung"

    • .NET-Erweiterbarkeit 3.5

    • .NET-Erweiterbarkeit 4.6

    • ASP.NET 3.5

    • ASP.NET 4.6

    • ISAPI-Erweiterungen

    • ISAPI-Filter

  9. Klicken Sie auf "Weiter".

  10. Überprüfen Sie Ihre Auswahl im Dialog "Installationsauswahl bestätigen" und klicken Sie auf "Installieren".

Im Dashboard wird "IIS" hinzugefügt und kann weiter konfiguriert werden.

Website erstellen

  1. Klicken Sie im Navigationsbereich auf "IIS" und im Bereich "Server" klicken Sie mit der rechten Maustaste und wählen Sie "Internetinformationsdienste (IIS)-Manager".

  2. Klicken Sie im Bereich "Verbindungen" auf "Sites" und klicken Sie dann auf "Default Web Site".

  3. Wählen Sie mit einem rechten Mausklick die Option "Virtuelles Verzeichnis hinzufügen...".

  4. Geben Sie im aufgeblendeten Dialog einen Anzeigenamen in das Feld "Alias" ein, z. B. "TIAPortalUpdates".

  5. Geben Sie im Feld "Physikalischer Pfad" den physikalischen Pfad des Ordners ein, in dem sich die Website befindet, oder klicken Sie auf die Schaltfläche zum Durchsuchen (...), um den Ordner im Dateisystem zu suchen.

  6. Klicken Sie auf "Einstellungen testen...", um zu prüfen, ob die Einstellungen korrekt sind.

  7. Klicken Sie auf "OK".

Virtuelles Verzeichnis aktivieren

  1. Markieren Sie im Bereich "Verbindungen > Sites > Default Web Ssite" das von Ihnen erstellte virtuelle Verzeichnis. Doppelklicken Sie in der Ansicht "Features" den Eintrag "Verzeichnis durchsuchen".

  2. Klicken Sie im Bereich "Aktionen" auf "Aktivieren".

MIME-Typ hinzufügen und konfigurieren

  1. Markieren Sie im Bereich "Verbindungen" die von Ihnen erstellte Website.

  2. Doppelklicken Sie in der Ansicht "Features" auf "MIME-Typ".

  3. Klicken Sie im Bereich "Aktionen" auf "Hinzufügen".

  4. Geben Sie im Dialog "MIME-Typ hinzufügen" im Textfeld "Dateinamenerweiterung" .* ein.

  5. Geben Sie im Textfeld "MIME-Typ" "all/files" ein.

  6. Klicken Sie auf "OK".

BITS-IIS-Servererweiterung aktivieren

  1. Wechseln Sie zum virtuellen Verzeichnis im IIS-Manager.

  2. Doppelklicken Sie in der Featureansicht des virtuellen Verzeichnisses auf "BITS-Uploads".

  3. Aktivieren Sie das Optionskästchen "Clients können Dateien hochladen" und klicken Sie dann auf "Übernehmen".

Selbstsigniertes Serverzertifikat erstellen

  1. Navigieren Sie im Bereich "Verbindungen" zu der Ebene, die Sie verwalten möchten.

  2. Doppelklicken Sie in der Ansicht "Features" auf "Serverzertifikate".

  3. Klicken Sie im Bereich "Aktionen" auf "Selbstsigniertes Zertifikat erstellen".

  4. Geben Sie im Dialog "Selbstsigniertes Zertifikat erstellen" im Feld "Anzeigename für das Zertifikat" einen Anzeigenamen für das Zertifikat ein und klicken Sie auf "OK".

SSL-Bindung erstellen

  1. Erweitern Sie im Bereich "Verbindungen" den Eintrag "Sites" und klicken Sie anschließend auf die Site, der Sie eine Bindung hinzufügen möchten.

  2. Klicken Sie im Bereich "Aktionen" auf "Bindungen".

  3. Klicken Sie im Dialog "Sitebindungen" auf "Hinzufügen".

  4. Wählen Sie im Dialog "Sitebindung hinzufügen" unter "Typ" "https" und unter "SSL-Zertifikat" das von Ihnen erstellte Zertifikat aus und klicken Sie dann auf "OK".

SSL-Bindung verifizieren

  1. Klicken Sie im Bereich "Aktionen" unter "Website durchsuchen" auf die zuvor erstellte Bindung.
    Im Internet Explorer wird eine Fehlerseite geöffnet, weil das selbstsignierte Zertifikat von Ihrem Computer erstellt wurde.

  2. Klicken Sie auf "Laden dieser Website fortsetzen (nicht empfohlen)".
    Wenn Sie das Zertifikat in den Zertifikatspeicher "Vertrauenswürdige Stammzertifizierungsstellen" hinzufügen, wird diese Meldung nicht mehr angezeigt.

SSL-Einstellungen konfigurieren

  1. Doppelklicken Sie in der Ansicht "Features" auf "SSL-Einstellungen".

  2. Verwenden Sie eines der folgenden Verfahren im Dialog "SSL-Einstellungen" im Bereich "Clientzertifikate":

    • Wählen Sie "Ignorieren", wenn auch dann keine Clientzertifikate akzeptiert werden sollen, wenn ein Client ein Zertifikat vorweisen kann.

    • Wählen Sie "Akzeptieren", wenn Clientzertifikate akzeptiert werden sollen.

    • Wählen Sie "Erforderlich", wenn Clientzertifikate erforderlich sein sollen. Damit die Option "Clientzertifikate erforderlich" verwendet werden kann, muss die Option "SSL erforderlich" aktiviert sein.

  3. Klicken Sie im Bereich "Aktionen" auf "Übernehmen".

Updates auf unterschiedliche Bereiche verteilen

Es kann vorkommen, dass verschiedene Abteilungen unterschiedliche Updates oder Support Packages benötigen. In diesem Fall ist es empfehlenswert, mehrere Server für Updates zu betreiben, die unterschiedliche Updates und Support Packages anbieten. Gehen Sie dazu folgendermaßen vor:

  1. Erstellen Sie unterschiedliche unternehmenseigene Server wie oben beschrieben.

oder

  1. Installieren Sie die Webserverrolle.

  2. Erstellen Sie mehrere Websites.
    Beachten Sie, dass Sie eindeutige Namen für diese Websites und die physikalischen Pfade vergeben, damit es nicht zu Verwechselungen kommt!

  3. Stellen Sie die oben beschriebenen Features für den Webserver bzw. die Websites ein.

Sie können nun die erforderlichen Updates und Support Packages für die verschiedenen Abteilungen in den definierten Verzeichnissen ablegen.


Updates auf einem unternehmenseigenen Server bereitstellen

Einführung Voraussetzung Updates vom TIA Automation Software Update Server hinzufügen Abbrechen des Download-Vorgangs Updates vom unternehmenseigenen Server löschen Server-Optionen
Eigenschaften und Vorteile eines unternehmenseigenen Servers Unternehmenseigenen Server für Updates konfigurieren
Updates auf einem unternehmenseigenen Server bereitstellen

Einführung

Im TIA Updater Corporate Configuration Tool können Sie einen unternehmenseigenen Server einstellen, auf dem Sie die verfügbaren Updates/Support Packages ablegen und den Anwendern zur Verfügung stellen können.

Voraussetzung

Sie müssen Administratorrechte besitzen.

Ein unternehmenseigener Server kann nur auf einem Microsoft Server Betriebssystem aufgesetzt werden, da zum Betrieb der BITS IIS-Dienst und ein laufender IIS-Sever benötigt wird.

Updates vom TIA Automation Software Update Server hinzufügen

Um Updates vom TIA Automation Software Update Server hinzuzufügen, gehen Sie folgendermaßen vor:

  1. Öffnen Sie das TIA Updater Corporate Configuration Tool.
    Die verfügbaren Updates werden angezeigt.

  2. Klicken Sie auf die Schaltfläche "Update hinzufügen" und aktivieren Sie im aufgeblendeten Dialog das Optionskästchen "Vom TIA Automation Software Update Server hinzufügen".

  3. Wählen Sie im Dialog "Update vom TIA Automation Software Update Server hinzufügen" die gewünschten Updates (Software und Support Packages) aus und klicken Sie auf "Hinzufügen".
    Wenn sich bereits Updates auf dem unternehmenseigenen Server befinden, so werden diese gegraut dargestellt. Sie können nicht erneut geladen werden. Während des Download-Vorgangs werden der Status und die verbleibende Zeit im Dialog angezeigt.

Abbrechen des Download-Vorgangs

Um den Vorgang abzubrechen, gehen Sie folgendermaßen vor:

  1. Klicken Sie auf die Schaltfläche "Download abbrechen".

  2. Bestätigen Sie den aufgeblendeten Dialog mit "Ja".
    Der Download des Updates wurde abgebrochen und es wurde aus der Liste gelöscht.

Updates vom unternehmenseigenen Server löschen

Um Updates zu löschen, gehen Sie folgendermaßen vor:

  1. Wählen Sie die gewünschten Updates aus und klicken Sie auf die Schaltfläche "Entfernen".

  2. Bestätigen Sie den aufgeblendeten Dialog mit "Ja".
    Die ausgewählten Updates wurden aus der Liste gelöscht.

Server-Optionen

Klicken Sie im Dialog " TIA Automation Software Update Server" auf "Einstellungen", um Folgendes festzulegen:

  1. Geben Sie unter "Server-Pfad" den Ordner an, in dem die Downloads gespeichert werden sollen. Sie können sowohl ein lokales Laufwerk als auch ein Netzlaufwerk auswählen.

    Hinweis

    Wenn Sie direkt auf dem Server arbeiten, ist das Zielverzeichnis gleich dem Bereitstellungsverzeichnis auf dem Server. Alle Änderungen werden direkt übernommen. Diese Vorgehensweise wird nicht empfohlen, da Konflikte mit aktiven Downloads auftreten können!

    Es wird empfohlen, auf einem sonstigen Rechner arbeiten; das Zielverzeichnis ist ein beliebiges Verzeichnis. Der Inhalt dieses Verzeichnisses muss dann noch in das Bereitstellungsverzeichnis kopiert werden. Stellen Sie hierbei ebenfalls sicher, dass keine Konflikte mit aktiven Downloads auftreten!

  2. Aktivieren Sie das Optionskästchen "Server immer im Hintergrund laufen lassen (Symbol in der Taskleiste wird angezeigt)", wenn der Server immer im Hintergrund laufen soll.

  3. Bestätigen Sie Ihre Eingaben mit "OK".


Support Packages automatisiert installieren

Support Packages automatisiert installieren

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Support Packages automatisiert installieren
  • Rückgabewerte des Installationsprozesses
  • Protokolldatei


Support Packages automatisiert installieren

Einleitung Voraussetzung Vorgehen
Rückgabewerte des Installationsprozesses Protokolldatei
Support Packages automatisiert installieren

Einleitung

Mit dem Support Package Installer können Sie ab V15.1 alle Support Packages wie z. B. HSPs (Hardware Support Packages), die kompatibel zur installierten Version des TIA Portals sind (z. B. isp.15_1), automatisiert über die Kommandozeile installieren bzw. hochrüsten.

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um die Installation direkt über die Kommandozeile mit den gewünschten Optionen zu starten, gehen Sie folgendermaßen vor:

  1. Starten Sie die Eingabeaufforderung von Windows über "Start > Ausführen > cmd".

  2. Wechseln Sie in das Verzeichnis, das die Datei "Siemens.Automation.SupportPackageInstaller.exe" enthält. Dies ist das Installationsverzeichnis Ihres installierten TIA Portals.

  3. Geben Sie in der Eingabeaufforderung den folgenden Befehl ein:
    %Installationsverzeichnis% > Siemens.Automation.SupportPackageInstaller.exe <Support Package(HSP)-Ablageverzeichnis> [-l <Name der Protokolldatei>] [-warnaserror]

<Support Package-Ablageverzeichnis>
Zwingend erforderliches Verzeichnis, in dem die Support Package-Dateien (*.isp) liegen. Dies kann sowohl ein lokaler Ordner oder ein Remote Share sein.

-l <Ablageort der Protokolldatei>
Dieser Parameter ist optional und gibt den Pfad zur Protokolldatei an. Wenn er nicht gesetzt ist, wird die Protokolldatei im Binärverzeichnis erstellt. Sie müssen über Schreibrechte im Ablageordner verfügen!

-warnaserror
Dieser Parameter ist optional und gibt an, dass jede Nachricht, die in der Regel als Warnungen gemeldet worden wäre, stattdessen als Fehler gemeldet wird. Wenn beispielsweise ein HSP nicht den notwendigen Voraussetzungen entspricht, wird ein entsprechender Rückgabe-/Abbruchwert an die Kommandozeile ausgegeben und das betreffende HSP wird übersprungen.

-?
Dieser Parameter ist optional und zeigt die Hilfe an.

Hinweis

  • Wenn das Ablageverzeichnis oder der Name der Protokolldatei Leerzeichen enthält, müssen Sie die Bezeichnungen in Anführungszeichen setzen.

  • Es werden nur Support Packages berücksichtigt, die direkt im Ablageverzeichnis liegen; Unterverzeichnisse werden ignoriert. D. h. die *.isp-files müssen unmittelbar im Ablageverzeichnis liegen.


Rückgabewerte des Installationsprozesses

Kernaussage
Support Packages automatisiert installieren Protokolldatei
Rückgabewerte des Installationsprozesses

Kernaussage

Die folgende Tabelle zeigt die Rückgabewerte und ihre Beschreibungen:

Code | Beschreibung
0 | Die Installation war erfolgreich.
1 | Die Installation war erfolgreich, es ist ein Neustart erforderlich.
-1 | Die Installation ist fehlgeschlagen.
-2 | Die Installation ist fehlgeschlagen: Das TIA Portal läuft noch.
-3 | Die Installation ist fehlgeschlagen: Eine andere Installation läuft bereits.
-4 | Die Installation ist fehlgeschlagen: Sie haben nicht genügend Rechte. Für die Installation sind Administrationsrechte erforderlich.
-6 | Die Installation ist fehlgeschlagen: Unzureichender Speicherplatz.
-7 | Die Installation ist fehlgeschlagen: Es ist ein Neustart erforderlich bevor die Installation starten kann.


Protokolldatei

Inhalt der Protokolldatei
Support Packages automatisiert installieren Rückgabewerte des Installationsprozesses
Protokolldatei

Inhalt der Protokolldatei

Die Protokolldatei enthält detaillierte Informationen über jede Installation. Wenn die Protokolldatei bereits existiert, wird sie ergänzt. Für jede Installation werden Kopf- und Fußzeilen erstellt, zwischen denen Sie die gewünschten Informationen finden.

Für die folgenden Ereignisse wird ein Eintrag erzeugt:

  • Support Packages, die zwar im Ablageverzeichnis aufgeführt und bei der Installation verfügbar sind, aber aufgrund fehlender Produkte nicht installiert werden konnten. Dem Eintrag in der Protokolldatei ist zu entnehmen, welche Produkte und welche Versionen dieser Produkte fehlen.

  • Support Packages, die nicht erfolgreich installiert werden konnten.

  • Support Packages, die erfolgreich installiert werden konnten.

Für jeden Eintrag wird der Dateiname des HSPs einschließlich der Dateiendung protokolliert.


Migrations-Tool installieren und deinstallieren

Migrations-Tool installieren und deinstallieren

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Systemvoraussetzungen
  • Migrations-Tool installieren
  • Migrations-Tool deinstallieren


Systemvoraussetzungen

Systemvoraussetzungen für das Migrations-Tool
Systemvoraussetzungen

Systemvoraussetzungen für das Migrations-Tool

Zur Verwendung des Migrations-Tools gelten folgende Systemvoraussetzungen:

  • Es sind alle Produkte installiert, mit denen das Quellprojekt erstellt wurde. Folgende Produkte werden unterstützt:

    • Ab STEP 7 V5.4 SP5

    • WinCC V7.5 mit den neuesten Updates

    • Ab WinCC flexible 2008 SP2

    • Integrierte Projekte aus STEP 7 V5.4 und den oben genannten WinCC-Produkten

    • STEP 7 Distributed Safety V5.4 SP5

    • F-Configuration-Pack V5.4 SP5 bis V5.5 SP12

    • SINUMERIK STARTER und Startdrives

    • Ab SIMOTION SCOUT V4.4

      Für die Migration von SIMOTION SCOUT-Projekten wird das SCOUT Migration Tool PlugIn in der zum SCOUT TIA entsprechenden Version benötigt.

  • Es sind alle Optionspakete installiert, welche für das Bearbeiten des STEP 7-Projekts notwendig sind. Dies umfasst beispielsweise alle HSPs für alle im Quellprojekt verwendeten Geräte.

  • Microsoft .Net Framework 4.6.2 ist installiert. Wenn Microsoft .Net Framework nicht installiert ist, wird die benötigte Version mit dem Migrations-Tool installiert.


Migrations-Tool installieren

Vertrieb des Migrations-Tools Vorgehen
Migrations-Tool installieren

Vertrieb des Migrations-Tools

Das Migrations-Tool befindet sich auf der Installations-DVD des TIA Portals im Verzeichnis "Support". Alternativ steht es im Siemens Industry Online Support zum Download bereit. Für manche Produkte sind zusätzliche Plugins für das Migrations-Tool erforderlich, z. B. für SIMATIC Failsafe oder SIMOTION. Die Plugins können Sie ebenfalls im Siemens Industry Online Support herunterladen oder von der Installations-DVD der jeweiligen Produkte installieren.

In der Regel wird das Migrations-Tool ohne das TIA Portal installiert. Da das TIA Portal eine eigene Migrations-Funktion bereits eingebunden hat, ist eine separate Installation des Migrations-Tools nicht notwendig.

Vorgehen

Um das Migrations-Tool zu installieren, gehen Sie folgendermaßen vor:

  1. Laden Sie die Installations-Datei im Siemens Industry Online Support herunter oder verwenden Sie für die Installation die Installations-Datei aus dem Verzeichnis "Support" der Installations-DVD des TIA Portals.

  2. Starten Sie die Installations-Datei.

    Das Setup-Programm für das Migrations-Tool wird geöffnet.

  3. Wählen Sie im ersten Schritt, in welcher Sprache das Setup angezeigt werden soll und klicken Sie auf die Schaltfläche "Weiter".

    Die Seite zur Auswahl der Software-Sprache wird angezeigt.

  4. Da das Migrations-Tool ausschließlich in englischer Sprache geliefert wird, können Sie keine weitere Sprache zur Installation wählen. Klicken Sie daher auf "Weiter", um zum nächsten Schritt zu gelangen.

    Die Seite zur Auswahl der Produkte wird angezeigt.

  5. Das Migrations-Tool besteht lediglich aus einer Software-Komponente. Daher ist das Migrations-Tool bereits ausgewählt. Klicken Sie auf die Schaltfläche "Weiter".

    Die Seite zur Bestätigung der Lizenzbestimmungen wird geladen.

  6. Klicken Sie auf die Einträge in der Liste der Lizenzbedingungen, um die Lizenzbedingungen und Securityhinweise zu lesen. Sind Sie mit allen Lizenzbedingungen einverstanden, aktivieren Sie die Optionskästchen "Ich akzeptiere sämtliche Bedingungen der aufgelisteten Lizenzvereinbarung(en)" und "Ich bestätige hiermit, dass ich die Securityhinweise zum sicheren Betrieb der Produkte gelesen und verstanden habe".

  7. Klicken Sie anschließend auf die Schaltfläche "Weiter".

    Eine Übersicht zur Installation wird angezeigt.

  8. Klicken Sie auf die Schaltfläche "Installieren".

    Die Installation wird mit den angezeigten Einstellungen durchgeführt.

    Nach der Installation des Migrations-Tools ist ein Neustart des Rechners erforderlich.


Migrations-Tool deinstallieren

Vorgehen
Migrations-Tool deinstallieren

Das Migrations-Tool kann über die Systemsteuerung deinstalliert werden.

Vorgehen

Um das Migrations-Tool zu deinstallieren, gehen Sie folgendermaßen vor:

  1. Öffnen Sie die Systemsteuerung.

  2. Doppelklicken Sie in der Systemsteuerung auf den Eintrag "Programme und Funktionen".

    Der Dialog "Programm deinstallieren oder ändern" wird geöffnet.

  3. Wählen Sie im Dialog "Programm deinstallieren oder ändern" den Eintrag für das Migrations-Tool aus und klicken Sie auf die Schaltfläche "Deinstallieren".

    Es erscheint eine Sicherheitsabfrage.

  4. Bestätigen Sie die Sicherheitsabfrage, indem Sie auf die Schaltfläche "Ja" klicken.

    Das Setup-Programm startet.

  5. Wählen Sie die Installationssprache aus und klicken Sie auf "Weiter".

  6. Wählen Sie das Migrations-Tool zur Deinstallation aus und klicken Sie auf "Weiter".

  7. Klicken Sie auf "Deinstallieren".

    Das Migrations-Tool wird deinstalliert.

  8. Um das Setup-Programm zu beenden, klicken Sie auf "Beenden".


TIA Projekt-Server installieren und deinstallieren

TIA Projekt-Server installieren und deinstallieren

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hinweise zur Installation des Projekt-Servers
  • Projekt-Server installieren
  • Projekt-Server deinstallieren


Hinweise zur Installation des Projekt-Servers

Einführung Installation des Multiuser-Servers mit dem TIA Portal Installation des Multiuser-Servers als Standalone-Installation Gleiche TIA Portal-Versionen bei der Installation Installationspfad Installation eines neueren Multiuser-Servers Virenscanner Unterstützte Virtualisierungsplattformen
Projekt-Server installieren Projekt-Server deinstallieren
Hinweise zur Installation des Projekt-Servers

Einführung

Die Installation des Multiuser-Servers ermöglicht Ihnen, die Funktionalität des Multiuser Engineering zu nutzen.

Sie können den Multiuser-Server wie folgt installieren:

  • Zusammen mit der Installation des TIA Portals.

  • Als Standalone-Installation über einen eigenständigen Installationsprozess ohne TIA Portal.

Hinweis

Für die Serverinstallation werden Administratorrechte benötigt.

Installation des Multiuser-Servers mit dem TIA Portal

Die Installation des Multiuser-Servers erfolgt zusammen mit der Installation folgender TIA Portal-Produkte:

  • SIMATIC STEP 7 Basic

  • SIMATIC STEP 7 Professional

  • SIMATIC WinCC Basic

  • SIMATIC WinCC Comfort/Advanced

  • SIMATIC WinCC Professional

Der Multiuser-Server ist in der Produktauswahl teilweise per Voreinstellung aktiviert und wird dann mitinstalliert. Überprüfen Sie die Einstellung während der Installation des TIA Portals. Sie finden die jeweilige Voreinstellung für den Multiuser Server während des Setups bei der Produktauswahl im Verzeichnis "Options". Wählen Sie hier durch das Setzen oder entfernen des Häkchens aus, ob der Multiuser-Server während der Installation des TIA Portals mitinstalliert werden soll oder nicht.

Installation des Multiuser-Servers als Standalone-Installation

Die Installation des Multiuser-Servers kann auch als Standalone-Installation durchgeführt werden.

Eine Beschreibung zur automatisierten Installation finden Sie auch auf der Produkt-DVD im Verzeichnis "Documents\Readme\<Sprachverzeichnis>".

Gleiche TIA Portal-Versionen bei der Installation

Achten Sie bei der Installation von TIA Portal-Produkten auf den verschiedenen Clients darauf, dass alle Teilnehmer für die Installation die gleichen Stände der Software-Produkte verwenden.

Wenn Sie also z. B. STEP 7 Professional, WinCCAdvanced und Safety sowie den Multiuser Server mit der Version Vx.y installiert haben, müssen alle anderen Teilnehmer von Team Engineering ebenfalls diese Software in identischen Versionen installiert haben.

Die Installation von Service Packs und Updates muss für alle Produkte zu einem gemeinsamen Zeitpunkt erfolgen.

Installationspfad

Verwenden Sie keine Unicode-Zeichen (z. B. chinesische Schriftzeichen) im Installationspfad.

Installation eines neueren Multiuser-Servers

Beachten Sie, dass Sie zuerst den neueren Multiuser-Server installieren und danach erst die ältere Version des Multiuser-Servers deinstallieren.

Mit dieser Vorgehensweise stellen Sie sicher, dass die für den Server vorhandenen Benutzerberechtigungen auch für den neuen Server übernommen werden können. Werden alle vorhandenen Multiuser-Server vor der Neuinstallation komplett gelöscht, gehen auch die Benutzereinstellungen verloren und müssen neu erstellt werden.

Virenscanner

Während der Installation ist es notwendig, dass auf bereits installierte Dateien lesend und schreibend zugegriffen werden kann. Einige Virenscanner verhindern dies. Daher wird empfohlen, während der Installation des Multiuser-Servers Virenscanner zu deaktivieren und erst danach wieder zu aktivieren.

Unterstützte Virtualisierungsplattformen

Sie können den Multiuser-Server ebenso wie das TIA Portal auch in einer virtuellen Maschine installieren.

Verwenden Sie dazu eine der folgenden Virtualisierungsplattformen in der angegebenen oder einer neueren Version:

  • VMware vSphere Hypervisor (ESXi) 6.5

  • VMware Workstation 12.5.7

  • VMware Player 12.5.7

  • Microsoft Hyper-V Server 2016

Für die Installation einer Visualisierungsplattform gelten die gleichen Voraussetzungen wie für die Installation des TIA Portals.


Projekt-Server installieren

Einleitung Regeln für die Installation Voraussetzungen für die Installation Projekt-Server mit dem TIA Portal installieren Ergebnis Projekt-Server standalone installieren Ergebnis
Hinweise zur Installation des Projekt-Servers Projekt-Server deinstallieren
Projekt-Server installieren

Einleitung

Der Projekt-Server kann im Rahmen der Installation des TIA Portals oder auch standalone installiert werden. Wird der Projekt-Server mit dem TIA Portal mitinstalliert, so wird immer auch die dem TIA Portal entsprechende Version des Projekt-Servers installiert.

Eine Beschreibung zur automatisierten Installation finden Sie auch auf der Produkt-DVD im Verzeichnis "Documents\Readme\<Sprachverzeichnis>".

Hinweis

Neuinstallation vor Deinstallation

Beachten Sie, dass Sie zuerst den neueren Projekt-Server installieren und danach erst die ältere Version des Projekt-Servers deinstallieren.

Mit dieser Vorgehensweise stellen Sie sicher, dass die für den Server vorhandenen Benutzerberechtigungen auch für den neuen Server übernommen werden können. Werden alle vorhandenen Projekt-Server vor der Neuinstallation komplett gelöscht, gehen auch die Benutzereinstellungen verloren und müssen neu erstellt werden.

Regeln für die Installation

Auf einem Computer können mehrere Versionen des Projekt-Servers installiert sein, die unterschiedliche Projektversionen des TIA Portals nutzen können.

Nutzbare Projektversionen:

Versionen des Projekt-Servers | Versionen des TIA Portals
Server V16 | V16, V15.1, V15 und V14
Server V15.1 | V15.1, V15 und V14
Server V15 | V15 und V14
Server V14 | V14

Beachten Sie jedoch, dass jede Version des TIA Portals und des Projekt-Servers jeweils nur über die in dieser Version enthaltene Funktionalität verfügt.

Multiuser Engineering führt kein Upgrade der Projektversionen durch.

Voraussetzungen für die Installation

Für die Installation des Projekt-Servers gelten die gleichen Voraussetzungen wie für die Installation des TIA Portals.

Projekt-Server mit dem TIA Portal installieren

Für die Installation gehen Sie folgendermaßen vor:

  1. Beachten Sie die Voraussetzungen für die Installation des ausgewählten Softwarepakets.

  2. Starten Sie das Setup-Programm des gewünschten Produkts durch Einlegen des Installationsdatenträgers in das entsprechende Laufwerk.

  3. Wählen Sie die gewünschten Einstellungen aus und klicken Sie auf die Schaltfläche "Installieren".

  4. Vergewissern Sie sich, dass der Projekt-Server in der Produktauswahl angewählt ist und folgen Sie den Hinweisen in den Setup-Dialogen.

Ergebnis

Der Projekt-Server wurde auf Ihrem Computer zusammen mit dem TIA Portal installiert.

Projekt-Server standalone installieren

Für die Installation gehen Sie folgendermaßen vor:

  1. Beachten Sie die Voraussetzungen für die Installation des Projekt-Servers.

  2. Starten Sie den Setup für die Standalone-Installation des Projekt-Servers durch Doppelklick auf die selbstextrahierende Exe-Datei "TIA_Portal_Projekt_Server_V<x.y>.exe". Sie finden diese Datei im "Support"-Verzeichnis auf der jeweiligen Produkt-DVD.

  3. Wählen Sie die gewünschten Einstellungen aus und klicken Sie auf die Schaltfläche "Installieren".

  4. Folgen Sie den Anweisungen in den Setup-Dialogen.

Ergebnis

Der Projekt-Server wurde auf Ihrem Computer installiert.


Projekt-Server deinstallieren

Einleitung Voraussetzungen für die Deinstallation Projekt-Server deinstallieren Ergebnis
Hinweise zur Installation des Projekt-Servers Projekt-Server installieren
Projekt-Server deinstallieren

Einleitung

Der Projekt-Server kann über die Systemsteuerung deinstalliert werden.

Hinweis

Neuinstallation vor Deinstallation

Beachten Sie, dass Sie zuerst den neueren Projekt-Server installieren und danach erst die ältere Version des Projekt-Servers deinstallieren.

Mit dieser Vorgehensweise stellen Sie sicher, dass die für den Server vorhandenen Benutzerberechtigungen auch für den neuen Server übernommen werden können. Werden alle vorhandenen Projekt-Server vor der Neuinstallation komplett gelöscht, gehen auch die Benutzereinstellungen verloren und müssen neu erstellt werden.

Voraussetzungen für die Deinstallation

Auf Ihrem Computer ist eine Projekt-Serverinstallation vorhanden.

Projekt-Server deinstallieren

Für die Deinstallation gehen Sie vor wie folgt:

  1. Öffnen Sie die Systemsteuerung.

  2. Doppelklicken Sie in der Systemsteuerung auf den Eintrag "Software".

    Der Dialog "Software" wird geöffnet.

  3. Wählen Sie im Dialog "Software" den Eintrag für den "Projekt-Server" aus und klicken Sie auf die Schaltfläche "Entfernen".

    Es erscheint eine Sicherheitsabfrage.

  4. Bestätigen Sie die Sicherheitsabfrage, indem Sie auf die Schaltfläche "Deinstallieren" klicken.

Ergebnis

Der Projekt-Server wurde auf ihrem Computer deinstalliert.