Technologiefunktionen

Beispiele Siehe auch Verlauf Extras
Technologiefunktionen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hinweise zu S7-1500 Motion Control (S7-1500, S7-1500T)
  • Hinweise zu weiteren Technologiefunktionen (S7-1500)
  • Hinweise zu Technologiefunktionen (S7-1200)
  • Hinweise zu Technologiefunktionen (S7-300, S7-400)
  • SIMATIC STEP 7 Easy Motion Control
  • SIMATIC STEP 7 PID Professional


Hinweise zu S7-1500 Motion Control (S7-1500, S7-1500T)

Beispiele Siehe auch Verlauf Extras
Technologie-Alarme 900-902 Hochrüsten von Projekten in die TIA Portal-Version V16 Verhalten des Modulozykluszählers beim Referenzieren mit "MC_Home" Verwendung des Datentyps "DX_TEL_SyncOp" bei PLC-übergreifendem Gleichlauf Verzögerungszeiten an der Leitachse und an der virtuellen Folgeachse manuell konfigurieren Berechnung des Schleppfehlers Performance der Anwendertransformation mit Dynamikadaption (S7-1500T) Die maximale Bandbreite der CPU ist bei Aufzeichnungen mit dem Kinematik-Trace begrenzt (S7-1500T) Überschleifen zwischen Bahnbewegungen und synchronen "Punkt-zu-Punkt"-Bewegungen (sPTP-Bewegungen) (S7-1500T) Änderung des Overrides bei synchronen "Punkt-zu-Punkt"-Bewegungen (sPTP-Bewegung) (S7-1500T) Verwenden des Überschleifens bei Kinematikbewegungen (S7-1500T) Verwendung der Motion Control Anweisung "MC_TrackConveyorBelt" mit der Technologieversion V5.0 (S7-1500T)
Hinweise zu S7-1500 Motion Control
S7-1500, S7-1500T

Technologie-Alarme 900-902

Im Gegensatz zum dokumentierten Verhalten wird bei den Technologie-Alarmen 900 und 901 als Alarmreaktion der empfangene Leitwert als ungültig erkannt. Der Technologie-Alarm 902 beinhaltet keine Alarmreaktion.

Die Technologie-Alarme 900 und 901 werden im Diagnosepuffer angezeigt.

Nr. | Reaktion | Fehlerbit | Warnungsbit | Restart | Diagnosepuffer | Alarmtext
900 | Leitwert ungültig setzen | X2 | - | - | X | Leitwerte ungültig.
901 | Leitwert ungültig setzen | X2 | - | - | X | Datenübertragungsfehler.
902 | Keine Reaktion | - | X2 | - | - | Leitwertgenauigkeit begrenzt.

Einen Technologie-Alarm 900 können Sie mit einem "MC_Reset"-Auftrag mit "Restart" = FALSE quittieren. Ein Restart ist nicht erforderlich.

Der Technologie-Alarm 900 wird mit folgendem Alarmtext angezeigt:

Alarmtext | Abhilfe
Leitwerte ungültig. | Stellen Sie eine höhere Toleranzzeit ein (<TO>.Parameter.ToleranceTimeExternalLeadingValueInvalid). Prüfen Sie die Verbindung der verschalteten Komponenten. Stellen Sie sicher, dass keine Kommunikationsstörung vorliegt. Stellen Sie sicher, dass sich die beteiligten CPUs im Betriebszustand RUN befinden.

Der Technologie-Alarm 901 wird mit folgendem Alarmtext angezeigt:

Alarmtext |  | Abhilfe
Datenübertragungsfehler. |  |
 | Ungültige Version | Prüfen Sie die Kommunikation.
 | Ungültiger Modulostartwert
 | Ungültige Modulolänge
 | Lebenszeichenfehler
 | Ungültige Position | Prüfen Sie den Leitwert der Leitachse auf der anderen CPU.
 | Ungültige Geschwindigkeit
 | Ungültige Beschleunigung

Hochrüsten von Projekten in die TIA Portal-Version V16

Durch Änderungen im Projekt-Ablageformat in der TIA Portal-Version V16 ist eine Konvertierung von bestehenden Projekten notwendig. Je nach Größe des Projekts kann eine Konvertierung sehr viel Zeit in Anspruch nehmen. Die Gesamtdauer der Konvertierung kann zwischen mehreren Minuten bis zu über einer Stunde betragen.

Verhalten des Modulozykluszählers beim Referenzieren mit "MC_Home"

Im Gegensatz zum dokumentierten Verhalten verhält sich der Modulozykluszähler beim direkten relativen Referenzieren mit "Mode" = 1, 12 und bei Absolutwertgeberjustage (relativ) mit "Mode" = 6 wie beim direkten absoluten Referenzieren mit "Mode" = 0. Die Zählerwerte der Modulozyklen ändern sich beim Referenzieren und der Absolutwertgeberjustage mit den genannten Modi wie folgt:

Aktion | Beschreibung
Absolutwertgeberjustage mit "Mode" = 6 | Als Modulowert wird die kürzeste Distanz zwischen aktueller und neuer Position gewertet. Abhängig von der Distanz kann der Modulozykluszähler gleich bleiben, sich um 1 erhöhen oder sich um 1 verringern.
Direktes Referenzieren relativ mit "Mode" = 1, 12 | Als Modulowert wird die kürzeste Distanz zwischen aktueller und neuer Position gewertet. Abhängig von der Distanz kann der Modulozykluszähler gleich bleiben, sich um 1 erhöhen oder sich um 1 verringern.

Verwendung des Datentyps "DX_TEL_SyncOp" bei PLC-übergreifendem Gleichlauf

Für den PLC-übergreifenden Gleichlauf werden Output- und Input-Variablen mit dem Datentyp "DX_TEL_SyncOp" an den Anfangsadressen des Transferbereichs angelegt. Wenn der Datentyp "DX_TEL_SyncOp" nicht zugeordnet werden kann, wurde dieser bei der letzten Übersetzung gelöscht.

Nicht verwendete Datentypen werden bei der Übersetzung gelöscht. Um den Datentyp "DX_TEL_SyncOp" wiederherzustellen, fügen Sie ein Technologieobjekt V5.0 hinzu. Nach der Verwendung des Datentyps in der PLC-Variable kann das Technologieobjekt wieder gelöscht werden.

Verzögerungszeiten an der Leitachse und an der virtuellen Folgeachse manuell konfigurieren

Wenn Sie die Verzögerungszeit der Leitachse in den Leitwerteinstellungen erhöhen, führt das zu einer Verringerung der Extrapolationszeit am Leitachsstellvertreter bzw. zu einer Erhöhung der Interpolationszeit des verteilten Leitwerts am Leitachsstellvertreter. Der entstehende Fehler bei der Extrapolation in den Beschleunigungs- und Verzögerungsphasen des Leitwerts wird dadurch reduziert.

Wenn Sie die Verzögerungszeit am Leitachsstellvertreter erhöhen, führt das zu einer Erhöhung der Extrapolationszeit bzw. zu einer Verringerung der Interpolationszeit.

Berechnung des Schleppfehlers

Der Schleppfehler ist die Differenz zwischen der Soll- und Istposition bezogen auf die Anschaltung der Achse am Antrieb. Im Gegensatz zum dokumentierten Verhalten sind die Übertragungszeiten des Sollwerts von der Steuerung zum Antrieb und des Positionsistwerts vom Antrieb zur Steuerung nicht Bestandteil des Schleppfehlers. Der Wert des Schleppfehlers ist damit nicht gleich der Differenz aus der in der Steuerung vorliegenden Sollposition minus der vorliegenden Istposition.

Performance der Anwendertransformation mit Dynamikadaption (S7-1500T)

Mit der Technologieversion V5.0 entstehen bei der Anwendertransformation größere Laufzeiten des MC-Interpolator [OB92]. Mit größeren Laufzeiten des MC-Interpolator [OB92] verlängern sich die Laufzeiten von Organisationsbausteinen mit geringer Priorität.

Die maximale Bandbreite der CPU ist bei Aufzeichnungen mit dem Kinematik-Trace begrenzt (S7-1500T)

Bei Überschreitung der maximalen Bandbreite können nicht alle Signale einer Aufzeichnung mit dem Kinematik-Trace aufgezeichnet und ausgewertet werden.

Berücksichtigen Sie die Systemgrenzen der CPU (maximal 16 Signale).

Für die verschiedenen Objekte werden folgende Signale benötigt:

Objekt | Verwendete Signale
TCP und Kinematik (abhängig von der Kinematik) | 4-8
TCP (abhängig von der Kinematik) | 2-4
OCS 1 (abhängig von der Kinematik) | 2-6
OCS 2 (abhängig von der Kinematik) | 2-6
OCS 3 (abhängig von der Kinematik) | 2-6

Deaktivieren Sie aktive Signale unter "Technologieobjekt > Kinematik-Trace > Konfiguration > Aufzeichnungen".

Überschleifen zwischen Bahnbewegungen und synchronen "Punkt-zu-Punkt"-Bewegungen (sPTP-Bewegungen) (S7-1500T)

Wenn Sie das Überschleifen von einer Bahnbewegung zu einer sPTP-Bewegung verwenden, kann vorkommen das nicht überschliffen wird oder das Überschleifsegment wesentlich verkleinert wird.

Bei Verwendung des Überschleifens von Bahnbewegungen und sPTP-Bewegungen stellen Sie die Bahndynamik möglichst hoch ein:

  • Ruck

  • Beschleunigung

Änderung des Overrides bei synchronen "Punkt-zu-Punkt"-Bewegungen (sPTP-Bewegung) (S7-1500T)

Bei Änderung des Overrides kann sich der Verlauf der Bewegung des Werkzeugarbeitspunkts (TCP) einer sPTP-Bewegung verändern.

Wenn die Bewegungskontur des TCP beibehalten werden soll, verfahren Sie die Kinematik mit geringer Änderung des Overrides.

Verwenden des Überschleifens bei Kinematikbewegungen (S7-1500T)

Beim Überschleifen kann es zu einer Dynamiküberhöhung an den Kinematikachsen kommen.

Verwendung der Motion Control Anweisung "MC_TrackConveyorBelt" mit der Technologieversion V5.0 (S7-1500T)

Die Verwendung der Motion Control Anweisung "MC_TrackConveyorBelt" ist mit der Technologieversion V5.0 nicht möglich.


Hinweise zu weiteren Technologiefunktionen (S7-1500)

Beispiele Siehe auch Verlauf Extras
Parameter der Technologieobjekte in TIA Portal Openness S_USSI an S7‑1500 PtP-Module mit CM 1243-5 PROFIBUS Master PID_Temp auf CPU 1500 V1.7
Hinweise zu weiteren Technologiefunktionen
S7-1500

Parameter der Technologieobjekte in TIA Portal Openness

Sie finden eine Auflistung der verfügbaren Technologieobjekt-Parameter in der Produktinformation "Parameter der Technologieobjekte in TIA Portal Openness" im Internet.

S_USSI an S7‑1500

Beachten Sie folgendes, falls Sie die Anweisung S_USSI der dezentralen Peripherie ET 200S 1SI an einer S7‑1500 einsetzen.

Der Parameter ANZ zeigt auch im Fehlerfall den Wert 0.

Prüfen Sie, falls die CPU durch die Anweisung S_USSI in STOP geschaltet wird, alle beim Parameter ANZ aufgelisteten Fehlermöglichkeiten.

PtP-Module mit CM 1243-5 PROFIBUS Master

Beim Einsatz der PtP-Module CM PtP RS232 BA, CM PtP RS422/485 BA, CM PtP RS232 HF, CM PtP RS422/485 HF und CM PtP mit einem CM 1243-5 PROFIBUS Master mit einer Firmware ≤ V1.3.4 müssen Sie im Instanz-DB der Anweisungen folgende Einstellungen treffen:

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240

PID_Temp auf CPU 1500 V1.7

Beachten Sie beim Einsatz von PID_Temp auf einer CPU 1500 mit Firmware-Version V1.7 folgendes:

  • Die in PID_Temp integrierte Totzone darf auf CPU 1500 V1.7 nicht genutzt werden.

    Ändern Sie die Vorbelegung 0.0 der zugehörigen Parameter Retain.CtrlParams.Heat.DeadZone und Retain.CtrlParams.Cool.DeadZone nicht.

  • Ist bei einem Regler mit aktivierter Kühlung und PID-Parameterumschaltung (Config.ActivateCooling = TRUE, Config.AdvancedCooling = TRUE) der Kühlausgang aktiv (PidOutputSum < 0.0, OutputCool <> 0.0) während eine "Erstoptimierung Kühlen" gestartet wird (Mode = 1, Heat.EnableTuning = FALSE, Cool.EnableTuning = TRUE), bricht diese mit Fehler ErrorBits = 16#0040_0000 ab.

    • Verwenden Sie in diesem Fall die "Nachoptimierung Kühlen" (Mode = 2, Heat.EnableTuning = FALSE, Cool.EnableTuning = TRUE)

    oder

    • wechseln Sie vor dem Start der Erstoptimierung in den Handbetrieb mit einem Handwert größer 0.0 (Mode = 4, ManualValue ≥ 0.0).

Beide Einschränkungen bestehen ab Firmware-Version V1.8 nicht mehr.


Hinweise zu Technologiefunktionen (S7-1200)

Beispiele Siehe auch Verlauf Extras
Antriebs- bzw. Geberwerte bei der Projektierung (offline) automatisch übernehmen ErrorID 16#820D PtP-Module mit CM 1243-5 PROFIBUS Master
Hinweise zu Technologiefunktionen
S7-1200

Antriebs- bzw. Geberwerte bei der Projektierung (offline) automatisch übernehmen

Bei der Anbindung eines SINAMICS V90 PN über HSP werden nicht alle Konfigurationsparameter automatisch übernommen. Deaktivieren Sie die Option "Antriebswerte bei der Projektierung (offline) automatisch übernehmen" und übernehmen Sie manuell die Konfigurationsparameter des Antriebs und des Gebers in die Konfiguration des Technologieobjekts.

ErrorID 16#820D

ErrorID | ErrorInfo | Beschreibung | Abhilfe
16#820D |  | Technologieobjekt befindet sich im Restart
 | 16#0001 | - | Fehler mit der Anweisung "MC_Reset" quittieren und ggf. Auftrag neu starten

PtP-Module mit CM 1243-5 PROFIBUS Master

Beim Einsatz der PtP-Module CM PtP RS232 BA, CM PtP RS422/485 BA, CM PtP RS232 HF, CM PtP RS422/485 HF und CM PtP mit einem CM 1243-5 PROFIBUS Master mit einer Firmware ≤ V1.3.4 müssen Sie im Instanz-DB der Anweisungen folgende Einstellungen treffen:

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240


Hinweise zu Technologiefunktionen (S7-300, S7-400)

Beispiele Siehe auch Verlauf Extras
Parametrierung FM x51 und FM x52 Programmierung FM x50-1, FM x51 und FM x52 Migration IM 174
Hinweise zu Technologiefunktionen
S7-300, S7-400

Parametrierung FM x51 und FM x52

Entgegen den Angaben in der Online-Hilfe werden bei einer Änderung des Maßsystems die bereits eingegebenen Parameterwerte nicht in das neue Maßsystem umgerechnet.

Programmierung FM x50-1, FM x51 und FM x52

Die in der Online-Hilfe zu den Anweisungen angegebenen "Anfangswerte" in den Parametertabellen entsprechen dem "Defaultwert" in der SW-Oberfläche der Anwenderprogrammierung.

Migration IM 174

Bei der Migration von Projekten mit IM 174 wird die Parametrierung der IM 174 auf Defaultwerte gesetzt. Die IM 174 muss nach der Migration in jedem Fall neu parametriert werden.