WinCC

Beispiele Siehe auch Verlauf Extras
WinCC

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Security-Hinweise
  • Datenschutz
  • Hinweise zur Benutzung
  • Migration
  • Engineering System
  • Übergreifende Funktionen
  • Übersetzen und Laden
  • Runtime
  • Bediengeräte
  • Optionen


Security-Hinweise

Security-Hinweise Passwörter Integrierte Webserver Kommunikation über Ethernet Verwendung von SSL 3.0 Netzwerkeinstellungen
Security-Hinweise

Security-Hinweise

Siemens bietet Produkte und Lösungen mit Industrial Security-Funktionen an, die den sicheren Betrieb von Anlagen, Lösungen, Maschinen, Geräten und/oder Netzwerken unterstützen.

Um Anlagen, Systeme, Maschinen und Netzwerke gegen Cyber-Bedrohungen zu sichern, ist es erforderlich, ein ganzheitliches Industrial Security-Konzept zu implementieren (und kontinuierlich aufrechtzuerhalten), das dem aktuellen Stand der Technik entspricht. Die Produkte und Lösungen von Siemens formen nur einen Bestandteil eines solchen Konzepts.

Der Kunde ist dafür verantwortlich, unbefugten Zugriff auf seine Anlagen, Systeme, Maschinen und Netzwerke zu verhindern. Systeme, Maschinen und Komponenten sollten nur mit dem Unternehmensnetzwerk oder dem Internet verbunden werden, wenn und soweit dies notwendig ist und entsprechende Schutzmaßnahmen (z.B. Nutzung von Firewalls und Netzwerksegmentierung) ergriffen wurden.

Zusätzlich sollten die Empfehlungen von Siemens zu entsprechenden Schutzmaßnahmen beachtet werden. Weitergehende Informationen über Industrial Security finden Sie unter:

http://www.siemens.com/industrialsecurity

Die Produkte und Lösungen von Siemens werden ständig weiterentwickelt, um sie noch sicherer zu machen. Siemens empfiehlt ausdrücklich, Aktualisierungen durchzuführen, sobald die entsprechenden Updates zur Verfügung stehen und immer nur die aktuellen Produktversionen zu verwenden. Die Verwendung veralteter oder nicht mehr unterstützter Versionen kann das Risiko von Cyber-Bedrohungen erhöhen.

Um stets über Produkt-Updates informiert zu sein, abonnieren Sie den Siemens Industrial Security RSS Feed unter:

http://www.siemens.com/industrialsecurity

Passwörter

In WinCC sind verschiedene Passwörter voreingestellt. Aus Sicherheitsgründen sollten Sie diese Passwörter ändern.

  • Bei Bediengeräten der Version 12 ist für den Sm@rtServer und für den integrierten Webserver das Passwort "100" voreingestellt. Bei Bediengeräten ab der Version 13 ist kein Passwort voreingestellt.

  • Für den Benutzer "Administrator" ist das Passwort "administrator" voreingestellt.

Integrierte Webserver

Auf einem PC ist es in Runtime möglich auf die HTML-Seiten zuzugreifen, obwohl die Option "HTML-Seiten" deaktiviert ist. Durch die Installation werden auf dem PC immer die Standardseiten des Webservers abgelegt. Vergeben Sie ein Administrator-Passwort, das den unbefugten Zugriff auf die Seiten verhindert.

Kommunikation über Ethernet

Bei Ethernet-basierter Kommunikation ist der Endanwender für die Sicherheit seines Datennetzes selbst verantwortlich, da z. B. bei gezielten Angriffen, die zur Überlast des Gerätes führen, die Funktionsfähigkeit nicht garantiert ist.

Verwendung von SSL 3.0

Aus Security-Gründen ist die Verwendung des Protokolls SSL 3.0 auf Comfort Panels und in Runtime Advanced nicht empfohlen. Auf Comfort Panels ist die Verwendung des Protokolls SSL 3.0 standardmäßig deaktiviert. Wenn Sie dennoch die Verwendung von SSL 3.0 aktiveren möchten, wählen Sie im Internet Explorer oder im "Start Center > Settings" unter „Internet Options > Advanced > Use SSL 3.0“.

Für RT Advanced kann die Verwendung von SSL 3.0 im Internet Explorer oder über Systemsteuerung unter „Internetoptionen > Erweitert“ durch Deaktivieren der Option „SSL 3.0 verwenden“ abgeschaltet werden.

Netzwerkeinstellungen

Die folgenden Tabellen zeigen die Netzwerkeinstellungen des jeweiligen Produkts, die Sie zur Analyse der Netzwerksicherheit und zur Konfiguration von externen Firewalls benötigten:

WinCC Professional (ohne Simulation)
Name | Port-Nummer | Transport-Protokoll | Richtung | Funktion | Beschreibung
ALM | 4410* | TCP | Inbound, Outbound | Lizenz-Service | Dieser Dienst stellt die komplette Funktionalität für Software-Lizenzen zur Verfügung und wird sowohl vom Automation License Manager als auch von allen lizenzrelevanten Softwareprodukten verwendet.
HMI Load | 1033 | TCP | Outbound | HMI Load (RT Basic) | Dieser Dienst wird verwendet, um Images und Konfigurationsdaten auf Basic Panels zu übertragen.
HMI Load | 2308 | TCP | Outbound | HMI Load (RT Advanced) | Dieser Dienst wird verwendet, um Images und Konfigurationsdaten auf Panels zu übertragen.
RPC | ** | UDP | Inbound, Outbound | Client / server & ES communication (CCAgent) | Dieser Dienst wird von WinCC Professional und WinCC Runtime Professional verwendet.
* Standard-Port, der durch Anwenderkonfiguration geändert werden kann ** Port wird automatisch vergeben

WinCC Simulation für Basic Panels
Name | Port-Nummer | Transport-Protokoll | Richtung | Funktion | Beschreibung
HMI Load | 1033 | TCP | Inbound | HMI Load (RT Basic) | Dieser Dienst wird verwendet, um Images und Konfigurationsdaten auf Basic Panels zu übertragen.
EtherNet/IP | 44818 | TCP | Outbound | Ethernet/IP-Kanal | Das Ethernet/IP-Protokoll wird für Verbindungen zu Allen Bradley PLCs verwendet.
 | 2222 | UDP | Inbound | Ethernet/IP-Kanal | Das Ethernet/IP-Protokoll wird für Verbindungen zu Allen Bradley PLCs verwendet.
Modbus TCP | 502 | TCP | Outbound | Modbus TCP-Kanal | Das Modbus TCP-Protokoll wird für Verbindungen zu Schneider PLCs verwendet.
RFC 1006 | 102 | TCP | Outbound | S7-Kanal | Kommunikation zum S7-Controller über Ethernet / PROFINET
Mitsubishi MC | 5002 | TCP | Outbound | Mitsubishi MC-Kanal | Das Mitsubishi-Protokoll wird für Verbindungen zu Mitsubishi PLCs verwendet.

WinCC Simulation für Panels und Runtime Advanced
Name | Port-Nummer | Transport-Protokoll | Richtung | Funktion | Beschreibung
DCP | --- | Ethernet | Outbound | PROFINET | Das DCP-Protokoll (Discovery and basic Configuration Protocol) wird von PROFINET verwendet und stellt die Basisfunktionalität zum Auffinden und Konfigurieren von PROFINET-Geräten zur Verfügung.
LLDP | --- | Ethernet | Inbound, Outbound | PROFINET | Das LLDP-Protokoll (Link Layer Discover Protocol ) wird von PROFINET zur Topologie-Erkennung verwendet.
SMTP | 25 | TCP | Outbound | SMTP Communication | Dieser Dienst wird von WinCC Runtime Advanced zum Versenden von E-Mails verwendet.
HTTP | 80* | TCP | Inbound | HTTP Channel Server HTML pages | Der Webserver ist nur vorhanden, wenn HTTP Channel Server bzw. HTML pages aktiviert sind. Der verwendete Port kann sich aufgrund von automatisch gewählten Einstellungen unterscheiden.
RFC 1006 | 102 | TCP | Outbound | S7-Kanal | Kommunikation zum S7-Controller über Ethernet / PROFINET
NTP | 123 | UDP | Outbound | Uhrzeit-synchronisation | Das NTP-Protokoll (Network Time Protocol) wird in IP-basierten Netzwerken zur Uhrzeitsynchronisation verwendet.
SNMP | 161 | UDP | Outbound | PROFINET | Die SNMP Client-Funktionalität wird von STEP 7 verwendet, um Statusinformationen von PROFINET-Geräten auszulesen.
HMI Load | 2308 | TCP | Outbound | HMI Load (RT Advanced) | Dieser Dienst wird verwendet, um Images und Konfigurationsdaten auf Panels zu übertragen.
HTTPS | 443* | TCP | Inbound | HTTP Channel Server HTML pages | Der Webserver mit HTTPS-Protokoll ist nur vorhanden, wenn HTTP Channel Server bzw. HTML pages aktiviert sind. Der verwendete Port kann sich aufgrund von automatisch gewählten Einstellungen unterscheiden.
VNC Server | 5900* | TCP | Inbound | Sm@rtServer | Dieser Dienst ist nur vorhanden, wenn Sm@rtService aktiviert wird.
 | 5800* | TCP | Inbound | Sm@rtServer | Dieser Dienst ist nur vorhanden, wenn Sm@rtService aktiviert wird.
VNC Client | 5500 | TCP | Outbound | Sm@rtServer | Dieser Dienst ist nur vorhanden, wenn Sm@rtService aktiviert wird.
* Standard-Port, der durch Anwenderkonfiguration geändert werden kann

WinCC Simulation für Runtime Professional
Name | Port-Nummer | Transport-Protokoll | Richtung | Funktion | Beschreibung
RPC | ** | UDP | Inbound, Outbound | Client / server & ES communication (CCAgent) | Dieser Dienst wird von WinCC Professional und WinCC RT Professional verwendet.
RPC | ** | UDP | Inbound, Outbound | Client / server communication (CCEServer / CCEClient) | Dieser Dienst wird von WinCC Runtime Professional verwendet.
HTTP | 80 | TCP | Inbound, Outbound | Client / server communication (CCEServer / CCEClient) | Dieser Dienst wird von WinCC Runtime Professional verwendet.
RFC 1006 | 102 | TCP | Outbound | S7-Kanal | Kommunikation zum S7-Controller über Ethernet / PROFINET
OPC UA | 4840 | TCP | Inbound | OPC UA Server | Dieser Dienst wird zur primären Kommunikation über OPC UA benötigt. Er wird bei der Installation aktiviert und konfiguriert.
OPC UA discovery | 52601 | TCP | Inbound | OPC UA Server | Dieser Dienst liefert Informationen über installierte OPC-Server. Er wird durch den OPC UA Server installiert und konfiguriert.
DCOM | 135 | TCP | Inbound | OPC Server | Dieser Dienst ist Teil des Betriebssystems Windows. Da die Kommunikation über OPC (DA) auf DCOM basiert, wird dieser Dienst zur Initialisierung von OPC (DA) Verbindungen benötigt.
DCOM | ** | TCP | Inbound | OPC Server | Die Kommunikation über OPC (DA) basiert auf DCOM und verwendet unspezifizierte vom System vergebene Ports. Dies sollte bei der Verwendung von OPC (DA) und der Erstellung von Regeln für die Firewall berücksichtigt werden.
HTTP | 80 | TCP | Inbound | OPC Server | Dieser Dienst wird zur primären Kommunikation über OPC XML benötigt. Er wird bei der Installation aktiviert und konfiguriert.
NetBIOS | 137 | UDP | Inbound | OPC Server | Dieser Dienst ist Teil des Betriebssystems Windows. Der Zugriff auf diesen Dienst wird z. B. von OPC-Scout zum Browsen benötigt.
NetBIOS | 138 | UDP | Inbound | OPC Server | Dieser Dienst ist Teil des Betriebssystems Windows. Der Zugriff auf diesen Dienst wird z. B. von OPC-Scout zum Browsen benötigt.
SNMP | 161 | UDP | Outbound | SNMP OPC Server | Dieser Dienst wird vom SNMP OPC Server verwendet, um Daten auf z. B. Netzlaufwerken zu ändern oder abzufragen.
SNMP Traps | 162 | UDP | Inbound | SNMP OPC Server | Dieser Dienst wird vom SNMP OPC Server verwendet, um Ereignisse von z. B. Netzlaufwerken abzufragen.
** Port wird automatisch vergeben

PROFINET-Protokolle für Panels und Runtime Advanced
Name | Port-Nummer | Transport-Protokoll | Richtung | Funktion | Beschreibung
DCP | --- | Ethernet | Outbound | Lifelist, PROFINET Discovery and configuration | Das DCP-Protokoll (Discovery and basic Configuration Protocol) wird von PROFINET verwendet und stellt die Basisfunktionalität zum Auffinden und Konfigurieren von PROFINET-Geräten zur Verfügung.
LLDP | --- | Ethernet | Inbound, Outbound | PROFINET Link Layer Discovery protocol | Das LLDP-Protokoll (Link Layer Discover Protocol ) wird von PROFINET zur Topologie-Erkennung verwendet.
MRP | --- | Ethernet | Outbound | PROFINET medium redundancy | Das MRP-Protokoll (Medium redundancy protocol) ermöglicht die Steuerung von redundanten Übertragungswegen durch eine Ringtopologie.
PROFINET IO Data | --- | Ethernet | Inbound, Outbound | PROFINET Cyclic IO data transfer | Der zyklische Datenaustausch wird von Panels für Direkttasten und LEDs verwendet.
ARP | --- | Ethernet | Inbound, Outbound | Name Addres Resolution | Dieses Protokoll wird verwendet, um Netzwerknamen aufzulösen und IP-Adressen zuzuweisen.
PROFINET Context Manager | 34964 | UDP | Inbound, Outbound | PROFINET connection less RPC | Der PROFINET Context Manager stellt einen Endpoint-Mapper zur Verfügung, um eine Applikationsbeziehung (PROFINET AR) herzustellen.

Kommunikationsverbindungen für Panels und WinCC Runtime Advanced
Name | Port-Nummer | Transport-Protokoll | Richtung | Funktion | Beschreibung
Telnet | 23 | TCP | Inbound | Telnet | Dieser Dienst kann für Wartung verwendet werden.
SMTP | 25 | TCP | Outbound | SendEMail | Dieser Dienst wird von Windows CE / PC Runtime zum Versenden von E-Mails verwendet.
HTTP | 80* | TCP | Intbound | Hypertext Transfer Protocol | Der HTTP Protokoll wird für die Kommunikation mit dem HMI Webserver verwendet.
RFC 1006 | 102 | TCP | Outbound | S7-Kanal | Kommunikation zum S7-Controller über Ethernet / PROFINET.
NTP | 123 | UDP | Outbound | Uhrzeit-synchronisation | Das NTP-Protokoll (Network Time Protocol) wird in IP-basierten Netzwerken zur Uhrzeitsynchronisation verwendet.
DCOM*** | 135 | TCP | Inbound | OPC Server | Dieser Dienst ist ein Bestandteil des Betriebssystems Microsoft Windows. Kommunikation über OPC (DA) basiert auf DCOM. Deshalb wird dieser Dienst benötigt, um OPC (DA) Verbindungen zu initialisieren.
DCOM*** | ** | TCP | Inbound | OPC Server | Die Kommunikation über OPC (DA) basiert auf DCOM und verwendet unspezifizierte vom System vergebene Ports. Dies sollte bei der Verwenundung von OPC (DA) und der Erstellung von Regeln für die Firewall berücksichtigt werden.
NetBIOS over TCP/IP | 137 | UDP | Outbound | Mit Verwendung von Remote-Fileshare | Anmeldung/Einloggen auf einem Remote-Server.
NetBIOS over TCP/IP | 138 | UDP | Outbound | Mit Verwendung von Remote-Fileshare | Anmeldung/Einloggen auf einem Remote-Server.
SNMP | 161 | UDP | Outbound | Simple Network Management Protocol | Die SNMP Client-Funktionalität wird von STEP 7 verwendet, um Statusinformationen von PROFINET-Geräten auszulesen.
HTTPS | 443* | TCP | Inbound | Secure Hypertext Transfer Protovol | Das HTTP-Protokoll wird zur Kommunikation mit dem HMI Webserver über Secure Socket Layer (SSL) verwendet.
Modbus TCP | 502* | TCP | Outbound | Modbus TCP-Kanal | Das Modbus TCP-Protokoll wird für Verbindungen zu Schneider PLCs verwendet.
Mitsubishi MC | 1025* | TCP | Outbound | Mitsubishi MC-Kanal | Das Mitsubishi-Protokoll wird für Verbindungen zu Mitsubishi PLCs verwendet.
Printing | 1032 | TCP | Outbound | Printing | Drucken auf dem Bedienfeld (über das Ethernet).
HMI Load | 2308 | TCP | Outbound | Transfer | Dieser Dienst wird verwendet, um Images und Konfigurationsdaten auf Panels zu übertragen. Auf Comfort Panels wird dieser Dienst ab V13 durch DeviceManager und SCS ersetzt.Dieser Dienst wird verwendet, um Konfigurationsdaten zu WinCC Runtime Advanced zu übertragen.
HMI Load | 50523 | TCP | Outbound | Transfer | Dieser Port wird verwendet, wenn Port 2308 nicht verfügbar ist. Dieser Dienst wird verwendet, um Images und Konfigurationsdaten auf Panels zu übertragen. Auf Comfort Panels wird dieser Dienst ab V13 durch DeviceManager und SCS ersetzt. Dieser Dienst wird verwendet, um Konfigurationsdaten zu WinCC Runtime Advanced zu übertragen.
ALM | 4410* | TCP | Inbound, Outbound | Application License Manager | Dieser Dienst von RT Advanced stellt die komplette Funktionalitäten für Software-Lizenzen zur Verfügung und wird vom Automation License Manager verwendet.
OPC UA | 4870* | TCP | Inbound | OPC UA Server | Dieser Dienst wird zur Kommunikation über OPC UA benötigt.
HMI Load | 5001 | TCP | Outbound | Device Manager | Dieser Dienst wird verwendet, um Images und Runtime auf Panels zu übertragen.
HMI Load | 5002 | TCP | Outbound | SCS (System Configuration Server) | Dieser Dienst wird verwendet, um Konfigurationsdaten zu Panels zu übertragen.
VNC Client | 5500 | TCP | Outbound | Sm@rtServer | VNC Client Verbindung
VNC Server | 5800* | TCP | Inbound | Sm@rtServer | VNC Server Verbindung HTTP
 | 5900* | TCP | Inbound | Sm@rtServer | VNC Server Verbindung
SIMATIC Logon | 16389* | TCP | Outbound | UMAC (User Management ans Access Control) | Anmeldung/Einloggen auf einem Remote-Server.
Allen Bradley Ethernet/IP | 44818 | TCP | Outbound | Ethernet/IP-Kanal | Das Ethernet/IP Protokoll wird für Verbindungen zu Allen Bradley PLCs verwendet.
Reserved | 49152 ... 65535 | TCP/UDP | Outbound |  | Dynamisches Portbereich wird z. B. zum Verbinden zum Remote-Filesharing verwendet.
* Standard-Port, der durch Anwenderkonfiguration geändert werden kann ** Port wird automatisch vergeben. *** Wird nur von WinCC Runtime Advanced unterstützt.


Datenschutz

Datenschutz

Siemens beachtet die Grundsätze des Datenschutzes, insbesondere die Gebote der Datenminimierung (privacy by design). Für dieses SIMATIC-Produkt bedeutet dies: Das Produkt verarbeitet / speichert keine personenbezogene Daten, lediglich technische Funktionsdaten (z. B. Zeitstempel). Verknüpft der Anwender diese Daten mit anderen Daten (z. B. Schichtpläne) oder speichert er personenbezogene Daten auf dem gleichen Medium (z. B. Festplatte) und stellt so einen Personenbezug her, hat er die Einhaltung der datenschutzrechtlichen Vorgaben selbst sicherzustellen.


Hinweise zur Benutzung

Inhalt Verhaltensänderung nach dem Hochrüsten Installationspfad Arbeiten mit Standard-Benutzerrechten Bildschirmtastatur (RT Advanced) Gerätewechsel - Zeichensätze (RT Professional) Texte in der Simulation (RT Professional) Online-Deltaload mit benutzerdefinierten Zyklen (RT Professional) Lizenztransfer über S7USB Lizenztransfer auf ein Panel unter 64-Bit-Betriebssystemen Postscript-Zeichensätze Aufgaben mit Variablentrigger
Hinweise zur Benutzung

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Verhaltensänderung nach dem Hochrüsten

Die neue WinCC Version enthält neue Funktionen und Verbesserungen gegenüber der Vorgängerversion. Dadurch können die Bezeichnungen oder das Verhalten von Eigenschaften und Funktionen nach dem Hochrüsten auf die neue Version kleine Änderungen aufzeigen. Auch die Standard-Eigenschaften von neu angelegten Objekten können gegenüber früheren Versionen verändert sein.

Diese Verhaltensänderungen können auch zu Fehlern beim Übersetzen des Projekts führen.

Installationspfad

Wenn Sie in einer früheren Version die Simulation installiert hatten, können Sie bei der Installation den Installationspfad nicht anpassen.

Arbeiten mit Standard-Benutzerrechten

Wenn Sie unter Windows 7 mit Standard-Benutzerrechten arbeiten, darf die "Benutzerkontensteuerung" (UAC) nicht deaktiviert sein.

Standardmäßig ist die "Benutzerkontensteuerung" unter Windows 7 aktiviert.

Weitere Informationen zur "Benutzerkontensteuerung" entnehmen Sie bitte aus der Onlinehilfe von Windows 7.

Bildschirmtastatur (RT Advanced)

Wenn Sie das TIA Portal geöffnet haben, dann können Sie die Bildschirmtastatur nicht mehr aufrufen.

Verwenden Sie für den Aufruf der Bildschirmtastatur in Windows: „Start > Alle Programme > Zubehör > Erleichterte Bedienung > Bildschirmtastatur“.

Gerätewechsel - Zeichensätze (RT Professional)

Wenn Sie an Bildobjekten für mehrsprachige Texte in den verschiedenen Projektsprachen unterschiedliche Zeichensätze projektiert haben, sollten Sie nach einem Bediengerätewechsel von einem Panel auf eine PC-basierte Runtime die Bilder überprüfen. Es kann vorkommen, dass die projektierten Zeichensätze durch den Gerätewechsel verändert wurden.

Texte in der Simulation (RT Professional)

Wenn in der Simulation eine Runtime-Sprache verwendet wird, die nicht einer installierten Produktsprache entspricht, so werden Systemtexte in einer installierten Produktsprache angezeigt. Abhängig vom Betriebssystem und den installierten Produktsprachen ist dies entweder Englisch oder Chinesisch.

Wenn Sie in Japanisch, Koreanisch oder Taiwanesisch in der Simulation alle Texte in der jeweiligen Sprache sehen möchten, sollten Sie WinCC zunächst ohne Simulation installieren. Anschließend installieren Sie WinCC Runtime Professional mit den benötigten Sprachen.

Online-Deltaload mit benutzerdefinierten Zyklen (RT Professional)

Wenn Sie im Editor "Zyklen" eigene Zyklen neu projektiert haben, wählen Sie beim Laden des Projekts den Befehl "Laden > Software (komplett übersetzen)". Ein Online-Deltaladen ist nicht möglich.

Lizenztransfer über S7USB

Der Lizenztransfer zu einem Panel über S7USB ist nur aus WinCC heraus möglich.

Lizenztransfer auf ein Panel unter 64-Bit-Betriebssystemen

Wenn auf einem 64-Bit-Betriebssystem im Automation License Manager der Menübefehl "Bearbeiten > Zielsysteme verbinden > Bediengerät verbinden" nicht zur Verfügung steht, öffnen Sie bitte die Kommandozeile und führen Sie, mit Administrator-Rechten, folgenden Befehl aus:

"%WINDIR%\system32\RegSvr32.exe" "%CommonProgramFiles%\siemens\AlmPanelPlugin\ALMPanelParam.dll"

Postscript-Zeichensätze

Im TIA Portal können nur Schriftarten verwendet werden, die nur True Type Daten enthalten. PostScript-Schriftarten und Open-Type-Schriftarten, die PostScript-Daten enthalten, werden nicht unterstützt.

Aufgaben mit Variablentrigger

Eine Aufgabe mit Variablentrigger wird ausgeführt, wenn der Wert der internen Variablen geschrieben wird. Auch wenn sich dabei der Wert der internen Variablen nicht ändert.


Migration

Inhalt Migration eines mit WinCC V7 erstellten Projektes Migration eines integrierten Projekts mit ProTool-Objekten Fortschrittsanzeige
Migration

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Migration eines mit WinCC V7 erstellten Projektes

Voraussetzung für die Migration ist, dass dieses Projekt mit mindestens WinCC V7 Update 3 bearbeitet wurde.

Migration eines integrierten Projekts mit ProTool-Objekten

Wenn Sie ein in STEP 7 integriertes WinCC flexible Projekt migrieren und die Fehlermeldung "Optionspaket(e) PROTOOL in STEP 7 fehlen" auftritt, haben Sie WinCC flexible 2008 SP3 oder neuer installiert. Zudem enthält das Projekt noch Objekte, die mit ProTool projektiert worden sind. Öffnen Sie das Projekt nicht mit WinCC flexible. Um das Projekt zu migrieren, gehen Sie wie folgt vor:

  1. Öffnen Sie das Projekt im SIMATIC Manager.

  2. Führen Sie im Menü "Datei" den Befehl "Speichern unter" aus.

  3. Aktivieren Sie im Dialog "Projekt speichern untern" die Option "Mit Reorganisation".

  4. Klicken Sie auf OK.

  5. Kopieren Sie das Projekt wieder auf den ursprünglichen Rechner.

  6. Starten Sie die Migration erneut.

Fortschrittsanzeige

Wenn die Fortschrittsanzeige 100% anzeigt, werden von der Software noch verschiedene Restarbeiten, z. B. das Schließen von Referenzen, durchgeführt. In dieser Zeit wird die Software nicht auf Eingaben im User Interface reagieren.


Engineering System

Engineering System

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Bilder und Bildobjekte
  • Variablen und Verbindungen
  • Meldesystem und Meldeanzeigen
  • Systemfunktionen und Skripte
  • Protokolle
  • Rezepturen
  • Benutzerverwaltung
  • Kommunikation


Bilder und Bildobjekte

Inhalt Anzeigeobjekte nach Bediengerätewechsel Gruppierung von Bildobjekten Viele visuell unterschiedliche Bildobjekte Dynamisierung von gruppierten Objekten (RT Professional) Dynamisierung von Bildbausteinen (RT Professional) Anzahl von Zeichen in Textfeldern, Listen und Meldetexten Transparenz in WinCC ab V13 SIMOTION PLC Webseiten im HTML-Browser anzeigen Darstellungsunterschiede zwischen der Projektierung und der Anzeige am Bediengerät GRAPH-Übersicht (RT Professional) Bildbausteine mit den UDTs vom Typ "IEC-Zeit" aktualisieren Überlagerte Controls mit Sichtbarkeitsanimationen System-Diagnoseanzeige: Zugriffsschutz "HMI-Zugriff" Schriftarten in der Überschrift von Fensterobjekten (Panels, Runtime Advanced) Ungültige Grafiktypen in den Grafiklisten nach dem Hochrüsten (Runtime Professional) Mehrsprachige Grafiken in Bildbausteinen Netzwerkänderungen in der PLC-Code-Anzeige (RT Professional) Eigene Controls Unterstützte Datentypen für Animationen
Bilder und Bildobjekte

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Anzeigeobjekte nach Bediengerätewechsel

Wenn Sie ein Gerät auf die neuen Bediengeräteversionen hochrüsten, sollten Sie die im Projekt enthaltenen Bilder überprüfen. Aufgrund des neuen Aussehens und der verbesserten Bedienmöglichkeit kann es vorkommen, dass z. B bei symbolischen EA-Feldern die Texte nicht vollständig lesbar sind und durch Bedienelemente überlagert werden.

Gruppierung von Bildobjekten

Wenn Sie Bildobjekte in WinCC gruppieren, dann kann es bei tieferen Verschachtelungen zu Performance-Problemen von WinCC kommen.

Viele visuell unterschiedliche Bildobjekte

Die Verwendung von Bildobjekten mit vielen visuell unterschiedlichen Eigenschaften (z.B. sehr viele verschiedene Stile) kann zur Verringerung der Performance in Runtime führen und den Verbrauch von Speicherplatz erhöhen. Vermeiden Sie z.B. sehr viele unterschiedliche Eckenrundungen: 0 Pixel, 1 Pixel, 2 Pixel, 3 Pixel, usw.

Dynamisierung von gruppierten Objekten (RT Professional)

Bei mehrfach geschachtelten Gruppierungen (Gruppe in Gruppe, Bildbaustein in Gruppe, Gruppe in Bildbaustein, ...) können bei der Dynamisierung mit Systemfunktionen nur die Ereignisse der äußersten Gruppe und der innersten Objekte verwendet werden. Systemfunktionen, die an die Ereignisse der unterlagerten Gruppe bzw. des unterlagerten Bildbausteins projektiert sind, werden nicht ausgeführt.

Die Projektierung von gleichzeitiger Bewegungsanimation einer Objektgruppe und Objekte innerhalb dieser Gruppe kann zur Laufzeit anders ausgeführt werden, als erwartet. Überprüfen Sie die Reihenfolge der Ausführung in Runtime und passen Sie die Projektierung gegebenenfalls an.

Dynamisierung von Bildbausteinen (RT Professional)

Die Dynamisierung einer Bildbaustein-Instanz mit Anwenderdatentyp-Anbindung ist nicht vorgesehen, kann aber in bestimmten Szenarios mittels einer Hilfsvariablen realisiert werden. Beachten Sie dazu die Hinweise in FAQ 109766634.

Anzahl von Zeichen in Textfeldern, Listen und Meldetexten

Die Anzahl der nutzbaren Zeichen im Text eines Bildobjekts ist nicht konstant. Bei der Eingabe von Textdaten werden Steueranweisungen und Formatierung mitberücksichtigt und die maximale Anzahl der Zeichen verringert sich entsprechend.

Transparenz in WinCC ab V13

Transparente Grafiken können ohne Verluste in Runtime dargestellt werden. Dies gilt für alle Comfort Panels und WinCC Runtime Advanced ab der Version 13.0.
Um die Transparenz in einer Grafikanzeige oder einem Grafischen E/A-Feld zu nutzen, muss die Eigenschaft „Füllmuster“ auf "Transparent" gestellt und die Eigenschaft „Transparente Farbe verwenden“ deaktiviert werden.

SIMOTION PLC Webseiten im HTML-Browser anzeigen

Falls die Websiten von SIMOTION PLC im HTML-Browser nicht richtig angezeigt werden, fügen Sie nach der Webseiten-URL "/basic" ein, um die Webseiten im Basismodus anzuzeigen.

Darstellungsunterschiede zwischen der Projektierung und der Anzeige am Bediengerät

Die Darstellung des in einem Bildobjekt projektierten Texts kann sich auf dem Bediengerät aufgrund der Display-Konfiguration unterscheiden. Falls Sie in der Projektierung die Möglichkeiten der automatischen Größenanpassung nutzen, überprüfen Sie die Darstellung auf Ihrem Bediengerät in jeder Sprache.

Falls Texte, die mit der Option "Objekte an Inhalt anpassen" projektiert sind, nicht vollständig angezeigt werden können, werden sie auf dem Bediengerät leicht verkleinert. Wenn durch die Verkleinerung Texte verzerrt dargestellt werden, deaktivieren Sie die Option "Objekte an Inhalt anpassen" und erweitern Sie den Text mit zusätzlichen Leerzeichen. Optional vergrößern Sie das Objekt in der Breite oder formulieren Sie den Text kürzer um.

GRAPH-Übersicht (RT Professional)

Beim Hochrüsten auf V14 wird die Signatur der C-Funktion am Ereignis "Klicken" geändert. Der in früheren Versionen vorhandene Parameter propertyName entfällt. Funktionen, die auf diesen Parameter zugreifen, werden nach dem Hochrüsten als fehlerhaft markiert.

Bildbausteine mit den UDTs vom Typ "IEC-Zeit" aktualisieren

Aus den benutzerdefinierten PLC-Datentypen (UDT), die den Datentyp "IEC-Zeit" verwenden, wurde das Element "ST" automatisch entfernt. Passen Sie die Bildbausteine, die diese UDTs beinhalten, auf eine neue Version des UDTs ohne ST-Element an.

Eine detaillierte Beschreibung dazu finden Sie im FAQ mit der Beitragsnummer "109740393" im SIMATIC Customer Online Support.

Überlagerte Controls mit Sichtbarkeitsanimationen

Die überlagerte Projektierung von tabellenbasierten Controls mit Sichtbarkeitsanimationen kann auf den Geräten mit dem Betriebssystem Windows CE/Embedded Compact zu Problemen bei der Touch-Bedienung führen.

System-Diagnoseanzeige: Zugriffsschutz "HMI-Zugriff"

Bei Verwendung der Schutzstufe "HMI-Zugriff" in Verbindung mit der SIMATIC S7-1200 PLC kann eine richtige Anzeige der Diagnosedaten erst ab Firmware-Version 4.1 oder höher sichergestellt werden.

Schriftarten in der Überschrift von Fensterobjekten (Panels, Runtime Advanced)

Die Schriftart, die Sie in den Runtime-Einstellungen des Geräts konfigurieren, wird in den Überschriften von Meldefenster, System-Diagnosefenster und Dialogüberschriften nicht verwendet.

Ungültige Grafiktypen in den Grafiklisten nach dem Hochrüsten (Runtime Professional)

Wenn Sie Ihr Projekt auf die TIA Portal Version V16 hochrüsten, resultieren aus ungültigen Grafiktypen der Grafikliste Fehler beim Übersetzen, die in V14 als Warnungen angezeigt wurden.

Um Fehlermeldungen beim Übersetzen zu vermeiden, müssen Sie bei Bedarf den Grafiktyp in der Grafikliste korrigieren.

Mehrsprachige Grafiken in Bildbausteinen

In einem Bildbaustein fügen Sie in ein Bildobjekt eine Grafik ein. Diese Grafik wird in allen festgelegten Projektsprachen verwendet.

Wenn Sie die Grafik mithilfe des Kontextmenü-Befehls „Editieren“ mit der Option "Grafik zentralbearbeiten" öffnen, wird die Grafik nach dem Bearbeiten und Speichern in einem externen Editor, z. B. MS Paint, nur für die aktuell festgelegte Projektsprache geändert. Die Änderung der entsprechenden Grafik wird in allen Objekten sichtbar, die diese Grafik verwenden.

Netzwerkänderungen in der PLC-Code-Anzeige (RT Professional)

Bei anstehender ProDiag-Meldung werden Netzwerkänderungen in der PLC-Code-Anzeige in Runtime aktualisiert.

Damit Netzwerkänderungen in der PLC-Code-Anzeige bezüglich Kriterienanalyse korrekt angezeigt werden können, muss die Meldung neu ausgelöst werden.

Eigene Controls

"Eigene Controls" werden im Engineering System möglicherweise nicht korrekt dargestellt. Sie sind jedoch uneingeschränkt projektierbar. Auch für die Darstellung und Bedienbarkeit in Runtime bestehen keine Einschränkungen. Sollte dieses Control auf OCX-Technologie basieren, wird der Umstieg auf .Net empfohlen.

Unterstützte Datentypen für Animationen

Als Datentypen für Animationen innerhalb eines Bildes sind ganzzahlige und boolesche Werte zulässig.


Variablen und Verbindungen

Inhalt Multiplexen von Variablen (Basic Panels) Variablen mit symbolischer Adressierung und Datentyp "Char Array" (RT Professional) Längenangabe für Variablen vom Typ "String" (RT Professional) Variable vom Typ "String" für Verbindungen mit SIMOTION-Steuerungen (Panels, RT Advanced) Variablen unter "Variable Box-ID" (Mobile Panel) Array-Elemente in WinCC Verwendung von 64-Bit Datentypen Systemdiagnose von PLCs im R/H-System im nicht-redundanten Betrieb
Variablen und Verbindungen

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Multiplexen von Variablen (Basic Panels)

Wenn Sie auf einem Basic Panel eine Variable mit einer externen Variablen multiplexen, wird in Runtime beim ersten Lesezyklus die Adresse aus der PLC gelesen. Erst beim zweiten Lesezyklus steht der Wert der gelesenen Adresse zur Verfügung.

Variablen mit symbolischer Adressierung und Datentyp "Char Array" (RT Professional)

Variablen mit symbolischer Adressierung und dem Datentyp "WString" sind für die Kommunikation von RT Professional und SIMATIC S7-1200 V3 nicht freigegeben.

Längenangabe für Variablen vom Typ "String" (RT Professional)

Im Editor "Variablen" ist die Längenangabe für die internen HMI-Variablen vom Typ "String" unwirksam. Wenn Sie die Variablenlänge, z. B. für ein Eingabefeld oder Ausgabefeld, einschränken möchten, begrenzen Sie die Länge mithilfe VB-Scripting oder C-Scripting.

Variable vom Typ "String" für Verbindungen mit SIMOTION-Steuerungen (Panels, RT Advanced)

Für SIMOTION-Steuerungen darf die Länge der String-Variablen 210 Zeichen nicht überschreiten.

Es ist möglich, im Engineering System eine String-Variable mit mehr als 210 Zeichen anzulegen. Jedoch wird die betreffende Variable in Runtime nicht geschrieben. Es erscheint die Meldung, dass die Wertgrenze außerhalb der Variable liegt.

Passen Sie in diesem Fall die Länge der String-Variable an.

Variablen unter "Variable Box-ID" (Mobile Panel)

Die Variable, die Sie unter "Runtime-Einstellungen > Allgemein" unter "Variable Box-ID" projektieren, darf nur im schreibgeschützten Modus verwendet werden.

In diese Variable dürfen keine Werte geschrieben werden, jedoch darf sie z. B. in Skripten gelesen oder in Bildern ausgegeben werden.

Array-Elemente in WinCC

Wenn Sie eine HMI-Variable mit einem Array aus einem STEP 7 Datenbaustein verbunden haben, das nicht mit einer Untergrenze von 0 beginnt, werden die Array-Elemente in WinCC auf die Untergrenze von 0 abgebildet.

Damit Sie beim Zugriff auf die einzelnen Arrayelemente nicht zwischen den STEP 7-Indizes und den WinCC-Indizes umdenken müssen, sollten Sie die Untergrenzen von Arrays auch in STEP 7 bei 0 beginnen lassen.

Verwendung von 64-Bit Datentypen

Bei der Verwendung von 64-Bit Datentypen kann es zu einem geringen Genauigkeitsverlust kommen, da diese Datentypen im HMI-Kanal auf den Datentyp Double abgebildet werden. Somit kann es vorkommen, dass ganzzahlige Datentypen mit Nachkommastellen angezeigt werden.

Systemdiagnose von PLCs im R/H-System im nicht-redundanten Betrieb

Zwei PLCs und zwei entsprechende Verbindungen sind in einem R/H-System projektiert. Wenn das R/H-System nicht im redundanten Betrieb ist, kann es vorkommen, dass die Systemdiagnose-Anzeigen der beiden Verbindungen für die gleiche PLC unterschiedliche Diagnosestatus-Symbole anzeigen.


Meldesystem und Meldeanzeigen

Inhalt Boolesche Variablen in Meldearchiven PLC-Meldungen Steuerungsmeldungen in Runtime (WinCC Professional) Kopieren von Projekten mit integrierten Verbindungen
Meldesystem und Meldeanzeigen

Inhalt

Hinweise, die nicht mehr in der Onlinehilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Boolesche Variablen in Meldearchiven

Variablen vom Typ Bool werden im Meldearchiv als 0 und -1 erkannt. Wenn Sie in einem Meldearchiv eine Textliste verwenden, die von einer Variable vom Typ Bool gesteuert wird, dann ergänzen Sie die entsprechende Textliste um den Eintrag für den Wert -1.

PLC-Meldungen

Eine PLC-Meldung ist nur dann im Editor "Meldungen" eines HMI-Gerätes sichtbar, wenn auch ein Instanz-Datenbaustein für diesen FB existiert.

Steuerungsmeldungen in Runtime (WinCC Professional)

Wenn Sie ein Projekt von den Versionen V13SP1 oder V13 SP2 auf die Versionen V14, V14 SP1, V15, V15.1, V16 hochrüsten, müssen Sie das Projekt übersetzen und in die Steuerung und das Bediengerät laden. Ansonsten werden die Steuerungsmeldungen in der Meldeanzeige durchgestrichen dargestellt.

Kopieren von Projekten mit integrierten Verbindungen

Wenn Sie aus einem Projekt die Geräte mit ihren integrierten Verbindungen (zwischen Bediengeräten und Steuerungen) in eine globale Bibliothek kopieren und von dort in ein neues Projekt einfügen, dann können die Informationen zu Steuerungsmeldungen am Bediengerät verloren gehen. Um diesen Informationsverlust zu vermeiden, kopieren Sie zuerst alle Steuerungen und dann erst alle Bediengeräte in das neue Projekt


Systemfunktionen und Skripte

Inhalt Skripte bei Service-Projekten (RT Professional) Simulation mit Skript-Debugger Triggervariablen von anwenderdefinierten Funktionen (RT Professional) Anwenderdefinierte Funktionen in Bildbausteinen Systemfunktionen der Bitbearbeitung (Mobile Panels und RT Advanced) Nicht weiterverwendete Eigenschaften (Comfort Panels und RT Advanced) Übergabe von Parametern an VB-Skripte (Panels und RT Advanced) Kurvenanzeige über anwenderdefinierte Funktion versorgen Maximale Parameteranzahl (Panels und RT Advanced) Systemfunktion "ZeigeAnmeldedialog" (Panels und RT Advanced)
Debug Err
Systemfunktionen und Skripte

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Skripte bei Service-Projekten (RT Professional)

Da in Service-Projekten normalerweise kein interaktiver Benutzer angemeldet ist, führen C-Skripte und VB-Skripte z. B. in folgenden Fällen zu Problemen:

  • Wenn die Skripte Interaktionen, z. B. Eingaben erfordern.

  • Wenn die Skripte Message-Boxen anzeigen.

Im Service Mode besteht kein gemeinsamer Datenbereich für C-Scripting. Daher können beispielsweise keine globalen C-Variablen zwischen "Aufgabenplaner" und "Bildern" ausgetauscht werden.

Simulation mit Skript-Debugger

Damit die "Simulation mit Skript-Debugger” vom TIA Portal gestartet werden kann, muss der Registry Key
HKEY_CLASSES_ROOT\CLSID\{834128A2-51F4-11D0-8F20-00805F2CD064}\LocalServer32 einen Eintrag "(Standard)" vom Typ "String" enthalten, der den vollen Pfad zum Standard-Skript-Debugger "devenv.exe" enthält. Der Debugger kann ohne diesen Registry Key an eine bereits laufende Simulation angebunden werden.

Triggervariablen von anwenderdefinierten Funktionen (RT Professional)

Wenn Sie an einem Bild einen HMI- oder einen PLC-Anwenderdatentyp projektiert haben, können Sie in neu erstellten oder geänderten benutzerdefinierten Anwenderfunktionen die Elemente des Anwenderdatentyps nicht als Triggervariable einsetzen.

Anwenderdefinierte Funktionen in Bildbausteinen

Wenn Sie in einem Bildbaustein mit einer anwenderdefinierten Funktion auf Variablen zugreifen wollen, können Sie den Namen der Variablen nicht dynamisch zusammensetzen.

Systemfunktionen der Bitbearbeitung (Mobile Panels und RT Advanced)

Es ist nicht möglich, aufgrund von Ereignissen Bitarrays zu manipulieren. Systemfunktionen wie z.B. InvertBit, SetBit usw. dürfen keine Elemente eines Bitarrays als Argument enthalten.

Nicht weiterverwendete Eigenschaften (Comfort Panels und RT Advanced)

In WinCC V13 wurden viele neue visuelle Eigenschaften eingebracht und viele bestehende Eigenschaften harmonisiert.

Im Zuge der Überarbeitung der Objekteigenschaften kann die Verwendung mancher dieser Eigenschaften, die in früheren Versionen von WinCC in VB Skripten nutzbar waren, in WinCC V13 nicht mehr unterstützt werden. Skripte, die nicht mehr unterstützte Eigenschaften nutzen, bleiben gültig, die betreffenden Aufrufe innerhalb der Skripte sind jedoch zur Laufzeit ohne Funktion. Diese Einschränkungen betreffen ausschließlich Comfort Panels und RT Advanced in der Geräteversion V13.0.

Die folgende Tabelle zeigt die nicht weiterverwendeten Eigenschaften der Bildobjekte:

Eigenschaft | Bildobjekt
BorderBrightColor3D | Schieberegler
BorderColor | Textfeld, E/A-Feld, Symbolisches E/A-Feld, Datum/Uhrzeit-Feld
BorderInnerWidth3D | Schieberegler
BorderOuterWidth3D | Schieberegler
BorderShadeColor3D | Schieberegler
BorderStyle3D | Textfeld, E/A-Feld, Schaltfläche, Symbolisches E/A-Feld, Grafisches E/A-Feld, Datum/Uhrzeit-Feld, Balken, Schalter
BorderWidth | Textfeld, Symbolisches E/A-Feld
CenterColor | Zeigerinstrument
DialColor | Zeigerinstrument
EdgeStyle | Textfeld, E/A-Feld

Übergabe von Parametern an VB-Skripte (Panels und RT Advanced)

In WinCC können Sie definieren, ob die Parameter von VB-Skripten "ByRef" (Adresse des Parameters) oder "ByVal" (Wert des Parameters) übergeben werden.

Eine Übergabe der Adresse des Parameters mithilfe von "ByRef" (Call by Reference) ist nur für die internen Variablen des VB-Skripts möglich. Bei HMI-Variablen wird immer der Wert des Parameters übergeben, unabhängig davon ob der Parameter als „ByRef“ oder als „ByVal“ definiert wurde.

Kurvenanzeige über anwenderdefinierte Funktion versorgen

Wenn Sie mit einer VBS-Funktion Werte aus einem Archiv lesen um diese in einer Kurvenanzeige anzuzeigen, müssen Sie darauf achten, dass die Differenz der Zeitstempel größer Null ist.

Maximale Parameteranzahl (Panels und RT Advanced)

Die maximale Anzahl der Parameter einer globalen Funktion beträgt für den Typ "sub" 8 und für den Typ "func" 7.

Systemfunktion "ZeigeAnmeldedialog" (Panels und RT Advanced)

Für Panel und Runtime Advanced sollte die Systemfunktion "ZeigeAnmeldedialog" nicht an des Ereignis "Weränderung" einer Variablen projektiert werden.


Protokolle

Inhalt Drucken von Protokollen (Panels)
Protokolle

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Drucken von Protokollen (Panels)

Abhängig vom verwendeten Drucker können die in den Protokollen am Rand platzierten Objekte beim Drucken abgeschnitten werden.

Vergewissern Sie sich, dass Ihr Protokoll eine passende Größe hat.


Rezepturen

Inhalt Rezeptursynchronisation (Basic Panels, Panels, Comfort Panels und RT Advanced)
Rezepturen

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Rezeptursynchronisation (Basic Panels, Panels, Comfort Panels und RT Advanced)

Beim Senden von Datensatzwerten an die Steuerung werden die Werte nur validiert, wenn für die Rezeptur unter "Allgemein > Synchronisation > Einstellungen" die Option "Manuelle Übertragung einzelner geänderter Werte (Teach-In-Betrieb)" aktiviert ist.


Benutzerverwaltung

Inhalt UMAC-Domainbenutzer
Benutzerverwaltung

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

UMAC-Domainbenutzer

In WinCC V16.0 dürfen nur nur lokale UMAC-Benutzer und keine UMAC-Domainbenutzer verwendet werden.


Kommunikation

Inhalt Verbindungsaufbau mit WinCC Runtime Advanced Verbindungswechsel bei nicht-integrierten Verbindungen Verbindungsunterbrechungen bei Mitsubishi Steuerungen Selbst signierte Zertifikate (RT Professional) Genauigkeit des Datentyps "DTL" Beschränkte Anzahl von möglichen HMI-Verbindungen Verwendung von PROFINET IO bei Panel-Bediengeräten Kommunikation der RT Advanced über den Station Manager (SIMATIC NET) mit einer S7-1200 IP-Einstellungen und Gerätename einer Steuerung im Control Panel des Bediengeräts ändern (Basic Panels) "Setzen der IP-Suite (Adresse) der PLC im Control Panel" bei SIMATIC S7-1200 V1 (Basic Panels) Verbindungen über PROFIBUS DP Wechsel einer Verbindung Kommunikation der Runtime Professional mit SIMATIC S7-1200 RT Advanced im Station Manager Rohdatenkommunikation in redundanten Projekten (RT Professional) Nicht integrierte Verbindung zu einem SIMATIC S7-1500 Software Controller (RT Advanced) Transferbereiche für die Betriebsart IO-Device und DP-Slave der HMI-Geräte Ermittlung von Diagnosedaten durch HMI-Geräte PROFIEnergy-Kommunikation Anzahl SmartClient-Verbindung
Kommunikation

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Verbindungsaufbau mit WinCC Runtime Advanced

Bitte beachten Sie, dass die im Engineering System projektierte Geräteversion mit der Version der installierten Runtime übereinstimmt, da ansonsten die Kommunikation beim Laden des Projektes nicht aufgebaut werden kann oder verzögert erfolgt.

Wenn die Geräteversion nicht mit der Version der installierten Runtime übereinstimmt, haben sie folgende Möglichkeiten:

  1. Ändern Sie die im Engineering System projektierte Geräteversion.

  2. Installieren sie die zur projektierten Geräteversion passende Version von WinCC Runtime Advanced.

Verbindungswechsel bei nicht-integrierten Verbindungen

Wenn Sie die Kommunikation von einer nicht-integrierten Verbindung auf eine andere nicht-integrierte Verbindung umstellen wollen, z. B. von Omron zu Mitsubishi, müssen Sie sicherstellen, dass die Datentypen der Variablen auch in der neuen Verbindung unterstützt werden.

Verbindungsunterbrechungen bei Mitsubishi Steuerungen

Nach mehrfachen Verbindungsunterbrechungen kann es zu der Situation kommen, dass in der Mitsubishi-Steuerung alle Verbindungsressourcen belegt sind und die Verbindung nicht mehr aufgebaut werden kann. Es wird empfohlen, im SPS-Programm der Steuerung diese Verbindungsressourcen zu kontrollieren und sie auch wieder freizugeben.

Selbst signierte Zertifikate (RT Professional)

Selbst signierte Zertifikate werden nicht mehr unterstützt.

Wenn Server-seitig ein selbst signiertes Zertifikat erkannt wird, findet die Authentifizierung über den zuvor verteilten PSK-Schlüssel (Pre-shared key) statt. Wenn der PSK-Schlüssel zwischen den Kommunikationspartnern nicht übereinstimmt, kommt keine Kommunikation zustande.

Genauigkeit des Datentyps "DTL"

Der Datentyp "DTL" unterstützt Zeitangaben bis im Bereich von Nanosekunden. Da Panels Zeitangaben lediglich bis in den Bereich von Millisekunden unterstützen, ergeben sich bei der Verwendung an den Bereichszeigern folgende Einschränkungen:

  • Bereichszeiger "Datum/Uhrzeit"
    Bei der Übertragung der Zeitangaben von einem Panel zur Steuerung gilt als kleinste Zeiteinheit 1 Millisekunde. Der Wertebereich von Mikrosekunden bis Nanosekunden des Datentyps "DTL" wird mit Nullen befüllt.

  • Bereichszeiger "Datum/Uhrzeit Steuerung"
    Bei der Übertragung der Zeitangaben von einer Steuerung zu einem Panel wird der Bereich von Mikrosekunden bis Nanosekunden ignoriert. Auf dem Panel wird die Zeitangabe bis einschließlich der Millisekunden weiterverarbeitet.

Beschränkte Anzahl von möglichen HMI-Verbindungen

Beim Übersetzen eines Geräts tritt eine Fehlermeldung auf, dass die Konfiguration der HMI-Verbindung im Editor "Geräte & Netze" ungültig ist. Die Ursache kann darin liegen, dass die maximale Anzahl der möglichen Verbindungen des HMI-Geräts bzw. der PLC überschritten ist.

Prüfen Sie die maximale Anzahl der möglichen Verbindungen. Informieren Sie sich bitte im Gerätehandbuch der von Ihnen verwendeten Geräte.

Verwendung von PROFINET IO bei Panel-Bediengeräten

Bei der Verwendung von PROFINET IO zur Verbindung der Direkttasten und LEDs von Bediengeräten mit der Steuerung können Sie bei der Projektierung in HW Konfig einen Offset für den Adressbereich der Eingänge und der Ausgänge festlegen.

Bei der Verwendung einer PROFINET IO-fähigen CPU der 400er Baureihe in Verbindung mit einem der unten aufgeführten Bediengeräte gilt folgende Einschränkung:

Der Offset für den Anfang des Adressbereichs der Eingänge darf nicht größer sein als der Offset für den Anfang des Adressbereichs der Ausgänge.

Die Einschränkung gilt für folgende Bediengeräte:

  • Mobile Panel 177

Für die Projektierung der Adressparameter öffnen Sie die Steuerung mit der CPU der 400er Baureihe in HW Konfig. Selektieren Sie im Stationsfenster von HW Konfig das über PROFINET IO verbundene Bediengerät. Im unteren Bereich des Stationsfensters wird in der Detailansicht eine Tabelle mit den Eigenschaften des Bediengeräts angezeigt. Selektieren Sie in der Tabelle die Zeile mit den Adressen des Bediengeräts und öffnen Sie die Objekteigenschaften über das Kontextmenü.

Aktivieren Sie im Dialog "Objekteigenschaften" die Registerkarte "Adressen". Unter "Eingänge > Anfang" projektieren Sie den Offset für die Eingänge. Unter "Ausgänge > Anfang" projektieren Sie den Offset für die Ausgänge.

Kommunikation der RT Advanced über den Station Manager (SIMATIC NET) mit einer S7-1200

Die Kommunikation von einer SIMATIC S7-1200 mit einem PC mit WinCC RT Advanced über einen Router gelten folgende Einschränkungen für den PC:

  • Windows 7: Nur mit installiertem SIMATIC NET 8.1

Diese Einschränkungen gelten auch, wenn Sie den Station Manager verwenden. Verbindungen mit Hilfe des Station Managers von der Runtime Advanced werden immer wie geroutete Verbindungen behandelt.

IP-Einstellungen und Gerätename einer Steuerung im Control Panel des Bediengeräts ändern (Basic Panels)

Auf dem Bediengerät ist das Control Panel im Menü "Service and Commissoning > IP-Adaptation" geöffnet. Wenn Sie die IP Einstellungen oder den Gerätenamen einer Steuerung ändern wollen, beachten Sie Folgendes:

Im Engineering System haben Sie zuvor im Inspektorfenster der Steuerung unter "Eigenschaften > Allgemein > PROFINET-Schnittstelle > Ethernet-Adressen" folgende Optionen aktiviert:

  • "IP-Adresse auf anderem Weg beziehen"

  • "PROFINET-Gerätenamen auf anderem Weg beziehen"

"Setzen der IP-Suite (Adresse) der PLC im Control Panel" bei SIMATIC S7-1200 V1 (Basic Panels)

Die Funktion "Setzen der IP Suite (Adresse) der PLC im Control Panel" ist für folgende Steuerungen nicht freigegeben:

  • SIMATIC S7-1200 V1

Verbindungen über PROFIBUS DP

Wenn eine Verbindung über PROFIBUS DP zwischen einer Steuerung und einem Bediengerät unterbrochen und dann wieder aufgebaut wird, dann werden sporadisch alle weiteren PROFIBUS DP-Verbindungen im Kommunikationsnetz abgebrochen und wieder aufgebaut.

Schalten Sie den getrennten Teilnehmer spannungslos, bevor Sie den Teilnehmer wieder verbinden.

Wechsel einer Verbindung

Bei einem Wechsel der Verbindung von einem Bediengerät zu einer Steuerung SIMATIC S7-300/400, zu einer Steuerung SIMATIC S7-1500 oder SIMATIC S7-1200 kann es zum Abbruch der Verbindung kommen.

Beachten Sie folgende Einstellungen in den Steuerungen SIMATIC S7-1500 oder SIMATIC S7-1200:

  • Absolute Adressierung der Variablen

  • Option "PUT/GET-Kommunikation deaktivieren" muss ausgewählt sein

  • Schutzstufe "Kompletter Schutz" darf nicht projektiert sein

Kommunikation der Runtime Professional mit SIMATIC S7-1200

Im Produktivbetrieb ist die Kommunikation von WinCC Runtime Professional mit SIMATIC S7-1200 nur für Einplatzsysteme freigegeben.

RT Advanced im Station Manager

Wenn RT Advanced und WinAC RTX denselben Kommunikationsprozessor eines PCs verwenden, dann ist eine HMI-Kommunikation zu SIMATIC S7-1200 und SIMATIC S7-1500 nicht möglich.

Rohdatenkommunikation in redundanten Projekten (RT Professional)

Simatic.NET, Named Connections und diverse Kommunikationsbausteine, wie z.B. BSEND/BRCV, können bei einer redundant konfigurierten PC-Station nur eingeschränkt verwendet werden, weil die Verbindungsparameter für den redundanten Partnerserver nicht projektiert werden können.

Nicht integrierte Verbindung zu einem SIMATIC S7-1500 Software Controller (RT Advanced)

Eine nicht integrierte Verbindung zwischen einem HMI-Gerät und einem SIMATIC S7-1500 Software Controller wird in WinCC nicht unterstützt.

Transferbereiche für die Betriebsart IO-Device und DP-Slave der HMI-Geräte

Wenn Sie für HMI-Bediengeräte die Betriebsart "IO-Device" bzw. "DP-Slave" aktiviert haben, sollten in den Eigenschaften des Bediengeräts keine Transferbereiche hinzugefügt oder gelöscht werden. Wenn Sie versehentlich einen Transferbereich gelöscht oder hinzugefügt haben, so entfernen und verbinden Sie den Controller erneut.

Ermittlung von Diagnosedaten durch HMI-Geräte

Entgegen der Beschreibung der Diagnosesymbole für Baugruppen und Geräte im Informationssystem hat für HMI-Geräte das folgende Symbol die hier angegebene Bedeutung:

Symbol | Bedeutung
 | Es sind keine Diagnosedaten verfügbar.

PROFIEnergy-Kommunikation

Um die PROFIEnergy-Kommunikation einzurichten, kontaktieren Sie den Customer Support.

Anzahl SmartClient-Verbindung

Auch wenn Basic Panel eine unbegrenzte Anzahl von SmartClient-Verbindungen erlauben, ist es empfehlenswert maximal 2 Verbindungen zu projektieren. Jede zusätzliche Verbindung hat Einfluss auf die Leistung.


Übergreifende Funktionen

Inhalt Systemdiagnose im Geräte-Proxy einsetzen Geräte-Proxy mit Daten aus einem Projekt der Vorgängerversion initialisieren Import und Export von Bibliothekstexten
Übergreifende Funktionen

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Systemdiagnose im Geräte-Proxy einsetzen

Um die Funktion Systemdiagnose in einem IPE Geräte-Proxy verwenden zu können, z. B. eine Systemdiagnose-Anzeige, fügen Sie die PLC-Meldungen als Inhalt eines Geräte-Proxys ein.

Geräte-Proxy mit Daten aus einem Projekt der Vorgängerversion initialisieren

In einem Projekt mit der Service Pack Version kann ein Geräte-Proxy nicht mit den Daten aus einem Projekt der zugehörigen Vollversion initialisiert werden.
Rüsten Sie das Quellprojekt auf die Service Pack Version hoch, um den Geräte-Proxy im Zielprojekt mit den Daten aus dem Quellprojekt initialisieren zu können.

Import und Export von Bibliothekstexten

Folgende Objekte werden beim Import und Export von Bibliothekstexten nicht unterstützt:

  • Import: Rezepturen, Rezepturelemente, Rezepturdatensätze, HMI-Meldungen, Textlisteneinträge, Bilder, Protokolle.

  • Export: Textlisteneinträge, Bilder, Protokolle.

  • Import und Export von Bibliothekstypen "Bild".


Übersetzen und Laden

Inhalt Übersetzen und Laden Prüfen der Adressparameter Fehlermeldung beim Laden von Daten auf die PLC Comfort Panels ab Geräteversion 13.0: Sicherung der Daten beim Laden von Projekten Anzeige von Zeichen in Transfer-Meldungen Projektgröße verringern
Microsoft KB3083806
Übersetzen und Laden

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Übersetzen und Laden

Wenn beim Übersetzen interne Fehler oder Warnungen auftreten, übersetzen Sie das Projekt vollständig über den Befehl "Übersetzen > Software (komplett übersetzen)" im Kontextmenü des Bediengeräts.

Bevor Sie mit Ihrem Projekt in den Produktivbetrieb gehen, übersetzen Sie das Projekt vollständig über den Befehl "Übersetzen > Software (komplett übersetzen)" im Kontextmenü des Bediengeräts.

Wenn Sie in Ihrem Projekt HMI-Variablen verwenden, die an Steuerungsvariablen angebunden sind, übersetzen Sie vor dem Bediengerät auch alle geänderten Bausteine über den Befehl "Übersetzen > Software" im Kontextmenü.

Prüfen der Adressparameter

Beim Übersetzen eines Bediengerätes in der Projektnavigation über den Befehl "Übersetzen > Hardware und Software (nur Änderungen)" im Kontextmenü werden die Adressparameter des Bediengeräts, wie z. B. die IP-Adresse, nicht überprüft. Um sicherzugehen, dass auch die Adressparameter überprüft werden, müssen Sie das Bediengerät im Editor "Geräte & Netze" über die Schaltfläche "Übersetzen" in der Symbolleiste übersetzen.

Fehlermeldung beim Laden von Daten auf die PLC

Ein Panel und eine PLC sind verbunden und kommunizieren miteinander.

Wenn beim Laden von Daten auf die PLC vom Panel aus auf eine Variable zugegriffen wird, wird am Panel eine Fehlermeldung ausgegeben.

Comfort Panels ab Geräteversion 13.0: Sicherung der Daten beim Laden von Projekten

Bei Comfort Panels mit der Geräteversion 13.0 oder höher stellt WinCC beim Abbruch der Übertragung sicher, dass keine Daten verloren gehen und dass die vorhandenen Daten auf dem Bediengerät erst nach vollständiger Übertragung gelöscht werden.

Anzeige von Zeichen in Transfer-Meldungen

Falls beim Transfer auf Bediengeräte mit der Geräteversion V12 oder älter die Zeichen in den Transfer-Meldungen nicht richtig dargestellt werden, überprüfen Sie das Gebietsschema in Windows. Stellen Sie die entsprechende Sprache unter "Sprache für Unicode-inkompatible Programme" ein.

Projektgröße verringern

Beim Übersetzen Ihres Bediengeräts weist eine Meldung Sie darauf hin, dass die Größe Ihres Projekts für das entsprechende Bediengerät an die Systemgrenze kommt. In diesem Fall kann das komplette Übersetzen der Software die Projektgröße verkleinern. Führen Sie dafür den Befehl "Übersetzen > Software (komplett übersetzen)" aus.


Runtime

Runtime

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hinweise zum Betrieb in Runtime
  • Hinweise zum Betrieb von Panels in Runtime
  • Hinweise zum Betrieb von Runtime Advanced
  • Hinweise zum Betrieb von Runtime Professional
  • Hinweise zum Betrieb von Runtime Unified


Hinweise zum Betrieb in Runtime

Inhalt Fokus in Runtime Sprachenverhalten - Layout der Bildschirmtastatur Variablenwerte überschreiten die maximale Länge Leere Meldetexte Dauer der Initialisierung der Archive (Panels, RT Advanced) Große Archive verlangsamen das Beenden der Runtime (Basic Panels 2nd Generation) Langsame Reaktion von SmartServer Bildschirmschoner auf dem Sm@rtServer beenden Beschädigte Dateien bei Stromausfall vermeiden Variable Schriftarten auf Bediengeräten
Hinweise zum Betrieb in Runtime

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Fokus in Runtime

Wenn Sie für ein Bediengerät mit der Geräteversion 12.0.0 oder kleiner eine kontrastarme Kombination von Fokus-Farbe und Rahmenfarbe projektiert haben, kann es nach einem Wechsel der Geräteversion im TIA Portal anschließend in Runtime vorkommen, dass der Fokus nicht mehr erkennbar ist. Ändern Sie eine der beiden Farben.

Sprachenverhalten - Layout der Bildschirmtastatur

Das Layout der Bildschirmtastatur wird nicht umgeschaltet, wenn Sie zu einer Runtime-Sprache wechseln, die unter Windows für das Tastatur-Layout nicht installiert ist.

In diesem Fall bleibt die Spracheinstellung der Tastatur auf der letzten gültigen Sprache eingestellt bzw. es wird die eingestellte Sprache des Standard-Tastatur-Layouts von Windows verwendet.

Variablenwerte überschreiten die maximale Länge

Sie geben eine Zeichenkette in eine String Variable über ein E/A-Feld ein. Wenn die Zeichenfolge die projektierte Länge der Variablen überschreitet, wird die Zeichenkette auf die projektierte Länge gekürzt.

Leere Meldetexte

Die Runtime läuft mit einem Projekt. Das Projekt ist auf einem Netzlaufwerk gespeichert.

Bei Unterbrechungen zum Netzlaufwerk kommt es gegebenenfalls vor, dass die Runtime versucht Meldetexte vom Netzlaufwerk zu laden.

Wenn die Verbindung getrennt ist, bleibt das Meldefenster bzw. die Meldeanzeige leer.

Um das Verhalten zu vermeiden, kopieren Sie das Projekt auf ein lokales Laufwerk bevor Sie das Projekt in der Runtime starten.

Dauer der Initialisierung der Archive (Panels, RT Advanced)

Die Initialisierung der Archive kann auf manchen Speichermedien bis zu 5 Minuten dauern. Der erfolgreiche Abschluss der Initialisierung wird durch eine Systemmeldung bestätigt, sobald diese abgeschlossen wurde. Bei einem eventuell fehlendem Speichermedium für die Archivierung kann beim Runtime-Start das Anzeigen der Systemmeldung ebenfalls bis zu 5 Minuten dauern.

Große Archive verlangsamen das Beenden der Runtime (Basic Panels 2nd Generation)

Bei der Verwendung von sehr großen Archiven kann das Beenden der Runtime längere Zeit in Anspruch nehmen. Verwenden Sie segmentierte Archive als Alternative zu sehr großen Umlaufarchiven.

Langsame Reaktion von SmartServer

Unter Windows 7 starten und reagieren folgende Programme möglicherweise sehr langsam:

  • HMI TouchInputPC

  • SmartServer: Tastenkombination <Strg+Alt+Del> beim Anmeldedialog

Die Verzögerung entsteht durch die Internet-Zertifikatprüfung auf Rückruf.

Abhilfe:

Auf der Produkt-DVD finden Sie unter:
Support\Windows\CRL_Check bzw. CD_RT\ Support\Windows7\CRL_Check\
die folgenden Dateien:

  • DisableCRLCheck_LocalSystem.cmd

  • DisableCRLCheck_CurrentUser.cmd

  1. Führen Sie die Datei "DisableCRLCheck_LocalSystem.cmd" mit Administratorrechten aus. Rufen Sie im Kontextmenü der Datei den Befehl "Run as administrator" auf.

  2. Starten Sie den PC neu.

Wenn das Problem damit nicht behoben ist, gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf die Datei und führen Sie die Datei "DisableCRLCheck_CurrentUser.cmd" mit Benutzerrechten aus.

  2. Starten Sie den PC neu

    Hinweis

    Die Zertifikatprüfung auf Rückruf wird benutzer- oder PC-weit deaktiviert. Um den Ausgangszustand wiederherzustellen, führen Sie die folgenden Dateien aus:

    • RestoreDefaults_LocalSystem.cmd

    • RestoreDefaults_CurrentUser.cmd

    Die Dateien finden Sie im folgenden Verzeichnis der Produkt-DVD:

    • Support\Windows\CRL_Check bzw. CD_RT\Support\Windows7\CRL_Check\

Bildschirmschoner auf dem Sm@rtServer beenden

Wenn der Bildschirmschoner auf dem Sm@rtServer am Server-Bediengerät aktiv ist, benötigen Sie einen schreibenden Zugriff auf der Sm@rtClient-Seite, um den Bildschirmschoner am Server-Bediengerät zu beenden.

Beschädigte Dateien bei Stromausfall vermeiden

Wenn bei Windows Systemen ein Stromausfall auftritt, während das WinCC System aktiv ist, können Dateien beschädigt oder zerstört werden. Der Betrieb mit dem Dateisystem NTFS bietet höhere Sicherheit.

Einen gesicherten Dauerbetrieb gewährleistet nur der Einsatz einer unterbrechungsfreien Stromversorgung (USV).

Variable Schriftarten auf Bediengeräten

Windows 10 unterstützt seit Version 1709 variable Schriftarten ("OpenType Font Variations"). Sie können im Engineering System auch die Varianten einer variablen Schriftart verwenden. Die tatsächliche Darstellung in Runtime ist abhängig vom Bediengerät und den Installationsbedingungen:

  • Basic Panels, Comfort Panels: Variable Schriftarten werden nicht unterstützt. Es wird immer die Basis-Variante angezeigt.

  • Runtime Advanced, Runtime Professional: Variable Schriftarten werden unterstützt, wenn als Betriebssystem mindestens Windows 10 Version 1709 verwendet wird und die Schriftart mit Administratorrechten installiert ist.


Hinweise zum Betrieb von Panels in Runtime

Inhalt Verwendung des Mausrades in Runtime Backup auf der Speicherkarte der PLC (Basic Panels) Panel Data Storage und S7-1500F (Basic Panels) Funktion "Panel Data Storage" (Basic Panels) Schriftarten mit Dateikennung ".ttx" Massendatentransfer über USB Ändern der IP-Adresse und des Gerätenamens bei Panels
Hinweise zum Betrieb von Panels in Runtime

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Verwendung des Mausrades in Runtime

Auf allen Panels wird die Verwendung des Mausrades in Runtime nicht unterstützt.

Backup auf der Speicherkarte der PLC (Basic Panels)

Sie erstellen die Backup-Datei "A.psb" auf der Speicherkarte der PLC. Beim Erstellen des Backups tritt ein Fehler auf z. B. ein Verbindungsabbruch.
Dadurch entsteht eine fehlerhafte Datei auf der Speicherkarte der PLC. Eine solche Datei hat als Präfix "~$".
Löschen Sie die Datei mit dem Präfix "~$", wenn Sie ein Backup unter dem gleichen Namen "A.psb" erneut speichern wollen.

Panel Data Storage und S7-1500F (Basic Panels)

Die Funktion "Panel Data Storage" PDS kann auf Basic Panels im Zusammenspiel mit S7-1500F nicht verwendet werden, wenn das Passwort für die Schutzstufe "Full access incl. fail-safe" verwendet wird.

Funktion "Panel Data Storage" (Basic Panels)

Die Funktion "Panel Data Storage" (PDS), die Ihnen auf Basic Panels zur Verfügung steht, unterstützt nur SIMATIC S7-1200 ab Firmware V4.0 und SIMATIC S7-1500. Für die PDS-Funktion muss das Panel direkt mit der CPU verbunden sein und darf nicht über den CP verbunden sein.

Schriftarten mit Dateikennung ".ttx"

Die Schriftarten mit der Dateikennung ".ttx" sind auf allen Panels und in Runtime Advanced verfügbar und können auf allen Geräten richtig dargestellt werden, z. B. die Schriftart "WinCC_flexible_smart".

Massendatentransfer über USB

Wenn Sie auf dem Projektierungs-PC Windows 10 installieren, ist der Transferkanal "USB" nicht verfügbar.

Diese Einschränkung gilt für die folgenden Geräte und Tools:

  • Basic Panels: KP300 Basic, KP400 Basic, TP1500 Basic

  • Mobile Panels: 170er Serie und 270er Serie

  • WinCC Engineering System

  • Service-Tool "ProSave"

Hinweis

Der Transferkanal "USB" bleibt verfügbar, wenn auf dem Projektierungs-PC Windows 7 installiert sind.

Abhilfe

Verwenden Sie andere Transferkanäle für die Übertragung der Projektdaten, z. B. den Kanal "Industrial Ethernet" oder "PROFIBUS DP".

Ändern der IP-Adresse und des Gerätenamens bei Panels

Auf Comfort Panels kann die IP-Adresse oder der Gerätename auch geändert werden, wenn Runtime gestartet ist.

Auf Basic Panels ist das Ändern der IP-Adresse oder des Gerätenamens bei laufender Runtime nicht möglich.


Hinweise zum Betrieb von Runtime Advanced

Inhalt Runtime starten Berechtigung für den Start der Runtime Advanced Bildschirmschoner auf Rechnern mit Windows 10 Windows 10 im Tabletmodus .Net-Controls in Runtime Automatische Überprüfung der Software-Aktualisierungen deaktivieren Zugriff auf Array-Variablen über OPC
Hinweise zum Betrieb von Runtime Advanced

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Runtime starten

Vom Engineering System aus kann nur WinCC Runtime V16 gestartet werden. Andere Versionen von WinCC Runtime können nur simuliert werden.

Berechtigung für den Start der Runtime Advanced

Auf einem Rechner mit Windows Betriebssystem kann WinCC Runtime Advanced nur gestartet werden, wenn der Benutzer, welcher die Runtime startet, der Gruppe "Siemens TIA Engineer" zugeordnet ist und ihre Rechte besitzt.

Bildschirmschoner auf Rechnern mit Windows 10

Auf einem Rechner mit Windows 10 wird ein aktivierter Bildschirmschoner durch das Auftreten einer Meldung der Klasse "Fehler" nicht mehr beendet.

Windows 10 im Tabletmodus

Es wird nicht empfohlen, Windows 10 im Tabletmodus zu nutzen.

Wenn Sie unter Windows 10 im Tabletmodus Anwendungen, z. B. Runtime Advanced, Sinumerik Operate usw. betreiben, werden diese Anwendungen nach dem Starten minimiert.

.Net-Controls in Runtime

Wenn Sie in Ihrem Projekt ein .Net-Control als "Spezifisches .Net-Control" eingebunden haben, müssen Sie die zu diesen Controls gehörenden Dateien in das Installations-Verzeichnis der WinCC Runtime, z. B. "C:\ProgramFiles\Siemens\Automation\WinCC RT Advanced", kopieren. Ansonsten kann das Control in Runtime nicht geladen werden.

Automatische Überprüfung der Software-Aktualisierungen deaktivieren

Wenn das Engineering System zusammen mit der Runtime auf einem PC installiert ist, bekommt der Bediener Benachrichtigungen über die Software-Aktualisierungen. Damit das System auf einem Mehrplatzsystem stabil läuft, muss auf allen Rechner dieselbe Software-Version installiert sein.

Es ist möglich, die automatische Überprüfung der Software-Aktualisierungen zu deaktivieren und die Performance damit zu verbessern.

Sie deaktivieren die automatische Überprüfung der Software-Aktualisierungen unter "Einstellungen > Allgemein > Software-Updates", indem Sie die Option "Täglich nach Updates suchen" deaktivieren.

Zugriff auf Array-Variablen über OPC

Wenn Sie WinCC Runtime Advanced als OPC UA Server einsetzen, wird das Lesen von Array-Variablen nur unterstützt, wenn die Einstellung "OPC UA Server Array index range access" aktiviert ist.

Das Schreiben von Array-Variablen ist nur möglich, der der OPC UA Client die Einstellung “Write array elements without IndexRange" unterstützt.


Hinweise zum Betrieb von Runtime Professional

Inhalt Benutzerberechtigungen im Betriebssystem Tastenkombinationen sperren Nicht fixierte Symbolleisten Störung der Verbindung zwischen Server und Client Störung der Verbindung zwischen Server und Client Starten von WinCC Runtime Professional Einstellung der Dienste für den SQL-Server "Systemfehler melden" in WinCC Runtime Professional WinCC-Schnittstellen und 64-Bit Betriebssystem Dynamische Grafiken im WinCCViewer RT Runtime Professional: Laden eines Projekts ohne Verbindung zum Projektierungs-PC Verbindung mit S7-1200 in Systemdiagnose Automatische Überprüfung der Software-Aktualisierungen deaktivieren Einschränkung der Online-Delta-Ladefähigkeit Bildobjekte in Protokollen als PDF Projekte in Runtime nach Windows 10-Update Speicherbedarf von Archiven
Hinweise zum Betrieb von Runtime Professional

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Benutzerberechtigungen im Betriebssystem

  1. Alle Benutzer müssen in die Benutzergruppe "SIMATIC HMI" aufgenommen sein. Dies gilt auch für Benutzer, die WinCC-Projekte remote öffnen wollen.

  2. Der Ablageordner der Projekte muss die NTFS Berechtigungen "SIMATIC HMI" mit Vollzugriff sowie "SIMATIC HMI Viewer" mit Leserechten versehen sein. Die Berechtigungen müssen für alle untergeordnete Objekte vererbt werden.

Tastenkombinationen sperren

Wenn Sie unter Windows Tastenkombinationen sperren wollen, müssen Sie in der Verwaltung des Betriebssystems die Gruppenrichtlinien anpassen.

Eine detaillierte Beschreibung dazu finden Sie im FAQ mit der Beitragsnummer "44027453" im SIMATIC Customer Online Support:

Internet: WinCC FAQ 44027453

Nicht fixierte Symbolleisten

Wenn für die Windows Taskleiste die Einstellung "Immer im Vordergrund" verwendet wird, können in Runtime nicht fixierte Symbolleisten hinter die Windows Taskleiste verschoben werden. Um die Symbolleisten wieder sichtbar zu machen, gehen Sie wie folgt vor:

  1. Wählen Sie im Kontextmenü der Taskleiste den Befehl "Eigenschaften".

  2. Deaktivieren Sie "Taskleiste immer im Vordergrund halten".

Störung der Verbindung zwischen Server und Client

Wenn die Verbindung zwischen Server und Client gestört ist, überprüfen sie Einstellungen der PG/PC-Schnittstelle. Für die "Benutzte Schnittstellenparametrierung" sollte nicht TCP/IP(Auto) verwendet werden. Verwenden Sie stattdessen feste IP-Adressen.

Störung der Verbindung zwischen Server und Client

Wenn der Rechner mit dem Engineering System gleichzeitig als Server verwendet wird und ein Client die Verbindung zum Server nicht aufbauen kann, sollten Sie die auf dem Server gesetzten Freigaben überprüfen.

  1. Beenden Sie auf dem Server die Runtime.

  2. Wählen Sie im Kontextmenü der Netzwerkumgebung auf dem Desktop des Servers den Befehl "Computer suchen...".

  3. Geben sie den Namen des Servers als den zu suchenden Computer ein.

  4. Öffnen Sie den gefundenen Computer, um die freigegebenen Verzeichnisse zu erkennen.

  5. Entfernen Sie alle Freigaben die mit "WinCC_Project_HMI" beginnen. Informationen dazu finden Sie in der Dokumentation des Betriebssystems.

Das Fehlverhalten wird verursacht durch die Verwendung des Befehls "Speichern unter..." in Verbindung mit dem Starten der Runtime dieses neuen Projektes. Zu Sicherungszwecken können Sie mit "Speichern unter..." Kopien der Projekte erzeugen. Sie sollten jedoch mit dem ursprünglichen Projekt weiterarbeiten.

Starten von WinCC Runtime Professional

Wenn auf einem Rechner Engineering System und Runtime betrieben werden, sollte Runtime oder Simulation zu einem im Engineering System geöffneten Projekt nur über das TIA Portal gestartet und beendet werden. Andere Möglichkeiten, z. B. das Symbol im Infobereich der Taskleiste, sollten nicht genutzt werden.

Beim Konfigurieren des Autostarts am Client ist für jedes eingetragene Server-Projekt die Eingabe von Login und Passwort zwingend notwendig. Um jedem Server ein Login zuordnen zu können, muss die Eingabe des jeweiligen Projektpfades mit der Taste „Anwenden“ bestätigt werden. Dies führt dazu, dass Sie bei redundanten oder alternativen Projekten Login und Passwort zweimal eingeben müssen.

Einstellung der Dienste für den SQL-Server

Um die volle Funktionalität des SQL-Servers für WinCC und WinCC Runtime sicherzustellen, müssen Sie Einstellungen des SQL-Servers überprüfen.

  1. Starten Sie im Startmenü "Programme > Microsoft SQL Server 2014 > Configuration Tools > SQL Server 2014 Configuration Manager".

  2. Klicken Sie im Baum auf "SQL Server Services".

  3. Überprüfen Sie die Dienste "SQL Server (WinCC)", "SQL Server (WINCCPLUSMIG)" und "SQL Server Browser".
    Für "Start Mode" muss "Automatic" eingetragen sein.
    Für "Log On As" muss "LocalSystem" für "SQL Server (WinCC)" eingetragen sein.
    Für "SQL Server Browser" muss "LOCALSERVICE" eingetragen sein
    Ändern Sie gegebenenfalls die Einstellungen.

  4. Klicken Sie im Baum auf "SQL Server Network Configuration".

  5. Klicken Sie auf "Protocols for WinCC".

  6. Überprüfen Sie das Protokoll "TCP/IP". Bei "Status" muss "Enabled" eingetragen sein. Ändern Sie gegebenenfalls die Einstellungen.

"Systemfehler melden" in WinCC Runtime Professional

Die Funktionalität "Systemfehler melden" ist in der WinCC Runtime Professional in Zusammenarbeit mit einer S7-300 bzw. S7-400 eingeschränkt. In einer Meldeanzeige wird zu einer Diagnoseart immer nur eine Meldung angezeigt. Meldungen zu weiteren Fehlern der gleichen Diagnoseart werden nicht angezeigt.

WinCC-Schnittstellen und 64-Bit Betriebssystem

Die offenen Schnittstellen von WinCC Runtime Professional bieten keine native 64-Bit Unterstützung. Davon sind vor allem Runtime API, VBS und der WinCC OleDB-Provider betroffen. Um die Schnittstellen von WinCC unter einem 64-Bit Betriebssystem nutzen zu können, müssen Sie folgendes beachten:
- VB-Skripte können Sie nicht einfach per Doppelklick starten. Sie müssen explizit die 32-Bit-Version unter "syswow64\wscript.exe" verwenden.
- .NET-Applikationen, die die WinCC-API verwenden, müssen explizit als 32-Bit Applikationen übersetzt werden. Nicht mit "AnyCPU" sondern mit "x86".
- C++ Applikationen dürfen nicht als 64-Bit Applikationen übersetzt werden.

Dynamische Grafiken im WinCCViewer RT

Wenn Sie dynamische Grafiken aus einer Grafiksammlung, z.B. an Skripte gebunden verwenden, dann werden diese Grafiken im WinCCViewer RT nicht aktualisiert.

Wählen Sie unter "Runtime-Einstellungen > Grafikeinstellungen" die Option "Benutzerdefiniert" aus.

Runtime Professional: Laden eines Projekts ohne Verbindung zum Projektierungs-PC

Bevor Sie mit dem Laden eines Projekts auf der Bedienstation starten, speichern Sie die Daten wie "Benutzerverwaltung" und "Rezepturdaten".

  1. Daten der Benutzerverwaltung werden standardmäßig überschrieben.

    Projektieren Sie daher zwei Schaltflächen in Ihrem Projekt für den Export bzw. Import der Benutzerverwaltung mit der Systemfunktion „ExportiereBenutzerverwaltung“. Der Export der Daten ist nur erforderlich, wenn Sie in Runtime Änderungen in der Benutzeranzeige vorgenommen haben.

  2. Beim Laden des Projekts bestimmen Sie im Dialog „Laden Vorschau“, ob Rezepturdaten überschrieben werden.

    Rezepturdaten können Sie in der Rezepturanzeige über die Bedienelemente „Archiv exportiere“ und „Archiv importieren“ speichern.

Beachten Sie, dass die zuletzt importierten bzw. geladenen Daten in Runtime verwendet werden.

Verbindung mit S7-1200 in Systemdiagnose

Bei Verwendung von Systemdiagnose kann nur ein WinCC Runtime Professional HMI System mit einer S7-1200 (bis V3) verbunden werden.

Automatische Überprüfung der Software-Aktualisierungen deaktivieren

Wenn das Engineering System zusammen mit der Runtime auf einem PC installiert ist, bekommt der Bediener Benachrichtigungen über die Software-Aktualisierungen. Damit das System auf einem Mehrplatzsystem stabil läuft, muss auf allen Rechner dieselbe Software-Version installiert sein.

Es ist möglich, die automatische Überprüfung der Software-Aktualisierungen zu deaktivieren und die Performance damit zu verbessern.

Sie deaktivieren die automatische Überprüfung der Software-Aktualisierungen unter "Einstellungen > Allgemein > Software-Aktualisierungen", indem Sie das Optionskästchen "Täglich auf Aktualisierungen überprüfen" deaktivieren.

Einschränkung der Online-Delta-Ladefähigkeit

Wenn Sie ein Design ersetzen, geht die Online-Delta-Ladefähigkeit des Projekts verloren. TIA Portal gibt in diesem Fall keine Fehlermeldung aus.

Bildobjekte in Protokollen als PDF

Die Qualität der Bildobjekte in den Protokollen, die Sie in Runtime als PDF-Datei erzeugen, hängt von den verwendeten PDF-Druckertreibern ab.

Projekte in Runtime nach Windows 10-Update

Sie haben auf einem PC mit WinCC Professional V15 und einem PC mit WinCC Professional RT V15 die Windows 10-Version 1709 installiert. Auf dem Runtime-PC haben Sie ein Windows 10-Update auf die Version 1803 durchgeführt. Nach dem Windows 10-Update ist es in Runtime unter Umständen nicht mehr möglich, ein vom Engineering System-PC geladenes Projekt manuell zu öffnen.

Abhilfe: Stellen Sie den Starttyp des Diensts der WinCC-SQL-Instanz manuell auf "Automatisch (Verzögerter Start)" und starten Sie das System neu.

Speicherbedarf von Archiven

Zur Berechnung des Speicherbedarfs für Meldungen über alle Segmente und für Einzelsegmente benötigen Sie die Information, wie viele Meldungen als Mittelwert pro Sekunde eingehen. Berücksichtigt wird der maximale Speicherbedarf einer Meldung von ca. 4000 Byte. Es gilt:
Speicherbedarf = Anzahl Meldungen/s * 4000 Byte * 60 s/min * 60 min/h * 24 h/Tag * 31 Tage/Monat * y Monate.

Im Beispiel wird von 1 Meldung pro Sekunde ausgegangen:

  • Für die max. Größe über alle Segmente bei 2 Monaten ergibt sich ca. 20 GB

  • Für ein Einzelsegment ergibt sich pro Tag ca. 330 MB

Zur Berechnung des Speicherbedarfs für Datenarchiven über alle Segmente und für Einzelsegmente benötigen Sie die Information, wie viele Werte pro Sekunde archiviert werden und die durchschnittliche Länge eines Porzesswertes. Es gilt:
Speicherbedarf = Anzahl der Archivwerte/s * x Bytes * 60 s/min * 60 min/h * 24 h/Tag * 31 Tage/Monat * y Monate

Im Beispiel wird von 750 Archivwerten pro Sekunde ausgegangen:

  • Für Prozesswerte mit 16 Bytes ergibt sich ein Speicherbedarf von ca. 60 GB

  • Für Prozesswerte mit 6 Bytes ergibt sich ein Speicherbedarf von ca. 22 GB


Bediengeräte

Bediengeräte

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hinweise zu Bediengeräten


Hinweise zu Bediengeräten

Inhalt Nicht unterstützte Bediengeräte (ab TIA Portal V15) Nicht unterstützte Bediengeräte (ab TIA Portal V15.1) Nicht unterstützte Bediengeräte (ab TIA Portal V16) Mehrtastenbedienung Bediengeräte mit hoher Kommunikationslast TS Adapter mit Ethernet Schnittstelle Simulation mit realer Steuerungsanbindung Simulation der Basic Panels Basic Panels 2nd Generation Bediengeräte mit Betriebssystem Windows CE 5.0 und höher Verbindungswechsel im Control Panel bei Basic Panels Meldungen drucken (Mobile Panel) DHCP auf KTP 400 PN, KTP 700 PN und KTP 900 PN Mobile Panel Sm@rtServer mit Mobile Panels Simulation von Basic Panels 2nd Generation Installation von Schriftarten Unterbrechung der DH485-Verbindung VB-Funktion "CDate" (Comfort Panels) Browser-Cache löschen (Panel)
PI Mobile
Hinweise zu Bediengeräten

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Nicht unterstützte Bediengeräte (ab TIA Portal V15)

Alle Bediengeräte mit der Version 11.x werden ab TIA Portal V15 nicht mehr unterstützt.

Folgende Bediengeräte werden ab TIA Portal V15 nicht mehr unterstützt:

  • WinAC MP 177, WinAC MP 277, WinAC MP 377

  • Panels: OP und TP der 70er Serie, 170er Serie und 270er Serie

  • Multi Panels: Multi Panels der 170er Serie, 270er Serie und 370er Serie

Um im TIA Portal V15 andere Geräte, z. B. Basic, Comfort oder Mobile Panels, nutzen zu können, die mit der Version 11.x projektiert wurden, ändern Sie die Geräteversion des betroffenen Geräts.

Auch die Ablagestruktur im Installationsverzeichnis enthält keine Daten für 11.0 mehr. Auf diese Weise wird die Größe des TIA Portal-Installationspakets im Vergleich zu den vorhergehenden Versionen reduziert.

Nicht unterstützte Bediengeräte (ab TIA Portal V15.1)

Folgende Bediengeräte werden ab TIA Portal V15.1 nicht mehr unterstützt:

  • WinCC Runtime Advanced V11

Nicht unterstützte Bediengeräte (ab TIA Portal V16)

Folgende Bediengeräte werden ab TIA Portal V15.1 nicht mehr unterstützt:

  • Mobile Panel mit der Geräteversion 12.x

  • Comfort Panel mit der Geräteversion 12.x

  • KP1500 Comfort mit der Geräteversion 13.x

  • TP1500 Comfort mit der Geräteversion 13.x

  • TP1900 Comfort mit der Geräteversion 13.x

  • TP2200 Comfort mit der Geräteversion 13.x

Mehrtastenbedienung

Durch eine Mehrtastenbedienung können unbeabsichtigte Aktionen ausgelöst werden:

  • Wenn Sie ein Tasten-Gerät verwenden, dürfen Sie nicht mehr als zwei Funktionstasten gleichzeitig betätigen.

  • Wenn Sie ein Touch-Gerät, einen Standard-PC oder einen Panel-PC verwenden, dürfen Sie immer nur eine Funktionstaste oder Schaltfläche gleichzeitig bedienen.

Bediengeräte mit hoher Kommunikationslast

Wenn bei einem Panel viele Verbindungen zu Steuerungen oder anderen Bediengeräten projektiert sind, sollte die S7-Diagnose deaktiviert sein. Andernfalls besteht die Gefahr der Überlastung des Panels.

TS Adapter mit Ethernet Schnittstelle

Wenn ein Bediengerät über Ethernet und einen TS Adapter verbunden ist, kann es nicht auf Werkseinstellungen zurückgesetzt werden.

Simulation mit realer Steuerungsanbindung

Der von der Simulation verwendete Zugangspunkt ist unabhängig von den Einstellungen im Engineering System und kann nur über das Tool " PG/PC Interface einstellen" in der Systemsteuerung verändert werden. Wenn die Verbindung zu einer Steuerung direkt nach dem Start der Simulation mit Meldung 140001 wieder abgebaut wird, sollten Sie den von der Simulation verwendeten Zugangspunkt mit " PG/PC Interface einstellen" überprüfen.

  1. Doppelklicken Sie in der Systemsteuerung auf "PG/PC Interface einstellen". Ein Dialog wird geöffnet.

  2. Wählen Sie im Bereich "Zugangspunkt der Applikation" "S7ONLINE" standardmäßig für HMI.

  3. Wählen Sie im Bereich "Benutzte Schnittstellenparametrierung" die Schnittstelle.

  4. Beenden Sie den Dialog "PG/PC Interface einstellen" mit OK.

Simulation der Basic Panels

Für die Ausgabe einer externen Variablen verwenden Sie ein Ausgabefeld in einem Meldetext. Bei der Simulation wird dann der Inhalt dieses Ausgabefelds immer mit "0" angezeigt.

Basic Panels 2nd Generation

Basic Panels 2nd Generation unterstützen die Option Sm@rtServer.

Wenn Sie keinen USB-Hub verwenden, wählen Sie den USB-Port USB_X60.1 als Ablagepfad.

Bediengeräte mit Betriebssystem Windows CE 5.0 und höher

Aufgrund einer geänderten Sicherheitseinstellung bei der Client-Server-Kommunikation darf der Zeitunterschied zwischen Bediengerät (Client) und einem PC (Server) nicht größer als 1 Tag sein. Wenn Sie z. B. Rezepturdaten vom Bediengerät auf ein Netzlaufwerk sichern, stellen Sie sicher, dass die Uhrzeit auf PC (Server) und Bediengerät (Client) korrekt eingestellt ist.

Verbindungswechsel im Control Panel bei Basic Panels

Wenn Sie die Funktion "Override projected connection information" verwenden, gilt folgende Einschränkung:

Der Verbindungswechsel im Control Panel eines Basic Panels von einer Steuerung ohne Schutzstufe zu einer Steuerung mit der Schutzstufe "Kompletter Schutz" ist nicht möglich.

Meldungen drucken (Mobile Panel)

Es ist nicht möglich, Meldungen als PDF oder HMTL zu drucken, wenn als "Storage Location" der interne Speicher "/flash" ausgewählt ist. Um Meldungen als PDF oder HMTL zu drucken, wählen Sie als Ablageort eine SD-Speicherkarte oder einen USB-Stick aus.

DHCP auf KTP 400 PN, KTP 700 PN und KTP 900 PN

Für die Geräte KTP 400 PN, KTP 700 PN und KTP 900 PN ist der Betrieb mit DHCP nicht empfohlen.

Unter Umständen kann es vorkommen, dass das Gerät nicht mehr bootet. In diesem Fall entfernen Sie das Netzwerkkabel und booten Sie das Gerät dann erneut. Nach dem erfolgreichen Hochlauf vergeben Sie bitte eine feste IP Adresse.

Mobile Panel

Mobile Panels 2nd Generation können mit TIA Portal V16 in der Geräteversion V15 projektiert werden. Allerdings kann das übersetzte Projekt nicht auf diese Geräte geladen werden.

Um mit Mobile Panels 2nd Generation im TIA Portal V16 zu arbeiten, ist eine Hochrüstung auf mindestens Geräteversion V15.1 erforderlich.

Sm@rtServer mit Mobile Panels

Die Auswertung der Sicherheitsbedienung über PROFIsafe ist nur gewährleistet, wenn der Sm@rtServer auf dem Panel deaktiviert ist.

Die Benutzung von Sm@rtServer auf Geräten ohne Sicherheitsfunktion ist nicht empfohlen.

Simulation von Basic Panels 2nd Generation

Für die Simulation der Basic Panels 2nd Generation sollte die 3D Hardwarebeschleunigung der Grafikkarte aktiviert sein.

Installation von Schriftarten

Wenn Sie mit ProSave neue Zeichensätze auf einem Panel installieren haben, ist ein Neustart des Panels erforderlich. Die Dauer des Startvorgangs der Runtime ist abhängig von Anzahl und Größe der Schriftarten.

Unterbrechung der DH485-Verbindung

Wenn Sie bei Comfort-Panels das Ethernet-Kabel an den Anschluss "PN_X1" des HMI-Panels anschließen, kann es zu einer Unterbrechung der DH485-Verbindung kommen.

Abhilfe für Comfort Redesign/PRO-Panels: Verwenden Sie beim Ausführen des DH485-Projekts auf dem HMI-Panel den Anschluss "PN_X3(Gigabit)" für die Ethernet-Kommunikation.

VB-Funktion "CDate" (Comfort Panels)

Auf folgenden Bediengeräten können Sie die VB-Funktion "CDate" nur mit statischen Parametern verwenden:

  • TP1200 Comfort Pro

  • TP1500 Comfort Pro / V2

  • TP1900 Comfort Pro / V2

  • TP2200 Comfort Pro / V2

Browser-Cache löschen (Panel)

Wenn Sie feststellen, dass das Laden von Webseiten im HTML-Browser deutlich länger dauert, kann dies am Browser-Cache liegen. Um den Browser-Cache zu löschen, führen Sie folgende VBS-Funktion in Runtime aus. Sie können diese VBS-Funktion auch im Aufgabenplanner als regelmäßige Aufgabe projektieren.

Kopiert den nachfolgenden Programmcode in die Zwischenablage.

Sub T7_DeleteBrowserCache()

' delete Browsercache filled temporary objects

Dim fso, nFileIndex,sFileName, nFileAttr, folder

On Error Resume Next

' Variable to show script is active

SmartTags("DeleteBrowserCacheActive") = True

folder = "\flash\simatic\Browsercache\data7\"

' Windows CE

Set fso = CreateObject("FileCtl.FileSystem")

' Get first item that matches path

sFileName = fso.Dir(folder & "*.*")

nFileIndex = 0

'Get the rest of matches

Do While sFileName <> ""

nFileAttr = fso.GetAttr(folder & sFileName)

If (nFileAttr And 16) <> 0 Then

fso.Kill("\flash\simatic\Browsercache\data7\"&sFileName&"\*.*")

If Err.Number <>0 Then

Err.Clear

End If

End If

nFileIndex = nFileIndex + 1

sFileName = fso.Dir

Loop

Set fso = Nothing

SmartTags("DeleteBrowserCacheActive") = False

End Sub


Optionen

Optionen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Sm@rtServer
  • Audit
  • DataMonitor
  • WebNavigator
  • WebUX
  • Redundancy
  • SIMATIC Information Server


Sm@rtServer

Inhalt SmartClient *.sac-Dateien unter Windows 10 öffnen
Sm@rtServer

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

SmartClient *.sac-Dateien unter Windows 10 öffnen

Sie speichern die Daten der aktuellen SmartServer-Verbindung mithilfe der ausführbaren Datei SmartClient.exe mit dem Format *.sac. Um die so erzeugte Dateien unter Windows 10 automatisch zu öffnen, muss eine *.sac-Datei mit SmartClient.exe einmal manuell über die Auswahlschaltfläche und Dialogfeld in der SmartClient.exe geöffnet werden.


Audit

Inhalt WinCC Audit Viewer 7.2 Update
Audit

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

WinCC Audit Viewer 7.2 Update

Für den optional installierbaren WinCC Audit Viewer 7.2 steht Ihnen ein Update zur manuellen Installation zur Verfügung.

Installieren Sie das Update zum WinCC Audit Viewer 7.2, indem Sie die Datei "AuditViewer_V72_00_Upd1.exe" aus dem Support-Verzeichnis der Produkt-DVD ausführen.


DataMonitor

Inhalt Deinstallation von WinCC Runtime Excel-Workbook auf einem PC mit Windows 7 Kanaldiagnose-Anzeige Zeitzonen von Webparts
DataMonitor

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Deinstallation von WinCC Runtime

Wenn Sie DataMonitor auch nach einer Deinstallation von WinCC Runtime Professional weiter verwenden wollen, müssen Sie eine Reparatur der Installation durchführen Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie die Systemsteuerung.

  2. Doppelklicken Sie "Software".

  3. Wählen Sie in der Liste der installierten Programme "SIMATIC WinCC/DataMonitor Client"

  4. Klicken Sie die Schaltflächen "Ändern/Entfernen".

  5. Wählen Sie im Setup von WinCC/DataMonitor die Einstellung "Reparatur".

Excel-Workbook auf einem PC mit Windows 7

Wenn Sie Excel-Workbook auf einem PC mit Windows 7 betreiben, müssen Sie die Darstellung "Aero Glass" deaktivieren.

Kanaldiagnose-Anzeige

Das Objekt "Kanaldiagnose-Anzeige" wird von der Option WinCC DataMonitor nicht unterstützt.

Zeitzonen von Webparts

Wenn Sie im Webcenter ein Webpart unter einer bestimmten Zeitzone erstellen und konfigurieren, wird die Zeitzone im Webcenter gespeichert.

Eine Änderung der Zeitzone im Betriebssystem kann dazu führen, dass die Zeitdarstellung im Webpart nicht korrekt ist.


WebNavigator

Inhalt Deinstallation von WinCC Runtime Virenscanner Trend Micro OfficeScan ProDiag-Übersicht, GRAPH-Übersicht und PLC-Code-Anzeige Nicht erlaubte Zeichen im WinCC WebNavigator Kanaldiagnose Verzögerung bei der Ausgabe der WebNavigator-Bilder
WebNavigator

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Deinstallation von WinCC Runtime

Wenn Sie WebNavigator auch nach einer Deinstallation von WinCC Runtime Professional weiter verwenden wollen, müssen Sie eine Reparatur der Installation durchführen Gehen Sie dazu wie folgt vor:

  1. Öffnen Sie die Systemsteuerung.

  2. Doppelklicken Sie "Software".

  3. Wählen Sie in der Liste der installierten Programme "SIMATIC WinCC/WebNavigator Client"

  4. Klicken Sie die Schaltflächen "Ändern/Entfernen".

  5. Wählen Sie im Setup von WinCC/WebNavigator die Einstellung "Reparatur".

Virenscanner Trend Micro OfficeScan

Die Verwendung des VirenScanners Trend Micro OfficeScan in Verbindung mit dem WebNavigator ist nicht empfehlenswert, da dieser Virenscanner zu sehr langen Bildaufschlagszeiten führen kann.

ProDiag-Übersicht, GRAPH-Übersicht und PLC-Code-Anzeige

Die Verwendung von WinCC Objekten "GRAPH-Übersicht", "ProDiag-Übersicht" und "PLC-Code-Anzeige" wird in der WinCC Option Web-Navigator nicht unterstützt.

Nicht erlaubte Zeichen im WinCC WebNavigator

Verwenden Sie in den Bildnamen und Projektnamen die Zeichen des ASCII-Zeichensatzes. Verwenden Sie keine Sonderzeichen und nationalen Sonderzeichen.

Kanaldiagnose

Das Objekt "Kanaldiagnose" wird von der Option WinCC WebNavigator nicht unterstützt.

Verzögerung bei der Ausgabe der WebNavigator-Bilder

Durch die WebServer-Technologie kann es vorkommen, dass aktualisierte WebNavigator-Bilder in Runtime verzögert ausgegeben werden.


WebUX

Inhalt Automatisches Login
WebUX

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Automatisches Login

Wenn das automatische Login nicht mehr gewünscht ist, müssen Sie die Browser-Historie im jeweiligen Browser löschen.


Redundancy

Inhalt Namen in der Konfiguration eines redundanten Systems
Redundancy

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Namen in der Konfiguration eines redundanten Systems

Für die Konfiguration eines redundanten Systems sind ausschließlich die Computernamen der Bediengeräte relevant. Den Computernamen eines Bediengeräts definieren Sie in dessen Betriebssystem. Der Name des Bediengeräts aus der Projektnavigation dient nur zur Identifikation des Bediengeräts im Projekt.


SIMATIC Information Server

Inhalt Installation von SIMATIC Information Server und WinCC Runtime Professional auf einem PC
SIMATIC Information Server

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe berücksichtigt werden konnten und wichtige Hinweise zu Produkt-Eigenschaften.

Installation von SIMATIC Information Server und WinCC Runtime Professional auf einem PC

Um den SIMATIC Information Server und WinCC Runtime Professional auf einem PC einzurichten, halten Sie die folgende Installationsreihenfolge ein:

  1. Installieren Sie WinCC Runtime Professional.

  2. Installieren Sie Information Server.

Wenn Sie die Installationsreihenfolge nicht einhalten, können Verbindungsprobleme auftreten.