Safety

Beispiele Siehe auch Verlauf Extras
Safety

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Security-Hinweise
  • Hinweise zur Benutzung
  • Geräte und Netze bearbeiten
  • PLC programmieren


Security-Hinweise

Security-Hinweise

Siemens bietet Produkte und Lösungen mit Industrial Security-Funktionen an, die den sicheren Betrieb von Anlagen, Systemen, Maschinen und Netzwerken unterstützen.

Um Anlagen, Systeme, Maschinen und Netzwerke gegen Cyber-Bedrohungen zu sichern, ist es erforderlich, ein ganzheitliches Industrial Security-Konzept zu implementieren (und kontinuierlich aufrechtzuerhalten), das dem aktuellen Stand der Technik entspricht. Die Produkte und Lösungen von Siemens formen einen Bestandteil eines solchen Konzepts.

Die Kunden sind dafür verantwortlich, unbefugten Zugriff auf ihre Anlagen, Systeme, Maschinen und Netzwerke zu verhindern. Diese Systeme, Maschinen und Komponenten sollten nur mit dem Unternehmensnetzwerk oder dem Internet verbunden werden, wenn und soweit dies notwendig ist und nur wenn entsprechende Schutzmaßnahmen (z. B. Firewalls und/oder Netzwerksegmentierung) ergriffen wurden.

Weiterführende Informationen zu möglichen Schutzmaßnahmen im Bereich Industrial Security finden Sie unter.

Die Produkte und Lösungen von Siemens werden ständig weiterentwickelt, um sie noch sicherer zu machen. Siemens empfiehlt ausdrücklich, Produkt-Updates anzuwenden, sobald sie zur Verfügung stehen und immer nur die aktuellen Produktversionen zu verwenden. Die Verwendung veralteter oder nicht mehr unterstützter Versionen kann das Risiko von Cyber-Bedrohungen erhöhen.

Um stets über Produkt-Updates informiert zu sein, abonnieren Sie den Siemens Industrial Security RSS Feed unter.


Hinweise zur Benutzung

Inhalt Das Handbuch als PDF-Datei
Hinweise zur Benutzung

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe und Handbuch berücksichtigt werden konnten.

Das Handbuch als PDF-Datei

Das Handbuch "SIMATIC Safety - Projektieren und Programmieren" wurde bei der Installation des Optionspakets STEP 7 Safety in den Installationsordner von STEP 7 Professional bzw. STEP 7 Basic in den Unterordner "Manuals" abgelegt.


Geräte und Netze bearbeiten

Geräte und Netze bearbeiten

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Allgemeine Hinweise zu Geräte und Netze


Allgemeine Hinweise zu Geräte und Netze

Keine Unterstützung für Roaming User Profiles Installation von HSPs Parametrierung der Phasenverschiebung für den F-OB
Allgemeine Hinweise zu Geräte und Netze

Keine Unterstützung für Roaming User Profiles

Sie können STEP 7 Safety nicht unter einem temporären Profil (engl. "Roaming User Profile") verwenden. Die Software ist damit nur eingeschränkt funktionsfähig. Kontaktieren Sie Ihren Domain Administrator, falls Sie ein temporäres Profil besitzen.

Installation von HSPs

Stellen Sie sicher, dass alle im Projekt benötigten HSPs installiert sind, bevor Sie mit dem Projekt arbeiten.

Parametrierung der Phasenverschiebung für den F-OB

Projektieren Sie die Phasenverschiebung für einen F-OB nach folgender Formel:

Phasenverschiebung < Max_Cyc - Weckalarm Zeit


PLC programmieren

PLC programmieren

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Allgemeine Hinweise zu PLC programmieren und zur Abnahme


Allgemeine Hinweise zu PLC programmieren und zur Abnahme

Inhalt Was müssen Sie bei der Installation von STEP 7 Safety beachten? Onlinefunktionen Hochrüsten auf STEP 7 Safety V16 Ergänzung zu Kapitel "CTD: Rückwärts zählen (STEP 7 Safety V16)" und Kapitel "CTUD: Vorwärts und rückwärts zählen (STEP 7 Safety V16)" Übersetzen des Sicherheitsprogramms Openness Startwerte von Variablen in der Bausteinschnittstelle Multiuser Engineering
Allgemeine Hinweise zu PLC programmieren und zur Abnahme

Inhalt

Hinweise, die nicht mehr in der Online-Hilfe und im Handbuch berücksichtigt werden konnten.

Was müssen Sie bei der Installation von STEP 7 Safety beachten?

Nach der Installation von STEP 7 Safety wird Ihr Sicherheitsprogramm im Safety Administration Editor als inkonsistent angezeigt. Stoßen Sie ein Übersetzen des Sicherheitsprogramms an. Als Ergebnis erhalten Sie ein konsistentes Sicherheitsprogramm. Die F-Gesamtsignatur Ihres Sicherheitsprogramms bleibt unverändert.

Onlinefunktionen

  • Das Öffnen von F-Bausteinen über die Lifelist ist mit STEP 7 Safety nicht möglich. Um alle Onlinefunktionen für F-Bausteine zu verwenden, müssen Sie das entsprechende Projekt offline geöffnet haben.

  • Verwenden Sie beim Offline-Online-Vergleich den Safety Administration Editor, wenn Sie Prüfsummen von F-Baustein betrachten wollen.

Hochrüsten auf STEP 7 Safety V16

  • Nach dem Hochrüsten eines Projekts, welches F-CPUs S7-300/400 enthält, empfehlen wir Ihnen, den Befehl "Übersetzen > Software (Bausteine komplett übersetzen)" auszuführen.

  • Der Name der F-Peripherie ist Bestandteil des Namens des zugehörigen F-Peripherie-DBs. Bei früheren Versionen von STEP 7 Safety wurde nicht immer sichergestellt, dass dieser Bestandteil mit dem Namen der F-Peripherie identisch ist. Dies wird beim Hochrüsten auf STEP 7 Safety V15 korrigiert. Die Funktionalität und die Gesamtsignatur Ihres Sicherheitsprogramms werden dadurch nicht geändert. Da sich jedoch die Namen der F-Peripherie-DBs geändert haben, sollten Sie nach der Hochrüstung einen aktuellen Sicherheitsausdruck erstellen und Ihren Abnahmeunterlagen hinzufügen.

Ergänzung zu Kapitel "CTD: Rückwärts zählen (STEP 7 Safety V16)" und Kapitel "CTUD: Vorwärts und rückwärts zählen (STEP 7 Safety V16)"

Wenn Sie in einem Know-how-geschützten F-Baustein die Anweisung CTD bzw. CTUD in der Version V1.1 verwenden, dann müssen Sie den F-Baustein vor dem Übersetzen durch Eingabe des Passworts öffnen, um die Version der Anweisung CTD bzw. CTUD auf eine Version ungleich V1.1 zu ändern.

Gleiches gilt, wenn Sie die Version der Anweisung CTD bzw. CTUD von einer Version ungleich V1.1 auf die Version V1.1 ändern möchten.

Übersetzen des Sicherheitsprogramms

In STEP 7 Safety V15.1 wird beim Übersetzen des Sicherheitsprogramms die F-Gesamtsignatur ermittelt und im Safety Administration Editor unter "Programmsignatur" angezeigt. Die F-Gesamtsignatur ist gültig, das Sicherheitsprogramm kann aber trotzdem inkonsistent sein. Dies ist der Fall, wenn die Hardware-Konfiguration nicht aktuell (übersetzt) ist.

Um ein konsistentes Sicherheitsprogramm zu erhalten, übersetzen Sie die Hardware-Konfiguration. Die F-Gesamtsignatur ändert sich dabei nicht.

Openness

Das Importieren und Exportieren von F-Bausteinen mit dem Openness-Befehlssatz wird nicht unterstützt.

Startwerte von Variablen in der Bausteinschnittstelle

Sie können auch in F-Bausteinen für Variablen (z. B. in der Static-Sektion) Anfangswerte vergeben, und hierfür Konstanten aus der TAG-Tabelle (globale Konstante) oder der CONST-Sektion (lokale Konstante) verwenden.

Beachten Sie, dass Sie F-Bausteine, bei denen globale Konstanten als Anfangswerte verwendet werden, nicht als Multiinstanz aufrufen dürfen, da in diesem Fall die F-CPU in STOP gehen kann. Bei Verwendung von lokalen Konstanten als Anfangswerte ist dies nicht der Fall.

Um den CPU-STOP zu vermeiden, sollten Sie globale Konstanten als Anfangswerte vermeiden, oder die Bausteine, in denen dies der Fall ist, ausschließlich als Single-Instanz aufrufen. Dies gilt sowohl für den Baustein selbst als auch für alle Bausteine, die diesen Baustein aufrufen, bis hinauf zum Main-Safety (gesamte Aufrufkette).

Multiuser Engineering

Beachten Sie in einer lokalen Session, dass es nicht möglich ist, Kommunikations-IDBs für Flexible F-Link auf dem Multiuser-Server einzuchecken. Das bedeutet, dass Sie Änderungen der Startwerte in der Serverprojekt-Ansicht durchführen müssen, da die Änderungen andernfalls durch Aktualisieren der lokalen Session überschrieben werden.