Readme

Examples See also History Extra
Readme

This section contains information on the following topics:
  • Notes on TIA Portal
  • STEP 7
  • WinCC
  • SIMOCODE ES
  • Safety
  • SIMATIC Safe Kinematics (S7-1500, S7-1500T)
  • SIMATIC Energy Suite readme
  • Readme Building Automation
  • Startdrive
  • SINUMERIK
  • SIMOTION SCOUT TIA
  • SINAMICS DCC
  • TIA Portal Version Control Interface


Notes on TIA Portal

Notes on TIA Portal

This section contains information on the following topics:
  • General notes
  • Notes on libraries
  • Notes on memory cards
  • Notes on using TIA Portal in a virtual environment (private cloud)
  • Notes on using the TIA Portal Teamcenter Gateway
  • Information on working with Multiuser Engineering


General notes

Information on TIA Portal in online support Collection of diagnostic and feedback data Starting TIA Portal Windows 7 / Windows Server 2008 R2: Invalid certificate validation Display of Asian characters in TIA Portal Installing new .Net versions or .Net service packs Operating TIA Portal Working with automatically synchronized network drives Entry of decimal places Opening projects with missing software components
General notes

The information in this readme file supersedes statements made in other documents.

Read the following notes carefully because they include important information for installation and use. Read these notes prior to installation.

Information on TIA Portal in online support

Overview of the most important technical information and solutions for TIA Portal in the Siemens Industry online support.

Internet link: TIA Portal in Siemens Industry online support

All information on service and support in the Siemens Industry online support:

Internet link: Service and support in Siemens Industry online support

Here, you can also subscribe to the newsletter that provides you with latest information relating to your products.

Collection of diagnostic and feedback data

We collect and process statistical usage and diagnostic data, such as frequency of use of TIA Portal editors or functions to keep the TIA Portal secure and up-to-date, to detect, diagnose and remedy problems, and for product improvements.

The usage and diagnostic data is initially saved locally on your computer in readable format where you can view it. Storage location: "...\ProgramData\Siemens\Automation\TelemetryConnector". (Note: The Windows administrator can set the folder so that it is visible.)

In a second step, the usage and diagnostic data is transferred to Siemens via secure communication for the purposes listed above.

Starting TIA Portal

When you start TIA Portal, Windows attempts to update the Certificate Revocation List (CRL) of "windowsupdate.com".

If no Internet access is available and there are multiple DNS servers, a timeout might occur and delay the start of TIA Portal.

Windows 7 / Windows Server 2008 R2: Invalid certificate validation

The new certificates used for signing might not be validated on the Windows 7 and Windows Server 2008 R2 operating systems.

If you do not have the possibility to update the certificate store online, the signature of the product files is displayed as invalid. In this case, update the root certificates provided by Microsoft on the offline systems. To do so, follow the instructions in FAQ 109748887.

Display of Asian characters in TIA Portal

Texts in TIA Portal might not display correctly if you install a Chinese TIA Portal on another Asian operating system (for example, Korean). To view the texts in TIA Portal correctly, open the Windows Control Panel and select "English" under "Language for non-Unicode programs". Note, however, that this can cause display problems in other programs.

Installing new .Net versions or .Net service packs

  • Close TIA Portal before installing a new .Net version or a new .Net service pack on your programming device/PC.

  • Restart TIA Portal only after successful installation of the new .Net version or the new .Net service pack.

Operating TIA Portal

  • If a project in the list of projects last used is located on a network drive that is not connected, you might experience delays when opening the "Project" menu.

  • When you insert a CPU, you might need to wait for some time if the project editor is open at the same time. This generally takes longer when you insert the first CPU in a newly created project. To be able to continue working at a good pace, you should close the project text editor before inserting a CPU.

  • The alarm "Application is not responding" might appear in Windows 7 with functions that take a long time to run (loading the CPU for example). If this occurs, wait until the function has correctly finished.

  • If you have installed a Microsoft mouse with IntelliPoint, you might find that it superimposes components over the buttons of the title bar. If this is the case, uninstall the IntelliPoint software from Microsoft.

  • Enabling the "Virtual Desktop" options with NVIDIA graphics cards can cause problems. In this case, disable the "nView virtual desktop manager" of your NVIDIA graphics driver.

Working with automatically synchronized network drives

A TIA Portal project consists of multiple files that are saved together in one directory. If you store a project that is automatically synchronized on a network drive or in a cloud directory (e.g. Dropbox, Syncplicity or GoogleDrive), this can lead to data loss if the synchronization only takes place partially or asynchronously. For this reason, we do not recommend editing TIA Portal projects directly on synchronized network drives or in cloud directories. Always close TIA Portal project before synchronization and make sure that all directories and files from the project directory are synchronized together and completely. You might wish to disable automatic synchronization while working with TIA Portal. The synchronization itself must be implemented in such a way that the current (local) project data replaces the project data on the network drive or in the cloud directory.

Entry of decimal places

With certain Windows language settings, it might occur that the entry of values with a comma as a decimal place is not recognized (entering "1,23" leads to an error). Instead, use the international format ("1.23").

Opening projects with missing software components

If a project cannot be opened in TIA Portal due to missing software components, you can download and install it as trial software from Siemens Industry online support. You can then open the project. Note that the trial software can only be used for a limited period of time.

Use the following link to open the page in Siemens Industry online support, where the various software products are available to you as trial software: www.siemens.com/tia-portal-trial


Notes on libraries

Contents Copying library elements
Notes on libraries

Contents

Information that could not be included in the online help and important information about product characteristics.

Copying library elements

If master copies and types have the same name, the corresponding objects in the project are overwritten when the action "Copy" is used. Note that this takes place without a prompt. The same behavior occurs when the name of the master copy is different to the name of the type, but an object within the master copy has the same name as the type.


Notes on memory cards

Contents SIMATIC memory cards Behavior in case of open force job Access protection for memory cards in USB card readers Removing/inserting the memory card
Notes on memory cards

Contents

Information that could not be included in the online help and important information about product characteristics.

SIMATIC memory cards

The SIMATIC memory cards have been formatted and set up by Siemens for use with S7-1200 and S7-1500 modules. This format must not be overwritten; otherwise, the card will no longer be accepted by the modules. Formatting with Windows tools is therefore not permitted.

Behavior in case of open force job

Note that an active force job is retained even after you have loaded a new project to the SIMATIC memory card. This means you should first delete the active force job before you remove a SIMATIC memory card from the CPU and before you overwrite the card in the PC with a new project. If you use a SIMATIC memory card with unknown content, you should format the SIMATIC memory card before the next download.

Access protection for memory cards in USB card readers

By improving the security mechanisms for online access and engineering of S7-1500 CPUs, the data storage on memory cards has been changed. For this reason, this version of STEP 7 cannot evaluate the passwords of the configured protection level when reading project data from memory cards that is accessed via a USB card reader. The changed response affects the memory cards for CPUs of the S7-1200/1500 series. Therefore, use physical safeguards to protect critical project data on memory cards for these devices.

Note

This restriction is not related to online access to devices or the know-how protection of program blocks.

Removing/inserting the memory card

After removing or inserting a memory card, always perform a memory reset on the CPU in order to restore the CPU to a functional condition.


Notes on using TIA Portal in a virtual environment (private cloud)

Contents Instructions for using TIA Portal in a virtual environment (private cloud) Environment variables "TiaUserSettingsPath" and "TiaDefaultProjectPath" Self-signed certificates using HTTPS as communication protocol
Notes on using TIA Portal in a virtual environment (private cloud)

Contents

Information that could not be included in the online help and important information about product characteristics.

Instructions for using TIA Portal in a virtual environment (private cloud)

You can find instructions on how to use TIA Portal in a virtual environment (private cloud) on the installation disk in the directory "Documents\Readme\<language directory>". You can open the PDF document "TIAPortalCloudConnectorHowTo<language ID>.pdf" here.

The TIA Portal Cloud Connector can be used with the Windows 7 (64-bit) and Windows 10 (64-bit) operating systems.

Environment variables "TiaUserSettingsPath" and "TiaDefaultProjectPath"

The environment variables "TiaUserSettingsPath" and "TiaDefaultProjectPath" can be used to set the location of the user and project settings different from the system default. This can be used, for example, to save the user and project settings at a central location.

You can find additional information on the use of environment variables in the Instructions on Using TIA Portal in a Virtual Environment (Private Cloud).

Self-signed certificates using HTTPS as communication protocol

Microsoft regularly checks whether the certificates in the Windows Certificate Store are from a trusted source. Certificates from untrusted sources are deleted. Therefore, ensure that your self-signed certificates are signed with a secure certificate.


Notes on using the TIA Portal Teamcenter Gateway

Contents Installing the TIA Portal Teamcenter Gateway Using the TIA Portal Teamcenter Gateway Installing the TIA Portal Teamcenter Gateway - data model Updating the existing TIA Portal Teamcenter Gateway data model Notes on Teamcenter Note on TCCS (Teamcenter Client Communication System) Note on UTF-8 Note on cloud computing Basic information on working with TIA Portal Teamcenter Gateway Connecting to Teamcenter Teamcenter version information Setting the TIA Portal Teamcenter Gateway cache path Performing TIA Portal Teamcenter Gateway operations while WinCC Professional Simulation is running
Notes on using the TIA Portal Teamcenter Gateway

Contents

Information that could not be included in the online help and important information about product characteristics.

Installing the TIA Portal Teamcenter Gateway

You can find instructions for installing the TIA Portal Teamcenter Gateway in the TIA Portal Teamcenter Gateway online help under "Installing and uninstalling TIA Portal Teamcenter Gateway".

Using the TIA Portal Teamcenter Gateway

The installation of the TIA Portal Teamcenter Gateway gives you access to the TIA Portal Teamcenter Gateway function that is available as of TIA Portal V14 and higher.

Installing the TIA Portal Teamcenter Gateway - data model

You can find a description for installing the TIA Portal Teamcenter Gateway data model on the installation data medium in the directory "\Support\Teamcenter_11\ServerSetupDocument\" on the STEP 7/WinCC DVD2. Open the PDF document "Datamodel_Installation_enUS". The instructions for installing the TIA Portal Teamcenter Gateway data model are only available in English.

Updating the existing TIA Portal Teamcenter Gateway data model

  • Restart TIA Portal after updating the existing TIA Portal Teamcenter Gateway data model.

  • In the TIA Portal Teamcenter Gateway V15 and V15.1, no changes were made to the existing TIA Portal Teamcenter Gateway data model and no changes specific to the Teamcenter as well.

Notes on Teamcenter

To work with the TIA Portal Teamcenter Gateway, Teamcenter Rich Application Client (RAC) or Teamcenter Client Communication System (TCCS) as of version 11.2 must be installed on your PG/PC.

Note on TCCS (Teamcenter Client Communication System)

If you have completed the installation of TCCS (Teamcenter Client Communication System) as a "standalone" installation, you also need to install "Microsoft Visual C++ 2013 – Redistributable".

Note on UTF-8

In order to display data from Teamcenter with non-English character sets, e.g. for Asian languages, in TIA Portal, Unicode character sets need to be used.

Note on cloud computing

If you run TIA Portal in a Cloud (for example virtual machine), this system has to be integrated into the Teamcenter environment. Direct integration via a remote connection is not supported by TIA Portal Teamcenter Gateway.

Basic information on working with TIA Portal Teamcenter Gateway

As of TIA Portal Teamcenter Gateway version V15, the Teamcenter operation "Teamcenter > Export..." is available for TIA Portal projects and global libraries.

With this operation, you create a copy of the current project, which is completely free of any Teamcenter information. If you need to separated from Teamcenter, use this operation instead of the "Save as" operation because "Save as" retains Teamcenter information in the project.

Connecting to Teamcenter

As of TIA Portal Teamcenter Gateway V15.1 Update 3, you can establish a connection between TIA Portal and Teamcenter both via HTTP and via HTTPS.

Teamcenter version information

To work with the TIA Portal Teamcenter Gateway version V15.1 or the TIA Portal Teamcenter Gateway version V16 and Teamcenter version V11.6, you need to have Teamcenter version V11.6.0.5 or higher installed. As of Teamcenter version V11.6.0.5, improvements have been which allow it to work smoothly with Teamcenter version V11.6.

As of the TIA Portal Teamcenter Gateway version V16, working with the Teamcenter version V12.2.0.0.0 is supported.

Setting the TIA Portal Teamcenter Gateway cache path

By default, the value entered under "Options > Settings > General > Teamcenter Gateway" in the "TIA Portal Teamcenter Gateway Cache Path" area is taken as "TIA Portal Teamcenter Gateway Cache Path".

By default, this value refers to the project directory path.

If you change the value of the "TIA Portal Teamcenter Gateway Cache Path", Teamcenter Gateway checks the validity of the values entered by default and the changed values.

Note

The default value must not be empty.

Performing TIA Portal Teamcenter Gateway operations while WinCC Professional Simulation is running

Do not perform Teamcenter Gateway operations, such as "Check in" or "Undo check out" during a started WinCC Professional Simulation.


Information on working with Multiuser Engineering

Contents Name changes Microsoft system account for project server Error message when starting the project server Working with active monitoring jobs and forcing jobs in the local session Working in the local session with the "Keep local session" option Working with different versions of TIA Portal Working with Multiuser Commissioning
TIA Portal in Siemens Industry online support FAQ with ID 109739926
Information on working with Multiuser Engineering

Contents

Information that could not be included in the online help and important information about product features of Multiuser Engineering and about the project server.

The installation of the project server allows you to use the "Multiuser Engineering", "Multiuser Commissioning" and "Exclusive Engineering" functions available with the corresponding TIA Portal.

Name changes

In TIA Portal version V16 the following name changes were made in the context of Multiuser Engineering :

Previous name | New name in TIA Portal V16 and higher
Multiuser server | TIA project server
Local Multiuser server | Local project server
Multiuser server project | Server project
Multiuser network profiles | Network profiles

The project server can be used for Multiuser Engineering, and also for Multiuser Commissioning and Exclusive Engineering .

There are no functionality restrictions between the project server V16 and the Multiuser server V15.1.

The functionality of the server remains unchanged depending on the version.

The project server V16 is backward compatible with the Multiuser server V14.

Microsoft system account for project server

When the project server is installed, a Microsoft system account is created for the project server. Microsoft changes the password cyclically for this account.

If the password for this account has expired, the password needs to be changed and then the project server needs to be restarted.

Error message when starting the project server

If you get an error message during or after installing the project server stating that the service for the project server cannot be started, the following procedure is recommended:

  1. Open the Windows event view and check whether an error entry with the error number "1069" is present.

  2. If this is the case, information on how to proceed is provided below.

    Internet link: TIA Portal in Siemens Industry online support

  3. Alternatively, you can contact Customer Support directly.

    Internet link to Customer Support: FAQ with ID 109739926

Working with active monitoring jobs and forcing jobs in the local session

Active monitoring jobs and forcing jobs must be closed before a check-in or update in the local session. It is not possible to check in or update in the local session while monitoring or forcing jobs are active.

Working in the local session with the "Keep local session" option

If the "Keep local session" option is selected after the check-in, all checked-in objects in the local session appear as outdated, even if their content is identical.

Working with different versions of TIA Portal

Local sessions created with <x.y> version of TIA Portal can only be worked on with this version.

Example: A local session created with TIA Portal V16 as part of a V16 project cannot be edited with an earlier version of TIA Portal.

Working with Multiuser Commissioning

  • When you work with Multiuser Commissioning, a new revision of the server project is created after each download to the CPU. However, a new revision is not created when objects that cannot be marked were edited in the local session. Changes to objects that cannot be marked are lost during check-in and are not downloaded to the CPU.

  • When you start download to the device in Commissioning mode from the project tree with the menu command "Download to device > Hardware configuration", the dialog which informs you that different data exists on the CPU and in the server project is always displayed.

  • When you work in Commissioning mode, only S7-1500 CPUs are fully supported. When using an S7-300/400 CPU, the dialog which informs you that different data exists on the CPU and in the server project is always displayed in Commissioning mode. The reason is that S7-300/400 CPUs do not support synchronization. To prevent this message from being displayed, you should disable the option "Check for data mismatch before loading (recommended)" in the Administration tool.