Technological functions

Examples See also History Extra
Technological functions

This section contains information on the following topics:
  • Notes on S7-1500 Motion Control (S7-1500, S7-1500T)
  • Notes on additional technology functions (S7-1500)
  • Notes on technological functions (S7-1200)
  • Notes on technological functions (S7-300, S7-400)
  • SIMATIC STEP 7 Easy Motion Control
  • SIMATIC STEP 7 PID Professional


Notes on S7-1500 Motion Control (S7-1500, S7-1500T)

Examples See also History Extra
Technology alarms 900-902 Upgrading projects in TIA Portal version V16 Behavior of the modulo cycle counter when homing with "MC_Home" Use of the "DX_TEL_SyncOp" data type for cross-PLC synchronous operation Manually configuring delay times on the leading axis and the virtual following axis Calculation of the following error Performance of the user transformation with dynamic adaptation (S7-1500T) The maximum bandwidth of the CPU is limited for records with kinematics trace (S7-1500T) Blending between path motions and synchronous "point-to-point" motions (sPTP motions) (S7-1500T) Changing the override for synchronous "Point-to-point" motions (sPTP motion) (S7-1500T) Use of blending with kinematics motions (S7-1500T) Use of the "MC_TrackConveyorBelt" Motion Control instruction with the technology version V5.0 (S7-1500T)
Notes on S7-1500 Motion Control
S7-1500, S7-1500T

Technology alarms 900-902

Contrary to the documented behavior, the received leading value is detected as invalid with technology alarms 900 and 901 as alarm response. Technology alarm 902 has no alarm response.

The technology alarms 900 and 901 are displayed in the diagnostics buffer.

No. | Response | Error bit | Warning bit | Restart | Diagnostics buffer | Alarm text
900 | Set invalid leading value | X2 | - | - | X | Invalid leading values.
901 | Set invalid leading value | X2 | - | - | X | Data transmission error.
902 | No response | - | X2 | - | - | Accuracy of leading value is limited.

You can acknowledge a technology alarm 900 with an "MC_Reset" job with "Restart" = FALSE. A restart is not required.

The technology alarm 900 is displayed with the following alarm text:

Alarm text | Solution
Invalid leading values. | Set a higher tolerance time (<TO>.Parameter.ToleranceTimeExternalLeadingValueInvalid). Check the connection of the interconnected components. Make sure that there is no communication interference. Make sure that the CPUs involved are in RUN operating state.

The technology alarm 901 is displayed with the following alarm text:

Alarm text |  | Solution
Data transmission error |  |
 | Invalid version | Check the communication.
 | Invalid modulo start value
 | Invalid modulo length
 | Sign-of-life error
 | Invalid position | Check the leading value of the leading axis on the other CPU.
 | Invalid velocity
 | Invalid acceleration

Upgrading projects in TIA Portal version V16

Due to changes in the project storage format in TIA Portal version V16, a conversion of existing projects is necessary. Depending on the size of the project, a conversion can take a long time. The total duration of the conversion can take between several minutes to over an hour.

Behavior of the modulo cycle counter when homing with "MC_Home"

In contrast to the documented behavior, the modulo cycle counter responds during direct relative homing with "Mode" = 1, 12 and with absolute value encoder calibration (relative) with "Mode" = 6 as with direct absolute homing with "Mode" = 0. The counter values of the modulo cycles change during homing and the absolute encoder calibration with the listed modes as follows:

Action | Description
Absolute value calibration with "Mode" = 6 | The modulo value is the shortest distance between the current and new position. Depending on the distance, the modulo cycle counter can remain the same, increase by 1 or decrease by 1.
Direct homing relative with "Mode" = 1, 12 | The modulo value is the shortest distance between the current and new position. Depending on the distance, the modulo cycle counter can remain the same, increase by 1 or decrease by 1.

Use of the "DX_TEL_SyncOp" data type for cross-PLC synchronous operation

Output and input tags with the "DX_TEL_SyncOp" data type are created for the cross-PLC synchronous operation at the start address of the transfer area. If the data type "DX_TEL_SyncOp" cannot be assigned, it was deleted with the last compilation.

Unused data types are deleted during the compilation. To restore the "DX_TEL_SyncOp" data type, add a V5.0 technology object. After using the data type in the PLC tag, the technology object can be deleted again

Manually configuring delay times on the leading axis and the virtual following axis

If you increase the delay time of the leading axis in the leading value settings, this results in a reduction of the extrapolation time at the leading axis proxy or to an increase of the interpolation time of the distributed leading value at the leading axis proxy. This reduces the error resulting from extrapolation in the acceleration and delay phases of the leading value.

If the delay time at the leading axis proxy is increased, this results in an increase of the extrapolation time or to a reduction of the interpolation time.

Calculation of the following error

The following error is the difference between the setpoint and actual position based on the connection of the axis at the drive. In contrast to the documented behavior, the transmission times of the setpoints from the controller to the drive and the position values from the drive to the controller are not part of the following error. The value of the following error is thus not the same as the difference between the setpoint available in the controller minus the existing actual position.

Performance of the user transformation with dynamic adaptation (S7-1500T)

With the Technology Version V5.0, longer runtimes of the MC-Interpolator [OB92] arise with the user transformation. With longer runtimes of the MC-Interpolator [OB92] the runtimes of the organization blocks with lower priority are extended.

The maximum bandwidth of the CPU is limited for records with kinematics trace (S7-1500T)

For violations of the maximum bandwidth, not all signals of a record can be recorded and evaluated with kinematics trace.

Consider the system limits of the CPU (maximum 16 signals)

For different objects, the following signals are required:

Object | Signals used
TCP and kinematics (depending on kinematics) | 4-8
TCP (depending on kinematics) | 2-4
OCS 1 (depending on kinematics) | 2-6
OCS 2 (depending on kinematics) | 2-6
OCS 3 (depending on kinematics) | 2-6

Deactivate active signals under "Technology object > Kinematics trace > Configuration > Records".

Blending between path motions and synchronous "point-to-point" motions (sPTP motions) (S7-1500T)

When using blending from a path motion to an sPTP motion, there might not be any blending or the blending segment could be significantly shortened.

When using blending of path motions and sPTP motions, set the path dynamics as high as possible.

  • Jerk

  • Acceleration

Changing the override for synchronous "Point-to-point" motions (sPTP motion) (S7-1500T)

When changing the override, the path of the motion of the tool center point (TCP) can change an sPTP motion.

If the motion contour of the TCP is to be retained, proceed with kinematics with minimal change to the override.

Use of blending with kinematics motions (S7-1500T)

Dynamic overruns on the kinematics axes might occur during blending.

Use of the "MC_TrackConveyorBelt" Motion Control instruction with the technology version V5.0 (S7-1500T)

Use of the "MC_TrackConveyorBelt" Motion Control instruction is not possible with the technology version V5.0.


Notes on additional technology functions (S7-1500)

Examples See also History Extra
Parameters of the technology objects in TIA Portal Openness S_USSI on S7‑1500 PtP module with CM 1243-5 PROFIBUS Master PID_Temp on CPU 1500 V1.7
Notes on additional technology functions
S7-1500

Parameters of the technology objects in TIA Portal Openness

You can find a list of the available technology object parameters in the product information "Parameters of the technology objects in TIA Portal Openness" on the internet.

S_USSI on S7‑1500

Note the following when using the instruction S_USSI of the distributed I/O ET 200S 1SI on an S7‑1500.

The parameter ANZ shows the value 0 even in the case of an error.

If the CPU is switched to stop with the S_USSI instruction, check all possible errors listed at the parameter ANZ.

PtP module with CM 1243-5 PROFIBUS Master

You have to make the following settings in the instance DB of the instructions when using the PtP modules CM PtP RS232 BA, CM PtP RS422/485 BA, CM PtP RS232 HF, CM PtP RS422/485 HF and CM PtP with a CM 1243-5 PROFIBUS Master with firmware ≤ V1.3.4:

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240

PID_Temp on CPU 1500 V1.7

Note the following when using PID_Temp on a CPU 1500 with firmware version V1.7:

  • The integrated dead zone in PID_Temp must not be used on CPU 1500 V1.7.

    Do not change the preset 0.0 of the associated parameters Retain.CtrlParams.Heat.DeadZone and Retain.CtrlParams.Cool.DeadZone.

  • If the cooling output is active (PidOutputSum < 0.0, OutputCool <> 0.0) for a closed loop controller with active cooling and PID parameter switchover (Config.ActivateCooling = TRUE, Config.AdvancedCooling = TRUE) while "Pretuning cooling" is started (Mode = 1, Heat.EnableTuning = FALSE, Cool.EnableTuning = TRUE), aborts with error ErrorBits = 16#0040_0000.

    • In this case use "Fine tuning cooling" (Mode = 2, Heat.EnableTuning = FALSE, Cool.EnableTuning = TRUE)

    or

    • Before starting the pretuning, switch to manual mode with a manual value larger than 0.0 (Mode = 4, ManualValue ≥ 0.0).

As of firmware version V1.8, these two restrictions no longer apply.


Notes on technological functions (S7-1200)

Examples See also History Extra
Automatically apply drive or encoder values during configuration (offline) ErrorID 16#820D PtP module with CM 1243-5 PROFIBUS Master
Notes on technological functions
S7-1200

Automatically apply drive or encoder values during configuration (offline)

Not all configuration parameters are automatically applied when connecting a SINAMICS V90 PN via HSP. Deactivate the "Automatically apply drive values during configuration (offline)" option and apply the configuration parameters of the drive and encoder manually in the configuration of the technology object.

ErrorID 16#820D

ErrorID | ErrorInfo | Description | Solution
16#820D |  | Technology object is in restart
 | 16#0001 | - | Acknowledge error with instruction "MC_Reset" and restart the job, if necessary

PtP module with CM 1243-5 PROFIBUS Master

You have to make the following settings in the instance DB of the instructions when using the PtP modules CM PtP RS232 BA, CM PtP RS422/485 BA, CM PtP RS232 HF, CM PtP RS422/485 HF and CM PtP with a CM 1243-5 PROFIBUS Master with firmware ≤ V1.3.4:

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240


Notes on technological functions (S7-300, S7-400)

Examples See also History Extra
Parameter assignment for the FM x51 and FM x52 Programming FM x50-1, FM x51 and FM x52 IM 174 migration
Notes on technological functions
S7-300, S7-400

Parameter assignment for the FM x51 and FM x52

In contrast to the information in the Online Help, if you change the measuring system, the previously entered parameter values are not converted to the new measuring system.

Programming FM x50-1, FM x51 and FM x52

The "initial values" specified in the parameter tables in the online help regarding the instructions correspond to the "default value" in the software interface of the user programming.

IM 174 migration

During the migration of projects with IM 174, the parameter assignment of IM 174 is set to default values. It is absolutely necessary to set parameters for IM 174 again after the migration.