STEP 7

Ejemplos Consulte también Historial Herramientas
STEP 7

Este capítulo incluye información sobre los siguientes temas:
  • Información de seguridad
  • Indicaciones de manejo
  • Funcionamiento online paralelo
  • Editar dispositivos y redes
  • Programación del PLC
  • Inter Project Engineering (IPE)
  • Funciones tecnológicas


Información de seguridad

Información de seguridad Ajustes de red
Información de seguridad

Información de seguridad

Siemens ofrece productos y soluciones con funciones de seguridad industrial con el objetivo de hacer más seguro el funcionamiento de instalaciones, sistemas, máquinas y redes.

Para proteger las instalaciones, los sistemas, las máquinas y las redes de amenazas cibernéticas, es necesario implementar (y mantener continuamente) un concepto de seguridad industrial integral que sea conforme a la tecnología más avanzada. Los productos y las soluciones de Siemens constituyen únicamente una parte de este concepto.

El cliente es responsable de impedir el acceso no autorizado a sus instalaciones, sistemas, máquinas y redes. Los sistemas, las máquinas y los componentes solo deben estar conectados a la red corporativa o a Internet cuando y en la medida que sea necesario y siempre que se hayan tomado las medidas de protección adecuadas (p. ej. uso de cortafuegos y segmentación de la red).

Adicionalmente, deberán observarse las recomendaciones de Siemens en cuanto a las medidas de protección correspondientes. Encontrará más información sobre seguridad industrial en

https://www.siemens.com/industrialsecurity

Los productos y las soluciones de Siemens están sometidos a un desarrollo constante con el fin de mejorar todavía más su seguridad. Siemens recomienda expresamente realizar actualizaciones en cuanto estén disponibles y utilizar únicamente las últimas versiones de los productos. El uso de versiones anteriores o que ya no se soportan puede aumentar el riesgo de amenazas cibernéticas.

Para mantenerse informado de las actualizaciones de productos, recomendamos que se suscriba al Siemens Industrial Security RSS Feed en

https://www.siemens.com/industrialsecurity

Ajustes de red

Las tablas siguientes muestran los ajustes de red de cada producto, necesarios para analizar la seguridad de red y la configuración de cortafuegos externos:

STEP 7 Professional
Nombre | Número de puerto | Protocolo de transporte | Sentido | Función | Descripción
ALM | 4410* | TCP | In-/Outbound | Servicio de licencias | Este servicio pone a disposición todas las funciones para licencias de software, y se utiliza tanto en el Automation License Manager como en todos los productos de software sujetos a licencias.
RFC 1006 | 102 | TCP | Outbound | Comunicación S7 | Comunicación con el controlador S7 a través de Ethernet / PROFINET con fines de programación y diagnóstico.
DCP | --- | Ethernet | Outbound | PROFINET | El protocolo DCP (Discovery and basic Configuration Protocol) se utiliza en PROFINET y es la función básica para la localización y configuración de dispositivos PROFINET.
SNMP | 161 | UDP | Outbound | PROFINET | La función de cliente SNMP se utiliza en STEP 7 para leer información de estado de dispositivos PROFINET.
* Puerto estándar, que el usuario puede cambiar mediante configuración

WinCC ES Basic (sin simulación)
Nombre | Número de puerto | Protocolo de transporte | Sentido | Función | Descripción
ALM | 4410* | TCP | In-/Outbound | Servicio de licencias | Este servicio pone a disposición todas las funciones para licencias de software, y se utiliza tanto en el Automation License Manager como en todos los productos de software sujetos a licencias.
HMI Load | 1033 | TCP | Outbound | HMI Load (RT Basic) | Este servicio se utiliza para transferir imágenes y datos de configuración a Basic Panels.
* Puerto estándar, que el usuario puede cambiar mediante configuración

Simulation RT Basic
Nombre | Número de puerto | Protocolo de transporte | Sentido | Función | Descripción
HMI Load | 1033 | TCP | Inbound | HMI Load (RT Basic) | Este servicio se utiliza para transferir imágenes y datos de configuración a Basic Panels.
EtherNet/IP | 44818 | TCP | Outbound | Ethernet/canal IP | El protocolo Ethernet/IP se utiliza para conexiones con todos los PLC Allen Bradley.
 | 2222 | UDP | Inbound | Ethernet/canal IP | El protocolo Ethernet/IP se utiliza para conexiones con todos los PLC Allen Bradley.
Modbus TCP | 502 | TCP | Outbound | Canal Modbus TCP | El protocolo Modbus TCP se utiliza para conexiones con PLC Schneider.
RFC 1006 | 102 | TCP | Outbound | Canal S7 | Comunicación con el controlador S7 vía Ethernet/PROFINET
Mitsubishi MC | 5002 | TCP | Outbound | Canal Mitsubishi MC | El protocolo Mitsubishi se utiliza para conexiones con PLC Mitsubishi.


Indicaciones de manejo

Contenido Compatibilidad tras actualizar un proyecto a la versión V16 Uso paralelo Enchufar y desenchufar tarjetas o módulos Ethernet Compatibilidad (S7-1200)
Indicaciones de manejo

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Compatibilidad tras actualizar un proyecto a la versión V16

Después de actualizar un proyecto a la versión V16 es posible que se indiquen diferencias entre los programas online y offline aunque estos sean idénticos. Estas diferencias se deben a que en la versión V16 se ha optimizado el cálculo de las sumas de verificación. Sin embargo, en la mayoría de los casos los bloques son compatibles.

No obstante, en raras ocasiones el cálculo modificado de la suma de verificación hace necesario compilar y cargar el proyecto nuevamente antes de poderlo observar y probar.

Encontrará más información en las propiedades del proyecto, en el informe de actualización. Si en el informe se notifica una incoherencia de las sumas de verificación, las diferencias entre online y offline se deben al cálculo modificado de las sumas de verificación.

Encontrará más información en el capítulo "Conexión online después de actualizar un proyecto".

Uso paralelo

Si después de la instalación, el nombre o la clave de licencia del software llevase el indicativo "Combo", estará autorizado para utilizar los siguientes productos y versiones según el apartado 1.6 de las Condiciones generales (véase también el texto de la instalación):

  • STEP 7 Professional 2017

  • STEP 7 Professional 2010

  • STEP 7 Professional 2006

Enchufar y desenchufar tarjetas o módulos Ethernet

En caso de desenchufar y volver a enchufar tarjetas o módulos Ethernet durante el funcionamiento, es necesario reiniciar el PC; de lo contrario la funcionalidad "Dispositivos accesibles" en STEP 7 o NCM PC no mostrará todos los dispositivos (estaciones). Mientras arranca el PC deben estar activadas las tarjetas o módulos Ethernet.

Compatibilidad (S7-1200)

La configuración de dispositivos y el programa de una CPU S7-1200 deben estar configurados por norma con la misma versión de STEP 7. Normalmente, el TIA Portal impide que surjan conflictos entre versiones mediante las indicaciones oportunas durante la carga en el dispositivo.

Sin embargo, en el caso de las CPUs S7-1200 con versión de firmware V1.x no es posible realizar esta comprobación automática, por lo que dicha responsabilidad recae en el usuario.


Funcionamiento online paralelo

Contenido Funcionamiento online paralelo Conexiones online simultáneas con una CPU S7-1200 (S7-1200)
Funcionamiento online paralelo

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Funcionamiento online paralelo

El funcionamiento paralelo en modo online de STEP 7 V5.6 o anterior y STEP 7 V16 (TIA Portal) no está autorizado.

Conexiones online simultáneas con una CPU S7-1200 (S7-1200)

No es posible establecer una conexión online con la misma CPU S7-1200 desde varias instancias del TIA Portal.


Editar dispositivos y redes

Editar dispositivos y redes

Este capítulo incluye información sobre los siguientes temas:
  • Indicaciones generales relativas a dispositivos y redes
  • Indicaciones acerca de la configuración hardware
  • Indicaciones sobre las funciones OPC UA
  • Detección de hardware de dispositivos IO
  • ID de hardware del tipo "Hw_SubModule" para un dispositivo IO HMI Panel
  • Uso de módulos en el S7-1200
  • CP 343-2 en SIMATIC S7 Embedded Controller EC31-RTX
  • Carga de CPU S7-1500 (SIPLUS)
  • ET 200MP (IM 155-5 DP ST) en un WinLC RTX
  • Indicaciones relativas a Online y diagnóstico
  • Componentes de la red


Indicaciones generales relativas a dispositivos y redes

Contenido S7-PCT IO-Link (S7-1200) Port Configuration Tool PCT
Indicaciones generales relativas a dispositivos y redes

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

S7-PCT IO-Link (S7-1200)

La S7-Port Configuration Tool puede descargarse gratuitamente desde el siguiente enlace.

http://support.automation.siemens.com/WW/view/37936752

Port Configuration Tool PCT

Si utiliza la herramienta PCT, debe asegurarse de que utiliza siempre la versión actual disponible de manera gratuita en el siguiente enlace:


Indicaciones acerca de la configuración hardware

Contenido Edición de la dirección IP de un dispositivo
Indicaciones acerca de la configuración hardware

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Edición de la dirección IP de un dispositivo

A la hora de editar la dirección IP de un dispositivo no debe utilizarse el rango de direcciones de 192.168.x.241 a 192.168.x.250. En caso necesario, el sistema asigna este rango de direccione automáticamente a una programadora. Esto se aplica análogamente a todas las clases de redes en función de la máscara de subred.


Indicaciones sobre las funciones OPC UA

Contenido Archivos de esquema utilizados para funciones OPC UA Objeto de PLC no visible en el espacio de direcciones del servidor Conexión cliente-servidor OPC UA a través de router NAT Reinicio del servidor OPC UA Mapeado de tipos de datos de CPU en tipos de datos OPC UA en CPU S7-1200 Otros códigos de estado para instrucciones del cliente OPC UA Copia de ejemplos de programa SCL del sistema de información
Indicaciones sobre las funciones OPC UA

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Archivos de esquema utilizados para funciones OPC UA

OPC Foundation proporciona a sus usuarios esquemas que los fabricantes pueden utilizar para sus correspondientes implementaciones de servidor/cliente. Dichos archivos se utilizan p. ej. para validar modelos de información o nodesets importados.

Para la versión V16 de TIA Portal o la CPU S7-1500 con versión de firmware V2.8 se utilizan los siguientes archivos de esquema y NodeSet:

Esquema/NodeSet | Explicación
https://opcfoundation.org/UA/schemas/1.04/UANodeSet.xsd | Esquema XML para archivos NodeSet (2018-12-04)
https://opcfoundation.org/UA/schemas/1.04/Opc.Ua.NodeSet2.xml | OPC UA ("CORE"), versión de modelo 1.04 (2018-06-04)
https://opcfoundation.org/UA/schemas/DI/1.1/Opc.Ua.Di.NodeSet2.xml | OPC UA para dispositivos ("DI"), versión de modelo 1.01 (2018-06-06)

Objeto de PLC no visible en el espacio de direcciones del servidor

En proyectos muy grandes, es posible que en casos excepcionales no se vea el nodo de la CPU o el objeto de PLC en el espacio de direcciones del servidor OPC UA a pesar de haber compilado y cargado correctamente el proyecto en la CPU. Cuando esto sucede, significa que la memoria reservada para OPC UA en la CPU no es suficiente.

El diagnóstico, p. ej. mediante UaExpert, devuelve el estado de servidor "Failed".

Solución

En las propiedades de la CPU desactive la interfaz de servidor SIMATIC predeterminada en caso de que no se necesite.

Reduzca el número o tamaño de los elementos que consumen recursos OPC UA. Reduzca, por ejemplo, el número de nodos para interfaces de servidor a menos de 30 000.

Otras medidas:

  • Reduzca el número de variables en el espacio de direcciones del servidor OPC UA, especialmente de variables con el tipo de datos Estructura.

    Para extraer variables del espacio de direcciones, desactive la opción "Accesible desde HMI/OPC UA" en la tabla de variables PLC o en los bloques de datos.

    Para bloques de datos también existe la posibilidad de extraer el DB por completo del espacio de direcciones, con todas las variables. Desactive para ello la opción "DB accesible desde OPC UA" en las propiedades del DB.

  • Reduzca la longitud de los nombres de elementos en estructuras de datos de gran tamaño.

  • Acorte las descripciones de los nodos.

  • Reduzca el número de métodos implementados.

Conexión cliente-servidor OPC UA a través de router NAT

Si el cliente y el servidor están conectados a través de un router NAT, este intento de conexión fallará en ese caso con los mensajes de error "BadCommunicationError" o "BadNotConnected".

Explicación: En sistemas NAT, el router manipula los paquetes IPv4. A consecuencia de ello, la IP de origen ("Source NAT") o la IP de destino ("Destination NAT") de un paquete se sustituye por una dirección IP (dependiendo del puerto de destino) configurada en el router. Este proceso es transparente para cliente y servidor, es decir, estos dispositivos no saben nada de este proceso.

Problema: El router NAT no puede sustituir también la descripción de Endpoint (la EndpointUrl) que devuelve el servidor, ya que esta información de dirección se encuentra en los datos de usuario de "GetEndpointsResponse".

Encontrará una descripción detallada del proceso en la siguiente FAQ.

Versión V2.6 del firmware de la CPU

La conexión cliente-servidor OPC UA a través del router NAT no es posible.

Solución a partir de la versión V2.8 del firmware de la CPU

Utilice el atributo "ServerUri" de la información de la conexión (parámetro "SessionConnectInfo" de la instrucción "OPC_UA_Connect").

Como "ServerUri", introduzca la ServerEndpointUrl completa con la dirección IP del router NAT. Esta ServerEndpointUrl se utilizará entonces en lugar de la EndpointUrl devuelta en la GetEndpointsResponse para establecer la conexión.
Si deja vacío el atributo, el comportamiento será el mismo que con la versión V2.6 del firmware de la CPU.

Si utiliza la parametrización de conexión para establecer la conexión OPC UA (crear la interfaz de cliente), deberá abrir el DB de interfaces de cliente (*_Configuration[DBx]) después de la parametrización y modificar el string en el parámetro "ServerUri". La entrada se conservará después de compilar la configuración OPC UA.

Ejemplo de establecimiento de la conexión (la dirección de ServerUri sustituye a la dirección de GetEndpointsResponse)

Procedimiento: en el parámetro "ServerUri" se escribe la dirección completa del servidor (ServerEndpointUrl), que consiste en la dirección IP, el puerto y la ruta opcional; la dirección IP es la dirección IP del lado del cliente del router NAT:

1) Abrir DB de configuración

2) Modificar parámetro "ServerUri"

La conexión se establece en los siguientes pasos:

  • GetEndpointsRequest: el cliente S7-1500 OPC UA direcciona el servidor por medio de la dirección de destino del router NAT en la subred del cliente (10.10.0.1).
    El router NAT convierte la dirección de destino en la dirección IP del servidor (192.168.0.1) en la subred del servidor.

  • GetEndpointsResponse: en la "GetEndpointsResponse", el servidor devuelve su EndpointUrl:
    "opc.tcp://192.168.0.1:4840/UA/DemoServer".
    El cliente no puede llegar a esa dirección directamente, ya que esta se encuentra detrás de un router NAT.

  • OpenSecureChannel:
    Para abrir el canal seguro, el cliente no toma la EndpointUrl de la GetEndpointsResponse, sino la EndpointUrl del parámetro "ServerUri":
    "opc.tcp://10.10.0.1:4840/UA/DemoServer".
    El cliente puede acceder a esta dirección IP; los datos se encaminan del router NAT a la dirección IP del servidor.

Reinicio del servidor OPC UA

A partir de la versión V2.8 del firmware, el servidor OPC UA de una CPU S7-1500 ya solo se detiene al cargar datos relevantes de OPC UA en la CPU (por ejemplo, al sobrescribir un bloque de datos). El servidor se reinicia a continuación si el usuario ha permitido este proceso de carga.

Tenga en cuenta que, en este caso, los clientes OPC no pueden seguir utilizando los servicios activos para este servidor y que, por tanto, es preciso volver a liberar los recursos necesarios.

A continuación deben solicitarse nuevamente los siguientes recursos:

  • Iniciar nuevamente el establecimiento de la conexión

  • Generar nuevamente las subscriptions

  • Crear nuevamente las órdenes de lectura y escritura

En muchos casos, por ejemplo, después de agregar bloques lógicos nuevos o bloques de datos nuevos que no son relevantes para OPC UA, el servidor ya no se detiene.

Mapeado de tipos de datos de CPU en tipos de datos OPC UA en CPU S7-1200

Las CPU S7-1200 tienen un servidor OPC UA a partir de la versión V4.4 de firmware. Para este servidor se pueden configurar interfaces de servidor OPC UA.

En los tipos de datos OPC UA se aplica el siguiente mapeado de los tipos de datos S7-1200:

Tipo de datos SIMATIC | Tipo de datos OPC UA
BOOL | Boolean
SINT | SByte
USINT | Byte
INT | Int16
UINT | UInt16
DINT | Int32
UDINT | UInt32
REAL | Float
LREAL | Double
WSTRING (UCS-2; Universal Coded Character Set) | String
DWORD | StatusCode

El servidor OPC UA del S7-1200 admite la lectura y escritura de los tipos de datos simples representados.

No se admiten los siguientes tipos de datos:

  • Estructuras

  • Arrays

  • Unions

Si bien es posible cargar variables con estos tipos de datos (ningún aviso de la prueba de coherencia), un acceso del cliente a estas variables en tiempo de ejecución se rechaza con un mensaje de error.

Los métodos tampoco pueden programarse.

Otros códigos de estado para instrucciones del cliente OPC UA

Debido al cambio en el comportamiento para habilitar controladores de la conexión en CPU S7-1500 con una versión de firmware V2.8 o superior, existen otros códigos de error que no están documentados para cada una de estas instrucciones.

La tabla siguiente contiene estos códigos de error con explicaciones.

Código de error

(valores hexadecimales)

Nombre del error

Explicación

80AE_0000

BadConnectionClosed

La conexión con el ConnectionHdl correspondiente está en el estado "ShutDown" (desconectada). La conexión/sesión no se ha podido "reactivar" automáticamente. Causa posible: Sesión borrada en el servidor, p. ej., por reinicio o timeout.

En este caso, la conexión se debe cerrar explícitamente con la instrucción "OPC_UA_Disconnect" para volver a liberar los recursos de conexión. El ConnectionHdl para esta conexión que ha dejado de ser válida debe restablecerse en el programa de usuario.

A continuación, debe establecerse una nueva conexión con el servidor (ver instrucción "OPC_UA_Connect").

El código de error puede aparecer en todas las instrucciones de cliente a excepción de las instrucciones OPC_UA_Connect, OPC_UA_Disconnect y OPC_UA_ConnectionGetStatus.

80AF_0000

BadInvalidState

La conexión con el ConnectionHdl correspondiente está en el estado "ConnectionError" (error temporal de conexión, conexión interrumpida). La CPU intenta "reactivar" la conexión. Si esto no se logra durante el intervalo de timeout ajustado (OPC UA Session Timeout), la conexión pasa al estado "Shutdown". Requisitos para el cambio de estado: La CPU ha podido acceder al servidor OPC UA para comprobar si la sesión todavía está presente o no.

El código de error puede aparecer en todas las instrucciones de cliente a excepción de las instrucciones OPC_UA_Connect, OPC_UA_Disconnect y OPC_UA_ConnectionGetStatus.

A000_0105

PLCopenUA_Bad_ConnectionInvalidHdl

Controlador (handle) de la conexión (ConnectionHdl) no válido/desconocido.

El código de error puede aparecer en todas las instrucciones de cliente a excepción de la instrucción OPC_UA_Connect.

Copia de ejemplos de programa SCL del sistema de información

El código de programa SCL de los ejemplos de programación OPC UA que se ha copiado en el sistema de información con el icono "Copiar" y que se ha pegado en el editor de programas no puede compilarse.

Para copiar el código de programa sin errores, marque el código en el sistema de información y seleccione el comando "Copiar" del menú contextual o la combinación de teclas "Ctrl+C". Pegue el código del programa en el editor de programas utilizando el comando "Pegar" del menú contextual o la combinación de teclas "Ctrl+V".


Detección de hardware de dispositivos IO

Contenido Detección de hardware incompleta en estaciones ET 200SP
Detección de hardware de dispositivos IO

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Detección de hardware incompleta en estaciones ET 200SP

La función online "Detección de hardware" de STEP 7 V15 permite determinar la configuración de la estación de dispositivos IO y aplicarla al proyecto del usuario, incluidos todos los módulos enchufados.

Si se incorpora un ET 200SP al proyecto mediante la detección de hardware, hay que completar manualmente la configuración de estación detectada: En el módulo de interfaz, compruebe si se ha detectado el adaptador de bus adecuado en la configuración hardware (p. ej. BA 2xRJ45 en lugar del BA 2xFC realmente enchufado).


ID de hardware del tipo "Hw_SubModule" para un dispositivo IO HMI Panel

Contenido Determinación de la ID de hardware con el tipo "Hw_SubModule" para un dispositivo IO HMI Panel
ID de hardware del tipo "Hw_SubModule" para un dispositivo IO HMI Panel

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Determinación de la ID de hardware con el tipo "Hw_SubModule" para un dispositivo IO HMI Panel

El parámetro "ID" del bloque de programa PROFIenergy "PE_START_END" debe tener la identificación de hardware (ID de hardware) con el tipo "Hw_SubModule" del dispositivo IO. En una CPU S7-1500/S7-1200/ET200SP, la ID de hardware con el tipo "Hw_SubModule" del dispositivo IO HMI Panel no se muestra en las constantes del sistema, pero puede determinarse. Para ello, en la lista de las variables PLC de la ficha "Constantes del sistema" se determina el símbolo para el dispositivo IO en el HMI Panel con el tipo "Hw_Device" y se reduce en uno, p. ej. "HMI_1_IE_CP_1~PROFINET_Interface_1~IODevice -1".


Uso de módulos en el S7-1200

Contenido Uso de módulos en el S7-1200 Cargar en la PG/el PC los comentarios de módulo del S7-1200
Uso de módulos en el S7-1200

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Uso de módulos en el S7-1200

Los módulos indicados a continuación no son compatibles con el S7-1200:

Familia | Módulo | Referencia
FM S7-300 | SM 338 | 6ES7 338-4BC01-0AB0
 | FM 350-1 | 6ES7 350-1AH03-0AE0
 | FM 350-2 | 6ES7 350-2AH00-0AE0, 6ES7 350-2AH01-0AE0
 | FM 351 | 6ES7 351-1AH01-0AE0, 6ES7 351-1AH02-0AE0
 | FM 352 | 6ES7 352-1AH02-0AE0
 | FM 355 S | 6ES7 355-1VH10-0AE0
 | FM 355 C | 6ES7 355-0VH10-0AE0
 | FM 355-2 C | 6ES7 355-2CH00-0AE0
 | FM 355-2 S | 6ES7 355-2SH00-0AE0
CP PtP S7-300 | CP 340 | 6ES7 340-1AH02-0AE0, 6ES7 340-1BH02-0AE0, 6ES7 340-1CH02-0AE0
 | CP 341 | 6ES7 341-1AH01-0AE0, 6ES7 341-1AH02-0AE0, 6ES7 341-1BH01-0AE0, 6ES7 341-1BH02-0AE0, 6ES7 341-1CH01-0AE0, 6ES7 341-1CH02-0AE0
Componente de red | Repetidor de diagnóstico | 6ES7 972-0AB01-0XA0
ET 200M | SIWAREX | 7MH4900-2AA01, 7MH4900-3AA01, 7MH4950-1AA01, 7MH4950-2AA01

Cargar en la PG/el PC los comentarios de módulo del S7-1200

En las configuraciones centralizadas con S7-1200 no se cargan los comentarios de los módulos, submódulos y signalboards. En el cado de CP/CM solo se cargan los comentarios de la interfaz IE o DP, respectivamente. En las configuraciones descentralizadas con ET 200SP o ET 200MP, de los comentarios de los módulos de E/S solo se cargan los comentarios de los canales.


CP 343-2 en SIMATIC S7 Embedded Controller EC31-RTX

Contenido CP 343-2 en SIMATIC S7 Embedded Controller EC31-RTX
CP 343-2 en SIMATIC S7 Embedded Controller EC31-RTX

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

CP 343-2 en SIMATIC S7 Embedded Controller EC31-RTX

Si bien el módulo AS-Interface CP 343-2 (referencia: 6GK7 343-2AH01) puede insertarse en un rack de ampliación del SIMATIC S7 Embedded Controller EC31-RTX (referencia: 6ES7 677-1DDxx-0BB0), el CP 343-2 no puede utilizarse con el EC31-RTX.


Carga de CPU S7-1500 (SIPLUS)

Contenido Comportamiento de una CPU S7-1500 SIPLUS (6AG1...) FW <V2.5 con Memory Card formateada
Carga de CPU S7-1500 (SIPLUS)

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Comportamiento de una CPU S7-1500 SIPLUS (6AG1...) FW <V2.5 con Memory Card formateada

Componentes implicados:

  • CPU 151x SIPLUS (6AG1...) con versión de firmware anterior a V2.5

  • SIMATIC Memory Card

Cuando se carga una CPU SIPLUS en una SIMATIC Memory Card formateada y se conmuta la CPU al estado operativo RUN, la CPU funciona sin errores. En cambio, tras desconectar y volver a conectar la tensión o tras realizar un borrado total de la memoria (MRES), la CPU SIPLUS pasa al estado STOP, y se emite un mensaje de error. En dicho mensaje se indica que la Memory Card no se detecta porque falta, es de tipo incorrecto, contiene datos erróneos o está protegida.

Este comportamiento no se produce con una CPU 151x SIPLUS (6AG1...) con versión de firmware V2.5 o posterior, o si en la Memory Card ya existe una configuración con una CPU SIMATIC S7-1500 (6ES7...) y se sobrescribe con una configuración del mismo tipo de CPU SIPLUS (6AG1...).

Solución:

  1. En la SIMATIC Memory Card debe estar cargada una configuración con CPU SIMATIC. Es suficiente que haya una CPU del tipo correspondiente; no es necesaria la presencia de la periferia.

  2. La CPU SIPLUS se carga en la tarjeta. La configuración SIMATIC existente en la Memory Card se sobrescribe con la configuración SIPLUS.

Con este procedimiento se evita un mensaje de error del TIA Portal.

Nota

Este procedimiento SOLO funciona cuando se carga online en la CPU. Si la tarjeta se programa mediante un lector de tarjetas externo, el error persistirá.

Si, por ejemplo, desea cargar una CPU 1511-1 PN SIPLUS (6AG1 511-1AK00...), proceda del siguiente modo.

  1. Introduzca una Memory Card vacía de suficiente tamaño en la CPU SIPLUS.

  2. Configure una CPU SIMATIC del mismo tipo; en este caso, una S7-1511-1 PN (6ES7 511-1AK00...). Para la primera carga, no se necesitan módulos de periferia.

  3. Cargue la configuración en la CPU SIPLUS.

  4. Sustituya la CPU SIMATIC en STEP 7 por la CPU SIPLUS (6AG1 511-1AK00...) y complete la configuración con los módulos de periferia y los dispositivos de periferia descentralizada previstos.

  5. Cargue la configuración modificada en la CPU SIPLUS.


ET 200MP (IM 155-5 DP ST) en un WinLC RTX

Contenido ET 200MP (IM 155-5 DP ST) no utilizable actualmente en un WinLC RTX a través de PROFIBUS
ET 200MP (IM 155-5 DP ST) en un WinLC RTX

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

ET 200MP (IM 155-5 DP ST) no utilizable actualmente en un WinLC RTX a través de PROFIBUS

Componentes implicados:

  • Sistemas PC con funcionalidad de Logic Controller WinLC RTX como maestro DP (todas las variantes: EC31-RTX (F), WinAC RTX (F) Software PLC); en adelante, abreviado a "WinLC RTX"

  • ET 200MP (IM 155-5 DP ST) como esclavo DP

Si se configuran módulos estándar o de seguridad en un ET 200MP y como maestro DP se utiliza un WinLC RTX, el maestro DP no parametrizará dichos módulos en el ET 200MP. Después de cargar la configuración y tras arrancar los componentes afectados, los módulos señalizan la falta de parametrización en el ET 200MP con LED verdes intermitentes.

STEP 7 no indica la no disponibilidad de los módulos online (estado "OK").

Solución:

  • Recomendación: utilice un módulo de interfaz IM 155-5 PN para conectar el ET 200MP a un WinLC RTX a través de PROFINET IO.

    o

  • Si no enchufa ningún módulo de seguridad en el ET 200MP: para configurar los módulos estándar, utilice la variante GSD del ET 200MP en un WinLC RTX


Indicaciones relativas a Online y diagnóstico

Contenido Detección de hardware y posterior conexión online Borrado de mediciones del dispositivo (tarjeta de memoria) (S7-1200) Trace del proyecto para controlador por software y Open Controller
Indicaciones relativas a Online y diagnóstico

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Detección de hardware y posterior conexión online

Si se ejecuta el comando "Online > Detección de hardware" para una CPU sin especificar, no se carga la configuración online de la CPU. Si no se carga en la CPU la configuración obtenida mediante la detección de hardware, siempre habrá diferencia entre las configuraciones offline y online en la vista de dispositivos y redes. En la vista Online y diagnóstico puede verse que hay configuraciones diferentes, aunque sean idénticas las referencias de la CPU realmente existente y de la CPU offline.

Borrado de mediciones del dispositivo (tarjeta de memoria) (S7-1200)

No borre ninguna medición del dispositivo mientras un Trace en el dispositivo genere nuevas mediciones en la tarjeta de memoria.

Trace del proyecto para controlador por software y Open Controller

Con TIA Portal V16, el trace del proyecto no admite el controlador por software ni Open Controller.


Programación del PLC

Programación del PLC

Este capítulo incluye información sobre los siguientes temas:
  • Indicaciones generales relativas a la programación del PLC
  • Indicaciones acerca de las instrucciones
  • Comprobar el programa de usuario
  • Actualización de bloques
  • Compatibilidad con programas de PLC de versiones anteriores


Indicaciones generales relativas a la programación del PLC

Contenido Atributos específicos de la instancia al importar bloques a través de TIA Portal Openness Indicación del nombre de la CPU en los avisos de sistema Modificar el ciclo de aplicación de un OB de alarma de sincronismo Uso del tipo de datos de sistema "TDiag_StatusExt" (S7-1200/1500) Información sobre la seguridad de la red Funciones de la librería global "Long Functions" con PLCSIM (S7-1500) Cargar programas no coherentes en una CPU S7-1500 (S7-1500) Intercambio de datos entre programa estándar y F cuando se utiliza Team Engineering
Indicaciones generales relativas a la programación del PLC

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Atributos específicos de la instancia al importar bloques a través de TIA Portal Openness

En determinadas situaciones, las reglas de importación pueden provocar la pérdida de atributos específicos de la instancia como, por ejemplo, valores de arranque.

Indicación del nombre de la CPU en los avisos de sistema

A partir de V15.1 el nombre de la CPU (o el nombre de la estación en el caso de las CPU H o R) se muestra en la columna "Texto adicional 1" de los avisos de sistema. Para ello es necesario compilar el hardware del dispositivo correspondiente. Si el nombre de la CPU no se muestra a través de la opción "Compilar > Hardware (solo cambios)", utilice la opción "Compilar > Hardware (compilar todo)".

Asegúrese de que efectivamente se ha realizado la carga en el dispositivo; la información de que el hardware es actual no es suficiente.

Modificar el ciclo de aplicación de un OB de alarma de sincronismo

Si se modifica el parámetro "Ciclo de aplicación (ms)" de un OB de alarma de sincronismo, también cambia implícitamente la configuración hardware. Para que el valor modificado para la duración del ciclo de aplicación sea efectivo en la CPU tras la próxima operación de carga, hay que cargar también explícitamente la configuración hardware. Para ello, elija el comando de menú "Cargar en dispositivo > Hardware y software" o el comando "Cargar en dispositivo > Configuración hardware".

Uso del tipo de datos de sistema "TDiag_StatusExt" (S7-1200/1500)

Opcionalmente al tipo de datos de sistema "TDiag_Status", también puede emplearse el tipo de datos de sistema ampliado "TDiag_StatusExt" para obtener información adicional sobre la causa de la interrupción de la conexión. En particular, la lectura del elemento de estructura "LastConnErrTimeStamp" hace que la CPU cambie al estado de sistema "Defect" y no debe utilizarse actualmente.

Información sobre la seguridad de la red

Los accesos de comunicación entre TIA Portal y CPU, o bien entre HMI y CPU (excepto cuando los accesos HMI se realizan a través de la "Comunicación GET/PUT") ofrecen funciones de seguridad integradas. Estas ofrecen una mayor protección frente a manipulaciones y una mayor protección de acceso. Para prevenir accesos no autorizados a través de redes a una CPU con accesos de comunicación estándar, como p. ej., "GET/PUT", "TSEND/TRCV", "Modbus", "FETCH/WRITE", se recomienda tomar además medidas de protección adecuadas (p. ej., concepto de protección de células).

Funciones de la librería global "Long Functions" con PLCSIM (S7-1500)

Mediante el proceso de compilación, las funciones de la familia de CPU S7-1500 quedan vinculadas a la CPU para protegerla contra manipulaciones. Las funciones empleadas en la CPU de la librería global "Long Functions" que poseen este tipo de vínculo no se pueden cargar en una simulación. Sin embargo, existe la posibilidad de sustituir estos elementos por sus originales de la librería global. Estos elementos no están vinculados a la CPU.

Cargar programas no coherentes en una CPU S7-1500 (S7-1500)

En el TIA Portal no es posible cargar programas no coherentes en una CPU S7-1500 sin realizar previamente una prueba de coherencia. Durante la carga se comprueban automáticamente todos los bloques del programa y, si hay incoherencias, se compilan nuevamente. No obstante, si la CPU contiene programas que fueron cargados con versiones anteriores de STEP 7, estos programas pueden presentar incoherencias.

En tal caso, tenga en cuenta lo siguiente:

Si carga un programa incoherente desde un dispositivo, no podrá cargar después el programa en una CPU S7-1500 sin modificarlo, ya que durante la carga se comprueba automáticamente la coherencia y se eliminan las incoherencias encontradas.

Intercambio de datos entre programa estándar y F cuando se utiliza Team Engineering

Para garantizar la coherencia de datos entre el programa estándar y de seguridad debe realizarse lo siguiente:

  • No intercambiar datos a través de marcas, sino de bloques de datos globales.

  • Limitar los accesos entre programas de seguridad y programas de usuario estándar a dos bloques de datos estándar.


Indicaciones acerca de las instrucciones

Contenido Instrucción "FileDelete: Borrar archivo en la Memory Card"
Indicaciones acerca de las instrucciones

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Instrucción "FileDelete: Borrar archivo en la Memory Card"

Al contrario de lo que se afirma en la Ayuda en pantalla, para los valores 8091 y 8094 del parámetro "Status" rige lo siguiente:

  • El valor 8091 tiene el siguiente significado: la ruta no existe o no es válida.

  • El valor 8094 no se emite.


Comprobar el programa de usuario

Comprobar el programa de usuario

Este capítulo incluye información sobre los siguientes temas:
  • Nota sobre el test con la tabla de observación
  • Nota sobre el test con la tabla de forzado permanente
  • Nota sobre el test con puntos de parada


Nota sobre el test con la tabla de observación

Contenido Accesos múltiples a la misma CPU (S7-300/400/1200) Cargar bloques de datos mientras se procesa una petición de forzado Función "Desbloquear salidas" Probar programas migrados de versiones anteriores de STEP 7 Probar programas que han sido actualizados Formatos de visualización modificados en la tabla de observación
Nota sobre el test con la tabla de observación

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Accesos múltiples a la misma CPU (S7-300/400/1200)

Desde una programadora o un PC solo se puede acceder online a una CPU (S7-300/400/1200) con el TIA Portal abierto. Los accesos múltiples a la misma CPU de esa familia no están permitidos y pueden provocar errores.

Cargar bloques de datos mientras se procesa una petición de forzado

Al cargar bloques de datos modificados mientras se procesa una petición de forzado pueden darse estados operativos imprevistos. La petición de forzado continúa forzando la dirección indicada, mientras que la asignación de direcciones puede haber cambiado en el bloque de datos. Finalice las peticiones de forzado que se estén procesando antes de proceder a cargar bloques de datos.

Función "Desbloquear salidas"

La función "Desbloquear salidas de periferia" no está disponible en el TIA Portal para las CPU de la serie S7-1500.

Esta función solo puede ejecutarse en el TIA Portal con una CPU S7-300, S7-400 o S7-1200.

Probar programas migrados de versiones anteriores de STEP 7

Para observar y probar un programa migrado de una versión anterior de STEP 7, es necesario compilarlo y cargarlo primero con la versión actual de STEP 7.

Probar programas que han sido actualizados

Después de actualizar proyectos a la versión V16, internamente se vuelven a calcular las sumas de verificación. En casos poco frecuentes, eso puede provocar que en la tabla de observación no se muestren valores para variables, ya que la suma de verificación ha cambiado, aunque los bloques son idénticos. En ese caso, en la columna "Valor de observación" no se muestra ningún valor, sino las gafas con el círculo rojo tachado. En tal caso es necesario volver a compilar y cargar el proyecto antes de poder observarlo y probarlo online con la tabla de observación.

Formatos de visualización modificados en la tabla de observación

El número de formatos de visualización se ha reducido, de modo que en caso de actualizar un proyecto, los formatos de visualización que se utilicen, pero que ya no estén soportados se restablecerán a sus valores predeterminados.

Ejemplo: los punteros no pueden visualizarse más que en los formatos "Puntero" o "Hexadecimal".


Nota sobre el test con la tabla de forzado permanente

Contenido Forzado permanente de variables con acceso directo a la periferia (S7-300) Ejemplo Formatos de visualización modificados en la tabla de forzado permanente
Nota sobre el test con la tabla de forzado permanente

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Forzado permanente de variables con acceso directo a la periferia (S7-300)

Si en el programa de usuario se utiliza un acceso directo a la periferia para una CPU S7-300, no está permitido el forzado permanente de esta dirección de periferia.

Ejemplo

Si en el programa de usuario se accede a la dirección "IB0:P", no podrán forzarse permanentemente las siguientes áreas de direcciones de la periferia: I0.0:P, IB0:P, IW0:P e ID0:P.

Formatos de visualización modificados en la tabla de forzado permanente

El número de formatos de visualización se ha reducido, de modo que en caso de actualizar un proyecto, los formatos de visualización que se utilicen, pero que ya no estén soportados se restablecerán a sus valores predeterminados.

Ejemplo: los punteros no pueden visualizarse más que en los formatos "Puntero" o "Hexadecimal".


Nota sobre el test con puntos de parada

Contenido Posicionar puntos de parada en el programa de usuario con CPU F S7-1500
Nota sobre el test con puntos de parada

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Posicionar puntos de parada en el programa de usuario con CPU F S7-1500

Cuando se alcanza un punto de parada activado, la CPU pasa inmediatamente a "STOP" después de una "PARADA". Si después de una "PARADA" debe volver a pasarse a RUN para seguir probando el programa de usuario estándar, puede simularlo con S7-PLCSIM.

Encontrará más información sobre el test con puntos de parada en las CPU F en el manual "SIMATIC Safety - Configuring and Programming".


Actualización de bloques

Contenido Actualización de bloques con protección de know-how (S7-1200/1500) Actualización de bloques GRAPH (S7-300, S7-400, S7-1500) Comparación offline/online Actualización de especificaciones del dispositivo
Actualización de bloques

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Actualización de bloques con protección de know-how (S7-1200/1500)

Los bloques con protección de know-how creados con una versión anterior de TIA Portal pueden cargarse en el controlador y ejecutarse sin necesidad de introducir una contraseña al actualizarse a la versión actual.

Para abrir y editar estos bloques en la versión actual, proceda del siguiente modo:

  • Bloques cuya protección de know-how se estableció con la versión V13 SP1 o superior:

    • Elimine la protección de know-how en la versión actual, edite el bloque y vuelva a activar la protección de know-how.

  • Bloques cuya protección de know-how se estableció con una versión anterior a V13 SP1:

    • Elimine la protección de know-how en V13 SP1 y actualice el bloque a la versión actual. Seguidamente, edite el bloque y vuelva a activar la protección de know-how en la versión actual.

Actualización de bloques GRAPH (S7-300, S7-400, S7-1500)

Después de actualizar a la versión V16 un proyecto de una versión inferior a la V15, compruebe si en el informe hay bloques GRAPH reparados y si dichos bloques pueden ejecutarse en su programa.

Si se actualiza un proyecto que contenga bloques GRAPH de la versión V15.x a la versión V16, primero deberán compilarse los bloques de programa antes de poderlos observar.

Comparación offline/online

En la versión actual se corrigieron los datos de proyecto internos para aumentar su integridad. Por ello, tras la instalación es posible que algunos bloques se corrijan automáticamente al abrirlos y la comparación offline/online mostrará, por tanto, sumas de verificación diferentes.

Actualización de especificaciones del dispositivo

Al actualizar el proyecto, en determinados casos se actualizan las especificaciones internas de las CPU utilizadas.

El siguiente mensaje indica que se está realizando una actualización: "Se ha actualizado la configuración de dispositivos de las CPU en el proyecto."

La actualización no afecta al programa que se ejecuta en la CPU.


Compatibilidad con programas de PLC de versiones anteriores

Compatibilidad con programas de PLC de versiones anteriores

Este capítulo incluye información sobre los siguientes temas:
  • Compatibilidad con programas de PLC de versiones anteriores a la V16
  • Compatibilidad de programas de PLC de versiones anteriores a la V15.1
  • Compatibilidad con programas de PLC de versiones anteriores a V15
  • Compatibilidad de programas de PLC de versiones anteriores a la V14 SP1
  • Compatibilidad con programas de PLC de versiones anteriores a V14
  • Compatibilidad de programas de PLC de versiones anteriores a la V13 SP1


Compatibilidad con programas de PLC de versiones anteriores a la V16

Contenido Compatibilidad Incoherencia en las sumas de verificación Software Units Análisis sintáctico de instancias (KOP, FUP, AWL, GRAPH) Instrucciones "UPPER_BOUND" y "LOWER BOUND" (KOP, S7-1200/S7-1500) Instrucción "S_CONV" (KOP) Inicialización del tipo de datos STRUCT al importar archivos de origen externos (SCL) Declaración AT Instrucción "MOVE" Instrucción "MOVE" (AWL) Instrucciones "SCATTER_BLK" y "GATHER_BLK" (SCL) Constantes sin tipo (SCL) Direccionamiento de ARRAYS mediante índice variable y acceso a periferia (S7-1200) Tamaño de los bloques si se utilizan ARRAY en estructuras Tamaño de los bloques GRAPH Asignación de constantes sin tipo (SCL)
Compatibilidad con programas de PLC de versiones anteriores a la V16

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Compatibilidad

Por principio es posible seguir utilizando en la V16 todos los programas de PLC que se hayan creado con versiones anteriores del TIA Portal. Sin embargo, puesto que en la V16 se han realizado algunas mejoras y se han solucionado errores del compilador, en unos pocos casos es posible que el programa se comporte de distinto modo después de la actualización o que deba corregirse manualmente el código del programa. A continuación se describen estos casos con detalle.

Incoherencia en las sumas de verificación

Después de actualizar un proyecto a la versión V16 es posible que se indiquen diferencias entre los programas online y offline, aunque estos sean totalmente idénticos. Estas diferencias se deben a que en la versión V16 se ha optimizado el cálculo de las sumas de verificación. Sin embargo, en la mayoría de los casos los bloques son compatibles.

No obstante, en raras ocasiones el cálculo modificado de la suma de verificación hace necesario compilar y cargar el proyecto nuevamente antes de poderlo observar y probar online.

Software Units

A partir de V16, para el nombre de una Software Unit rigen las siguientes normas:

  • Se permiten todos los caracteres alfanuméricos y el guion bajo.

  • El número máximo es de 125 caracteres.

  • El nombre de una Software Unit debe ser unívoco en toda la CPU y tampoco puede existir en ella ningún bloque con el mismo nombre.

Si las Software Units del programa no cumplen estas normas, se mostrará un error de sintaxis después de la actualización. En tal caso, modifique la propiedad de la Software Unit y compile nuevamente el programa.

Análisis sintáctico de instancias (KOP, FUP, AWL, GRAPH)

Al llamar un bloque de función ahora se comprueba con mayor precisión si el bloque de datos de instancia indicado es del mismo tipo que el FB llamado. Además del número y la estructura del bloque también se comprueba el nombre del bloque.

En caso de incoherencias, se emite un error de sintaxis después de la actualización. En este caso, compruebe el tipo del bloque de datos de instancia en las propiedades del bloque, área "General". Si el tipo no coincide con el del FB llamado, deberá cambiarse la llamada del bloque e indicarse una instancia adecuada.

Instrucciones "UPPER_BOUND" y "LOWER BOUND" (KOP, S7-1200/S7-1500)

La entrada de habilitación "EN" de sendas instrucciones "UPPER_BOUND" y "LOWER BOUND" ahora se evalúa correctamente. Si la entrada "EN" tiene el estado lógico "0", la instrucción no se ejecuta y la salida de habilitación "ENO" tiene el estado lógico "0". Si utiliza una de ambas instrucciones, compruebe después de la actualización si el programa se ejecuta como hasta ahora.

Instrucción "S_CONV" (KOP)

En versiones anteriores de TIA Portal, la entrada de habilitación "EN" de la instrucción "S_CONV" no se evaluaba en la conversión de (W)Char a (W)String si no había ningún parámetro interconectado en la salida de habilitación "ENO". Este comportamiento se ha corregido. Si utiliza "S_CONV", compruebe después de la actualización si el programa se ejecuta como hasta ahora.

Inicialización del tipo de datos STRUCT al importar archivos de origen externos (SCL)

Las reglas de inicialización para STRUCT se han unificado. Ahora, las listas de inicialización se evalúan siempre siguiendo las mismas reglas, independientemente de si se trabaja en la interfaz de bloque textual o tabular.

Si en una lista de inicialización se utiliza una sintaxis distinta y, por ejemplo, algunos elementos se inicializan indicando su nombre y otros indicando solo su valor, debe comprobarse el programa tras importarlo a TIA Portal V16.

El ejemplo siguiente muestra cómo se evalúan los elementos de estructura en V16, tanto en la interfaz de bloque tabular como en la textual:

myStruct : Struct

member_1 : Int;

member_2 : Int;

member_3 : Int;

member_4 : Int;

member_5 : Int;

End_Struct:=(1,mem_3:=33,2,3);

//Los elementos de estructura se inicializan como se indica a continuación:

//mem_1 := 1;

//mem_3 := 33;

//mem_4 := 2;

//mem_5 := 3;

Declaración AT

En casos poco frecuentes se escribían valores erróneos en los parámetros de bloque que siguen inmediatamente a una declaración AT en la interfaz. Este comportamiento se ha corregido.

Al mismo tiempo, ya no es posible superponer parámetros de bloque de los tipos de datos BOOL, BYTE, SINT, USINT o CHAR con variables del tipo de datos STRUCT y UDT. Las superposiciones con variables del tipo ARRAY solo son posibles en tanto que el tamaño del array no exceda el tamaño de datos del tipo superpuesto.

Si utiliza declaraciones AT, compruebe el programa tras la actualización.

Instrucción "MOVE"

La instrucción "MOVE" permite copiar todas las variables de un bloque de datos a otro bloque de datos ("DA a" := "DB b"), si ambos bloques tienen la misma estructura, es decir, la cantidad, los tipos de datos y el orden de declaración de las variables declaradas son idénticos. Además, ambos bloques de datos tienen que tener el mismo formato de almacenamiento (optimizado y sin optimizar).

Si ambos bloques aparecen en el formato de almacenamiento optimizado, todas las variables de ambos bloques deberán ser o bien remanentes, o bien no remanentes.

Instrucción "MOVE" (AWL)

A partir de TIA Portal V16, en AWL ya no se puede transferir una variable del tipo de datos VARIANT de las áreas InOut u Out de la interfaz de bloque a la salida OUT de una instrucción MOVE.

Instrucciones "SCATTER_BLK" y "GATHER_BLK" (SCL)

A partir de la V16 se han restringido los tipos de datos admisibles: Si como parámetros utiliza estructuras (STRUCT o tipo de datos PLC), estas solo pueden contener variables del tipo de datos BOOL.

Constantes sin tipo (SCL)

La prueba semántica de constantes sin tipo se ha adaptado a los otros lenguajes de programación: Si una constante no tipificada no es compatible con el tipo de datos del operando asignado, se notificará un error de compilación siempre que esté activada la verificación IEC.

Direccionamiento de ARRAYS mediante índice variable y acceso a periferia (S7-1200)

En una CPU de la serie S7-1200, ya no se pueden direccionar ARRAYS mediante un índice variable en combinación con el identificador de acceso a periferia ":P".

Ejemplo de un direccionamiento de ARRAY no permitido:

#array[0, #myIndexTag, 2]:P

Ejemplos de direccionamientos de ARRAY permitidos con acceso a periferia:

#array[0, #myConstant, 2]:P

#array[0, 1, 2]:P

Ejemplos de direccionamientos de ARRAY permitidos con índice variable:

#array[0, #myIndexTag, 2]

Tamaño de los bloques si se utilizan ARRAY en estructuras

Si se utilizan estructuras (STRUCT) que contienen más de un elemento ARRAY, podría producirse el siguiente error:

Si varios accesos de ARRAY se encontraban fuera del rango válido, la CPU no pasó a STOP, sino que se accedió a un elemento ARRAY.

Este comportamiento se ha corregido en V16: si eso ocurre, la CPU pasa a STOP o ejecuta un tratamiento local o global de errores si lo tiene programado.

Debido a la corrección es posible que los bloques afectados tengan un tamaño mayor.

Tamaño de los bloques GRAPH

Recuerde que con la corrección anterior todos los bloques GRAPH aumentan aproximadamente en 90 bytes.

Asignación de constantes sin tipo (SCL)

Para la asignación de constantes sin tipo a variables del tipo "Real" se genera un mensaje de error si la comprobación "IEC Check" está activada y al mismo tiempo la constante se encuentra dentro del rango de valores de un LReal y fuera del rango de valores de un Real.


Compatibilidad de programas de PLC de versiones anteriores a la V15.1

Contenido Compatibilidad Secuencia de ejecución de llamadas de función en SCL (S7-1200/S7-1500) Comparadores (SCL S7-1200 >= 4.2 y S7-1500 >= 2.0) Importación de temporizadores CEI (S7-1200/S7-1500) Sustitución de caracteres Unicode no válidos durante la actualización Instrucciones "SCATTER" / "SCATTER_BLK" y "GATHER" / "GATHER_BLK" (S7-1200/1500) Instrucciones "BLKMOV" / "UBLKMOV" y "FILL" / "UFILL" Instrucción “RUNTIME” (SCL/AWL S7-1200/S7-1500)
Compatibilidad de programas de PLC de versiones anteriores a la V15.1

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Compatibilidad

Por principio es posible seguir utilizando en V15.1 todos los programas de PLC que se hayan creado con versiones anteriores de TIA Portal. Sin embargo, puesto que en V15.1 se han realizado algunas mejoras y se han solucionado errores del compilador, en unos pocos casos es posible que el programa tenga un comportamiento distinto después de la actualización o que deba corregirse manualmente el código del programa. A continuación se describen estos casos con detalle.

Secuencia de ejecución de llamadas de función en SCL (S7-1200/S7-1500)

En las versiones anteriores del TIA Portal, la secuencia de ejecución de asignaciones que contenían expresiones o llamadas de función no siempre era unívoca. La ejecución no se realizaba consecuentemente de derecha y izquierda, sino que en determinados casos se evaluaban primero partes de la expresión en la parte izquierda.

Este comportamiento se ha corregido en la versión V15.1, de manera que ahora siempre se calcula primero la parte derecha de la asignación y después se determina la parte izquierda.

Ejemplo:

#myArr["FC_1"()]:= #x + #y;

En las versiones anteriores, aquí se ejecutaba primero la "FC1" para determinar un elemento del ARRAY. Después se calculaba #x + #y.

A partir de la versión V15.1, el programa ahora se ejecuta correctamente de derecha a izquierda: Primero se calcula #x + #y y después se ejecuta la "FC1".

Esta corrección puede hacer que el programa se comporte de distinta manera después de la actualización, p. ej., en caso de que en la "FC1" se activen las variables #x o #y. Compruebe por ello el programa después de la actualización.

Comparadores (SCL S7-1200 >= 4.2 y S7-1500 >= 2.0)

Cuando se comparan entre sí dos bloques de datos de instancia con operaciones de comparación en SCL, no se compara la estructura de los bloques sino simplemente el número de bloque. A partir de la versión V15.1 aparece un mensaje de error durante la compilación, que le indica que esta operación puede no devolver el resultado deseado (por regla general se devuelve FALSE, puesto que los números de los bloques son diferentes).

Ejemplo:

El resultado de la siguiente operación de comparación es FALSE aunque la estructura de los dos bloques sea idéntica.

IF "MyDBofFB" = "MyDBofSameFB" THEN …

Importación de temporizadores CEI (S7-1200/S7-1500)

Los temporizadores CEI contienen parámetros protegidos contra escritura, p. ej. ET (valor de tiempo actual). En las versiones anteriores del TIA Portal se sobrescribían en determinados casos los valores de arranque de estos parámetros protegidos contra escritura al importar archivos fuente externos. Este comportamiento se ha corregido con V15.1. Los valores de arranque de los parámetros protegidos contra escritura ahora se ignoran al importar archivos fuente. En su lugar se utilizan los valores predeterminados del tipo de datos. Compruebe por ello el programa después de la importación.

Sustitución de caracteres Unicode no válidos durante la actualización

Durante la actualización a V15.1, en el programa se corrigen los caracteres Unicode no válidos; p. ej. los caracteres no válidos de las constantes String son sustituidos por secuencias Escape definidas mediante IEC. Por ello puede cambiar la suma de verificación del programa, y se muestran diferencias entre el programa online y el programa offline. En este caso, compile y cargue de nuevo el programa.

Instrucciones "SCATTER" / "SCATTER_BLK" y "GATHER" / "GATHER_BLK" (S7-1200/1500)

Con las instrucciones "SCATTER" / "SCATTER_BLK" se puede dispersar una secuencia de bits en bits individuales. Con los comandos "GATHER" / "GATHER_BLK" se pueden reunir bits individuales en una secuencia de bits.

Los valores con los que operan las instrucciones no pueden encontrarse en el área de periferia o en el DB de un objeto tecnológico, ya que en estas áreas no se garantiza la coherencia de los datos.

Esta regla se verifica con un análisis sintáctico más preciso a partir de V15.1. Si en el programa la instrucción mencionada recibe valores de parámetros de entrada no admisibles, se notificará un error al compilarlo.

Como posible solución a este problema pueden copiarse las variables primero a un área de memoria temporal y transferirlas después a las instrucciones "SCATTER" o "GATHER".

Instrucciones "BLKMOV" / "UBLKMOV" y "FILL" / "UFILL"

Las instrucciones "BLKMOV" / "UBLKMOV" y "FILL" / "UFILL" copian los contenidos de un área de memoria (área de origen) en un área de memoria diferente (área de destino). Si dichas instrucciones se asignan a un área de memoria inexistente, se emite un error de programación. En versiones anteriores, en casos aislados se generaba un código de error en el parámetro "RET_VAL" en vez de un error de programación. Este comportamiento se ha corregido en las CPU S7-1500 a partir de la versión del firmware 2.6.

Instrucción “RUNTIME” (SCL/AWL S7-1200/S7-1500)

El parámetro "Mem" de la instrucción "RUNTIME" es del tipo de datos "LREAL" y solo puede utilizarse con una variable de este tipo de datos. Aquí no es posible realizar una conversión implícita. En la versión V15.1 se comprueba esta regla con un análisis sintáctico más preciso. Si el parámetro "Mem" de la instrucción "RUNTIME" de su programa tiene un tipo de datos no permitido, aparecerá un mensaje de error durante la compilación.


Compatibilidad con programas de PLC de versiones anteriores a V15

Contenido Compatibilidad S7-GRAPH: conversiones implícitas "Tipos de datos de hardware <> INT" Subcategorías en ProDiag (S7-1500) Instrucciones "(U)MOVE_BLK" y "(U)FILL_BLK" (S7-1500) Bucles de programa en SCL (S7-1200/S7-1500) Valores de retorno de funciones en SCL LDT_TO_DATE en SCL (S7-1500) Comparación de un elemento de ARRAY con una variable del tipo de datos "VARIANT" en SCL (S7-1200/1500) Instrucción "GetSymbolPath" (S7-1200/S7-1500) Instrucción "GetInstancePath" (S7-1200/S7-1500) Sumas y restas con DTL/LDT/DT Información sobre el tiempo de ejecución (S7-1200/S7-1500) ARRAYs de multiinstancias Parámetros de bloque del tipo de datos "VARIANT" (S7-1200/1500) Importar fuentes externas Tamaño de ARRAY of BOOL/BYTE/CHAR (S7-1500)
Compatibilidad con programas de PLC de versiones anteriores a V15

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Compatibilidad

Por principio es posible seguir utilizando en V15 todos los programas de PLC que se hayan creado con versiones anteriores del TIA Portal. Sin embargo, puesto que en V15 se han realizado algunas mejoras y se han solucionado errores del compilador, en unos pocos casos es posible que el programa tenga un comportamiento distinto después de la actualización o que deba corregirse manualmente el código del programa. A continuación se describen estos casos con detalle.

S7-GRAPH: conversiones implícitas "Tipos de datos de hardware <> INT"

A partir de TIA Portal V15 ya no es posible programar conversiones implícitas de tipos de datos de hardware (p. ej. INT -> DB_ANY o DB_ANY -> INT), tal como sucede ya en KOP, FUP, AWL y SCL.

En su lugar, utilice el tipo de datos UINT o una conversión explícita.

Subcategorías en ProDiag (S7-1500)

A partir del TIA Portal V14 SP1 Update 2 ya no se agregan manualmente las diferentes subcategorías para ProDiag, sino que se activan o desactivan en la columna "Activación".

Esto hace que, después de actualizar un proyecto <V14 SP1 Update 2 que utilice subcategorías existentes en una supervisión como mínimo, sea necesario ejecutar el botón "Reparar" antes de poder crear otras subcategorías.

Instrucciones "(U)MOVE_BLK" y "(U)FILL_BLK" (S7-1500)

En las versiones del TIA Portal <= V15, las instrucciones "(U)MOVE_BLK" y "(U)FILL_BLK" solo accedían a la memoria imagen de proceso en caso de acceso directo a la periferia.

Este comportamiento se ha corregido y ahora provoca un error en tiempo de ejecución, pues no se permiten accesos directos a periferia con comandos BLK.

Bucles de programa en SCL (S7-1200/S7-1500)

En S7-1200/S7-1500 no es posible modificar en SCL el índice de un bucle de programa desde el propio bucle.

El siguiente ejemplo no sería válido:

FOR #i := 1 TO 10 DO

#i := #i + 1;

END_FOR;

En este contexto, a partir de TIA Portal V15 se comprueba la sintaxis con mayor detalle y se emite un error de compilación.

Valores de retorno de funciones en SCL

Este comportamiento se ha igualado en las funciones cuyo valor de retorno tiene un tipo de datos estructurado. Tipos de datos estructurados son, p. ej., tipos de datos PLC, STRUCT o STRING.

Dependiendo de si se utilizara o no la salida ENO de la función, hasta ahora podía ocurrir que se creara una copia de trabajo temporal del valor de función, aunque esta copia no se creara con la misma llamada sin ENO. La asignación de esta copia temporal a la variable interconectada se efectuaba al finalizar la función.

Este comportamiento se ha modificado del modo siguiente:

El uso del parámetro de salida ENO ahora ya no influye en si el valor de retorno se transfiere mediante copia o mediante referencia. Si el valor de retorno tiene un tipo de datos estructurado, normalmente se transfiere mediante referencia. Las reglas de transferencia se describen detalladamente en el capítulo "Transferencia de parámetros como copia o como puntero"

LDT_TO_DATE en SCL (S7-1500)

Se ha corregido el comportamiento de LDT_TO_DATE en caso de error de conversión en tiempo de ejecución.

Comparación de un elemento de ARRAY con una variable del tipo de datos "VARIANT" en SCL (S7-1200/1500)

Hasta ahora, en algunos casos no se llevaba a cabo correctamente la comparación de un elemento de ARRAY de indexación variable con un VARIANT. En lugar del elemento de ARRAY se tomaba todo el ARRAY para la comparación.

Este comportamiento se ha corregido en V15: para la comparación se evalúa ahora el elemento de ARRAY indexado. Si utiliza este tipo de comparaciones en el programa, tendrá que comprobar el bloque en cuestión después de la actualización.

Ejemplo:

IF (#my_Array[#1] = #my_variant) THEN…

Hasta ahora se comparaba "my_variant" con "my_Array". A partir de V15, la comparación se realiza correctamente y "my_variant" se compara con el elemento #1 de "my_Array".

Instrucción "GetSymbolPath" (S7-1200/S7-1500)

Si un FB interconecta una variable estática en un parámetro formal de una llamada y un bloque subordinado utiliza "GetSymbolPath" V1.0 o V1.1 para el parámetro, al compilar este bloque se muestra adicionalmente el nombre del DB antes del nombre de la variable estática, sin utilizar el punto como separador ni sustituir #. La versión V1.2 de "GetSymbolPath" muestra la ruta correctamente, con el punto como separador y sin #.

Si utiliza la instrucción "GetSymbolPath" en el programa, después de actualizar a la versión >=V15 debería utilizar la instrucción "GetSymbolPath" V1.2.

Instrucción "GetInstancePath" (S7-1200/S7-1500)

Si un FB interconecta una variable estática en un parámetro formal de una llamada y un bloque subordinado utiliza "GetInstancePath", al compilar este bloque se muestra adicionalmente el nombre del DB antes del nombre de la variable estática.

Sumas y restas con DTL/LDT/DT

En las sumas y restas con los tipos de datos DTL/LDT/DT ya no es posible utilizar constantes sin tipo. Se notifica un error de sintaxis.

Así, por ejemplo, ya no es posible realizar las siguientes operaciones aritméticas:

#myDTL + 1

#myLDT + 1

#myDate_And_Time +1

Utilice en su lugar constantes del tipo de datos "Time" o "LTime".

#myDTL + TIME#1d

#myLDT + TIME#1ms

#myDate_And_Time + LTIME#1ns

Información sobre el tiempo de ejecución (S7-1200/S7-1500)

Las instrucciones avanzadas "GetInstanceName", "GetInstancePath", "GetSymbolName", "GetSymbolPath" y "GetBlockName" tienen ahora el mismo comportamiento en todos los lenguajes de programación: Si la cadena de caracteres que debe devolverse no cabe en el parámetro de salida "OUT" debido a limitaciones de tamaño, el nombre se acorta y se muestra el carácter "..." al final de la cadena de caracteres.

ARRAYs de multiinstancias

Hasta ahora, en algunos casos no era posible direccionar correctamente ARRAYs de multiinstancias, cuando mediante un índice variable se direccionaba una multiinstancia que estaba instanciada en otra multiinstancia que, a su vez, era un elemento de un ARRAY de multiinstancias.

Ejemplo:

#MyMultiArray[#index].MyMultiMember := 10;

Este comportamiento se ha corregido en V15.

Si ha utilizado este tipo de accesos en el programa, tendrá que comprobar el bloque en cuestión después de la actualización y posiblemente volver a compilarlo.

Parámetros de bloque del tipo de datos "VARIANT" (S7-1200/1500)

Igual que en KOP, FUP, AWL y GRAPH, ahora tampoco es posible asignar en SCL un DB de instancia como parámetro actual a un parámetro formal del tipo de datos "VARIANT".

De esta norma se exceptúan los DB de instancia que derivan de un tipo de datos PLC o un tipo de datos de sistema. Estos pueden asignarse a un parámetro de bloque del tipo de datos "VARIANT" en todos los lenguajes de programación.

Ya no es posible asignar una variable protegida contra escritura a un parámetro de bloque de tipo "VARIANT" como parámetro actual.

Siempre que sea posible, elimine la protección contra escritura de la variable. Si esto no fuera posible, intente modificar el programa para evitar el acceso a la variable protegida contra escritura. Si, por ejemplo, solo desea un acceso de lectura, puede copiar el contenido de la variable protegida contra escritura del bloque llamante en otra variable que no tenga protección contra escritura. Seguidamente, puede transferir esta variable como parámetro actual.

Importar fuentes externas

Hasta ahora, cuando se importaba una fuente externa en la que se utilizaba una instrucción como multiinstancia o instancia individual, todo el programa se convertía a la versión de la instrucción utilizada en la fuente. A partir de la versión V15 de TIA Portal se ha corregido este comportamiento: Las instrucciones que ya están en el proyecto no se convierten, sino que conservan la versión de instrucción configurada.

Si el proyecto contiene diferentes versiones de una instrucción tras la importación, se notifica un error de sintaxis. En tal caso, vuelva a compilar todo el programa. Para ello, en el árbol del proyecto seleccione la carpeta "Bloques de programa" y, en el menú contextual, elija el comando "Compilar > Software (solo cambios)" o "Compilar > Software (compilar todo)".

Tamaño de ARRAY of BOOL/BYTE/CHAR (S7-1500)

Hasta ahora, los ARRAYs de los tipos de datos BOOL, BYTE o CHAR tenían tamaños distintos en función de si se utilizaban dentro de una estructura o no. A partir de V15 se ha unificado el tamaño de los ARRAYs. Si en el programa se accede de forma absoluta, p. ej. a través de un puntero ANY, a un ARRAY of BOOL, BYTE o CHAR, hay que comprobar el programa después de la actualización.


Compatibilidad de programas de PLC de versiones anteriores a la V14 SP1

Contenido Compatibilidad Tamaño total de los valores asociados para avisos de programa Bucles de programa en SCL (S7-1200/S7-1500) Instrucciones CASE en SCL ARRAYs de multiinstancias Tipo de parámetro "Block_DB" para indicar el DB de instancia Accesos a periferia en calidad de parámetros de entrada de bloques (S7-1500 con firmware V2.1 o superior)
Compatibilidad de programas de PLC de versiones anteriores a la V14 SP1

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Compatibilidad

Por principio es posible seguir utilizando en V14 SP1 todos los programas de PLC que se hayan creado con versiones anteriores del TIA Portal. Sin embargo, puesto que en V14 SP1 se han realizado algunas mejoras y se han solucionado errores del compilador, en unos pocos casos es posible que el programa tenga un comportamiento distinto después de la actualización o que deba adaptarse manualmente el código del programa. A continuación se describen estos casos con detalle.

Asimismo, existe la posibilidad de editar el proyecto en modo de compatibilidad. Encontrará más información sobre la compatibilidad en "Compatibilidad de proyectos".

Tamaño total de los valores asociados para avisos de programa

El sistema de avisos de la CPU S7-1500 proporciona un máximo de 512 bytes para valores asociados (parámetros SD) de la instrucción "Program_Alarm".

Este tamaño se indicaba simplemente con una advertencia durante la compilación en las versiones v14 de TIA Portal o anteriores. A partir del TIA Portal V14 SP1 se lleva a cabo una comprobación más estricta. Si se excede este tamaño, durante la compilación se emite un error con el fin de excluir escenarios de error en tiempo de ejecución. A partir de ahora, esta comprobación ya no hace referencia al tamaño real de los parámetros SD en el momento de llamar a la instrucción "Program_Alarm", sino al tamaño máximo posible de los parámetros SD. Por consiguiente, hay que considerar de antemano la longitud con la que se declararán las variables de secuencias de caracteres que se transferirán, pues ocupan muchos bytes.

Esta cuestión deberá tenerse en cuenta al migrar proyectos de la versión V14 o anteriores a la versión V14 SP1 Update 1 o superiores.

Bucles de programa en SCL (S7-1200/S7-1500)

En S7-1200/S7-1500 no es posible modificar en SCL el índice de un bucle de programa desde el propio bucle.

El siguiente ejemplo no sería válido:

FOR #i := 1 TO 10 DO

#i := #i + 1;

END_FOR;

A partir de TIA Portal V14.0.1 se comprueba la sintaxis con mayor detalle y se emite un error de compilación.

Instrucciones CASE en SCL

En una instrucción CASE ya no se admiten etiquetas sin la instrucción "GOTO" correspondiente. Se notifica un error de sintaxis.

ARRAYs de multiinstancias

En la versión V14 podía ocurrir que los ARRAYs de multiinstancias no se direccionaran correctamente cuando algunas variables de una multiinstancia tenían el ajuste de remanencia "Ajustar en IDB“. Este comportamiento se ha corregido en V14 SP1:

Si ha utilizado este tipo de variables en el programa, es posible que tenga que compilar el bloque en cuestión después de la actualización.

Tipo de parámetro "Block_DB" para indicar el DB de instancia

En KOP y FUP no es posible indicar el DB de instancia mediante una entrada del tipo "Block_DB". Este comportamiento se ha unificado en todas las familias de CPU y en todos los tipos de bloques.

A partir de TIA Portal V14 SP1 se emite un error de sintaxis.

Si ha transferido Dbs de instancia en el programa con el tipo de datos "Block_DB", deberá modificar el programa. En su lugar, utilice una instancia de parámetro para transferir la instancia en tiempo de ejecución.

Accesos a periferia en calidad de parámetros de entrada de bloques (S7-1500 con firmware V2.1 o superior)

Los accesos directos a periferia que están interconectados a bloques como parámetros de entrada ya no impiden que se ejecute el bloque cuando se produce un error de acceso a periferia. En su lugar se trabaja con el valor sustitutivo de la señal en el bloque.

En las CPU S7-1500 con firmware inferior a la versión V2.1 y en todas las CPU S7-1200, el comportamiento del sistema no cambia:

No se llama al bloque debido al error de acceso a periferia. El programa sigue ejecutándose tras llamar al bloque. Si existe un OB 122 o si el tratamiento local de errores está activado, estos se ejecutan.


Compatibilidad con programas de PLC de versiones anteriores a V14

Contenido Compatibilidad AWL: Instrucciones "SRW", "SLW" y "SSI" (S7-300, S7-400, S7-1500) Representación del formato BCD Instrucciones "SET_BF: Activar mapa de bits" y "RESET_BF: Desactivar mapa de bits" (S7-1200, S7-1500) Instrucciones "SCALE: Escalar" y "UNSCALE: Desescalar" (S7-1500) Bits no utilizados de tipos de datos PLC (UDT) para firmware >= V1.8.1 Conversión explícita de tipos de datos en SCL (S7-1200) para firmware >= V4.2 SCL: Mecanismo EN/ENO en parámetros de bloque del tipo de datos (W)STRING (S7-1200/1500) Transmisión de parámetros STRING entre bloques optimizados y bloques estándar (S7-1200/1500) Declaración de longitudes en constantes del tipo de datos "STRING" o "WSTRING" Cambio del tipo de datos básico para HW_ANY de WORD a UINT Longitud de comentarios de bloque Comprobación de sintaxis de las instrucciones " SR: Flipflop de activación/desactivación " y " RS: Flipflop de desactivación/activación " Puntero Any: acceso a datos optimizados Tipo de datos "(L)REAL" Parámetro "ST" con temporizadores CEI Valores asociados para avisos (S7-1500) Conversión de tipos de datos implícita en parámetros de bloque del tipo de datos "DB_ANY" Interfaz de los bloques de organización con acceso estándar Comparación de variables del tipo de datos WORD con variables del tipo de datos S5TIME (S7-1500)
Compatibilidad con programas de PLC de versiones anteriores a V14

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Compatibilidad

En principio es posible seguir utilizando en V14 todos los programas de PLC que se hayan creado con versiones anteriores del TIA Portal. Sin embargo, puesto que en V14 se han realizado algunas mejoras y se han solucionado errores del compilador, en unos pocos casos es posible que el programa tenga un comportamiento distinto después de la actualización o que deba adaptarse manualmente el código del programa. A continuación se describen estos casos con detalle.

AWL: Instrucciones "SRW", "SLW" y "SSI" (S7-300, S7-400, S7-1500)

El rango de valores permitido para el número de desplazamiento de estas instrucciones en el TIA Portal V14 ha cambiado respecto al TIA Portal V13 SP1.

En la versión V13 SP1 es posible indicar como número de desplazamiento en una CPU de las series S7-1200/1500 un número comprendido entre 0 y 31 y, en una CPU de las series S7-300/400, un número comprendido entre 0 y 15.

A partir de la versión V14, los rangos de valores para todas las series de CPU (S7-300/400/1200/1500) se han fijado a un valor unitario de 0 a 15.

Representación del formato BCD

La representación del formato BCD ha cambiado en relación al signo del TIA Portal V13 SP1 respecto del TIA Portal V14.

En la versión V13 SP1, los valores en formato BCD se representan sin signo.

A partir de la versión V14, los valores en formato BCD se representan con signo. Esto puede provocar que los valores en formato BCD presenten una representación modificada.

Enteros (sistema decimal) | Números hexadecimales | Representación en V13 SP1 | Representación en V14
0 | 16#0000 | BCD#0 | BCD#0
-26215 | 16#9999 | BCD#9999 | BCD#-999
1365 | 16#0555 | BCD#555 | BCD#555
21845 | 16#5555 | BCD#5555 | BCD#555
4096 | 16#1000 | BCD#1000 | BCD#0
-28672 | 16#9000 | BCD#9000 | BCD#0

Instrucciones "SET_BF: Activar mapa de bits" y "RESET_BF: Desactivar mapa de bits" (S7-1200, S7-1500)

El comportamiento de la instrucción en relación con las estructuras del TIA Portal V13 SP1 ha cambiado respecto al TIA Portal V14.

En la versión V13 SP1 se activan o desactivan siempre tantos bits como se indican en la entrada. Esto se aplica también cuando se ha indicado una estructura del tipo de datos PLC, STRUCT o ARRAY, por ejemplo. Si, p. ej., desea activar o desactivar 10 bits y la estructura solo contiene 5 bits, se activarán o desactivarán también los 5 bits siguientes del orden de direcciones.

A partir de la versión V14, en estructuras del tipo de datos PLC, STRUCT o ARRAY se activan como máximo tantos bits como contiene la estructura: Si se indica el valor "20", por ejemplo, y la estructura solo contiene 10 bits, solo se activarán esos 10 bits. Si se indica el valor "5", por ejemplo, y la estructura contiene 10 bits, se activarán exactamente 5 bits.

Instrucciones "SCALE: Escalar" y "UNSCALE: Desescalar" (S7-1500)

El comportamiento de la instrucción ha cambiado en relación a la indicación de los valores límite (LO_LIM > HI_LIM) del TIA Portal V13 SP1 respecto del TIA Portal V14.

En la versión V13 SP1 se obtenía un mensaje de error si el valor límite inferior era mayor que el superior.

A partir de la versión V14 esta entrada sí que está permitida y el resultado se escala invertido y proporcional al valor de entrada.

En las CPU de las series S7-300/400 la instrucción siempre ha escalado el resultado invertido y proporcional al valor de entrada.

Bits no utilizados de tipos de datos PLC (UDT) para firmware >= V1.8.1

Los bits no utilizados de tipos de datos PLC en áreas de memoria estándar se asignan o sobrescriben, p. ej. en un tipo de datos PLC que contiene 4 bits.

En las versiones de firmware anteriores a V1.8.1 no era posible dar otro uso a los bits no utilizados de un tipo de datos PLC.

En las versiones de firmware V1.8.1 y posteriores se asignan o sobrescriben todos los bits, incluso aunque solo se utilicen 4 bits.

Nota

Asignaciones de direcciones

Preste atención a que los diferentes direccionamientos simbólicos no asignen dos veces la misma dirección absoluta.

Conversión explícita de tipos de datos en SCL (S7-1200) para firmware >= V4.2

Para versiones de firmware < V4.2, en la conversión explícita de datos en SCL de SINT/INT/DINT/REAL_TO_STRING/WSTRING, la cadena de caracteres se transfirió alineada la derecha y se rellenó con espacios iniciales.

Ejemplo: REAL_TO_WSTRING(12) = ' 1.200000E+1'

A partir del TIA Portal V13, en la conversión explícita de datos en SCL de SINT/INT/DINT/REAL_TO_STRING/WSTRING, la cadena de caracteres se representa con un signo antepuesto y se transfiere alineada a la izquierda.

Ejemplo: REAL_TO_WSTRING(12) = '+1.200000E+1'

SCL: Mecanismo EN/ENO en parámetros de bloque del tipo de datos (W)STRING (S7-1200/1500)

A partir de TIA Portal V14 se comprueba si los parámetros de bloque del tipo de datos (W)STRING se cortan en tiempo de ejecución al transferir los parámetros. Esto puede ocurrir si los parámetros formales y actuales declarados tienen longitudes diferentes. Si la longitud declarada del parámetro de destino no es suficiente en tiempo de ejecución para incorporar el (W)STRING, el (W)STRING queda cortado y la salida de habilitación ENO se pone a "FALSE".

Si la salida de habilitación ENO se evalúa en el programa, es posible que la semántica del programa cambie.

Transmisión de parámetros STRING entre bloques optimizados y bloques estándar (S7-1200/1500)

Antes de TIA Portal V14, al transferir parámetros entre bloques optimizados y no optimizados no se transmitía información de longitud de STRING al bloque llamado. De ese modo, al procesar posteriormente el STRING se podían producir errores de acceso no detectados por el mecanismo ENO. El mecanismo de habilitación "ENO" permanecía en "TRUE" a pesar del error de acceso.

A partir de TIA Portal V14 se transmite la información de longitud de STRING y el mecanismo ENO detecta los errores de acceso. Si la salida de habilitación ENO se evalúa en el programa, es posible que la semántica del programa cambie.

Declaración de longitudes en constantes del tipo de datos "STRING" o "WSTRING"

En las constantes (W)STRING locales y globales no se permiten declaraciones de longitudes. Si su programa contiene declaraciones de longitudes, p. ej., "MyStringConst [7]", se eliminan automáticamente al actualizar. De todas formas, este cambio no afecta a la semántica del programa.

Cambio del tipo de datos básico para HW_ANY de WORD a UINT

El tipo de datos de hardware "HW_ANY" permite identificar un componente de hardware cualquiera, p. ej. de un módulo. En V14 el tipo de datos básico de "HW_ANY" se cambió de WORD a UINT. Por eso, tras la conversión a V14 pueden producirse errores durante la compilación si en un parámetro del tipo de datos "HW_ANY" se ha indicado como valor actual una constante WORD explícita (p. ej. W#16#1) o una variable del tipo de datos WORD.

En ese caso, cambie la notación de la constante (p. ej. a 16#1) o cambie el tipo de datos de las variables a UINT.

Longitud de comentarios de bloque

A partir de TIA Portal V14 los comentarios de bloque no deben superar una longitud de 32767 caracteres Unicode.

Comprobación de sintaxis de las instrucciones " SR: Flipflop de activación/desactivación " y " RS: Flipflop de desactivación/activación "

En la entrada "S" se pueden utilizar como operandos entradas, salidas, marcas y datos tanto estáticos como locales. No se permite el uso de constantes. Sin embargo, hasta ahora la comprobación de sintaxis no rechazaba el uso de las constantes "0" y "1". A partir del TIA Portal V14 se ha mejorado el análisis sintáctico, de forma que ahora también se rechaza el uso de "0" o "1" en la entrada "S". Es posible que al compilar reciba ahora un mensaje de error para un programa que hasta ahora se podía compilar sin errores. En este caso, cambie su programa y utilice un operando permitido.

Puntero Any: acceso a datos optimizados

El puntero ANY solo debe apuntar a las áreas de memoria con tipo de acceso "Estándar", incluso en una CPU de la serie S7-1500. No se permite el acceso a datos optimizados a través de un puntero ANY.

A partir de TIA Portal V14 tiene lugar una comprobación de sintaxis más precisa para los punteros ANY. Ahora se rechaza el acceso a datos optimizados. Es posible que al compilar reciba ahora un mensaje de error para un programa que hasta ahora se podía compilar sin errores.

Tipo de datos "(L)REAL"

En determinadas ocasiones, en las versiones de Windows de 64 bits el tipo de datos LREAL se evalúa de forma diferente que en las versiones de 32 bits. Pueden surgir diferencias al redondear y con valores (L)Real de constantes en el bit menos significativo.

La posible diferencia está en la última posición de la mantisa, por lo que en la mayoría de casos solo afectará mínimamente a la precisión.

Si se evalúa la última posición de la mantisa, la semántica del programa STEP 7 puede variar tras la conversión.

Parámetro "ST" con temporizadores CEI

El parámetro "ST" de un temporizador CEI se utiliza internamente y no puede escribirse. Por eso ese parámetro ya no es visible a partir de TIA Portal V14. Si en el programa se accede en modo de escritura al parámetro "ST", tras actualizar la versión se muestra un mensaje de error al compilar.

Si se sustituyen datos con ingeniería interproyecto y se ha accedido al parámetro "ST" con HMI, primero hay que exportar el proyecto y volver a importarlo en la CPU proxy. Solo entonces desaparecerá el parámetro "ST" en la configuración HMI.

Valores asociados para avisos (S7-1500)

Los proyectos creados con una versión anterior del TIA Portal pueden contener valores asociados incrustados con diferentes estructuras en los distintos idiomas del proyecto. Por ejemplo, los valores asociados pueden tener un orden diferente o faltar en uno de los idiomas. Al actualizar uno de estos proyectos se unifica el orden de los valores asociados. La actualización se rige por el idioma de referencia configurado en el proyecto original. En tal caso es recomendable revisar y corregir los textos traducidos.

Conversión de tipos de datos implícita en parámetros de bloque del tipo de datos "DB_ANY"

Cuando se accede a un parámetro de bloque del tipo de datos "DB_ANY" con la sintaxis DB_ANY.%DB(B|W|D), hasta ahora no se llevaba a cabo ninguna conversión de tipos de datos implícita. El patrón de bits del valor de origen se desplazaba simplemente al tipo de datos de destino. Si el tipo de datos de destino era menor que el de origen, se producía un desbordamiento y podía suceder que el valor escrito fuera falso o impreciso. En caso de pérdidas de precisión o errores en tiempo de ejecución, la salida de habilitación ENO no se ponía a "FALSE".

A partir de la V14, en caso de transferencia de parámetros con la sintaxis DB_ANY.%DB(B|W|D) se lleva a cabo una conversión conforme a las reglas de conversión de tipos de datos implícita. Tenga en cuenta que esto puede provocar que tras actualizar la versión se escriba un valor distinto y que la semántica del programa puede cambiar. Asimismo, cuando se produce un error en tiempo de ejecución, la salida de habilitación ENO se pone a "FALSE".

Interfaz de los bloques de organización con acceso estándar

La interfaz de los bloques de organización con acceso estándar debe tener por lo menos un tamaño de 20 bytes. En versiones anteriores del TIA Portal, durante el proceso de compilación solo se comprobaba el tamaño mínimo de la interfaz del OB1. A partir de V14 se comprueban las interfaces de todos los bloques de organización. Es posible que al compilar reciba ahora un mensaje de error para un programa que hasta ahora se podía compilar sin errores.

Comparación de variables del tipo de datos WORD con variables del tipo de datos S5TIME (S7-1500)

A partir del TIA Portal V14, cuando se compara una variable del tipo de datos WORD con una variable del tipo de datos S5TIME, ambas variables se convierten al tipo de datos TIME. La variable WORD se interpreta como un valor S5TIME. En caso de que no fuera posible convertir una de las dos variables, la comparación no se realizará y el resultado será FALSE. Si la conversión es correcta, la comparación se realizará en función de la expresión de comparación seleccionada.


Compatibilidad de programas de PLC de versiones anteriores a la V13 SP1

Contenido Compatibilidad Bits no utilizados de tipos de datos PLC (UDT) para firmware >= V1.8.1 Conversión explícita de tipos de datos en SCL (S7-1200) para firmware >= V4.2 Lectura de una entrada de periferia no válida Instrucción "S_CONV: Convertir cadena de caracteres" Instrucción "SET: Activar área por bits" (S7-300/S7-400) Instrucción "MUX: Multiplexar" (SCL) Instrucción "DEMUX: Desmultiplexar" (SCL) Instrucción "MOVE: Copiar valor" (AWL) (S7-1500) Instrucción "Program_Alarm: Crear aviso de programa con valores asociados" (S7-1500) Instrucciones "READ_DBL: Leer en un bloque de datos de la memoria de carga" y "WRIT_DBL: Escribir en un bloque de datos de la memoria de carga" Instrucciones "READ_DBL: Leer de un bloque de datos de la memoria de carga" y "WRIT_DBL: Escribir en un bloque de datos de la memoria de carga" (SCL) Valores de función (Return) Comparación de los dos tipos de datos de hardware HW_IO y HW_DEVICE Conversión implícita de números en coma flotante a DWORD (GRAPH) (S7-1500) Asignación de un valor a una constante LTIME (S7-1500) Indexación indirecta de componentes ARRAY del tipo de datos Secuencia de bits en SCL (S7-1200/S7-1500) Mecanismo EN/ENO en conversiones de STRING (S7-1200/S7-1500) Rebase por exceso de la pila de datos locales (S7-300/S7-400)
Compatibilidad de programas de PLC de versiones anteriores a la V13 SP1

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Compatibilidad

En principio es posible seguir utilizando en V13 SP1 todos los programas de PLC que se hayan creado con el TIA Portal V12 SP1 o V13. Sin embargo, puesto que en V13 SP1 se han realizado algunas mejoras y se han solucionado errores del compilador (compilación del código del programa), en unos pocos casos es posible que el programa tenga un comportamiento distinto después de la actualización o que deba adaptarse manualmente el código del programa. A continuación se describen estos casos con detalle.

Bits no utilizados de tipos de datos PLC (UDT) para firmware >= V1.8.1

Los bits no utilizados de tipos de datos PLC en áreas de memoria estándar se asignan o sobrescriben, p. ej. en un tipo de datos PLC que contiene 4 bits.

En las versiones de firmware anteriores a V1.8.1 no era posible dar otro uso a los bits no utilizados de un tipo de datos PLC.

En las versiones de firmware V1.8.1 y posteriores se asignan o sobrescriben todos los bits, incluso aunque solo se utilicen 4 bits.

Nota

Asignaciones de direcciones

Preste atención a que los diferentes direccionamientos simbólicos no asignen dos veces la misma dirección absoluta.

Conversión explícita de tipos de datos en SCL (S7-1200) para firmware >= V4.2

Para versiones de firmware < V4.2, en la conversión explícita de datos en SCL de SINT/INT/DINT/REAL_TO_STRING/WSTRING, la cadena de caracteres se transfirió alineada la derecha y se rellenó con espacios iniciales.

Ejemplo: REAL_TO_WSTRING(12) = ' 1.200000E+1'

A partir del TIA Portal V13, en la conversión explícita de datos en SCL de SINT/INT/DINT/REAL_TO_STRING/WSTRING, la cadena de caracteres se representa con un signo antepuesto y se transfiere alineada a la izquierda.

Ejemplo: REAL_TO_WSTRING(12) = '+1.200000E+1'

Lectura de una entrada de periferia no válida

En TIA Portal a partir de la versión V12 el código de error 16#2942 para la lectura de una entrada de periferia no válida solo se emite si el acceso erróneo se ha programado de tal forma que también sea efectivo, p. ej. %MW10 := "AccesoPalabraNoVálida":P, y no se encuentre dentro de una secuencia irrelevante. Esto sería p. ej. #tmp := "AccesoPalabraNoVálida":P, si la variable #tmp no se utiliza en el bloque de programa restante.

Instrucción "S_CONV: Convertir cadena de caracteres"

En el TIA Portal V13 SP1, el mecanismo EN/ENO tiene un comportamiento distinto al del TIA Portal V13.

En la versión V13, la salida de habilitación ENO tiene el estado lógico "0" en caso de error, incluso si se ha desactivado. Si se ha conmutado otra instrucción en la salida de habilitación ENO, no se ejecutará.

En la versión V13 SP1, la salida de habilitación ENO tiene el estado lógico "1" en caso de error si se ha desactivado. Si se ha conmutado otra instrucción en la salida de habilitación ENO, se ejecutará del modo previsto.

Instrucción "SET: Activar área por bits" (S7-300/S7-400)

El TIA Portal permite interconectar también un elemento de un bloque de datos en el parámetro N de la instrucción SET.

Instrucción "MUX: Multiplexar" (SCL)

Hasta el TIA Portal V13 inclusive, el valor de las variables en el parámetro de entrada se emitía sin cambios como valor de función, incluso si el parámetro K tenía un entero negativo. Este comportamiento ha cambiado en el TIA Portal V13 SP1.

Si en TIA Portal V13 SP1, en los parámetros de entrada de la instrucción MUX, se indica una variable con un tipo de datos válido y el parámetro K tiene un entero negativo, el valor de la variable se modifica. Encontrará los tipos de datos válidos en la descripción de la instrucción MUX que se incluye en el sistema de información.

Instrucción "DEMUX: Desmultiplexar" (SCL)

Hasta el TIA Portal V13 inclusive, en el parámetro de salida OUTELSE no se emitía ningún valor si el valor del parámetro K era < 0. En cambio, en el parámetro de salida OUTELSE se emitía el valor del parámetro de entrada IN cuando el valor del parámetro K era > a las salidas disponibles. Este comportamiento ha cambiado en el TIA Portal V13 SP1.

Si en el TIA Portal V13 SP1 no se indica ningún valor en el parámetro K que esté fuera de las salidas disponibles (K < 0 o K > salidas disponibles), en el parámetro de salida OUTELSE se emitirá el valor del parámetro de entrada IN.

Instrucción "MOVE: Copiar valor" (AWL) (S7-1500)

A partir del TIA Portal V13 SP1, la regla de sintaxis para la instrucción "MOVE" en AWL es más estricta:

Hasta el TIA Portal V13 inclusive, era posible indicar las constantes sin tipo, p. ej., "0", en el parámetro de entrada IN.

Si en el TIA Portal V13 SP1 se quiere copiar el valor "0", por ejemplo, ahora debe indicarse una constante con tipo, según el tipo de datos del parámetro de salida (p. ej., INT#0, DINT#0, etc.).

Instrucción "Program_Alarm: Crear aviso de programa con valores asociados" (S7-1500)

A partir de TIA Portal V13 SP1 el tipo de datos INT ya no puede utilizarse para los valores asociados o para una variable de indexación de una lista de textos. En su lugar, utilice el tipo de datos UNIT.

Instrucciones "READ_DBL: Leer en un bloque de datos de la memoria de carga" y "WRIT_DBL: Escribir en un bloque de datos de la memoria de carga"

El TIA Portal V13 SP1 notifica un error de compilación si se utiliza "READ_DBL" V1.0 o "WRIT_DBL" V1.0 y se accede a un bloque de datos con el atributo "Guardar solo en memoria de carga" con el parámetro DSTBLK.

En su lugar, utilice la versión 1.2 de ambas instrucciones.

Instrucciones "READ_DBL: Leer de un bloque de datos de la memoria de carga" y "WRIT_DBL: Escribir en un bloque de datos de la memoria de carga" (SCL)

A partir de TIA Portal V13 SP1, en las instrucciones "READ_DBL" y "WRIT_DBL" de SCL rige la misma regla sintáctica estricta, igual que en todos los lenguajes de programación restantes:

En el TIA Portal V13 era posible indicar en los parámetros SRCBLK y DSTBLK bloques de datos "estándar" cuyas variables tenían tipos de datos diferentes.

A partir de TIA Portal V13 SP1 las diferentes variables contenidas, tanto en bloques "estándar" como "optimizados", tienen que tener el mismo tipo de datos, dado que de lo contrario se emite un error de compilación.

Valores de función (Return)

A partir del TIA Portal V13 SP1, las reglas de sintaxis para llamadas de función son más estrictas:

Se comprueba que el valor de función (Return) se escriba en todos los casos, aunque puedan ejecutarse varias rutas de programa posibles en la función, p. ej. en caso de utilizar comandos de salto o bucles IF. De este modo ya no hay peligro de que dejen de escribirse valores de función por descuido durante el tiempo de ejecución.

Sin embargo, es posible que durante la compilación se reciban errores de sintaxis en funciones que con V13 podían compilarse correctamente. En ese caso debe cambiarse el código del programa para que el valor de función se escriba en todas las rutas del programa posibles.

Ejemplo:

SCL Copia el código de programa siguiente en el portapapeles.

IF #MyIn1 = #MyIn2 THEN

#Block_3 := #MyIn1 + 1;

END_IF;

En este ejemplo, el valor de función de "Block_3" no se escribe si no se cumple la condición de la instrucción IF. El valor de función contiene entonces un valor indefinido.

SCL Copia el código de programa siguiente en el portapapeles.

#Block_3 := #MyIn1;

IF #MyIn1 = #MyIn2 THEN

#Block_3 := #MyIn1 + 1;

END_IF;

En este ejemplo, el valor de función de "Block_3" se escribe siempre, puesto que está predefinido con "MyIn1" antes de ejecutar el bucle IF.

Comparación de los dos tipos de datos de hardware HW_IO y HW_DEVICE

A partir del TIA Portal V13 SP1, se aplica una regla de sintaxis más estricta en la comparación de los tipos de datos HW_IO y HW_DEVICE:

Hasta la versión TIA Portal V13 inclusive era posible comparar directamente los dos tipos de datos HW_IO y HW_DEVICE.

Si desea comparar los dos tipos de datos en el TIA Portal V13 SP1, primero deberá crear una variable del tipo HW_ANY en la sección "Temp" de la interfaz del bloque y después copiar el LADDR (del tipo HW_DEVICE) en la variable. A continuación se puede comparar HW_ANY y HW_IO.

Conversión implícita de números en coma flotante a DWORD (GRAPH) (S7-1500)

A partir del TIA Portal V13 SP1, las reglas de sintaxis para la conversión implícita de números en coma flotante a DWORD son más estrictas:

Hasta el TIA Portal V13 inclusive, una constante sin tipo (p. ej., 1.0) podía convertirse de manera implícita al tipo de datos DWORD si el valor era menor que 32 bits.

Si en el TIA Portal V13 SP1 se quiere convertir implícitamente un número en coma flotante al tipo de datos DWORD, tan solo pueden utilizarse constantes con tipo (p. ej., REAL#1.0), ya que una constante sin tipo (p. ej., 1.0) se interpreta como tipo de datos LREAL y, por tanto, ya no puede convertirse implícitamente a DWORD.

Asignación de un valor a una constante LTIME (S7-1500)

A partir del TIA Portal V13 SP1, se aplica una regla de sintaxis más estricta para definir un valor para una constante LTIME:

Hasta la versión TIA Portal V13 inclusive, era posible asignar un valor TIME (p. ej. T#10s) a una constante LTIME.

Para asignar un valor a una constante LTIME en TIA Portal V13 SP1 es preciso utilizar una sintaxis LTIME (p. ej. LT#10s).

Tenga en cuenta que los proyectos de TIA Portal de versiones anteriores deben adaptarse antes de actualizar a la versión TIA Portal V13 SP1.

Indexación indirecta de componentes ARRAY del tipo de datos Secuencia de bits en SCL (S7-1200/S7-1500)

Dentro del TIA Portal V13, en SCL existe la posibilidad de indicar una variable del tipo de datos BYTE, WORD, DWORD o LWORD como índice además de una variable del tipo de datos Entero para el direccionamiento de los componentes de un ARRAY en una CPU de las series S7-1200/1500, siempre que la verificación CEI no esté ajustada. Eso no es posible en una CPU de las series S7-300/400.

Eso provoca una incompatibilidad con respecto al TIA Portal V12 SP1, ya que en él también está permitida la indexación indirecta con el tipo de datos Secuencia de bits en una CPU de las series S7-300/400.

Mecanismo EN/ENO en conversiones de STRING (S7-1200/S7-1500)

Conversión

Significado

Strg_TO_Chars: Convertir cadena de caracteres en Array of CHAR

La salida de habilitación ENO tiene el estado lógico "0" incluso si se ha desactivado:

  • cuando hay un carácter no válido en el parámetro CHARS

  • cuando hay un índice de ARRAY no válido en el parámetro PCHARS

  • si la suma de los parámetros PCHARS y STRG excede la longitud del ARRAY de destino.

Chars_TO_Strg: Convertir Array of CHAR en cadena de caracteres

La salida de habilitación ENO tiene el estado lógico "0" incluso si se ha desactivado:

  • si la suma de los parámetros PCHARS y CNT excede la longitud del ARRAY de origen.

Rebase por exceso de la pila de datos locales (S7-300/S7-400)

A partir del TIA Portal V13 SP1 se comprueba si se rebasa por exceso el tamaño de la pila de datos locales definida en la configuración hardware para las prioridades de OB.

Con ello, es posible que durante la compilación se reciban mensajes de error en proyectos que con V13 podían compilarse correctamente. En este caso, debe cambiarse el tamaño máximo de la pila de datos locales en la configuración hardware.


Inter Project Engineering (IPE)

Inter Project Engineering (IPE)

Este capítulo incluye información sobre los siguientes temas:
  • Indicaciones relativas a IPE


Indicaciones relativas a IPE

Contenido Utilizar el diagnóstico del sistema en el proxy de dispositivos Conexiones con el controlador por software SIMATIC S7-1500 Soporte de avisos Alarm_S Compatibilidad
Indicaciones relativas a IPE

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Utilizar el diagnóstico del sistema en el proxy de dispositivos

Para poder utilizar la función "Diagnóstico del sistema" en un proxy de dispositivos IPE, p. ej. un visor de diagnóstico del sistema, inserte los "Avisos PLC" como contenido de un proxy de dispositivos.

Conexiones con el controlador por software SIMATIC S7-1500

Las conexiones con el controlador por software SIMATIC S7-1500 como proxy de dispositivo únicamente son posibles a través de las interfaces asignadas al PLC de software.

Soporte de avisos Alarm_S

La funcionalidad Configuración integrada con WinCC y SIMATIC Manager soporta los avisos Alarm_S, a los que puede accederse mediante bloques de datos y Continuous Function Chart (CFC).

Compatibilidad

Con TIA Portal V15.1 se pueden abrir los archivos IPE de la misma versión y de versiones anteriores a partir de V13 SP1.

Los archivos IPE creados con TIA Portal versión V15.1 no pueden abrirse con versiones anteriores.