Funciones tecnológicas

Ejemplos Consulte también Historial Herramientas
Funciones tecnológicas

Este capítulo incluye información sobre los siguientes temas:
  • Notas sobre S7-1500 Motion Control (S7-1500, S7-1500T)
  • Notas sobre funciones tecnológicas adicionales (S7-1500)
  • Indicaciones sobre las funciones tecnológicas (S7-1200)
  • Indicaciones sobre las funciones tecnológicas (S7-300, S7-400)
  • SIMATIC STEP 7 Easy Motion Control
  • SIMATIC STEP 7 PID Professional


Notas sobre S7-1500 Motion Control (S7-1500, S7-1500T)

Ejemplos Consulte también Historial Herramientas
Alarmas tecnológicas 900-902 Convertir proyectos a la versión TIA Portal V16 Comportamiento del contador de ciclos de módulo en el referenciado con "MC_Home" Uso del tipo de datos "DX_TEL_SyncOp" con sincronismo de varios PLC Configuración manual de los tiempos de deceleración en el eje conductor y en el eje conducido virtual Cálculo del error de seguimiento Rendimiento de la transformación de usuario con adaptación dinámica (S7-1500) El ancho de banda de la CPU está limitado para los registros con el Trace de la cinemática (S7-1500T) Suavizar la transición entre movimientos de la trayectoria y movimientos "punto a punto" síncronos (movimientos sPTP) (S7-1500T) Modificación del multiplicador (override) en movimientos "punto a punto" síncronos (movimiento sPTP) (S7-1500T) Suavizar la transición en movimientos de la cinemática (S7-1500T) Uso de la instrucción "MC_TrackConveyorBelt" de Motion Control con la versión tecnológica V5.0 (S7-1500T)
Notas sobre S7-1500 Motion Control
S7-1500, S7-1500T

Alarmas tecnológicas 900-902

A diferencia del comportamiento descrito en la documentación, en las alarmas tecnológicas 900 y 901, como reacción a la alarma se detecta como no válido el valor conductor recibido. La alarma tecnológica 902 no contiene reacción.

Las alarmas tecnológicas 900 y 901 se indican en el búfer de diagnóstico.

N.º | Reacción | Bit de error | Bit de advertencia | Reinicio | Búfer de diagnóstico | Texto de alarma
900 | Ajustar valor conductor como no válido | X2 | - | - | X | Valores conductores no válidos.
901 | Ajustar valor conductor como no válido | X2 | - | - | X | Error de transferencia de datos.
902 | Ninguna reacción | - | X2 | - | - | Precisión limitada del valor conductor.

La alarma tecnológica 900 se puede confirmar con una orden "MC_Reset" con "Restart" = FALSE. No es necesario reiniciar.

La alarma tecnológica 900 se indica con el siguiente texto de alarma:

Texto de alarma | Solución
Valores conductores no válidos. | Ajuste un tiempo de tolerancia mayor (<TO>.Parameter.ToleranceTimeExternalLeadingValueInvalid). Compruebe la conexión de los componentes interconectados. Asegúrese de que no hay fallos de comunicación. Asegúrese de que las CPU implicadas se encuentran en estado operativo RUN.

La alarma tecnológica 901 se indica con el siguiente texto de alarma:

Texto de alarma |  | Solución
Error de transferencia de datos. |  |
 | Versión no válida | Compruebe la comunicación.
 | Valor inicial de módulo no válido
 | Longitud de módulo no válida
 | Error de señal de vida
 | Posición no válida | Compruebe el valor conductor del eje conductor de la otra CPU.
 | Velocidad no válida
 | Aceleración no válida

Convertir proyectos a la versión TIA Portal V16

Debido a los cambios del formato de almacenamiento de proyectos en la versión TIA Portal V16 es necesario convertir los proyectos existentes. Dependiendo del tamaño del proyecto, la conversión puede requerir mucho tiempo. El tiempo total de conversión puede requerir entre varios minutos y hasta más de una hora.

Comportamiento del contador de ciclos de módulo en el referenciado con "MC_Home"

A diferencia del comportamiento descrito en la documentación, el contador de ciclos de módulo se comporta en el referenciado relativo directo con "Mode" = 1, 12 y en el reajuste del encóder absoluto (relativo) con "Mode" = 6 como en el referenciado absoluto directo "Mode" = 0. Los valores del contador de ciclos de módulo cambian en el referenciado y en el reajuste del encóder absoluto con los modos mencionados como se indica a continuación:

Acción | Descripción
Reajuste del encóder absoluto con "Mode" = 6 | Como valor de módulo se calcula la distancia más corta entre la posición actual y la nueva. En función de la distancia, el contador de ciclos de módulo puede permanecer tal cual, aumentar en 1 o disminuir en 1.
Referenciado directo relativo con "Mode" = 1, 12 | Como valor de módulo se calcula la distancia más corta entre la posición actual y la nueva. En función de la distancia, el contador de ciclos de módulo puede permanecer tal cual, aumentar en 1 o disminuir en 1.

Uso del tipo de datos "DX_TEL_SyncOp" con sincronismo de varios PLC

Para el sincronismo de varios PLC se crean variables Output e Input con el tipo de datos "DX_TEL_SyncOp" en las direcciones iniciales del área de transferencia. Si no se puede asignar el tipo de datos "DX_TEL_SyncOp", significa que se borró durante la última compilación.

Los tipos de datos no utilizados se borran durante la compilación. Para restablecer el tipo de datos "DX_TEL_SyncOp", agregue un TO V5.0. Después de utilizar el tipo de datos en la variable PLC puede borrarse el objeto tecnológico.

Configuración manual de los tiempos de deceleración en el eje conductor y en el eje conducido virtual

Si se aumenta el tiempo de deceleración del eje conductor en la configuración del eje conductor, se reducirá el tiempo de extrapolación en el sustituto del eje conductor o aumentará el tiempo de interpolación del valor conductor distribuido en el sustituto del eje conductor. El error que se produce en la extrapolación en las fases de aceleración y deceleración del valor conductor se reduce en consecuencia.

Si aumenta el tiempo de deceleración en el sustituto del eje conductor, aumentará el tiempo de extrapolación o se reducirá el tiempo de interpolación.

Cálculo del error de seguimiento

El error de seguimiento es la diferencia entre la consigna de posición y la posición real referida a la conexión del eje en el accionamiento. A diferencia del comportamiento descrito en la documentación, los tiempos de transferencia de la consigna desde el controlador hasta el accionamiento y del valor real de posición desde el accionamiento al controlador no forman parte del error de seguimiento. Por consiguiente, el valor del error de seguimiento no es igual a la diferencia de la consigna de posición del controlador menos la posición real existente.

Rendimiento de la transformación de usuario con adaptación dinámica (S7-1500)

Con la versión tecnológica V5.0 se alargan los tiempos de ejecución del MC-Interpolator [OB92] en la transformación de usuario. Los tiempos de ejecución más largos del MC-Interpolator [OB92] alargan a su vez los tiempos de ejecución de los bloques de organización de menor prioridad.

El ancho de banda de la CPU está limitado para los registros con el Trace de la cinemática (S7-1500T)

Cuando se excede el ancho de banda máximo no pueden registrarse ni evaluarse todas las señales de un registro con el Trace de la cinemática.

Tenga en cuenta los límites del sistema de la CPU (máx. 16 señales).

Para los distintos objetos se requieren las siguientes señales:

Objeto | Señales utilizadas
TCP y cinemática (depende de la cinemática) | 4-8
TCP (depende de la cinemática) | 2-4
OCS 1 (depende de la cinemática) | 2-6
OCS 2 (depende de la cinemática) | 2-6
OCS 3 (depende de la cinemática) | 2-6

Desactive las señales activas en "Objeto tecnológico > Trace de la cinemática > Configuración > Registros".

Suavizar la transición entre movimientos de la trayectoria y movimientos "punto a punto" síncronos (movimientos sPTP) (S7-1500T)

Si suaviza la transición de un movimiento de la trayectoria a un movimiento sPTP, puede suceder que no se suavice la transición o que el segmento correspondiente se reduzca notablemente.

Si suaviza la transición de movimientos de trayectoria y movimientos sPTP, ajuste una dinámica de la trayectoria lo más elevada posible:

  • Tirón

  • Aceleración

Modificación del multiplicador (override) en movimientos "punto a punto" síncronos (movimiento sPTP) (S7-1500T)

En caso de modificar el multiplicador (override) puede verse alterado el desarrollo del movimiento del punto de operación de la herramienta (TCP) de un movimiento sPTP.

Si debe conservarse el contorno del movimiento del TCP, desplace la cinemática cambiando mínimamente el multiplicador.

Suavizar la transición en movimientos de la cinemática (S7-1500T)

Al suavizar la transición puede aumentar excesivamente la dinámica en los ejes de la cinemática.

Uso de la instrucción "MC_TrackConveyorBelt" de Motion Control con la versión tecnológica V5.0 (S7-1500T)

La instrucción "MC_TrackConveyorBelt" de Motion Control no se puede utilizar con la versión tecnológica V5.0.


Notas sobre funciones tecnológicas adicionales (S7-1500)

Ejemplos Consulte también Historial Herramientas
Parámetros de los objetos tecnológicos de TIA Portal Openness S_USSI a S7‑1500 Módulos PaP con CM 1243-5 maestro PROFIBUS PID_Temp en la CPU 1500 V1.7
Notas sobre funciones tecnológicas adicionales
S7-1500

Parámetros de los objetos tecnológicos de TIA Portal Openness

Encontrará una lista de los parámetros de los objetos tecnológicos disponibles en la información del producto "Parámetros de los objetos tecnológicos de TIA Portal Openness" en Internet.

S_USSI a S7‑1500

Tenga en cuenta lo siguiente si utiliza la instrucción S_USSI de la periferia descentralizada ET 200S 1SI en un S7‑1500.

El parámetro ANZ indica el valor 0 también en caso de error.

Si la CPU es conmutada a STOP por la instrucción S_USSI, compruebe todos los errores posibles listados en el parámetro ANZ.

Módulos PaP con CM 1243-5 maestro PROFIBUS

Si se utilizan los módulos PaP CM PtP RS232 BA, CM PtP RS422/485 BA, CM PtP RS232 HF, CM PtP RS422/485 HF y CM PtP con un CM 1243-5 maestro PROFIBUS y un firmware ≤ V1.3.4, deberán realizarse los siguientes ajustes en el DB de instancia de las instrucciones:

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240

PID_Temp en la CPU 1500 V1.7

Si utiliza PID_Temp en una CPU 1500 con la versión de firmware V1.7, tenga en cuenta lo siguiente:

  • La zona muerta integrada en PID_Temp no debe emplearse en la CPU 1500 V1.7.

    No modifique el ajuste predeterminado 0.0 de los parámetros Retain.CtrlParams.Heat.DeadZone y Retain.CtrlParams.Cool.DeadZone correspondientes.

  • Si en un regulador con refrigeración activada y conmutación de parámetros PID (Config.ActivateCooling = TRUE, Config.AdvancedCooling = TRUE) está activada la salida de refrigeración (PidOutputSum < 0.0, OutputCool <> 0.0) mientras se inicia una "optimización inicial para refrigeración" (Mode = 1, Heat.EnableTuning = FALSE, Cool.EnableTuning = TRUE), esta se interrumpe con el error ErrorBits = 16#0040_0000.

    • En ese caso, utilice la "optimización fina para refrigeración" (Mode = 2, Heat.EnableTuning = FALSE, Cool.EnableTuning = TRUE)

    o bien

    • antes de iniciar la optimización inicial, cambie al modo manual con un valor manual superior a 0.0 (Mode = 4, ManualValue ≥ 0.0).

Ambas restricciones desaparecen a partir de la versión de firmware V1.8.


Indicaciones sobre las funciones tecnológicas (S7-1200)

Ejemplos Consulte también Historial Herramientas
Aplicar automáticamente los valores del accionamiento o del encóder durante la configuración (offline) ErrorID 16#820D Módulos PaP con CM 1243-5 maestro PROFIBUS
Indicaciones sobre las funciones tecnológicas
S7-1200

Aplicar automáticamente los valores del accionamiento o del encóder durante la configuración (offline)

Al integrar un SINAMICS V90 PROFINET utilizando un HSP no se aplican automáticamente todos los parámetros de configuración. Desactive la opción "Aplicar automáticamente los valores del accionamiento durante la configuración (offline)" y aplique manualmente los parámetros de configuración del accionamiento y del encóder en la configuración del objeto tecnológico.

ErrorID 16#820D

ErrorID | ErrorInfo | Descripción | Solución
16#820D |  | El TO está reiniciando
 | 16#0001 | - | Confirmar error con la instrucción "MC_Reset" y reiniciar la orden, si es necesario

Módulos PaP con CM 1243-5 maestro PROFIBUS

Si se utilizan los módulos PtP CM PtP RS232 BA, CM PtP RS422/485 BA, CM PtP RS232 HF, CM PtP RS422/485 HF y CM PtP con un CM 1243-5 maestro PROFIBUS y un firmware ≤ V1.3.4, deberán realizarse los siguientes ajustes en el DB de instancia de las instrucciones:

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240


Indicaciones sobre las funciones tecnológicas (S7-300, S7-400)

Ejemplos Consulte también Historial Herramientas
Parámetrización FM x51 y FM x52 Programación FM x50-1, FM x51 y FM x52 Migración IM 174
Indicaciones sobre las funciones tecnológicas
S7-300, S7-400

Parámetrización FM x51 y FM x52

Contrariamente a lo indicado en la ayuda en pantalla, en caso de modificar el sistema de medida los valores ya introducidos de los parámetros no se convierten al nuevo sistema de medida.

Programación FM x50-1, FM x51 y FM x52

Los "valores iniciales" contenidos en las tablas de parámetros que figuran en la ayuda en pantalla de las instrucciones equivalen al "valor predeterminado" que se indica en la interfaz del programa de usuario.

Migración IM 174

Al migrar proyectos con IM 174, la parametrización del IM 174 se ajusta a los valores predeterminados. El IM 174 debe reparametrizarse en cualquier caso después de la migración.