WinCC

Ejemplos Consulte también Historial Herramientas
WinCC

Este capítulo incluye información sobre los siguientes temas:
  • Indicaciones de seguridad
  • Protección de datos
  • Indicaciones de uso
  • Migración
  • Engineering System
  • Funciones generales
  • Compilar y cargar
  • Runtime
  • Paneles de operador
  • Opciones


Indicaciones de seguridad

Información de seguridad Contraseñas Servidor web integrado Comunicación vía Ethernet Uso de SSL 3.0 Ajustes de red
Indicaciones de seguridad

Información de seguridad

Siemens suministra productos y soluciones con funciones de seguridad industrial con el objetivo de hacer más seguro el funcionamiento de instalaciones, sistemas, máquinas y redes.

Para proteger las instalaciones, los sistemas, las máquinas y las redes de amenazas cibernéticas, es necesario implementar (y mantener continuamente) un concepto de seguridad industrial integral que sea conforme a la tecnología más avanzada. Los productos y las soluciones de Siemens constituyen únicamente una parte de este concepto.

El cliente es responsable de impedir el acceso no autorizado a sus instalaciones, sistemas, máquinas y redes. Los sistemas, las máquinas y los componentes solo deben estar conectados a la red corporativa o a Internet cuando y en la medida que sea necesario y siempre que se hayan tomado las medidas de protección adecuadas (p. ej., uso de cortafuegos y segmentación de la red).

Adicionalmente, deberán observarse las recomendaciones de Siemens en cuanto a las medidas de protección correspondientes. Encontrará más información sobre seguridad industrial en

http://www.siemens.com/industrialsecurity

Los productos y las soluciones de Siemens están sometidos a un desarrollo constante con el fin de mejorar todavía más su seguridad. Siemens recomienda expresamente realizar actualizaciones en cuanto estén disponibles y utilizar únicamente las últimas versiones de los productos. El uso de versiones anteriores o que ya no se soportan puede aumentar el riesgo de amenazas cibernéticas.

Para mantenerse informado de las actualizaciones de productos, recomendamos que se suscriba al Siemens Industrial Security RSS Feed en:

http://www.siemens.com/industrialsecurity

Contraseñas

En WinCC hay preajustadas varias contraseñas. Por motivos de seguridad es necesario cambiar estas contraseñas.

  • En los paneles de operador de la versión 12 está preajustada la clave "100" para el Sm@rtServer y el servidor web integrado. En los paneles de operador de la versión 13 o superior no hay ninguna contraseña preajustada.

  • Para el usuario "Administrador" está preajustada la contraseña "administrator".

Servidor web integrado

Desde un PC se puede acceder en runtime a las páginas HTML, aunque esté desactivada la opción "Páginas HTML". Durante la instalación se depositan en el PC siempre las páginas estándar del servidor web. Asigne una contraseña de administrador que impida el acceso no autorizado a las páginas.

Comunicación vía Ethernet

En la comunicación basada en Ethernet, el usuario final es el responsable de la seguridad de su red de datos, ya que en intrusiones selectivas que provocan una sobrecarga del equipo, no está garantizado el funcionamiento correcto de éste.

Uso de SSL 3.0

Por motivos de seguridad no se recomienda el uso del protocolo SSL 3.0 en Comfort Panels ni en Runtime Advanced. En Comfort Panels, el uso del protocolo SSL 3.0 está desactivado por defecto. Si a pesar de todo quisiera activar el uso de SSL 3.0, en Internet Explorer o en "Start Center > Settings" seleccione "Internet Options > Advanced > Use SSL 3.0".

Para RT Advanced, el uso de SSL 3.0 se desactiva en Internet Explorer o mediante el panel de control, en "Opciones de Internet > Opciones avanzadas" desactivando la opción "Usar SSL 3.0".

Ajustes de red

Las tablas siguientes muestran los ajustes de red de cada producto, necesarios para analizar la seguridad de la red y la configuración de cortafuegos externos:

WinCC Professional (sin simulación)
Nombre | Número de puerto | Protocolo de transporte | Dirección | Función | Descripción
ALM | 4410* | TCP | Inbound, Outbound | Servicio de licencias | Este servicio pone a disposición todas las funciones para licencias de software, y se utiliza tanto en el Automation License Manager como en todos los productos de software sujetos a licencias.
HMI Load | 1033 | TCP | Outbound | HMI Load (RT Basic) | Este servicio se utiliza para transferir imágenes y datos de configuración a Basic Panels.
HMI Load | 2308 | TCP | Outbound | HMI Load (RT Advanced) | Este servicio se utiliza para transferir imágenes y datos de configuración a paneles.
RPC | ** | UDP | Inbound, Outbound | Comunicación cliente/servidor & ES (CCAgent) | Este servicio es utilizado por WinCC Professional y WinCC Runtime Professional.
* Puerto estándar, que el usuario puede cambiar mediante configuración ** El puerto se asigna automáticamente

WinCC Simulation para Basic Panels
Nombre | Número de puerto | Protocolo de transporte | Dirección | Función | Descripción
HMI Load | 1033 | TCP | Inbound | HMI Load (RT Basic) | Este servicio se utiliza para transferir imágenes y datos de configuración a Basic Panels.
EtherNet/IP | 44818 | TCP | Outbound | Ethernet/canal IP | El protocolo Ethernet/IP se utiliza para conexiones con todos los PLC Allen Bradley.
 | 2222 | UDP | Inbound | Ethernet/canal IP | El protocolo Ethernet/IP se utiliza para conexiones con todos los PLC Allen Bradley.
Modbus TCP | 502 | TCP | Outbound | Canal Modbus TCP | El protocolo Modbus TCP se utiliza para conexiones con PLC Schneider.
RFC 1006 | 102 | TCP | Outbound | Canal S7 | Comunicación con el controlador S7 vía Ethernet/PROFINET
Mitsubishi MC | 5002 | TCP | Outbound | Canal Mitsubishi MC | El protocolo Mitsubishi se utiliza para conexiones con PLC Mitsubishi.

WinCC Simulation para Panels y Runtime Advanced
Nombre | Número de puerto | Protocolo de transporte | Dirección | Función | Descripción
DCP | --- | Ethernet | Outbound | PROFINET | El protocolo DCP (Discovery and basic Configuration Protocol) se utiliza en PROFINET y es la función básica para la localización y configuración de dispositivos PROFINET.
LLDP | --- | Ethernet | Inbound, Outbound | PROFINET | El protocolo LLDP (Link Layer Discover Protocol) es utilizado por PROFINET para el descubrimiento de topología.
SMTP | 25 | TCP | Outbound | Comunicación SMTP | Este servicio es utilizado por WinCC Runtime Advanced para enviar correos electrónicos.
HTTP | 80* | TCP | Inbound | HTTP Channel Server HTML pages | El servidor web solo está disponible si se activa HTTP Channel Server o HTML pages. El puerto utilizado puede distinguirse por los ajustes automáticamente seleccionados.
RFC 1006 | 102 | TCP | Outbound | Canal S7 | Comunicación con el controlador S7 vía Ethernet/PROFINET
NTP | 123 | UDP | Outbound | Sincronización horaria | El protocolo NTP (Network Time Protocol) se utiliza en redes basadas en IP para la sincronización horaria.
SNMP | 161 | UDP | Outbound | PROFINET | STEP 7 utiliza la funcionalidad de cliente SNMP para leer información de estado de dispositivos PROFINET.
HMI Load | 2308 | TCP | Outbound | HMI Load (RT Advanced) | Este servicio se utiliza para transferir imágenes y datos de configuración a paneles.
HTTPS | 443* | TCP | Inbound | HTTP Channel Server HTML pages | El servidor web con protocolo HTTPS solo está disponible si se activa HTTP Channel Server o HTML pages. El puerto utilizado puede distinguirse por los ajustes automáticamente seleccionados.
Servidor VNC | 5900* | TCP | Inbound | Sm@rtServer | Este servicio solo está disponible cuando se activa Sm@rtService.
 | 5800* | TCP | Inbound | Sm@rtServer | Este servicio solo está disponible cuando se activa Sm@rtService.
Cliente VNC | 5500 | TCP | Outbound | Sm@rtServer | Este servicio solo está disponible cuando se activa Sm@rtService.
* Puerto estándar, que el usuario puede cambiar mediante configuración

WinCC Simulation para Runtime Professional
Nombre | Número de puerto | Protocolo de transporte | Dirección | Función | Descripción
RPC | ** | UDP | Inbound, Outbound | Comunicación cliente/servidor & ES (CCAgent) | Este servicio es utilizado por WinCC Professional y WinCC RT Professional.
RPC | ** | UDP | Inbound, Outbound | Comunicación cliente/servidor (CCEServer / CCEClient) | Este servicio es utilizado por WinCC Runtime Professional.
HTTP | 80 | TCP | Inbound, Outbound | Comunicación cliente/servidor (CCEServer / CCEClient) | Este servicio es utilizado por WinCC Runtime Professional.
RFC 1006 | 102 | TCP | Outbound | Canal S7 | Comunicación con el controlador S7 vía Ethernet/PROFINET
OPC UA | 4840 | TCP | Inbound | OPC UA Server | Este servicio se necesita para la comunicación primaria vía OPC UA. Se activa y configura durante la instalación.
OPC UA discovery | 52601 | TCP | Inbound | OPC UA Server | Este servicio proporciona información sobre servidores OPC instalados. Se instala y configura mediante el servidor OPC UA.
DCOM | 135 | TCP | Inbound | OPC Server | Este servicio forma parte del sistema operativo Windows. Dado que la comunicación vía OPC (DA) está basada en DCOM, este servicio se necesita para inicializar conexiones OPC (DA).
DCOM | ** | TCP | Inbound | OPC Server | La comunicación vía OPC (DA) está basada en DCOM y utiliza puertos no especificados y asignados por el sistema. Esto deberá tenerse en cuenta al utilizar OPC (DA) y al crear reglas para el cortafuegos.
HTTP | 80 | TCP | Inbound | OPC Server | Este servicio se necesita para la comunicación primaria vía OPC XML. Se activa y configura durante la instalación.
NetBIOS | 137 | UDP | Inbound | OPC Server | Este servicio forma parte del sistema operativo Windows. El acceso a este servicio se necesita, p. ej., para que OPC-Scout pueda navegar.
NetBIOS | 138 | UDP | Inbound | OPC Server | Este servicio forma parte del sistema operativo Windows. El acceso a este servicio se necesita, p. ej., para que OPC-Scout pueda navegar.
SNMP | 161 | UDP | Outbound | SNMP OPC Server | El servidor SNMP OPC utiliza este servicio para modificar o consultar datos en unidades de red y demás.
SNMP Traps | 162 | UDP | Inbound | SNMP OPC Server | El servidor SNMP OPC utiliza este servicio para consultar eventos de unidades de red y demás.
** El puerto se asigna automáticamente

Protocolos PROFINET para Panels y Runtime Advanced
Nombre | Número de puerto | Protocolo de transporte | Dirección | Función | Descripción
DCP | --- | Ethernet | Outbound | LifeList, PROFINET Discovery and configuration | El protocolo DCP (Discovery and basic Configuration Protocol) se utiliza en PROFINET y es la función básica para la localización y configuración de dispositivos PROFINET.
LLDP | --- | Ethernet | Inbound, Outbound | PROFINET Link Layer Discovery protocol | El protocolo LLDP (Link Layer Discover Protocol) es utilizado por PROFINET para el descubrimiento de topología.
MRP | --- | Ethernet | Outbound | PROFINET medium redundancy | El protocolo MRP (Medium Redundancy Protocol) permite el control de vías de transmisión redundantes mediante una topología en anillo.
PROFINET IO Data | --- | Ethernet | Inbound, Outbound | PROFINET Cyclic IO data transfer | Los Panels utilizan el intercambio cíclico de datos para teclas directas y LED.
ARP | --- | Ethernet | Inbound, Outbound | Name Addres Resolution | Este protocolo se utiliza para resolver nombres de red y asignar direcciones IP.
PROFINET Context Manager | 34964 | UDP | Inbound, Outbound | PROFINET connection less RPC | El PROFINET Context Manager ofrece un mapeador de extremos (puntos finales) para establecer una relación de aplicación (PROFINET AR).

Enlaces de comunicación para Panels y WinCC Runtime Advanced
Nombre | Número de puerto | Protocolo de transporte | Dirección | Función | Descripción
Telnet | 23 | TCP | Inbound | Telnet | Este servicio puede utilizarse para mantenimiento.
SMTP | 25 | TCP | Outbound | SendEMail | Este servicio es utilizado por Windows CE / PC Runtime para enviar correos electrónicos.
HTTP | 80* | TCP | Inbound | Hypertext Transfer Protocol | El protocolo HTTP se utiliza para la comunicación con el servidor web del HMI.
RFC 1006 | 102 | TCP | Outbound | Canal S7 | Comunicación con el controlador S7 vía Ethernet/PROFINET.
NTP | 123 | UDP | Outbound | Sincronización horaria | El protocolo NTP (Network Time Protocol) se utiliza en redes basadas en IP para la sincronización horaria.
DCOM*** | 135 | TCP | Inbound | OPC Server | Este servicio forma parte del sistema operativo Microsoft Windows. La comunicación vía OPC (DA) está basada en DCOM. Por ello se necesita este servicio para inicializar conexiones OPC (DA).
DCOM*** | ** | TCP | Inbound | OPC Server | La comunicación vía OPC (DA) está basada en DCOM y utiliza puertos no especificados y asignados por el sistema. Esto deberá tenerse en cuenta al utilizar OPC (DA) y al crear reglas para el firewall.
NetBIOS over TCP/IP | 137 | UDP | Outbound | Usando Remote File Share | Inicio de sesión en un servidor remoto.
NetBIOS over TCP/IP | 138 | UDP | Outbound | Usando Remote File Share | Inicio de sesión en un servidor remoto.
SNMP | 161 | UDP | Outbound | Simple Network Management Protocol | STEP 7 utiliza la funcionalidad de cliente SNMP para leer información de estado de dispositivos PROFINET.
HTTPS | 443* | TCP | Inbound | Secure Hypertext Transfer Protocol | El protocolo HTTP se utiliza para la comunicación con el servidor web del HMI vía Secure Socket Layer (SSL).
Modbus TCP | 502* | TCP | Outbound | Canal Modbus TCP | El protocolo Modbus TCP se utiliza para conexiones con PLC Schneider.
Mitsubishi MC | 1025* | TCP | Outbound | Canal Mitsubishi MC | El protocolo Mitsubishi se utiliza para conexiones con PLC Mitsubishi.
Printing | 1032 | TCP | Outbound | Printing | Impresión en el panel de mando (vía Ethernet).
HMI Load | 2308 | TCP | Outbound | Transfer | Este servicio se utiliza para transferir imágenes y datos de configuración a paneles. En los Comfort Panels a partir de la versión 13, este servicio se sustituye por el DeviceManager y SCS. Este servicio se utiliza para transferir datos de configuración a WinCC Runtime Advanced.
HMI Load | 50523 | TCP | Outbound | Transfer | Este puerto se utiliza cuando no está disponible el puerto 2308. Este servicio se utiliza para transferir imágenes y datos de configuración a paneles. En los Comfort Panels a partir de la versión 13, este servicio se sustituye por el DeviceManager y SCS. Este servicio se utiliza para transferir datos de configuración a WinCC Runtime Advanced.
ALM | 4410* | TCP | Inbound, Outbound | Application License Manager | Este servicio de RT Advanced pone a disposición todas las funciones para licencias de software y se utiliza en el Automation License Manager.
OPC UA | 4870* | TCP | Inbound | OPC UA Server | Este servicio se necesita para la comunicación vía OPC UA.
HMI Load | 5001 | TCP | Outbound | Device Manager | Este servicio se utiliza para transferir imágenes y Runtime a paneles.
HMI Load | 5002 | TCP | Outbound | SCS (System Configuration Server) | Este servicio se utiliza para transferir datos de configuración a paneles.
Cliente VNC | 5500 | TCP | Outbound | Sm@rtServer | Conexión cliente VNC
Servidor VNC | 5800* | TCP | Inbound | Sm@rtServer | Conexión HTTP servidor VNC
 | 5900* | TCP | Inbound | Sm@rtServer | Conexión servidor VNC
SIMATIC Logon | 16389* | TCP | Outbound | UMAC (User Management and Access Control) | Inicio de sesión en un servidor remoto.
Allen Bradley Ethernet/IP | 44818 | TCP | Outbound | Ethernet/canal IP | El protocolo Ethernet/IP se utiliza para conexiones con todos los PLC Allen Bradley.
Reserved | 49152 ... 65535 | TCP/UDP | Outbound |  | El rango de puertos dinámico se utiliza p. ej. para la conexión al Remote File Sharing.
* Puerto estándar, que el usuario puede cambiar mediante configuración ** El puerto se asigna automáticamente. *** Soportado solo por WinCC Runtime Advanced.


Protección de datos

Protección de datos

Siemens observa los principios de la protección de datos, especialmente los preceptos de la minimización de datos (privacy by design). Para el presente producto SIMATIC, esto significa que el producto no procesa ni guarda datos personales, simplemente datos técnicos sobre las funciones (p. ej. sello de tiempo). Si el usuario vincula estos datos con otros (p. ej. horarios de turnos) o guarda datos personales en el mismo soporte (p. ej. disco duro) y establece con ello una referencia personal, debe garantizar por cuenta propia las especificaciones legales sobre la protección de datos.


Indicaciones de uso

Contenido Cambio de comportamiento tras la actualización Ruta de instalación Trabajar con derechos de usuario estándar Teclado de pantalla (RT Advanced) Cambio de dispositivo - Juegos de caracteres (RT Professional) Textos de la simulación (RT Professional) Carga de modificaciones online con ciclos personalizados (RT Professional) Transferencia de licencia mediante S7USB Transferencia de licencias en un panel con sistemas operativos de 64 bits Juegos de caracteres PostScript Tareas con disparador de variable
Indicaciones de uso

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Cambio de comportamiento tras la actualización

La nueva versión de WinCC contiene nuevas funciones y mejoras frente a la versión anterior. Esto puede dar lugar a que las denominaciones o el comportamiento de propiedades y funciones presenten pequeñas diferencias tras la actualización a la nueva versión. También las propiedades estándar de los objetos nuevos que se hayan creado pueden haber cambiado con respecto a las versiones anteriores.

Estos cambios de comportamiento pueden dar lugar a errores al compilar el proyecto.

Ruta de instalación

Si había instalado la simulación en una versión anterior, no podrá cambiar la ruta de instalación durante la instalación.

Trabajar con derechos de usuario estándar

Para trabajar con derechos de usuario estándar en Windows 7, el "control de cuentas de usuario" (UAC) no debe estar desactivado.

El "control de cuentas de usuario" está activado de forma estándar en Windows 7.

Encontrará más información sobre el "control de cuentas de usuario" en la Ayuda en pantalla de Windows 7.

Teclado de pantalla (RT Advanced)

Una vez abierto el TIA Portal ya no es posible acceder al teclado de pantalla.

Para acceder al teclado de pantalla en Windows, elija: "Inicio > Todos los programas > Accesorios > Accesibilidad > Teclado en pantalla".

Cambio de dispositivo - Juegos de caracteres (RT Professional)

Si se han configurado distintos juegos de caracteres en los diferentes idiomas del proyecto en los objetos de imagen para textos multilingües, se deben comprobar las imágenes tras cambiar de un panel a un runtime basado en PC. Puede ocurrir que los juegos de caracteres configurados se hayan modificado al cambiar de dispositivo.

Textos de la simulación (RT Professional)

Si en la simulación se utiliza un idioma runtime que no se corresponde con uno de los idiomas de producto instalados, los textos del sistema se mostrarán en uno de los idiomas de producto instalados. Dependiendo del sistema operativo y de los idiomas de producto instalados, se trata de inglés o chino.

Si en la simulación desea ver todos los textos en japonés, coreano o taiwanés, primero debería instalar WinCC sin simulación. Seguidamente deberá instalar WinCC Runtime Professional con los idiomas requeridos.

Carga de modificaciones online con ciclos personalizados (RT Professional)

Si ha reconfigurado ciclos propios en el editor "Ciclos", al cargar el proyecto seleccione el comando "Cargar > Software (compilar todo)". No es posible una carga de modificaciones online.

Transferencia de licencia mediante S7USB

La transferencia de licencia a un panel mediante S7USB solo es posible desde WinCC.

Transferencia de licencias en un panel con sistemas operativos de 64 bits

Si en un sistema operativo de 64 bits no está disponible el comando de menú "Edición > Conectar sistema de destino > Conectar panel de operador" en el Automation License Manager, abra la línea de comando y ejecute el comando siguiente con derechos de administrador:

"%WINDIR%\system32\RegSvr32.exe" "%CommonProgramFiles%\siemens\AlmPanelPlugin\ALMPanelParam.dll"

Juegos de caracteres PostScript

En el TIA Portal solo pueden utilizarse fuentes que contengan únicamente datos TrueType. Las fuentes PostScript y Open Type que contienen datos PostScript no se soportan.

Tareas con disparador de variable

Una tarea con disparador de variable se ejecuta cuando se escribe el valor de la variable interna, incluso en el caso en que el valor de la variable interna no cambie.


Migración

Contenido Migración de un proyecto creado con WinCC V7 Migración de un proyecto integrado con objetos ProTool Indicador de progreso
Migración

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Migración de un proyecto creado con WinCC V7

Para poder migrar un proyecto, es necesario que el proyecto se haya editado por lo menos con WinCC V7 Update 3.

Migración de un proyecto integrado con objetos ProTool

Si se migra un proyecto de WinCC flexible integrado en STEP 7 y aparece el mensaje de error "Faltan paquetes opcionales PROTOOL en STEP 7", significa que tiene instalado WinCC flexible 2008 SP3 o posterior. Además, el proyecto aún contiene objetos que se han configurado con ProTool. No abra el proyecto con WinCC flexible. Para migrar el proyecto, proceda del siguiente modo:

  1. Abra el proyecto en el SIMATIC Manager.

  2. Ejecute el comando "Guardar como" del menú "Archivo".

  3. Active la opción "Con reorganización" en el cuadro de diálogo "Guardar proyecto como".

  4. Haga clic en Aceptar.

  5. Copie el proyecto nuevamente en el equipo de origen.

  6. Reinicie la migración.

Indicador de progreso

Cuando el indicador de progreso muestra 100%, el software todavía tiene que realizar algunos trabajos residuales, como cerrar referencias, por ejemplo. Durante este tiempo, el software no reaccionará a entradas en la interfaz de usuario.


Engineering System

Engineering System

Este capítulo incluye información sobre los siguientes temas:
  • Imágenes y objetos de imagen
  • Variables y conexiones
  • Sistema de avisos y visor de avisos
  • Funciones de sistema y scripts
  • Informes
  • Recetas
  • Administración de usuarios
  • Comunicación


Imágenes y objetos de imagen

Contenido Objetos de visualización tras cambiar de panel de operador Agrupación de objetos de imagen Muchos objetos de imagen visualmente diferentes Dinamización de objetos agrupados (RT Professional) Dinamización de faceplates (RT Professional) Número de caracteres en campos de texto, listas y textos de aviso Transparencias en WinCC V13 y superior Visualización de páginas web de SIMOTION PLC en el navegador HTML Diferencias visuales entre la configuración y la visualización en el panel de operador Vista general de GRAPH (RT Professional) Actualizar faceplates con los UDT del tipo "Temporizador CEI" Controles superpuestos con animaciones de visibilidad Visor de diagnóstico del sistema Protección de acceso "Acceso HMI" Fuentes en el título de objetos de ventana (Panels, Runtime Advanced) Tipos de gráficos no válidos en las listas de gráficos después de una actualización (Runtime Professional) Gráficos multilingües en faceplates Modificaciones de segmentos en el visor de código PLC (RT Professional) Controles propios Tipos de datos soportados para animaciones
Imágenes y objetos de imagen

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Objetos de visualización tras cambiar de panel de operador

Tras actualizar un equipo con una nueva versión de panel de operador, se recomienda comprobar las imágenes contenidas en el proyecto. A causa del nuevo aspecto y de las funciones de manejo mejoradas puede ocurrir, p. ej., que en los campos E/S simbólicos el texto aparezca recortado u oculto por elementos de manejo.

Agrupación de objetos de imagen

Si se agrupan objetos de imagen en WinCC, pueden surgir problemas de rendimiento en WinCC si la profundidad de anidamiento es elevada.

Muchos objetos de imagen visualmente diferentes

El uso de objetos de imagen con muchas propiedades visualmente diferentes (p. ej., un gran número de estilos diferentes) puede reducir el rendimiento en runtime y aumentar el consumo de memoria. Evite, p. ej., la proliferación de redondeos de vértices distintos: 0 píxeles, 1 píxel, 2 píxeles, 3 píxeles, etc.

Dinamización de objetos agrupados (RT Professional)

En caso de existir agrupaciones anidadas a varios niveles (grupo en grupo, faceplate en grupo, grupo en faceplate, etc.), para la dinamización con funciones de sistema solo pueden utilizarse los eventos del último grupo exterior y de los últimos objetos interiores. Las funciones de sistema asociadas a eventos del grupo o del faceplate subordinado no se ejecutan.

La configuración de la animación de movimiento simultánea de un grupo de objetos y de objetos dentro de ese grupo puede ejecutarse en runtime de modo distinto al esperado. Compruebe el orden de ejecución en runtime y modifique la configuración si es necesario.

Dinamización de faceplates (RT Professional)

La dinamización de una instancia de faceplate con conexión al tipo de datos de usuario no está prevista, pero en determinados casos puede implementarse utilizando una variable auxiliar. Lea las indicaciones que figuran en la FAQ 109766634.

Número de caracteres en campos de texto, listas y textos de aviso

El número de caracteres disponibles en el texto de un objeto de imagen no es constante. Al introducir datos de texto se consideran las instrucciones de control y el formato, y el número máximo de caracteres se reduce en consecuencia.

Transparencias en WinCC V13 y superior

Los gráficos transparentes pueden visualizarse sin pérdidas en runtime. Esto es válido para todos los Comfort Panels y WinCC Runtime Advanced a partir de la versión 13.0.
Para usar la transparencia en un visor de gráficos o un campo E/S gráfico, la propiedad "Patrón de relleno" debe estar ajustada a "Transparente" y la propiedad "Utilizar color transparente" debe estar desactivada.

Visualización de páginas web de SIMOTION PLC en el navegador HTML

Si las páginas web de SIMOTION PLC no se muestran correctamente en el navegador HTML, añada ""/basic"" tras la URL del sitio web para que las páginas web se muestren en modo básico.

Diferencias visuales entre la configuración y la visualización en el panel de operador

La representación de un texto configurado en un objeto de imagen puede diferir en el panel de operador debido a la configuración de la pantalla. Si utiliza las opciones de ajuste automático del tamaño en la configuración, compruebe la visualización de los textos en el panel de operador en todos los idiomas.

Si los textos configurados con la opción "Adaptar objetos al contenido" no se pueden ver completos, se mostrarán más pequeños en el panel de operador. Si por este motivo los textos aparecen distorsionados, desactive la opción "Adaptar objetos al contenido" y amplíe el texto con espacios adicionales. Como alternativa puede ampliar el objeto a lo ancho o bien formularlo de forma abreviada.

Vista general de GRAPH (RT Professional)

Al actualizar a V14 se modifica la firma de la función C en el evento "Hacer clic". El parámetro propertyName que había en versiones anteriores desaparece. Las funciones que acceden a este parámetro se marcarán como erróneas después de la actualización.

Actualizar faceplates con los UDT del tipo "Temporizador CEI"

El elemento "ST" se ha eliminado automáticamente de los tipos de datos PLC definidos por el usuario (UDT) que utilizan el tipo de datos "Temporizador CEI". Adapte los faceplates que contengan estos UDT a una versión nueva del UDT sin elemento ST.

Encontrará una descripción detallada al respecto en la FAQ con el ID de artículo "109740393" en el SIMATIC Customer Online Support.

Controles superpuestos con animaciones de visibilidad

La configuración superpuesta de controles basados en tablas con animaciones de visibilidad puede dar origen a problemas en el manejo táctil en los dispositivos con sistema operativo Windows CE/Embedded Compact.

Visor de diagnóstico del sistema Protección de acceso "Acceso HMI"

En caso de emplear el nivel de protección "Acceso HMI" en combinación con el PLC SIMATIC S7-1200, sólo puede garantizarse una visualización correcta de los datos de diagnóstico a partir de la versión de firmware 4.1.

Fuentes en el título de objetos de ventana (Panels, Runtime Advanced)

La fuente establecida en la configuración de runtime del dispositivo no se emplea en los títulos de las ventanas de avisos, las ventanas de diagnóstico del sistema ni los cuadros de diálogo.

Tipos de gráficos no válidos en las listas de gráficos después de una actualización (Runtime Professional)

Si actualiza su proyecto a TIA Portal versión 16, los tipos de gráficos no válidos de la lista de gráficos causarán errores durante la compilación, que en la versión 14 se indicaban como advertencia.

Para evitar que aparezcan mensajes de error durante la compilación, puede ser necesario corregir el tipo de gráfico en la lista de gráficos.

Gráficos multilingües en faceplates

En un faceplate, inserte un gráfico en un objeto de imagen. Este gráfico se utilizará en todos los idiomas definidos para el proyecto.

Si abre el gráfico con el comando "Editar" del menú contextual y la opción "Editar gráfico de forma centralizada", después de editarlo y guardarlo en un editor externo, p. ej., MS Paint, el gráfico se modificará solamente para el idioma del proyecto actualmente definido. La modificación del gráfico correspondiente es visible en todos los objetos que utilizan dicho gráfico.

Modificaciones de segmentos en el visor de código PLC (RT Professional)

Cuando hay un aviso ProDiag pendiente se actualizan los cambios de segmentos en el visor de código PLC en runtime.

Para que las modificaciones de segmentos se puedan mostrar correctamente en el visor de código PLC en relación con los análisis de criterios, debe volver a dispararse el aviso.

Controles propios

Es posible que los "Controles propios" no se representen correctamente en el sistema de ingeniería. Sin embargo, no existe ninguna limitación para su configuración. Tampoco existen limitaciones para la representación y la operación en runtime. Si este control está basado en la tecnología OCX, se recomienda cambiar a .Net.

Tipos de datos soportados para animaciones

Como tipos de datos para animaciones de una imagen pueden utilizarse valores enteros y booleanos.


Variables y conexiones

Contenido Multiplexado de variables (Basic Panels) Variables con direccionamiento simbólico y tipo de datos "Char Array" (RT Professional) Indicación de longitud para variables del tipo "String" (RT Professional) Variable del tipo "String" para conexiones con controladores SIMOTION (Panels, RT Advanced) Variables de "Variable ID de la caja" (Mobile Panel) Elementos de matriz en WinCC Uso de tipos de datos de 64 bits Diagnóstico del sistema de PLC en el sistema R/H en funcionamiento no redundante
Variables y conexiones

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Multiplexado de variables (Basic Panels)

Si se multiplexa una variable con una variable externa en un Basic Panel, en el primer ciclo de lectura en runtime se leerá la dirección del PLC. El valor de la dirección leída tan solo estará disponible en el segundo ciclo de lectura.

Variables con direccionamiento simbólico y tipo de datos "Char Array" (RT Professional)

Las variables con direccionamiento simbólico y el tipo de datos "WString" no están autorizadas para la comunicación de RT Professional y SIMATIC S7-1200 V3.

Indicación de longitud para variables del tipo "String" (RT Professional)

En el editor "Variables", la indicación de longitud para variables HMI internas del tipo "String" no es efectiva. Si desea limitar la longitud de las variables, p. ej., para un campo de entrada o salida, hágalo utilizando VB Script o C Script.

Variable del tipo "String" para conexiones con controladores SIMOTION (Panels, RT Advanced)

Para controladores SIMOTION, la longitud de las variables String no debe superar los 210 caracteres.

En el sistema de ingeniería es posible crear una variable String con más de 210 caracteres. No obstante, la variable en cuestión no se escribe en Runtime. Aparece el mensaje advirtiendo de que el límite del valor se encuentra fuera de la variable.

En este caso, modifique la longitud de la variable String.

Variables de "Variable ID de la caja" (Mobile Panel)

La variable que se configura en "ID de la caja de variables", en "Configuración de runtime > General", solo puede utilizarse en modo de protección contra escritura.

En esta variable no está permitido escribir valores, aunque puede leerse en scripts o visualizarse en imágenes, por ejemplo.

Elementos de matriz en WinCC

Si ha conectado una variable HMI con una matriz de un bloque de datos de STEP 7 que no empieza con un límite inferior de 0, en WinCC se representan los elementos de matriz en el límite inferior de 0.

Para evitar tener que cambiar entre el índice STEP 7 y el índice WinCC al acceder a los distintos elementos de matriz, debe hacer que los límites inferiores de las matrices también empiecen en 0 en STEP 7.

Uso de tipos de datos de 64 bits

Si se usan tipos de datos de 64 bits, puede producirse una pequeña pérdida de exactitud, ya que estos tipos de datos se mapean como tipo de datos Double en el canal HMI. Esto puede ocasionar que tipos de datos enteros se muestren con decimales.

Diagnóstico del sistema de PLC en el sistema R/H en funcionamiento no redundante

En un sistema R/H hay configurados dos PLC y dos conexiones correspondientes. Si el sistema R/H no se encuentra en modo redundante, puede ocurrir que los visores del diagnóstico del sistema de ambas conexiones muestren diferentes símbolos de estado de diagnóstico para el mismo PLC.


Sistema de avisos y visor de avisos

Contenido Variables booleanas en ficheros de avisos Avisos de PLC Avisos de controlador en runtime (WinCC Professional) Copia de proyectos con conexiones integradas
Sistema de avisos y visor de avisos

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Variables booleanas en ficheros de avisos

Las variables de tipo Bool se reconocen en el fichero de avisos como 0 y -1. Si en un fichero de avisos se utiliza una lista de textos controlada por una variable de tipo Bool, complete la lista de textos correspondiente con la entrada del valor -1.

Avisos de PLC

Un aviso de PLC solo es visible en el editor "Avisos" de un dispositivo HMI si también existe un bloque de datos de instancia para ese FB.

Avisos de controlador en runtime (WinCC Professional)

Si actualiza un proyecto de las versiones V13 SP1 o V13 SP2 a las versiones V14, V14 SP1, V15, V15.1, V16, deberá compilar el proyecto y cargarlo en el controlador y en el panel de operador. De lo contrario, los avisos de controlador aparecerán tachados en el visor de avisos.

Copia de proyectos con conexiones integradas

Si copia los dispositivos con sus conexiones integradas (entre paneles de operador y controladores) desde un proyecto a una librería global y los pega desde allí en un nuevo proyecto, se puede perder la información relativa a los avisos del controlador en el panel de operador. Para evitar esta pérdida de información, copie primero todos los controladores y después todos los paneles de operador en el nuevo proyecto.


Funciones de sistema y scripts

Contenido Scripts en proyectos de servicio (RT Professional) Simulación con depurador de scripts Variables de disparo de funciones definidas por el usuario (RT Professional) Funciones definidas por el usuario en faceplates Funciones de sistema del procesamiento por bits (Mobile Panels y RT Advanced) Propiedades que ya no se utilizan (Comfort Panels y RT Advanced) Transferencia de parámetros a scripts en VB (Panels y RT Advanced) Transferencia de valores al visor de curvas mediante una función definida por el usuario Número máximo de parámetros (Panels y RT Advanced) Función de sistema "MostrarDiálogoInicioSesión" (Panels y RT Advanced)
Debug Err
Funciones de sistema y scripts

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Scripts en proyectos de servicio (RT Professional)

Puesto que en los proyectos de servicio no suele estar registrado ningún usuario interactivo, los C Script y VB Script pueden causar problemas, p. ej., en los siguientes casos:

  • Si los scripts requieren interacciones, p. ej., entradas.

  • Si los scripts muestran cuadros de aviso.

En el Service Mode no existe ningún área de datos compartida para C-Scripting. Por ello, no es posible intercambiar, p. ej., variables globales C entre el "Planificador de tareas" e "Imágenes".

Simulación con depurador de scripts

Para que TIA Portal pueda iniciar la "Simulación con depurador de scripts”, la clave del Registro
HKEY_CLASSES_ROOT\CLSID\{834128A2-51F4-11D0-8F20-00805F2CD064}\LocalServer32 deberá contener una entrada "(Standard)" de tipo "String" que contenga la ruta completa del depurador de scripts estándar "devenv.exe". Sin esta clave del Registro, el depurador no puede conectarse a la simulación que se esté ejecutando.

Variables de disparo de funciones definidas por el usuario (RT Professional)

Si ha configurado un tipo de datos de usuario HMI o PLC en una imagen, no puede utilizar los elementos del tipo de datos de usuario como variable de disparo en las funciones de usuario creadas posteriormente o modificadas.

Funciones definidas por el usuario en faceplates

Si desea acceder a variables en un faceplate con una función definida por el usuario, el nombre de las variables no puede componerse de forma dinámica.

Funciones de sistema del procesamiento por bits (Mobile Panels y RT Advanced)

No es posible manipular matrices de bits debido a eventos. Las funciones de sistema, como p. ej., InvertBit, SetBit, etc., no pueden contener elementos de una matriz de bit como argumento.

Propiedades que ya no se utilizan (Comfort Panels y RT Advanced)

En WinCC V13 se han incorporado muchas nuevas características visuales y se han armonizado otras muchas ya existentes.

Como consecuencia de la revisión de las propiedades de objetos, es posible que algunas de estas características, disponibles en scripts en VB de versiones anteriores de WinCC, no estén soportadas en WinCC V13. Los scripts que utilizan características ya no soportadas siguen siendo válidos, pero las llamadas en cuestión contenidas en los scripts carecen de efecto en runtime. Estas limitaciones afectan exclusivamente a los Comfort Panels y RT Advanced en la versión de panel V13.0.

La siguiente tabla muestra las características ya no utilizadas de los objetos de imagen:

Propiedad | Objeto de imagen
BorderBrightColor3D | Deslizador
BorderColor | Campo de texto, campo E/S, campo E/S simbólico, campo de fecha y hora
BorderInnerWidth3D | Deslizador
BorderOuterWidth3D | Deslizador
BorderShadeColor3D | Deslizador
BorderStyle3D | Campo de texto, campo E/S, botón, campo E/S simbólico, campo E/S gráfico, campo de fecha y hora, barra, interruptor
BorderWidth | Campo de texto, campo E/S simbólico
CenterColor | Indicador gauge
DialColor | Indicador gauge
EdgeStyle | Campo de texto, campo E/S

Transferencia de parámetros a scripts en VB (Panels y RT Advanced)

En WinCC se puede definir si se transfieren los parámetros de scripts en VB "ByRef" (dirección del parámetro) o "ByVal" (valor del parámetro).

La transferencia de la dirección del parámetro con "ByRef" (Call by Reference) solo es posible para las variables internas del script en VB. En el caso de las variables HMI, el valor del parámetro siempre se transfiere, independientemente de que el parámetro se haya definido como "ByRef" o como "ByVal".

Transferencia de valores al visor de curvas mediante una función definida por el usuario

Si lee valores de un fichero con una función de VBS para visualizarlos en un visor de curvas, debe prestar atención a que la diferencia entre los sellos de tiempo sea mayor que cero.

Número máximo de parámetros (Panels y RT Advanced)

El número máximo de parámetros de una función global es de 8 para el tipo "sub" y de 7 para el tipo "func".

Función de sistema "MostrarDiálogoInicioSesión" (Panels y RT Advanced)

En los Panel y Runtime Advanced no debe configurarse la función de sistema "MostrarDiálogoInicioSesión" en el evento "Cambio de valor" de una variable.


Informes

Contenido Imprimir informes (Panels)
Informes

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Imprimir informes (Panels)

Dependiendo de la impresora utilizada, los objetos posicionados en los márgenes del informe pueden quedar cortados al imprimirlos.

Asegúrese de que su informe tenga un tamaño adecuado.


Recetas

Contenido Sincronización de recetas (Basic Panels, Panels, Comfort Panels y RT Advanced)
Recetas

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Sincronización de recetas (Basic Panels, Panels, Comfort Panels y RT Advanced)

Al enviar valores de registros al controlador, los valores solo se validan si está activada la opción "Transmisión manual de valores modificados (modo Teach-In)" para la receta en "General > Sincronización > Configuración".


Administración de usuarios

Contenido Usuarios del dominio UMAC
Administración de usuarios

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Usuarios del dominio UMAC

En WinCC V16.0 solo pueden utilizarse usuarios UMAC locales y ningún usuario de dominio UMAC.


Comunicación

Contenido Establecimiento de la conexión con WinCC Runtime Advanced Cambio de conexión en conexiones no integradas Interrupciones de la conexión en controladores Mitsubishi Certificados autofirmados (RT Professional) Precisión del tipo de datos "DTL" Número limitado de conexiones HMI posibles Uso de PROFINET IO en paneles de operador tipo Panel Comunicación de RT Advanced a través del Station Manager (SIMATIC NET) con un S7-1200 Cambio de configuración IP y nombre de un controlador en el Control Panel del panel de operador (Basic Panels) "Establecer la (dirección) IP-Suite del PLC en el Control Panel" en SIMATIC S7-1200 V1 (Basic Panels) Conexiones vía PROFIBUS DP Cambio de una conexión Comunicación de Runtime Professional con SIMATIC S7-1200 RT Advanced en el Station Manager Comunicación de datos sin formato en proyectos redundantes (RT Professional) Conexión no integrada a un SIMATIC S7-1500 Software Controller (RT Advanced) Áreas de transferencia para el modo de operación "Dispositivo IO" y "Esclavo DP" de los dispositivos HMI Determinación de datos de diagnóstico por medio de dispositivos HMI Comunicación PROFIenergy Número de conexiones SmartClient
Comunicación

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Establecimiento de la conexión con WinCC Runtime Advanced

Preste atención a que la versión de dispositivo configurada en el sistema de ingeniería coincida con la versión del runtime instalado porque, de lo contrario, no se podrá establecer la comunicación al cargar el proyecto o se establecerá de forma retardada.

Si la versión del dispositivo no coincide con la versión del runtime instalado, puede hacer lo siguiente:

  1. Cambie la versión de dispositivo que se ha configurado en el sistema de ingeniería.

  2. Instale la versión de WinCC Runtime Advanced que coincida con la versión de dispositivo configurada.

Cambio de conexión en conexiones no integradas

Si se desea cambiar la comunicación de una conexión no integrada a otra conexión no integrada, p. ej., de Omron a Mitsubishi, deberá asegurarse de que los tipos de datos de las variables también se soporten en la nueva conexión.

Interrupciones de la conexión en controladores Mitsubishi

Tras varias interrupciones de la conexión, puede ocurrir que queden ocupados todos los recursos de conexión en el controlador Mitsubishi y ya no sea posible establecer la conexión. Por ello, se recomienda comprobar los recursos de conexión en el programa PLC del controlador y liberarlos nuevamente.

Certificados autofirmados (RT Professional)

Los certificados autofirmados ya no se soportan.

Si el servidor detecta un certificado autofirmado, la autenticación tiene lugar a través de la clave PSK compartida previamente (Pre-shared key). Si la clave PSK no coincide entre los interlocutores, no se establece ninguna comunicación.

Precisión del tipo de datos "DTL"

El tipo de datos "DTL" soporta la indicación de la hora en el rango de nanosegundos. Como los paneles solo soportan la indicación de la hora hasta el rango de milisegundos, al utilizarla en los punteros de área se dan las siguientes limitaciones:

  • Puntero de área "Fecha/hora"
    Al transferir las indicaciones de fecha y hora desde un Panel al controlador, debe tenerse en cuenta que la unidad de tiempo mínima es 1 milisegundo. El rango de valores de microsegundos a nanosegundos del tipo de datos "DTL" se rellena con ceros.

  • Puntero de área "Fecha/hora controlador"
    Al transferir las indicaciones de fecha y hora desde un controlador a un panel, se ignora el rango de microsegundos a nanosegundos. La indicación de fecha y hora se sigue procesando en el panel, incluidos los milisegundos.

Número limitado de conexiones HMI posibles

Al compilar un dispositivo aparece un mensaje de error indicando que la configuración de la conexión HMI en el editor "Dispositivos y redes" no es válida. La causa puede ser que se haya excedido el número máximo de conexiones posibles del dispositivo HMI o del PLC.

Compruebe el número máximo de conexiones posibles. Consulte el manual de producto de los dispositivos utilizados.

Uso de PROFINET IO en paneles de operador tipo Panel

Si utiliza PROFINET IO para conectar las teclas directas y LED de paneles de operador con el controlador, en HW Config se puede definir un offset para el área de direcciones de las entradas y salidas.

Si utiliza una CPU de la serie 400 apta para PROFINET IO en combinación con uno de los paneles de operador indicados abajo, tenga en cuenta la siguiente restricción:

El offset para el inicio del área de direcciones de las entradas no puede ser mayor que el offset para el inicio del área de direcciones de las salidas.

Esta restricción rige para los siguientes paneles de operador:

  • Mobile Panel 177

Para configurar los parámetros de dirección abra en HW Config el controlador con la CPU de la serie 400. En HW Config, seleccione en la ventana de la estación el panel de operador conectado vía PROFINET IO. En el área inferior de la ventana de la estación aparece en la vista detallada una tabla con las propiedades del panel de operador. Seleccione en la tabla la fila que contiene las direcciones del panel de operador y abra las propiedades de objeto desde el menú contextual.

Active la ficha "Direcciones" en el cuadro de diálogo "Propiedades del objeto". Configure el offset para las entradas en "Entradas > Inicio". Configure el offset para las salidas en "Salidas > Inicio".

Comunicación de RT Advanced a través del Station Manager (SIMATIC NET) con un S7-1200

En la comunicación entre un SIMATIC S7-1200 y un PC con WinCC RT Advanced o RT Professional a través de un router existen las siguientes restricciones para el PC:

  • Windows 7: Solo con SIMATIC NET 8.1 instalado

Estas restricciones también son válidas si se utiliza el Station Manager. Las conexiones de Runtime Advanced con ayuda del Station Manager siempre se tratan como conexiones enrutadas.

Cambio de configuración IP y nombre de un controlador en el Control Panel del panel de operador (Basic Panels)

En el panel de operador está abierto el Control Panel en el menú "Service and Commissoning > IP-Adaptation". Si desea cambiar la configuración IP o el nombre de dispositivo de un controlador, tenga en cuenta lo siguiente:

En el sistema de ingeniería ha activado previamente las siguientes opciones en la ventana de inspección del controlador, en "Propiedades > General > Interfaz PROFINET > Direcciones Ethernet".

  • "Obtener la dirección IP de otro modo"

  • "Obtener nombre de dispositivo PROFINET por otra vía"

"Establecer la (dirección) IP-Suite del PLC en el Control Panel" en SIMATIC S7-1200 V1 (Basic Panels)

La función "Establecer la (dirección) IP-Suite del PLC en el Control Panel" no está habilitada en los controladores siguientes:

  • SIMATIC S7-1200 V1

Conexiones vía PROFIBUS DP

Si se interrumpe y restablece una conexión mediante PROFIBUS DP entre un controlador y un panel de operador, el resto de conexiones PROFIBUS DP de la red de comunicación se interrumpirán y restablecerán esporádicamente.

Desconecte la tensión del dispositivo desconectado antes de volver a conectarlo.

Cambio de una conexión

Al cambiar la conexión de un panel de operador a un controlador SIMATIC S7-300/400 por un controlador SIMATIC S7-1500 o SIMATIC S7-1200, es posible que se interrumpa la conexión.

Tenga en cuenta los siguientes ajustes en el caso de los controladores SIMATIC S7-1500 o SIMATIC S7-1200:

  • Direccionamiento absoluto de las variables

  • Debe estar seleccionada la opción "Desactivar comunicación PUT-GET"

  • No debe estar configurado el nivel de protección "Protección completa"

Comunicación de Runtime Professional con SIMATIC S7-1200

En modo productivo, la comunicación entre WinCC Runtime Professional y SIMATIC S7-1200 solo está liberada para sistemas monopuesto.

RT Advanced en el Station Manager

Cuando RT Advanced y WinAC RTX utilizan el mismo procesador de comunicaciones de un PC, no es posible la comunicación HMI a SIMATIC S7-1200 ni SIMATIC S7-1500.

Comunicación de datos sin formato en proyectos redundantes (RT Professional)

Simatic.NET, Named Connections y diversos bloques de comunicación como, p. ej., BSEND/BRCV, solo pueden utilizarse de forma limitada en un equipo PC configurado de forma redundante porque los parámetros de conexión para la pareja redundante del servidor no pueden configurarse.

Conexión no integrada a un SIMATIC S7-1500 Software Controller (RT Advanced)

En WinCC no se soporta una conexión no integrada entre un dispositivo HMI y un SIMATIC S7-1500 Software Controller.

Áreas de transferencia para el modo de operación "Dispositivo IO" y "Esclavo DP" de los dispositivos HMI

Si ha activado el modo de operación "Dispositivo IO" o "Esclavo DP" para los paneles de operador HMI, no deberá agregar ni borrar áreas de transferencia en las propiedades del panel de operador. Si ha borrado o agregado un área de transferencia por error, bórrela y conecte de nuevo el controlador.

Determinación de datos de diagnóstico por medio de dispositivos HMI

Contrariamente a lo indicado en la descripción de los símbolos de diagnóstico de los módulos y dispositivos en el sistema de información, el siguiente símbolo significa lo siguiente para los dispositivos HMI:

Símbolo | Significado
 | No hay datos de diagnóstico disponibles.

Comunicación PROFIenergy

Para configurar la comunicación PROFIenergy póngase en contacto con el Customer Support.

Número de conexiones SmartClient

Aunque los Basic Panel permiten un número ilimitado de conexiones SmartClient, se recomienda configurar un máximo de 2 conexiones. Cualquier conexión adicional influye en el rendimiento.


Funciones generales

Contenido Utilizar el diagnóstico del sistema en el proxy de dispositivos Inicializar un proxy de dispositivo usando datos de un proyecto de la versión anterior Importación y exportación de textos de librerías
Funciones generales

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Utilizar el diagnóstico del sistema en el proxy de dispositivos

Para poder utilizar la función de diagnóstico del sistema en un proxy de dispositivos IPE, p. ej., un visor de diagnóstico del sistema, inserte los avisos de PLC como contenido de un proxy de dispositivos.

Inicializar un proxy de dispositivo usando datos de un proyecto de la versión anterior

En un proyecto con la versión de Service Pack no puede inicializarse un proxy de dispositivo con datos procedentes de un proyecto de la versión completa correspondiente.
Actualice el proyecto fuente a la versión del Service Pack para poder inicializar el proxy de dispositivo en el proyecto de destino con datos procedentes del proyecto fuente.

Importación y exportación de textos de librerías

Objetos no soportados en la importación y exportación de textos de librerías

  • Importación: recetas, elementos de receta, registros de receta, avisos HMI, entradas de listas de textos, imágenes, informes.

  • Exportación: entradas de listas de textos, imágenes, informes.

  • Importación y exportación de tipos de librerías "Imagen".


Compilar y cargar

Contenido Compilar y cargar Comprobación de los parámetros de dirección Mensaje de error al cargar datos en el PLC Comfort Panels a partir de la versión de dispositivo 13.0: protección de los datos al cargar proyectos Visualización de caracteres en avisos de transferencia Reducción del tamaño del proyecto
Microsoft KB3083806
Compilar y cargar

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Compilar y cargar

Si al compilar se producen errores internos o advertencias, compile el proyecto completamente con el comando "Compilar > Software (compilar todo)" del menú contextual del panel de operador.

Antes de pasar al modo productivo con el proyecto, compílelo completamente con el comando "Compilar > Software (compilar todo)" del menú contextual del panel de operador.

Si en el proyecto se utilizan variables HMI que están vinculadas a variables del controlador, antes de compilar el panel de operador compile todos los bloques modificados con el comando "Compilar > Software" del menú contextual.

Comprobación de los parámetros de dirección

Al compilar un panel de operador en el árbol del proyecto con el comando "Compilar > Hardware y software (solo cambios)" del menú contextual, no se comprueban los parámetros de dirección del panel de operador como, p. ej., la dirección IP. Para asegurarse de que también se comprueban los parámetros de dirección, hay que compilar el panel de operador en el editor "Dispositivos y redes" pulsando el botón "Compilar" de la barra de herramientas.

Mensaje de error al cargar datos en el PLC

Un Panel y un PLC están conectados y se comunican.

Si al cargar datos desde el Panel al PLC se accede a una variable, se visualiza un mensaje de error en el Panel.

Comfort Panels a partir de la versión de dispositivo 13.0: protección de los datos al cargar proyectos

Si se interrumpe la transferencia en los Comfort Panels de la versión de dispositivo 13.0 o superior, WinCC asegura automáticamente que no se pierdan datos y que los datos existentes en el panel solo se borren una vez completada la transferencia.

Visualización de caracteres en avisos de transferencia

Si en la transferencia a paneles de operador de la versión de dispositivo V12 o superiores los caracteres no se visualizan correctamente en los avisos de transferencia, compruebe la configuración regional y de idioma en Windows. Ajuste el idioma que corresponda en "Idioma para programas que no son Unicode".

Reducción del tamaño del proyecto

Al compilar el panel de operador, un aviso le indica que el tamaño del proyecto en el panel de operador alcanza el límite del sistema. Es este caso es posible reducir el tamaño del proyecto mediante la compilación completa del software. Ejecute para ello el comando "Compilar > Software (compilar todo)".


Runtime

Runtime

Este capítulo incluye información sobre los siguientes temas:
  • Indicaciones relativas al funcionamiento en runtime
  • Indicaciones relativas al funcionamiento de Panels en runtime
  • Indicaciones relativas al funcionamiento de Runtime Advanced
  • Indicaciones relativas al funcionamiento de Runtime Professional
  • Notas relativas al funcionamiento de Runtime Unified


Indicaciones relativas al funcionamiento en runtime

Contenido Foco en runtime Comportamiento en caso de cambio de idioma - Formato del teclado de pantalla Valores de variables que exceden la longitud máxima Textos de avisos vacíos Duración de la inicialización de los ficheros (Panels, RT Advanced) Los ficheros de gran tamaño hacen que tarde más en cerrarse el Runtime (Basic Panels 2nd Generation) Reacción lenta de SmartServer Desactivar el protector de pantalla en el Sm@rtServer Prevención de daños en archivos en caso de fallo de alimentación Fuentes variables en paneles de operador
Indicaciones relativas al funcionamiento en runtime

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Foco en runtime

Si en un panel de operador con versión 12.0.0 o inferior se ha configurado una combinación de color de foco y color de borde de bajo contraste, es posible que tras cambiar la versión del panel en el TIA Portal no se distinga claramente el foco en runtime. Modifique uno de los dos colores.

Comportamiento en caso de cambio de idioma - Formato del teclado de pantalla

El formato del teclado de pantalla no cambia si se cambia a un idioma de runtime que no esté instalada para el formato de teclado en Windows.

En tal caso, el idioma del teclado permanece ajustado con el último idioma válido o bien se utiliza el idioma ajustado para el formato de teclado estándar de Windows.

Valores de variables que exceden la longitud máxima

Se introduce una cadena de caracteres en una variable String mediante un campo E/S. Si la cadena de caracteres excede la longitud configurada de la variable, se reducirá hasta la longitud configurada.

Textos de avisos vacíos

Runtime se ejecuta con un proyecto. El proyecto está guardado en una unidad de red.

En caso de interrupciones hacia la unidad de red puede ocurrir que runtime intente cargar textos de avisos de la unidad de red.

Si la conexión está desconectada, la ventana o el visor de avisos permanecen vacíos.

Para evitar este comportamiento se debe copiar el proyecto en una unidad local antes de iniciar el proyecto en runtime.

Duración de la inicialización de los ficheros (Panels, RT Advanced)

La inicialización de los ficheros puede requerir hasta 5 minutos en algunos medios de almacenamiento. Un aviso de sistema confirma que la inicialización ha finalizado correctamente. Si falta un medio de almacenamiento para el archivado, el aviso de sistema puede tardar hasta 5 minutos en aparecen durante el inicio de runtime.

Los ficheros de gran tamaño hacen que tarde más en cerrarse el Runtime (Basic Panels 2nd Generation)

El cierre de Runtime requiere más tiempo cuando se utilizan ficheros de gran tamaño. Utilice ficheros segmentados como alternativa a ficheros circulares de gran tamaño.

Reacción lenta de SmartServer

Es posible que en Windows 7 los siguientes programas se inicien y respondan muy lentamente:

  • HMI TouchInputPC

  • SmartServer: Combinación de teclas <Ctrl+Alt+Supr> en el diálogo de inicio de sesión

El retraso es provocado por la comprobación de certificados revocados de Internet.

Solución:

En el DVD de producto encontrará bajo:
Support\Windows7\CRL_Check o CD_RT\Support\Windows7\CRL_Check\
los siguientes archivos:

  • DisableCRLCheck_LocalSystem.cmd

  • DisableCRLCheck_CurrentUser.cmd

  1. Ejecute el archivo "DisableCRLCheck_LocalSystem.cmd" con derechos de administrador. Llame el comando "Run as administrator" del menú contextual del archivo.

  2. Reinicie el PC.

Si de esta manera no se resuelve el problema, proceda del siguiente modo:

  1. Haga doble clic en el archivo y ejecute el archivo "DisableCRLCheck_CurrentUser.cmd" con derechos de usuario.

  2. Reinicie el PC

    Nota

    La comprobación de certificados revocados se desactiva para los usuarios o el PC. Para restaurar el estado inicial ejecute los siguientes archivos:

    • RestoreDefaults_LocalSystem.cmd

    • RestoreDefaults_CurrentUser.cmd

    Los archivos se encuentran en el siguiente directorio del DVD de producto:

    • Support\Windows7\CRL_Check o CD_RT\Support\Windows7\CRL_Check\

Desactivar el protector de pantalla en el Sm@rtServer

Si el protector de pantalla está activado en el Sm@rtServer en el panel de operador servidor, es necesario disponer de acceso de escritura al Sm@rtClient para poder desactivar el protector de pantalla en el panel de operador servidor.

Prevención de daños en archivos en caso de fallo de alimentación

Si se produce un fallo de alimentación en sistemas Windows mientras está activado el sistema WinCC, los archivos pueden resultar dañados o quedar destruidos. La utilización del sistema de archivos NTFS ofrece mayor seguridad.

Solo el uso de una fuente de alimentación ininterrumpida (SAI) garantizará un servicio continuo seguro.

Fuentes variables en paneles de operador

Windows 10 soporta fuentes variables desde la versión 1709 ("OpenType Font Variations"). En el sistema de ingeniería (ES) también puede utilizar las variantes de una fuente variable. La representación real en runtime dependerá del panel de operador y de las condiciones de instalación:

  • Basic Panels, Comfort Panels: No se soportan las fuentes variables. Se muestra siempre la variante básica.

  • Runtime Advanced, Runtime Professional: Se soportan las fuentes variables, si como sistema operativo se utiliza Windows 10 Version 1709 como mínimo y la fuente está instalada con derechos de administrador.


Indicaciones relativas al funcionamiento de Panels en runtime

Contenido Utilización de la rueda del ratón en runtime Copia de seguridad en la tarjeta de memoria del PLC (Basic Panels) Panel Data Storage y S7-1500F (Basic Panels) Función "Panel Data Storage" (Basic Panels) Fuentes con extensión de archivo ".ttx" Transferencia de datos masivos vía USB Cambiar la dirección IP y el nombre de dispositivo en paneles
Indicaciones relativas al funcionamiento de Panels en runtime

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Utilización de la rueda del ratón en runtime

La utilización de la rueda del ratón en runtime no se soporta en ningún panel.

Copia de seguridad en la tarjeta de memoria del PLC (Basic Panels)

Se crea el archivo de backup "A.psb" en la tarjeta de memoria del PLC. Al crear la copia de seguridad se produce un error, p. ej., una interrupción de la comunicación.
Con ello se genera un archivo defectuoso en la tarjeta de memoria del PLC. Los archivos de este tipo llevan el prefijo "~$".
Borre el archivo con el prefijo "~$" si quiere guardar una nueva copia de seguridad con el mismo nombre "A.psb".

Panel Data Storage y S7-1500F (Basic Panels)

La función "Panel Data Storage" PDS no puede utilizarse en Basic Panels en combinación con S7-1500F si se utiliza la contraseña para el nivel de protección "Full access incl. fail-safe".

Función "Panel Data Storage" (Basic Panels)

La función "Panel Data Storage" (PDS), disponible en Basic Panels, soporta únicamente SIMATIC S7-1200 a partir del firmware V4.0 y SIMATIC S7-1500. Para utilizar la función PDS, el panel debe estar conectado directamente a la CPU; no puede estar conectado a través del CP.

Fuentes con extensión de archivo ".ttx"

Las fuentes con extensión ".ttx" están disponibles en todos los paneles y en Runtime Advanced y pueden visualizarse correctamente en todos los equipos, p. ej., la fuente "WinCC_flexible_smart".

Transferencia de datos masivos vía USB

Si instala Windows 10 en el PC de configuración, el canal de transferencia "USB" no está disponible.

Esta limitación afecta a los siguientes equipos y herramientas:

  • Basic Panels: KP300 Basic, KP400 Basic, TP1500 Basic

  • Mobile Panels: Serie 170 y serie 270

  • WinCC Engineering System

  • Herramienta de servicio "ProSave"

Nota

El canal de transferencia "USB" sigue estando disponible si en el PC de configuración está instalado Windows 7.

Solución

Utilice otros canales de transferencia para transferir los datos de proyecto, p. ej., el canal "Industrial Ethernet" o "PROFIBUS DP".

Cambiar la dirección IP y el nombre de dispositivo en paneles

En los Comfort Panels es posible cambiar la dirección IP o el nombre de dispositivo aunque se haya iniciado el runtime.

En los Basic Panels no es posible cambiar la dirección IP o el nombre de dispositivo cuando se está ejecutando el runtime.


Indicaciones relativas al funcionamiento de Runtime Advanced

Contenido Iniciar runtime Permiso para iniciar Runtime Advanced Protector de pantalla en equipos con Windows 10 Windows 10 en modo tableta .Net-Controls en runtime Desactivar la comprobación automática de actualizaciones de software Acceso a variables de array vía OPC
Indicaciones relativas al funcionamiento de Runtime Advanced

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Iniciar runtime

Desde el sistema de ingeniería solo puede iniciarse WinCC Runtime V16. Otras versiones de WinCC solo se pueden simular.

Permiso para iniciar Runtime Advanced

En un equipo con sistema operativo Windows, WinCC Runtime Advanced solo puede iniciarse si el usuario que inicia el runtime está asignado al grupo "Siemens TIA Engineer" y tiene sus derechos.

Protector de pantalla en equipos con Windows 10

En un equipo con Windows 10 el protector de pantalla activado ya no se cierra al aparecer un aviso de la clase "Error".

Windows 10 en modo tableta

No se recomienda utilizar Windows 10 en modo tableta.

Si utiliza aplicaciones, p. ej., Runtime Advanced, Sinumerik Operate, etc., con Windows 10 en modo tableta, dichas aplicaciones se minimizan tras iniciarlas.

.Net-Controls en runtime

Si en el proyecto se ha integrado un control .Net como "Control .Net específico", es necesario copiar los archivos correspondientes a esos controles en el directorio de instalación de WinCC Runtime, p. ej., "C:\Archivos de programa\Siemens\Automation\WinCC RT Advanced". De lo contrario no será posible cargar el control en runtime.

Desactivar la comprobación automática de actualizaciones de software

Si el sistema de ingeniería está instalado en un PC junto con el runtime, el operador recibe notificaciones sobre las actualizaciones de software. Para que el sistema funcione de forma estable en un sistema multipuesto, todos los equipos deben tener instalada la misma versión de software.

Existe la posibilidad de desactivar la comprobación automática de actualizaciones de software y mejorar con ello el rendimiento.

La comprobación automática de las actualizaciones de software se desactiva en "Configuración > General > Actualizaciones de software" desactivando la opción "Buscar actualizaciones cada día".

Acceso a variables de array vía OPC

Si utiliza WinCC Runtime Advanced como servidor OPC UA, solo podrá leer variables de array si está activado el ajuste "OPC UA Server Array index range access".

Las variables de array solo pueden escribirse si el cliente OPC UA admite el ajuste “Write array elements without IndexRange".


Indicaciones relativas al funcionamiento de Runtime Professional

Contenido Autorizaciones de usuario en el sistema operativo Bloquear combinaciones de teclas Barras de herramientas no fijas Fallo de conexión entre servidor y cliente Fallo de conexión entre servidor y cliente Iniciar WinCC Runtime Professional Configuración de los servicios para el servidor SQL "Notificar errores de sistema" en WinCC Runtime Professional Interfaces WinCC y sistema operativo de 64 bits Gráficos dinámicos en el WinCCViewer RT Runtime Professional: Carga de un proyecto sin conexión al PC de configuración Conexión con S7-1200 en el diagnóstico del sistema Desactivar la comprobación automática de actualizaciones de software Restricciones en la carga de modificaciones online Objetos de imagen en informes en formato PDF Proyectos en runtime tras la actualización de Windows 10 Memoria que requieren los ficheros
Indicaciones relativas al funcionamiento de Runtime Professional

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Autorizaciones de usuario en el sistema operativo

  1. Todos los usuarios deben haber sido agregados al grupo de usuarios "SIMATIC HMI". Esto también rige para usuarios que deseen abrir proyectos WinCC remotos.

  2. La carpeta de almacenamiento de los proyectos tiene que disponer de las autorizaciones NTFS "SIMATIC HMI" con pleno acceso y "SIMATIC HMI Viewer" con derechos de lectura. Las autorizaciones deben poder ser heredadas por todos los objetos subordinados.

Bloquear combinaciones de teclas

Si desea bloquear combinaciones de teclas en Windows, deberá adaptar las directivas de grupos en la administración del sistema operativo.

Encontrará una descripción detallada al respecto en la FAQ con la ID de artículo "44027453" en el SIMATIC Customer Online Support:

Internet: WinCC FAQ 44027453

Barras de herramientas no fijas

Si se utiliza el ajuste "Siempre visible" para la barra de tareas de Windows, es posible mover las barras de herramientas no fijas detrás de la barra de tareas de Windows. Para mostrar nuevamente las barras de herramientas proceda del siguiente modo:

  1. Elija el comando "Propiedades" del menú contextual de la barra de herramientas.

  2. Desactive la opción "Mantener la barra de tareas siempre visible".

Fallo de conexión entre servidor y cliente

Si la conexión entre servidor y cliente falla, compruebe los ajustes de la interfaz PG/PC. Para la "Parametrización de interfaz utilizada" no debe utilizarse TCP/IP(Auto). Utilice en su lugar direcciones IP fijas.

Fallo de conexión entre servidor y cliente

Si el equipo con el sistema de ingeniería se está utilizando simultáneamente como servidor y un cliente no puede establecer una conexión con el servidor, se deben comprobar las autorizaciones establecidas en este.

  1. Finalice el runtime en el servidor.

  2. Seleccione el comando "Buscar equipos..." en el menú contextual de "Mis sitios de red" en el escritorio del servidor.

  3. Introduzca el nombre del servidor para el equipo que quiere buscar.

  4. Abra el equipo encontrado para detectar los directorios compartidos.

  5. Elimine todos los directorios compartidos que empiecen por "WinCC_Project_HMI". Encontrará más información en la documentación del sistema operativo.

El comportamiento incorrecto se debe al uso del comando "Guardar como..." en combinación con el inicio de runtime de este nuevo proyecto. Con el fin de disponer de copias de seguridad de los proyectos, utilice el comando "Guardar como..." para crear copias de los proyectos. Sin embargo debería seguir trabajando con el proyecto original.

Iniciar WinCC Runtime Professional

Si en un equipo están instalados el sistema de ingeniería y el runtime, entonces conviene abrir y cerrar el runtime o la simulación relativa a un proyecto abierto en el sistema de ingeniería solo desde el TIA Portal. Para ello no conviene usar otras posibilidades como el icono que figura en la barra de tareas.

Al configurar el inicio automático en el cliente es necesario introducir el nombre de usuario y la contraseña para cada proyecto de servidor registrado. Para asignar un nombre de usuario (login) a cada servidor, se debe confirmar la introducción de la ruta de proyecto correspondiente con la tecla "Aplicar". Esto hace que, en el caso de proyectos redundantes o alternativos, el nombre de usuario (login) y la contraseña se tengan que introducir dos veces.

Configuración de los servicios para el servidor SQL

Para poder asegurar la plena funcionalidad del servidor SQL para WinCC y WinCC Runtime es necesario comprobar la configuración del servidor SQL.

  1. Inicie en el menú de inicio "Programme > Microsoft SQL Server 2014 > Configuration Tools > SQL Server 2014 Configuration Manager".

  2. Haga clic en el árbol sobre "SQL Server Services".

  3. Compruebe los servicios "SQL Server (WinCC)", "SQL Server (WINCCPLUSMIG)" y "SQL Server Browser".
    Para "Start Mode" debe indicarse "Automatic".
    Para "Log On As" debe indicarse "LocalSystem" para "SQL Server (WinCC)".
    Para "SQL Server Browser" debe indicarse "LOCALSERVICE".
    Cambie los ajustes si es necesario.

  4. Haga clic en el árbol sobre "SQL Server Network Configuration".

  5. Haga clic en "Protocols for WinCC".

  6. Compruebe el protocolo "TCP/IP". En "Status" tiene que estar registrado "Enabled". Modifique la configuración, si es necesario.

"Notificar errores de sistema" en WinCC Runtime Professional

La funcionalidad "Notificar errores de sistema" está limitada en el WinCC Runtime Professional en combinación con un S7-300 o S7-400. En un visor de avisos solo se muestra un aviso por cada tipo de diagnóstico. Los avisos relativos a otros errores del mismo tipo de diagnóstico no se visualizan.

Interfaces WinCC y sistema operativo de 64 bits

Las interfaces abiertas de WinCC Runtime Professional no ofrecen soporte nativo para 64 bits. Esto afecta sobre todo a Runtime API, VBS y a WinCC OleDB-Provider. Para poder utilizar las interfaces de WinCC en un sistema operativo de 64 bits, debe tener en cuenta lo siguiente:
- Los VB Scripts no se pueden iniciar con solo un doble clic. Debe utilizarse explícitamente la versión de 32 bits en "syswow64\wscript.exe".
- Las aplicaciones .NET que utilizan WinCC-API deben compilarse explícitamente como aplicaciones de 32 bits. No con "AnyCPU" sino con "x86".
- Las aplicaciones C++ no deben compilarse como aplicaciones de 64 bits.

Gráficos dinámicos en el WinCCViewer RT

Si se asocian gráficos dinámicos de una colección de gráficos, p. ej., a scripts, estos gráficos no se actualizarán en el WinCCViewer RT.

Seleccione la opción "Definido por el usuario" en "Configuración runtime > Configuración de gráficos".

Runtime Professional: Carga de un proyecto sin conexión al PC de configuración

Antes de proceder a cargar un proyecto en la estación de operador, guarde los datos tales como "Administración de usuarios" y "Datos de recetas".

  1. Los datos de la administración de usuarios se sobrescriben de forma estándar.

    Por ello se recomienda configurar dos botones en el proyecto para exportar o importar la administración de usuarios con la función de sistema "ExportarAdministraciónDeUsuarios". Solo es necesario exportar los datos si se han realizado modificaciones en el visor de usuarios en runtime.

  2. Al cargar el proyecto, especifique en el cuadro de diálogo "Vista preliminar Carga" si deben sobrescribirse datos de recetas.

    Los datos de recetas se pueden guardar en el visor de recetas con los elementos de mando "Exportar fichero" e "Importar fichero".

Tenga en cuenta que los últimos datos importados o cargados se utilizarán en runtime.

Conexión con S7-1200 en el diagnóstico del sistema

Si se usa el diagnóstico del sistema, solo se puede conectar un sistema HMI WinCC Runtime Professional con un S7-1200 (hasta V3).

Desactivar la comprobación automática de actualizaciones de software

Si el sistema de ingeniería está instalado en un PC junto con el runtime, el operador recibe notificaciones sobre las actualizaciones de software. Para que el sistema funcione de forma estable en un sistema multipuesto, todos los equipos deben tener instalada la misma versión de software.

Existe la posibilidad de desactivar la comprobación automática de actualizaciones de software y mejorar con ello el rendimiento.

La comprobación automática de actualizaciones de software se desactiva en "Configuración > General > Actualizaciones de software" desmarcando la casilla de verificación "Comprobar actualizaciones cada día".

Restricciones en la carga de modificaciones online

Si utiliza un diseño, ya no podrá cargar modificaciones online en el proyecto. En estos casos, TIA Portal no emite ningún mensaje error.

Objetos de imagen en informes en formato PDF

La calidad de los objetos de imagen en los informes que se generen como archivos PDF depende de los controladores de impresora PDF que se utilicen.

Proyectos en runtime tras la actualización de Windows 10

Ha instalado la versión 1709 de Windows 10 en un PC con WinCC Professional V15 y en un PC con WinCC Professional RT V15. En el PC Runtime ha actualizado Windows 10 a la versión 1803. Tras la actualización de Windows 10, en determinadas circunstancias ya no es posible abrir manualmente un proyecto cargado del PC del sistema de ingeniería.

Solución: Ajuste manualmente el tipo de inicio del servicio de la instancia SQL de WinCC a "Automático (inicio retrasado)" y reinicie el sistema.

Memoria que requieren los ficheros

Para calcular la memoria necesaria para guardar los avisos de todos los segmentos y para segmentos individuales es necesario saber el número de avisos que entran por segundo de promedio. Se tiene el cuenta el espacio máximo de memoria que requiere un aviso, aproximadamente 4000 bytes. Se aplica:
memoria necesaria = número de avisos/s * 4000 bytes * 60 s/min * 60 min/h * 24 h/día * 31 días/mes * y meses.

En el ejemplo se parte de 1 aviso por segundo:

  • Para el espacio máximo de todos los segmentos en dos meses resultan aprox. 20 GB.

  • Para un segmento individual resultan aproximadamente 330 MB diarios

Para calcular la memoria necesaria para ficheros de datos de todos los segmentos y para segmentos individuales es necesario saber cuántos valores se archivan por segundo y la longitud media de un valor de proceso. Se aplica:
memoria necesaria = número de valores de fichero/s * x bytes * 60 s/min * 60 min/h * 24 h/día * 31 días/mes * y meses

En el ejemplo se parte de 750 valores de fichero por segundo:

  • Para valores de proceso con 16 bytes resulta un espacio de memoria de aproximadamente 60 GB.

  • Para valores de proceso con 6 bytes resulta un espacio de memoria de aproximadamente 22 GB.


Paneles de operador

Paneles de operador

Este capítulo incluye información sobre los siguientes temas:
  • Indicaciones acerca de paneles de operador


Indicaciones acerca de paneles de operador

Contenido Paneles de operador no soportados (a partir de TIA Portal V15) Paneles de operador no soportados (a partir de TIA Portal V15.1) Paneles de operador no soportados (a partir de TIA Portal V16) Manejo simultáneo de varias teclas Paneles de operador con elevada carga de comunicación TS Adapter con interfaz Ethernet Simulación con conexión real al controlador Simulación de Basic Panels Basic Panels 2nd Generation Paneles de operador con el sistema operativo Windows CE 5.0 y superior Cambio de conexión en el Control Panel de Basic Panels Imprimir avisos (Mobile Panel) DHCP en KTP 400 PN, KTP 700 PN y KTP 900 PN Mobile Panel Sm@rtServer con Mobile Panels Simulación de Basic Panels 2nd Generation Instalación de fuentes Interrupción de la conexión DH485 Función VB "CDate" (Comfort Panels) Borrar caché del navegador (Panel)
PI Mobile
Indicaciones acerca de paneles de operador

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Paneles de operador no soportados (a partir de TIA Portal V15)

A partir de TIA Portal V15 no se soportan los panales de la versión 11.x.

A partir de TIA Portal V15 no se soportan los siguientes paneles de operador:

  • WinAC MP 177, WinAC MP 277, WinAC MP 377

  • Panels: OP y TP de las series 70, 170 y 270

  • Multi Panels: Multi Panels de las series 170, 270 y 370

Para poder utilizar otros dispositivos en TIA Portal V15, (p. ej., Basic, Comfort o Mobile Panels) que hayan sido configurados con la versión 11.x, cambie la versión del dispositivo afectado.

La estructura de almacenamiento del directorio de instalación ya no contiene datos para 11.0. De este modo se reduce el tamaño del paquete de instalación del TIA Portal con respecto a las versiones anteriores.

Paneles de operador no soportados (a partir de TIA Portal V15.1)

A partir de TIA Portal V15.1 ya no se soportan los siguientes paneles de operador:

  • WinCC Runtime Advanced V11

Paneles de operador no soportados (a partir de TIA Portal V16)

A partir de TIA Portal V15.1 ya no se soportan los siguientes paneles de operador:

  • Mobile Panel de la versión 12.x

  • Comfort Panel de la versión 12.x

  • KP1500 Comfort de la versión 13.x

  • TP1500 Comfort de la versión 13.x

  • TP1900 Comfort de la versión 13.x

  • TP2200 Comfort de la versión 13.x

Manejo simultáneo de varias teclas

El manejo simultáneo de varias teclas puede provocar acciones no intencionadas:

  • En caso de utilizar un dispositivo con teclado, no está permitido accionar más de dos teclas de función a la vez.

  • En caso de utilizar un dispositivo táctil, un PC estándar o un Panel PC, no está permitido accionar más de una tecla de función o botón a la vez.

Paneles de operador con elevada carga de comunicación

Si en un panel se han configurado muchas conexiones con controladores u otros paneles de operador, el diagnóstico S7 debe estar desactivado. De lo contrario, hay peligro de que el panel se sobrecargue.

TS Adapter con interfaz Ethernet

Si un panel de operador está conectado a través de Ethernet y de un TS Adapter, no podrá restablecerse la configuración de fábrica.

Simulación con conexión real al controlador

El punto de acceso utilizado por la simulación es independiente de los ajustes en el Engineering System y únicamente puede modificarse con la herramienta "Ajustar interface PG/PC" en el Panel de control. Si la conexión con un controlador se deshace directamente después de arrancar la simulación y se genera el aviso 140001, debería verificar el punto de acceso utilizado por la simulación con "Ajustar interface PG/PC".

  1. Haga doble clic en "Ajustar interface PG/PC" dentro del Panel de control. Se abre un cuadro de diálogo.

  2. Seleccione en el área "Punto de acceso de la aplicación" "S7ONLINE" de manera estándar para HMI.

  3. Seleccione la interface en el área "Parametrización de interface utilizada".

  4. Finalice el cuadro de diálogo "Ajustar interface PG/PC" con Aceptar.

Simulación de Basic Panels

Para la salida de una variable externa utilice un campo de salida en un texto de aviso. En la simulación se mostrará siempre un "0" como contenido de este campo de salida.

Basic Panels 2nd Generation

Los Basic Panels 2nd Generation soportan la opción Sm@rtServer.

Si no utiliza ningún hub USB, seleccione el puerto USB USB_X60.1 como ruta de almacenamiento.

Paneles de operador con el sistema operativo Windows CE 5.0 y superior

Debido a un cambio en los ajustes de seguridad de la comunicación entre cliente y servidor, la diferencia horaria entre un panel de operador (cliente) y un PC (servidor) no puede ser superior a 1 día. Si guarda una copia de seguridad, p. ej., de datos de recetas del panel de operador en una unidad de red, asegúrese de que la hora del PC (servidor) y del panel de operador (cliente) esté ajustada correctamente.

Cambio de conexión en el Control Panel de Basic Panels

Si se utiliza la función "Override projected connection information", hay que tener en cuenta la restricción siguiente:

En el Control Panel de un Basic Panel no es posible cambiar la conexión de un controlador sin nivel de protección a un controlador con el nivel de protección "Protección completa".

Imprimir avisos (Mobile Panel)

No es posible imprimir avisos en formato PDF o HTML, si se ha seleccionado la memoria interna "/flash" como "Storage Location". Para imprimir avisos en formato PDF o HTML, seleccione una tarjeta de memoria SD o un lápiz USB como ubicación.

DHCP en KTP 400 PN, KTP 700 PN y KTP 900 PN

No se recomienda el uso de los paneles KTP 400 PN, KTP 700 PN y KTP 900 PN con DHCP

Bajo determinadas circunstancias puede suceder que el dispositivo ya no arranque. En tal caso, desenchufe el cable de red y reinicie el dispositivo. Después de arrancar correctamente, asigne una dirección IP.

Mobile Panel

Los Mobile Panels 2nd Generation pueden configurarse con TIA Portal V16 en la versión de dispositivo V15. Sin embargo, el proyecto compilado no puede cargarse en estos paneles.

Para poder trabajar en TIA Portal V16 con Mobile Panels 2nd Generation, es preciso actualizar por lo menos a la versión de dispositivo V15.1.

Sm@rtServer con Mobile Panels

La evaluación del manejo de seguridad mediante PROFIsafe solo se garantiza si Sm@rtServer está desactivado en el panel.

No se recomienda el uso de Sm@rtServer en dispositivos sin función de seguridad.

Simulación de Basic Panels 2nd Generation

Para la simulación de los Basic Panels 2nd Generation debería estar activada la aceleración de hardware 3D de la tarjeta gráfica.

Instalación de fuentes

Si ha instalado con ProSave nuevos juegos de caracteres en un panel, es preciso reiniciar el panel. La duración del proceso de inicio del runtime depende del número y tamaño de las fuentes.

Interrupción de la conexión DH485

Si, en el caso de los Comfort Panels, el cable Ethernet se conecta a la conexión "PN_X1" del panel HMI, puede interrumpirse la conexión DH485.

Solución para Comfort Redesign/PRO-Panels: Al ejecutar el proyecto DH485 en el panel HMI, utilice la conexión "PN_X3(Gigabit)" para la comunicación Ethernet.

Función VB "CDate" (Comfort Panels)

En los siguientes paneles de operador solo puede utilizar la función VB "CDate" con parámetros estáticos:

  • TP1200 Comfort Pro

  • TP1500 Comfort Pro / V2

  • TP1900 Comfort Pro / V2

  • TP2200 Comfort Pro / V2

Borrar caché del navegador (Panel)

Si observa que la carga de páginas web en el navegador HTML requiere más tiempo del habitual, la causa puede ser la caché del navegador. Ejecute la siguiente función de VBS en runtime para borrar la caché del navegador. Asimismo, puede programar esta función de VBS como tarea periódica en el planificador de tareas.

Copia el código de programa siguiente en el portapapeles.

Sub T7_DeleteBrowserCache()

' delete Browsercache filled temporary objects

Dim fso, nFileIndex,sFileName, nFileAttr, folder

On Error Resume Next

' Variable to show script is active

SmartTags("DeleteBrowserCacheActive") = True

folder = "\flash\simatic\Browsercache\data7\"

' Windows CE

Set fso = CreateObject("FileCtl.FileSystem")

' Get first item that matches path

sFileName = fso.Dir(folder & "*.*")

nFileIndex = 0

'Get the rest of matches

Do While sFileName <> ""

nFileAttr = fso.GetAttr(folder & sFileName)

If (nFileAttr And 16) <> 0 Then

fso.Kill("\flash\simatic\Browsercache\data7\"&sFileName&"\*.*")

If Err.Number <>0 Then

Err.Clear

End If

End If

nFileIndex = nFileIndex + 1

sFileName = fso.Dir

Loop

Set fso = Nothing

SmartTags("DeleteBrowserCacheActive") = False

End Sub


Opciones

Opciones

Este capítulo incluye información sobre los siguientes temas:
  • Sm@rtServer
  • Audit
  • DataMonitor
  • WebNavigator
  • WebUX
  • Redundancia
  • SIMATIC Information Server


Sm@rtServer

Contenido Abrir archivos *.sac SmartClient en Windows 10
Sm@rtServer

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Abrir archivos *.sac SmartClient en Windows 10

Los datos de la conexión SmartServer actual se guardan con ayuda del archivo ejecutable SmartClient.exe con el formato *.sac. Para abrir automáticamente los archivos generados así en Windows 10, debe abrirse una vez manualmente un archivo *.sac con SmartClient.exe con el botón de selección y el cuadro de diálogo de SmartClient.exe.


Audit

Contenido Actualización de WinCC Audit Viewer 7.2
Audit

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Actualización de WinCC Audit Viewer 7.2

Para WinCC Audit Viewer 7.2, instalable opcionalmente, tiene a su disposición una actualización para instalarla manualmente.

Instale la actualización para WinCC Audit Viewer 7.2 ejecutando el archivo "AuditViewer_V72_00_Upd1.exe" del directorio Support del DVD de producto.


DataMonitor

Contenido Desinstalación de WinCC Runtime Excel-Workbook en un PC con Windows 7 Visor de diagnóstico de canal Zonas horarias de WebParts
DataMonitor

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Desinstalación de WinCC Runtime

Para poder continuar utilizando el DataMonitor tras desinstalar WinCC Runtime Professional, es necesario reparar la instalación. Para ello proceda del siguiente modo:

  1. Abra el Panel de control.

  2. Haga doble clic en "Agregar o quitar programas".

  3. En la lista de los programas instalados, haga clic en "SIMATIC WinCC/DataMonitor Client"

  4. Haga clic en el botón "Cambiar o quitar".

  5. Seleccione la opción "Reparar" en el programa de instalación de WinCC/DataMonitor.

Excel-Workbook en un PC con Windows 7

Si se utiliza Excel-Workbook en un PC con Windows 7 hay que desactivar la representación "Aero Glass".

Visor de diagnóstico de canal

El objeto "Visor de diagnóstico de canal" no está soportado por la opción WinCC DataMonitor.

Zonas horarias de WebParts

Si en el Webcenter crea y configura un WebPart (elemento web) bajo una determinada zona horaria, esa zona horaria se guardará en el Webcenter.

Una modificación del huso horario en el sistema operativo puede hacer que la hora no se indique correctamente en la WebPart.


WebNavigator

Contenido Desinstalación de WinCC Runtime Programa antivirus Trend Micro OfficeScan Vista general de ProDiag, Vista general de GRAPH y Visor de código PLC Caracteres no permitidos en WinCC WebNavigator Diagnóstico de canal Retardo al visualizar las imágenes de WebNavigator
WebNavigator

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Desinstalación de WinCC Runtime

Para poder continuar utilizando DataMonitor tras desinstalar WinCC Runtime Professional, es necesario reparar la instalación. Para ello proceda del siguiente modo:

  1. Abra el Panel de control.

  2. Haga doble clic en "Agregar o quitar programas".

  3. En la lista de los programas instalados, haga clic en "SIMATIC WinCC/WebNavigator Client"

  4. Haga clic en el botón "Cambiar o quitar".

  5. Seleccione la opción "Reparar" en el programa de instalación de WinCC/WebNavigator.

Programa antivirus Trend Micro OfficeScan

No se recomienda la utilización del programa antivirus Trend Micro OfficeScan en combinación con WebNavigator, pues este programa antivirus puede prolongar el tiempo de apertura de las imágenes.

Vista general de ProDiag, Vista general de GRAPH y Visor de código PLC

No se admite el uso de los objetos WinCC "Vista general de GRAPH", "Vista general de ProDiag" y "Visor de código PLC" en la opción de WinCC Web Navigator.

Caracteres no permitidos en WinCC WebNavigator

En los nombres de imagen y nombres de proyecto, utilice caracteres del juego de caracteres ASCII. No utilice caracteres especiales ni caracteres nacionales especiales.

Diagnóstico de canal

El objeto "Diagnóstico de canal" no está soportado por la opción WinCC WebNavigator.

Retardo al visualizar las imágenes de WebNavigator

Gracias a la tecnología de servidor puede suceder que las imágenes WebNavigator se visualicen retardadas.


WebUX

Contenido Inicio de sesión automático
WebUX

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Inicio de sesión automático

Si ya no desea iniciar sesión automáticamente, deberá borrar el historial de navegación en el navegador correspondiente.


Redundancia

Contenido Nombres en la configuración de un sistema redundante
Redundancia

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Nombres en la configuración de un sistema redundante

Para la configuración de un sistema redundante solo son relevantes los nombres de equipo de los paneles de operador. El nombre de equipo de un panel de operador se define en el respectivo sistema operativo. El nombre del panel de operador en el árbol del proyecto solo sirve para identificar el panel de operador en el proyecto.


SIMATIC Information Server

Contenido Instalación de SIMATIC Information Server y WinCC Runtime Professional en un PC
SIMATIC Information Server

Contenido

Indicaciones que no se han podido incluir en la Ayuda en pantalla e indicaciones importantes sobre las características del producto.

Instalación de SIMATIC Information Server y WinCC Runtime Professional en un PC

Para instalar el SIMATIC Information Server y WinCC Runtime Professional en un PC, siga el orden de instalación siguiente:

  1. Instale WinCC Runtime Professional.

  2. Instale el Information Server.

Si no se observa el orden de instalación pueden producirse problemas.