Fonctions technologiques

Exemples Voir aussi Historique Outils
Fonctions technologiques

Ce chapitre contient des informations sur les sujets suivants :
  • Remarques sur Motion Control S7-1500 (S7-1500, S7-1500T)
  • Remarques sur d'autres fonctions technologiques (S7-1500)
  • Recommandations concernant les fonctions technologiques (S7-1200)
  • Recommandations concernant les fonctions technologiques (S7-300, S7-400)
  • SIMATIC STEP 7 Easy Motion Control
  • SIMATIC STEP 7 PID Professional


Remarques sur Motion Control S7-1500 (S7-1500, S7-1500T)

Exemples Voir aussi Historique Outils
Alarmes technologiques 900-902 Mettre à niveau des projets dans TIA Portal version V16 Comportement du compteur de cycles modulo en cas de référencement avec "MC_Home" Utilisation du type de données "DX_TEL_SyncOp" en cas de synchronisme inter-API Vous pouvez configurer manuellement des temps de retard sur l'axe pilote et sur l'axe asservi virtuel. Calcul de l'écart de traînage Performance de la transformation de l'utilisateur avec adaptation de la dynamique (S7-1500T) La largeur de bande maximale de la CPU est limitée pour les enregistrements avec la trace de la cinématique (S7-1500T) Lissage entre des trajectoires et des mouvements "Point à point" synchrones (mouvements sPTP) (S7-1500T) Modification de l'override en cas de mouvements "point à point" synchrones (mouvements sPTP) (S7-1500T) Utilisation du lissage en cas de mouvements de cinématique (S7-1500T) Utilisation de l'instruction Motion Control "MC_TrackConveyorBelt" avec la version technologique V5.0 (S7-1500T)
Remarques sur Motion Control S7-1500
S7-1500, S7-1500T

Alarmes technologiques 900-902

Contrairement au comportement documenté, la valeur pilote reçue est détectée comme invalide en réaction à une alarme pour les alarmes technologiques 900 et 901. L'alarme technologique 902 ne comprend aucune réaction à une alarme.

Les alarmes technologiques 900 et 901 sont signalées dans le tampon de diagnostic.

N° | Réaction | Bit d'erreur | Bit d'alarme | Redémarrage | Tampon de diagnostic | Texte d'alarme
900 | Définir la valeur pilote comme non valide | X2 | - | - | X | Valeurs pilotes non valides.
901 | Définir la valeur pilote comme non valide | X2 | - | - | X | Erreur de transmission de données.
902 | Aucune réaction | - | X2 | - | - | Exactitude de la valeur pilote limitée.

Vous pouvez acquitter une alarme technologique 900 avec une commande "MC_Reset" avec "Restart" = FALSE. Un redémarrage n'est pas nécessaire.

L'alarme technologique 900 est affichée avec le texte d'alarme suivant :

Texte d'alarme | Solution
Valeurs pilotes non valides. | Définissez un temps de tolérance plus élevé (<TO>.Parameter.ToleranceTimeExternalLeadingValueInvalid). Vérifiez la liaison des composants connectés. Assurez-vous que la communication n'est pas perturbée. Assurez-vous que les CPU concernées sont à l'état de fonctionnement MARCHE.

L'alarme technologique 901 est affichée avec le texte d'alarme suivant :

Texte d'alarme |  | Solution
Erreur de transmission de données. |  |
 | Version non valide | Vérifiez la communication.
 | Valeur de départ modulo non valide
 | Longueur modulo non valide
 | Erreur de signe de vie
 | Position non valide | Vérifiez la valeur pilote de l'axe pilote sur l'autre CPU.
 | Vitesse non valide
 | Accélération non valide

Mettre à niveau des projets dans TIA Portal version V16

Une conversion de projets existants est nécessaire en cas de modifications du format d'enregistrement de projets dans la version V16 de TIA Portal. Selon la taille du projet, une conversion peut prendre un certain temps. La durée totale de la conversion peut s'étendre de plusieurs minutes à plus d'une heure.

Comportement du compteur de cycles modulo en cas de référencement avec "MC_Home"

Contrairement au comportement documenté, le compteur de cycles modulo se comporte en cas de référencement relatif direct avec "Mode" = 1, 12 et en cas de référencement du codeur absolu (relatif) avec "Mode" = 6 comme lors du référencement absolu direct avec "Mode" = 0. Les valeurs de comptage des cycles modulo sont modifiées de la manière suivante lors du référencement et du référencement du codeur absolu avec les modes cités :

Action | Description
Référencement du codeur absolu avec "Mode" = 6 | La valeur modulo définie est la distance la plus courte entre la position actuelle et la nouvelle position. Selon la distance, le compteur de cycles modulo peut conserver la même valeur, être incrémenté de 1 ou être décrémenté de 1.
Référencement direct relatif avec "Mode" = 1, 12 | La valeur modulo définie est la distance la plus courte entre la position actuelle et la nouvelle position. Selon la distance, le compteur de cycles modulo peut conserver la même valeur, être incrémenté de 1 ou être décrémenté de 1.

Utilisation du type de données "DX_TEL_SyncOp" en cas de synchronisme inter-API

Pour le synchronisme inter-API, les variables Output et Input sont créées avec le type de données "DX_TEL_SyncOp" aux adresses de début de la zone de transfert. En cas d'impossibilité d'affectation du type de données "DX_TEL_SyncOp", ce dernier était supprimé à la dernière compilation.

Des types de données non utilisés sont supprimés à la compilation. Pour restaurer le type de données "DX_TEL_SyncOp", ajoutez un objet technologique V5.0. L'objet technologique peut être supprimé après l'utilisation du type de données dans la variable API.

Vous pouvez configurer manuellement des temps de retard sur l'axe pilote et sur l'axe asservi virtuel.

Si vous augmentez le temps de retard de l'axe pilote dans les paramètres de la valeur pilote, cela entraîne une baisse du temps d'extrapolation dans le représentant d'axe pilote ou une augmentation du temps d'interpolation de la valeur pilote distribuée dans le représentant d'axe pilote. L'erreur générée lors de l'extrapolation dans les phases d'accélération et de retard de la valeur pilote est alors réduite.

Si vous augmentez le temps de retard du représentant d'axe pilote, cela entraîne une augmentation du temps d'extrapolation ou une baisse du temps d'interpolation.

Calcul de l'écart de traînage

L'écart de traînage est la différence entre la position de consigne et la position réelle par rapport au couplage de l'axe sur l'entraînement. Contrairement au comportement documenté, les temps de transmission de la valeur de consigne de l'automate à l'entraînement et de la valeur réelle de position de l'entraînement à l'automate ne sont pas pris en compte lors du calcul de l'écart de traînage. La valeur de l'écart de traînage n'est donc pas égale à la différence entre la position de consigne figurant dans l'automate et la position réelle.

Performance de la transformation de l'utilisateur avec adaptation de la dynamique (S7-1500T)

Avec la version technologique V5.0, les temps d'exécution du MC-Interpolator [OB92] augmentent en cas de transformation de l'utilisateur. Les temps d'exécution plus importants du MC-Interpolator [OB92] entraînent une augmentation des temps d'exécution de blocs d'organisation de priorité inférieure.

La largeur de bande maximale de la CPU est limitée pour les enregistrements avec la trace de la cinématique (S7-1500T)

En cas de dépassement de la largeur de bande maximale, tous les signaux d'un enregistrement avec la trace de la cinématique ne peuvent pas être enregistrés et évalués.

Tenez compte des limites système de la CPU (16 signaux max.).

Les signaux suivants sont requis pour les différents objets :

Objet | Signaux utilisés
TCP et cinématique (en fonction de la cinématique) | 4-8
TCP (en fonction de la cinématique) | 2-4
OCS 1 (en fonction de la cinématique) | 2-6
OCS 2 (en fonction de la cinématique) | 2-6
OCS 3 (en fonction de la cinématique) | 2-6

Désactivez des signaux actifs sous "Objet technologique > Trace cinématique > Configuration > Enregistrements".

Lissage entre des trajectoires et des mouvements "Point à point" synchrones (mouvements sPTP) (S7-1500T)

Si vous utilisez le lissage d'une trajectoire vers un mouvement sPTP, il se peut que le lissage ne soit pas réalisé ou que le segment de lissage soit réduit de manière significative.

En cas d'utilisation du lissage de trajectoires et de mouvements sPTP, réglez une dynamique de trajectoire la plus élevée possible.

  • À-coup

  • Accélération

Modification de l'override en cas de mouvements "point à point" synchrones (mouvements sPTP) (S7-1500T)

En cas de modification de l'override, l'évolution du mouvement du point de fonctionnement de l'outil (TCP) d'un mouvement sPTP peut être modifiée.

Si le contour du mouvement du TCP doit être conservé, utilisez la cinématique avec une moindre modification de l'override.

Utilisation du lissage en cas de mouvements de cinématique (S7-1500T)

Un lissage peut entraîner une augmentation excessive de la dynamique sur les axes cinématiques.

Utilisation de l'instruction Motion Control "MC_TrackConveyorBelt" avec la version technologique V5.0 (S7-1500T)

L'utilisation de l'instruction Motion Control "MC_TrackConveyorBelt" n'est pas possible avec la version technologique V5.0.


Remarques sur d'autres fonctions technologiques (S7-1500)

Exemples Voir aussi Historique Outils
Paramètres des objets technologiques dans TIA Portal Openness S_USSI dans S7‑1500 Modules PtP avec CM 1243-5 PROFIBUS maître PID_Temp sur la CPU 1500 V1.7
Remarques sur d'autres fonctions technologiques
S7-1500

Paramètres des objets technologiques dans TIA Portal Openness

Vous trouverez une liste des paramètres d'objets technologiques disponibles dans l'information produit "Paramètres d'objets technologiques dans TIA Portal Openness" sur Internet.

S_USSI dans S7‑1500

Tenez compte de ce qui suit si vous utilisez l'instruction S_USSI de la périphérie décentralisée ET 200S 1SI dans un S7‑1500.

Le paramètre ANZ indique également la valeur 0 en cas d'erreur.

Dans le cas où la CPU est commutée sur ARRET par l'instruction S_USSI, vérifiez toutes les possibilités d'erreurs listées dans le paramètre ANZ.

Modules PtP avec CM 1243-5 PROFIBUS maître

Pour l'utilisation de modules PtP CM PtP RS232 BA, CM PtP RS422/485 BA, CM PtP RS232 HF, CM PtP RS422/485 HF et CM PtP avec un CM 1243-5 PROFIBUS maître avec un firmware ≤ V1.3.4, vous devez procéder aux paramétrages suivants dans le DB d'instance des instructions :

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240

PID_Temp sur la CPU 1500 V1.7

Tenez compte de ce qui suit pour l'utilisation de PID_Temp sur une CPU 1500 avec version de firmware V1.7 :

  • La zone morte intégrée à PID_Temp ne doit pas être utilisée sur une CPU 1500 V1.7.

    Ne modifiez pas la valeur par défaut 0.0 des paramètres Retain.CtrlParams.Heat.DeadZone et Retain.CtrlParams.Cool.DeadZone.

  • Si sur un régulateur avec refroidissement et commutation de paramètres PID (Config.ActivateCooling = TRUE, Config.AdvancedCooling = TRUE) activés, la sortie de refroidissement est activée (PidOutputSum < 0.0, OutputCool <> 0.0) tandis qu'une optimisation préalable du refroidissement est démarrée (Mode = 1, Heat.EnableTuning = FALSE, Cool.EnableTuning = TRUE), celle-ci est interrompue avec l'erreur ErrorBits = 16#0040_0000.

    • Utilisez dans ce cas l'optimisation fine du refroidissement (Mode = 2, Heat.EnableTuning = FALSE, Cool.EnableTuning = TRUE)

    ou

    • commutez avant le démarrage de l'optimisation préalable dans le mode manuel avec une valeur manuelle supérieure à 0.0 (Mode = 4, ManualValue ≥ 0.0).

Ces deux restrictions n'existent plus à partir de la version de firmware V1.8.


Recommandations concernant les fonctions technologiques (S7-1200)

Exemples Voir aussi Historique Outils
Appliquer automatiquement les valeurs de l'entraînement ou du codeur lors de la configuration (hors ligne) ErrorID 16#820D Modules PtP avec CM 1243-5 PROFIBUS maître
Recommandations concernant les fonctions technologiques
S7-1200

Appliquer automatiquement les valeurs de l'entraînement ou du codeur lors de la configuration (hors ligne)

En cas de connexion d'un SINAMICS V90 PROFINET via HSP, tous les paramètres de configuration ne sont pas appliqués automatiquement. Désactivez l'option "Appliquer automatiquement les valeurs d'entraînement lors de la configuration (hors ligne)" et appliquez manuellement les paramètres de configuration de l'entraînement et du codeur dans la configuration de l'objet technologique.

ErrorID 16#820D

ErrorID | ErrorInfo | Description | Solution
16#820D |  | L'objet technologique est à l'état Redémarrage
 | 16#0001 | - | Acquitter l'erreur avec l'instruction "MC_Reset" et, le cas échéant, redémarrer la commande

Modules PtP avec CM 1243-5 PROFIBUS maître

Pour l'utilisation de modules PtP CM PtP RS232 BA, CM PtP RS422/485 BA, CM PtP RS232 HF, CM PtP RS422/485 HF et CM PtP avec un CM 1243-5 PROFIBUS maître avec un firmware ≤ V1.3.4, vous devez procéder aux paramétrages suivants dans le DB d'instance des instructions :

  • Send_P2P

    max_record_len = 240

  • Modbus_Master

    Send_P2P.max_record_len = 240

  • Modbus_Slave

    Send_P2P.max_record_len = 240


Recommandations concernant les fonctions technologiques (S7-300, S7-400)

Exemples Voir aussi Historique Outils
Paramétrage du FM x51 et du FM x52 Programmation des FM x50-1, FM x51 et FM x52 Migration IM 174
Recommandations concernant les fonctions technologiques
S7-300, S7-400

Paramétrage du FM x51 et du FM x52

Contrairement aux informations de l'aide en ligne, les valeurs de paramètres déjà saisies ne sont pas converties dans le nouveau système de mesures en cas de changement de système de mesures.

Programmation des FM x50-1, FM x51 et FM x52

Les "Valeurs initiales" indiquées dans l'aide en ligne pour les instructions dans les tables de paramètres correspondent à la "valeur par défaut" dans l'interface utilisateur de la programmation utilisateur.

Migration IM 174

Lors de la migration de projets avec IM 174, le paramétrage de l'IM 174 est réglé sur des valeurs par défaut. L'IM 174 doit être en tous les cas paramétré de nouveau après la migration.