WinCC

Exemples Voir aussi Historique Outils
WinCC

Ce chapitre contient des informations sur les sujets suivants :
  • Notes relatives à la sécurité
  • Protection des données
  • Informations sur l'utilisation
  • Migration
  • Système d'ingénierie
  • Fonctions transversales
  • Compilation et chargement
  • Runtime
  • Pupitres opérateur
  • Options


Notes relatives à la sécurité

Notes relatives à la sécurité Mots de passe Serveurs Web intégrés Communication via Ethernet Utilisation de SSL 3.0 Paramétrages réseau
Notes relatives à la sécurité

Notes relatives à la sécurité

Siemens commercialise des produits et solutions comprenant des fonctions de sécurité industrielle qui contribuent à une exploitation sûre des installations, solutions, machines, équipements et/ou réseaux.

Pour garantir la sécurité des installations, systèmes, machines et réseaux contre les cybermenaces, il est nécessaire d’implémenter (et de préserver) un concept de sécurité industrielle global et moderne. Les produits et solutions de Siemens ne constituent qu’une partie d’un tel concept.

Il incombe au client d'empêcher tout accès non autorisé à ses installations, systèmes, machines et réseaux. Les systèmes, machines et composants doivent uniquement être connectés au réseau d’entreprise ou à Internet si et dans la mesure où c’est nécessaire et si des mesures de protection correspondantes (p. ex. utilisation de pare-feux et segmentation du réseau) ont été prises.

En outre, vous devez tenir compte des recommandations de Siemens concernant les mesures de protection correspondantes. Pour plus d’informations sur la sécurité industrielle, rendez-vous sur

http://www.siemens.com/industrialsecurity

Les produits et solutions Siemens font l’objet de développements continus pour être encore plus sûrs. Siemens vous recommande donc vivement d’effectuer des actualisations dès que les mises à jour correspondantes sont disponibles et de ne toujours utiliser que les versions de produit actuelles. L’utilisation de versions obsolètes ou qui ne sont plus prises en charge peut augmenter le risque de cybermenaces.

Afin d’être informé des mises à jour produit dès qu’elles surviennent, abonnez-vous au flux RSS Siemens Industrial Security sous.

http://www.siemens.com/industrialsecurity

Mots de passe

Différents mots de passe sont définis par défaut dans WinCC. Il convient de modifier ces mots de passe pour des raisons de sécurité.

  • Le mot de passe "100" est défini par défaut pour le Sm@rtServer et pour le serveur Web intégré sur les pupitres opérateur de la version 12. Aucun mot de passe n'est défini par défaut pour les pupitres opérateur à partir de la version 13.

  • Le mot de passe défini par défaut pour l'utilisateur "Administrateur" est "administrator".

Serveurs Web intégrés

Sur un PC, il est possible d'accéder aux pages HTML dans Runtime bien que l'option "Pages HTML" soit désactivée. Du fait de l'installation, ce sont toujours les pages standard du serveur Web qui sont stockées sur le PC. Attribuez un mot de passe administrateur qui empêche l'accès non autorisé aux pages.

Communication via Ethernet

En communication basée sur Ethernet, l'utilisateur final est lui-même responsable de la sécurité de son réseau de données, puisque le fonctionnement n'est pas garanti en cas d'attaques ciblées provoquant la surcharge de l'appareil, par exemple.

Utilisation de SSL 3.0

Pour des raisons de sécurité, l'utilisation du protocole SSL 3.0 sur des Comfort Panel et dans Runtime Advanced n'est pas recommandée. Sur les Comfort Panel, l'utilisation du protocole SSL 3.0 est désactivée par défaut. Si vous souhaitez néanmoins activer l'utilisation de SSL 3.0 aktiveren möchten, sélectionnez-la dans Internet Explorer ou dans "Start Center > Settings" sous „Internet Options > Advanced > Use SSL 3.0“.

Pour RT Advanced, l'utilisation de SSL 3.0 peut être interrompue dans Internet Explorer ou via le panneau de configuration sous „Options Internet > Avancées“ en désactivant l'option „Utiliser SSL 3.0“.

Paramétrages réseau

Les tableaux suivants indiquent pour chaque produit les paramétrages réseau dont vous avez besoin pour analyser la sécurité du réseau et pour configurer les pare-feu externes :

WinCC Professional (sans simulation)
Nom | Numéro de port | Protocole de transport | Sens | Fonction | Description
ALM | 4410* | TCP | Inbound, Outbound | Service de licences | Ce service met à disposition la totalité des fonctions pour les licences logicielles et est utilisé aussi bien par le gestionnaire Automation License Manager que par tous les produits logiciels liés aux licences.
HMI Load | 1033 | TCP | Outbound | HMI Load (RT Basic) | Ce service est utilisé pour transférer des images et des données de configuration sur les Basic Panels.
HMI Load | 2308 | TCP | Outbound | HMI Load (RT Advanced) | Ce service est utilisé pour transférer des images et des données de configuration sur les Panels.
RPC | ** | UDP | Inbound, Outbound | Communication ES client/serveur (CCAgent) | Ce service est utilisé par WinCC Professional et WinCC Runtime Professional.
* Port par défaut pouvant être modifié par la configuration utilisateur ** Port attribué automatiquement

Simulation WinCC pour Basic Panels
Nom | Numéro de port | Protocole de transport | Sens | Fonction | Description
HMI Load | 1033 | TCP | Inbound | HMI Load (RT Basic) | Ce service est utilisé pour transférer des images et des données de configuration sur les Basic Panels.
EtherNet/IP | 44818 | TCP | Outbound | Voie Ethernet/IP | Le protocole Ethernet/IP est utilisé pour les liaisons aux API Allen Bradley.
 | 2222 | UDP | Inbound | Voie Ethernet/IP | Le protocole Ethernet/IP est utilisé pour les liaisons aux API Allen Bradley.
Modbus TCP | 502 | TCP | Outbound | Voie Modbus TCP | Le protocole Modbus TCP est utilisé pour les liaisons aux API Schneider.
RFC 1006 | 102 | TCP | Outbound | Voie S7 | Communication avec le contrôleur S7 via Ethernet / PROFINET
Mitsubishi MC | 5002 | TCP | Outbound | Voie Mitsubishi MC | Le protocole Mitsubishi est utilisé pour les liaisons aux API Mitsubishi.

Simulation WinCC pour Panels et Runtime Advanced
Nom | Numéro de port | Protocole de transport | Sens | Fonction | Description
DCP | --- | Ethernet | Outbound | PROFINET | Le protocole DCP (Discovery and basic Configuration Protocol) est utilisé par PROFINET et fournit les fonctions de base pour la recherche et la configuration d'appareils PROFINET.
LLDP | --- | Ethernet | Inbound, Outbound | PROFINET | Le protocole LLDP (Link Layer Discover Protocol) est utilisé par PROFINET pour la reconnaissance de topologie.
SMTP | 25 | TCP | Outbound | Communication SMTP | Ce service est utilisé par WinCC Runtime Advanced pour envoyer des e-mails.
HTTP | 80* | TCP | Inbound | Serveur HTTP Channel Pages HTML | Le serveur Web est uniquement disponible si le serveur HTTP Channel ou les pages HTML sont disponibles. Le port utilisé peut varier selon les paramétrages automatiquement sélectionnés.
RFC 1006 | 102 | TCP | Outbound | Voie S7 | Communication avec le contrôleur S7 via Ethernet / PROFINET
NTP | 123 | UDP | Outbound | Synchronisation de l'heure | Le protocole NTP (Network Time Protocol) est utilisé dans des réseaux basés sur des adresses IP pour synchroniser l'heure.
SNMP | 161 | UDP | Outbound | PROFINET | La fonctionnalité client SNMP est utilisée par STEP 7 pour lire des informations d'état dans les appareils PROFINET.
HMI Load | 2308 | TCP | Outbound | HMI Load (RT Advanced) | Ce service est utilisé pour transférer des images et des données de configuration sur les Panels.
HTTPS | 443* | TCP | Inbound | Serveur HTTP Channel Pages HTML | Le serveur Web avec protocole HTTPS est uniquement disponible si le serveur HTTP Channel ou les pages HTML sont activées. Le port utilisé peut varier selon les paramétrages automatiquement sélectionnés.
VNC Server | 5900* | TCP | Inbound | Sm@rtServer | Ce service est uniquement disponible si Sm@rtService est activé.
 | 5800* | TCP | Inbound | Sm@rtServer | Ce service est uniquement disponible si Sm@rtService est activé.
VNC Client | 5500 | TCP | Outbound | Sm@rtServer | Ce service est uniquement disponible si Sm@rtService est activé.
* Port par défaut pouvant être modifié par la configuration utilisateur

Simulation WinCC pour Runtime Professional
Nom | Numéro de port | Protocole de transport | Sens | Fonction | Description
RPC | ** | UDP | Inbound, Outbound | Communication ES client/serveur (CCAgent) | Ce service est utilisé par WinCC Professional et WinCC RT Professional.
RPC | ** | UDP | Inbound, Outbound | Communication client/serveur (CCEServer / CCEClient) | Ce service est utilisé par WinCC Runtime Professional.
HTTP | 80 | TCP | Inbound, Outbound | Communication client/serveur (CCEServer / CCEClient) | Ce service est utilisé par WinCC Runtime Professional.
RFC 1006 | 102 | TCP | Outbound | Voie S7 | Communication avec le contrôleur S7 via Ethernet / PROFINET
OPC UA | 4840 | TCP | Inbound | Serveur OPC UA | Ce service est nécessaire à la communication primaire via OPC UA. Il est activé et configuré lors de l'installation.
OPC UA discovery | 52601 | TCP | Inbound | Serveur OPC UA | Ce service fournit des informations sur le serveur OPC installé. Il est installé et configuré par le serveur OPC UA.
DCOM | 135 | TCP | Inbound | Serveur OPC | Ce service fait partie du système d'exploitation Windows. Comme la communication via OPC (DA) se base sur DCOM, ce service est requis pour l'initialisation de liaisons OPC (DA).
DCOM | ** | TCP | Inbound | Serveur OPC | La communication via OPC (DA) se base sur DCOM et utilise des ports non spécifiés et attribués par le système. Vous devez en tenir compte lors de l'utilisation d'OPC (DA) et de la création de règles pour le pare-feu.
HTTP | 80 | TCP | Inbound | Serveur OPC | Ce service est nécessaire à la communication primaire via OPC XML. Il est activé et configuré lors de l'installation.
NetBIOS | 137 | UDP | Inbound | Serveur OPC | Ce service fait partie du système d'exploitation Windows. L'accès à ce service est requis par OPC Scout pour la navigation.
NetBIOS | 138 | UDP | Inbound | Serveur OPC | Ce service fait partie du système d'exploitation Windows. L'accès à ce service est requis par OPC Scout pour la navigation.
SNMP | 161 | UDP | Outbound | Serveur SNMP OPC | Ce service est utilisé par le serveur SNMP OPC pour modifier ou interroger des données sur des lecteurs réseau, par exemple.
SNMP Traps | 162 | UDP | Inbound | Serveur SNMP OPC | Ce service est utilisé par le serveur SNMP OPC pour interroger des événements sur des lecteurs réseau, par exemple.
** Port attribué automatiquement

Protocoles PROFINET pour Panels et Runtime Advanced
Nom | Numéro de port | Protocole de transport | Sens | Fonction | Description
DCP | --- | Ethernet | Outbound | Lifelist, PROFINET Discovery and configuration | Le protocole DCP (Discovery and basic Configuration Protocol) est utilisé par PROFINET et fournit les fonctions de base pour la recherche et la configuration d'appareils PROFINET.
LLDP | --- | Ethernet | Inbound, Outbound | PROFINET Link Layer Discovery protocol | Le protocole LLDP (Link Layer Discover Protocol) est utilisé par PROFINET pour la reconnaissance de topologie.
MRP | --- | Ethernet | Outbound | PROFINET medium redundancy | Le protocole MRP (Medium redundancy protocol) permet la commande de voies de transmission redondantes via une topologie en anneau.
PROFINET IO Data | --- | Ethernet | Inbound, Outbound | PROFINET Cyclic IO data transfer | L'échange de données cyclique est utilisé par les pupitres pour les touches directes et les LED.
ARP | --- | Ethernet | Inbound, Outbound | Name Addres Resolution | Ce protocole est utilisé pour la résolution des noms de réseau et l'attribution des adresses IP.
PROFINET Context Manager | 34964 | UDP | Inbound, Outbound | PROFINET connection less RPC | Le PROFINET Context Manager met à disposition un mappeur de point de terminaison afin de créer une relation d'application (PROFINET AR).

Liaisons de communication pour les Panels et WinCC Runtime Advanced
Nom | Numéro de port | Protocole de transport | Sens | Fonction | Description
Telnet | 23 | TCP | Inbound | Telnet | Ce service peut être utilisé pour la maintenance.
SMTP | 25 | TCP | Outbound | SendEMail | Ce service est utilisé par Windows CE / PC Runtime pour envoyer des e-mails.
HTTP | 80* | TCP | Inbound | Hypertext Transfer Protocol | Le protocole HTTP est utilisé pour la communication avec le serveur web HMI.
RFC 1006 | 102 | TCP | Outbound | Voie S7 | Communication avec le contrôleur S7 via Ethernet / PROFINET.
NTP | 123 | UDP | Outbound | Synchronisation de l'heure | Le protocole NTP (Network Time Protocol) est utilisé dans des réseaux basés sur des adresses IP pour synchroniser l'heure.
DCOM*** | 135 | TCP | Inbound | Serveur OPC | Ce service fait partie du système d'exploitation Microsoft Windows. Communication via OPC (DA) basé sur DCOM. Ce service est donc nécessaire pour initialiser les liaisons OPC (DA).
DCOM*** | ** | TCP | Inbound | Serveur OPC | La communication via OPC (DA) se base sur DCOM et utilise des ports non spécifiés et attribués par le système. Vous devez en tenir compte lors de l'utilisation d'OPC (DA) et de la création de règles pour le pare-feu.
NetBIOS over TCP/IP | 137 | UDP | Outbound | Avec l'utilisation de Remote-Fileshare (partage de fichiers distant) | Connexion/ouverture de session sur un serveur distant
NetBIOS over TCP/IP | 138 | UDP | Outbound | Avec l'utilisation de Remote-Fileshare (partage de fichiers distant) | Connexion/ouverture de session sur un serveur distant
SNMP | 161 | UDP | Outbound | Simple Network Management Protocol | La fonctionnalité client SNMP est utilisée par STEP 7 pour lire des informations d'état dans les appareils PROFINET.
HTTPS | 443* | TCP | Inbound | Secure Hypertext Transfer Protocol | Le protocole HTTP est utilisé pour la communication avec le serveur Web HMI via le protocole Secure Socket Layer (SSL).
Modbus TCP | 502* | TCP | Outbound | Voie Modbus TCP | Le protocole Modbus TCP est utilisé pour les liaisons aux API Schneider.
Mitsubishi MC | 1025* | TCP | Outbound | Voie Mitsubishi MC | Le protocole Mitsubishi est utilisé pour les liaisons aux API Mitsubishi.
Printing | 1032 | TCP | Outbound | Printing | Impression sur le pupitre opérateur (via Ethernet).
HMI Load | 2308 | TCP | Outbound | Transfert | Ce service est utilisé pour transférer des images et des données de configuration sur les Panels. Sur les Comfort Panels, ce service est remplacé à partir de V13 par DeviceManager et SCS. Ce service est utilisé afin de transférer des données de configuration sur WinCC Runtime Advanced.
HMI Load | 50523 | TCP | Outbound | Transfert | Ce port est utilisé si le port 2308 n'est pas disponible. Ce service est utilisé pour transférer des images et des données de configuration sur les Panels. Sur les Comfort Panels, ce service est remplacé à partir de V13 par DeviceManager et SCS. Ce service est utilisé pour transférer des fichiers de configuration sur WinCC Runtime Advanced.
ALM | 4410* | TCP | Inbound, Outbound | Application License Manager | Ce service de RT Advanced met à disposition la totalité des fonctions pour les licences logicielles et est utilisé par le gestionnaire Automation License Manager.
OPC UA | 4870* | TCP | Inbound | Serveur OPC UA | Ce service est nécessaire à la communication via OPC UA.
HMI Load | 5001 | TCP | Outbound | Device Manager | Ce service est utilisé pour transférer des images et Runtime sur les Panels.
HMI Load | 5002 | TCP | Outbound | SCS (System Configuration Server) | Ce service est utilisé pour transférer des fichiers de configuration sur les Panels.
VNC Client | 5500 | TCP | Outbound | Sm@rtServer | Connexion VNC Client
VNC Server | 5800* | TCP | Inbound | Sm@rtServer | Connexion HTTP VNC Server
 | 5900* | TCP | Inbound | Sm@rtServer | Connexion VNC Server
SIMATIC Logon | 16389* | TCP | Outbound | UMAC (User Management and Access Control) | Connexion/ouverture de session sur un serveur distant
Allen Bradley Ethernet/IP | 44818 | TCP | Outbound | Voie Ethernet/IP | Ethernet/le protocole IP est utilisé pour les liaisons aux API Allen Bradley.
Reserved | 49152 ... 65535 | TCP/UDP | Outbound |  | La plage de ports dynamiques p. ex. est utilisée pour la connexion au Remote-Filesharing (partage de fichiers à distance).
* Port par défaut pouvant être modifié par la configuration utilisateur ** Port attribué automatiquement. *** Est uniquement pris en charge par WinCC Runtime Advanced.


Protection des données

Protection des données

Siemens respecte les principes de la protection des données, tout particulièrement les préceptes de la limitation des données (privacy by design). Pour ce produit SIMATIC, cela signifie que : le produit ne traite / enregistre aucune donnée personnelle, uniquement des données techniques fonctionnelles (p. ex. l'horodatage). SI l'utilisateur lie ces données à d'autres données (p. ex. des tableaux de service) ou enregistre des données personnelles sur le même support (p. ex. un disque dur) et crée ainsi une référence à la personne, il doit assurer lui-même le respect des dispositions légales relatives à la protection des données.


Informations sur l'utilisation

Contenu Modification du comportement après la mise à niveau Chemin d'installation Utilisation avec des droits d'utilisateur standard Clavier Virtuel (RT Advanced) Remplacement d'appareil - polices de caractères (RT Professional) Textes en simulation (RT Professional) Rechargement en ligne avec cycles définis par l'utilisateur (RT Professional) Transfert de licence via S7USB Transfert de licence sur un Panel avec des systèmes d'exploitation 64 bits Polices de caractères PostScript Tâches avec déclenchement de variables
Informations sur l'utilisation

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Modification du comportement après la mise à niveau

La nouvelle version de WinCC contient de nouvelles fonctions et des améliorations par rapport à la version précédente. Il est donc possible que des désignations ou des comportements de propriétés et de fonctions soient légèrement différents après la mise à niveau à la nouvelle version. Les propriétés par défaut de nouveaux objets créés peuvent également présenter de modifications par rapport aux versions précédentes.

Ces modifications de comportement peuvent également entraîner des erreurs lors de la compilation du projet.

Chemin d'installation

Si vous avez installé la simulation dans une version antérieure, vous ne pouvez pas modifier le chemin d'installation lors de l'installation.

Utilisation avec des droits d'utilisateur standard

Si vous utilisez Windows 7 avec des droits d'utilisateur standard, le "Contrôle de compte d'utilisateur" (UAC) ne doit pas être désactivé.

Le "Contrôle de compte d'utilisateur" est activé par défaut sous Windows 7.

Vous trouverez de plus amples informations sur le "Contrôle de compte d'utilisateur" dans l'aide en ligne de Windows 7.

Clavier Virtuel (RT Advanced)

Une fois que vous avez ouvert TIA Portal, vous ne pouvez plus appeler le clavier tactile.

Utilisez la commande suivante pour l'appel du clavier tactile dans Windows : "Démarrer > Tous les programmes > Accessoires > Options d'ergonomie > Clavier tactile".

Remplacement d'appareil - polices de caractères (RT Professional)

Si vous avez configuré diverses polices de caractères sur des objets graphiques pour des textes multilingues dans les différentes langues de projet, il est conseillé de vérifier les vues après le remplacement d'un pupitre sur un Runtime basé PC. Il est possible que les polices de caractères configurées aient été modifiées par le remplacement de pupitre.

Textes en simulation (RT Professional)

Si, en simulation, une langue Runtime ne correspondant pas à une langue de produit installée est utilisée, les textes système sont affichés dans une langue de produit installée. Selon le système d'exploitation et les langues de produit installées, il s'agit soit de l'anglais, soit du chinois.

Si vous souhaitez voir les textes en japonais, coréen ou taiwanais en simulation, vous devez d'abord installer WinCC sans la simulation. Installez ensuite WinCC Runtime Professional dans les langues voulues.

Rechargement en ligne avec cycles définis par l'utilisateur (RT Professional)

Si vous avez reconfiguré vos propres cycles dans l'éditeur "Cycles", choisissez la commande "Charger > (Compiler entièrement le) logiciel" lors du chargement du projet. Un rechargement en ligne n'est pas possible.

Transfert de licence via S7USB

Le transfert de licence à un Panel via S7USB n'est possible qu'à partir de WinCC.

Transfert de licence sur un Panel avec des systèmes d'exploitation 64 bits

Si la commande de menu "Editer > Connecter des systèmes cible > Connecter le pupitre opérateur" n'est pas disponible dans Automation License Manager avec un système d'exploitation 64 bits, veuillez ouvrir la ligne de commandes et exécuter, avec les droits d'administrateur, la commande suivante :

"%WINDIR%\system32\RegSvr32.exe" "%CommonProgramFiles%\siemens\AlmPanelPlugin\ALMPanelParam.dll"

Polices de caractères PostScript

Seules les polices de caractère qui contiennent uniquement des données True Type peuvent être utilisées dans TIA Portal. Les polices PostScript et Open-Type qui contiennent des donnés PostScript ne sont pas prises en charge.

Tâches avec déclenchement de variables

Une tâche avec déclenchement de variables est exécutée lorsque la valeur de la variable interne est écrite. Même si la valeur de la variable interne n'est pas modifiée.


Migration

Contenu Migration d'un projet créé avec WinCC V7 Migration d'un projet intégré avec objets ProTool Affichage de la progression
Migration

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Migration d'un projet créé avec WinCC V7

La migration nécessite que ce projet ait été édité avec WinCC V7 Update 3 ou versions supérieures.

Migration d'un projet intégré avec objets ProTool

Si vous migrez un projet WinCC flexible intégré dans STEP 7 et que le message d'erreur "Pack(s) d'option PROTOOL manquant(s) dans STEP 7" apparaît, vous avez installé WinCC flexible 2008 SP3 ou plus récent. Le projet contient en outre encore des objets qui ont été configurés avec ProTool. N'ouvrez pas le projet avec WinCC flexible. Pour migrer le projet, procédez comme suit :

  1. Ouvrez le projet dans SIMATIC Manager.

  2. Dans le menu "Fichier", exécutez la commande "Enregistrer sous".

  3. Dans la boîte de dialogue "Enregistrer le projet sous", activez l'option "Avec réorganisation".

  4. Cliquez sur OK.

  5. Copiez à nouveau le projet vers l'ordinateur d'origine.

  6. Relancez la migration.

Affichage de la progression

Une fois que l'affichage de progression indique 100%, le logiciel effectue encore quelques travaux résiduels comme la fermeture de références. Le logiciel ne peut pas réagir à des entrées dans l'interface utilisateur pendant ce temps.


Système d'ingénierie

Système d'ingénierie

Ce chapitre contient des informations sur les sujets suivants :
  • Vues et objets graphiques
  • Variables et connexions
  • Système d'alarmes et vues des alarmes
  • Fonctions système et scripts
  • Journaux
  • Recettes
  • Gestion des utilisateurs
  • Communication


Vues et objets graphiques

Contenu Objets d'affichage avec changement de pupitre opérateur Regroupement d'objets graphiques De nombreux objets graphiques d'apparence différente Dynamisation des objets groupés (RT Professional) Dynamisation de blocs d'affichage (RT Professional) Nombre de caractères dans les champs de textes, les listes et les textes d'alarme Transparence dans WinCC à partir de V13 Afficher les pages Web API SIMOTION dans le navigateur HTML Différences de représentation entre la configuration et l'affichage sur le pupitre opérateur Vue d'ensemble GRAPH (RT Professional) Actualiser les blocs d'affichage possédant des types de données utilisateur "Temporisations CEI" Contrôles superposés avec animations de visibilité Vue de diagnostic système : Protection d'accès "Accès IHM" Polices dans le titre d'objets de fenêtre (Panels, Runtime Advanced) Types de graphiques invalides dans les listes de graphiques après la mise à niveau (Runtime Professional) Graphiques multilingues dans des blocs d'affichage Modifications du réseau dans l'affichage de code API (RT Professional) Contrôles personnalisés Types de données pris en charge pour des animations
Vues et objets graphiques

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Objets d'affichage avec changement de pupitre opérateur

Si vous mettez à jour la version d'un pupitre opérateur à une nouvelle version, vous devez contrôler les vues présentes dans le projet. En raison de la nouvelle présentation et de l'interface optimisée, il peut arriver, p. ex. pour les champs d'E/S symboliques, que les textes ne soient pas entièrement lisibles et soient masqués par des éléments de commande.

Regroupement d'objets graphiques

Le regroupement d'objets graphiques dans WinCC peut entraîner, en cas d'imbrications profondes, des problèmes de performance de WinCC.

De nombreux objets graphiques d'apparence différente

L'utilisation d'objets graphiques avec de nombreux attributs ayant une apparence différente (p. ex. de nombreux styles différents) peut réduire la performance en Runtime et augmenter l'utilisation de l'espace mémoire. Evitez p. ex. d'utiliser un très grand nombre d'arrondis différents : 0 pixel, 1 pixel, 2 pixels, 3 pixels, etc.

Dynamisation des objets groupés (RT Professional)

En cas d'imbrications multiples de groupements (groupe dans groupe, objet graphique dans groupe, groupe dans objet graphique, ...), seuls les événements du groupe se trouvant le plus à l'extérieur et des objets se trouvant le plus à l'intérieur peuvent être utilisés lors de la dynamisation avec des fonctions système. Les fonctions système configurées dans les événements du groupe inférieur ou du bloc d'affichage inférieur ne sont pas exécutées.

La configuration de l'animation de mouvement simultané d'un groupe d'objets et d'objets dans ce groupe peut se dérouler de manière inattendue durant l'exécution. Vérifiez l'ordre d'exécution dans Runtime et adaptez la configuration le cas échéant.

Dynamisation de blocs d'affichage (RT Professional)

La dynamisation d'une instance de bloc d'affichage avec couplage de type de données utilisateur n'est pas prévue, mais elle peut être réalisée dans certains scénarios à l'aide de variables auxiliaires. Tenez compte à cet effet des remarques dans la FAQ 109766634.

Nombre de caractères dans les champs de textes, les listes et les textes d'alarme

Le nombre de caractères utilisables dans le texte d'un objet graphique n'est pas fixe. Les instructions de commande et le formatage sont pris en compte lors de la saisie de textes et le nombre maximal de caractères se réduit en conséquence.

Transparence dans WinCC à partir de V13

Les graphiques transparents peuvent être représentés en Runtime sans pertes. Cela est valable pour tous les Comfort Panels et WinCC Runtime Advanced à partir de la version 13.0.
Pour utiliser la transparence dans une vue de graphique ou un champ d'E/S graphique, la propriété "Motif de remplissage" doit être paramétrée sur "Transparent" et la propriété "Utiliser couleur transparente" doit être désactivée.

Afficher les pages Web API SIMOTION dans le navigateur HTML

Si les pages Web de l'API SIMOTION ne sont pas affichées correctement dans le navigateur HTML, ajouter "/basic" à l'URL afin d'afficher les pages Web en mode de base.

Différences de représentation entre la configuration et l'affichage sur le pupitre opérateur

La représentation sur le pupitre opérateur du texte configuré dans un objet graphique peut différer de celle configurée. Si vous utilisez les possibilités du dimensionnement automatique dans la configuration, vérifiez la représentation dans chaque langue sur le pupitre opérateur.

Si des textes configurés avec l'option "Adapter les objets au contenu" ne sont pas entièrement affichés, ils sont légèrement réduits sur le pupitre opérateur. Si la représentation des textes est déformée du fait de leur réduction, désactivez l'option "Adapter les objets au contenu" et agrandissez le texte en insérant des espaces supplémentaires. Une autre solution consiste à agrandir l'objet dans la largeur ou à reformuler le texte en l'abrégeant.

Vue d'ensemble GRAPH (RT Professional)

Lors de la mise à niveau vers V14, la signature de la fonction C est modifiée dans l'événement "Cliquer". Le paramètre propertyName présent dans les anciennes versions est supprimé. Les fonctions qui accèdent à ce paramètre sont signalées comme erronées après la mise à niveau.

Actualiser les blocs d'affichage possédant des types de données utilisateur "Temporisations CEI"

L'élément "ST" a été supprimé automatiquement des types de données utilisateur (UDT) d'API définies par l'utilisateur, qui utilisent le type de données "Temporisations CEI". Adaptez les blocs d'affichage contenant ces UDT à une nouvelle version d'UDT ne comportant pas d'élément ST.

Vous trouverez une description détaillée à ce sujet dans la FAQ du SIMATIC Customer Online Support avec l'ID de contribution "109740393" :

Contrôles superposés avec animations de visibilité

La configuration superposée des contrôles basés sur les tables avec animations de visibilité peut causer des problèmes au niveau de la commande tactile des appareils munis du système d'exploitation Windows CE/Embedded Compact.

Vue de diagnostic système : Protection d'accès "Accès IHM"

Lors de l'utilisation du niveau de protection "Accès IHM" conjointement avec l'API SIMATIC S7-1200, un affichage correct des données de diagnostic n'est garanti qu'à partir de la version de firmware 4.1 ou version ultérieure.

Polices dans le titre d'objets de fenêtre (Panels, Runtime Advanced)

La police que vous configurez dans les paramètres du Runtime de l'appareil ne sera pas utilisée dans les titres de fenêtres des alarmes, fenêtres de diagnostic système et titres de boîtes de dialogue.

Types de graphiques invalides dans les listes de graphiques après la mise à niveau (Runtime Professional)

Quand vous mettez votre projet à niveau à la version TIA Portal V16, des erreurs résultant de types de graphiques invalides dans la liste de graphiques et affichées comme avertissements dans la version V14 se produisent lors de la compilation.

Afin d'éviter que des messages d'erreur ne s'affichent lors de la compilation, vous devez corriger le type de graphique dans la liste de graphiques si nécessaire.

Graphiques multilingues dans des blocs d'affichage

Dans un bloc d'affichage, vous insérez un graphique dans un objet graphique. Ce graphique est utilisé dans toutes les langues du projet définies.

Lorsque vous ouvrez le graphique à l'aide de la commande de menu contextuel "Editer", avec l'option "Editer le graphique de manière centrale", le graphique, une fois édité et enregistré dans un éditeur externe (p. ex. MS Paint), est uniquement modifié pour la langue de projet actuellement définie. La modification du graphique correspondant est visible dans tous les objets qui utilisent ce graphique.

Modifications du réseau dans l'affichage de code API (RT Professional)

Dans le message ProDiag en attente, les modifications du réseau sont mises à jour au Runtime dans la vue de code API.

Pour que les modifications du réseau puissent être affichées correctement en termes d'analyse des critères dans la vue de code API, le message doit être de nouveau généré.

Contrôles personnalisés

Il est possible que les "Contrôles personnalisés" ne soient pas correctement représentés dans le système d'ingénierie. Ils sont cependant configurables sans restrictions. Aucune restriction ne s'applique non plus à la représentation et à la commande au Runtime. Si ce contrôle est basé sur la technologie OCX, un passage à .Net est recommandé.

Types de données pris en charge pour des animations

Les types de données autorisés pour les animations dans une vue sont des valeurs entières et booléennes.


Variables et connexions

Contenu Multiplexage de variables (Basic Panels) Variables avec adressage symbolique et type de données "Char Array" (RT Professional) Indication de la longueur pour les variables du type "String" (RT Professional) Variables du type "String" pour les liaisons avec les automates SIMOTION (Panels, RT Advanced) Variables sous "Variable ID de boîtier" (Mobile Panel) Éléments du tableau dans WinCC Utilisation de type de données 64 bits Diagnostic système d'API dans le système R/H en fonctionnement non redondant
Variables et connexions

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Multiplexage de variables (Basic Panels)

Si vous multiplexez une variable avec une variable externe sur un Basic Panel, l'adresse sera lue en Runtime à partir de l'API lors du premier cycle de lecture. C'est seulement au deuxième cycle de lecture que la valeur de l'adresse lue sera disponible.

Variables avec adressage symbolique et type de données "Char Array" (RT Professional)

Les variables avec adressage symbolique et type de données "WString" ne sont pas validées pour la communication de RT Professional et SIMATIC S7-1200 V3.

Indication de la longueur pour les variables du type "String" (RT Professional)

Dans l'éditeur "Variables", l'indication de la longueur pour les variables IHM internes du type "String" n'a aucun effet. Si vous voulez limiter la longueur des variables, par exemple pour un champ de saisie ou un champ de sortie, utilisez des scripts VB ou C.

Variables du type "String" pour les liaisons avec les automates SIMOTION (Panels, RT Advanced)

Pour les automates SIMOTION, la longueur des variables String ne doit pas dépasser 210 caractères.

Il est possible de créer dans le système d'ingénierie une variable String avec plus de 210 caractères. Cependant, la variable concernée n'est pas écrite en Runtime. Un message affiche que la limite de valeur est en dehors de la variable.

Adaptez dans ce cas la longueur de la variable String.

Variables sous "Variable ID de boîtier" (Mobile Panel)

La variable que vous configurez sous "Paramètres Runtime > Général", "Variable ID de boîtier", ne peut être utilisée qu'en mode Lecture seule.

Aucune valeur ne peut être écrite dans cette variable. Toutefois, elle peut être lue, par exemple dans des scripts, ou affichée dans des vues.

Éléments du tableau dans WinCC

Si vous associez une variable IHM à un tableau issu d'un bloc de données STEP 7 ne commençant pas par une limite inférieure de 0, les éléments du tableau dans WinCC sont mappés sur une limite inférieure de 0.

Pour que vous n'ayez pas à vous occuper de savoir s'il s'agit d'indices STEP 7 ou d'indices WinCC lors de l'accès aux différents éléments du tableau, définissez le début des limites inférieures des tableaux sur 0 également dans STEP 7.

Utilisation de type de données 64 bits

En cas d'utilisation de types de données 64 bits, il faut compter avec une légère perte de précision, car ces types de données sont transposés en type de données Double dans le canal IHM. Il peut donc arriver que des entiers comme types de données soient représentés avec une partie décimale après la virgule.

Diagnostic système d'API dans le système R/H en fonctionnement non redondant

Deux API et deux liaisons correspondantes sont configurées dans un système R/H. Lorsque le système R/H n'est pas en fonctionnement redondant, il peut arriver que les affichages de diagnostic système des deux liaisons affichent des icônes d'état de diagnostic différentes pour le même API.


Système d'alarmes et vues des alarmes

Contenu Variables booléennes dans les archives d'alarmes Alarmes API Alarmes de l'API en Runtime (WinCC Professional) Copie de projets avec connexions intégrées
Système d'alarmes et vues des alarmes

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Variables booléennes dans les archives d'alarmes

Les variables du type Bool sont reconnues par les chiffres 0 et -1 dans les archives d'alarmes. Si vous utilisez, dans une archive d'alarmes, une liste de textes commandée par une variable de type Bool, ajoutez à la liste de textes correspondante l'entrée pour la valeur -1.

Alarmes API

Une alarme API est alors visible dans l'éditeur "Alarmes" d'un appareil IHM si un bloc de données d'instance existe aussi pour ce FB.

Alarmes de l'API en Runtime (WinCC Professional)

Si vous mettez à niveau un projet des versions V13 SP1 ou V13 SP2 vers les versions V14, V14 SP1, V15, V15.1, V16, vous devez compiler le projet et le charger dans l'automate et le pupitre opérateur. Les alarmes de l'API seront sinon représentées barrées dans la vue des alarmes en Runtime.

Copie de projets avec connexions intégrées

Lorsque vous copiez les appareils avec leurs connexions intégrées (entre pupitres opérateur et automates) d'un projet vers une bibliothèque globale, et que vous insérez depuis là un nouveau projet, il est possible que les informations relatives aux alarmes de l'API soient perdues sur le pupitre opérateur. Pour éviter cette perte d'informations, copiez d'abord tous les automates, puis seulement tous les pupitres opérateur dans le nouveau projet.


Fonctions système et scripts

Contenu Scripts pour les projets de service (RT Professional) Simulation avec débogueur de script Variables de déclenchement des fonctions personnalisées (RT Professional) Fonctions personnalisées dans les blocs dans les blocs d'affichage Fonctions système de traitement de bits (Mobile Panels et RT Advanced) Attributs qui ne sont plus utilisés (Comfort Panels et dans RT Advanced) Transfert des paramètres aux scripts VB (Panels et RT Advanced) Fournir des vues de courbes sur les fonctions personnalisées Nombre maximal de paramètres (Panels et RT Advanced) Fonction système "AfficherDialogueConnexion" (Panels et RT Advanced)
Debug Err
Fonctions système et scripts

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Scripts pour les projets de service (RT Professional)

Comme aucun utilisateur interactif n'est normalement connecté dans les projets de service, les scripts C et VB peuvent provoquer des problèmes dans les cas suivants p. ex. :

  • Lorsque les scripts requièrent des interactions, comme des entrées.

  • Si les scripts affichent des boîtes de message.

Aucune zone de données commune n'existe pour les scripts C en mode service. Il n'est donc pas possible d'échanger des variables globales C entre "Planificateur de tâche" et "Vues".

Simulation avec débogueur de script

Pour pouvoir démarrer la "Simulation avec débogueur de script” de TIA Portal, la clé de Registre
HKEY_CLASSES_ROOT\CLSID\{834128A2-51F4-11D0-8F20-00805F2CD064}\LocalServer32 doit contenir une entrée "(par défaut)" de type "String" renfermant le chemin complet du débogueur de script par défaut "devenv.exe". Le débogueur peut sans cette clé de Registre être connecté à une simulation déjà en cours d'exécution.

Variables de déclenchement des fonctions personnalisées (RT Professional)

Lorsque vous configurez un type de données utilisateur IHM ou API sur une vue, l'utilisation des éléments du type de données utilisateur comme variable de déclenchement dans les fonctions utilisateur personnalisées, créées ou modifiées, n'est pas possible.

Fonctions personnalisées dans les blocs dans les blocs d'affichage

Lorsque vous voulez accéder aux variables via une fonction définie par l'utilisateur dans un bloc dans un bloc d'affichage, vous ne pouvez pas composer le nom des variables de manière dynamique.

Fonctions système de traitement de bits (Mobile Panels et RT Advanced)

Il n'est pas possible de manipuler des tableaux de bits en raison d'événements. Les fonctions système telles que InvertBit, SetBit, etc. ne doivent pas recevoir d'éléments d'un tableau de bits comme argument.

Attributs qui ne sont plus utilisés (Comfort Panels et dans RT Advanced)

Nombre de nouveaux attributs visuels ont été introduits dans WinCC V13 et un grand nombre d'attributs existants ont été harmonisés.

Suite à la modification des attributs d'objet, il se peut que certains de ces attributs utilisables dans les scripts VB dans les versions antérieures de WinCC, ne soient plus pris en charge dans WinCC V13. Les scripts utilisant des attributs qui ne sont plus pris en charge restent valides mais les appels concernés au sein des scripts ne fonctionnent pas lors de l'exécution. Ces restrictions concernent exclusivement les Comfort Panels et RT Advanced dans la version d'appareil V13.0.

Le tableau suivant affiche les attributs des objets graphiques qui ne sont plus utilisés :

Attribut | Objet graphique
BorderBrightColor3D | Curseur
BorderColor | Champ de texte, champ d'E/S, champ d'E/S symbolique, Champ date/heure
BorderInnerWidth3D | Curseur
BorderOuterWidth3D | Curseur
BorderShadeColor3D | Curseur
BorderStyle3D | Champ de texte, champ d'E/S, bouton, champ d'E/S symbolique, champ d'E/S graphique, champ date/heure, bargraphe, commutateur
BorderWidth | Champ de texte, champ d'E/S symbolique
CenterColor | Instrument à aiguille
DialColor | Instrument à aiguille
EdgeStyle | Champ de texte, champ d'E/S

Transfert des paramètres aux scripts VB (Panels et RT Advanced)

Dans WinCC, vous pouvez définir si les paramètres des scripts VB "ByRef" (adresse du paramètre) ou "ByVal" (valeur du paramètre) seront transférés.

Le transfert de l'adresse du paramètre à l'aide de "ByRef" (Call by Reference) n'est possible que pour les variables internes du script VB. Dans le cas des variable HMI, la valeur du paramètre sera toujours transmise, indépendamment du fait que le paramètre soit défini en tant que „ByRef“ ou „ByVal“.

Fournir des vues de courbes sur les fonctions personnalisées

Lorsqu'avec une fonction VBS vous lisez des valeurs d'une archive pour l'afficher dans une vue de courbes, vous devez veillez à ce que la différence d'horodatage soit supérieure à zéro.

Nombre maximal de paramètres (Panels et RT Advanced)

Le nombre maximal de paramètres d'une fonction globale est 8 pour le type "sub" et 7 pour le type "func".

Fonction système "AfficherDialogueConnexion" (Panels et RT Advanced)

Pour les Panels et Runtime Advanced, la fonction système "AfficherDialogueConnexion" ne doit pas être configurée dans l'événement "Modification de valeur" d'une variable.


Journaux

Contenu Impression de journaux (Panels)
Journaux

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Impression de journaux (Panels)

En fonction de l'imprimante utilisée, les objets placés au bord dans les journaux peuvent être coupés à l'impression.

Assurez-vous que la taille de votre journal est adaptée.


Recettes

Contenu Synchronisation de recette (Basic Panels, Panels, Comfort Panels et RT Advanced)
Recettes

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Synchronisation de recette (Basic Panels, Panels, Comfort Panels et RT Advanced)

En cas d'envoi de valeurs d'enregistrement à la commande, les valeurs ne sont validées que si l'option "Transfert manuel de valeurs isolées modifiées (mode d'apprentissage)" est activée sous "Général > Synchronisation > Paramètres" pour la recette.


Gestion des utilisateurs

Contenu Utilisateur de domaine UMAC
Gestion des utilisateurs

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Utilisateur de domaine UMAC

Seuls des utilisateurs UMAC locaux sont autorisés dans WinCC V16.0, pas les utilisateurs de domaine UMAC.


Communication

Contenu Etablissement de la liaison avec WinCC Runtime Advanced Changement de liaison pour les liaisons non intégrées Interruptions de la liaison pour les automates Mitsubishi Certificats auto-signés (RT Professional) Précision du type de données "DTL" Nombre restreint de liaisons IHM possibles Utilisation de PROFINET IO pour les pupitres opérateur Panel Communication de RT Advanced avec un S7-1200 via le gestionnaire de station (SIMATIC NET) Modification des paramètres IP et du nom d'appareil d'un automate dans le Control Panel du pupitre opérateur (Basic Panels) "Définition de la suite IP (adresse) de l'API dans le Control Panel" pour SIMATIC S7-1200 V1 (Basic Panels) Liaisons via PROFIBUS DP Changement d'une liaison Communication entre Runtime Professional et SIMATIC S7-1200 RT Advanced dans le gestionnaire de station Communication de données brutes dans les projets redondants (RT Professional) Liaisons non intégrées à un contrôleur logiciel SIMATIC S7-1500 (RT Advanced) Zones de transfert pour les modes IO-Device et esclave DP des appareils IHM Détermination des données de diagnostic par appareils IHM Communication PROFIEnergy Nombre de liaisons SmartClient
Communication

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Etablissement de la liaison avec WinCC Runtime Advanced

Veillez à ce que la version d'appareil configurée dans le système d'ingénierie corresponde à la version du Runtime installée, sinon la communication lors du chargement du projet risque de ne pouvoir être établie ou d'être retardée.

Si la version d'appareil ne correspond pas à la version du Runtime installée, vous disposez des options suivantes :

  1. Modifiez dans le système d'ingénierie la version d'appareil configurée.

  2. Installez la version de WinCC Runtime Advanced qui correspond à la version d'appareil configurée.

Changement de liaison pour les liaisons non intégrées

Pour faire passer la communication d'une liaison non intégrée à une autre liaison non intégrée, par ex. de Omron à Mitsubishi, vous devez vous assurer que les types de données des variables sont aussi pris en charge dans la nouvelle liaison.

Interruptions de la liaison pour les automates Mitsubishi

Plusieurs interruptions de la liaison peuvent avoir pour effet que toutes les ressources de liaison de l'automate Mitsubishi soient occupées et qu'il ne soit plus possible d'établir la connexion. Il est recommandé de contrôler ces ressources de liaison dans le programme API de l'automate et également de les valider à nouveau.

Certificats auto-signés (RT Professional)

Les certificats auto-signés ne sont plus pris en charge.

Si le serveur reconnaît un certificat auto-signé, l'authentification a lieu via la clé PSK (clé prépartagée) partagée auparavant. Aucune communication ne s'établit si la clé PSK ne correspond pas entre les partenaires de communication.

Précision du type de données "DTL"

Le type de données "DTL" prend en charge des indications de temps jusqu'aux nanosecondes. Comme les Panels prennent en charge des indications de temps uniquement jusqu'aux millisecondes, les restrictions suivantes sont valables en cas d'utilisation dans les pointeurs de zone :

  • Pointeur de zone "Date/heure"
    Lors de la transmission des indications de temps d'un Panel vers l'automate, la plus petite unité de temps est 1 milliseconde. La plage de valeurs des microsecondes aux nanosecondes du type de données "DTL" est remplie de zéros.

  • Pointeur de zone "Date/heure de l'automate"
    Lors de la transmission des indications de temps d'un automate vers un Panel, la plage des microsecondes aux nanosecondes n'est pas prise en compte. Sur le Panel, l'indication de temps est traitée jusqu'aux millisecondes comprises.

Nombre restreint de liaisons IHM possibles

Lors de la compilation d'un appareil, un message d'erreur signale que la configuration de la liaison IHM dans l'éditeur "Pupitres & réseaux" est invalide. La cause de ce message peut être un dépassement du nombre maximal de liaisons possibles du pupitre IHM ou de l'API.

Vérifiez le nombre maximal de liaisons possibles. Veuillez consulter à ce sujet les manuels des appareils que vous utilisez.

Utilisation de PROFINET IO pour les pupitres opérateur Panel

Si vous utilisez PROFINET IO pour relier les touches directes et les LED des pupitres opérateur à l'automate, vous pouvez définir un décalage pour la plage d'adresses des entrées et des sorties lors de la configuration dans HW Config.

Si vous utilisez une CPU de la série 400 prenant en charge PROFINET IO avec l'un des pupitres opérateur mentionnés ci-dessous, la restriction suivante s'applique :

Le décalage pour le début de la plage d'adresses des entrées ne doit pas être plus grand que celui pour le début de la plage d'adresses des sorties.

La restriction s'applique aux pupitres opérateur suivants :

  • Mobile Panel 177

Pour configurer les paramètres d'adresse, ouvrez l'automate avec la CPU de la série 400 dans HW Config. Sélectionnez dans la fenêtre de station de HW Config le pupitre opérateur relié via PROFINET IO. Un tableau des propriétés du pupitre opérateur apparaît dans la vue de détails en bas de la fenêtre de station. Sélectionnez dans le tableau la ligne avec les adresses du pupitre opérateur et ouvrez les propriétés de l'objet via le menu contextuel.

Dans la boîte de dialogue "Propriétés de l'objet", activez l'onglet "Adresses". Configurez le décalage pour les entrées sous "Entrées > Début". Configurez le décalage pour les sorties sous "Sorties > Début".

Communication de RT Advanced avec un S7-1200 via le gestionnaire de station (SIMATIC NET)

Les restrictions suivantes s'appliquent au PC pour la communication d'un SIMATIC S7-1200 avec un PC sur lequel est installé WinCC RT Advanced via un routeur :

  • Windows 7 : uniquement si SIMATIC NET 8.1 est installé

Ces restrictions sont également valables si vous utilisez le gestionnaire de station. Les liaisons sont toujours traitées à l'aide du gestionnaire de station de Runtime Advanced comme des liaisons routées.

Modification des paramètres IP et du nom d'appareil d'un automate dans le Control Panel du pupitre opérateur (Basic Panels)

Le Control Panel est ouvert dans le menu "Service and Commissoning > IP-Adaptation" du pupitre opérateur. Si vous voulez modifier les paramètres IP et le nom d'appareil d'un automate, vous devez prendre en compte le point suivant :

Dans le système d'ingénierie, vous avez activé au préalable l'option suivante dans la fenêtre d'inspection de l'automate sous "Propriétés > Général > Interface PROFINET > Adresses Ethernet" :

  • "Dériver l'adresse IP d'une autre source"

  • "Dériver le nom d'appareil PROFINET d'une autre source"

"Définition de la suite IP (adresse) de l'API dans le Control Panel" pour SIMATIC S7-1200 V1 (Basic Panels)

La fonction "Définition de la suite IP (adresse) de l'API dans le Control Panel" n'est pas validée pour les automates suivants :

  • SIMATIC S7-1200 V1

Liaisons via PROFIBUS DP

Si une liaison via PROFIBUS DP est interrompue, puis rétablie entre un automate et un pupitre opérateur, toutes les autres liaisons PROFIBUS DP sont interrompues puis rétablies de manière sporadique

Mettez l'abonné coupé hors tension avant de le reconnecter.

Changement d'une liaison

En cas de changement de la liaison entre un pupitre opérateur et un automate SIMATIC S7-300/400 à un automate SIMATIC S7-1500 ou SIMATIC S7-1200, une interruption de la liaison peut se produire.

Tenez compte des paramétrages suivants pour les automates SIMATIC S7-1500 ou SIMATIC S7-1200 :

  • Adressage absolu des variables

  • L'option "Désactiver la communication PUT-GET" doit être sélectionnée

  • Le niveau de protection "Protection complète" ne doit pas être configuré

Communication entre Runtime Professional et SIMATIC S7-1200

En mode productif, la communication entre WinCC Runtime Professional et SIMATIC S7-1200 est uniquement validée pour les systèmes monopostes.

RT Advanced dans le gestionnaire de station

Si RT Advanced et WinAC RTX utilisent le même processeur de communication d'un PC, la communication IHM vers SIMATIC S7-1200 et SIMATIC S7-1500 n'est pas possible.

Communication de données brutes dans les projets redondants (RT Professional)

Simatic.NET, les Named Connections et divers blocs de communication, p. ex. BSEND/BRCV, peuvent uniquement être utilisés de manière restreinte lorsque la station PC est configurée avec redondance, car les paramètres de connexion du serveur partenaire redondant ne peuvent pas être configurés.

Liaisons non intégrées à un contrôleur logiciel SIMATIC S7-1500 (RT Advanced)

Une liaison non intégrée entre un appareil IHM et un contrôleur logiciel SIMATIC S7-1500 n'est pas prise en charge dans WinCC.

Zones de transfert pour les modes IO-Device et esclave DP des appareils IHM

Si vous avez activé le mode "IO-Device" ou "esclave DP" pour des pupitres opérateur IHM, aucune zone de transfert ne doit être ajoutée ou supprimée dans les propriétés du pupitre opérateur. Si vous avez ajouté ou supprimé une zone de transfert par inadvertance, supprimez et reconnectez le contrôleur.

Détermination des données de diagnostic par appareils IHM

Contrairement à la description des icônes de diagnostic pour les modules et appareils dans le système d'information, l'icône suivante correspond à la signification donnée ci-après pour les appareils IHM :

Icône | Signification
 | Aucune donnée de diagnostic disponible.

Communication PROFIEnergy

Pour configurer la communication PROFIEnergy, contactez le support client.

Nombre de liaisons SmartClient

Même si les Basic Panel autorisent un nombre illimité de liaisons SmartClient, il est recommandé de configurer au maximum deux liaisons. Chaque liaison supplémentaire a une influence sur la performance.


Fonctions transversales

Contenu Utiliser un diagnostic système dans des appareils Proxy Initialiser un appareil Proxy avec des données issues d'un projet de la version précédente Importation et exportation des textes de bibliothèque
Fonctions transversales

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Utiliser un diagnostic système dans des appareils Proxy

Pour pouvoir utiliser la fonction de diagnostic système dans un appareil Proxy IPE, par ex. un affichage du diagnostic système, insérez les alarmes API comme contenu d'un appareil Proxy.

Initialiser un appareil Proxy avec des données issues d'un projet de la version précédente

Dans un projet de la version du Service Pack, il est impossible d'initialiser un appareil Proxy avec des données issues d'un projet de la version complète correspondante.
Faites une mise à niveau du projet source vers la version du Service Pack, afin de pouvoir initialiser l'appareil Proxy du projet cible avec des données issues du projet source.

Importation et exportation des textes de bibliothèque

Les objets suivants ne sont pas pris en charge lors de l'importation et l'exportation des textes de bibliothèque

  • Importation : Recettes, éléments de recette, enregistrements de recette, alarmes IHM, entrées de listes de textes, vues, protocoles.

  • Exportation : Entrées de listes de textes, vues, protocoles.

  • Importation et exportation des types de bibliothèque "Vue".


Compilation et chargement

Contenu Compilation et chargement Vérification des paramètres d'adresse Message d'erreur lors du chargement de données sur l'API Comfort Panels à partir de la version d'appareil 13.0 : Sécurité des données lors du chargement de projets Affichage de caractères dans les alarmes de transfert Réduction de la taille du projet
Microsoft KB3083806
Compilation et chargement

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Compilation et chargement

Quand des erreurs ou des avertissements surviennent lors de la compilation, compilez le projet dans son intégralité en vous servant de la commande "Compiler > Logiciel (tout compiler)" dans le menu contextuel du pupitre opérateur.

Avant de passer en mode de production avec votre projet, compilez le projet dans son intégralité via la commande "Compiler > Logiciel (tout compiler)" dans le menu contextuel du pupitre opérateur.

Si vous utilisez, dans votre projet, des variables IHM qui sont associées à des variables API, compilez aussi tous les blocs modifiés avant le chargement dans le pupitre opérateur avec la commande "Compiler > Logiciel" dans le menu contextuel.

Vérification des paramètres d'adresse

Lorsque vous compilez un pupitre opérateur dans la navigation du projet au moyen de la commande "Compiler > Matériel et logiciel (uniquement modification)" du menu contextuel, les paramètres d'adresse du pupitre opérateur, tels que l'adresse IP par exemple, ne sont pas vérifiés. Pour être sûr que les paramètres d'adresse sont également vérifiés, il faut compiler le pupitre opérateur au moyen du bouton "Compiler" dans la barre d'outils de l'éditeur "Pupitres & Réseaux".

Message d'erreur lors du chargement de données sur l'API

Un Panel et un API sont connectés et communiquent l'un avec l'autre.

Si, pendant le chargement de données sur l'API, vous accédez à une variable depuis le Panel, un message d'erreur est généré sur le Panel.

Comfort Panels à partir de la version d'appareil 13.0 : Sécurité des données lors du chargement de projets

Sur les Comfort Panels en version d'appareil 13.0 ou supérieure, WinCC garantit qu'aucune donnée n'est perdue lorsque la transmission est interrompue et empêche la suppression des données présentes sur le pupitre opérateur avant que la transmission ne soit complète.

Affichage de caractères dans les alarmes de transfert

Si lors du transfert à des pupitres opérateur de version V12 ou antérieure, les caractères dans les alarmes de transfert ne sont pas correctement représentés, vérifiez les paramètres régionaux dans Windows. Réglez la langue correspondante sous "Langue pour les programmes non Unicode".

Réduction de la taille du projet

Lors de la compilation de votre pupitre opérateur, un message vous informe que la taille de votre projet atteint les limites du système du pupitre opérateur en question. Dans ce cas, la compilation totale du logiciel peut réduire la taille de votre projet. Pour ce faire, exécutez la commande "Compiler > Logiciel (compilation complète)".


Runtime

Runtime

Ce chapitre contient des informations sur les sujets suivants :
  • Précisions sur le fonctionnement dans Runtime
  • Remarques sur le fonctionnement des Panels au Runtime
  • Remarques sur le fonctionnement de Runtime Advanced
  • Remarques sur le fonctionnement de Runtime Professional
  • Remarques sur le fonctionnement de Runtime Unified


Précisions sur le fonctionnement dans Runtime

Contenu Mise au point sur Runtime Choix de la langue - clavier virtuel Valeurs de variable dépassant la longueur maximale Textes de message vides Durée de l'initialisation des archives (Panels, RT Advanced) Les archives importantes ralentissent l'arrêt du Runtime (Basic Panels 2nd Generation) Réaction lente de SmartServer Quitte l'économiseur d'écran sur le Sm@rtServer Eviter les fichiers endommagés en cas de coupure de courant Polices variables sur des pupitres opérateur
Précisions sur le fonctionnement dans Runtime

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Mise au point sur Runtime

Si vous utilisez dans un pupitre opérateur avec la version d'appareil 12.0.0 ou inférieure une combinaison de couleur de surbrillance et couleur de bordure peu contrastée, il est possible que la surbrillance ne soit plus identifiable consécutivement à un changement de la version d'appareil dans TIA Portal au runtime. Modifiez l'une des deux couleurs.

Choix de la langue - clavier virtuel

L'apparence du clavier virtuel ne change pas lorsque vous passez à une langue du Runtime qui n'a pas été installée dans Windows pour le clavier virtuel.

Dans ce cas, le paramétrage de la langue du clavier reste dans la dernière langue de paramétrage valide ou la langue de paramétrage par défaut de l'apparence de clavier est utilisée.

Valeurs de variable dépassant la longueur maximale

Vous saisissez une chaîne de caractères pour variable String dans un champ d'E/S. Quand la suite de caractères dépasse la longueur configurée pour la variable, la chaîne de caractères est tronquée à la longueur configurée.

Textes de message vides

Runtime est en cours avec un projet. Le projet est enregistré sur un lecteur réseau.

En cas d'interruptions avec le lecteur réseau, il peut arriver que Runtime tente de charger des textes de message du lecteur réseau.

Si la liaison est coupée, la fenêtre d'alarme ou la vue des alarmes reste vide.

Pour éviter ce comportement, copiez le projet sur un lecteur local avant de démarrer le projet dans Runtime.

Durée de l'initialisation des archives (Panels, RT Advanced)

L'initialisation des archives peut durer jusqu'à 5 minutes sur certains supports de mémoire. Le succès de l'initialisation est confirmé par une alarme système, aussitôt cette dernière terminée. En l'absence éventuelle d'un support de mémoire pour l'archivage, l'affichage du message système au démarrage du Runtime peut également prendre jusqu'à 5 minutes.

Les archives importantes ralentissent l'arrêt du Runtime (Basic Panels 2nd Generation)

Lors de l'utilisation d'archives de très grande taille, l'arrêt du Runtime peut prendre plus de temps. Utilisez des archives segmentées comme alternative aux archives cycliques de grande taille.

Réaction lente de SmartServer

Sous Windows 7, les programmes suivants peuvent parfois démarrer et réagir avec lenteur :

  • HMI TouchInputPC

  • SmartServer : Combinaison de touches <Ctrl+Alt+Suppr> pour la boîte de dialogue de connexion

Le retard est dû au contrôle du certificat Internet sur rappel.

Solution :

Vous trouvez sur le DVD produit sous :
Support\Windows\CRL_Check ou CD_RT\ Support\Windows7\CRL_Check\
les fichiers suivants :

  • DisableCRLCheck_LocalSystem.cmd

  • DisableCRLCheck_CurrentUser.cmd

  1. Exécutez le fichier "DisableCRLCheck_LocalSystem.cmd" avec les droits d'administrateur. Appelez la commande "Run as administrator" dans le menu contextuel du fichier.

  2. Redémarrez l'ordinateur.

Si le problème persiste, procédez comme suit :

  1. Effectuez un double-clic sur le fichier et exécutez le fichier "DisableCRLCheck_CurrentUser.cmd" avec les droits d'utilisateur.

  2. Redémarrez l'ordinateur.

    Remarque

    Le contrôle du certificat sur rappel est désactivé pour l'utilisateur ou pour le PC. Pour restaurer l'état initial, exécutez les fichiers suivants :

    • RestoreDefaults_LocalSystem.cmd

    • RestoreDefaults_CurrentUser.cmd

    Vous trouverez ces fichiers sur le DVD de produit, dans les répertoires suivants :

    • Support\Windows7\CRL_Check ou CD_RT\Support\Windows7\CRL_Check\

Quitte l'économiseur d'écran sur le Sm@rtServer

Lorsque l'économiseur d'écran du pupitre opérateur du Sm@rtServer est actif, vous avez besoin d'un accès en écriture à la page Sm@rtClient pour arrêter économiseur d'écran du pupitre opérateur du serveur.

Eviter les fichiers endommagés en cas de coupure de courant

Si une coupure de courant se produit pour les systèmes Windows pendant que le système WinCC est activé, des fichiers peuvent être endommagés et détruits. Le fonctionnement avec le système de fichiers NTFS offre davantage de sécurité.

Seule l'utilisation d'une alimentation sans interruption (UPS) garantit un fonctionnement continu sécurisé.

Polices variables sur des pupitres opérateur

Windows 10 prend en charge les polices variables ("OpenType Font Variations") depuis la version 1709. Dans le système d'ingénierie, vous pouvez également utiliser les variantes d'une police de caractères variable. La représentation effective au Runtime dépend du pupitre opérateur et des conditions d'installation :

  • Basic Panels, Comfort Panels : les polices variables ne sont pas prises en charge. La variante de base est toujours affichée.

  • Runtime Advanced, Runtime Professional : les polices variables sont prises en charge si au moins Windows 10 version 1709 est utilisé comme système d'exploitation et si la police est installée avec des droits d'administrateur.


Remarques sur le fonctionnement des Panels au Runtime

Contenu Utilisation de la molette de la souris au Runtime Sauvegarde sur la carte mémoire de l'API (Basic Panels) Panel Data Storage et S7-1500F (Basic Panels) Fonction "Panel Data Storage" (Basic Panels) Polices avec l'extension de fichier ".ttx" Transfert de données de masse via USB Modification de l'adresse IP et du nom d'appareil des Panels
Remarques sur le fonctionnement des Panels au Runtime

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Utilisation de la molette de la souris au Runtime

L'utilisation de la molette de la souris au Runtime n'est prise en charge sur aucun Panel.

Sauvegarde sur la carte mémoire de l'API (Basic Panels)

Vous créez le fichier de sauvegarde "A.psb" sur la carte mémoire de l'API. Une erreur se produit lors de la création de la sauvegarde, p. ex. une rupture de liaison.
Un fichier erroné est alors généré sur la carte mémoire de l'API. Un tel fichier contient le préfixe "~$".
Supprimez le fichier ayant le préfixe "~$", si vous voulez enregistrer à nouveau une sauvegarde sous le même nom "A.psb".

Panel Data Storage et S7-1500F (Basic Panels)

La fonction "Panel Data Storage" PDS ne peut pas être utilisée en combinaison avec le S7-1500F sur les Basic Panels si le mot de passe pour le niveau de protection "Full access incl. fail-safe" n'est pas employé.

Fonction "Panel Data Storage" (Basic Panels)

La fonction "Panel Data Storage" (PDS) disponible sur les Basic Panels n'est prise en charge que par SIMATIC S7-1200 à partir de la version de firmware V4.0 et par SIMATIC S7-1500. Pour la fonction PDS, le Panel doit être connecté directement à la CPU ; une connexion via le CP n'est pas autorisée.

Polices avec l'extension de fichier ".ttx"

Les polices possédant l'extension de fichier ".ttx" sont disponibles sur tous les Panel dans Runtime Advanced et peuvent être affichées correctement sur tous les appareils, par ex. la police "WinCC_flexible_smart".

Transfert de données de masse via USB

Lorsque vous installez Windows 10 sur le PC de configuration, le canal de transfert "USB" n'est pas disponible.

Cette restriction s'applique aux appareils et outils suivants :

  • Basic Panels : KP300 Basic, KP400 Basic, TP1500 Basic

  • Mobile Panels : gammes 170 et 270

  • Système d'ingénierie WinCC

  • Outil de maintenance "ProSave"

Remarque

Le canal de transfert "USB" reste disponible lorsque Windows 7 est installé sur le PC de configuration.

Solution

Utilisez d'autres canaux de transfert pour transférer les données de projet, par exemple le canal "Industrial Ethernet" ou "PROFIBUS DP".

Modification de l'adresse IP et du nom d'appareil des Panels

Il est possible de modifier l'adresse IP ou le nom d'appareil en Runtime sur les Comfort Panels.

Il n'est pas possible de modifier l'adresse IP ou le nom d'appareil en Runtime sur les Basic Panels.


Remarques sur le fonctionnement de Runtime Advanced

Contenu Démarrage de Runtime Autorisation pour le démarrage de Runtime Advanced Economiseur d'écran des ordinateurs fonctionnant sous Windows 10 Windows 10 en mode tablette .Net Controls au Runtime Désactiver la vérification automatique des mises à jour logicielles Accès aux variables tableau via OPC
Remarques sur le fonctionnement de Runtime Advanced

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Démarrage de Runtime

Seul WinCC Runtime V16 peut être démarré du système d'ingénierie. Les autres versions de WinCC Runtime peuvent seulement être simulées.

Autorisation pour le démarrage de Runtime Advanced

Sur un ordinateur avec système d'exploitation Windows 7, WinCC Runtime Advanced peut être démarré uniquement si l'utilisateur ayant démarré Runtime est affecté au groupe "Siemens TIA Engineer" et possède les droits correspondants.

Economiseur d'écran des ordinateurs fonctionnant sous Windows 10

Un économiseur d'écran actif d'un ordinateur sous Windows 10 ne peut plus être quitté suite à l'apparition d'un message de la classe "Erreur".

Windows 10 en mode tablette

Il n'est pas conseillé d'utiliser Windows 10 en mode tablette.

Si vous utilisez des applications comme Runtime Advanced, Sinumerik Operate, etc. sous Windows 10 en mode tablette, la fenêtre de ces applications est réduite après le démarrage.

.Net Controls au Runtime

Si vous avez intégré dans votre projet un .Net-Control en tant que ".Net-Control spécifique", vous devez copier les fichiers appartenant à ces contrôles dans le répertoire d'installation de WinCC Runtime, p. ex. "C:\ProgramFiles\Siemens\Automation\WinCC RT Advanced". Dans le cas contraire, le contrôle ne peut pas être chargé au Runtime.

Désactiver la vérification automatique des mises à jour logicielles

Si le système d'ingénierie est installé sur un PC avec Runtime, l'opérateur reçoit des messages sur les mises à jour logicielles. Pour que le système fonctionne de manière stable sur un système multiposte, la même version logicielle doit être installée sur tous les ordinateurs.

Il est possible de désactiver la vérification automatique des mises à jour logicielles et ainsi d'améliorer la performance.

Vous désactivez la vérification automatique des mises à jour logicielles sous "Paramètres > Général > Mises à jour logicielles", en décochant la case "Rechercher des mises à jour quotidiennement".

Accès aux variables tableau via OPC

Si vous utilisez WinCC Runtime Advanced comme serveur OPC-UA, la lecture de variables tableau n'est prise en charge que si le paramètre "OPC UA Server Array index range access" est activé.

L'écriture de variables tableau n'est possible que si le client OPC UA prend en charge le paramètre "Write array elements without IndexRange".


Remarques sur le fonctionnement de Runtime Professional

Contenu Autorisations utilisateur dans le système d'exploitation verrouiller les raccourcis clavier Barres d'outils non fixées Défaillance de la connexion entre le serveur et le client Défaillance de la connexion entre le serveur et le client Démarrage de WinCC Runtime Professional Réglage des services pour le serveur SQL "Signalisation d'erreurs système" dans WinCC Runtime Professional Interfaces WinCC et système d'exploitation 64 bits Graphiques dynamiques dans WinCCViewer RT Runtime Professional : chargement d'un projet sans liaison au PC de configuration Liaison avec S7-1200 dans le diagnostic système Désactiver la vérification automatique des mises à jour logicielles Restriction de la capacité de chargement delta en ligne. Objets graphiques comme PDF dans les journaux Projets au Runtime après la mise à jour Windows 10 Espace mémoire requis pour les archives
Remarques sur le fonctionnement de Runtime Professional

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Autorisations utilisateur dans le système d'exploitation

  1. Tous les utilisateurs doivent faire partie du groupe d'utilisateurs "SIMATIC HMI". Cela s'applique également aux utilisateurs qui souhaitent ouvrir les projets WinCC à distance.

  2. Le dossier d'archivage des projets doit disposer des autorisations NTFS "SIMATIC HMI" avec accès complet et "SIMATIC HMI Viewer" avec droits de lecture. Les autorisations doivent être héritées pour tous les objets subordonnés.

verrouiller les raccourcis clavier

Si vous voulez verrouiller des raccourcis clavier sous Windows 7, vous devez adapter les stratégies de groupe dans la gestion du système d'exploitation.

Vous trouverez une description détaillée à ce sujet dans la FAQ du SIMATIC Customer Online Support avec l'ID de contribution "44027453" :

Internet : WinCC FAQ 44027453

Barres d'outils non fixées

Si vous utilisez l'option "Toujours au premier plan" pour la barre des tâches Windows, il se peut que des barres d'outils non fixées disparaissent derrière la barre des tâches Windows en runtime. Pour voir à nouveau les barres d'outils, procédez comme suit :

  1. Sélectionnez la commande "Propriétés" dans le menu contextuel.

  2. Désactivez "Toujours laisser la barre des tâches au premier plan".

Défaillance de la connexion entre le serveur et le client

Si la connexion entre le serveur et le client est défaillante, vérifiez les paramètres de l'interface PG/PC. TCP/IP(Auto) ne doit pas être utilisé pour le "Paramétrage d'interface utilisé". A la place, utilisez des adresses IP fixes.

Défaillance de la connexion entre le serveur et le client

Si l'ordinateur avec le système d'ingénierie est employé simultanément comme serveur et si un client est dans l'incapacité d'établir la connexion au serveur, vous devez vérifier les autorisations définies sur le serveur.

  1. Quittez Runtime sur le serveur.

  2. Dans le menu contextuel de l'environnement réseau sur le bureau du serveur, sélectionnez la commande "Rechercher un ordinateur...".

  3. Entrez le nom du serveur comme ordinateur à rechercher.

  4. Ouvrez l'ordinateur trouvé afin d'identifier les répertoires partagés.

  5. Supprimez tous les partages commençant par "WinCC_Project_HMI". Pour plus d'informations, veuillez vous référer à la documentation du système d'exploitation.

Le comportement erroné est dû à l'utilisation de la commande "Enregistrer sous.." conjointement au lancement du Runtime de ce nouveau projet. Par mesure de sécurité, vous pouvez créer des copies des projets à l'aide de la commande "Enregistrer sous...". Mais vous devez cependant continuer à travailler avec le projet d'origine.

Démarrage de WinCC Runtime Professional

Si le système d'ingénierie et Runtime sont exécutés sur un seul ordinateur, il est recommandé de lancer et de fermer Runtime ou la simulation d'un projet ouvert dans le système d'ingénierie uniquement au moyen du portail TIA. Il est déconseillé d'utiliser d'autres possibilités, p. ex. l'icône dans la zone info de la barre des tâches.

Lors de la configuration de l'autodémarrage chez le client, la saisie de l'identifiant et du mot de passe est impérativement obligatoire pour chaque projet de serveur inscrit. Afin de pouvoir attribuer un identifiant à chaque serveur, il est nécessaire de confirmer la saisie de chaque chemin de projet avec le bouton "Appliquer". Pour les projets redondants ou alternatifs, cela implique de saisir deux fois l'identifiant et le mot de passe.

Réglage des services pour le serveur SQL

Pour assurer la fonctionnalité complète du serveur SQL pour WinCC et WinCC Runtime, vous devez vérifier les paramètres du serveur SQL.

  1. Lancez "Programme > Microsoft SQL Server 2014 > Configuration Tools > SQL Server 2014 Configuration Manager" dans le menu Démarrer.

  2. Cliquez dans l'arborescence sur "SQL Server Services".

  3. Contrôlez les services "SQL Server (WinCC)", "SQL Server (WINCCPLUSMIG)" et "SQL Server Browser".
    "Automatic" doit être entré pour "Start Mode".
    Pour "Log On As", "LocalSystem" doit être entré pour "SQL Server (WinCC)".
    Pour "SQL Server Browser", "LOCALSERVICE" doit être entré.
    Modifiez les paramètres le cas échéant.

  4. Cliquez dans l'arborescence sur "SQL Server Network Configuration".

  5. Cliquez sur "Protocols for WinCC".

  6. Vérifiez le protocole "TCP/IP". "Enabled" doit être entré pour "Status". Modifiez les paramètres le cas échéant.

"Signalisation d'erreurs système" dans WinCC Runtime Professional

La fonctionnalité "Signalisation d'erreurs système" est limitée dans WinCC Runtime Professional en liaison avec un S7-300 ou S7-400. Une alarme uniquement est affichée dans la vue des alarmes pour un type d'alarme. Les alarmes concernant d'autres erreurs de même type de diagnostic ne sont pas affichées.

Interfaces WinCC et système d'exploitation 64 bits

Les interfaces ouvertes de WinCC Runtime Professional n'offrent pas de prise en charge native 64 bits. Cela concerne surtout Runtime API, VBS un le fournisseur OLE DB de WinCC. Pour pouvoir utiliser les interfaces de WinCC avec un système d'exploitation 64 bits, vous devez tenir compte des points suivants :
- Vous ne pouvez pas lancer les scripts VB par un simple double-clic. Vous devez utiliser explicitement la version 32 bits sous "syswow64\wscript.exe".
- Les applications .NET qui utilisent les API de WinCC doivent être explicitement compilées comme applications 32 bits. Pas avec "AnyCPU", mais avec "x86".
- Les applications C++ ne doivent pas être compilées comme applications 64 bits.

Graphiques dynamiques dans WinCCViewer RT

Si vous utilisez des graphiques dynamiques d'un recueil de graphiques, p. ex. des graphiques reliés à des scripts, ces graphiques ne sont alors pas mis à jour dans WinCCViewer RT.

Sélectionnez l'option "Défini par l'utilisateur" sous "Paramètres Runtime > Paramètres des graphiques".

Runtime Professional : chargement d'un projet sans liaison au PC de configuration

Avant de démarrer le chargement d'un projet sur la station opérateur, enregistrez les données telles que "Gestion des utilisateurs" et "Données de recette".

  1. Par défaut, les données de la gestion des utilisateurs sont écrasées.

    Configurez par conséquent deux boutons dans votre projet pour l'exportation ou l'importation de la gestion des utilisateurs avec la fonction système "ExporterGestionDesUtilisateurs". L'exportation des données est uniquement requise si vous avez procédé à des modifications dans la vue des utilisateurs au runtime.

  2. Lors du chargement du projet, vous indiquez dans la boîte de dialogue "Aperçu du chargement" si les données de recette seront écrasées.

    Vous pouvez enregistrer les données de recette dans la vue de recette via les éléments de commande "Exporter l'archive" et "Importer l'archive".

Notez que les dernières données importées ou chargées sont utilisées au runtime.

Liaison avec S7-1200 dans le diagnostic système

Lors de l'utilisation du diagnostic système, seul un système IHM WinCC Runtime Professional peut être connecté à un S7-1200 (jusqu'à la version V3).

Désactiver la vérification automatique des mises à jour logicielles

Si le système d'ingénierie est installé sur un PC avec Runtime, l'opérateur reçoit des messages sur les mises à jour logicielles. Pour que le système fonctionne de manière stable sur un système multiposte, la même version logicielle doit être installée sur tous les ordinateurs.

Il est possible de désactiver la vérification automatique des mises à jour logicielles et ainsi d'améliorer la performance.

Vous désactivez la vérification automatique des mises à jour logicielles sous "Paramètres > Général > Mises à jour logicielles", en décochant la case "Rechercher des mises à jour quotidiennement".

Restriction de la capacité de chargement delta en ligne.

Si vous modifiez une apparence, la capacité de chargement delta en ligne est perdue. Dans ce cas, aucun message d'erreur n'est généré par TIA Portal.

Objets graphiques comme PDF dans les journaux

La qualité des objets graphiques dans les journaux que vous créez comme fichier PDF en Runtime dépend des pilotes d'imprimante PDF utilisés.

Projets au Runtime après la mise à jour Windows 10

Vous avez installé Windows 10 version 1709 sur un PC avec WinCC Professional V15 et un PC avec WinCC Professional RT V15. Vous avez exécuté une mise à jour de Windows 10 à la version 1803 sur le PC Runtime. Après la mise à jour de Windows 10, il n'est plus possible dans certains cas d'ouvrir manuellement au Runtime un projet chargé par un PC système d'ingénierie.

Solution : Définissez manuellement le paramètre de démarrage du service de l'instance WinCC SQL sur "Automatique (début différé)" et redémarrez le système.

Espace mémoire requis pour les archives

Pour le calcul de l'espace mémoire requis pour les alarmes sur tous les segments et pour les segments individuels, vous avez besoin de savoir combien d'alarmes arrivent en moyenne par seconde. Un espace mémoire maximal d'environ 4 000 octets est compté pour un message. Règle :
Espace mémoire requis = nombre d'alarmes/s * 4 000 octets * 60 s/min * 60 min/h * 24 h/jour * 31 jours/mois * y mois.

Dans l'exemple, on part de 1 alarme par seconde :

  • Pour la taille maximale sur tous les segments et pour 2 mois, on obtient environ 20 Go.

  • Pour un segment individuel, on obtient environ 330 Mo par jour.

Pour le calcul de l'espace mémoire requis pour les archives de données sur tous les segments et pour les segments individuels, vous avez besoin de savoir combien de valeurs sont archivées par seconde ainsi que de la longueur moyenne d'une valeur de processus. Règle :
Espace mémoire requis = nombre de valeurs d'archive/s * x octets * 60 s/min * 60 min/h * 24 h/jour * 31 jours/mois * y mois.

Dans l'exemple, on part de 750 valeurs d'archive par seconde :

  • Pour des valeurs de processus de 16 octets, on obtient un espace mémoire requis d'environ 60 Go.

  • Pour des valeur de processus de 6 octets, on obtient un espace mémoire requis d'environ 22 Go.


Pupitres opérateur

Pupitres opérateur

Ce chapitre contient des informations sur les sujets suivants :
  • Remarques sur les pupitres opérateur


Remarques sur les pupitres opérateur

Contenu Pupitres opérateur non pris en charge (à partir de TIA Portal V15) Pupitres opérateur non pris en charge (à partir de TIA Portal V15.1) Pupitres opérateur non pris en charge (à partir de TIA Portal V16) Commande par plusieurs touches Pupitres opérateur avec charge de communication élevée Adaptateur TS avec interface Ethernet Simulation avec une connexion réelle à l'automate Simulation des Basic Panels Basic Panels 2nd Generation Pupitres opérateur avec système d'exploitation Windows CE 5.0 ou ultérieur Changement de liaison dans le Control Panel pour les Basic Panels Imprimer des alarmes (Mobile Panel) DHCP sur KTP 400 PN, KTP 700 PN et KTP 900 PN Mobile Panel Sm@rtServer avec Mobile Panels Simulation de Basic Panels 2nd Generation Installation de polices Interruption de liaison DH485 Fonction VB "CDate" (Comfort Panels) Supprimer le cache du navigateur (Panel)
PI Mobile
Remarques sur les pupitres opérateur

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Pupitres opérateur non pris en charge (à partir de TIA Portal V15)

Tous les pupitres opérateur de version 11.x ne sont plus pris en charge à partir de la version TIA Portal V15.

Les pupitres opérateur suivants ne sont plus pris en charge à partir de la version TIA Portal V15.

  • WinAC MP 177, WinAC MP 277, WinAC MP 377

  • Panels : OP et TP des gammes 70, 170 et 270

  • Multi Panels : Multi Panels des gammes 170, 270 et 370

Pour pouvoir utiliser dans TIA Portal V15 d'autres appareils, p. ex. Basic, Comfort ou Mobile Panels qui ont été configurés avec la version 11.x, modifiez la version des appareils concernés.

De même, la structure d'archivage dans le répertoire d'installation ne contient plus de données pour 11.0. La taille du pack d'installation TIA Portal est ainsi réduite par rapport aux versions précédentes.

Pupitres opérateur non pris en charge (à partir de TIA Portal V15.1)

Les pupitres opérateur suivants ne sont plus pris en charge à partir de la version TIA Portal V15.1 :

  • WinCC Runtime Advanced V11

Pupitres opérateur non pris en charge (à partir de TIA Portal V16)

Les pupitres opérateur suivants ne sont plus pris en charge à partir de la version TIA Portal V15.1 :

  • Mobile Panel avec la version d'appareil 12.x

  • Comfort Panel avec la version d'appareil 12.x

  • KP1500 Comfort avec la version d'appareil 13.x

  • TP1500 Comfort avec la version d'appareil 13.x

  • TP1900 Comfort avec la version d'appareil 13.x

  • TP2200 Comfort avec la version d'appareil 13.x

Commande par plusieurs touches

La commande de plusieurs touches peut déclencher des actions non intentionnées :

  • Si vous utilisez un pupitre à touches, vous ne devez pas actionner plus de deux touches de fonction à la fois.

  • Si vous utilisez un pupitre tactile, un PC standard ou un Panel PC, vous ne devez actionner qu'une touche de fonction ou touche à la fois.

Pupitres opérateur avec charge de communication élevée

Si de nombreuses connexions avec des automates ou d'autres pupitres opérateur sont configurés sur un Panel, le diagnostic S7 doit être désactivé. Si tel n'est pas le cas, le Panel court le risque d'une surcharge.

Adaptateur TS avec interface Ethernet

Si un pupitre opérateur est connecté via Ethernet et un adaptateur TS, il ne peut pas être réinitialisé sur les réglages d'usine.

Simulation avec une connexion réelle à l'automate

Le point d'accès utilisé par la simulation est indépendant des paramètres dans le système d'ingénierie et il peut uniquement être modifié avec l'outil "Paramétrage de l'interface PG/PC" dans le panneau de configuration. Si la liaison avec un automate est à nouveau interrompue, avec émission du message 140001, directement après le lancement de la simulation, vous devez vérifier le point d'accès utilisé par la simulation au moyen de l'outil "Paramétrage de l'interface PG/PC".

  1. Dans le Panneau de configuration, double-cliquez sur "Paramétrage de l'interface PG/PC". Une boîte de dialogue s'ouvre.

  2. Dans la zone "Point d'accès de l'application", sélectionnez "S7ONLINE" par défaut pour HMI.

  3. Sélectionnez l'interface dans la zone "Interface Parameter Assignment Used".

  4. Quittez la boîte de dialogue "Paramétrage de l'interface PG/PC" avec OK.

Simulation des Basic Panels

Vous utilisez un champ de sortie dans un texte d'alarme pour la sortie d'une variable externe. Lors de la simulation, le contenu affiché dans ce champ de sortie est toujours "0".

Basic Panels 2nd Generation

Les Basic Panels 2nd Generation prennent en charge l'option Sm@rtServer.

Si vous n'utilisez pas de concentrateur USB, sélectionnez le port USB USB_X60.1 comme chemin d'archivage.

Pupitres opérateur avec système d'exploitation Windows CE 5.0 ou ultérieur

En raison de la modification d'un réglage de sécurité au niveau de la communication client/serveur, l'écart de temps entre le pupitre opérateur (client) et un PC (serveur) ne doit pas dépasser 1 jour. Lorsque vous sauvegardez, par ex., des données de recette du pupitre opérateur sur un lecteur réseau, vérifiez que l'heure est correctement réglée sur le PC (serveur) et le pupitre opérateur (client).

Changement de liaison dans le Control Panel pour les Basic Panels

Si vous utilisez la fonction "Override projected connection information", la restriction suivante est applicable :

Le changement de liaison dans le Control Panel d'un Basic Panel permettant de passer d'une commande sans niveau de protection à une commande avec le niveau de protection "Protection complète" n'est pas possible.

Imprimer des alarmes (Mobile Panel)

Il n'est pas possible d'imprimer les alarmes comme PDF ou HMTL, lorsque la mémoire interne "/flash" est choisie comme "Storage Location". Pour imprimer les alarmes comme PDF ou HMTL, sélectionnez comme emplacement de stockage une carte mémoire SD ou une clé USB.

DHCP sur KTP 400 PN, KTP 700 PN et KTP 900 PN

Pour les appareils KTP 400 PN, KTP 700 PN et KTP 900 PN, le fonctionnement avec DHCP est déconseillé.

Dans certaines circonstances, l'appareil risque de ne plus démarrer. Retirez alors le câble réseau et démarrez à nouveau l'appareil. Après un démarrage réussi, affectez une adresse IP fixe.

Mobile Panel

Il est possible de configurer des Mobile Panels 2nd Generation de version d'appareil V15 avec TIA Portal V16. Le projet compilé ne peut en revanche pas être chargé sur ces appareils.

Pour travailler avec des Mobile Panels 2nd Generation dans TIA Portal V16, une mise niveau à la version d'appareil V15.1 et versions supérieures est requise.

Sm@rtServer avec Mobile Panels

L'évaluation de la commande de sécurité via PROFIsafe n'est effectuée qu'à la condition que le Sm@rtServer soit désactivé sur le Panel.

L'utilisation de Sm@rtServer sur des appareils sans fonction de sécurité n'est pas recommandée.

Simulation de Basic Panels 2nd Generation

L'accélérateur matériel 3D de la carte graphique doit être activé pour la simulation de Basic Panels 2nd Generation.

Installation de polices

Un redémarrage du pupitre est nécessaire si vous y avez installé un nouveau jeu de caractères avec ProSave. La durée de démarrage du Runtime dépend du nombre et de la taille des polices.

Interruption de liaison DH485

Si, pour les Comfort Panel, vous raccordez le câble Ethernet au connecteur "PN_X1" du HMI Panel, une interruption de la liaison DH485 peut se produire.

Aide de Comfort Redesign/PRO-Panels : Utilisez pour l'exécution du projet DH485 sur le HMI Panel le connecteur "PN_X3(Gigabit)" pour la communication Ethernet.

Fonction VB "CDate" (Comfort Panels)

Sur les pupitres opérateur suivants, vous ne pouvez utiliser la fonction VB "CDate" qu'avec des paramètres statiques :

  • TP1200 Comfort Pro

  • TP1500 Comfort Pro / V2

  • TP1900 Comfort Pro / V2

  • TP2200 Comfort Pro / V2

Supprimer le cache du navigateur (Panel)

Si vous constatez que le chargement de pages Web dans le navigateur HTML prend bien plus de temps, cela peut être dû au cache du navigateur. Pour supprimer le contenu du cache, exécutez la fonction VBS suivante au Runtime. Vous pouvez également configurer cette fonction VBS comme tâche périodique dans le planificateur de tâches.

Copie le code de programme suivant dans le presse-papiers

Sub T7_DeleteBrowserCache()

' delete Browsercache filled temporary objects

Dim fso, nFileIndex,sFileName, nFileAttr, folder

On Error Resume Next

' Variable to show script is active

SmartTags("DeleteBrowserCacheActive") = True

folder = "\flash\simatic\Browsercache\data7\"

' Windows CE

Set fso = CreateObject("FileCtl.FileSystem")

' Get first item that matches path

sFileName = fso.Dir(folder & "*.*")

nFileIndex = 0

'Get the rest of matches

Do While sFileName <> ""

nFileAttr = fso.GetAttr(folder & sFileName)

If (nFileAttr And 16) <> 0 Then

fso.Kill("\flash\simatic\Browsercache\data7\"&sFileName&"\*.*")

If Err.Number <>0 Then

Err.Clear

End If

End If

nFileIndex = nFileIndex + 1

sFileName = fso.Dir

Loop

Set fso = Nothing

SmartTags("DeleteBrowserCacheActive") = False

End Sub


Options

Options

Ce chapitre contient des informations sur les sujets suivants :
  • Sm@rtServer
  • Audit
  • DataMonitor
  • WebNavigator
  • WebUX
  • Redundancy
  • SIMATIC Information Server


Sm@rtServer

Contenu Ouverture de fichiers SmartClient *.sac sous Windows 10
Sm@rtServer

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Ouverture de fichiers SmartClient *.sac sous Windows 10

Vous enregistrez les données de la liaison SmartServer actuelle à l'aide du fichier exécutable SmartClient.exe au format *.sac. Pour ouvrir automatiquement sous Windows 10 les fichiers créés, un fichier *.sac avec SmartClient.exe doit être ouvert manuellement une fois via le bouton de sélection et la boîte de dialogue dans SmartClient.exe.


Audit

Contenu WinCC Audit Viewer 7.2 Update
Audit

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

WinCC Audit Viewer 7.2 Update

Pour le WinCC Audit Viewer 7.2 installable en option, vous disposez d'une mise à jour pour l'installation manuelle.

Installez la mise à jour de WinCC Audit Viewer 7.2 en exécutant le fichier "AuditViewer_V72_00_Upd1.exe" du répertoire d'assistance du DVD du produit.


DataMonitor

Contenu Désinstallation de WinCC Runtime Excel-Workbook sur un PC avec Windows 7 Vue de diagnostic de voie Fuseaux horaires de WebParts
DataMonitor

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Désinstallation de WinCC Runtime

Si vous voulez continuer à utiliser DataMonitor même après la désinstallation de WinCC Runtime Professional, vous devez effectuer une réparation de l'installation. Pour ce faire, procédez comme suit :

  1. Ouvrez le panneau de configuration.

  2. Double-cliquez sur "Logiciel".

  3. Dans la liste des programmes installés, sélectionnez "SIMATIC WinCC/DataMonitor Client"

  4. Cliquez sur les boutons "Modifier/supprimer".

  5. Sélectionnez l'option "Réparer" dans le Setup de WinCC/DataMonitor.

Excel-Workbook sur un PC avec Windows 7

Si vous utilisez Excel-Workbook sur un PC avec Windows 7, vous devez désactiver la représentation "Aero Glass".

Vue de diagnostic de voie

L'objet "Vue de diagnostic de voie" n'est pas pris en charge par l'option WinCC DataMonitor.

Fuseaux horaires de WebParts

Si vous créez et configurez dans le WebCenter une WebPart dans un fuseau horaire particulier, ce fuseau sera enregistré dans le WebCenter.

Une modification du fuseau horaire peut provoquer un affichage incorrect de la date/heure dans le Webpart.


WebNavigator

Contenu Désinstallation de WinCC Runtime Anti-virus Trend Micro OfficeScan Vue d'ensemble ProDiag, vue d'ensemble GRAPH et affichage de code API Caractères non autorisés dans le WinCC WebNavigator Diagnostic de voie Retard à l'affichage des vues WebNavigator
WebNavigator

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Désinstallation de WinCC Runtime

Si vous voulez continuer à utiliser WebNavigator même après la désinstallation de WinCC Runtime Professional, vous devez effectuer une réparation de l'installation. Pour ce faire, procédez comme suit :

  1. Ouvrez le panneau de configuration.

  2. Double-cliquez sur "Logiciel".

  3. Dans la liste des programmes installés, sélectionnez "SIMATIC WinCC/WebNavigator Client"

  4. Cliquez sur les boutons "Modifier/supprimer".

  5. Sélectionnez l'option "Réparer" dans le Setup de WinCC/WebNavigator.

Anti-virus Trend Micro OfficeScan

L'utilisation de l'anti-virus Trend Micro OfficeScan en liaison avec le WebNavigator n'est pas conseillée, car cet anti-virus peut entraîner de très longues durées d'appel d'image.

Vue d'ensemble ProDiag, vue d'ensemble GRAPH et affichage de code API

L'utilisation d'objets WinCC pour la surveillance et le diagnostic "Vue d'ensemble GRAPH", "Vue d'ensemble ProDiag" et "Affichage de code API" dans l'option WinCC navigateur Web n'est pas prise en charge.

Caractères non autorisés dans le WinCC WebNavigator

Utilisez pour les noms de vues et de projet les caractères du jeu de caractères ASCII. N'utilisez pas de caractères spéciaux ni de caractères spéciaux nationaux.

Diagnostic de voie

L'objet "Diagnostic de voie" n'est pas pris en charge par l'option WinCC WebNavigator.

Retard à l'affichage des vues WebNavigator

Du fait de la technologie serveur Web, il peut arriver que les vues WebNavigator actualisées soient affichées avec un certain retard en Runtime.


WebUX

Contenu Ouverture de session automatique
WebUX

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Ouverture de session automatique

Si l'ouverture de session automatique n'est plus souhaitée, vous devez supprimer l'historique du navigateur dans le navigateur correspondant.


Redundancy

Contenu Noms dans la configuration d'un système redondant
Redundancy

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Noms dans la configuration d'un système redondant

Seuls les noms d'ordinateur des pupitres opérateurs sont utiles pour la configuration d'un système redondant. Définissez le nom d'ordinateur d'un pupitre opérateur dans son système d'exploitation. Le nom du pupitre opérateur dans la navigation de projet ne sert qu'à identifier le pupitre opérateur dans le projet.


SIMATIC Information Server

Contenu Installation de SIMATIC Information Server et WinCC Runtime Professional sur un PC
SIMATIC Information Server

Contenu

Remarques n'ayant pu figurer dans l'aide en ligne et remarques importantes sur des caractéristiques du produit.

Installation de SIMATIC Information Server et WinCC Runtime Professional sur un PC

Pour installer SIMATIC Information Server et WinCC Runtime Professional sur un PC, respectez l'ordre d'installation suivant :

  1. Installez WinCC Runtime Professional.

  2. Installez Information Server.

Si vous ne respectez pas l'ordre d'installation, des problèmes de connexion peuvent se produire.