Safety

Examples See also History Extra
Safety

This section contains information on the following topics:
  • Security information
  • Notes on use
  • Editing devices and networks
  • Programming PLC


Security information

Security information

Siemens provides products and solutions with industrial security functions that support the secure operation of plants, systems, machines and networks.

In order to protect plants, systems, machines and networks against cyber threats, it is necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. Siemens’ products and solutions constitute one element of such a concept.

Customers are responsible for preventing unauthorized access to their plants, systems, machines and networks. Such systems, machines and components should only be connected to an enterprise network or the internet if and to the extent such a connection is necessary and only when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.

For additional information on industrial security measures that can be implemented, please visit.

Siemens' products and solutions undergo continuous development to make them more secure. Siemens strongly recommends that product updates are applied as soon as they are available and that the latest product versions are used. Use of product versions that are no longer supported, and failure to apply the latest updates may increase customers' exposure to cyber threats.

To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed visit.


Notes on use

Content The manual as PDF file
Notes on use

Content

Notes that could not be taken into account in the online help and the manual.

The manual as PDF file

The "SIMATIC Safety - Configuring and Programming" manual was stored in the installation folder of STEP 7 Professional or STEP 7 Basic in the "Manuals" subfolder during installation of the STEP 7 Safety optional package.


Editing devices and networks

Editing devices and networks

This section contains information on the following topics:
  • General notes on devices and networks


General notes on devices and networks

Roaming User Profiles not supported Installation of HSPs Configuring phase shifting for the F-OB
General notes on devices and networks

Roaming User Profiles not supported

You cannot use STEP 7 Safety in a roaming user profile. The software has only limited functionality under these circumstances. Contact your domain administrator if you have a roaming user profile.

Installation of HSPs

Make that all HSPs required in the project are installed before you work with the project.

Configuring phase shifting for the F-OB

Assign phase shift parameters for an F-OB using the following formula:

Phase shift < Max_Cyc - Cyclic interrupt time


Programming PLC

Programming PLC

This section contains information on the following topics:
  • General Notes on PLC Programming and on Acceptance


General Notes on PLC Programming and on Acceptance

Content What do you need to observe with regard to the installation of STEP 7 Safety? Online functions Upgrading to STEP 7 Safety V16 Supplement to the section "CTD: Count down (STEP 7 Safety V16)" and section "CTUD: Count up and down (STEP 7 Safety V16)" Compiling the safety program Openness Start values of tags in the block interface Multiuser Engineering
General Notes on PLC Programming and on Acceptance

Content

Notes that could not be taken into account in the online help and the manual.

What do you need to observe with regard to the installation of STEP 7 Safety?

After the installation of STEP 7 Safety, your safety program will be shown as inconsistent in the Safety Administration Editor. Initiate compilation of the safety program. You will obtain a consistent safety program as a result. The collective F-signature of your safety program remains unchanged.

Online functions

  • It is not possible to open F-blocks via the Lifelist with STEP 7 Safety. You have to have the corresponding project opened offline in order to use all of the online functions for F-blocks.

  • Use the Safety Administration Editor for the offline-online comparison if you wish to view the checksums of F-blocks.

Upgrading to STEP 7 Safety V16

  • After upgrading a project that contains S7-300/400 F-CPUs, we recommend executing the command "Compile > Software (rebuild all blocks)".

  • The name of the F-I/O is a component of the name of the associated F-I/O DB. In earlier versions of STEP 7 Safety, it was not always ensured that this component was identical to the name of the F-I/O. This is corrected with the upgrade to STEP 7 Safety V15. This does not change the functionality or the collective signature of your safety program. However, since the names of the F-I/O DBs have changed, you should generate an up-to-date safety summary after the upgrade and add it to your acceptance documents.

Supplement to the section "CTD: Count down (STEP 7 Safety V16)" and section "CTUD: Count up and down (STEP 7 Safety V16)"

If you use the CTD or CTUD instruction with version 1.1 in a know-how-protected block, you must open the block by entering the password before compiling in order to change the version of the CTD or CTUD instruction to a version other than V1.1.

The same applies if you want to change the version of the CTD or CTUD instruction from a version other than V1.1 to version V1.1.

Compiling the safety program

The collective F-signature is determined in STEP 7 Safety V15.1 when you compile the safety program and shown in the Safety Administration Editor under "Code signature". The collective F-signature is valid but the safety program can still be inconsistent. This is the case when the hardware configuration is not up-to-date (compiled).

Compile the hardware configuration to obtain a consistent safety program. The collective F-signature does not change as a result.

Openness

Importing and exporting F-blocks is not supported by the Openness command set.

Start values of tags in the block interface

You can also assign start values in F-blocks for tags (e. g. in the static selection), and use constants from the TAG table (global constants) or the CONST selection (local constants) for this.

Note that the F-blocks which use global constants as start values must not be called as a multi-instance because in this case the F-CPU can go into STOP. This is not the case when using local constants as start values.

To avoid CPU STOP, you have to avoid using global constants as start values, or use only single-instance calls for blocks where this is the case. This applies to the blocks themselves, as well as for all blocks which call these blocks, including everything up to Main Safety (complete call sequence).

Multiuser Engineering

Please note that in a local session, it is not possible to check in communication IDBs for Flexible F-Link on the multi-user server. This means you have to make changes to the start values in the server-project view, as they will otherwise be overwritten when updating the local session.