Leggimi

Esempi Vedere anche Cronologia Strumenti
Leggimi

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Avvertenze sul TIA Portal
  • STEP 7
  • WinCC
  • SIMOCODE ES
  • Safety
  • SIMATIC Safe Kinematics (S7-1500, S7-1500T)
  • Leggimi SIMATIC Energy Suite
  • Leggimi Building Automation
  • Startdrive
  • SINUMERIK
  • SIMOTION SCOUT TIA
  • SINAMICS DCC
  • TIA Portal Version Control Interface


Avvertenze sul TIA Portal

Avvertenze sul TIA Portal

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Avvertenze generali
  • Avvertenze sulle biblioteche
  • Avvertenze sulle memory card
  • Avvertenze per l’utilizzo del TIA Portal in un ambiente virtuale (Private Cloud)
  • Avvertenze per l’utilizzo di TIA Portal Teamcenter Gateway
  • Avvertenze sull'utilizzo del Multiuser Engineering


Avvertenze generali

Informazioni sul TIA Portal nell'Online Support Rilevamento di dati di diagnostica e di feedback Avvio del TIA Portal Windows 7 / Windows Server 2008 R2: Convalida del certificato non valida Visualizzazione caratteri asiatici in TIA Portal Installazione di nuove versioni .Net o .Net Service Pack Comando di TIA Portal Uso di drive di rete automaticamente sincronizzati Immissione di numeri decimali Apertura del progetto in caso di componenti software mancanti
Avvertenze generali

Le avvertenze del presente file Leggimi hanno priorità su qualsiasi altra affermazione riportata in altri documenti.

Si prega di leggerle attentamente in quanto contengono informazioni importanti per l'installazione e l'utilizzo. Leggere le presenti avvertenze prima dell'installazione.

Informazioni sul TIA Portal nell'Online Support

Panoramica sulle principali informazioni tecniche e soluzioni per il TIA Portal nella sezione Siemens Industry Online Support.

Link: TIA Portal in Siemens Industry Online Support

Tutte le informazioni suo Service e Support nella sezione Siemens Industry Online Support:

Link: Service e Support alla sezione Siemens Industry Online Support

Qui è anche possibile abbonare la Newsletter, costantemente aggiornata con tutte le informazioni sui prodotti.

Rilevamento di dati di diagnostica e di feedback

Rileviamo ed elaboriamo dati statistici sull'utilizzo e la diagnostica come ad es. la frequenza di utilizzo degli editor o delle funzioni di TIA Portal allo scopo di garantire la sicurezza e l'aggiornamento di TIA Portal, per rilevare, diagnosticare e risolvere problemi nonché per migliorare il prodotto.

I dati di utilizzo e di diagnostica vengono dapprima salvati sul computer locale in un formato leggibile e possono essere consultati dall'utente. Percorso: "...\ProgramData\Siemens\Automation\TelemetryConnector". (Note: l'amministratore di Windows può rendere visibile la cartella.)

In una seconda fase i dati di utilizzo e di diagnostica rilevati agli scopi sopra indicati vengono trasmessi a Siemens attraverso un percorso di comunicazione sicuro.

Avvio del TIA Portal

All'avvio del TIA Portal, Windows tenta di aggiornare il Certificate Revocation List (CRL) di "windowsupdate.com".

In caso di mancato accesso a Internet o in presenza di più server DNS, può verificarsi un timeout che ritarda l'avvio del TIA Portal.

Windows 7 / Windows Server 2008 R2: Convalida del certificato non valida

I nuovi certificati utilizzati per la firma non vengono probabilmente convalidati nei sistemi operativi Windows 7 e Windows Server 2008 R2.

Se non esiste la possibilità di aggiornare la memoria di certificati online, la firma dei file di prodotti potrebbe venire visualizzata come non valida. In questo caso aggiornare sui sistemi offline i certificati Root disponibili di Microsoft. A riguardo seguire le istruzioni in FAQ 109748887.

Visualizzazione caratteri asiatici in TIA Portal

Eventualmente i testi in TIA Portal non vengono visualizzati correttamente se un TIA Portal in cinese viene installato su un altri sistema operativo asiatico (ad es. coreano). Per poter visualizzare correttamente questi testi nel TIA Portal, selezionare nel pannello di controllo di Windows l'impostazione "Inglese" alla voce "Lingua per programmi non Unicode". Tuttavia occorre tenere presente che questa impostazione potrebbe causare problemi nella visualizzazione di altri programmi.

Installazione di nuove versioni .Net o .Net Service Pack

  • Uscire dal TIA Portal prima di installare sul PG/PC una nuova versione .Net o un nuovo .Net Service Pack.

  • Avviare il TIA Portal solo dopo aver concluso l'installazione della nuova versione .Net o del nuovo .Net Service Pack.

Comando di TIA Portal

  • Se un progetto dell'elenco degli ultimi progetti utilizzati si trova su un drive di rete non collegato, è possibile che l'apertura del menu "Progetto" venga rallentata.

  • Il tempo di attesa per l'inserimento di una CPU può prolungarsi se al tempo stesso è aperto l'editor dei testi del progetto. In particolare se si tratta della prima CPU in un nuovo progetto occorre prevedere un tempo di attesa prolungato. Per assicurare una buona velocità chiudere l'editor dei testi del progetto prima di inserire una CPU.

  • Nel caso di funzioni che si prolungano, come ad es. il caricamento della CPU, è possibile che in Windows 7 venga visualizzato il messaggio "L'applicazione non risponde". In questo caso, attendere finché la funzione non si conclude regolarmente.

  • Se è stato installato un mouse Microsoft con IntelliPoint, è possibile che i pulsanti nella barra del titolo si sovrappongano. In questo caso disinstallare il software IntelliPoint Microsoft.

  • Se si attiva l'opzione "Virtual Desktop" per le schede grafiche NVIDIA è possibile che insorgano dei problemi. In questo caso disattivare l'opzione "nView virtual desktop manager" del driver grafico NVIDIA.

Uso di drive di rete automaticamente sincronizzati

Un progetto TIA Portal-consiste di più file salvati in una cartella. Se un progetto viene salvato in un drive di rete o un drive cloud (p. es. Dropbox, Syncplicity o GoogleDrive) il quale viene sincronizzato automaticamente, ciò può causare una perdita di dati in caso il progetto venga sincronizzato solo parzialmente o in modo asincrono. Per questo motivo non si consiglia di salvare progetti di TIA Portal su drive di rete sincronizzati o di lavorare direttamente su drive cloud. Chiudere il progetto TIA Portal di massima prima della sincronizzazione e assicurarsi che tutte le cartelle e file della cartella del progetto vengano sincronizzati insieme e completamente. Disinserire eventualmente sincronizzazione automatica quando si lavora con TIA Portal. La sincronizzazione stessa deve essere eseguita in modo da sostituire i dati del progetto sul drive di rete o sul drive cloud con quelli attuali (locali).

Immissione di numeri decimali

Nel caso di determinate impostazioni Windows delle lingue può accadere che l'immissione di valori con virgola non vengano riconosciute (l'immissione di "1,23" causa un errore). Utilizzare per questo motivo la modalità di scrittura internazionale ("1.23").

Apertura del progetto in caso di componenti software mancanti

Se a causa di componenti software mancanti, l'apertura di un progetto in TIA Portal non è possibile, i componenti interessati possono essere scaricati e installati come software di prova alla sezione Siemens Industry Online Support in Internet. In seguito sarà possibile aprire il progetto. Il software di prova è utilizzabile per un periodo di tempo limitato.

Selezionando il seguente link si apre la pagina di Siemens Industry Online Support con i diversi software di prova disponibili: www.siemens.com/tia-portal-trial


Avvertenze sulle biblioteche

Contenuto Copia degli elementi di una biblioteca
Avvertenze sulle biblioteche

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Copia degli elementi di una biblioteca

Se copie master e tipi hanno lo stesso nome, gli oggetti del progetto corrispondenti vengono sovrascritti mediante l'utilizzo del comando "Copia". Tenere presente che ciò avviene senza richiesta di conferma. Lo stesso comportamento si verifica anche quando il nome della copia master è diverso dal nome del tipo ma uno degli oggetti all'interno della copia master ha lo stesso nome del tipo.


Avvertenze sulle memory card

Contenuto SIMATIC Memory Card Comportamento in caso di job di forzamento aperto Protezione di accesso per le memory card nei lettori di schede USB Estrazione/inserimento della memory card
Avvertenze sulle memory card

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

SIMATIC Memory Card

Le SIMATIC Memory Card vengono formattate e configurate da Siemens per l'impiego su unità S7-1200 e S7-1500. Il formato non deve essere sovrascritto poiché altrimenti la scheda non viene più accettata dalle unità. Pertanto la formattazione con strumenti di Windows non è consentita.

Comportamento in caso di job di forzamento aperto

Tenere presente che un eventuale job di forzamento attivo viene mantenuto anche dopo il caricamento di un nuovo progetto sulla SIMATIC Memory Card. Per questo motivo, prima di estrarre una scheda SIMATIC Memory Card da una CPU si deve eliminare il job di forzamento attivo, quindi si può sovrascrivere la scheda nel PC con un nuovo progetto. In caso di impiego di una scheda SIMATIC Memory Card di cui non si conosce il contenuto, si consiglia di provvedere alla relativa formattazione prima di effettuare un nuovo caricamento.

Protezione di accesso per le memory card nei lettori di schede USB

Con il perfezionamento dei meccanismi di sicurezza per l'accesso online e l'engineering delle CPU S7-1500 è stato modificato anche il salvataggio dei dati sulle memory card. Per questo motivo, al momento di leggere i dati di progetto da memory card alle quali si accede da un lettore di schede USB, questa versione di STEP 7 non è in grado di analizzare le password del livello di protezione configurato. Questo comportamento modificato riguarda le memory card per le CPU delle serie S7-1200/1500. Utilizzare pertanto meccanismi di protezione fisici per proteggere i dati del progetto critici sulle memory card di questi dispositivi.

Nota

Questa limitazione non è connessa con l'accesso online ai dispositivi o con la protezione del know-how dei blocchi di programma.

Estrazione/inserimento della memory card

Affinché la CPU sia nuovamente in grado di funzionare, eseguire sempre la cancellazione totale dopo l'estrazione o l'inserimento della memory card.


Avvertenze per l’utilizzo del TIA Portal in un ambiente virtuale (Private Cloud)

Contenuto Istruzioni per l’utilizzo del TIA Portal in un ambiente virtuale (Private Cloud) Variabili di ambiente "TiaUserSettingsPath" e "TiaDefaultProjectPath" Certificati autogenerati in caso di utilizzo di HTTPS come protocollo di comunicazione
Avvertenze per l’utilizzo del TIA Portal in un ambiente virtuale (Private Cloud)

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Istruzioni per l’utilizzo del TIA Portal in un ambiente virtuale (Private Cloud)

Le istruzioni per l’utilizzo del TIA Portal in un ambiente virtuale (Private Cloud) sono disponibili sul supporto dati di installazione nella directory “Documents\Readme\<directory lingua>”. Aprire il documento PDF “TIAPortalCloudConnectorHowTo<ID lingua>.pdf".

TIA Portal Cloud Connector è supportato dai sistemi operativi Windows 7 (64 bit) e Windows 10 (64 bit).

Variabili di ambiente "TiaUserSettingsPath" e "TiaDefaultProjectPath"

Con le variabili di ambiente "TiaUserSettingsPath" e "TiaDefaultProjectPath" è possibile impostare un percorso di salvataggio per l'impostazione dell'utente e del progetto diverso da quello predefinito nel sistema. Questo può essere utilizzato ad es. per salvare le impostazioni dell'utente e del progetto a livello centrale.

Ulteriori informazioni sull'utilizzo delle variabili di ambiente sono contenute nelle istruzioni per l'utilizzo di TIA Portal in un ambiente virtuale (Private Cloud).

Certificati autogenerati in caso di utilizzo di HTTPS come protocollo di comunicazione

Microsoft verifica regolarmente che i certificati nell'archivio certificati di Windows provengano da fonti affidabili e provvede alla cancellazione di quelli che non soddisfano questi presupposti. Accertarsi di firmare i propri certificati utilizzando uno strumento di certificazione sicuro.


Avvertenze per l’utilizzo di TIA Portal Teamcenter Gateway

Contenuto Installazione di TIA Portal Teamcenter Gateway L’utilizzo di TIA Portal Teamcenter Gateway Installazione del TIA Portal Teamcenter Gateway - Modello di dati Aggiornamento di TIA Portal Teamcenter Gateway esistente - modello di dati Avvertenza su Teamcenter Avvertenza su TCCS (Teamcenter Client Communication System) Avvertenza su UTF 8 Avvertenza su Cloud Computing Nozioni di base per l’utilizzo del TIA Portal Teamcenter Gateway Creazione del collegamento con il Teamcenter Informazioni sulla versione di Teamcenter Definizione del Percorso Cache del TIA Portal Teamcenter Gateway Esecuzione delle operazioni TIA Portal Teamcenter Gateway durante una simulazione WinCC Professional avviata
Avvertenze per l’utilizzo di TIA Portal Teamcenter Gateway

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Installazione di TIA Portal Teamcenter Gateway

Per le istruzioni di installazione di TIA Portal Teamcenter Gateway consultare la relativa Guida in linea in "Installazione e disinstallazione di TIA Portal Teamcenter Gateway".

L’utilizzo di TIA Portal Teamcenter Gateway

L’installazione di TIA Portal Teamcenter Gateway consente di utilizzare la funzione di TIA Portal Teamcenter Gateway disponibile a partire da TIA Portal V14.

Installazione del TIA Portal Teamcenter Gateway - Modello di dati

La descrizione per l’istallazione di TIA Portal Teamcenter Gateway - Modello di dati sono disponibili sul supporto dati di installazione nella directory "\Support\Teamcenter_11\ServerSetupDocument\" nel DVD2 di STEP 7/WinCC. Aprire il documento PDF "Datamodel_Installation_enUS"". Le istruzioni sull'installazione del modello di dati di TIA Portal Teamcenter Gateway sono disponibili solo in lingua inglese.

Aggiornamento di TIA Portal Teamcenter Gateway esistente - modello di dati

  • Dopo l'aggiornamento dell'attuale TIA Portal Teamcenter Gateway - Modello di dati, riavviare il TIA Portal.

  • In TIA Portal Teamcenter Gateway V15 e V15.1 non sono state apportate modifiche all'attuale TIA Portal Teamcenter Gateway - Modello di dati e nemmeno modifiche specifiche al Teamcenter.

Avvertenza su Teamcenter

Per lavorare con TIA Portal Teamcenter Gateway, deve essere installata sul PG/PC la versione di Teamcenter Rich Application Client (RAC) o Teamcenter Client Communication System (TCCS) 11.2 o superiore.

Avvertenza su TCCS (Teamcenter Client Communication System)

Se TCCS (Teamcenter Client Communication System) è stato installato come programma "stand-alone" si deve installare anche "Microsoft Visual C++ 2013 – Redistributable".

Avvertenza su UTF 8

Per visualizzare i dati in TIA Portal dal Teamcenter con "set di caratteri non inglesi", ad es. per le lingue asiatiche, nel server di Teamcenter devono essere utilizzati i set di caratteri Unicode.

Avvertenza su Cloud Computing

Se si utilizza TIA Portal in un cloud (ad es. macchina virtuale), questo sistema deve essere integrato nell'ambiente Teamcenter. TIA Portal Teamcenter Gateway non supporta un collegamento diretto mediante uno remoto.

Nozioni di base per l’utilizzo del TIA Portal Teamcenter Gateway

A partire dalla versione TIA Portal Teamcenter Gateway V15 è disponibile l’operazione Teamcenter "Teamcenter > Esportazione..." per progetti TIA Portal e le biblioteche globali.

Questa operazione genera una copia del progetto attuale completamente indipendente da qualsiasi informazione Teamcenter. Se si desidera una disconnessione dal Teamcenter, utilizzare questa operazione anziché operazioni "Save as", in quanto con "Save as" le informazioni Teamcenter restano nel progetto.

Creazione del collegamento con il Teamcenter

A partire dalla versione TIA Portal Teamcenter Gateway V15.1 Update 3 è possibile stabilire il collegamento tra TIA Portal e Teamcenter sia tramite HTTP che tramite HTTPS.

Informazioni sulla versione di Teamcenter

Per poter utilizzare TIA Portal Teamcenter Gateway versione V15.1 o TIA Portal Teamcenter Gateway versione V16 e Teamcenter versione V11.6 si presuppone l'installazione di Teamcenter versione V11.6.0.5 o superiore. Da Teamcenter versione V11.6.0.5 in poi sono stati apportati vari miglioramenti che consentono di utilizzare Teamcenter versione V11.6 senza problemi.

A partire da TIA Portal Teamcenter Gateway versione V16 è supportato l'utilizzo di Teamcenter versione V12.2.0.0.0.

Definizione del Percorso Cache del TIA Portal Teamcenter Gateway

Come standard, il valore inserito in "Strumenti" > "Impostazioni >"Generale" > "Teamcenter Gateway" > nell’area "Percorso Cache del TIA Portal Teamcenter Gateway” viene acquisito come "Percorso Cache del TIA Portal Teamcenter Gateway”.

Questo valore rimanda automaticamente al percorso della cartella del progetto.

Se si modifica il valore del “Percorso Cache del TIA Portal Teamcenter Gateway", il Teamcenter Gateway controlla la validità dei valori standard inseriti e dei valori modificati.

Nota

Il valore inserito per default non deve essere vuoto.

Esecuzione delle operazioni TIA Portal Teamcenter Gateway durante una simulazione WinCC Professional avviata

Non eseguire operazioni Teamcenter Gateway quali, ad es., “Archivia" o “Annulla estrazione", durante una simulazione WinCC Professional avviata.


Avvertenze sull'utilizzo del Multiuser Engineering

Contenuto Modifiche dei nomi Account di sistema Microsoft per server di progetti Messaggio di errore all'avvio del server di progetti Utilizzo della sessione locale con compiti di controllo e forzamento attivi Utilizzo della sessione locale con l'opzione "Mantieni sessione locale" Utilizzo di diverse versioni TIA Portal Utilizzo di Multiuser Commissioning
TIA Portal nel Siemens Industry Online Support FAQ ID 109739926
Avvertenze sull'utilizzo del Multiuser Engineering

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto Multiuser Engineering e server di progetti.

L'installazione del server di progetto consente di utilizzare le funzioni di "Multiuser Engineering", "Multiuser Commissioning" ed "Exclusive Engineering" disponibili con la corrispondente versione di TIA Portal.

Modifiche dei nomi

In TIA Portal versione V16 sono state introdotte le seguenti modifiche dei nomi nel contesto di Multiuser Engineering :

Denominazione precedente | Nuova denominazione da TIA Portal V16
Server multiutente | Server di progetto TIA
Server multiutente locale | Server di progetto locale
Progetto server multiutente | Progetto server
Profili di rete multiutente | Profili di rete

Il server di progetto può essere utilizzato sia per Multiuser Engineering che per Multiuser Commissioning ed Exclusive Engineering .

Non esistono limitazioni della funzionalità tra il server di progetto V16 e il server multiutente V15.1.

La funzionalità del server nelle rispettive versioni rimane invariata.

Il server di progetto V16 è compatibile verso il basso con il server multiutente V14.

Account di sistema Microsoft per server di progetti

Durante l'installazione del server di progetti viene generato un account di sistema Microsoft per il server di progetti. Per questo account Microsoft sostituisce la password ciclicamente.

Se la password dovesse essere scaduta per questo account quest'ultima deve essere rinnovata e il server di progetti deve quindi essere riavviato.

Messaggio di errore all'avvio del server di progetti

Se viene visualizzato il messaggio durante o dopo l'installazione del server di progetti segnalante che il servizio per il server di progetti non può essere avviato, è consigliabile attenersi alla seguente procedura:

  1. Aprire la finestra degli eventi di Windows e verificare se è presente un messaggio di errore dal numero "1069".

  2. In caso positivo, attenersi alle seguenti avvertenze su come procedere successivamente.

    Link: TIA Portal nel Siemens Industry Online Support

  3. In via alternativa è possibile contattare direttamente anche il Customer Support.

    Link Internet al Customer Support: FAQ ID 109739926

Utilizzo della sessione locale con compiti di controllo e forzamento attivi

Prima di archiviare e aggiornare la sessione locale è necessario portare a termine i compiti di controllo e forzamento attivi Non è possibile archiviare e aggiornare la sessione locale con compiti di controllo e forzamento attivi.

Utilizzo della sessione locale con l'opzione "Mantieni sessione locale"

Se dopo l'archiviazione viene selezionata l'opzione "Mantieni sessione locale", tutti gli oggetti archiviati vengono visualizzati nella sessione locale come se fossero meno recenti anche se questi, dal punto di vista del contenuto, sono identici.

Utilizzo di diverse versioni TIA Portal

Le sessioni locali create con una versione <x.y> di TIA Portal possono essere modificate soltanto con questa versione di TIA Portal.

Esempio: Una sessione locale creata con TIA Portal V16 per un progetto V16 non può essere modificata con una precedente versione di TIA Portal.

Utilizzo di Multiuser Commissioning

  • Con l'impiego di Multiuser Commissioning dopo ogni caricamento nella CPU viene generata una nuova revisione del progetto server. Se tuttavia nella sessione locale vengono elaborati oggetti non selezionabili, la generazione di una nuova revisione non avviene. Le modifiche apportate agli oggetti non selezionabili vanno perse durante l'archiviazione e non vengono caricate nella CPU.

  • Se nel modo Commissioning il caricamento nel dispositivo viene avviato al di fuori della navigazione del progetto, utilizzando il comando di menu „Carica nel dispositivo > Configurazione hardware“, viene sempre visualizzata una finestra di dialogo indicante la discordanza tra i dati nella CPU e quelli del progetto sul server.

  • Nel modo Commissioning vengono completamente supportate soltanto le CPU S7-1500. Se si opera nel modo Commissioning con una CPU S7300/400, al momento del caricamento nella CPU, viene sempre visualizzata una finestra di dialogo indicante la discordanza tra i dati nella CPU e quelli del progetto sul server. La causa risiede nel fatto che le CPU S7-300/400 non supportano la sincronizzazione. Per evitare la comparsa di questa segnalazione, disattivare l'opzione "Verifica coerenza dati prima del caricamento·(raccomandata)" in Administration Tool.