WinCC

Esempi Vedere anche Cronologia Strumenti
WinCC

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Avvertenze sulla sicurezza
  • Protezione dati
  • Avvertenze per l'utilizzo
  • Migrazione
  • Sistema di engineering
  • Funzioni valide in più progetti
  • Compilazione e caricamento
  • Runtime
  • Pannelli operatore
  • Opzioni


Avvertenze sulla sicurezza

Avvertenze sulla sicurezza Password Server web integrato Comunicazione tramite Ethernet Utilizzo di SSL 3.0 Impostazioni di rete
Avvertenze sulla sicurezza

Avvertenze sulla sicurezza

Siemens commercializza prodotti di automazione e azionamento per la sicurezza industriale che contribuiscono al funzionamento sicuro di impianti, soluzioni, macchinari, apparecchiature e/o reti.

La protezione di impianti, sistemi, macchine e reti da minacce cibernetiche, richiede l'implementazione e la gestione continua di un concetto globale di Industrial Security che corrisponda allo stato attuale della tecnica. I prodotti e le soluzioni Siemens costituiscono soltanto una componente imprescindibile di questo concetto.

È responsabilità del cliente prevenire accessi non autorizzati ad impianti, sistemi, macchine e reti. Il collegamento di sistemi, macchine e componenti, se necessario, deve avvenire esclusivamente nell'ambito della rete aziendale o tramite Internet previa adozione di opportune misure (ad es. impiego di firewall e segmentazione della rete).

Attenersi inoltre alle raccomandazioni di Siemens sulle misure di sicurezza adeguate. Per ulteriori informazioni sulla sicurezza industriale, vedere:

http://www.siemens.com/industrialsecurity

I prodotti e le soluzioni Siemens vengono costantemente perfezionati per incrementarne la sicurezza. Siemens raccomanda espressamente di eseguire gli aggiornamenti non appena sono disponibili i relativi update e di impiegare sempre le versioni aggiornate dei prodotti. L’uso di prodotti non più attuali o di versioni non più supportate incrementa il rischio di attacchi cibernetici.

Per essere costantemente aggiornati sugli update dei prodotti, abbonarsi a Siemens Industrial Security RSS Feed al sito.

http://www.siemens.com/industrialsecurity

Password

In WinCC sono preimpostate diverse password. Per motivi di sicurezza è preferibile modificare queste password.

  • Nei pannelli operatore con la versione 12 per lo Sm@rtServer e il server web integrato è preimpostata la password "100". Nei pannelli operatore dalla versione 13 la password non è preimpostata.

  • Per l'utente "Amministratore" è preimpostata la password "administrator".

Server web integrato

Su un PC è possibile accedere alle pagine HTML in Runtime anche se l'opzione "Pagine HTML" è disattivata. Durante l'installazione vengono sempre memorizzate sul PC le pagine standard del server web. Assegnare una password di amministratore che impedisca l'accesso non autorizzato alle pagine.

Comunicazione tramite Ethernet

Nella comunicazione basata su Ethernet l'utente finale è responsabile della sicurezza della propria rete di dati perché non è garantita la funzionalità ad°es. nel caso di attacchi mirati che conducono a un sovraccarico del pannello operatore.

Utilizzo di SSL 3.0

Per ragioni legate alla sicurezza non si sconsiglia l'impiego del protocollo SSL 3.0 su Comfort Panel e in Runtime Advanced. Nei Comfort Panel l'impiego del protocollo SSL 3.0 è disattivato per default. Se si intende tuttavia attivare l'impiego di SSL 3.0 selezionare in Internet Explorer o in "Start Center > Settings" alla voce "Internet Options > Advanced > Use SSL 3.0".

In RT Advanced, l'impiego di SSL 3.0 può essere disattivato in Internet Explorer o dal pannello di controllo alla voce "Opzioni Internet > Avanzate" deselezionando l'opzione "Utilizzo di SSL 3.0".

Impostazioni di rete

Le seguenti tabelle illustrano le impostazioni di rete del prodotto di volta in volta interessato, necessarie per l'analisi della sicurezza di rete e la configurazione di firewall esterni:

WinCC Professional (senza simulazione)
Nome | Numero di porta | Protocollo di trasporto | Direzione | Funzione | Descrizione
ALM | 4410* | TCP | Inbound, Outbound | License service | Questo servizio fornisce la funzionalità completa per le licenze software e viene utilizzato sia da Automation License Manager sia da tutti i prodotti software di rilievo ai fini delle licenze.
HMI Load | 1033 | TCP | Outbound | HMI Load (RT Basic) | Questo servizio viene utilizzato per il trasferimento di immagini speculari e di dati di configurazione nei Basic Panel.
HMI Load | 2308 | TCP | Outbound | HMI Load (RT Advanced) | Questo servizio viene utilizzato per il trasferimento di immagini speculari e di dati di configurazione nei pannelli operatore.
RPC | ** | UDP | Inbound, Outbound | Client / server & ES communication (CCAgent) | Questo servizio viene utilizzato da WinCC Professional e WinCC Runtime Professional.
* Porta standard modificabile nella configurazione utente ** La porta viene assegnata automaticamente

Simulazione WinCC per Basic Panel
Nome | Numero di porta | Protocollo di trasporto | Direzione | Funzione | Descrizione
HMI Load | 1033 | TCP | Inbound | HMI Load (RT Basic) | Questo servizio viene utilizzato per il trasferimento di immagini speculari e di dati di configurazione nei Basic Panel.
EtherNet/IP | 44818 | TCP | Outbound | Canale Ethernet/IP | Il protocollo Ethernet/IP trova impiego per i collegamenti ai PLC Allen Bradley.
 | 2222 | UDP | Inbound | Canale Ethernet/IP | Il protocollo Ethernet/IP trova impiego per i collegamenti ai PLC Allen Bradley.
Modbus TCP | 502 | TCP | Outbound | Canale Modbus TCP | Il protocollo Modbus TCP trova impiego per i collegamenti ai PLC Schneider.
RFC 1006 | 102 | TCP | Outbound | Canale S7 | Comunicazione con il Controller S7 tramite Ethernet / PROFINET
Mitsubishi MC | 5002 | TCP | Outbound | Canale Mitsubishi MC | Il protocollo Mitsubishi trova impiego per i collegamenti ai PLC omonimi.

Simulazione WinCC per Panel e Runtime Advanced
Nome | Numero di porta | Protocollo di trasporto | Direzione | Funzione | Descrizione
DCP | --- | Ethernet | Outbound | PROFINET | Il protocollo DCP (Discovery and basic Configuration Protocol) viene utilizzato da PROFINET e fornisce la funzionalità di base per la rilevazione e la configurazione di dispositivi PROFINET.
LLDP | --- | Ethernet | Inbound, Outbound | PROFINET | Il protocollo LLDP (Link Layer Discover Protocol ) viene utilizzato da PROFINET per il riconoscimento della topologia.
SMTP | 25 | TCP | Outbound | SMTP Communication | Questo servizio viene utilizzato da WinCC Runtime Advanced per l'invio di e-mail.
HTTP | 80* | TCP | Inbound | Client / server communication (CCEServer / CCEClient) HTML pages | Il server web è disponibile solo se sono attivati HTTP Channel Server o HTML pages. La porta utilizzata può variare in base alle impostazioni selezionate automaticamente.
RFC 1006 | 102 | TCP | Outbound | Canale S7 | Comunicazione con il Controller S7 tramite Ethernet / PROFINET
NTP | 123 | UDP | Outbound | Sincronizzazione dell'ora | Il protocollo NTP (Network Time Protocol) viene utilizzato nelle reti basate su IP per la sincronizzazione dell'ora.
SNMP | 161 | UDP | Outbound | PROFINET | La funzionalità client SNMP viene impiegata da STEP 7 per la lettura di informazioni di stato in dispositivi PROFINET.
HMI Load | 2308 | TCP | Outbound | HMI Load (RT Advanced) | Questo servizio viene utilizzato per il trasferimento di immagini speculari e di dati di configurazione nei pannelli operatore.
HTTPS | 443* | TCP | Inbound | HTTP Channel Server HTML pages | Il server web con il protocollo HTTPS è disponibile solo se sono attivati HTTP Channel Server o HTML pages. La porta utilizzata può variare in base alle impostazioni selezionate automaticamente.
VNC Server | 5900* | TCP | Inbound | Sm@rtServer | Questo servizio è disponibile solo se viene attivato Sm@rtService.
 | 5800* | TCP | Inbound | Sm@rtServer | Questo servizio è disponibile solo se viene attivato Sm@rtService.
VNC Client | 5500 | TCP | Outbound | Sm@rtServer | Questo servizio è disponibile solo se viene attivato Sm@rtService.
* Porta standard modificabile nella configurazione utente

Simulazione WinCC per Runtime Professional
Nome | Numero di porta | Protocollo di trasporto | Direzione | Funzione | Descrizione
RPC | ** | UDP | Inbound, Outbound | Client / server & ES communication (CCAgent) | Questo servizio viene utilizzato da WinCC Professional e WinCC RT Professional.
RPC | ** | UDP | Inbound, Outbound | Client / server communication (CCEServer / CCEClient) | Questo servizio viene utilizzato da WinCC Runtime Professional.
HTTP | 80 | TCP | Inbound, Outbound | Client / server communication (CCEServer / CCEClient) | Questo servizio viene utilizzato da WinCC Runtime Professional.
RFC 1006 | 102 | TCP | Outbound | Canale S7 | Comunicazione con il Controller S7 tramite Ethernet / PROFINET
OPC UA | 4840 | TCP | Inbound | Server OPC UA | Questo servizio è necessario per la comunicazione primaria tramite OPC UA. Viene attivato e configurato durante l'installazione.
OPC UA discovery | 52601 | TCP | Inbound | Server OPC UA | Questo servizio fornisce informazioni sui server OPC installati. Esso viene installato e configurato tramite il server OPC UA.
DCOM | 135 | TCP | Inbound | Server OPC | Questo servizio è parte del sistema operativo Windows. Poiché la comunicazione via OPC (DA) si basa su DCOM, il servizio è necessario per l'inizializzazione dei collegamenti OPC (DA).
DCOM | ** | TCP | Inbound | Server OPC | La comunicazione via OPC (DA) si basa su DCOM e utilizza porte non specificate assegnate dal sistema. Ciò andrebbe tenuto in considerazione durante l'utilizzo di OPC (DA) e la creazione di regole per i firewall.
HTTP | 80 | TCP | Inbound | Server OPC | Questo servizio è necessario per la comunicazione primaria tramite OPC XML. Viene attivato e configurato durante l'installazione.
NetBIOS | 137 | UDP | Inbound | Server OPC | Questo servizio è parte del sistema operativo Windows. L'accesso al servizio viene utilizzato ad es. da OPC Scout per la navigazione.
NetBIOS | 138 | UDP | Inbound | Server OPC | Questo servizio è parte del sistema operativo Windows. L'accesso al servizio viene utilizzato ad es. da OPC Scout per la navigazione.
SNMP | 161 | UDP | Outbound | Server SNMP OPC | Questo servizio viene utilizzato dal server SNMP OPC ad es. per modificare o interrogare dati su drive di rete.
SNMP Traps | 162 | UDP | Inbound | Server SNMP OPC | Questo servizio viene utilizzato dal server SNMP OPC ad es. per modificare o interrogare eventi su drive di rete.
** La porta viene assegnata automaticamente

Protocolli PROFINET per Panel e Runtime Advanced
Nome | Numero di porta | Protocollo di trasporto | Direzione | Funzione | Descrizione
DCP | --- | Ethernet | Outbound | Lifelist, PROFINET Discovery and configuration | Il protocollo DCP (Discovery and basic Configuration Protocol) viene utilizzato da PROFINET e fornisce la funzionalità di base per la rilevazione e la configurazione di dispositivi PROFINET.
LLDP | --- | Ethernet | Inbound, Outbound | PROFINET Link Layer Discovery protocol | Il protocollo LLDP (Link Layer Discover Protocol ) viene utilizzato da PROFINET per il riconoscimento della topologia.
MRP | --- | Ethernet | Outbound | PROFINET medium redundancy | Il protocollo MRP (Medium redundancy protocol) consente il comando, tramite topologie ad anello, di percorsi di trasmissione ridondanti.
PROFINET IO Data | --- | Ethernet | Inbound, Outbound | PROFINET Cyclic IO data transfer | Lo scambio ciclico di dati viene utilizzato dai pannelli operatore per tasti diretti e LED.
ARP | --- | Ethernet | Inbound, Outbound | Name Addres Resolution | Il protocollo viene utilizzato per la risoluzione dei nomi della rete e per l'assegnazione di indirizzi IP.
PROFINET Context Manager | 34964 | UDP | Inbound, Outbound | PROFINET connection less RPC | PROFINET Context Manager mette a disposizione un Endpoint Mapper per la creazione di un riferimento di applicazioni (PROFINET AR).

Collegamenti di comunicazione per Panel e WinCC Runtime Advanced

Nome

Numero di porta

Protocollo di trasporto

Direzione

Funzione

Descrizione

Telnet

23

TCP

Inbound

Telnet

Questo servizio può essere utilizzato per la manutenzione.

SMTP

25

TCP

Outbound

InviaEMail

Questo servizio viene utilizzato da Windows CE / PC Runtime per l'invio di e-mail.

HTTP

80*

TCP

Inbound

Hypertext Transfer Protocol

Il protocollo HTTP viene utilizzato per la comunicazione con il server web HMI.

RFC 1006

102

TCP

Outbound

Canale S7

Comunicazione con il controller S7 tramite Ethernet/PROFINET.

NTP

123

UDP

Outbound

Sincronizzazione dell'ora

Il protocollo NTP (Network Time Protocol) viene utilizzato nelle reti basate su IP per la sincronizzazione dell'ora.

DCOM***

135

TCP

Inbound

Server OPC

Questo servizio è parte integrante del sistema operativo Microsoft Windows. La comunicazione tramite OPC (DA) è basata su DCOM. Perciò questo servizio è necessario per inizializzare i collegamenti OPC (DA).

DCOM***

**

TCP

Inbound

Server OPC

La comunicazione via OPC (DA) si basa su DCOM e utilizza porte non specificate assegnate dal sistema. Ciò andrebbe tenuto in considerazione durante l'utilizzo di OPC (DA) e la creazione di regole per i firewall.

NetBIOS over TCP/IP

137

UDP

Outbound

Con utilizzo di Remote Fileshare

Connessione/login su un server remoto.

NetBIOS over TCP/IP

138

UDP

Outbound

Con utilizzo di Remote Fileshare

Connessione/login su un server remoto.

SNMP

161

UDP

Outbound

Simple Network Management Protocol

La funzionalità client SNMP viene impiegata da STEP 7 per la lettura di informazioni di stato in dispositivi PROFINET.

HTTPS

443*

TCP

Inbound

Secure Hypertext Transfer Protocol

Il protocollo HTTP viene utilizzato per la comunicazione con il server web HMI tramite Secure Socket Layer (SSL).

Modbus TCP

502*

TCP

Outbound

Canale Modbus TCP

Il protocollo Modbus TCP trova impiego per i collegamenti ai PLC Schneider.

Mitsubishi MC

1025*

TCP

Outbound

Canale Mitsubishi MC

Il protocollo Mitsubishi trova impiego per i collegamenti ai PLC omonimi.

Printing

1032

TCP

Outbound

Printing

Stampa sul pannello di comando (attraverso Ethernet).

HMI Load

2308

TCP

Outbound

Trasferimento

Questo servizio viene utilizzato per il trasferimento di immagini speculari e di dati di configurazione nei pannelli operatore. A partire dalla versione V13 dei Comfort Panel, esso viene sostituito da DeviceManager e SCS. Ci si avvale di questo servizio per il trasferimento in WinCC Runtime Advanced dei dati di configurazione.

HMI Load

50523

TCP

Outbound

Trasferimento

Questa porta viene utilizzata quando la porta 2308 non è disponibile.

Questo servizio viene utilizzato per il trasferimento di immagini speculari e di dati di configurazione nei pannelli operatore. A partire dalla versione V13 dei Comfort Panel, questo servizio viene sostituito da DeviceManager e SCS.

Questo servizio viene utilizzato per il trasferimento di dati di configurazione in WinCC Runtime Advanced.

ALM

4410*

TCP

Inbound, Outbound

Application License Manager

Questo servizio di RT Advanced mette a disposizioni le funzionalità complete per le licenze software e viene utilizzato da Automation License Manager.

OPC UA

4870*

TCP

Inbound

Server OPC UA

Questo servizio è necessario per la comunicazione tramite OPC UA.

HMI Load

5001

TCP

Outbound

Device Manager

Questo servizio viene utilizzato per il trasferimento di immagini speculari e runtime nei pannelli operatore.

HMI Load

5002

TCP

Outbound

SCS (System Configuration Server)

Questo servizio viene utilizzato per il trasferimento di dati di configurazione nei pannelli operatore.

VNC Client

5500

TCP

Outbound

Sm@rtServer

Collegamento VNC Client

VNC Server

5800*

TCP

Inbound

Sm@rtServer

Collegamento VNC Server HTTP

5900*

TCP

Inbound

Sm@rtServer

Collegamento VNC Server

SIMATIC Logon

16389*

TCP

Outbound

UMAC (User Management ans Access Control)

Connessione/login su un server remoto.

Allen Bradley Ethernet/IP

44818

TCP

Outbound

Canale Ethernet/IP

Il protocollo Ethernet/IP trova impiego per i collegamenti ai PLC Allen Bradley.

Reserved

49152 ... 65535

TCP/UDP

Outbound

Il campo della porta dinamico viene ad es. utilizzato per il collegamento alla condivisione remota di file.

* Porta standard modificabile nella configurazione utente

** La porta viene assegnata automaticamente

*** Supportato solo da WinCC Runtime Advance


Protezione dati

Protezione dati

Siemens rispetta i principi della protezione dei dati, in particolare le norme relative alla minimizzazione dei dati (privacy by design). Per il presente prodotto SIMATIC ciò significa: il prodotto non elabora / memorizza alcun dato personale, bensì esclusivamente dati funzionali tecnici (es. time stamp). Se l’utente collega questi dati ad altri (ad es. i piani dei turni) o memorizza dei dati personali sullo stesso supporto (es. un disco rigido) creando in questo modo un riferimento a persone, deve garantire personalmente il rispetto delle disposizioni in materia di protezione dei dati.


Avvertenze per l'utilizzo

Contenuto Modifiche nella reazione dopo l'aggiornamento Percorso di installazione Utilizzo di diritti utente standard Tastiera a schermo (Advanced) Cambio del pannello operatore - set di caratteri (RT Professional) Testi nella simulazione (RT Professional) Caricamento delle modifiche online con cicli definiti dall’utente (RT Professional) Trasferimento delle licenze tramite S7USB Trasferimento della licenza su un pannello operatore con sistemi operativi a 64 bit Set di caratteri Postscript Compiti con trigger di variabili
Avvertenze per l'utilizzo

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Modifiche nella reazione dopo l'aggiornamento

Rispetto alle versioni precedenti, la nuova versione di WinCC contiene nuove funzioni e miglioramenti. È pertanto probabile che in seguito all'aggiornamento alle nuove versioni, le denominazioni o il comportamento di proprietà e funzioni abbiano subito lievi variazioni. Anche le proprietà standard dei nuovi oggetti creati possono essere cambiate rispetto alle versioni precedenti.

Queste modifiche del comportamento possono causare problemi durante la compilazione del progetto.

Percorso di installazione

Se in una versione precedente era stata installata la simulazione, non è possibile adattare il percorso di installazione durante l'installazione stessa.

Utilizzo di diritti utente standard

Se si utilizza Windows 7 con diritti utente standard non deve essere disattivato il "Controllo dell'account utente" (UAC).

In Windows 7 il "Controllo dell'account utente" è attivo per default.

Ulteriori informazioni sul "Controllo dell'account utente" sono riportate nella Guida in linea a Windows 7.

Tastiera a schermo (Advanced)

Quando è aperto TIA Portal non è possibile richiamare la tastiera a schermo.

La si deve richiamare da Windows con i seguenti comandi: "Start > Tutti i programmi > Accessori > Accessibilità > Tastiera su schermo".

Cambio del pannello operatore - set di caratteri (RT Professional)

Se negli oggetti della pagina per testi multilingue sono stati progettati più set di caratteri nelle diverse lingue del progetto, si consiglia un controllo delle pagine dopo un cambio del pannello operatore da un Panel ad un runtime basato su PC. Può accadere che i set di caratteri progettati subiscano modifiche dovute al cambio del pannello operatore.

Testi nella simulazione (RT Professional)

Se per la simulazione viene utilizzata una lingua di runtime che non corrisponde a una lingua installata del prodotto, vengono visualizzati testi del sistema in una delle lingue del prodotto installate. A seconda del sistema operativo e delle lingue del prodotto installate si tratta della lingua inglese o cinese.

Se si desidera vedere tutti i testi in giapponese, coreano o taiwanese nella simulazione nelle relative lingue, installare innanzitutto WinCC senza simulazione. Successivamente installare WinCC Runtime Professional con le lingue richieste.

Caricamento delle modifiche online con cicli definiti dall’utente (RT Professional)

Se si sono progettati dei cicli individuali nell'editor "Cicli", al momento di caricare il progetto selezionare il comando "Carica > Software (compilazione completa)". Non è possibile caricare solo le modifiche online.

Trasferimento delle licenze tramite S7USB

È possibile trasferire una licenza su un pannello operatore tramite S7USB solo da WinCC.

Trasferimento della licenza su un pannello operatore con sistemi operativi a 64 bit

Se il sistema operativo a 64 bit in Automation License Manager non dispone del comando di menu "Modifica > Collega sistemi di destinazione > Collega pannello operatore", aprire la riga di comando e, avvalendosi dei diritti di amministratore, eseguire il seguente comando:

"%WINDIR%\system32\RegSvr32.exe" "%CommonProgramFiles%\siemens\AlmPanelPlugin\ALMPanelParam.dll"

Set di caratteri Postscript

In TIA Portal si possono utilizzare solo set di caratteri contenenti dati TrueType. Set di caratteri PostScript e Open-Type contenenti dati PostScript non vengono supportati.

Compiti con trigger di variabili

Un compito con trigger di variabili viene eseguito se il valore delle variabili interne viene scritto. Anche se il valore delle variabili interne non viene modificato.


Migrazione

Contenuto Migrazione di un progetto creato con WinCC V7 Migrazione di un progetto integrato con oggetti ProTool Segnalazione stato di avanzamento
Migrazione

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Migrazione di un progetto creato con WinCC V7

Presupposto per la migrazione è che questo progetto sia stato elaborato almeno con WinCC V7 Update 3.

Migrazione di un progetto integrato con oggetti ProTool

Se si migra un progetto WinCC flexible integrato in STEP 7 e viene emessa la segnalazione di errore "Manca/no pacchetto/i opzionale/i PROTOOL in STEP 7" significa che è stato installato WinCC flexible 2008 SP3 o più recente. Inoltre il progetto contiene ancora oggetti progettati con ProTool. Non aprire il progetto con WinCC flexible! Per eseguire la migrazione del progetto procedere nel seguente modo:

  1. Aprire il progetto in SIMATIC Manager.

  2. Selezionare il menu "File" ed eseguire il comando "Salva con nome".

  3. Nella finestra di dialogo "Salva progetto con nome" attivare l'opzione "Riorganizza".

  4. Fare clic su "OK".

  5. Copiare nuovamente il progetto sul computer originario.

  6. Riavviare la migrazione.

Segnalazione stato di avanzamento

Quando la segnalazione dello stato di avanzamento ha raggiunto il 100%, il software sta ancora svolgendo operazioni residue, quali ad es. la chiusura di riferimenti e non è pertanto in grado di reagire ai comandi inviati dalla superficie utente.


Sistema di engineering

Sistema di engineering

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Pagine e oggetti delle pagine
  • Variabili e collegamenti
  • Sistema di segnalazione e viste segnalazioni
  • Funzioni di sistema e script
  • Protocolli
  • Ricette
  • Amministrazione utenti
  • Comunicazione


Pagine e oggetti delle pagine

Contenuto Oggetti di visualizzazione dopo il cambio del pannello operatore Raggruppamento di oggetti delle pagine Numerosi oggetti della pagina con svariate proprietà di visualizzazione Dinamizzazione di oggetti raggruppati (RT Professional) Dinamizzazione di faceplate (RT Professional) Numero di caratteri nelle caselle di testo, negli elenchi e nei testi delle segnalazioni Trasparenza in WinCC dalla versione V13 Visualizzazione di pagine web SIMOTION PLC nel browser HTML Differenze tra la rappresentazione della progettazione e la visualizzazione nel pannello operatore Panoramica GRAPH (RT Professional) Aggiornamento dei faceplate con gli UDT del tipo "Temporizzatore IEC" Control sovrapposti con animazione della visibilità Vista della diagnostica di sistema: Livello di protezione di accesso "Accesso HMI" Tipi di carattere per i titoli di oggetti finestra (Panels, Runtime Advanced) Tipi di grafiche non validi negli elenchi di grafiche dopo l’aggiornamento (Runtime Professional) Grafiche multilingue nei faceplate Modifiche della rete nella Vista codice PLC (RT Professional) Control personalizzati Tipi di dati per supportati per animazioni
Pagine e oggetti delle pagine

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Oggetti di visualizzazione dopo il cambio del pannello operatore

Si consiglia, dopo l'aggiornamento di un pannello operatore a nuove versioni, il controllo delle pagine contenute nel progetto. Per effetto del nuovo aspetto delle interfacce e delle funzioni ottimizzate, può accadere ad es. che i testi nei campi I/O simbolici non siano completamente leggibili e che vi si sovrappongano elementi di comando.

Raggruppamento di oggetti delle pagine

Se si raggruppano oggetti delle pagine in WinCC si possono verificare problemi di performance di WinCC in presenza di gerarchizzazioni profonde.

Numerosi oggetti della pagina con svariate proprietà di visualizzazione

L'impiego di oggetti della pagina con numerose e diversificate proprietà di visualizzazione (ad es. numerosi e svariati stili) può comportare una riduzione della performance in runtime ed un incremento del fabbisogno di spazio di memoria. Evitare ad es. di apportare troppi smussamenti agli spigoli: 0 pixel, 1 pixel, 2 pixel, 3 pixel, etc.

Dinamizzazione di oggetti raggruppati (RT Professional)

Nella dinamizzazione con funzioni di sistema in presenza di gruppi caratterizzati di diversi annidamenti (gruppo nel gruppo, faceplate nel gruppo, gruppi nel faceplate ...), possono essere utilizzati soltanto gli eventi dei gruppi più all'esterno e degli oggetti più all'interno. Le funzioni di sistema progettate per gli eventi del gruppo o del faceplate subordinato non vengono eseguite.

La progettazione di animazioni di movimenti simultanee di un gruppo di oggetti e oggetti all'interno dello stesso gruppo può venire eseguita in modo diverso da quanto previsto. Controllare la sequenza di esecuzione in runtime e adattare di conseguenza la progettazione.

Dinamizzazione di faceplate (RT Professional)

La dinamizzazione di un'istanza di faceplate con collegamento del tipo di dati dell'utente non è prevista, ma in determinati scenari può essere realizzata per mezzo di una variabile ausiliaria. Osservare le avvertenze in FAQ 109766634.

Numero di caratteri nelle caselle di testo, negli elenchi e nei testi delle segnalazioni

Il numero dei caratteri utilizzabili nel testo dell'oggetto di una pagina non è costante. Quando si specificano dati di testo vengono incluse automaticamente anche le istruzioni di comando e la formattazione e il numero massimo di caratteri diminuisce di conseguenza.

Trasparenza in WinCC dalla versione V13

Le grafiche trasparenti possono essere rappresentate in runtime senza comprometterne la qualità. Questo vale per tutti i Comfort Panel e per WinCC Runtime Advanced a partire dalla versione 13.0.
Per l'impiego della trasparenza in una vista grafica o in un campo I/O grafico, impostare su "Trasparente" la proprietà "Motivo di riempimento" e disattivare la proprietà "Utilizza colore trasparente".

Visualizzazione di pagine web SIMOTION PLC nel browser HTML

Se le pagine web di SIMOTION PLC non vengono visualizzate correttamente nel browser HTML, inserire "/basic" dopo l'URL per visualizzarle nella modalità di base.

Differenze tra la rappresentazione della progettazione e la visualizzazione nel pannello operatore

A causa della configurazione del display la rappresentazione dei testi progettati negli oggetti di pagina può essere diversa da quella del pannello operatore. Se nella progettazione si utilizzano le opzioni di adattamento automatico delle dimensioni è importante controllare in che modo viene rappresentato il testo nelle diverse lingue.

Se i testi progettati con l'opzione "Adatta dimensioni oggetto a contenuto" non possono essere visualizzati per intero nel pannello operatore, vengono leggermente rimpiccioliti. Se, riducendo le dimensioni, i testi compaiono distorti si deve disattivare l'opzione "Adatta dimensioni oggetto a contenuto" e ingrandire il testo aggiungendo degli spazi vuoti. In opzione si può allargare l'oggetto o riformulare il testo in modo da abbreviarlo.

Panoramica GRAPH (RT Professional)

Durante l’upgrade a V14 la firma della funzione C viene modificata nell’evento “Fare clic". Il parametro esistente nelle versioni precedenti propertyName è stato eliminato. Le funzioni che accedono a questo parametro vengono segnalate come errate dopo l'upgrade.

Aggiornamento dei faceplate con gli UDT del tipo "Temporizzatore IEC"

Dai tipi di dati PLC definiti dall'utente (UDT) che utilizzano il tipo di dati "Temporizzatore IEC" è stato eliminato automaticamente l'elemento "ST". Adeguare i faceplate che contengono questi UDT a una nuova versione degli UDT senza elemento ST.

Maggiori dettagli al proposito sono contenuti nella FAQ con il numero di articolo "109740393" nel SIMATIC Customer Online Support.

Control sovrapposti con animazione della visibilità

La progettazione sovrapposta di Control basati su tabella con animazione della visibilità può causare dei problemi nell'utilizzo dello schermo tattile sui dispositivi con sistema operativo Windows CE/Embedded Compact.

Vista della diagnostica di sistema: Livello di protezione di accesso "Accesso HMI"

In caso di utilizzo del livello di protezione "Accesso HMI" con un PLC SIMATIC S7-1200, la visualizzazione corretta dei dati di diagnostica può essere garantita soltanto a partire dalla versione firmware 4.1 o superiore.

Tipi di carattere per i titoli di oggetti finestra (Panels, Runtime Advanced)

Il tipo di carattere che si configura nelle impostazioni di runtime del dispositivo non viene utilizzato nelle finestre delle segnalazioni, della diagnostica di sistema e nei titoli delle finestre di dialogo.

Tipi di grafiche non validi negli elenchi di grafiche dopo l’aggiornamento (Runtime Professional)

Se il progetto viene aggiornato alla versione V16 del TIA Portal, i tipi di grafiche non validi dell’elenco grafiche generano errori di compilazione che nella versione V14 vengono visualizzati come avvisi.

Per evitare segnalazioni di errore durante la compilazione, può essere necessaria la correzione del tipo di grafica nell'elenco grafiche.

Grafiche multilingue nei faceplate

Inserire una grafica nell'oggetto della pagina di un faceplate. Questa grafica viene utilizzata in tutte le lingue definite per il progetto.

Se aperta dal menu di scelta rapida "Modifica", utilizzando l'opzione "Modifica grafica centralmente", la grafica in oggetto, dopo essere stata elaborata e salvata in un editor esterno, ad es. MS Paint, viene modificata soltanto per la lingua di progetto attualmente definita. La modifica della grafica è visibile in tutti gli oggetti che utilizzano questa grafica.

Modifiche della rete nella Vista codice PLC (RT Professional)

Se una delle segnalazioni ProDiag è pendente, le modifiche della rete vengono aggiornate in runtime nella Vista codice PLC.

Perché tali modifiche, in particolare quelle rilevanti per l'analisi dei criteri, vengano visualizzate correttamente nella Vista codice PLC, è necessario rigenerare la segnalazione.

Control personalizzati

La visualizzazione dei "Control personalizzati" nel sistema di engineering non è probabilmente corretta. Le possibilità di progettazione di questi Control sono comunque illimitate. Anche per quanto concerne la visualizzazione e l'utilizzo in runtime non sussistono limitazioni. Se questo Control deve essere basato sulla tecnologia OCX, si raccomanda di passare a .Net.

Tipi di dati per supportati per animazioni

Come tipi di dati per animazioni all'interno di una pagina sono ammessi valori interi e valori booleani.


Variabili e collegamenti

Contenuto Multiplexaggio di variabili (Basic Panel) Variabili con indirizzamento simbolico e tipo di dati "Char Array" (RT Professional) Indicazione della lunghezza per variabili del tipo "String" (RT Professional) Variabile di tipo "String" per collegamenti con i controllori SIMOTION (Panels, RT Advanced) Variabili in “ID box variabile" (Mobile Panel) Elementi array in WinCC Utilizzo di tipi di dati a 64 bit Diagnostica di sistema di PLC nel sistema R/H nel funzionamento non ridondante
Variabili e collegamenti

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Multiplexaggio di variabili (Basic Panel)

Con il multiplexaggio di una variabile con una variabile esterna su un Basic Panel, con il primo ciclo di lettura in runtime viene letto l'indirizzo dal PLC. Il valore dell'indirizzo letto è disponibile solo con il secondo ciclo di lettura.

Variabili con indirizzamento simbolico e tipo di dati "Char Array" (RT Professional)

Le variabili con indirizzamento simbolico e tipo di dati "WString" non sono abilitate per la comunicazione di RT Professional e SIMATIC S7-1200 V3.

Indicazione della lunghezza per variabili del tipo "String" (RT Professional)

Nell’editor “Variabili" l’indicazione della lunghezza per le variabili HMI interne del tipo "String" non è attiva. Se si vuole limitare la lunghezza delle variabili, ad es. per una casella di immissione o una casella di visualizzazione, limitare la lunghezza utilizzando VB Scripting o C Scripting.

Variabile di tipo "String" per collegamenti con i controllori SIMOTION (Panels, RT Advanced)

Per i controllori SIMOTION la lunghezza della variabile String non deve superare una lunghezza di 210 caratteri.

È possibile creare una variabile String con più di 210 caratteri nel sistema di engineering. Tuttavia questa variabile non viene scritta in Runtime. Un messaggio segnala che il limite del valore è al di fuori della variabile.

In questo caso adeguare la lunghezza della variabile String.

Variabili in “ID box variabile" (Mobile Panel)

La variabile che progetta in “Impostazioni Runtime > Generale" in “ID box variabile" può essere utilizzata solo in modalità protetta in scrittura.

In questa variabile non possono essere scritti valori, tuttavia essa può essere letta ad es. in script o visualizzata nelle pagine.

Elementi array in WinCC

Quando si collega una variabile HMI con un array di un blocco dati STEP 7 che non inizia con un limite inferiore pari a 0, gli elementi array vengono rappresentati in WinCC sul limite inferiore 0.

Affinché l'utente non debba preoccuparsi di distinguere tra l'indice STEP 7 e quello WinCC quando accede ai singoli elementi array, i limiti inferiori degli array dovrebbero iniziare da 0 anche in STEP 7.

Utilizzo di tipi di dati a 64 bit

Se si utilizzano tipi di dati a 64 bit può verificarsi una piccola perdita di precisione, poiché questi tipi di dati vengono rappresentanti nel canale HMI sul tipo di dati Double. Pertanto può accadare che i tipi di dati interi vengano visualizzati con cifre decimali.

Diagnostica di sistema di PLC nel sistema R/H nel funzionamento non ridondante

In un sistema R/H sono stati progettati due PLC con i relativi collegamenti. Se il sistema R/H non si trova nel funzionamento ridondante, può accadere che le viste dalle diagnostica di sistema dei due collegamenti visualizzino per lo stesso PLC simboli diversi della diagnostica di stato.


Sistema di segnalazione e viste segnalazioni

Contenuto Variabili booleane negli archivi delle segnalazioni Messaggi PLC Segnalazioni del controllore in runtime (WinCC Professional) Copia di progetti con collegamenti integrati
Sistema di segnalazione e viste segnalazioni

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Variabili booleane negli archivi delle segnalazioni

Le variabili di tipo Bool vengono riconosciute come 0 e -1 nell'archivio delle segnalazioni. Se si utilizza un elenco di testi comandato da una variabile di tipo Bool in un archivio segnalazioni, inserire nell'elenco corrispondente anche una voce per il valore -1.

Messaggi PLC

Un messaggio PLC è visibile nell’editor “Messaggi" di un dispositivo HMI solo se esiste anche un blocco dati di istanza per questo FB.

Segnalazioni del controllore in runtime (WinCC Professional)

Se un progetto delle versioni V13SP1 o V13 SP2 viene aggiornato alle versioni V14, V14 SP1, V15, V15.1, V16, è necessario compilarlo e caricarlo nel controllore e nel pannello operatore. Altrimenti le segnalazioni del controllore vengono visualizzate nella vista segnalazioni in modo barrato.

Copia di progetti con collegamenti integrati

Con la copia dei dispositivi e delle rispettive connessioni integrate (tra pannelli operatore e controllori) da un progetto in una biblioteca globale, e il relativo inserimento da quest'ultima in un nuovo progetto, le informazioni sulle segnalazioni controllore nel pannello operatore potrebbero andare perdute. Per prevenire la perdita di informazioni, nel nuovo progetto copiare innanzitutto tutti i controllori, quindi tutti i pannelli operatore.


Funzioni di sistema e script

Contenuto Script nei progetti Service (RT Professional) Simulazione con Script debugger Variabili di trigger di funzioni definite dall'utente (RT Professional) Funzioni definite dall'utente nel faceplate Funzioni di sistema di elaborazione bit (Mobile Panels e RT Advanced) Proprietà non più utilizzate (Comfort Panel e RT Advanced) Trasferimento dei parametri agli script VB (Panel e RT Advanced) Impostazione della vista delle curve tramite la funzione definita dall’utente Numero massimo di parametro (Panels e RT Advanced) Funzione di sistema "VisualizzaFinestraConnessione" (Panels e RT Advanced)
Debug Err
Funzioni di sistema e script

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Script nei progetti Service (RT Professional)

Poiché nei progetti Service non è generalmente registrato alcun utente interattivo, i C Script e VB Script possono causare problemi ad es. nei seguenti casi:

  • Se gli script richiedono interazioni, ad es. immissioni.

  • Se gli script visualizzano box di messaggi.

Nel modo Service non è presente alcun campo dati comune dei C Script. Pertanto non è possibile ad es. realizzare uno scambio di variabili C globali tra "Schedulazioni" e "Pagine".

Simulazione con Script debugger

Affinché la "Simulazione con Script debugger" possa essere avviata da TIA Portal, la Registry Key
HKEY_CLASSES_ROOT\CLSID\{834128A2-51F4-11D0-8F20-00805F2CD064}\LocalServer32 deve contenere una registrazione "(standard)" di tipo "String" contenente a sua volta il percorso completo allo Script debugger standard "devenv.exe". Il debugger può essere collegato ad una simulazione già in corso senza questa Registry Key.

Variabili di trigger di funzioni definite dall'utente (RT Professional)

Se è stata progetta una pagina con un tipo di dati utente HMI o PLC, nelle nuove funzioni utente personalizzate o in quelle modificate non è possibile impiegare gli elementi del tipo di dati utenti come variabile di trigger.

Funzioni definite dall'utente nel faceplate

Per accedere ad una variabile in un faceplate con una funzione definita dall'utente non è possibile comporre il nome della variabile in modo dinamico.

Funzioni di sistema di elaborazione bit (Mobile Panels e RT Advanced)

Gli array di bit non possono essere manipolati sulla base degli eventi. Funzioni di sistema quali InvertBit, SetBit etc. non devono contenere, come argomento, elementi di un array di bit.

Proprietà non più utilizzate (Comfort Panel e RT Advanced)

WinCC V13 è stato arricchito di una vasta gamma di nuove proprietà di visualizzazione, mentre sono state armonizzate molte proprietà preesistenti.

In seguito all'aggiornamento delle proprietà degli oggetti, può accadere che l'utilizzo di alcune proprietà delle versioni meno recenti di WinCC, in precedenza utili negli script VB, non sia più supportato in WinCC V13. Gli script che utilizzano proprietà non più supportate conservano validità, i richiami di queste ultime negli script interessati durante il runtime sono tuttavia privi di funzione. Queste limitazioni si riferiscono esclusivamente ai Comfort Panel e RT Advanced della versione V13.0.

La tabella sottostante fornisce una panoramica delle proprietà non più utilizzate degli oggetti della pagina:

Proprietà | Oggetto della pagina
BorderBrightColor3D | Barra di scorrimento
BorderColor | Casella di testo, campo E/A, campo E/A simbolico, campo per Data/ora
BorderInnerWidth3D | Barra di scorrimento
BorderOuterWidth3D | Barra di scorrimento
BorderShadeColor3D | Barra di scorrimento
BorderStyle3D | Casella di testo, campo E/A, pulsante, campo E/A simbolico, campo E/A grafico, campo per Data/ora, barre, interruttori
BorderWidth | Casella di testo, campo I/O simbolico
CenterColor | Strumento indicatore
DialColor | Strumento indicatore
EdgeStyle | Casella di testo, campo I/O

Trasferimento dei parametri agli script VB (Panel e RT Advanced)

In WinCC è possibile stabilire se assegnare i parametri degli script VB "ByRef" (indirizzo del parametro) o "ByVal" (valore del parametro).

L'assegnazione dell'indirizzo del parametro con l'aiuto di "ByRef" (Call by Reference) è possibile solo per le variabili interne dello script VB. Nel caso delle variabili HMI viene sempre trasmesso il parametro, a prescindere che il parametro sia definito come "ByRef" o come "ByVal".

Impostazione della vista delle curve tramite la funzione definita dall’utente

Se si leggono valori da un archivio con una funzione VBS per visualizzarli in una vista delle curve, è necessario fare attenzione che la differenza di data e ora sia superiore a zero.

Numero massimo di parametro (Panels e RT Advanced)

Il numero massimo di parametri di una funzione globale è 8 per il tipo "sub" e 7 per il tipo "func".

Funzione di sistema "VisualizzaFinestraConnessione" (Panels e RT Advanced)

Per Panel e Runtime Advanced la funzione di sistema "VisualizzaFinestraConnessione" non dovrebbe essere progettata sull'evento "Modifica valore" di una variabile.


Protocolli

Contenuto Stampa di protocolli (Panel)
Protocolli

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Stampa di protocolli (Panel)

A seconda della stampante impiegata può accadere che gli oggetti collocati sul margine nei protocolli vengano tagliati durante la stampa.

Accertarsi che le dimensioni del protocollo siano adeguate.


Ricette

Contenuto Sincronizzazione ricetta (Basic Panels, Panels, Comfort Panels e RT Advanced)
Ricette

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Sincronizzazione ricetta (Basic Panels, Panels, Comfort Panels e RT Advanced)

In caso di invio di valori di record di dati al controllo numerico, i valori vengono validati solo se per la ricetta in "Generale > Sincronizzazione > Impostazioni" è attivata l’opzione "Trasferimento manuale di singoli valori modificati (funzionamento Teach-In)".


Amministrazione utenti

Contenuto Utenti di dominio UMAC
Amministrazione utenti

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Utenti di dominio UMAC

In WinCC V16.0 possono essere utilizzati solo utenti UMAC locali e non utenti di dominio UMAC.


Comunicazione

Contenuto Creazione del collegamento con WinCC Runtime Advanced Sostituzione di un collegamento non integrato con un altro Interruzioni del collegamento nel caso dei controllori Mitsubishi Certificati autofirmati (RT Professional) Precisione del tipo di dati "DTL" Numero limitato di possibili collegamenti HMI Utilizzo di PROFINET IO sui pannelli operatore Comunicazione di RT Advanced con un S7-1200 tramite Station Manager (SIMATIC NET) Modifica di impostazioni IP e nome dispositivo di un controllore nel Control Panel del pannello operatore (Basic Panels) "Impostazione dell'IP Suite (indirizzo) del PLC nel Control Panel" in SIMATIC S7-1200 V1 (Basic Panels) Collegamenti tramite PROFIBUS DP Cambio di un collegamento Comunicazione di Runtime Professional con SIMATIC S7-1200 RT Advanced in Station Manager Comunicazione di dati grezzi nei progetti ridondanti (RT Professional) Collegamento non integrato con un software controller SIMATIC S7-1500 (RT Advanced) Aree di trasferimento per il modo di funzionamento IO Device e slave DP dei dispositivi HMI Rilevamento dei dati di diagnostica con i dispositivi HMI Comunicazione PROFIEnergy Numero collegamento SmartClient
Comunicazione

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Creazione del collegamento con WinCC Runtime Advanced

Osservare che la versione del pannello operatore progettata nell'Engineering System coincida con la versione del Runtime installato altrimenti, durante il caricamento del progetto, la comunicazione non viene instaurata o viene rallentata.

Nel caso in cui la versione del pannello operatore non coincidesse con la versione Runtime installata, sono previste le seguenti alternative:

  1. Modificare la versione del pannello operatore progettata nell'Engineering System.

  2. Installare la versione di WinCC runtime Advanced compatibile alla versione del pannello operatore da progettare.

Sostituzione di un collegamento non integrato con un altro

Se si vuole impostare la comunicazione su un collegamento integrato diverso da quello attuale, ad es. sostituendo Omron con Mitsubishi, si deve verificare che il nuovo collegamento supporti i tipi di dati delle variabili.

Interruzioni del collegamento nel caso dei controllori Mitsubishi

In seguito a una serie di interruzioni del collegamento è possibile che tutte le risorse di collegamento di un controllore Mitsubishi siano occupate e che non sia più possibile ripristinare la connessione. Si consiglia di controllare queste risorse di collegamento nel programma PLC del controllore e di riabilitarle.

Certificati autofirmati (RT Professional)

I certificati autofirmati non sono più supportati.

Se dalla parte del server viene riconosciuto un certificato autofirmato l'autenticazione avviene mediante la chiave PSK messa a disposizione a priori (Pre-shared key). Se la chiave PSK non è compatibile con quella del partner di comunicazione, la comunicazione non funziona.

Precisione del tipo di dati "DTL"

Il tipo di dati "DTL" supporta indicazioni temporali fino all'ordine dei nanosecondi. Poiché i Panel supportano solo indicazioni temporali fino all'ordine dei millisecondi, l'utilizzo nei puntatori di area comporta le seguenti limitazioni:

  • Puntatore di area "Data/ora"
    Per il trasferimento delle indicazioni temporali da un Panel al controllore l'unità di tempo minima valida è 1 millisecondo. Il campo di valori da microsecondi a nanosecondi del tipo di dati "DTL" viene completato con zeri.

  • Puntatore di area "Data/ora PLC"
    Per il trasferimento delle indicazioni temporali da un controllore a un Panel il campo dai microsecondi ai nanosecondi viene ignorato. Sul pannello operatore l'indicazione temporale viene ulteriormente elaborata fino ai millisecondi inclusi.

Numero limitato di possibili collegamenti HMI

Con la compilazione di un dispositivo viene emesso un messaggio di errore secondo il quale la configurazione del collegamento HMI nell'editor "Dispositivi & Reti" non è valida. La causa potrebbe essere il superamento del numero massimo di collegamenti consentiti per il dispositivo HMI o per il PLC.

Verificare il numero massimo di collegamenti consentito. Consultare il manuale dei dispositivi utilizzati.

Utilizzo di PROFINET IO sui pannelli operatore

Se si utilizza PROFINET IO per collegare i tasti diretti e i LED dei pannelli operatore con il controllore, al momento della progettazione è possibile definire in Configurazione HW un offset per l'area di indirizzi degli ingressi e delle uscite.

Se si utilizza una CPU della serie 400 che supporta PROFINET IO insieme a uno dei pannelli operatore qui sotto elencati, vale la limitazione seguente:

L'offset per l'inizio dell'area di indirizzi degli ingressi non deve essere maggiore di quello per l'inizio dell'area di indirizzi delle uscite.

La limitazione vale per i seguenti pannelli operatore:

  • Mobile Panel 177

Per progettare i parametri degli indirizzi aprire il controllore con la CPU della serie 400 in Configurazione HW. Nella finestra della stazione di Configurazione HW selezionare il pannello operatore collegato tramite PROFINET IO. Nella parte inferiore della finestra della stazione viene visualizzata nei dettagli una tabella con le proprietà del pannello operatore. Nella tabella selezionare la riga con gli indirizzi del pannello operatore e aprire le proprietà dell'oggetto dal menu di scelta rapida.

Nella finestra di dialogo "Proprietà dell'oggetto" attivare la scheda "Indirizzi". Selezionare "Ingressi > Inizio" e progettare l'offset per gli ingressi. Selezionare "Uscite > Inizio" e progettare l'offset per le uscite.

Comunicazione di RT Advanced con un S7-1200 tramite Station Manager (SIMATIC NET)

Nel caso della comunicazione di un sistema SIMATIC S7-1200 con un PC con WinCC RT Advanced tramite un router, per il PC valgono le seguenti limitazioni:

  • Windows 7: solo con SIMATIC NET 8.1 installato

Queste limitazioni valgono anche per l'utilizzo di Station Manager. Runtime Advanced tratta sempre i collegamenti con l'aiuto di Station Manager come collegamenti di routing.

Modifica di impostazioni IP e nome dispositivo di un controllore nel Control Panel del pannello operatore (Basic Panels)

Sul pannello operatore è aperto il Control Panel nel menu "Service and Commissoning > IP-Adaptation". Se si intendono modificare le impostazioni IP o il nome dispositivo di un controllore è importante tener conto di quanto segue:

Nel sistema di engineering, nella finestra di ispezione del controllore, alla voce "Proprietà > Generale > Interfaccia PROFINET > Indirizzi Ethernet" si è attivata precedentemente la seguente opzione:

  • "Acquisisci indirizzo IP in altro modo"

  • "Acquisisci nome dispositivo PROFINET in altro modo"

"Impostazione dell'IP Suite (indirizzo) del PLC nel Control Panel" in SIMATIC S7-1200 V1 (Basic Panels)

La funzione "Impostazione dell'IP Suite (indirizzo) del PLC nel Control Panel" non è abilitata per i seguenti controllori:

  • SIMATIC S7-1200 V1

Collegamenti tramite PROFIBUS DP

Se un collegamento tramite PROFIBUS DP viene interrotto e poi riattivato tra un controllore e un pannello operatore, anche tutti gli altri collegamenti PROFIBUS DP vengono sporadicamente interrotti e riattivati nella rete di comunicazione.

Disinserire il nodo separato prima di ricollegarlo.

Cambio di un collegamento

Il cambio di un collegamento da un pannello operatore ad un controllore SIMATIC S7-300/400, ad un controllore SIMATIC S7-1500 o SIMATIC S7-1200, può causare un'interruzione del collegamento.

Tenere presente le seguenti impostazioni nei controllori SIMATIC S7-1500 o SIMATIC S7-1200:

  • Indirizzamento assoluto delle variabili

  • L'opzione "Disattiva comunicazione PUT/GET" deve essere selezionata

  • Il livello di protezione "Protezione completa" non deve essere progettato

Comunicazione di Runtime Professional con SIMATIC S7-1200

Nella produzione la comunicazione di WinCC Runtime Professional con SIMATIC S7-1200 è abilitata solo per sistemi a una stazione.

RT Advanced in Station Manager

Se RT Advanced e WinAC RTX impiegano lo stesso processore di comunicazione di un PC, la comunicazione HMI con SIMATIC S7-1200 e SIMATIC S7-1500 non è possibile.

Comunicazione di dati grezzi nei progetti ridondanti (RT Professional)

Simatic.NET, Named Connections e alcuni blocchi di comunicazione quali ad es. BSEND/BRCV, possono essere utilizzati solo limitatamente nelle stazioni PC con configurazione ridondante perché non è possibile progettare i parametri di collegamento per il server partner ridondante.

Collegamento non integrato con un software controller SIMATIC S7-1500 (RT Advanced)

WinCC non supporta i collegamenti non integrati tra un dispositivo HMI e un software controller SIMATIC S7-1500.

Aree di trasferimento per il modo di funzionamento IO Device e slave DP dei dispositivi HMI

Se è stato attivato il modo di funzionamento "IO Device" o "Slave DP" per i pannelli operatore HMI, nelle proprietà del pannello operatore non si deve inserire né cancellare nessuna area di trasferimento. Se si è inserita o cancellata inavvertitamente un'area di trasferimento, rimuovere il controller e ricollegarlo.

Rilevamento dei dati di diagnostica con i dispositivi HMI

Diversamente da quanto affermato nel sistema di informazione riguardo ai simboli di diagnostica per le unità e i dispositivi, nei dispositivi HMI il seguente simbolo ha il significato qui descritto:

Simbolo | Descrizione
 | Non sono disponibili dati di diagnostica.

Comunicazione PROFIEnergy

Per configurare la comunicazione PROFIEnergy contattare il Customer Support.

Numero collegamento SmartClient

Anche se il Basic Panel consente un numero limitato di collegamenti SmartClient si consigia di progettarne al massimo due. Ogni collegamento ulteriore influisce sulla potenza.


Funzioni valide in più progetti

Contenuto Utilizzo della diagnostica di sistema nel proxy dei dispositivi Inizializzazione di proxy dei dispositivi con i dati di un progetto della versione precedente Importazione ed esportazione dei testi della biblioteca
Funzioni valide in più progetti

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Utilizzo della diagnostica di sistema nel proxy dei dispositivi

Per poter utilizzare in un proxy dei dispositivi IPE la funzione diagnostica di sistema, ad es. una visualizzazione della diagnostica di sistema, inserire le segnalazioni PLC come contenuto di un proxy dei dispositivi.

Inizializzazione di proxy dei dispositivi con i dati di un progetto della versione precedente

Nei progetti con versione Service Pack non è possibile inizializzare il proxy dei dispositivi con i dati di un progetto della rispettiva versione completa.
Per poter inizializzare un proxy dei dispositivi in un progetto di destinazione con i dati di un progetto sorgente si deve aggiornare il progetto sorgente alla versione Service Pack.

Importazione ed esportazione dei testi della biblioteca

I seguenti oggetti non vengono supportati durante l'importazione e l'esportazione dei testi della biblioteca:

  • Importazione: Ricette, elementi della ricetta, set di dati di ricette, segnalazioni HMI, voci degli elenchi di testi, pagine, protocolli.

  • Esportazione: Voci degli elenchi di testi, pagine, protocolli.

  • Importazione ed esportazione di tipi di biblioteche "Pagina".


Compilazione e caricamento

Contenuto Compilazione e caricamento Verifica dei parametri di indirizzo Messaggi di errore durante il caricamento dei dati nel PLC Comfort Panel dalla versione di dispositivo 13.0: backup dei dati al caricamento dei progetti Visualizzazione dei caratteri nei massaggi trasferiti Riduzione delle dimensioni del progetto
Microsoft KB3083806
Compilazione e caricamento

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Compilazione e caricamento

Se durante la compilazione si verificano errori interni o vengono emessi avvisi, compilare il progetto per intero con il comando "Compila > Software (compilazione completa)" del menu di scelta rapida del pannello operatore.

Prima di avviare il funzionamento produttivo compilare l'intero progetto con il comando "Compila > Software (compilazione completa)" nel menu di scelta rapida del pannello operatore.

Se nel progetto si utilizzano delle variabili HMI collegate con le variabili del controllore, prima del pannello operatore compilare anche tutti i blocchi modificati utilizzando il comando "Compila > Software" del menu di scelta rapida.

Verifica dei parametri di indirizzo

Durante la compilazione di un pannello operatore nella navigazione del progetto mediante il comando "Compila > Hardware e Software (solo modifiche)" nel menu di scelta rapida, i parametri di indirizzo del pannello, come ad es. l'indirizzo IP, non vengono verificati. Per assicurarsi che vengano verificati anche i parametri di indirizzo è necessario compilare il pannello operatore nell'editor "Dispositivi & Reti" mediante il pulsante "Compila" nella barra degli strumenti.

Messaggi di errore durante il caricamento dei dati nel PLC

Un pannello operatore e un PLC sono collegati e comunicano tra loro.

Se si accede a una variabile durante il caricamento di dati dal pannello operatore al PLC, nel pannello operatore viene emesso un messaggio di errore.

Comfort Panel dalla versione di dispositivo 13.0: backup dei dati al caricamento dei progetti

Sui Comfort Panel con versione di dispositivo 13.0 o superiore, WinCC assicura che i dati non vadano persi in caso di interruzione della trasmissione e che i dati esistenti sul pannello operatore vengano cancellati solo a trasmissione completata.

Visualizzazione dei caratteri nei massaggi trasferiti

Se durante il trasferimento nei pannelli operatore con versione V12 o precedente, i caratteri dei messaggi non compaiono correttamente, controllare le impostazioni locali in Windows. Impostare quindi la lingua corretta in "Lingua per programmi non Unicode".

Riduzione delle dimensioni del progetto

Durante la compilazione del pannello operatore, un messaggio segnala che le dimensioni del progetto hanno raggiunto i limiti di sistema per il pannello in uso. In questo caso la compilazione completa del software può ridurre le dimensioni del progetto. Eseguire il comando "Compila > Software (Compila tutto)".


Runtime

Runtime

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Informazioni sul funzionamento in runtime
  • Informazioni sul funzionamento dei pannelli in runtime
  • Informazioni sul funzionamento di Runtime Advanced
  • Informazioni sul funzionamento di Runtime Professional
  • Avvertenze sul funzionamento di Runtime Unified


Informazioni sul funzionamento in runtime

Contenuto Focalizzazione in runtime Comportamento della lingua - Layout della tastiera a schermo I valori delle variabili superano la lunghezza massima Testi di segnalazione vuoti Durata dell'inizializzazione degli archivi (Panel, RT Advanced) Archivi di grandi dimensioni rallentano la chiusura del runtime (Basic Panels 2nd Generation) Reazione lenta dello SmartServer Termine della funzione Salvaschermo in Sm@rtServer Come evitare che i file si danneggino in caso di caduta della corrente Tipi di carattere variabili sui pannelli operatore
Informazioni sul funzionamento in runtime

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Focalizzazione in runtime

Se per un pannello operatore della versione 12.0.0 o precedente, la combinazione del colore della focalizzazione e del colore del bordo è povera di contrasti, al momento del successivo passaggio a nuove versioni del pannello operatore in TIA Portal in runtime, può accadere che la focalizzazione non sia più riconoscibile. Modificare uno di questi due colori.

Comportamento della lingua - Layout della tastiera a schermo

Se si commuta in una lingua di runtime non supportata da Windows per il layout della tastiera a schermo, questo non cambia.

In questo caso la lingua della tastiera rimane impostata all'ultima lingua attivata e/o viene utilizzata la lingua impostata del layout della tastiera standard di Windows.

I valori delle variabili superano la lunghezza massima

L'utente immette una stringa di caratteri in una variabile String mediante un campo I/O. Se supera la lunghezza progettata della variabile, la stringa di caratteri viene ridotta alla lunghezza progettata.

Testi di segnalazione vuoti

Runtime funziona con un progetto. Il progetto è salvato su un drive di rete.

In caso di interruzioni con il drive di rete è possibile che il runtime tenti di caricare testi di segnalazione dal drive di rete.

Se il collegamento è interrotto la finestra o la vista delle segnalazioni rimane vuota.

Per evitare questo comportamento copiare il progetto su un drive locale prima di avviarlo in runtime.

Durata dell'inizializzazione degli archivi (Panel, RT Advanced)

L'inizializzazione degli archivi in alcuni supporti di memoria può durare fino a 5 minuti. Il completamento dell'inizializzazione viene confermato da un messaggio di sistema che compare non appena l'inizializzazione è conclusa. Se dovesse mancare un supporto di memoria per l'archiviazione, all'avvio del runtime anche la visualizzazione del messaggio di sistema può durare fino a 5 minuti.

Archivi di grandi dimensioni rallentano la chiusura del runtime (Basic Panels 2nd Generation)

Con l'impiego di archivi di dimensioni particolarmente elevate, il termine del runtime può richiedere molto tempo. Impiegare archivi segmentati in luogo di archivi ciclici troppo grandi.

Reazione lenta dello SmartServer

In Windows 7 i seguenti programmi potrebbero avviarsi e reagire molto lentamente:

  • HMI TouchInputPC

  • SmartServer: combinazione di tasti <Ctrl+Alt+Canc> nella finestra per la connessione

Il ritardo è dovuto alla verifica di certificati Internet revocati.

Rimedio:

Sul DVD del prodotto, nella directory:
Support\Windows\CRL_Check bzw. CD_RT\ Support\Windows7\CRL_Check\
, si trovano i file seguenti:

  • DisableCRLCheck_LocalSystem.cmd

  • DisableCRLCheck_CurrentUser.cmd

  1. Eseguire il file "DisableCRLCheck_LocalSystem.cmd" con diritti di amministratore. Richiamare nel menu di scelta rapida del file il comando "Run as administrator".

  2. Riavviare il PC.

Se il problema non si è ancora risolto procedere nel modo seguente:

  1. Fare doppio clic sul file ed eseguire il file "DisableCRLCheck_CurrentUser.cmd" con diritti utente.

  2. Riavviare il PC

    Nota

    La verifica del certificato su richiamo viene disattivata a livello di utente o di PC. Per ripristinare lo stato iniziale eseguire i file seguenti:

    • RestoreDefaults_LocalSystem.cmd

    • RestoreDefaults_CurrentUser.cmd

    I file sono contenuti nella seguente directory del DVD del prodotto:

    • Support\Windows\CRL_Check bzw. CD_RT\Support\Windows7\CRL_Check\

Termine della funzione Salvaschermo in Sm@rtServer

Se il salvaschermo è attivato sullo Sm@rtServer del pannello operatore server, per terminare la funzione Salvaschermo su questo pannello è necessario disporre del diritto di accesso in scrittura da Sm@rtClient.

Come evitare che i file si danneggino in caso di caduta della corrente

Se si verifica una caduta di corrente nei sistemi Windows mentre il sistema WinCC è attivo, i file possono danneggiarsi anche irreparabilmente. Il sistema di file NTFS offre una maggiore sicurezza,

anche se solo l'uso di un gruppo di continuità (UPS) è in grado di garantire con sicurezza un funzionamento ininterrotto.

Tipi di carattere variabili sui pannelli operatore

Windows 10 supporta tipi di carattere variabili dalla versione 1709 ("OpenType Font Variations"). Nell'engineering system è possibile utilizzare anche le varianti di un tipo di carattere variabile. La rappresentazione effettiva in runtime dipende dal pannello e dalle condizioni di installazione:

  • Basic Panel, Comfort Panel: i tipi di carattere variabili non sono supportati. È sempre visualizzata la variante di base.

  • Runtime Advanced, Runtime Professional: I tipi di carattere variabili sono supportati se si utilizza almeno Windows 10 Versione 1709 come sistema operativo e il tipo di carattere è installato con diritti di amministratore.


Informazioni sul funzionamento dei pannelli in runtime

Contenuto Utilizzo della rotellina del mouse in runtime Backup sulla scheda di memoria del PLC (Basic Panel) Panel Data Storage e S7-1500F (Basic Panel) Funzione "Panel Data Storage" (Basic Panel) Tipi di carattere con estensione ".ttx" Trasferimento dati di massa tramite USB Modifica dell'indirizzo IP e del nome del dispositivo nei Panel
Informazioni sul funzionamento dei pannelli in runtime

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Utilizzo della rotellina del mouse in runtime

Nessun pannello operatore supporta l'utilizzo della rotellina del mouse in runtime.

Backup sulla scheda di memoria del PLC (Basic Panel)

Si crea il file di backup "A.psb" sulla scheda di memoria del PLC. Durante la creazione del backup si verifica un errore, ad es. un'interruzione del collegamento.
Di conseguenza si genera un file errato sulla scheda di memoria del PLC. Questo tipo di file ha come prefisso "~$".
Cancellare il file con il prefisso "~$" se si vuole memorizzare nuovamente un backup con lo stesso nome "A.psb".

Panel Data Storage e S7-1500F (Basic Panel)

Se si utilizza la password per il livello di protezione "Full access incl. fail-safe", la funzione "Panel Data Storage" PDS non può essere impiegata sui Basic Panel in combinazione con S7-1500F.

Funzione "Panel Data Storage" (Basic Panel)

La funzione "Panel Data Storage" (PDS) disponibile sui Basic Panel supporta solo SIMATIC S7-1200 dal firmware V4.0 e SIMATIC S7-1500. Per la funzione PDS il pannello deve essere collegato direttamente con la CPU e non deve essere collegato attraverso il CP.

Tipi di carattere con estensione ".ttx"

I caratteri con l'estensione ".ttx" sono disponibili in tutti i Panel e in Runtime Advanced e possono essere rappresentati correttamente in tutti i dispositivi, ad es. il carattere “WinCC_flexible_smart“.

Trasferimento dati di massa tramite USB

Se si installa Windows 10 sul PC di progettazione, il canale di trasferimento USB non è disponibile.

Tale restrizione vale per i seguenti dispositivi e applicazioni:

  • Basic Panel: KP300 Basic, KP400 Basic, TP1500 Basic

  • Mobile Panel: serie 170 e 270

  • WinCC Engineering System

  • Service Tool "ProSave"

Nota

Il canale di trasferimento "USB" rimane disponibile se sul PC di progettazione sono installati Windows 7.

Rimedio

Utilizzare altri canali di trasferimento per la trasmissione dei dati di progetto, ad es. il canale "Industrial Ethernet" o "PROFIBUS DP".

Modifica dell'indirizzo IP e del nome del dispositivo nei Panel

Nei Comfort Panel è possibile modificare l'indirizzo IP o il nome del dispositivo anche quando è avviato il runtime.

Nei Basic Panel la modifica dell'indirizzo IP o del nome del dispositivo non è invece consentita quando il runtime è operativo.


Informazioni sul funzionamento di Runtime Advanced

Contenuto Avvio del runtime Autorizzazione all'avvio di Runtime Advanced Screen saver su computer con Windows 10 Windows 10 in modalità tablet .Net-Controls in runtime Disattivazione del controllo automatico degli aggiornamenti software Accesso alle variabili di array tramite OPC
Informazioni sul funzionamento di Runtime Advanced

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Avvio del runtime

Dal sistema di engineering può essere avviato solo WinCC Runtime V16. Altre versione di WinCC Runtime possono essere solo simulate.

Autorizzazione all'avvio di Runtime Advanced

Su un computer con sistema operativo Windows è possibile avviare WinCC Runtime Advanced solo se l’utente che avvia il runtime è assegnato al gruppo "Siemens TIA Engineer" e dispone dei relativi diritti.

Screen saver su computer con Windows 10

Lo screen saver attivato su un computer con Windows 10 non viene più disattivato a causa dell'emissione di una segnalazione della classe "Errore".

Windows 10 in modalità tablet

Si consiglia l'impiego di Windows 10 in modalità tablet.

Se in Windows 10 in modalità tablet, vengono utilizzate applicazioni quali Runtime Advanced, Sinumerik Operate, dopo l'avvio queste applicazioni rimangono aperte in forma ridotta.

.Net-Controls in runtime

Qualora fosse stato integrato nel progetto un .Net-Control come ".Net-Control specifico", i relativi file devono essere copiati nella directory di installazione di WinCC Runtime, per es. "C:\ProgramFiles\Siemens\Automation\WinCC RT Advanced". In caso contrario il caricamento del Control in runtime non è possibile.

Disattivazione del controllo automatico degli aggiornamenti software

Se il sistema di engineering è stato installato in un PC assieme al runtime, l'operatore viene avvisato degli aggiornamenti software. Perché il sistema sia stabile se eseguito in più stazioni si deve installare la stessa versione software in tutti i PC.

Per migliorare le prestazioni si può disattivare il controllo automatico degli aggiornamenti software.

Per disattivare il controllo automatico degli aggiornamenti software in “Impostazioni > Generale > Aggiornamenti software” disattivare l’opzione “Controlla aggiornamenti ogni giorno".

Accesso alle variabili di array tramite OPC

Se si utilizza WinCC Runtime Advanced come server server OPC DA, la lettura di variabili di array è supportata soltanto se è attiva l'impostazione "OPC UA Server Array index range access".

La scrittura di variabili di array è possibile soltanto se il client OPC UA Client supporta l'impostazione "Write array elements without IndexRange".


Informazioni sul funzionamento di Runtime Professional

Contenuto Autorizzazioni utente nel sistema operativo blocco delle combinazioni di tasti Barre degli strumenti mobili Collegamento disturbato tra server e client Collegamento disturbato tra server e client Avvio di WinCC Runtime Professional Creazione dei servizi per il server SQL "Segnala errori di sistema" in WinCC Runtime Professional Interfacce WinCC e sistema operativo a 64 bit Grafiche dinamiche in WinCCViewer RT Runtime Professional: Caricamento di un progetto senza collegamento al PC di progettazione Collegamento con S7-1200 nella diagnostica di sistema Disattivazione del controllo automatico degli aggiornamenti software Limitazione della proprietà di caricamento di modifiche online Oggetti della pagina nei protocolli generati come PDF Progetti in runtime dopo l'aggiornamento di Windows 10 Memoria necessaria di archivi
Informazioni sul funzionamento di Runtime Professional

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Autorizzazioni utente nel sistema operativo

  1. Tutti gli utenti devono essere inseriti nel gruppo "SIMATIC HMI". Lo stesso vale per gli utenti che desiderano aprire i progetti WinCC in remoto.

  2. La cartella dei progetti deve disporre delle autorizzazioni NTFS "SIMATIC HMI" con pieno accesso e "SIMATIC HMI Viewer" con diritti di lettura. Le autorizzazioni devono essere trasmesse a tutte le cartelle subordinate.

blocco delle combinazioni di tasti

Per bloccare le combinazioni di tasti in Windows occorre adeguare i criteri di gruppo nella gestione del sistema operativo.

Maggiori dettagli al proposito sono contenuti nella FAQ con il numero di articolo "44027453" nel SIMATIC Customer Online Support:

Internet: WinCC FAQ 44027453

Barre degli strumenti mobili

Se si utilizza l'impostazione "Sempre in primo piano" per la barra delle applicazioni di Windows, è possibile che in runtime le barre degli strumenti che non sono state fissate si spostino dietro la barra delle applicazioni di Windows. Per rendere nuovamente visibili le barre degli strumenti procedere nel seguente modo:

  1. Selezionare il comando "Proprietà" dal menu di scelta rapida della barra delle applicazioni.

  2. Disattivare "Barra delle applicazioni sempre in primo piano".

Collegamento disturbato tra server e client

Se il collegamento tra server e client è disturbato, verificare le impostazioni dell'interfaccia PG/PC. Per la "Parametrizzazione interfacce utilizzata" non utilizzare TCP/IP(Auto). Utilizzare invece indirizzi IP fissi.

Collegamento disturbato tra server e client

Se un computer provvisto di Engineering System viene impiegato contemporaneamente come server ed un client non è in grado di collegarsi a quest'ultimo, controllare le abilitazioni impostate sul server.

  1. Terminare il Runtime sul server.

  2. Nel menu di scelta rapida dell'ambiente di rete sul desktop del server, selezionare il comando "Trova computer...".

  3. Come nome del computer cercato, indicare il nome del server.

  4. Aprire il computer rilevato per individuare le directory abilitate.

  5. Rimuovere tutte le abilitazioni che iniziano con "WinCC_Project_HMI". Per informazioni consultare la documentazione sul sistema operativo.

L'errore è causato dall'attivazione del comando di menu "Salva con nome..." congiuntamente all'avvio del runtime di questo nuovo progetto. Per ragioni di sicurezza è possibile creare copie dei progetti richiamando la funzione "Salva con nome..." . Si consiglia tuttavia di proseguire l'elaborazione nel progetto originario.

Avvio di WinCC Runtime Professional

Se su un PC vengono utilizzati l'Engineering System e Runtime, Runtime o la simulazione di un progetto aperto nell'Engineering System dovrebbero essere avviati e chiusi solo tramite il TIA Portal. Il ricorso ad altre opzioni, quali ad es. l'icona nell' area di notifica della barra delle applicazioni, è sconsigliato.

Quando si configura l'avvio automatico sul client è assolutamente necessario inserire login e password per ogni progetto server registrato. Per poter assegnare un login a ogni server, è necessario confermare l'immissione del rispettivo percorso del progetto con il tasto "Applica". Ciò comporta che in presenza di progetti ridondanti o alternativi è necessario immettere due volte login e password.

Creazione dei servizi per il server SQL

Per garantire la funzionalità completa del server SQL per WinCC e WinCC Runtime, controllare le impostazioni del server SQL.

  1. Avviare nel menu di avvio "Programme > Microsoft SQL Server 2014 > Configuration Tools > SQL Server 2014 Configuration Manager".

  2. Fare clic nell'albero su "SQL Server Services".

  3. Controllare i servizi di "SQL Server (WinCC)", "SQL Server (WINCCPLUSMIG)" e "SQL Server Browser".
    Per "Start Mode" deve essere immesso "Automatic".
    Per "Log On As" deve essere inserito "LocalSystem" per "SQL Server (WinCC)".
    Per "SQL Server Browser" deve essere inserito "LOCALSERVICE"
    Eventualmente modificare le impostazioni.

  4. Fare clic nell'albero su "SQL Server Network Configuration".

  5. Fare clic su "Protocols for WinCC".

  6. Verificare il protocollo "TCP/IP". In "Status" deve essere immesso "Enabled". Modificare se necessario le impostazioni.

"Segnala errori di sistema" in WinCC Runtime Professional

La funzionalità "Segnala errori di sistema" è limitata in WinCC Runtime Professional in interazione con S7-300 e S7-400. In una vista segnalazioni viene visualizzata sempre solo una segnalazione per un tipo di diagnostica. Le segnalazioni relative a ulteriori errori dello stesso tipo di diagnostica non vengono visualizzate.

Interfacce WinCC e sistema operativo a 64 bit

Le interfacce aperte di WinCC Runtime Professional non offrono alcun supporto nativo a 64 bit. Ciò riguarda soprattutto Runtime API, VBS e il provider WinCC OleDB. Per poter utilizzare le interfacce di WinCC con un sistema operativo a 64 bit, è necessario tenere conto di quanto segue:
- Non è possibile avviare gli script VB solo mediante doppio clic, ma è necessario utilizzare esplicitamente la versione a 32 bit alla voce "syswow64\wscript.exe".
- Le applicazioni .NET che utilizzano l'API di WinCC devono essere compilate esplicitamente come applicazioni a 32 bit, e non con "AnyCPU" bensì con "x86".
- Le applicazioni C++ non possono essere compilate come applicazioni a 64 bit.

Grafiche dinamiche in WinCCViewer RT

Se si utilizzano grafiche dinamiche, ad es. collegate a script, queste grafiche non verranno quindi aggiornate in WinCCViewer RT.

Selezionare in "Impostazioni runtime > Impostazioni di grafica" l'opzione "Definito dall'utente".

Runtime Professional: Caricamento di un progetto senza collegamento al PC di progettazione

Prima di avviare il caricamento di un progetto sulla stazione operatore, salvare i dati come "Gestione utente" e "Dati della ricetta".

  1. I dati della gestione utente vengono sovrascritti per default.

    Progettare quindi due pulsanti nel progetto per l'esportazione o l'importazione della gestione utente con la funzione di sistema „Esporta gestione utente“. L'esportazione dei dati è richiesta soltanto se si desiderano apportare delle modifiche in runtime nella Vista utenti.

  2. In fase di caricamento del progetto definire nella finestra di dialogo "Carica anteprima" se si vogliono sovrascrivere i dati della ricetta.

    I dati della ricetta possono essere salvati nella Vista ricette sugli elementi di comando „Esporta archivio“ e „Importa archivio“.

Osservare che verranno utilizzati gli ultimi dati importati o caricati in runtime.

Collegamento con S7-1200 nella diagnostica di sistema

Se si utilizza la diagnostica di sistema WinCC Runtime Professional HMI System può essere collegato solo con un S7-1200 (fino alla versione V3).

Disattivazione del controllo automatico degli aggiornamenti software

Se il sistema di engineering è stato installato in un PC assieme al runtime, l'operatore viene avvisato degli aggiornamenti software. Perché il sistema sia stabile se eseguito in più stazioni si deve installare la stessa versione software in tutti i PC.

Per migliorare le prestazioni si può disattivare il controllo automatico degli aggiornamenti software.

Per procedere selezionare "Impostazioni > Generale > Aggiornamenti software" e disattivare la casella di scelta "Controlla aggiornamenti ogni giorno".

Limitazione della proprietà di caricamento di modifiche online

Se si sostituisce un design la proprietà di caricamento di modifiche online del progetto va persa. TIA Portale non segnala in questo caso alcun messaggio di errore.

Oggetti della pagina nei protocolli generati come PDF

La qualità degli oggetti della pagina nei protocolli generati in runtime come file PDF, dipende dai driver della stampante PDF utilizzati.

Progetti in runtime dopo l'aggiornamento di Windows 10

È stato installato Windows 10 versione 1709 in PC con WinCC Professional V15 e in un PC con WinCC Professional RT V15. Nel PC di runtime è stato eseguito un aggiornamento di Windows 10 alla versione 1803. Dopo l'aggiornamento di Windows 10 potrebbe non essere più possibile aprire manualmente in runtime un progetto caricato dal PC del sistema di engineering.

Rimedio: Impostare manualmente su "Automatico (avvio ritardato)" il tipo di avvio del servizio dell'istanza WinCC SQL, quindi riavviare il sistema.

Memoria necessaria di archivi

Per il calcolo della memoria necessaria per le segnalazioni su tutti i segmenti e per i singoli elementi è necessario conoscere il numero di segnalazioni in arrivo come valore medio al secondo. Viene tenuta in considerazione la memoria necessaria massima di una segnalazione di ca. 4000 byte. Vale:
memoria necessaria = numero di segnalazioni/s * 4000 byte * 60 s/min * 60 min/h * 24 h/giorno * 31 giorni/mese * y mesi.

Nell'esempio viene emessa 1 segnalazione al secondo:

  • Per la grandezza massima su tutti i segmenti per 2 mesi risultano ca. 20 GB

  • Per un segmento singolo risultano al giorno ca. 330 MB

Per il calcolo della memoria necessaria per la disarchiviazione su tutti i segmenti e per i singoli elementi è necessario conoscere il numero di valori archiviati al secondo e la lunghezze media di un valore di processo. Vale:
memoria necessaria = numero di valori archiviati/s * x byte * 60 s/min * 60 min/h * 24 h/giorno * 31 giorni/mese * y mesi.

Nell'esempio vengono emessi 750 valori archiviati al secondo:

  • Per i valori di processo con 16 byte risulta una memoria necessaria di ca. 60 GB

  • Per i valori di processo con 6 byte risulta una memoria necessaria di ca. 22 GB


Pannelli operatore

Pannelli operatore

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Avvertenze sui pannelli operatore


Avvertenze sui pannelli operatore

Contenuto Pannelli operatore non supportati (da TIA Portal V15) Pannelli operatore non supportati (da TIA Portal V15.1) Pannelli operatore non supportati (da TIA Portal V16) Comando a più tasti Pannelli operatore con carico di comunicazione elevato TS Adapter con interfaccia Ethernet Simulazione con collegamento reale al controllore Simulazione dei Basic Panel Basic Panel 2nd Generation Pannelli operatore con sistema operativo Windows CE 5.0 e superiore Cambio di connessione nel Control Panel dei Basic Panel Stampa segnalazioni (Mobile Panel) DHCP su KTP 400 PN, KTP 700 PN e KTP 900 PN Mobile Panel Sm@rtServer con Mobile Panel Simulazione di Basic Panel 2nd Generation: Installazione dei caratteri Interruzione del collegamento DH485 Funzione VB "CDate" (Comfort Panel) Cancellazione della cache del browser (Panel)
PI Mobile
Avvertenze sui pannelli operatore

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Pannelli operatore non supportati (da TIA Portal V15)

TIA Portal V15 e versioni successive non supportano più i pannelli operatore con versione 11.x.

TIA Portal V15 e versioni successive non supportano più i seguenti pannelli operatore.

  • WinAC MP 177, WinAC MP 277, WinAC MP 377

  • Panels: OP e TP delle serie 70, 170 e 270

  • Multi Panel: Multi Panels delle serie 170, 270 e 370

Per poter utilizzare in TIA Portal V15 altri dispositivi, ad es. Basic, Comfort o Mobile Panel, progettati con la versione 11.x si deve modificare la versione del dispositivo specifico.

Anche la struttura di archiviazione della cartella di installazione non contiene più dati per la versione 11.0. In questo modo le dimensioni del pacchetto di installazione di TIA Portal vengono ridotte rispetto alle versioni precedenti.

Pannelli operatore non supportati (da TIA Portal V15.1)

TIA Portal V15.1 e le versioni successive non supportano più i seguenti pannelli operatore:

  • WinCC Runtime Advanced V11

Pannelli operatore non supportati (da TIA Portal V16)

TIA Portal V15.1 e le versioni successive non supportano più i seguenti pannelli operatore:

  • Mobile Panel con versione dispositivo 12.x

  • Comfort Panel con versione dispositivo 12.x

  • KP1500 Comfort con versione dispositivo 13.x

  • TP1500 Comfort con versione dispositivo 13.x

  • TP1900 Comfort con versione dispositivo 13.x

  • TP2200 Comfort con versione dispositivo 13.x

Comando a più tasti

Eseguendo comandi a più tasti si rischia di attivare inavvertitamente azioni indesiderate:

  • Se si utilizza un pannello a tasti non si devono premere più di due tasti funzione contemporaneamente.

  • Se si utilizza un touch screen, un PC standard o un panel PC si deve sempre premere un solo tasto funzione o un tasto alla volta.

Pannelli operatore con carico di comunicazione elevato

Se per un pannello sono stati progettati numerosi collegamenti con controllori o altri pannelli operatore è opportuno disattivare la diagnostica S7. In caso contrario si potrebbe sovraccaricare il pannello.

TS Adapter con interfaccia Ethernet

Se un pannello operatore è collegato tramite Ethernet e un TS Adapter non è possibile resettarlo alle impostazioni di fabbrica.

Simulazione con collegamento reale al controllore

Il punto di accesso utilizzato dalla simulazione non dipende dalle impostazioni effettuate nel sistema di engineering e può essere modificato solo con il tool "Imposta interfaccia PG/PC" nel Pannello di controllo. Se il collegamento ad un controllore viene ristabilito direttamente dopo l'avvio della simulazione con la segnalazione 140001, verificare il punto di accesso utilizzato dalla simulazione con "Imposta interfaccia PG/PC".

  1. Fare doppio clic su "Imposta interfaccia PG/PC" nel Pannello di controllo. Si apre una finestra di dialogo.

  2. Nell'area "Punto di accesso dell'applicazione" selezionare "S7ONLINE" come default per HMI.

  3. Selezionare l'interfaccia nell'area "Parametrizzazione interfaccia utilizzata".

  4. Chiudere la finestra di dialogo "Imposta interfaccia PG/PC" con OK.

Simulazione dei Basic Panel

Per l'emissione di una variabile esterna utilizzare un campo di emissione in un testo di segnalazione. Con la simulazione il contenuto di questo campo di emissione viene sempre visualizzato con "0".

Basic Panel 2nd Generation

I Basic Panel 2nd Generation supportano l’opzione Sm@rtServer.

Se non si utilizza uno hub USB selezionare come percorso di archiviazione la porta USB USB_X60.1.

Pannelli operatore con sistema operativo Windows CE 5.0 e superiore

In seguito alla modifica di un'impostazione di sicurezza nella comunicazione client-server la differenza di tempo tra pannello operatore (client) e un PC (server) non deve essere maggiore di 1 giorno. In caso di backup di dati di ricette dal pannello operatore a un drive di rete, ad es., assicurarsi che l'ora del PC (server) e del pannello operatore (client) sia impostata correttamente.

Cambio di connessione nel Control Panel dei Basic Panel

Se si utilizza la funzione "Override projected connection information" vale la limitazione seguente:

Il cambio di connessione nel Control Panel dei Basic Panel da un controllore senza livello di protezione ad un controllore con il livello di protezione "Protezione completa" non è possibile.

Stampa segnalazioni (Mobile Panel)

La stampa di segnalazioni nel formato PDF o HMTL, non è possibile se nel percorso "Storage Location" è stata selezionata la memoria interna "/flash". Per la stampa di segnalazioni nel formato PDF o HMTL, progettare come percorso di archiviazione una scheda di memoria SD oppure una chiavetta USB.

DHCP su KTP 400 PN, KTP 700 PN e KTP 900 PN

Il funzionamento con DHCP non è consigliabile per i dispositivi KTP 400 PN, KTP 700 PN e KTP 900 PN.

È possibile che il dispositivo non si avvii. In tal caso occorre rimuovere il cavo di rete e riavviare nuovamente il dispositivo. Dopo l'avvio assegnare un indirizzo IP fisso.

Mobile Panel

I Mobile Panel 2nd Generation possono essere configurati con TIA Portal V16, versione V15. Il progetto compilato non può tuttavia essere caricato su questi dispositivi.

Per poter utilizzare i Mobile Panel 2nd Generation in TIA Portal V16 è necessario un aggiornamento almeno alla versione V15.1.

Sm@rtServer con Mobile Panel

L'analisi della condizione di sicurezza attraverso PROFIsafe è garantita solo se lo Sm@rtServer sul pannello operatore è disattivato.

Non è consigliato l'utilizzo di Sm@rtServer su pannelli operatore senza funzione di sicurezza.

Simulazione di Basic Panel 2nd Generation:

Per la simulazione di Basic Panel 2nd Generation deve essere attivata la velocità dell'hardware 3D della scheda grafica.

Installazione dei caratteri

Se sono stati installati in ProSave nuovi set di caratteri su un Panel è necessario riavviare quest'ultimo. La durata dell'operazione di avvio del Runtime dipende dal numero e dimensione dei tipi di carattere.

Interruzione del collegamento DH485

Se nei Comfort Panel il cavo Ethernet viene collegato alla porta "PN_X1" del pannello operatore HMI, si può verificare un'interruzione del collegamento DH485.

Rimedio per Comfort Redesign/PRO Panel: per l'esecuzione del progetto DH485 sul pannello operatore HMI, utilizzare la porta "PN_X3(Gigabit)" per la comunicazione Ethernet.

Funzione VB "CDate" (Comfort Panel)

Sui seguenti pannelli operatore è possibile usare la funzione VB "CDate" solo con parametri statici:

  • TP1200 Comfort Pro

  • TP1500 Comfort Pro / V2

  • TP1900 Comfort Pro / V2

  • TP2200 Comfort Pro / V2

Cancellazione della cache del browser (Panel)

Se si nota che il caricamento dei siti web con il browser HTML dura troppo a lungo, è possibile che la cache del browser sia piena. Per svuotarla eseguire la seguente funzione VBS in runtime. La funzione può essere progettata anche come attività regolare nell’utilità di pianificazione.

Copia il codice di programma seguente negli Appunti.

Sub T7_DeleteBrowserCache()

' delete Browsercache filled temporary objects

Dim fso, nFileIndex,sFileName, nFileAttr, folder

On Error Resume Next

' Variable to show script is active

SmartTags("DeleteBrowserCacheActive") = True

folder = "\flash\simatic\Browsercache\data7\"

' Windows CE

Set fso = CreateObject("FileCtl.FileSystem")

' Get first item that matches path

sFileName = fso.Dir(folder & "*.*")

nFileIndex = 0

'Get the rest of matches

Do While sFileName <> ""

nFileAttr = fso.GetAttr(folder & sFileName)

If (nFileAttr And 16) <> 0 Then

fso.Kill("\flash\simatic\Browsercache\data7\"&sFileName&"\*.*")

If Err.Number <>0 Then

Err.Clear

End If

End If

nFileIndex = nFileIndex + 1

sFileName = fso.Dir

Loop

Set fso = Nothing

SmartTags("DeleteBrowserCacheActive") = False

End Sub


Opzioni

Opzioni

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Sm@rtServer
  • Audit
  • DataMonitor
  • WebNavigator
  • WebUX
  • Redundancy
  • SIMATIC Information Server


Sm@rtServer

Contenuto In Windows 10 aprire i file *.sac di SmartClient
Sm@rtServer

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

In Windows 10 aprire i file *.sac di SmartClient

Salvare i dati del collegamento SmartServer attuale utilizzando il file eseguibile SmartClient.exe con il formato *.sac. Per consentire l'apertura automatica in Windows 10 dei file così creati, si deve aprire una volta manualmente un file *.sac con SmartClient.exe dal pulsante di selezione e dalla finestra di dialogo in SmartClient.exe.


Audit

Indice WinCC Audit Viewer 7.2 Update
Audit

Indice

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle caratteristiche del prodotto.

WinCC Audit Viewer 7.2 Update

Per WinCC Audit Viewer 7.2, installabile in via opzionale, è disponibile un aggiornamento per l'installazione manuale.

Installare l'aggiornamento di WinCC Audit Viewer 7.2, attivando l'esecuzione del file "AuditViewer_V72_00_Upd1.exe" nella directory "Support" sul DVD del prodotto.


DataMonitor

Contenuto Disinstallazione di WinCC Runtime Excel-Workbook su un PC con Windows 7 Vista Diagnostica di canale Fusi orari delle webpart
DataMonitor

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Disinstallazione di WinCC Runtime

Per continuare ad utilizzare DataMonitor anche dopo la disinstallazione di WinCC Runtime Professional è necessario eseguire la riparazione dell'installazione. Procedere nel modo seguente:

  1. Aprire il Pannello di controllo.

  2. Fare doppio clic su "Installazione applicazioni".

  3. Nell'elenco dei programmi installati selezionare "SIMATIC WinCC/DataMonitor Client".

  4. Fare clic sul pulsante "Modifica/Rimuovi".

  5. Selezionare nel setup di WinCC/DataMonitor l'impostazione "Riparazione".

Excel-Workbook su un PC con Windows 7

Se si utilizza l'Excel-Workbook su un PC con Windows 7, è necessario disattivare la rappresentazione "Aero Glass".

Vista Diagnostica di canale

L'oggetto "Vista Diagnostica di canale" non è supportato dall'opzione WinCC DataMonitor.

Fusi orari delle webpart

Se si crea e configura una webpart nel Webcenter con un determinato fuso orario, questo fuso orario viene salvato nel Webcenter.

Una modifica del fuso orario nel sistema operativo può causare la visualizzazione dell'ora errata nella webpart.


WebNavigator

Contenuto Disinstallazione di WinCC Runtime Programma antivirus Trend Micro OfficeScan Vista generale di ProDiag, Panoramica GRAPH e Vista codice PLC Caratteri non consentiti in WinCC WebNavigator Diagnostica di canale Ritardo nella visualizzazione delle pagine del WebNavigator
WebNavigator

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Disinstallazione di WinCC Runtime

Per continuare ad utilizzare WebNavigator anche dopo la disinstallazione di WinCC Runtime Professional è necessario eseguire la riparazione dell'installazione. Procedere nel modo seguente:

  1. Aprire il Pannello di controllo.

  2. Fare doppio clic su "Installazione applicazioni".

  3. Nell'elenco dei programmi installati selezionare "SIMATIC WinCC/WebNavigator Client".

  4. Fare clic sul pulsante "Modifica/Rimuovi".

  5. Selezionare nel setup di WinCC/WebNavigator l'impostazione "Riparazione".

Programma antivirus Trend Micro OfficeScan

Si sconsiglia di utilizzare il programma antivirus Trend Micro OfficeScan insieme a WebNavigator poiché può prolungare considerevolmente il tempo necessario per aprire le pagine.

Vista generale di ProDiag, Panoramica GRAPH e Vista codice PLC

L'utilizzo di oggetti WinCC "Panoramica GRAPH", "Vista generale ProDiag" e "Vista codice PLC" non viene supportato in WinCC Option Web Navigator.

Caratteri non consentiti in WinCC WebNavigator

Utilizzare nei nomi delle pagine e dei progetti i caratteri del set ASCII. Non utilizzare caratteri speciali o caratteri speciali nazionali.

Diagnostica di canale

L'oggetto "Diagnostica di canale" non è supportato dall'opzione WinCC WebNavigator.

Ritardo nella visualizzazione delle pagine del WebNavigator

A causa della tecnologia del WebServer può succedere che in Runtime le pagine aggiornate del WebNavigator vengano visualizzate con un ritardo.


WebUX

Contenuto Login automatico
WebUX

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Login automatico

Per eliminare l'accesso automatico è necessario cancellare la cronologia dal browser interessato.


Redundancy

Contenuto Nomi nella configurazione di un sistema ridondante
Redundancy

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Nomi nella configurazione di un sistema ridondante

Per la configurazione di un sistema ridondante sono rilevanti solamente i nomi di computer dei pannelli operatore. Il nome di computer di un pannello operatore si definisce nel sistema operativo del pannello. Il nome del pannello operatore nella navigazione del progetto consente di identificare il pannello operatore nel progetto.


SIMATIC Information Server

Contenuto Installazione di SIMATIC Information Server e WinCC Runtime Professional su un PC
SIMATIC Information Server

Contenuto

Indicazioni non più comprese nella Guida in linea e avvertenze importanti sulle proprietà del prodotto.

Installazione di SIMATIC Information Server e WinCC Runtime Professional su un PC

Per la configurazione di SIMATIC Information Server e WinCC Runtime Professional su un PC attenersi alla seguente sequenza di installazione:

  1. Installare WinCC Runtime Professional.

  2. Installare l’Information Server

Se non si rispetta la sequenza di installazione possono verificarsi problemi di collegamento.