Automatisierte Installation durchführen

Beispiele Siehe auch Verlauf Extras
Automatisierte Installation durchführen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Automatisierte Intallation über den Record-/Play-Modus
  • Automatisierte Installation über Kommandozeile
  • Grundlagen der automatisierten Installation
  • Parameterliste
  • Rückgabewerte des Installationsprozesses


Automatisierte Intallation über den Record-/Play-Modus

Automatisierte Intallation über den Record-/Play-Modus

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Aufzeichnung starten
  • Installationseinstellungen auswählen
  • Aufzeichnung abspielen


Aufzeichnung starten

Voraussetzung Vorgehen Ergebnis
Aufzeichnung starten

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

Vorgehen

Um die Installation aufzuzeichnen, gehen Sie folgendermaßen vor:

  1. Starten Sie die Eingabeaufforderung von Windows über "Start > Ausführen > cmd".

  2. Wechseln Sie in das Verzeichnis, das die Datei "Start.exe" enthält.

  3. Geben Sie in der Eingabeaufforderung den folgenden Befehl ein:

    • "Start.exe /record"

  4. Bestätigen Sie Ihre Eingabe mit <Return>.

Ergebnis

Der Installationsdialog wird mit dem Hinweis, dass Sie sich im Record-Modus befinden und das System nicht verändert wird, göffnet.


Installationseinstellungen auswählen

Vorgehen Ergebnis
Installationseinstellungen auswählen

Vorgehen

Um die Optionen für die Installation auszuwählen, gehen Sie folgendermaßen vor:

  1. Wählen Sie im Dialog zur Auswahl der Setup-Sprache die Sprache, in der Sie die Dialoge des Setup-Programms angezeigt bekommen möchten und klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zur Auswahl der Produktsprachen wird geöffnet.

  2. Wählen Sie die Sprachen für die Produktoberfläche und klicken Sie auf die Schaltfläche "Weiter".

    Hinweis

    Die Produktsprache "Englisch" wird als Basis immer installiert.

    Der Dialog zur Auswahl der Produktkonfiguration wird geöffnet.

  3. Wählen Sie die Produkte, die Sie installieren möchten:

    • Wenn Sie das Programm mit einer minimalen Programmzusammenstellung installieren möchten, klicken Sie auf die Schaltfläche "Minimal".

    • Wenn Sie das Programm mit produkttypischen Programmzusammenstellungen installieren möchten, klicken Sie auf die Schaltfläche "Typisch".

    • Wenn Sie selbst auswählen möchten, welche Produkte installiert werden sollen, aktivieren/deaktivieren Sie die Optionskästchen für die Produkte, die Sie installieren möchten. Die Schaltfläche "Benutzerdefiniert" wird hierbei automatisch aktiviert.

  4. Wenn eine Verknüpfung auf dem Desktop angelegt werden soll, aktivieren Sie das Optionskästchen "Desktop-Verknüpfung anlegen".

  5. Klicken Sie auf die Schaltfläche "Durchsuchen", wenn Sie das Zielverzeichnis für die Installation ändern möchten.

    Hinweis

    Es wird empfohlen, den Ordner "Program Files" als Zielverzeichnis zu wählen. Falls Sie ein festes Laufwerk (z. B. "D:") wählen, stellen Sie sicher, dass dieses Laufwerk auf allen Computern, auf denen das Programm installiert werden soll, vorhanden ist.

  6. Klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zu den Lizenzbedingungen wird geöffnet.

  7. Um die Installation fortzusetzen, lesen und akzeptieren Sie alle Lizenzvereinbarungen und klicken Sie auf "Weiter".

    Für den Fall, dass für die Installation des TIA-Portals Sicherheits- und Rechteeinstellungen geändert werden müssen, wird der Dialog zu den Sicherheitseinstellungen geöffnet.

  8. Um die Installation fortzusetzen, akzeptieren Sie die Änderungen der Sicherheits- und Rechteeinstellungen und klicken Sie auf die Schaltfläche "Weiter".

    Im nächsten Dialog wird eine Übersicht der Installationseinstellungen angezeigt.

  9. Überprüfen Sie die gewählten Installationseinstellungen. Wenn Sie Änderungen vornehmen möchten, klicken Sie auf die Schaltfläche "Zurück" bis Sie die zu ändernde Stelle im Dialog erreicht haben. Wenn Sie die gewünschten Änderungen vorgenommen haben, kehren Sie mit "Weiter" wieder zur Übersicht zurück.

  10. Klicken Sie auf die Schaltfläche "Weiter".

    Der Dialog zum Verhalten für einen Neustart und bei auftretenden Fehlern wird geöffnet.

  11. Wählen Sie die gewünschten Optionen aus und speichern Sie die Konfiguration.

  12. Klicken Sie auf die Schaltfläche "Beenden".

Ergebnis

Die Datei zur automatisierten Installation wurde erstellt und gespeichert.


Aufzeichnung abspielen

Voraussetzung Vorgehen Ergebnis
Aufzeichnung abspielen

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Die zuvor aufgezeichnete Datei ("*.rec") ist vorhanden.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um die Installation abzuspielen, gehen Sie folgendermaßen vor:

  1. Starten Sie die Eingabeaufforderung von Windows über "Start > Ausführen > cmd".

  2. Wechseln Sie in das Verzeichnis, das die Datei "Start.exe" enthält.

  3. Geben Sie in der Eingabeaufforderung den folgenden Befehl ein:

    • "Start.exe /play=<Laufwerk>:\<Verzeichnis>\<Dateiname>", z. B. "Start.exe /play=c:\siemens configuration\autoinstall.rec"

  4. Bestätigen Sie Ihre Eingabe mit <Return>.

    Hinweis

    Wenn während der Installation kein License Key gefunden wird, wird der Lizenztransfer übersprungen und Sie können dies später mit dem Automation License Manager nachholen.

Ergebnis

Der Installation wird mit den in der Konfigurationsdatei aufgezeichneten Einstellungen automatisch durchgeführt.


Automatisierte Installation über Kommandozeile

Automatisierte Installation über Kommandozeile

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Installation automatisieren
  • Hochrüsten automatisieren
  • Reparieren automatisieren
  • Deinstallation automatisieren
  • Beispiele für automatisierte Installationen über Kommandozeile


Installation automatisieren

Voraussetzung Vorgehen
Installation automatisieren

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um die Installation direkt über die Kommandoschnittstelle mit den gewünschten Optionen zu starten, gehen Sie folgendermaßen vor:

  1. Starten Sie die Eingabeaufforderung von Windows über "Start > Ausführen > cmd".

  2. Wechseln Sie in das Verzeichnis, das die Datei "Start.exe" enthält.

  3. Geben Sie in der Eingabeaufforderung einen der folgenden Befehle ein:

    • Installation mit sichtbaren Installationsinformationen: "Start.exe /qb <Parameter>"

    • Installation ohne sichtbare Installationsinformationen: "Start.exe /qn <Parameter>" oder "Start.exe /silent <Parameter>"

      Hinweis

      Die Installation mit den Parametern /qb oder /qn bewirkt, dass keine Meldefenster angezeigt werden, auch dann nicht, wenn ein Fehler auftritt. Sie können die Ergebnisse nur über den Rückgabewert auswerten.

      Beachten Sie bei Verwendung der Option "REBOOT=Suppress", dass Sie den Rückgabewert selbst auswerten und gegebenenfalls das System neu starten müssen und nach dem Neustart die Installation selbst auch wieder starten, damit die Auswertung des Rückgabewertes möglich ist.

  4. Bestätigen Sie Ihre Eingabe mit <Return>.


Hochrüsten automatisieren

Voraussetzung Vorgehen
Grundlagen der automatisierten Installation
Hochrüsten automatisieren

Sie haben die Möglichkeit, installierte Produkte automatisiert auf eine neue Version hochzurüsten (Update). Dazu können Sie eine erneute Installation mit den gewünschten Optionen direkt als Kommandozeile starten.

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um installierte Produkte direkt über die Kommandozeile hochzurüsten, gehen Sie folgendermaßen vor:

  1. Starten Sie die Eingabeaufforderung von Windows über "Start > Ausführen > cmd".

  2. Wechseln Sie in das Verzeichnis, das die Datei "Start.exe" enthält.

  3. Geben Sie in der Eingabeaufforderung einen der folgenden Befehle ein:

    • Installation mit sichtbaren Installationsinformationen: "Start.exe /qb <Parameter>"

    • Installation ohne sichtbare Installationsinformationen: "Start.exe /qn <Parameter>" oder "Start.exe /silent <Parameter>"

      Hinweis

      Die Installation mit den Parametern /qb oder /qn bewirkt, dass keine Meldefenster angezeigt werden, auch dann nicht, wenn ein Fehler auftritt. Sie können die Ergebnisse nur über den Rückgabewert auswerten.

      Beachten Sie bei Verwendung der Option "REBOOT=Suppress", dass Sie den Rückgabewert selbst auswerten und gegebenenfalls das System neu starten müssen und nach dem Neustart die Installation selbst auch wieder starten, damit die Auswertung des Rückgabewertes möglich ist.

  4. Bestätigen Sie Ihre Eingabe mit <Return>.


Reparieren automatisieren

Voraussetzung Vorgehen
Reparieren automatisieren

Wenn Sie "Start.exe" nach erfolgter Installation mit dem Parameter "REINSTALL=ALL" erneut aufrufen, wird eine erneute Installation (Re-Installation) aller Komponenten durchgeführt, genauso wie beim Auswählen von "Reparieren" bei einer dialoggeführten Installation. Dabei wird die identische Installation wie zuvor durchgeführt. Das automatisierte Reparieren erfolgt wie die automatisierte Installation über die Kommandoschnittstelle. Das Neustartverhalten können Sie dabei über einen Parameter eingeben.

"REINSTALL" kann nur mit den Parametern "REBOOT", "/qn" und "/qb" kombiniert werden. Alle anderen Parameter sind nicht zulässig.

Voraussetzung

  • Hardware und Software des PG/PC entsprechen den Systemanforderungen.

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um eine Installation direkt über die Kommandoschnittstelle zu reparieren, gehen Sie folgendermaßen vor:

  1. Starten Sie die Eingabeaufforderung von Windows über "Start > Ausführen > cmd".

  2. Wechseln Sie in das Verzeichnis, das die Datei "Start.exe" enthält.

  3. Geben Sie in der Eingabeaufforderung einen der folgenden Befehle ein:

    • Installation mit sichtbare Installationsinformationen: "Start.exe /qb REINSTALL=ALL <REBOOT-Parameter>"

    • Installation ohne sichtbare Installationsinformationen: "Start.exe /qn REINSTALL=ALL <REBOOT-Parameter>" oder "Start.exe /silent REINSTALL=ALL <REBOOT-Parameter>"

      Hinweis

      Der REBOOT-Parameter ist optional. Beachten Sie aber bei der Verwendung der Option "REBOOT=Suppress", dass Sie den Rückgabewert selbst auswerten und gegebenenfalls das System neu starten müssen.

  4. Bestätigen Sie Ihre Eingabe mit <Return>.


Deinstallation automatisieren

Voraussetzung Vorgehen
Deinstallation automatisieren

Wenn Sie eine bestehende Installation entfernen möchten, können Sie dies über eine automatisierte Deinstallation erledigen. Dabei werden die kompletten Softwarepakete deinstalliert. Die automatisierte Deinstallation erfolgt wie die automatisierte Installation über die Kommandoschnittstelle. Das Neustartverhalten können Sie dabei über einen Parameter eingeben.

"REMOVE" kann nur mit den Parametern "REBOOT", "/qn" und "/qb" kombiniert werden. Alle anderen Parameter sind nicht zulässig.

Voraussetzung

  • Sie haben Administrationsrechte auf Ihrem Computer.

  • Alle laufenden Programme sind beendet.

Vorgehen

Um die Deinstallation direkt über die Kommandoschnittstelle zu starten, gehen Sie folgendermaßen vor:

  1. Starten Sie die Eingabeaufforderung von Windows über "Start > Ausführen > cmd".

  2. Wechseln Sie in das Verzeichnis, das die Datei "Start.exe" enthält.

  3. Geben Sie in der Eingabeaufforderung einen der folgenden Befehle ein:

    • Deinstallation mit sichtbaren Installationsinformationen: "Start.exe /qb REMOVE=ALL <REBOOT-Parameter>"

    • Deinstallation ohne sichtbare Installationsinformationen: "Start.exe /qn REMOVE=ALL <REBOOT-Parameter>" oder "Start.exe /silent REMOVE=ALL <REBOOT-Parameter>"

      Hinweis

      Der REBOOT-Parameter ist optional. Beachten Sie aber bei Verwendung der Option "REBOOT=Suppress", dass Sie den Rückgabewert selbst auswerten und gegebenenfalls das System neu starten müssen.

  4. Bestätigen Sie Ihre Eingabe mit <Return>.


Beispiele für automatisierte Installationen über Kommandozeile

Beispiel für eine typische Installation mit REBOOT=AUTO Beispiel für eine vollständige Installation mit REBOOT=Suppress Beispiel für das Abfragen des Rückgabewerts per Batch-Datei
Beispiele für automatisierte Installationen über Kommandozeile

Beispiel für eine typische Installation mit REBOOT=AUTO

Das folgende Beispiel zeigt eine typische Installation über die Kommandozeile:

Start.exe /qb REBOOT=Auto INSTALLLANGUAGE=1031;1033 INSTALLDIR="D:\TIAPortal" INSTALLLEVEL=Typical

In diesem Beispiel wird eine typische Installation ("INSTALLLEVEL=Typical") für die Sprachen Deutsch und Englisch ("INSTALLLANGUAGE=1031;1033") durchgeführt. Das System wird am Ende der Installation ohne Rückfrage automatisch neu gestartet ("REBOOT=Auto"). Als Installationsverzeichnis wird das Verzeichnis "D:\TIAPortal" verwendet ("INSTALLDIR=D:\TIAPortal").

Beispiel für eine vollständige Installation mit REBOOT=Suppress

Das folgende Beispiel zeigt eine vollständige Installation über die Kommandozeile:

Start.exe /qb REBOOT=Suppress INSTALLLANGUAGE=1031;1033 INSTALLDIR="D:\TIAPortal" INSTALLLEVEL=Complete

In diesem Beispiel wird eine vollständige Installation ("INSTALLLEVEL=Complete") für die Sprachen Deutsch und Englisch ("INSTALLLANGUAGE=1031;1033") durchgeführt. Ein Neustart des Systems am Ende der Installation wird unterdrückt ("REBOOT=Suppress"). Dadurch müssen Sie den Rückgabewert selbst auswerten und gegebenenfalls das System eigenständig neu starten.

Beispiel für das Abfragen des Rückgabewerts per Batch-Datei

Das folgende Beispiel zeigt, wie Sie den Rückgabewert per Batch-Datei abfragen:

SET SetupSuccess=%ERRORLEVEL%

if '%SetupSuccess%' EQU '0' (

echo Setup successful. Return code: %SetupSuccess%

) else (

if '%SetupSuccess%' EQU '3010' (

echo Setup successful. A reboot is needed! Return code: %SetupSuccess%

) else (

echo "ERROR during Setup! Return code: %SetupSuccess%

)

)

pause

Der Rückgabewert "1641" dokumentiert ebenfalls ein erfolgreiches Ende der Installation und dass ein Neustart bereits eingeleitet wurde. Dieser tritt aber nur bei der Verwendung von "/REBOOT=Auto" auf und wurde deswegen in der Batch-Datei des Beispiels nicht ausgewertet.

Alle möglichen Rückgabewerte finden Sie unter Rückgabewerte des Installationsprozesses.


Grundlagen der automatisierten Installation

Einführung Besonderheiten
Grundlagen der automatisierten Installation

Einführung

Wenn Sie für die Verwaltung der Software-Pakete auf mehreren Rechnern verantwortlich sind, haben Sie unterschiedliche Möglichkeiten, die Installation zu automatisieren.

Record-/Play-Funktion

Sie können folgende Installationsprozesse automatisiert über die Record-/Play-Funktion ablaufen lassen:

  • Installation

    Die Software wird gemäß den verwendeten Parametern installiert.

  • Modifizieren oder Hochrüsten

    Die Software wird erneut gemäß den verwendeten Parametern installiert.

Kommandozeile

Sie können folgende Installationsprozesse automatisiert über Kommandozeile ablaufen lassen:

  • Installation

    Die Software wird gemäß den verwendeten Parametern installiert.

  • Modifizieren oder Hochrüsten

    Die Software wird erneut gemäß den verwendeten Parametern installiert.

  • Reparieren (REINSTALL)

    Bei dieser Option wird die bereits vorhandene Installation der Software durch eine erneute Installation (Re-Installation) repariert. Sie können den Parameter "REINSTALL" nur mit den Parametern "REBOOT", "/qn" und "/qb" kombinieren. Die Software wird also mit den gleichen Parametern installiert, die für die ursprüngliche Installation verwendet wurden.

  • Deinstallation (REMOVE)

    Die Software wird vom System entfernt. Sie können den Parameter "REMOVE" nur mit den Parametern "REBOOT", "/qn" und "/qb" kombinieren.

Hinweis

Um Installation, Modifizieren oder Hochrüsten, Reparieren oder Deinstallation automatisiert durchzuführen, müssen Sie einen der beiden Parameter "/qn" oder "/qb" verwenden. Lassen Sie diese Parameter weg, wird der normale Installationsdialog geöffnet, in dem Sie die Installation manuell durchführen können.

Besonderheiten

  • Über Kommandozeile kann nur eine Modifikation vorgenommen werden, z. B. der Umfang der Produktsprachen.

  • Über Kommandozeile kann eine Hochrüstung auf eine neuere Version vorgenommen werden. Dabei werden nur die bereits installierten Teile hochgerüstet.

  • Über Kommandozeile können keine einzelnen Produkt-Bestandteile installiert oder deinstalliert werden. Falls Sie einzelne Teile dazuinstallieren möchten, verwenden Sie den Record/Play-Modus.

  • Die Deinstallation einzelner Bestandteile wird nicht unterstützt.

  • Eine Deinstallation kann nur komplett durchgeführt werden. Beachten Sie hierbei, dass die Teile, die eigene Einträge in der Systemsteuerung unter "Programme und Funktionen" haben, nicht automatisch entfernt werden.


Parameterliste

Parameter für die automatisierte Installation
Parameterliste

Parameter für die automatisierte Installation

Die folgende Tabelle zeigt die Parameter, die Ihnen für eine automatisierte Installation zur Verfügung stehen:

Parameter

Beschreibung

Zulässig für

Mögliche Werte

Erklärung der Werte

/qb 1)

Mithilfe dieses Parameters können Sie eine automatisierte Installation durchführen. Während der Installation erhalten Sie Informationen zur laufenden Installation.

Hinweise:

  • Ohne die Parameter "qb" oder "qn" können Sie keine automatisierte Installation durchführen.

  • Die Parameter "qn" und "qb" können nicht gemeinsam innerhalb eines Aufrufs verwendet werden.

  • Die Informationen während der Installation erhalten Sie in der eingestellten Installationssprache. Dadurch passen diese Informationen zu den Texten in den Logfiles. Diese Logfiles benötigen Sie z. B., wenn Sie sich an den Support wenden.

  • Die Ergebnisse der Installation können Sie den Rückgabewerten entnehmen.

Installation

Neuinstallation

Deinstallation

-

/qn oder /silent 1)

Mithilfe dieses Parameters können Sie eine automatisierte Installation durchführen. Während der Installation erhalten Sie keine Informationen zur laufenden Installation.

Hinweise:

  • Ohne die Parameter "qb" oder "qn" können Sie keine automatisierte Installation durchführen.

  • Die Parameter "qn" und "qb" können nicht gemeinsam innerhalb eines Aufrufs verwendet werden.

  • Die Ergebnisse der Installation können Sie den Rückgabewerten entnehmen.

Installation

Neuinstallation

Deinstallation

-

/lcid

Mithilfe dieses Parameters können Sie die Setup-Sprache festlegen, die in der Sie installieren möchten. Dabei geben Sie die folgenden lokalen ID (LCID) der gewünschten Sprache im Dezimalformat ein.

Beispiel:

/lcid=1031

Installation

Neuinstallation

Deinstallation

1031

Deutsch

1033

Englisch

1040

Italienisch

1036

Französisch

3082

Spanisch

2052

Chinesisch

...

Weitere Produktsprachen

/record

Mithilfe dieses Parameters können Sie den Record-Modus starten. Dieser erzeugt die Datei "autoinstall.rec" für die automatische Installation

Installation

/play

Mithilfe dieses Parameters können Sie den Play-Modus starten. In diesem Modus benötigen Sie die Konfigurationsdatei, die im Record-Modus erstellt wird.

Beispiel:

/play="C:\Siemens Configurations\autoinstall.rec"

Installation

INSTALLDIR 2)

Mithilfe dieses Parameters können Sie das Zielverzeichnis für die Installation festlegen.

Beispiel:

INSTALLDIR="D:\TIAPortal"

Installation

INSTALLLANGUAGE

INSTALLLANGUAGE

Mithilfe dieses Parameters können Sie die Produktsprachen festlegen, die Sie installieren möchten. Dabei geben Sie die folgenden lokalen IDs (LCID) der gewünschten Sprachen im Dezimalformat ein.

Beispiel:

INSTALLLANGUAGE=1031;1033

Installation

1031

Deutsch

1033

Englisch

1040

Italienisch

1036

Französisch

3082

Spanisch

2052

Chinesisch

...

Weitere Produktsprachen

REBOOT

Mithilfe dieses Parameters können Sie das Neustartverhalten während der Installation festlegen.

Beispiel:

REBOOT=Suppress

Installation

Neuinstallation

Deinstallation

Auto

Am Ende der Installation wird automatisch ein Neustart durchgeführt, wenn dies erforderlich ist.

Suppress 3)

Am Ende der Installation wird der Neustart unterdrückt. Falls ein Neustart erforderlich wäre, muss der aufrufende Prozess den Neustart veranlassen.

Ebenfalls wird die Fortsetzung der Installation unterdrückt, falls diese nach dem Neustart notwendig ist (bei Rückgabewert 13010).

ONERROR

Mithilfe dieses Parameters können Sie das Verhalten im Fehlerfall am Ende der Installation festlegen.

Beispiel:

ONERROR=Suppress

Installation

Neuinstallation

Deinstallation

Suppress

Am Ende der Installation wird der Dialog mit den aufgetretenen Fehlern unterdrückt. Die Auswertung der Fehler kann auf Basis der Rückgabewerte des Prozesses erfolgen.

User

Am Ende der Installation wird im Fehlerfall der Dialog mit den aufgetretenen Fehlern angezeigt.

INSTALLLEVEL

Mithilfe dieses Parameters können Sie die Art der Installation festlegen.

Beispiel:

INSTALLLEVEL=Complete

Installation 4)

Minimal

Minimale Installation

Typical

Typische Installation

Complete

Vollständige Installation

1) Die Installation mit den Parametern /qb oder /qn bewirkt, dass keine Meldefenster angezeigt werden, auch dann nicht, wenn ein Fehler auftritt. Sie können die Ergebnisse nur über den Rückgabewert auswerten.

2) Achten Sie darauf, dass Sie hier den realen Windows-Pfad angeben ("C:\Program Files\...", und nicht z.B. "C:\Programme\...") und ebenso keine variablen Pfade verwenden (z.B. [ProgramFilesFolder]).
Der Parameter wird nicht benötigt, wenn Sie in das Standardverzeichnis installieren wollen (C:\Program Files\Siemens\Automation).

3) Wenn die Installation noch nicht abgeschlossen ist (Rückgabewert 13010), müssen Sie zunächst das System und dann die Installation wieder starten, damit die Auswertung des Rückgabewertes möglich ist.

4) Dieser Parameter darf nur bei der Erstinstallation der Software verwendet werden.


Rückgabewerte des Installationsprozesses

Liste der Rückgabewerte
Rückgabewerte des Installationsprozesses

Liste der Rückgabewerte

Die folgende Tabelle zeigt die Rückgabewerte einer automatisierten Installation und ihre Beschreibungen:

Rückgabewert

Technische Fehlerbezeichnung

Beschreibung

?

OtherError

Alle Rückgabewerte, die nachfolgend in der Tabelle nicht beschrieben sind, bedeuten generell einen Fehler.

Detaillierte Informationen zu allen Fehlern finden Sie grundsätzlich im Protokoll der Installation. Öffnen Sie dazu die neueste log-Datei, deren Namen mit "SIA" beginnt.

0

Success

Die Installation war erfolgreich. Es sind keine Fehler aufgetreten.

5

AccessDenied

Sie haben nicht genügend Rechte. Für die Installation sind Administrationsrechte erforderlich.

112

DiskFull

Unzureichender Speicherplatz auf dem Zielmedium.

1601

InstallServiceFailure

Es ist ein interner Fehler während der Initialisierungsphase aufgetreten.

1602

UserExit

Abbruch durch den Anwender erfolgt, meist aufgrund eines gewählten Abbruchs im Dialog.

1603

InstallFailure

Es ist ein Fehler während der Durchführung der Installation aufgetreten.

1605

UnknownProduct

Es ist ein interner Fehler in der Produktkonfiguration aufgetreten.

1610

BadConfiguration

Es ist ein interner Fehler in der Produktkonfiguration aufgetreten.

1618

InstallAlreadyRunning

Eine andere Installation läuft bereits. Eine gleichzeitige Ausführung ist nicht möglich.

1622

InstallLogFailure

Es ist ein Fehler während des Schreibens in das Protokoll aufgetreten.

1627

FunctionFailed

Es ist ein interner Fehler aufgetreten.

1633

InstallPlatformUnsupported

Dieses Betriebssystem wird nicht unterstützt.

1639

InvalidCommandline

Es ist ein Fehler in der angegebenen Kommandozeile vorhanden.

1641

SuccessRebootInitiated

Die Installation war erfolgreich. Um den Vorgang ganz abzuschließen, wurde bereits ein Neustart eingeleitet.

3010

SuccessRebootRequired

Die Installation war erfolgreich. Um den Vorgang ganz abzuschließen, ist aber unbedingt ein Neustart nötig!

5001

PrerequisitesFailure

Die Installationsbedingungen sind nicht erfüllt. Für mehr Informationen können Sie die Installation erneut per Doppelklick auf die start.exe starten.

5002

InvalidIEVersion

Der Internet Explorer ist nicht vorhanden oder es ist eine nicht unterstützte Version installiert.

5003

ResourcesFailed

Es ist ein interner Fehler während der Initialisierungsphase aufgetreten.

5004

ProductInitFailed

Es ist ein interner Fehler aufgetreten (eventuell ist das Installationsmedium defekt).

5005

ProductInitNewerVersionInstalled

Eine neuere Version des Produkts ist bereits installiert.

5006

ProductInitMoreValuableEditionInstalled

Eine umfangreichere Edition des Produkts ist bereits installiert (z. B. wird versucht eine Basisversion zu installieren, obwohl bereits eine Professional-Version vorhanden ist).

5007

ProductInitOptionalWithoutMain

Sie haben versucht, ein Optionspaket ohne die Hauptsoftware zu installieren.

5008

ProductIncompatibility

Es ist bereits ein Produkt vorhanden, zu dem das zu installierende Produkt inkompatibel ist.

5009

AutoinstallFileNotFound

Die Datei für den Play-Modus wurde nicht gefunden.

5010

AutoinstallUnexpectedContent

Die Datei für den Play-Modus kann nicht gelesen werden (falsches Format, falsche Version oder unpassendes Installationsmedium)

11641

NotCompleteReboot

Das Setup ist nicht vollständig und muss nach dem Neustart fortgesetzt werden. Der Neustart ist bereits eingeleitet. Nach dem Neustart müssen Sie die Installation wieder starten.

13010

NotCompleteRebootRequired

Das Setup ist nicht vollständig und muss nach dem Neustart fortgesetzt werden. Sie müssen den Neustart veranlassen und nach dem Neustart die Installation wieder starten.