Lisezmoi SiVArc

Exemples Voir aussi Historique Outils
Lisezmoi SiVArc

Ce chapitre contient des informations sur les sujets suivants :
  • Notes relatives à la sécurité
  • Politique de confidentialité
  • Informations sur l'utilisation


Notes relatives à la sécurité

Exemples Voir aussi Historique Outils
Notes relatives à la sécurité Lecteur réseau Communication via Ethernet
Notes relatives à la sécurité

Notes relatives à la sécurité

Siemens commercialise des produits et solutions comprenant des fonctions de sécurité industrielle qui contribuent à une exploitation sûre des installations, systèmes, machines et réseaux.

Pour garantir la sécurité des installations, systèmes, machines et réseaux contre les cybermenaces, il est nécessaire d’implémenter (et de préserver) un concept de sécurité industrielle global et moderne. Les produits et solutions de Siemens ne constituent qu’une partie d’un tel concept.

Il incombe au client d‘empêcher tout accès non autorisé à ses installations, systèmes, machines et réseaux. De tels systèmes, machines et composants doivent uniquement être connectés au réseau d'entreprise ou à Internet si et dans la mesure où c'est nécessaire et si des mesures de protection correspondantes (p. ex. utilisation de pare-feux et segmentation du réseau) ont été prises.

En outre, vous devez tenir compte des recommandations de Siemens concernant les mesures de protection correspondantes. Pour plus d’informations sur la sécurité industrielle, rendez-vous sur

http://www.siemens.com/industrialsecurity

Les produits et solutions Siemens font l’objet de développements continus pour être plus sûrs. Siemens recommande d'utiliser impérativement les mises à jour des produits dès qu'elles sont disponibles ainsi que les versions de produits les plus récentes. L'utilisation de versions de produits qui ne sont plus supportées et la non-application des mises à jour les plus récentes peut augmenter le risque d'exposition du client à des cybermenaces.

Afin d’être informé des mises à jour des produits, veuillez souscrire au flux RSS Siemens Industrial Security à l'URL suivante :

http://www.siemens.com/industrialsecurity.

Lecteur réseau

Assurez-vous que les lecteurs réseau de votre infrastructure réseau et votre ordinateur sont protégés contre tout accès non autorisé.

Communication via Ethernet

Dans le cas de la communication basée sur Ethernet, les utilisateurs finaux sont eux-mêmes responsables de la sécurité de leur réseau de données. Le fonctionnement correct de l'appareil ne peut pas être garanti dans toutes les circonstances. Par exemple, des attaques ciblées peuvent entraîner la surcharge de l'appareil.


Politique de confidentialité

Exemples Voir aussi Historique Outils
Politique de confidentialité

Siemens respecte les politiques de protection de la vie privée, en particulier le principe de minimisation des données (intégration de la protection des données dès la conception). Ce qui signifie qu'aucune donnée à caractère personnel n'est traitée/enregistrée pour ce produit SIMATIC.


Informations sur l'utilisation

Exemples Voir aussi Historique Outils
Nouvelles fonctions
Informations sur l'utilisation

Nouvelles fonctions

Les nouvelles fonctions et extensions suivantes sont prises en charge dans SiVArc V16 :

Nouvelles fonctions

  • SiVArc étend la prise en charge lors de la génération aux clients comme Energy Suite. Energy Suite génère des vues et des objets graphiques sur la base des règles de vue configurées décrites comme règles de vue système. Dans la boîte de dialogue "Sélectionner une station et des commandes pour la génération SiVArc" de la station, vous pouvez sélectionner le type de règle à générer de la manière suivante dans la colonne "Jeu de règles" :

    • Règles créées par l'utilisateur – pour les règles créées par l'utilisateur dans SiVArc

    • Règles Energy Suite – pour les règles créées Energy Suite

    • Toutes les règles – combinaison de règles SiVArc- et Energy Suite

  • Visualisation de données énergétique sans licence SiVArc lors de la génération du programme Energy Suite

  • Vues basées sur la configuration matérielle – Vous pouvez configurer des périphérique IO connectés à l'API et générer des vues (à l'aide d'expressions) qui mènent au nom d'appareil IO, au type d'invariant et au numéro de référence. La génération SiVArc entraîne la création de vues pour une seule ou plusieurs instances de nom d'appareil IO, de type d'invariant et de numéro de référence.

  • Alarmes basées sur la configuration matérielle – Vous pouvez configurer des périphérique IO connectés à l'API et générer des alarmes, des groupes d'alarmes et des classes d'alarmes (à l'aide d'expressions) qui mènent au nom d'appareil IO, au type d'invariant et au numéro de référence. La génération SiVArc entraîne la création d'alarmes pour une seule ou plusieurs instances de nom d'appareil IO, de type d'invariant et de numéro de référence.

  • Avec SiVArc vous pouvez configurer des expressions pour différentes propriétés d'objets IHM qui se résolvent dans le nom de l'unité logicielle qui contient le bloc API utilisé lors de la création de la règle SiVArc.

  • Les variables API sont utilisées sur les appareils IHM via la case à cocher "Accès depuis IHM" dans la fenêtre de variables API. Lors de la création de vues, les champs d'entrée et de sortie d'un objet graphique sont configurés avec les variables API et sont utilisés dans la génération IHM.

Extensions

  • Vous pouvez configurer une liste de fonctions dans un événement d'un modèle de génération d'une vue. Les vues avec des événements configurés peuvent être positionnées sous une bibliothèque et utilisées lors de la génération.

  • Sélection multiple d'objets d'alarme dans l'éditeur "Règles d'alarme".

  • Prise en charge d'Openness API étendue à la création et au traitement de règles.

  • Prise en charge d'Openness API pour la génération SiVArcétendue à plusieurs appareils IHM.

  • Lors de la configuration d'un bloc d'affichage avec des propriétés d'interface d'objets graphiques, vous pouvez conserver les modifications apportées à des valeurs statiques et dynamiques pour des blocs d'affichage via la case à cocher Conserver les modifications manuelles dans l'éditeur Plug-Ins.

  • Lors de la configuration des vues de débordement, vous pouvez configurer les boutons de navigation "Précédent" et "Suivant" séparément dans l'éditeur Plug-ins de SiVArc.

  • Vous pouvez affecter des vues de modèle/contextuelles ou des objets graphiques à différents appareils cibles IHM à l'aide de la matrice de génération.

  • Le vues/modèles créés via des règles de copie sont pris en charge par la matrice de génération.

  • Le nombre de caractères max. pour la colonne Condition dans l'éditeur de règles SiVArc a été augmenté à 1 000.

  • Lors de la génération SiVArc pour les HMI-Panels/Runtime Advanced, le numéro de vue est conservé / adapté à l'ancienne valeur de la même vue, même après une modification de la copie maître ou de la règle de vue.