SIMATIC Automation Tool V3.1 SP4 Installationshinweise

Im Abschnitt Anleitungen Beispiele Grundlagen Verlauf Extras
Start Zurück Weiter

SIMATIC Automation Tool V3.1 SP4 Installationshinweise

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Lizenzbedingungen
  • Installationshinweise


Lizenzbedingungen

Lizenzbedingungen

Durch Installation des SIMATIC Automation Tool erklären Sie sich mit der Endbenutzervereinbarung einverstanden. Sie akzeptieren außerdem die Sicherheitsinformationen zum sicheren Betrieb des Produkts. Durch die Installation erklären Sie sich ferner mit den Lizenzbedingungen von Fremdanbietern (einschl. Open Source) einverstanden. Diese Bedingungen sind einsehbar, wenn Sie das vollständige Installations-Setup ausführen. Verwenden Sie die Funktion für die automatisierte Installation erst, wenn Sie alle Bedingungen dieser Werkzeuge wie in den Setup-Dialogfeldern für die nicht automatisierte Installation beschrieben gelesen und sich damit einverstanden erklärt haben.


Installationshinweise

Installationshinweise

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Unterstützung von Betriebssystemen und Software
  • Betriebsumgebung
  • Wissenswertes zur Installation
  • Installation über den TIA Software Updater
  • Herunterladen vom Siemens Industry Online-Support
  • Kaufen, Lizenzieren und Herunterladen des SIMATIC Automation Tool
  • Installation über die selbstextrahierende EXE-Datei
  • Installation über die ISO-Datei
  • Optionale automatisierte Installation


Unterstützung von Betriebssystemen und Software

Unterstützung für Betriebssysteme des Typs Microsoft Windows auf 64-Bit-Basis Unterstützung für VM-Software (Virtual Machine) Unterstützung für Antiviren- und Sicherheitssoftware Unterstützte Sprachen Kommunikation Unterstützte Siemens-Hardware
Start Zurück Weiter

Unterstützung von Betriebssystemen und Software

Unterstützung für Betriebssysteme des Typs Microsoft Windows auf 64-Bit-Basis

Das SIMATIC Automation Tool funktioniert mit den folgenden 64-Bit-Betriebssystemen:

  • Windows 7 Home Premium SP1

  • Windows 7 Professional SP1

  • Windows 7 Enterprise SP1

  • Windows 7 Ultimate SP1

  • Windows 10 Home Version 1809 (OS-Build 17763)

  • Windows 10 Home Version 1903 (OS-Build 18362)

  • Windows 10 Pro Version 1809 (OS-Build 17763)

  • Windows 10 Pro Version 1903 (OS-Build 18362)

  • Windows 10 Enterprise Version 1809 (OS-Build 17763)

  • Windows 10 Enterprise Version 1903 (OS-Build 18362)

  • Windows 10 IoT Enterprise 2015 LTSB (OS-Build 10240)

  • Windows 10 Enterprise 2016 LTSB (OS-Build 14393)

  • Windows 10 IoT Enterprise 2019 LTSB (OS-Build 17763)

Siemens gibt keine Garantie dafür, dass andere Versionen funktionieren. Für andere Versionen bietet Siemens keinen technischen Support.

Unterstützung für VM-Software (Virtual Machine)

Das SIMATIC Automation Tool kann mit der folgenden VM-Software verwendet werden:

  • VMware vSphere Hypervisor (ESXi) 6.5 oder höher

  • VMware Workstation 12.5.5

  • VMware Workstation 15.0.2 oder höher

  • VMware Player 12.5.5

  • VMware Player 15.0.2 oder höher

  • Microsoft Hyper-V Server 2016

Siemens gibt keine Garantie dafür, dass andere Versionen funktionieren. Für andere Versionen bietet Siemens keinen technischen Support.

Unterstützung für Antiviren- und Sicherheitssoftware

Siemens hat geprüft, dass das SIMATIC Automation Tool mit der folgenden Antiviren- und Sicherheitssoftware verwendet werden kann:

  • McAfee Endpoint Security (ENS) 10.5

  • Trend Micro Office Scan 12.0

  • Kaspersky Endpoint Security 11.1

  • Windows Defender (als Bestandteil von Windows-Betriebssystemen)

  • Qihoo 360 "Safe Guard 11.5" + "Virus Scanner"

  • Microsoft Bitlocker (Bestandteil von Windows-Betriebssystemen)

  • McAfee Application Control 8.0

Möglicherweise funktioniert das SIMATIC Automation Tool auch mit anderer Software.

Unterstützte Sprachen

Die Benutzeroberfläche und das Benutzerhandbuch von SIMATIC Automation Tool sind in den folgenden Sprachen verfügbar:

  • Englisch

  • Deutsch

  • Französisch

  • Spanisch

  • Italienisch

  • Chinesisch (vereinfacht)

Kommunikation

Das SIMATIC Automation Tool kommuniziert mit Siemens-Geräten über ein Ethernet-Kabel, das an eine Netzwerkschnittstelle angeschlossen ist.

Unterstützte Siemens-Hardware

Das SIMATIC Automation Tool bietet einen Gerätekatalog, in dem alle von dem Tool unterstützten Geräte und Firmware-Versionen aufgeführt werden. Der Gerätekatalog ist ein Excel-Arbeitsblatt und kann über das Menü "Hilfe" im SIMATIC Automation Tool aufgerufen werden.


Betriebsumgebung

Betriebsumgebung

Nehmen Sie die folgenden Einstellungen für Windows-Betriebssysteme vor:

  • Deaktivieren Sie den Ruhezustand, wenn Sie das SIMATIC Automation Tool verwenden. Wird der Ruhezustand aktiviert, während Internetverbindungen bestehen oder während über ein Netzwerk auf Projektdaten zugegriffen wird, kann dies zu Fehlern führen.

  • Stellen Sie die Energiespareinstellungen für das Betriebssystem so ein, dass der Computer niemals in den Schlafmodus wechselt. Dadurch wird gewährleistet, dass der Schlafmodus nicht automatisch durch einen Timer ausgelöst wird. Aktivieren Sie nicht manuell den Ruhezustand während einer Kommunikations-Task.


Wissenswertes zur Installation

Übersicht zu den Installationsoptionen Regeln für die Installation
Start Zurück Weiter

Wissenswertes zur Installation

Übersicht zu den Installationsoptionen

Sie können das SIMATIC Automation Tool auf eine der folgenden Arten installieren:

  • Wenn Sie bereits die Version 3.1 oder höher des SIMATIC Automation Tool installiert haben, können Sie Ihre Version über den TIA Software Updater auf V3.1 SP4 aktualisieren.

  • Wenn Sie das SIMATIC Automation Tool mit einer kostenlosen, 21 Tage gültigen Trial License herunterladen und installieren möchten, können Sie diese Lizenz vom Siemens Industry Online-Support herunterladen. Anschließend können Sie das SIMATIC Automation Tool über die heruntergeladene EXE-Datei installieren und die 21 Tage gültige Trial License aktivieren. Beachten Sie, dass Funktionen im SIMATIC Automation Tool nach 21 Tagen eingeschränkt werden, wenn Sie keine Lizenz erwerben.

  • In der Siemens Industry Mall können Sie das SIMATIC Automation Tool erwerben, lizenzieren und herunterladen. Mit einer Lizenz steht Ihnen der volle Funktionsumfang zur Verfügung. Sie können das SIMATIC Automation Tool entweder über die heruntergeladene EXE-Datei oder über die heruntergeladene ISO-Datei installieren.

  • Sie können eine automatisierte Installation nutzen, um das SIMATIC Automation Tool nach erfolgreichem Herunterladen der Software vom Siemens Industry Online Support oder von der Website Siemens Online Software Delivery (OSD) zu installieren.

Die für jede Option durchzuführenden Schritte werden in weiteren Themen beschrieben.

Regeln für die Installation

Auf einem Programmiergerät darf nur jeweils eine Version des SIMATIC Automation Tool installiert sein.

Das Installationsprogramm des SIMATIC Automation Tool prüft, ob eine Vorgängerversion vorhanden ist, und leitet Sie entsprechend an:

  • Wenn keine Version des SIMATIC Automation Tool auf Ihrem Programmiergerät vorhanden ist, installieren Sie das SIMATIC Automation Tool über das Setup-Programm.

  • Wenn auf Ihrem Programmiergerät eine Version 2.x oder eine frühere Version des SIMATIC Automation Tool vorhanden ist, müssen Sie die ältere Version über Windows deinstallieren. Nachdem Sie die Vorgängerversion deinstalliert haben, starten Sie das Setup-Programm erneut und installieren V3.1 SP4.

  • Wenn eine Installation der Version 3.0 oder höher auf Ihrem Programmiergerät vorhanden ist, wählen Sie "Ändern/Aktualisieren", um V3.1 SP4 über die vorhandene Installation zu installieren. Wenn Sie bereits eine Lizenz für Ihre Version 3.0 oder höher haben, gilt diese Lizenz auch für V3.1 SP4.


Installation über den TIA Software Updater

Installation über den TIA Software Updater

Der TIA Software Updater umfasst das SIMATIC Automation Tool. Wenn Ihr Programmiergerät mit dem Internet verbunden ist, können Sie die Softwareaktualisierungen für SIMATIC Automation Tool von Siemens herunterladen.

Mit dem SIMATIC Automation Tool können Sie automatisch nach verfügbaren Aktualisierungen für installierte SIMATIC-Softwareprodukte suchen. Wenn Aktualisierungen verfügbar sind, haben Sie die Möglichkeit, diese auf Ihrem Programmiergerät zu installieren.

Um den TIA Software Updater für die Aktualisierung Ihres SIMATIC Automation Tool auf die neueste Version zu nutzen, gehen Sie wie folgt vor:

  1. Wählen Sie den Menübefehl "Hilfe > Über SIMATIC Automation Tool".

  2. Im Dialogfeld "Über SIMATIC Automation Tool" klicken Sie auf "Auf Aktualisierungen prüfen".

    Daraufhin wird der TIA Software Updater geöffnet und zeigt im Register "Software" verfügbare Software-Aktualisierungen an. Warten Sie, bis der TIA Software Updater nach verfügbaren Softwareversionen sucht und diese anzeigt.

  3. Wenn für das SIMATIC Automation Tool eine Aktualisierung vorhanden ist, klicken Sie zum Herunterladen der neuen Version auf die Schaltfläche "Herunterladen".

    Beim Herunterladen der Software wird Ihnen eine Fortschrittsmeldung angezeigt. Nach Abschluss des Ladevorgangs ist die Schaltfläche "Installieren" aktiv und die Schaltfläche "Herunterladen" zeigt nun "Heruntergeladen" an.

  4. Klicken Sie auf die Schaltfläche "Installieren", um die heruntergeladene Software zu installieren. Das Setup-Programm führt Sie durch den Installationsvorgang.

Sie können im TIA Software Updater jederzeit auf "Nach Software-Aktualisierungen suchen" klicken, um erneut zu suchen.


Herunterladen vom Siemens Industry Online-Support

Das SIMATIC Automation Tool mit einer kostenlosen, 21 Tage gültigen Trial License installieren und verwenden Aktivieren der Trial License Funktionsbeschränkungen bei einem nicht lizenzierten SIMATIC Automation Tool Lizenzieren des SIMATIC Automation Tool
Start Zurück Weiter

Herunterladen vom Siemens Industry Online-Support

Das SIMATIC Automation Tool mit einer kostenlosen, 21 Tage gültigen Trial License installieren und verwenden

Sie können eine unlizenzierte Version des SIMATIC Automation Tool von der Website Siemens Industry Online-Support herunterladen und es mit einer kostenlosen Trial License über einen Zeitraum von 21 Tagen verwenden. Die Trial License für das SIMATIC Automation Tool unterstützt alle Funktionen bis zum Ablauf des Testzeitraums von 21 Tagen.

Um die 21-Tage-Testversion herunterzuladen, gehen Sie wie folgt vor:

  1. Laden Sie die Datei SIMATIC_Automation_Tool_V3_1_SP4.exe von der Webseite Siemens Industry Online-Support herunter. Sie haben zwei Möglichkeiten zum Herunterladen:

    • Speichern Sie die Datei SIMATIC_Automation_Tool_V3_1_SP4.exe an einem Speicherort auf Ihrem Computer. Wenn Sie keinen Speicherort angeben, wird die Datei in Ihrem Ordner "Downloads" abgelegt. Sie können später an diesen Speicherort navigieren und auf die EXE-Datei doppelklicken, um das selbstextrahierende Installationsprogramm auszuführen.

    • Führen Sie das selbstextrahierende Installationsprogramm aus.

  2. Folgen Sie zum Installieren des Produkts der unter Installation über die selbstextrahierende EXE-Datei beschriebenen Vorgehensweise.

Aktivieren der Trial License

Nachdem Sie die 21-Tage-Testversion erfolgreich heruntergeladen haben, gehen Sie zum Aktivieren der Trial License wie folgt vor:

  1. Starten Sie das SIMATIC Automation Tool über das Menü Start oder auf andere Weise. Das SIMATIC Automation Tool zeigt einen Dialog "Automation License Management" an.

  2. Wählen Sie im Dialog "Automation License Management" den License Key der Trial License für das SIMATIC Automation Tool aus.

  3. Klicken Sie auf die Schaltfläche "Activate".

Nach Aktivierung der Trial License können Sie alle Funktionen des SIMATIC Automation Tool 21 Tage lang nutzen.

Wenn Sie das Aktivieren der Lizenz überspringen, können Sie das SIMATIC Automation Tool wie im unlizenzierten Zustand verwenden.

Funktionsbeschränkungen bei einem nicht lizenzierten SIMATIC Automation Tool

Wenn Sie die Trial License nicht aktiviert haben oder wenn die 21-Tage-Trial License abgelaufen ist, unterstützt das SIMATIC Automation Tool nur die folgenden Funktionen:

  • Menübedienungen in den folgenden Menüs:

    • Menü "Datei"

    • Menü "Bearbeiten" einschließlich Bearbeitungen innerhalb der Gerätetabelle

    • Menü "Optionen"

    • Menü "Tools"

    • Menü "Hilfe"

  • Durchsuchen eines Netzwerks

  • Einfügen und Löschen von Geräten

  • Eingeben von Kommentaren in die Gerätetabelle

  • Abrufen von Servicedaten

  • Anzeigen der CPU-Diagnose

  • Eingeben und Ändern von CPU-Passwörtern

  • Versetzen von CPUs in die Betriebsart RUN oder STOP

Lizenzieren des SIMATIC Automation Tool

Um auf alle Funktionen des SIMATIC Automation Tool über die 21-Tage-Frist der Trial License hinaus zugreifen zu können, müssen Sie in der Siemens Industry Mall eine Lizenz erwerben.

Hinweis

Lizenz bleibt nach der Deinstallation erhalten

Wenn Sie eine Lizenz für das SIMATIC Automation Tool haben, bleibt die Lizenz bei der Deinstallation des SIMATIC Automation Tool auf Ihrem Programmiergerät erhalten.


Kaufen, Lizenzieren und Herunterladen des SIMATIC Automation Tool

Installieren einer lizenzierten Version des SIMATIC Automation Tool Herunterladen der lizenzierten Version des SIMATIC Automation Tool
Start Zurück Weiter - Alles aufklappen Alles zuklappen

Kaufen, Lizenzieren und Herunterladen des SIMATIC Automation Tool

Um den vollen Funktionsumfang nutzen zu können, ist für das SIMATIC Automation Tool eine Softwarelizenz erforderlich.

Installieren einer lizenzierten Version des SIMATIC Automation Tool

Je nach Ihrem Herkunftsland können Sie das SIMATIC Automation Tool entweder über Ihren Distributor bestellen oder direkt unter Siemens Industry Mall kaufen. Kunden in den Vereinigten Staaten müssen die Bestellung bei einem Distributor aufgeben. Gehen Sie wie von Ihrem Distributor oder Vertriebspartner empfohlen vor, um das SIMATIC Automation Tool zu bestellen. Für die Bestellung müssen Sie die Lieferadresse in Ihrem Land bestätigen und die Exportbedingungen akzeptieren.

Herunterladen der lizenzierten Version des SIMATIC Automation Tool

Öffnen Sie aus dem Automation License Manager die Webseite "Online Software Delivery", sofern sie nicht bereits geöffnet ist. Im Register "Produkt-Download" werden Ihnen Ihre erworbenen und lizenzierten Softwareprodukte angezeigt.

Hinweis

Sie haben nach der Kaufbestätigung 28 Tage Zeit, um Ihr gekauftes Produkt herunterzuladen. Achten Sie darauf, dass Sie alle Bestandteile der Produktlieferung herunterladen, bevor die 28 Tage ablaufen.

Gehen Sie im Register "Produkt-Download" wie folgt vor, um das Lizenzzertifikat und das SIMATIC Automation Tool herunterzuladen:

  1. Klicken Sie für das SIMATIC Automation Tool auf die Schaltfläche "Zertifikat", um das Zertifikat Ihrer Lizenz anzuzeigen oder zu speichern:

  2. Verwenden Sie den Automation License Manager, um Ihre Lizenz für das SIMATIC Automation Tool auf Ihre Festplatte zu übertragen. Ziehen Sie in der Spalte "License Key" das Feld "Übertragen" in einen Ordner auf Ihrer Festplatte. Legen Sie den übertragenen License Key an einem Speicherort auf Ihrem Programmiergerät ab. Im Automation License Manager zeigt der Navigationsbaum auf der linken Seite die verfügbaren Speicherorte an.

  3. Klicken Sie auf die Schaltfläche "Download", um das lizenzierte SIMATIC Automation Tool auf Ihr Programmiergerät herunterzuladen.

  4. Im Download-Bildschirm können Sie die ISO-Datei, die komprimierte selbstextrahierende EXE-Datei und Dokumente zum Herunterladen auswählen. Sie können alle Optionen auswählen oder nur diejenigen, die Sie benötigen. Die ISO-Datei ist besonders praktisch, wenn Sie eine Installations-DVD brennen möchten. Andernfalls laden Sie die EXE-Datei herunter. Sie können die EXE-Datei zum Installieren des SIMATIC Automation Tool verwenden. Beide Dateitypen (ISO oder EXE) können Sie für eine automatisierte Installation verwenden. Geben Sie, wenn Sie dazu aufgefordert werden, einen Ordner für Ihre heruntergeladenen Artikel an.
Hinweis

Wenn Sie Probleme mit Erwerb, Lizenzierung oder Download haben, können Sie auf der Webseite "Online Software Delivery" eine Supportanfrage absenden.

Das SIMATIC Automation Tool kann nach dem Herunterladen nicht zurückgegeben werden und es ist keine Erstattung möglich.


Installation über die selbstextrahierende EXE-Datei

Start Zurück Weiter - Alles aufklappen Alles zuklappen

Installation über die selbstextrahierende EXE-Datei

Um das SIMATIC Automation Tool über die selbstextrahierende EXE-Datei zu installieren, gehen Sie folgendermaßen vor:

  1. Sofern noch nicht ausgeführt, doppelklicken Sie auf die heruntergeladene Datei SIMATIC_Automation_Tool_SDK_V3_1_SP4.exe.

  2. Folgen Sie zum Extrahieren der Dateien und zum Installieren des SIMATIC Automation Tool den angezeigten Anweisungen. Sie haben die folgenden Möglichkeiten, wenn Sie das Setup starten:

    • Extrahieren der Setup-Dateien ohne nachfolgende Installation: Sie können später zu dem Ordner gehen, in dem Sie die Installationsdateien extrahiert haben, und auf die Datei Start.exe klicken, um die Installation zu starten. Alternativ können Sie an diesem Speicherort eine automatisierte Installation der Dateien ausführen.

    • Extrahierte Dateien beim Beenden löschen: Das Setup-Programm extrahiert die Dateien und führt Sie durch die Installation. Wenn Sie die Installation beenden, löscht das Setup-Programm die extrahierten Dateien. Wählen Sie diese Option nicht, wenn Sie die Dateien für künftige Installationen nutzen möchten.

Das Setup-Programm des SIMATIC Automation Tool führt Sie schrittweise durch den Installationsvorgang.


Installation über die ISO-Datei

Installation über die ISO-Datei

Die ISO-Datei ist ein Festplattenabbild der Installation von SIMATIC Automation Tool. Sie können sie beispielsweise verwenden, um eine DVD zu brennen. Um das SIMATIC Automation Tool über die ISO-Datei zu installieren, gehen Sie folgendermaßen vor:

  1. Verwenden Sie ein handelsübliches Extraktions- oder Brennprogramm, um eine der folgenden Aufgaben zu erledigen:

    • Extrahieren Sie die Ordnerstruktur der ISO-Datei auf Ihr Programmiergerät.
      Hinweis: Sie können Dateien aus einer ISO-Datei auf die gleiche Weise extrahieren wie aus einer ZIP-Datei. Wenn Sie möchten, können Sie die extrahierten Dateien für eine automatisierte Installation verwenden.

    • Brennen Sie eine DVD, die die Installationsdateien für das SIMATIC Automation Tool enthält.

  2. Doppelklicken Sie auf die Datei Start.exe, um das Setup-Programm für die Installation zu starten. Die Datei Start.exe befindet sich an dem Speicherort, an dem Sie die Dateien extrahiert haben, oder im Stammverzeichnis der DVD. Folgen Sie zur Durchführung der Installation den Setup-Anweisungen.

    Das Setup-Programm führt Sie schrittweise durch den Installationsvorgang.


Optionale automatisierte Installation

Optionale automatisierte Installation

Sie können das SIMATIC Automation Tool über die Befehlszeile installieren. Bei der automatisierten Installation sind keine Benutzereingaben erforderlich. Bei der unbeaufsichtigten Durchführung der automatisierten Installation werden keine Installationsdialoge angezeigt.

Wenn Sie das SIMATIC Automation Tool mit Hilfe der automatisierten Installation installieren, erklären Sie sich mit allen Lizenzbedingungen einverstanden. Überprüfen Sie die Lizenzbedingungen im nicht automatisierten Setup-Programm, bevor Sie eine automatisierte Installation des SIMATIC Automation Tool durchführen.

Wenn Sie die extrahierten Installationsdateien nicht gelöscht haben, finden Sie eine Beschreibung der automatisierten Installation in dem Ordner, in dem Sie die Dateien extrahiert haben. Die Dokumentation für die automatisierte Installation finden Sie an folgendem Speicherort:

Documents\<Sprachordner>\PEAutoInstall<Spracherweiterung>.chm

Sie finden die gleichen Anweisungen auch in Ihrem Installationsordner:

SIMATIC Automation Tool\bin\<Sprachordner>\PEAutoInstall<Spracherweiterung>.chm

Beachten Sie, dass die automatisierte Installation des SIMATIC Automation Tool unabhängig von Ihren Spracheinstellungen für die automatisierte Installation die folgenden Sprachen für die Benutzeroberfläche anbietet:

  • Englisch

  • Französisch

  • Deutsch

  • Italienisch

  • Spanisch

  • Chinesisch (vereinfacht)