SIMATIC Automation Tool V3.1 SP4 Benutzerhandbuch

Im Abschnitt Anleitungen Beispiele Grundlagen Verlauf Extras
Start Zurück Weiter

SIMATIC Automation Tool V3.1 SP4 Benutzerhandbuch

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Vorwort
  • SIMATIC Automation Tool - Übersicht
  • Voraussetzungen und Einrichten der Kommunikation
  • Erste Schritte mit dem SIMATIC Automation Tool
  • Gerätevorgänge
  • Verwalten von Projektdateien
  • Menüs, Symbolleisten, Tastenkombinationen und Referenzinformationen
  • SIMATIC Automation Tool API für .NET Framework
  • Unterstützte Geräte im SIMATIC Automation Tool
  • Fehlerbehebung bei Meldungen des Ereignisprotokolls


Vorwort

Vorwort

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Security-Hinweise
  • Service & Support


Security-Hinweise

Security-Hinweise

Siemens bietet Produkte und Lösungen mit Industrial Security-Funktionen an, die den sicheren Betrieb von Anlagen, Systemen, Maschinen und Netzwerken unterstützen.

Um Anlagen, Systeme, Maschinen und Netzwerke gegen Cyber-Bedrohungen zu sichern, ist es erforderlich, ein ganzheitliches Industrial Security-Konzept zu implementieren (und kontinuierlich aufrechtzuerhalten), das dem aktuellen Stand der Technik entspricht. Die Produkte und Lösungen von Siemens formen einen Bestandteil eines solchen Konzepts.

Die Kunden sind dafür verantwortlich, unbefugten Zugriff auf ihre Anlagen, Systeme, Maschinen und Netzwerke zu verhindern. Diese Systeme, Maschinen und Komponenten sollten nur mit dem Unternehmensnetzwerk oder dem Internet verbunden werden, wenn und soweit dies notwendig ist und nur wenn entsprechende Schutzmaßnahmen (z. B. Firewalls und/oder Netzwerksegmentierung) ergriffen wurden.

Weiterführende Informationen zu möglichen Schutzmaßnahmen im Bereich Industrial Security finden Sie unter.

Die Produkte und Lösungen von Siemens werden ständig weiterentwickelt, um sie noch sicherer zu machen. Siemens empfiehlt ausdrücklich, Produkt-Updates anzuwenden, sobald sie zur Verfügung stehen und immer nur die aktuellen Produktversionen zu verwenden. Die Verwendung veralteter oder nicht mehr unterstützter Versionen kann das Risiko von Cyber-Bedrohungen erhöhen.

Um stets über Produkt-Updates informiert zu sein, abonnieren Sie den Siemens Industrial Security RSS Feed unter.


Service & Support

Sprache des Quelldokuments

Service & Support

Zusätzlich zu diesem Benutzerhandbuch bietet Siemens technische Hilfe im Internet und auf der Siemens Automation Website sowie auf der Siemens Industry Online Support Website. Falls Sie technische Fragen haben, eine Schulung benötigen oder S7-Produkte bestellen wollen, wenden Sie sich bitte an Ihre Siemens-Vertretung. Das technisch geschulte Vertriebspersonal verfügt über sehr spezifische Kenntnisse zu Einsatzmöglichkeiten und Prozessen sowie zu den verschiedenen Siemens-Produkten und kann Ihnen deshalb am schnellsten und besten weiterhelfen, wenn Probleme auftreten.

Sprache des Quelldokuments

Maßgeblich für Informationen über das SIMATIC Automation Tool ist die englischsprachige Fassung des Handbuchs SIMATIC Automation Tool Benutzerhandbuch . Bei Abweichungen in den übersetzten Handbüchern bestimmt Siemens das englische Handbuch als maßgebliche ursprüngliche Quelle.


SIMATIC Automation Tool - Übersicht

SIMATIC Automation Tool - Übersicht

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Verwalten von Netzwerken
  • Netzwerkzugriff
  • Netzwerkoptionen
  • .NET API (Anwendungsprogrammierschnittstelle)


Verwalten von Netzwerken

Verwalten von SIMATIC-Gerätenetzwerken Vorgänge für Konfiguration, Betrieb und Wartung Funktionsbeschränkungen bei einem nicht lizenzierten SIMATIC Automation Tool DCP-Vorgänge Zugriff auf den Gerätekatalog Beispiel einer S7-1200-Netzwerkinstallation
Start Zurück Weiter

Verwalten von Netzwerken

Das SIMATIC Automation Tool ist beim Maschinen- und Anlagenbetrieb nützlich. Mit diesem Tool können Sie einen Vorgang auf mehreren Netzwerkgeräten gleichzeitig ausführen. Das SIMATIC Automation Tool unterstützt Sie bei den folgenden Tätigkeiten:

  • Inbetriebnahme

    Mit dem SIMATIC Automation Tool können Sie beispielsweise mehrere IP-Adressen gleichzeitig aktualisieren oder Projekte auf mehrere Geräte laden.

  • Wartung

    Sie können beispielsweise Firmware-Aktualisierungen für mehrere Geräte durchführen. Oder Sie können ein Programm von einem Gerät sichern, um es später auf mehreren Geräten wiederherzustellen.

  • Service

    Es kann beispielsweise nützlich sein, Diagnose- und Servicedaten von mehreren Geräten abzurufen.

Verwalten von SIMATIC-Gerätenetzwerken

Nachdem ein Steuerungsprogramm mit der TIA Portal-Software von Siemens erzeugt, geprüft und heruntergeladen wurde, kann das SIMATIC Automation Tool zum Konfigurieren, Betreiben, Warten und Dokumentieren einer Vielzahl von Geräten in Automatisierungsnetzwerken genutzt werden.

Hinweis

Sie können mit dem SIMATIC Automation Tool keine Geräte in Ihrem Automatisierungsnetzwerk lesen, wenn S7-PLCSIM auf demselben Programmiergerät zur gleichen Zeit wie das SIMATIC Automation Tool ausgeführt wird. Sie müssen S7‑PLCSIM schließen, damit das SIMATIC Automation Tool ein Gerätenetzwerk lesen kann.

Vorgänge für Konfiguration, Betrieb und Wartung

Wenn Sie eine gültige, nicht abgelaufene Lizenz besitzen, können Sie mit dem SIMATIC Automation Tool viele nützliche Vorgänge in einem Gerätenetzwerk ausführen:

Vorgänge im Netzwerk

  • Durchsuchen des Netzwerks und Anlegen einer Gerätetabelle mit den im Netzwerk erreichbaren Geräten. Die Gerätetabelle kann CPUs, Module, HMIs, SCALANCE Industrial Ethernet Switches, dezentrale Peripherie und andere Siemens-Geräte enthalten. Sie können die Gerätetabelle in einer sicheren SAT-Projektdatei oder in einer CSV-Datei mit offenem Text speichern.

  • Identifizieren von Geräten mit blinkenden LEDs oder HMI-Bildschirmen

  • Aktualisieren von Geräteadressen (IP, Subnetz, Gateway)

  • Aktualisierung des PROFINET-Namens (Stationsname) eines Geräts

Systemkonfiguration

  • Einstellen der Zeit in einer CPU auf die aktuelle Zeit Ihres Programmiergeräts

  • Aktualisieren des CPU-Programms oder des HMI-Betriebssystems und der Runtime Software

  • Laden, Hinzufügen, Ersetzen oder Löschen von Rezeptdaten aus einer CPU

  • Laden aus CPU oder Löschen von Datenprotokolldaten von einer CPU

  • Aktualisierung der Modul-Firmware

Betrieb

  • Versetzen einer CPU in den Betriebszustand RUN oder STOP

Systemdiagnose und -wartung

  • Sichern von Daten in einer Sicherungsdatei für eine CPU oder ein HMI-Gerät

  • Wiederherstellen von Daten aus einer Sicherungsdatei für eine CPU oder ein HMI-Gerät

  • Diagnosepuffer einer CPU anzeigen

  • Kommunikationsparameter zurücksetzen

  • Urlöschen des CPU-Speichers

  • Laden von Servicedaten aus einer CPU

  • Formatieren der SIMATIC Memory Card in einer CPU

  • Rücksetzen von Geräten auf Werkseinstellungen

  • Dokumentieren und Speichern von Netzwerkinformationen in einer .csv-Datei mit Standardtext oder in einer passwortgeschützten .sat-Datei

Gerätetabelle im SIMATIC Automation Tool

Funktionsbeschränkungen bei einem nicht lizenzierten SIMATIC Automation Tool

Wenn Sie die Trial License nicht aktiviert haben oder die Trial License nach 21 Tagen abgelaufen ist, unterstützt das SIMATIC Automation Tool nur die folgenden Funktionen:

  • Menübedienungen in den folgenden Menüs:

    • Menü "Datei"

    • Menü "Bearbeiten" einschließlich Bearbeitungen innerhalb der Gerätetabelle

    • Menü "Optionen"

    • Menü "Werkzeuge"

    • Menü "Hilfe"

  • Durchsuchen eines Netzwerks

  • Einfügen und Löschen von Geräten

  • Eingeben von Kommentaren in die Gerätetabelle

  • Abrufen von Servicedaten

  • Anzeigen der CPU-Diagnose

  • Eingeben und Ändern von CPU-Passwörtern

  • Versetzen von CPUs in die Betriebsart RUN oder STOP

DCP-Vorgänge

Beachten Sie, dass einige Geräte nur DCP-Vorgänge (Discovery and Configuration Protocol = Erkennungs- und Konfigurationsprotokoll) unterstützen:

  • Siemens PROFINET-Geräte

  • Nicht unterstützte, nicht von Siemens stammende PROFINET- oder Ethernet-Geräte

Die DCP-Vorgänge sind folgende:

  • Netzwerk durchsuchen

  • Gerät identifizieren (Geräte-LED blinken lassen oder Anzeige auf HMI-Bild blinken lassen)

  • IP-Adresse, Subnetz-Maske und Gateway-Adresse in einem Gerät aktualisieren

  • PROFINET-Gerätenamen aktualisieren

  • Kommunikationsparameter zurücksetzen

Zugriff auf den Gerätekatalog

Mit dem SIMATIC Automation Tool besteht die Möglichkeit zum Öffnen einer Microsoft Excel-Datei mit einem Gerätekatalog, in dem die unterstützten Geräte angezeigt werden. Der Gerätekatalog zeigt für jedes Gerät die unterstützten Vorgänge an. Zusätzliche Informationen finden Sie unter Unterstützte Geräte im SIMATIC Automation Tool.

Beispiel einer S7-1200-Netzwerkinstallation

Panel Shop-Herstellung und erstmaliges Laden des Programms

  • Jede CPU verwendet dieselbe Hardwarekonfiguration und dasselbe Steuerungsprogramm

  • Die CPU PROFINET-Konfiguration nutzt die Optionen "Anpassen der IP-Adresse direkt am Gerät erlauben" und "Anpassen des PROFINET-Gerätenamens direkt am Gerät erlauben".

  • Jedes Panel ist identisch.

  • Sie können das SIMATIC Automation Tool, eine SIMATIC SD Memory Card oder das TIA Portal verwenden, um Projektdaten in CPU-/HMI-Geräte zu laden.

Wird ein Netzwerk mit vielen Geräten betrieben, kann das SIMATIC Automation Tool die Vorgänge vereinfachen und Zeit sparen. Sie können einen Vorgang auf mehreren Geräten gleichzeitig ausführen. Das SIMATIC Automation Tool bietet Multithreading für Geräte, die keine fehlersicheren Geräte sind. Multithreading bedeutet, dass mehrere Vorgänge gleichzeitig ausgeführt werden können. Während das Programmiergerät einen Vorgang auf einem Gerät ausführt, kann ein anderer Thread einen Vorgang auf einem anderen Gerät starten. Multithreading ist die Standardeinstellung im Kommunikationseinstellungen. Sie können Multithreading bei Bedarf auch deaktivieren.


Netzwerkzugriff

Kommunikation mit Netzwerkgeräten DCP-Vorgänge Kommunikationsmodelle und -schichten Netzwerkzugriff und Vorgänge mit dem SIMATIC Automation Tool
Start Zurück Weiter

Netzwerkzugriff

Kommunikation mit Netzwerkgeräten

Die Netzwerksuche im SIMATIC Automation Tool findet Geräte, die direkt mit einem Netzwerk verbunden sind, mit Hilfe der MAC-(Media Access Control)-Adresse. Jedes Gerät besitzt eine eindeutige MAC-Adresse. Die MAC-Adresse kann nicht geändert werden und ist auf dem Gerät aufgedruckt. Das SIMATIC Automation Tool erkennt angeschlossene Geräte unabhängig davon, ob sie mit einer IP-, Subnetz- und Gateway-Adresse oder nicht konfiguriert sind. Die IP-Adresse 0.0.0.0 kennzeichnet Geräte, die nicht konfiguriert sind.

Auf MAC-Adressen basierende Vorgänge verwenden das DCP (Discovery and Configuration Protocol). DCP ist ein Ethernet-Standard.

DCP-Vorgänge

Bei allen direkt verbundenen Netzwerkgeräten unterstützt das SIMATIC Automation Tool die DCP-Vorgänge für MAC-Adressen:

  • Netzwerk durchsuchen

  • Geräte identifizieren

  • Festlegen der IP-Adresse

  • Festlegen des PROFINET-Namens

  • Kommunikationsparameter zurücksetzen

Direkt verbundene Geräte, die DCP unterstützen, sind z. B.:

  • unterstützte PROFINET-Geräte

  • nicht unterstützte PROFINET-Geräte

  • nicht unterstützte Ethernet-Geräte von anderen Anbietern als Siemens

Kommunikationsmodelle und -schichten

Unterschiedliche Kommunikationsmodelle stehen für verschiedene Arten von Kommunikationsprotokollen. Für ein Verständnis der Funktionsweise des SIMATIC Automation Tool sollten die folgenden Kommunikationsschichten bekannt sein:

Schicht | Gerät | Adressierung
Netzwerk (Schicht 3) | Router | Nur IP-Adressen
Verbindung (Schicht 2) | Switch | MAC-Adressen (DCP) IP-Adressen
Physikalisch (Schicht 1) | Hub | Bits

Schicht 1: Einfaches Netzwerk, bei dem das Programmiergerät direkt mit einer CPU mit lokaler Peripherie verbunden ist:

  • Auf der MAC-Adresse basierende Vorgänge sind möglich.

  • Eine gültige IP-Adresse und die TIA Portal-Gerätekonfiguration in der CPU sind erforderlich für:

    • Anzeigen der lokalen Module für eine CPU

    • Auf der IP-Adresse basierende Vorgänge

Schicht 2: Mehrere CPUs mit lokaler Peripherie, die über einen Ethernet-Switch verbunden sind:

  • Auf MAC-Adressen basierende Vorgänge sind für alle Geräte möglich.

  • Eine gültige IP-Adresse und die TIA Portal-Gerätekonfiguration in den einzelnen CPUs sind erforderlich für:

    • Anzeigen der lokalen Module für eine CPU

    • Auf der IP-Adresse basierende Vorgänge

Schicht 3: CPUs in komplexen Netzwerken mit dezentraler Peripherie und IP-Adress-Routern:

  • Auf MAC-Adressen basierte Vorgänge sind nur für Geräte möglich, die direkt mit dem gleichen Subnetz verbunden sind, z. B. für das Programmiergerät, auf dem das SIMATIC Automation Tool läuft.

  • Eine gültige IP-Adresse und die TIA Portal-Gerätekonfiguration in den einzelnen CPUs sind erforderlich für:

    • Anzeigen von hinter der CPU befindlichen Geräten

    • Auf der IP-Adresse basierende Vorgänge

Auf der IP-Adresse basierende Vorgänge funktionieren nur bei unterstützten Siemens-Geräten.

Hinweis

Beim Durchsuchen eines Netzwerks kann das SIMATIC Automation Tool Geräte hinter einem NAT-Router zur Netzwerkadressübersetzung nicht erkennen.

Das SIMATIC Automation Tool erkennt Geräte bei der Durchsuchung eines Netzwerks an ihrer MAC-Adresse und IP-Adresse. Da NAT-Router keine DCP-Befehle weiterleiten, können mit einem NAT-Router verbundene Geräte bei der Durchsuchung eines Netzwerks nicht erkannt werden. Aus dem gleichen Grund können Sie keine Geräte einfügen, die sich hinter einem NAT-Router befinden.

Beispielsweise besitzt eine S7-1500 CPU eine PROFINET-Netzwerkverbindung zum SIMATIC Automation Tool. Diese S7-1500-CPU stellt die Verbindung zu einem anderen PROFINET-Netzwerk über ein lokales CP-Modul her. An dieses Netzwerk wiederum sind dezentrale Peripheriegeräte angeschlossen.

Damit das SIMATIC Automation Tool das Netzwerk mit der dezentralen Peripherie erkennen kann, gehen Sie wie folgt vor:

  1. Weisen Sie der S7-1500 CPU in STEP 7 eine gültige IP-Adresse zu.

  2. Übersetzen Sie das STEP 7-Projekt und laden Sie das Projekt in die CPU.

  3. Durchsuchen Sie das Netzwerk über das SIMATIC Automation Tool.

Bei indirekt angeschlossenen Geräten hinter einer CPU, einem CM oder CP-Modul ist nur der Vorgang der Firmware-Aktualisierung möglich.

Netzwerkzugriff und Vorgänge mit dem SIMATIC Automation Tool

Die Art des Netzwerkzugriffs hängt von dem von Ihnen ausgeführten Befehl ab, wie in der folgenden Tabelle dargestellt wird.

SIMATIC Automation Tool
-Befehl

Verwendete Geräteadresse

CPU-Passwort für geschützte CPU erforderlich

Netzwerkzugriff

Durchsuchen (CPUs, HMI-Geräte, Peripherie und andere Geräte erkennen)

MAC

Nein

  • Lokales Netzwerk: Sie können über Ethernet-Switches auf Netzwerkgeräte zugreifen. Sie können über einen IP-Adress-Router nicht auf Geräte in einem anderen Netzwerk zugreifen.

  • VPN-Anbindung (virtuelles privates Netzwerk) an das lokale Netzwerk.
    Für diese MAC-Funktionen müssen Sie die VPN-Schicht 2 nutzen.

Geräte identifizieren (Geräte-LED/HMI-Bildschirm)

MAC

Nein

Einstellen von IP-Adresse, Subnetzmaske und Gateway-Adresse in Geräten

MAC

Nein

Einstellen des PROFINET-Namens in Geräten

MAC

Nein

Kommunikationsparameter zurücksetzen

MAC

Nein

Versetzen von CPUs in RUN oder STOP

IP

Ja1

  • Lokales Netzwerk: Sie können über Ethernet-Switches auf Netzwerkgeräte zugreifen.

  • Remote-Netzwerk: Sie können über einen IP-Adress-Router auf Geräte in einem anderen Netzwerk zugreifen.

  • VPN: Anbindung an das lokale Netzwerk

CPU-Zeit auf Zeit des Programmiergeräts setzen

IP

Ja1

Programmaktualisierung durchführen: CPU-Programme

IP

Ja3

Programmaktualisierung durchführen: HMI-Aktualisierung für Betriebssystem und Runtime-Software

IP

-/-

Rezeptdaten aus einer CPU laden

IP

Ja2

Rezeptdaten aus einer CPU hinzufügen, ersetzen oder löschen

IP

Ja1

Datenprotokolldaten von einer CPU laden

IP

Ja2

Datenprotokolldaten von einer CPU löschen

IP

Ja1

CPU in einer Datei sichern

IP

Ja2

HMI in einer Datei sichern

IP

-/-

CPU aus Sicherungsdatei wiederherstellen

IP

Ja3

HMI aus Sicherungsdatei wiederherstellen

IP

-/-

Servicedaten aus CPUs laden

IP

Ja2

Lesen des CPU-Diagnosepuffers

IP

Ja2

Urlöschen des CPU-Speichers

IP

Ja1

Rücksetzen auf Werkseinstellungen

IP

Ja3

Firmware in Geräten aktualisieren

IP

Ja1

CPU Memory Card formatieren

IP

Ja3

1Erfordert die Zugriffsstufe "Vollzugriff (kein Schutz)"

2Erfordert eine Zugriffsstufe mit "Lesezugriff"
3 Für Standard-CPUs ist der "Vollzugriff (kein Schutz)" erforderlich. Fehlersichere CPUs erfordern entweder die Zugriffsstufe "Vollzugriff (kein Schutz)" oder "Vollzugriff inkl. Failsafe (kein Schutz)" je nach Firmware-Version der CPU. Außerdem müssen für diese Vorgänge fehlersichere CPUs erneut ausgewählt und bestätigt werden.

Weitere Informationen über CPU-Zugriffsstufen siehe Thema CPU-Passwörter.

Hinweis

IP-Subnetze und Netzwerkschnittstellenprotokolle

Das Programmiergerät, auf dem das SIMATIC Automation Tool installiert ist, und die an das lokale Netzwerk angeschlossenen Geräte müssen angemessene IP-Subnetzzuweisungen verwenden.

Die Art des von Ihnen gewählten Netzwerkschnittstellenprotokolls ("TCPIP" bzw. "TCPIP.Auto") kann sich darauf auswirken, ob Geräte während der Durchsuchung des Netzwerks vom SIMATIC Automation Tool erkannt werden.

Ein Beispiel finden Sie unter Einrichten der Kommunikation.


Netzwerkoptionen

Lokale und dezentrale Netzwerke Beispiel 1: Lokales S7-1200 Netzwerk Beispiel 2: Dezentrales S7-1200 Netzwerk Beispiel 3: Kombiniertes lokales und dezentrales S7-1200 Netzwerk
Start Zurück Weiter

Netzwerkoptionen

Lokale und dezentrale Netzwerke

Die folgenden Beispiele zeigen lokale und dezentrale Netzwerke, die das SIMATIC Automation Tool nutzen kann. Zur besseren Darstellung der grundlegenden Konnektivität sind die Diagramme vereinfacht und zeigen keine HMI-Geräte, lokale Peripherie, dezentrale Peripheriegeräte (PROFINET und PROFIBUS) oder andere Geräte, auf die ebenfalls zugegriffen werden kann. Auch andere Netzwerktopologien sind möglich.

Wenn Sie das Netzwerk durchsuchen, befüllt das SIMATIC Automation Tool die Gerätetabelle. Die Gerätedaten in der Gerätetabelle können Sie in eine Datei im Format CSV exportieren. In der CSV-Datei können Sie dann die Gerätedaten mit Microsoft Excel oder einem Tool Ihrer Wahl ändern. Anschließend können Sie die neuen Daten kopieren und in die Gerätetabelle im SIMATIC Automation Tool einfügen.

Beispiel 1: Lokales S7-1200 Netzwerk

Beispiel 2: Dezentrales S7-1200 Netzwerk

Beispiel 3: Kombiniertes lokales und dezentrales S7-1200 Netzwerk


.NET API (Anwendungsprogrammierschnittstelle)

.NET API (Anwendungsprogrammierschnittstelle)

Sie können Ihre eigene Anwendungs-Software erstellen, die die SIMATIC Automation Tool Microsoft .NET API nutzt, um dieselben Gerätevorgänge wie das SIMATIC Automation Tool auszuführen.

Damit Sie die API verwenden können, muss auf dem Programmiergerät entweder das SIMATIC Automation Tool oder das SIMATIC Automation Tool SDK (Software Development Kit) installiert sein. Das SIMATIC Automation Tool und Ihre Anwendungs-Software verwenden die API DLL-Datei und außerdem S7-Kommunikationsdateien. Mit der Installation des SIMATIC Automation Tool werden alle benötigten Dateien bereitgestellt und die API-Dateien werden im Installationsordner des SIMATIC Automation Tool abgelegt.

Softwarelizenz erforderlich ab V3.0

Wenn Sie eine gültige und nicht abgelaufene Lizenz für das SIMATIC Automation Tool haben, können Sie die API verwenden.


Voraussetzungen und Einrichten der Kommunikation

Voraussetzungen und Einrichten der Kommunikation

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Installieren des SIMATIC Automation Tools
  • Aufrufen des SIMATIC Automation Tools
  • Einrichten der Kommunikation
  • Konfigurationsvoraussetzungen für die Einstellung einer IP-Adresse
  • Konfigurationsvoraussetzungen für die Einstellung eines PROFINET-Namens


Installieren des SIMATIC Automation Tools

Installieren des SIMATIC Automation Tools

In den aus dem Setup-Programm aufrufbaren Installationshinweisen finden Sie weitere Informationen zur Installation des SIMATIC Automation Tool.


Aufrufen des SIMATIC Automation Tools

Aufrufen des SIMATIC Automation Tools

Das SIMATIC Automation Tool kann auf eine der folgenden Arten aufgerufen werden:

  • Über einen Doppelklick auf das Symbol des SIMATIC Automation Tools auf dem Desktop.

  • Klicken Sie auf die Windows-Schaltfläche "Start" und wählen Sie dann den Menübefehl "Alle Programme" > "Siemens Automation" > "SIMATIC Automation Tool" > "SIMATIC Automation Tool".

  • Doppelklicken Sie auf eine SIMATIC Automation Tool-Projektdatei (*.sat).


Einrichten der Kommunikation

Identifizieren der mit dem Gerätenetzwerk verbundenen Netzwerkschnittstellenkarte Zuweisen der Netzwerkschnittstelle im SIMATIC Automation Tool
Start Zurück Weiter

Einrichten der Kommunikation

Identifizieren der mit dem Gerätenetzwerk verbundenen Netzwerkschnittstellenkarte

Nachdem Sie eine Verbindung zwischen Programmiergerät und Netzwerk hergestellt haben, können Sie den Namen der Netzwerkschnittstellenkarte über die Windows-Systemsteuerung einsehen.

Im folgenden Beispiel ist das SIMATIC-Gerätenetzwerk über einen Ethernet-USB-Konverter mit einem PC (Betriebssystem Windows) verbunden. Welche Netzwerknamen auf Ihrem Programmiergerät tatsächlich angezeigt werden, hängt von Ihrer Netzwerk-Hardware ab.

Identifizieren Sie den Namen des Geräts mit Hilfe der Windows-Systemsteuerung.

  1. Öffnen Sie die Windows-Systemsteuerung (Windows 7) oder die Windows-Einstellungen (Windows 10).

  2. Klicken Sie auf Netzwerk- und Freigabecenter (Windows 7) oder navigieren Sie zu Netzwerk und Internet > Ethernet > Netzwerk- und Freigabecenter (Windows 10):

  3. Sehen Sie sich die aktiven Netzwerke an und klicken Sie auf das mit Ihren Geräten verbundene Netzwerk.

  4. Klicken Sie in der Verbindungsstatusanzeige auf die Schaltfläche "Details".

  5. Lesen Sie die Beschreibung der Netzwerkschnittstelle.

Zuweisen der Netzwerkschnittstelle im SIMATIC Automation Tool

Sie müssen die Netzwerkschnittstelle einem neuen Projekt zuweisen, bevor mit der Kommunikation begonnen werden kann. Für die Einstellung der Netzwerkschnittstelle gehen Sie wie folgt vor:

  1. Starten Sie das SIMATIC Automation Tool.

  2. Klicken Sie auf die Klappliste der Netzwerkschnittstellenkarte.

  3. Wählen Sie die Netzwerkschnittstelle, die mit Ihrem Siemens-Gerätenetzwerk verbunden ist.

Sie sehen möglicherweise andere Netzwerkschnittstellen als in der folgenden Abbildung dargestellt, denn die Liste enthält die Netzwerkschnittstellen, die auf Ihrem Programmiergerät verfügbar sind.

Wenn eine Netzwerkschnittstellenkarte ausgewählt ist, aber die Geräte keine gültigen IP-Adressen haben, können Sie die auf IP-Adressen basierenden Funktionen nicht verwenden.
Sie können die auf MAC-Adressen basierenden Funktionen verwenden und gültige IP-Adressen für die Geräte in Ihrem Netzwerk einrichten.

MAC-Adressfunktionen

  • Durchsuchen auf Geräte im Netzwerk

  • Geräte identifizieren

  • Festlegen von Ethernet-IP-Adressen

  • Festlegen von PROFINET-Namen

  • Rücksetzen auf Werkseinstellungen Der auf MAC-Adressen basierende Vorgang zum Zurücksetzen auf die Werkseinstellungen funktioniert nur für PROFINET-Peripheriegeräte, für andere Geräte muss ein auf einer IP-Adresse basierender Vorgang verwendet werden.

Auswahl der Netzwerkschnittstelle

Wie aus der vorstehenden Abbildung ersichtlich, kann es zwei Einträge für eine Netzwerkkarte geben, die sich durch die Ergänzung der Zeichen ".Auto" voneinander unterscheiden.

Bei Auswahl der Ethernet-Schnittstelle können Sie zwischen zwei Netzwerkprotokollarten wählen:

  • TCPIP

  • TCPIP.Auto

Siemens empfiehlt die Auswahl von TCPIP ohne "Auto", um die Erstellung temporärer IP-Adressen im Windows-Ethernet-Adapter zu verhindern. In der Windows-Konfiguration für Ihre Netzwerkschnittstelle müssen Sie eine gültige IP-Adresse zuweisen.

Alternativ bietet sich die Auswahl von TCPIP.Auto an. Nach Ausführung einer Netzwerksuche müssen Sie überprüfen, ob automatisch erstellte temporäre IP-Adressen nicht mit den IP-Adressen anderer Geräte im Netzwerk in Konflikt stehen.

Das TCPIP.Auto-Protokoll hat die folgenden Vorteile:

  • Das Protokoll TCPIP.Auto ermöglicht es der Netzwerkschnittstelle, eine temporäre IP-Adresse in demselben Subnetz zu erstellen wie Geräte, die sich nicht in demselben physischen Subnetz wie die Netzwerkschnittstelle befinden. Das Protokoll TCPIP kann nur auf Geräte in demselben physischen Subnetz zugreifen.

  • Sie können die IP-Adressen von erreichbaren Netzwerkgeräten auf ein Subnetz ändern, das mit dem TCPIP-Protokoll kompatibel ist.

  • Nach abgeschlossener Netzwerksuche besitzt der Windows-Ethernet-Adapter immer gültige temporäre IP-Adressen für alle Siemens-Geräte. Sie müssen neue IP-Adressen unter Windows nicht explizit zuweisen.

Das TCPIP.Auto-Protokoll kann jedoch auch Probleme bei der Netzwerkkommunikation verursachen:

  • Die Zuweisung von temporären IP-Adressen ist nicht möglich.

  • Temporäre Adressen gehen nach Aus- und Wiedereinschalten der Spannungsversorgung bzw. nach Rücksetzen des Programmiergeräts verloren. Beim nächsten Durchsuchen des Netzwerks, bei dem das Protokoll TCPIP.Auto verwendet wird, werden neue temporäre IP-Adressen erstellt.

  • Es wird möglicherweise automatisch eine temporäre IP-Adresse erstellt, die bereits von einem anderen Teilnehmer verwendet wird (z. B. ein anderes Programmiergerät, das beim Durchsuchen des Netzwerks nicht vom SIMATIC Automation Tool erkannt wird). Ein Adresskonflikt kann in einigen Netzwerkteilen schwer diagnostizierbare Kommunikationsfehler verursachen.

Beispiel für die Verwendung des TCPIP- und TCPIP.Auto-Protokolls

Die IP-Adressen des Windows-Netzwerkadapters können durch Eingabe von "ipconfig /all" in die Befehlszeile abgerufen werden.

Der Befehl "ipconfig /all" wurde zum Abrufen der im Beispiel gezeigten IP-Adressen verwendet.

  1. Führen Sie nach dem Rücksetzen eines Programmiergeräts und vor dem Durchsuchen eines Netzwerks mit dem SIMATIC Automation Tool den Befehl "ipconfig /all" in der Befehlszeile aus. Das Ergebnis für die an das Siemens-Gerätenetzwerk angeschlossene Ethernet-Adapterkarte ist nachstehend aufgeführt. Der Ethernet-Adapter für Windows ist mit der IP-Adresse 192.168.2.200 konfiguriert:

  2. Schließen Sie einen Siemens S7-1200 PLC mit der IP-Adresse 192.168.3.1 an. Die Subnetzmaske lautet 255.255.255.0. Das S7‑1200-Gerät ist somit für ein abweichendes Subnetz konfiguriert. Das dritte Oktett ist "3" und muss "2" sein, damit eine Kommunikation mit der Subnetzadresse 192.168.2 des Ethernetadapters möglich ist.

  3. Starten Sie das SIMATIC Automation Tool, stellen Sie die Netzwerkschnittstelle auf das TCPIP-Protokoll ein und führen Sie eine Netzwerksuche durch. In diesem Fall wird der S7‑1200 PLC nicht gefunden, da er mit einer falschen Subnetzadresse konfiguriert ist.

  4. Ändern Sie die Netzwerkschnittstelle des SIMATIC Automation Tool auf das TCPIP.Auto-Protokoll und führen Sie eine Netzwerksuche durch.

  5. Die Netzwerksuche verwendet das TCPIP.Auto-Protokoll und erkennt das S7-1200 Gerät. Zur Gerätetabelle des SIMATIC Automation Tool werden neue S7-1200 Geräteinformationen hinzugefügt.

  6. Führen Sie "ipconfig /all" in der Befehlszeile aus.
    Wie Sie im folgenden Bild sehen, wurde die temporäre IP-Adresse 192.168.3.241 für den Ethernet-Adapter erstellt. Über die temporäre IP-Adresse ist der Zugriff auf das Subnetz 192.168.3 möglich.

    Es werden mehrere temporäre IP-Adressen erstellt, wenn das Protokoll TCPIP.Auto mehrere Subnetze in einem komplexen Netzwerk erkennt.
    Die temporären IP-Adressen werden beim Rücksetzen des Windows-Programmiergeräts gelöscht.

  7. Das SIMATIC Automation Tool kann nun mit Hilfe der temporären IP-Adresse 192.168.3.241 eine Verbindung zum S7-1200 Gerät herstellen und anschließend die IP-Adresse des S7-1200 Geräts ändern. Verwenden Sie das SIMATIC Automation Tool zum Aktualisieren der IP-Adresse. Ändern Sie die IP-Adresse von 192.168.3.1 in 192.168.2.1.

  8. Setzen Sie das Programmiergerät zurück und starten Sie Windows neu. Alle temporären IP-Adressen werden nach dem Neustart gelöscht.

  9. Starten Sie das SIMATIC Automation Tool, stellen Sie die Netzwerkschnittstelle auf das TCPIP-Protokoll ein und führen Sie eine Netzwerksuche durch.
    Der S7-1200 PLC (192.168.2.1) wird erkannt und kann mit dem Windows-Ethernet-Adapter (192.168.2.200) kommunizieren.
    Es werden keine temporären IP-Adressen erzeugt. Es wird lediglich die IP-Adresse verwendet, die unter Windows in den Netzwerkadaptereigenschaften konfiguriert wurden.

Wenn die Netzwerkschnittstellenkarte ausgewählt ist und die IP-Adressen der Geräte gültig sind, können Sie die Funktionen im SIMATIC Automation Tool nutzen, die eine IP-Adresse verwenden.

IP-Adressfunktionen

  • Versetzen von CPUs in RUN oder STOP

  • Einstellen der CPU-Zeit auf die Zeit des Programmiergeräts

  • Aktualisieren von Programmen für CPUs und HMI-Geräte

  • Laden, Hinzufügen, Ersetzen oder Löschen von Rezeptdaten aus einer CPU

  • Laden oder Löschen von Datenprotokolldaten aus/von einer CPU

  • Sichern/Wiederherstellen von CPU- und HMI-Daten

  • Laden von Servicedaten aus CPUs

  • Anzeigen der Diagnose

  • Urlöschen des CPU-Speichers

  • Formatieren der Memory Card in einer CPU

  • Rücksetzen von Geräten auf Werkseinstellungen

  • Firmware in Geräten aktualisieren

Hinweis

Kommunikationsprobleme mit dem SIMATIC Automation Tool

Möglicherweise senden Sie einen Gerätevorgang an mehrere Geräte, aber ein Gerät schließt den Vorgang nicht ab. Im Ereignisprotokoll wird ein Kommunikationsfehler angezeigt. Andere Geräte führen den Vorgang jedoch wie erwartet aus. Tritt dieses Problem auf, gehen Sie wie folgt vor:

  1. Senken Sie die Anzahl zulässiger gleichzeitiger Vorgänge in den Kommunikationseinstellungen.

  2. Schließen Sie das SIMATIC Automation Tool und starten Sie es erneut.

  3. Wiederholen Sie den Vorgang mit einem oder mehreren Geräten.

Wenn Sie einen Gerätevorgang ausführen und die Verbindung zum Gerät nur eine sehr geringe Datenübertragungsgeschwindigkeit zulässt, wird Ihnen möglicherweise ein Timeout-Fehler für die Kommunikation angezeigt. Wenn dieses Problem auftritt, erhöhen Sie den Zeitverzögerungswert für Kommunikationsvorgänge in den Kommunikationseinstellungen.


Konfigurationsvoraussetzungen für die Einstellung einer IP-Adresse

Voraussetzung für die Einstellung einer IP-Adresse bei direktem Anschluss Beispiel: S7-1200 Konfiguration in STEP 7
Start Zurück Weiter

Konfigurationsvoraussetzungen für die Einstellung einer IP-Adresse

Sie können das SIMATIC Automation Tool verwenden, um die IP-Adresse des Geräts festzulegen. Damit die IP-Adresse nach dem Aus- und Wiedereinschalten gespeichert bleibt, muss diese Funktion in der Gerätekonfiguration im STEP 7-Projekt auf dem Gerät aktiviert sein. Sie müssen das STEP 7-Projekt übersetzen und das Projekt auf das Zielgerät laden. Ohne die Einstellung in der STEP 7-Gerätekonfiguration ist die festgelegte IP-Adresse temporär.

Voraussetzung für die Einstellung einer IP-Adresse bei direktem Anschluss

Das Einstellen der IP-Adresse ist ein DCP-Vorgang, bei dem für den Zugriff auf das Zielgerät eine MAC-Adresse verwendet wird. Geräte, die indirekt verbunden sind, verwenden eine IP-Adresse. Indirekt verbundene Geräte können die DCP-Vorgänge nicht nutzen. Es muss eine temporäre direkte Verbindung zwischen dem Zielgerät und dem SIMATIC Automation Tool hergestellt werden, um die IP-Adresse zu ändern.

Beachten Sie, wann das Einstellen der IP-Adresse möglich und wann es nicht möglich ist:

  • Möglich bei PROFINET-Geräten, die direkt mit dem Netzwerk-Subnetz verbunden sind, das mit dem SIMATIC Automation Tool verbunden ist.

    Bei den Geräten kann es sich um CPUs, HMIs, dezentrale Peripherie und andere Geräte handeln, auch solche, die über einen Ethernet-Switch verbunden sind.

  • Nicht möglich bei PROFINET-Geräten mit einer indirekten Verbindung hinter einem der folgenden Geräte:

    • CPU

    • CP- oder CM-Modul

    • Schnittstellenmodul

    • Zweiter Ethernet-Port der CPU

  • Nicht möglichbei PROFINET-Geräten in einem anderen Netzwerk mit einer Verbindung zum SIMATIC Automation Tool, die über einen IP-Adress-Router verläuft.

Rufen Sie den Gerätekatalog auf, um zu erfahren, welche Vorgänge vom SIMATIC Automation Tool bei den jeweiligen Geräten unterstützt werden.

Beispiel: S7-1200 Konfiguration in STEP 7

Wenn Sie möchten, dass das SIMATIC Automation Tool eine IP-Adressen einstellt, die nicht nur temporär ist, legen Sie die S7-1200 CPU-Gerätekonfiguration wie folgt fest:

  1. Öffnen Sie die Gerätekonfiguration für die S7‑1200 CPU.

  2. Klicken Sie auf die PROFINET-Schnittstelle im CPU-Abbild in der Gerätekonfiguration, um die Schnittstellenparameter anzuzeigen.

  3. Klicken Sie im Register Eigenschaften auf das Register Allgemein, um die Optionen für Ethernet-Adressen anzuzeigen.

  4. Klicken Sie auf die Option "Anpassen der IP-Adresse direkt am Gerät erlauben". Diese Option wird je nach Freigabestand von STEP 7 unterschiedlich bezeichnet. Mögliche Namen in diesem Feld sind:

    • IP-Adresse wird direkt am Gerät festgelegt

    • IP-Adresse direkt am Gerät festlegen

    • Anpassen der IP-Adresse über eine andere Methode erlauben

    Durch diese Auswahl kann das SIMATIC Automation Tool eine IP-Adresse zuweisen. Bei Geräten mit mehreren PROFINET-Schnittstellen wie die S7-1500 CPU können Sie eine Schnittstelle oder alle Schnittstellen so konfigurieren, dass IP-Adressen geändert werden können.

  5. Speichern Sie das Projekt und laden Sie die neuen Konfigurationsänderungen in das Gerät.

Hinweis

Standardeinstellungen der PROFINET-IP-Parameter

Beim Erstellen eines TIA Portal-Projekts werden die PROFINET-Standardparameteroptionen auf "IP-Adresse im Projekt einstellen" gesetzt. Mit den Standardoptionen können Sie mit dem SIMATIC Automation Tool nur eine temporäre IP-Adresse einstellen.


Konfigurationsvoraussetzungen für die Einstellung eines PROFINET-Namens

Voraussetzung für die Einstellung eines PROFINET-Namens bei direktem Anschluss Beispiel: S7-1200-Konfiguration in STEP 7
Start Zurück Weiter

Konfigurationsvoraussetzungen für die Einstellung eines PROFINET-Namens

Wenn Sie möchten, dass das SIMATIC Automation Tool den PROFINET-Namen eines Geräts einstellt, muss diese Funktion in der Gerätekonfiguration im STEP 7-Projekt für das Gerät aktiviert sein. Bevor Sie den PROFINET-Namen eines Geräts mit dem SIMATIC Automation Tool einstellen können, müssen Sie das STEP 7-Projekt übersetzen und in das Zielgerät laden.

Voraussetzung für die Einstellung eines PROFINET-Namens bei direktem Anschluss

Das Einstellen des PROFINET-Namens ist ein DCP-Vorgang, bei dem für den Zugriff auf das Zielgerät eine MAC-Adresse verwendet wird. Geräte, die indirekt angeschlossen sind, verwenden eine IP-Adresse für den Zugang und können die DCP-Funktionen nicht nutzen. Es muss eine temporäre direkte Verbindung zwischen dem Zielgerät und dem SIMATIC Automation Tool hergestellt werden, um den PROFINET-Namen zu ändern.

Beachten Sie, wann das Einstellen des PROFINET-Namens möglich und wann es nicht möglich ist:

  • Möglich bei PROFINET-Geräten (CPUs, HMI-Geräten, dezentraler Peripherie und anderen Geräten) mit direktem Anschluss an das Netzwerk-Subnetz, das mit dem SIMATIC Automation Tool verbunden ist, einschließlich Verbindung per Ethernet-Switch.

  • Nicht möglich bei PROFINET-Geräten mit indirektem Anschluss hinter einer/einem direkt verbundenen CPU, CP/CM-Modul, Interface Modul oder einem zweiten Ethernet-Port einer CPU.

  • Nicht möglichbei PROFINET-Geräten in einem anderen Netzwerk mit einer Verbindung zum SIMATIC Automation Tool, die über einen IP-Adress-Router verläuft.

Rufen Sie den Gerätekatalog auf, um zu erfahren, welche Vorgänge vom SIMATIC Automation Tool bei den jeweiligen Geräten unterstützt werden.

Beispiel: S7-1200-Konfiguration in STEP 7

Wenn Sie möchten, dass das SIMATIC Automation Tool den PROFINET-Namen einstellt, legen Sie die S7-1200 CPU-Gerätekonfiguration wie folgt fest:

  1. Öffnen Sie die Gerätekonfiguration für die S7‑1200 CPU.

  2. Klicken Sie auf die PROFINET-Schnittstelle im CPU-Abbild in der Gerätekonfiguration, um die Schnittstellenparameter anzuzeigen.

  3. Klicken Sie im Register Eigenschaften auf das Register Allgemein, um die Optionen Ethernet-Adressen anzuzeigen.

  4. Klicken Sie unter den Optionen für Ethernet-Adressen auf die Option "Anpassen des PROFINET-Gerätenamens direkt am Gerät erlauben". Diese Option wird je nach Freigabestand von STEP 7 unterschiedlich bezeichnet. Mögliche Namen für dieses Feld sind:

    • PROFINET-Gerätename wird direkt am Gerät festgelegt

    • PROFINET-Gerätenamen am Gerät einstellen

    Durch diese Auswahl kann das SIMATIC Automation Tool einen PROFINET-Stationsnamen zuweisen. Für Geräte mit mehreren PROFINET-Schnittstellen wie die S7-1500 CPU können Sie alle Schnittstellen so konfigurieren, dass PROFINET-Namen geändert werden können, oder Sie können nur eine Schnittstelle für die Änderung von PROFINET-Namen konfigurieren.

  5. Speichern Sie das Projekt und laden Sie die neuen Konfigurationsänderungen in das Gerät.

Hinweis

Standardeinstellungen der PROFINET-IP-Parameter

Beim Erstellen eines neuen TIA Portal-Projekts werden die PROFINET-Standardparameteroptionen auf "PROFINET-Gerätenamen automatisch generieren" gesetzt. Mit den Standardoptionen können Sie mit dem SIMATIC Automation Tool keine PROFINET-Gerätenamen einstellen.


Erste Schritte mit dem SIMATIC Automation Tool

Erste Schritte mit dem SIMATIC Automation Tool

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Arbeiten mit der Gerätetabelle
  • Mit dem Ereignisprotokoll arbeiten
  • CPU-Passwörter
  • Multithread-Verarbeitungsoptionen


Arbeiten mit der Gerätetabelle

Arbeiten mit der Gerätetabelle Kontextmenü für Tabellenzellen Kontextmenü für Spaltenüberschriften Standardspalten wiederherstellen Filtern der angezeigten Zeilen Filtern nicht unterstützter Geräte
Start Zurück Weiter

Arbeiten mit der Gerätetabelle

Das SIMATIC Automation Tool besteht aus zwei Teilen:

  • Gerätetabelle: Die Gerätetabelle ist anfänglich leer. Nachdem Sie das Netzwerk durchsucht oder Geräte eingefügt haben, zeigt die Gerätetabelle die verbundenen Geräte an.

  • Ereignisprotokoll: Das Ereignisprotokoll zeigt die Ergebnisse von Vorgängen an.

Das SIMATIC Automation Tool zeigt für jedes Gerät Spalten mit Angaben zu diesem Gerät an. Die Register in der Gerätetabelle unterstützen eine Vielzahl an Vorgängen in den Geräten und stellen Felder für Dateneingaben bereit.

Arbeiten mit der Gerätetabelle

Die Gerätetabelle ähnelt Microsoft Excel. Sie können Daten in andere oder aus anderen Anwendungen kopieren und einfügen.

Die folgenden Tipps erleichtern die Arbeit mit der Gerätetabelle:

  • Klicken Sie auf eine Spaltenüberschrift, um die Zeilen nach den Spaltendaten zu sortieren bzw. um die Sortierung umzukehren.

  • Klicken Sie mit der rechten Maustaste auf eine Spaltenüberschrift, um Spalten anzuzeigen bzw. auszublenden.

  • Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ kann Menübefehl "Bearbeiten > Auswählen" verwendet werden, und dann entweder "Zeile(n) auswählen" oder "Zeile(n) abwählen". Auch durch Rechtsklick in eine Gerätezeile gelangen Sie in das Menü "Bearbeiten".

  • Durch Klick in die obere linke Ecke der Gerätetabelle werden alle Zeilen markiert.

  • Klicken Sie auf die Zelle links vom Kontrollkästchen einer Zeile, um eine gesamte Zeile auszuwählen. Ziehen Sie den Mauszeiger ab der ausgewählten Zeile aufwärts oder abwärts, um mehrere Zeilen auszuwählen.

  • Klicken Sie auf die Zelle links vom Kontrollkästchen eines Geräts, um alle Zeilen in der Gerätetabelle auszuwählen.

  • Wenn Sie mit der rechten Maustaste auf eine Zeile oder mehrere ausgewählte Zeilen klicken, zeigt das SIMATIC Automation Tool ein Kontextmenü an. Im Kontextmenü können Sie die Befehle Auswählen, Erweitern, Reduzieren, Einfügen, Löschen und Aktualisieren für eine Gruppe von Zeilen durchführen.

  • Sie können Zeilenfilter für die Spalten "Gerät", "Gerätetyp" und "Artikelnummer" erstellen.

  • Wählen Sie für die Vorgänge ein oder mehrere Geräte aus. Das SIMATIC Automation Tool zeigt die ausgewählten Gerätezeilen in Fettschrift an.

  • Klicken Sie auf den Pfeil links von einem Gerät, um es zu erweitern. Daraufhin werden die dem jeweiligen Gerät untergeordneten Module angezeigt. Das SIMATIC Automation Tool zeigt die unterstützten und die nicht unterstützten Module an, die einem unterstützten Gerät untergeordnet sind.

  • Sie können auch eine Gerätetabelle in eine CSV-Datei exportieren, um sie anzuzeigen und in Microsoft Excel oder einem anderen Tool zu bearbeiten.

Sie können das Netzwerk durchsuchen, um die Gerätetabelle mit den Geräten in Ihrem Netzwerk zu füllen. Sie können ferner Geräte direkt einfügen.

Viele der Gerätevorgänge funktionieren mit Dateien auf Ihrem Programmiergerät. Sie finden die Standardpfadnamen für diese Vorgänge in den Einstellungen für jeden Vorgang. Bei der Auswahl können Sie die Standardpfadnamen und andere Einstellungen über den Menübefehl "Optionen > Einstellungen" ändern.

Kontextmenü für Tabellenzellen

Durch Rechtsklick auf eine Gerätezeile in der Gerätetabelle wird ein Kontextmenü aufgerufen, das identisch mit Menü Bearbeiten ist.

Kontextmenü für Spaltenüberschriften

Das SIMATIC Automation Tool zeigt für jedes Register der Gerätetabelle standardmäßig eine Reihe von Spalten an. Sie können wählen, welche Spalten angezeigt oder ausgeblendet werden sollen.

Für die Einstellung der Spalten, die angezeigt bzw. ausgeblendet werden sollen, gehen Sie wie folgt vor:

  1. Rechtsklick auf die Kopfzeile des Geräts zur Anzeige des Kontextmenüs für die Spalten.

  2. Wählen Sie mit den Kontrollkästchen, welche Spalten angezeigt oder ausgeblendet werden sollen.

Standardspalten wiederherstellen

Die Spalten der Gerätetabelle können auf ihre Standardeinstellungen zurückgesetzt werden. Gehen Sie zum Wiederherstellen von Spalten auf ihre Standardeinstellungen wie folgt vor:

  1. Klicken Sie mit der rechten Maustaste auf die Kopfzeile für ein Gerät, um das Kontextmenü für die Spalten anzuzeigen.

  2. Klicken Sie auf den Befehl "Zurück auf Werkseinstellungen".

Filtern der angezeigten Zeilen

Sie können die Spalten "Gerät", "Gerätetyp" und "Artikelnummer" filtern. Klicken Sie auf eine dieser drei Spaltenüberschriften, damit die Schaltfläche für die Filtererweiterung [image] in der Spaltenüberschrift angezeigt wird. Klicken Sie auf diese Schaltfläche, um das Fenster "Filter" zu öffnen.

Sie können beispielsweise die Artikelnummern 6ES7 214-1HF40-0XB0 und 6ES7 215-1HF40-0XB0 auswählen. Wenn Sie auf die Schaltfläche "OK" klicken, werden in der Gerätetabelle nur die Zeilen mit diesen Artikelnummern angezeigt.

In den Allgemeine Einstellungen kann die Anzeige nicht unterstützter Geräte ein-/ausgeschaltet werden.

Filtern nicht unterstützter Geräte

Das SIMATIC Automation Tool zeigt nicht unterstützte Geräte in Grau an. Für nicht unterstützte Geräte sind nur die folgenden Vorgänge möglich:

  • Festlegen der IP-Adresse

  • Festlegen des PROFINET-Namens

  • Gerät identifizieren

  • Kommunikationsparameter zurücksetzen

  • Kommentar zum Gerät bearbeiten

  • Bearbeitungsfunktionen wie Kopieren und Einfügen


Mit dem Ereignisprotokoll arbeiten

Mit dem Ereignisprotokoll arbeiten

Das Ereignisprotokoll wird im SIMATIC Automation Tool im Fensterbereich unter der Gerätetabelle angezeigt. Wenn Sie das Netzwerk durchsuchen und Geräte auswählen, werden Fehler und Ergebnisse der Vorgänge im Ereignisprotokoll angezeigt.

Standardmäßig wird mit jedem neuen Gerätevorgang das Ereignisprotokoll am Anfang des Vorgangs gelöscht. Ob das Ereignisprotokoll zu Beginn eines Vorgangs gelöscht werden soll, können sie in den Einstellungen für Ereignisprotokolle wählen.

Mit dem SIMATIC Automation Tool kann auch der Vorgangsstatus automatisch in einer Datei protokolliert werden.

Zeile im Ereignisprotokoll, die einen erfolgreichen Vorgang anzeigt:

Klicken Sie im Ereignisprotokoll mit der rechten Maustaste auf eine Spaltenüberschrift, um Spalten anzuzeigen bzw. auszublenden:

Klicken Sie mit der rechten Maustaste auf eine Ereigniszeile, um Einträge im Ereignisprotokoll zu kopieren, zu speichern oder zu löschen.

Die Symbole im Ereignisprotokoll haben die folgenden Bedeutungen:

Vorgang erfolgreich

Vorgang fehlgeschlagen. In der Ergebnis-Spalte wird der Grund für das Scheitern beschrieben. Beim Speichern des Ereignisprotokolls beginnen diese Einträge mit "FEHLER:".

Vorgang erfolgreich, aber Warnmeldung vorhanden. In der Ergebnis-Spalte wird die Warnung beschrieben. Beim Speichern des Ereignisprotokolls beginnen diese Einträge mit "WARNUNG".

Nur zur Information

Hinweis

Ereignisprotokoll bei Sprachumstellung der Benutzeroberfläche

Wenn Sie die Sprache für die Benutzeroberfläche des SIMATIC Automation Tool ändern, wird das Ereignisprotokoll durch das SIMATIC Automation Tool zurückgesetzt. Informationen über vorherige Ereignisse werden gelöscht.


CPU-Passwörter

Verwenden von Passwörtern Schutzstufen für CPU-Passwörter Fehlersichere CPUs und Passwörter Passwort-Symbole
Start Zurück Weiter

CPU-Passwörter

Wenn in einer CPU ein Passwortschutz konfiguriert ist, müssen Sie das Passwort für die Sicherheitsstufe eingeben, das es dem SIMATIC Automation Tool gestattet, den gewünschten Vorgang auszuführen. Ein Passwort geben Sie in der Spalte "Passwort in CPU" in der Gerätetabelle ein.

Das Passwort in Spalte "Passwort in CPU" bezieht sich auf den derzeit in der Ziel-CPU vorhandenen Passwortschutz.

Eine neue CPU in einer Verpackung von Siemens hat beispielsweise kein Programm, keine Hardwarekonfiguration und keinen Passwortschutz. Nachdem ein neues Projekt in die CPU geladen wurde, müssen Sie die Passwörter verwenden, die für dieses Projekt konfiguriert sind.

Das SIMATIC Automation Tool zeigt an, ob eine CPU passwortgeschützt ist oder nicht. Das Passwortfeld für eine CPU ist dunkelgrau und nicht bearbeitbar, wenn die CPU kein Passwort besitzt.

Verwenden von Passwörtern

Das SIMATIC Automation Tool handhabt Passwörter wie folgt:

  • Wenn eine CPU passwortgeschützt ist, setzt das SIMATIC Automation Tool die Passwortanforderungen gemäß der im TIA Portal festgelegten Passwort-Zugriffsstufe durch. Bei passwortgeschützten Vorgängen müssen Sie in der Zelle "Passwort in CPU" ein gültiges Passwort eingeben.

  • Register "Programmaktualisierung" hat zwei Spalten für die Passwort-Eingabe: "Passwort in CPU" und "Passwort in Programmdatei".

    Eine Programmdatei kann mit einem anderen Passwort als dem vorhandenen CPU-Passwort geschützt sein. Ist eine Programmdatei mit einem Passwort geschützt, müssen Sie im Feld "Passwort in Programmdatei" das Passwort für die Programmdatei eingeben, um eine Programmaktualisierung auszuführen. Nach einer erfolgreichen Programmaktualisierung kopiert das SIMATIC Automation Tool das Passwort für die Programmdatei in das Feld mit dem CPU-Passwort. Mit diesem Passwort versucht das SIMATIC Automation Tool dann, eine Verbindung zur CPU herzustellen.

  • Register "Aus Sicherungskopie wiederherstellen" hat zwei Spalten für die Passwort-Eingabe: "Passwort in CPU" und "Passwort in Sicherungsdatei".

    Eine Sicherungsdatei kann mit einem anderen Passwort als dem vorhandenen CPU-Passwort geschützt sein. Wenn eine Sicherungsdatei passwortgeschützt ist, müssen Sie im Feld "Passwort in Sicherungsdatei" das Passwort für die Sicherungsdatei eingeben. Das Passwort für die Sicherungsdatei wird zum CPU-Passwort, nachdem der Vorgang der Wiederherstellung aus einer Sicherungskopie erfolgreich beendet ist. Nach einer erfolgreichen Wiederherstellung aus einer Sicherungskopie kopiert das SIMATIC Automation Tool das Passwort für die Sicherungsdatei in das Feld für das CPU-Passwort. Mit diesem Passwort versucht das SIMATIC Automation Tool dann, eine Verbindung zur CPU herzustellen.

  • Ist ein gültiges CPU-Passwort eingegeben, können Sie mit dem Mauszeiger über das Passwortfeld fahren; ein Tooltipp zeigt dann die Schutzstufe an.

Schutzstufen für CPU-Passwörter

Eine Standard-CPU hat vier Schutzstufen. Eine fehlersichere CPU hat fünf Schutzstufen.

Die Vorgänge im SIMATIC Automation Tool, für die Lesezugriff erforderlich ist, können nicht bei einer CPU verwendet werden, die die Schutzstufe "HMI-Zugriff" oder "Kein Zugriff (kompletter Schutz)" hat. Sie müssen im TIA Portal ein Passwort des Typs "Lesezugriff" oder "Vollzugriff" konfigurieren. Sie müssen das Passwort dann für die Ziel-CPU in die Gerätetabelle eingeben.

Die Vorgänge im SIMATIC Automation Tool, für die Schreibzugriff erforderlich ist, können nicht bei einer CPU verwendet werden, die die Schutzstufe "Lesezugriff", "HMI-Zugriff" oder "Kein Zugriff" hat. Sie müssen im TIA Portal ein Passwort des Typs "Lesezugriff" oder "Vollzugriff" konfigurieren. Sie müssen das Passwort dann für die Ziel-CPU in die Gerätetabelle eingeben.

Die Schutzstufen der CPU finden Sie in Teil Schutz & Sicherheit der Eigenschaften im TIA Portal:

Weitere Informationen über Schutzstufen und Passwörter finden Sie im STEP 7 Informationssystem (Online-Hilfe für TIA Portal).

Fehlersichere CPUs und Passwörter

Das SIMATIC Automation Tool kann mit fehlersicheren CPUs arbeiten. Mit einem Passwort für "Lesezugriff" oder für "Vollzugriff (kein Schutz)" können Sie eine Verbindung zu einer fehlersicheren CPU herstellen und bestimmte Vorgänge ausführen. In diesem Benutzerhandbuch wird dieses Passwort als Sicherheitspasswort für eine F-CPU bezeichnet. Sicherheitsrelevante Vorgänge erfordern jedoch das Sicherheitspasswort für eine F-CPU.

  • Das SIMATIC Automation Tool zeigt das Passwortfeld des Geräts in Gelb an, wenn ein Sicherheitspasswort für eine F-CPU eingegeben wird.

  • Ist eine fehlersichere CPU passwortgeschützt, muss für jeden sicherheitsrelevanten Vorgang das Sicherheitspasswort für die F-CPU in Spalte "Passwort in CPU" eingegeben werden.
    Ist eine fehlersichere CPU nicht passwortgeschützt, wird für sicherheitsrelevante Vorgänge auch kein Sicherheitspasswort gefordert.
    Sicherheitsrelevante Vorgänge sind:

    • Programmaktualisierung

    • Gerät aus Datei wiederherstellen

    • Rücksetzen auf Werkseinstellungen

    • Memory Card formatieren

  • Wenn die Programmdatei ein Sicherheitsprogramm enthält, muss das Sicherheitspasswort für die F-CPU in die Spalte "Passwort in Programmdatei" eingegeben werden, um eine Programmaktualisierung durchzuführen.

  • Wenn die Sicherungsdatei ein Sicherheitsprogramm enthält, muss das Sicherheitspasswort für die F-CPU in die Spalte "Passwort in Sicherungsdatei" eingegeben werden, um den Vorgang "Aus Sicherungsdatei wiederherstellen" durchzuführen.

Passwort-Symbole

Das SIMATIC Automation Tool verfügt über drei Statussymbole für Passwörter:

Passwort ist gültig.

Passwort ist ungültig.

Passwort für Gerät in Sicherungsdatei kann noch nicht validiert werden.

Ein grünes Häkchen bedeutet, dass das Passwort in der CPU oder Programmdatei ein gültiges Passwort ist. Ein rotes X bedeutet, dass das Passwort in der CPU oder Programmdatei kein gültiges Passwort ist.

Wenn ein Passwort eingegeben wird, weiß das SIMATIC Automation Tool nicht, welche Vorgänge ausgeführt werden sollen. Das SIMATIC Automation Tool validiert nicht das Passwort bei der Eingabe für einen bestimmten Vorgang. Für die Aktualisierung eines Sicherheitsprogramms wird zum Beispiel das Sicherheitspasswort für eine F-CPU verlangt. Für viele andere Vorgänge genügt dagegen das normale Passwort für Vollzugriff (kein Schutz). Ein grünes Häkchen bedeutet nicht, dass das Passwort für jeden Vorgang gültig ist. Die Prüfung der Schutzstufe erfolgt erst, wenn Sie den Vorgang starten. Wenn das Passwort für einen Vorgang nicht ausreichend ist, erzeugt das SIMATIC Automation Tool im Ereignisprotokoll einen Fehlereintrag für jedes Gerät, bei dem ein Fehler aufgetreten ist.

Ein Fragezeichen kann nur im Passwortfeld für die Sicherungsdatei angezeigt werden:

Im Passwortfeld für die Sicherungsdatei erscheint kein Symbol, wenn das Feld deaktiviert oder leer ist. Wird eine Sicherungsdatei in der Liste ausgewählt oder ein CPU-Passwort in der Spalte für das Passwort einer Sicherungsdatei eingegeben, zeigt das SIMATIC Automation Tool das Fragezeichen an. Das SIMATIC Automation Tool kann das Passwort nicht prüfen, wenn eine Datei ausgewählt oder ein Passwort eingegeben wird.


Multithread-Verarbeitungsoptionen

Möglichkeiten und Beschränkungen für Multithreading Warteschlangen für die Verarbeitung Status der Threadverarbeitung
Start Zurück Weiter

Multithread-Verarbeitungsoptionen

Wenn Sie ein Netzwerk mit vielen Geräten verwalten, kann das SIMATIC Automation Tool Vorgänge vereinfachen und Zeit sparen, indem eine Gruppe von Geräten mit mehreren Verarbeitungsthreads automatisch verarbeitet wird. Während ein Verarbeitungsthread mit einem Gerät verbunden ist und auf eine Nachricht wartet, dass ein SIMATIC-Gerät seine Aufgabe beendet hat, können andere Threads in dieser Zeit mit anderen Geräten in der Gruppe kommunizieren.

Geräte in einem Netzwerk mit Sterntopologie

Wenn Ihr Netzwerk eine Sterntopologie hat, bei der jedes Gerät eine direkte Verbindung zum Programmiergerät über einen Ethernet-Switch unterhält, können Sie die Multithread-Option problemlos aktivieren.

Geräte in einem Netzwerk mit Linientopologie

Falls Ihr Netzwerk eine Linientopologie besitzt, deaktivieren Sie das Multithreading, um zu verhindern, dass ein Gerät die Kommunikation mit anderen Geräten unterbricht. Dies wird unter Kommunikationseinstellungen beschrieben.

Möglichkeiten und Beschränkungen für Multithreading

Das SIMATIC Automation Tool ermöglicht Multithreading für zahlreiche Vorgänge. Für andere Vorgänge müssen Sie Multithreading im Kommunikationseinstellungen aktivieren. Das SIMATIC Automation Tool führt Vorgänge an mehreren fehlersicheren Geräten über einen einzigen Thread für jeden Vorgang für jedes Gerät aus. Sie können Multithreading nicht für Vorgänge an fehlersicheren Geräten aktivieren.

Die Tabelle unten zeigt, wann das SIMATIC Automation Tool mit Multithreading arbeitet.

Legende:

✓ Multithreading wird immer verwendet

O Multithreading ist möglich, sofern im Kommunikationseinstellungen aktiviert

X Sicherheitsrelevanter Vorgang in fehlersicheren Geräten: Nur Single-Thread-Verarbeitung möglich.

Vorgang des SIMATIC Automation Tool | Multithreading Standardgerät | Multithreading Fehlersicheres Gerät
Netzwerk durchsuchen | ✓ | ✓
Geräte identifizieren | ✓ | ✓
Geräteadressen aktualisieren | ✓ | ✓
PROFINET-Name eines Geräts aktualisieren | ✓ | ✓
CPU-Zeit auf Zeit in Programmiergerät einstellen | ✓ | ✓
Programmaktualisierung für CPU | ✓ | X
Programmaktualisierung für HMI-Geräte | ✓ | ✓
Laden, Hinzufügen, Ersetzen oder Löschen von Rezeptdaten aus einer CPU | ✓ | ✓
Datenprotokolldateien aus CPU laden oder in CPU löschen | ✓ | ✓
Firmware in einem Gerät aktualisieren | O | O
Versetzen einer CPU in den Betriebszustand RUN oder STOP | ✓ | ✓
Sichern von Daten in einer Sicherungsdatei für CPUs und HMI-Geräte | ✓ | ✓
Wiederherstellen einer CPU aus einer Sicherungsdatei | O | X
Wiederherstellen eines HMI-Geräts aus einer Sicherungsdatei | O | O
Diagnosepuffer einer CPU anzeigen | ✓ | ✓
Urlöschen des CPU-Speichers | O | O
Laden von Servicedaten aus einer CPU | ✓ | ✓
Memory Card formatieren (SIMATIC Memory Card in CPU gesteckt) | O | X
Rücksetzen auf Werkseinstellungen | O | X
Kommunikationsparameter zurücksetzen | ✓ | ✓

Warteschlangen für die Verarbeitung

Sie können in den Zeilen der Gerätetabelle eine Gruppe mit Standardgeräten und fehlersicheren Geräten auswählen und dann einen Vorgang starten. Das SIMATIC Automation Tool führt auf allen Geräten in der Gruppe den gleichen Vorgang durch. Das SIMATIC Automation Tool verwendet zwei Warteschlangen für die Verarbeitung:

  • Eine Warteschlange mit Priorität 1 für fehlersichere Geräte für die Verarbeitung sicherheitsrelevanter Vorgänge (nur Single-Thread-Verarbeitung)

  • Eine Warteschlange mit Priorität 2, die 1 bis 5 Threads für Standardgeräte und für fehlersichere Geräte verwendet, die Multithreading zulassen

Das SIMATIC Automation Tool verarbeitet die Warteschlange für sicherheitsrelevante Vorgänge in fehlersicheren Geräten zuerst mit einem einzelnen Thread. Der Thread führt jeden Vorgang einzeln auf einem einzelnen fehlersicheren Gerät durch.

Wenn das SIMATIC Automation Tool die Warteschlange für sicherheitsrelevante Vorgänge im fehlersicheren Gerät abgearbeitet hat, wird die zweite Warteschlange mit mehreren Threads verarbeitet.

Manche Vorgänge nutzen das Multithreading immer. Andere verwenden Multithreading nur, wenn durch Kommunikationseinstellungen mehrere Threads aktiviert sind.

Status der Threadverarbeitung

Wenn Sie einen Vorgang für eine Gruppe von Geräten starten, blendet das SIMATIC Automation Tool einen Fortschrittsdialog ein, in dem angezeigt wird, wie viele Geräte in jeder Warteschlange den Vorgang beendet haben. Der Dialog zeigt außerdem den Verarbeitungsfortschritt (in %) für die aktiven Verarbeitungs-Threads an.


Gerätevorgänge

Gerätevorgänge

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Durchsuchen eines Netzwerks
  • Einfügen eines Geräts
  • Aktualisieren von IP-, Subnetz- und Gateway-Adressen
  • Aktualisieren von PROFINET-Gerätenamen
  • Versetzen von CPUs in die Betriebsart RUN oder STOP
  • Identifizieren von Geräten
  • Aktualisieren von Geräteprogrammen über das SIMATIC Automation Tool
  • Laden, Hinzufügen, Ersetzen und Löschen von Rezepten in CPUs
  • Laden und Löschen von Datenprotokollen in CPUs
  • Installieren neuer Firmware auf Geräten
  • Sichern und Wiederherstellen von Gerätedaten
  • Zurücksetzen der Kommunikationsparameter
  • Urlöschen von CPUs
  • Rücksetzen von Geräten auf Werkseinstellungen
  • Formatieren einer Memory Card
  • Abrufen von Servicedaten aus CPUs
  • Einstellen der Uhrzeit in CPUs auf die aktuelle Zeit des Programmiergeräts
  • Anzeigen eines Diagnosepuffers
  • Anzeigen von Gerätereferenzen
  • Kopieren und Einfügen mehrerer Zellen in der Gerätetabelle
  • Reihenfolge der Ausführung von Prozessen


Durchsuchen eines Netzwerks

Ihr Netzwerk durchsuchen Konventionen für die Gerätetabelle Erläuterungen zur Gerätetabelle PROFINET-Peripherie CPUs für Software-Steuerungen Daten der Gerätetabelle aktualisieren Fehler bei der Netzwerkdurchsuchung
Start Zurück Weiter

Durchsuchen eines Netzwerks

Die Gerätetabelle eines neuen Projekts im SIMATIC Automation Tool ist leer. Zu Beginn der Arbeit mit dem SIMATIC Automation Tool muss das Kommunikationsnetzwerk durchsucht werden, um die Gerätetabelle zu füllen. Sie können auch manuell ein Gerät einfügen.

Ihr Netzwerk durchsuchen

Zum Durchsuchen des Netzwerks wählen Sie die Menübefehle "Vorgänge>Netzwerk durchsuchen>Gesamtes Netzwerk durchsuchen". Alternativ können Sie in der Symbolleiste auf die Durchsuchen-Schaltfläche [image] klicken und im Dropdown-Menü die Option "Gesamtes Netzwerk durchsuchen" auswählen.

Hinweis

Das SIMATIC Automation Tool ist ein Offline-Tool

Das SIMATIC Automation Tool führt keine ständige Aktualisierung der Gerätedaten durch. Das SIMATIC Automation Tool zeigt Gerätedaten für den Zeitpunkt an, an dem das Kommunikationsnetzwerk durchsucht oder aktualisiert wurde oder Geräte eingefügt wurden. Gerätedaten können beispielsweise im TIA Portal oder im Webserver seit der letzten Durchsuchung geändert worden sein. Bevor Vorgänge in Geräten ausgeführt werden, ist das Netzwerk zu durchsuchen oder die Geräte, in denen diese Vorgänge durchgeführt werden sollen, zu aktualisieren.

Wenn Sie das Netzwerk durchsuchen, speichert das SIMATIC Automation Tool die Gerätedaten der letzten Durchsuchung, bis es die Gerätedaten mit den Ergebnissen der neuen Durchsuchung aktualisiert. Wenn eine Durchsuchung für ein Gerät fehlschlägt, zeigt das Gerät die Daten der vorherigen Durchsuchung an, und in das Ereignisprotokoll wird ein Fehler eingetragen.
Hinweis

Geräte hinter einem NAT-Router zur Netzwerkadressübersetzung kann das SIMATIC Automation Tool nicht erkennen.

Das SIMATIC Automation Tool erkennt Geräte bei der Durchsuchung eines Netzwerks an ihrer MAC-Adresse und IP-Adresse. Da NAT-Router keine DCP-Befehle weiterleiten, können Geräte hinter einem NAT-Router bei einer Netzwerkdurchsuchung nicht erkannt werden.

Konventionen für die Gerätetabelle

Zeilensymbole helfen Ihnen beim Identifizieren der Zeilen in der Gerätetabelle:

Gerät ist unbekannt oder nicht voll unterstützt. Das SIMATIC Automation Tool zeigt die Gerätedaten in grauem Text an.

Fehlersicheres Gerät ist unbekannt oder wird nicht vollständig unterstützt. Das SIMATIC Automation Tool zeigt die Gerätedaten in grauem Text an.

PROFINET-Gerät

Fehlersicheres PROFINET-Gerät

PROFINET HMI-Gerät

Fehlersicheres PROFINET HMI-Gerät

PROFINET-Gerät der dezentralen Peripherie

Fehlersicheres PROFINET-Gerät der dezentralen Peripherie

Ordner mit PROFINET-Controller-Geräten

Ordner mit PROFIBUS-Mastergeräten

Ordner mit PROFINET AS-i-Mastergeräten

Ordner mit Datenprotokoll- oder Rezeptdaten

Ordner mit lokaler Peripherie oder dezentralen Peripheriemodulen

Datenprotokolldaten

Rezeptdaten

Doppelte IP-Adressen und PROFINET-Stationsnamen werden in rotem Text angezeigt.

Identitätsproblem bei Standardgerät

Identitätsproblem bei einem fehlersicheren Gerät

Hinweis

TIA Portal Online-Verbindungen mit Geräten

Wenn ein Gerät eine Online-Verbindung in TIA Portal unterhält, ist es möglich, dass das SIMATIC Automation Tool die Daten des Geräts nicht lesen kann. Die Gerätetabelle zeigt das Symbol für ein unbekanntes Gerät an und meldet einen Fehler im Ereignisprotokoll. Der Fehler besagt, dass das SIMATIC Automation Tool einen Fehler erkannt hat und das Gerät nicht identifizieren konnte.

Um das Gerät lesen zu können, gehen Sie in TIA Portal offline.

Klicken Sie auf das Kontrollkästchen neben einem Gerät, um es auszuwählen. Das SIMATIC Automation Tool zeigt den Gerätetext in Schwarz für Geräte an, die nicht ausgewählt wurden, und in schwarzer Fettschrift für Geräte, die ausgewählt sind.

In Zellen mit hellgrauem Hintergrund können Sie Text eingeben. In Zellen mit dunkelgrauem Hintergrund können Sie keinen Text eingeben. Eine dunkelgraue Zelle zeigt an, dass das SIMATIC Automation Tool den Vorgang für diesen Gerätetyp bzw. diese Firmware-Version nicht unterstützt.

Erläuterungen zur Gerätetabelle

Hinweis

Durch erneutes Durchsuchen des Netzwerks können Identitätsprobleme von Geräten beseitigt werden

Ein Identitätsproblem mit einem Gerät kann beispielsweise auftreten, wenn das TIA Portal das Geräteprogramm oder die Gerätekonfiguration seit dem letzten Durchsuchen des Netzwerks durch das SIMATIC Automation Tool geändert hat. Bei einem Gerät mit einem Identitätsproblem schlagen alle Vorgänge und Aktualisierungsbefehle fehl. Sie müssen das Netzwerk durchsuchen, um das Identitätsproblem des Geräts zu beheben.

Fehlersichere Geräte

Wenn die Identität eines Geräts oder der Status des Sicherheitsprogramms mit dem SIMATIC Automation Tool geändert wird, führt das Tool die Änderungen ohne eine erneute Durchsuchung des Netzwerks durch. Wird beispielsweise eine neue Firmware-Version mit dem SIMATIC Automation Tool geladen, aktualisiert das SIMATIC Automation Tool die Gerätevariablen auf die neuen Werte. Das SIMATIC Automation Tool ist ein bewährtes Werkzeug für die Arbeit an sicherheitsgerichteten Geräten und kann Änderungen des Sicherheitsstatus bearbeiten.

Wenn Sie in Ihrem Netzwerk eine fehlersichere CPU haben, in die jedoch kein Sicherheitsprogramm geladen ist, werden die Zellen der Gerätezeile grau angezeigt:

Haben Sie ein Sicherheitsprogramm in eine fehlersichere CPU geladen, werden die Informationsfelder zum Gerät gelb angezeigt:

Die folgenden Eingabefelder für fehlersichere CPUs mit einem Sicherheitsprogramm werden zunächst grau angezeigt. Sobald in diesen Feldern gültige Werte eingegeben sind, werden Sie vom SIMATIC Automation Tool in Gelb angezeigt:

  • Passwort in CPU

  • Ordner Programmaktualisierung

  • Passwort in Programmdatei

  • Sicherungsdatei

Beispiel:

Über CPUs und IP-Adress-Router verbundene Geräte

Nachdem im Register "IP-Adresse" der Gerätetabelle gültige IP-Adressen eingetragen wurden, können mit dem Menübefehl "Vorgänge>Aktualisieren>IP-Adresse" die Adresszuweisungen an direkt verbundene ausgewählte Geräte übertragen werden. Sie können alternativ auch auf die Schaltfläche Aktualisieren klicken [image] und den Befehl "IP-Adresse" im Dropdown-Menü der Schaltfläche auswählen.

Wenn unterstützte Netzwerkgeräte gültige IP-Adressen haben, werden beim Durchsuchen des Netzwerks Geräte hinter CPUs und IP-Adress-Routern angezeigt.

Direkt verbundene Geräte (einschließlich Verbindung per Ethernet-Switch)

Ein direkt verbundenes Gerät kann alle MAC-Adressfunktionen bei nicht konfigurierter oder konfigurierter IP-Adresse verwenden. Bei konfigurierter IP-Adresse kann ein direkt verbundenes Gerät alle IP-Adressfunktionen verwenden.

Eine anfängliche Durchsuchung zeigt die Geräte im Netzwerk:

Auswirkung einer Durchsuchung des Netzwerks auf die Gerätetabelle

Falls bereits eine MAC-Adresse in der Tabelle existiert, werden bei der Netzwerkdurchsuchung die Felder "IP-Adresse", "Subnetz" und "Gateway" für diese Zeile der Gerätetabelle aktualisiert. Die Daten in den restlichen Feldern bleiben unverändert.

Ist eine MAC-Adresse neu, legt das SIMATIC Automation Tool eine neue Zeile mit der MAC-Adresse, der IP-Adresse, dem Subnetz und dem Gateway an. Alle restlichen Felder sind leer.

Erweitern von Gerätezeilen zum Anzeigen lokaler Module, dezentraler Peripheriegeräte und CPU-Dateien (Rezepte und Datenprotokolle)

Klicken Sie zum Erweitern einer Zeile in der Gerätetabelle auf das Symbol [image]. Klicken Sie zum Reduzieren einer Zeile in der Gerätetabelle auf das Symbol [image]. Verwenden Sie das Rechtsklick-Menü oder das Menü "Bearbeiten" zum Erweitern/Reduzieren aller Ebenen.

Passwort-Identifikation

Ist das Gerät durch ein Passwort einer beliebigen Schutzstufe geschützt, wird das Passwortfeld vom SIMATIC Automation Tool aktiviert.

PROFINET-Peripherie

PROFINET-Peripheriegeräte können zweimal in der Gerätetabelle erscheinen. Das Gerät wird einmal in einer Zeile im oberen Bereich angezeigt, wo durch eine direkte Verbindung alle unterstützten Vorgänge im SIMATIC Automation Tool möglich sind. Dann wird das Gerät auch in einer Zeile weiter unten nach einer CPU (mit gültiger IP-Adresse und Hardwarekonfiguration) aufgeführt, wo aufgrund der indirekten Toolverbindung nur die Firmware-Aktualisierung möglich ist. Die zwei Zeilen in der Gerätetabelle sind darauf zurückzuführen, dass es im Ethernet-Netzwerk zwei mögliche Verbindungswege gibt.

In der Gerätetabelle unten zeigt das SIMATIC Automation Tool das Gerät IM 155‑6 PN HF zweimal an.

  • In einer Zeile im oberen Bereich als "im 155-6 pn hf", wo alle unterstützten Vorgänge verfügbar sind

  • In einer Zeile im unteren Bereich als "IM 155-6 PN HF" in der verteilten Peripherie von PLC_1, wo nur der Aktualisierungsvorgang verfügbar ist

Indirekt verbundene Geräte

Geräte auf den unteren Ebenen repräsentieren Geräte und CPU-Datendateien, die über eine direkt verbundene CPU indirekt mit dem SIMATIC Automation Tool verbunden sind. Eine gültige IP-Adresse und eine gültige Gerätekonfiguration sind Grundvoraussetzung in einer CPU, bevor über diese CPU verbundene Geräte in der Gerätetabelle sichtbar werden.

Geräte auf den unteren Ebenen können dezentrale Peripheriegeräte (PROFINET- und PROFIBUS-Geräte) repräsentieren. Eine IP-Konfiguration ist für ein dezentrales Peripheriemodul erforderlich, bevor die dezentralen Peripheriegeräte in der Gerätestruktur sichtbar werden.

CPUs für Software-Steuerungen

Damit das SIMATIC Automation Tool mit CPUs für Software-Steuerungen kommunizieren kann, muss Ihr Programmiergerät über die Ethernet-Schnittstelle mit der Software-Steuerung verbunden sein. Im typischen Fall handelt es sich bei dieser Schnittstelle um X1 oder X2. Je nach Gerät kann die Schnittstelle als PROFINET (LAN) oder PN/IE (LAN) ausgeführt sein. Das SIMATIC Automation Tool kommuniziert mit Software-Steuerungen über X2 und mit Open Controllers über X1. Der Gerätekatalog führt die vom SIMATIC Automation Tool unterstützten CPUs für Software-Steuerungen und die unterstützten Gerätevorgänge auf.

Daten der Gerätetabelle aktualisieren

Das SIMATIC Automation Tool aktualisiert Daten in der Gerätetabelle in den folgenden Fällen:

  • Bei einer Durchsuchung des Netzwerks

  • Nach der Ausführung eines Vorgangs

  • Wenn ein oder mehrere Geräte aktualisiert wurden

Zum Aktualisieren von Daten der Gerätetabelle gehen Sie auf eine der folgenden Arten vor:

  • Wählen Sie "Gesamtes Netzwerk durchsuchen" entweder im Dropdown-Menü der Schaltfläche [image] in der Symbolleiste oder Menü "Vorgänge > Netzwerk durchsuchen", um alle Geräte zu aktualisieren.

  • Wählen Sie einzelne Geräte aus und klicken Sie dann auf "Status aller ausgewählten Geräte aktualisieren" entweder im Dropdown-Menü der Schaltfläche [image] in der Symbolleiste oder Menü "Vorgänge > Netzwerk durchsuchen".

  • Wählen Sie Menübefehl Bearbeiten > Aktualisieren oder klicken Sie mit der rechten Maustaste auf eine Gerätezeile und wählen Sie dann im Kontextmenü die Option Aktualisieren. Wählen Sie dann eine der folgenden Optionen des Menübefehls Aktualisieren:

    • Gerät

    • Alle ausgewählten Geräte F5

    • Alle Geräte

  • Drücken Sie Taste F5, um "Alle ausgewählten Geräte" zu aktualisieren

Das SIMATIC Automation Tool aktualisiert die Gerätedaten aus den Geräten und behält alle Benutzereingaben bei.

Werden Geräte aktualisiert, die nicht mehr im Netzwerk vorhanden sind, zeigt das SIMATIC Automation Tool die Daten in der Gerätezeile kursiv an.

Hinweis

Aktualisieren ausgewählter Geräte

Sie können nur die ausgewählten Geräte der obersten Ebene aktualisieren. Wenn ein Gerät einem anderen Gerät in der Gerätetabelle untergeordnet ist, können Sie nicht das untergeordnete Gerät allein aktualisieren. Sie müssen das Gerät der obersten Ebene auswählen, um den Status untergeordneter Geräte zu aktualisieren. Wenn Sie zum Beispiel ein einer CPU untergeordnetes Schnittstellenmodul (IM) haben, können Sie nicht das Schnittstellenmodul allein aktualisieren. Um den Status des Schnittstellenmoduls zu aktualisieren, wählen Sie die CPU aus und aktualisieren Sie anschließend den Status des ausgewählten Geräts. Das SIMATIC Automation Tool aktualisiert den Status der CPU und aller Module, die ihr untergeordnet sind.

Fehler bei der Netzwerkdurchsuchung

Wenn das SIMATIC Automation Tool bei einer Durchsuchung des Netzwerks einen Fehler bei der Kommunikation mit einem Gerät erkennt, fügt das Tool einen Eintrag in das Ereignisprotokoll ein. Das SIMATIC Automation Tool zeigt bei der Durchsuchung erkannte Fehler im Ereignisprotokoll in der Reihenfolge ihres Auftretens an.


Einfügen eines Geräts

Einfügen eines Geräts

Sie können ein Gerät in die Gerätetabelle einfügen. Nur Geräte mit einer eindeutigen MAC-Adresse und einer eindeutigen IP-Adresse können in die Gerätetabelle eingefügt werden.

Um ein Gerät einzufügen, gehen Sie folgendermaßen vor:

  1. Wählen Sie im Menü "Bearbeiten" oder durch Rechtsklick im Kontextmenü der Gerätetabelle den Befehl "Einfügen > Gerät".

  2. Im Dialog "Gerät einfügen" geben Sie entweder eine IP-Adresse oder eine MAC-Adresse für das Gerät ein. Die eingegebene Adresse darf nicht zu einem vorhandenen Gerät gehören. Verwenden Sie für eine MAC-Adresse einen Doppelpunkt (:) als Trennzeichen und keinen Bindestrich (-).

Das SIMATIC Automation Tool lehnt jeden Versuch ab, ein Gerät ohne eindeutige Adresse oder gültige IP-Adresse einzufügen.

Ist eine eindeutige IP-Adresse bzw. eine eindeutige MAC-Adresse eingegeben, versucht das SIMATIC Automation Tool, mit dieser Adresse zu kommunizieren. Ist die Kommunikation erfolgreich, fügt das SIMATIC Automation Tool das Gerät in die Gerätetabelle ein. Ist die Kommunikation nicht erfolgreich, teilt das SIMATIC Automation Tool dem Benutzer mit, dass das Gerät im Netzwerk nicht vorhanden ist.

Befindet sich das Gerät hinter einem Router, zeigt das SIMATIC Automation Tool den Gerätename blau an.

Hinweis

Geräte hinter einem NAT-Router zur Netzwerkadressübersetzung kann das SIMATIC Automation Tool nicht einfügen.

Das SIMATIC Automation Tool erkennt Geräte bei der Durchsuchung eines Netzwerks an ihrer MAC-Adresse und IP-Adresse. Weil NAT-Router keine DCP-Befehle weiterleiten, können Sie kein Gerät hinter einem NAT-Router einfügen.


Aktualisieren von IP-, Subnetz- und Gateway-Adressen

Festlegen der IP-Adresse für unterstützte Geräte Festlegen der IP-Adresse für nicht unterstützte Geräte IP-Adresse nach Aus- und Wiedereinschalten
Start Zurück Weiter

Aktualisieren von IP-, Subnetz- und Gateway-Adressen

Damit eine IP-Adresse eingestellt werden kann, die nach dem Aus- und Wiedereinschalten erhalten bleibt, muss in der Gerätekonfiguration im STEP 7-Projekt das Einstellen der IP-Adresse direkt am Gerät erlaubt sein. Wenn das STEP 7-Projekt im Gerät diese Einstellung nicht erlaubt, kann eine IP-Adresse mit dem SIMATIC Automation Tool eingestellt werden, sie ist jedoch nur temporär und geht beim nächsten Ausschalten verloren.

Festlegen der IP-Adresse für unterstützte Geräte

Um die IP-Adresse eines Geräts einzustellen, gehen Sie wie folgt vor:

  1. Klicken Sie auf das Register "IP-Adresse festlegen".

  2. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  3. Geben Sie die Werte in den Spalten "Neue IP-Adresse", "Neues Subnetz" und "Neues Gateway" ein. Beachten Sie, dass Sie keine Kommunikationsschnittstelle wie "X1" oder "X2" eingeben, wenn Sie die neue IP-Adresse eingeben.

    Wird eine ungültige Syntax eingegeben, zeigt das SIMATIC Automation Tool den Text im Feld rot an. Beheben Sie ggf. vorhandene Fehler.

  4. Wählen Sie die Option Aktualisierung im Menü Vorgänge oder klicken Sie in der Symbolleiste auf [image] Aktualisierung und wählen Sie im Dropdown-Menü "IP-Adresse festlegen".

Durch die Aktualisierung werden die IP-, Subnetz- und Gateway-Adressen in den ausgewählten Geräten eingestellt.

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Doppelte IP-Adressen

Haben zwei oder mehr Geräte die gleiche IP-Adresse, erscheinen die Adressen in rotem Text wie in der folgenden Abbildung.

Sie können Geräte mit doppelten IP-Adressen auswählen, die IP-Adressen aktualisieren und das Problem im Netzwerk damit beheben. Für Geräte mit doppelten IP-Adressen sind nur die folgenden Vorgänge möglich:

  • Löschen

  • Festlegen der IP-Adresse

  • Festlegen des PROFINET-Namens

  • Geräte identifizieren

Für Geräte mit doppelten IP-Adressen sind keine weiteren Gerätevorgänge möglich.

Festlegen der IP-Adresse für nicht unterstützte Geräte

Auf MAC-Adressen basierende Vorgänge verwenden das DCP (Discovery and Configuration Protocol). DCP ist ein Ethernet-Standard. Das SIMATIC Automation Tool kann die auf DCP-MAC-Adressen basierenden Vorgänge "IP-Adresse aktualisieren" für alle direkt angeschlossenen Netzwerkgeräte ausführen (CPUs, HMIs, dezentrale Peripherie und andere Geräte).

Wählen Sie die Zeile für das nicht unterstützte Gerät, geben Sie in der jeweiligen Spalte die neuen Daten ein und aktualisieren Sie die IP-Adresse für das Gerät so, wie Sie es für unterstützte Geräte tun würden.

Nicht unterstützte Geräte nehmen auf der Hardware-Konfiguration des Geräts basierende Änderungen möglicherweise nicht an.

Standardmäßig zeigt das SIMATIC Automation Tool nicht unterstützte Geräte an. Sie können diese Option unter Allgemeine Einstellungen deaktivieren.

Hinweis

Das SIMATIC Automation Tool kann einige der Informationen von Geräten, die hinter einem IP-Router angeschlossen sind, nicht erfassen, weil DCP-Befehle nicht routingfähig sind.

Zum Beispiel arbeitet das SIMATIC Automation Tool mit DCP, um die Adresse der Standard-Gateways von Geräten abzurufen. DCP ist kein routingfähiges Protokoll. Das SIMATIC Automation Tool kann daher keine Informationen von hinter einem Router angeschlossenen Geräten lesen. In diesem Fall sind die zugehörigen Felder in der Gerätetabelle leer.

IP-Adresse nach Aus- und Wiedereinschalten

Die Gerätekonfiguration des STEP 7-Projekts bestimmt, wie das Gerät die IP-Adresse nutzt, die mit dem SIMATIC Automation Tool eingestellt wird. Wird im SIMATIC Automation Tool eine IP-Adresse für ein Gerät eingestellt, hat das nächste Aus- und Wiedereinschalten bei diesem Gerät folgende Auswirkungen:

Einstellung STEP 7-Gerätekonfiguration | IP-Adresse nach Aus- und Wiedereinschalten
IP-Adresse wird direkt am Gerät festgelegt (oder ähnlich) | Die IP-Adresse, die Sie im SIMATIC Automation Tool einstellen, ist die IP-Adresse des Geräts
IP-Adresse im Projekt einstellen (oder ähnlich) | Die IP-Adresse in der Gerätekonfiguration des STEP 7-Projekts ist die IP-Adresse


Aktualisieren von PROFINET-Gerätenamen

Einstellen des PROFINET-Namens Festlegen des PROFINET-Namens für nicht unterstützte Geräte
Start Zurück Weiter

Aktualisieren von PROFINET-Gerätenamen

Um einen PROFINET-Gerätenamen zu ändern, beachten Sie, dass die Gerätekonfiguration im heruntergeladenen TIA Portal-Projekt diese Änderung unterstützen muss.

Gültige PROFINET-Namen richten sich nach den üblichen DNS-Namenskonventionen (Domain Name System). Wenn Sie einen ungültigen Namen eingeben, konvertiert das SIMATIC Automation Tool ihn in einen gültigen PROFINET-Namen. Sie sehen den konvertierten Namen in der Spalte "Konvertierter PROFINET-Name".

PROFINET-Namensregeln

Die maximale Anzahl von Zeichen für den Gerätenamen beträgt 63. Zu den gültigen Zeichen zählen die Kleinbuchstaben "a" bis "z", die Ziffern 0 bis 9, das Bindestrichzeichen (Minuszeichen) und das Punktzeichen.

Ungültige Namen

  • Der Name darf nicht das Format n.n.n.n haben, wobei n ein Wert zwischen 0 und 999 ist.

  • Sie dürfen den Namen nicht mit der Zeichenkette "port-nnn" oder der Zeichenkette "port-nnnnnnnn" beginnen, wobei n eine Ziffer zwischen 0 und 9 ist. Beispielsweise sind "port-123" und "port-123-45678" unzulässige Namen.

  • Ein Name darf nicht mit einem Bindestrich "-" oder mit einem Punkt "." beginnen oder enden.

Einstellen des PROFINET-Namens

Zum Einstellen des PROFINET-Namen für ein oder mehrere Geräte führen Sie die folgenden Schritte aus:

  1. Klicken Sie auf Register "PROFINET-Namen festlegen".

  2. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  3. Geben Sie in der Spalte "Neuer PROFINET-Name" einen neuen PROFINET-Namen ein.

  4. Wählen Sie die Option Aktualisierung im Menü Vorgänge oder klicken Sie auf die Schaltfläche Aktualisierung in der Symbolleiste [image] und wählen Sie "PROFINET-Name" im Dropdown-Menü der Schaltfläche.

Durch die Aktualisierung werden neue PROFINET-Namen in den ausgewählten Geräten eingestellt. Wenn Sie nach den Regeln für PROFINET-Namen einen ungültigen PROFINET-Namen eingeben, ändert das SIMATIC Automation Tool den Namen in einen gültigen Namen. Die Spalte "Konvertierter PROFINET-Name" zeigt den konvertierten Namen an.

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Doppelte PROFINET-Namen

Wenn zwei oder mehr Geräte doppelte PROFINET-Namen haben, werden diese in roter Schrift angezeigt. Das SIMATIC Automation Tool unterstützt die volle Funktionalität dieser Geräte und zeigt alle anderen Informationen an.

Festlegen des PROFINET-Namens für nicht unterstützte Geräte

Auf MAC-Adressen basierende Vorgänge verwenden das DCP (Discovery and Configuration Protocol). DCP ist ein Ethernet-Standard. Das SIMATIC Automation Tool kann die auf DCP-MAC-Adressen basierenden Vorgänge Gesamtes Netzwerk durchsuchen, Identifizieren, IP-Adresse aktualisieren und PROFINET-Name aktualisieren für alle direkt verbundenen Netzwerkgeräte ausführen (CPUs, HMIs, dezentrale Peripherie und andere Geräte).

Wählen Sie die Zeile für das nicht unterstützte Gerät, geben Sie in der jeweiligen Spalte die neuen Daten ein und aktualisieren Sie den PROFINET-Namen für das Gerät so, wie Sie es für unterstützte Geräte tun würden.

Nicht unterstützte Geräte nehmen auf der Hardware-Konfiguration des Geräts basierende Änderungen möglicherweise nicht an.

Standardmäßig zeigt das SIMATIC Automation Tool nicht unterstützte Geräte an. Sie können diese Option unter Allgemeine Einstellungen deaktivieren.


Versetzen von CPUs in die Betriebsart RUN oder STOP

CPUs in die Betriebsart RUN oder STOP versetzen

Versetzen von CPUs in die Betriebsart RUN oder STOP

CPUs in die Betriebsart RUN oder STOP versetzen

Um die Betriebsart eines Geräts zu ändern, ist wie folgt vorzugehen:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Für jede ausgewählte CPU ist ggf. ein Passwort in der Spalte "Passwort in CPU" des aktuell geöffneten Registers einzugeben.

  3. Die Betriebsart entweder auf RUN oder STOP einstellen:

    • Wählen Sie im Menü "Vorgänge" Option RUN oder klicken Sie in der Symbolleiste auf die Schaltfläche RUN [image]. In der CPU muss ein gültiges Programm vorhanden sein, bevor ein Wechsel in die Betriebsart RUN möglich ist.

    • Wählen Sie im Menü "Vorgänge" Option STOP oder klicken Sie in der Symbolleiste auf die Schaltfläche STOP [image].

Das SIMATIC Automation Tool versetzt die ausgewählten CPUs in die Betriebsart RUN oder STOP.

Die Spalten "Modus" und "Betriebszustand" in der Gerätetabelle geben den aktuellen CPU-Status an.

  • Gelb: Betriebsart STOP

  • Grün: Betriebsart RUN

  • Rot: CPU-Fehler

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.


Identifizieren von Geräten

Ein Gerät durch Blinken lassen von LEDs oder LEDs in HMI-Bildschirmen lokalisieren Nicht unterstützte Geräte durch Blinkenlassen einer LED oder eines HMI-Bildes lokalisieren
Start Zurück Weiter

Identifizieren von Geräten

Bei Geräten der obersten Ebene der Gerätetabelle können Sie mit dem Vorgang "Identifizieren" vorhandene Geräte physisch im Netzwerk lokalisieren.

Ein Gerät durch Blinken lassen von LEDs oder LEDs in HMI-Bildschirmen lokalisieren

Sie können den Vorgang "Identifizieren" in der Betriebsart RUN und STOP verwenden. Zum Identifizieren von Geräten gehen Sie wie folgt vor:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Wählen Sie Menübefehl "Vorgänge > Identifizieren" oder klicken Sie in der Symbolleiste auf die Schaltfläche [image] zur Identifizierung ausgewählter Geräte.

Daraufhin blinken die LEDs ausgewählter CPU-Geräte, SCALANCE-Geräte und anderer Geräte und zeigen damit deren Standort an. Bei HMI-Geräten blinkt der Bildschirm auf.

Der Blinkvorgang dauert so lange, bis Sie auf die Schaltfläche Schließen klicken.

Nicht unterstützte Geräte durch Blinkenlassen einer LED oder eines HMI-Bildes lokalisieren

Auf MAC-Adressen basierende Vorgänge verwenden das DCP (Discovery and Configuration Protocol). DCP ist ein Ethernet-Standard. Das SIMATIC Automation Tool kann die auf DCP-MAC-Adressen basierten Vorgänge Gesamtes Netzwerk durchsuchen, Identifizieren, IP-Adresse aktualisieren und PROFINET-Name aktualisieren für alle direkt verbundenen Netzwerkgeräte ausführen (unterstützte PROFINET-Geräte, nicht unterstützte PROFINET-Geräte und nicht unterstützte Siemens-fremde Ethernet-Geräte).

Um ein nicht unterstütztes Gerät zu identifizieren, wählen Sie das Gerät aus und führen den Vorgang "Identifizieren" genauso aus wie für ein unterstütztes Gerät.

Nicht unterstützte Geräte lassen basierend auf der Hardware-Konfiguration des Geräts ihre LEDs möglicherweise nicht blinken.

Standardmäßig zeigt das SIMATIC Automation Tool nicht unterstützte Geräte an. Sie können diese Option unter Allgemeine Einstellungen deaktivieren.


Aktualisieren von Geräteprogrammen über das SIMATIC Automation Tool

Beispiel: Ein CPU-Programm für die Nutzung mit dem SIMATIC Automation Tool vorbereiten Beispiel: HMI-Betriebssystem und -Runtime-Software für die Verwendung mit dem SIMATIC Automation Tool vorbereiten Aktualisieren von CPU-Programmen oder des HMI-Betriebssystems und der Runtime-Software Programmvalidierung Passwortstatus nach einer Programmaktualisierung F-Signaturvalidierung Regeln für die Aktualisierung von CPU-Programmen Auswirkung einer Programmaktualisierung auf die IP-Adresse Beispiel: Programmaktualisierung
Start Zurück Weiter

Aktualisieren von Geräteprogrammen über das SIMATIC Automation Tool

Bevor Sie ein Programm mit dem SIMATIC Automation Tool in eine CPU übertragen können, benötigen Sie Zugriff auf das Programm auf einem der folgenden Medien:

  • SIMATIC SD Memory Card

  • USB-FlashDrive

  • Festplatte Ihres Programmiergeräts

Beispiel: Ein CPU-Programm für die Nutzung mit dem SIMATIC Automation Tool vorbereiten

In diesem Beispiel wird eine SIMATIC SD Memory Card für die Übertragung verwendet. Sie können auch einen USB-FlashDrive oder einen Windows-Ordner auf Ihrem Programmiergerät verwenden.

Um ein CPU-Projekt in STEP 7 auf eine SIMATIC Memory Card zu übertragen, gehen Sie wie folgt vor:

  1. Stecken Sie eine SIMATIC Memory Card in das Lesegerät Ihres Programmiergeräts

  2. Wählen Sie in STEP 7 die CPU in der Projektnavigation

  3. Wählen Sie Menübefehl "Projekt > Kartenleser/USB-Speicher > Auf Memory Card schreiben":

  4. Wählen Sie Ihre Memory Card im Dialog:

STEP 7 speichert auf Ihrer SIMATIC Memory Card einen SIMATIC.S7S-Ordner mit Ihrem CPU-Projekt. Sie können das STEP 7-Projekt auch in die Memory Card kopieren, indem Sie das Projekt in der Projektnavigation auf die Memory Card ziehen.

Weitere Informationen finden Sie im STEP 7 Informationssystem (Online-Hilfe).

Nachdem die Programmdaten von STEP 7 auf ein Speichergerät übertragen wurden, können Sie den Windows Datei-Explorer zum Übertragen des Programms in den vom SIMATIC Automation Tool verwendeten Ordner aufrufen.

Ordner "SIMATIC.S7S" für jedes CPU-Programm kopieren

Befolgen Sie diese Schritte, um dem SIMATIC Automation Tool ein CPU-Programm zugänglich zu machen

  1. Legen Sie Unterordner unter dem Ordner Programmaktualisierung an. Erstellen Sie für jedes Programm einen Ordner und geben Sie einen Ordnernamen ein, der das Programm identifiziert. Die von Ihnen erzeugten Ordnernamen werden in der Klappliste des SIMATIC Automation Tool angezeigt.

  2. Verwenden Sie den Windows Datei-Explorer, um den Ordner "SIMATIC.S7S" (einschließlich aller Unterordner und Dateien) in jeden Unterordner für jedes Programm zu kopieren. Ein TIA Portal-Programm (ein Ordner "SIMATIC.S7S") kann in einem ZIP-Dateiarchiv gepackt und in Ihrem Unterordner entpackt werden. Achten Sie darauf, Rezepte in einem separaten Rezeptvorgang zu aktualisieren.

Siehe Abschnitt "Beispiel für die Aktualisierung eines CPU-Programms" an anderer Stelle in diesem Kapitel.

Hinweis

STEP 7-Programmdaten

Die Programmdaten sind geschützt. Einzelheiten wie Projektname oder Ziel-CPU eines STEP 7-Programms lassen sich aus den in einem SIMATIC.S7S-Ordner abgelegten Daten nicht auslesen. Sie können den SIMATIC.S7S-Ordner eines Programms nicht über den SIMATIC.S7S-Ordner eines anderen Programms identifizieren.
Sie müssen im Programmaktualisierungsordner des SIMATIC Automation Tool Unterordner zur Identifizierung der Programmfunktion oder Ziel-CPU anlegen und benennen. Kopieren Sie den SIMATIC.S7S-Ordner eines Programms in den von Ihnen benannten Unterordner. Die von Ihnen erstellten Unterordnernamen werden in der Klappliste in der Spalte "Programm" des SIMATIC Automation Tool angezeigt und enthalten den Pfad zum korrekten SIMATIC.S7S-Ordner.

Beispiel: HMI-Betriebssystem und -Runtime-Software für die Verwendung mit dem SIMATIC Automation Tool vorbereiten

In diesem Beispiel wird eine SIMATIC SD Memory Card für die Übertragung verwendet. Sie können auch einen USB-FlashDrive oder einen Windows-Ordner auf Ihrem Programmiergerät verwenden.

HMI-Geräte ab Version 14 unterstützen die Speicherung des Betriebssystems und der Runtime-Software von STEP 7.

Um das Betriebssystem und die Runtime-Dateien für ein HMI-Gerät auf eine SIMATIC Memory Card zu kopieren, gehen Sie wie folgt vor:

  1. Stecken Sie eine SIMATIC Memory Card in das Lesegerät Ihres Programmiergeräts.

  2. Erweitern Sie in der Projektnavigation Option "Kartenleser/USB-Speicher", damit das Laufwerk für Ihren Kartenleser angezeigt wird.

  3. Wählen Sie Ihr HMI-Gerät in der Projektnavigation und ziehen Sie es auf das Laufwerk Ihres Kartenlesers.

STEP 7 speichert auf Ihrer SIMATIC Memory Card einen SIMATIC.HMI-Ordner mit Ihrer HMI-Runtime und Ihrem HMI-Betriebssystem. HMI-Aktualisierungen umfassen das Betriebssystem und Runtime-Daten. Eine Teilaktualisierung können Sie nicht auswählen.

Nachdem das TIA Portal den SIMATIC.HMI-Ordner auf ein Speichergerät übertragen hat, machen Sie den SIMATIC.HMI-Ordner im Windows Datei-Explorer für das SIMATIC Automation Tool zugänglich:

  1. Erstellen Sie im Ordner Programmaktualisierung einen Unterordner für das HMI-Programm.

  2. Kopieren Sie den SIMATIC.HMI-Ordner in den Unterordner.

Wenn Sie den Firmware-Anteil (Betriebssystem) des SIMATIC.HMI-Ordners für die Aktualisierung der Firmware eines HMI-Geräts verwenden möchten, gehen Sie folgendermaßen vor:

  1. Navigieren Sie durch den Ordner "Firmware" des SIMATIC.HMI-Ordners, bis Sie eine Datei mit der Erweiterung *.fwf finden.

  2. Kopieren Sie die FWF-Datei in den Ordner Firmware-Aktualisierung.

Aktualisieren von CPU-Programmen oder des HMI-Betriebssystems und der Runtime-Software

Wenn Sie für die Kommunikation eine Linientopologie nutzen und in den Kommunikationseinstellungen Multithreading aktiviert ist, kann es bei diesem Vorgang zu einer Unterbrechung der Kommunikation kommen.

Hinweis

Fehlersichere Geräte

Wenn die fehlersichere CPU geschützt ist, muss in der Spalte "Passwort in CPU" das Safety-Passwort für F-CPU eingegeben werden, um das Programm in einem fehlersicheren Gerät zu aktualisieren.

Sie müssen dann eine zusätzliche Aufforderung für Programmaktualisierungen in F-CPUs bestätigen und unter den folgenden Bedingungen Ihr Gerät erneut auswählen:

  • Sie aktualisieren ein Sicherheitsprogramm mit einem anderen Sicherheitsprogramm

  • Sie aktualisieren ein Sicherheitsprogramm mit einem Standardprogramm

  • Sie laden ein Sicherheitsprogramm zum ersten Mal

  • Sie aktualisieren ein Standardprogramm, das das CPU-Passwort für Schutzstufe "Vollzugriff einschl. Fail-safe (kein Schutz)" erfordert

Das SIMATIC Automation Tool platziert Anforderungen für Programmaktualisierungen für fehlersichere Geräte in der Warteschlange für sicherheitsrelevante F-CPU-Vorgänge. Das SIMATIC Automation Tool verwendet für die Warteschlange für sicherheitsrelevante Vorgänge nur die zeitliche Single-Thread-Abarbeitung.

Das Zielgerät für ein Sicherheitsprogramm muss eine fehlersichere CPU sein.

Warnung

Vergewissern Sie sich vor dem Aktualisieren des Programms, dass das Gerät aktuell keinen Prozess ausführt.

Durch das Installieren eines neuen Programms geht die CPU in die Betriebsart STOP, was sich auf den Betrieb eines Online-Prozesses oder einer Maschine auswirken kann. Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.
Hinweis

Übertragungseinstellungen für ein HMI-Gerät (SIMATIC Panel)

Zum Kommunizieren mit einer HMI müssen Sie die Übertragungseinstellungen am HMI-Gerät auf PN/IE oder Ethernet setzen. Die Kommunikationseinstellungen für den HMI-Übertragungskanal müssen Sie auf die gleiche Einstellung setzen.

Nach dem Speichern von Programmen im Ordner Programmaktualisierung können mit dem SIMATIC Automation Tool neue Programme in ein oder mehrere Geräte geladen werden. Für eine Programmaktualisierung gehen Sie folgendermaßen vor:

  1. Klicken Sie auf das Register "Programmaktualisierung".

  2. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  3. Verwenden Sie für jedes ausgewählte Gerät die Klappliste in der Spalte "Ordner Programmaktualisierung", um einen Ordnernamen auszuwählen. Die Klappliste zeigt die Ordner an, die Sie im Programmaktualisierungspfad erstellt haben.

    Sie können auch über die Durchsuchen-Schaltfläche [image] zu dem Ordner navigieren, in dem das Programm auf Ihrem Programmiergerät gespeichert ist. Wenn Sie ein Programm auswählen, wird es vom SIMATIC Automation Tool zur Klappliste hinzugefügt. Wenn die ausgewählte Datei den gleichen Namen hat wie eine der bereits aufgelisteten Dateien, wird der neuen Datei durch das SIMATIC Automation Tool eine Zahl hinzugefügt, damit die Namen eindeutig sind. Zur eindeutigen Identifizierung der Dateien bewegen Sie den Mauszeiger über den Programmnamen im Feld "Programmaktualisierung"; es wird dann ein Tooltipp angezeigt, der die Geräteschnittstelle und IP-Informationen zeigt, z. B.:

    Enthält die Programmdatei keine IP-Adresse, zeigt das Tooltipp für alle IP-Adressfelder "Direkt am Gerät einstellen".

  4. Ggf. Passwörter in den Spalten "Passwort in CPU" und "Passwort in Programmdatei" eingeben. Eine Programmaktualisierung ist ein sicherheitsrelevanter Vorgang. Ist das Gerät fehlersicher, muss das Safety-Passwort für F-CPU eingegeben werden.

  5. Um den Vorgang zu starten, wählen Sie Menü "Vorgänge > Aktualisieren > Programmaktualisierung". Alternativ wählen Sie in der Symbolleiste die Schaltfläche Aktualisierung [image] und dann im Dropdown-Menü die Option "Programmaktualisierung".

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Programmvalidierung

Das SIMATIC Automation Tool prüft die Programmdaten, bevor das Programm in einer CPU aktualisiert wird.

Wird ein Fehler in den Programmdaten erkannt, zeigt das SIMATIC Automation Tool in der Zelle "Ordner Programmaktualisierung" ein rotes X an. Weitere Fehlerinformationen sind über einen Tooltipp verfügbar, wenn der Mauszeiger über die Zelle geführt wird.

Passwortstatus nach einer Programmaktualisierung

Eine Programmdatei kann mit einem anderen Passwort als dem vorhandenen CPU-Passwort geschützt sein. Ist eine Programmdatei mit einem Passwort geschützt, so ist das Programm-Passwort in Feld "Passwort in Programmdatei" einzugeben, um eine Programmaktualisierung auszuführen. Das Passwort der Programmdatei wird zum CPU-Passwort, nachdem die Programmaktualisierung beendet ist.

Nach der erfolgreichen Programmaktualisierung kopiert das SIMATIC Automation Tool das Passwort in Programmdatei automatisch in das Feld für das CPU-Passwort und versucht, mit dem neuen Passwort eine Verbindung aufzubauen. Das SIMATIC Automation Tool löscht dann das Feld Passwort in Programmdatei und das Feld Programmaktualisierungsordner.

Ist das Passwort, das in der Spalte "Passwort in Programmdatei" eingegeben wird, nicht das Passwort, das in STEP 7 für das Projekt konfiguriert wurde, zeigt das Ereignisprotokoll nach Beendigung des Vorgangs eine Warnung. Das CPU-Passwort ist dann mit einem roten ‘X’ markiert, das ein ungültiges Passwort anzeigt.

F-Signaturvalidierung

Ein Projekt im TIA Portal, das ein Sicherheitsprogramm enthält, hat eine F-Signatur, mit der die Daten in einem kopierten Programm überprüft und ein zusätzliches Schutzniveau für Sicherheitsprogramme eingerichtet wird. Nach einer Programmaktualisierung wird die F-Signatur im Projekt mit der F-Signatur verglichen, die jetzt im CPU-Gerät geladen ist.

Das SIMATIC Automation Tool meldet einen erfolgreichen Vergleich im Ereignisprotokoll mit "Ergebnis des CRC-Vergleichs online und offline: Kollektive F-Signaturen stimmen nicht überein".

Das SIMATIC Automation Tool meldet einen fehlgeschlagenen Vergleich im Ereignisprotokoll mit " Ergebnis des CRC-Vergleichs online und offline: kollektive F-Signaturen stimmen nicht überein" Bei einem fehlgeschlagenen Vergleich ist das Gerät auf die Werkseinstellungen zurückzusetzen und die Programmaktualisierung zu wiederholen.

Warnung

Vergewissern Sie sich, dass Sie das richtige Sicherheitsprogramm laden.

Die Ausführung des falschen Programms auf einer F-CPU kann den Betrieb eines Prozesses oder einer Maschine beeinträchtigen. Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Versuchen Sie nicht, in RUN zu schalten, wenn Sie nicht sicher sind, dass das richtige Sicherheitsprogramm geladen ist.

Regeln für die Aktualisierung von CPU-Programmen

Das SIMATIC Automation Tool unterstützt die Programmaktualisierung für Standard-CPUs und fehlersichere CPUs.

Beachten Sie die folgenden Regeln zur Programmaktualisierung:

  • Die Firmware-Version der CPU-Hardware muss größer oder gleich der Firmware-Version im zu ladenden Projekt sein. Sie können diese Einschränkung durch Aktualisierung der Firmware in der CPU umgehen, sofern möglich.

  • Der Gerätekatalog enthält die Geräte, die den Programmaktualisierungsvorgang unterstützen. Über das Menü Hilfe können Sie auf den Gerätekatalog zugreifen.

Auswirkung einer Programmaktualisierung auf die IP-Adresse

Vor einer Programmaktualisierung wird im STEP 7-Projekt in der CPU in der Gerätekonfiguration festgelegt, wie die IP-Adresse eingestellt wird. Für diese Einstellung gibt es folgende Optionen:

  • IP-Adresse im Projekt einstellen (oder ähnlich)

  • IP-Adresse wird direkt am Gerät festgelegt (oder ähnlich)

Das Programm, das aktualisiert wird, kann möglicherweise eine andere Einstellung als die Gerätekonfiguration des in der CPU geladenen Projekts aufweisen. Außerdem hat möglicherweise ein anderer Benutzer die IP-Adresse des Geräts mit dem SIMATIC Automation Tool aktualisiert. In diesem Fall ist die benutzeraktualisierte Geräteadresse in der CPU.

Die IP-Adresse des Geräts nach einer Programmaktualisierung und einem anschließenden Aus- und Wiedereinschalten der CPU hängt von der Einstellung im neuen Programm und der aktuellen IP-Adresse ab. Die folgende Tabelle beschreibt verschiedene Möglichkeiten für die IP-Adresse des Geräts.

Gerätekonfiguration im neuen Programm zur Aktualisierung | IP-Adresse nach Programmaktualisierung | IP-Adresse nach nächstem Aus- und Wiedereinschalten der CPU nach Programmaktualisierung
IP-Adresse im Projekt einstellen | Die IP-Adresse ist die IP-Adresse des aktualisierten Programms. | Die IP-Adresse ist die IP-Adresse des aktualisierten Programms.
IP-Adresse wird direkt am Gerät festgelegt | Die IP-Adresse ist die IP-Adresse des Geräts vor der Programmaktualisierung. | Die IP-Adresse ist die IP-Adresse des Geräts vor der Programmaktualisierung.

Beispiel: Programmaktualisierung

Wenn Sie möchten, dass fünf verschiedene CPU-Programme für die Programmaktualisierung verfügbar sind, müssen Sie im Programmaktualisierungsordner fünf Ordner erstellen und benennen. Kopieren Sie alle "SIMATIC.S7S"-Ordner in die fünf entsprechenden Ordner.

In diesem Beispiel identifizieren die Ordnernamen "Program1", "Program2", "Program3", "Program4" und "Program5" die verfügbaren Programme. Sie können einen beliebigen Ordnernamen vergeben. Der Ordnername kann sich auf eine Programmfunktion oder einen CPU-Speicherort beziehen.

Die folgende Abbildung zeigt die vom Windows Datei-Explorer erzeugte Ansicht der Unterordner unter dem Programmordner. Die entsprechenden SIMATIC.S7S-Programmordner werden in diese Ordner kopiert.

Wenn Sie mit Windows 10 arbeiten, sieht Ihr Datei-Explorer anders aus, aber Sie kopieren dennoch Dateien in die gleiche Ordnerstruktur.

Die folgende Abbildung zeigt das Register "Programmaktualisierung" des SIMATIC Automation Tool mit beispielhaften Ordnernamen in der Klappliste der Spalte "Neue Programmaktualisierung". Sie müssen die Klappliste in der Spalte "Neue Programmaktualisierung"verwenden, um festzulegen, welches Programm verwendet werden soll. Ist mehr als eine CPU-Zeile ausgewählt, müssen Sie den Vorgang wiederholen und für jede ausgewählte CPU das korrekte Programm zuweisen.

Um die Programmaktualisierung zu starten, wählen Sie Menü "Vorgänge > Aktualisieren > Programmaktualisierung". Alternativ wählen Sie in der Symbolleiste die Schaltfläche "Aktualisierung" und dann im Dropdown-Menü die Option "Programmaktualisierung".

Der Prozess ist für HMI-Daten ähnlich. Der Name des Ordners in einem Projektordner lautet "SIMATIC.HMI" an Stelle von "SIMATIC.S7S". Die Vorgehensweise ist identisch.


Laden, Hinzufügen, Ersetzen und Löschen von Rezepten in CPUs

Aktionen über die Symbolleiste Rezeptdateien aus der CPU laden oder löschen Rezeptdateien hinzufügen oder ersetzen (aus der CPU laden)
Start Zurück Weiter

Laden, Hinzufügen, Ersetzen und Löschen von Rezepten in CPUs

Rezeptvorgänge funktionieren bei CPUs, die Rezepte im externen Ladespeicher haben (SIMATIC Memory Card). Die CPU kann sich dabei im Betriebszustand RUN oder STOP befinden.

Rezeptdaten sind als CSV-Textdateien (durch Komma getrennte Werte) formatiert.

Sie können mehrere Rezepte auf einmal hinzufügen oder ersetzen, wenn sich die Rezepte alle auf verschiedenen CPUs befinden. Pro Vorgang können Sie nicht mehr als ein Rezept in einer CPU hinzufügen oder ersetzen.

Sie können mehrere Rezepte zum Laden oder Löschen aus der CPU in einem einzigen Vorgang auswählen.

Wenn Sie eine Rezeptdatei oder einen Rezeptordner auswählen, zeigt das SIMATIC Automation Tool die entsprechende Zeile der Gerätetabelle in Fettschrift an.

Zum Laden von Rezepten in die CPU klicken Sie auf das Register "Rezept" und wählen eine Zeile mit einem Rezeptordner der CPU.

Das SIMATIC Automation Tool erzeugt einen eindeutigen Ordnernamen für jede CPU, um aus der CPU geladene Rezeptdateien auf Ihrem Programmiergerät zu speichern. Der Ordnername wird aus dem CPU-Namen und der MAC-Adresse erstellt. Wenn Sie die gleiche Rezeptdatei zweimal auswählen und aus der CPU laden, hängt das SIMATIC Automation Tool an den Dateinamen eine Zahl an, damit alle Dateinamen eindeutig sind.

Das SIMATIC Automation Tool benötigt Lesezugriff, um Rezeptdateien aus der CPU laden zu können. Zum Löschen, Hinzufügen oder Ersetzen von Rezeptdateien benötigt das SIMATIC Automation Tool vollständigen Zugriff (Lesen und Schreiben). Deshalb müssen Sie möglicherweise ein Passwort eingeben, um Dateien löschen oder hinzufügen/ersetzen zu können. Wenn Sie kein Passwort eingeben oder wenn das Passwort keinen Schreibzugriff auf die CPU gewährt, schlägt der Vorgang für die CPU fehl und im Protokoll wird eine Fehlermeldung erfasst.

Aktionen über die Symbolleiste

Im Klappmenü, das mit dem Symbol für "Dateivorgänge" in der Symbolleiste [image] geöffnet wird, haben Sie die folgenden Auswahlmöglichkeiten:

  • Rezepte aus CPU laden: Kopiert ausgewählte Rezeptdateien von einer CPU in den Rezeptordner Ihres Programmiergeräts.

  • Rezepte hinzufügen/ersetzen (wählbar, wenn Register "Rezept laden" angezeigt wird): Kopiert ausgewählte Rezeptdateien von Ihrem Programmiergerät in eine CPU.

  • Rezepte löschen Löscht ausgewählte Rezeptdateien aus einer CPU.

Rezeptdateien aus der CPU laden oder löschen

Um Rezeptdateien aus der CPU zu laden oder zu löschen, ist wie folgt vorzugehen:

  1. Auf Register "Rezept laden" in der Gerätetabelle klicken.

  2. Erweitern Sie ein CPU-Gerät und machen Sie einen Rezeptordner [image] sichtbar.

  3. Erweitern Sie einen Rezeptordner und wählen Sie die Rezeptdateien [image], die Sie in den Vorgang einschließen möchten.

  4. Für jede ausgewählte CPU ist ggf. ein Passwort in der Spalte "Passwort in CPU" einzugeben.

  5. Wählen Sie den Menübefehl "Vorgänge > Dateivorgänge" oder klicken Sie auf die Schaltfläche für "Dateivorgänge" in der Symbolleiste:

  6. Wählen Sie im Menü "Dateivorgänge" entweder "Rezepte aus CPU laden" oder "Rezept löschen".

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Rezeptdateien hinzufügen oder ersetzen (aus der CPU laden)

Um CPU-Rezeptdateien mit Dateien aus Ihrem Programmiergerät hinzuzufügen oder zu ersetzen, ist wie folgt vorzugehen:

  1. Kopieren Sie die CSV-Dateien mit Rezeptdaten, die in einer CPU hinzugefügt oder ersetzt werden sollen, in den Rezeptordner.

  2. Klicken Sie in der Gerätetabelle auf Register "Rezept laden".

  3. Erweitern Sie den Ordner "Rezepte" [image] für die CPU.

  4. Wählen Sie die Rezeptdatei aus, die Sie laden möchten.

  5. Verwenden Sie für jede ausgewählte Rezeptdatei die Klappliste der Spalte "Rezept hinzufügen/ersetzen" und wählen Sie einen Rezeptdateinamen aus. Die Klappliste zeigt die Namen der CSV-Dateien in dem Verzeichnispfad an, der in Teil "Rezepte" des Dialogs "Optionen > Einstellungen" zugewiesen wurde.
    Sie können auch die Durchsuchen-Schaltfläche     [image] verwenden und zu dem Ordner navigieren, in dem Rezeptdateien auf Ihrem Programmiergerät gespeichert werden. Die ausgewählte Datei wird vom SIMATIC Automation Tool zur Klappliste hinzugefügt. Wenn die ausgewählte Datei den gleichen Namen hat wie eine der bereits aufgelisteten Dateien, wird der neuen Datei durch das SIMATIC Automation Tool eine Zahl hinzugefügt, damit die Namen eindeutig sind. Damit Sie die Dateien identifizieren können, zeigt ein Tooltipp den gesamten Pfad und Dateinamen an.

  6. Wählen Sie den Menübefehl "Vorgänge > Dateivorgänge" oder klicken Sie auf die Schaltfläche für "Dateivorgänge" in der Symbolleiste:

  7. Wählen Sie im Menü "Dateivorgänge" Option "Rezept hinzufügen/ersetzen".

Ist das Rezept bereits vorhanden, wird es durch das SIMATIC Automation Tool ersetzt. Ist das Rezept nicht vorhanden, wird es vom SIMATIC Automation Tool hinzugefügt.

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Nach einem erfolgreichen Laden des Rezepts wird der Pfad der Rezeptdatei gelöscht.

Warnung

Sicherheitshinweis

Der Betrieb eines Prozesses oder einer Maschine mit manipulierten Daten kann sich auf den Betrieb eines Online-Prozesses oder einer Maschine auswirken. Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Schützen Sie die CSV-Dateien der Rezepte durch verschiedene Maßnahmen vor Manipulation (zum Beispiel durch Einschränkung des Netzwerkzugriffs und Einrichtung von Firewalls).


Laden und Löschen von Datenprotokollen in CPUs

Laden und Löschen von Datenprotokollen in CPUs

Das Laden von Datenprotokollen aus der CPU funktioniert bei CPUs, die Datenprotokolle im externen Ladespeicher haben (SIMATIC Memory Card). Die CPU kann sich dabei im Betriebszustand RUN oder STOP befinden.

Das Löschen des Datenprotokolls funktioniert nur im Betriebszustand STOP der CPU. Wenn Sie eines oder mehrere Datenprotokolle von einer oder mehreren CPUs zum Löschen auswählen, prüft das SIMATIC Automation Tool, ob sich eine der CPUs davon im Betriebszustand RUN befindet. Falls sich eine der CPUs im Betriebszustand RUN befindet, informiert Sie das SIMATIC Automation Tool, dass es alle ausgewählten CPUs in den Betriebszustand STOP versetzt, bevor es den Vorgang ausführt. Wenn Sie nicht in den Betriebszustand STOP wechseln, stoppt das SIMATIC Automation Tool den gesamten Löschvorgang.

Datenprotokolle werden vom SIMATIC Automation Tool als CSV-Textdateien (durch Komma getrennte Werte) aus der CPU geladen.

Sie können mehrere Datendateien einer oder mehrerer CPUs auswählen und alle ausgewählten Dateien in einem einzigen Vorgang verarbeiten.

Das SIMATIC Automation Tool erstellt einen eindeutigen Ordnernamen für jede CPU, um aus der CPU geladene Rezeptdateien auf Ihrem Programmiergerät zu speichern. Der Ordnername wird aus dem CPU-Namen und der MAC-Adresse erstellt. Wenn Sie die gleiche Datenprotokolldatei zweimal auswählen und aus der CPU laden, wird an den Dateinamen eine Zahl angehängt, damit alle Dateinamen eindeutig sind.

Das SIMATIC Automation Tool benötigt Lesezugriff, um Datenprotokolldateien aus der CPU laden zu können, und vollständigen Zugriff (Lesen und Schreiben), um Datenprotokolldateien von einer CPU löschen zu können. Sie müssen möglicherweise ein Passwort eingeben, um Datenprotokolle zu löschen. Wenn Sie kein Passwort eingeben oder wenn das Passwort keinen Schreibzugriff gewährt, löscht das SIMATIC Automation Tool die Datenprotokolle für diese CPU nicht. Im Ereignisprotokoll wird eine entsprechende Meldung angezeigt.

Datenprotokoll-Aktionen

Die Schaltfläche für Dateivorgänge in der Symbolleiste [image] und im Menü "Dateivorgänge" bieten die folgenden Menübefehle:

  • Datenprotokolle aus CPU laden: Lädt eine Kopie ausgewählter Datenprotokolldatei(en) aus der CPU in das Programmiergerät. Das SIMATIC Automation Tool kopiert die Dateien in das Verzeichnis, das in den Einstellungen für Datenprotokolle zugewiesen wurde.

  • Datenprotokolle löschen: Löscht ausgewählte Datenprotokolldateien, die in einer CPU gespeichert sind.

Datenprotokolldateien aus CPU laden oder löschen

Um Datenprotokolldateien aus einer CPU zu laden oder zu löschen, ist wie folgt vorzugehen:

  1. Erweitern Sie eine CPU-Zeile und machen Sie die Datenprotokollordner [image] sichtbar.

  2. Erweitern Sie einen Datenprotokollordner und wählen Sie Datenprotokolldateien [image] aus:

  3. Für jede ausgewählte CPU ist ggf. ein Passwort in der Spalte "Passwort in CPU" des aktuell geöffneten Registers einzugeben.

  4. Wählen Sie Menübefehl "Vorgänge > Dateivorgänge > Datenprotokolle aus CPU laden" oder "Vorgänge > Dateivorgänge > Datenprotokolle löschen". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche für "Dateivorgänge" [image] und wählen Sie im Dropdown-Menü den Befehl "Datenprotokolle aus CPU laden" oder "Datenprotokolle löschen".

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Warnung

Sicherheitshinweis

Der Betrieb eines Prozesses oder einer Maschine mit manipulierten Daten kann sich auf den Betrieb eines Online-Prozesses oder einer Maschine auswirken. Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Schützen Sie die CSV-Dateien des Datenprotokolls durch verschiedene Maßnahmen vor Manipulation, zum Beispiel durch Einschränkung des Netzwerkzugriffs und Einrichtung von Firewalls.


Installieren neuer Firmware auf Geräten

Möglichkeit einer Firmware-Aktualisierung klären Vorbereiten von Firmware-Aktualisierungsdateien für CPUs und Module für die Verwendung mit dem SIMATIC Automation Tool Vorbereiten von Firmware-Aktualisierungsdateien für HMI-Geräte für die Verwendung mit dem SIMATIC Automation Tool Vorabladen von Firmware-Aktualisierungsdateien Durchführen von Firmware-Aktualisierungen für Geräte Passwörter fehlersicherer CPUs für Firmware-Aktualisierungen Zeitüberschreitungs-Fehlermeldung aufgrund langsamer Kommunikation mit .upd-Dateispeichergerät Beispiel: Firmware-Aktualisierung für eine CPU Methoden zur Aktualisierung der Firmware ohne das SIMATIC Automation Tool
Start Zurück Weiter

Installieren neuer Firmware auf Geräten

Das SIMATIC Automation Tool kann die Firmware einer Gerätegruppe aktualisieren. Die Dateierweiterung für eine Firmware-Aktualisierung ist vom Gerätetyp abhängig:

  • Bei HMI-Geräten hat eine Firmware-Aktualisierungsdatei die Erweiterung *.fwf.

  • Bei SCALANCE-Geräten haben Firmware-Aktualisierungsdateien die Erweiterung *.lad, *.sfw oder *.fwl.

  • Bei CPUs und anderen Geräten können Sie das Format einer einzelnen UPD-Datei verwenden oder das ältere (klassische) Format, das aus mindestens drei separaten UPD-Dateien besteht.

Wenn Sie für die Kommunikation eine Linientopologie nutzen und in den Kommunikationseinstellungen Multithreading aktiviert ist, kann es bei diesem Vorgang zu einer Unterbrechung der Kommunikation kommen.

Hinweis

Die Kommunikationsmodule S7-1200 CM müssen vor der Firmware-Aktualisierung konfiguriert werden.

Bei einem Modul S7-1200 CM muss das Modul in STEP 7 konfiguriert und die Konfiguration in das Modul geladen werden, bevor die CM-Firmware mit dem SIMATIC Automation Tool aktualisiert werden kann.

Hinweis

Herabstufen der CPU-Firmware

Sie können das SIMATIC Automation Tool zum Herabstufen der CPU-Firmware (Laden einer älteren Firmware-Version) verwenden, doch die IP-Adresse und das Programm werden dabei möglicherweise gelöscht. In diesem Fall kann die IP-Adresse auf 0.0.0.0 zurückgesetzt werden und eine erneute Netzwerksuche ist erforderlich, um mit diesem Gerät zu kommunizieren. Sie müssen die IP-Adresse festlegen, um die vorherige Netzwerkadresse wiederherzustellen.

Bei einigen Geräten können Sie die Firmware nicht herabstufen. Prüfen Sie dies in der Dokumentation Ihres Geräts.

Beachten Sie, dass Programme für eine CPU-Firmware-Version möglicherweise auf einer anderen Firmware-Version nicht ausgeführt werden können. Die CPU kann nicht in den Betriebszustand RUN wechseln, wenn das Programm nicht mit der Firmware-Version kompatibel ist.

Wenn Sie ein Herabstufen der Firmware vorgenommen haben und das Programm mit der neuen Firmware-Version nicht mehr kompatibel ist, müssen Sie Ihre CPU wie folgt zurücksetzen:

  • Wenn Ihre CPU mit dem internen Ladespeicher arbeitet, setzen Sie die CPU auf die Werkseinstellungen zurück.

  • Wenn Ihre CPU mit einem externen Ladespeicher arbeitet, formatieren Sie die Memory Card und schalten die CPU aus und wieder ein.

Nach dem Rücksetzen der CPU laden Sie ein für die Firmware-Version in der CPU gültiges Programm.

Möglichkeit einer Firmware-Aktualisierung klären

Der Gerätekatalog enthält die Geräte und Versionen, für die das SIMATIC Automation Tool eine Firmware-Aktualisierung durchführen kann. Damit das SIMATIC Automation Tool in der Lage ist, die Firmware für Geräte zu aktualisieren, müssen Gerät und Version die Firmware-Aktualisierung unterstützen und einer der folgenden Kategorien angehören:

  • Eine CPU auf oberster Ebene der Gerätetabelle

  • Eine HMI auf oberster Ebene der Gerätetabelle

  • Ein lokales Modul einer CPU, eingeschlossen PROFIBUS CM/CP-Module

    Lokale Module für eine CPU erscheinen unter der CPU im Ordner "Lokale Module":

  • Ein dezentrales Gerät oder Modul innerhalb eines PROFINET IO-Systems

    Dezentrale Peripherie in einem PROFINET IO-System erscheint unter einem Ordner für PROFINET IO-Systeme:

Beachten Sie, dass beide Bedingungen erfüllt sein müssen:

  • Laut Gerätekatalog unterstützt das SIMATIC Automation Tool die Firmware-Aktualisierung für das Gerät.

  • Das Gerät oder Modul befindet sich auf einer unterstützten Ebene in der Gerätetabelle.

Das SIMATIC Automation Tool führt keine Firmware-Aktualisierung für Module in den folgenden IO-Systemen durch:

  • PROFIBUS IO-System:

  • AS-i IO-System:

Hinweis

Abhängigkeiten für lokale Module von CPUs

Bei lokalen Modulen können Sie die Firmware nicht aktualisieren, wenn die CPU keine Firmware-Aktualisierung unterstützt. Beispiel: CPUs der Baureihe S7-1200 mit einer Firmware-Version kleiner V4.0 unterstützen keine Firmware-Aktualisierung über Ethernet. Die Firmware lokaler Module, die an diesen CPUs angeschlossen sind, können Sie mit dem SIMATIC Automation Tool nicht aktualisieren.

Vorbereiten von Firmware-Aktualisierungsdateien für CPUs und Module für die Verwendung mit dem SIMATIC Automation Tool

Sie können Firmware-Aktualisierungsdateien für CPUs und Module über die Website des Siemens-Produktsupports beziehen.

Sie können auch eine Gerätezeile auswählen und dann entweder im Menü "Werkzeuge" oder in der Symbolleiste die Option "Auf Firmware-Aktualisierungen prüfen" auswählen. Das SIMATIC Automation Tool ruft die Webseite des Customer Support für das Gerät auf. Die Auswahl einer Siemens-Support-Webseite entspricht der in einer Gerätetabellenzeile angezeigten Artikelnummer. Der für die Artikelnummer 6ES7 215‑1HG31‑0XB0 ausgeführte Befehl "Auf Aktualisierungen prüfen" leitet Sie z. B. auf die zugehörige CPU 1215C Support-Webseite weiter.

Beispiel für eine CPU: Die Firmware-Aktualisierungsdatei mit der Bezeichnung 6ES7 211-1AE40-0XB0_V04.00.02.exe ist nur für die Ausführung CPU 1211C DC/DC/DC geeignet. Falls Sie die UPD-Datei in diesem Paket für ein anderes S7-1200 CPU-Modell verwenden, schlägt der Aktualisierungsprozess fehl.

Wenn Sie die Aktualisierungsdatei ausführen und die Dateien extrahieren, sehen Sie die folgenden Dateien und Ordner.

  • Datei: S7-JOB.SYS

  • Ordner: FWUPDATE.SYS enthält die UPD-Datei.

    • Datei: 6ES7 211-1AE40-0XB0 V04.00.02.upd (UPD-Datei wird vom SIMATIC Automation Tool verwendet)

Beispiel für ein Peripheriemodul: Die Firmware-Aktualisierungsdatei mit der Bezeichnung 232‑4HD32‑0XB0_V203.exe ist nur für das Modul SM 1232 ANALOGAUSGABE 4AO geeignet. Die selbstentpackende EXE-Datei enthält die Datei 6ES7 232‑4HD32‑0XB0V02.00.03_00.00.00.00.upd, die vom SIMATIC Automation Tool verwendet wird.

Hinweis

Firmware-Aktualisierungsdateien im neuen Format

  • Der Name der selbstentpackenden exe-Datei mit dem Aktualisierungspaket muss der Artikelnummer des Geräts entsprechen, das Sie aktualisieren möchten.

  • Der Name der selbstentpackenden UPD-Datei muss der Artikelnummer des Geräts und der Firmware-Version entsprechen, die Sie laden möchten.
Hinweis

Firmware-Aktualisierungsdateien im alten Format

  • Der Name der selbstentpackenden exe-Datei mit dem Aktualisierungspaket muss der Artikelnummer des Geräts entsprechen, das Sie aktualisieren möchten.

  • Enthält je nach Firmware-Größe mindestens drei Dateien

  • Erstellen Sie im Firmware-Aktualisierungsordner einen Ordner mit einem beliebigen Namen. Zwecks einfacher Identifikation können Sie dem Ordner die Artikelnummer und Versionsnummer zuweisen oder Sie vergeben einen beliebigen Namen. Das SIMATIC Automation Tool analysiert beim Start alle Firmware-Dateien zur Bestätigung der genauen Firmware-Versionsnummern.

UPD-Dateien in den Firmware-Aktualisierungsordner kopieren

Die einzelnen Firmware-Aktualisierungsdateien (UPD-Dateien) im neuen Format enthalten die Modell- und Versionsnummern des Zielmoduls im Dateinamen. Sie können mehrere UPD-Dateien in einen einzigen Firmware-Ordner kopieren und anschließend das Zielmodul anhand des UPD-Dateinamens identifizieren. Kopieren Sie alle benötigten UPD-Dateien in den Ordner für Firmware-Aktualisierungen.

Warnung

Vergewissern Sie sich vor dem Installieren von Firmware-Aktualisierungen, dass die CPU keinen Prozess ausführt.

Durch das Installieren einer Firmware-Aktualisierung geht die CPU in die Betriebsart STOP, was sich auf den Betrieb eines Online-Prozesses oder einer Maschine auswirken kann. Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Vorbereiten von Firmware-Aktualisierungsdateien für HMI-Geräte für die Verwendung mit dem SIMATIC Automation Tool

Eine Firmware-Aktualisierungsdatei für ein HMI-Gerät hat die Dateierweiterung *.fwf. Diese Datei ist Bestandteil des Runtime- und Betriebssystems des HMI-Geräts, die Sie aus dem TIA Portal-Projekt kopieren können. Unter Aktualisieren von Geräteprogrammen über das SIMATIC Automation Tool finden Sie Anweisungen zum Übertragen der SIMATIC.HMI-Dateistruktur vom TIA Portal auf ein Speichermedium wie eine SIMATIC Memory Card. Nachdem Sie die SIMATIC.HMI-Dateistruktur auf Ihr Speichermedium kopiert haben, gehen Sie folgendermaßen vor, um die Firmware für ein HMI-Gerät zu aktualisieren:

  1. Öffnen Sie im SIMATIC.HMI-Ordner auf Ihrer SIMATIC Memory Card den Unterordner "Firmware" und gehen sie so weit in die Ordnerstruktur, bis Sie die Datei mit der Erweiterung *.fwf gefunden haben.

  2. Kopieren Sie die FWF-Datei in Ihren Ordner Firmware-Aktualisierung.

Sie können mehrere FWF-Dateien für mehrere HMI-Geräte und mehrere Firmware-Versionen im Firmware-Aktualisierungsordner speichern.

Hinweis

Übertragungseinstellungen für ein HMI-Gerät (SIMATIC Panel)

Zum Kommunizieren mit einer HMI müssen Sie die Übertragungseinstellungen am HMI-Gerät auf PN/IE oder Ethernet setzen. Die Kommunikationseinstellungen für den HMI-Übertragungskanal müssen Sie auf die gleiche Einstellung setzen.

Vorabladen von Firmware-Aktualisierungsdateien

Sie können die neueste verfügbare Firmware-Aktualisierung in der Spalte "Neue Firmwareversion" vorab laden. Das SIMATIC Automation Tool untersucht den Firmware-Aktualisierungsordner. Wenn das SIMATIC Automation Tool für ein Gerät Firmware-Aktualisierungsdateien findet, bei denen es sich um eine neuere Version als die im Gerät vorhandene handelt, lädt das SIMATIC Automation Tool die neueste verfügbare Version in die Spalte "Neue Firmwareversion".

Um Firmware-Aktualisierungsdateien vorab zu laden, wählen Sie den Menübefehl "Werkzeuge > Firmware-Aktualisierungsdateien vorab laden". Alternativ können Sie auf die Schaltfläche "Werkzeuge" [image] klicken und im Kontextmenü den Menübefehl "Firmware-Aktualisierungsdateien vorab laden" auswählen.

Das SIMATIC Automation Tool lädt dann für jedes Gerät die neueste Version in die Spalte "Neue Firmwareversion", die neuer ist als die im Gerät vorhandene Version. Wenn das SIMATIC Automation Tool keine Automatisierungsdatei findet, die neuer ist als die im Gerät vorhandene Version, lässt es die Spalte "Neue Firmwareversion" leer.

Sie können Firmware-Aktualisierungszellen durch Kopieren und Einfügen in andere anwendbare Firmware-Aktualisierungszellen übertragen. Die Funktionen zum Kopieren und Einfügen vereinfachen Firmware-Aktualisierungen für mehrere Dateien.

Durchführen von Firmware-Aktualisierungen für Geräte

Um einen Firmware-Aktualisierungsvorgang durchzuführen, gehen Sie folgendermaßen vor:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Klicken Sie auf das Register "Firmware-Aktualisierung".

  3. Wenn Sie keine Firmware-Aktualisierungsdateien vorab geladen haben, wählen Sie die Firmware-Aktualisierungsdateien aus. Verwenden Sie für jede ausgewählte Gerätezeile die Klappliste der Spalte "Neue Firmwareversion" und wählen Sie eine Firmware-Version aus. Die Klappliste enthält die Namen der Dateien im Firmware-Aktualisierungsordner, die Ihrer Geräteauswahl entsprechen. Sind neue Firmware-Versionen im Ordner für die Firmware-Aktualisierung verfügbar, stehen diese Dateien in der Klappliste "Neue Firmwareversion" zur Verfügung.

    Sie können auch über die Durchsuchen-Schaltfläche [image] zu einem Ordner auf Ihrem Programmiergerät navigieren, in dem Firmware-Aktualisierungsdateien gespeichert sind. Wählen Sie eine Datei aus, die zur Klappliste hinzugefügt werden soll. Wenn die ausgewählte Datei den gleichen Namen hat wie eine der bereits aufgelisteten Dateien, wird der neuen Datei durch das SIMATIC Automation Tool eine Zahl hinzugefügt, damit die Namen eindeutig sind. Damit Sie die Dateien identifizieren können, zeigt ein Tooltipp den gesamten Pfad und Dateinamen an.

    Wenn Sie eine Firmware-Aktualisierungsdatei im alten Format auswählen, wählen Sie die Datei header.upd aus. Wählen Sie keine andere auswählbare .upd-Datei aus.

  4. Für jede ausgewählte CPU ist ggf. ein Passwort in die Spalte "Passwort in CPU" einzugeben.

  5. Wählen Sie für jedes ausgewählte SCALANCE-Gerät das SNMP-Profil für Ihr Gerät aus. Ein Symbol neben dem SNMP-Profil zeigt an, ob der Name des SNMP-Profils einem Profilnamen in der Profildatei im Ordner der SNMP-Profile entspricht:

    • : SNMP-Profil entspricht keinem SNMP-Profil in der Profildatei im Ordner der SNMP-Profile.

    • : SNMP-Profil entspricht einem SNMP-Profil in der Profildatei im Ordner der SNMP-Profile.

    Hinweis

    Sie müssen einen TFTP-Server (Trivial File Transfer Protocol) zur Verfügung stellen, um Firmware in SCALANCE-Geräten zu installieren.

  6. Zum Starten des Vorgangs wählen Sie das Menü "Vorgänge > Aktualisieren > Firmware-Aktualisierung". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche Aktualisierung [image] und wählen Sie dann im Dropdown-Menü der Schaltfläche Option "Firmware-Aktualisierung".

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt. Nach einer erfolgreichen Firmware-Aktualisierung wird das Feld "Neue Firmwareversion" vom SIMATIC Automation Tool gelöscht.

Passwörter fehlersicherer CPUs für Firmware-Aktualisierungen

Bei älteren Firmware-Versionen als S7-1200 V4.2 und S7-1500 V2.0 erfordert eine passwortgeschützte fehlersichere CPU ein Safety-Passwort für F-CPU (Stufe 5) für die Firmware-Aktualisierung. Da eine Firmware-Aktualisierung kein sicherheitsrelevanter Vorgang ist, wurde die Passwortstufe herabgesetzt. Spätere Firmware-Versionen der F-CPU erfordern nur einen Lese-Schreibzugriff (Stufe 4 mit Vollzugriff).

Das SIMATIC Automation Tool prüft die Legitimierung für die verschiedenen Firmware-Versionen nicht. Der Vorgang wird gestartet und das Gerät lehnt ein Passwort abhängig von der Implementierung in der Firmware ab; gleichzeitig wird ein Fehler im Ereignisprotokoll wie folgt generiert:

"Das angegebene Passwort ist nicht ausreichend, um den Vorgang durchzuführen."

S7-1200 V4.2 oder neuer und S7-1500 V2.0 oder neuer erfordern nur einen "Vollzugriff (kein Schutz)" für Lesen und Schreiben. Wird das Safety-Passwort für F-CPU benutzt, erlaubt auch dieses den Lese- und Schreibzugriff, so dass der Vorgang immer erfolgreich durchgeführt wird, wenn Sie dieses Passwort eingeben.

Zeitüberschreitungs-Fehlermeldung aufgrund langsamer Kommunikation mit .upd-Dateispeichergerät

Wenn die folgende Fehlermeldung angezeigt wird, sind mehr als zehn Sekunden vergangen. In dieser Zeit konnte das SIMATIC Automation Tool nicht alle UPD-Dateien verarbeiten. Die Zeit, die zum Öffnen und Durchsuchen aller .upd-Dateien benötigt wird, hängt von der Datenzugriffszeit und der Anzahl der .upd-Dateien im Ordner ab.

Dieser Zeitüberschreitungsfehler kann auftreten, wenn die Kommunikation mit einem entfernten Speichergerät zu langsam abläuft.

Um dieses Problem zu vermeiden, kopieren Sie die Dateien für die Firmware-Aktualisierung auf ein lokales Speichergerät, das schnelleren Zugriff bietet. Geben Sie diesen Pfad als Ordner für die Firmware-Aktualisierung an und wiederholen Sie den Vorgang.

Beispiel: Firmware-Aktualisierung für eine CPU

In diesem Beispiel wird gezeigt, wie die Firmware für ein Gerät im Netzwerk aktualisiert wird.

Für eine Firmware-Aktualisierung gehen Sie folgendermaßen vor:

  1. Die Klappliste mit verfügbaren Versionen in der Spalte "Neue Firmware-Version" öffnen. Die Klappliste zeigt alle verfügbaren Firmware-Aktualisierungsdateien im Firmware-Aktualisierungsordner an.

  2. Die Firmware-Aktualisierungsversion auswählen, die verwendet werden soll. (War mehr als ein Gerät ausgewählt, ist für jedes ausgewählte Gerät die korrekte Aktualisierungsdatei zuzuweisen.)

  3. Zum Starten des Vorgangs wählen Sie das Menü "Vorgänge > Aktualisieren > Firmware-Aktualisierung". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche "Aktualisierung" und wählen Sie dann im Dropdown-Menü die Option "Firmware-Aktualisierung".

Hinweis

Die Firmware bestimmter S7-1200 Module kann mit dem SIMATIC Automation Tool nicht aktualisiert werden

Einige CPUs unterstützen die Firmware-Aktualisierung nicht. Wenn eine CPU keine Firmware-Aktualisierung unterstützt, können Sie das Gerät nur mit einer SIMATIC SD-Karte aktualisieren. Auch die Firmware von Modulen, die mit dieser CPU verbunden sind, kann mit dem SIMATIC Automation Tool nicht aktualisiert werden.

Methoden zur Aktualisierung der Firmware ohne das SIMATIC Automation Tool

Alternative Möglichkeiten der Firmware-Aktualisierung sind z. B.:

  • SIMATIC SD Memory Card in entsprechenden Geräten

  • TIA Portal Online- und Diagnosefunktionen

  • Die Modul-Informationsseite des Webservers einer CPU

Hinweis

Aktualisierung von HMI-Betriebssystem und Runtime-Software

Für die Aktualisierung von HMI-Betriebssystem und Runtime-Software können Sie den Programmaktualisierungsvorgang im SIMATIC Automation Tool verwenden. Der Programmaktualisierungsvorgang aktualisiert alle Datenkomponenten nach Bedarf, um einen konsistenten Ladevorgang zu gewährleisten.

Sie können das HMI-Betriebssystem (Firmware) aktualisieren, ohne die Runtime-Software zu aktualisieren. In den Versionen vor V3.1 SP2 gab es noch nicht die Möglichkeit, lediglich die Betriebssystem-Firmware zu aktualisieren. Sie mussten stets eine Programmaktualisierung durchführen.


Sichern und Wiederherstellen von Gerätedaten

Sichern und Wiederherstellen von Gerätedaten

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Sicherung einer CPU oder HMI
  • Sichern von HMI-Rezepten
  • Sichern von Daten der HMI-Benutzerverwaltung
  • Wiederherstellen von Sicherungsdateien


Sicherung einer CPU oder HMI

Durchführen einer Komplettsicherung

Sicherung einer CPU oder HMI

Durch das Sichern einer CPU oder HMI werden eine oder mehrere Sicherungsdateien erstellt und die Dateien im Ordner für das Sichern und Wiederherstellen abgelegt.

Sie können diese Dateien für die Gerätewiederherstellung im SIMATIC Automation Tool verwenden.

Das SIMATIC Automation Tool ermöglicht die folgenden Arten von Sicherungen:

  • Komplettsicherung einer CPU oder HMI

  • HMI-Rezeptsicherung

  • Sicherung von HMI-Benutzerverwaltungsdaten

Der Dateiname für eine CPU-Sicherung wird aus dem Projektnamen, dem Typ der Sicherung und der MAC-Adresse zusammengesetzt. Der Dateiname für die HMI-Sicherung setzt sich aus dem HMI-Typ, der MAC-Adresse und dem Typ der Sicherung zusammen. Alle Sicherungsdaten haben die Dateierweiterung *.s7pbkp. Das SIMATIC Automation Tool kopiert die Dateien in den Ordner für Sichern und Wiederherstellen.

Durchführen einer Komplettsicherung

Sie können den Sicherungsvorgang über eine beliebige Registerauswahl starten.

Um eine Sicherungsdatei anzulegen, gehen Sie folgendermaßen vor:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen "Geräte" oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Wählen Sie im Menü "Vorgänge" die Menübefehle "Gerät sichern > Komplettsicherung". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche zum Sichern und Wiederherstellen [image] und wählen im Dropdown-Menü "Gerät sichern > Komplettsicherung" aus.

Das Ereignisprotokoll zeigt die Ergebnisse des Vorgangs an.

Bei einem erfolgreichen Vorgang erstellt das SIMATIC Automation Tool für jedes ausgewählte Gerät eine Sicherungsdatei.


Sichern von HMI-Rezepten

Sichern von HMI-Rezepten

Sie können den Sicherungsvorgang über eine beliebige Registerauswahl starten.

Zum Erstellen einer Sicherungsdatei für HMI-Rezepte von einem oder mehreren HMI-Geräten gehen Sie wie folgt vor:

  1. Wählen Sie ein oder mehrere HMI-Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen "Geräte" oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Wählen Sie im Menü "Vorgänge" die Menübefehle "Gerät sichern > HMI > Rezepte". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche zum Sichern und Wiederherstellen [image] und wählen im Dropdown-Menü "Gerät sichern > HMI > Rezepte".

Das Ereignisprotokoll zeigt die Ergebnisse des Vorgangs an.

Bei einem erfolgreichen Vorgang erstellt das SIMATIC Automation Tool eine HMI-Rezeptsicherungsdatei für jedes HMI-Gerät. Das SIMATIC Automation Tool speichert die Dateien im Ordner für das Sichern und Wiederherstellen. Dabei ignoriert das SIMATIC Automation Tool Geräte, die keine HMI-Geräte sind.


Sichern von Daten der HMI-Benutzerverwaltung

Sichern von Daten der HMI-Benutzerverwaltung

Sie können den Sicherungsvorgang über eine beliebige Registerauswahl starten.

Zum Erstellen einer Sicherungsdatei mit Daten der HMI-Benutzerverwaltung von einem oder mehreren HMI-Geräten gehen Sie wie folgt vor:

  1. Wählen Sie ein oder mehrere HMI-Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen "Geräte" oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Wählen Sie im Menü "Vorgänge die Menübefehle "Gerät sichern > HMI > Daten Benutzerverwaltung". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche zum Sichern und Wiederherstellen [image] und wählen im Dropdown-Menü "Gerät sichern > HMI > Daten Benutzerverwaltung".

Das Ereignisprotokoll zeigt die Ergebnisse des Vorgangs an.

Bei einem erfolgreichen Vorgang erstellt das SIMATIC Automation Tool für jedes HMI-Gerät eine Sicherungsdatei mit Daten der HMI-Benutzerverwaltung. Das SIMATIC Automation Tool speichert die Dateien im Ordner für das Sichern und Wiederherstellen. Dabei ignoriert das SIMATIC Automation Tool Geräte, die keine HMI-Geräte sind.


Wiederherstellen von Sicherungsdateien

Wiederherstellen von Geräten aus Sicherungsdateien Validierung der Sicherungsdatei Passwort-Status nach dem Wiederherstellen F-Signaturvalidierung Auswirkung der Wiederherstellung eines CPU-Programms auf die IP-Adresse Beispiel für Wiederherstellen aus einer Sicherungsdatei
Start Zurück Weiter

Wiederherstellen von Sicherungsdateien

Wiederherstellen von Geräten aus Sicherungsdateien

Mit dem Befehl "Gerät wiederherstellen" werden Sicherungsdateien auf den entsprechenden Geräten wiederhergestellt. CPU- und HMI-Sicherungsdateien, die mit dem Befehl "Gerät sichern" angelegt wurden, haben die Erweiterung "s7pbkp". Diese Dateien können aus dem Ordner für Sichern und Wiederherstellen wiederhergestellt oder an einem anderen Ort gesucht werden.

Wenn Sie für die Kommunikation eine Linientopologie nutzen und in den Kommunikationseinstellungen Multithreading aktiviert ist, kann es bei diesem Vorgang zu einer Unterbrechung der Kommunikation kommen.

Hinweis

Fehlersichere Geräte

Wenn eine fehlersichere CPU geschützt ist, muss in der Spalte "Passwort in CPU" das Safety-Passwort für F-CPU eingegeben werden, um ein fehlersicheres Gerät aus einer Sicherungsdatei wiederherzustellen.

Sie müssen eine zusätzliche Aufforderung bestätigen und Ihr Gerät erneut auswählen, wenn das Programm in der F-CPU ein Sicherheitsprogramm ist.

Das SIMATIC Automation Tool platziert Anforderungen "Aus Sicherungskopie wiederherstellen" für fehlersichere Geräte in der Warteschlange für sicherheitsrelevante F-CPU-Vorgänge. Das SIMATIC Automation Tool verwendet für die Warteschlange für sicherheitsrelevante Vorgänge nur die zeitliche Single-Thread-Abarbeitung.

Das Zielgerät für ein Sicherheitsprogramm muss eine fehlersichere CPU sein.
Warnung

Vergewissern Sie sich vor dem Wiederherstellen eines Geräts aus einer Sicherungsdatei, dass das Gerät aktuell keinen Prozess ausführt.

Durch das Wiederherstellen einer CPU geht die CPU in die Betriebsart STOP, was sich auf den Betrieb eines Online-Prozesses oder einer Maschine auswirken kann. Die Wiederherstellung eines HMI-Geräts unterbricht Bedieneraktionen in Bedienerbildschirmen, was auch zur Prozessunterbrechung führen kann.

Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Vergewissern Sie sich vor dem Wiederherstellen eines Geräts aus einer Sicherungsdatei, dass Ihr Prozess eine Unterbrechung verarbeiten kann.
Hinweis

Übertragungseinstellungen für ein HMI-Gerät (SIMATIC HMI-Panel)

Zum Kommunizieren mit einer HMI müssen Sie die Übertragungseinstellungen am HMI-Gerät auf PN/IE oder Ethernet setzen. Die Kommunikationseinstellungen für den HMI-Übertragungskanal müssen Sie auf die gleiche Einstellung setzen.

Um ausgewählte Geräte aus einer Sicherungsdatei wiederherzustellen, gehen Sie wie folgt vor:

  1. Klicken Sie in der Gerätetabelle auf Register "Aus Sicherungskopie wiederherstellen".

  2. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  3. Wählen Sie für jedes Gerät einen Sicherungsdateinamen in der Klappliste "Sicherungsdatei". Die Klappliste zeigt die Namen der s7pbkp-Dateien, die im Ordner für Sichern und Wiederherstellen vorhanden sind.

    Sie können auch über die Durchsuchen-Schaltfläche [image] zu einem Ordner auf Ihrem Programmiergerät navigieren, in dem Sicherungsdateien gespeichert sind. Wählen Sie eine Datei aus, die zur Klappliste hinzugefügt werden soll. Wenn die ausgewählte Datei den gleichen Namen hat wie eine vorhandene Datei, wird der neuen Datei durch das SIMATIC Automation Tool eine Zahl hinzugefügt, damit die Namen eindeutig sind.

    Bei gültigen Dateien zeigt ein Tooltipp den gesamten Pfad und Dateinamen an. Neben dem Dateinamen erscheint ferner ein grünes Häkchen.

    Bei ungültigen Dateien zeigt das Tooltipp den Dateifehler an, der auch im Ereignisprotokoll angezeigt wird. Neben dem Dateinamen erscheint ein rotes X.

  4. Ggf. Passwörter in dem Spalten "Passwort in CPU" und "Passwort in Sicherungsdatei" eingeben. Das Wiederherstellen aus einer Sicherungsdatei ist ein sicherheitsrelevanter Vorgang, für den bei passwortgeschützten fehlersicheren Geräten das Safety-Passwort für die F-CPU erforderlich ist.

  5. Zum Starten des Vorgangs wählen Sie Menü "Vorgänge > Sichern/Wiederherstellen > Gerät wiederherstellen". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche Sichern/Wiederherstellen [image] und wählen dann im Dropdown-Menü der Schaltfläche die Option "Gerät wiederherstellen".

Validierung der Sicherungsdatei

Vor Beginn der Wiederherstellung führt das SIMATIC Automation Tool begrenzte Prüfungen der Sicherungsdateidaten durch.

  • Die Dateierweiterung und die Namen im Dateikopf werden geprüft.

  • Die Wiederherstellung aus einer Sicherungsdatei, die ein Sicherheitsprogramm enthält, ist nur möglich, wenn das Zielgerät eine fehlersichere CPU ist.

Ist die Sicherungsdatei nicht gültig, zeigt das SIMATIC Automation Tool ein rotes "X" in Feld "Sicherungsdatei" an. Weitere Fehlerinformationen sind über ein Tooltipp verfügbar, wenn der Mauszeiger über die Zelle geführt wird.

Passwort-Status nach dem Wiederherstellen

Ist eine CPU passwortgeschützt, muss ein Passwort eingegeben werden, damit das Wiederherstellen aus der Sicherungsdatei erfolgreich ausgeführt werden kann.

Nach dem Wiederherstellen einer Sicherungsdatei in einer CPU kann die neue Datei ein Passwort haben. Das wiederhergestellte Passwort kann anders als das vorhergehende Passwort sein, wenn die CPU ein Passwort hatte. Daher müssen Sie in der Spalte "Passwort in Sicherungsdatei" ein zweites Passwort eingeben. Das zweite Passwort wird nach beendeter Wiederherstellung zum CPU-Passwort.

Nach der erfolgreichen Wiederherstellung kopiert das SIMATIC Automation Tool das zweite Passwort (das zuvor eingegebene "Passwort in Sicherungsdatei") automatisch in das Feld für das CPU-Passwort und versucht, mit dem neuen Passwort eine Verbindung aufzubauen. Das SIMATIC Automation Tool löscht dann das zweite Passwort und den Sicherungsdateipfad.

Vor dem Wiederherstellen einer Sicherungsdatei in einer CPU:

Nach dem Wiederherstellen einer Sicherungsdatei in einer CPU:

Ist das Passwort, das in der Spalte "Passwort in Sicherungsdatei" eingegeben wurde, falsch und kein Passwort, das in den wiederhergestellten CPU-Daten konfiguriert ist, zeigt das Ereignisprotokoll eine Warnung, wenn der Vorgang beendet ist. Das CPU-Passwort ist dann mit einem roten X markiert, das ein ungültiges Passwort anzeigt.

F-Signaturvalidierung

Ein Projekt in TIA Portal, das ein Sicherheitsprogramm enthält, hat eine F-Signatur. Das SIMATIC Automation Tool überprüft mit Hilfe der F-Signatur die Daten in einer Programmdatei, wodurch eine zusätzliche Sicherheitsstufe für Sicherheitsprogramme bereitgestellt wird. Nach dem Wiederherstellen von einer Sicherungsdatei vergleicht das SIMATIC Automation Tool die F-Signatur in der Projektdatei mit der F-Signatur, die jetzt im Programm des CPU-Geräts vorhanden ist.

Das Ereignisprotokoll meldet einen erfolgreichen Vergleich mit: "Ergebnis des CRC-Vergleichs online und offline: kollektive F-Signaturen stimmen überein"

Das SIMATIC Automation Tool meldet einen fehlgeschlagenen Vergleich im Ereignisprotokoll mit: "Ergebnis des CRC-Vergleichs online und offline: Kollektive F-Signaturen stimmen nicht überein" Bei einem fehlgeschlagenen Vergleich ist das Gerät auf die Werkseinstellungen zurückzusetzen und die Programmaktualisierung zu wiederholen. Versuchen Sie nicht, in RUN zu schalten, wenn Sie nicht sicher sind, dass das richtige Sicherheitsprogramm geladen ist.

Auswirkung der Wiederherstellung eines CPU-Programms auf die IP-Adresse

Vor einer Wiederherstellung wird im STEP 7-Projekt in der CPU in der Gerätekonfiguration festgelegt, wie die IP-Adresse eingestellt wird. Für diese Einstellung gibt es folgende Optionen:

  • IP-Adresse im Projekt einstellen (oder ähnlich)

  • IP-Adresse wird direkt am Gerät festgelegt (oder ähnlich)

Das Programm, das wiederhergestellt wird, kann möglicherweise eine andere Einstellung als die Gerätekonfiguration des in der CPU geladenen Projekts aufweisen. Außerdem hat möglicherweise ein anderer Benutzer die IP-Adresse des Geräts mit dem SIMATIC Automation Tool aktualisiert. In diesem Fall ist die benutzeraktualisierte IP-Adresse des Geräts in der CPU.

Die IP-Adresse des Geräts nach der Wiederherstellen eines Programms und einem anschließenden Aus- und Wiedereinschalten der CPU hängt von der Einstellung im neuen Programm und der aktuellen IP-Adresse ab. Die folgende Tabelle beschreibt verschiedene Möglichkeiten für die IP-Adresse des Geräts.

Gerätekonfiguration in Sicherungsdatei | IP-Adresse nach Wiederherstellung von Sicherung | IP-Adresse nach Aus- und Wiedereinschalten der CPU nach Wiederherstellung von Sicherung
IP-Adresse im Projekt einstellen | Die IP-Adresse ist die IP-Adresse des wiederhergestellten Programms. | Die IP-Adresse ist die IP-Adresse des wiederhergestellten Programms.
IP-Adresse wird direkt am Gerät festgelegt | Die IP-Adresse ist die IP-Adresse des Geräts vor der Wiederherstellung des Programms. | Die IP-Adresse ist die IP-Adresse des Geräts vor der Wiederherstellung des Programms.

Beispiel für Wiederherstellen aus einer Sicherungsdatei

Dieses Beispiel zeigt ein ausgewähltes Gerät und die Auswahl einer Sicherungsdatei für Feld "Sicherungsdatei". Bei mehreren Geräten ist eine Sicherungsdatei für die Wiederherstellung für jedes Gerät auszuwählen:

Nach der Ausführung von "Gerät wiederherstellen" zeigt das Ereignisprotokoll die Ergebnisse des Vorgangs an.


Zurücksetzen der Kommunikationsparameter

Zurücksetzen der Kommunikationsparameter

Das SIMATIC Automation Tool unterstützt den DCP-Befehl "Kommunikationsparameter zurücksetzen" für PROFINET-Geräte. Der PROFINET-Standard definiert den Befehl "Kommunikationsparameter zurücksetzen" als einen Befehl, der Geräte in einen Zustand "wie geliefert" versetzt. Konkret setzt der Befehl folgende Werte für die Kommunikationsschnittstellen und ARs (Application Relationships, d. h. Anwendungsbeziehungen) zurück:

Parameter

Wert

NameOfStation

"" (leere Zeichenkette)

IP-Suite-Parameter

0.0.0.0

DHCP-Parameter, falls verfügbar

Werkseinstellungen

P-Dev-Parameter:

  • PD IR Data

  • PD Port Data Adjust

  • PD Interface

  • MRP Data Adjust

  • Sonstige

Werkseinstellungen

Parameter von MIB-II, angepasst durch SNMP, zum Beispiel:

  • sysContact

  • sysName

  • sysLocation

Werkseinstellungen

Zum Zurücksetzen der Kommunikationsparameter für PROFINET-Geräte gehen Sie folgendermaßen vor:

  1. Wählen Sie in der Gerätetabelle die zurückzusetzenden Geräte aus.

  2. Wählen Sie den Menübefehl Vorgänge > Zurücksetzen > Kommunikationsparameter zurücksetzen.

Das SIMATIC Automation Tool sendet den DCP-Befehl "Kommunikationsparameter zurücksetzen" an die Geräte. Das Ereignisprotokoll zeigt eine Meldung für Geräte an, die den DCP-Rücksetzbefehl nicht unterstützen. Das Ereignisprotokoll zeigt auch Fehlermeldungen für Geräte an, die Fehler zurückgeben.

Hinweis

Sie müssen CPUs in der STEP 7-Gerätekonfiguration als Peripheriegeräte konfigurieren, um die CPU zu befähigen, die Kommunikationsparameter zurückzusetzen. Die Einstellungen des Peripheriegeräts befinden sich in der Betriebsartengruppe der PROFINET-Schnittstelleneinstellungen in der STEP 7-Gerätekonfiguration.


Urlöschen von CPUs

Urlöschen von CPUs

Zum Urlöschen benötigen Sie Schreibzugriff auf eine CPU.

Um ein Urlöschen ausgewählter CPUs durchzuführen, gehen Sie folgendermaßen vor:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Für jede ausgewählte CPU ist ggf. ein Passwort in Spalte "Passwort in CPU" einzugeben.

  3. Um den Vorgang zu starten, wählen Sie Menü "Vorgänge > Zurücksetzen > Urlöschen". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche "Rücksetzen" und wählen Sie dann im Dropdown-Menü die Option "Urlöschen".

  4. Klicken Sie im Dialogfeld "Urlöschen" auf die Schaltfläche "Fortfahren".

Das SIMATIC Automation Tool führt ein Urlöschen des Speichers in den ausgewählten Geräten aus.

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.


Rücksetzen von Geräten auf Werkseinstellungen

Rücksetzen ausgewählter Geräte auf die Werkseinstellungen Auswirkung des Rücksetzens einer CPU auf die Werkseinstellungen auf die IP-Adresse
Start Zurück Weiter

Rücksetzen von Geräten auf Werkseinstellungen

Rücksetzen ausgewählter Geräte auf die Werkseinstellungen

Sie können ausgewählte Geräte auf die Werkseinstellungen zurücksetzen, Ausnahme ist die IP-Adresse. Die vorhandene IP-Adresse wird beibehalten, sodass Ihre IP-Netzwerkzuweisungen nicht verloren gehen.

Wenn Sie für die Kommunikation eine Linientopologie nutzen und in den Kommunikationseinstellungen Multithreading aktiviert ist, kann es bei diesem Vorgang zu einer Unterbrechung der Kommunikation kommen.

Hinweis

Fehlersichere Geräte

Wenn eine fehlersichere CPU geschützt ist, muss in der Spalte "Passwort in CPU" das Safety-Passwort für F-CPU eingegeben werden, um ein fehlersicheres Gerät auf die Werkseinstellungen zurückzusetzen.

Sie müssen dann eine zusätzliche Aufforderung bestätigen und Ihr Gerät erneut auswählen, wenn das Programm in der F-CPU ein Sicherheitsprogramm ist.

Anforderungen zum Rücksetzen auf Werkseinstellungen für fehlersichere Geräte werden in die Warteschlange für sicherheitsrelevante Vorgänge platziert und es ist nur die zeitliche Single-Thread-Abarbeitung erlaubt.
Warnung

Vergewissern Sie sich vor dem Rücksetzen auf Werkseinstellungen, dass das Gerät aktuell keinen Prozess ausführt.

Durch das Rücksetzen auf die Werkseinstellungen geht die CPU in die Betriebsart STOP, was sich auf den Betrieb eines Online-Prozesses oder einer Maschine auswirken kann. Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Um ausgewählte Geräte auf die Werkseinstellungen zurückzusetzen, gehen Sie wie folgt vor:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

    Für jede ausgewählte CPU ist ggf. ein Passwort in der Spalte "Passwort in CPU" des aktuell geöffneten Registers einzugeben. Das Rücksetzen auf die Werkseinstellungen ist ein sicherheitsrelevanter Vorgang, für den das Safety-Passwort für F-CPUs für passwortgeschützte fehlersichere Geräte erforderlich ist.

  2. Um den Vorgang zu starten, wählen Sie Menü "Vorgänge > Zurücksetzen > Auf Werkseinstellungen zurücksetzen". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche [image] "Rücksetzen" und wählen Sie dann im Dropdown-Menü Option "Rücksetzen auf die Werkseinstellungen".

    Für fehlersichere CPUs zeigt das SIMATIC Automation Tool den Dialog "Programmaktualisierung" für eine zusätzliche Bestätigung an. Wählen Sie das Gerät, die Geräte oder alle Geräte aus, die auf Werkseinstellungen zurückgesetzt werden sollen.

  3. Klicken Sie auf die Schaltfläche "Fortfahren" im Dialog "Auf Werkseinstellungen zurücksetzen".

    Das SIMATIC Automation Tool setzt die ausgewählten Geräte auf die Werkseinstellungen zurück.

Hinweis

Durch das Rücksetzen auf Werkseinstellungen wird die SIMATIC SD Memory Card nicht gelöscht

Ist in einer CPU eine SIMATIC Memory Card vorhanden, wird diese durch das Rücksetzen auf Werkseinstellungen nicht gelöscht. Ist in einer CPU keine SIMATIC SD Memory Card vorhanden, wird durch das Rücksetzen auf Werkseinstellungen das Programm im internen Ladespeicher der CPU gelöscht.

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Auswirkung des Rücksetzens einer CPU auf die Werkseinstellungen auf die IP-Adresse

Vor der Rücksetzen einer CPU auf die Werkseinstellungen wird im STEP 7-Projekt in der CPU in der Gerätekonfiguration festgelegt, wie die IP-Adresse eingestellt wird. Für diese Einstellung gibt es folgende Optionen:

  • IP-Adresse im Projekt einstellen (oder ähnlich)

  • IP-Adresse wird direkt am Gerät festgelegt (oder ähnlich)

Außerdem hat möglicherweise ein anderer Benutzer die IP-Adresse des Geräts mit dem SIMATIC Automation Tool aktualisiert. In diesem Fall ist die benutzeraktualisierte IP-Adresse des Geräts in der CPU.

Die IP-Adresse nach dem Rücksetzen einer CPU auf die Werkseinstellungen und einem anschließenden Aus- und Wiedereinschalten der CPU hängt von mehreren Faktoren ab. Die folgende Tabelle beschreibt verschiedene Möglichkeiten für die IP-Adresse des Geräts.

IP-Adresse in der CPU | Besitzt die CPU eine SC Card? | IP-Adresse nach Programmaktualisierung | IP-Adresse nach Aus- und Wiedereinschalten der CPU nach dem Rücksetzen auf Werkseinstellungen
Gerätekonfiguration: IP-Adresse im Projekt einstellen | Ja | Die IP-Adresse ist die IP-Adresse des Projekts auf der SD Memory Card. | Die IP-Adresse ist die IP-Adresse des Projekts auf der SD Memory Card.
 | Nein | Die IP-Adresse ist die IP-Adresse des Geräts vor dem Rücksetzen auf Werkseinstellungen. | Die IP-Adresse ist die IP-Adresse des Geräts vor dem Rücksetzen auf Werkseinstellungen.
Temporäre IP-Adresse, zum Beispiel nach einem Vorgang IP-Adresse einstellen | Ja | Die IP-Adresse ist die IP-Adresse des Projekts auf der SD Memory Card. | Die IP-Adresse ist die IP-Adresse des Projekts auf der SD Memory Card.
 | Nein | Die IP-Adresse ist die IP-Adresse des Geräts vor dem Rücksetzen auf Werkseinstellungen. | Die IP-Adresse ist die IP-Adresse des Geräts vor dem Rücksetzen auf Werkseinstellungen.
Gerätekonfiguration: IP-Adresse wird direkt am Gerät festgelegt | -/- | Die IP-Adresse ist die IP-Adresse des Geräts vor dem Rücksetzen auf Werkseinstellungen. | Die IP-Adresse ist die IP-Adresse des Geräts vor dem Rücksetzen auf Werkseinstellungen.


Formatieren einer Memory Card

Formatieren einer Memory Card

SIMATIC SD Memory Cards werden in SIMATIC-Geräte gesteckt und unterstützen zahlreiche Funktionen. Je nach Gerätetyp oder -familie können eine Memory Card für folgende Zwecke verwendet werden:

  • Ladespeicher einer CPU

  • Speichermedium für ein Projekt

  • Firmware-Sicherungen und -Aktualisierungen

  • Speichermedium für den PROFINET-Gerätenamen

  • Übertragen von Projekten zwischen Geräten

  • Andere Dateien

Hinweis

Verwenden Sie zum Formatieren der SIMATIC Memory Card nur Siemens-Software

Wird eine SIMATIC Memory Card für SIMATIC-fremde Zwecke verwendet oder falsch formatiert, wird die interne Struktur der SIMATIC Memory Card überschrieben. Die Struktur ist nicht wiederherstellbar und die SIMATIC Memory Card kann für SIMATIC-Geräte dann nicht mehr verwendet werden.

Verwenden Sie die SIMATIC Memory Card nicht für SIMATIC-fremde Zwecke und formatieren Sie SIMATIC Memory Cards nicht mit fremden Geräten oder Windows-Tools.

Wenn Sie für die Kommunikation eine Linientopologie nutzen und in den Kommunikationseinstellungen Multithreading aktiviert ist, kann es bei diesem Vorgang zu einer Unterbrechung der Kommunikation kommen.

Warnung

Vergewissern Sie sich vor dem Formatieren einer Memory Card, dass das Gerät aktuell keinen Prozess ausführt.

Durch das Formatieren einer Memory Card geht die CPU in den Betriebszustand STOP, was sich auf den Betrieb eines Online-Prozesses oder einer Maschine auswirken kann. Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Zum Formatieren von SIMATIC Memory Cards in ausgewählten Geräten gehen Sie wie folgt vor:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Stellen Sie für jede ausgewählte CPU sicher, dass die Memory Card bereits in der CPU gesteckt ist und dass die CPU die Memory Card als externen Ladespeicher verwendet.

  3. Geben Sie für jede ausgewählte CPU ein Passwort in die Spalte "Passwort in CPU" ein.

  4. Um den Vorgang zu starten, wählen Sie Menü "Vorgänge > Zurücksetzen > Memory Card formatieren". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche "Rücksetzen" und wählen Sie dann im Dropdown-Menü der Schaltfläche Option "Memory Card formatieren".

  5. Klicken Sie im Dialogfeld "Memory Card formatieren" auf die Schaltfläche "Fortfahren".

Das SIMATIC Automation Tool formatiert die Speicherkarte der ausgewählten Geräte. Das Ereignisprotokoll zeigt die Ergebnisse des Vorgangs an. Überprüfen Sie ggf. den Diagnosepuffer auf CPU-Diagnosen nach der Formatierung. Zu gerätespezifischen Fragen lesen Sie die Benutzerdokumentation für das Gerät.

Hinweis

Fehlersichere Geräte

Wenn eine fehlersichere CPU geschützt ist, muss in der Spalte "Passwort in CPU" das Safety-Passwort für F-CPU eingegeben werden, um eine SIMATIC Memory Card in einem fehlersicheren Gerät zu formatieren.

Sie müssen dann eine zusätzliche Aufforderung bestätigen und Ihr Gerät erneut auswählen, wenn das Programm in der F-CPU ein Sicherheitsprogramm ist.

Bei fehlersicheren Geräten stellt das SIMATIC Automation Tool Anforderungen zum Formatieren der Memory Card in die Warteschlange für sicherheitsrelevante Vorgänge und lässt nur eine Single-Thread-Abarbeitung zu.

In diesem Beispiel formatiert das SIMATIC Automation Tool die Memory Cards der ausgewählten Geräte nach einem Klick auf die Schaltfläche "Fortfahren".

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Das Formatieren einer Memory Card hat keine Auswirkung auf die IP-Adresse des Geräts.


Abrufen von Servicedaten aus CPUs

Servicedatendateien

Abrufen von Servicedaten aus CPUs

Wenn eine CPU in einen Fehlerzustand geht, werden in der CPU Fehlerinformationen gespeichert, die Sie in Ihr Programmiergerät laden können. Sie können diese Servicedaten zur Diagnose an den Siemens Customer Support senden.

Servicedaten können Sie in den Betriebszuständen STOP oder RUN aus der CPU laden. Die Servicedaten enthalten mehrere Dateien, die zu einer einzigen ZIP-Datei komprimiert werden, deren Name auf dem PLC-Namen und der MAC-Adresse basiert. An den Dateinamen wird eine eindeutige Nummer angehängt, um doppelte Dateinamen zu vermeiden.

Sie können den Standardpfad für die Servicedaten konfigurieren oder aus den Einstellungen für Servicedaten übernehmen.

Gehen Sie wie folgt vor, um Servicedaten aus ausgewählten CPUs abzurufen:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Für jede ausgewählte CPU ist ggf. ein Passwort in der Spalte "Passwort in CPU" des aktuell geöffneten Registers einzugeben.

  3. Um den Vorgang zu starten, wählen Sie Menü "Vorgänge > Diagnose > Servicedaten abrufen". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche "Gerätediagnose anzeigen" [image] und wählen dann im Dropdown-Menü der Schaltfläche die Option "Servicedaten abrufen".

  4. Klicken Sie im Dialog "Servicedaten aus CPU laden" auf die Schaltfläche "Fortfahren".

Das SIMATIC Automation Tool lädt die Servicedaten aus den ausgewählten CPUs und speichert die Dateien im Ordner Servicedaten.

Beispiel:

Nach Klick auf die Schaltfläche "Fortfahren" lädt das SIMATIC Automation Tool die Servicedaten aus den ausgewählten Geräten.

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.

Servicedatendateien

Hinweis

Servicedatendateien von passwortgeschützten CPUs abrufen

Wenn eine CPU passwortgeschützt ist, müssen Sie ein Passwort für Lesezugriff oder vollständigen Zugriff angeben, damit die Servicedatendateien aus der CPU geladen werden können. Geben Sie die CPU-Passwörter in die Spalte "Passwort in CPU" des SIMATIC Automation Tool ein, bevor Sie den Befehl "Servicedaten abrufen" ausführen.

Beispiel für eine S7-1200 Servicedatendatei: PLC_1 00-1C-06-13-58-10.zip

Inhalt der .zip-Datei:

  • ResourceStats.txt

  • RAM.img

  • PLCInformation.txt

  • NAND.img

  • General.txt

  • Fault.bin

  • Fault2.bin

  • DNN.txt

  • CommBuffers.txt

  • ASLog.txt

  • Alarms.txt

S7‑1500 Servicedatendateien sind ähnlich. Sie enthalten eine Teilmenge der obigen Dateien.

Warnung

Servicedaten werden im Klartext angezeigt

Ein unbefugter Anwender könnte mithilfe der Servicedatendateien Informationen zum Status und zur Konfiguration des Leitsystems erlangen. Die Servicedatendateien werden in der CPU im Klartext (binäre Kodierung), also unverschlüsselt, gespeichert. Durch Vergabe eines CPU-Passworts kann der Zugriff auf diese Informationen kontrolliert werden.

Der Betrieb eines Prozesses oder einer Maschine mit manipulierten Daten kann sich auf den Betrieb eines Online-Prozesses oder einer Maschine auswirken. Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Richten Sie den CPU-Schutz über die Gerätekonfiguration des TIA Portals ein und vergeben Sie ein starkes Passwort. Starke Passwörter sind mindestens zehn Zeichen lang, bestehen aus Buchstaben, Zahlen und Sonderzeichen, sind keine Wörter, die in einem Wörterbuch gefunden werden können, und sind keine Namen oder Kennungen, die sich aus persönlichen Daten ableiten lassen. Halten Sie das Passwort geheim und ändern Sie es häufig.


Einstellen der Uhrzeit in CPUs auf die aktuelle Zeit des Programmiergeräts

Einstellen der Uhrzeit in CPUs auf die aktuelle Zeit des Programmiergeräts

Über die Schaltfläche "Uhrzeit" kann die Uhrzeit ausgewählter CPUs auf die aktuelle Zeit Ihres Programmiergeräts eingestellt werden. Zeitumrechnungsangaben hinsichtlich Zeitzone und Sommerzeit werden nicht geändert und müssen im TIA Portal-Projekt angepasst werden.

Warnung

Eine Änderung der CPU-Uhrzeit kann den Prozessbetrieb unterbrechen

Eine Änderung der CPU-Uhrzeit kann bei STEP 7-Programmen, die auf der Uhrzeit basierende Programmlogik ausführen, zu Prozessunterbrechung führen.

Unvorhersehbarer Betrieb eines Prozesses oder einer Maschine kann zu tödlichen oder schweren Verletzungen und/oder Sachschaden führen.

Vergewissern Sie sich, dass eine Änderung der Uhrzeit nicht unerwünschte Auswirkungen im STEP 7-Programm verursacht.

Zum Einstellen der CPU-Zeit benötigen Sie Schreibzugriff auf eine CPU.

Gehen Sie zum Einstellen der CPU-Zeit auf die Zeit des Programmiergeräts wie folgt vor:

  1. Wählen Sie ein oder mehrere Geräte aus, die in den Vorgang eingeschlossen werden sollen. Mit dem Kontrollkästchen für die Geräte oben in der Gerätetabelle können Geräte ausgewählt oder abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu den Optionen "Alle auswählen" und "Alle abwählen" gehen.

  2. Für jede ausgewählte CPU ist ggf. ein Passwort in der Spalte "Passwort in CPU" des aktuell geöffneten Registers einzugeben.

  3. Wählen Sie den Menübefehl "Vorgänge > Uhrzeit einstellen" oder klicken Sie auf die Schaltfläche "Uhrzeit der ausgewählten Geräte einstellen" in der Symbolleiste:

  4. Klicken Sie im Dialogfeld "Uhrzeit einstellen" auf die Schaltfläche "Fortfahren".

Das SIMATIC Automation Tool stellt die Systemzeit der ausgewählten Geräte auf die aktuelle Uhrzeit Ihres Programmiergeräts ein.

Im Ereignisprotokoll unterhalb der Gerätetabelle werden die Ergebnisse dieses Vorgangs angezeigt.


Anzeigen eines Diagnosepuffers

Beispiel-Diagnosepuffer
Kommunikationseinstellungen
Start Zurück Weiter

Anzeigen eines Diagnosepuffers

Ein CPU-Diagnosepuffer enthält zu jedem Diagnoseereignis einen Eintrag. Jeder Eintrag umfasst das Datum und die Uhrzeit, zu denen das Ereignis aufgetreten ist, eine Ereigniskategorie und eine Ereignisbeschreibung. Die Einträge werden im Diagnosepuffer in chronologischer Reihenfolge angezeigt, wobei das jüngste Ereignis an oberster Stelle steht. Ist der Puffer voll, wird immer das älteste Ereignis durch ein neues Ereignis überschrieben. Bei einer Unterbrechung der Stromversorgung werden die Ereignisse gespeichert.

Zum Anzeigen des Diagnosepuffers einer CPU benötigen Sie Lesezugriff oder Vollzugriff auf ihren Diagnosepuffer.

Gehen Sie wie folgt vor, um die Gerätediagnose anzuzeigen:

  1. Wählen Sie ein oder mehrere Geräte in der Gerätetabelle aus. Sollen zuerst alle Geräte abgewählt werden, kann das Kontrollkästchen für die Geräte oben in der Gerätetabelle abgewählt werden. Alternativ können Sie mit Rechtsklick das Kontextmenü öffnen oder über den Menübefehl "Bearbeiten > Auswählen" zu Option "Alle abwählen" gehen.

  2. Für jede ausgewählte CPU ist ggf. ein Passwort in der Spalte "Passwort in CPU" des aktuell geöffneten Registers einzugeben.

  3. Wählen Sie Menü "Vorgänge > Diagnose > Diagnose anzeigen". Alternativ klicken Sie in der Symbolleiste auf die Schaltfläche "Gerätediagnose anzeigen" [image] und wählen Sie dann im Dropdown-Menü der Schaltfläche die Option "Diagnose anzeigen".

Das SIMATIC Automation Tool zeigt dann einen Dialog an, der die Diagnosepuffer der ausgewählten CPUs enthält. Sie können eine CPU in der Geräteliste links auswählen, um den Diagnosepuffer dieser CPU zu sehen.

Hinweis

Der Diagnosepuffer zeigt die Ereignisse in der Reihenfolge ihres Auftretens an, unabhängig von Datum und Uhrzeit des Ereignisses. Die Einstellung der CPU-Zeit auf einen Uhrzeit in der Vergangenheit wirkt sich nicht auf die Reihenfolge der Ereignisse aus.

Beispiel-Diagnosepuffer

Der Diagnosepuffer enthält die folgenden Eintragsarten:

  • Systemdiagnoseereignis (jeder CPU-Fehler und Modulfehler)

  • CPU-Zustandsänderungen (jeder Hochlauf, Wechsel in STOP, Wechsel in RUN)

Sie können sich mithilfe des Kontrollkästchens "Zeitstempel des Geräts in Ortszeit PG/PC anzeigen" die Zeitstempel in der Ortszeit oder in UTC-Zeit (Coordinated Universal Time) anzeigen lassen.


Anzeigen von Gerätereferenzen

Anzeigen von Gerätereferenzen

Für jedes Gerät der obersten Ebene im Gerätekatalog oder für jedes Gerät in einem PROFINET IO-System können Sie alle Referenzen zu dem Gerät anzeigen. Das SIMATIC Automation Tool bietet den Menübefehl Referenzen anzeigen. Dieser Menübefehl ist verfügbar im Menü Bearbeiten oder im Kontextmenü der Gerätetabelle, wenn Sie ein Gerät der obersten Ebene oder ein Gerät in einem PROFINET IO-System auswählen.

Wenn Sie Referenzen anzeigen auswählen, zeigt das SIMATIC Automation Tool alle Referenzen zu dem Gerät an, das Sie anhand der Seriennummer des Geräts ausgewählt hatten. Falls notwendig, erweitert das SIMATIC Automation Tool die Gerätezeilen nach Bedarf, um Gerätereferenzen anzuzeigen:


Kopieren und Einfügen mehrerer Zellen in der Gerätetabelle

Einsatz der schnellen Kopier- und Einfügefunktion Kopieren und Einfügen mit inkrementierten Werten
Start Zurück Weiter

Kopieren und Einfügen mehrerer Zellen in der Gerätetabelle

Das SIMATIC Automation Tool macht es Ihnen leicht, den Inhalt einer Zelle in viele Zellen derselben Spalte zu kopieren. Wenn Sie zum Beispiel in vielen Geräten des gleichen Typs die Firmware aktualisieren möchten, können Sie die Datei "Neue Firmware-Version" einmal auswählen und die Auswahl durch Ziehen mit der Maus in die Zelle "Neue Firmware-Version" für die anderen Geräte kopieren.

Diese schnelle Kopier- und Einfügefunktion arbeitet als Editiervorgang innerhalb einer Spalte. Sie müssen den Kopierschritt nicht wiederholt in mehreren Zellen ausführen. Wie in Microsoft Excel können Sie mehrere Zellen für das Einfügen auswählen, indem Sie den Zeiger über eine Auswahl von Zellen ziehen. Das SIMATIC Automation Tool erkennt, welche Zellen für den Einfügevorgang gültig sind und welche Zellen nicht. Das SIMATIC Automation Tool fügt den kopierten Inhalt nur in gültige Zellen.

Die schnelle Kopier- und Einfügefunktion ist für jede der für Benutzereingaben vorgesehenen Spalten in der Gerätetabelle verfügbar.

Einsatz der schnellen Kopier- und Einfügefunktion

Betrachten Sie einen Fall, in dem Sie zahlreiche CPUs des gleichen Typs haben (wie S7-1200 1215C DC/DC/DC CPUs). Sie möchten alle diese CPUs auf die Firmware-Version V04.02.00 aktualisieren. Diese Version befindet sich in Ihrem Ordner für Firmware-Aktualisierungen. Ihre Gerätetabelle enthält auch CPUs anderer Typen. Sie möchten die "Neue Firmware-Version" nicht manuell in alle S7-1200 1215C DC/DC/DC CPUs kopieren, wobei Sie die anderen Geräte jeweils überspringen müssten.

Um für dieses Beispiel eine Zellenauswahl in mehrere Zellen zu kopieren, folgen Sie diesen Schritten:

  1. Wählen Sie die Neue Firmware-Version für eine Ihrer S7-1200 1215C DC/DC/DC CPUs, vielleicht die erste in Ihrer Liste.

  2. Wenn das SIMATIC Automation Tool zurückmeldet, dass Ihre Auswahl gültig ist, klicken Sie auf die Zelle "Neue Firmware-Version". Das SIMATIC Automation Tool zeigt ein Fokusrechteck für die Zelle an. Dies ist die Quellzelle für Ihren Kopiervorgang:

  3. Ziehen Sie die untere rechte Ecke des Fokusrechtecks durch die Spalte "Neue Firmware-Version". Wie Microsoft Excel zeigt auch das SIMATIC Automation Tool Ihnen, welche Zellen Sie in Ihr neues Fokusrechteck einbeziehen. Sie können wahlweise die gesamte Spalte auswählen oder nur wenige Zellen:

  4. Durch Loslassen der linken Maustaste kopieren Sie Ihre Auswahl in alle Zellen des neuen Fokusrechtecks, für das die ursprüngliche Auswahl gültig ist. In diesem Beispiel kopiert das SIMATIC Automation Tool den Inhalt der Zelle "Neue Firmware-Version V04.02.00" in die Zellen, die den S7-1200 1215C DC/DC/DC CPUs entsprechen. Das SIMATIC Automation Tool kopiert nur in CPUs des gleichen CPU-Typs und in CPUs, für die die Firmware-Aktualisierung gültig ist:

Sie können die schnelle Kopier- und Einfügefunktion für jede editierbare Spalte in der Gerätetabelle nutzen. Die Funktion spart Zeit bei zahlreichen Vorgängen, die das Kopieren einer Auswahl in mehrere Zielzellen erfordert, zum Beispiel:

  • Geräteauswahl

  • Sicherungsdateien

  • Kommentare

  • Firmware-Aktualisierungen

  • Gateway

  • Passwörter (CPU und Programmdatei)

  • Programmaktualisierungen

  • Rezepte

  • Subnetz

Kopieren und Einfügen mit inkrementierten Werten

Bei neuen IP-Adressen und neuen PROFINET-Namen inkrementiert die Kopier- und Einfügefunktion den kopierten Text beim Einfügen in die Zielzellen:

  • Bei neuen IP-Adressen wird jede Adresse in den eingefügten Zellen inkrementiert (+ 1).

  • Bei neuen PROFINET-Namen kopiert das SIMATIC Automation Tool den neuen PROFINET-Namen und ergänzt jeden Namen in den eingefügten Zellen um ein Zahleninkrement.

Hinweis

Ausgeblendete Zellen

Wenn Sie eine oder mehrere erweiterbare Zellenzeilen reduziert haben, werden beim Einfügevorgang auch die nicht sichtbaren Zellen gefüllt. Wenn Sie die reduzierten Zeilen erweitern, sehen Sie den eingefügten Inhalt.


Reihenfolge der Ausführung von Prozessen

Ausführungsbeispiele

Reihenfolge der Ausführung von Prozessen

Viele Menübefehle oder Symbolleistenvorgänge im SIMATIC Automation Tool erzeugen Diagnosepuffereinträge. Bei jedem Klick auf eine Schaltfläche in der Symbolleiste fügt das SIMATIC Automation Tool in der Warteschlange für jede ausgewählte Gerätezeile einen Vorgang hinzu. Wenn beispielsweise 20 verschiedene CPUs ausgewählt sind und auf die Schaltfläche RUN geklickt wird, wird die Warteschlange vom SIMATIC Automation Tool um 20 RUN-Prozesse ergänzt.

Zur Leistungsverbesserung können separate Threads unabhängig voneinander laufen, um die in der Warteschlange enthaltenen Prozesse zu initialisieren und auszuführen. Die Anzahl gleichzeitiger Vorgänge können Sie in den Kommunikationseinstellungen festlegen. Separate Threads dürfen Aufträge in einer CPU nicht gleichzeitig starten, um Situationen zu vermeiden, in denen ein Auftrag die CPU in die Betriebsart STOP und ein anderer Auftrag dieselbe CPU in die Betriebsart RUN versetzt. Ein Auftrag kann zum Beispiel die CPU nicht in STOP versetzen, während ein anderer Auftrag versucht, dieselbe CPU in RUN zu setzen.

Ausführungsbeispiele

Beispiel 1:

Wenn die Prozess-Warteschlange 10 Go-to-RUN-Aufträge für verschiedene CPUs enthält, arbeiten mehrere Threads parallel, um alle CPUs in die Betriebsart RUN zu versetzen. Da die Threads parallel ausgeführt werden, kann nicht garantiert werden, in welcher Reihenfolge die CPUs in die Betriebsart RUN gehen. Die Kommunikationsgeschwindigkeiten können je nach CPU unterschiedlich sein. Auch die Zeitdauer zur Ausführung eines Auftrags kann je nach CPU variieren.

Beispiel 2:

Sie können so viele Aufträge des gleichen Typs in die Warteschlange stellen, wie Sie möchten. Beispielsweise können Sie 100 CPUs in die Betriebsart STOP versetzen, indem Sie alle 100 CPUs auswählen und auf die Schaltfläche "STOP" klicken. Das SIMATIC Automation Tool zeigt so lange ein Dialogfeld mit einem Fortschrittsbalken an, bis alle 100 Aufträge abgeschlossen sind. Das SIMATIC Automation Tool blockiert so lange andere Vorgänge, bis alle STOP-Vorgänge abgeschlossen sind.


Verwalten von Projektdateien

Verwalten von Projektdateien

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Erzeugen, Speichern und Öffnen von SAT-Projektdateien
  • Exportieren von Informationen über das SIMATIC Automation Tool


Erzeugen, Speichern und Öffnen von SAT-Projektdateien

Erzeugen einer neuen Projektdatei Speichern einer Projektdatei Öffnen einer Projektdatei Richtlinien für das Speichern und Öffnen von Projektdateien Hinweise zum Übertragen einer SAT-Projektdatei von einem Programmiergerät zu einem anderen Sicherheit der .sat-Datei im SIMATIC Automation Tool Passwortüberprüfung Kompatibilität der Projektdateien mit Vorgängerversionen
Start Zurück Weiter

Erzeugen, Speichern und Öffnen von SAT-Projektdateien

Erzeugen einer neuen Projektdatei

Um eine neue Projektdatei mit einer leeren Gerätetabelle zu erzeugen, verwenden Sie den Menübefehl "Datei > Neu".

Speichern einer Projektdatei

Zum Speichern Ihres Projekts in einer verschlüsselten SAT-Projektdatei verwenden Sie den Menübefehl "Datei > Speichern" oder "Datei > Speichern unter" oder klicken auf die Schaltfläche "Speichern" [image]. Diese Projektdatei enthält Ihre Gerätetabelleninformationen. Die Projektdatei speichert nicht die Betriebsart des Geräts, den Auswahlstatus oder die Bestätigung von Auswahldaten.

Öffnen einer Projektdatei

Sobald Sie mit dem SIMATIC Automation Tool ein Projekt gespeichert haben, können Sie den Befehl "Datei > Öffnen" oder die Schaltfläche "Öffnen" [image] zum Wiederherstellen der Gerätetabelle dieses Projekts verwenden. Mit dem Befehl "Aktualisieren" können die Betriebszustände gelesen werden.

Richtlinien für das Speichern und Öffnen von Projektdateien

Beachten Sie beim Speichern und Öffnen von Projektdateien die folgenden Richtlinien:

  • Die Projekteinstellungen legen den Ordner zum Speichern von SAT-Projektdateien fest.

  • Zum Speichern einer .sat-Projektdatei im SIMATIC Automation Tool müssen Sie ein gültiges Passwort angeben.

  • Zum erneuten Öffnen einer vorhandenen .sat-Projektdatei im SIMATIC Automation Tool müssen Sie das korrekte Passwort eingeben.

Hinweise zum Übertragen einer SAT-Projektdatei von einem Programmiergerät zu einem anderen

Sie können ein im SIMATIC Automation Tool angelegtes Projekt auf einem Programmiergerät speichern und es dann auf einen anderen Computer übertragen, um es dort zu öffnen. Die SAT-Projektdatei enthält jedoch lediglich die Gerätetabelle und die konfigurierten Einstellungen aus dem Menü "Optionen". Zu den Einstellungen im Menü "Optionen" gehören die Speicherorte von Ordnern für unterschiedliche Vorgänge. Die Dateien in diesen Ordnern müssen Sie aus dem Quell-Programmiergerät in das Ziel-Programmiergerät übertragen, um folgende Vorgänge mit Geräten auszuführen:

  • Firmware-Aktualisierungen: Um die Firmware-Aktualisierungsdateien auf dem Ziel-Programmiergerät verfügbar zu haben, müssen Sie den Ordner für Firmware-Aktualisierungen übertragen.

  • Programmaktualisierung: Um die Programmaktualisierungsdateien auf dem Ziel-Programmiergerät verfügbar zu haben, müssen Sie den Programmaktualisierungsordner übertragen.

  • Servicedaten: Um auf Servicedaten zugreifen zu können, die Sie zuvor abgerufen haben, müssen Sie den Servicedatenordner übertragen.

  • Sichern/Wiederherstellen: Um Sicherungsdateien vom Quell-Programmiergerät für Wiederherstellungen auf dem Ziel-Programmiergerät verfügbar zu haben, müssen Sie den Sicherungs- und Wiederherstellungsordner übertragen.

  • Rezepte: Um die Rezeptdateien zum Laden auf dem Ziel-Programmiergerät verfügbar zu haben, müssen Sie den Rezeptordner übertragen.

  • Datenprotokolle: Um auf abgerufene Datenprotokolle zugreifen zu können, müssen Sie den Datenprotokollordner übertragen.

  • Ereignisprotokoll: Wenn Sie das Ereignisprotokoll gespeichert haben und es auf Ihrem Ziel-Programmiergerät verfügbar haben möchten, müssen Sie den Ereignisprotokollordner übertragen.

  • Exportieren: Um Inhalte aus Gerätetabellen-Dateien, die Sie aus dem SIMATIC Automation Tool exportiert haben, kopieren zu können, müssen Sie den Exportordner übertragen.

  • SNMP-Profile: Um die SNMP-Profile für SCALANCE-Geräte auf dem Ziel-Programmiergerät verfügbar zu haben, müssen Sie den SNMP-Profilordner übertragen.

Sicherheit der .sat-Datei im SIMATIC Automation Tool

Ihr Projekt müssen Sie mit einem Passwort schützen. Siemens empfiehlt, Ihr Projekt im SIMATIC Automation Tool mit einem starken Passwort zu schützen. Starke Passwörter halten folgende Regeln ein:

  • Mindestens zehn Zeichen lang

  • Kombination aus Buchstaben, Zahlen und Sonderzeichen

  • Kombination aus Groß- und Kleinbuchstaben

  • Keine Wörter, die in einem Wörterbuch zu finden sind

  • Keine Namen oder Kennungen, die sich aus persönlichen Daten ableiten lassen

Halten Sie das Passwort geheim und ändern Sie es häufig.

Zum Öffnen einer SAT-Datei müssen Sie das Passwort für das Projekt eingeben.

Passwortüberprüfung

Wenn Sie ein Projektpasswort erzeugen, weist das SIMATIC Automation Tool darauf hin, dass es sich um ein schwaches Passwort handelt, wenn eine der folgenden Bedingungen zutrifft:

  • Das Passwort ist kürzer als zehn Zeichen

  • Das Passwort enthält nicht mindestens eines der folgenden Elemente:

    • Großbuchstabe

    • Kleinbuchstabe

    • Ziffer

    • Sonderzeichen

Kompatibilität der Projektdateien mit Vorgängerversionen

Sie können eine Projektdatei V3.1 oder höher mit SIMATIC Automation Tool V3.1 SP4 ohne Datenverlust öffnen.

Das SIMATIC Automation Tool V3.1 und spätere Versionen unterstützen sicherheitsrelevante Vorgänge, die in der Version 3.0 und früheren Versionen verboten waren. SAT-Projektdateien der Version V3.0 oder früher enthalten keine Sicherheitsdaten in der Projektdatei. Wenn Sie eine Projektdatei einer der Versionen V2.x bis V3.0 öffnen, werden Sie vom SIMATIC Automation Tool darauf hingewiesen, dass Sie eine Netzwerkdurchsuchung durchführen müssen. Nach dem Durchsuchen öffnet das SIMATIC Automation Tool die Projektdatei und wendet die Projektdateidaten auf die Geräte an, die bei der Netzwerkdurchsuchung gefunden wurden.

V1.x-Projektdateien können nicht geöffnet werden.

Sie können ein Projekt der Version V3.1 SP4 nicht mit einer früheren Version des SIMATIC Automation Tool öffnen.


Exportieren von Informationen über das SIMATIC Automation Tool

Exportieren von Informationen über das SIMATIC Automation Tool

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Exportieren von Informationen über das SIMATIC Automation Tool
  • Exportieren von Geräteinformationen
  • Exportieren der Gerätediagnose
  • Exportieren von PC-Daten


Exportieren von Informationen über das SIMATIC Automation Tool

Exportieren von Informationen über das SIMATIC Automation Tool

Das SIMATIC Automation Tool beinhaltet Menübefehle zum Exportieren der folgenden Arten von Informationen:

  • Geräteinformationen aus der Gerätetabelle

  • Gerätediagnose

  • PC-Daten:

    • Informationen über das Programmiergerät, mit dem Sie das SIMATIC Automation Tool ausführen

    • Informationen über Siemens-Anwendungen, die auf Ihrem Programmiergerät installiert sind

Bei Geräteinformationen und Gerätediagnosedaten können Sie auswählen, ob die Daten für alle Geräte oder für ausgewählte Geräte exportiert werden sollen. Das SIMATIC Automation Tool speichert die Daten im CSV-Format.

Im Unterschied zu früheren Releases des SIMATIC Automation Tool ist bei diesem Release kein Importbefehl mehr verfügbar, mit dem die Gerätetabelle aus einer exportierten Datei befüllt werden kann. Dank der Flexibilität und individuellen Anpassung der Datei mit den exportierten Geräteinformationen können diese Informationen durch Kopieren und Einfügen in der Gerätetabelle wiederhergestellt werden.

Die Menübefehle für den Exportvorgang lauten wie folgt:

  • Datei > Exportieren > Geräteinformationen > Alle Geräte: Speichert die gesamte Gerätetabelle in einer CSV-Datei.

  • Datei > Exportieren > Geräteinformationen > Alle ausgewählten Geräte: Speichert die Gerätetabelle für die ausgewählten Geräte in einer CSV-Datei

  • Datei > Exportieren > Gerätediagnose > Alle Geräte: Speichert die Diagnosepufferdaten für alle infrage kommenden Geräte in einer CSV-Datei. Derzeit unterstützen CPU-Geräte den Export der Gerätediagnose.

  • Datei > Exportieren > Gerätediagnose > Alle ausgewählten Geräte: Speichert die Diagnosepufferdaten für die ausgewählten infrage kommenden Geräte in einer CSV-Datei.

  • Datei > Exportieren > PC-Daten > Lokaler PC: Speichert Informationen über Betriebssystem, Prozessor, Speicher, installierte Siemens-Anwendungen sowie andere Systeminformationen in einer ZIP-Datei.


Exportieren von Geräteinformationen

Format der CSV-Datei mit Geräteinformationen Kopieren und Einfügen als Alternative zum Exportieren Beispiel für den Export von Geräteinformationen IP-Adresskonflikte zwischen Netzwerk und exportierter CSV-Datei
Start Zurück Weiter

Exportieren von Geräteinformationen

Wenn Sie Geräteinformationen exportieren, erzeugt und speichert das SIMATIC Automation Tool eine CSV-Datei, in der die aktuellen Daten in der Gerätetabelle enthalten sind. Das SIMATIC Automation Tool führt keine erneute Netzwerkdurchsuchung durch und aktualisiert das Netzwerk nicht. Die Exportdatei enthält die aktuellen Daten aus der Gerätetabelle.

Wählen Sie zum Exportieren der Geräteinformationen einen der folgenden Menübefehle:

  • Datei > Exportieren > Geräteinformationen > Alle Geräte

  • Datei > Exportieren > Geräteinformationen > Alle ausgewählten Geräte

Die Zeilen in der CSV-Datei entsprechen Geräten, Ordnern von lokalen Modulen sowie Ordnern, falls vorhanden, von dezentralen Peripheriegeräten. Innerhalb des jeweiligen Zeilentyps weisen die Spaltenüberschriften auf die unterschiedlichen Datentypen innerhalb der Zeile hin.

In den Exporteinstellungen wird der Dateipfad für den Export der Gerätetabelle festgelegt.

Aus Sicherheitsgründen exportiert das SIMATIC Automation Tool keine CPU-Passwörter.

Sie können die CSV-Datei in Microsoft Excel oder in einem Texteditor öffnen und bearbeiten. Um die bearbeiteten Datei-Inhalte in das SIMATIC Automation Tool zu kopieren, müssen Sie das Format der Gerätetabelle beibehalten. Die Gerätetabelle im SIMATIC Automation Tool enthält Konfigurationsdaten für die Kommunikation. Wenn Sie falsche Informationen in die Zellen einer Gerätetabelle eingeben, können Vorgänge mit dem betreffenden Gerät fehlschlagen. Korrigieren Sie in diesem Fall die Gerätedaten und wiederholen Sie den Vorgang.

Format der CSV-Datei mit Geräteinformationen

Das Format der CSV-Datei mit Geräteinformationen entspricht der Struktur der Gerätetabelle. Die Datei mit Geräteinformationen ist wie folgt aufgebaut:

  • Kopfzeile: Die erste Zeile ist eine Kopfzeile, die die Namen der Spaltenüberschriften aus der Gerätetabelle enthält:

    • Gerät

    • Steckplatz

    • Gerätetyp

    • Artikelnummer

    • Seriennummer

    • Firmwareversion

    • Hardware

    • MAC-Adresse

    • IP-Adresse

    • Subnetz

    • Gateway

    • PROFINET-Name

    • Konvertierter PROFINET-Name

  • Gerätezeile: Jedes der Geräte aus der Gerätetabelle erscheint in einer eigenen Zeile der CSV-Datei; wobei die Gerätedaten auf die einzelnen Spalten verteilt sind. In der exportierten CSV-Datei sind alle Spalten der Gerätetabelle des SIMATIC Automation Tool enthalten. Auch wenn Sie im SIMATIC Automation Tool Spalten ausblenden, erscheinen die den ausgeblendeten Spalten entsprechenden Daten trotzdem in der CSV-Datei. Das Ausblenden von Spalten im SIMATIC Automation Tool hat keine Auswirkungen auf den Inhalt der CSV-Datei.

  • Zeile mit Ordnern von lokalen Modulen: Wenn ein Gerät über lokale Module verfügt, enthält die CSV-Datei eine Zeile "Lokale Module" mit den folgenden Spaltenüberschriften:

    • Gerät

    • Steckplatz

    • Gerätetyp

    • Artikelnummer

    • Seriennummer

    • Firmwareversion

    • Hardware

  • Zeile "Lokale Module": Jedes der lokalen Module erscheint in einer eigenen Zeile der CSV-Datei; wobei die Moduldaten auf die einzelnen Spalten verteilt sind. Die Moduldaten sind in der Datei verfügbar, wenn das SIMATIC Automation Tool die Moduldaten auslesen kann und die Daten in der Gerätetabelle sichtbar sind.

  • Zeilenüberschrift "Dezentrale Peripherie": Die Beschriftung "Dezentrale Peripherie" über einer Zeile weist darauf hin, dass die nachfolgenden Zeilen Angaben über Module der dezentralen Peripherie enthalten.

  • Kopfzeile für Ordner eines dezentralen Peripheriesystems: Eine Zeile für ein dezentrales Peripheriesystem enthält den Namen des dezentralen Peripheriesystems und die folgenden Spaltenüberschriften:

    • Gerät

    • Steckplatz

    • Gerätetyp

    • Artikelnummer

    • Seriennummer

    • Firmwareversion

    • Hardware

  • Zeilenüberschrift für dezentrales Peripheriegerät: Jedes der Geräte im dezentralen Peripheriesystem erscheint in einer eigenen Zeile, wobei die Gerätedaten auf die entsprechenden Spalten verteilt sind. Die Daten des dezentralen Peripheriegeräts sind in der Datei verfügbar, wenn das SIMATIC Automation Tool die Gerätedaten auslesen kann und die Daten in der Gerätetabelle sichtbar sind.

  • Zeile für Modul der dezentralen Peripherie: Jedes der Module für die einzelnen dezentralen Peripheriegeräte erscheint in einer eigenen Zeile, wobei die Moduldaten auf die entsprechenden Spalten verteilt sind. Die Moduldaten sind in der Datei verfügbar, wenn das SIMATIC Automation Tool die Moduldaten auslesen kann und die Daten in der Gerätetabelle sichtbar sind.

Eine Exportdatei mit Gerätedaten umfasst keine Datenprotokolle oder Rezepte, die in CPUs abgelegt sind.

Hinweis

CPU-Schutz und -Passwörter

Für geschützte CPUs in der Gerätetabelle exportiert das SIMATIC Automation Tool die Daten des lokalen Moduls und der dezentralen Peripherie für eine CPU nur dann, wenn in der Gerätetabelle ein CPU-Passwort vorhanden ist, das mindestens Lesezugriff ermöglicht.

Kopieren und Einfügen als Alternative zum Exportieren

Hinweis

Kopieren zwischen der Gerätetabelle und Microsoft Excel

Sie können ausgewählte Zellen wie folgt aus der Gerätetabelle kopieren und in eine Microsoft Excel-Tabelle einfügen:

  1. Erweitern Sie alle Zeilen in der Gerätetabelle mit dem Menübefehl "Bearbeiten >Erweitern > Alle Geräte".

  2. Markieren Sie mit Strg+A alle Zeilen und Spalten oder wählen Sie durch Ziehen mit dem Mauszeiger einen Zellenbereich aus.

  3. Kopieren Sie mit Strg-C die Daten der Gerätetabelle in die Windows-Zwischenablage.

  4. Fügen Sie die Daten aus der Zwischenablage mit Strg+V in ein Microsoft Excel Dokument ein.

Die Exportfunktion bietet die Möglichkeit, alle oder ausgewählte Geräte in einem lesbaren Format zu kopieren. Das Kopieren aus der Gerätetabelle ist normalerweise nicht notwendig, aber möglich. Sie können durch Kopieren und Einfügen beispielsweise von Benutzern eingegebene Geräteinformationen ändern.

Beispiel für den Export von Geräteinformationen

Wenn Sie eine Datei mit exportierten Geräteinformationen in Microsoft Excel öffnen, haben die Spalten eine feste Breite.

Um die Spaltenbreite zu vergrößern, sodass der Inhalt lesbar wird, gehen Sie wie folgt vor:

  1. Klicken Sie auf das kleine Dreieck in der linken oberen Ecke zwischen Zeile 1 und Spalte A, um das gesamte Arbeitsblatt auszuwählen.

  2. Klicken Sie in der Spaltenzeile (der obersten Zeile) von Microsoft Excel doppelt zwischen zwei beliebige Spalten, um die Spaltenbreite zu vergrößern. Klicken Sie beispielsweise auf die Trennlinie zwischen den Spalten A und B.

Die folgende Abbildung zeigt einen Export mit Geräteinformationen, der in Microsoft Excel bei vergrößerter Spaltenbreite geöffnet wurde:

Sie können die Daten in Microsoft Excel bearbeiten. Sie können auch zoomen, um den Inhalt besser lesbar zu machen. Achten Sie beim Hinzufügen oder Löschen von Zeilen darauf, dass das Format und die hierarchische Struktur erhalten bleiben. Wenn Sie Zellen in die Gerätetabelle im SIMATIC Automation Tool kopieren, gehen Sie wie folgt vor, um alle Geräte und Dateien anzuzeigen:

  1. Übertragen Sie durch Kopieren und Einfügen den gewünschten Zellenbereich aus Microsoft Excel in die Gerätetabelle.

  2. Wenn geschützte CPUs betroffen sind, geben Sie die CPU-Passwörter im SIMATIC Automation Tool erneut ein.

  3. Wählen Sie in der Gerätetabelle alle Geräte aus.

  4. Aktualisieren Sie die Gerätetabelle mit dem Menübefehl Vorgänge > Netzwerk durchsuchen > Status aller ausgewählten Geräte aktualisieren. Diesen Befehl können Sie auch über die Schaltfläche in der Symbolleiste ausführen.

Hinweis

Anzeigen von CSV-Dateien in Microsoft Notepad oder Microsoft Excel

Aufgrund unterschiedlicher Zeichensätze zeigen Microsoft Notepad und Microsoft Excel bestimmte Zeichen in Ihrer CSV-Datei möglicherweise nicht richtig an. Um Zeichen in Ihrer Sprache anzuzeigen, die ansonsten nicht sichtbar sind, öffnen Sie die Datei mit dem Zeichensatz Unicode (UTF-8). Unabhängig vom Erscheinungsbild von Kopfzeilen- und Überschriftstexten können Sie Projektdateien exportieren und Inhalte aus den exportierten Dateien in das SIMATIC Automation Tool kopieren.

IP-Adresskonflikte zwischen Netzwerk und exportierter CSV-Datei

Eine exportierte CSV-Datei können Sie in Microsoft Excel öffnen. Anschließend können Sie Gerätedaten aus Microsoft Excel kopieren und in die Gerätetabelle im SIMATIC Automation Tool einfügen. Unter den kopierten Daten kann auch ein Gerät an einer IP-Adresse sein, die mit der IP-Adresse eines anderen Geräts identisch ist, das sich aktuell in Ihrem Netzwerk befindet. Die Gerätetabelle zeigt jedoch das Gerät an, das sich aktuell in Ihrem Netzwerk an dieser IP-Adresse befindet.

Betrachten Sie hierfür folgendes Szenario:

  • Gegenwärtig haben Sie in Ihrem Netzwerk eine S7-1200 CPU mit dem Namen "PLC_1" an IP-Adresse X1: 192.168.2.202.

  • Sie kopieren Gerätedaten aus einer zuvor exportierten CSV-Datei mit Geräteinformationen, die folgende Zeilen enthält:

  • Sie fügen die kopierten Daten in die Gerätetabelle im SIMATIC Automation Tool ein.

  • Das Ereignisprotokoll meldet, dass der Vorgang für das Gerät SCALANCE-202 erfolgreich abgeschlossen wurde.

  • Die Gerätetabelle zeigt "PLC_1" an IP-Adresse X1: 192.168.2.202 an, nicht "SCALANCE-202". Die Gerätetabelle enthält alle Felder für PLC_1.

Ergebnis: Wenn beim Kopieren und Einfügen aus einer CSV-Datei ein IP-Adresskonflikt vorliegt, werden die Gerätedaten für ein derzeit im Netzwerk vorhandenes Gerät nicht überschrieben.


Exportieren der Gerätediagnose

Format der CSV-Datei mit der Gerätediagnose

Exportieren der Gerätediagnose

Wenn Sie Gerätediagnosedaten exportieren, erzeugt und speichert das SIMATIC Automation Tool eine CSV-Datei, die CPU-Diagnosepuffer enthält.

Wählen Sie zum Exportieren der Gerätediagnose einen der folgenden Menübefehle:

  • Datei > Exportieren > Geräteinformationen > Alle Geräte

  • Datei > Exportieren > Geräteinformationen > Alle ausgewählten Geräte

Format der CSV-Datei mit der Gerätediagnose

Die Diagnosepuffer für die exportierten Geräte befinden sich in einer einzigen CSV-Datei. Die Kopfzeilen trennen das Ende des Diagnosepuffers eines Geräts vom Anfang des Diagnosepuffers für das nächste Gerät.

Die Einträge für ein Gerät beginnen jeweils mit der Kopfzeile, die die folgenden Spaltenüberschriften enthält:

  • Gerät

  • Datum

  • Uhrzeit

  • Ereignistyp

  • Ereignis

  • Ereignisbeschreibung

Die Ereignisse des Diagnosepuffers belegen die darauffolgenden Zeilen der Datei und enthalten alle Ereignisse des aktuellen Diagnosepuffers für das Gerät.

Am Anfang der Einträge für das nächste Gerät steht wieder eine neue Kopfzeile. In den anschließenden Zeilen folgen die Ereignisse des Diagnosepuffers für das Gerät. Je nachdem, was Sie auswählen, enthält die Datei entweder Einträge für alle Geräte oder für alle ausgewählten Geräte.

Hinweis

Das Exportieren von Gerätediagnosen aus einer umfangreichen Gerätetabelle kann sehr lange dauern. Das SIMATIC Automation Tool zeigt während des Exportvorgangs einen Fortschrittsbalken an. Ein laufender Exportvorgang kann abgebrochen werden.


Exportieren von PC-Daten

Exportieren von PC-Daten

Das SIMATIC Automation Tool bietet die Fähigkeit, Informationen über Ihren PC und Dateien, die bei der Behebung von Fehlern/Problemen hilfreich sein können, zu exportieren. Wenn Sie PC-Daten exportieren, erzeugt und speichert das SIMATIC Automation Tool eine ZIP-Datei mit Detailinformationen zum Programmiergerät, auf dem Sie das SIMATIC Automation Tool ausführen. Sie können diese Informationen im Problemfall auf Anforderung an Siemens übermitteln.

Wählen Sie zum Exportieren von PC-Daten den Menübefehl Datei > Exportieren > PC-Daten > Lokaler PC. Das SIMATIC Automation Tool speichert die PC-Daten in der Datei im Exportordner.


Menüs, Symbolleisten, Tastenkombinationen und Referenzinformationen

Menüs, Symbolleisten, Tastenkombinationen und Referenzinformationen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hauptmenü
  • Symbole der Symbolleiste
  • Tastenkombinationen
  • Definition eines Sicherheitsprogramms
  • Programmausfälle beim SIMATIC Automation Tool


Hauptmenü

Hauptmenü

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Hauptmenü
  • Menü "File"
  • Menü "Edit"
  • Menü "Vorgänge"
  • Menü "Optionen"
  • Menü "Werkzeuge"
  • Menü Hilfe


Hauptmenü

Hauptmenü

Das SIMATIC Automation Tool bietet die folgenden Menüs für Geräte-Operationen.

  • Datei

  • Bearbeiten

  • Vorgänge

  • Optionen

  • Tools

  • Hilfe

Durch Drücken der Alt-Taste zeigt der unterstrichene Buchstabe an, welche Alt-Taste für die Aktivierung eines Menü- oder Untermenü-Befehls verwendet werden kann.

Zusätzlich können einige Menübefehle mit Tastenkombinationen aufgerufen werden.


Menü "File"

Menü "File"

Sym-
bol

Menübefehl

Beschreibung

Neu

Erstellen eines neuen SIMATIC Automation Tool-Projekts.

Öffnen

Anzeigen eines Dialogs "Öffnen", in dem Sie zu einem Ordner navigieren, eine SAT-Projektdatei auswählen und ein Passwort zum Öffnen einer verschlüsselten Projektdatei eingeben können. Dialog "Öffnen" zeigt den Projektordneran, ein Projekt kann jedoch auch an einem anderen Ort abgelegt werden.

Speichern

Speichern der Daten der Gerätetabelle in einer SAT-Datei. Falls kein Dateiname zugewiesen wurde, greift dieser Vorgang auf den Befehl "Speichern unter" zurück. Der Projektordner ist der Standardordner zum Speichern von Projekten.

Speichern unter

Speichern der Daten der Gerätetabelle in einer SAT-Datei. Sie können zu einem Ordner navigieren, einen SAT-Projektdateinamen angeben und ein Passwort zum Schutz der Projektdatei vergeben.

Exportieren

  • Geräteinformationen

    • Alle ausgewählten Geräte

Speichern der Gerätetabelle für die ausgewählten Geräte, einschließlich lokaler Module und dezentraler Peripherie, in einer CSV-Datei.

  • Geräteinformationen

    • Alle Geräte

Speichern der Gerätetabelle für alle Geräte, einschließlich lokaler Module und dezentraler Peripherie, in einer CSV-Datei.

  • Gerätediagnose

    • Alle ausgewählten Geräte

Speichern der Diagnosepufferdaten für die ausgewählten Geräte in einer CSV-Datei.

  • Gerätediagnose

    • Alle Geräte

Speichern der Diagnosepufferdaten für alle Geräte in einer CSV-Datei.

  • PC-Daten

    • Lokaler PC

Speichern der PC-Daten für das lokale Programmiergerät in einer ZIP-Datei.

Beenden

Schließen der Anwendung. Wenn das Projekt seit dem letzten Speichervorgang geändert wurde, gibt das SIMATIC Automation Tool Ihnen die Möglichkeit, das Projekt zu speichern.


Menü "Edit"

Menü "Edit"

Sym-
bol

Menü-
befehl

Beschreibung

Ausschneiden

Ausschneiden der ausgewählten Daten und Kopieren dieser Daten in die Zwischenablage. Die Einträge in der Zwischenablage sind mit Microsoft Excel kompatibel, sodass Daten zwischen den beiden Anwendungen ausgetauscht werden können. Schreibgeschützte Zellen werden nicht gelöscht.

Kopieren

Kopieren der ausgewählten Daten in einem Microsoft Excel-kompatiblen Format in die Zwischenablage.

Einfügen

Einfügen der in der Zwischenablage enthaltenen Daten in ein ausgewähltes Feld bzw. in ausgewählte Felder im SIMATIC Automation Tool. Schreibgeschützte Zellen werden nicht geändert.

Auswählen

  • Zeile(n) auswählen

Auswählen der Zeilen der Gerätetabelle, auf denen der Fokus steht.

  • Zeile(n) abwählen

Abwählen der Zeilen der Gerätetabelle, auf denen der Fokus steht.

Erweitern

  • Gerät

Erweitern des aktuellen Geräts

  • Alle ausgewählten Geräte

Erweitern aller ausgewählten Geräte

  • Alle Geräte

Erweitern aller Geräte- und Modulzeilen.

Reduzieren

  • Gerät

Reduzieren des aktuellen Geräts.

  • Alle ausgewählten Geräte

Reduzieren aller ausgewählten Geräte.

  • Alle Geräte

Reduzieren aller Geräte- und Modulzeilen.

Einfügen

  • Gerät

Einfügen einer neuen Gerätezeile in der ausgewählten Zeile und Verschieben der nachfolgenden Gerätezeilen nach unten. Mit diesem Befehl können Sie der Gerätetabelle schnell ein Gerät hinzufügen. Wenn Sie diesen Befehl zum Einfügen eines Geräts verwenden, das sich hinter einem Router befindet, wird der Gerätename blau dargestellt. Die blaue Kennzeichnung bedeutet, dass die auf MAC-Adressen basierenden Vorgänge (Gerät identifizieren, IP-Adresse einstellen und PROFINET-Namen einstellen) nicht möglich sind und die entsprechenden Zellen der Gerätetabelle deaktiviert sind.

Löschen

  • Zellentext

Löschen des aktuellen Zelleninhalts.

  • Gerät

Löschen des Inhalts der aktuellen Gerätezeile.

  • Alle ausgewählten Geräte

Löschen des Inhalts aller ausgewählten Geräte.

  • Alle Geräte

Löschen des Inhalts aller Gerätezeilen.

Aktualisieren

  • Gerät

Aktualisieren des aktuellen Geräts.

  • Alle ausgewählten Geräte

Aktualisieren aller ausgewählten Geräte.

  • Alle Geräte

Aktualisieren aller Geräte.

Referenzen anzeigen

Hervorheben aller Referenzen in der Gerätetabelle für das ausgewählte Gerät.

Das ausgewählte Gerät muss ein Gerät des oberen Bereichs in der Gerätetabelle oder ein Gerät in einem PROFINET IO-System sein.


Menü "Vorgänge"

Menü "Vorgänge"

Sym-
bol

Menü-
befehl

Beschreibung

Netzwerk durchsuchen

  • Gesamtes Netzwerk durchsuchen

Durchsuchen des Gerätenetzwerks.

  • Aktualisieren des Versionsstand aller ausgewählten Geräte

Aktualisieren ausgewählter Geräte in der Gerätetabelle.

RUN

Versetzen der ausgewählten CPUs in die Betriebsart RUN.

STOP

Versetzen der ausgewählten CPUs in die Betriebsart STOP.

Aktualisieren

  • IP-Adresse einstellen

Aktualisieren der CPU mit der IP-Adresse für das/die ausgewählte(n) Gerät(e).

  • PROFINET-Namen einstellen

Aktualisieren der CPU mit dem PROFINET-Namen für das/die ausgewählte(n) Gerät(e).

  • Programmaktualisierung

Aktualisieren des CPU-Programms oder des HMI-Betriebssystems und der Runtime Software für das/die ausgewählte(n) Gerät(e).

  • Firmware-Aktualisierung

Aktualisieren der Firmware für das (die) ausgewählte(n) Gerät(e).

Identifizieren

LED-Blinken an Geräten oder Blinken in HMI-Bildern.

Verwenden Sie diese Funktion zum physischen Lokalisieren eines Geräts.

Rücksetzen

  • Kommunikationsparameter zurücksetzen

Zurücksetzen der DCP-Kommunikationsparameter für Geräte, die den DCP-Rücksetzbefehl unterstützen.

  • Urlöschen

Urlöschen des Speichers ausgewählter Geräte.

  • Rücksetzen auf Werkseinstellungen

Rücksetzen ausgewählter Geräte auf die Werkseinstellungen.

  • Memory Card formatieren

Formatieren der Speicherkarte in ausgewählten Geräten.

Diagnose

  • Anzeigen der Diagnose

Anzeigen des Diagnosepuffers für eine ausgewählte CPU.

  • Servicedaten abrufen

Abrufen von Servicedaten für ausgewählte Geräte

Uhrzeit einstellen

Einstellen der Uhrzeit in ausgewählten CPUs auf die Zeit des Programmiergeräts.

Gerät sichern

  • Komplettsicherung

Sichern aller Daten für alle ausgewählten Geräte. Das SIMATIC Automation Tool speichert eine Sicherheitsdatei für jedes ausgewählte Gerät.

  • HMI

    • Rezepte

Sichern von HMI-Rezepten.

  • HMI

    • Benutzerverwaltung

Sichern der HMI-Benutzerverwaltungsdaten.

Gerät wiederherstellen

Wiederherstellen der Daten aus Sicherungsdateien für das/die ausgewählte(n) Gerät(e).

Dateivorgänge

Hinweis: Dateivorgänge betreffen nur CPU-Dateien.

  • Datenprotokolle aus CPU laden

Laden ausgewählter Datenprotokolldateien in Ihr Programmiergerät.

  • Datenprotokolle löschen

Löschen ausgewählter Datenprotokolldateien.

  • Rezepte aus CPU laden

Laden von Rezeptdateien aus den ausgewählten CPUs in Ihr Programmiergerät.

  • Rezept hinzufügen/ersetzen

Hinzufügen/Ersetzen von Rezeptdateien aus dem Programmiergerät in die ausgewählten CPUs.

Mit diesem Vorgang werden Rezepte hinzugefügt, sofern sie noch nicht vorhanden sind, bzw. bestehende Rezepte ersetzt.

  • Rezept löschen

Löschen ausgewählter Rezepte aus den entsprechenden CPUs.


Menü "Optionen"

Menü "Optionen"

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Menü "Optionen"
  • Pfadnamen im SIMATIC Automation Tool
  • Allgemeine Einstellungen
  • Kommunikationseinstellungen
  • Projekteinstellungen
  • Einstellungen für Firmware-Aktualisierungen
  • Einstellungen für Programmaktualisierungen
  • Einstellungen für Servicedaten
  • Einstellungen für Sichern/Wiederherstellen
  • Rezept-Einstellungen
  • Einstellungen für Datenprotokolle
  • Einstellungen für Ereignisprotokolle
  • Exporteinstellungen
  • SNMP-Profile


Menü "Optionen"

Menü "Optionen"

Menü "Optionen" enthält die folgenden Menübefehle:

Sym-
bol

Menü-
befehl

Beschreibung

Einstellungen

Öffnen des Einstellungsdialogs, in dem Standardeinstellungen für die folgenden Kategorien vorgenommen werden können.

  • Allgemein

  • Kommunikation

  • Projekte

  • Firmware-Aktualisierung

  • Programmaktualisierung

  • Servicedaten

  • Sichern / Wiederherstellen

  • Rezepte

  • Datenprotokolle

  • Ereignisprotokoll

  • Exportieren

  • SNMP-Profile

Bei den Gerätevorgängen, die Dateivorgänge enthalten, legen die Einstellungen den Namen des Standardpfads für den Vorgang fest.

Automation License Manager starten

Starten des Automation License Manager, mit dem das SIMATIC Automation Tool lizenziert werden kann


Pfadnamen im SIMATIC Automation Tool

Unterschied zwischen angezeigtem Pfad und der Navigation zu einem Ordner Windows 7 Windows 10
Start Zurück Weiter

Pfadnamen im SIMATIC Automation Tool

Die beispielhaften Pfadnamen für den Dialog "Optionen > Einstellungen" zeigen Pfadnamen von Ordnern in C:\Benutzer\MyAccount\SIMATIC Automation Tool\, wobei "MyAccount" für Ihre Benutzer-ID steht.

Der Menübefehl "Optionen > Einstellungen" liefert Standardpfade für die folgenden Dateispeicherorte:

  • Projekte

  • Firmware-Aktualisierung

  • Programmaktualisierung

  • Servicedaten

  • Sichern/Wiederherstellen

  • Rezepte

  • Datenprotokolle

  • Ereignisprotokoll

  • SNMP-Profile

Unterschied zwischen angezeigtem Pfad und der Navigation zu einem Ordner

Im Dialog "Einstellungen" werden z. B. Pfade so angezeigt, wie sie in den Einstellungen der Programmaktualisierung erscheinen:

Wenn mit der Durchsuchen-Funktion in der Gerätetabelle nach einer Datei wie z. B. einer Firmware-Aktualisierungsdatei oder einer Programmaktualisierungsdatei gesucht wird, sehen Sie Ihre Benutzer-ID nicht als Ordner unter "Benutzer". Stattdessen sehen Sie bei Verwendung von Windows 7 den Ordner "Meine Dokumente". Bei Verwendung von Windows 10 sehen Sie den Ordner "Dokumente". Wenn Sie diesen Ordner erweitern, sehen Sie den Ordner "SIMATIC Automation Tool".

Bei der Navigation in Windows 7 oder Windows 10 wird außerdem ein anderer Navigationspfad als der Pfadname im Dialog "Einstellungen" angezeigt.

Windows 7

Im Windows Explorer entspricht der Ordner Dokumente im Ordner Bibliotheken ebenfalls den Ordnern Meine Dokumente und "MyAccount".

Windows 10

Im Datei-Explorer entspricht der Ordner Dokumente unter Schnellzugriff ebenfalls den Ordnern "Dokumente" und "MyAccount".


Allgemeine Einstellungen

Allgemeine Einstellungen

Sie können die Sprache der Benutzeroberfläche auswählen: Englisch, Deutsch, Französisch, Spanisch, Italienisch oder Chinesisch

Aktivieren Sie das Kontrollkästchen, um nicht unterstützte Geräte beim Durchsuchen des Netzwerks anzuzeigen. Das SIMATIC Automation Tool zeigt nicht unterstützte Geräte in der Gerätetabelle in Grau als deaktiviert an.

Ist das Kontrollkästchen abgeklickt, werden nicht unterstützte Geräte in der Gerätetabelle durch das SIMATIC Automation Tool ausgefiltert.

Hinweis

Bei Änderung der Sprache der Benutzeroberfläche wird das Ereignisprotokoll gelöscht

Wenn Sie die Spracheinstellung der Benutzeroberfläche ändern, löscht das SIMATIC Automation Tool das Ereignisprotokoll.

Hinweis

Durchsuchen des Netzwerks zum Aktualisieren von Ordnernamen

Wenn Sie die Spracheinstellung der Benutzeroberfläche ändern, wird für Ordnernamen in der Gerätetabelle die zuvor eingestellte Sprache beibehalten. Durchsuchen Sie das Netzwerk, um Ordnernamen auf die neue Sprache der Benutzeroberfläche zu aktualisieren.


Kommunikationseinstellungen

Verwenden mehrerer Threads für Vorgänge Einstellen des HMI-Übertragungskanals
Start Zurück Weiter

Kommunikationseinstellungen

Mit den Kommunikationseinstellungen können Optionen für Multithreading und HMI-Kommunikation eingestellt werden.

Verwenden mehrerer Threads für Vorgänge

Wenn Ihr Netzwerk eine Sterntopologie hat, bei der jede CPU eine direkte Verbindung zum Programmiergerät über einen Ethernet-Switch unterhält, können Sie die Multithread-Option problemlos verwenden.

Falls Ihr Netzwerk eine Linientopologie besitzt, ist diese Option zu deaktivieren, damit eine CPU die Kommunikation mit anderen Geräten nicht unterbricht. Eine Linientopologie hätte zum Beispiel Linienverbindungen vom Programmiergerät zur CPU 1, zur CPU 2, zur CPU 3 und weiteren Geräten.

Beispiel: Linientopologie

Beim Multithreading wird von einem Thread, der einen Neustart von CPU 1 bewirkt, ein laufender Vorgang für CPU 2 bzw. jede andere CPU in der Kette unterbrochen. Beachten Sie, dass eine Linientopologie auch bei CM- und CP-Modulen implementiert werden kann.

Gleichzeitige Vorgänge

Die Leistung des SIMATIC Automation Tool kann gesteigert werden, indem zugelassen wird, dass Vorgänge auf mehreren Geräten gleichzeitig in mehreren Threads auftreten.

Hinweis

Kommunikationsprobleme mit dem SIMATIC Automation Tool

Beispielsweise senden Sie einen Befehl an mehrere Geräte, aber ein Gerät schließt den Vorgang nicht ab, und dieses Gerät meldet einen Kommunikationsfehler. Die anderen Geräte kommunizieren und führen den Vorgang jedoch wie erwartet aus. Wenn dieses Problem auftritt, senken Sie die Anzahl gleichzeitiger (Threads/Verbindungen). Schließen Sie das SIMATIC Automation Tool und öffnen Sie die Anwendung erneut. Wiederholen Sie anschließend die Gruppenfunktion.

Timeout für Kommunikationsvorgänge

Wenn Sie einen Befehl für einen Vorgang an ein Gerät senden und die Verbindung eine sehr langsame Datenübertragungsrate hat, wird Ihnen möglicherweise ein Timeout-Fehler für die Kommunikation angezeigt. Wenn dieses Problem auftritt, erhöhen Sie den Zeitverzögerungswert für Kommunikationsvorgänge.

Einstellen des HMI-Übertragungskanals

Das SIMATIC Automation Tool kann über PN/IE oder Ethernet mit HMI-Geräten kommunizieren. Wählen Sie in den Kommunikationseinstellungen für das SIMATIC Automation Tool die gleiche Einstellung wie in den Dateiübertragungseinstellungen Ihres HMI-Geräts. Ethernet ermöglicht höhere Kommunikationsgeschwindigkeiten.


Projekteinstellungen

Projekteinstellungen

Sie können den Standardpfad übernehmen, um Projektdaten des SIMATIC Automation Tools zu speichern, oder Sie können einen neuen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben, und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.


Einstellungen für Firmware-Aktualisierungen

Einstellungen für Firmware-Aktualisierungen

Sie können den Standardpfad für Firmware-Aktualisierungsdateien übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben, und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.

Klicken Sie auf das Kontrollkästchen, um eine Firmware-Aktualisierung mit der gleichen Firmware-Version zu gestatten bzw. nicht zu gestatten. Wird der Ersatz einer identischen Firmware-Version nicht gestattet, so spart dies Verarbeitungszeit, da unnötige Vorgänge verhindert werden.


Einstellungen für Programmaktualisierungen

Einstellungen für Programmaktualisierungen

Sie können den Standardpfad für Programmdateien übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben, und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.


Einstellungen für Servicedaten

Einstellungen für Servicedaten

Sie können den Standardpfad für Servicedatendateien übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.


Einstellungen für Sichern/Wiederherstellen

Einstellungen für Sichern/Wiederherstellen

Sie können den Standardpfad für Sicherungs- und Wiederherstellungsdateien übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.


Rezept-Einstellungen

Rezept-Einstellungen

Sie können den Standardpfad für Rezeptdateien übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.


Einstellungen für Datenprotokolle

Einstellungen für Datenprotokolle

Sie können den Standardpfad für Datenprotokolldateien übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.


Einstellungen für Ereignisprotokolle

Einstellungen für Ereignisprotokolle

Standardmäßig wird mit jedem neuen Gerätevorgang das Ereignisprotokoll am Anfang des Vorgangs durch das SIMATIC Automation Tool gelöscht. Die Option "Vor jedem Vorgang das Protokoll löschen" kann abgewählt werden, um die Standardeinstellung zu deaktivieren.

Wenn das Kontrollkästchen "Ereignisse automatisch der Ereignisprotokolldatei hinzufügen und speichern" aktiviert ist, können Sie den Standardpfad übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers. Das SIMATIC Automation Tool speichert dann jede Meldung im Ereignisprotokollfenster in der Datei "EventLogFile.csv". Wenn Sie das SIMATIC Automation Tool schließen und erneut öffnen, wird die Protokollierung im Ereignisprotokoll automatisch fortgesetzt.

Sie können den Inhalt des Ereignisprotokolls über die Schaltfläche "Protokoll löschen" löschen. Dadurch wird der Inhalt der Datei gelöscht, nicht jedoch die Datei selbst.


Exporteinstellungen

Exporteinstellungen

Sie können den Standardpfad für die Speicherung von Exportdateien übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben, und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.


SNMP-Profile

Hinzufügen eines SNMP-Profils Ändern eines SNMP-Profils Löschen eines SNMP-Profils Übernehmen sämtlicher hinzugefügter, geänderter und gelöschter Profile
Start Zurück Weiter

SNMP-Profile

Um über das SIMATIC Automation Tool mit SCALANCE-Geräten in Ihrem Netzwerk zu kommunizieren, müssen Sie die SNMP-Profile der Geräte konfigurieren. Weitere Informationen zur SNMP-Konfiguration finden Sie in der Dokumentation Ihrer SCALANCE-Geräte. Wenn Sie viele SCALANCE-Geräte in Ihrem Netzwerk haben, erleichtert Ihnen das SIMATIC Automation Tool das Speichern der SNMP-Profile, die Sie für mehrere Geräte verwenden.

Sie müssen einen TFTP-Server (Trivial File Transfer Protocol) zur Verfügung stellen, um Firmware in SCALANCE-Geräten zu installieren.

Sie können den Standardpfad für die Speicherung der SNMP-Profildatei übernehmen oder einen anderen Pfad festlegen.

Ihr Pfad hat möglicherweise einen anderen Laufwerksbuchstaben, und "MyAccount" steht für den Anmeldenamen des aktuellen Benutzers.

Das SIMATIC Automation Tool unterstützt die folgenden SNMP-Profile:

  • Version 1: Definiert in RFC (Request For Comments) für SNMPv1 von der Internet Engineering Task Force (IETF) und einer von zwei historischen SNMP-Standards

  • Version 2: Definiert in RFC (Request For Comments) für SNMPv2 von der Internet Engineering Task Force (IETF) und das zweite von zwei historischen SNMP-Standards

  • Version 3: Definiert in RFC (Request For Comments) für SNMPv3 von der Internet Engineering Task Force (IETF) und die Version, die von der IETF für das Internet-Management empfohlen wird

Weitere Informationen zu SNMP-Protokollen finden Sie auf der Website von SNMP Research International, Inc. (nur in Englisch).

Hinzufügen eines SNMP-Profils

Um ein SNMP-Profil hinzuzufügen, gehen Sie folgendermaßen vor:

  1. Klicken Sie in den Einstellungen für SNMP-Profile auf die Schaltfläche "Hinzufügen", um ein SNMP-Profil hinzuzufügen.

  2. Geben Sie einen Namen für Ihr Profil ein.

  3. Geben Sie die IP-Adresse des TFTP-Servers ein.

  4. Geben Sie die Server-Portnummer ein oder wählen Sie die Portnummer aus.

  5. Wählen Sie in der Klappliste die Versionsnummer aus.

SNMP-Profil Version 1 oder Version 2 | SNMP-Profil Version 3

Bei einem Profil der Version 1 oder Version 2 gehen Sie folgendermaßen vor:

  1. Geben Sie die Lese-Community ein oder übernehmen Sie den Standardwert.

  2. Geben Sie die Schreib-Community ein oder übernehmen Sie den Standardwert.

Bei einem Profil der Version 3 gehen Sie folgendermaßen vor:

  1. Geben Sie einen Benutzernamen ein.

  2. Geben Sie einen Kontextnamen ein.

  3. Wählen Sie in der Klappliste eine Schutzstufe aus:

    • NoAuth, NoPriv: Kommunikation ohne Authentifizierung und ohne Datenschutz

    • Auth, NoPriv: Kommunikation mit Authentifizierung und ohne Datenschutz

    • Auth, Priv: Kommunikation mit Authentifizierung und Datenschutz

Bei einem Profil der Version 3 mit Authentifizierung konfigurieren Sie die folgenden Felder für die Authentifizierung:

  • Algorithmus für die Authentifizierung: Wählen Sie eine Option in der Klappliste aus.

  • Passwort für die Authentifizierung:

Bei einem Profil der Version 3 mit Datenschutz konfigurieren Sie die folgenden Felder für den Datenschutz:

  • Algorithmus für den Datenschutz: Wählen Sie eine Option in der Klappliste aus.

  • Passwort für den Datenschutz

Nach der Konfiguration der Profilinformationen klicken Sie im Dialog "Hinzufügen" auf "OK", um das Profil zu speichern. Das SIMATIC Automation Tool überprüft Ihre Auswahl und informiert Sie, sollten Felder gar nicht oder unvollständig ausgefüllt sein. Klicken Sie auf "Abbrechen", wenn Sie das Profil nicht speichern möchten.

Hinweis

Sie können bis zu 25 SNMP-Profile hinzufügen.

Ändern eines SNMP-Profils

Um ein vorhandenes Profil zu ändern, gehen Sie folgendermaßen vor:

  1. Wählen Sie das SNMP-Profil aus, das Sie ändern möchten.

  2. Klicken Sie auf die Schaltfläche "Ändern".

  3. Ändern Sie im Dialog "Ändern" die gewünschten Felder.

Nachdem Sie die Änderungen durchgeführt haben, klicken Sie im Dialog "Ändern" auf "OK", um das Profil zu speichern. Das SIMATIC Automation Tool überprüft Ihre Auswahl und informiert Sie, sollten Felder gar nicht oder unvollständig ausgefüllt sein. Klicken Sie auf "Abbrechen", wenn Sie das geänderte Profil nicht speichern möchten.

Löschen eines SNMP-Profils

Um ein SNMP-Profil zu löschen, gehen Sie folgendermaßen vor:

  1. Wählen Sie das zu löschende SNMP-Profil aus.

  2. Klicken Sie auf die Schaltfläche "Löschen".

  3. Bestätigen Sie, dass Sie das Profil löschen möchten. Das SIMATIC Automation Tool informiert Sie, ob das Profil verwendet wird.

Übernehmen sämtlicher hinzugefügter, geänderter und gelöschter Profile

Klicken Sie im Dialog der SNMP-Profileinstellungen auf "OK", um alle vorgenommenen Änderungen zu übernehmen. Das SIMATIC Automation Tool speichert die Profile in der Datei im Ordner der SNMP-Profile.

Klicken Sie auf "Abbrechen", um alle Ihre Änderungen zu verwerfen.


Menü "Werkzeuge"

Menü "Werkzeuge"

Menü "Werkzeuge"

Menü "Werkzeuge"

Menü "Werkzeuge" kann auch über das Symbol [image] in der Symbolleiste geöffnet werden.

Sym- bol | Menü- befehl | Beschreibung
 | Nach Firmware-Aktualisierungen suchen | Suchen nach Firmware-Aktualisierungen für ein einzelnes ausgewähltes Gerät. Das SIMATIC Automation Tool zeigt die Webseite mit Firmware-Aktualisierungsdateien für das ausgewählte Gerät an.
 | Firmware-Aktualisierungsdateien vorladen | Suchen nach Firmware-Aktualisierungsdateien im Firmware-Aktualisierungsordner Das SIMATIC Automation Tool lädt dann die Firmware-Aktualisierungsdateien vorab in die Spalte "Neue Firmwareversion" für alle Geräte. Das Tool lädt eine Aktualisierungsdatei nur dann, wenn es sich bei der Datei um eine neuere Version handelt als die Version im Gerät. Das SIMATIC Automation Tool lädt die neueste entsprechende Datei, die es finden kann.


Menü Hilfe

Menü Hilfe

Symbol

Menübefehl

Beschreibung

Benutzerhandbuch anzeigen

Öffnen des Benutzerhandbuchs für das SIMATIC Automation Tool.

Gerätekatalog anzeigen

Anzeigen einer schreibgeschützten Tabelle der Geräte im Microsoft Excel-Format.

Zum Anzeigen der Datei benötigen Sie Microsoft Excel auf Ihrem Gerät.

Über SIMATIC Automation Tool

Anzeigen von Informationen zu:

  • Produktname

  • Version

  • Lizenzinformationen

  • Schaltfläche für die Suche nach Aktualisierungen für das SIMATIC Automation Tool.


Symbole der Symbolleiste

Symbole der Symbolleiste

Sym-
bol

Beschreibung

Neu: Erstellen eines neuen SIMATIC Automation Tool-Projekts mit der Dateinamenerweiterung "*.sat".

Öffnen: Anzeigen des Dialogs "Öffnen", in dem Sie zu einem Ordner navigieren, eine .sat-Projektdatei auswählen und ein Passwort zum Öffnen einer verschlüsselten Projektdatei eingeben können.

Speichern der geöffneten Projektdaten in einer Datei. Falls weder Dateiname noch Passwort zugewiesen wurden, wird der Dialog "Speichern unter" angezeigt.

Ausschneiden der ausgewählten Daten und Kopieren dieser Daten in die Zwischenablage. Die Daten in der Zwischenablage sind mit Microsoft Excel kompatibel, sodass Daten zwischen den beiden Anwendungen ausgetauscht werden können.

Kopieren der ausgewählten Daten in die Zwischenablage.

Einfügen der in der Zwischenablage enthaltenen Daten in das ausgewählte Feld bzw. in die ausgewählten Felder.

Durchsuchen des ausgewählten Netzwerks mit den folgenden Optionen:

  • Durchsuchen der ausgewählten Netzwerkschnittstelle auf erreichbare CPUs und Module.

  • Aktualisieren des Status aller Geräte in der Gerätetabelle.

RUN: Versetzen der ausgewählten CPUs in die Betriebsart RUN.

STOP: Versetzen der ausgewählten CPUs in die Betriebsart STOP.

Aktualisieren der Geräte mit Daten aus dem SIMATIC Automation Tool für eine der folgenden Optionen:

  • IP-Adresse einstellen

  • PROFINET-Name einstellen

  • Programmaktualisierung

  • Firmware-Aktualisierung

Sie müssen die entsprechenden Register in der Gerätetabelle auswählen, um die zu aktualisierenden Daten einzugeben.

Identifizieren von Geräten durch blinkende LEDs oder HMI-Bilder auf ausgewählten Geräten. Verwenden Sie diese Funktion zum physischen Lokalisieren eines Geräts.

Rücksetzfunktionen für ausgewählte Geräte:

  • Urlöschen des Speichers

  • Rücksetzen auf Werkseinstellungen

  • Formatieren der Memory Card

Zugriff auf Diagnoseinformationen:

  • Anzeigen der Diagnose

  • Servicedaten von ausgewählten Geräten abrufen

Einstellen der Uhrzeit: Einstellen der Systemzeit ausgewählter CPUs auf die aktuelle Zeit des Programmiergeräts.

Sichern und Wiederherstellen:

  • Erstellen von Sicherungsdateien für ausgewählte CPUs und HMI-Geräte.

  • Wiederherstellen ausgewählter Geräte aus Sicherungsdateien

Dateivorgänge:

  • Datenprotokolle laden oder löschen

  • Rezepte laden, hinzufügen, ersetzen oder löschen

Zum Löschen muss sich die CPU im Betriebszustand STOP befinden.

Nach Firmware-Aktualisierungen suchen oder Firmware-Aktualisierungsdateien vorab laden

Klappliste der Netzwerkschnittstelle: Auswählen der Ethernet-Netzwerkschnittstelle, die mit dem Industriesteuerungsnetzwerk verbunden ist.


Tastenkombinationen

Tastenkombinationen

Das SIMATIC Automation Tool unterstützt die folgenden Tastenkombinationen für das Navigieren in der Gerätetabelle und einige Menübefehle.

STRG+Bild auf | Umschalten zwischen Registern, rechts nach links
STRG+Bild ab | Umschalten zwischen Registern, links nach rechts
STRG+A | Auswählen der gesamten Tabelle
STRG+C | Kopieren der Auswahl in die Zwischenablage
STRG+N | Erstellen eines neuen SIMATIC Automation Tool-Projekts.
STRG+O | Anzeigen des Dialogs "Projekt öffnen" zum Öffnen einer neuen Projektdatei
STRG+S | Anzeigen des Dialogs "Speichern unter"
STRG+V | Einfügen der Inhalte aus der Zwischenablage am Einfügepunkt und Ersetzen der Auswahl
STRG+X | Ausschneiden der ausgewählten Zellen
STRG+Z | Rückgängig machen des letzten Bearbeitungs- oder Löschvorgangs
PFEILTASTEN | Eine Zelle nach oben, unten, links oder rechts navigieren
UMSCHALT+PFEILTASTEN | Erweitern der Auswahl
LÖSCHEN | Entfernen der Inhalte der aktiven Zelle
EINGABE | Abschließen der Zellenbearbeitung und Validieren der Daten
ESC | Abbrechen der Zellenbearbeitung und Wiederherstellen des ursprünglichen Zellenwerts
POS1 | Zum Anfang einer Zeile navigieren
STRG+POS1 | Zum Anfang der Tabelle navigieren
ENDE | Zum Ende einer Zeile navigieren
STRG+ENDE | Zum Ende der Tabelle navigieren
BILD AB | In der Tabelle einen Bildschirm nach unten navigieren
BILD AUF | In der Tabelle einen Bildschirm nach oben navigieren
LEERTASTE | Kontrollkästchen für das Gerät auswählen oder löschen
TAB | Eine Zelle nach rechts navigieren
F5 | Aktualisieren aller ausgewählten Geräte
Alt+F4 | Beenden


Definition eines Sicherheitsprogramms

Definition eines Sicherheitsprogramms

Ein Sicherheitsprogramm ist ein Programm, das in STEP 7 angelegt wird und das Sicherheitsbausteine enthält. Wenn STEP 7 Safety Advanced installiert ist, enthält der Ordner mit den Programmbausteinen automatisch die Sicherheitsbausteine, wenn eine fehlersichere CPU im STEP 7-Projekt hinzugefügt wird. Wird dieses Programm in eine fehlersichere CPU geladen, ist es ein Sicherheitsprogramm.


Programmausfälle beim SIMATIC Automation Tool

Senden von Informationen, wenn Sie keinen E-Mail-Client haben
Start Zurück Weiter

Programmausfälle beim SIMATIC Automation Tool

In seltenen Fällen kann es bei der Software SIMATIC Automation Tool zu einem unerwarteten Fehler kommen. Wenn ein solcher Fehler auftritt, zeigt das SIMATIC Automation Tool ein Dialogfeld an. Siemens bittet Sie, in diesem Dialogfeld auf die Schaltfläche "Bericht senden" zu klicken, um die Servicedaten für den Fehler an Siemens zu senden. Das SIMATIC Automation Tool verwendet den Standard-E-Mail-Client auf Ihrem Programmiergerät zum Öffnen einer E-Mail, die im Textfeld den Inhalt der Servicedaten enthält. Der Empfänger ist helpline.sii@siemens.com. Sie können der E-Mail weitere Informationen oder weitere Empfänger hinzufügen. Anschließend müssen Sie auf "Senden" klicken, um die E-Mail abzusenden.

Wenn Sie möchten, können Sie in dem Fehlerdialog auch auf die Schaltfläche "Projekt speichern" klicken, um das SIMATIC Automation Tool-Projekt, in dem der Fehler aufgetreten ist, auf Ihrem Programmiergerät zu speichern.

Senden von Informationen, wenn Sie keinen E-Mail-Client haben

Wenn Ihr Programmiergerät keinen E-Mail-Client hat, können Sie die Servicedatendatei auf ein Gerät kopieren, von dem aus Sie E-Mails senden können. Um Servicedaten zu speichern, zu kopieren und an Siemens zu senden, gehen Sie wie folgt vor:

  1. Kopieren Sie die Datei "SATServiceData.txt" aus dem Servicedatenordner auf ein anderes Gerät.

  2. Senden Sie die Datei an helpline.sii@siemens.com.


SIMATIC Automation Tool API für .NET Framework

SIMATIC Automation Tool API für .NET Framework

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Einführung in API
  • API-Softwarelizenz und Versionskompatibilität
  • Entwickeln einer Benutzeroberflächenanwendung für fehlersichere Geräte und sicherheitsrelevante Vorgänge
  • Übersicht über die Architektur
  • Referenzieren der API in einer Benutzeroberflächenanwendung
  • Voraussetzungen für die S7-Kommunikation
  • Häufig zur Unterstützung verwendete Klassen
  • Allgemeine Support-Schnittstellen
  • Klasse Network
  • Klasse HealthCheck
  • Klasse IProfinetDeviceCollection
  • Schnittstelle IProfinetDevice
  • Klasse IModuleCollection und Moduleigenschaften
  • Schnittstelle ICPU
  • Die Schnittstelle ICPUClassic
  • IHMI-Schnittstelle
  • IScalance-Schnittstelle
  • ISNMPProfile-Schnittstelle
  • Codebeispiele für IScalance- und ISNMP-Firmware-Aktualisierungen
  • Ausnahmen
  • API-Enumerationen
  • Netzwerkbeispiel


Einführung in API

Einführung in API

Mit Hilfe der SIMATIC Automation Tool API können Sie mit einem umfangreichen Satz aus Schnittstellen, Klassen und Methoden des .NET Framework benutzerspezifische Anwendungen erzeugen. Mit Hilfe der API können Sie mit Geräten in einem Netzwerk kommunizieren. Sie können eine benutzerspezifische Anwendung so entwickeln, dass Vorgänge kombiniert und benutzerspezifische Abläufe im industriellen Automatisierungsnetzwerk unterstützt werden.


API-Softwarelizenz und Versionskompatibilität

API-Softwarelizenz und Versionskompatibilität

Softwarelizenz erforderlich ab V3.0

Sie benötigen eine gültige Lizenz für das SIMATIC Automation Tool, um mit der API (Anwendungsprogrammierschnittstelle) zu arbeiten.

Sie können die API für die Programmierung benutzerspezifischer Anwendungen einsetzen, nachdem Sie die folgenden Aufgaben erledigt haben:

  • Installation des lizenzierten SIMATIC Automation Tool

  • Einverständniserklärung mit den Lizenzbedingungen bei der Installation

Es ist nicht erlaubt, das SIMATIC Automation Tool einschließlich aller API .exe- oder .dll-Dateien ganz oder teilweise zu kopieren oder weiterzugeben.

Damit Sie Ihre benutzerspezifische Anwendung an einen Dritten weitergeben können, muss dieser Dritte ebenfalls über eine gültige Lizenz für das SIMATIC Automation Tool verfügen.

Kompatibilität mit Vorgängerversionen

Die API für V3.1 SP4 ist mit V3.1 und höheren Versionen kompatibel. Sie können alle API-Programme ausführen, die Sie mit der API Version 3.1 oder einer API eines Service Packs von V3.1 entwickelt haben. Aktualisieren oder überprüfen Sie die Referenzen Ihrer Lösung und erstellen Sie Ihre Anwendung erneut mit der API V3.1 SP4.

Die API für V3.1 und höhere Versionen ist nicht mit Versionen kompatibel, die älter sind als V3.1. Programme, die mit früheren Versionen als API V3.1 geschrieben wurden, müssen neu geschrieben werden.


Entwickeln einer Benutzeroberflächenanwendung für fehlersichere Geräte und sicherheitsrelevante Vorgänge

Entwickeln einer Benutzeroberflächenanwendung für fehlersichere Geräte und sicherheitsrelevante Vorgänge

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • API-Unterstützung für sicherheitsrelevante Vorgänge und fehlersichere Geräte
  • Programmierrichtlinien für Benutzeroberflächen für sicherheitsrelevante Vorgänge
  • Farbkennzeichnung von Sicherheitsfeldern in ihrer Benutzeroberfläche
  • Hamming-Codes


API-Unterstützung für sicherheitsrelevante Vorgänge und fehlersichere Geräte

Sicherheitsmerkmale der API

API-Unterstützung für sicherheitsrelevante Vorgänge und fehlersichere Geräte

Die API des SIMATIC Automation Tool unterstützt die folgenden sicherheitsrelevanten Vorgänge:

  • Programmaktualisierung

  • Wiederherstellen des Geräts aus einer Sicherungsdatei

  • Rücksetzen auf Werkseinstellungen

  • Memory Card formatieren

Hinweis

Das Handbuch "SIMATIC Safety - Projektieren und Programmieren" enthält einen Warnhinweis "S078". Dieser Warnhinweis lautet sinngemäß: "Bei Verwendung von Tools zur Automatisierung/Bedienung von Benutzeroberflächen (z. B. TIA Portal, Webserver), die die Umgehung des Zugriffsschutzes zur F-CPU (z. B. durch Speichern oder automatische Eingabe eines CPU-Passworts für die Schutzstufe "Vollzugriff inkl. Fail-safe (kein Schutz)" oder eines Webserver-Passworts) ermöglichen, kann es dazu kommen, dass die sicherheitsrelevanten Projektdaten nicht mehr gegen unbeabsichtigte Änderungen geschützt sind."

Dieser Warnhinweis "S078" gilt für die API des SIMATIC Automation Tool. Die API unterstützt das Kommunizieren mit F-CPUs und das Speichern von CPU-Passwörtern für F-CPUs.

Sicherheitsmerkmale der API

Der TÜV SÜD hat die API für das SIMATIC Automation Tool und das SIMATIC Automation Tool SDK zertifiziert.

Die API des SIMATIC Automation Tool nutzt verschiedene und redundante Techniken. Somit schützt die API den Programmcode von Benutzeranwendungen vor der Durchführung möglicherweise unsicherer Vorgänge. Die API stellt die folgenden Funktionen bereit:

  • Unabhängiger Verbindungs- und Legitimierungsprozess für jeden sicherheitsrelevanten Vorgang

  • Identitätsprüfungen für sicherheitsrelevante Vorgänge an fehlersicheren Geräten

  • Identifizierung von Sicherheitsprogrammen

  • Verwendung von Sicherheitspasswörtern für F-CPUs für jeden sicherheitsrelevanten Vorgang an einer passwortgeschützten F-CPU

  • Verwendung von CRC-Prüfsummen (32 Bit) für den Vergleich der Online- und Offline-Darstellung fehlersicherer Geräte

  • Verwendung von Hamming-Codes für die Anzeige von WAHR- und FALSCH-Zuständen

  • Vergleich von F-Signaturen nach der Programmaktualisierung und der Wiederherstellung aus einer Sicherungskopie, um zu überprüfen, ob der Vorgang erfolgreich durchgeführt wurde


Programmierrichtlinien für Benutzeroberflächen für sicherheitsrelevante Vorgänge

Identifizieren und Schutz sicherheitsrelevanter Vorgänge Empfohlene Programmierpraxis Anforderungen für die Programmaktualisierung Anforderungen für das Wiederherstellen aus einer Sicherungsdatei Zertifizierung
Start Zurück Weiter

Programmierrichtlinien für Benutzeroberflächen für sicherheitsrelevante Vorgänge

Warnung

Weitestgehender Schutz sicherheitsrelevanter Vorgänge

Fehlersichere CPUs in Verbindung mit fehlersicherer Peripherie und Sicherheitsprogrammen bieten ein hohes Maß an Betriebssicherheit.

Bei der Arbeit mit der SIMATIC Automation Tool API ist sicherzustellen, dass sicherheitsrelevante Vorgänge so sicher wie möglich sind. Siemens übernimmt keine Haftung für Benutzeroberflächenanwendungen, die mit der SIMATIC Automation Tool API entwickelt werden. Die gesamte Haftung liegt beim Software-Entwickler.

Die Missachtung angemessener Programmierungsrichtlinien kann zu Tod oder Verletzung führen, wenn der Benutzer mit der Anwendung arbeitet.

Identifizieren und Schutz sicherheitsrelevanter Vorgänge

Siemens empfiehlt, für sicherheitsrelevante Vorgänge einen Bestätigungsdialog zu verwenden. Programmieren Sie Ihre Anwendung so, dass der Benutzer das jeweilige fehlersichere Gerät für einen Vorgang auswählen und auf "Fortfahren" klicken muss, bevor der Vorgang ausgeführt werden kann.

Bei der Entwicklung einer Benutzeroberflächenanwendung mit der API stellen Sie zuerst fest, ob ein Vorgang einer der folgenden sicherheitsrelevanten Vorgänge ist:

  • Programmaktualisierung

  • Wiederherstellen des Geräts aus einer Sicherungsdatei

  • Rücksetzen auf Werkseinstellungen

  • Memory Card formatieren

Für sicherheitsrelevante Vorgänge ist ein Bestätigungsdialog für den Benutzer vorzusehen. Mit der API-Methode DetermineConfirmationMessage ist die Art des Bestätigungsdialogs festzulegen, der angezeigt werden soll. Durch einen zusätzlichen Bestätigungsdialog wird verhindert, dass Benutzer unabsichtlich einen sicherheitsrelevanten Vorgang ausführen. Der folgende Dialog ist ein Beispiel eines Bestätigungsdialogs für eine Programmaktualisierung.

Empfohlene Programmierpraxis

Die folgenden Programmierungsrichtlinien sind einzuhalten, damit sicherheitsrelevante Vorgänge geschützt und die Gefahr unsicherer Benutzeraktionen verringert wird:

  • Alle sicherheitsrelevanten Vorgänge sind in einem einzigen Thread auszuführen.

  • Erforderliche Eingabe des Safety-Passworts für F-CPUs bei sicherheitsrelevanten Vorgängen. Überprüfung des eingegebenen Passworts anhand des CPU-Passworts. Passwörter sind bei der Eingabe durch den Benutzer am Bildschirm mit Sternchen zu verbergen.

  • Die Rückgabecodes aller Methoden sind zu prüfen. Es ist sicherzustellen, dass die Programmlogik nur nach erfolgreicher Rückgabe der Methoden fortgesetzt wird.

  • Eine geeignete Ausnahmebehandlung ist in der Implementierung vorzusehen. Die API gibt Ausnahme für kritische interne Fehler aus, die sie erkennt. Stellen Sie sicher, dass Ihre Software Ausnahmen angemessen bearbeitet.

  • Für alle sicherheitsrelevanten Vorgänge prüfen Sie, ob der Vorgang erfolgreich war. Dem Benutzer muss eine Mitteilung über eine erfolgreiche Programmaktualisierung angezeigt werden. Bei einer fehlgeschlagenen Programmaktualisierung muss eine Fehlermeldung angezeigt werden.

  • Verwenden Sie Hamming-Codes in Ihrer Anwendung, um Boolesche Zustände zu implementieren.

  • Verwenden Sie in Ihrer Anwendung unterschiedliche Farben, um fehlersichere Geräte, Sicherheitsprogramme, sichere F-CPU-Passwörter und andere vom Benutzer eingegebene Daten visuell zu unterscheiden.

  • Aufforderung zur Bestätigung jeder Betriebsartenänderung (RUN/STOP).

  • Aktualisieren der Benutzeroberfläche nach jedem Vorgang, damit immer die korrekten Gerätedaten angezeigt werden.

Anforderungen für die Programmaktualisierung

Bei Programmaktualisierungen für ausgewählte F-CPUs zeigen Sie dem Benutzer einen zusätzlichen Dialog an, in dem der Benutzer die fehlersicheren Geräte erneut auswählen und die folgenden Vorgänge bestätigen muss:

  • Aktualisieren eines vorhandenen Sicherheitsprogramms mit einem anderen Sicherheitsprogramm

  • Aktualisieren eines vorhandenen Sicherheitsprogramms mit einem Standardprogramm

  • Aktualisieren eines vorhandenen Standardprogramms mit einem Sicherheitsprogramm

  • Aktualisieren einer CPU ohne Programm mit einem Sicherheitsprogramm

  • Löschen eines vorhandenen Sicherheitsprogramms

Nach einer Aktualisierung eines Sicherheitsprogramms prüfen Sie, ob die F-Signatur des in der CPU aktualisierten Programms mit der F-Signatur in der Programmaktualisierungsdatei übereinstimmt.

Anforderungen für das Wiederherstellen aus einer Sicherungsdatei

Vor dem Wiederherstellen aus einer Sicherungsdatei ist zu prüfen, ob die Datei ein Sicherheitsprogramm ist und vom Benutzer müssen die gleichen Bestätigungen angefordert werden wie für Programmaktualisierungen.

Zertifizierung

Hinweis

Erwerb einer Zertifizierung für Ihre Benutzeroberflächenanwendung

Siemens empfiehlt dringend, die Sicherheit Ihrer Entwicklung und Implementierung von einer benannten Stelle wie dem TÜV SÜD zertifizieren zu lassen.


Farbkennzeichnung von Sicherheitsfeldern in ihrer Benutzeroberfläche

Farbkennzeichnung von Sicherheitsfeldern in ihrer Benutzeroberfläche

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Farbkennzeichnung von Sicherheitsfeldern in ihrer Benutzeroberflächenanwendung
  • Farbkennzeichnung eines CPU-Gerätesymbols
  • Farbkennzeichnung von Gerätedaten
  • Farbkennzeichnung eines CPU-Passworts
  • Farbkennzeichnung eines Programmordners
  • Farbkennzeichnung eines Programmpassworts


Farbkennzeichnung von Sicherheitsfeldern in ihrer Benutzeroberflächenanwendung

Konventionen des Entscheidungsbaums

Farbkennzeichnung von Sicherheitsfeldern in ihrer Benutzeroberflächenanwendung

Wenn Sie mit der API eine Benutzeroberfläche entwickeln, empfiehlt Siemens dringend die Verwendung von Farbkennzeichnungen, um dem Benutzer einen visuellen Hinweis auf fehlersichere CPUs und Sicherheitsprogramme zu bieten. Die Entscheidungsbäume zeigen die Logik, die Siemens für die Farbkennzeichnung typischer sicherheitsrelevanter Felder empfiehlt. Bei der Entwicklung Ihrer eigenen Anwendung sollten Sie ein ähnliches oder das gleiche Konzept anwenden.

Konventionen des Entscheidungsbaums

* Bei Unterprozessen, die nicht fehlschlagen können, gibt es keine Fehlerverarbeitung bzw. liegt eine Situation vor, in der die Anwendung Fehler absichtlich ignoriert.


Farbkennzeichnung eines CPU-Gerätesymbols

Farbkennzeichnung eines CPU-Gerätesymbols


Farbkennzeichnung von Gerätedaten

Farbkennzeichnung von Gerätedaten


Farbkennzeichnung eines CPU-Passworts

Farbkennzeichnung eines CPU-Passworts


Farbkennzeichnung eines Programmordners

Farbkennzeichnung eines Programmordners


Farbkennzeichnung eines Programmpassworts

Farbkennzeichnung eines Programmpassworts


Hamming-Codes

Hamming-Codes

Hamming-Codes sind binäre Codes. Sie können zufällige Bitfehler erkennen. Das SIMATIC Automation Tool verwendet Hamming-Codes (32-Bit) mit einer Hamming-Distanz von acht. Die API verwendet Hamming-Codes für die Darstellung aller Booleschen Werte, die auf sicherheitsrelevante Vorgänge bezogen sind. Sie können Ihre Benutzeroberflächenanwendung so programmieren, dass die bereitgestellten Booleschen Wertzustände für sicherheitsrelevante Vorgänge verwendet werden. Da die API diese Zustände mit Hamming-Codes implementiert, ist ein hohes Vertrauen in die Datenintegrität der sicherheitsrelevanten Booleschen Zustände gegeben.


Übersicht über die Architektur

Netzwerke Geräte
Methode FirmwareUpdate Methode Backup (ICPU-Schnittstelle) Methode SetOperatingState Eigenschaft Modules und Klasse IModuleCollection Methode Restore (ICPU-Schnittstelle) Methode SetIP Methode Identify Methode RefreshStatus Methode SetProfinetName Methode GetCurrentDateTime Methode MemoryReset Methode ProgramUpdate Methode ResetToFactoryDefaults Methode SetCurrentDateTime Methode UploadServiceData Schnittstelle IModule Methode DeleteDataLog Methode DeleteRecipe Methode UploadDataLog Methode UploadRecipe Methode Backup (IHMI-Schnittstelle) Methode ProgramUpdate (IHMI-Schnittstelle) Methode Restore (IHMI-Schnittstelle) Methode DownloadRecipe Eigenschaft RemoteInterfaces IProfinetDevice-Ereignisse
Start Zurück Weiter

Übersicht über die Architektur

Die API bietet Klassen, Schnittstellen und Methoden zur Unterstützung der Kommunikation mit einem Netzwerk aus SIMATIC-Geräten.

Netzwerke

Die Klasse .NET Network stellt das industrielle Netzwerk als Ganzes dar. Diese Klasse führt Funktionen mit Hilfe einer auf einem Programmiergerät installierten Netzwerkkarte (NIC) aus. Die Klasse Network wird verwendet, um nach verfügbaren Schnittstellenkarten zu suchen und die zu verwendende Schnittstellenkarte auszuwählen.

Die Klasse Network umfasst den Konstruktor und die folgende Eigenschaft und Methoden:

  • Network-Konstruktor

  • Methode QueryNetworkInterfaceCards

  • Methode SetCurrentNetworkInterface

  • Eigenschaft CurrentNetworkInterface

  • Methode ScanNetworkDevices

  • Methode SetCommunicationsTimeout

  • Methode GetCommunicationsTimeout

  • Methode GetEmptyCollection

Geräte

Die einzelnen Geräte im Netzwerk werden durch Schnittstellen repräsentiert. Jede NIC-Karte stellt Eigenschaften und Methoden bereit, die für das repräsentierte Netzwerkgerät geeignet sind. Die im Netzwerk vorhandenen Hardwaregeräte werden jeweils am besten durch eine der folgenden Schnittstellen repräsentiert:

IProfinetDevice – Durch diese Schnittstelle kann jedes im Industrienetzwerk erreichbare Gerät dargestellt werden.

ICPU – Diese Schnittstelle steht für S7-CPUs, die direkt mit dem Netzwerk verbunden sind. Bei CPUs werden spezifische Funktionen unterstützt.

ICPUClassic – Diese Schnittstelle steht für CPUs des klassischen Typs S7-300 und S7-400, die direkt mit dem Netzwerk verbunden sind.

IHMI – Diese Schnittstelle steht für SIMATIC HMI-Geräte, die direkt mit dem Netzwerk verbunden sind. Bei HMI-Geräten werden spezifische Funktionen unterstützt.

IBaseDevice – Mit dieser Schnittstelle werden Geräte repräsentiert, die nicht direkt mit dem Ethernet-Netzwerk verbunden, aber über ein anderes Gerät erreichbar sind. Dies ist beispielsweise eine mit einer CPU verbundene PROFIBUS-Slave-Station, die im Netzwerk als IBaseDevice repräsentiert wird.

IModule – Mit dieser Schnittstelle werden einzelne Peripheriemodule repräsentiert, die in eine CPU, ein PROFINET-Gerät oder eine PROFIBUS-Station eingesteckt sind.

IHardware – Die Basisklasse für alle anderen Schnittstellen. Diese Schnittstelle bietet Zugriff auf alle Eigenschaften, die den im Netzwerk erkannten Hardwareelementen gemeinsam sind.

Die Schnittstellen sind in Sammlungen zusammengefasst, die jeweils Gruppen von Geräten darstellen. Die Sammlungen werden für Iterationen, Filter- und Suchvorgänge bereitgestellt.

IProfinetDeviceCollection – Eine Sammlung aller im Netzwerk direkt erreichbaren Geräte.

IModuleCollection – Eine Sammlung, die in eine CPU oder in ein IM gesteckte Module darstellen kann.

IHardwareCollection – Diese Sammlung stellt eine CPU und all ihre Module dar.

IScanErrorCollection – Diese Sammlung stellt die Gruppe der Fehler dar, die bei einer Netzwerksuche von allen Geräten zurückgegeben werden.

Geräteklassen, Schnittstellen, und Methoden:

  • Klasse IProfinetDeviceCollection

  • Schnittstelle IProfinetDevice

  • Schnittstelle ICPU

  • IHMI-Schnittstelle

Das folgende Klassendiagramm zeigt die Vererbung zwischen diesen Schnittstellenklassen:

Hinweis

Siehe das Beispiel für ein Industrienetzwerk und die zur Darstellung der einzelnen Netzwerkkomponenten verwendeten Klassen der SIMATIC Automation Tool API.


Referenzieren der API in einer Benutzeroberflächenanwendung

Referenzieren der API in einer Benutzeroberflächenanwendung

Siemens liefert die API mit mehreren DLLs, ausführbaren Dateien und Quelldateien aus:

  • SIMATICAutomationToolAPI.dll

  • DeviceManagerClient.dll (HMI)

  • hmitr.dm.client.proxy.dll (HMI)

  • hmitr.dm.client.stub.exe (HMI)

  • hmitr.ipc.dll (HMI)

  • Ordner AsModels und Unterordner (Offline-Objektmodelle)

Bei Verwendung der API müssen sich diese Dateien und der Ordner AsModels in demselben Ordner befinden, in dem Sie Ihre benutzerspezifische Anwendung entwickeln.

Die API wurde mit Microsoft Visual Studio 2015 SP2 Update 3 und .NET Framework Version 4.6.2 erzeugt. Sie ist verwendbar mit Anwendungen, die mit dieser Version von Visual Studio erzeugt wurden. Alle Codebeispiele und Screenshots in diesem Dokument wurden mit Visual Studio 2015 SP2 Update 3 in der Programmiersprache C# generiert.

Wenn Sie die API in Ihre Anwendung aufnehmen möchten, müssen Sie SIMATICAutomationToolAPI.dll als Referenz in Ihre Visual-Studio-Lösung einfügen.

Um PC-Daten aus Ihren Anwendungen exportieren zu können, fügen Sie SimaticAutomationToolHealthCheck.dll als Referenz hinzu.

In jeder Anwendung, die auf die API-Klassen verweist, muss die folgende Anweisung als Verweis auf den API-Namespace eingefügt werden:

using Siemens.Automation.AutomationTool.API;

Wenn Ihre Anwendung PC-Daten exportiert, müssen Sie die folgende Anweisung hinzufügen:

using Siemens.Automation.AutomationTool.HealthCheck;

Zur Übersetzung aller Codebeispiele in diesem Dokument müssen Sie die richtigen using-Anweisungen in dieselbe Quelldatei (*.cs) wie den Beispielcode aufnehmen. Der Einfachheit halber ist die using-Anweisung in den einzelnen Codebeispielen dieses Dokuments nicht aufgeführt.


Voraussetzungen für die S7-Kommunikation

S7-Kommunikation bei der Entwicklung Ihrer Anwendung S7-Kommunikation für Endbenutzer Ihrer Anwendung
Start Zurück Weiter

Voraussetzungen für die S7-Kommunikation

S7-Kommunikation bei der Entwicklung Ihrer Anwendung

Für die Ausführung von Anwendungen, die Sie mit der API entwickeln, benötigen Sie auf Ihrem Programmiergerät installierte S7-Kommunikationskomponenten. Wenn Sie das SIMATIC Automation Tool installiert haben, sind auch die erforderlichen S7-Kommunikationskomponenten installiert. Wenn S7-Kommunikation auf einem Programmiergerät stattfindet, können Sie die in Referenzieren der API in einer Benutzeroberflächenanwendung benannten Dateien und Ordner in einem beliebigen Ordner auf dem Programmiergerät unterbringen. Legen Sie die EXE-Datei für Ihre benutzerspezifische Anwendung in demselben Ordner ab. Führen Sie die Anwendung aus diesem Ordner aus und nehmen Sie Ihre Tests vor.

S7-Kommunikation für Endbenutzer Ihrer Anwendung

Ihre Endbenutzer müssen eine lizenzierte Version des SIMATIC Automation Tool installieren. Ihre benutzerspezifische Anwendung muss sich in demselben Ordner mit den erforderlichen Dateien und Ordnern auf dem Programmiergerät des Endbenutzers befinden.


Häufig zur Unterstützung verwendete Klassen

Häufig zur Unterstützung verwendete Klassen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Klasse EncryptedString
  • Klasse Result
  • Diagnoseklasse
  • Klasse DataChangedEventArgs
  • Klasse ProgressChangedEventArgs


Klasse EncryptedString

Klasse EncryptedString

Viele API-Vorgänge erfordern eine legitimierte Verbindung zu einer geschützten S7 CPU. Für diese Vorgänge erfordern die Methoden ein Passwort als einen der Parameter für die Methode. Die S7-CPU nimmt das Passwort in verschlüsseltem Format entgegen. Zum Verschlüsseln des Passworts stellt die API die Klasse EncryptedString bereit.

Constructor | Beschreibung
EncryptedString() | Leere, verschlüsselte Zeichenkette
EncryptedString(string strText) | Verschlüsselte Zeichenkette

Name der Eigenschaft | Rückgabetyp | Beschreibung
IsEmpty | bool | Wahr, wenn kein Passwort existiert
IsEncrypted | bool | Wahr, wenn ein verschlüsseltes Passwort existiert

Methodenname | Rückgabetyp | Beschreibung
ToString() | string | Hexadezimale Zeichenkette als Darstellung des verschlüsselten Passworts
Clear() | void | Löscht das verschlüsselte Passwort
GetHash() | byte[] | Passwortverschlüsselte Hash-Array-Darstellung des Passworts
WriteToStream(Stream stream) | void | Serialisieren des Passworts aus einem Stream
ReadFromStream(Stream stream) | void | Deserialisieren des Passworts aus einem Stream

Mit Hilfe dieser Klasse kann ein Klartextpasswort so verschlüsselt werden, dass Sie damit eine CPU-Verbindung legitimieren können. Viele der Codebeispiele zeigen eine typische Verwendungsweise dieser Klasse.

Wenn Sie ein Passwort zur mehrfachen Verwendung in Ihrem Code verschlüsseln möchten, instanziieren Sie den EncryptedString. Anschließend können Sie diesen wie folgt als Parameter an mehrere Aufrufe übergeben:

    EncryptedString pwd = new EncryptedString("password");

    devAsCpu.Selected = true;
    devAsCpu.SetPassword(pwd);

Hinweis

Wenn eine CPU nicht passwortgeschützt ist, übergeben Sie einfach eine leere Zeichenkette an den EncryptedString-Constructor. Beispielsweise könnte der folgende Code erfolgreich bei einer CPU eingesetzt werden, für die kein Schutz konfiguriert ist:

    devAsCpu.SetPassword(new EncryptedString("Password"));
    devAsCpu.Selected = true;
    Result retVal = devAsCpu.RefreshStatus();

Im EncryptedString-Objekt wird das vom Anwender zugeordnete Klartextpasswort nicht gespeichert. Wenn Passwörter von ihrer Anwendung als Literalzeichenketten codiert werden, entsteht jedoch ein Sicherheitsrisiko.

Beispielsweise übersetzt new EncryptedString("myPassword") den Klartext "myPassword" in das Anwenderprogramm. Dieses Passwort ist unter Umständen sichtbar für andere, die .NET Reflection nutzen.


Klasse Result

Klasse Result

Die Klasse Result verkapselt die Logik, die ermittelt, ob eine bestimmte API-Aktion erfolgreich war. Die meisten API-Aktionen erfordern Netzwerkkommunikation. Bei vielen Aktionen wird außerdem eine Verbindung zu einem Netzwerkgerät geöffnet. Einige Aktionen sind möglicherweise nicht erfolgreich. Prüfen Sie das von API-Aktionen zurückgegebene Result-Objekt, um zu ermitteln, ob die Aktion erfolgreich war oder fehlgeschlagen ist.

Constructor | Beschreibung
Result() | Erzeugt ein erfolgreiches Ergebnis ohne Warnungen
Result(ErrorCode nCode) | Erzeugt einen spezifischen Fehler ohne Warnungen
Result(string strCode) | Gerätedefinierte Fehlerbeschreibung
Result(Result result) | Erzeugt ein Ergebnis mit den Ergebnisparameterinhalten

Name der Eigenschaft | Rückgabetyp | Beschreibung
Warnungen | ErrorCode[]{get;} | Ausgabe aller Warnungen in einem Array mit Fehlercodes
Fehler | ErrorCode {get;} | Gibt einen Fehlercode zurück
HasWarnings | Bool {get;} | Wahr, wenn Warnungen vorhanden sind
Failed | Bool {get;} | Wahr, wenn das Ergebnis fehlgeschlagen ist
Succeeded | Bool {get;} | Wahr, wenn das Ergebnis erfolgreich ist Erfolgreich = nicht Failed

Methodenname | Rückgabetyp | Beschreibung
Clear() | void | Löscht Fehler und alle Warnungen
SetError(ErrorCode error) | void | Setzt den aktuellen Fehler
AddWarning(ErrorCode warning) | void | Fügt eine Warnung hinzu
ChangeErrorToWarning() | void | Verwandelt den aktuellen Fehler in eine Warnung
GetErrorDescription(Language language) | string | Ruft den aktuellen Fehlerstring in der angegebenen Sprache ab
GetWarningDescription(Language language) | string[] | Ruft den Warnungsstring in der angegebenen Sprache ab

In einigen Fällen gibt das Gerät einen Fehlerstring zurück, der einen gerätespezifischen Fehler beschreibt. In diesem Fall wird ErrorCode als DeviceDefinedError zurückgegeben. Die Methode GetErrorDescription liefert den gerätespezifischen Fehlerstring.

In vielen Fällen dürfte es ausreichen, zu wissen, ob eine bestimmte Aktion erfolgreich war. Überprüfen Sie in diesem Fall die Eigenschaft Succeeded:

        ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
//-----------------------------------------------------
//
         Das Gerät ist eine CPU.
//
         Für die Interaktion mit dem Gerät kann die ICPU-Schnittstelle verwendet werden.
//-----------------------------------------------------

dev.Selected = true;
Result retVal = dev.RefreshStatus();
if (retVal.Succeeded)
{
//------------------------------------
//
        Mit Vorgängen fortfahren
        ....
//------------------------------------
}

In anderen Fällen sind möglicherweise weitere Informationen über den fehlgeschlagenen Vorgang nützlich. Zur Inspektion des konkreten Fehlers verwenden Sie die Eigenschaft ErrorCode wie folgt:

            dev.Selected = true;
Result retVal = dev.RefreshStatus();
if (retVal.Succeeded)
{
//------------------------------------
//
        Mit Vorgängen fortfahren
        ....
//------------------------------------
}
else
{
//------------------------------------
//
        Was ist geschehen?
//------------------------------------
switch (retVal.Error)
{
case ErrorCode.AccessDenied:
break;
case ErrorCode.TooManySessions:
break;
}
}

Siehe Thema ErrorCode mit einer Liste möglicher Fehlerwerte.

Die Result-Klasse liefert auch eine sprachenspezifische Fehlerbeschreibung. Die Methode GetErrorDescription verwendet einen Language-Wert als Parameter zum Bereitstellen der Fehlerbeschreibung in der angegebenen Sprache.

Beispielsweise gibt der folgende Code die Fehlerbeschreibung auf Deutsch aus:

String strError = retVal.GetErrorDescription(Language.German);

Siehe Thema Sprache mit einer Werteliste.

Das SIMATIC Automation Tool hat eine Funktion, die eine Warnmeldung zur Information über aufgetretene Probleme erzeugt. Beispielsweise ist es bei der Aktualisierung des Geräts nach Abschluss einer Programmaktualisierung möglich, nicht direkt mit der Hauptaufruffunktion verbundene Warnmeldungen zu erzeugen. Diese Warnmeldungen sind wie folgt über Klasse Result aufrufbar.

if (retVal.HasWarnings)
{
foreach (ErrorCode warning in retVal.Warnings)
{
//------------------------------------
//
        Mit Vorgängen fortfahren
        ....
//------------------------------------
}
}


Diagnoseklasse

Diagnoseklasse

Ein Diagnoseelement enthält Diagnoseinformationen zu einem einzelnen Ereignis. Der Diagnosepuffer einer CPU kann ausgelesen werden. Siehe Kapitel ICPU-Schnittstelle mit weiteren Details.

Constructor | Beschreibung
DiagnosticsItem() | Erstellt ein Standard-Diagnoseelement

Name der Eigenschaft | Rückgabetyp | Beschreibung
TimeStamp | DateTime {get;} | Zeitstempel des Diagnoseereignisses
State | Byte {get;} | 0=Gehendes Ereignis; 1=Kommendes Ereignis
Description1 | String {get;} | Allgemeine Beschreibung
Description2 | String {get;} | Detaillierte Beschreibung


Klasse DataChangedEventArgs

Klasse DataChangedEventArgs

Ein Ereignis DataChanged enthält Informationen über Daten, die in der API geändert wurden. Siehe Kapitel IProfinet-Schnittstelle mit weiteren Details.

Constructor | Beschreibung
DataChangedEventArgs(DataChangedType type) | Erstellt Ereignisse eines bestimmten Typs
DataChangedType type | Datentyp, der sich geändert hat

Name der Eigenschaft | Rückgabetyp | Beschreibung
Type | DataChangedType | Ereignistyp

Wird mit dem folgenden Event Handler benutzt:

public delegate void DataChangedEventHandler(object sender, DataChangedEventArgs e);


Klasse ProgressChangedEventArgs

Klasse ProgressChangedEventArgs

Ein Ereignis ChangedEvent enthält Informationen über Daten, die in der API geändert wurden. Siehe Kapitel IProfinet-Schnittstelle mit weiteren Details.

Constructor | Beschreibung
ProgressChangedEventArgs(ProgressAction action, int index, int count, uint hardwareID) | Wird für die Erstellung und Standardeinstellung einer Klasse ProgressChangedEventArgs verwendet
ProgressAction action | Art des erzielten Fortschritts
int index | Index des aktuell verarbeiteten Elements
int count | Gesamtzahl der Elemente, die zu verarbeiten sind
uint hardwareID | ID des Elements, das verarbeitet wird

Name der Eigenschaft | Rückgabetyp | Beschreibung
ID | uint {get;} | ID des Elements
Cancel | bool {get;} | Wird auf Wahr gesetzt, um einen Vorgang zu beenden
Count | int {get;} | Höchstwert
Index | int {get;} | Istwert
Action | ProgressAction {get;} | Aktionstyp dieses Ereignisses

Wird mit dem folgenden Event Handler benutzt:

public delegate void ProgressChangedEventHandler(object sender, ProgressChangedEventArgs e);


Allgemeine Support-Schnittstellen

Allgemeine Support-Schnittstellen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Schnittstelle IRemoteFile
  • Schnittstelle IRemoteFolder
  • Schnittstelle IRemoteInterface
  • IHardware-Schnittstelle
  • Schnittstelle IBaseDevice
  • Schnittstelle IHardwareCollection
  • Schnittstelle IModuleCollection
  • Klasse IScanErrorCollection
  • IScanErrorEvent-Klasse


Schnittstelle IRemoteFile

Schnittstelle IRemoteFile

IRemoteFile ist eine Schnittstelle für die Darstellung von Dateien in Datenprotokollen und Rezepten.

Name der Eigenschaft | Rückgabetyp | Beschreibung
Selected | bool {get; set;} | Ausgewählter Zustand
FileSize | ulong {get;} | Größe der Datei in der CPU
Name | string {get;set;} | Dateiname und Dateierweiterung im Gerät


Schnittstelle IRemoteFolder

Schnittstelle IRemoteFolder

IRemoteFolder dient zur Darstellung von Ordnern in Datenprotokollen und Rezepten.

Methodenname | Rückgabetyp | Beschreibung
SetRemoteFile(string strFile) | Result | Den Namen der entfernten Datei festlegen
string strFile |  | Vollständiger Dateiname und -pfad der dezentralen Datei

Name der Eigenschaft | Rückgabetyp | Beschreibung
NewFileNameErrorCode | Result {get;} | Fehlercode, der nach dem Aufruf der Methode SetRemoteFile gespeichert wird
NewFileNameIsValid | bool {get;} | Wahr, wenn der Dateiname gültig ist.
FileUpdateAllowed | bool {get;} | Wahr, wenn der Ordner eine Datei in der Liste hinzufügen oder ersetzen kann
SelectedCount | int {get;} | Anzahl ausgewählter Dateien
Files | List<IRemoteFile> {get;} | Liste der Dateien in diesem Ordner
FolderType | RemoteFolderType {get;} | Ordnertyp (Datenprotokoll oder Rezept)
Exists | bool {get;} | Wahr, wenn dieser Ordner im Gerät vorhanden ist
Selected | bool {get;set;} | Wahr, wenn der Ordner ausgewählt ist
NewFile | string {get;} | Vollständiger Dateipfad der Datei, die hinzugefügt oder ersetzt werden soll
NewFileName | string {get;} | Name der Datei, die hinzugefügt oder ersetzt werden soll
Name | string {get;} | Name des Ordners


Schnittstelle IRemoteInterface

Schnittstelle IRemoteInterface

IRemoteInterface ist eine Schnittstelle für die Darstellung der dezentralen Peripherie in einem Netzwerk.

Name der Eigenschaft | Rückgabetyp | Beschreibung
Devices | List<IBaseDevice>{get;} | Liste entfernter Schnittstellen für die Darstellung der dezentralen Peripherie
InterfaceType | RemoteInterfaceType{get;} | Typ der entfernten Schnittstelle wie PROFINET oder PROFIBUS
Name | string {get;} | Dateiname und Dateierweiterung im Gerät


IHardware-Schnittstelle

IHardware-Schnittstelle

IHardware ist eine Schnittstelle für die Darstellung der gemeinsamen Hardwareschnittstelle für Geräte und Module. IModule erweitert die IHardware-Schnittstelle.

Methodenname | Rückgabetyp | Beschreibung
SetFirmwareFile(string strFile) | Result | Legt die Firmware-Datei fest, die für dieses Gerät oder Modul zu aktualisieren ist.

Name der Eigenschaft | Rückgabetyp | Beschreibung
Comment | string {get;set;} | Kommentar für jedes Gerät und Modul
Selected | bool {get;set;} | Für die externe Speicherung des ausgewählten Zustands
NewFirmwareNameErrorCode | Result {get;} | Letzter Fehler der Methode SetFirmwareFile
FirmwareUpdateAllowed | bool {get;} | Wahr, wenn dieses Gerät oder Modul die Firmware-Aktualisierung unterstützt
NewFirmwareNameIsValid | bool {get;} | Wahr, wenn die Firmware-Datei für dieses Gerät oder Modul gültig ist.
Failsafe | bool {get;} | Wahr, wenn das Gerät oder Modul fehlersicher ist
Supported | bool {get;} | Wahr, wenn das Gerät oder Modul unterstützt wird
NewFirmwareFile | string {get;} | Vollständiger Dateipfad der Firmware-Datei
NewFirmwareVersion | string {get;} | Version der Firmware-Datei, die im Klappmenü angezeigt wird
Configured | bool {get;} | Wahr, wenn das Gerät oder Modul konfiguriert ist
HardwareNumber | short {get;} | Hardware-Änderungsstand des Geräts oder Moduls
SlotName | string {get;} | Steckplatzname des Geräts oder Moduls
SubSlot | uint {get;} | Untersteckplatznummer des Geräts oder Moduls
Slot | uint {get;} | Steckplatznummer des Geräts oder Moduls
StationNumber | uint {get;} | Stationsnummer des Geräts oder Moduls
SerialNumber | string {get;} | Seriennummer des Geräts oder Moduls
FirmwareVersion | string {get;} | Firmware-Version des Geräts oder Moduls
ArticleNumber | string {get;} | Artikelnummer des Geräts oder Moduls
Description | string {get;} | Beschreibung der Artikelnummer des Geräts oder Moduls
Name | string {get;} | Name des Geräts oder Moduls
ID | uint {get;} | ID des Geräts oder Moduls


Schnittstelle IBaseDevice

Schnittstelle IBaseDevice

IBaseDevice ist eine Schnittstelle für die Erweiterung der IHardware-Schnittstelle, die den Basisgerätetyp darstellt.

Methodenname | Rückgabetyp | Beschreibung
GetHardwareFromID(uint hardwareID) | IHardware | Sucht ein Gerät oder Modul mit Hilfe der ID

Name der Eigenschaft | Rückgabetyp | Beschreibung
HardwareInDisplayOrder | IHardwareCollection | Sammlung der Hardware-Elemente in der anzuzeigenden Reihenfolge
HardwareInFirmwareOrder | IHardwareCollection | Sammlung der Hardware-Elemente in der Reihenfolge der Firmware-Updates
Modules | IModuleCollection | Sammlung von Modulen
ThreadNumber | int | Aktuelle Thread-Nummer des Vorgangs
Family | DeviceFamily | Familientyp-Enum

Ereignisse | Rückgabetyp | Beschreibung
ProgressChanged | ProgressChangedEventHandler | Wird für die Überwachung des Fortschritts aufgerufen
DataChanged | DataChangedEventHandler | Wird aufgerufen, wenn sich Daten in APi ändern


Schnittstelle IHardwareCollection

Schnittstelle IHardwareCollection

IHardwareCollection ist eine Schnittstelle für die Darstellung einer Liste von IHardware-Schnittstellen. Diese Schnittstelle erweitert eine .NET Listenklasse.

Name der Eigenschaft | Typ | Beschreibung
Keine |  |


Schnittstelle IModuleCollection

Schnittstelle IModuleCollection

IModuleCollection ist eine Schnittstelle für die Darstellung eines Arrays von IModule-Schnittstellen. Diese Schnittstelle erweitert eine .NET Listenklasse. Diese Schnittstelle stellt lokale und entfernte Module im Hardware-Baugruppenträger dar.

Name der Eigenschaft | Typ | Beschreibung
Keine |  |


Klasse IScanErrorCollection

Klasse IScanErrorCollection

Diese Schnittstelle verkapselt die Logik, die feststellt, ob die Durchsuchung eines Netzwerks nach Geräten mit dem Aufruf ScanNetworkDevices erfolgreich war. Diese Klasse liefert außerdem Fehlerinformationen für jedes Gerät im Netzwerk, für das die Durchsuchung nicht erfolgreich war, indem ein ScanErrorEvent für das Gerät zurückgegeben wird. Das von einem ScanNetworkDevices-Aufruf zurückgegebene IScanErrorCollection-Objekt sollte immer auf erfolgreiche oder fehlgeschlagene Ausführung überprüft werden. Diese Schnittstelle wird hinzugefügt, um dem Anwender zu ermöglichen, bei einer Durchsuchung mehr gerätespezifische Fehlerinformation zu erhalten, um diese für die Diagnose von Problemen bei der Durchsuchung eines Netzwerks zu nutzen.

Constructor | Beschreibung
ScanErrorCollection() | Liefert das Ergebnis, dass ein Netzwerk erfolgreich durchsucht wurde

Name der Eigenschaft | Rückgabetyp | Beschreibung
Count | Int | Anzahl der Fehlerereignisse bei einer Durchsuchung
ScanErrorEvent[int] | ScanErrorEvent | Gibt das benannte Suchereignis in der Sammlung der Suchereignisse zurück. Gibt bei einem ungültigen Element den Wert null zurück.
Failed | Bool {get;} | Wahr, wenn das Ergebnis fehlgeschlagen ist
Succeeded | Bool {get;} | Wahr, wenn das Ergebnis erfolgreich ist Succeeded = Failed

Die folgenden Bedingungen resultieren in einem Status, dass die Durchsuchung fehlgeschlagen ist:

  • Keine SAT-Lizenz vorhanden oder SDK-Installation

  • Ungültige Netzwerkschnittstelle

  • Bei der Suche wurden keine Geräte gefunden

  • Vorgang vom Anwender abgebrochen

Methodenname | Rückgabetyp | Beschreibung
GetEnumerator() | IEnumerator<IScanErrorEvent> | Ruft einen Enumerator für die Sammlung der Fehlerereignisse bei der Durchsuchung ab


IScanErrorEvent-Klasse

IScanErrorEvent-Klasse

Diese Klasse liefert Informationen über einen fehlgeschlagenen Durchsuchungsversuch eines Geräts infolge eines Aufrufs an die Methode ScanNetworkDevices. Der Inhalt des ScanErrorEvent liefert die über das Gerät verfügbaren Informationen und spezifiziert den Fehler als Information, Warnung, Fehler oder ungültig.

Constructor | Beschreibung
ScanErrorEvent() | Erzeugt ein ScanErrorEvent

Name der Eigenschaft | Rückgabetyp | Beschreibung
Code | ErrorCode {get;} | Der Fehler bei der Durchsuchung
IP | Uint {get;} | Die IP-Adresse des Geräts
MAC | ulong {get;} | Die MAC-Adresse des Geräts
Name | string {get;} | Der Name des Geräts
TimeStamp | DateTime {get;} | Der dem Fehler zugeordnete Zeitstempel
Type | ScanErrorType {get}; | Die Art der Durchsuchung, bei der der Fehler aufgetreten ist


Klasse Network

Klasse Network

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Network-Constructor
  • Methode QueryNetworkInterfaceCards
  • Methode SetCurrentNetworkInterface
  • Eigenschaft CurrentNetworkInterface
  • Methode ScanNetworkDevices
  • Methode SetCommunicationsTimeout
  • Methode GetCommunicationsTimeout
  • Methode GetEmptyCollection


Network-Constructor

Network-Constructor

Die .NET-Klasse Network dient dazu, Funktionen mit Hilfe einer auf einem Programmiergerät installierten Netzwerkkarte (NIC) auszuführen. Die Klasse Network wird verwendet, um nach verfügbaren Schnittstellenkarten zu suchen und die Schnittstellenkarte auszuwählen, die mit dem Industrienetzwerk kommunizieren kann.

Zur Interaktion mit dem Industrienetzwerk deklariert Ihr Programm eine Variable des Typs Network wie folgt:

Network myNetwork = new Network();

Sie können mit Hilfe dieses Objekts verfügbare Netzwerkschnittstellen ermitteln und eine Netzwerkschnittstelle auswählen.


Methode QueryNetworkInterfaceCards

Methode QueryNetworkInterfaceCards

Rückgabetyp | Methodenname
Result | QueryNetworkInterfaceCards

Parameter
Name | Datentyp | Parametertyp | Beschreibung
aInterfaces | List<string> | Out | Eine Sammlung aller Netzwerkschnittstellenkarten auf dem Programmiergerät in einer Auflistung nach Namen

Zur Ermittlung der verfügbaren Netzwerkkarten verwenden Sie wie im folgenden Beispiel gezeigt die Methode QueryNetworkInterfaceCards:

Network myNetwork = new Network();

        List<String> interfaces = new List<String>();
Result retVal = myNetwork.QueryNetworkInterfaceCards(out interfaces);
if (retVal.Succeeded)
{
//-----------------------------------------------------
//
        Die Methode gibt eine Liste von Zeichenketten aus.
//
        Jede Zeichenkette in der Liste steht für eine verfügbare Netzwerkkarte (NIC).
//
        Die Liste kann in Arraynotation iteriert werden.
//-----------------------------------------------------
for (Int32 index = 0; index < interfaces.Count; index++)
{
String strInterfaceName = interfaces[index];
}
}

Wie das Beispiel zeigt, gibt diese Methode eine Liste von Zeichenketten aus. Jedes Element in der Liste steht für eine durch den Namen identifizierte verfügbare Netzwerkkarte.

Die QueryNetworkInterfaceCards gibt ein Result-Objekt zurück, das den Status des Vorgangs enthält. Dieses Objekt zeigt an, ob der Vorgang erfolgreich war (ob die Eigenschaft Succeeded wahr ist) oder fehlgeschlagen ist (d. h. die Eigenschaft Succeeded falsch ist). Vorgänge können aus vielen Gründen fehlschlagen. Die Result-Klasse enthält Eigenschaften und Methoden zum Abrufen weiterer Informationen über Fehler.


Methode SetCurrentNetworkInterface

Methode SetCurrentNetworkInterface

Rückgabetyp | Methodenname
Result | SetCurrentNetworkInterface

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strInterface | string | Eingang | Der Name der zu verwendenden Netzwerkkarte. In der Regel handelt es sich dabei um einen der zurückgegebenen Namen der Methode QueryNetworkInterfaceCards.

Um eine der identifizierten Netzwerkschnittstellenkarten für den Zugriff auf das Industrienetzwerk zu verwenden, müssen Sie diese Schnittstelle "einstellen". Der folgende Code zeigt, wie eine der identifizierten Netzwerkschnittstellen für API-Operationen zugewiesen wird. Bei diesem Beispiel wird mit dem Code die erste in QueryNetworkInterfaceCards ermittelte Netzwerkschnittstellenkarte ausgewählt:

Network myNetwork = new Network();

List<String> interfaces = new List<String>();
Result retVal = myNetwork.QueryNetworkInterfaceCards(out interfaces);
if (retVal.Succeeded)
{
retVal = myNetwork.SetCurrentNetworkInterface(interfaces[0]);
if (retVal.Succeeded)
{
//---------------------------------------------------
//
        Die Aktion war erfolgreich. Mit Vorgängen fortfahren.
//---------------------------------------------------
}
}


Eigenschaft CurrentNetworkInterface

Eigenschaft CurrentNetworkInterface

Diese schreibgeschützte Eigenschaft dient zum Durchführen einer Abfrage nach der aktuell ausgewählten Netzwerkschnittstelle. Im folgenden Beispiel wird die Verwendung dieser Eigenschaft gezeigt.

Network myNetwork = new Network();
string currentInterface = myNetwork.CurrentNetworkInterface;

Hinweis

Diese Eigenschaft gibt eine leere Zeichenkette aus, wenn durch einen früheren Aufruf der Methode SetCurrentNetworkInterface keine Netzwerkschnittstelle ausgewählt wurde.


Methode ScanNetworkDevices

Methode ScanNetworkDevices

Rückgabetyp | Methodenname
IScanErrorCollection | ScanNetworkDevices

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFile | IProfinetDeviceCollection | Ausgang | Eine Sammlung, die für jedes erreichbare Gerät im Industrienetzwerk ein Element IProfinetDevice enthält.

Nach Einrichtung einer Netzwerkschnittstelle können Sie die Geräte im Industrienetzwerk abfragen. Die Methode ScanNetworkDevices gibt eine Sammlung von Elementen aus, bei der jedes der Elemente ein direkt mit dem Ethernet-Netzwerk verbundenes Gerät darstellt. Bei diesen Geräten kann es sich um CPUs, lokale Module, dezentrale Peripheriestationen, HMI-Geräte und andere Geräte handeln.

Das Durchsuchen eines Netzwerks mit vielen Geräten kann mehrere Minuten dauern. Die Eigenschaft Succeeded in der zurückgegebenen IScanErrorCollection teilt Ihnen mit, ob die Suche erfolgreich war oder fehlgeschlagen ist.

Mit dem folgenden Beispiel wird eine Sammlung aller über die ausgewählte Netzwerkschnittstelle erreichbaren Geräte erzeugt.

Network myNetwork = new Network();

        //--------------------------------------------------------------------
//
        Hinweis: Bei diesem Beispiel wird davon ausgegangen, dass ein Aufruf von SetCurrentNetworkInterface
//
         die Zuordnung der Netzwerkschnittstellenkarte eingerichtet hat.
//--------------------------------------------------------------------

IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//---------------------------------------------------
//
         Die Aktion war erfolgreich. Mit Vorgängen fortfahren.
//---------------------------------------------------
}
else
{
foreach (ScanErrorEvent scanErrorEvent in scanResult)
{
//
        Fehlereignisse bei der Durchsuchung von Prozessen
}
}

Diese Methode gibt eine IProfinetDeviceCollection zurück.

Hinweis

Voraussetzungen für die Anwendung der Methode ScanNetworkDevices

Sie benötigen eine gültige und nicht abgelaufen SAT-Lizenz oder eine Installation des SDK, um die Methode ScanNetworkDevices erfolgreich anwenden zu können. Wenn das SDK oder eine nicht abgelaufene SAT-Lizenz während der Laufzeit nicht vorhanden ist, gibt die Methode ScanNetworkDevices eine leere Sammlung zurück. ScanNetworkDevices gibt keine Geräteinformationen an die aufrufende Anwendung zurück.


Methode SetCommunicationsTimeout

Methode SetCommunicationsTimeout

Rückgabetyp | Methodenname
Result | SetCommunicationsTimeout

Parameter
Name | Datentyp | Parametertyp | Beschreibung
nTimeout | uint | Eingang | Festgelegte Zeitbegrenzung für Vorgänge

Für die mit der API aufgerufenen Vorgänge kann eine Zeitbegrenzung festgelegt werden. Mit SetCommunicationsTimeout können Sie die Zeitbegrenzung auf einen Wert von 180 bis 999 Sekunden einstellen. Werte außerhalb dieses Bereichs führen zu einem Fehler des Vorgangs.

Das folgende Beispiel zeigt, wie die Methode für die Einstellung einer Zeitbegrenzung für ScanNetworkDevices-Vorgänge verwendet wird.

        Network myNetwork = new Network();

IProfinetDeviceCollection scannedDevices;

Result retVal = Network.SetCommunicationsTimeout(180); //
        Zeitbegrenzung von 3 Minuten
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//---------------------------------------------------
//
        Die Aktion war erfolgreich. Mit Vorgängen fortfahren.
//---------------------------------------------------
}


Methode GetCommunicationsTimeout

Methode GetCommunicationsTimeout

Rückgabetyp | Methodenname
uint | GetCommunicationsTimeout

Nach dem Einstellen des Zeitüberschreitungswert für die Kommunikation kann der Timeout-Wert mit Aufruf von GetCommunicationsTimeout abgefragt werden. Diese Methode gibt den aktuellen Timeout-Wert aus.

Das folgende Beispiel zeigt, wie der aktuelle Timeout-Wert abgefragt und ein neuer Timeout-Wert von 180 Sekunden eingestellt werden kann, wenn der aktuelle Wert größer als 180 Sekunden ist.

uint timeout = Network.GetCommunicationsTimeout();
if (timeout > 180)
{
    Result retVal = Network.SetCommunicationsTimeout(180);
}


Methode GetEmptyCollection

Methode GetEmptyCollection

Rückgabetyp | Methodenname
IProfinetDeviceCollection | GetEmptyCollection

Die GetEmptyCollection-Methode bietet einen alternativen Mechanismus zum Erfassen einer Sammlung von Profinet-Geräten ohne Netzwerkdurchsuchung. Das ist zum Beispiel praktisch, um einen Anwender in die Lage zu versetzen, ein Gerät in eine IProfinetDeviceCollection einzufügen, ohne zuvor eine vollständige Netzwerkdurchsuchung durchführen zu müssen.

IProfinetDeviceCollection ist eine Schnittstelle, die nicht instanziiert werden kann. Eine Netzwerkdurchsuchung gibt die Sammlung zurück. Um ein Projekt zu öffnen, ohne eine Netzwerkdurchsuchung durchzuführen, rufen Sie die Methode GetEmptyCollection so auf, dass sie eine leere Sammlung zurückgibt. Anschließend können Sie in die leere Profinet-Gerätesammlung ein Gerät einfügen, ohne eine Netzwerkdurchsuchung durchzuführen.

Das folgende Beispiel zeigt die Verwendung der Methode GetEmptyCollection.

IProfinetDeviceCollection collection = Network.GetEmptyCollection();
MemoryStream stream = new MemoryStream();

Result result = collection.WriteToStream(stream);
if (result.Succeeded)
{
//---------------------------------------------------
//
        Sammlung wurde erfolgreich serialisiert
//---------------------------------------------------
}


Klasse HealthCheck

Klasse HealthCheck

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • HealthCheck-Konstruktor
  • Methode ExportPCData


HealthCheck-Konstruktor

HealthCheck-Konstruktor

Die .NET-Klasse HealthCheck unterstützt die Erzeugung der PC-Datendatei und ist in der SimaticAutomationToolHealthCheck.dll definiert.

Zur Interaktion mit dem Industrienetzwerk instanziiert Ihr Programm ein Objekt des Typs HealthCheck wie folgt:

HealthCheck myHealthCheck = new HealthCheck();


Methode ExportPCData

Verwendung des Ereignisses ProgressChanged zur Überwachung des Fortschritts eines PC-Daten-Exports
Start Zurück Weiter

Methode ExportPCData

Rückgabetyp | Methodenname
HealthCheckResultType | ExportPCData

Parameter
Name | Datentyp | Parametertyp | Beschreibung
filePath | string | In | Der vollständige Pfad zum Speichern der ZIP-Datei mit den exportierten PC-Daten.

Die Methode ExportPCData erzeugt eine Datei HealhCheck.zip, die Daten über das Programmiergerät enthält. Das zurückgegebene HealthCheckResultType-Objekt zeigt das Ergebnis des Vorgangs an. Die Datei "HealthCheck.log" in der Datei "HealthCheck.zip" enthält Einzelheiten zu den exportierten Daten oder zu aufgetretenen Fehlern.

        HealthCheck myHealthCheck = new HealthCheck ();
String healthCheckFilePath = @"c:\export\healthcheck.zip";
HealthCheckResultType hcResult = myHealthCheck.ExportPCData(healthCheckFilePath);
if (hcResult == HealthCheckResultType.Success)
{
//---------------------------------------------------
//
        Aktion war erfolgreich. Vorgänge fortsetzen.
//
        Die Datei "HealthCheck.log" in der Datei "HealthCheck.zip"
//
        enthält Einzelheiten zu den exportierten Daten.
//---------------------------------------------------
}
else
{
//---------------------------------------------------
//
         Die Aktion ist fehlgeschlagen, es gab Warnungen oder sie wurde vom Anwender abgebrochen.
//
//
        Wenn der Vorgang nicht abgebrochen wurde, enthält die Datei "HealthCheck.log"
//
         in der Datei "HealthCheck.zip"

        Informationen
//
         zum Exportvorgang.
//---------------------------------------------------
}

Verwendung des Ereignisses ProgressChanged zur Überwachung des Fortschritts eines PC-Daten-Exports

Die API bietet das Ereignis ProgressChanged zur Überwachung des Fortschritts von Methoden, deren Ausführung lange Zeit in Anspruch nehmen kann. ExportPCData ist eine Methode, die lange Zeit in Anspruch nehmen kann.

Um das Ereignis ProgressChanged zur Überwachung des Fortschritts von ExportPCData verwenden zu können, hängen Sie einen Ereignis-Handler an das Ereignis an. Der Ereignis-Handler wird automatisch aufgerufen, wenn in Bezug auf den Fortschritt des Vorgangs eine Änderung eintritt.

Das folgende Beispiel zeigt, wie das Ereignis ProgressChanged eingesetzt wird, um den Fortschritt eines Exports von PC-Daten zu überwachen. Mit dem Beispielcode wird ein Ereignis-Handler definiert und an das Ereignis ProgressChanged angehängt. Anschließend ruft der Code die Methode ExportPCData auf, was lange Zeit in Anspruch nehmen kann. Wenn ExportPCData beendet ist, trennt der Beispielcode den Ereignis-Handler wieder vom Ereignis.

        HealthCheck myHealthCheck = new HealthCheck ();

//
         Für Fortschrittsereignis anmelden
myHealthCheck.ProgressChanged += healthCheck_ProgressChanged;

HealthCheckResultType hcResult = myHealthCheck.ExportPCData(healthCheckFilePath);

//
        Anmeldung für Fortschrittsereignis entfernen
myHealthCheck.ProgressChanged -= healthCheck_ProgressChanged;

private static void healthCheck_ProgressChanged(object sender,ExportProgressEventArgs e)
{
String strProgress = String.Format("Processing {0} of {1}", e.WorkItem, e.MaxEntries);
//
        Zum Abbrechen des Fortschritts auf Wahr setzen
e.Cancel = false;
}


Klasse IProfinetDeviceCollection

Klasse IProfinetDeviceCollection

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Elemente in der Sammlung iterieren
  • Elemente in der Sammlung filtern
  • Auffinden eines bestimmten Geräts in der Sammlung
  • Serialisierung
  • Elemente manuell der Sammlung hinzufügen
  • Daten aus einer Sammlung kopieren
  • Geräte aus der Sammlung entfernen


Elemente in der Sammlung iterieren

Elemente in der Sammlung iterieren

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Elemente in der Sammlung iterieren
  • Methode GetEnumerator
  • Eigenschaft Count
  • [ ] Eigenschaft


Elemente in der Sammlung iterieren

Elemente in der Sammlung iterieren

Die Methode ScanNetworkDevices gibt ein Objekt des Typs IProfinetDeviceCollection aus. Diese Klasse stellt die Fähigkeit bereit, die Elemente der Sammlung auf unterschiedliche Weise zu iterieren. Außerdem bietet sie Methoden zum "Filtern" der Elemente in der Sammlung nach bestimmten Kriterien.

Das Durchsuchen eines Netzwerks mit vielen Geräten kann mehrere Minuten dauern. Die Eigenschaft Succeeded in der zurückgegebenen IScanErrorCollection teilt Ihnen mit, ob die Suche erfolgreich war oder fehlgeschlagen ist.

Mit dem folgenden Beispiel wird eine Sammlung aller über die ausgewählte Netzwerkschnittstelle erreichbaren Geräte erstellt.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

Programmierer, die eine Array-ähnliche Syntax bevorzugen, können wie folgt auf die Elemente in scannedDevices zugreifen:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

if (scanResult.Succeeded)
{

for (int deviceIdx = 0; deviceIdx < scannedDevices.Count; deviceIdx++)
{
//‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
//
        Jedes Element in der Sammlung ist ein IProfinetDevice.
//
        Diese Schnittstelle wird im nächsten Abschnitt ausführlich beschrieben
//‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
IProfinetDevice dev = scannedDevices[deviceIdx];
}
}

Die Sammlung unterstützt außerdem die Iteration mit Hilfe der foreach-Syntax. Das folgende Beispiel zeigt dieselbe Sammlung mit einer Iteration mit Hilfe dieser Syntax:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
//‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
//
        Die Variable "
        dev
        " stellt jetzt das nächste Element der Sammlung dar
//‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
}
}


Methode GetEnumerator

Methode GetEnumerator

Rückgabetyp | Methodenname
IEnumerator<IProfinetDevice> | GetEnumerator

Parameter
Name | Datentyp | Parametertyp | Beschreibung
Keine |  |  |

Diese Methode dient zur Enumeration aller IProfinetDevices im IProfinetDeviceCollection.


Eigenschaft Count

Eigenschaft Count

Rückgabetyp | Name der Eigenschaft
int | Count

Diese Eigenschaft gibt die Anzahl IProfinetDevices in IProfinetDeviceCollection zurück.


[ ] Eigenschaft

[ ] Eigenschaft

Rückgabetyp | Name der Eigenschaft
IProfinetDevice | this[int index]

Diese Eigenschaft gibt das IProfinetDevice an einem spezifischen Index zurück. Siehe folgendes Beispiel:

IProfinetDeviceCollection collection = Network.GetEmptyCollection();
MemoryStream stream = new MemoryStream();

Result result = collection.WriteToStream(stream);
if (retVal.Succeeded)
{
//---------------------------------------------------
//
        Sammlung wurde erfolgreich serialisiert
//---------------------------------------------------

IProfinetDevice device = collection[0];
}


Elemente in der Sammlung filtern

Elemente in der Sammlung filtern

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Elemente der Sammlung
  • Methode FilterByDeviceFamily
  • Methode FilterOnlyCPUs


Elemente der Sammlung

Elemente der Sammlung

Die Sammlung enthält ein Element für jedes Gerät im Industrial-Ethernet-Netzwerk. Die Sammlung kann Geräte aus mehreren Produktfamilien (z. B. S7-1200, S7-1500 oder ET 200S) enthalten.

Die Sammlung kann ebenfalls unterschiedliche "Kategorien" von Geräten (z. B. CPUs oder Peripheriestationen) enthalten. Für unterschiedliche Gerätekategorien sind spezifische Operationen verfügbar. Deshalb kann es manchmal sinnvoll sein, die Sammlung zu "filtern", um nur mit bestimmten Geräten zu arbeiten.


Methode FilterByDeviceFamily

Methode FilterByDeviceFamily

Rückgabetyp | Name der Methode
List<IProfinetDevice> | FilterByDeviceFamily

Parameter
Name | Datentyp | Parametertyp | Beschreibung
familiesToInclude | List<DeviceFamily> | Eingang | Gerätefamilientypen, die in der Liste auszugeben sind

Diese Methode gibt eine Sammlung aus, die nur Geräte der angegebenen Produktfamilien enthält. Das Filterergebnis wird zunächst als Liste mit einer oder mehreren Produktfamilien aufgebaut. Beispielsweise erstellt die folgende Deklaration einen Filter nur mit S7-1200- und S7-1500-Geräten.

Übergeben Sie diesen "Filter" an die Methode FilterByDeviceFamily. Das Ergebnis ist eine Sammlung IProfinetDeviceCollection, die nur die Geräte der angegebenen Produktfamilien enthält:

Network myNetwork = new Network();
List<DeviceFamily> fams = new List<DeviceFamily> { DeviceFamily.CPU1200, DeviceFamily.CPU1500 };

IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

List<IProfinetDevice> onlyPlus = scannedDevices.FilterByDeviceFamily(fams);

Die resultierende Sammlung kann anschließend iteriert werden, um Aktionen nur mit den enthaltenen Geräten durchzuführen.

Hinweis

Die Übergabe einer leeren Deklaration List<DeviceFamily> führt zur Ausgabe einer leeren Sammlung.


Methode FilterOnlyCPUs

Methode FilterOnlyCPUs

Rückgabetyp | Name der Methode
List<ICPU> | FilterOnlyCPUs

Die SIMATIC Automation Tool API unterstützt zahlreiche Operationen, die nur mit CPUs zulässig sind. Daher ist es sinnvoll, die Sammlung nur nach den CPUs zu filtern, die im Netzwerk erkannt wurden.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

if (scanResult.Succeeded)

        {

List<ICPU> cpus = scannedDevices.FilterOnlyCpus();
foreach (ICPU cpu in cpus)
{
//----------------------------------------------------------
//
        Iteration im Durchgang durch die Liste nur aus CPU-Geräten
//----------------------------------------------------------
}
}

Diese Methode gibt eine Liste von ICPU aus. Für CPU-Geräte werden weitere API-Operationen unterstützt. Über die Schnittstelle ICPU werden diese Operationen bereitgestellt. Die Schnittstelle ICPU wird im Kapitel Schnittstelle ICPU ausführlich beschrieben.


Auffinden eines bestimmten Geräts in der Sammlung

Auffinden eines bestimmten Geräts in der Sammlung

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Methode FindDeviceByIP
  • Methode FindDeviceByMAC


Methode FindDeviceByIP

Methode FindDeviceByIP

Auffinden eines bestimmten Geräts in der Sammlung

Rückgabetyp | Methodenname
IProfinetDevice | FindDeviceByIP

Parameter
Name | Datentyp | Parametertyp | Beschreibung
ip | uint | Eingang | Die zu suchende IP-Adresse

Das folgende Beispiel zeigt die Suche nach einem Gerät an einer angegebenen IP-Adresse. Wird das Gerät nicht in der Sammlung gefunden, wird eine Referenz NULL zurückgegeben:

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
//
         Gefunden!
}


Methode FindDeviceByMAC

Methode FindDeviceByMAC

Mit der Methode FindDeviceByMAC kann nach einem Gerät mit einer bestimmten MAC-Adresse gesucht werden.

Rückgabetyp | Methodenname
IProfinetDevice | FindDeviceByMAC

Parameter
Name | Datentyp | Parametertyp | Beschreibung
mac | ulong | Eingang | Die zu suchende MAC-Adresse

Das folgende Beispiel zeigt die Suche nach einem Gerät an einer angegebenen MAC-Adresse. Wird das Gerät nicht in der Sammlung gefunden, wird eine Referenz NULL zurückgegeben:

ulong targetMAC = 0x112233445566; //
        äquivalent zur Zeichenkette 11:22:33:44:55:66
Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMAC);
if (dev != null)
{
//
         Gefunden!
}


Serialisierung

Serialisierung

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Übertragen einer Sammlung an eine externe Datendatei oder von dieser Datendatei
  • Methode WriteToStream
  • Methode ReadFromStream
  • Methode ExportDeviceInformation
  • Methode ExportDeviceDiagnostics


Übertragen einer Sammlung an eine externe Datendatei oder von dieser Datendatei

Übertragen einer Sammlung an eine externe Datendatei oder von dieser Datendatei

Die Serialisierungsmethoden ermöglichen es, den Inhalt einer Sammlung zu serialisieren und an eine externe Datendatei oder von dieser Datendatei zu übertragen.


Methode WriteToStream

Methode WriteToStream

Rückgabetyp | Methodenname
Result | WriteToStream

Parameter
Name | Datentyp | Parametertyp | Beschreibung
stream | Stream | Eingang | Das Ziel für die serialisierte Ausgabe der Sammlung.

Mit Hilfe dieser Methode wird der Inhalt der Sammlung extern gespeichert. Das folgende Beispiel zeigt die Verwendung dieser Methode.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
    return;

FileStream f = File.Create("myDataFile.SAT");

Result retVal = scannedDevices.WriteToStream(f);

f.Close();

Diese Methode serialisiert Versionsinformationen, wodurch die Vorwärtskompatibilität gespeicherter Daten unterstützt wird.


Methode ReadFromStream

Methode ReadFromStream

Mithilfe der Methode ReadFromStream wird die Sammlung aus einer zuvor erstellten Serialisierungsdatei hergestellt. Im folgenden Beispiel wird die Verwendung dieser Methode gezeigt:

Rückgabetyp | Methodenname
Result | ReadFromStream

Parameter
Name | Datentyp | Parametertyp | Beschreibung
stream | Stream | Eingang | Die Quelle für die Wiederherstellung einer serialisierten Sammlung

Mit Hilfe dieser Methode wird die Sammlung aus einer zuvor erstellten Serialisierungsdatei hergestellt. Das folgende Beispiel zeigt die Verwendung dieser Methode.

IProfinetDeviceCollection devices = Network.GetEmptyCollection();

FileStream f = File.OpenRead("myDataFile.SAT");

Result retVal = devices.ReadFromStream(f);

f.Close();


Methode ExportDeviceInformation

Methode ExportDeviceInformation

Die Methode ExportDeviceInformation erzeugt und exportiert eine CSV-Datei, die die Sammlungsdaten des aktuellen Geräts enthält:

Rückgabetyp | Methodenname
Result | ExportDeviceInformation

Parameter
Name | Datentyp | Parametertyp | Beschreibung
ExportFilePath | string | Eingang | Zieldateipfad für die generierte Exportdatei

Das folgende Beispiel zeigt die Verwendung dieser Methode:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

//--------------------------------------------------------------------------
//
        Hinweis: Dieses Beispiel geht davon aus, dass die Zuordnung der Netzwerkschnittstellenkarte (NIC) bereits durchgeführt wurde,
//
        wie in SetCurrentNetworkInterface dargestellt
//--------------------------------------------------------------------------

//--------------------------------------------------------------------------
// Die aktuellen Geräteinhalte im Netzwerk abrufen
//--------------------------------------------------------------------------

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

//--------------------------------------------------------------------------
//
        Passwort für jede CPU vergeben, die ein Passwort für den Zugriff auf Geräteinformationen benötigt.
//--------------------------------------------------------------------------
List<ICPU> aCPUs = scannedDevices.FilterOnlyCpus();
foreach (ICPU cpu in aCPUs)
{
if (cpu.Protected == true)
{
cpu.SetPassword(new EncryptedString("Password"));
}
}

String exportFilePath = @"c:\export\DeviceInformation.csv";
Result retVal = scannedDevices.ExportDeviceInformation(exportFilePath);


Methode ExportDeviceDiagnostics

Verwendung des Ereignisses ProgressChanged zur Überwachung des Fortschritts eines Gerätediagnose-Exports
Start Zurück Weiter

Methode ExportDeviceDiagnostics

Die Methode ExportDeviceDiagnostics erzeugt und exportiert eine CSV-Datei, die die Diagnosedaten jeder CPU in der aktuellen Gerätesammlung enthält. Die Spaltenüberschriften in der CSV-Datei sind auf Englisch.

Rückgabetyp | Methodenname
Result | ExportDeviceDiagnostics

Parameter
Name | Datentyp | Parametertyp | Beschreibung
ExportFilePath | string | Eingang | Zieldateipfad für die generierte Exportdatei
Language | Language | Eingang | Sprache für die exportierten Diagnosepuffereinträge
Format | TimeFormat | Eingang (optional) | Format für die Anzeige von Datum und Uhrzeit der Diagnoseeinträge

Das folgende Beispiel zeigt die Verwendung dieser Methode:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
//--------------------------------------------------------------------
// Note: this example assumes Network NIC assignment has already been made
//
         wie dargestellt in
        SetCurrentNetworkInterface
//--------------------------------------------------------------------
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

//--------------------------------------------------------------------------
//
        Wählen Sie alle für Diagnoseinformationen einzubeziehenden CPUs in der Geräteliste aus
//--------------------------------------------------------------------------
foreach (IProfinetDevice profi in scannedDevices)
{
if((profi.Family == DeviceFamily.CPU1200)||(profi.Family == DeviceFamily.CPU1500)||
(profi.Family == DeviceFamily.CPU300) || profi.Family == DeviceFamily.CPU400))

    profi.Selected = true;
}

//--------------------------------------------------------------------

        //
        Vergeben Sie ein Passwort für jede CPU, die ein Passwort für den Zugriff auf Geräteinformationen benötigt.
//--------------------------------------------------------------------
List<ICPU> aCPUs = deviceCollection.FilterOnlyCpus();
foreach (ICPU cpu in aCPUs)
{
cpu.SetPassword(new EncryptedString("Password"));
}

//  Bei der API bestimmt die Clientanwendung den Dateipfad und Dateinamen

String exportFilePath = @"c:\export\Device\DeviceDiagnostics.csv";

IScanErrorCollection exportResult =
   scannedDevices.ExportDeviceDiagnostics(exportFilePath, Language.English,TimeFormat.Local);

Die zurückgegebene Fehlersammlung gibt für jede CPU in der Sammlung an, ob die Diagnosedaten erfolgreich erfasst wurden. Wenn ein erforderliches Passwort nicht angegeben wurde oder ein Netzwerkfehler aufgetreten ist, wird der Fehler für die CPU aufgeführt. Ein Fehler bewirkt, dass für die CPU eine Null-Dateneingabe gespeichert wird.

Verwendung des Ereignisses ProgressChanged zur Überwachung des Fortschritts eines Gerätediagnose-Exports

Die API bietet das Ereignis ProgressChanged zur Überwachung von Methoden, deren Ausführung lange dauern kann. ExportDeviceDiagnostics ist eine Methode, die viel Zeit beanspruchen kann.

Um das Ereignis ProgressChanged zur Überwachung des Fortschritts von ExportDeviceDiagnostics verwenden zu können, hängen Sie einen Ereignis-Handler an das Ereignis an. Der Ereignis-Handler wird automatisch aufgerufen, wenn in Bezug auf den Fortschritt des Vorgangs eine Änderung eintritt.

Das folgende Beispiel zeigt, wie das Ereignis ProgressChanged eingesetzt wird, um den Fortschritt eines Gerätediagnose-Exports zu überwachen. Mit dem Beispielcode wird ein Ereignis-Handler definiert und an das Ereignis ProgressChanged angehängt. Anschließend ruft der Code die Methode ExportDeviceDiagnostics auf, was lange Zeit in Anspruch nehmen kann. Wenn ExportDeviceDiagnostics beendet wird, trennt der Beispielcode den Ereignis-Handler wieder vom Ereignis.

        Network myNetwork = new Network();

IProfinetDeviceCollection deviceCollection = null;

//
        Aufrufsequenz zum Export von Gerätediagnosedaten
//
         Durchsuchung nach Netzwerkgeräten
IScanErrorCollection scanErrors = myNetwork.ScanNetworkDevices(out deviceCollection);

// Für Fortschrittsereignis anmelden
deviceCollection.ProgressChanged += Export_ProgressChanged;

IScanErrorCollection ExportDeviceDiagnosticsErrors = deviceCollection.ExportDeviceDiagnostics(@"C:\MyDocuments\DeviceDiagnostics.csv", Language.English, TimeFormat.UTC);

// Anmeldung für Fortschrittsereignis entfernen

deviceCollection.ProgressChanged -= Export_ProgressChanged;

private static void Export_ProgressChanged(object sender,ExportProgressEventArgs e)
{
String strProgress = String.Format("Processing {0} of {1}", e.WorkItem, e.MaxEntries);
// Zum Abbrechen des Fortschritts auf Wahr setzen
e.Cancel = false;
}


Elemente manuell der Sammlung hinzufügen

Elemente manuell der Sammlung hinzufügen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Elemente manuell der Sammlung hinzufügen
  • Methode InsertDeviceByIP
  • Methode InsertDeviceByMAC


Elemente manuell der Sammlung hinzufügen

Elemente manuell der Sammlung hinzufügen

Abhängig von der physischen Topologie des industriellen Netzwerks gibt es möglicherweise Geräte im Netzwerk, die nicht auf einen DCP-Befehl reagieren können (wie z. B. die von der Methode ScanNetworkDevices verwendeten), auf die jedoch über die IP-Adresse zugegriffen werden kann. Mit den Methoden zum Einfügen eines Geräts können Sie der Sammlung ein Gerät anhand seiner Adresse manuell hinzufügen.


Methode InsertDeviceByIP

Methode InsertDeviceByIP

Rückgabetyp | Methodenname
Result | InsertDeviceByIP

Parameter
Name | Datentyp | Parametertyp | Beschreibung
index | int | Eingang | Stelle in der Sammlung, an der der Wert eingefügt werden soll
ip | uint | Eingang | IP-Adresse des zur Sammlung hinzuzufügenden Geräts

Der folgende Code fragt das Netzwerk ab und fügt dann manuell ein Gerät an einer spezifischen IP-Adresse und dem angegebenen Index hinzu.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
    return;

UInt32 missingDeviceIPAddress = 0xC0A80001; // 192.168.0.1
Int32 index = 0;

Result retVal = scannedDevices.InsertDeviceByIP(index, missingDeviceIPAddress);


Methode InsertDeviceByMAC

Methode InsertDeviceByMAC

Rückgabetyp | Methodenname
Result | InsertDeviceByMAC

Parameter
Name | Datentyp | Parametertyp | Beschreibung
index | int | Eingang | Stelle in der Sammlung, an der der Wert eingefügt werden soll
mac | ulong | Eingang | MAC-Adresse des zur Sammlung hinzuzufügenden Geräts

Der folgende Code durchsucht das Netzwerk und fügt dann manuell ein Gerät an einer spezifischen MAC-Adresse und dem angegebenen Index hinzu.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

UInt64 targetMAC = 0x112233445566; //
         äquivalent zur Zeichenkette 11:22:33:44:55:66
Int32 index = 0;

retVal = scannedDevices.InsertDeviceByMAC(index, targetMAC);


Daten aus einer Sammlung kopieren

Daten aus einer Sammlung kopieren

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Methode CopyUserData


Methode CopyUserData

Methode CopyUserData

Unter Umständen müssen Sie die vom Anwender eingegebenen Daten von einer IProfinetDeviceCollection in eine andere kopieren. Der Anwender muss jedoch diese Informationen nicht erneut eingeben, sondern die API stellt dazu die Methode CopyUserData bereit.

Rückgabetyp | Methodenname
Result | CopyUserData

Parameter
Name | Datentyp | Parametertyp | Beschreibung
oldNetwork | IProfinetDeviceCollection | Eingang | Zuvor in der Anwendung verwendete Liste

Mit dem folgenden Code werden vom Benutzer eingegebene Daten von einer Suche im Netzwerk in eine andere Suche kopiert.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
    return;

IProfinetDeviceCollection rescannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out rescannedDevices);
if (!scanResult.Succeeded)
    return;

Result retVal = rescannedDevices.CopyUserData(scannedDevices);
if (!retVal.Succeeded)
    return;


Geräte aus der Sammlung entfernen

Geräte aus der Sammlung entfernen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Methode Clear
  • Methode Remove


Methode Clear

Methode Clear

Rückgabetyp | Methodenname
void | Clear

Parameter
Name | Datentyp | Parametertyp | Beschreibung
Keine |  |  |

Mithilfe dieser Methode wird der Inhalt der durchsuchten Geräte gelöscht.


Methode Remove

Methode Remove

Rückgabetyp | Methodenname
void | Remove

Parameter
Name | Datentyp | Parametertyp | Beschreibung
device | IProfinetDevice | Eingang | Aus der Liste zu entfernendes Gerät

Mit dieser Methode wird ein Gerät aus der Sammlung entfernt.


Schnittstelle IProfinetDevice

Schnittstelle IProfinetDevice

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • IProfinetDevice-Eigenschaften
  • IProfinetDevice-Methoden
  • IProfinetDevice-Ereignisse


IProfinetDevice-Eigenschaften

DeviceFamily Eigenschaft Modules und Klasse IModuleCollection
Start Zurück Weiter

IProfinetDevice-Eigenschaften

Jedes Element der Sammlung IProfinetDeviceCollection wird durch die Schnittstelle IProfinetDevice repräsentiert. Diese Schnittstelle ermöglicht den Zugriff auf die Daten und stellt Vorgänge für alle Geräte bereit, die direkt mit dem Industrienetzwerk verbunden sind.

Die Schnittstelle IProfinetDevice unterstützt die folgenden Eigenschaften, die Informationen über das Netzwerkgerät bereitstellen. Alle diese Eigenschaften sind schreibgeschützt. Damit sichergestellt ist, dass die Eigenschaften die aktuellen Informationen zurückgeben, müssen Sie vor dem Auslesen einer Eigenschaft zunächst die Methode RefreshStatus für das Gerät aufrufen.

Name der Eigenschaft

Rückgabetyp

Beschreibung

ArticleNumber

string {get;}

Bestellnummern des Moduls. Auch bezeichnet als MLFB oder "Artikelnummer".

Comment

string {get;set;}

Hiermit kann der Anwender dem Gerät einen Kommentar zuordnen, der in der Benutzeroberfläche des SIMATIC Automation Tool verwendet wird. Der Kommentar ist für API-Operationen nicht relevant.

Configured

bool {get;}

Wahr, wenn das Gerät eine gültige Konfiguration besitzt

DefaultGateway

uint {get;}

Die Standard-Gateway-Adresse des Geräts, dargestellt als vorzeichenlose Ganzzahl. In der verschlüsselten Gateway-Adresse wird jeweils ein Byte zur Darstellung der einzelnen Dezimalwerte in der Adresse verwendet. So ist z. B. der verschlüsselte Wert 0xC0A80001 äquivalent zu der häufigeren Zeichenketten-Darstellung als "192.168.0.1"

DefaultGatewayString

string {get;}

Die Standard-Gateway-Adresse des Geräts bei Darstellung als Zeichenkette, im Format "xx.xx.xx.xx"
Beispiel: 192.168.0.1

Description

string {get;}

Eine Beschreibung des Hardware-Elements auf Basis der Artikelnummer. Hierbei handelt es sich um dieselbe Beschreibung, die der Anwender im TIA Portal sieht.

Beispiel: CPU 1215 DC/DC/DC

DeviceFound

bool {get;}

Wurde das Gerät beim Durchsuchen des Netzwerks gefunden?

DuplicateIP

bool {get;}

Hat das Gerät eine IP-Adresse, die dupliziert ist?

DuplicateProfinetName

bool {get;}

Hat das Gerät einen PROFINET-Namen, der dupliziert ist?

Failsafe

bool {get;}

Ist dies laut Artikelnummer (ArticleNumber) ein fehlersicheres Gerät?

Family

DeviceFamily {get;}

Zu welcher "Gerätefamilie" gehört das Gerät? Weitere Informationen finden Sie in der Beschreibung der DeviceFamily-Enumeration.

FirmwareUpdateAllowed

bool {get;}

Unterstützt dieses Gerät Firmware-Aktualisierungen?

FirmwareVersion

string {get;}

Aktuelle Firmware-Version des Geräts

ID

uint {get;}

Die eindeutige Kennung für jedes Gerät und Modul in der Station. Sie wird als eindeutige Kennung bei Ausführung eines Vorgangs FirmwareUpdate verwendet.

HardwareNumber

short {get;}

Hardware-Version oder "F-Stand" des Geräts (Funktionszustand)

IP

uint {get;}

Die IP-Adresse des Geräts, dargestellt als vorzeichenlose Ganzzahl. In der verschlüsselten IP-Adresse wird jeweils ein Byte zur Darstellung der einzelnen Dezimalwerte in der IP-Adresse verwendet. So ist z. B. der verschlüsselte Wert 0xC0A80001 äquivalent zu der häufigeren Zeichenketten-Darstellung als "192.168.0.1"

HINWEIS: Das SIMATIC Automation Tool unterstützt nur IPv4-Adressen. IPv6-Adressierung wird nicht unterstützt.

IPString

string {get;}

Die IP-Gateway-Adresse des Geräts bei Darstellung als Zeichenkette im Format "xx.xx.xx.xx" (z. B. 192.168.0.1)

MAC

ulong {get;}

Die dem Gerät zugeordnete eindeutige MAC-Adresse. In der verschlüsselten MAC-Adresse wird jeweils ein Byte zur Verschlüsselung eines der 6 Oktette verwendet, die für die Adresse definiert sind. So ist z. B. die verschlüsselte MAC-Adresse 0x112233445566 äquivalent zu der üblicheren Zeichenkettendarstellung als "11:22:33:44:55:66"

MACString

string {get;}

Die dem Gerät zugeordnete eindeutige MAC-Adresse, dargestellt als Zeichenkette im Format "11:22:33:44:55:66".

Modules

IModuleCollection {get;}

Eine Sammlung der in die Station eingesteckten Module. Diese Eigenschaft wird hier ausführlich beschrieben.

Name

string {get;}

Name des Geräts

NewFirmwareFile

string {get;}

Ort der Firmware-Datei für eine Firmware-Aktualisierung

NewFirmwareNameErrorCode

Result {get;}

ErrorCode zum neuen Firmware-Namen

NewFirmwareNameIsValid

bool {get;}

Ist die eingestellte Firmware-Datei gültig?

NewFirmwareVersion

string {get;}

Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.

NewDefaultGateway

String {get;}

Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.

NewIP

String {get;set;}

Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.

NewProfinetName

String{get;set;}

Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.

NewProgramName

String {get;set;}

Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.

NewRestoreName

String{get;set;}

Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.

ProfinetName

String {get;}

PROFINET-Name des Geräts

ResetToFactoryAllowed

bool {get;}

Ist ResetToFactory für das Gerät erlaubt?

Selected

bool {get;set;}

Markiert das Gerät als ausgewählt für die auszuführenden Operationen

SerialNumber

string {get;}

Eindeutige Seriennummer des Geräts

Slot

uint {get;}

Steckplatznummer des Hardware-Elements

SlotName

string {get;}

Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.

StationNumber

uint {get;}

Stationsnummer des Geräts

SubSlot

uint {get;}

Die Subslot-Nummer des Geräts. Diese ist für steckbare Submodule wie die S7-1200 SB-Module relevant.

Supported

bool {get;}

Wahr, wenn die Artikelnummer in der Datenbank vorhanden ist und das Gerät durch das aktuelle SIMATIC Automation Tool API unterstützt wird.

SubnetMask

uint {get;}

Die Subnetzmaske des Geräts, dargestellt als vorzeichenlose Ganzzahl. In der verschlüsselten Subnetzmaske wird jeweils ein Byte zur Darstellung der einzelnen Dezimalwerte in der Adresse verwendet. So ist z. B. der verschlüsselte Wert 0xFFFFFF00 äquivalent zu der üblicheren Zeichenketten-Darstellung als "255.255.255.0"

SubnetMaskString

string {get;}

Die Subnetzmaske des Geräts, dargestellt als Zeichenkette im Format "xx.xx.xx.xx" (z. B. 192.168.0.1)


IProfinetDevice-Methoden

IProfinetDevice-Methoden

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Methode RefreshStatus
  • Methode FirmwareUpdate
  • Methode Identify
  • Methode ResetCommunicationParameters
  • Methode SetIP
  • Methode SetProfinetName
  • Methode ValidateIPAddressSubnet
  • Methode ValidatePROFINETName


Methode RefreshStatus

Methode RefreshStatus

Rückgabetyp | Methodenname
Result | RefreshStatus

Wenn mit der Methode ScanNetworkDevices eine IProfinetDeviceCollection-Sammlung erstellt wird, gibt die Netzwerksuche zu den einzelnen Geräten nur eine minimale Informationsmenge zurück. Um alle verfügbaren Informationen über das Gerät abzurufen, rufen Sie die Methode RefreshStatus auf. Diese Methode stellt eine Verbindung zum Gerät her, fragt verschiedene Informationen ab und trennt die Verbindung dann wieder.

Mit dem folgenden Code wird RefreshStatus für jedes Gerät im Netzwerk aufgerufen:

        Network myNetwork = new Network();
Result retVal = new Result();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded))
{
foreach (IProfinetDevice dev in scannedDevices)
{

retVal = dev.RefreshStatus();
if (retVal.Succeeded)
{
//-------------------------------------------------
//
        Der Vorgang war erfolgreich. Die Daten sind vertrauenswürdig
//-------------------------------------------------
}
}
}

Die Methode RefreshStatus stellt eine Verbindung zum Gerät her, um Informationen auszulesen. Wenn das Gerät eine CPU ist, ist die CPU möglicherweise passwortgeschützt. Die Methode RefreshStatus und alle anderen Methoden, die eine interne Geräteverbindung mit der CPU herstellen, erfordern einen Passwortparameter.
Das Beispiel zeigt die Klasse IProfinetDevice. ICPU erfordert eine Passworteinstellung im Gerät, bevor die Methode RefreshStatus aufgerufen wird. Legen Sie mit der Methode SetPassword (EncryptedString) ein Passwort fest.


Methode FirmwareUpdate

Methode FirmwareUpdate

Rückgabetyp | Methodenname
Result | FirmwareUpdate

Parameter
Name | Datentyp | Parametertyp | Beschreibung
hardwareID | uint | Eingang | Hardware-Kennung des Moduls
bUpdateSameVersion | Bool | Eingang | Wenn wahr, setzt die Methode die Aktualisierung fort. Die Aktualisierung wird fortgesetzt, wenn die Aktualisierungsdatei die gleiche Version aufweist wie die aktuelle Firmware-Version des Moduls.

Mit dieser Methode wird die Firmware-Version des angegebenen Hardware-Elements (hardwareID) auf dem Gerät aktualisiert. Die Hardware-Kennung (hardwareID) gibt entweder das Gerät selbst oder ein Modul auf demselben Baugruppenträger an.

Einige Geräte unterstützen die Firmware-Aktualisierungsfunktion nicht. Ob das aktuelle Gerät diese Funktion unterstützt, kann mit Hilfe der Eigenschaft FirmwareUpdateAllowed überprüft werden.

Das folgende Beispiel zeigt die Suche nach einem Gerät an einer bestimmten IP-Adresse und die Aktualisierung der Firmware in diesem Gerät.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
    return;

uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string updateFile = @"c:\myUpdates\6ES7 221-1BF32-0XB0 V02.00.00.upd";

IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
    Result retVal = dev.RefreshStatus();

if (!retVal.Succeeded)
        return;

dev.Selected = true;
    dev.SetFirmwareFile(updateFile);
    retVal = dev.FirmwareUpdate(dev.ID, true);
}

Mithilfe der Methode FirmwareUpdate kann auch die Firmware eines Moduls an einer Zentralstation aktualisiert werden. Der folgende Code zeigt die Suche nach einer CPU an einer bestimmten Adresse und die anschließende Prüfung der Module an dieser CPU auf eine bestimmte Artikelnummer. Im Ergebnis wird die Firmware der Module aktualisiert, die den Suchkriterien entsprechen.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string targetModule = @"6ES7 221-1BF32-0XB0";
string updateFile = @"c:\myUpdates\6ES7 221-1BF32-0XB0 V02.00.00.upd";

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

if (!scanResult.Succeeded)
return;

IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{

Result retVal = dev.RefreshStatus();
if (!retVal.Succeeded)
return;

//----------------------------------
//
        Nach Modulen an der CPU suchen
//----------------------------------
IModuleCollection mods = dev.Modules;
foreach (IModule mod in mods)
{
if (mod.ArticleNumber == targetModule)
{
mod.Selected = true;
mod.SetFirmwareFile(updateFile);

//----------------------------------------
//
        Firmware für übereinstimmende Module aktualisieren
//----------------------------------------
dev.FirmwareUpdate(mod.ID, true);
}
}
}

Beachten Sie, dass die Methode FirmwareUpdate für die CPU aufgerufen wird. Die an die Methode übergebene hardwareID gibt an, welches Modul aktualisiert werden soll.

Hinweis

Firmware-Aktualisierungsdateien Classic und Plus

Es gibt zwei verschiedene Arten von Firmware-Aktualisierungsdateien.

  • Die Firmware-Aktualisierungsordner des Typs Classic enthalten verschiedene Dateien, die die Firmware-Aktualisierung bilden. Die Datei header.upd bzw. cpu_hd.upd in diesem Ordner ist die Datei, die an die Methode FirmwareUpdate übergeben wird.

  • Bei der Firmware-Aktualisierungsdatei des Typs Plus handelt es sich um eine einzelne Aktualisierungsdatei. Dies ist die Datei, die an die Methode FirmwareUpdate übergeben wird.


Methode Identify

Methode Identify

Rückgabetyp | Methodenname
Result | Identify

Diese Methode bewirkt das Blinken einer Geräte-LED oder eines HMI-Displays eines bestimmten Netzwerkgeräts. Die blinkende Leuchte hilft, den physischen Standort des Geräts zu ermitteln.

Das Beispiel zeigt den Code, durch den die LED oder der Bildschirm an dem Gerät mit der IP-Adresse 192.168.0.1 blinkt.

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//-----------------------------------------------------------
//
        Nach dem Gerät an der IP-Adresse suchen und Blinken von LED/HMI-Bildschirm auslösen
//-----------------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
retVal = dev.Identify();
}
}


Methode ResetCommunicationParameters

Methode ResetCommunicationParameters

Rückgabetyp | Name der Methode
Result | ResetCommunicationParameters

Diese Methode dient zum Zurücksetzen von Kommunikationsparametern eines PROFINET-Geräts auf die Werkseinstellungen. Damit werden die folgenden Parameter eingestellt:

  • NameOfStation auf leere Zeichenkette ""

  • IP-Suite-Parameter auf 0.0.0.0

  • DHCP-Parameter (falls verfügbar) auf Werkseinstellungen

  • Alle P Dev-Parameter (PD IR Data, PD Port Data Adjust, PD Interface MRP Data Adjust …) auf Werkseinstellungen

  • Von SMNP angepasste Parameter wie sysContact, sysName und sysLocation von MIB-II auf Werkeinstellungen

Das folgende Beispiel zeigt den Aufruf der Methode ResetCommunicationParameters für ein Gerät an einer bestimmten IP-Adresse:

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001;  // 192.168.0.1
IProfinetDeviceCollection scannedDevices;

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//--------------------------------------------------------------------
//
        Nach dem Gerät unter der IP-Adresse suchen und das Gerät zurücksetzen
//--------------------------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
Result retVal = dev.ResetCommunicationParameters();
}
}

Hinweis

Diese Methode kann nicht zum Zurücksetzen einer CPU verwendet werden, es sei denn, die CPU ist als I-Device konfiguriert. Zum Rücksetzen von CPUs bietet die ICPU-Schnittstelle die Methode ResetToFactoryDefaults.


Methode SetIP

Adressen aus einem Zeichenkettenformat in eine verschlüsselte vorzeichenlose Ganzzahl (Uint) umwandeln:
Start Zurück Weiter

Methode SetIP

Rückgabetyp | Methodenname
Result | SetIP

Parameter
Name | Datentyp | Parametertyp | Beschreibung
nIP | uint | Eingang | Neue verschlüsselte IP-Adresse
nSubnet | uint | Eingang | Neue verschlüsselte Subnetz-Adresse
nGateway | uint | Eingang | Neue verschlüsselte Gateway-Adresse

Diese Methode wird zum Einstellen oder Ändern der IP-Adresse eines Geräts verwendet.

Damit dieser Vorgang erfolgreich ausgeführt wird, muss für den Geräteport die Option "IP-Adresse direkt am Gerät einstellen" konfiguriert sein.

Das folgende Beispiel zeigt die Suche nach einem Gerät an einer angegebenen MAC-Adresse und das Einstellen der IP-Adresse des Geräts:

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Nach dem Gerät an dieser MAC-Adresse suchen und IP-Adresse einstellen
//------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMACAddress);
if (dev != null)
{
Result retVal = dev.SetIP(0xC0A80001, 0xFFFFFF00, 0x0);
}
}

Adressen aus einem Zeichenkettenformat in eine verschlüsselte vorzeichenlose Ganzzahl (Uint) umwandeln:

Die Methode SetIP erwartet, dass die Adressen in verschlüsseltem Format vorliegen (wie oben gezeigt). Sie können die Adressen mit folgendem C#-Code von einem Zeichenkettenformat in ein verschlüsseltes Format Uint (vorzeichenlose Ganzzahl) umwandeln:

string userEnteredAddress = @"192.168.0.1"; // Beispiel

//-------------------------------
// Zeichenketten-Adressen in Uint umwandeln
//-------------------------------

System.Net.IPAddress ip = System.Net.IPAddress.Parse(userEnteredAddress);
byte[] bytes = ip.GetAddressBytes();
Array.Reverse(bytes);

uint encodedIp = BitConverter.ToUInt32(bytes, 0); // verschlüsselte IP-Adresse, zur Verwendung verfügbar


Methode SetProfinetName

Methode SetProfinetName

Rückgabetyp | Methodenname
Result | SetProfinetName

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strName | String | Eingang | Der neue Name für die PROFINET-Station

Verwenden Sie diese Methode, um den Namen der PROFINET-Station für das Gerät festzulegen oder zu ändern. Damit diese Operation erfolgreich ausgeführt wird, muss für den Geräteport im STEP 7-Projekt die Option "PROFINET-Name direkt am Gerät einstellen" konfiguriert sein:

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Nach dem Gerät an dieser MAC-Adresse suchen und PROFINET-Namen einstellen
//------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMACAddress);
if (dev != null)
{
Result retVal = dev.SetProfinetName("new name");
}
}


Methode ValidateIPAddressSubnet

Methode ValidateIPAddressSubnet

Rückgabetyp | Methodenname
Result | ValidateIPAddressSubnet

Parameter
Name | Datentyp | Parametertyp | Beschreibung
nIP | uint | Eingang | IP-Adresse
nSubnetMask | uint | Eingang | Subnetzmaske

Verwenden Sie diese Methode, um eine Kombination aus IP-Adresse und Subnetzmaske darauf zu überprüfen, ob beide miteinander kompatibel sind.

Das folgende Beispiel zeigt die Suche nach einem Gerät an einer angegebenen MAC-Adresse und die Bestätigung, dass IP-Adresse und Subnetzmaske des Geräts kompatibel sind.

        Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Nach dem Gerät an dieser MAC-Adresse suchen und IP-Adresse einstellen
//------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMACAddress);

if (dev != null)
{
Result retVal = dev.ValidateIPAddressSubnet(dev.IP, dev.SubnetMask);
}
}


Methode ValidatePROFINETName

Methode ValidatePROFINETName

Rückgabetyp | Methodenname
Result | ValidatePROFINETName

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strName | string | Eingang | PROFINET-Name, der bestätigt werden soll

Mit dieser Methode kann der angegebene PROFINET-Name bestätigt werden.

Das folgende Beispiel zeigt die Suche nach einem Gerät an einer angegebenen MAC-Adresse und die Bestätigung, dass der angegebene PROFINET-Name gültig ist, bevor er dem Gerät zugeordnet wird:

        Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Nach dem Gerät an dieser MAC-Adresse suchen und IP-Adresse einstellen
//------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMACAddress);

if (dev != null)
{
string name = "ValidName";
Result retVal = dev.ValidatePROFINETName(name);
if (retVal.Succeeded)
{
retVal = dev.SetProfinetName(name);
}
}
}


IProfinetDevice-Ereignisse

IProfinetDevice-Ereignisse

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Ereignis DataChanged
  • Ereignis ProgressChanged


Ereignis DataChanged

Klasse DataChangedEventArgs

Ereignis DataChanged

Die Schnittstelle IProfinetDevice unterstützt das Ereignis DataChanged.

Mit Hilfe dieses Ereignisses kann das Programm überwachen, ob bei einem gegebenen Gerät im Netz Änderungen auftreten, die durch andere von der API veranlasste Vorgänge verursacht wurden. Wenn beispielsweise das Programm einen Verweis auf ein bestimmtes IProfinetDevice enthält, kann es bestimmte Änderungen an diesem Gerät registrieren ("abhören").

Im folgenden Beispiel nimmt der Code eine Verknüpfung mit dem Ereignis DataChanged für jedes Gerät im Netzwerk vor.

private void AttachEvents(IProfinetDeviceCollection devices)
{
  foreach (IProfinetDevice dev in devices)
  {
    dev.DataChanged += new DataChangedEventHandler(Dev_DataChanged);
  }
}

private void DetachEvents(IProfinetDeviceCollection devices)
{
  foreach (IProfinetDevice dev in devices)
  {
    dev.DataChanged -= new DataChangedEventHandler(Dev_DataChanged);
}
}

        private void Dev_DataChanged(object sender, DataChangedEventArgs e)
{
if (e.Type == DataChangedType.OperatingState)
{
//
        Betriebszustand des Objekts hat sich geändert. Hier auf Änderungen reagieren.
}
}

Wenn nun eine Aktion der API einen Betriebszustandswechsel des Geräts hervorruft, wird die Methode Dev_DataChanged aufgerufen.

Hinweis

Das Ereignis DataChanged überwacht das Netzwerk nicht aktiv im Betrieb, sondern es überwacht die Eigenschaften von IProfinetDevice. Um das Ereignis auszulösen, muss sich der Zustand des Objekts ändern.

Klasse DataChangedEventArgs

Der Handler für das Ereignis DataChanged empfängt ein Objekt DataChangedEventArgs. Wie im obigen Beispiel gezeigt, besitzt diese Klasse eine einzige Eigenschaft "Type" vom Datentyp DataChangedType.


Ereignis ProgressChanged

Klasse ProgressChangedEventArgs

Ereignis ProgressChanged

Die Schnittstelle IProfinetDevice unterstützt das Ereignis ProgressChanged.

Das Ereignis ermöglicht dem Programm die Überwachung von Methoden, die lange Zeit in Anspruch nehmen. FirmwareUpdate ist ein Beispiel für eine solche Methode.

Damit das Ereignis genutzt werden kann, hängen Sie einen Ereignis-Handler an das Ereignis an. Der Ereignis-Handler wird aufgerufen, wenn es zu einer Änderung im Fortschritt eines Vorgangs kommt.

Das folgende Beispiel zeigt, wie Sie den Ausführungsfortschritt überwachen können. In diesem Beispiel wird eine Methode gezeigt, welche die Firmware für ein Gerät im Netzwerk aktualisiert. Dieser Vorgang kann erhebliche Zeit in Anspruch nehmen. Um den Fortschritt der Aktion überwachen zu können, definiert die Methode einen Ereignis-Handler und hängt ihn an das Ereignis ProgressChanged an. Nach Beendigung der Firmware-Aktualisierung wird der Ereignis-Handler wieder vom Ereignis entfernt:

private void UpdateCpuAtAddress(IProfinetDeviceCollection devices,uint targetIPAddress, string updateFile)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        dev.ProgressChanged += new

        ProgressChangedEventHandler(Dev_ProgressChanged);
        dev.SetFirmwareFile(updateFile);
        dev.FirmwareUpdate(dev.ID, true);

        dev.ProgressChanged -= new

        ProgressChangedEventHandler(Dev_ProgressChanged);
    }
}

private void Dev_ProgressChanged(object sender, ProgressChangedEventArgs e)
{
    IProfinetDevice device = sender as IProfinetDevice;
    double percent = 0;
    if (device != null)
    {
        if (e.Count != 0)
        {
            string sPercent = e.Index.ToString() + " %";
        }
    }
}

Klasse ProgressChangedEventArgs

Der Handler für das Ereignis ProgressChanged empfängt ein Objekt ProgressChangedEventArgs. Dieses Objekt hat folgende Eigenschaften:

Name der Eigenschaft | Rückgabetyp | Beschreibung
Action | ProgressAction | Beschreibung der aktuellen Aktion
Cancel | bool | Wurde die Aktion abgebrochen?
Count | int | Gesamtmenge der zu übertragenden Daten
ID | uint | Hardware-ID
Index | int | Die aktuelle übertragene Datenmenge


Klasse IModuleCollection und Moduleigenschaften

Klasse IModuleCollection und Moduleigenschaften

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Eigenschaft Modules und Klasse IModuleCollection
  • Schnittstelle IModule


Eigenschaft Modules und Klasse IModuleCollection

Eigenschaft Modules und Klasse IModuleCollection

Die Schnittstelle IProfinetDevice stellt Informationen über Module an der Station bereit, beispielsweise über Signalmodule, Signalboards, CMs und CPs. Die Eigenschaft Modules gibt eine Sammlung dieser Module aus.

Der folgende Code zeigt den Zugriff auf diese Informationen mithilfe eines bereits vorhandenen IProfinetDevice.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//---------------------------------------------------
//
        Um Aktualität und Vollständigkeit der Informationen sicherzustellen,
//
        zuerst aufrufen:
         RefreshStatus()
//---------------------------------------------------
Result retVal = scannedDevices[0].RefreshStatus();
if (retVal.Succeeded)
{
//-----------------------------------------------------
//
        Die Eigenschaft Modules gibt eine Sammlung zurück von
        IModule
//-----------------------------------------------------
IModuleCollection modules = scannedDevices[0].Modules;
foreach (IModule mod in modules)
{
//---------------------------------------------------
//
        Artikelnummer abrufen für jedes Modul an der Station
//---------------------------------------------------
string displayArticleNum = mod.ArticleNumber;
}
}
}


Schnittstelle IModule

Schnittstelle IModule

Jedes Modul an der Station wird als eine Schnittstelle IModule repräsentiert. Diese Schnittstelle stellt eine Teilmenge der für ein Gerät verfügbaren Eigenschaften bereit.

Die Schnittstelle IModule stellt keine Methoden zur Verfügung. Alle an einem Modul durchgeführten Operationen müssen am Gerät ausgelöst werden.
Die Schnittstelle IModule unterstützt die folgenden Eigenschaften:

Name der Eigenschaft | Rückgabetyp | Beschreibung
ArticleNumber | string | Bestellnummer des Moduls. Auch bezeichnet als MLFB oder "Artikelnummer".
Comment | string | Hiermit kann der Anwender dem Gerät einen Kommentar zuordnen, der in der Benutzeroberfläche des SIMATIC Automation Tool verwendet wird. Der Kommentar ist für API-Operationen nicht relevant.
Configured | bool | Wahr, wenn das Gerät eine gültige Konfiguration besitzt
Description | string | Eine Beschreibung des Hardware-Elements auf Basis der Artikelnummer. Hierbei handelt es sich um dieselbe Beschreibung, die der Anwender im TIA Portal sieht. (z. B. "CPU-1215 DC/DC/DC")
Failsafe | bool | Ist dies laut Artikelnummer (ArticleNumber) ein fehlersicheres Gerät?
FirmwareUpdateAllowed | bool | Unterstützt dieses Gerät Firmware-Aktualisierungen?
FirmwareVersion | string | Aktuelle Firmware-Version des Geräts
ID | uint | Die eindeutige Kennung für jedes Gerät und Modul in der Station. Sie wird als eindeutige Kennung bei Ausführung eines Vorgangs FirmwareUpdate verwendet.
Name | string | Name des Geräts
NewFirmwareNameErrorCode | Result | ErrorCode zum neuen Firmware-Namen
NewFirmwareNameIsValid | bool | Wahr, wenn die Firmware-Datei für dieses Gerät oder Modul gültig ist.
FirmwareVersion | string | Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.
Selected | bool | Ist das Gerät derzeit ausgewählt? Dies bezieht sich auf die Markierung in der Benutzeroberfläche.
SerialNumber | string | Eindeutige Seriennummer des Geräts
Slot | uint | Steckplatznummer des Hardware-Elements
SlotName | string | Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.
StationNumber | uint | Stationsnummer des Geräts
SubSlot | uint | Die Subslot-Nummer des Geräts. Diese ist für steckbare Submodule wie die S7-1200 SB-Module relevant.
Supported | FeatureSupport | Wird das erkannte Netzwerkgerät von aktuellen Operationen des SIMATIC Automation Tool unterstützt?


Schnittstelle ICPU

Schnittstelle ICPU

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Dient zur Identifikation von CPU-Geräten in einer IProfinetDeviceCollection
  • Eigenschaften von ICPU
  • ICPU-Merker
  • ICPU-Methoden
  • Eigenschaft RemoteInterfaces


Dient zur Identifikation von CPU-Geräten in einer IProfinetDeviceCollection

Dient zur Identifikation von CPU-Geräten in einer IProfinetDeviceCollection

Die Methode ScanNetworkDevices generiert eine IProfinetDeviceCollection. Diese Sammlung enthält ein Element für jedes erreichbare Gerät im Industrienetzwerk. Zu diesen Geräten können u. a. CPUs und dezentrale Peripheriestationen gehören.

Die Schnittstelle IProfinetDevice stellt Eigenschaften und Methoden zur Verfügung, die auf alle Kategorien von Geräten anwendbar sind. Es gibt jedoch bestimmte Eigenschaften und Methoden, die spezifisch für ein CPU-Gerät gelten. Der Zugriff auf diese Eigenschaften und Methoden erfolgt über die Schnittstelle ICPU.

Um festzustellen, ob eine bestimmte Schnittstelle IProfinetDevice wirklich ein CPU-Gerät repräsentiert, senden Sie sie einfach an eine Schnittstelle ICPU. Wenn die Übertragung erfolgreich ist, handelt es sich bei dem Netzwerkgerät um eine CPU und die Schnittstelle ICPU kann verwendet werden. Das folgende Beispiel veranschaulicht dies:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
//-----------------------------------------------------
//
        Das Gerät ist eine CPU.
//
        Für die Interaktion mit dem Gerät kann die ICPU-Schnittstelle verwendet werden.
//-----------------------------------------------------
}
}
}

Hinweis

Die Schnittstelle ICPU erbt ihre Einstellungen von IProfinetDevice. Deshalb werden alle von IProfinetDevice unterstützten Eigenschaften und Methoden auch von der Schnittstelle ICPU unterstützt.
Hinweis

Sie müssen die Merker Selected und SelectedConfirmed setzen, bevor Sie über die API Vorgänge auf den Geräten ausführen können. Selected ist für alle Funktionen der ICPU-Schnittstelle erforderlich. Sie müssen SelectedConfirmed setzen, wenn die ICPU einen Sicherheitsvorgang darstellt. Die sicherheitsrelevanten Vorgänge sind Programmaktualisierung, Memory Card formatieren, Rücksetzen auf Werkseinstellungen und Wiederherstellen.


Eigenschaften von ICPU

Eigenschaften von ICPU

Die Schnittstelle ICPU erweitert IProfinetDevice um die folgenden Eigenschaften. Diese Eigenschaften sind schreibgeschützt. Damit sichergestellt ist, dass die Eigenschaften die aktuellen Informationen ausgeben, muss der Code zunächst die Methode RefreshStatus aufrufen.

Name der Eigenschaft | Rückgabetyp | Beschreibung
RemoteInterfaces | List<IRemoteInterface> | Eine Liste der Remote-Peripherieschnittstellen, die für die CPU konfiguriert sind. Die Verwendung dieser Eigenschaft wird in einem späteren Abschnitt dieses Dokuments beschrieben.
DataLogFolder | IRemoteFolder | Informationen über Datenprotokolle, die auf der SIMATIC-Speicherkarte der CPU gefunden wurden
RecipeFolder | IRemoteFolder | Informationen über Rezepte, die auf der SIMATIC Memory Card der CPU gefunden wurden
OperatingMode | OperatingState | Gibt den aktuellen Betriebszustand der CPU an. Dieser Wert ist schreibgeschützt.
IdentityCrisis | bool | Wahr, wenn die Identität des Geräts nicht bestimmt werden kann.
LastRefreshSuccessful | bool | Wahr, wenn der letzte Aufruf von RefreshStatus erfolgreich ausgeführt wurde.
SelectedConfirmed | bool | Bei Methoden, die sicherheitsrelevante Vorgänge ausführen, muss Merker SelectedConfirmed auf WAHR gesetzt werden, wenn der Benutzer ein oder mehrere Geräte in einem Bestätigungsdialog für den Vorgang erneut auswählt und den Vorgang bestätigt. SelectedConfirmed bedeutet, dass der Vorgang ausgewählt und bestätigt ist.
Initialized | bool | Wahr, wenn das Gerät oder Modul eine gültige Konfiguration besitzt.
InterfaceNumber | int | Name der Schnittstelle, über die das Gerät verbunden ist
Password | EncryptedString | CPU-Passwort für Funktionen, die im Gerät ausgeführt werden
PasswordProtectionLevel | ProtectionLevel | Schutzstufe eines legitimierten CPU-Passworts
Protected | bool | Die CPU ist aktuell durch ein Passwort geschützt. Das bedeutet, dass ein Passwort benötigt wird, um auf einige oder alle Funktionen - je nach Zugriffsstufe - zuzugreifen.
PasswordValid | bool | Ist der Aufruf von SetPassword() gültig?

Siehe auch Eigenschaft RemoteInterfaces


ICPU-Merker

ICPU-Merker

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Programmaktualisierungsmerker
  • Wiederherstellen-Merker
  • Funktionsmerker


Programmaktualisierungsmerker

Programmaktualisierungsmerker

Um sicherheitsrelevante Funktionen in einem Gerät erfolgreich ausführen zu können, werden weitere Informationen vom Gerät benötigt. Mit den folgenden Merkern wird sichergestellt, dass die Programmaktualisierung in einem Sicherheitsgerät korrekt und sicher ausgeführt werden kann.

Name der Eigenschaft | Rückgabetyp | Beschreibung
NewProgramNamePassword | EncryptedString | CPU-Passwort, mit dem der Verbindungsaufbau versucht wird, nachdem die Programmaktualisierung beendet ist. Der Wert wird über SetProgramPassword(EncryptedString) gesetzt.
HasSafetyProgram | bool | Boolescher Wert, der gesetzt wird, wenn im Gerät ein Sicherheitsprogramm vorhanden ist. Dies wird beim Verbinden mit einer CPU festgestellt.
NewProgramNameIsValid | bool | Wahr, wenn die Methode SetProgramFolder mit einem gültigen Programm aufgerufen wird
NewProgramNameIsSafety | bool | Wahr, wenn die Methode SetProgramFolder mit einem gültigen Sicherheitsprogramm aufgerufen wird
NewProgramNameHasSafetyPassword | bool | Wahr, wenn die Methode SetProgramFolder mit einem gültigen Sicherheitsprogramm aufgerufen wird. Falsch, wenn ein Standardprogramm geöffnet wird.
NewProgramNamePasswordIsValid | bool | Wahr, wenn die Methode SetProgramPassword mit einem gültigen Passwort aufgerufen wird
NewProgramNamePasswordIsSafety | bool | Wahr, wenn die Methode SetProgramPassword mit einem gültigen Passwort aufgerufen wird und das Passwort für das neue Programm über ein Safety-Passwort für eine F-CPU verfügt.
ProgramUpdateSucceeded | bool | Wahr, wenn die Methode ProgramUpdate erfolgreich ist. Die Programmaktualisierung kann trotzdem einen Fehler zurückgeben.
NewProgramNamePasswordPresent | bool | Wahr, wenn die Methode SetProgramFolder aufgerufen wird und das Programm passwortgeschützt ist.
NewProgramNamePasswordLevel | ProtectionLevel | Welche Schutzstufe hat das CPU-Passwort für das neue Programm?
NewProgramName | string | Welchen Namen hat das neue Programm?
NewProgramFolder | string | Wo befindet sich der Ordner für das neue Programm? Der Wert wird über die Methode SetProgramFolder gesetzt.
NewProgramNameFSignature | uint | Welche FSignature hat das neue Projekt? Wird zu Vergleichszwecken verwendet, um festzustellen, ob ProgramUpdate erfolgreich ausgeführt wurde
NewProgramNameIP | uint | IP-Adresse, die im neuen Programm gespeichert ist
NewProgramNameSubnetMask | uint | Subnetzmaske des Geräts im neuen Programm
NewProgramNameGateway | uint | Gateway des Geräts im neuen Programm
NewProgramNameErrorCode | Result | Möglichkeit zum Aufspüren von Problemen bei der Validierung des Programms, zum Beispiel wenn das Programm für das Gerät ungültig ist oder die IP des Programms im Netzwerk bereits vorhanden ist
NewProgramNamePasswordErrorCode | Result | Speichert den Fehlercode des letzten Aufrufs von SetProgramPassword.


Wiederherstellen-Merker

Wiederherstellen-Merker

Die API enthält die folgenden Merker, damit die Wiederherstellung aus einer Sicherungsdatei in einem Sicherheitsgerät korrekt und sicher ausgeführt werden kann. Eine Sicherungsdatei enthält nicht alle Programmaktualisierungsinformationen, weil sich eine Sicherungsdatei vom Inhalt her von einer Programmdatei unterscheidet.

Name der Eigenschaft | Rückgabetyp | Beschreibung
NewRestoreNamePassword | EncryptedString | CPU-Passwort, mit dem der Verbindungsaufbau versucht wird, nachdem die Wiederherstellung beendet ist. Der Wert wird über SetBackupFilePassword(EncryptedString) gesetzt.
NewRestoreNameIsValid | bool | Wahr, wenn die Methode SetBackupFile aufgerufen wird und die Wiederherstellungsdatei gültig ist
NewRestoreNameIsSafety | bool | Wahr, wenn die Methode SetBackupFile aufgerufen wird und die Wiederherstellungsdatei eine Safety-Restore-Datei ist
NewRestoreNamePasswordIsValid | bool | Wahr, wenn der Aufruf SetBackupFilePassword ein gültiges Passwort enthält.
NewRestoreNamePasswordIsSafety | bool | Wahr, wenn der Aufruf SetBackupFilePassword ein gültiges Safety-Passwort enthält.
RestoreSucceeded | bool | War der Vorgang Restore erfolgreich?
NewRestoreName | string | Welchen Namen hat das neue Programm?
NewRestoreFile | string | Wo befindet sich die Datei für das neue Programm? Der Wert wird über die Methode SetBackupFile gesetzt
NewRestoreNameFSignature | uint | Welche FSignature hat das neue Projekt? Wird zu Vergleichszwecken verwendet, um festzustellen, ob Restore erfolgreich ausgeführt wurde
NewRestoreNameErrorCode | Result | Möglichkeit zum Aufspüren von Problemen bei der Validierung des Programms, zum Beispiel wenn das Programm für das Gerät ungültig oder mit dem Gerät nicht kompatibel ist


Funktionsmerker

Funktionsmerker

Das SIMATIC Automation Tool umfasst die Funktionsmerker in der ICPU-Schnittstelle und IHMI-Schnittstelle. Der Rückgabetyp dieser Merker ist bool.

Name der Eigenschaft | Rückgabetyp | Beschreibung
ChangeModeAllowed | bool | WAHR, wenn die CPU die Betriebsartumschaltung unterstützt (RUN und STOP)?
BackupAllowed | bool | WAHR, wenn die CPU die Datensicherung unterstützt.
MemoryResetAllowed | bool | WAHR, wenn die CPU das Rücksetzen auf Werkseinstellungen unterstützt.
ProgramUpdateAllowed | bool | WAHR, wenn die CPU Programmaktualisierungen unterstützt
RestoreAllowed | bool | WAHR, wenn die CPU das Wiederherstellen unterstützt.
FormatMCAllowed | bool | WAHR, wenn die CPU die Formatierung von Memory Cards unterstützt.
PasswordAllowed | bool | WAHR, wenn die CPU ein Passwort unterstützt.
RemoteRecipesAllowed | bool | WAHR, wenn die CPU Rezeptvorgänge unterstützt.
RemoteDataLogsAllowed | bool | WAHR, wenn die CPU Datenprotokollvorgänge unterstützt.
ServiceDataAllowed | bool | WAHR, wenn die CPU den Upload von Servicedaten unterstützt.
SetTimeAllowed | bool | WAHR, wenn die CPU den Vorgang "Zeit einstellen und lesen" unterstützt.
DiagBufferAllowed | bool | WAHR, wenn die CPU Diagnosepuffervorgänge unterstützt.


ICPU-Methoden

ICPU-Methoden

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Geschützte CPUs und Passwörter
  • Methode SetPassword
  • Methode SetProgramFolder
  • Methode SetProgramPassword
  • Methode ProgramUpdate
  • Methode SetBackupFile
  • Methode SetBackupFilePassword
  • Methode Restore (ICPU-Schnittstelle)
  • Methode Backup (ICPU-Schnittstelle)
  • Methode DownloadRecipe
  • Methode DeleteDataLog
  • Methode DeleteRecipe
  • Methode GetCurrentDateTime
  • Methode GetDiagnosticsBuffer
  • Methode MemoryReset
  • Methode ResetToFactoryDefaults
  • Methode SetOperatingState
  • Methode SetCurrentDateTime
  • Methode UploadDataLog
  • Methode UploadRecipe
  • Methode UploadServiceData
  • Methode FormatMemoryCard
  • DetermineConfirmationMessage


Geschützte CPUs und Passwörter

Geschützte CPUs und Passwörter

Die meisten Aktionen in Bezug auf die Schnittstelle ICPU erfordern eine legitimierte Verbindung mit der CPU und möglicherweise ein Passwort. Deshalb brauchen die meisten Methoden für die Schnittstelle ICPU einen Passwort-Parameter.


Methode SetPassword

Methode SetPassword

Rückgabetyp | Methodenname
Result | SetPassword

Parameter
Name | Datentyp | Parametertyp | Beschreibung
password | EncryptedString | Eingang | Setzt das CPU-Passwort für das Objekt, das für die Ausführung von Operationen benutzt wird

Die Methode SetPassword vergibt ein Passwort für eine CPU. Bevor Sie versuchen, das Passwort festzulegen, prüfen Sie beim Aufrufen der Methode SetPassword die Eigenschaft dev.Protected . Wenn das Gerät geschützt ist, gibt die Methode SetPassword einen Fehler zurück. Das folgende Beispiel zeigt die Verwendung der Methode SetPassword:

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{

            //------------------------------------------------
//
        Nach dem Gerät an dieser MAC-Adresse suchen und Passwort einstellen
//------------------------------------------------
ICPU dev = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (dev != null)
{
if (dev.Protected)
{
Result retVal = dev.SetPassword(new EncryptedString("Password"));
}
}
}


Methode SetProgramFolder

Methode SetProgramFolder

Rückgabetyp | Name der Methode
Result | SetProgramFolder

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFolder | string | Eingang | Legt den Speicherort des Ordners für das geladene Programm fest

Die Methode setzt die folgenden Merker am Objekt ICPU.

  • NewProgramFolder

  • NewProgramName

  • NewProgramNameIP

  • NewProgramNameSubnetMask

  • NewProgramNameGateway

  • NewProgramNameIsValid

Wenn der Vorgang für ein Sicherheitsobjekt ausgeführt wird, haben Sie folgende Einstellungsmöglichkeiten:

  • NewProgramNameIsSafety

  • NewProgramNameHasSafetyPassword

Das folgende Beispiel zeigt, wie der Programmordner in einem Gerät eingestellt wird.

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Nach dem Gerät an dieser MAC-Adresse suchen und Programmordner einstellen
//------------------------------------------------
ICPU dev = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (dev != null)
{
Result retVal = dev.SetProgramFolder(@"C:\MyFolder");
if (retVal.Error == ErrorCode.ProgramPasswordNeeded)
{
retVal = dev.SetProgramPassword(new EncryptedString("Password"));
}
}
}

Hinweis

Wenn Sie ein passwortgeschütztes Programm ausgewählt haben, gibt SetProgramFolder einen Fehler aus. Wenn SetProgramFolder einen Fehler ausgibt, rufen Sie SetProgramPassword auf.


Methode SetProgramPassword

Methode SetProgramPassword

Ausgabetyp | Methodenname
Result | SetProgramPassword

Parameter
Name | Datentyp | Parametertyp | Beschreibung
password | EncryptedString | Eingang | Stellt das CPU-Passwort für das Projekt ein, das während des ProgramUpdate an die CPU übergeben werden soll.

Nachdem Sie eine ProgramUpdate durchgeführt haben, versucht die Anwendung, wieder eine Verbindung zum Gerät herzustellen. Wenn das in die CPU geladene Programm passwortgeschützt ist, geben Sie das aktualisierte CPU-Passwort an, um wieder Zugriff auf das Gerät zu erhalten.

Die Methode setzt die folgenden Merker am Objekt ICPU:

  • NewProgramNamePasswordIsValid

  • NewProgramNamePasswordIsSafety

  • NewProgramNamePasswordLevel

Das folgende Beispiel zeigt, wie ein aktualisiertes CPU-Passwort an einem Gerät eingestellt wird:

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Nach dem Gerät an dieser MAC-Adresse suchen und Programmordner einstellen
//------------------------------------------------
ICPU dev = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (dev != null)
{
Result retVal = dev.SetProgramFolder(@"C:\MyFolder");
if (retVal.Error == ErrorCode.ProgramPasswordNeeded)
{
retVal = dev.SetProgramPassword(new EncryptedString("Password"));
}
}
}


Methode ProgramUpdate

Methode ProgramUpdate

Rückgabetyp | Name der Methode
Result | ProgramUpdate

Diese Methode führt eine Programmaktualisierung auf der CPU durch.

Die folgenden Voraussetzungen müssen erfüllt sein, damit das Programm aktualisiert wird:

  • Das Gerät muss ausgewählt sein.

  • Wenn es sich um ein fehlersicheres Gerät handelt, muss SelectedConfirmed wahr sein

  • Der NewProgramFolder für das Objekt muss eingestellt sein.

  • Wenn das neue Programm ein CPU-Passwort enthält, muss NewProgramPasswordPresent wahr sein und den über SetProgramPassword. eingestellten Wert haben.

  • Die Programmaktualisierung muss vom Gerät unterstützt werden (ProgramUpdateAllowed).

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält, und das Programm für diese CPU wird aktualisiert.

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
ICPU cpu = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (cpu != null && cpu.ProgramUpdateAllowed == true)
{
//
        Zu aktualisierende CPU auswählen
cpu.Selected = true;

retVal = cpu.SetProgramFolder(@"C:\MyFolder");
if (retVal.Error == ErrorCode.ProgramPasswordNeeded)
{
retVal = cpu.SetProgramPassword(new EncryptedString("Password"));
if (retVal.Failed == true)
return;
}
if (retVal.Failed == true)
return;

//
        IP-Adresse eindeutig?
if (cpu.DuplicateIP == true)
return;

//
        Wird das Gerät unterstützt?
if (cpu.Supported == false)
return;

//
        Ist das Gerät initialisiert?
if (cpu.Initialized == false)
return;

//
        Ist das Gerät fehlersicher?
if (cpu.Failsafe == true)
{
ConfirmationType type = cpu.DetermineConfirmationMessage(FailsafeOperation.ProgramUpdateOperation);

//
        Typ überprüfen und bestätigen
cpu.SelectedConfirmed = true;

//
        Prüfen, um sicherzustellen, dass wir aktualisieren können
if (cpu.HasSafetyProgram == true || cpu.Protected == true ||cpu.NewProgramNameIsSafety == true)
{
//
        Ist das Gerät passwortgeschützt?
if (cpu.Protected == true)
{
//
        Wurde ein gültiges Passwort eingegeben?
if (cpu.PasswordValid == false)
return;

//
        Haben wir die Berechtigung für die Sicherheitsstufe?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe;
if (bSufficientAccess == false)
return;

}
}
}
else
{
//
        Soll ein Sicherheitsprogramm geladen werden?
if (cpu.NewProgramNameHasSafetyPassword == true)
return;
}

//
        Ist das Gerät passwortgeschützt?
if (cpu.Protected == true)
{
//
        Wurde ein gültiges Passwort eingegeben?
if (cpu.PasswordValid == false)
return;

                    //
        Haben wir eine ausreichende Berechtigungsstufe, damit der Vorgang erfolgreich durchgeführt werden kann?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe || cpu.PasswordProtectionLevel == ProtectionLevel.Full;
if (bSufficientAccess == false)
return;
}
//
        Programmaktualisierung durchführen
retVal = cpu.ProgramUpdate();

//
        Zurücksetzen
cpu.SelectedConfirmed = false;
}
}

Hinweis

Der an die Methode ProgramUpdate übergebene Ordnername muss einen Ordner namens SIMATIC.S7S enthalten. Der Ordner SIMATIC.S7S enthält das zu ladende Programm.


Methode SetBackupFile

Methode SetBackupFile

Rückgabetyp | Name der Methode
Ergebnis | SetBackupFile

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFile | string | Eingang | Stellt den Speicherort für eine Sicherungsdatei ein

Die Methode setzt die folgenden Merker am Objekt ICPU:

  • NewRestoreName

  • NewRestoreFile

  • NewRestoreNameIsValid

  • NewRestoreNameIsSafety

  • NewRestorenameFSignature

Das folgende Beispiel zeigt, wie der Pfad für die Sicherungsdatei eingestellt wird:

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
ICPU cpu = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (cpu != null && cpu.RestoreAllowed == true)
{
//
        Zu aktualisierende CPU auswählen
cpu.Selected = true;

Result retVal = cpu.SetBackupFile(@"C:\MyFolder\Backup.s7pbkp");

if (retVal.Failed == true)
return;

//
        IP-Adresse eindeutig?
if (cpu.DuplicateIP == true)
return;

//
        Wird das Gerät unterstützt?
if (cpu.Supported == false)
return;

//
        Ist das Gerät initialisiert?
if (cpu.Initialized == false)
return;

//
         Ist das Gerät fehlersicher?
if (cpu.Failsafe == true)
{
ConfirmationType type =
cpu.DetermineConfirmationMessage(FailsafeOperation.RestoreOperation);

//
        Typ überprüfen und bestätigen
cpu.SelectedConfirmed = true;

//
        Prüfen, um sicherzustellen, dass wir aktualisieren können
if (cpu.HasSafetyProgram == true || cpu.Protected == true || cpu.NewRestoreNameIsSafety == true)
{
//
        Ist das Gerät passwortgeschützt?
if (cpu.Protected == true)
{
//
        Wurde ein gültiges Passwort eingegeben?
if (cpu.PasswordValid == false)
return;

//
         Haben wir die Berechtigung für die Sicherheitsstufe?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe;
if (bSufficientAccess == false)
return;
}
}
}
else
{
//
        Soll ein Sicherheitsprogramm geladen werden?
if (cpu.NewRestoreNameIsSafety == true)
return;
}

//
        Ist das Gerät passwortgeschützt?
if (cpu.Protected == true)
{
//
        Wurde ein gültiges Passwort eingegeben?
if (cpu.PasswordValid == false)
return;

//
        Haben wir eine ausreichende Berechtigungsstufe, damit der Vorgang erfolgreich durchgeführt werden kann?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe || cpu.PasswordProtectionLevel == ProtectionLevel.Full;
if (bSufficientAccess == false)
return;
}
//
        Wiederherstellung durchführen
retVal = cpu.Restore();

//
        Zurücksetzen
cpu.SelectedConfirmed = false;
}
}

Hinweis

Wenn die ausgewählte Sicherungsdatei ein CPU-Passwort enthält, gibt SetBackupFile einen Fehler aus. Sie müssen die Methode SetBackupFilePassword aufrufen und erfolgreich zurückgeben, bevor Sie die Methode Restore aufrufen können.


Methode SetBackupFilePassword

Methode SetBackupFilePassword

Ausgabetyp | Methodenname
Result | SetBackupFilePassword

Parameter
Name | Datentyp | Parametertyp | Beschreibung
password | EncryptedString | Eingang | Stellt das Passwort für das Projekt ein, das während der Wiederherstellung an die CPU übergeben werden soll.

Nachdem Sie eine Wiederherstellung durchgeführt haben, versucht die Anwendung, die Verbindung zum Gerät erneut aufzubauen. Wenn das in die CPU geladene Programm passwortgeschützt ist, geben Sie das aktualisierte CPU-Passwort an, um wieder Zugriff auf das Gerät zu erhalten.

Die Methode setzt den folgenden Merker am Objekt ICPU.

  • NewRestoreNamePassword

Das folgende Beispiel zeigt, wie ein aktualisiertes CPU-Passwort an einem Gerät eingestellt wird:

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Nach dem Gerät an dieser MAC-Adresse suchen und Passwort für Sicherungsdatei einstellen
//------------------------------------------------
ICPU dev = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (dev != null)
{
if (dev.Protected)
{
Result retVal = dev.SetBackupFile(@"C:\MyFolder\MyCPUBackupFile.s7pbkup");
retVal = dev.SetBackupFilePassword(new EncryptedString("Password"));
}
}
}


Methode Restore (ICPU-Schnittstelle)

Methode Restore (ICPU-Schnittstelle)

Rückgabetyp | Name der Methode
Result | Restore

Mit Hilfe dieser Methode werden die Daten einer früheren Sicherung der CPU wiederhergestellt. Einige CPUs unterstützen die Funktion zum Sichern/Wiederherstellen nicht.

Die folgenden Voraussetzungen müssen erfüllt sein, damit der Vorgang durchgeführt werden kann:

  • Das Gerät muss ausgewählt sein.

  • Wenn es sich um ein fehlersicheres Gerät handelt, muss SelectedConfirmed wahr sein.

  • Der NewProgramFolder für das Objekt muss eingestellt sein.

  • Wenn das neue Programm ein CPU-Passwort enthält, muss NewProgramPasswordPresent wahr sein und den über SetProgramPassword eingestellten Wert haben

  • Restore muss unterstützt werden, damit die Aktion durchgeführt werden kann (RestoreAllowed).

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält. Wird diese CPU gefunden, wird geprüft, ob das passwortgeschützte Gerät die Wiederherstellungsfunktion unterstützt. Anschließend wird die Methode Restore für eine Sicherungsdatei, die kein CPU-Passwort enthält, aufgerufen.

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string bkFile = @"C:\MyCPUBackupFile.s7pbkp";
IProfinetDeviceCollection devices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        ICPU devAsCpu = dev as ICPU;
        if (devAsCpu != null && devAsCpu.RestoreAllowed)
        {
            retVal = devAsCpu.SetPassword(new EncryptedString("Password"));
            retVal = devAsCpu.SetBackupFile(bkFile);
            devAsCpu.Selected = true;
            if (devAsCpu.Failsafe)
                devAsCpu.SelectedConfirmed = true;

            retVal = devAsCpu.Restore();
        }
    }
}


Methode Backup (ICPU-Schnittstelle)

Methode Backup (ICPU-Schnittstelle)

Ausgabetyp | Methodenname
Result | Backup

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFile | string | Eingang | Vollständig qualifizierter Pfad und Dateiname zum Speichern der Sicherungsdatei

Diese Methode dient zur Sicherung der Daten in einer CPU. Einige CPUs unterstützen die Funktion zum Sichern/Wiederherstellen nicht. Ob die aktuelle CPU diese Funktion unterstützt, kann mit Hilfe der Eigenschaft BackupAllowed überprüft werden.

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält. Wird diese CPU gefunden, wird geprüft, ob sie die Sicherungsfunktion unterstützt. Wenn ja, wird die Methode Backup aufgerufen.

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string bkFile = @"C:\MyCPUBackupFile.s7pbkp";
IProfinetDeviceCollection devices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPU devAsCpu = dev as ICPU;

        if (devAsCpu != null && devAsCpu.IP == targetIPAddress && devAsCpu.BackupAllowed)
        {
            devAsCpu.Selected = true;
            retVal = devAsCpu.Backup(bkFile);
        }
    }
}


Methode DownloadRecipe

Methode DownloadRecipe

Rückgabetyp | Methodenname
Result | DownloadRecipe

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFile | string | Eingang | Vollständiger Pfad und Dateiname der zu ladenden Rezeptdatei (Übertragung vom Programmiergerät zur Memory Card der CPU).

Verwenden Sie diese Methode, um eine CSV-Rezeptdatei auf der Memory Card der CPU hinzuzufügen oder zu ersetzen. Einige CPUs unterstützen den Fernzugriff auf Rezepte nicht. Ob die aktuelle CPU diese Funktion unterstützt, kann mit Hilfe der Eigenschaft RemoteRecipesAllowed überprüft werden. Das folgende Codebeispiel zeigt, wie eine Rezeptdatei in die Memory Card einer CPU geschrieben werden kann.

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string rcpFile = @"C:\NewRecipe.csv";
IProfinetDeviceCollection devices;

Result retVal = myNetwork.ScanNetworkDevices(out devices);
if (retVal.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPU devAsCpu = dev as ICPU;
        if ((devAsCpu != null) &&
            (devAsCpu.IP == targetIPAddress) &&
            (devAsCpu.RemoteRecipesAllowed))
        {
            retVal = devAsCpu.SetPassword(new EncryptedString("Password"));
            IRemoteFolder recipes = devAsCpu.RecipeFolder;
            recipes.Selected = true;
            recipes.SetRemoteFile(rcpFile);
            retVal = devAsCpu.DownloadRecipe(rcpFile);

        }
    }
}

Hinweis

Wenn ein Rezept gleichen Namens bereits auf der Memory Card der CPU vorhanden ist, wird es ersetzt.


Methode DeleteDataLog

Methode DeleteDataLog

Rückgabetyp | Methodenname
Result | DeleteDataLog

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFileName | string | Eingang | Dateiname der Datenprotokolldatei, die von einer CPU Memory Card gelöscht werden soll.

Mit dieser Methode löschen Sie eine Datenprotokolldatei von der Memory Card einer CPU.

Einige CPUs unterstützen den Fernzugriff auf Datenprotokolle nicht. Ob die aktuelle CPU diese Funktion unterstützt, kann mit Hilfe der Eigenschaft RemoteDataLogsAllowed überprüft werden.

Im folgenden Codebeispiel werden mit Hilfe der Eigenschaft DataLogFolder alle Datenprotokolle auf der Memory Card der CPU iteriert. Jedes Datenprotokoll wird gelöscht.

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in devices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
if (devAsCpu.RemoteDataLogsAllowed)
{
//------------------------------------------
//
        Zunächst prüfen, ob Datenprotokolle auf der Memory Card verfügbar sind
//------------------------------------------
if (devAsCpu.DataLogFolder.Exists)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
//------------------------------------------
//
        Nach allen Datenprotokolldateien suchen
//------------------------------------------
foreach (IRemoteFile datalog in
devAsCpu.DataLogFolder.Files)
{
datalog.Selected = true;
//------------------------------------------
//
        Datenprotokoll löschen
//------------------------------------------
devAsCpu.DeleteDataLog(datalog.Name);
}
}
}
}
}
}


Methode DeleteRecipe

Methode DeleteRecipe

Ausgabetyp | Methodenname
Result | DeleteRecipe

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFileName | string | Eingang | Dateiname der von der Memory Card einer CPU zu löschenden Rezeptdatei.

Mit dieser Methode löschen Sie eine Rezeptdatei von der Memory Card einer CPU.

Einige CPUs unterstützen den Fernzugriff auf Rezepte nicht. Ob die aktuelle CPU diese Funktion unterstützt, kann mit Hilfe der Eigenschaft RemoteRecipesAllowed überprüft werden.

Im folgenden Codebeispiel werden mit Hilfe der Eigenschaft RecipeFolder alle Rezepte auf der Memory Card der CPU iteriert. Jedes Rezept wird gelöscht:

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in devices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
if (devAsCpu.RemoteDataLogsAllowed)
{
//------------------------------------------
//
        Zunächst prüfen, ob Rezepte auf der Memory Card verfügbar sind
//------------------------------------------
if (devAsCpu.RecipeFolder.Exists)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
//------------------------------------------
//
        Nach allen Rezepten suchen
//------------------------------------------
foreach (IRemoteFile recipe in devAsCpu.RecipeFolder.Files)
{
recipe.Selected = true;
//------------------------------------------
//
        Rezept löschen
        .
//------------------------------------------
devAsCpu.DeleteRecipe(recipe.Name);
}
}
}
}
}
}


Methode GetCurrentDateTime

Methode GetCurrentDateTime

Ausgabetyp | Methodenname
Result | GetCurrentDateTime

Parameter
Name | Datentyp | Parametertyp | Beschreibung
DateTime | System.DateTime | Ausgang | Von der CPU ausgegebenes Datum und ausgegebene Uhrzeit

Mit dieser Methode wird der aktuelle Zeitstempel für die CPU abgerufen.

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU an einer bestimmten IP-Adresse enthält, deren aktuelles Datum und aktuelle Uhrzeit abgerufen werden.

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

uint targetIPAddress = 0xC0A80001; // 192.168.0.1

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (!scanResult.Succeeded)
    return;

foreach (IProfinetDevice dev in devices)
{
    ICPU devAsCpu = dev as ICPU;
    if ((devAsCpu != null) && (devAsCpu.IP == targetIPAddress))
    {
        devAsCpu.SetPassword(new EncryptedString("Password"));
        devAsCpu.Selected = true;

        DateTime curTime = new DateTime();

        Result retVal = devAsCpu.GetCurrentDateTime(out curTime);
    }
}


Methode GetDiagnosticsBuffer

Methode GetDiagnosticsBuffer

Rückgabetyp | Methodenname
Result | GetDiagnosticsBuffer

Parameter
Name | Datentyp | Parametertyp | Beschreibung
DiagnosticsItems | List<DiagnosticsItem> | Ausgang | Eine Sammlung von Diagnose-Elementen. Dabei steht jedes Element der Sammlung für einen Eintrag im Diagnosepuffer.
Language | Language | Eingang | Angeforderte Sprache für die exportierten Diagnosepuffereinträge.

Mit dieser Methode werden die aktuellen Diagnoseeinträge aus der CPU ausgelesen. Die Methode GetDiagnosticsBuffer gibt eine Sammlung von Objekten DiagnosticsItem aus. Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält. Wird diese gefunden, werden die Diagnoseinformationen aus der CPU ausgelesen. Der Parameter Language enum dient zum Abrufen von Diagnoseeinträgen in einer bestimmten Sprache:

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
List<DiagnosticsItem> aLogs = new List<DiagnosticsItem>();
IProfinetDeviceCollection devices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPU devAsCpu = dev as ICPU;
        if ((devAsCpu != null) && (devAsCpu.IP == targetIPAddress))
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            retVal = devAsCpu.GetDiagnosticsBuffer(out aLogs, Language.English);
            if (retVal.Succeeded)
            {
                for (int idxLog = 0; idxLog < aLogs.Count; idxLog++)
                {
                //get information time stamp
                string descrTimes = aLogs[idxLog].TimeStamp.ToString();

                //get information basic description
                string descrBasic = aLogs[idxLog].Description1;

                //get information detailed description
                string descrDetail = aLogs[idxLog].Description2;

                //get information state (incoming/outgoing)
                string descrState = aLogs[idxLog].State.ToString();

                }
            }
        }
    }
}


Methode MemoryReset

Methode MemoryReset

Ausgabetyp | Methodenname
Result | MemoryReset

Diese Methode führt ein Urlöschen des Speichers auf der CPU durch.

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält, und MemoryReset wird für diese CPU aufgerufen.

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        ICPU devAsCpu = dev as ICPU;
        if (devAsCpu != null)
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            Result retVal = devAsCpu.MemoryReset();
        }
    }
}


Methode ResetToFactoryDefaults

Methode ResetToFactoryDefaults

Ausgabetyp | Methodenname
Result | ResetToFactoryDefaults

Parameter
Name | Datentyp | Parametertyp | Beschreibung
password | EncryptedString | Eingang | Diese Methode öffnet eine legitimierte Verbindung zum Gerät. Daher kann ein Passwort erforderlich sein.

Diese Methode setzt eine CPU auf die Werkseinstellungen zurück.

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält, und die Methode ResetToFactoryDefaults wird aufgerufen. Bei fehlersicheren Geräten müssen Sie den Merker SelectedConfirmed auf WAHR setzen.

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
ICPU cpu = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (cpu != null && cpu.ResetToFactoryAllowed == true)
{
//
        Zu aktualisierende CPU auswählen
cpu.Selected = true;

//
        IP-Adresse eindeutig?
if (cpu.DuplicateIP == true)
return;

//
        Wird das Gerät unterstützt?
if (cpu.Supported == false)
return;

//
        Ist das Gerät initialisiert?
if (cpu.Initialized == false)
return;

//
        Ist das Gerät fehlersicher?
if (cpu.Failsafe == true)  { ConfirmationType type = cpu.DetermineConfirmationMessage(FailsafeOperation.ResetToFactoryOperation);
//
        Typ überprüfen und bestätigen
cpu.SelectedConfirmed = true;

//
        Prüfen, um sicherzustellen, dass wir aktualisieren können
if (cpu.HasSafetyProgram == true || cpu.Protected == true || cpu.NewRestoreNameIsSafety == true)
{
//
        Ist das Gerät passwortgeschützt?
if (cpu.Protected == true)
{
//
        Wurde ein gültiges Passwort eingegeben?
if (cpu.PasswordValid == false)
return;

//
        Haben wir die Berechtigung für die Sicherheitsstufe?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe;
if (bSufficientAccess == false)
return;
}
}
}
else
{
//
        Soll ein Sicherheitsprogramm geladen werden?
if (cpu.NewRestoreNameIsSafety == true)
return;
}
//
        Ist das Gerät passwortgeschützt?
if (cpu.Protected == true)
{
//
        Wurde ein gültiges Passwort eingegeben?
if (cpu.PasswordValid == false)
return;

//
        Haben wir eine ausreichende Berechtigungsstufe, damit der Vorgang erfolgreich durchgeführt werden kann?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe || cpu.PasswordProtectionLevel == ProtectionLevel.Full;
if (bSufficientAccess == false)
return;
}
//
        Rücksetzen auf die Werkseinstellungen durchführen
Result retVal = cpu.ResetToFactoryDefaults();

//
        Zurücksetzen
cpu.SelectedConfirmed = false;
}
}


Methode SetOperatingState

Methode SetOperatingState

Ausgabetyp | Methodenname
Result | SetOperatingState

Parameter
Name | Datentyp | Parametertyp | Beschreibung
nRequestState | OperatingStateREQ | Eingang | Der neue Betriebszustand

Diese Methode dient zum Wechseln des Betriebszustands einer CPU.

Einige CPUs unterstützen diese Funktion nicht. Ob die aktuelle CPU diese Funktion unterstützt, kann mit Hilfe der Eigenschaft ChangeModeAllowed überprüft werden.

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält. Wird diese CPU gefunden, wird geprüft, ob sie die Funktion für den Betriebszustandswechsel unterstützt. Wenn ja, wird die CPU in RUN versetzt.

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        ICPU devAsCpu = dev as ICPU;
        if ((devAsCpu != null) && (devAsCpu.ChangeModeAllowed))
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            Result retVal = devAsCpu.SetOperatingState(OperatingStateREQ.Run);
        }
    }
}


Methode SetCurrentDateTime

Methode SetCurrentDateTime

Ausgabetyp | Methodenname
Result | SetCurrentDateTime

Parameter
Name | Datentyp | Parametertyp | Beschreibung
password | EncryptedString | Eingang | Diese Methode öffnet eine legitimierte Verbindung zum Gerät. Daher kann ein Passwort erforderlich sein.
time | System.DateTime | Eingang | Neuer Wert für die aktuelle Uhrzeit der CPU

Mit dieser Methode wird die aktuelle Zeit für die CPU eingestellt. Durch diese Aktion werden die konfigurierten Zeitumwandlungsregeln nicht geändert. Der angegebene Wert für DateTime basiert deshalb auf der UTC und nicht auf der Ortszeit.

Im folgenden Beispiel wird das gesamte Industrienetzwerk erfasst und die Uhrzeit für jedes CPU-Gerät auf die aktuelle Uhrzeit des Programmiergeräts eingestellt.

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPU devAsCpu = dev as ICPU;
        if (devAsCpu != null)
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            retVal = devAsCpu.SetCurrentDateTime(DateTime.UtcNow);
        }
    }
}


Methode UploadDataLog

Methode UploadDataLog

Rückgabetyp | Methodenname
Result | UploadDataLog

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFileName | string | Eingang | Dateiname des aus der steckbaren SIMATIC Memory Card einer CPU zu ladenden Datenprotokolls
strDestinationFolder | string | Eingang | Vollständig qualifizierter Pfad, unter dem die aus der CPU geladene Datenprotokolldatei gespeichert wird

Diese Methode lädt eine Kopie einer angegebenen Datenprotokolldatei aus der Memory Card einer CPU in Ihr Programmiergerät. Einige CPUs unterstützen den Fernzugriff auf Datenprotokolle nicht. Ob die aktuelle CPU diese Funktion unterstützt, kann mit Hilfe der Eigenschaft RemoteDataLogsAllowed überprüft werden.
Im folgenden Codebeispiel werden mit Hilfe der Eigenschaft DataLogFolder alle Datenprotokolle auf der Memory Card der CPU iteriert. Eine Kopie jedes Datenprotokolls wird in den Ordner C:\MyDataLogs geladen:

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in devices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
devAsCpu.SetPassword(new EncryptedString("Password"));

if (devAsCpu.RemoteDataLogsAllowed)
{
//------------------------------------------
//
        Zunächst prüfen, ob Datenprotokolle auf der Memory Card verfügbar sind
//------------------------------------------
if (devAsCpu.DataLogFolder.Exists)
{
//------------------------------------------
//
        Nach allen Datenprotokolldateien suchen
//------------------------------------------
foreach (IRemoteFile datalog in devAsCpu.DataLogFolder.Files)
{
datalog.Selected = true;
//------------------------------------------
//
        Eine Kopie jedes Datenprotokolls aus der CPU laden.
//------------------------------------------
devAsCpu.UploadDataLog(datalog.Name, @"C:\MyDataLogs");
}
}
}
}
}
}


Methode UploadRecipe

Methode UploadRecipe

Rückgabetyp | Methodenname
Result | UploadRecipe

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFileName | string | Eingang | Dateiname des aus der Memory Card der CPU zu ladenden Rezepts
strDestinationFolder | string | Eingang | Vollständig qualifizierter Pfad, in den die aus der CPU geladene Rezeptdatei geschrieben wird

Diese Methode lädt eine Kopie einer Rezeptdatei aus der Memory Card einer CPU. Einige CPUs unterstützen den Fernzugriff auf Rezepte nicht. Ob die aktuelle CPU diese Funktion unterstützt, kann mit Hilfe der Eigenschaft RemoteRecipesAllowed überprüft werden.

Im folgenden Codebeispiel werden mit Hilfe der Eigenschaft RecipeFolder alle Rezepte auf der Memory Card der CPU iteriert. Eine Kopie jedes Rezepts wird in den Ordner C:\MyRecipes geladen:

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in devices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
if (devAsCpu.RemoteRecipesAllowed)
{
//------------------------------------------
//
        Zunächst prüfen, ob Rezepte auf der Memory Card verfügbar sind
//------------------------------------------
if (devAsCpu.RecipeFolder.Exists)
{
//------------------------------------------
//
        Nach allen Rezeptdateien suchen
//------------------------------------------
foreach (IRemoteFile recipe in devAsCpu.RecipeFolder.Files)
{
recipe.Selected = true;
//------------------------------------------
//
        Eine Kopie jedes Rezepts aus der CPU laden.
//------------------------------------------
devAsCpu.UploadRecipe(recipe.Name, @"C:\MyRecipes");
}
}
}
}
}
}


Methode UploadServiceData

Methode UploadServiceData

Ausgabetyp | Methodenname
Result | UploadServiceData

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strPath | string | Eingang | Vollständig qualifizierter Pfad zu dem Ordner, der den Inhalt der Programmkarte enthält
format | TimeFormat | Eingang (optional) | Format für die Anzeige von Datum und Uhrzeit. Mögliche Werte sind "UTC" und "Local"; falls nicht anders angegeben, ist das Format "Local".

Mit Hilfe dieser Methode können die Servicedaten aus einer defekten CPU geladen werden.

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält. Anschließend wird der OperatingState der CPU geprüft. Wenn die CPU defekt ist, werden die Servicedaten aus der CPU geladen.

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string strDiagFolder = @"c:\Diagnostics";

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
ICPU devAsCpu = dev as ICPU;

if (devAsCpu != null)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
devAsCpu.Selected = true;
if (devAsCpu.OperatingMode == OperatingState.Defective)
{
//
        Servicedaten mit lokalem Zeitstempelformat abrufen
Result retVal = devAsCpu.UploadServiceData(strDiagFolder);

//
        Servicedaten mit UTC-Zeitstempelformat abrufen
Result retVal = devAsCpu.UploadServiceData(strDiagFolder, TimeFormat.UTC);
}
}
}
}


Methode FormatMemoryCard

Methode FormatMemoryCard

Rückgabetyp | Name der Methode
Result | FormatMemoryCard

Diese Methode dient dazu, die in eine CPU gesteckte SIMATIC Memory Card zu formatieren.

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält. Anschließend wird die Memory Card des Geräts formatiert. Bei fehlersicheren Geräten müssen Sie den Merker SelectedConfirmed auf WAHR setzen.

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
ICPU cpu = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (cpu != null && cpu.FormatMCAllowed == true)
{
//
        Zu aktualisierende CPU auswählen
cpu.Selected = true;

//
        IP-Adresse eindeutig?
if (cpu.DuplicateIP == true)
return;

//
        Wird das Gerät unterstützt?
        ?
if (cpu.Supported == false)
return;

//
        Ist das Gerät initialisiert?
if (cpu.Initialized == false)
return;

//
        Ist das Gerät fehlersicher?
if (cpu.Failsafe == true)
{
ConfirmationType type = cpu.DetermineConfirmationMessage(FailsafeOperation.ResetToFactoryOperation);

//
        Typ überprüfen und bestätigen
cpu.SelectedConfirmed = true;

//
        Prüfen, um sicherzustellen, dass wir aktualisieren können
if (cpu.HasSafetyProgram == true || cpu.Protected == true || cpu.NewRestoreNameIsSafety == true)
{
// Is the device password protected?if (cpu.Protected == true)
{
//
        Wurde ein gültiges Passwort eingegeben?
if (cpu.PasswordValid == false)
return;

//
        Haben wir die Berechtigung für die Schutzstufe?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe;
if (bSufficientAccess == false)
return;
}
}
}
else
{
//
        Soll ein Sicherheitsprogramm geladen werden?
if (cpu.NewRestoreNameIsSafety == true)
return;
}

//
        Ist das Gerät passwortgeschützt?
if (cpu.Protected == true)
{
//
        Wurde ein gültiges Passwort eingegeben?
if (cpu.PasswordValid == false)
return;

//
        Haben wir eine ausreichende Berechtigungsstufe, damit der Vorgang erfolgreich durchgeführt werden kann?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe || cpu.PasswordProtectionLevel == ProtectionLevel.Full;
if (bSufficientAccess == false)
return;
}
//
        Memory Card formatieren
Result retVal = cpu.FormatMemoryCard();

//
        Zurücksetzen
cpu.SelectedConfirmed = false;
}
}


DetermineConfirmationMessage

DetermineConfirmationMessage

Rückgabetyp | Name der Methode
ConfirmationType | DetermineConfirmationMessage

Parameter
Name | Datentyp | Parametertyp | Beschreibung
operation | FailsafeOperation | Eingang | Ausgewerteter Vorgang

Diese Methode ermittelt, welchen Inhalt die Bestätigungsmeldung enthält, wenn der Benutzer versucht, einen sicherheitsrelevanten Vorgang durchzuführen.

Die Klasse ConfirmationType enthält eine Reihe von Hamming-Codes, die jeweils eine Fehlermeldung repräsentieren, die dem Benutzer wie folgt angezeigt werden sollen:

ConfirmationType | Anzuzeigende Meldung
SafetyPasswordIsBeingUsed | Ein Vorgang für ein Standardprogramm soll mit dem Safety-Passwort der CPU initiiert werden.
DeletingExistingSafetyProgram | Ein vorhandenes Sicherheitsprogramm soll gelöscht werden.
ReplacingExistingSafetyProgram | Ein vorhandenes Sicherheitsprogramm soll mit einem anderen Sicherheitsprogramm aktualisiert werden.
ReplacingExistingSafetyProgramWithNonSafetyProgram | Ein vorhandenes Sicherheitsprogramm soll durch ein Standardprogramm ersetzt werden.
LoadingSafetyProgram | Ein Sicherheitsprogramm soll zum ersten Mal geladen werden.

Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine CPU unter einer bestimmten IP-Adresse enthält. Diese Methode dient dazu, vor Ausführung eines sicherheitsrelevanten Vorgangs in einem Dialogfeld zur Benutzerbestätigung eine Meldung über den sicherheitsrelevanten Status anzuzeigen:

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        ICPU devAsCpu = dev as ICPU;
        if (devAsCpu != null)
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            if (devAsCpu.Failsafe)
            {
                devAsCpu.SelectedConfirmed = true;
            }
            ConfirmationType confirm = devAsCpu.DetermineConfirmationMessage(FailsafeOperation.FormatMCOperation);

            if (confirm == ConfirmationType.DeletingExistingSafetyProgram)
                devAsCpu.FormatMemoryCard();
        }
    }
}


Eigenschaft RemoteInterfaces

Eigenschaft RemoteInterfaces

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Dezentrale Peripheriemodule
  • IRemoteInterface-Eigenschaften


Dezentrale Peripheriemodule

Dezentrale Peripheriemodule

Jede CPU kann mehrere dezentrale Peripheriemodule unterstützen. Informationen über die an diese Remote-Schnittstellen angehängten Geräte sind über die Eigenschaft RemoteInterfaces der ICPU-Schnittstelle abrufbar.

Das folgende Beispiel zeigt den Zugriff auf diese Informationen für alle CPUs in einem Netzwerk:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
ICPU devAsCpu = dev as ICPU;

List<IRemoteInterface> decentalNets = devAsCpu.RemoteInterfaces;
foreach (IRemoteInterface net in decentalNets)
{
//-----------------------------------------------------------
//
        Remote-Schnittstelle untersuchen
//-----------------------------------------------------------
}
}
}


IRemoteInterface-Eigenschaften

IRemoteInterface-Eigenschaften

Die Schnittstelle IRemoteInterface unterstützt die folgenden Eigenschaften. Diese Eigenschaften sind schreibgeschützt.

Name der Eigenschaft | Rückgabetyp | Beschreibung
Devices | List<IBaseDevice> | Eine Liste der dezentralen Peripheriestationen, die mit dieser Remote-Schnittstelle verbunden sind
InterfaceType | RemoteInterfaceType | Kommunikationsprotokoll für diese Remote-Schnittstelle Siehe auch RemoteInterfaceType-Enumeration
Name | string | Konfigurierter Name für die Remote-Schnittstelle

Die Eigenschaft Devices kann dazu verwendet werden, Operationen mit Wirkung auf ein gesamtes dezentrales Netzwerk auszuführen. Jedes Gerät in einem dezentralen Netzwerk wird durch eine Schnittstelle IBaseDevice repräsentiert. Dieser Schnittstelle ist eine Teilmenge der Eigenschaften zugeordnet, die für ein IProfinetDevice verfügbar sind. Die Schnittstelle bietet den begrenzten Funktionsumfang, der für diese Geräte in der SIMATIC Automation Tool API vorgesehen ist.

Die folgenden Eigenschaften sind an der Schnittstelle IBaseDevice verfügbar.

Name der Eigenschaft | Rückgabetyp | Beschreibung
ArticleNumber | string | Bestellnummern des Moduls. Auch bezeichnet als MLFB oder "Artikelnummer".
Comment | string | Hiermit kann der Anwender dem Gerät einen Kommentar zuordnen. Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.
Configured | bool | Hat das Gerät eine gültige Konfiguration?
Description | string | Beschreibung des Hardware-Elements auf Basis der Artikelnummer. Hierbei handelt es sich um die gleiche Beschreibung, die der Anwender im TIA Portal sieht. (z. B. "CPU-1215 DC/DC/DC")
Failsafe | FeatureSupport | Ist dies laut Artikelnummer ein fehlersicheres Gerät?
Family | DeviceFamily | Zu welcher "Gerätefamilie" gehört das Gerät? Weitere Informationen finden Sie in der Beschreibung der Enumeration DeviceFamily.
FirmwareUpdateAllowed | FeatureSupport | Unterstützt dieses Gerät Firmware-Aktualisierungen?
FirmwareVersion | string | Aktuelle Firmware-Version des Geräts
HardwareInFirmwareOrder | IHardwareCollection | Hardware-Sammlung in Firmware-Bestellung
HardwareInDisplayOrder | IHardwareCollection | Hardware in angezeigter Reihenfolge
HardwareNumber | short | Nummernkennung
ID | uint | Die eindeutige Kennung für jedes Gerät und Modul in der Station. Sie wird als eindeutige Kennung bei Ausführung einer Operation FirmwareUpdate verwendet.
Modules | IModuleCollection | Eine Sammlung lokaler, an die Station angeschlossener Module. Diese Eigenschaft wird hier ausführlich beschrieben.
Name | string | Name des Geräts
NewFirmwareFile | string | Dateipfad zur neuen Firmware-Datei
NewFirmwareVersion | string | Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.
NewFirmwareNameIsValid | bool | Ist die neue Firmware-Datei gültig?
Selected | bool | Ist das Gerät ausgewählt?
SerialNumber | string | Eindeutige Seriennummer des Geräts
Slot | uint | Steckplatznummer des Hardware-Elements
SlotName | string | Diese Eigenschaft wird in der Benutzeroberfläche des SIMATIC Automation Tool verwendet. Sie ist für API-Operationen nicht relevant.
StationNumber | uint | Stationsnummer des Geräts
SubSlot | uint | Die Subslot-Nummer des Geräts. Diese ist für steckbare Submodule wie das SB-1200 relevant.
Supported | FeatureSupport | Wird das erkannte Netzwerkgerät von aktuellen Operationen der SIMATIC Automation Tool API unterstützt?

Mit Hilfe der Eigenschaft Devices der Schnittstelle IRemoteInterface können alle Stationen eines dezentralen Netzwerks untersucht werden.

Das folgende Beispiel ist eine Erweiterung des Beispiels aus dem Thema Dezentrale Peripheriemodule:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

foreach (IProfinetDevice dev in scannedDevices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu == null)
continue;

List<IRemoteInterface> decentalNets = devAsCpu.RemoteInterfaces;
List<string> orderNumbers = new List<string>();

foreach (IRemoteInterface net in decentalNets)
{
//-----------------------------------------------------------
//
        Remote-Schnittstelle untersuchen
//-----------------------------------------------------------
if (net.InterfaceType == RemoteInterfaceType.Profinet)
{
//-------------------------------------------------------
//
        Jede dezentrale Station betrachten
//-------------------------------------------------------
List<IBaseDevice> stations = net.Devices;

foreach (IBaseDevice station in stations)
{
orderNumbers.Add(station.ArticleNumber);
}
}
}
}

Bei diesem Beispiel werden alle PROFINET-Remoteschnittstellen erfasst und es wird eine Liste der Artikelnummern für alle dezentralen Stationen im Industrienetzwerk erstellt.

Da IBaseDevice auch die Eigenschaft Modules unterstützt, kann das Beispiel einfach erweitert werden und es können über die dezentralen Stationen hinaus auch die lokalen Module an jeder Station erfasst werden.


Die Schnittstelle ICPUClassic

Die Schnittstelle ICPUClassic

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Identifikation von klassischen CPU-Geräten in einer IProfinetDeviceCollection
  • Methode GetDiagnosticsBuffer


Identifikation von klassischen CPU-Geräten in einer IProfinetDeviceCollection

Identifikation von klassischen CPU-Geräten in einer IProfinetDeviceCollection

Die Methode ScanNetworkDevices generiert eine IProfinetDeviceCollection. Diese Sammlung enthält ein Element für jedes erreichbare Gerät im Industrienetzwerk. Zu diesen Geräten können S7‑300 und S7‑400 (klassische) CPUs gehören.

Die Schnittstelle IProfinetDevice stellt Eigenschaften und Methoden zur Verfügung, die auf alle Kategorien von Geräten anwendbar sind. Eine Methode ist jedoch speziell für klassische CPU-Geräte vorgesehen. Der Zugriff auf diese Methode, GetDiagnosticsBuffer, kann über die Schnittstelle ICPUClassic erfolgen.

Um festzustellen, ob eine bestimmte Schnittstelle IProfinetDevice wirklich ein klassisches CPU-Gerät repräsentiert, senden Sie sie an eine ICPUClassic. Wenn die Übertragung erfolgreich ist, handelt es sich bei dem Netzwerkgerät um eine klassische CPU und Sie können die Methode für die Schnittstelle ICPUClassic verwenden. Das folgende Beispiel veranschaulicht diesen Übertragungsvorgang:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
ICPUClassic devAsClassicCpu = dev as ICPUClassic;
if (devAsClassicCpu != null)
{
//-----------------------------------------------------
//
        Das Gerät ist eine klassische CPU.
//
        Für die Interaktion mit dem Gerät kann die Schnittstelle ICPUClassic verwendet werden.
//-----------------------------------------------------
}
}
}

Hinweis

Die Schnittstelle ICPUClassic erbt ihre Einstellungen von IProfinetDevice. Deshalb werden alle von IProfinetDevice unterstützten Eigenschaften und Methoden auch von der Schnittstelle ICPUClassic unterstützt.


Methode GetDiagnosticsBuffer

Methode GetDiagnosticsBuffer

Rückgabetyp | Methodenname
Result | GetDiagnosticsBuffer

Parameter
Name | Datentyp | Parametertyp | Beschreibung
DiagnosticsItems | List<DiagnosticsItem> | Ausgang | Eine Sammlung von Diagnose-Elementen. Dabei steht jedes Element der Sammlung für einen Eintrag im Diagnosepuffer.
Language | Language | Eingang | Angeforderte Sprache für die exportierten Diagnosepuffereinträge.

Mit dieser Methode werden die aktuellen Diagnoseeinträge aus der CPU ausgelesen. Die Methode GetDiagnosticsBuffer gibt eine Sammlung von Objekten DiagnosticsItem aus. Im folgenden Beispiel wird die Sammlung IProfinetDeviceCollection daraufhin durchsucht, ob sie eine klassische CPU unter einer bestimmten IP-Adresse enthält. Wird diese gefunden, werden die Diagnoseinformationen aus der CPU ausgelesen. Die Language enum dient zum Abrufen von Diagnoseeinträgen in einer bestimmten Sprache:

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
List<DiagnosticsItem> aLogs = new List<DiagnosticsItem>();
IProfinetDeviceCollection devices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPUClassic devAsCpu = dev as ICPUClassic;
        if ((devAsCpu != null) && (devAsCpu.IP == targetIPAddress))
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            retVal = devAsCpu.GetDiagnosticsBuffer(out aLogs, Language.English);
            if (retVal.Succeeded)
            {
                for (int idxLog = 0; idxLog < aLogs.Count; idxLog++)
                {
                //get information time stamp
                string descrTimes = aLogs[idxLog].TimeStamp.ToString();

                //get information basic description
                string descrBasic = aLogs[idxLog].Description1;

                //get information detailed description
                string descrDetail = aLogs[idxLog].Description2;

                //get information state (incoming/outgoing)
                string descrState = aLogs[idxLog].State.ToString();
                }
            }
        }
    }
}

Die Methode GetDiagnosticsBuffer gibt eine Sammlung von Objekten DiagnosticsItem aus.


IHMI-Schnittstelle

IHMI-Schnittstelle

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • IHMI-Schnittstelle
  • IHMI-Eigenschaften und Merker
  • IHMI-Methoden


IHMI-Schnittstelle

IHMI-Schnittstelle

Die Methode ScanNetworkDevices wird aufgerufen, um IProfinetDeviceCollection zu generieren. Diese Sammlung enthält ein Element für jedes erreichbare Gerät im Industrienetzwerk. Zu diesen Geräten können u. a. CPUs, HMI-Geräte, dezentrale Peripheriestationen und andere Siemens-Geräte gehören. Die Schnittstelle IProfinetDevice stellt Eigenschaften und Methoden zur Verfügung, die für alle Kategorien von Geräten gelten.

Es gibt jedoch Methoden, die nur für HMI-Geräte verwendet werden. Der Zugriff auf diese Eigenschaften und Methoden erfolgt über die Schnittstelle IHMI.

Um festzustellen, ob eine bestimmte Schnittstelle IProfinetDevice wirklich ein HMI-Gerät repräsentiert, senden Sie sie an eine IHMI. Wenn die Übertragung erfolgreich ist, handelt es sich bei dem Netzwerkgerät um ein HMI-Gerät und Sie können die Methoden für die Schnittstelle IHMI verwenden. Das folgende Beispiel veranschaulicht dieses Vorgehen.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
IHMI devAsHmi = dev as IHMI;
if (devAsHmi != null)
{
//-----------------------------------------------------
//
        Das Gerät ist ein HMI-Gerät.
//
        Für die Interaktion mit dem Gerät kann die IHMI-Schnittstelle verwendet werden.
//-----------------------------------------------------
}
}

}

Hinweis

Die Schnittstelle IHMI erbt ihre Einstellungen von IProfinetDevice. Deshalb werden alle von IProfinetDevice unterstützten Eigenschaften und Methoden auch von der Schnittstelle IHMI unterstützt. Im folgenden Abschnitt zu den IHMI-Eigenschaften werden nur die Eigenschaften/Methoden beschrieben, die speziell bei der Schnittstelle IHMI vorhanden sind.
Hinweis

Die Schnittstelle IHMI unterstützt die Methode FirmwareUpdate. Diese Methode gibt jedoch stets den Fehler FirmwareUpdateNotSupported aus. Um die Firmware für ein HMI-Gerät zu aktualisieren, muss die Methode zur Programmaktualisierung ausgeführt werden.


IHMI-Eigenschaften und Merker

IHMI-Eigenschaften und Merker

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • IHMI-Eigenschaften
  • Programmaktualisierungsmerker
  • Wiederherstellen-Merker
  • Funktionsmerker


IHMI-Eigenschaften

IHMI-Eigenschaften

Die Schnittstelle IHMI besteht aus den folgenden Eigenschaften:

Name der Eigenschaft | Rückgabetyp | Beschreibung
DeviceType | string | Gibt den Typ des HMI-Geräts zurück, der von dem Objekt dargestellt wird
FirmwareDeviceVersion | string | Gibt die Firmware-Version zurück, die auf dem HMI-Gerät vorhanden ist
RuntimeDeviceVersion | string | Gibt die Runtime-Version zurück, die auf dem HMI-Gerät vorhanden ist


Programmaktualisierungsmerker

Programmaktualisierungsmerker

Diese Merker können Sie mit der IHMI-Schnittstelle verwenden:

Name der Eigenschaft | Rückgabetyp | Beschreibung
NewProgramNameIsValid | bool | Wahr, wenn die Methode SetProgramFolder mit einem gültigen Programmordner aufgerufen wird. Falsch, wenn das Programm nicht gültig ist.
ProgramUpdateSucceeded | bool | Wahr, wenn die Programmaktualisierung erfolgreich ist, obwohl möglicherweise bei einem intern aktualisierten Zustand ein Fehler zurückgegeben wird
NewProgramName | string | Name des neuen Programms
NewProgramFolder | string | Speicherort des Ordners für das neue Programm: Der Wert wird über die Methode SetProgramFolder gesetzt
NewProgramNameErrorCode | Result | Codes zum Aufspüren von Problemen bei der Validierung des Programms, zum Beispiel wenn das Programm für das Gerät ungültig ist oder die im Programm zugewiesene IP-Adresse im Netzwerk bereits vorhanden ist


Wiederherstellen-Merker

Wiederherstellen-Merker

Diese Merker können Sie mit der IHMI-Schnittstelle verwenden:

Name der Eigenschaft | Rückgabetyp | Beschreibung
NewRestoreNameIsValid | bool | Wahr, wenn die Methode SetBackupFolder mit einer gültigen Sicherungsdatei aufgerufen wird. Falsch, wenn die Sicherungsdatei nicht gültig ist.
RestoreSucceeded | bool | Wahr, wenn die Wiederherstellung erfolgreich ist, obwohl möglicherweise bei einem intern aktualisierten Zustand ein Fehler zurückgegeben wurde
NewRestoreName | string | Welchen Namen hat das neue Programm?
NewRestoreFile | string | Wo befindet sich die Datei für das neue Programm? Der Wert wird über die Methode SetbackupFile gesetzt
NewRestoreNameErrorCode | Result | Möglichkeit zum Aufspüren von Problemen bei der Validierung des Programms, zum Beispiel wenn das Programm für das Gerät ungültig oder mit dem Gerät nicht kompatibel ist


Funktionsmerker

Funktionsmerker

Diese Merker können Sie mit der IHMI-Schnittstelle verwenden:

Name der Eigenschaft | Rückgabetyp | Beschreibung
BackupAllowed | bool | Wahr, wenn das Gerät Sicherungen zulässt
ProgramUpdateAllowed | bool | Wahr, wenn das Gerät Programmaktualisierungen zulässt
RestoreAllowed | bool | Wahr, wenn das Gerät Wiederherstellungen zulässt


IHMI-Methoden

IHMI-Methoden

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Methode Backup (IHMI-Schnittstelle)
  • Methode ProgramUpdate (IHMI-Schnittstelle)
  • Methode Restore (IHMI-Schnittstelle)
  • Methode SetProgramFolder
  • Methode SetBackupFile
  • Methode SetTransferChannel


Methode Backup (IHMI-Schnittstelle)

Methode Backup (IHMI-Schnittstelle)

Rückgabetyp | Methodenname
Result | Backup

Parameter

Name

Datentyp

Parametertyp

Beschreibung

strFile

string

Eingang

Ein vollständig qualifizierter Pfad und Dateiname für die Speicherung der Sicherungsdatei.

type

BackupType

Eingang (optional)

Falls vorhanden, gibt dies an, welche Daten gesichert werden sollen:

  • Komplettsicherung

  • Rezepte

  • Daten der Benutzerverwaltung

Diese Methode dient zum Sichern der Daten eines HMI-Geräts. Einige HMI-Geräte unterstützen die Funktion zum Sichern/Wiederherstellen nicht. Ob das aktuelle HMI-Gerät diese Funktion unterstützt, kann mit Hilfe der Eigenschaft BackupAllowed überprüft werden. Im folgenden Beispiel wird IProfinetDeviceCollection auf ein HMI-Gerät an einer bestimmten IP-Adresse durchsucht. Wird dieses HMI-Gerät gefunden, wird geprüft, ob es die Sicherungsfunktion unterstützt. Wenn ja, wird die Methode Backup aufgerufen.

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string bkFile = @"C:\MyHMIBackupFile.s7pbkp";
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
    IHMI devAsHmi = dev as IHMI;

        if ((devAsHmi != null) &&
            (devAsHmi.IP == targetIPAddress) &&
            (devAsHmi.BackupAllowed)
           )
        {
            devAsHmi.Selected = true;
            // back up only recipes
            retVal = devAsHmi.Backup(bkFile, BackupType.Recipes);

            // or do full HMI backup
            Result retVal = devAsHmi.Backup(bkFile);
        }
    }
}


Methode ProgramUpdate (IHMI-Schnittstelle)

Methode ProgramUpdate (IHMI-Schnittstelle)

Rückgabetyp | Methodenname
Result | ProgramUpdate

Diese Methode aktualisiert das Betriebssystem und die Runtime-Software des HMI-Geräts. Der Parameter strPath legt einen Ordner fest, der das zu ladende Programm enthält.

Um die Methode ProgramUpdate auf der IHMI-Schnittstelle erfolgreich durchzuführen, müssen Sie Folgendes prüfen:

  • Gerät ist ausgewählt

  • NewProgramFolder wurde durch SetProgramFolder festgelegt

Im folgenden Beispiel wird in IProfinetDeviceCollection nach einem HMI-Gerät unter einer bestimmten IP-Adresse gesucht und das Programm für dieses HMI-Gerät aktualisiert.

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

Result retVal - new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        IHMI devAsHMI = dev as IHMI;
        if (devAsHMI != null)
        {
            devAsHMI.Selected = true;
            devAsHMI.SetProgramFolder( @"c:\myFolder\ProgramUpdate\Simatic.HMI\RT_Projects\Project1");
            retVal = devAsHMI.ProgramUpdate();
        }
    }
}

Der neue Programmordner muss die folgenden Dateien enthalten, damit der Vorgang erfolgreich durchgeführt werden kann:
DownloadTask.xml
ProjectCharacteristics.rdf

Diese Dateien befinden sich üblicherweise in einem Ordner, der (mit dem TIA Portal) in folgendem Format erstellt wird:
{DeviceName)\Simatic.HMI\RT_Projects\{ProjectName}.{DeviceName}

Beispiel:
"C:\Desktop\hmim14000100a\Simatic.HMI\RT_Projects\DasBasicUndMobilePanelen.hmim14000100a[KTP700 Mobile]"

Hinweis

Aktualisierung von HMI-Betriebssystem und Runtime-Software

Die Methode ProgramUpdate für ein HMI-Gerät unterscheidet sich von der für eine CPU. Diese Methode kann das Betriebssystem und Runtime-Software für HMI-Geräte aktualisieren. Eine Teilaktualisierung können Sie nicht auswählen. Das SIMATIC Automation Tool aktualisiert alle Datenkomponenten nach Bedarf, um einen konsistenten Ladevorgang zu gewährleisten. Auf einer Karte für die HMI-Programmaktualisierung können sich mehrere Projekte befinden, so dass unter \Simatic.HMI\RT_Projects\ ein Ordner zum Laden angegeben werden muss.


Methode Restore (IHMI-Schnittstelle)

Methode Restore (IHMI-Schnittstelle)

Rückgabetyp | Methodenname
Result | Restore

Mit dieser Methode können Sie HMI-Gerätedaten aus einer früheren Sicherung des Geräts wiederherstellen. Einige HMI-Geräte unterstützen die Funktion zum Sichern/Wiederherstellen nicht. Ob das aktuelle HMI-Gerät diese Funktion unterstützt, kann mit Hilfe der Eigenschaft RestoreAllowed überprüft werden.

Um die Methode Restore auf der IHMI-Schnittstelle erfolgreich durchzuführen, muss der Benutzer folgende Punkte prüfen:

  • Gerät ist ausgewählt

  • BackupFile wurde durch SetBackupFile festgelegt

Im folgenden Beispiel wird IProfinetDeviceCollection auf ein HMI-Gerät an einer bestimmten IP-Adresse durchsucht. Wird dieses HMI-Gerät gefunden, wird geprüft, ob es die Wiederherstellungsfunktion unterstützt. Wenn ja, wird die Methode Restore aufgerufen.

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IHMI hmi = scannedDevices.FindDeviceByMAC(targetMACAddress) as IHMI;
if (hmi != null && hmi.RestoreAllowed == true)
{
//
        Zu aktualisierendes HMI-Gerät auswählen
hmi.Selected = true;

retVal = hmi.SetBackupFile(@"C:\MyFolder\Backup.s7pbkp");
if (retVal.Failed == true)
return;

//
        IP-Adresse eindeutig?
if (hmi.DuplicateIP == true)
return;

//
        Wird das Gerät unterstützt?
if (hmi.Supported == false)
return;

//
        Wiederherstellung durchführen
retVal = hmi.Restore();
}
}


Methode SetProgramFolder

Methode SetProgramFolder

Rückgabetyp | Name der Methode
Result | SetProgramFolder

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFolder | string | Eingang | Stellt den Speicherort des Ordners ein, in dem die Quelle zum Laden des Programms gespeichert wird.

Das folgende Beispiel zeigt, wie der Programmordner in einem HMI-Gerät eingestellt wird.

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IHMI hmi = scannedDevices.FindDeviceByMAC(targetMACAddress) as IHMI;
if (hmi != null && hmi.ProgramUpdateAllowed == true)
{
//
        Zu aktualisierendes HMI-Gerät auswählen
hmi.Selected = true;

retVal = hmi.SetProgramFolder(@"C:\MyFolder");
if (retVal.Failed == true)
return;

//
        IP-Adresse eindeutig?
if (hmi.DuplicateIP == true)
return;

//
        Wird das Gerät unterstützt?
if (hmi.Supported == false)
return;

//
        Programmaktualisierung durchführen
retVal = hmi.ProgramUpdate();
}
}

Der Ordner, der für "strPath" angegeben ist, muss die folgenden Dateien enthalten, damit der Vorgang erfolgreich ausgeführt werden kann:

  • DownloadTask.xml

  • ProjectCharacteristics.rdf

Diese Dateien befinden sich üblicherweise in einem Ordner, der (mit dem TIA Portal) in folgendem Format erstellt wird:

{DeviceName)\Simatic.HMI\RT_Projects\{ProjectName}.{DeviceName}

Beispiele:
"C:\Desktop\hmim14000100a\Simatic.HMI\RT_Projects\DasBasicUndMobilePanelen.hmim14000100a[KTP700 Mobile]"

Hinweis

Die Methode ProgramUpdate für ein HMI-Gerät unterscheidet sich von der für eine CPU. Bei einem HMI-Gerät kann diese Methode das Betriebssystem und die Runtime-Software aktualisieren. Eine Teilaktualisierung können Sie nicht auswählen. Das SIMATIC Automation Tool aktualisiert alle Komponenten nach Bedarf, um einen konsistenten Ladevorgang zu gewährleisten. Auf einer Karte für die HMI-Programmaktualisierung können sich mehrere Projekte befinden, sodass unter \Simatic.HMI\RT_Projects\ ein Ordner angegeben werden muss.


Methode SetBackupFile

Methode SetBackupFile

Rückgabetyp | Name der Methode
Result | SetBackupFile

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strFile | string | Eingang | Stellt den Speicherort des Ordners ein, in dem die Quelle für die Sicherungsdatei gespeichert wird.

Die Methode setzt die folgenden Merker am IHMI-Objekt:

  • NewRestoreName

  • NewRestoreFile

  • NewRestoreNameIsValid

Das folgende Beispiel zeigt, wie der Pfad für die Sicherungsdatei an einem HMI-Gerät eingestellt wird.

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IHMI hmi = scannedDevices.FindDeviceByMAC(targetMACAddress) as IHMI;
if (hmi != null && hmi.RestoreAllowed == true)
{
//
        Zu aktualisierendes HMI-Gerät auswählen
hmi.Selected = true;

retVal = hmi.SetBackupFile(@"C:\MyFolder\Backup.s7pbkp");
if (retVal.Failed == true)
return;

//
        IP-Adresse eindeutig?
if (hmi.DuplicateIP == true)
return;

//
        Wird das Gerät unterstützt?
if (hmi.Supported == false)
return;

//
        Wiederherstellung durchführen
retVal = hmi.Restore();
}
}


Methode SetTransferChannel

Methode SetTransferChannel

Rückgabetyp | Name der Methode
Result | SetTransferChannel

Parameter
Name | Datentyp | Parametertyp | Beschreibung
transferChannel | HMITransferChannel | Eingang | Bestimmt die Art der Kommunikation (Übertragungskanal) zum Kommunizieren mit dem HMI-Gerät.

HMI-Geräte können mehrere Protokolle unterstützen, um Daten mit dem SIMATIC Automation Tool auszutauschen. Die Protokolle sind die Übertragungskanäle. Die Methode legt den HMI-Übertragungskanal fest:

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566;  // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IHMI hmi = scannedDevices.FindDeviceByMAC(targetMACAddress) as IHMI;
if (hmi != null)
{
//
         PN/IE als Protokoll für die Kommunikation mit diesem HMI-Gerät zuweisen.
Result retVal = hmi.SetTransferChannel(HMITransferChannel.PN_IE);
}
}

Hinweis

Der standardmäßige Übertragungskanal ist HMITransferChannel.PN_IE.


IScalance-Schnittstelle

IScalance-Schnittstelle

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • IScalance-Schnittstelle
  • IScalance-Eigenschaften
  • IScalance-Methoden


IScalance-Schnittstelle

IScalance-Schnittstelle

Ein SCALANCE-Gerät gehört zu den Gerätetypen, die von der ScanNetworkDevices-Methode erkannt werden können. ScanNetworkDevices generiert eine IProfinetDeviceCollection, die für jedes erreichbare Gerät im industriellen Netzwerk ein Element enthält. Die Geräte können CPUs, HMIs, SCALANCE-Geräte und dezentrale Peripheriestationen enthalten.

Die IProfinetDevice-Schnittstelle stellt Eigenschaften und Methoden zur Verfügung, die auf alle Geräte anwendbar sind. Bei Geräten, bei denen es sich um SCALANCE-Geräte handelt, bietet die IScalance-Schnittstelle für SCALANCE-Geräte spezifische Eigenschaften und Methoden.

Um zu ermitteln, ob eine Geräteschnittstelle ein SCALANCE-Gerät darstellt, belegen Sie die IProfinetDevice-Schnittstelle mit einer IScalance-Schnittstelle. Wenn die Belegung erfolgreich ist, handelt es sich bei dem Netzwerkgerät um ein SCALANCE-Gerät, und Sie können die IScalance-Methoden und -Eigenschaften verwenden. Da die IScalance-Schnittstelle von der IProfinetDevice-Schnittstelle erbt, stehen für ein SCALANCE-Gerät alle IProfinetDevice-Methoden und -Eigenschaften zur Verfügung.

Das folgende Beispiel zeigt, wie Sie das durchsuchte Netzwerk auf SCALANCE-Geräte untersuchen:

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
IScalance devAsScalance = dev as IScalance;
if (devAsScalance != null)
{
//-----------------------------------------------------
//
        Das Gerät ist ein
        SCALANCE
        -Gerät.
//
        Für die Interaktion mit dem Gerät kann die IScalance-Schnittstelle verwendet werden.
//-----------------------------------------------------
}
}
}


IScalance-Eigenschaften

IScalance-Eigenschaften

Die IScalance-Schnittstelle hat die folgenden Eigenschaften:

Name der Eigenschaft | Rückgabetyp | Beschreibung
ProfileName | string | Gibt den Namen des SNMP-Profils zurück.
ProfileNameisValid | bool | WAHR, wenn ein gültiger Profilname vorhanden ist.


IScalance-Methoden

IScalance-Methoden

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Methode SetProfile
  • Methode FirmwareUpdate


Methode SetProfile

Methode SetProfile

Die Benutzeroberflächenanwendung ruft die Methode SetProfile auf, um die Profilkonfiguration für ein SCALANCE-Gerät einzurichten.

Rückgabetyp | Name der Methode
Result | SetProfile

Parameter
Name | Datentyp | Parametertyp | Beschreibung
Profile | ISNMPProflie | Eingang | Konfiguration von SNMP-Profil und TFTP (Trivial File Transfer Protocol) für die FW-Aktualisierung des SCALANCE-Geräts

Ein Beispiel für den Aufruf der Methode SetProfile finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

  • Beispiel: Konfiguration SNMP Version 3

In diesen Beispielen befindet sich der Aufruf von SetProfile eher am Ende des Beispielcodes.


Methode FirmwareUpdate

Methode FirmwareUpdate

Die Benutzeroberflächenanwendung ruft die Methode FirmwareUpdate auf, um die Firmware des SCALANCE-Geräts zu aktualisieren.

Rückgabetyp | Name der Methode
Result | FirmwareUpdate

Parameter
Name | Datentyp | Parametertyp | Beschreibung
Keine |  |  |

Ein Beispiel für den Aufruf der Methode FirmwareUpdate finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

  • Beispiel: Konfiguration SNMP Version 3

In diesen Beispielen befindet sich der Aufruf von FirmwareUpdate eher am Ende des Beispielcodes.


ISNMPProfile-Schnittstelle

ISNMPProfile-Schnittstelle

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • ISNMPProfile-Eigenschaften
  • ISNMPProfile-Methoden
  • SNMPProfile-Klasse


ISNMPProfile-Eigenschaften

ISNMPProfile-Eigenschaften

Das ISNMPProfile ist eine aggregierte Sammlung von Eigenschaften, mit denen Sie eine Aktualisierung der SCALANCE-Gerätefirmware mittels SNMP durchführen. Die für ein bestimmtes Gerät geltende Aktualisierung der Gerätefirmware ist von der auf diesem Gerät konfigurierten SNMP-Protokollversion abhängig. Die Beschreibungen der Eigenschaften weisen darauf hin, für welche SNMP-Version (V1, V2, V3) eine Eigenschaft gilt. Bei den für alle SNMP-Versionen geltenden Eigenschaften ist in der Beschreibung keine Versionsangabe enthalten.

Name der Eigenschaft | Rückgabetyp | Beschreibung
ProfileName | string | Name des SNMP-Profils
Version | SNMPVersion | Verwendete SNMP-Protokollversion
ServerIP | string | Darstellung der IP-Adresse als Zeichenkette
ServerIPArray | byte[] | IP-Adresse des TFTP-Servers
ServerPort | UInt16 | TFTP-Portzuweisung
ReadCommunity | string | V1/V2, ID-Zeichenkette für Leseberechtigung (PW)
WriteCommunity | string | V1/V2, ID-Zeichenkette für Schreibberechtigung (PW)
UserName | string | V3, Benutzername
ContextName | string | V3, Kontext-ID für Verwaltungsinfo
SecurityLevel | SNMPSecurityLevel | V3, Schutzstufe
AuthAlgorithm | SNMPAuthAlgorithm | V3, Algorithmus für Authentifizierung
AuthKey | byte[] | V3, Authentifizierungsschlüssel
PrivAlgorithm | SNMPPrivAlgorithm | V3, Algorithmus für Datenschutz
PrivKey | byte[] | V3, Datenschutzschlüssel


ISNMPProfile-Methoden

ISNMPProfile-Methoden

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Methode Validate


Methode Validate

Methode Validate

Die Methode Validate wertet die Argumente des SNMP-Profils aus, um sicherzustellen, dass ein konsistenter Satz erforderlicher Parameter für die Firmware-Aktualisierung vorhanden ist. Das zurückgegebene Ergebnis weist auf jegliche Inkonsistenzen hin.

Rückgabetyp | Name der Methode
Result | Validate

Parameter
Name | Datentyp | Parametertyp | Beschreibung
Keine |  |  |

Ein Beispiel für den Aufruf der Methode Validate finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

  • Beispiel: Konfiguration SNMP Version 3

In diesen Beispielen erfolgt der Aufruf von Validate nach dem Einstellen der Profilparameter.


SNMPProfile-Klasse

SNMPProfile-Klasse

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • ISNMPProfile-Klasseneigenschaften
  • ISNMPProfile-Klassenmethoden


ISNMPProfile-Klasseneigenschaften

ISNMPProfile-Klasseneigenschaften

Die SNMPProfile-Klasse dient zum Speichern und Bearbeiten von SNMP-Profilen.

Name der Eigenschaft | Rückgabetyp | Beschreibung
ProfileName | string | Name des SNMP-Profils
Version | SNMPVersion | Verwendete SNMP-Protokollversion
ServerIP | string | Darstellung der IP-Adresse als Zeichenkette
ServerIPArray | byte[] | IP-Adresse des TFTP-Servers
ServerPort | UInt16 | TFTP-Portzuweisung
ReadCommunity | string | V1/V2, ID-Zeichenkette für Leseberechtigung
WriteCommunity | string | V1/V2, ID-Zeichenkette für Schreibberechtigung
UserName | string | V3, Benutzername
ContextName | string | V3, Kontext-ID für Verwaltungsinfo
SecurityLevel | SNMPSecurityLevel | V3, Schutzstufe
AuthAlgorithm | SNMPAuthAlgorithm | V3, Algorithmus für Authentifizierung
AuthKey | byte[] | V3, Authentifizierungsschlüssel
PrivAlgorithm | SNMPPrivAlgorithm | V3, Algorithmus für Datenschutz
PrivKey | byte[] | V3, Datenschutzschlüssel


ISNMPProfile-Klassenmethoden

ISNMPProfile-Klassenmethoden

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • SetProfileName
  • SetSNMPVersion
  • Methode SetServerIP
  • Methode SetServerPort
  • Methode SetReadCommunity
  • Methode SetWriteCommunity
  • Methode SetUserName
  • Methode SetContextName
  • Methode SetSecurityLevel
  • Methode SetAuthAlgorithm
  • Methode SetPrivAlgorithm


SetProfileName

SetProfileName

Die Methode SetProfileName weist den Wert der Eingangszeichenkette dem Namen des Profils zu.

Rückgabetyp | Name der Methode
Result | SetProfileName

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strName | string | Eingang | Profilname

Ein Beispiel für den Aufruf der Methode SetProfileName finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

  • Beispiel: Konfiguration SNMP Version 3

In diesen Beispielen erfolgt der Aufruf von SetProfileName eher am Anfang des Codebeispiels.


SetSNMPVersion

SetSNMPVersion

Die Methode SetSNMPVersion legt die SNMP-Protokollversion fest. Das SNMP-Protokoll hat entweder die Version 1, 2 oder 3.

Rückgabetyp | Name der Methode
Result | SetSNMPVersion

Parameter
Name | Datentyp | Parametertyp | Beschreibung
nVersion | SNMPVersion | Eingang | SNMP-Version 1, 2, 3

Ein Beispiel für den Aufruf der Methode SetSNMPVersion finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

  • Beispiel: Konfiguration SNMP Version 3

In diesen Beispielen erfolgt der Aufruf von SetSNMPVersion eher am Anfang des Codebeispiels.


Methode SetServerIP

Methode SetServerIP

Die Methode SetServerIP legt die IP-Adresse des TFTP-Servers fest. Diese Methode ist für alle SNMP-Profile anwendbar.

Rückgabetyp | Name der Methode
Result | SetServerIP

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strIP | string | Eingang | IP-Zuweisung

Ein Beispiel für den Aufruf der Methode SetServerIP finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

  • Beispiel: Konfiguration SNMP Version 3

In diesen Beispielen erfolgt der Aufruf von SetServerIP eher am Anfang des Codebeispiels.


Methode SetServerPort

Methode SetServerPort

Die Methode SetServerPort legt die Portzuweisung des TFTP-Servers fest. Diese Methode ist für alle SNMP-Profile anwendbar.

Rückgabetyp | Name der Methode
Result | SetServerPort

Parameter
Name | Datentyp | Parametertyp | Beschreibung
nVersion | UInt16 | Eingang | TFTP-Portzuweisung

Ein Beispiel für den Aufruf der Methode SetServerPort finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

  • Beispiel: Konfiguration SNMP Version 3

In diesen Beispielen erfolgt der Aufruf von SetServerPort direkt nach dem Aufruf von SetServerIP.


Methode SetReadCommunity

Methode SetReadCommunity

Die Methode SetReadCommunity weist der Eingangszeichenkette die Lese-Community zu. Die Lese-Community-Zeichenkette ermöglicht es einem Remote-Gerät, schreibgeschützte Informationen aus einem Gerät abzurufen. Diese Methode ist für ein SNMP-Profil Version 1 oder Version 2 anwendbar.

Rückgabetyp | Name der Methode
Result | SetReadCommunity

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strCommunity | string | Eingang | Zuweisung der Lese-Community

Ein Beispiel für den Aufruf der Methode SetReadCommunity finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

In diesen Beispielen erfolgt der Aufruf von SetReadCommunity nahe der Mitte des Codebeispiels.


Methode SetWriteCommunity

Methode SetWriteCommunity

Die Methode SetWriteCommunity weist der Eingangszeichenkette die Schreib-Community zu. Die Schreib-Community-Zeichenkette gestattet einem Gerät sowohl Lese- als auch Schreibvorgänge. Diese Methode ist für ein SNMP-Profil Version 1 oder Version 2 anwendbar.

Rückgabetyp | Name der Methode
Result | SetWriteCommunity

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strCommunity | string | Eingang | Zuweisung der Schreib-Community

Ein Beispiel für den Aufruf der Methode SetWriteCommunity finden Sie in den folgenden Beispielen:

  • Beispiel: Konfiguration SNMP Version 1

  • Beispiel: Konfiguration SNMP Version 2

In diesen Beispielen erfolgt der Aufruf von SetWriteCommunity eher am Anfang des Codebeispiels.


Methode SetUserName

Methode SetUserName

Die Methode SetUserName legt den Benutzernamen für ein SNMP-Profil Version 3 fest.

Rückgabetyp | Name der Methode
Result | SetUserName

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strName | string | Eingang | V3, SNMP-Benutzername

Ein Beispiel für den Aufruf der Methode SetUserName sehen Sie nahe der Mitte des Codebeispiels Beispiel: Konfiguration SNMP Version 3.


Methode SetContextName

Methode SetContextName

Die Methode SetContextName legt den Kontextnamen für ein SNMP-Profil Version 3 fest.

Rückgabetyp | Name der Methode
Result | SetContextName

Parameter
Name | Datentyp | Parametertyp | Beschreibung
strName | string | Eingang | V3, Kontext SNMP-Verwaltungsinformationen

Ein Beispiel für den Aufruf der Methode SetContextName sehen Sie nahe der Mitte des Codebeispiels Beispiel: Konfiguration SNMP Version 3.


Methode SetSecurityLevel

Methode SetSecurityLevel

Die Methode SetSecurityLevel legt die Schutzstufe für ein SNMP-Profil Version 3 fest.

Rückgabetyp | Name der Methode
Result | SetSecurityLevel

Parameter
Name | Datentyp | Parametertyp | Beschreibung
level | SNMPSecurityLevel | Eingang | V3, SNMP-Schutzstufe

Ein Beispiel für den Aufruf der Methode SetSecurityLevel sehen Sie nahe der Mitte des Codebeispiels Beispiel: Konfiguration SNMP Version 3.


Methode SetAuthAlgorithm

Methode SetAuthAlgorithm

Die Methode SetAuthAlgorithm legt den Algorithmus für die Authentifizierung für ein SNMP-Profil Versionsstand 3 fest. Der Algorithmus für die Authentifizierung gilt dann, wenn die Schutzstufe "Authentifizierung" fordert. Das Passwort für die Authentifizierung gilt dann, wenn die Schutzstufe sowohl "Datenschutz" als auch "Authentifizierung" verlangt.

Rückgabetyp | Name der Methode
Result | SetAuthAlgorithm

Parameter
Name | Datentyp | Parametertyp | Beschreibung
algorithm | SNMPAuthAlgorithm | Eingang | V3, SNMP-Algorithmus für Authentifizierung
strPassword | string | Eingang | V3, SNMP-Passwort für die Authentifizierung

Ein Beispiel für den Aufruf der Methode SetAuthAlgorithm sehen Sie nahe der Mitte des Codebeispiels Beispiel: Konfiguration SNMP Version 3.


Methode SetPrivAlgorithm

Methode SetPrivAlgorithm

Die Methode SetPrivAlgorithm legt den Algorithmus für den Datenschutz für ein SNMP-Profil Version 3 fest. Der Algorithmus für den Datenschutz gilt dann, wenn die Schutzstufe "Datenschutz" fordert.

Rückgabetyp | Name der Methode
Result | SetPrivAlgorithm

Parameter
Name | Datentyp | Parametertyp | Beschreibung
algorithm | SNMPPrivAlgorithm | Eingang | V3, SNMP-Algorithmus für Datenschutz
strPassword | string | Eingang | V3, SNMP-Passwort für Datenschutz

Ein Beispiel für den Aufruf der Methode SetPrivAlgorithm sehen Sie nahe der Mitte des Codebeispiels Beispiel: Konfiguration SNMP Version 3.


Codebeispiele für IScalance- und ISNMP-Firmware-Aktualisierungen

Codebeispiele für IScalance- und ISNMP-Firmware-Aktualisierungen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Beispiel: Konfiguration SNMP Version 1
  • Beispiel: Konfiguration SNMP Version 2
  • Beispiel: Konfiguration SNMP Version 3


Beispiel: Konfiguration SNMP Version 1

Beispiel: Konfiguration SNMP Version 1

Dieses Beispiel zeigt, wie Sie eine Firmware-Aktualisierung für ein SCALANCE-Gerät konfigurieren und initiieren. In diesem Beispiel verwendet das SCALANCE-Gerät SNMP Version 1.

SNMPProfile　profileV1　=　new　SNMPProfile();

// Profil mit SNMP-Version 1 erzeugen
Result　retVal　=　profileV1.SetSNMPVersion(SNMPVersion.Version1);
if　(retVal.Failed)
      return;

// Name für dieses Profil festlegen
retVal = profileV1.SetProfileName("Profile_1");
if (retVal.Failed)
      return;
// IP-Adresse für TFTP-Server festlegen (obligatorisch)
retVal　=　profileV1.SetServerIP("192.168.0.1");
if　(retVal.Failed)
      return;
// Port für TFTP-Server festlegen, Standard ist 69 (optional)
retVal　=　profileV1.SetServerPort(69);
if　(retVal.Failed)
      return;

//　SCALANCE Lese-Community festlegen, Standard ist "öffentlich" (optional)
retVal　=　profileV1.SetReadCommunity("public");
if　(retVal.Failed)
      return;

//　SCALANCE Schreib-Community festlegen, Standard ist "privat" (optional)
retVal　=　profileV1.SetWriteCommunity("private");
if　(retVal.Failed)
      return;

//　Prüfen, ob Profil gültig ist, um sicherzustellen, dass kein Parameter übersehen wurde
retVal　=　profileV1.Validate();
if　(retVal.Failed)
      return;

// Durchsuchen und Firmware-Aktualisierung auf allen SCALANCE-Geräten durchführen
Network　myNetwork　=　new　Network();
IProfinetDeviceCollection　scannedDevices;
//　Netzwerk auf alle angeschlossenen Geräte durchsuchen
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
      //　SCALANCE-Geräte filtern
      List<IProfinetDevice>　onlyScalance　=
       scannedDevices.FilterByDeviceFamily(new　List<DeviceFamily>(1)　{　DeviceFamily.SCALANCE　});
      foreach　(IScalance　scalance　in　onlyScalance)
      {
         // SNMP-Profil für die Kommunikation mit diesem SCALANCE-Gerät festlegen
         retVal　=　scalance.SetProfile(profileV1);
         if　(retVal.Succeeded)
         {
         // Neue Firmware-Datei für die Aktualisierung von SCALANCE festlegen
         retVal　=　scalance.SetFirmwareFile(@"C:\Firmware\FirmwareFile.lad");
         if　(retVal.Succeeded)
               retVal　=　scalance.FirmwareUpdate();
         }
      }
}


Beispiel: Konfiguration SNMP Version 2

Beispiel: Konfiguration SNMP Version 2

Dieses Beispiel zeigt, wie Sie eine Firmware-Aktualisierung für ein SCALANCE-Gerät konfigurieren und initiieren. In diesem Beispiel verwendet das SCALANCE-Gerät SNMP Version 2.

SNMPProfile profileV2 = new SNMPProfile();

// Profil mit SNMP-Version 2 erstellen
Result retVal = profileV2.SetSNMPVersion(SNMPVersion.Version2);
if (retVal.Failed)
      return;

// Name für dieses Profil festlegen
retVal = profileV2.SetProfileName("Profile_2");
if (retVal.Failed)
      return;

// Adresse für TFTP-Server festlegen (obligatorisch)
retVal = profileV2.SetServerIP("192.168.0.1");
if (retVal.Failed)
      return;

// Port für TFTP-Server festlegen, Standard ist 69 (optional)
retVal = profileV2.SetServerPort(69);
if (retVal.Failed)
      return;

// SCALANCE Lese-Community festlegen, Standard ist "öffentlich" (optional)
retVal = profileV2.SetReadCommunity("public");
if (retVal.Failed)
      return;

// SCALANCE Schreib-Community festlegen, Standard ist "privat" (optional)
retVal = profileV2.SetWriteCommunity("private");
if (retVal.Failed)
      return;

// Prüfen, ob Profil gültig ist, um sicherzustellen, dass kein Parameter übersehen wurde
retVal = profileV2.Validate();
if (retVal.Failed)
      return;

// Durchsuchen und Firmware-Aktualisierung auf allen SCALANCE-Geräten durchführen
Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

// Netzwerk auf alle angeschlossenen Geräte durchsuchen
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
 {

      // SCALANCE-Geräte filtern
       List<IProfinetDevice> onlyScalance =
       scannedDevices.FilterByDeviceFamily(new List<DeviceFamily>(1) { DeviceFamily.SCALANCE });
       foreach (IScalance scalance in onlyScalance)
      {
            // SNMP-Profil für die Kommunikation mit diesem SCALANCE-Gerät festlegen
             retVal = scalance.SetProfile(profileV2);
             if (retVal.Succeeded)
            {
                  // Neue Firmware-Datei für die Aktualisierung von SCALANCE festlegen
                   retVal = scalance.SetFirmwareFile(@"C:\Firmware\FirmwareFile.lad");
                   if (retVal.Succeeded)
                         retVal = scalance.FirmwareUpdate();
            }
      }
}


Beispiel: Konfiguration SNMP Version 3

Beispiel: Konfiguration SNMP Version 3

Dieses Beispiel zeigt, wie Sie eine Firmware-Aktualisierung für ein SCALANCE-Gerät konfigurieren und initiieren. In diesem Beispiel verwendet das SCALANCE-Gerät SNMP Version 3 mit Authentifizierung und Datenschutz.

SNMPProfile profileV3_3 = new SNMPProfile();

// Profil mit SNMP-Version 3 erstellen
Result retVal = profileV3_3.SetSNMPVersion(SNMPVersion.Version3);
if (retVal.Failed)
      return;

// Name für dieses Profil festlegen
retVal = profileV3_3.SetProfileName("Profile_3.1");
if (retVal.Failed)
      return;

// IP-Adresse für TFTP-Server festlegen (obligatorisch)
retVal = profileV3_3.SetServerIP("192.168.0.1");
if (retVal.Failed)
      return;

// Port für TFTP-Server festlegen, Standard ist 69 (optional)
retVal = profileV3_3.SetServerPort(69);
if (retVal.Failed)
      return;

// Benutzername festlegen (obligatorisch)
retVal = profileV3_3.SetUserName("User1");
if (retVal.Failed)
      return;

// Kontextname festlegen (optional)
retVal = profileV3_3.SetContextName("Context1");
if (retVal.Failed)
      return;

// SCALANCE-Schutzstufe NoAuthNoPriv festlegen (obligatorisch)
retVal = profileV3_3.SetSecurityLevel(SNMPSecurityLevel.AuthPriv);

 //　Auth.-Algorithmus MD5 und Passwort festlegen (obligatorisch)
retVal　=　profileV3_3.SetAuthAlgorithm(SNMPAuthAlgorithm.MD5,　"Password1");
if　(retVal.Failed)
    return;

//　Datenschutz-Algorithmus DES und Passwort festlegen (obligatorisch)
retVal　=　profileV3_3.SetPrivAlgorithm(SNMPPrivAlgorithm.DES,　"Password2");
if　(retVal.Failed)
        return;

if (retVal.Failed)
      return;

// Prüfen, ob Profil gültig ist, um sicherzustellen, dass kein Parameter übersehen wurde
retVal = profileV3_3.Validate();
if (retVal.Failed)
      return;

// Durchsuchen und Firmware-Aktualisierung auf allen SCALANCE-Geräten durchführen
Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

// Netzwerk auf alle angeschlossenen Geräte durchsuchen
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
       {
            // SCALANCE-Geräte filtern
            List<IProfinetDevice> onlyScalance =
             scannedDevices.FilterByDeviceFamily(new List<DeviceFamily>(1) { DeviceFamily.SCALANCE });
            foreach (IScalance scalance in onlyScalance)
            {
                  // SNMP-Profil für die Kommunikation mit diesem SCALANCE-Gerät festlegen
                  retVal = scalance.SetProfile(profileV3_3);
                  if (retVal.Succeeded)
                  {
                        // Neue Firmware-Datei für die Aktualisierung von SCALANCE festlegen
                        retVal = scalance.SetFirmwareFile(@"C:\Firmware\FirmwareFile.lad");
                        if (retVal.Succeeded)
                              retVal = scalance.FirmwareUpdate();
                   }
               }
      }


Ausnahmen

Ausnahmen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • CriticalInternalErrorException


CriticalInternalErrorException

CriticalInternalErrorException

Die API-Schnittstelle umfasst eine Ausnahme dafür, wenn ein kritischer Zustand erkannt wurde.

Wenn Ihre Anwendung erkennt, dass die Ausnahme CriticalInternalErrorException ausgelöst wurde, schließen Sie die Anwendung, die die API verwendet. Ein kritischer Fehler ist aufgetreten.

Network myNetwork = new Network();
try
{
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)

{
IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
devAsCpu.Selected = true;
if (devAsCpu.Failsafe)devAsCpu.SelectedConfirmed = true;
Result retVal = devAsCpu.ResetToFactoryDefaults();
}
}
}
}
catch (CriticalInternalErrorException e)
{
//
        In der API ist ein kritischer interner Fehler aufgetreten
}
catch (Exception e)
{
//
        In der API ist eine Ausnahme aufgetreten

}


API-Enumerationen

API-Enumerationen

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • DataChangedType
  • DeviceFamily
  • ConfirmationType
  • ErrorCode
  • Sprache
  • OperatingState
  • OperatingStateREQ
  • ProgressAction
  • RemoteInterfaceType
  • ProtectionLevel
  • ConfirmationType
  • FailsafeOperation
  • RemoteFolderType
  • SNMPVersion
  • SNMPSecurityLevel
  • SNMPAuthAlgorithm
  • SNMPPrivAlgorithm
  • ScanErrorType
  • HMITransferChannel
  • BackupType
  • TimeFormat


DataChangedType

DataChangedType

Diese Enumeration legt die möglichen Argumentwerte für den DataChangedEventHandler fest.

Invalid
OperatingState
RackInformation
Folders
File
ProfinetName
IPAddress
Password


DeviceFamily

DeviceFamily

Diese Enumeration gibt die Produktfamilie eines Hardware-Elements an.

None
CPU1200
CPU1500
CPU300
CPU400
ET200SP
ET200MP
ET200AL
ET200PRO
ET200ECO
ET200S
ET200M
HMI
SITOPUPS
SCALANCE
SIMOCODE
Unsupported
SIRIUS_ACT
Gateway
NetworkDevice
MicroDrive
SoftStarter
CommunicationsModule
OpticalReader


ConfirmationType

ConfirmationType

Diese Enumeration gibt die Arten der Benutzerbestätigung für Safety-relevante Vorgänge an.

Invalid = 0
SafetyPasswordIsBeingUsed = 0x2f161717
DeletingExistingSafetyProgram = 0x40232122
ReplacingExistingSafetyProgram = 0x492a282b
ReplacingExistingSafetyProgramWithNonSafetyProgram = 0x4a2c2b2d
LoadingSafetyProgram = 0x46292728,


ErrorCode

ErrorCode

Diese Enumeration führt alle möglichen Rückgabewerte für ein Result-Objekt auf.

OK
AccessDenied
ServiceTimeout
Disconnected
FailedToDisconnect
ServiceNotConnected
TooManySessions
SessionDelegitimated
NotChangableInRun
InvalidFileName
MultiESNotSupported
ServiceAborted
MultiESLimitExceeded
MultiESIncompatibleOtherESVersion
MultiESConflict
WriteProtected
DiskFull
InvalidVersion
PathNotFound

Failed
CPUFailedToEnterRunMode
MACAddressIsNotValid
IPAddressIsNotValid
SubnetMaskIsNotValid
GatewayIsNotValid
ProfinetNameIsNotValid
NewIPAddressIsNotValid
NewSubnetMaskIsNotValid
NewGatewayIsNotValid
NewProfinetNameIsNotValid
InvalidPointer
SetIPErrorDueProjectSettings
UnsupportedDevice
SetNameErrorDueProjectSettings
OperationNotSupportedByThisDevice
DeviceNotOnNetwork
FirmwareVersionMatch
FirmwareFileNotCompatibleToNew
FirmwareFileNotCompatibleToOld
FirmwareFileNotCompatibleNotSame
FirmwareFileNotCompatibleSame
FirmwareFileNotCompatible
FirmwareModuleNotReachable
FirmwareModuleNotAccepted
FirmwareIDNotFound
WriteBlockFailed
InvalidProjectVersion
DeviceIsNotAcceptingChanges
InvalidSignature
ParmeterOutOfRange
FailedToZipFolderContents
ErrorWritingToFile
ErrorCreatingFile
ErrorCreatingFolder
NoSATLicensePresent
InvalidTimeoutValue
NoDataToBackup
ErrorWritingToStream
ErrorReadingFromStream
InvalidProjectPath
ProjectNotCompatibleWithDevice
FailedToSetProfinetName
FailedToSetIPAddress
DownloadInvalidRecipe
IdentityFailure
DeviceMismatch
InvalidInterface
DeviceNotSelected
FailsafeAccessRequired
InternalApplicationError
InvalidPassword
DuplicateIPAddress
DuplicateProfinetName
SafetyDeviceMustBeConfirmed
NoSDCardPresent
InvalidProgramFolder
FSignaturesDoesNotMatch
FSignaturesMatch
DeviceDoesNotSupportProject
ProjectsUpdateIPNotReachable
RestoreIPNotReachable
ProjectIPNotUnique
SafetyProjectDownloadedToStandardNotAllowed
PasswordDiversityFailed
InvalidBackupFile
InvalidBackupFileExtension
IncompatibleBackupFile
InvalidFirmwareFile
OperationWasNotSuccessful
CouldNotValidatePassword
IPAddressAlreadyExistsOnNetwork
MissingProgramFilePassword
InvalidProgramFilePassword
OperationCancelledByUser
InvalidProgramForDevice
InvalidProgramFilePasswordLegitimizationLevel
DeviceNotFound
DeviceAlreadyExists
IPAddressAlreadyOnNetwork
ProfinetNameAlreadyOnNetwork
FailedToConnect
DeviceNotInitialized
CPUNewerVersionNotSupported
IPSuitNotValid
IPAddressChanged
ScanNoDevicesFound
DeviceCannotBeInserted
InsertDeviceDuplicateIP
IPNotReachable
CouldNotReadFSignature
InvalidNetworkInterface
InsufficientLegitimizationLevel
NoProgramPassword
ProjectVersionV1NotSupported
ProjectOpenCanceled
ProgramPasswordNeeded
RestoreError
IncompatibleProgramFile
UnsupportedProgramFile
ProgramFileFamilyMismatch
DuplicateNewIPAddress
SNMPErrorNoAccess
SNMPErrorReadOnly
SNMPErrorNotWritable
SNMPErrorAuthorizationError
SNMPError
InvalidProfileName
InvalidSNMPVersion
InvalidServerIP
InvalidServerPort
InvalidReadCommunity
InvalidWriteCommunity
InvalidUserName
InvalidContextName
InvalidSecurityLevel
InvalidAuthAlgorithm
InvalidAuthPassword
InvalidPrivAlgorithm
InvalidPrivPassword
InvalidProfile
ProfileNameAlreadyExists
ObsoleteMethod
FailedToInitiateFirmwareTransfer
DeviceDefinedError
ErrorDeletingFile
ErrorDeletingFolder
ErrorInvalidMAC
FailedToUpdateDuplicates
DuplicateNewProfinetName
ErrorBackingupData
FailsafeControlObjectIncorrectType
InvalidIPAddressOrUsedByNIC
FirmwareIntegrityFailed
ExportDiagnosticsBufferError
AlmFailedInitialize
AlmFailedCleanup
AlmFailedSessionInitialize
AlmFailedSessionCleanup
AlmSessionIDMissing
AlmSessionIDUnknown
AlmCouldNotConnect
AlmOutOfMemory
AlmOperationTimeout
AlmFunctionNotFound
AlmAborted
AlmBadfunctionArgument
AlmUnkownOption
AlmSendError
AlmReceiveError
AlmNoConnectionAvailable
AlmOpenSession
AlmResources
AlmService
AlmCryptography
AlmTaskAlreadyRunning
AlmInvalidPointer
AlmResultMismatch
AlmBadResult
AlmBatchWrongArgumentNumber
AlmBatchWrongArgument
AlmBatchWrongInputFile
AlmBatchWrongInputStream
AlmBatchAPILoadFailed
AlmBatchOutputfileExists
AlmBatchWrongOutputParmater
AlmBatchOutputCreationFailure
AlmBatchAccessDenied
AlmUnknownError
PowerCycleRequired

//HMI
UnexpectedOperatingSystemError
ServiceActive
RemoteTransferDisabled
HardwareSoftwareNotComplete
LogicalVolumneMissing
LogicalVolumneOutOfSpace
Abort
FirwareTypeNotSupported
FirwareTypeNotInstalled
StoreReadFailed
StoreWriteFailed
RescueBackupNotPossible
RescueRestoreNotPossible
ConnectionRequired
ObjectNotFound
BufferToSmall
InvalidArguements
AttributeNotFound
InvalidPath
TypeConversionFailed
FileReadFailed
FileWriteFailed
OutOfResources
OutOfSpace
UnknownAddon
IncompatibleAddon
AddonsUnsupported
LicenseFailed
UnknownApp
UnknownAppAddon
UnknownReferenceApp
RuntimeMissing
RuntimeBroken
SignatureRequired
SignatureInvalid
SignatureFailure
CertificateInvalid
CertificateFailure
CertificateNotReady
CertificateExpired
CertificateRevoked
SecurityLib
WrongRuntimeVersion
MajorRuntimeDowngrade
MajorRuntimeUpgrade
MajorImageDowngrade
MajorImageUpgrade
WrongRuntime
NotEnoughMemory
ProjectCharacteristicsMissing
ProjectCharacteristicsInvalid
PanelOrientationIsPortrait
PanelOrientationIsLandscape
WrongDevicetype
NoRuntimeInstalled
RuntimeCorrupt
InvalidTransferChannel
InvalidBackupType


Sprache

Sprache

Mit der Enumeration Language können Sie die Sprache für die ausgegebenen String-Daten festlegen. Sie enthält die folgenden Werte:

English
German
French
Spanish
Italian
Chinese


OperatingState

OperatingState

Diese Enumeration legt die möglichen Zustände der Eigenschaft OperatingState fest.

NotSupported
StopFwUpdate
StopSelfInitialization
Stop
Startup
Run
RunRedundant
Halt
LinkUp
Update
Defective
ErrorSearch
NoPower
CiR
STOPwithoutODIS
RunODIS


OperatingStateREQ

OperatingStateREQ

Diese Enumeration definiert die möglichen Zustände, die bei einem Aufruf der Methode GetOperatingState angefordert werden können.

Stop
Run


ProgressAction

ProgressAction

Diese Enumeration legt die möglichen Argumentwerte fest, die an einen ProgressChangedEventHandler gesendet werden können.

Invalid
Connecting
Reconnecting
Disconnecting
Initializing
Updating
Processing
Downloading
Uploading
Deleting
Reseting
Rebooting
Verifying
Formatting
Refreshing
Finished
UpdatingFirmware
InstallingRuntime
InstallingAddOns
UninstallingAddOns
UpdatingProgram


RemoteInterfaceType

RemoteInterfaceType

Diese Enumeration definiert die möglichen Zustände, die von einem Aufruf der Eigenschaft InterfaceType an der Schnittstelle IRemoteInterfaces ausgegeben werden können.

None
Profinet
Profibus
ASi


ProtectionLevel

ProtectionLevel

Die Enumeration ProtectionLevel gibt die Schutzstufe eines CPU-Passworts an:

Unknown
Failsafe
Full
Read
HMI
NoAccess
NoPassword


ConfirmationType

ConfirmationType

Diese Enumeration dient dazu, den Status fehlersicherer CPUs anzuzeigen.

Beschreibung | Wert
Invalid | 0
SafetyPasswordIsBeingUsed | 0x2f161717
DeletingExistingSafetyProgram | 0x40232122
ReplacingExistingSafetyProgram | 0x492a282b
ReplacingExistingSafetyProgramWithNonSafetyProgram | 0x4a2c2b2d
LoadingSafetyProgram | 0x46292728


FailsafeOperation

FailsafeOperation

Die Enumeration FailSafeOperation zeigt sicherheitsrelevante Vorgänge an.

Beschreibung | Wert
Invalid | 0
ResetToFactoryOperation | 0x2f161717
FormatMCOperation | 0x46292728
ProgramUpdateOperation | 0x43252224
RestoreOperation | 0x45262427


RemoteFolderType

RemoteFolderType

Die Enumeration RemoteFolderType zeigt den Typ des entfernten Ordners an.

Beschreibung | Wert
None | 0
Recipe | 1
Datalog | 2


SNMPVersion

SNMPVersion

Die Enumeration SNMPVersion gibt die SNMP-Versionsnummer für SCALANCE-Geräte an.

Beschreibung | Wert
NotSupported | -1
Version1 | 0
Version2 | 1
Version3 | 2


SNMPSecurityLevel

SNMPSecurityLevel

Die Enumeration SNMPSecurityLevel gibt die Schutzstufe für ein SNMP-Profil Version 3 an. Ein SCALANCE-Gerät, das ein SNMP-Profil Version 3 verwendet, hat Einstellungen für die Schutzstufe.

Beschreibung | Wert
NotSupported | -1
NoAuthNoPriv | 0
AuthNoPriv | 1
AuthPriv | 2


SNMPAuthAlgorithm

SNMPAuthAlgorithm

Die Enumeration SNMPAuthAlgorithm gibt den Algorithmus für die Authentifizierung für ein SCALANCE-Gerät an, das ein SNMP-Profil Version 3 verwendet.

Beschreibung | Wert
NotSupported | -1
MD5 | 0
SHA | 1


SNMPPrivAlgorithm

SNMPPrivAlgorithm

Die Enumeration SNMPPrivAlgorithm gibt den Algorithmus für den Datenschutz für ein SCALANCE-Gerät an, das ein SNMP-Profil Version 3 verwendet.

Beschreibung | Wert
NotSupported | -1
DES | 0
AES | 1


ScanErrorType

ScanErrorType

Die Enumeration ScanErrorType gibt die Art des Fehlers an, der von einer Gerätesuche zurückgegeben wird:

Beschreibung | Wert
Invalid | -1
Success | 0
Error | 1
Warning | 2
Information | 3


HMITransferChannel

HMITransferChannel

Die Enumeration HMITransferChannel gibt das Protokoll an, das zur Kommunikation mit einem HMI-Gerät verwendet wird:

Beschreibung | Wert
Invalid | -1
PN_IE | 0
Ethernet | 1


BackupType

BackupType

Die Enumeration BackupType gibt das Protokoll an, das zur Kommunikation mit einem HMI-Gerät verwendet wird:

Beschreibung | Wert
Invalid | 0
FullBackup | 1
Recipes | 2
UserAdministration | 3


TimeFormat

TimeFormat

TimeFormat gibt ein Zeitformat für Zeitstrings an:

Beschreibung | Wert
Local | 0
UTC | 1

UTC steht für Coordinated Universal Time.


Netzwerkbeispiel

Netzwerkbeispiel

Dieses Beispiel zeigt eine Netzwerkkonfiguration des TIA Portals und die API-Schnittstellen, die die vernetzten Geräte darstellen.

Hierbei gelten folgenden Annahmen: Alle Geräte in der obersten Zeile (PLC_1, IO device_1 und PLC_2) sind mit einem externen Ethernet-Netzwerk verbunden (nicht abgebildet). Die SIMATIC Automation Tool API kann direkt auf sie zugreifen. Ferner sei angenommen, dass das mit PLC_2 verbundene PROFINET-Subnetz nicht mit dem externen Netzwerk verbunden ist.

Die SIMATIC Automation Tool API kann für alle PLCs und Peripheriestationen in dieser Konfiguration Informationen und Operationen bereitstellen.

Das folgende Schaubild zeigt die gleiche Netzwerkkonfiguration und die Hardwaregeräte im Netzwerk:

Im Schaubild oben wird durch die Symbole in Form eines "Lollis" jeweils angegeben, welche Schnittstellenklasse der SIMATIC Automation Tool API die betreffende Netzwerkkomponente am besten repräsentiert.

  • Mit dem externen Netzwerk direkt verbundene CPUs werden durch die Schnittstelle ICPU dargestellt

  • Mit dem externen Netzwerk direkt verbundene Peripheriestationen werden durch die Schnittstelle IProfinetDevice repräsentiert

  • Die von einer CPU ausgehenden Subnetze werden durch die Schnittstelle IRemoteInterface repräsentiert.

  • Mit dem externen Netzwerk nicht direkt verbundene (aber über eine CPU erreichbare) Peripheriestationen werden durch die Schnittstelle IBaseDevice dargestellt.

  • Peripherie- oder Kommunikationsmodule, die mit einer CPU oder Peripheriestation verbunden sind, werden durch die Schnittstelle IModule repräsentiert.


Unterstützte Geräte im SIMATIC Automation Tool

Unterstützte Geräte im SIMATIC Automation Tool

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Unterstützte und nicht unterstützte Geräte und Firmware-Versionen
  • Unterstützung von fehlersicheren CPUs


Unterstützte und nicht unterstützte Geräte und Firmware-Versionen

Gerätekatalog Handhabung nicht unterstützter Geräte und nicht unterstützter Firmware-Versionen im SIMATIC Automation Tool
Start Zurück Weiter

Unterstützte und nicht unterstützte Geräte und Firmware-Versionen

Gerätekatalog

Sie können den Gerätekatalog über den Menübefehl "Hilfe > Gerätekatalog anzeigen" im SIMATIC Automation Tool anzeigen. Der Gerätekatalog zeigt die unterstützten Siemens-Geräte und die unterstützten Vorgänge des SIMATIC Automation Tool an.

Bei der Datei mit dem Gerätekatalog handelt es sich um eine Microsoft Excel-Datei. Sie benötigen die neueste Version 2010 von Microsoft Excel, um den Gerätekatalog ordnungsgemäß anzuzeigen und Funktionen wie z. B. Sortieren und Filtern zu verwenden. Die Gerätekatalogdatei ist schreibgeschützt. Sie können die Datei nicht ändern, um Funktionen für ein Gerät zu aktivieren.

Der Gerätekatalog hat Spalten, die einen WAHR-Zustand mit Häkchen in einer Zelle und einen FALSCH-Zustand mit einem Leerzeichen anzeigen. Wenn die Spalte "SAT Support" ein Häkchen für ein Gerät enthält, wird dieses Gerät vom SIMATIC Automation Tool unterstützt. Wenn die Zelle unter "SAT Support" leer ist, unterstützt das SIMATIC Automation Tool das Gerät nicht. Der Status der Zelle "SAT Support" überschreibt Häkchen bei anderen Einstellungen, die ansonsten Unterstützung für andere Funktionen, z. B. Fehlersicherheit, bedeuten.

Handhabung nicht unterstützter Geräte und nicht unterstützter Firmware-Versionen im SIMATIC Automation Tool

Wenn Sie ein nicht unterstütztes Gerät mit Ihrem Netzwerk verbinden, erkennt das SIMATIC Automation Tool zwei Möglichkeiten:

  • Das Gerät wird nicht unterstützt

  • Das Gerät wird unterstützt, aber die Firmware im Gerät wird nicht unterstützt

Nicht unterstützte Firmware

Das SIMATIC Automation Tool unterstützt das Siemens-Gerät, aber die Firmware-Version ist neuer als die vom SIMATIC Automation Tool neueste unterstützte Version. In diesem Fall führt das SIMATIC Automation Tool die folgenden Aktionen durch:

  • Das Gerät wird in einer Zeile der Gerätetabelle angezeigt

  • Es wird das Symbol eines unterstützten Geräts in der Zeile angezeigt

  • Die Tool-Vorgänge werden auf die Vorgänge begrenzt, die das SIMATIC Automation Tool für die frühere Firmware-Version unterstützt

Nicht unterstütztes Gerät

Das SIMATIC Automation Tool unterstützt das Gerät nicht. In diesem Fall führt das SIMATIC Automation Tool die folgenden Aktionen durch:

  • Das Gerät wird mit Teilinformationen in einer Zeile der Gerätetabelle angezeigt

  • Es wird das Fragezeichen-Symbol für nicht unterstützte Geräte in der Zeile angezeigt

  • Wenn das Gerät mit demselben Subnetz verbunden ist wie das Programmiergerät, auf dem das SIMATIC Automation Tool läuft, werden nur die folgenden DCP-Vorgänge unterstützt:

    • Gesamtes Netzwerk durchsuchen

    • Identifizieren

    • IP-Adresse aktualisieren

    • PROFINET-Name aktualisieren

    • Kommunikationsparameter zurücksetzen


Unterstützung von fehlersicheren CPUs

Unterstützung von fehlersicheren CPUs

In der folgenden Tabelle werden alle fehlersicheren CPUs und Firmware-Versionen angezeigt, die vom SIMATIC Automation Tool unterstützt werden:

Artikelnummer | Typbeschreibung | Firmwareversion | Unterstützung ab SIMATIC Automation Tool-Version
6ES7 212-1AF40-0XB0 | CPU 1212FC DC/DC/DC | V4.2 | V3.1
6ES7 212-1AF40-0XB0 | CPU 1212FC DC/DC/DC | V4.3 | V3.1 SP2
6ES7 212-1AF40-0XB0 | CPU 1212FC DC/DC/DC | V4.4 | V3.1 SP4
6ES7 212-1HF40-0XB0 | CPU 1212FC DC/DC/Rly | V4.2 | V3.1
6ES7 212-1HF40-0XB0 | CPU 1212FC DC/DC/Rly | V4.3 | V3.1 SP2
6ES7 212-1HF40-0XB0 | CPU 1212FC DC/DC/Rly | V4.4 | V3.1 SP4
6ES7 214-1AF40-0XB0 | CPU 1214FC DC/DC/DC | V4.1 | V3.1
6ES7 214-1AF40-0XB0 | CPU 1214FC DC/DC/DC | V4.2 | V3.1
6ES7 214-1AF40-0XB0 | CPU 1214FC DC/DC/DC | V4.3 | V3.1 SP2
6ES7 214-1AF40-0XB0 | CPU 1214FC DC/DC/DC | V4.4 | V3.1 SP4
6ES7 214-1HF40-0XB0 | CPU 1214FC DC/DC/Rly | V4.1 | V3.1
6ES7 214-1HF40-0XB0 | CPU 1214FC DC/DC/Rly | V4.2 | V3.1
6ES7 214-1HF40-0XB0 | CPU 1214FC DC/DC/Rly | V4.3 | V3.1 SP2
6ES7 214-1HF40-0XB0 | CPU 1214FC DC/DC/Rly | V4.4 | V3.1 SP4
6ES7 215-1AF40-0XB0 | CPU 1215FC DC/DC/DC | V4.1 | V3.1
6ES7 215-1AF40-0XB0 | CPU 1215FC DC/DC/DC | V4.2 | V3.1
6ES7 215-1AF40-0XB0 | CPU 1215FC DC/DC/DC | V4.3 | V3.1 SP2
6ES7 215-1AF40-0XB0 | CPU 1215FC DC/DC/DC | V4.4 | V3.1 SP4
6ES7 215-1HF40-0XB0 | CPU 1215FC DC/DC/Rly | V4.1 | V3.1
6ES7 215-1HF40-0XB0 | CPU 1215FC DC/DC/Rly | V4.2 | V3.1
6ES7 215-1HF40-0XB0 | CPU 1215FC DC/DC/Rly | V4.3 | V3.1 SP2
6ES7 215-1HF40-0XB0 | CPU 1215FC DC/DC/Rly | V4.4 | V3.1 SP4
6ES7 510-1SJ00-0AB0 | CPU 1510SP F-1 PN | V1.7 | V3.1
6ES7 510-1SJ00-0AB0 | CPU 1510SP F-1 PN | V1.8 | V3.1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V1.8 | V3.1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.0 | V3.1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.1 | V3.1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.5 | V3.1 SP1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.6 | V3.1 SP2
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.8 | V3.1 SP4
6ES7 511-1FK00-0AB0 | CPU 1511F-1 PN | V1.7 | V3.1
6ES7 511-1FK00-0AB0 | CPU 1511F-1 PN | V1.8 | V3.1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V1.8 | V3.1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.0 | V3.1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.1 | V3.1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.5 | V3.1 SP1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.6 | V3.1 SP2
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.8 | V3.1 SP4
6ES7 511-1FK02-0AB0 | CPU 1511F-1 PN | V2.5 | V3.1 SP1
6ES7 511-1FK02-0AB0 | CPU 1511F-1 PN | V2.6 | V3.1 SP2
6ES7 511-1FK02-0AB0 | CPU 1511F-1 PN | V2.8 | V3.1 SP4
6ES7 511-1UK01-0AB0 | CPU 1511TF-1 PN | V2.1 | V3.1
6ES7 511-1UK01-0AB0 | CPU 1511TF-1 PN | V2.5 | V3.1 SP1
6ES7 511-1UK01-0AB0 | CPU 1511TF-1 PN | V2.6 | V3.1 SP2
6ES7 511-1UK01-0AB0 | CPU 1511TF-1 PN | V2.8 | V3.1 SP4
6ES7 512-1SK00-0AB0 | CPU 1512SP F-1 PN | V1.7 | V3.1
6ES7 512-1SK00-0AB0 | CPU 1512SP F-1 PN | V1.8 | V3.1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V1.8 | V3.1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.0 | V3.1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.1 | V3.1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.5 | V3.1 SP1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.6 | V3.1 SP2
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.8 | V3.1 SP4
6ES7 513-1FL00-0AB0 | CPU 1513F-1 PN | V1.7 | V3.1
6ES7 513-1FL00-0AB0 | CPU 1513F-1 PN | V1.8 | V3.1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V1.8 | V3.1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.0 | V3.1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.1 | V3.1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.5 | V3.1 SP1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.6 | V3.1 SP2
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.8 | V3.1 SP4
6ES7 513-1FL02-0AB0 | CPU 1513F-1 PN | V2.5 | V3.1 SP1
6ES7 513-1FL02-0AB0 | CPU 1513F-1 PN | V2.6 | V3.1 SP2
6ES7 513-1FL02-0AB0 | CPU 1513F-1 PN | V2.8 | V3.1 SP4
6ES7 513-2GL00-0AB0 | CPU 1513pro F-2 PN | V2.8 | V3.1 SP4
6ES7 515-2FM00-0AB0 | CPU 1515F-2 PN | V1.6 | V3.1
6ES7 515-2FM00-0AB0 | CPU 1515F-2 PN | V1.7 | V3.1
6ES7 515-2FM00-0AB0 | CPU 1515F-2 PN | V1.8 | V3.1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V1.8 | V3.1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.0 | V3.1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.1 | V3.1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.5 | V3.1 SP1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.6 | V3.1 SP2
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.8 | V3.1 SP4
6ES7 515-2FM02-0AB0 | CPU 1515F-2 PN | V2.8 | V3.1 SP4
6ES7 515-2UM01-0AB0 | CPU 1515TF-2 PN | V2.1 | V3.1
6ES7 515-2UM01-0AB0 | CPU 1515TF-2 PN | V2.5 | V3.1 SP1
6ES7 515-2UM01-0AB0 | CPU 1515TF-2 PN | V2.6 | V3.1 SP2
6ES7 515-2UM01-0AB0 | CPU 1515TF-2 PN | V2.8 | V3.1 SP4
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.0 | V3.1
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.1 | V3.1
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.5 | V3.1 SP1
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.6 | V3.1 SP2
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.8 | V3.1 SP4
6ES7 516-3FN00-0AB0 | CPU 1516F-3 PN/DP | V1.5 | V3.1
6ES7 516-3FN00-0AB0 | CPU 1516F-3 PN/DP | V1.6 | V3.1
6ES7 516-3FN00-0AB0 | CPU 1516F-3 PN/DP | V1.7 | V3.1
6ES7 516-3FN00-0AB0 | CPU 1516F-3 PN/DP | V1.8 | V3.1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V1.8 | V3.1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.0 | V3.1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.1 | V3.1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.5 | V3.1 SP1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.6 | V3.1 SP2
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.8 | V3.1 SP4
6ES7 516-3FN02-0AB0 | CPU 1516F-3 PN/DP | V2.8 | V3.1 SP4
6ES7 516-3UN00-0AB0 | CPU 1516TF-3 PN/DP | V2.5 | V3.1 SP1
6ES7 516-3UN00-0AB0 | CPU 1516TF-3 PN/DP | V2.6 | V3.1 SP2
6ES7 516-3UN00-0AB0 | CPU 1516TF-3 PN/DP | V2.8 | V3.1 SP4
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V1.6 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V1.7 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V1.8 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.0 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.1 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.5 | V3.1 SP1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.6 | V3.1 SP2
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.8 | V3.1 SP4
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.0 | V3.1
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.1 | V3.1
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.5 | V3.1 SP1
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.6 | V3.1 SP2
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.8 | V3.1 SP4
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V1.5 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V1.6 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V1.7 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V1.8 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.0 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.1 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.5 | V3.1 SP1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.6 | V3.1 SP2
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.8 | V3.1 SP4
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.0 | V3.1 SP1
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.1 | V3.1 SP1
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.5 | V3.1 SP1
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.6 | V3.1 SP2
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.8 | V3.1 SP4
6ES7 518-4FX00-1AB0 | CPU 1518F-4 PN/DP MFP | V2.5 | V3.1 SP1
6ES7 518-4FX00-1AB0 | CPU 1518F-4 PN/DP MFP | V2.6 | V3.1 SP2
6ES7 518-4FX00-1AB0 | CPU 1518F-4 PN/DP MFP | V2.8 | V3.1 SP4
6ES7 672-5SC01-0YA0 | CPU 1505SP F | V2.0 | V3.1 SP2
6ES7 672-5SC01-0YA0 | CPU 1505SP F | V2.1 | V3.1 SP2
6ES7 672-5SC11-0YA0 | CPU 1505SP F | V2.5 | V3.1 SP2
6ES7 672-5SC11-0YA0 | CPU 1505SP F | V2.6 | V3.1 SP2
6ES7 672-5SC11-0YA0 | CPU 1505SP F | V2.7 | V3.1 SP4
6ES7 672-5WC11-0YA0 | CPU 1505SP TF | V2.5 | V3.1 SP2
6ES7 672-5WC11-0YA0 | CPU 1505SP TF | V2.6 | V3.1 SP2
6ES7 672-5WC11-0YA0 | CPU 1505SP TF | V2.7 | V3.1 SP4
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.0 | V3.1 SP2
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.1 | V3.1 SP2
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.5 | V3.1 SP2
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.6 | V3.1 SP2
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.7 | V3.1 SP4
6ES7 672-8FC01-0YA0 | CPU 1508S F | V2.6 | V3.1 SP2
6ES7 672-8FC01-0YA0 | CPU 1508S F | V2.7 | V3.1 SP4


Fehlerbehebung bei Meldungen des Ereignisprotokolls

Gerätespezifische Meldungen Meldungen im Zusammenhang mit dem Export von PC-Daten
Start Zurück Weiter

Fehlerbehebung bei Meldungen des Ereignisprotokolls

Die folgende Tabelle enthält zusätzliche Informationen zu Meldungen des Ereignisprotokolls. Wenn Sie weitere Informationen zu einer Meldung brauchen, kopieren Sie die Meldung aus dem Ereignisprotokoll und durchsuchen die Online-Hilfe nach dem Meldetext.

Meldung des Ereignisprotokolls

Wahrscheinliche Ursache und Abhilfe

Das eingegebene CPU-Passwort ist nicht gültig, um diesen Vorgang durchzuführen.

Sie haben ein ungültiges CPU-Passwort für den Vorgang eingegeben. Geben Sie ein gültiges Passwort ein.

Die CPU konnte nicht in den Betriebszustand RUN versetzt werden.

Mögliche Gründe: Das in die CPU geladene TIA Portal-Projekt ist für diesen CPU-Typ möglicherweise nicht gültig oder es wurde kein Programm in die CPU geladen.

Im Diagnosepuffer finden Sie weitere Details.

Die CPU konnte nicht in den Betriebszustand RUN gehen. Die CPU hat möglicherweise kein gültiges Anwenderprogramm. Im Diagnosepuffer finden Sie weitere Details.

Das Gerät nimmt die neue Konfiguration nicht an.

Das Gerät hat einen DCP-Befehl zum Einstellen der IP-Adresse oder des PROFINET-Namens zurückgewiesen. Prüfen Sie die Kommunikationsverbindungen im Netzwerk. Prüfen Sie Ihre Eingaben für die IP-Adresse bzw. den PROFINET-Namen.

Es konnte keine Verbindung zum Gerät hergestellt werden. Prüfen Sie, ob die MAC-Adresse korrekt ist.

Das SIMATIC Automation Tool konnte im Netzwerk kein Gerät mit dieser MAC-Adresse identifizieren. Prüfen Sie die von Ihnen eingegebene MAC-Adresse und die MAC-Adresse des Geräts.

Die Verbindung zum Gerät ging vorzeitig verloren.

Das SIMATIC Automation Tool ist nicht mehr mit dem Gerät verbunden. Prüfen Sie die Kommunikationsverbindungen im Netzwerk.

Der Vorgang ist fehlgeschlagen und hat folgenden Fehler ausgegeben: ID#

Interner Fehler im SIMATIC Automation Tool. Wenden Sie sich an Ihren Siemens-Vertreter.

Verbindung konnte nicht getrennt werden.

Das SIMATIC Automation Tool war nicht in der Lage, die Verbindung mit dem Gerät zu trennen. Wiederholen Sie den Vorgang.

Die angegebene Firmware-Aktualisierungsdatei ist mit dem Gerät nicht kompatibel

Die ausgewählte Firmware-Aktualisierungsdatei ist nicht mit diesem Gerät kompatibel. Wählen Sie eine Firmware-Aktualisierung auf die Version, die dem jeweiligen Gerät entspricht.

Die angegebene Firmware-Aktualisierungsdatei ist mit dem Gerät nicht kompatibel, weil die Hardware einen unterschiedlichen Firmware-Versionstyp erfordert.

Aufgrund der Geräte-Hardware ist es erforderlich, dass die Firmware-Aktualisierungsdatei sich von der vorhandenen Dateiversion unterscheidet. Wählen Sie für die Firmware-Aktualisierung eine Version, die sich von der bestehenden Firmware-Version unterscheidet.

Die angegebene Firmware-Aktualisierungsdatei ist mit dem Gerät nicht kompatibel, weil die Hardware eine identische Firmware-Version erfordert.

Aufgrund der Geräte-Hardware ist es erforderlich, dass die Firmware-Aktualisierungsdatei mit der vorhandenen Dateiversion identisch ist. Wählen Sie für die Firmware-Aktualisierung eine identische Version.

Die angegebene Firmware-Aktualisierungsdatei ist mit dem Gerät nicht kompatibel, weil die Hardware eine neuere Firmware-Version erfordert.

Aufgrund der Geräte-Hardware ist es erforderlich, dass die Firmware-Aktualisierungsdatei eine neuere Version aufweist als die Version im Gerät. Wählen Sie für die Firmware-Aktualisierung eine neuere Version.

Die angegebene Firmware-Aktualisierungsdatei ist mit dem Gerät nicht kompatibel, weil die Hardware eine ältere Firmware-Version erfordert.

Aufgrund der Geräte-Hardware ist es erforderlich, dass die Firmware-Aktualisierungsdatei eine ältere Version aufweist als die Version im Gerät. Wählen Sie eine ältere Version für die Firmware-Aktualisierung.

Die Modul-ID ist nicht gültig.

Die API-Methode FirmwareUpdate hat für den Parameter hardwareID einen Wert empfangen, der nicht dem Modul entspricht. Geben Sie beim Aufrufen der Methode FirmwareUpdate die richtige ID für das Modul an.

Die Firmware-Aktualisierung wurde vom Modul nicht akzeptiert.

Wählen Sie eine Firmware-Aktualisierungsdatei, die kompatibel mit dem zu aktualisierenden Modul ist.

Das Modul ist nicht erreichbar. Laden Sie eine gültige Hardwarekonfiguration in die CPU oder schließen Sie das Gerät direkt an.

Das SIMATIC Automation Tool kann nicht mit dem Gerät kommunizieren. Laden Sie eine gültige Gerätekonfiguration aus dem TIA Portal in das Gerät. Verwenden Sie alternativ das SIMATIC Automation Tool zum Aktualisieren des CPU-Programms.

Die Firmware-Aktualisierung des Moduls wird von diesem Werkzeug nicht unterstützt.

Das SIMATIC Automation Tool unterstützt keine Firmware-Aktualisierung bei dieser Art von Modul. Die Firmware dieses Moduls kann mit dem SIMATIC Automation Tool nicht aktualisiert werden.

Die Firmware-Aktualisierungsdatei hat die gleiche Firmware-Version wie das Gerät.

Die Firmware-Aktualisierungsdatei hat die gleiche Firmware-Version wie das Gerät. Keine Firmware-Aktualisierung durchgeführt und keine weitere Aktion erforderlich.

Das Formatieren der Memory Card wird auf diesem Gerät nicht unterstützt.

Sie können die Memory Card für dieses Gerät nicht formatieren.

Die Gateway-Adresse ist nicht gültig.

Die Gateway-Adresse ist nicht mit der Subnetzmaske und der IP-Adresse gültig. Vergewissern Sie sich, dass IP-Adresse, Subnetzmaske und Gateway für Ihr Gerät und Netzwerk korrekt sind.

Interner Fehler aufgetreten.

Interner Fehler im SIMATIC Automation Tool. Wenden Sie sich an Ihren Siemens-Vertreter.

Adresse des Zielservers ist ungültig.

Das SIMATIC Automation Tool konnte keine Verbindung zur CPU oder zum HMI-Gerät herstellen. Prüfen Sie MAC-Adresse und IP-Adresse des Geräts.

Das Projekt kann mit dieser Version des SIMATIC Automation Tool nicht geöffnet werden.

Das SIMATIC Automation Tool kann Version V1.x-Projekte oder Projekte aus einem späteren Freigabestand nicht öffnen. Siehe Thema "Speichern und Öffnen von SAT-Projektdateien".

Ungültige Signatur erkannt. Reparieren Sie die Installation.

Die Installation des SIMATIC Automation Tool ist unvollständig oder beschädigt. Installieren Sie das SIMATIC Automation Tool neu.

Die IP-Adresse ist nicht gültig.

Die IP-Adresse entspricht nicht den Anforderungen für IP-Adressen. Geben Sie eine gültige IP-Adresse ein.

Die MAC-Adresse ist nicht gültig.

Die MAC-Adresse entspricht nicht den Anforderungen für MAC-Adressen. Geben Sie eine gültige MAC-Adresse ein.

Dieser Vorgang ist nicht zulässig, weil ein anderes Konfigurationswerkzeug wie z. B. das TIA Portal verbunden ist.

Es kann sich jeweils nur ein Software-Tool mit einem Gerät verbinden. Schließen Sie die andere Verbindung zu dem Gerät, zum Beispiel, indem Sie das TIA Portal offline aufrufen. Wiederholen Sie anschließend den Vorgang aus dem SIMATIC Automation Tool.

Eine bereits aktive ES-Instanz unterstützt MultiES nicht.

Dieses Gerät unterstützt jeweils nicht mehr als eine Online-Verbindung aus dem SIMATIC Automation Tool, dem TIA Portal oder einem anderen Tool. Rufen Sie das TIA Portal oder das andere Tool offline auf und wiederholen Sie anschließend den Vorgang aus dem SIMATIC Automation Tool.

Die maximale Anzahl von CPU-Verbindungen wurde überschritten.

Dieses Gerät unterstützt eine begrenzte Anzahl von Online-Verbindungen aus dem SIMATIC Automation Tool, dem TIA Portal oder einem anderen Tool. Der Grenzwert wurde überschritten. Rufen Sie das TIA Portal oder das andere Tool offline auf und wiederholen Sie anschließend den Vorgang aus dem SIMATIC Automation Tool.

Verbindungen von mehreren Tools mit dieser CPU werden nicht unterstützt.

Dieses Gerät unterstützt eine begrenzte Anzahl von Online-Verbindungen aus dem SIMATIC Automation Tool, dem TIA Portal oder einem anderen Tool. Von mehreren Tools ausgehende Verbindungen werden nicht unterstützt. Rufen Sie das TIA Portal oder das andere Tool offline auf und wiederholen Sie anschließend den Vorgang aus dem SIMATIC Automation Tool.

Der Client möchte einen Schreibvorgang auf der Objektvariable oder dem Link ausführen, doch eine Änderung ist im Betriebszustand RUN der CPU nicht möglich.

Die CPU kann diesen Vorgang nicht im Betriebszustand RUN ausführen. Versetzen Sie die CPU in den Betriebszustand STOP.

Der Vorgang wurde erfolgreich abgeschlossen.

Nur zur Information

Der Vorgang wurde vom Benutzer abgebrochen.

Nur zur Information

Das Gerät unterstützt den gewünschten Vorgang nicht.

Entnehmen Sie dem Gerätekatalog, welche Vorgänge das Gerät für die aktuelle Firmware-Version unterstützt.

Parameter ist außerhalb des Bereichs.

Eine Anwendung hat die API-Methode SetOperatingState mit einem ungültigen Wert aufgerufen. Diese Methode muss mit dem Betriebszustand "Stop" oder "RUN" aufgerufen werden.

Der PROFINET-Name ist nicht gültig.

Der PROFINET-Name ist nicht gültig. Geben Sie einen gültigen und in Bezug auf alle anderen Geräte eindeutigen PROFINET-Namen ein.

Es konnte keine Verbindung zum Gerät hergestellt werden.

Das SIMATIC Automation Tool konnte keine Verbindung zum Gerät herstellen. Prüfen Sie Ihre Netzwerkverbindungen. Vergewissern Sie sich, dass kein anderes Software-Tool, zum Beispiel das TIA Portal, eine Online-Verbindung zum Gerät hat. Sollte eine solche Online-Verbindung bestehen, gehen Sie mit dem anderen Tool offline. Vergewissern Sie sich, dass das Gerät zu dem von Ihnen angegebenen Subnetz gehört. Prüfen Sie gegebenenfalls Ihr Routing. Stellen Sie Ihre Netzwerkschnittstellenkarte auf die Auswahl "Auto" ein, falls noch nicht geschehen.

Die Zeit für den Vorgang ist abgelaufen.

Die CPU hat den Vorgang nicht abgeschlossen. Wiederholen Sie den Vorgang. Wenn bei der Ausführung des Vorgangs weiterhin die Zeitbegrenzung überschritten wird, prüfen Sie Ihr Gerät und Ihre Netzwerkkommunikation.

Verbindung wurde nicht legitimiert, weil die Zeit für das Passwort abgelaufen ist.

Das Passwort für die CPU ist aufgrund von Inaktivität abgelaufen. Geben Sie das Passwort für die CPU ein und wiederholen Sie den Vorgang.

IP-Adresse konnte nicht eingestellt werden

Das SIMATIC Automation Tool konnte die IP-Adresse nicht einstellen. Prüfen Sie, ob die IP-Adresse gültig und eindeutig ist. Prüfen Sie, ob die Gerätekonfiguration im STEP 7-Projekt das Einstellen der IP-Adresse direkt am Gerät erlaubt.

PROFINET-Name konnte nicht eingestellt werden

Das SIMATIC Automation Tool konnte den PROFINET-Namen nicht einstellen. Prüfen Sie, ob der PROFINET-Name gültig und eindeutig ist. Prüfen Sie, ob die Gerätekonfiguration im STEP 7-Projekt das Einstellen der IP-Adresse direkt am Gerät erlaubt.

Die Subnetzmaske ist nicht gültig.

Die Subnetzmaske entspricht nicht den Anforderungen für eine gültige Subnetzmaske. Geben Sie eine gültige Subnetzmaske ein.

Das Gerät wird nicht unterstützt oder konnte nicht initialisiert werden.

Das SIMATIC Automation Tool unterstützt dieses Gerät nicht oder konnte es nicht initialisieren. Entnehmen Sie dem Gerätekatalog, welche Geräte und Versionen unterstützt werden.

Das Gerät hat die Firmwareaktualisierungsdatei nicht akzeptiert.

Das Gerät hat die Firmware-Aktualisierung zurückgewiesen. Vergewissern Sie sich, dass die Firmware-Aktualisierungsdatei für Ihr Gerät gültig ist. Achten Sie bei der Aktualisierung von einem alten Format darauf, im Feld "Neue Firmware-Version" die UPD-Headerdatei auszuwählen. Prüfen Sie außerdem, ob das Gerät ordnungsgemäß funktioniert.

Inhalte des Ordners konnten nicht komprimiert werden

Das SIMATIC Automation Tool konnte den Inhalt des Ordners nicht komprimieren. Prüfen Sie, ob das Dateisystem genug Speicherkapazität für die ZIP-Datei hat. Prüfen Sie auch die Dateiordnerberechtigungen. Beides kann die Ursache des Problems sein.

Fehler beim Schreiben in Datei

Das SIMATIC Automation Tool konnte die Datei nicht auf dem Programmiergerät speichern. Prüfen Sie Speicherkapazität und Dateiberechtigungen auf Ihrem Programmiergerät.

Fehler beim Erstellen der Datei

Das SIMATIC Automation Tool konnte die Datei nicht auf dem Programmiergerät erzeugen. Prüfen Sie Speicherkapazität und Dateiberechtigungen auf Ihrem Programmiergerät.

Fehler beim Löschen der Datei

Das SIMATIC Automation Tool konnte die Datei nicht vom Programmiergerät löschen. Prüfen Sie die Dateiberechtigungen auf Ihrem Programmiergerät.

Fehler beim Löschen des Ordners

Das SIMATIC Automation Tool konnte den Ordner nicht vom Programmiergerät löschen. Prüfen Sie die Ordnerberechtigungen auf Ihrem Programmiergerät. Achten Sie darauf, dass der Ordner nicht geöffnet ist.

Fehler beim Erstellen des Ordners

Das SIMATIC Automation Tool konnte keinen temporären Ordner für Servicedaten anlegen. Prüfen Sie die Speicherkapazität auf Ihrem Programmiergerät.

Um die API verwenden zu können, müssen Sie eine Lizenz erwerben.

Sie haben keine gültige Lizenz für die Verwendung der API. Sie können die kostenlose 21-Tage-Testlizenz 21 Tage lang nutzen. Andernfalls erwerben Sie eine Lizenz für das SIMATIC Automation Tool (SAT) oder das Software Developers Kit (SDK), wenn Sie die API verwenden möchten.

Ungültiger Wert der Zeitbegrenzung. Gültige Werte sind 180 bis 999 Sekunden.

In den Kommunikationsoptionen liegt der Zeitbegrenzungswert für Kommunikationsvorgänge außerhalb des gültigen Bereichs. Stellen Sie den Wert auf 180 bis 999 Sekunden ein.

Keine Daten im Gerät zum Sichern

Das SIMATIC Automation Tool kann keine Sicherung erzeugen, wenn das Gerät kein Anwenderprogramm hat. Laden Sie Ihr Projekt aus STEP 7 in das Gerät oder aktualisieren Sie das Programm aus dem SIMATIC Automation Tool. Wenn Ihnen für dieses Gerät eine Sicherungsdatei zur Verfügung steht, können Sie das Programm aus dem SIMATIC Automation Tool wiederherstellen.

Fehler beim Lesen aus Stream

Das SIMATIC Automation Tool konnte eine zuvor gespeicherte Projektdatei nicht lesen. Vergewissern Sie sich, dass die Projektdatei aus einer kompatiblen Version des SIMATIC Automation Tool stammt. Öffnen Sie ein gültiges Projekt, wenn eines verfügbar ist.

Fehler beim Schreiben in Stream

Das SIMATIC Automation Tool konnte eine Projektdatei für das aktuelle Projekt nicht speichern. Prüfen Sie die Speicherkapazität auf Ihrem Programmiergerät.

Die HMI-Projektdatei ist ungültig oder unvollständig.

Sie versuchen, das HMI-Programm zu aktualisieren. Die Programmaktualisierungsdatei ist beschädigt. Sie können diese Datei nicht wiederherstellen.

Das HMI-Projekt ist nicht mit dem Gerät kompatibel.

Sie versuchen, eine nicht mit dem HMI-Gerät kompatible Programmaktualisierung durchzuführen. Sie können nur eine der Hardware Ihres HMI-Geräts entsprechende Programmaktualisierung durchführen.

Ein Dateivorgang konnte wegen Schreibschutz nicht durchgeführt werden.

Der Speicherort für den Dateivorgang ist schreibgeschützt. Wählen Sie einen nicht schreibgeschützten Speicherort auf Ihrem Programmiergerät.

IP-Adresse dieses Geräts konnte nicht geändert werden

Das SIMATIC Automation Tool konnte die IP-Adresse nicht einstellen. Geben Sie eine gültige IP-Adresse ein. Prüfen Sie die Verbindungen Ihrer Netzwerkkommunikation.

PROFINET-Name dieses Geräts konnte nicht geändert werden

Das SIMATIC Automation Tool konnte den PROFINET-Namen nicht einstellen. Geben Sie einen gültigen PROFINET-Namen ein. Prüfen Sie die Verbindungen Ihrer Netzwerkkommunikation.

Anforderung abgebrochen

Nur zur Information

Das Gerät unterstützt noch keine Geräte-Add-on-Übertragung.

Die Programmaktualisierungsdatei enthält Add-ons. Das HMI-Gerät, das Sie aktualisieren möchten, unterstützt keine Add-ons. Sie können dieses HMI-Gerät nur mit einem Programm ohne Add-ons aktualisieren.

Attribut nicht gefunden

Ein HMI-Vorgang versucht, an einem nicht vorhandenen Speicherort zu lesen oder zu schreiben. Vergewissern Sie sich, dass die Programmaktualisierungsdatei bzw. Sicherungsdatei für die HMI gültig ist.

Puffer zu klein für alle angeforderten Daten

Das HMI-Gerät hat gemeldet, dass ein interner Puffer zu klein war. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

HMI-Zertifikat ist abgelaufen.

Das HMI-Zertifikat ist nicht mehr gültig. Aktualisieren Sie das Zertifikat im HMI-Gerät.

Allgemeiner Fehler beim Prüfen der Zertifikatsignatur

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Dateizertifikat ist ungültig.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Zertifikat ist noch nicht gültig

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Zertifikat wurde widerrufen.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Hergestellte Clientverbindung für Aktion erforderlich

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Der Vorgang zum Lesen der Datei ist fehlgeschlagen.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Der Vorgang zum Schreiben der Datei ist fehlgeschlagen.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Firmware des Typs nicht installiert

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Firmware des Typs nicht unterstützt

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Die Firmwaredatei ist für dieses Gerät nicht gültig.

Sie haben eine nicht für das Gerät gültige Firmware-Aktualisierungsdatei ausgewählt. Wählen Sie eine Firmware-Aktualisierungsdatei aus, die Ihrem Gerät und Ihrer Version entspricht.

Dieses Add-on ist mit diesem Gerät/dieser Firmware nicht kompatibel

Die Programmaktualisierungsdatei enthält Add-ons. Das Add-on in der Projektaktualisierungsdatei ist nicht kompatibel mit dem HMI-Gerät, das Sie aktualisieren möchten. Sie können nur ein Programm aktualisieren, das entweder keine Add-ons oder kompatible Add-ons hat.

Ungültige Argumente an Methode übergeben

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ungültiger Dateipfad

Der Dateipfad ist nicht vorhanden oder ungültig. Geben Sie einen gültigen Dateipfad an.

Lizenzsteuerung fehlgeschlagen.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein logisches Volume fehlt.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein logisches Volume hat nicht genügend Speicherkapazität.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Objekt nicht gefunden

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Nicht genügend Ressourcen, um den geforderten Vorgang auszuführen

Der gewünschte Vorgang erfordert mehr Systemressourcen als verfügbar sind. Schließen Sie einige Anwendungen auf Ihrem Programmiergerät und versuchen Sie es erneut.

Nicht genügend Speicherkapazität im Dateisystem

Das Dateisystem hat nicht genug Speicherkapazität für den gewünschten Vorgang. Löschen Sie Dateien, um Speicherkapazität im Dateisystem freizumachen, oder wählen Sie ein anderes Dateisystem mit mehr Speicherkapazität.

Remote-Übertragung deaktiviert

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Rettungssicherung nicht möglich, z. B. wegen falschen Gerätezustands oder falscher Firmwaredatei

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Rettungswiederherstellung nicht möglich, z. B. wegen falschen Gerätezustands

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Runtime-Installation ist defekt.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Runtime ist nicht installiert.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Allgemeines Problem mit Handhabung der Sicherheitsbibliothek

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein anderer Dienst ist bereits aktiv.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Allgemeiner Fehler beim Prüfen der Zertifikatsignatur

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Dateisignatur ist ungültig.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Datei ist nicht signiert.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein Vorgang zum Lesen des Speichers ist fehlgeschlagen.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein Vorgang zum Schreiben des Speichers ist fehlgeschlagen.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Typkonvertierung fehlgeschlagen

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein unerwarteter Betriebssystemfehler ist aufgetreten.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein Add-on mit dem angegebenen Namen ist nicht installiert.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Eine Anwendung mit der angegebenen ID ist nicht installiert.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein Anwendungs-Add-on mit der angegebenen ID ist nicht installiert.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein Anwendungs-Add-on verweist auf eine Anwendung, die nicht installiert ist.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Der Rezeptdateiname ist nicht gültig.

Prüfen Sie den Dateinamen. Geben Sie einen gültigen Dateinamen an.

Nicht genügend Speicherkapazität zum Durchführen dieses Vorgangs

Die SIMATIC SD Memory Card in der CPU hat nicht genug Kapazität zum Speichern der Datei. Löschen Sie nicht benötigte Inhalte von der Memory Card oder verwenden Sie eine Memory Card mit höherer Kapazität.

Auf dem Zielgerät ist ein neueres inkompatibles Firmware-Image vorhanden. Wenn Sie das Betriebssystem aktualisieren, werden Rezeptdaten, Benutzerdaten und einige Systemeinstellungen möglicherweise dauerhaft gelöscht.

Die Firmware auf dem Gerät ist neuer als die von Ihnen ausgewählte Firmware-Aktualisierung. Wenn Sie mit dieser Firmware-Aktualisierung fortfahren, werden möglicherweise Rezeptdaten, Benutzerdaten und einige Systemeinstellungen gelöscht. Vergewissern Sie sich, dass Sie auf diese Firmware aktualisieren möchten, bevor Sie fortfahren.

Auf dem Zielgerät ist ein älteres inkompatibles Firmware-Image vorhanden. Wenn Sie das Betriebssystem aktualisieren, könnten Rezeptdaten, Benutzerdaten und einige Systemeinstellungen dauerhaft gelöscht werden.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Auf dem Zielgerät ist eine neuere inkompatible Runtime vorhanden.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Auf dem Zielgerät ist eine ältere inkompatible Runtime vorhanden.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Auf dem Zielgerät ist keine Runtime installiert.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Nicht genügend Speicher auf dem Zielgerät.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Falsche Display-Ausrichtung (Hochformat konfiguriert, Querformat auf dem HMI-Gerät eingestellt).

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Falsche Display-Ausrichtung (Querformat konfiguriert, Hochformat auf dem HMI-Gerät eingestellt).

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Allgemeiner Fehler. Übersetzen Sie das Projekt erneut und wiederholen Sie das Laden in die CPU.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Allgemeiner Fehler. Wiederholen Sie das Laden in die CPU.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Auf dem Zielgerät ist keine Runtime installiert.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Das konfigurierte Gerät entspricht nicht dem Zielgerät.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Auf dem Zielgerät ist eine nicht kompatible Runtime installiert.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Es ist eine falsche Runtime-Version installiert. Die installierte Runtime kann das Projekt nicht verarbeiten. Installieren Sie die Runtime manuell auf dem Zielgerät.

Interner Fehler im HMI-Gerät. Wenden Sie sich an den Customer Support für Ihr HMI-Gerät.

Ein Fehler ist aufgetreten und die Geräteidentität konnte nicht ermittelt werden.

Das SIMATIC Automation Tool konnte die Identität dieser CPU nicht ermitteln.

Die Geräteidentität wurde geändert, bitte durchsuchen Sie das gesamte Netzwerk erneut.

Die Identität des CPU-Geräts ist nicht mehr dieselbe wie zu dem Zeitpunkt, als das SIMATIC Automation Tool die Verbindung mit der CPU hergestellt hat. Durchsuchen Sie das Netzwerk erneut, um für das SIMATIC Automation Tool die tatsächliche Geräteidentität zu ermitteln.

Die verbundene Schnittstelle wurde nicht gefunden.

Die ausgewählte Netzwerkschnittstelle ist nicht mehr vorhanden. Überprüfen Sie die Verbindungen Ihrer Netzwerkschnittstelle sowie die Funktion der Schnittstelle. Wenn Sie festgestellt haben, dass die Netzwerkschnittstelle gültig ist, wählen Sie diese Netzwerkschnittstelle über das SIMATIC Automation Tool aus.

Gerät ist nicht ausgewählt.

Es ist kein Gerät ausgewählt. Sie müssen ein Gerät aus der Gerätetabelle auswählen.

Für sicherheitsrelevante Vorgänge ist das Safety-Passwort erforderlich.

Sie müssen das Safety-Passwort für die F-CPU angeben, um den sicherheitsrelevanten Vorgang fortsetzen zu können.

Interner Anwendungsfehler

Beim Festlegen eines Passworts ist ein interner Fehler aufgetreten. Legen Sie ein gültiges Passwort fest und prüfen Sie, ob das Gerät geschützt ist.

Das eingegebene CPU-Passwort ist ungültig.

Geben Sie ein gültiges CPU-Passwort ein.

Die IP-Adresse des Geräts ist ein Duplikat im Netzwerk.

Das SIMATIC Automation Tool hat im Netzwerk eine doppelte IP-Adresse gefunden, die eventuell von einer externen Änderung stammt. Sortieren Sie die Gerätetabelle nach der IP-Adresse, um das Duplikat zu finden. Korrigieren Sie eine der Adressen, um das Duplikat zu beseitigen.

Die eingegebene IP-Adresse ist im Netzwerk doppelt vergeben.

Sie haben eine IP-Adresse eingegeben, die ein Duplikat einer anderen IP-Adresse ist. Geben Sie eine im Netzwerk eindeutige IP-Adresse ein. Sortieren Sie die Gerätetabelle nach der IP-Adresse, um das Duplikat zu finden.

Doppelter PROFINET-Name

Geben Sie einen im Netzwerk eindeutigen PROFINET-Namen ein.

Sicherheitsrelevante Vorgänge müssen bestätigt werden.

Zum Ausführen der folgenden Vorgänge für eine F-CPU müssen Sie den jeweiligen Vorgang bestätigen:

- Auf Werkseinstellungen zurücksetzen
- Wiederherstellen
- Programm aktualisieren
- Memory Card formatieren

Wenn Sie diese Meldung von einer Anwendung erhalten haben, die die API verwendet, müssen Sie die Eigenschaft SelectedConfirmed für die CPU festlegen.

Es ist keine SD-Karte vorhanden oder die SD-Karte ist bereits leer.

Voraussetzung für das Formatieren einer Memory Card ist, dass eine SIMATIC SD Memory Card vorhanden ist. Stecken Sie eine SIMATIC SD Memory Card in die CPU, falls keine vorhanden ist. Wenn die Karte vorhanden ist, jedoch keine Dateiinhalte aufweist, können Sie diese Meldung ignorieren.

Die Programmdatei ist ungültig oder kann von dieser Version des SIMATIC Automation Tool nicht geöffnet werden.

Das SIMATIC Automation Tool kann über den im Dialog "Optionen" angegebenen Pfad nicht auf die Programmaktualisierungsdatei zugreifen. Prüfen Sie den Pfadnamen im Dialog "Optionen" in den Einstellungen zur Programmaktualisierung.

Ergebnis des CRC-Vergleichs online und offline: Kollektive F-Signaturen stimmen nicht überein.

Die Programmaktualisierung ist fehlschlagen. Die Programmaktualisierungsdatei stimmt nach dem Programmaktualisierungsvorgang nicht mit dem Programm in der CPU überein. Probieren Sie folgende Schritte zur Fehlerbehebung:

  1. Setzen Sie die CPU auf die Werkseinstellungen zurück.

  2. Formatieren Sie die Memory Card, falls Sie eine verwenden.

  3. Versuchen Sie erneut, das Programm zu aktualisieren.

Wenn der Fehler weiterhin besteht, können Sie diese Programmaktualisierungsdatei nicht verwenden.

Die Programmdatei kann nicht in ein älteres Gerät geladen werden.

Die Geräteversion des Zielgeräts ist älter als die Version in der Programmdatei. Aktualisieren Sie das Gerät auf eine neuere Version oder wählen Sie eine Programmaktualisierungsdatei, die mit dem älteren Gerät kompatibel ist.

IP-Suite der Projekte ist nicht erreichbar

Prüfen Sie IP-Adresse, Subnetzmaske und Gateway. Berichtigen Sie alle Werte, die für Ihr Netzwerk nicht korrekt sind.

IP-Suite ist nicht erreichbar

Prüfen Sie IP-Adresse, Subnetzmaske und Gateway. Berichtigen Sie alle Werte, die für Ihr Netzwerk nicht korrekt sind.

Die Sicherungsdatei enthielt eine IP-Suite, die über PROFINET-Kommunikation nicht erreichbar ist.

Nach dem Restore-Vorgang kann das SIMATIC Automation Tool nicht auf das Gerät zugreifen. Die IP-Suite in dem wiederhergestellten Projekt (IP-Adresse, Subnetzmaske, Gateway) entspricht nicht dem tatsächlichen Gerät und Subnetz. Berichtigen Sie die Werte der IP-Suite für das Gerät. Stellen Sie die Netzwerkschnittstellenkarte auf die Auswahl "Auto" ein, falls noch nicht geschehen.

Die IP-Adresse in der neuen Programmdatei ist im Netzwerk nicht eindeutig.

Lösen Sie den Konflikt der IP-Adressen. Stellen Sie eines der Geräte auf eine andere IP-Adresse ein.

Ein Sicherheitsprogramm kann nicht in eine Standard-CPU geladen werden.

Ein Sicherheitsprogramm kann nicht in eine Standard-CPU geladen werden. In eine Standard-CPU können Sie nur ein Standardprogramm laden.

Die Diversitätsprüfung für das eingegebene CPU-Passwort ist fehlgeschlagen.

Das SIMATIC Automation Tool kann keine Verbindung mit der CPU herstellen. Geräteidentifizierungsdaten wie MAC-Adresse oder Seriennummer sind in der Gerätetabelle im SIMATIC Automation Tool und im tatsächlichen Gerät unterschiedlich. Durchsuchen Sie das Netzwerk.

Die Sicherungsdatei ist für dieses Gerät nicht gültig.

Die von Ihnen ausgewählte Sicherungsdatei ist für diese CPU nicht gültig. Wählen Sie eine Sicherungsdatei, die Ihrem CPU-Gerätetyp entspricht.

Die Dateinamenerweiterung der Sicherungsdatei ist für dieses Gerät nicht gültig.

Die Dateinamenerweiterung der Datei ist ungültig. Wählen Sie eine Sicherungsdatei mit der Dateinamenerweiterung .s7pbkp.

Der Vorgang ist fehlgeschlagen.

Einer der folgenden Vorgänge ist fehlschlagen:

- Auf Werkseinstellungen zurücksetzen
- Speicher zurücksetzen
- Memory Card formatieren
Versetzen Sie gegebenenfalls das Gerät in den Betriebszustand STOP, um sicherzustellen, das eine SIMATIC Memory Card in der CPU ist. Wiederholen Sie den Vorgang.

Die Firmwaredatei ist für dieses Gerät nicht gültig.

Wählen Sie eine Firmware-Aktualisierungsdatei, die dem jeweiligen Gerät entspricht.

Das Passwort für die Programmdatei konnte nicht überprüft werden.

Das "Passwort in Programmdatei", das Sie für eine Programmaktualisierungsdatei eingegeben haben, entspricht keinem der Passwörter in der Programmdatei. Um ein Programm zu aktualisieren, müssen Sie ein gültiges Passwort eingeben, das in der Programmdatei enthalten ist.

Die Programmdatei enthält eine IP-Adresse, die im Netzwerk bereits vorhanden ist.

Mit dem SIMATIC Automation Tool ist es nicht möglich, eine Programmdatei wiederherzustellen, die eine doppelte IP-Adresse verursacht. Ändern Sie die IP-Adresse des Geräts, die identisch ist, oder stellen Sie eine andere Programmdatei wieder her.

Passwort für Programmdatei fehlt

Sie müssen ein gültiges Passwort für das Programm eingeben.

Ungültiges Passwort für Programmdatei

Sie müssen ein gültiges Passwort für das Programm eingeben.

Der Vorgang wurde vom Anwender abgebrochen.

Nur zur Information

Die Programmdatei ist für dieses Gerät nicht gültig.

Wählen Sie eine Programmaktualisierungsdatei, die dem jeweiligen Gerät entspricht.

Das eingegebene Passwort für die Programmdatei ist ungültig oder nicht ausreichend, um den Vorgang durchzuführen.

Geben Sie für die Programmdatei ein Passwort mit einer für den gewünschten Vorgang ausreichenden Zugriffsstufe ein.

Das gewünschte Gerät wurde im Netzwerk nicht gefunden.

Das SIMATIC Automation Tool konnte kein Gerät im Netzwerk finden. Überprüfen Sie die Netzwerkschnittstelle, Netzwerkverbindung und IP-Adresse. Schließen Sie S7‑PLCSIM oder eine andere Simulationssoftware, sofern eine solche läuft.

Sie können kein Gerät einfügen, das bereits vorhanden ist.

Sie haben versucht, ein Gerät einzufügen, das bereits in der Gerätetabelle enthalten ist. Sie können nur ein Gerät einfügen, dass sich noch nicht in der Gerätetabelle befindet.

Die IP-Adresse kann nicht geändert werden, weil sie bereits im Netzwerk vorhanden ist.

Sie haben versucht, als IP-Adresse eine IP-Adresse anzugeben, die bereits in Gebrauch ist. Legen Sie für die IP-Adresse des Geräts eine eindeutige Adresse fest.

Der PROFINET-Name kann nicht geändert werden, weil er bereits im Netzwerk vorhanden ist.

Sie haben versucht, als PROFINET-Namen einen PROFINET-Namen anzugeben, der bereits in Gebrauch ist. Wählen Sie einen eindeutigen PROFINET-Namen.

Es konnte keine Verbindung zum Gerät hergestellt werden.

Das SIMATIC Automation Tool konnte keine Verbindung zum Gerät herstellen. Überprüfen Sie die Netzwerkschnittstelle, Netzwerkverbindung und IP-Adresse.

Das Gerät konnte nicht vollständig initialisiert werden.

Das SIMATIC Automation Tool konnte das Gerät nicht initialisieren. Achten Sie darauf, dass sich das Gerät im selben Netzwerk befindet wie Ihr Programmiergerät.

Das SIMATIC Automation Tool unterstützt keine CPUs mit neueren Programmen.

Sie versuchen gerade, ein Programm mit einer neueren Version als die Version zu verwenden, die das SIMATIC Automation Tool unterstützt. Ermitteln Sie anhand des Gerätekatalogs die passende Versionsunterstützung für Ihr Gerät.

IP-Suite ist nicht gültig.

Die Kombination aus IP-Adresse, Gateway und Subnetz ist nicht gültig. Geben Sie eine gültige IP-Suite ein.

Die ausgewählte Sicherungsdatei ist mit diesem Gerät nicht kompatibel

Die von Ihnen gewählte Sicherungsdatei ist nicht mit Ihrem Gerät kompatibel. Vergewissern Sie sich, dass Sie die richtige Sicherungsdatei für das Gerät und die Geräteversion ausgewählt haben.

Die IP-Adresse hat sich geändert oder im Netzwerk ist eine doppelte IP-Adresse vorhanden.

Die IP-Adresse für dieses Gerät hat sich seit der letzten Netzwerkdurchsuchung geändert oder ein anderes Gerät weist dieselbe IP-Adresse auf. Durchsuchen Sie das Netzwerk erneut und beseitigen Sie bestehende IP-Adresskonflikte.

Keine Geräte beim Durchsuchen gefunden.

Das SIMATIC Automation Tool hat bei der Netzwerkdurchsuchung keine Geräte gefunden. Überprüfen Sie die Netzwerkschnittstelle und die Netzwerkverbindungen. Überprüfen Sie das Subnetz für die Geräte. Schließen Sie S7‑PLCSIM oder eine andere Simulationssoftware, sofern eine solche läuft.

Ergebnis des CRC-Vergleichs online und offline: Kollektive F-Signaturen stimmen überein.

Nur zur Information: Ihr Vorgang mit einer F-CPU wurde erfolgreich ausgeführt. Sie brauchen nichts weiter zu tun.

Das Gerät konnte nicht eingefügt werden.

Das SIMATIC Automation Tool konnte das von Ihnen eingegebene Gerät nicht in die Geräte einfügen. Prüfen Sie, ob die IP-Adresse eindeutig ist und ob die von Ihnen eingegebenen Daten einem Gerät im Netzwerk entsprechen.

Sie können kein Gerät einfügen, das eine IP-Adresse hat, die bereits im Netzwerk vorhanden ist.

Sie haben versucht, ein Gerät mit einer zu einem anderem Gerät gehörenden IP-Adresse einzufügen. Sie müssen beim Einfügen eines Geräts eine eindeutige IP-Adresse angeben.

Die neue Gateway-Adresse ist nicht gültig.

Sie haben eine ungültige Gateway-Adresse eingegeben. Geben Sie eine für Ihr Netzwerk gültige Gateway-Adresse ein.

Die neue IP-Adresse ist nicht gültig.

Sie haben eine ungültige neue IP-Adresse eingegeben. Geben Sie eine gültige IP-Adresse an, die.

Die neue PROFINET-Name ist nicht gültig.

Sie haben einen ungültigen neuen PROFINET Namen eingegeben. Geben Sie einen gültigen PROFINET-Namen ein.

Die neue Subnetzmaske ist nicht gültig.

Sie haben eine ungültige Subnetzmaske eingegeben. Geben Sie eine für Ihr Gerät und Netzwerk gültige Subnetzmaske ein.

F-Signaturen konnten nicht gelesen werden

F-CPUs enthalten eine fehlersichere Signatur. Das SIMATIC Automation Tool konnte die fehlersichere Signatur nicht aus dem Gerät auslesen. Ihr Vorgang kann mit diesem Fehler nicht fortgesetzt werden.

Formatieren Sie die Memory Card, wenn Sie eine verwenden. Setzen Sie das Gerät auf die Werkseinstellungen zurück. Wiederholen Sie anschließend den Vorgang.

Ungültige oder nicht angegebene Netzwerkschnittstelle

Wählen Sie aus der Dropdown-Liste eine für Ihre Kommunikationseinstellungen gültige Netzwerkschnittstelle aus.

Das angegebene Passwort ist nicht ausreichend, um den Vorgang durchzuführen.

Zur Ausführung dieses Vorgangs benötigen Sie eine höhere Zugriffsstufe. Sie legen die Passwörter für die Zugriffsstufen im STEP 7-Projekt fest. Geben Sie ein Passwort mit einer für den gewünschten Vorgang ausreichenden Zugriffsstufe ein.

Die Programmdatei enthält keine Passwörter.

In der Programmdatei befinden sich keine Passwörter. Diese Meldung dient nur der Information und erfordert keine aktive Reaktion.

Beim Verarbeiten dieses Vorgangs ist eine unverarbeitete Ausnahme aufgetreten.

Ein unerwarteter Fehler ist aufgetreten. Durchsuchen Sie das Netzwerk nochmals und wiederholen Sie den Vorgang. Starten Sie das SIMATIC Automation Tool erneut, wenn durch eine Netzwerksuche das Problem nicht behoben wird. Wenn das Problem weiterhin besteht, wenden Sie sich an Ihren Siemens-Vertreter.

Das Öffnen von Projekten im Dateiformat V1.x wird nicht unterstützt.

Ein Projekt mit der Version 1.x des SIMATIC Automation Tool kann nicht geöffnet werden. Es können nur Projekte ab Version 2.0 geöffnet werden.

Das Öffnen des Projekts wurde abgebrochen.

Sie haben begonnen, ein Projekt zu öffnen, und die Aktion abgebrochen. Sie brauchen weiter nichts zu tun.

Es ist ein Passwort für die Programmdatei erforderlich

Sie müssen das Passwort für die Programmdatei eingeben.

Die Sicherungsdatei konnte nicht geöffnet, gelesen oder verarbeitet werden

Die Sicherungsdatei konnte vom SIMATIC Automation Tool nicht geöffnet, gelesen oder verarbeitet werden. Verwenden Sie eine Sicherungsdatei, die Ihrem Gerät und dessen Version entspricht.

Inkompatible Programmdatei für dieses Gerät

Die Programmdatei ist mit Ihrem Gerät nicht kompatibel. Verwenden Sie eine Programmdatei, die Ihrem Gerät und dessen Version entspricht.

Das SIMATIC Automation Tool unterstützt die Hardware-Konfiguration des STEP 7 Projekts nicht.

Das SIMATIC Automation Tool unterstützt die Hardware-Konfiguration des STEP 7-Programms im Gerät nicht. Überprüfen Sie die Gerätekonfiguration im STEP 7-Projekt und ermitteln Sie im Gerätekatalog die Unterstützung für Ihr Gerät.

Die Hardware-Konfiguration des Programms ist für das angeschlossene Gerät nicht gültig.

Die Hardware-Konfiguration des STEP 7-Programms ist für das aktuelle Gerät im Netzwerk nicht gültig. Überprüfen Sie die Gerätekonfiguration im STEP 7-Projekt und ermitteln Sie im Gerätekatalog die Unterstützung für Ihr Gerät.

Das Dateisystem kann nicht geladen werden. Versuchen Sie, die CPU aus- und wieder einzuschalten.

Das SIMATIC Automation Tool konnte die Dateien nicht von der CPU laden. CPU-Dateien sind möglicherweise beschädigt. Schalten Sie die CPU aus und wieder ein. Wenn das Problem weiterhin besteht, setzen Sie die CPU auf die Werkseinstellungen zurück.

SNMP: Es wurde ein ungültiges Passwort eingegeben.

Sie haben ein ungültiges Passwort in das Profil der SNMP-Version 3 eingegeben. Geben Sie ein gültiges Passwort für das Gerät ein.

SNMP: Der Wert ist nicht vorhanden

Ein SNMP-Wert ist ungültig. Prüfen Sie Ihre SNMP-Profileinstellungen.

SNMP: Der Wert kann nicht geändert werden

In einem SNMP-Profil haben Sie versucht, einen Wert in einen ungültigen Wert zu ändern. Geben Sie einen gültigen Wert ein.

SNMP: Der Wert ist schreibgeschützt und kann nicht geändert werden

Sie haben versucht, einen schreibgeschützten Wert in einem SNMP-Profil zu ändern. Sie können diesen Wert nicht ändern.

Ungültiger Authentifizierungsalgorithmus

Der Authentifizierungsalgorithmus im Profil der SNMP-Version 3 ist ungültig. Wählen Sie in der Dropdown-Liste im Dialog "Hinzufügen" des SNMP-Profils einen gültigen Authentifizierungsalgorithmus aus.

Ungültiges Authentifizierungspasswort

Das Authentifizierungspasswort im Profil der SNMP-Version 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils ein gültiges Authentifizierungspasswort ein.

Ungültiger Kontextname

Der Kontextname im Profil der SNMP-Version 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils einen gültigen Kontextnamen ein.

Ungültiger Datenschutzalgorithmus

Der Datenschutzalgorithmus im Profil der SNMP-Version 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils einen gültigen Datenschutzalgorithmus ein.

Ungültiges Datenschutzpasswort

Das Datenschutzpasswort im Profil der SNMP-Version 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils ein gültiges Datenschutzpasswort ein.

Ungültiger Profilname

Der Profilname im Profil der SNMP-Version 1, 2 oder 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils einen gültigen Profilnamen ein.

Ungültige Lese-Community

Die Lese-Community in Version 1 oder 2 des SNMP-Profils ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils eine gültige Lese-Community ein.

Ungültige Sicherheitsstufe

Die Sicherheitsstufe im Profil der SNMP-Version 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils eine gültige Sicherheitsstufe ein.

Ungültige Server-IP-Adresse

Die Server-IP-Adresse im Profil der SNMP-Version 1, 2 oder 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils eine gültige Server-IP-Adresse ein.

Ungültiger Serverport

Der Serverport im Profil der SNMP-Version 1, 2 oder 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils einen gültigen Serverport ein.

Ungültige SNMP-Version

Die SNMP-Version ist ungültig. Wählen Sie im Dialog "Hinzufügen" des SNMP-Profils 1, 2 oder 3 als SNMP-Versionsnummer.

Ungültiger Benutzername

Der Benutzername im Profil der SNMP-Version 3 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils einen gültigen Benutzernamen ein.

Ungültige Schreib-Community

Die Schreib-Community im Profil der SNMP-Version 1 oder 2 ist ungültig. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils eine gültige Schreib-Community ein.

Der Profilname ist bereits vorhanden.

Der Profilname im Profil der SNMP-Version 1, 2 oder 3 gehört zu einem anderen Profil. Geben Sie im Dialog "Hinzufügen" des SNMP-Profils einen eindeutigen Profilnamen ein.

Diese Methode ist veraltet. Verwenden Sie die neuere Methode gleichen Namens.

-/-

Ungültiges Profil

Das SNMP-Profil ist für das Gerät ungültig. Überprüfen Sie die Konfiguration im Dialog "Hinzufügen" und nehmen Sie die erforderlichen Änderungen vor.

Firmware-Übertragung konnte nicht initiiert werden

Die Firmware-Aktualisierung ist fehlgeschlagen. Überprüfen Sie alle Netzwerkverbindungen. Achten Sie darauf, dass die Firmware-Aktualisierungsdatei für das Gerät gültig ist. Versuchen Sie erneut, eine Firmware-Aktualisierung durchzuführen.

Ein SNMP-Fehler ist aufgetreten

Bei der SNMP-Kommunikation mit dem Gerät ist ein Fehler aufgetreten. Prüfen Sie Ihre SNMP-Profileinstellungen. Wenn das Problem weiterhin besteht, wenden Sie sich an den Customer Support für das Gerät.

Ungültiger Übertragungskanal

Die Auswahl für den HMI-Übertragungskanal ist ungültig. Stellen Sie entweder PN_IE oder Ethernet für den HMI-Übertragungskanal für die API-Methode SetTransferChannel ein.

Das Gerät hat eine ungültige MAC-Adresse zurückgeliefert.

Das SIMATIC Automation Tool konnte die MAC-Adresse für die von Ihnen angegebene IP-Adresse nicht ermitteln. Dieser Fehler kann nur auftreten, wenn Sie ein Gerät anhand der IP-Adresse einfügen. Vergewissern Sie sich, dass Sie ein in Ihrem Netzwerk verfügbares Gerät einfügen. Vergewissern Sie sich, dass die IP-Adresse für das Gerät korrekt ist. Fügen Sie alternativ das Gerät anhand seiner MAC-Adresse ein.

Aktualisierung doppelter IPs und PROFINET-Namen fehlgeschlagen

Das SIMATIC Automation Tool hat einen internen Fehler. Wiederholen Sie die Durchsuchung des Netzwerks. Wenn das Problem weiterhin besteht, wenden Sie sich an Ihren Siemens-Vertreter.

Die eingegebene PROFINET-Name ist im Netzwerk doppelt vorhanden.

Ein anderes Gerät verwendet diesen PROFINET-Namen. Geben Sie einen eindeutigen PROFINET-Namen ein.

Fehler bei Datensicherung

Die CPU hat dem SIMATIC Automation Tool keine gültigen Sicherungsdaten geliefert. Schalten Sie die CPU aus und wieder ein und wiederholen Sie den Vorgang. Wenn das Problem weiterhin besteht, wenden Sie sich an Ihren Siemens-Vertreter.

Das fehlersichere Steuerungsobjekt der CPU entspricht nicht dem richtigen Typ.

Das aktuelle Programm in der F-CPU existiert nicht als Sicherheitsprogramm oder ist beschädigt. Laden Sie das Sicherheitsprogramm aus dem TIA Portal in das Gerät oder aktualisieren Sie das Programm aus dem SIMATIC Automation Tool.

Die angegebene IP-Adresse ist ungültig oder wird bereits von der NIC verwendet

Sie haben eine ungültige Adresse eingegeben oder die Adresse wird von einem anderen Gerät verwendet. Geben Sie eine gültige, eindeutige IP-Adresse ein.

Die Firmware-Aktualisierung ist aufgrund von Integritätsprüfungen fehlgeschlagen.

Die UPD-Datei für die Firmware-Aktualisierung ist beschädigt. Verwenden Sie eine gültige UPD-Datei für die Firmware-Aktualisierung.

Typ der Sicherung ungültig

Der Typ der HMI-Sicherung ist ungültig. Gültige Sicherungstypen für eine HMI sind Komplettsicherung, Rezept oder Benutzerverwaltungsdaten. Stellen Sie einen gültigen Sicherungstyp zur Verfügung.

Kein Zugriff auf einen oder mehrere Gerätediagnosepuffer möglich

Beim Exportieren von Gerätediagnosen konnte das SIMATIC Automation Tool auf einen oder mehrere Diagnosepuffer nicht zugreifen. Überprüfen Sie, ob die Geräte in der Gerätetabelle an das Kommunikationsnetzwerk angeschlossen sind. Überprüfen Sie das Ereignisprotokoll auf Meldungen über nicht erreichbare Geräte. Falls erforderlich, stellen Sie den Anschluss an das Netzwerk her und durchsuchen Sie das Netzwerk.

Fehler im Automation License Manager – Initialisierungsfehler, ALM-Neustart versuchen

Bei der Initialisierung ist ein Fehler aufgetreten. Starten Sie den Automation License Manager neu.

Fehler im Automation License Manager – interner Fehler, globale Bereinigung fehlgeschlagen, ALM-Neustart versuchen

Bei globalen Bereinigungsaufgaben ist ein Fehler aufgetreten. Starten Sie den Automation License Manager neu.

Fehler im Automation License Manager – interner Fehler, Sitzungsinitialisierung fehlgeschlagen, ALM-Neustart versuchen

Bei der Sitzungsinitialisierung ist ein Fehler aufgetreten. Starten Sie den Automation License Manager neu.

Fehler im Automation License Manager – interner Fehler, Sitzungsbereinigung fehlgeschlagen, ALM-Neustart versuchen

Bei Sitzungsbereinigungsaufgaben ist ein Fehler aufgetreten. Starten Sie den Automation License Manager neu.

Fehler im Automation License Manager – interner Fehler, fehlende Sitzungs-ID, Siemens-Support benachrichtigen

Es ist ein interner Fehler der Sitzungs-ID aufgetreten. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Sitzungs-ID nicht vorhanden, Siemens-Support benachrichtigen

Es ist ein interner Fehler der Sitzungs-ID aufgetreten. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – Verbindung fehlgeschlagen, Netzwerkzugriff auf ALM-Server prüfen

Die Verbindung zum Automation License Manager ist fehlschlagen. Prüfen Sie Ihren Netzwerkzugriff.

Fehler im Automation License Manager – interner Fehler, nicht genug Speicher, System neu starten oder Siemens-Support benachrichtigen

Der Automation License Manager konnte nicht genug Speicher für den Betrieb zuweisen. Starten Sie Ihr Programmiergerät neu und versuchen Sie es erneut. Wenn das Problem weiterhin besteht, wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – Zeitbegrenzung wurde überschritten, System neu starten oder Siemens-Support benachrichtigen

Die Zeitbegrenzung des Automation License Manager wurde überschritten. Starten Sie Ihr Programmiergerät neu und versuchen Sie es erneut. Wenn das Problem weiterhin besteht, wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Funktion nicht gefunden, Siemens-Support benachrichtigen

Eine interne Funktion im Automation License Manager hatte einen Fehler. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Aufgabe wurde abgebrochen, Siemens-Support benachrichtigen

Eine interne Aufgabe im Automation License Manager hatte einen Fehler. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, falsche Funktionsargumente, Siemens-Support benachrichtigen

Eine interne Funktion im Automation License Manager hatte einen Fehler im Zusammenhang mit den Argumenten. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Benutzer hat unbekannte Option angegeben, Siemens-Support benachrichtigen

Die Optionen für den Automation License Manager waren ungültig. Versuchen Sie es nochmals. Wenn das Problem weiterhin besteht, wenden Sie sich an den Siemens-Support.

Automation License Manager – Senden der Netzwerkdaten fehlgeschlagen, Netzwerkverbindung prüfen

Der Automation License Manager konnte die Netzwerkdaten nicht senden. Prüfen Sie die Netzwerkverbindung.

Automation License Manager – Empfangen der Netzwerkdaten fehlgeschlagen, Netzwerkverbindung prüfen

Der Automation License Manager konnte die Netzwerkdaten nicht empfangen. Prüfen Sie die Netzwerkverbindung.

Automation License Manager – keine Verbindung verfügbar, Netzwerkverbindung prüfen

Der Automation License Manager ist nicht mit dem Netzwerk verbunden. Prüfen Sie die Netzwerkverbindung.

Fehler im Automation License Manager – interner Fehler, Öffnen der Sitzung fehlgeschlagen, Siemens-Support benachrichtigen

Der Automation License Manager konnte eine Sitzung nicht öffnen. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, fehlende Ressourcen, Siemens-Support benachrichtigen

Der Automation License Manager hatte nicht genug interne Ressourcen. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – Service läuft nicht, ALM-Service neu starten

Starten Sie den Automation License Manager neu, um den Service zu starten. Wenn das Problem weiterhin besteht, wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Kryptographie fehlgeschlagen, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Kryptographiefehler. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Aufgabe ist bereits in Bearbeitung, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler wegen einer in Bearbeitung befindlichen Aufgabe. Führen Sie sowohl für Ihr Programmiergerät als auch für den Automation License Manager einen Neustart durch. Wenn das Problem weiterhin besteht, wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, falscher Pointer, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Pointerfehler. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Ergebnis stimmt nicht überein, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler mit unerwartetem Ergebnis. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, fehlerhaftes Ergebnis, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler mit ungültigem Ergebnis. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Batch-API, falsche Argumentnummer, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler im Zusammenhang mit der Batch-Schnittstelle. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Batch-API, falsches Argument, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler im Zusammenhang mit der Batch-Schnittstelle. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Batch-API, falsche Eingabedatei, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler im Zusammenhang mit der Batch-Schnittstelle. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Batch-API, falscher XML-Eingabestream, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler im Zusammenhang mit der Batch-Schnittstelle. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Batch-API, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler im Zusammenhang mit der Batch-Schnittstelle. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Batch-API, Ausgabedatei bereits vorhanden, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler im Zusammenhang mit der Batch-Schnittstelle. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Batch-API, falscher Ausgabeparameter, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler im Zusammenhang mit der Batch-Schnittstelle. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – interner Fehler, Batch-API, Ausgabedatei konnte nicht erstellt werden, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen internen Fehler im Zusammenhang mit der Batch-Schnittstelle. Wenden Sie sich an den Siemens-Support.

Fehler im Automation License Manager – Benutzerzugriffsrechte für Ordner prüfen

Der Automation License Manager hatte einen Fehler beim Zugriff auf den Ordner. Prüfen Sie die Benutzerzugriffsrechte für den Ordner.

Fehler im Automation License Manager – interner Fehler, unbekannter Fehler, Siemens-Support benachrichtigen

Der Automation License Manager hatte einen unbekannten internen Fehler. Wenden Sie sich an den Siemens-Support.

Die maximale Anzahl von PC-Verbindungen wurde überschritten

Das SIMATIC Automation Tool kann keine weitere Verbindung herstellen. Die maximale Anzahl wurde erreicht. Sie können keine Verbindung zu zusätzlichen Geräten herstellen. Wenn das TIA Portal online ist, trennen Sie die Online-Verbindung. Trennen Sie andere Geräte vom PC.

Der Dateiname ist nicht gültig

Der Dateiname ist für den Vorgang nicht gültig. Vergewissern Sie sich, dass Pfad und Dateiname für den Vorgang gültig sind.

Die laufende Dienstanforderung wurde vom Client abgebrochen

Nur zur Information: Der Client hat einen laufenden Dienst abgebrochen.

Die SNMP-Version ist ungültig

Die SNMP-Version ist ungültig. Wählen Sie als SNMP-Versionsnummer 1, 2 oder 3.

Vor Durchführung dieses Vorgangs müssen Sie die CPU aus- und wieder einschalten.

Vor diesem Vorgang muss die CPU aus- und wieder eingeschaltet werden. Schalten Sie die CPU aus und wieder ein und wiederholen Sie den Vorgang.

Die Projektdatei wurde nicht geöffnet, weil auf die Schaltfläche "Abbrechen" geklickt wurde.

Nur zur Information: Sie haben die Browser zum Öffnen einer Projektdatei beendet.

Projektdatei <Dateiname> wurde erfolgreich geöffnet.

Nur zur Information: Das SIMATIC Automation Tool hat die benannte Projektdatei geöffnet.

Projektdatei <Dateiname> konnte nicht geöffnet werden.

Das SIMATIC Automation Tool konnte die benannte Projektdatei nicht öffnen. Vergewissern Sie sich, dass die Datei eine gültige und mit Ihrer Version kompatible SAT-Projektdatei ist.

Das eingegebene Passwort ist nicht korrekt.

Sie haben ein ungültiges Passwort für die Projektdatei eingegeben. Sie müssen das korrekte Passwort für diese Projektdatei eingeben.

Die Projektdatei wurde nicht gespeichert, weil auf die Schaltfläche "Abbrechen" geklickt wurde.

Nur zur Information: Sie haben die Browser zum Speichern einer Projektdatei beendet.

Export von PC-Daten fehlgeschlagen.

Mit dem Vorgang zum Exportieren von PC-Daten konnte die Exportdatei nicht erzeugt werden. Prüfen Sie die Festplattenkapazität und die Berechtigungen für den Exportordner.

Projektdatei <Dateiname> konnte nicht gespeichert werden.

Das SIMATIC Automation Tool konnte die Projektdatei nicht speichern. Prüfen Sie Ordnerberechtigungen und Festplattenkapazität auf Ihrem Programmiergerät.

Der Export wurde nicht durchgeführt, weil auf die Schaltfläche "Abbrechen" geklickt wurde.

Nur zur Information: Sie haben einen Export gestartet und dann abgebrochen.

Das Einfügen des Geräts wurde nicht durchgeführt, weil auf die Schaltfläche "Abbrechen" geklickt wurde.

Nur zur Information: Sie hatten begonnen, ein Gerät einzufügen, und dann den Vorgang abgebrochen.

Es wurde keine gültige Produktlizenz gefunden. Einige Produktfunktionen sind deaktiviert.

Sie haben keine gültige Produktlizenz. Nur diejenigen Aufgaben, die das SIMATIC Automation Tool für eine unlizenzierte Version unterstützt, können ausgeführt werden. Um auf alle Funktionen zugreifen zu können, müssen Sie eine Lizenz erwerben wie in den Installationshinweisen beschrieben.

Es wurde eine gültige Produktlizenz gefunden. Alle Produktfunktionen sind aktiviert.

Nur zur Information: Mit einer gültigen und nicht abgelaufenen Lizenz können Sie alle Aufgaben mit dem SIMATIC Automation Tool ausführen.

Um auf einige PC-Exportdaten zugreifen zu können, sind Windows-Administratorrechte erforderlich. Starten Sie das SIMATIC Automation Tool neu und verwenden Sie zum Exportieren dieser Daten den Befehl "Als Administrator ausführen".

Führen Sie den Vorgang zum Exportieren von PC-Daten mit Windows-Administratorrechten aus, um auf einige der Daten zugreifen zu können. Starten Sie das SIMATIC Automation Tool neu und verwenden Sie zum Exportieren dieser Daten den Befehl "Als Administrator ausführen".

Der Export hat alle angeforderten Daten erfasst. Die Protokolldatei enthält eine ausführliche Liste der exportierten Daten.

Nur zur Information: Der Vorgang zum Exportieren von PC-Daten war erfolgreich. Die Protokolldatei in der ZIP-Exportdatei führt die exportierten Daten auf.

Der Export konnte nicht alle Daten erfassen. Die Protokolldatei enthält Einzelheiten über die Daten, die der Export erfolgreich erfasst hat, und die Gründe dafür, dass die anderen Daten nicht erfasst werden konnten.

Mit dem Vorgang zum Exportieren von PC-Daten wurden nicht alle Daten exportiert. Sehen Sie nach, ob die Ursache in der Protokolldatei angegeben wird. Die Protokolldatei in der ZIP-Exportdatei enthält folgende Informationen:

  • Informationen über die Daten, die der Exportvorgang erfolgreich erfasst und exportiert hat

  • Gründe dafür, dass der Exportvorgang die anderen Daten nicht erfasst hat

Projektdatei <Dateiname> wurde erfolgreich gespeichert.

Nur zur Information: Das SIMATIC Automation Tool hat die benannte Projektdatei erfolgreich gespeichert.

Gerätespezifische Meldungen

Geräte können auch gerätespezifische Meldungen zurückgeben. Diese Meldungen sind in der oben genannten Liste nicht enthalten. Wenn eine gerätespezifische Meldung nicht selbsterklärend ist, wenden Sie sich an den Gerätehersteller.

Meldungen im Zusammenhang mit dem Export von PC-Daten

Der Export von PC-Daten generiert möglicherweise Meldungen, die nicht in der oben genannten Liste enthalten sind. Das SIMATIC Automation Tool protokolliert diese Meldungen wie vom Exportprozess zurückgegeben. Wenn Sie eine Ereignisprotokollmeldung der Ereignisklasse "Export von PC-Daten" erhalten, probieren Sie diese Korrekturmaßnahmen aus:

  • Prüfen Sie, ob die Festplattenkapazität ausreichend ist. Die exportierte ZIP-Datei mit den PC-Daten erfordert möglicherweise mehr Kapazität als verfügbar ist. Schaffen Sie gegebenenfalls zusätzliche Kapazität auf der Festplatte.

  • Prüfen Sie die Berechtigungen für den Exportordner.

Wenn Sie weitere nicht erläuterte Ereignisprotokollmeldungen der Ereignisklasse "Export von PC-Daten" erhalten, wenden Sie sich an Ihren Siemens-Vertreter.