Guide utilisateur SIMATIC Automation Tool V3.1 SP4

Au chapitre Instructions Exemples Notions élémentaires Historique Outils
Démarrer Précédent Suivant

Guide utilisateur SIMATIC Automation Tool V3.1 SP4

Ce chapitre contient des informations sur les sujets suivants :
  • Préface
  • Présentation de SIMATIC Automation Tool
  • Prérequis et configuration de la communication
  • Prise en main de SIMATIC Automation Tool
  • Opérations d'appareil
  • Gestion des fichiers de projet
  • Menus, barres d'outils, raccourcis clavier et informations de référence
  • API SIMATIC Automation Tool pour architecture .NET
  • Prise en charge des appareils SIMATIC Automation Tool
  • Traitement des erreurs des messages de journal des événements


Préface

Préface

Ce chapitre contient des informations sur les sujets suivants :
  • Note relative à la sécurité
  • Service et assistance


Note relative à la sécurité

Note relative à la sécurité

Siemens commercialise des produits et solutions comprenant des fonctions de sécurité industrielle qui contribuent à une exploitation sûre des installations, systèmes, machines et réseaux.

Pour garantir la sécurité des installations, systèmes, machines et réseaux contre les cybermenaces, il est nécessaire de mettre en œuvre - et de maintenir en permanence - un concept de sécurité industrielle global et de pointe. Les produits et solutions de Siemens constituent une partie de ce concept.

Il incombe aux clients d'empêcher tout accès non autorisé à ses installations, systèmes, machines et réseaux. Ces systèmes, machines et composants doivent uniquement être connectés au réseau d'entreprise ou à Internet si et dans la mesure où cela est nécessaire et seulement si des mesures de protection adéquates (ex : pare-feu et/ou segmentation du réseau) ont été prises.

Pour plus d'informations sur les mesures de protection pouvant être mises en œuvre dans le domaine de la sécurité industrielle, rendez-vous sur.

Les produits et solutions Siemens font l'objet de développements continus pour être encore plus sûrs. Siemens recommande vivement d'effectuer des mises à jour dès que celles-ci sont disponibles et d'utiliser la dernière version des produits. L'utilisation de versions qui ne sont plus prises en charge et la non-application des dernières mises à jour peut augmenter le risque de cybermenaces pour nos clients.

Pour être informé des mises à jour produit, abonnez-vous au flux RSS Siemens Industrial Security à l'adresse suivante :


Service et assistance

Langue source du document

Service et assistance

En complément de ce guide utilisateur, Siemens propose son expertise technique sur Internet et via le site Web Siemens Automation et le site Web du support en ligne Siemens Industry Adressez-vous à votre agence Siemens si certaines de vos questions techniques restent sans réponse, si vous voulez connaître les offres de formation ou si vous désirez commander des produits S7. Comme ce personnel est techniquement formé et a des connaissances très pointues sur vos activités, vos processus et vos industries, ainsi que sur les différents produits Siemens que vous utilisez, il peut apporter les réponses les plus rapides et les plus efficaces possibles à tout problème que vous pourriez rencontrer.

Langue source du document

La version anglaise du Guide utilisateur SIMATIC Automation Tool est la langue officielle (originale) pour les informations SIMATIC Automation Tool. Siemens identifie le manuel le manuel anglais comme étant la source officielle originale en cas de divergences entre les manuels traduits.


Présentation de SIMATIC Automation Tool

Présentation de SIMATIC Automation Tool

Ce chapitre contient des informations sur les sujets suivants :
  • Gestion des réseaux
  • Accès au réseau
  • Options de réseau
  • .NET API (application programming interface)


Gestion des réseaux

Gestion de réseaux d'appareils SIMATIC Opérations de configuration, de pilotage et de maintenance Restriction des fonctionnalités pour un SIMATIC Automation Tool sans licence Opérations DCP Accès au catalogue des appareils Exemple d'installation d'un réseau S7‑1200
Menu Fichier Menu Edition Menu Outils Menu Aide Travailler avec la table des appareils Mots de passe de la CPU Insérer un appareil Menu Options
Démarrer Précédent Suivant

Gestion des réseaux

SIMATIC Automation Tool est un outil précieux pour l'exploitation des machines et des installations. A l'aide de cet outil, vous pouvez effectuer en même temps une opération sur plusieurs appareils d'un réseau. SIMATIC Automation Tool vous assiste dans les tâches suivantes :

  • Mise en service

    Vous pouvez utiliser SIMATIC Automation Tool, par exemple, pour mettre à jour simultanément plusieurs adresses IP ou charger des projets dans plusieurs appareils.

  • Maintenance

    Par exemple, vous pouvez aussi effectuer des mises à jour du firmware sur plusieurs appareils. Vous pouvez aussi sauvegarder un programme d'un appareil pour le restaurer sur plusieurs appareils.

  • Service

    Il peut être utile, par exemple, de récupérer des données de diagnostic et de maintenance de plusieurs appareils.

Gestion de réseaux d'appareils SIMATIC

Une fois qu'un programme de commande est créé, vérifié et téléchargé avec le Siemens TIA Portal, SIMATIC Automation Tool peut être utilisé pour configurer, piloter, effectuer la maintenance et documenter un grand nombre d'appareils sur des réseaux d'automatisation.

Remarque

Vous ne pouvez pas utiliser SIMATIC Automation Tool pour lire les appareils présents dans votre réseau d'automatisation si S7-PLCSIM s'exécute sur la même console de programmation en même temps que SIMATIC Automation Tool. Vous devez fermer S7‑PLCSIM pour que SIMATIC Automation Tool puisse lire un réseau d'appareils.

Opérations de configuration, de pilotage et de maintenance

SIMATIC Automation Tool avec une licence valide et non expirée vous permet de réaliser de nombreuses opérations utiles sur un réseau d'appareils :

Opérations réseau

  • Analyser le réseau et créer une table des appareils qui indique les appareils accessibles dans le réseau. La table des appareils peut inclure des CPU, modules, IHM, commutateurs SCALANCE Industrial Ethernet, périphérie décentralisée et autres appareils Siemens. Vous pouvez enregistrer la table des appareils dans un fichier projet *.sat sécurisé ou dans un fichier .csv open text.

  • Identifier les appareils avec des LED / écrans IHM clignotants

  • Mettre à jour les adresses des appareils (IP, sous-réseau, passerelle)

  • Mettre à jour le nom PROFINET (nom de la station) d'un appareil

Configuration système

  • Régler l'heure d'une CPU sur celle de votre console de programmation

  • Mettre à jour un programme CPU ou le système d'exploitation et le logiciel exécutif d'un appareil IHM

  • Charger, ajouter, remplacer ou supprimer des données de recette d'une CPU

  • Charger ou supprimer les données de Data log d'une CPU

  • Mettre à jour le firmware des modules

Opération

  • Placer une CPU en mode RUN ou STOP

Diagnostic système et maintenance

  • Sauvegarder des données vers un fichier de sauvegarde pour une CPU ou un appareil HMI

  • Restaurer des données depuis un fichier de sauvegarde pour une CPU ou un appareil HMI

  • Afficher le tampon de diagnostic d'une CPU

  • Réinitialiser les paramètres de communication

  • Réinitialiser la mémoire de la CPU

  • Récupérer les données de maintenance depuis une CPU

  • Formater la carte mémoire SIMATIC installée dans une CPU

  • Restaurer les paramètres d'usine des appareils

  • Documenter et sauvegarder les informations réseau dans un fichier texte standard .cvs ou un dans un fichier .sat protégé par mot de passe.

Table des appareils SIMATIC Automation Tool

Restriction des fonctionnalités pour un SIMATIC Automation Tool sans licence

Si vous n'avez pas activé la licence d'essai ou si la licence d'essai gratuite de 21 jours a expiré, SIMATIC Automation Tool prend en charge uniquement les fonctionnalités suivantes :

  • Opérations de menu à partir des menus suivants :

    • Menu Fichier

    • Menu Édition, comprenant les opérations d'édition dans la table des appareils

    • Menu Options

    • Menu Outils

    • Menu Aide

  • Scanner un réseau

  • Intégrer et supprimer des appareils

  • Saisir des commentaires d'appareil dans la table des appareils

  • Récupérer les données de maintenance

  • Afficher les diagnostics de CPU

  • Saisir et modifier des mots de passe CPU

  • Réglage des CPU en mode RUN ou STOP

Opérations DCP

Notez que certains appareils ne prennent en charge que les opérations DCP (Discovery and Configuration Protocol) :

  • Appareils Siemens PROFINET

  • Appareils PROFINET ou Ethernet non Siemens non pris en charge

Les opérations DCP sont les suivantes :

  • Scanner un réseau

  • Identifier un appareil (clignotement LED appareil ou clignotement indicateur sur écran HMI)

  • Mettre à jour l'adresse IP, le masque de sous-réseau et l'adresse de la passerelle sur l'appareil

  • Mettre à jour le nom d'appareil PROFINET

  • Réinitialiser les paramètres de communication

Accès au catalogue des appareils

SIMATIC Automation Tool permet d'ouvrir un fichier Microsoft Excel du catalogue des appareils montrant les appareils pris en charge. Pour chaque appareil, le catalogue des appareils montre les opérations prises en charge. Pour plus d'informations, voir Prise en charge des appareils SIMATIC Automation Tool.

Exemple d'installation d'un réseau S7‑1200

Fabrication en atelier et chargement initial du programme :

  • Les CPU utilisent toutes la même configuration matérielle et le même programme de commande.

  • La configuration de la CPU PROFINET utilise les options "Set IP address on the device" (configurer l'adresse IP sur l'appareil) et "Set PROFINET device name on the device option" (définir le nom d'appareil PROFINET sur l'option de l'appareil).

  • Les panels sont tous identiques.

  • Vous pouvez utiliser SIMATIC Automation Tool, une carte mémoire SD SIMATIC ou TIA Portal pour charger les appareils CPU / IHM avec les données de projet.

Si vous gérez un réseau contenant de nombreux appareils, SIMATIC Automation Tool peut simplifier les opérations et réduire le temps nécessaire. Vous pouvez effectuer une opération sur plusieurs appareils en même temps. SIMATIC Automation Tool propose le traitement multifil pour les appareils autres que les appareils de sécurité. Le traitement multi-thread signifie que les opérations peuvent s'effectuer simultanément. Pendant que la console de programmation effectue une opération sur un seul appareil, un autre fil (thread) peut commencer l'opération sur un autre appareil. Le traitement multi-thread est paramétré par défaut dans le Paramètres de communication. Vous pouvez désactiver le traitement multi-thread si vous le souhaitez.


Accès au réseau

Communiquer avec les appareils réseau Opérations DCP Modèles et couches de communication Accès réseau et opérations SIMATIC Automation Tool
Démarrer Précédent Suivant

Accès au réseau

Communiquer avec les appareils réseau

Le scan réseau SIMATIC Automation Tool détecte les appareils raccordés directement à un réseau à l'aide de l'adresse MAC (Media Access Control). Chaque appareil possède une adresse MAC propre et unique. L'adresse MAC ne peut pas être modifiée et est imprimée sur l'appareil. SIMATIC Automation Tool détecte les appareils connectés, qu'ils soient configurés avec une adresse IP, de sous-réseau ou de passerelle ou qu'ils ne soient pas configurés. Les adresses IP 0.0.0.0 indiquent des appareils qui ne sont pas configurés.

Les opérations sur l'adresse MAC utilisent le protocole DCP (Discovery and Configuration Protocol). Le DCP est un standard Ethernet.

Opérations DCP

Pour tous les appareils réseau connectés directement, SIMATIC Automation Tool prend en charge les opérations DCP suivantes sur les adresses MAC :

  • Scan du réseau

  • Identifier les appareils

  • Configurer l'adresse IP

  • Définir le nom PROFINET

  • Réinitialiser les paramètres de communication

Les appareils connectés directement prenant en charge le protocole DCP, sont les suivants :

  • Appareil PROFINET pris en charge

  • Appareil PROFINET non pris en charge

  • Appareils Ethernet non-Siemens non pris en charge

Modèles et couches de communication

Différents modèles de communication représentent différents protocoles de communication. Pour comprendre SIMATIC Automation Tool prenez en compte les couches de communication suivantes :

Couche | Appareil | Adressage
Réseau (couche 3) | Routeur | Adresses IP uniquement
Lien (couche 2) | Commutateur | Adresses MAC (DCP) Adresses IP
Couche physique (couche 1) | Hub | Bits

Couche 1 : réseau simple avec la console de programmation connectée directement à une CPU avec E/S locale :

  • Les opérations sur l'adresse MAC sont possibles.

  • Une adresse IP et une configuration d'appareil TIA Portal valides dans la CPU sont nécessaires :

    • pour afficher les modules locaux d'une CPU

    • pour effectuer des opérations sur l'adresse IP

Couche 2 : CPU multiples avec E/S locales connectées via un commutateur Ethernet :

  • Les opérations sur l'adresse MAC sont possibles pour tous les appareils.

  • Une adresse IP et une configuration d'appareil TIA Portal valides dans chaque CPU sont nécessaires :

    • pour afficher les modules locaux d'une CPU

    • pour effectuer des opérations sur l'adresse IP

Couche 3 : CPU en réseaux complexes avec E/S décentralisées et routeurs d'adresses IP :

  • Les opérations sur l'adresse MAC ne sont possibles que pour les appareils directement connectés au même sous-réseau que la console de programmation qui exécute SIMATIC Automation Tool.

  • Une adresse IP et une configuration d'appareil TIA Portal valides dans chaque CPU sont nécessaires :

    • pour afficher les appareils situés derrière la CPU

    • pour effectuer des opérations sur l'adresse IP

Les opérations sur l'adresse IP ne fonctionnent que pour les appareils Siemens pris en charge.

Remarque

Lors du scan d'un réseau, SIMATIC Automation Tool ne peut pas détecter les appareils derrière un routeur NAT (Network Address Translation)

SIMATIC Automation Tool détecte les appareils lors d'un scan réseau à l'aide d'une combinaison de l'adresse MAC et de l'adresse IP. Comme les routeurs NAT ne transmettent pas les commandes DCP, un scan réseau ne permet pas de détecter les appareils sur les routeurs NAT. Pour la même raison, vous ne pouvez pas insérer un appareil se trouvant derrière un routeur NAT.

Par exemple, une CPU S7-1500 possède une connexion réseau PROFINET au SIMATIC Automation Tool. Cette CPU S7-1500 possède un module CP local pour se raccorder à un autre réseau PROFINET. Les périphériques I/O décentralisés se connectent à ce réseau.

Pour que SIMATIC Automation Tool identifie le réseau décentralisé I/O, suivez les étapes suivantes :

  1. Affectez une adresse IP valide à la CPU S7-1500 dans STEP 7.

  2. Compilez le projet STEP 7, puis chargez-le dans la CPU.

  3. Scannez le réseau depuis SIMATIC Automation Tool

Pour les appareils raccordés indirectement derrière une CPU, un module CM ou CP, seule la mise à jour du firmware est possible.

Accès réseau et opérations SIMATIC Automation Tool

Le type d'accès réseau dépend de la commande exécutée, comme illustré dans le tableau suivant :

Commande
SIMATIC Automation Tool

Adresse d'appareil utilisée

Mot de passe obligatoire pour une CPU protégée

Accès réseau

Scanner (détecter des CPU, des IHM, des E/S et d'autres appareils)

MAC

Non

  • Réseau local : vous pouvez accéder aux appareils du réseau à l'aide des commutateurs Ethernet. Vous ne pouvez pas accéder aux appareils d'un autre réseau via un routeur d'adresse IP.

  • Connexion VPN (Virtual Private Network) au réseau local
    Vous devez utiliser la couche 2 VPN pour ces fonctions MAC.

Identifier les appareils (LED / écrans IHM clignotants)

MAC

Non

Configurer l'adresse IP, le masque de sous-réseau et l'adresse de la passerelle sur les appareils

MAC

Non

Définir le nom PROFINET sur les appareils

MAC

Non

Réinitialiser les paramètres de communication

MAC

Non

Mettre les CPU en mode RUN ou STOP (Marche/arrêt)

IP

Oui1

  • Réseau local : vous pouvez accéder aux appareils du réseau à l'aide des commutateurs Ethernet.

  • Réseau distant : vous pouvez accéder aux appareils d'un autre réseau via un routeur d'adresse IP.

  • VPN : connexion au réseau local

Régler l'heure de la CPU sur celle de la console de programmation

IP

Oui1

Mettre à jour le programme : Programmes de la CPU

IP

Oui3

Mettre à jour le programme : Mise à jour du système d'exploitation et du logiciel exécutif d'un appareil IHM

IP

Sans objet

Charger des données Recette d'une CPU

IP

Oui2

Ajouter, remplacer ou supprimer des données Recette d'une CPU

IP

Oui1

Charger les données de Data log d'une CPU

IP

Oui2

Supprimer les données de Data log d'une CPU

IP

Oui1

Réaliser une copie de sauvegarde de la CPU dans un fichier

IP

Oui2

Réaliser une copie de sauvegarde de l'IHM dans un fichier

IP

Sans objet

Restaurer la CPU à partir d'un fichier de sauvegarde

IP

Oui3

Restaurer l'IHM à partir d'un fichier de sauvegarde

IP

Sans objet

Charger les données de maintenance depuis des CPU

IP

Oui2

Lire le tampon de diagnostic de la CPU

IP

Oui2

Restaurer la mémoire de la CPU

IP

Oui1

Restaurer les paramètres d'usine

IP

Oui3

Mettre à jour le firmware dans des appareils

IP

Oui1

Formater la carte mémoire CPU

IP

Oui3

1 Nécessite le niveau d'accès "Accès complet (pas de protection)".

2Nécessite un niveau d'accès comprenant "Accès en lecture"
3 Les CPU standard nécessitent le niveau d'accès "Accès complet (pas de protection)". Les CPU de sécurité nécessitent le niveau d'accès "Accès complet (pas de protection)" ou l'"Accès complet, y compris failsafe (pas de protection)" selon la version de firmware de la CPU. Vous devez également resélectionner et confirmer les CPU de sécurité pour ces opérations.

Pour plus d'informations sur les niveaux d'accès CPU, voir la rubrique "Mots de passe de la CPU".

Remarque

Protocoles pour sous-réseaux IP et interface réseau

La console de programmation qui exécute SIMATIC Automation Tool et les appareils raccordés à votre réseau local doivent utiliser des affectations de sous-réseau IP appropriées.

Selon le type de protocole d'interface réseau que vous sélectionnez ("TCPIP" ou "TCPIP.Auto"), SIMATIC Automation Tool sera ou non capable de détecter des appareils durant le scan du réseau.

Voir l'exemple sous larubrique Réglage de la communication.


Options de réseau

Réseaux locaux et réseaux distants Exemple 1 : Réseau local S7-1200 Exemple 2 : Réseau distant S7-1200 Exemple 3 : Réseaux combinés S7-1200
Travailler avec la table des appareils
Démarrer Précédent Suivant

Options de réseau

Réseaux locaux et réseaux distants

Les exemples suivants montrent des réseaux locaux des réseaux distants utilisables par SIMATIC Automation Tool. Ces diagrammes simplifiés montrent la connectivité de base et n'affichent pas les appareils IHM, les périphériques d'E/S locaux et décentralisés (PROFINET et PROFIBUS) ou d'autres appareils qui sont également accessibles. D'autres environnements réseau sont aussi possibles.

Lorsque vous effectuez un scan du réseau, SIMATIC Automation Tool remplit la table des appareils. Vous pouvez exporter les données d'appareil dans la table des appareils à un fichier au format .csv, à l'aide de Microsoft Excel ou d'un outil de votre choix. Vous pouvez alors copier/coller les nouvelles données dans la table des appareils SIMATIC Automation Tool.

Exemple 1 : Réseau local S7-1200

Exemple 2 : Réseau distant S7-1200

Exemple 3 : Réseaux combinés S7-1200


.NET API (application programming interface)

.NET API (application programming interface)

Vous pouvez créer votre propre outil logiciel qui utilise l'API Microsoft .NET de SIMATIC Automation Tool pour effectuer les mêmes opérations que SIMATIC Automation Tool.

Pour utiliser l'API, vous devez avoir SIMATIC Automation Tool ou SIMATIC Automation Tool SDK (Software Development Kit) sur votre console de programmation. SIMATIC Automation Tool et votre outil logiciel utilisent le fichier API .dll et des fichiers de communication S7 supplémentaires. SIMATIC Automation Tool fournit tous les fichiers dont vous avez besoin et stocke les fichiers API dans le dossier d'installation SIMATIC Automation Tool.

Licence logicielle requise pour V3.0 et versions ultérieures

Si une licence valide et non expirée est détectée pour SIMATIC Automation Tool, vous pouvez utiliser l'API.


Prérequis et configuration de la communication

Prérequis et configuration de la communication

Ce chapitre contient des informations sur les sujets suivants :
  • Installation de SIMATIC Automation Tool
  • Démarrage de SIMATIC Automation Tool
  • Configuration de la communication
  • Configuration requise pour définir une adresse IP
  • Configuration requise pour définir un nom PROFINET


Installation de SIMATIC Automation Tool

Installation de SIMATIC Automation Tool

Reportez-vous aux notes d'installation accessibles depuis le setup pour obtenir des informations sur l'installation de SIMATIC Automation Tool.


Démarrage de SIMATIC Automation Tool

Démarrage de SIMATIC Automation Tool

Utilisez l'une des méthodes suivantes pour démarrer SIMATIC Automation Tool :

  • Double-cliquer sur l'icône SIMATIC Automation Tool du Bureau.

  • Cliquez sur le bouton Démarrer de Windows, puis sur les commandes de menu "Tous les programmes" > "Siemens Automation" > "SIMATIC Automation Tool" > "SIMATIC Automation Tool".

  • Double-cliquez sur un fichier de projet SIMATIC Automation Tool (.sat).


Configuration de la communication

Identification de la carte d'interface réseau raccordée au réseau de l'appareil. Affectation de l'interface réseau dans SIMATIC Automation Tool
Démarrer Précédent Suivant

Configuration de la communication

Identification de la carte d'interface réseau raccordée au réseau de l'appareil.

Une fois que vous avez connecté votre console de programmation à un réseau, vous pouvez utiliser le panneau de configuration Windows pour afficher le nom de la carte d'interface réseau.

Dans l'exemple suivant, le réseau d'appareils SIMATIC est connecté à un PC exécutant Windows par un convertisseur Ethernet-USB. Les noms de réseau que vous voyez sur votre console de programmation dépendent de votre matériel réseau.

Utiliser le panneau de configuration Windows pour identifier le nom de l'appareil :

  1. Ouvrez le panneau de configuration Windows (Windows 7) ou les Paramètres (Windows 10)/

  2. Cliquez sur le centre Réseau et partage (Windows 7) ou naviguez jusqu'à Réseau et Internet > Ethernet > Centre Réseau et partage (Windows 10) :

  3. Affichez vos réseaux actifs et cliquez sur celui qui est connecté à vos appareils :

  4. Cliquez sur le bouton Détails dans la vue de l'état de la connexion :

  5. Affichez la description de l'interface réseau :

Affectation de l'interface réseau dans SIMATIC Automation Tool

Vous devez affecter l'interface réseau à un nouveau projet pour que la communication puisse commencer. Pour configurer l'interface réseau, procédez comme suit :

  1. Lancez SIMATIC Automation Tool.

  2. Cliquez sur la liste déroulante de la carte d'interface réseau.

  3. Choisissez l'interface réseau connectée à votre réseau d'appareils Siemens.

Il se peut que les interfaces réseau qui s'affichent soient différentes de celles présentées sur l'image suivante, car la liste montre les interfaces réseau effectivement disponibles dans votre console de programmation :

Si vous avez sélectionné une carte d'interface réseau mais que les appareils ne possèdent pas d'adresse IP valide, vous ne pouvez pas utiliser les opérations basées sur l'adresse IP.
Vous pouvez utiliser les opérations basées sur l'adresse MAC et paramétrer des adresses IP valides pour les appareils de votre réseau.

Opérations avec adresse MAC

  • Rechercher les appareils du réseau

  • Identifier les appareils

  • Définir les adresses IP Ethernet

  • Définir les noms PROFINET

  • Restaurer les paramètres d'usine L'opération Restaurer les paramètres d'usine basée sur l'adresse MAC ne fonctionne que pour les périphériques PROFINET I/O ; les autres appareils utilisent une opération de restauration des paramètres d'usine basée sur l'adresse IP.

Sélection de l'interface réseau

Comme illustré dans la figure précédente, vous pouvez voir deux entrées pour chaque interface réseau. La différence se trouve dans l'ajout des caractères ".Auto".

Lorsque vous sélectionnez l'interface Ethernet, vous avez le choix entre les types de protocole réseau suivants :

  • TCPIP

  • TCPIP.Auto

Siemens recommande de choisir TCPIP sans "Auto" car les adresses IP temporaires ne sont pas créées automatiquement dans l'adaptateur Windows Ethernet. Vous devez affecter une adresse IP valide dans la configuration Windows pour l'interface réseau.

Sinon, vous pouvez aussi choisir TCPIP.Auto. Une fois que vous avez scruté le réseau, vous devez vérifier que les adresses IP temporaires créées automatiquement ne sont pas en conflit avec les adresses IP des autres appareils sur le réseau.

Le protocole TCPIP.Auto présente les avantages suivants :

  • Le protocole TCPIP.Auto permet à l'interface réseau de créer une adresse IP temporaire sur le même sous-réseau que les appareils qui ne sont pas sur le même sous-réseau physique que l'interface réseau. Le protocole TCPIP peut uniquement accéder à des appareils sur le même sous-réseau physique.

  • Vous pouvez modifier les adresses IP des appareils réseau accessibles pour utiliser un sous-réseau compatible avec le protocole TCPIP.

  • Après un scan du réseau, l'adaptateur Ethernet Windows dispose toujours d'adresses IP temporaires valides pour tous les appareils Siemens. Vous n'avez pas besoin d'affecter de nouvelles adresses IP explicitement dans Windows.

Cependant, le protocole TCPIP.Auto peut créer des problèmes de communication dans le réseau :

  • Vous ne pouvez pas affecter des adresses IP temporaires.

  • Les adresses temporaires sont perdues après une mise hors tension puis sous tension ou une réinitialisation de la console de programmation. De nouvelles adresses IP temporaires sont créées lors du scan réseau suivant qui utilise le protocole TCPIP.Auto.

  • Il est possible qu'une adresse IP temporaire créée automatiquement soit déjà utilisée par un autre nœud (par exemple, une autre console de programmation non visible par un scan réseau SIMATIC Automation Tool). Un conflit d'adresses peut générer des erreurs de communication difficiles à diagnostiquer dans certains secteurs du réseau.

Exemple d'utilisation des protocoles TCPIP et TCPIP.Auto

Vous pouvez vérifier les adresses IP de l'adaptateur réseau Windows en entrant "ipconfig /all" sur la ligne de commande.

La commande "ipconfig /all" a été utilisée pour obtenir les adresses IP affichées dans l'exemple suivant :

  1. Après une réinitialisation de la console de programmation (réamorçage) et avant de lancer un scan réseau SIMATIC Automation Tool, exécutez "ipconfig /all" dans la fenêtre de ligne de commande. Vous voyez ci-dessous le résultat pour la carte de l'adaptateur Ethernet connecté au réseau d'appareils Siemens. L'adresse IP configurée de l'adaptateur Ethernet Windows est 192.168.2.200 :

  2. Raccordez un automate programmable Siemens S7-1200 configuré avec l'adresse IP 192.168.3.1. Le masque de sous-réseau est 255.255.255.0, l'appareil S7-1200 est donc configuré pour un autre sous-réseau. Le troisième octet est "3" et doit être "2" afin que la communication avec l'adresse de sous-réseau 192.168.2 de l'adaptateur Ethernet soit possible.

  3. Démarrez SIMATIC Automation Tool, configurez l'interface réseau sur le protocole TCIP et lancez un scan réseau. Dans ce cas, l'automate programmable S7-1200 n'est pas détecté car il est configuré avec une adresse de sous-réseau incorrecte.

  4. Modifiez l'interface réseau SIMATIC Automation Tool sur le protocole TCIP.Auto et lancez un scan réseau.

  5. Le scan réseau utilise le protocole TCPIP.Auto et détecte l'appareil S7-1200. Les informations sur le nouvel appareil S7-1200 sont ajoutées à la table des appareils de SIMATIC Automation Tool.

  6. Exécutez "ipconfig /all" sur la ligne de commande.
    Comme le montre l'image suivante, une adresse IP Ethernet adapter temporaire 192.168.3.241 a été créée. L'adresse IP temporaire permet d'accéder au sous-réseau 192.168.3 :

    Plusieurs adresses IP temporaires sont créées lorsque le protocole TCPIP.Auto détecte plusieurs sous-réseaux dans un réseau complexe.
    Les adresses IP temporaires sont supprimées si la console de programmation Windows est réinitialisée.

  7. SIMATIC Automation Tool peut maintenant se connecter à l'appareil S7-1200 avec l'adresse IP temporaire 192.168.3.241 et changer l'adresse IP de l'appareil S7-1200. Utilisez SIMATIC Automation Tool pour mettre à jour l'adresse IP. Changez l'adresse IP de 192.168.3.1 en 192.168.2.1.

  8. Réinitialisez la console de programmation et redémarrez Windows. Toutes les adresses IP temporaires sont supprimées au redémarrage.

  9. Démarrez SIMATIC Automation Tool, configurez l'interface réseau sur le protocole TCIP et lancez un scan réseau.
    L'automate programmable S7-1200 (192.168.2.1) est détecté et peut communiquer avec l'adaptateur Ethernet Windows (192.168.2.200).
    Aucune adresse IP temporaire n'est créée. Seule l'adresse IP configurée dans les propriétés de l'adaptateur réseau Windows est utilisée.

Si la carte d'interface réseau est sélectionnée et que les adresses IP sont valides, vous pouvez utiliser les opérations SIMATIC Automation Tool qui s'appuient sur une adresse IP.

Opérations utilisant les adresses IP

  • Mettre les CPU en mode RUN ou STOP (Marche/arrêt)

  • Régler l'heure de la CPU sur celle de la console de programmation

  • Mettre à jour le programme pour une CPU et des appareils IHM

  • Charger, ajouter, remplacer ou supprimer des données de recette d'une CPU

  • Charger ou supprimer les données de Data log d'une CPU

  • Sauvegarder/restaurer les données de la CPU et de l'IHM

  • Récupérer les données de maintenance depuis des CPU

  • Afficher le diagnostic

  • Réinitialiser la mémoire de la CPU

  • Formater la carte mémoire dans une CPU

  • Restaurer les paramètres d'usine des appareils

  • Mettre à jour le firmware dans des appareils

Remarque

Problèmes de communication avec SIMATIC Automation Tool

Vous envoyez peut-être une opération à plusieurs appareils, mais un des appareils ne termine pas l'opération. Le journal des événements (Event log) affiche une erreur de communication. Cependant, les autres appareils exécutent l'opération comme prévu. Si vous rencontrez ce problème, procédez comme suit :

  1. Réduisez le nombre d'opérations simultanées que vous autorisez sous Paramètres de communication.

  2. Fermez et redémarrez SIMATIC Automation Tool.

  3. Réessayez l'opération pour un ou plusieurs appareils.

Si vous exécutez une opération sur un appareil et que le débit de transfert de données de la connexion à l'appareil est très bas, une erreur de dépassement de temps de la communication peut être renvoyée. Si vous rencontrez ce problème, augmentez la durée du délai d'attente affecté aux opérations de communication sous Paramètres de communication.


Configuration requise pour définir une adresse IP

Conditions de raccordement direct pour définir une adresse IP Exemple : Configuration de S7-1200 dans STEP 7
Démarrer Précédent Suivant

Configuration requise pour définir une adresse IP

Vous pouvez utiliser SIMATIC Automation Tool pour définir l'adresse IP de l'appareil. Pour conserver l'adresse IP après une mise hors tension/sous tension, le projet STEP 7 dans l'appareil doit activer cette fonction dans la configuration de l'appareil. Vous devez compiler le projet STEP 7 et le charger dans l'appareil cible. Sans le réglage dans la configuration d'appareil STEP 7, l'adresse IP que vous définissez est temporaire.

Conditions de raccordement direct pour définir une adresse IP

Configurer l'adresse IP est une opération DCP qui utilise une adresse MAC pour accéder à l'appareil cible. Les appareils raccordés indirectement utilisent une adresse IP. Ils ne peuvent pas utiliser les opérations DCP. Vous devez établir temporairement une connexion directe entre l'appareil cible et SIMATIC Automation Tool pour modifier l'adresse IP.

Quand l'opération Définir une adresse IP est-elle possible et quand est-elle impossible ?

  • Possible pour les appareils PROFINET connectés directement au sous-réseau du réseau connecté à SIMATIC Automation Tool.

    Ces appareils incluent les CPU, les IHM, la périphérie décentralisée et autres appareils, y compris ceux connectés via un commutateur Ethernet.

  • Impossible pour les appareils PROFINET connectés indirectement en aval d'un(e) :

    • CPU

    • Module CP ou CM

    • Module d'interface

    • Second port Ethernet d'une CPU

  • Impossible pour les appareils PROFINET d'un autre réseau avec une connexion à SIMATIC Automation Tool qui passe par un routeur d'adresses IP.

Consultez le catalogue des appareils pour voir quelles opérations SIMATIC Automation Tool prend en charge pour chaque appareil.

Exemple : Configuration de S7-1200 dans STEP 7

Pour permettre à SIMATIC Automation Tool de définir une adresse IP non temporaire, effectuez la configuration d'appareil de la CPU S7-1200 comme suit :

  1. Ouvrez la configuration d'appareil pour la CPU S7‑1200.

  2. Cliquez sur l'interface PROFINET sur l'image de la configuration d'appareil de la CPU pour afficher les paramètres de l'interface.

  3. Sous l'onglet Propriétés, cliquez sur l'onglet Général pour afficher l'option Adresses Ethernet.

  4. Cliquez sur l'option "Permettre la modification de l'adresse IP directement sur l'appareil". Cette option porte des noms différents en fonction de la version de STEP 7. Vous pouvez trouver :

    • Adresse IP définie directement sur l'appareil

    • Configurer l'adresse IP sur l'appareil

    • Définir l'adresse IP avec une autre méthode

    Cette sélection permet à SIMATIC Automation Tool d'affecter une adresse IP. Pour les appareils avec des interfaces PROFINET multiples, comme la CPU S7-1500, vous pouvez configurer une interface ou toutes les interfaces pour permettre des modifications de l'adresse IP.

  5. Enregistrez le projet et téléchargez la nouvelle configuration sur l'appareil.

Remarque

Réglages par défaut des paramètres IP PROFINET

Lorsque vous créez un projet TIA Portal, le réglage par défaut de PROFINET est "Set IP address in the project" (définir l'adresse IP dans le projet). Les options par défaut permettent seulement de définir une adresse IP temporaire avec SIMATIC Automation Tool.


Configuration requise pour définir un nom PROFINET

Conditions de raccordement direct pour définir un nom PROFINET Exemple : Configuration de S7-1200 dans STEP 7
Démarrer Précédent Suivant

Configuration requise pour définir un nom PROFINET

Pour permettre la définition du nom PROFINET d'un appareil avec SIMATIC Automation Tool, le projet STEP 7 pour l'appareil doit activer cette fonction dans la configuration de l'appareil. Vous devez compiler le projet STEP 7 et le télécharger sur l'appareil cible avant d'utiliser SIMATIC Automation Tool pour définir le nom PROFINET d'un appareil.

Conditions de raccordement direct pour définir un nom PROFINET

Configurer le nom PROFINET est une opération DCP qui utilise une adresse MAC pour accéder à l'appareil cible. Les appareils raccordés indirectement utilisent une adresse IP pour l'accès et ne peuvent pas utiliser les opérations DCP. Vous devez établir temporairement une connexion directe entre l'appareil cible et SIMATIC Automation Tool pour modifier le nom PROFINET.

Quand l'opération Définir le nom PROFINET est-elle possible et quand est-elle impossible ?

  • Possibles pour les appareils PROFINET (CPU, IHM, E/S décentralisées et autres appareils) connectés directement au sous-réseau du réseau connecté à SIMATIC Automation Tool (y compris via un commutateur Ethernet).

  • Impossibles pour les appareils PROFINET connectés indirectement derrière une CPU, un module CP/CM ou un module d'interface connecté directement, ou par un port Ethernet secondaire d'une CPU.

  • Impossibles pour les appareils PROFINET d'un autre réseau avec une connexion à SIMATIC Automation Tool qui passe par un routeur d'adresses IP.

Consultez le catalogue des appareils pour voir quelles opérations SIMATIC Automation Tool prend en charge pour chaque appareil.

Exemple : Configuration de S7-1200 dans STEP 7

Pour permettre à SIMATIC Automation Tool de définir le nom PROFINET, effectuez la configuration d'appareil de la CPU S7-1200 comme suit :

  1. Ouvrez la configuration d'appareil pour la CPU S7‑1200.

  2. Cliquez sur l'interface PROFINET dans la vue de la configuration d'appareil de la CPU pour afficher les paramètres de l'interface.

  3. Sur l'onglet Propriétés, cliquez sur l'onglet Général pour afficher les options Adresses Ethernet.

  4. Pour les options Adresses Ethernet , cliquez sur Nom PROFINET défini directement sur l'appareil. Cette option porte des noms différents en fonction de la version de STEP 7. Vous pouvez trouver :

    • Nom d'appareil PROFINET défini directement sur l'appareil

    • Régler le nom d'appareil PROFINET sur l'appareil

    La sélection permet à SIMATIC Automation Tool d'affecter un nom de station PROFINET. Pour les appareils avec des interfaces PROFINET multiples, comme la CPU S7-1500, vous pouvez configurer toutes les interfaces pour permettre la modification du nom PROFINET ou une seule interface.

  5. Enregistrez le projet et téléchargez la nouvelle configuration sur l'appareil.

Remarque

Réglages par défaut des paramètres IP PROFINET

Lorsque vous créez un nouveau projet TIA Portal, le réglage par défaut de PROFINET est "Générer automatiquement un nom d'appareil PROFINET". Les options par défaut ne permettent pas de définir des noms d'appareil PROFINET avec SIMATIC Automation Tool.


Prise en main de SIMATIC Automation Tool

Prise en main de SIMATIC Automation Tool

Ce chapitre contient des informations sur les sujets suivants :
  • Travailler avec la table des appareils
  • Travailler avec le journal des événements (Event Log)
  • Mots de passe de la CPU
  • Options de traitement multifil (multi-thread)


Travailler avec la table des appareils

Utilisation de la table des appareils Menu contextuel (clic droit) pour les cellules de la table Menu contextuel pour les en-têtes des colonnes Restauration des colonnes par défaut Filtrage des lignes affichées Filtrage des appareils non pris en charge
Démarrer Précédent Suivant

Travailler avec la table des appareils

SIMATIC Automation Tool est constitué de deux parties :

  • Table des appareils : Initialement la table des appareils est vide. Après un scan du réseau ou l'insertion d'appareils, elle affiche les appareils connectés.

  • Journal des événements (Event Log) : L'Event log affiche les résultats des opérations.

Pour chaque appareil, SIMATIC Automation Tool affiche des colonnes contenant des données sur l'appareil. Les onglets dans la table des appareils prennent en charge différentes opérations sur les appareils et fournissent des champs de saisie de données :

Utilisation de la table des appareils

La table des appareils est similaire à Microsoft Excel. Vous pouvez effectuer des opérations de copier et coller vers ou à partir d'autres applications.

Les conseils suivants peuvent vous aider à utiliser la table des appareils :

  • Cliquer sur l'en-tête d'une colonne pour trier les lignes selon les données de colonne par ordre croissant ou décroissant.

  • Cliquez avec le bouton droit de la souris sur l'en-tête d'une colonne pour l'afficher ou la masquer.

  • Cochez la case Appareil en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser la commande de menu "Modifier > Sélectionner" pour choisir soit "Sélectionner les lignes" soit "Désélectionner les lignes". Vous pouvez également faire un clic droit sur une ligne de l'appareil pour accéder au menu Modifier.

  • Cliquez sur le coin supérieur gauche de la table des appareils pour sélectionner toutes les lignes.

  • Cliquez sur la cellule à gauche de la case à cocher d'une ligne pour sélectionner une ligne entière. Déplacez le curseur vers le haut ou le bas depuis la sélection pour sélectionner plusieurs lignes.

  • Cliquez sur la cellule à gauche de la case à cocher Appareil pour sélectionner toutes les lignes de la table des appareils.

  • Lorsque vous faites un clic droit sur une ligne ou une sélection de lignes, SIMATIC Automation Tool affiche un menu contextuel. Depuis le menu contextuel ci-dessous vous permet d'utiliser les commandes Sélectionner, Développer, Réduire, Insérer, Supprimer et Actualiser avec un groupe de lignes.

  • Vous pouvez créer des filtres de lignes pour les colonnes Appareil, Type d'appareil et Numéro d'article.

  • Sélectionnez un ou plusieurs appareils pour y effectuer des opérations. SIMATIC Automation Tool affiche en gras les lignes sélectionnées.

  • Cliquez sur la flèche à gauche d'un appareil pour le développer. Les modules subordonnés à l'appareil sur lequel vous avez cliqué s'affichent alors. SIMATIC Automation Tool affiche à la fois les modules pris en charge et non pris en charge qui sont subordonnés à un appareil pris en charge.

  • Vous pouvez également exporter une table d'appareils dans un fichier .csv pour la visualisation et l'édition dans Microsoft Excel ou un autre outil.

Vous pouvez scanner le réseau pour remplir la table des appareils avec les appareils de votre réseau. Vous pouvez également Insérer des appareils directement.

De nombreuses opérations sur les appareils fonctionnent avec des fichiers sur votre console de programmation. Vous pouvez trouver les noms de chemins de fichiers par défaut dans les paramètres de chaque opération. Vous pouvez modifier les noms de chemins de fichiers par défaut et d'autres paramètres depuis la commande de menu "Options > Paramètres".

Menu contextuel (clic droit) pour les cellules de la table

Lorsque vous faites un clic droit sur une ligne de la table des appareils, le menu contextuel est identique au menu Éditer.

Menu contextuel pour les en-têtes des colonnes

Pour chaque onglet de la table des appareils, SIMATIC Automation Tool affiche un ensemble de colonnes par défaut. Vous pouvez choisir les colonnes à afficher ou à masquer.

Pour configurer les colonnes à afficher ou à masquer, procédez comme suit :

  1. Faites un clic droit sur la ligne d'en-tête de l'appareil pour afficher le menu contextuel pour les colonnes.

  2. Sélectionnez les cases à cocher pour afficher ou masquer les colonnes pour cette vue d'onglet.

Restauration des colonnes par défaut

Vous pouvez restaurer les colonnes de la table des appareils à leur valeur par défaut originale. Procédez comme suit pour restaurer les colonnes par défaut :

  1. Faites un clic droit sur la ligne d'en-tête de l'appareil pour afficher le menu contextuel pour les colonnes.

  2. Cliquez sur la commande "Restaurer les colonnes par défaut".

Filtrage des lignes affichées

Vous pouvez filtrer les colonnes Appareil, Type d'appareil et Numéro d'article. Cliquez sur l'un de ces en-têtes de colonne pour afficher le bouton [image]. Cliquez sur ce bouton pour ouvrir une fenêtre de filtre.

Par exemple, vous pouvez sélectionner les numéros d'article 6ES7 214-1HF40-0XB0 et 6ES7 215-1HF40-0XB0. Lorsque vous cliquez sur le bouton OK, la table des appareils affiche uniquement les lignes contenant ces valeurs :

Vous pouvez utiliser Paramètres généraux pour activer/désactiver l'affichage des appareils non pris en charge.

Filtrage des appareils non pris en charge

SIMATIC Automation Tool affiche en gris les appareils non pris en charge. Vous pouvez effectuer uniquement les opérations suivantes sur les appareils non pris en charge :

  • Configurer l'adresse IP

  • Définir le nom PROFINET

  • Identifier l'appareil

  • Réinitialiser les paramètres de communication

  • Éditer le commentaire pour l'appareil

  • Utiliser des fonctions d'édition comme par ex. copier - coller


Travailler avec le journal des événements (Event Log)

Travailler avec le journal des événements (Event Log)

SIMATIC Automation Tool affiche le journal d'événements (Event Log) dans la zone de la fenêtre qui se trouve sous la table des appareils. Lorsque vous scannez le réseau ou sélectionnez des appareils et exécutez des opérations, les messages du journal d'événementssignalent les erreurs et les résultats des opérations.

Par défaut, toute opération nouvelle sur un appareil efface l'Event Log au début de l'opération. Vous pouvez choisir de supprimer ou non l'Event Log au début d'une opération dans Paramètres de l'Event Log.

Le SIMATIC Automation Tool peut également journaliser automatiquement des états d'opérations dans un fichier.

Ligne de l'Event Log affichant une opération réussie :

Faites un clic droit sur l'en-tête d'une colonne de l'Event Log pour afficher ou masquer des colonnes :

Cliquez avec le bouton droit sur une ligne d'événement pour copier, enregistrer ou supprimer les messages Event Log :

Les icônes de l'Event Log ont les significations suivantes :

Opération terminée avec succès

Échec de l'opération La colonne Résultat indique la cause de l'échec. Si vous sauvegardez l'Event Log, ces entrées commencent par "ÉCHEC :"

Opération terminée avec succès, mais ayant généré un avertissement. La colonne Résultat décrit l'avertissement. Si vous sauvegardez l'Event Log, ces entrées commencent par "AVERTISSEMENT :"

Informations uniquement

Remarque

Modifier la langue de l'Event Log et de l'interface utilisateur

Lorsque vous modifiez la langue de l'interface utilisateur de SIMATIC Automation Tool, l'Event Log est effacé. Les informations concernant les événements antérieurs sont supprimées.


Mots de passe de la CPU

Utiliser des mots de passe Niveaux d'accès associés aux mots de passe dans la CPU CPU de sécurité et mots de passe Icones relatives aux mots de passe
Démarrer Précédent Suivant

Mots de passe de la CPU

Si une protection par mot de passe est configurée sur une CPU, vous devez entrer ce mot de passe pour le niveau d'accès qui autorise SIMATIC Automation Tool à exécuter l'opération que vous voulez. Vous fournissez un mot de passe dans la colonne "Mot de passe dans la CPU" de la table des appareils.

Le mot de passe saisi sous la colonne "Mot de passe dans la CPU" renvoie à la protection par mot de passe existant sur la CPU cible.

Par exemple, une nouvelle CPU Siemens dans son emballage n'a pas de programme, pas de configuration matérielle et pas de protection par mot de passe. Une fois qu'un nouveau projet est chargé sur la CPU, vous devez utiliser les mots de passe qui sont configurés dans ce projet.

SIMATIC Automation Tool vous indique si une CPU est ou non protégée par mot de passe. La cellule de mot de passe d'une CPU est gris foncé et n'est pas modifiable si la CPU n'a pas de mot de passe.

Utiliser des mots de passe

SIMATIC Automation Tool gère les mots de passe comme suit :

  • Si une CPU est protégée par mot de passe, SIMATIC Automation Tool impose les exigences de mot de passe en fonction des niveau d'accès de mot de passe que vous avez définis dans TIA Portal. Pour les opérations protégées par mot de passe, vous devez entrer un mot de passe dans la cellule "Mot de passe dans la CPU".

  • L'onglet "Mise à jour du programme" comporte deux colonnes pour la saisie des mots de passe : "Mot de passe dans la CPU" et "Mot de passe dans le fichier de programme".

    Un fichier programme peut avoir un mot de passe, qui peut être différent du mot de passe actuel de la CPU. Lorsqu'un fichier programme comporte un mot de passe, vous devez entrer le mot de passe du fichier programme dans la cellule "Mot de passe dans le fichier de programme" pour effectuer une mise à jour du programme. Une fois que l'opération Mise à jour du programme est terminée avec succès, SIMATIC Automation Tool copie le mot de passe du fichier programme vers la cellule de mot de passe de la CPU. À l'aide de ce mot de passe, SIMATIC Automation Tool essaie ensuite de se connecter à la CPU.

  • L'onglet "Restaurer à partir de la sauvegarde" comporte deux colonnes pour la saisie des mots de passe : "Mot de passe dans la CPU" et "Mot de passe dans le fichier de sauvegarde".

    Un fichier de sauvegarde peut avoir un mot de passe, qui peut être différent du mot de passe actuel de la CPU. Lorsqu'un fichier de sauvegarde comporte un mot de passe, vous devez entrer le mot de passe du fichier de sauvegarde dans la cellule "Mot de passe dans le fichier de sauvegarde" Le mot de passe du fichier de sauvegarde devient le mot de passe de la CPU après l'achèvement de l'opération Restaurer à partir de la sauvegarde . SIMATIC Automation Tool copie le mot de passe du fichier de sauvegarde dans la cellule de mot de passe de la CPU après l'achèvement de l'opération Restaurer à partir de la sauvegarde. À l'aide de ce mot de passe, SIMATIC Automation Tool essaie ensuite de se connecter à la CPU.

  • En cas de saisie de mot de passe de CPU valide, vous pouvez déplacer le curseur de votre souris sur le champ mot de passe pour afficher une infobulle qui indique le niveau d'accès.

Niveaux d'accès associés aux mots de passe dans la CPU

Une CPU standard possède quatre niveaux d'accès. Une CPU de sécurité en possède cinq.

Les opérations SIMATIC Automation Tool qui nécessitent un accès en lecture ne peuvent pas fonctionner avec une CPU qui possède un niveau de protection de niveau "Accès HMI" ou "Pas d'accès (protection complète)". Vous devez configurer un mot de passe "Accès en lecture" ou "Accès intégral" dans TIA Portal. Vous devez ensuite saisir ce mot de passe dans la ligne de la CPU cible dans la table des appareils.

Les opérations SIMATIC Automation Tool qui nécessitent un accès en lecture ou en écriture ne peuvent pas fonctionner avec une CPU qui possède un niveau de protection de niveau "Accès en lecture", "Accès HMI" ou "Pas d'accès". Vous devez configurer un mot de passe "Accès en lecture" ou "Accès intégral" dans TIA Portal. Vous devez ensuite saisir ce mot de passe dans la ligne de la CPU cible dans la table des appareils.

Vous pouvez voir les niveaux d'accès de la CPU dans la section Protection & Sécurité des propriétés de TIA Portal.

Pour plus d'informations sur les niveaux d'accès et les mots de passe, reportez-vous au Système d'information STEP 7 (aide en ligne TIA Portal).

CPU de sécurité et mots de passe

SIMATIC Automation Tool peut fonctionner avec des CPU de sécurité. Vous pouvez vous connecter à une CPU de sécurité et effectuer certaines opérations à l'aide d'un mot de passe "Accès en lecture" ou d'un mot de passe "Accès complet (pas de protection)". Le Guide utilisateur désigne ces mots de passe comme des mots de passe de sécurité CPU F. Toutefois, les opérations relatives à la sécurité requièrent le mot de passe de CPU F de sécurité.

  • The SIMATIC Automation Tool affiche la cellule de mot de passe d'un appareil en jaune lorsque vous entrez un mot de passe de CPU F de sécurité.

  • Si une CPU de sécurité est protégée par mot de passe, toutes les opérations relatives à la sécurité nécessitent que vous entriez le mot de passe de CPU F de sécurité dans la colonne "Mot de passe dans la CPU".
    Si une CPU de sécurité n'utilise pas de protection par mot de passe, les opérations relatives à la sécurité ne nécessitent pas le mot de passe de CPU F de sécurité pour lancer l'opération.
    Les opérations relatives à la sécurité sont les suivantes :

    • Mise à jour du programme

    • Restaurer l'appareil depuis un fichier

    • Restaurer les paramètres d'usine

    • Formater la carte mémoire

  • Lorsqu'un fichier programme comporte un programme de sécurité, vous devez entrer le mot de passe de CPU F de sécurité dans la colonne "Mot de passe dans le fichier de programme" pour effectuer l'opération "Mise à jour du programme".

  • Lorsqu'un fichier de sauvegarde comporte un programme de sécurité, vous devez entrer le mot de passe de CPU F de sécurité dans la colonne "Mot de passe dans le fichier de sauvegarde" pour effectuer l'opération "Restaurer à partir de la sauvegarde".

Icones relatives aux mots de passe

SIMATIC Automation Tool qualifie le mot de passe au moyen de trois icônes :

Le mot de passe est valide.

Le mot de passe est invalide.

Le mot de passe pour l'appareil dans le fichier de sauvegarde ne peut pas encore être validé.

Une coche verte signifie que le mot de passe est un mot de passe valide dans la CPU ou le fichier programme. Une croix rouge signifie que le mot de passe n'est pas un mot de passe valide dans la CPU ou le fichier programme :

Lorsque vous entrez un mot de passe, SIMATIC Automation Tool ne sait pas quelles opérations vous comptez lancer. Par conséquent, SIMATIC Automation Tool ne valide pas le mot de passe à la saisie pour une opération spécifique. Par exemple, la mise à jour d'un programme de sécurité requiert le mot de passe de CPU F de sécurité. Pour de nombreuses autres opérations, le mot de passe Accès complet (pas de protection) suffit. Une coche verte ne signifie pas que le mot de passe est validé pour toutes les opérations. La validation du niveau d'accès se fait lorsque vous déclenchez l'opération. Si un mot de passe ne suffit pas pour une opération, SIMATIC Automation Tool génère une erreur dans le journal d'événements pour chaque appareil où une erreur s'est produite.

La cellule de mot de passe du fichier de sauvegarde est la seule à pouvoir afficher un point d'interrogation :

La cellule de mot de passe du fichier de sauvegarde ne comporte aucune icône lorsque le champ est désactivé ou vide. Lorsque vous sélectionnez un fichier de sauvegarde dans la liste ou entrez un mot de passe de CPU dans la colonne de mot de passe du fichier de sauvegarde, SIMATIC Automation Tool affiche l'icône de point d'interrogation. SIMATIC Automation Tool ne peut pas valider le mot de passe au moment où vous sélectionnez un fichier ou saisissez un mot de passe.


Options de traitement multifil (multi-thread)

Possibilités et restrictions pour le traitement multifil Files d'attente de traitement État de traitement des fils
Démarrer Précédent Suivant

Options de traitement multifil (multi-thread)

Si vous gérez un réseau contenant de nombreux appareils, SIMATIC Automation Tool peut simplifier et réduire le temps de pilotage en traitant automatiquement un groupe d'appareils avec des fils (threads) multiples. Pendant qu'un fil de traitement attend le message indiquant que la tâche d'un appareil SIMATIC est terminée, d'autres fils peuvent utiliser ce temps pour communiquer avec d'autres appareils du groupe.

Appareils dans un réseau à topologie en étoile

Si votre réseau possède une topologie en étoile dans laquelle chaque appareil est connecté directement à la console de programmation par un commutateur Ethernet, vous pouvez activer l'option de traitement multifil en toute sécurité.

Appareils dans un réseau à topologie en chaîne

Si votre réseau possède une topologie en chaîne, vous devez désactiver l'option multi-thread, afin d'éviter qu'un appareil n'interrompe la communication vers les autres appareils, comme décrit à la rubrique Paramètres de communication.

Possibilités et restrictions pour le traitement multifil

SIMATIC Automation Tool active le traitement multifil pour de nombreuses opérations. Pour d'autres opérations, vous devez activer le traitement multifil dans les Paramètres de communication. SIMATIC Automation Tool exécute les opérations vers plusieurs appareils de sécurité sur un fil unique pour chaque opération relative à chaque appareil. Vous ne pouvez pas activer le traitement multifil pour des opérations sur des appareils de sécurité.

Le tableau ci-dessous montre quand SIMATIC Automation Tool utilise le traitement multifil.

Légende :

✓ Traitement multi-thread permanent

O Traitement multi-thread possible, si activé dans Paramètres de communication.

X Opération de sécurité sur un appareil de sécurité : Traitement à thread unique uniquement.

Opération SIMATIC Automation Tool | Traitement multi-thread pour appareil standard | Traitement multi-thread pour appareil de sécurité
Scanner le réseau | ✓ | ✓
Identifier les appareils | ✓ | ✓
Mettre à jour les adresses des appareils | ✓ | ✓
Mettre à jour le nom PROFINET d'un appareil | ✓ | ✓
Régler l'heure de la CPU sur celle de la console de programmation | ✓ | ✓
Mettre à jour le programme pour une CPU | ✓ | X
Mettre à jour le programme pour des appareils IHM | ✓ | ✓
Charger, ajouter, remplacer ou supprimer des données de recette d'une CPU | ✓ | ✓
Charger ou supprimer les données de Data log d'une CPU | ✓ | ✓
Mettre à jour le firmware dans un appareil | O | O
Placer une CPU en mode RUN ou STOP | ✓ | ✓
Sauvegarder des données vers un fichier de sauvegarde pour une CPU ou un appareil IHM | ✓ | ✓
Restaurer la CPU à partir d'un fichier de sauvegarde | O | X
Restaurer l'appareil IHM à partir d'un fichier de sauvegarde | O | O
Afficher le tampon de diagnostic d'une CPU | ✓ | ✓
Réinitialiser la mémoire de la CPU | O | O
Récupérer les données de maintenance depuis une CPU | ✓ | ✓
Formater la carte mémoire dans une CPU (carte mémoire SIMATIC insérée dans une CPU) | O | X
Restaurer les paramètres d'usine | O | X
Réinitialiser les paramètres de communication | ✓ | ✓

Files d'attente de traitement

Vous pouvez sélectionner un groupe d'appareils standard et de sécurité dans les lignes de la table des appareils, puis lancer une opération. SIMATIC Automation Tool effectue la même opération sur tous les appareils du groupe. SIMATIC Automation Tool utilise deux files d'attente de traitement :

  • Une file d'attente prioritaire pour les appareils de sécurité, dédiée au traitement des opérations relatives à la sécurité (traitement à un fil uniquement)

  • Une file d'attente secondaire qui utilise de 1 à 5 threads pour les appareils standard et les appareils de sécurité permettant le traitement multi-thread.

SIMATIC Automation Tool traite d'abord la file d'attente des opérations de sécurité portant sur les appareils de sécurité à l'aide d'un fil de traitement unique. Le fil exécute une opération sur un appareil de sécurité à la fois.

Une fois que SIMATIC Automation Tool a terminé la file d'attente des opérations de sécurité portant sur les appareils de sécurité, il applique à la seconde file d'attente un traitement multifil.

Certaines opérations utilisent systématiquement le traitement multi-thread. D'autres l'utilisent si les Paramètres de communication autorisent plusieurs fils.

État de traitement des fils

Lorsque vous démarrez une opération sur un groupe d'appareils, SIMATIC Automation Tool affiche une boîte de dialogue indiquant, pour chaque file d'attente, le nombre d'appareils sur lesquels l'opération est terminée. La boîte de dialogue affiche aussi la progression du traitement (% achèvement) pour les fils de traitement actifs.


Opérations d'appareil

Opérations d'appareil

Ce chapitre contient des informations sur les sujets suivants :
  • Scanner un réseau
  • Insérer un appareil
  • Mise à jour des adresses IP, de sous-réseau et de passerelle
  • Mise à jour des noms d'appareils PROFINET
  • Réglage des CPU en mode RUN ou STOP
  • Identification des appareils
  • Mise à jour des programmes des appareils depuis SIMATIC Automation Tool
  • Charger, ajouter, remplacer et supprimer des recettes dans les CPU
  • Charger et supprimer des journaux de données (Data logs) dans les CPU
  • Installation de nouveaux firmware dans les appareils
  • Sauvegarde et restauration des données d'appareil
  • Réinitialisation des paramètres de communication
  • Effectuer un effacement général sur les CPU
  • Restauration des paramètres d'usine des appareils
  • Formatage d'une carte mémoire
  • Récupération des données de maintenance depuis des CPU
  • Réglage de l'heure des CPU sur celle de la console de programmation
  • Affichage du tampon de diagnostic
  • Affichage des références aux appareils
  • Copier et coller dans plusieurs cellules de la table des appareils
  • Ordre d'exécution des opérations


Scanner un réseau

Scanner le réseau Conventions applicables à la table des appareils Comprendre la table des appareils Périphérie PROFINET CPU de contrôleurs logiciels Actualiser les données de la table des appareils Erreurs de scan réseau
Démarrer Précédent Suivant

Scanner un réseau

La table des appareils pour un nouveau projet SIMATIC Automation Tool est vide. Pour commercer à travailler avec SIMATIC Automation Tool, vous scannez le réseau de communication afin de remplir la table des appareils. Vous pouvez également insérer un appareil manuellement.

Scanner le réseau

Pour scanner le réseau, sélectionnez la commande de menu "Opérations>Scanner le réseau>Scanner le réseau complet". Vous pouvez également cliquer sur le bouton Scan [image] dans la barre d'outils et sélectionner "Scan du réseau entier" dans le menu déroulant.

Remarque

SIMATIC Automation Tool est un outil hors ligne

Notez que SIMATIC Automation Tool n'effectue pas de mise à jour continue des données des appareils. SIMATIC Automation Tool affiche les informations sur les appareils au moment où vous avez scanné ou actualisé votre réseau de communication, ou au moment où vous avez inséré des appareils. TIA Portal ou le serveur Internet, par exemple, peuvent avoir modifié les données de vos appareils depuis votre dernier scan. Avant d'effectuer des opérations sur les appareils, scannez le réseau ou actualisez les appareils sur lesquels vous souhaitez effectuer des opérations.

Lorsque vous scannez le réseau, SIMATIC Automation Tool conserve les données des appareils du scan précédent jusqu'à ce qu'il actualise les données des appareils avec le nouveau scan. Si le scan échoue pour un appareil, celui-ci affiche les données du scan précédent et le journal d'événements signale une erreur.
Remarque

SIMATIC Automation Tool ne peut pas détecter les appareils derrière un routeur NAT (Network Address Translation)

SIMATIC Automation Tool détecte les appareils lors d'un scan réseau à l'aide d'une combinaison de l'adresse MAC et de l'adresse IP. Comme les routeurs NAT ne transmettent pas les commandes DCP, un scan réseau ne permet pas de détecter les appareils derrière les routeurs NAT.

Conventions applicables à la table des appareils

Des icônes de ligne vous aident à identifier les lignes de la table des appareils :

Appareil non reconnu ou non pris en charge entièrement. SIMATIC Automation Tool affiche en texte gris les données d'appareil.

Appareil de sécurité non reconnu ou non pris en charge entièrement. SIMATIC Automation Tool affiche en texte gris les données d'appareil.

Appareil PROFINET

Appareil PROFINET de sécurité

Appareil PROFINET IHM

Appareil PROFINET IHM de sécurité

Appareil PROFINET périphérie décentralisée

Appareil de sécurité PROFINET périphérie décentralisée

Dossier contenant les appareils contrôleurs PROFINET

Dossier contenant les appareils maître PROFIBUS

Dossier contenant les appareils maître AS-i PROFINET

Dossier contenant le Data Log ou les données de recette

Dossier contenant les modules de périphérie locale ou de périphérie décentralisée

Données du Data log

Données de recette

Les adresses IP et les noms de station PROFINET en double sont affichés en rouge.

Problème d'identification de l'appareil standard

Problème d'identification de l'appareil de sécurité

Remarque

Connexions en ligne vers les appareils depuis TIA Portal

Si un appareil possède une connexion en ligne dans TIA Portal, il est possible que SIMATIC Automation Tool ne puisse pas lire les informations de l'appareil. La table des appareils affiche l'icône indiquant que l'appareil n'est pas reconnu et signale une erreur dans le journal d'événements. L'erreur signifie que SIMATIC Automation Tool n'a pas pu déterminer l'identité de l'appareil.

Pour pouvoir lire l'appareil, passez en mode non connecté dans TIA Portal.

Cliquez sur la case située à côté de l'appareil que vous voulez sélectionner. SIMATIC Automation Tool affiche le texte sur l'appareil en noir pour les appareils que vous n'avez pas sélectionnés et en noir gras lorsque vous les avez sélectionnés.

Vous pouvez saisir du texte dans les cellules à fond gris clair. Vous ne pouvez pas saisir de texte dans les cellules à fond gris foncé. Une cellule à fond gris foncé indique que SIMATIC Automation Tool ne prend pas en charge l'opération pour ce type d'appareil / cette version de firmware.

Comprendre la table des appareils

Remarque

Effectuez un nouveau scan du réseau pour résoudre les problèmes d'identification des appareils.

Un problème d'identification de l'appareil peut se produire, p. ex. si TIA Portal a modifié le programme ou la configuration de l'appareil depuis le dernier scan du réseau par SIMATIC Automation Tool. Aucune opération, ni commande d'actualisation, n'est possible sur un appareil qui présente un problème d'identification. Vous devez scanner votre réseau pour résoudre le problème d'identification.

Appareils de sécurité

Lorsque vous modifiez l'identité d'un appareil ou l'état du programme de sécurité à partir de SIMATIC Automation Tool, l'outil effectue les modifications sans exécuter de nouveau scan réseau. Par exemple, si vous téléchargez une nouvelle version de firmware à partir de SIMATIC Automation Tool, SIMATIC Automation Tool met à jour les variables de l'appareil pour tenir compte des nouvelles valeurs. SIMATIC Automation Tool est un outil certifié pour l'exploitation des appareils de sécurité et peut gérer les changements d'état de sécurité.

Si vous avez une CPU de sécurité dans votre réseau mais que vous n'y avez pas chargé de programme de sécurité, les cellules de la ligne correspondant à l'appareil sont affichées en gris :

Si vous avez chargé un programme de sécurité dans une CPU de sécurité, les champs d'information de la ligne correspondant à l'appareil sont affichés en jaune :

Dans le cas des CPU de sécurité pour lesquelles il existe un programme de sécurité, les champs de saisie utilisateur suivants s'affichent initialement en gris. SIMATIC Automation Tool affiche ces champs de saisie utilisateur en jaune une fois que vous avez saisi des valeurs valides :

  • Mot de passe dans la CPU

  • Dossier de mise à jour du programme

  • Mot de passe dans le fichier de programme

  • Fichier de sauvegarde

Exemple :

Appareils connectés via des CPU et des routeurs d'adresses IP

Une fois que vous avez saisi des adresses IP valides dans l'onglet Adresse IP de la table des appareils, vous pouvez utiliser la commande de menu "Opérations > Mise à jour > Adresse IP" pour transférer les affectations d'adresse aux appareils directement connectés que vous avez sélectionnés. Vous pouvez également cliquer sur le bouton Mise à jour [image] et choisir la commande "Adresse IP" dans le menu déroulant.

Si les appareils du réseau pris en charge ont des adresses IP valides, un scan réseau affiche les appareils situés derrière les CPU et les routeurs d'adresse IP.

Appareils raccordés directement (notamment avec une connexion par un commutateur Ethernet)

Un appareil raccordé directement peut utiliser toutes les opérations sur adresse MAC que l'adresse IP soit configurée ou non. Lorsqu'une adresse IP est configurée, un appareil raccordé directement peut utiliser toutes les opérations sur adresse IP.

Un scan initial montre les appareils dans le réseau :

Effet d'un scan réseau sur la table des appareils

Si une adresse MAC existe déjà dans la table, un scan du réseau actualise les champs Adresse IP, Sous-réseau et Passerelle de la ligne de la table correspondant à cet appareil. Tous les autres champs de données sont conservés.

Si l'adresse MAC est nouvelle, SIMATIC Automation Tool crée une nouvelle ligne avec les champs Adresse MAC, Adresse IP, Sous-réseau et Passerelle. Tous les autres champs sont vides.

Développer les lignes d'appareil pour afficher les modules locaux, la périphérie décentralisée et les fichiers CPU (recettes et Data logs)

Cliquez sur l'icône [image] pour développer une ligne de la table des appareils. Cliquez sur l'icône [image] pour réduire une ligne de la table des appareils. Utilisez le menu contextuel (clic droit) ou le menu Éditer pour développer ou réduire tous les niveaux :

Identification par mot de passe

Si l'appareil est protégé par mot de passe, SIMATIC Automation Tool active le champ du mot de passe quel que soit le niveau de protection.

Périphérie PROFINET

Les périphériques PROFINET peuvent apparaître deux fois dans la table des appareils. L'appareil apparaît une fois sur une ligne de niveau supérieur où une connexion directe permet toutes les opérations SIMATIC Automation Tool prises en charge. Il apparaît également dans une ligne de niveau inférieur derrière une CPU (avec une adresse IP et une configuration matérielle valides), où une connexion indirecte autorise la seule opération de mise à jour du firmware. Les deux lignes de la table des appareils résultent des deux chemins de connexion différents qui sont possibles sur le réseau Ethernet.

Dans la table des appareils ci-dessous, SIMATIC Automation Tool affiche deux fois l'IM 155‑6 PN HF :

  • Dans une ligne de niveau supérieur comme "im 155-6 pn hf", où toutes les opérations prises en charge sont disponibles

  • dans une ligne de niveau inférieur comme "IM 155-6 PN HF" dans la périphérie I/O de PLC_1, où seule l'opération de mise à jour du firmware est possible

Appareils connectés indirectement

Les appareils aux niveaux inférieurs représentent les appareils et les fichiers de données CPU qui sont connectés indirectement à SIMATIC Automation Tool par le biais d'une CPU raccordée directement. Une CPU doit comporter une adresse IP et une configuration d'appareil valides pour que les appareils qui se connectent par son intermédiaire deviennent visibles dans la table des appareils.

Les appareils aux niveaux inférieurs peuvent représenter des périphériques décentralisés (périphériques PROFINET et PROFIBUS). Un module de périphérie décentralisée doit disposer d'une configuration IP pour que les périphériques décentralisés deviennent visibles dans la table des appareils.

CPU de contrôleurs logiciels

Pour que SIMATIC Automation Tool puisse communiquer avec les CPU de contrôleurs logiciels, votre console de programmation doit se connecter au contrôleur logiciel par le biais de l'interface Ethernet. Il s'agit typiquement de l'interface X1 ou X2. Selon l'appareil, l'interface est désignée par PROFINET (LAN) ou PN/IE (LAN). SIMATIC Automation Tool communique avec les Software Controller à l'aide de X2 et avec les Open Controller à l'aide de X1. Le catalogue des appareils énumère les CPU de contrôleurs logiciels prises en charge par SIMATIC Automation Tool, ainsi que les opérations sur appareil prises en charge.

Actualiser les données de la table des appareils

SIMATIC Automation Tool actualise les données dans les lignes de la table des appareils dans les cas suivants :

  • Lors d'un scan du réseau

  • Après avoir terminé une opération

  • Lorsque vous actualisez un ou plusieurs appareils

Pour actualiser les données de la table des appareils, choisissez l'une des méthodes suivantes :

  • Sélectionnez "Scanner le réseau complet" soit dans le menu déroulant [image] de la barre d'outils, soit dans le menu "Opérations > Scanner le réseau" pour actualiser tous les appareils.

  • Sélectionnez les appareils et sélectionnez "Rafraîchir l'état de tous les appareils sélectionnés" soit dans le menu déroulant [image] de la barre d'outils, soit dans le menu "Opérations > Scanner le réseau".

  • Sélectionnez la commande de menu Éditer>Rafraîchir ou faites un clic droit sur la ligne associée à un appareil et sélectionnez Rafraîchir dans le menu contextuel. Ensuite, choisissez l'une des options suivantes à partir de la commande de menu Actualiser :

    • Appareil

    • Tous les appareils sélectionnés - F5

    • Tous les appareils

  • Appuyez sur la touche F5 pour actualiser "Tous les appareils sélectionnés"

SIMATIC Automation Tool actualise les données qu'il lit sur les appareils et conserve tous les champs de données saisis par l'utilisateur.

Si vous actualisez des appareils qui ne sont plus présents sur le réseau, SIMATIC Automation Tool affiche les données de la ligne correspondante en italique.

Remarque

Actualisation des appareils sélectionnés

Vous pouvez uniquement actualiser les appareils sélectionnés de niveau supérieur. Si un appareil est subordonné à un autre appareil dans la table des appareils, vous ne pouvez pas actualiser l'appareil subordonné seul. Vous devez sélectionner l'appareil de niveau supérieur pour actualiser l'état de n'importe lequel de ses appareils subordonnés. Ainsi, si vous avez un module d'interface subordonné à une CPU, vous ne pouvez pas actualiser le module d'interface uniquement. Pour actualiser l'état du module d'interface, sélectionnez la CPU puis actualisez l'état de l'appareil sélectionné. SIMATIC Automation Tool actualise alors l'état de la CPU et de tous les appareils qui lui sont subordonnés.

Erreurs de scan réseau

Si une erreur de communication se produit avec un appareil alors que SIMATIC Automation Tool réalise un scan réseau, l'outil ajoute une entrée au journal d'événements. SIMATIC Automation Tool consigne les erreurs de scan dans le journal d'événements dans l'ordre où elles se produisent.


Insérer un appareil

Insérer un appareil

Vous pouvez insérer un appareil dans la table des appareils. Vous pouvez uniquement ajouter un appareil ayant une adresse MAC et une adresse IP uniques par rapport aux autres appareils répertoriés dans la table des appareils.

Pour insérer un appareil, procédez comme suit :

  1. Sélectionnez la commande "Ajouter > Appareil" soit dans le menu Éditer, soit dans le menu contextuel (clic droit) de la table des appareils.

  2. Dans la boîte de dialogue "Ajouter l'appareil", entrez soit une adresse IP soit une adresse MAC pour l'appareil. L'adresse que vous entrez ne doit pas correspondre à l'adresse d'un appareil déjà répertorié. Pour une adresse MAC, utilisez ":" comme séparateur et non "-".

SIMATIC Automation Tool rejette la tentative d'ajout d'un appareil qui n'a pas d'adresse unique ou d'adresse IP valide.

Lorsque vous entrez une adresse IP ou une adresse MAC unique, SIMATIC Automation Tool essaie de communiquer avec l'adresse que vous avez indiquée. Si la communication est établie avec succès, SIMATIC Automation Tool insère l'appareil dans la table des appareils. Si la tentative de communication échoue, SIMATIC Automation Tool vous informe que l'appareil n'existe pas dans le réseau.

Si l'appareil se trouve derrière un routeur, SIMATIC Automation Tool affiche le nom de l'appareil en bleu.

Remarque

SIMATIC Automation Tool ne peut pas insérer d'appareils derrière un routeur NAT (Network Address Translation)

SIMATIC Automation Tool détecte les appareils lors d'un scan réseau à l'aide d'une combinaison de l'adresse MAC et de l'adresse IP. Comme les routeurs NAT ne transmettent pas les commandes DCP, vous ne pouvez pas insérer un appareil se trouvant derrière un routeur NAT.


Mise à jour des adresses IP, de sous-réseau et de passerelle

Configurer l'adresse IP sur des appareils pris en charge Configurer l'adresse IP sur des appareils non pris en charge Adresse IP après une mise hors tension/sous tension
Démarrer Précédent Suivant

Mise à jour des adresses IP, de sous-réseau et de passerelle

Pour pouvoir définir une adresse IP d'appareil qui reste permanente après une mise hors tension/sous tension, la configuration de l'appareil dans le projet STEP 7 doit indiquer que l'adresse IP est définie sur l'appareil. Si le projet STEP 7 sur l'appareil ne permet pas d'activer ce réglage, vous pouvez définir une adresse IP avec SIMATIC Automation Tool, mais uniquement de façon temporaire, jusqu'à la mise hors tension/sous tension suivante.

Configurer l'adresse IP sur des appareils pris en charge

Pour configurer l'adresse IP d'un appareil, procédez comme suit :

  1. Cliquez sur l'onglet "Configurer l'adresse IP".

  2. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  3. Saisissez des valeurs dans les colonnes "Nouvelle adresse IP", "Nouveau sous-réseau" et "Nouvelle passerelle". Notez que vous n'entrez pas d'interface de communication telle que "X1" ou "X2" quand vous entrez la nouvelle adresse IP.

    Si vous entrez une syntaxe invalide, SIMATIC Automation Tool affiche le champ en rouge. Corrigez les erreurs si nécessaire.

  4. Sélectionnez Mettre à jour dans le menu Opérations ou cliquez sur le Mettre à jour dans la barre d'outils [image] et sélectionnez "Configurer l'adresse IP" dans le menu déroulant.

L'opération de mise à jour définit les adresses IP, de sous-réseau et de passerelle dans les appareils sélectionnés.

Le journal d'événements sous la table des appareils montre le résultat de cette opération.

Dupliquer les adresses IP

Lorsque plusieurs appareils ont la même adresse IP, les adresses sont indiquées en rouge, comme le montre l'image suivante.

Vous pouvez sélectionner les appareils qui présentent des adresses IP en double, mettre à jour les adresses IP et corriger le problème réseau. Seules les opérations suivantes sont possibles sur les appareils qui présentent des adresses IP identiques :

  • Supprimer

  • Configurer l'adresse IP

  • Définir le nom PROFINET

  • Identifier les appareils

Aucune autre opération n'est possible sur les appareils qui présentent des adresses IP identiques.

Configurer l'adresse IP sur des appareils non pris en charge

Les opérations sur l'adresse MAC utilisent le protocole DCP (Discovery and Configuration Protocol). Le DCP est un standard Ethernet. SIMATIC Automation Tool peut utiliser les opérations DCP-MAC Mettre à jour l'adresse IP pour tous les appareils réseau raccordés directement (CPU, HMI, périphérie décentralisée et autres appareils).

Sélectionnez la ligne de l'appareil non pris en charge, entrez les nouvelles données dans la colonne appropriée et mettez à jour l'adresse IP de l'appareil non pris en charge de la même manière que vous mettez à jour les appareils pris en charge.

Les appareils non pris en charge risquent de ne pas accepter une modification fondée sur la configuration matérielle de l'appareil.

Par défaut, SIMATIC Automation Tool affiche les appareils non pris en charge. Vous pouvez désactiver cette option dans Paramètres généraux

Remarque

SIMATIC Automation Tool ne peut pas collecter certaines informations en provenance d'appareils connectés derrière un routeur IP, car les commandes DCP ne sont pas routables.

Par exemple, SIMATIC Automation Tool utilise DCP pour lire l'adresse de passerelle par défaut d'un appareil. Or DCP n'est pas un protocole apte au routage. SIMATIC Automation Tool ne peut donc pas lire les informations d'appareils connectés derrière un routeur. Dans ce cas, les champs de la table des appareils correspondants sont vides.

Adresse IP après une mise hors tension/sous tension

La configuration de l'appareil du projet STEP 7 détermine comment l'appareil utilise l'adresse IP que vous définissez dans SIMATIC Automation Tool. Lorsque vous définissez une adresse IP pour un appareil dans SIMATIC Automation Tool, les conséquences de la mise hors tension/sous tension de l'appareil suivante sont :

Configuration des appareils STEP 7 | Adresse IP après une mise hors tension/sous tension
Adresse IP définie directement sur l'appareil (ou équivalent) | L'adresse IP que vous définissez dans SIMATIC Automation Tool est l'adresse IP de l'appareil.
Configurer l'adresse IP dans le projet (ou équivalent) | L'adresse IP dans la configuration de l'appareil dans le projet STEP 7 est l'adresse IP.


Mise à jour des noms d'appareils PROFINET

Définir le nom PROFINET Définir le nom PROFINET d'appareils non pris en charge
Démarrer Précédent Suivant

Mise à jour des noms d'appareils PROFINET

Notez que, pour modifier un nom d'appareil PROFINET, la configuration d'appareil dans le projet TIA Portal téléchargé doit prendre en charge cette modification.

Les noms PROFINET valides suivent les conventions de dénomination standard du système DNS (Domain Name System). Si vous entrez un nom invalide, SIMATIC Automation Tool le convertit en nom PROFINET valide. Vous pouvez voir le nom converti dans la colonne Nom PROFINET converti.

Règles de noms PROFINET

Le nombre maximal de caractères pour le nom de l'appareil est de 63. Les caractères valides sont les minuscules de "a" à "z", les chiffres 0 à 9, le tiret (signe moins) et la virgule.

Noms invalides

  • Le nom ne doit pas avoir le format n.n.n.n, avec une valeur allant de 0 à 999.

  • Le nom ne peut pas commencer par la chaîne port-nnn ou la chaîne port-nnnnnnnn, n étant un chiffre compris entre 0 et 9. Par ex., "port-123" et "port-123-45678" sont des noms invalides.

  • Un nom ne peut commencer ou se terminer par un tiret "-" ou un point ".".

Définir le nom PROFINET

Procédez comme suit pour définir le nom PROFINET pour un ou plusieurs appareils :

  1. Cliquez sur l'onglet "Définir le nom PROFINET".

  2. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  3. Saisissez un nouveau nom PROFINET dans la colonne "Nouveau nom PROFINET".

  4. Sélectionnez Mettre à jour dans le menu Opérations ou cliquez sur le bouton Mettre à jour dans la barre d'outils [image] et sélectionnez "Nom PROFINET" dans le menu déroulant.

L'opération de mise à jour définit les nouveaux noms PROFINET sur les appareils sélectionnés. Si vous entrez un nom PROFINET invalide selon les règles de dénomination PROFINET, SIMATIC Automation Tool corrige le nom en nom valide. La colonne "Nom PROFINET converti" affiche le nom converti.

Le journal d'événements sous la table des appareils montre le résultat de cette opération.

Noms PROFINET identiques

SIMATIC Automation Tool indique en rouge les appareils qui présentent des noms PROFINET identiques. SIMATIC Automation Tool prend en charge la pleine fonctionnalité de ces appareils et affiche toutes les autres informations :

Définir le nom PROFINET d'appareils non pris en charge

Les opérations sur l'adresse MAC utilisent le protocole DCP (Discovery and Configuration Protocol). Le DCP est un standard Ethernet. SIMATIC Automation Tool peut utiliser les opérations DCP basées sur l'adresse MAC, Scan du réseau entier, Identifier, Mettre à jour l'adresse IP et Mettre à jour le nom PROFINET, pour tous les appareils réseau connectés directement (CPU, IHM, périphérie décentralisée et autres appareils).

Sélectionnez la ligne de l'appareil non pris en charge, entrez les nouvelles données dans la colonne appropriée et mettez à jour le nom PROFINET de l'appareil non pris en charge, de la même manière que vous mettez à jour les appareils pris en charge.

Les appareils non pris en charge risquent de ne pas accepter une modification fondée sur la configuration matérielle de l'appareil.

Par défaut, SIMATIC Automation Tool affiche les appareils non pris en charge. Vous pouvez désactiver cette option dans Paramètres généraux.


Réglage des CPU en mode RUN ou STOP

Bascule des CPU en mode RUN ou STOP

Réglage des CPU en mode RUN ou STOP

Bascule des CPU en mode RUN ou STOP

Pour modifier l'état de fonctionnement d'un appareil, procédez comme suit :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Pour chaque CPU sélectionnée, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU" de l'onglet ouvert.

  3. Définissez le mode de fonctionnement, en choisissant entre mode RUN (MARCHE) et mode STOP (ARRÊT) :

    • Dans le menu Opérations, sélectionnez RUN ou cliquez sur le bouton RUN [image] de la barre d'outils. Pour que la CPU passe en mode RUN, il faut qu'un programme valide existe.

    • Dans le menu Opérations, sélectionnez STOP ou cliquez sur le bouton STOP [image] de la barre d'outils.

SIMATIC Automation Tool configure les CPU sélectionnées en mode RUN ou STOP.

Les colonnes Mode et État de fonctionnement dans la table des appareils indiquent l'état actuel de la CPU :

  • Jaune : état STOP

  • Vert : état RUN

  • Rouge : défaut CPU

Le journal d'événements (Event Log) sous la table des appareils montre le résultat de cette opération.


Identification des appareils

Identifier un appareil avec des LED clignotantes ou des LED d'écran HMI Identifier les appareils non pris en charge en faisant clignoter les LED ou les écrans HMI
Démarrer Précédent Suivant

Identification des appareils

Pour les appareils de niveau supérieur dans la table des appareils, l'opération Identifier vous aide à localiser physiquement des appareils dans le réseau.

Identifier un appareil avec des LED clignotantes ou des LED d'écran HMI

Vous pouvez utiliser l'opération Identifier en mode RUN et en mode STOP. Procédez comme suit pour identifier les appareils :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Sélectionnez la commande de menu "Opérations> Identifier" ou cliquez sur le bouton [image] de la barre d'outils pour identifier les appareils sélectionnés.

Les CPU, les appareils SCALANCE et d'autres appareils font clignoter leur LED pour signaler leur emplacement. Les appareils IHM font clignoter leur écran.

Le clignotement continue jusqu'à ce que vous cliquiez sur le bouton Fermer.

Identifier les appareils non pris en charge en faisant clignoter les LED ou les écrans HMI

Les opérations sur l'adresse MAC utilisent le protocole DCP (Discovery and Configuration Protocol). Le DCP est un standard Ethernet. SIMATIC Automation Tool peut utiliser les opérations DCP basées sur l'adresse MAC, Scan du réseau entier, Identifier, Mettre à jour l'adresse IP et Mettre à jour le nom PROFINET, pour tous les appareils réseau connectés directement (appareils PROFINET pris en charge, appareils PROFINET non pris en charge et appareils Ethernet non Siemens non pris en charge).

Pour identifier un appareil non pris en charge, de la même manière que vous identifiez les appareils pris en charge.

Les appareils non pris en charge risquent de ne pas activer leurs LED en fonction de la configuration matérielle de l'appareil.

Par défaut, SIMATIC Automation Tool affiche les appareils non pris en charge. Vous pouvez désactiver cette option dans Paramètres généraux.


Mise à jour des programmes des appareils depuis SIMATIC Automation Tool

Exemple : Préparation d'un programme CPU pour une utilisation avec SIMATIC Automation Tool Exemple : Préparer le système d'exploitation et le logiciel exécutif d'un appareil IHM en vue de leur utilisation avec SIMATIC Automation Tool Mettre à jour le programme de CPU ou le système d'exploitation et le logiciel runtime d'un appareil IHM Validation du programme Gestion des mots de passe après l'opération de mise à jour du programme Validation de la signature de sécurité Règles de mise à jour du programme de CPU Effet de la mise à jour du programme sur l'adresse IP Exemple : Mise à jour du programme
Démarrer Précédent Suivant

Mise à jour des programmes des appareils depuis SIMATIC Automation Tool

Avant de pouvoir transférer un programme sur une CPU à l'aide de SIMATIC Automation Tool, vous devez avoir accès au programme sur l'un des supports suivants :

  • Carte mémoire SD SIMATIC

  • un lecteur flash USB

  • un disque dur de votre console de programmation

Exemple : Préparation d'un programme CPU pour une utilisation avec SIMATIC Automation Tool

Cet exemple utilise une carte mémoire SD SIMATIC pour le transfert. Vous pouvez aussi effectuer le transfert vers une clé USB ou un dossier Windows sur votre console de programmation.

Pour transférer un projet STEP 7 d'une CPU vers une carte mémoire SIMATIC, procédez comme suit :

  1. Insérez une carte mémoire SIMATIC dans le lecteur de carte de votre console de programmation.

  2. À partir de STEP 7, sélectionnez la CPU dans le navigateur du projet.

  3. Sélectionnez la commande de menu "Projet > Card Reader/Mémoire USB > Écrire sur la carte mémoire" :

  4. Sélectionnez votre carte mémoire dans la boîte de dialogue :

STEP 7 enregistre un dossier SIMATIC.S7S sur votre carte mémoire SIMATIC, qui contient votre projet de CPU. Vous pouvez également copier le projet STEP 7 vers la carte mémoire en faisant glisser le projet vers la carte mémoire dans l'arborescence de projet.

Pour plus d'informations, reportez-vous au Système d'information STEP 7 (aide en ligne).

Une fois que STEP 7 a transféré les données de programme sur un support de stockage, vous pouvez utiliser l'Explorateur de fichiers Windows pour transférer le programme dans le dossier utilisé par SIMATIC Automation Tool.

Copie du dossier "SIMATIC.S7S" pour chaque programme de CPU

Procédez comme suit pour rendre un programme CPU accessible à SIMATIC Automation Tool :

  1. Créer des sous-dossiers sous Dossier de mise à jour du programme. Créez un dossier par programme et créez un nom de dossier qui identifie le programme. Les noms des dossiers que vous créez sont affichés dans la liste déroulante de SIMATIC Automation Tool.

  2. Utilisez l'Explorateur de fichiers Windows pour copier le dossier "SIMATIC.S7S" (avec tous les sous-dossiers et fichiers) dans chaque sous-dossier pour chaque programme. Vous pouvez placer un programme TIA Portal (un dossier "SIMATIC.S7S") dans un fichier d'archive compressé et l'extraire vers l'emplacement de votre sous-dossier. Notez qu'il s'agit d'une opération distincte de celle consistant à mettre à jour les données de recette.

Voir plus loin la partie "Exemple de mise à jour du programme de CPU".

Remarque

Données de programmation STEP 7

Les données du programme sont protégées. Il n'est pas possible de détecter certaines informations telles que le nom du projet ou la CPU cible d'un programme STEP 7 à partir des données enregistrées dans un dossier SIMATIC.S7S. Vous ne pouvez pas distinguer un dossier SIMATIC.S7S d'un autre dossier SIMATIC.S7S.
Vous devez créer et nommer les sous-dossiers sous le dossier SIMATIC Automation Tool de mise à jour du programme qui identifie la fonction du programme ou la CPU cible. Copiez un dossier SIMATIC.S7S du programme dans le sous-dossier que vous avez nommé. Les noms des sous-dossiers que vous créez sont affichés sur la liste déroulante "Programme" de SIMATIC Automation Tool et indiquent le chemin d'accès vers le dossier SIMATIC.S7S correct.

Exemple : Préparer le système d'exploitation et le logiciel exécutif d'un appareil IHM en vue de leur utilisation avec SIMATIC Automation Tool

Cet exemple utilise une carte mémoire SD SIMATIC pour le transfert. Vous pouvez aussi effectuer le transfert vers une clé USB ou un dossier Windows sur votre console de programmation.

Les appareils IHM v 14 et supérieures prennent en charge la sauvegarde du système d'exploitation et du logiciel d'exécution depuis STEP 7.

Pour copier le système d'exploitation et les fichiers d'exécution d'un appareil IHM sur une carte mémoire SIMATIC, procédez comme suit :

  1. Insérez une carte mémoire SIMATIC dans le lecteur de carte de votre console de programmation.

  2. Développez "Card Reader/Mémoire USB" dans l'arborescence du projet pour afficher le lecteur correspondant à votre lecteur de carte.

  3. Sélectionnez votre IHM dans l'arborescence du projet et faites-le glisser vers la lettre de lecteur de votre lecteur de carte.

STEP 7 enregistre un dossier SIMATIC.HMI sur votre carte mémoire SIMATIC, qui contient votre logiciel d'exécution IHM et votre système d'exploitation IHM. Les mises à jour IHM comprennent le système d'exploitation et les données de runtime. Vous ne pouvez pas choisir une mise à jour partielle.

Une fois que TIA Portal a transféré le dossier SIMATIC.HMI sur un support de stockage, utilisez l'Explorateur de fichiers Windows pour rendre le dossier SIMATIC.HMI accessible à SIMATIC Automation Tool :

  1. Créez un sous-dossier pour le dossier IHM dans le dossier Mise à jour du programme.

  2. Copiez le dossier SIMATIC.HMI dans le sous-dossier.

Si vous souhaitez utiliser la partie firmware (système d'exploitation) du dossier SIMATIC.HMI pour mettre à jour le firmware d'un appareil HMI, effectuez les étapes suivantes :

  1. Naviguez dans le dossier "Firmware" du dossier SIMATIC.HMI jusqu'au fichier .fwf.

  2. Copiez le fichier .fwf dans le dossier Mise à jour du firmware.

Mettre à jour le programme de CPU ou le système d'exploitation et le logiciel runtime d'un appareil IHM

Si votre réseau présente une topologie en chaîne et que les Paramètres de communication activent le traitement multi-thread (multifil), prenez garde au risque d'interruption de communication lors de cette opération.

Remarque

Appareils de sécurité

Si la CPU de sécurité est protégée, vous devez entrer le mot de passe de CPU F de sécurité dans la colonne "Mot de passe dans la CPU" pour mettre à jour le programme dans un appareil de sécurité.

Vous devez confirmer une invite supplémentaire pour les mises à jour de programme pour les CPU F et sélectionner de nouveau votre appareil dans les conditions suivantes :

  • Vous mettez à jour un programme de sécurité avec un autre programme de sécurité

  • Vous mettez à jour un programme de sécurité avec un programme standard

  • Vous chargez un programme de sécurité pour la première fois

  • Vous mettez à jour un programme standard qui nécessite le mot de passe CPU pour le niveau d'accès "Accès complet, y compris failsafe (pas de protection)".

SIMATIC Automation Tool place les demandes de mise à jour du programme pour les appareils de sécurité dans la file d'attente des opérations relatives à la sécurité des CPU F. SIMATIC Automation Tool utilise uniquement le traitement séquentiel à thread unique pour la file d'attente d'opérations de sécurité.

L'appareil de destination pour un programme de sécurité doit être une CPU de sécurité.

Attention

Vérifiez qu'aucun appareil ne soit en train d'exécuter un processus avant de mettre à jour le programme.

L'installation d'un nouveau programme fait passer les CPU à l'arrêt, ce qui peut affecter l'exécution d'un processus ou d'une machine en ligne. dont la mise en route inattendue peut entraîner la mort, des blessures graves et des dommages matériels importants.
Remarque

Paramètres de transfert pour un appareil IHM (pupitre SIMATIC)

Pour communiquer avec une IHM, vous devez définir les paramètres de transfert sur l'appareil IHM à PN/IE ou Ethernet. Vous devez donner la même valeur aux paramètres de communication pour le mode de transfert IHM.

Une fois que vous avez stocké les données du programme dans le dossier de mise à jour, vous pouvez utiliser SIMATIC Automation Tool pour charger de nouveaux programmes sur un ou plusieurs appareils. Procédez comme suit pour mettre à jour le programme :

  1. Cliquez sur l'onglet "Mettre à jour le programme".

  2. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  3. Pour chaque appareil sélectionné, utilisez la colonne "Dossier de mise à jour du programme" de la liste déroulante pour choisir un nom de dossier. La liste déroulante affiche les dossiers que vous avez créés sous le chemin d'accès vers la mise à jour des programmes.

    Vous pouvez également utiliser le bouton Parcourir [image] pour accéder au dossier où vous avez stocké un programme sur votre console de programmation. Lorsque vous sélectionnez un programme, SIMATIC Automation Tool l'ajoute à la liste déroulante. Si le fichier sélectionné porte le même nom qu'un fichier de la liste, SIMATIC Automation Tool ajoute un chiffre au nouveau fichier afin que le nom reste univoque. Pour vous aider à identifier les fichiers, lorsque vous faites passer votre curseur sur le nom du programme dans le champ Mettre à jour le programme, une info-bulle affiche les informations d'interface et l'IP de l'appareil, par exemple :

    Si le fichier de programme ne contient pas d'adresse IP, l'info-bulle affiche "Défini directement sur l'appareil" pour tous les champs d'adresse IP.

  4. Le cas échéant, entrez les mots de passe dans les colonnes "Mot de passe dans la CPU" et "Mot de passe dans le fichier de programme". L'opération de mise à jour du programme est liée à la sécurité. S'il s'agit d'un appareil de sécurité, vous devez entrer le mot de passe de CPU F de sécurité.

  5. Sélectionnez la commande de menu "Opérations > Mettre à jour > Mettre à jour le programme" pour démarrer l'opération. Vous pouvez également sélectionner le bouton Mise à jour [image] de la barre d'outils et choisir "Mise à jour du programme" dans le menu déroulant.

Le journal d'événements sous la table des appareils montre le résultat de cette opération.

Validation du programme

SIMATIC Automation Tool vérifie les données du programme avant de mettre à jour le programme dans une CPU.

S'il y a une erreur dans les données du programme, SIMATIC Automation Tool affiche une icône "X" rouge dans la cellule "Dossier de mise à jour du programme". Des informations supplémentaires sur l'erreur s'affichent dans une info-bulle lorsque vous passez le curseur sur la cellule.

Gestion des mots de passe après l'opération de mise à jour du programme

Un fichier programme peut avoir un mot de passe, qui peut être différent du mot de passe actuel de la CPU. Lorsqu'un fichier programme comporte un mot de passe, vous devez entrer le mot de passe du programme dans la cellule "Mot de passe dans le fichier de programme" pour effectuer une mise à jour du programme. Le mot de passe du programme devient le mot de passe de la CPU une fois que l'opération Mise à jour du programme est terminée.

Une fois que l'opération Mise à jour du programme est terminée avec succès, SIMATIC Automation Tool copie automatiquement le Mot de passe dans le fichier de programme vers le champ de mot de passe de la CPU et effectue une tentative de connexion à l'aide du nouveau mot de passe. SIMATIC Automation Tool efface alors le champ Mot de passe dans le fichier de programme et le champ Dossier de mise à jour du programme .

Si le mot de passe que vous entrez dans la colonne "Mot de passe dans le fichier de programme" n'est pas le mot de passe configuré pour le projet dans STEP 7, l'Event Log affiche un avertissement une fois l'opération terminée. Dans ce cas, le mot de passe CPU comporte un X en rouge qui signale un mot de passe invalide.

Validation de la signature de sécurité

Un projet TIA Portal qui contient un programme de sécurité comporte une signature de sécurité, qui sert à vérifier les données dans un programme copié et renforce le niveau de sécurité pour des programmes de sécurité. Après une opération de mise à jour du programme, la signature de sécurité dans le projet est comparée à la signature de sécurité qui vient d'être chargée sur l'appareil CPU.

SIMATIC Automation Tool signale une comparaison réussie dans l'Event Log comme "Résultat de la comparaison CRC : les signatures de sécurité globales en ligne et hors ligne ne correspondent pas".

Lorsqu'elle échoue, la comparaison est indiquée comme suit dans l'Event Log par SIMATIC Automation Tool : "Résultat de la comparaison CRC : les signatures de sécurité globales en ligne et hors ligne ne correspondent pas.". Dans ce cas, restaurez les paramètres d'usine de l'appareil et relancez la mise à jour du programme.

Attention

Assurez-vous de charger le bon programme de sécurité.

Le fait de faire fonctionner le mauvais programme sur une CPU F peut affecter le fonctionnement d'un processus ou d'une machine. Le démarrage inattendu d'un processus ou d'une machine peut entraîner la mort ou des dommages corporels et/ou matériels.

N'essayez pas de passer en mode RUN si vous n'êtes pas certain(e) d'avoir chargé le bon programme.

Règles de mise à jour du programme de CPU

SIMATIC Automation Tool prend en charge l'opération de mise à jour du programme pour les CPU standard et les CPU de sécurité.

Prenez en compte les règles de mise à jour du programme suivantes :

  • La version de firmware du matériel de la CPU doit être supérieure ou égale à celle du projet à télécharger. Vous pouvez contourner cette restriction en mettant à jour le firmware dans la CPU si cela est possible.

  • Le catalogue des appareils montre les appareils qui prennent en charge les mises à jour de programme. Vous pouvez accéder au catalogue des appareils depuis le Menu Aide.

Effet de la mise à jour du programme sur l'adresse IP

Avant une mise à jour de programme, le projet STEP 7 dans la CPU a un réglage dans la configuration de l'appareil indiquant comment l'adresse IP est définie. En résumé, la configuration est l'une des suivantes :

  • Configurer l'adresse IP dans le projet (ou équivalent)

  • Adresse IP définie directement sur l'appareil (ou équivalent)

Le programme en cours de mise à jour peut avoir un réglage différent de la configuration de l'appareil du projet qui se trouve actuellement sur la CPU. De plus, un utilisateur peut avoir mis à jour l'adresse IP de l'appareil avec SIMATIC Automation Tool. Dans ce cas, l'adresse de l'appareil mise à jour par l'utilisateur est actuellement dans la CPU.

L'adresse IP de l'appareil après une mise à jour du programme et après un redémarrage consécutif de la CPU dépend du réglage du nouveau programme et de l'adresse IP actuelle. Le tableau suivant décrit les différentes possibilités pour l'adresse IP de l'appareil.

Configuration de l'appareil dans le nouveau programme pour la mise à jour | Adresse IP après mise à jour du programme | Adresse IP après le redémarrage de la CPU suite à la mise jour du programme
Configurer l'adresse IP dans le projet | L'adresse IP est celle du programme nouvellement mis à jour. | L'adresse IP est celle du programme nouvellement mis à jour.
Adresse IP définie directement sur l'appareil | L'adresse IP est celle de l'appareil avant la mise à jour du programme. | L'adresse IP est celle de l'appareil avant la mise à jour du programme.

Exemple : Mise à jour du programme

Si vous voulez disposer de cinq programmes de CPU différents pour la Mise à jour du programme, vous devez créer et nommer cinq dossiers dans le Dossier de mise à jour du programme. Copiez tous les dossiers "SIMATIC.S7S" dans les cinq dossiers correspondants.

Dans l'exemple, les noms de dossier "Program1", "Program2", "Program3", "Program4" et "Program5" identifient les programmes disponibles. Vous pouvez choisir un nom de dossier quelconque. Le nom de dossier peut renvoyer à une fonction du programme ou à un emplacement sur la CPU.

La figure suivante montre la vue de l'Explorateur de fichiers Windows avec les sous-dossiers du dossier Programs. Vous copiez les dossiers programme SIMATIC.S7S correspondants dans ces dossiers :

Si vous utilisez Windows 10, la vue de l'Explorateur de fichiers est différente mais la copie des fichiers se fait dans la même structure de dossiers.

L'image suivante montre l'onglet Mettre à jour le programme de SIMATIC Automation Tool avec les exemples de noms de dossiers dans la liste déroulante de la colonne "Mettre à jour le nouveau programme". Vous devez utiliser la liste déroulante dans la colonne "Mettre à jour le nouveau programme" pour définir le programme à utiliser. Si plusieurs lignes de CPU sont sélectionnées, vous devez répéter la procédure et affecter le bon programme à chaque CPU sélectionnée.

Sélectionnez la commande de menu "Opérations > Mettre à jour > Mettre à jour le programme" pour lancer la mise à jour du programme. Vous pouvez également cliquer sur le bouton de barre d'outils Mettre à jour et sélectionner "Mettre à jour le programme" dans le menu déroulant.

Le processus est similaire pour les données IHM. Le nom du dossier dans un dossier de projet est "SIMATIC.HMI" au lieu de "SIMATIC.S7S". La procédure est la même.


Charger, ajouter, remplacer et supprimer des recettes dans les CPU

Actions de la barre d'outils Charger ou supprimer les fichiers recette Ajouter ou remplacer (télécharger) des fichiers recette
Démarrer Précédent Suivant

Charger, ajouter, remplacer et supprimer des recettes dans les CPU

Les opérations de recette fonctionnent pour les CPU qui possèdent des recettes dans une mémoire de chargement externe (carte mémoire SIMATIC). La CPU peut être à l'état RUN ou à l'état STOP.

Les données de recette sont des fichiers au format .csv (valeurs séparées par des virgules).

Vous pouvez ajouter ou remplacer plusieurs recettes en une seule opération si elles se trouvent toutes sur différentes CPU. Vous ne pouvez pas ajouter ni remplacer plus d'une recette dans une CPU en une seule opération.

Vous pouvez sélectionner plusieurs recettes à charger ou supprimer dans une CPU en une seule opération.

Lorsque vous sélectionnez un fichier de recette ou un dossier de recette, SIMATIC Automation Tool affiche en gras la ligne correspondante dans la table des appareils.

Pour le téléchargement, cliquez sur l'onglet Recette et sélectionnez un dossier Recette.

SIMATIC Automation Tool crée un nom de dossier unique pour chaque CPU, dans lequel sont stockés les fichiers de recette chargés sur votre console de programmation. Le nom de fichier comprend le nom de la CPU et l'adresse MAC. Si vous sélectionnez et chargez le même fichier de recette une deuxième fois, SIMATIC Automation Tool ajoute un chiffre au nom pour conserver l'univocité des noms de fichiers.

SIMATIC Automation Tool doit avoir un accès en lecture pour charger les fichiers de recette. SIMATIC Automation Tool doit avoir un accès complet (lecture et écriture) pour supprimer, ajouter, ou remplacer les fichiers recette. Vous aurez peut-être besoin de saisir un mot de passe pour pouvoir effectuer une opération de suppression ou d'ajout / de remplacement. Si vous n'entrez pas de mot de passe ou si le mot de passe ne permet pas l'accès en écriture sur la CPU, l'opération va échouer pour cette CPU et un message d'erreur sera entré dans le journal des événements (Event Log).

Actions de la barre d'outils

Dans le menu déroulant de barre d'outils "Opérations sur fichier" [image], vous avez les choix suivants :

  • Charger les recettes : copie les fichiers recette sélectionnés d'une CPU dans le dossier recette de votre console de programmation.

  • Ajouter/remplacer recette (choix disponible lorsque l'onglet Charger la recette est affiché) : copie les fichiers recette sélectionnés de votre console de programmation dans une CPU.

  • Supprimer les recettes : supprime les fichiers recette sélectionnés d'une CPU.

Charger ou supprimer les fichiers recette

Pour charger ou supprimer les fichiers recette d'une CPU, procédez comme suit :

  1. Cliquez sur l'onglet "Charger la recette" sur la table des appareils.

  2. Développez une ligne d'appareil CPU et affichez un dossier recette [image].

  3. Développez un dossier recette et sélectionnez les fichiers recette [image] à inclure dans l'opération.

  4. Pour chaque CPU sélectionnée, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU".

  5. Sélectionnez la commande de menu "Opérations > Opérations sur fichier" ou cliquez sur le bouton de barre d'outils "Opérations sur fichier" :

  6. Sélectionnez soit "Charger les recettes" soit "Supprimer la recette" dans le menu Opérations sur fichier.

Le journal d'événements (Event Log) sous la table des appareils montre le résultat de cette opération.

Ajouter ou remplacer (télécharger) des fichiers recette

Pour ajouter ou remplacer des fichiers de recette CPU parmi les fichiers présents sur votre console de programmation, procédez comme suit :

  1. Copiez les fichiers de données de recette .csv que vous souhaitez ajouter ou remplacer dans une CPU vers le dossier recettes.

  2. Cliquez sur l'onglet "Charger la recette" dans la table des appareils.

  3. Développez le dossier Recettes [image] pour la CPU.

  4. Sélectionnez le fichier recette que vous souhaitez charger.

  5. Pour chaque fichier recette sélectionné, cliquez sur la liste déroulante dans la colonne "Ajouter/remplacer une recette" et sélectionnez un nom de fichier de recette. La liste déroulante affiche les noms des fichiers .csv qui existent dans le chemin de répertoire défini dans la partie Recettes de la boîte de dialogue "Options > Paramètres".
    Vous pouvez également utiliser le bouton Parcourir     [image] pour accéder au dossier contenant les fichiers recette stockés sur votre console de programmation. SIMATIC Automation Tool ajoute le fichier sélectionné à la liste déroulante. Si le fichier sélectionné porte le même nom qu'un fichier de la liste, SIMATIC Automation Tool ajoute un chiffre au nouveau fichier afin que le nom reste univoque. Pour vous aider à identifier les fichiers, une info-bulle affiche le chemin d'accès complet et le nom du fichier.

  6. Sélectionnez la commande de menu "Opérations > Opérations sur fichier" ou cliquez sur le bouton de barre d'outils "Opérations sur fichier" :

  7. Sélectionnez soit "Ajouter/remplacer une recette" dans le menu Opérations sur fichier.

S'il s'agit d'une recette existante, SIMATIC Automation Tool la remplace. S'il ne s'agit pas d'une recette existante, SIMATIC Automation Tool l'ajoute.

Le journal d'événements sous la table des appareils montre le résultat de cette opération.

Une fois que l'opération de téléchargement de recette est terminée avec succès, le chemin du fichier recette est supprimé.

Attention

Note de sécurité

Le fait de faire fonctionner un processus ou une machine avec des données corrompues peut affecter l'exécution d'un processus ou le fonctionnement d'une machine en ligne. Le démarrage inattendu d'un processus ou d'une machine peut entraîner la mort ou des dommages corporels et/ou matériels.

Suivez les étapes pour protéger les fichiers .csv de recette d'une éventuelle compromission, notamment en limitant l'accès au réseau ou en utilisant des pare-feux.


Charger et supprimer des journaux de données (Data logs) dans les CPU

Charger et supprimer des journaux de données (Data logs) dans les CPU

L'opération de chargement du Data Log fonctionne pour les CPU qui possèdent des Data Logs dans une mémoire de chargement externe (carte mémoire SIMATIC). La CPU peut être à l'état RUN ou à l'état STOP.

Pour les CPU, l'opération de suppression d'un journal de données est possible uniquement en mode STOP. Si vous sélectionnez un ou plusieurs Data logs sur une ou plusieurs CPU, SIMATIC Automation Tool vérifie si l'une des CPU est en mode RUN. Si c'est le cas, SIMATIC Automation Tool vous demande de mettre toutes les CPU sélectionnées en mode STOP avant de tenter d'effectuer l'opération. Si vous décidez de ne pas basculer en mode STOP, SIMATIC Automation Tool arrête la procédure complète de suppression.

SIMATIC Automation Tool charge les Data Logs sous forme de fichiers texte au format .csv (valeurs séparées par des virgules).

Vous pouvez sélectionner plusieurs fichiers de données sur une ou plusieurs CPU et traiter tous les fichiers sélectionnés en une seule fois.

SIMATIC Automation Tool crée un nom de dossier unique pour chaque CPU, dans lequel sont stockés les fichiers Data Log chargés sur votre console de programmation. Le nom de fichier est composé à partir du nom de la CPU et de l'adresse MAC. Si vous sélectionnez et chargez le même fichier Data log une deuxième fois, un chiffre est ajouté au nom pour assurer son univocité.

SIMATIC Automation Tool doit avoir un accès en lecture pour charger les fichiers Data log et un accès complet (lecture et écriture) pour supprimer des fichiers Data log dans une CPU. Vous aurez peut-être besoin de saisir un mot de passe pour supprimer des Data Logs. Si vous n'entrez pas de mot de passe ou si le mot de passe ne permet pas l'accès en écriture, SIMATIC Automation Tool ne supprime pas les data logs pour cette CPU. Un message d'erreur sera entré dans le journal des événements (Event Log).

Actions relatives au Data Log

Le bouton de barre d'outils "Opérations sur fichier" [image] et le menu Opérations sur les fichiers proposent les commandes de menu suivantes :

  • Charger les Data logs : Charge une copie des fichiers Data log sélectionnés de la CPU dans la console de programmation. SIMATIC Automation Tool copie les fichiers sous le répertoire défini dans Paramètres des journaux de données (Data logs).

  • Supprimer les Data logs : supprime les fichiers Data log sélectionnés enregistrés dans une CPU.

Charger ou supprimer des fichiers Data log

Pour charger ou supprimer des fichiers Data log, procédez comme suit :

  1. Développez une ligne de CPU et affichez tout dossier Data log [image].

  2. Développez un dossier Data log et sélectionnez les fichiers Data log :

  3. Pour chaque CPU, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU" de l'onglet ouvert.

  4. Sélectionnez la commande de menu "Opérations > Opérations sur fichier > Charger les Data logs" ou la commande de menu "Opérations > Opérations sur fichier > Supprimer les Data logs". Vous pouvez également cliquer sur le bouton de barre d'outils "Opérations sur les fichiers" [image] et sélectionner la commande "Charger les Data logs" ou "Supprimer les Data logs" dans le menu déroulant.

Le journal d'événements (Event Log) sous la table des appareils montre le résultat de cette opération.

Attention

Note de sécurité

Le fait de faire fonctionner un processus ou une machine avec des données corrompues peut affecter l'exécution d'un processus ou le fonctionnement d'une machine en ligne. Le démarrage inattendu d'un processus ou d'une machine peut entraîner la mort ou des dommages corporels et/ou matériels.

Suivez les étapes pour protéger les fichiers .csv de Data Log d'une éventuelle compromission, notamment en limitant l'accès au réseau et en utilisant des pares-feux.


Installation de nouveaux firmware dans les appareils

Déterminer si une mise à jour du firmware est possible Préparation des fichiers de mise à jour du firmware de CPU et de module pour utilisation avec SIMATIC Automation Tool Préparation des fichiers de mise à jour du firmware HMI pour utilisation avec SIMATIC Automation Tool Précharger les fichiers de mise à jour du firmware Effectuer la mise à jour du firmware pour les appareils Mots de passe des CPU de sécurité requis pour la mise à jour du firmware Message d'erreur de dépassement de temps suite à une communication trop lente avec le support de stockage du fichier .upd. Exemple : Mise à jour du firmware pour une CPU Méthodes de mise à jour du firmware autres que SIMATIC Automation Tool
Démarrer Précédent Suivant

Installation de nouveaux firmware dans les appareils

SIMATIC Automation Tool peut mettre à jour le firmware d'un groupe d'appareils. L'extension de fichier pour une mise à jour du firmware dépend du type de l'appareil :

  • Pour les HMI, une mise à jour du firmware possède une extension .fwf.

  • Pour les appareils SCALANCE, les mises à jour du firmware possèdent une extension .lad, .sfw ou .fwl.

  • Pour les CPU et autres appareils, vous pouvez utiliser un fichier .upd unique ou bien l'ancien format (classique) qui utilise au moins trois fichiers upd séparés.

Si votre réseau présente une topologie de communication en chaîne et que les Paramètres de communication activent le traitement multi-thread (multifil), prenez garde au risque d'interruption de communication lors de cette opération.

Remarque

Les modules de communication S7-1200 doivent être configurés avant toute mise à jour du firmware.

Pour un module CM S7-1200, vous devez configurer le module CM dans STEP 7 et charger la configuration dans le module avant de pouvoir utiliser SIMATIC Automation Tool pour mettre à jour le firmware du module CM.

Remarque

Mise à niveau inférieur du firmware de la CPU

Vous pouvez utiliser SIMATIC Automation Tool pour rétrograder le firmware de la CPU (chargement d'une version antérieure), mais l'adresse IP et le programme risquent d'être écrasés. Dans ce cas, l'adresse IP peut être restaurée à 0.0.0.0 et il faut lancer un nouveau scan du réseau pour communiquer avec cet appareil. Vous devez définir l'adresse IP pour rétablir l'adresse réseau précédente.

Vous ne pouvez pas rétrograder le firmware pour certains appareils. Consultez la documentation de votre appareil.

Notez que les programmes prévus pour une version de firmware de CPU risquent de ne pas fonctionner avec une autre version de firmware. La CPU ne peut pas passer en mode Run si le programme est incompatible avec la version de firmware.

Si vous faites une mise à niveau inférieur du firmware et que le programme n'est plus compatible avec la nouvelle version firmware, vous devez réinitialiser la CPU comme suit :

  • Si elle fonctionne à partir de la mémoire de chargement interne, réinitialisez la CPU sur les paramétrages d'usine.

  • Si elle fonctionne à partir de la mémoire de chargement externe, formatez la carte mémoire et redémarrez la CPU.

Après réinitialisation de la CPU, téléchargez un programme valide pour la version firmware de la CPU.

Déterminer si une mise à jour du firmware est possible

Le catalogue des appareils énumère les appareils et versions pour lesquels SIMATIC Automation Tool peut effectuer une mise à jour du firmware. Pour que SIMATIC Automation Tool puisse mettre à jour le firmware d'un appareil, l'appareil et la version doivent prendre en charge la mise à jour du firmware et l'appareil doit être :

  • une CPU au niveau supérieur dans la table des appareils

  • une IHM au niveau supérieur dans la table des appareils

  • un module local d'une CPU, modules CM/CP PROFIBUS compris

    Les modules locaux d'une CPU apparaissent sous la CPU dans le dossier Modules locaux :

  • un appareil ou module décentralisé dans un réseau PROFINET IO

    Les modules de périphérie décentralisée dans un réseau PROFINET IO apparaissent sous un dossier Réseau PROFINET IO :

Notez que les deux conditions doivent être remplies :

  • Le catalogue des appareils indique que SIMATIC Automation Tool prend en charge la mise à jour du firmware pour l'appareil.

  • L'appareil ou le module se trouve à un niveau accepté dans la table des appareils.

Notez que SIMATIC Automation Tool ne prend pas en charge la mise à jour du firmware pour les modules se situant dans les réseaux IO suivants :

  • Réseau PROFIBUS IO :

  • Réseau AS-i IO :

Remarque

Dépendances pour les modules locaux des CPU

Vous ne pouvez pas mettre à jour le firmware de modules locaux si la CPU ne prend pas en charge la mise à jour du firmware. Par exemple, les CPU S7-1200 de version de firmware antérieure à V4.0 n'acceptent pas la mise à jour du firmware par Ethernet. Vous ne pouvez donc pas utiliser SIMATIC Automation Tool pour mettre à jour le firmware des modules locaux connectés à ces CPU.

Préparation des fichiers de mise à jour du firmware de CPU et de module pour utilisation avec SIMATIC Automation Tool

Les mises à jour du firmware de CPU et de modules sont disponibles sur le site Web Siemens d'assistance produit.

Vous pouvez également sélectionner la ligne d'un appareil, puis sélectionner "Rechercher des mises à jour du firmware", soit depuis le menu Outils soit depuis l'icône Outils de la barre d'outils. SIMATIC Automation Tool lance la page Web de support client de l'appareil. Le site Internet d'assistance de Siemens affiche la page correspondant au numéro d'article affiché dans la ligne de la table des appareils. Par ex., une commande "Rechercher des mises à jour" sur le numéro d'article 6ES7 215‑1HG31‑0XB0 renvoie vers la page Web d'assistance de la CPU 1215C

Pour une CPU, le fichier de mise à jour du firmware nommé 6ES7 211-1AE40-0XB0_V04.00.02.exe est, par exemple, destiné uniquement au modèle CPU 1211C DC/DC/DC. Si vous utilisez le fichier .upd contenu dans ce package pour un autre modèle de CPU S7‑1200, la mise à jour échouera.

Lorsque vous exécutez le fichier de mise à jour et que les fichiers sont extraits, les dossiers et fichiers suivants sont affichés.

  • Fichier : S7-JOB.SYS

  • Dossier : FWUPDATE.SYS contient le fichier .upd.

    • fichier : 6ES7 211-1AE40-0XB0 V04.00.02.upd (fichier .upd utilisé par SIMATIC Automation Tool)

Pour un module E/S, le fichier de mise à jour du firmware nommé 232‑4HD32‑0XB0_V203.exe est destiné uniquement au module SM1232 ANALOG OUTPUT 4AO. Le fichier .exe auto-extractible contient le fichier 6ES7 232‑4HD32‑0XB0 V02.00.03_00.00.00.00.upd qui est utilisé par SIMATIC Automation Tool.

Remarque

Nouveau format des fichiers de mise à jour du firmware

  • Le nom du fichier .exe de mise à jour auto-extractible doit renvoyer au numéro d'article de l'appareil que vous voulez mettre à jour.

  • Le nom du fichier .upd extrait doit correspondre au numéro d'article de l'appareil et à la version de firmware que vous voulez charger.
Remarque

Ancien format des fichiers de mise à jour du firmware

  • Le nom du fichier .exe de mise à jour auto-extractible doit renvoyer au numéro d'article de l'appareil que vous voulez mettre à jour.

  • Contient trois fichiers ou plus en fonction de la taille du firmware.

  • Créez un dossier avec un nom au choix dans le Dossier de mise à jour du firmware. Vous pouvez choisir un nom reprenant le numéro d'article et le numéro de version, afin de simplifier l'identification, mais vous pouvez choisir un nom quelconque. SIMATIC Automation Tool examine tous les fichiers de firmware au démarrage pour confirmer les numéros de version du firmware.

Copie des fichiers .upd dans le dossier de mise à jour du firmware

Les noms des fichiers .upd au nouveau format reprennent le modèle du module cible et les numéros de version. Vous pouvez copier plusieurs fichiers .upd dans un même dossier firmware et identifier le module cible ) l'aide du nom du fichier .upd. Copiez tous les fichiers .upd requis dans le dossier de mise à jour du firmware.

Attention

Vérifiez qu'un processus ne soit pas en cours sur la CPU avant d'installer les mises à jour du firmware.

L'installation d'une mise à jour du firmware sur une CPU ou un module fait passer la CPU en mode STOP, ce qui peut affecter l'exécution d'un processus ou d'une machine en ligne, dont la mise en route inattendue peut entraîner la mort, des blessures graves et des dommages matériels importants.

Préparation des fichiers de mise à jour du firmware HMI pour utilisation avec SIMATIC Automation Tool

Un fichier de mise à jour du firmware pour un fichier HMI possède l'extension .fwf. Ce fichier fait partie du runtime et du système d'exploitation HMI que vous pouvez copier depuis le projet TIA Portal. Voir le thème Mise à jour des programmes des appareils depuis SIMATIC Automation Tool pour des instructions sur le transfert de la structure de fichier SIMATIC.HMI depuis TIA Portal vers un support de stockage tel que SIMATIC memory card. Après avoir copié la structure de fichier SIMATIC.HMI vers votre support de données, suivez ces étapes pour mettre à jour le firmware pour un appareil HMI :

  1. Depuis le dossier SIMATIC.HMI sur votre SIMATIC memory card ou un autre support, commencez au niveau du sous-dossier "Firmware" et développez jusqu'à ce que vous voyiez un fichier avec l'extension .fwf.

  2. Copiez le fichier .fwf dans votre dossier Mise à jour du firmware .

Vous pouvez stocker plusieurs fichiers .fwf pour plusieurs appareils HMI et plusieurs versions de firmware dans le dossier Mise à jour du firmware.

Remarque

Paramètres de transfert pour un appareil IHM (pupitre SIMATIC)

Pour communiquer avec une IHM, vous devez définir les paramètres de transfert sur l'appareil IHM à PN/IE ou Ethernet. Vous devez donner la même valeur aux paramètres de communication pour le mode de transfert IHM.

Précharger les fichiers de mise à jour du firmware

Vous pouvez précharger la dernière mise à jour du firmware disponible dans la colonne "Nouvelle version firmware". SIMATIC Automation Tool examine le dossier de mise à jour du firmware. Pour chaque appareil, si SIMATIC Automation Tool trouve des fichiers de mise à jour du firmware plus récents que la version actuelle sur l'appareil, SIMATIC Automation Tool charge la colonne "Nouvelle version firmware" avec la nouvelle version disponible

Pour précharger les fichiers de mise à jour du firmware, sélectionnez la commande de menu "Outils > Précharger les fichiers de mise à jour du firmware". Vous pouvez aussi cliquer sur le bouton Outils [image] et sélectionner la commande "Précharger les fichiers de mise à jour du firmware" depuis le menu contextuel.

Pour chaque appareil, SIMATIC Automation Tool précharge alors la colonne "Nouvelle version firmware" avec la version la plus récente dans le dossier plus récent que la version dans l'appareil. Si SIMATIC Automation Tool ne trouve pas de version plus récente que la version dans l'appareil, la colonne "Nouvelle version firmware" reste vide.

Vous pouvez copier et coller les cellules de fichier de mise à jour du firmware dans d'autres cellules de mise à jour du firmware applicables. Copier et coller peut simplifier les opérations de mise à jour du firmware pour plusieurs appareils.

Effectuer la mise à jour du firmware pour les appareils

Procédez comme suit pour mettre à jour le firmware :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Cliquez sur l'onglet "Mise à jour du firmware".

  3. Si vous n'avez pas préchargé les fichiers de mise à jour du firmware, sélectionnez les fichiers de mise à jour du firmware. Pour chaque ligne d'appareil sélectionnée, utilisez la liste déroulante de la colonne "Nouvelle version firmware" et sélectionnez une version de firmware. La liste déroulante affiche le nom des fichiers dans le dossier de mise à jour du firmware correspondant à votre sélection d'appareil. Si de nouvelles versions du firmware sont disponibles dans le dossier de mise à jour du firmware, alors ces fichiers sont disponibles à partir de la liste déroulante "Nouvelle version firmware".

    Vous pouvez également utiliser le bouton Parcourir [image] pour accéder au dossier contenant les fichiers de mise à jour du firmware sur votre console de programmation. Sélectionnez un fichier pour l'ajouter à la liste déroulante. Si le fichier sélectionné porte le même nom qu'un fichier de la liste, SIMATIC Automation Tool ajoute un chiffre au nouveau fichier afin que le nom reste univoque. Pour vous aider à identifier les fichiers, une info-bulle affiche le chemin d'accès complet et le nom du fichier.

    Si vous choisissez un fichier de mise à jour du firmware à l'ancien format, sélectionnez le fichier header.upd. Ne sélectionnez pas un autre fichier .upd du lot.

  4. Pour chaque CPU sélectionnée, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU".

  5. Pour chaque appareil SCALANCE sélectionné, sélectionnez le profil SNMP pour votre appareil. Une icône à proximité du profil SNMP indique si le nom du profil SNMP correspond à un nom de profil du fichier profil contenu dans le dossier Profils SNMP :

    • : Le profil SNMP correspond à un profil SNMP du dossier Profils SNMP.

    • : Le profil SNMP ne correspond pas à un profil SNMP du dossier Profils SNMP.

    Remarque

    Vous devez indiquer un serveur TFTP (Trivial File Transfer Protocol) pour installer le firmware dans des appareils SCALANCE.

  6. Sélectionner la commande de menu "Opérations > Mettre à jour > Mise à jour du firmware" pour démarrer l'opération. Vous pouvez également cliquer sur le bouton de barre d'outils Mettre à jour [image] et la commande "Mise à jour du firmware" dans le menu déroulant.

Le journal d'événements (Event Log) sous la table des appareils montre le résultat de cette opération. Une fois que l'opération de mise à jour du firmware est terminée avec succès, SIMATIC Automation Tool efface le champ "Nouvelle version firmware".

Mots de passe des CPU de sécurité requis pour la mise à jour du firmware

Pour les versions de firmware antérieures à S7-1200 V4.2 et S7-1500 V2.0, une CPU de sécurité protégée par mot de passe nécessite le mot de passe de CPU F de sécurité (niveau maximum 5) pour l'opération de mise à jour du firmware. Étant donné qu'une mise à jour du firmware n'est pas une opération liée à la sécurité, le niveau de sécurité du mot de passe a été rabaissé. Les versions ultérieures du firmware de CPU F nécessitent uniquement un accès en lecture-écriture (accès complet de niveau 4).

SIMATIC Automation Tool ne vérifie pas le niveau de légitimation pour différentes versions de firmware. L'opération est lancée et l'appareil rejette un mot de passe selon la configuration du firmware, ce qui génère l'erreur suivante dans l'Event Log :

"Le mot de passe saisi est insuffisant pour l'exécution de l'opération".

La version S7-1200 V4.2 ou les versions ultérieures et la version S7-1500 V2.0 ou les versions ultérieures, ne nécessitent qu'un "Accès complet (aucune protection)". Si le mot de passe de CPU F de sécurité est utilisé, vous bénéficiez également de l'accès en lecture-écriture, de sorte que l'opération réussira toujours si le mot de passe de sécurité est entré.

Message d'erreur de dépassement de temps suite à une communication trop lente avec le support de stockage du fichier .upd.

Si le message d'erreur suivant s'affiche, plus de dix secondes se sont écoulées. SIMATIC Automation Tool n'a pas fini de traiter tous les fichiers .upd. La durée nécessaire pour ouvrir et scanner tous les fichiers .upd est fonction du temps d'accès aux données et du nombre de fichiers .upd qui se trouvent dans le dossier.

Ce dépassement de temps peut survenir lorsque la communication avec un support de stockage distant est trop lente.

Pour éviter ce problème, copiez les fichiers de mise à jour du firmware sur un dispositif de stockage local qui permet un accès rapide. Affectez ce chemin comme dossier de mise à jour du firmware et répétez l'opération.

Exemple : Mise à jour du firmware pour une CPU

Cet exemple montre comment mettre à jour le firmware pour une seule CPU.

Procédez comme suit pour effectuer la mise à jour du firmware :

  1. Ouvrez la liste déroulante des versions disponibles à partir de la colonne "Nouvelle version firmware". La liste déroulante affiche tous les fichiers de mise à jour du firmware dans le dossier de mise à jour du firmware.

  2. Sélectionnez la version de mise à jour du firmware à utiliser (si vous avez sélectionné plusieurs appareils, vous devez choisir un fichier de mise à jour pour chaque appareil sélectionné).

  3. Sélectionner la commande de menu "Opérations > Mettre à jour > Mise à jour du firmware" pour démarrer l'opération. Vous pouvez également cliquer sur le bouton de barre d'outils Mettre à jour et la commande de menu "Mise à jour du firmware" dans le menu déroulant.

Remarque

Le firmware de certains modules S7-1200 ne peut pas être mis à jour avec SIMATIC Automation Tool

Certaines CPU ne prennent pas en charge la mise à jour du firmware. Si une CPU ne prend pas en charge la mise à jour du firmware, vous pouvez uniquement mettre à jour l'appareil avec une carte SD SIMATIC. Le firmware des modules connectés à la CPU ne peut pas non plus être mis à jour avec SIMATIC Automation Tool

Méthodes de mise à jour du firmware autres que SIMATIC Automation Tool

Les autres mises à jour possibles du firmware sont les suivantes :

  • Carte mémoire SD SIMATIC dans les appareils où cela est possible

  • Fonctions en ligne et de diagnostic de TIA Portal

  • Page d'informations sur un module du serveur Web de la CPU

Remarque

Mises à jour du système d'exploitation et du logiciel runtime d'appareils IHM

Vous pouvez utiliser l'opération Mise à jour du programme de SIMATIC Automation Tool pour mettre à jour le système d'exploitation et le logiciel runtime d'appareils IHM. L'opération Mise à jour du programme met à jour tous les composants de données nécessaires pour assurer un téléchargement cohérent.

Vous pouvez mettre à jour le système d'exploitation de l'IHM (firmware) sans mettre à jour le logiciel runtime. Dans les versions antérieures à V3.1 SP2, il n'était pas possible de mettre à jour uniquement le firmware du système d'exploitation. Il fallait mettre le programme à jour.


Sauvegarde et restauration des données d'appareil

Sauvegarde et restauration des données d'appareil

Ce chapitre contient des informations sur les sujets suivants :
  • Sauvegarde d'une CPU ou IHM
  • Sauvegarder des recettes IHM
  • Sauvegarder des données de gestion des utilisateurs IHM
  • Restaurer des fichiers de sauvegarde


Sauvegarde d'une CPU ou IHM

Effectuer une sauvegarde complète

Sauvegarde d'une CPU ou IHM

La sauvegarde d'une CPU ou d'une IHM crée un ou plusieurs fichiers de sauvegarde et stocke les fichiers dans le dossier de sauvegarde et de restauration.

Vous pouvez utiliser ces fichiers avec l'opération Restaurer l'appareil dans SIMATIC Automation Tool.

SIMATIC Automation Tool fournit les types de sauvegardes suivants :

  • Sauvegarde complète d'une CPU ou d'une IHM

  • Sauvegarde de recettes IHM

  • Sauvegarde de données de gestion des utilisateurs IHM

Le nom de fichier d'une sauvegarde de CPU combine le nom du projet, le type de sauvegarde et l'adresse MAC. Le nom de fichier d'une sauvegarde d'IHM combine le type d'IHM, le type de sauvegarde et l'adresse MAC. Tous les fichiers de sauvegarde possèdent une extension .s7pbkp. SIMATIC Automation Tool copie les fichiers dans le dossier de sauvegarde et restauration :

Effectuer une sauvegarde complète

Vous pouvez lancer la sauvegarde à partir de n'importe quel onglet.

Pour créer un fichier de sauvegarde, procédez comme suit :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher "Appareil" située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Éditer > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Sélectionner la commande de menu "Sauvegarder l'appareil > Sauvegarde complète" dans le menu Opérations. Vous pouvez également cliquer sur le bouton Sauvegarde et restauration [image] de la barre d'outils et sélectionner "Appareil de sauvegarde> Restauration complète" dans le menu déroulant.

L'Event Log affiche les résultats de l'opération.

Pour que l'opération se déroule correctement, SIMATIC Automation Tool crée un fichier de sauvegarde pour chaque appareil sélectionné.


Sauvegarder des recettes IHM

Sauvegarder des recettes IHM

Vous pouvez lancer la sauvegarde à partir de n'importe quel onglet.

Procédez comme suit afin de créer un fichier de sauvegarde pour une ou plusieurs recettes IHM :

  1. Sélectionnez un ou plusieurs appareils IHM à inclure dans l'opération. Vous pouvez utiliser la case à cocher "Appareil" située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Éditer > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Sélectionner la commande de menu "Sauvegarder l'appareil > IHM > Recettes" dans le menu Opérations. Vous pouvez également cliquer sur le bouton Sauvegarde et restauration [image] de la barre d'outils et sélectionner "Sauvegarder l'appareil> IHM > Recettes" dans le menu déroulant.

L'Event Log affiche les résultats de l'opération.

Pour que l'opération se déroule correctement, SIMATIC Automation Tool crée un fichier de sauvegarde de recettes IHM pour chaque appareil IHM. SIMATIC Automation Tool stocke les fichiers dans le dossier de sauvegarde et restauration : SIMATIC Automation Tool ignore les appareils qui ne sont pas des IHM.


Sauvegarder des données de gestion des utilisateurs IHM

Sauvegarder des données de gestion des utilisateurs IHM

Vous pouvez lancer la sauvegarde à partir de n'importe quel onglet.

Procédez comme suit pour créer un fichier de sauvegarde des données de gestion des utilisateurs IHM pour un ou plusieurs appareils IHM :

  1. Sélectionnez un ou plusieurs appareils IHM à inclure dans l'opération. Vous pouvez utiliser la case à cocher "Appareil" située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Éditer > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Sélectionner la commande de menu "Sauvegarder l'appareil > IHM > Données de gestion des utilisateurs" dans le menu Opérations. Vous pouvez également cliquer sur le bouton Sauvegarde et restauration [image] de la barre d'outils et sélectionner "Sauvegarder l'appareil> IHM > Données de gestion des utilisateurs" dans le menu déroulant.

L'Event Log affiche les résultats de l'opération.

Pour que l'opération se déroule correctement, SIMATIC Automation Tool crée un fichier de sauvegarde avec les données de gestion des utilisateurs IHM pour chaque appareil IHM. SIMATIC Automation Tool stocke les fichiers dans le dossier de sauvegarde et restauration : SIMATIC Automation Tool ignore les appareils qui ne sont pas des IHM.


Restaurer des fichiers de sauvegarde

Restaurer un appareil à partir d'un fichier de sauvegarde Validation du fichier de sauvegarde Gestion des mots de passe après l'opération de restauration Validation de la signature de sécurité Effet de la restauration d'un programme CPU sur l'adresse IP Exemple de restauration à partir d'un fichier de sauvegarde
Démarrer Précédent Suivant

Restaurer des fichiers de sauvegarde

Restaurer un appareil à partir d'un fichier de sauvegarde

Vous utilisez la commande "Restaurer l'appareil" pour restaurer les fichiers de sauvegarde sur les appareils correspondants. Les fichiers de sauvegarde CPU et HMI que vous avez créés avec la commande "Sauvegarder l'appareil" portent le nom d'extension "s7pbkp". Vous pouvez restaurer les fichiers à partir du dossier de sauvegarde et de restauration ou naviguer vers un autre emplacement.

Si vous avez une topologie de communication en chaîne et que les Paramètres de communication activent le multithreading, tenez compte du risque d'interruption de la communication lors de cette opération.

Remarque

Appareils de sécurité

Si une CPU de sécurité est protégée, vous devez entrer le mot de passe de CPU F de sécurité dans la colonne "Mot de passe dans la CPU" pour restaurer l'appareil de sécurité à partir d'un fichier de sauvegarde.

Vous devez confirmer une invite supplémentaire et sélectionner de nouveau votre appareil si le programme installé dans une CPU F est un programme de sécurité.

SIMATIC Automation Tool place les demandes "Restaurer à partir de la sauvegarde" pour les appareils de sécurité dans la file d'attente des opérations relatives à la sécurité des CPU F. SIMATIC Automation Tool utilise uniquement le traitement séquentiel à thread unique pour la file d'attente d'opérations de sécurité.

L'appareil de destination pour un programme de sécurité doit être une CPU de sécurité.
Attention

Vérifiez qu'aucun appareil ne soit en train d'exécuter un processus avant de restaurer un appareil à partir d'un fichier de sauvegarde.

La restauration d'une CPU fait passer la CPU en mode STOP, ce qui peut affecter l'exécution d'un processus ou d'une machine en ligne. La restauration d'une HMI interrompt les actions opérateur depuis l'écran opérateur, ce qui peut aussi provoquer une interruption du processus.

Le démarrage inattendu d'un processus ou d'une machine peut entraîner la mort ou des dommages corporels et/ou matériels.

Vérifiez que votre processus peut supporter une interruption avant de restaurer un appareil à partir d'un fichier de sauvegarde.
Remarque

Paramètres de transfert pour un appareil IHM (SIMATIC HMI Panel)

Pour communiquer avec une IHM, vous devez définir les paramètres de transfert sur l'appareil IHM à PN/IE ou Ethernet. Vous devez donner la même valeur aux paramètres de communication pour le mode de transfert IHM.

Pour restaurer les appareils sélectionnés à partir d'un fichier de sauvegarde, procédez comme suit :

  1. Cliquez sur l'onglet "Restaurer à partir de la sauvegarde" dans la table des appareils.

  2. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  3. Pour chaque appareil, sélectionnez un nom de fichier de sauvegarde dans la liste déroulante "Fichier de sauvegarde". La liste déroulante affiche le nom des fichiers .s7pbkp qui se trouvent dans le dossier de sauvegarde et de restauration.

    Vous pouvez également utiliser le bouton Parcourir [image] pour accéder au dossier contenant les fichiers de sauvegarde sur votre console de programmation. Sélectionnez un fichier pour l'ajouter à la liste déroulante. Si le fichier que vous avez sélectionné porte le même nom qu'un fichier existant, SIMATIC Automation Tool ajoute un chiffre au nouveau fichier afin que le nom reste univoque.

    Pour les fichiers valides, une info-bulle affiche le chemin d'accès et le nom du fichier. Vous voyez également une coche verte à côté du nom du fichier.

    Pour les fichiers non valides, l'info-bulle affiche l'erreur de fichier, également affichée dans l'Event Log. Vous voyez un "X" rouge à côté du nom du fichier.

  4. Le cas échéant, entrez les mots de passe dans les colonnes "Mot de passe dans la CPU" et "Mot de passe dans le fichier de sauvegarde". L'opération "Restaurer à partir de la sauvegarde" est liée à la sécurité ; le mot de passe de CPU F de sécurité est donc requis pour un appareil de sécurité protégé par mot de passe.

  5. Sélectionnez la commande de menu "Opérations > Sauvegarder/Restaurer > Restaurer l'appareil" pour démarrer l'opération. Vous pouvez également cliquer sur le bouton Sauvegarder/Restaurer [image] de la barre d'outils et sélectionner "Restaurer l'appareil" dans le menu déroulant.

Validation du fichier de sauvegarde

Avant de lancer l'opération de restauration, SIMATIC Automation Tool effectue des contrôles limités sur les données du fichier de sauvegarde :

  • Le nom de l'extension de fichier et les données d'en-tête sont validés.

  • Vous ne pouvez pas effectuer de restauration à partir d'un fichier de sauvegarde qui contient un programme de sécurité lorsque l'appareil cible n'est pas une CPU de sécurité.

Si un fichier de sauvegarde n'est pas valide, SIMATIC Automation Tool affiche une icône "X" rouge dans le champ "Fichier de sauvegarde". De plus amples informations sur les erreurs sont disponibles dans une info-bulle lorsque vous passez votre curseur sur la cellule.

Gestion des mots de passe après l'opération de restauration

Si une CPU est protégée par mot de passe, vous devez entrer un mot de passe pour que l'opération Restaurer à partir de la sauvegarde puisse être terminée avec succès.

Après qu'un fichier de sauvegarde a été restauré sur une CPU, le nouveau fichier peut avoir un mot de passe. Le mot de passe que vous avez restauré peut être différent du mot de passe précédent si la CPU avait un mot de passe. Vous devez donc entrer un second mot de passe dans la colonne "Mot de passe dans le fichier de sauvegarde". Le second mot de passe devient le mot de passe de la CPU une fois que l'opération de restauration est terminée.

Une fois que l'opération de restauration est terminée avec succès, SIMATIC Automation Tool copie automatiquement le second mot de passe (le mot de passe que vous avez entré sous "Mot de passe dans le fichier de sauvegarde") vers le champ mot de passe de la CPU et effectue une tentative de connexion à l'aide du nouveau mot de passe. SIMATIC Automation Tool supprime ensuite le second mot de passe et le chemin d'accès vers le fichier de sauvegarde.

Avant la restauration d'un fichier de sauvegarde sur une CPU :

Après la restauration d'un fichier de sauvegarde sur une CPU :

Si le mot de passe que vous avez entré dans la colonne "Mot de passe dans le fichier de sauvegarde" est incorrect et n'est pas le mot de passe configuré dans les données restaurées de la CPU, l'Event Log affiche un avertissement une fois l'opération terminée. Dans ce cas, le mot de passe de la CPU affiche une icône 'X' rouge qui indique un mot de passe non-valide.

Validation de la signature de sécurité

Un projet TIA Portal qui contient un programme de sécurité comporte une signature de sécurité. SIMATIC Automation Tool utilise la signature de sécurité pour vérifier les données dans un fichier programme, ce qui renforce le niveau de sécurité des programmes de sécurité. Après une opération Restaurer à partir de la sauvegarde, SIMATIC Automation Tool compare la signature de sécurité dans le fichier de projet à la signature de sécurité qui se trouve maintenant dans le programme de la CPU.

L'Event Log signale une comparaison réussie comme suit : "Les résultats de la comparaison CRC en ligne et des signatures de sécurité collectives hors ligne correspondent."

Lorsqu'elle échoue, la comparaison est signalée comme suit par SIMATIC Automation Tool dans le journal d'événements : "Résultat de la comparaison CRC : les signatures de sécurité globales en ligne et hors ligne ne correspondent pas.". Dans ce cas, restaurez les paramètres d'usine de l'appareil et relancez la mise à jour du programme. N'essayez pas de passer en mode RUN si vous n'êtes pas certain(e) d'avoir chargé le bon programme.

Effet de la restauration d'un programme CPU sur l'adresse IP

Avant une restauration, le projet STEP 7 dans la CPU a un réglage dans la configuration de l'appareil indiquant comment l'adresse IP est définie. En résumé, la configuration est l'une des suivantes :

  • Configurer l'adresse IP dans le projet (ou équivalent)

  • Adresse IP définie directement sur l'appareil (ou équivalent)

Le programme en cours de mise à jour peut avoir un réglage différent de la configuration de l'appareil du projet qui se trouve actuellement sur la CPU. De plus, un utilisateur peut avoir mis à jour l'adresse IP de l'appareil avec SIMATIC Automation Tool. Dans ce cas, l'adresse IP de l'appareil mise à jour par l'utilisateur est actuellement dans la CPU.

L'adresse IP de l'appareil après une restauration du programme et après un redémarrage consécutif de la CPU dépend du réglage du nouveau programme et de l'adresse IP actuelle. Le tableau suivant décrit les différentes possibilités pour l'adresse IP de l'appareil.

Configuration de l'appareil dans le fichier de sauvegarde | Adresse IP après restauration de la sauvegarde | Adresse IP après le redémarrage de la CPU suite à la restauration
Configurer l'adresse IP dans le projet | L'adresse IP est celle du programme nouvellement restauré. | L'adresse IP est celle du programme nouvellement restauré.
Adresse IP définie directement sur l'appareil | L'adresse IP est celle de l'appareil avant la restauration du programme. | L'adresse IP est celle de l'appareil avant la restauration du programme.

Exemple de restauration à partir d'un fichier de sauvegarde

Cet exemple montre un appareil sélectionné et la sélection d'un fichier de sauvegarde pour le champ "Fichier de sauvegarde". Si votre installation comporte plusieurs appareils, vous sélectionnez un fichier de sauvegarde à restaurer pour chaque appareil :

Après exécution de "Restaurer l'appareil", le journal des événements affiche les résultats de l'opération.


Réinitialisation des paramètres de communication

Réinitialisation des paramètres de communication

SIMATIC Automation Tool prend en charge la commande DCP "Réinitialiser les paramètres de communication" pour les appareils PROFINET. La norme PROFINET définit la commande "Réinitialiser les paramètres de communication" comme une commande consistant à mettre les appareils dans un état similaire à un "état standard". De manière spécifique, la commande réinitialise les valeurs suivantes pour les interfaces de communication et les relations d'application :

Paramètre

Valeur

NameOfStation

"" (chaîne vide)

Paramètres IP suite

0.0.0.0

Paramètres DHCP, le cas échéant

Valeurs d'usine

Paramètres P Dev :

  • PD IR Data

  • PD Port Data Adjust

  • PD Interface

  • MRP Data Adjust

  • autres

Valeurs d'usine

Paramètres de MIB-II modifiés par SMNP, par exemple :

  • sysContact

  • sysName

  • sysLocation

Valeurs d'usine

Procédez comme suit pour réinitialiser les paramètres de communication des appareils PROFINET :

  1. Dans la table des appareils, sélectionnez les appareils que vous voulez réinitialiser.

  2. Sélectionnez la commande de menu Opérations > Restaurer > Restaurer les paramètres de communication .

SIMATIC Automation Tool envoie la commande DCP "Réinitialiser les paramètres de communication" DCP aux appareils. Le journal d'événements affiche un message pour les appareils qui ne prennent pas en charge la commande de réinitialisation DCP. Il affiche également des messages pour les appareils qui renvoient des erreurs.

Remarque

Vous devez configurer les CPU comme périphériques IO dans la configuration d'appareil STEP 7 pour qu'elles puissent réinitialiser les paramètres de communication. Les paramètres de périphérique IO se trouvent dans le groupe Mode de fonctionnement des paramètres d'interface PROFINET dans la configuration d'appareil STEP 7.


Effectuer un effacement général sur les CPU

Effectuer un effacement général sur les CPU

Vous devez avoir accès en écriture à une CPU pour effectuer une remise à zéro de la mémoire.

Procédez comme suit pour réinitialiser la mémoire des CPU sélectionnées :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Pour chaque CPU sélectionnée, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU".

  3. Sélectionner la commande "Opérations > Réinitialiser > RAZ mémoire" pour démarrer l'opération. Vous pouvez également cliquer sur le bouton "Réinitialiser" de la barre d'outils et sélectionner "RAZ mémoire" dans le menu déroulant.

  4. Cliquez sur le bouton "Continuer" dans la boîte de dialogue "RAZ mémoire".

SIMATIC Automation Tool effectue une réinitialisation de la mémoire sur les appareils sélectionnés.

Le journal d'événements sous la table des appareils montre le résultat de cette opération.


Restauration des paramètres d'usine des appareils

Restaurer les paramètres d'usine des appareils sélectionnés Effet de la restauration des paramètres d'usine d'une CPU sur l'adresse IP
Démarrer Précédent Suivant

Restauration des paramètres d'usine des appareils

Restaurer les paramètres d'usine des appareils sélectionnés

Vous pouvez restaurer les paramètres d'usine des appareils sélectionnés, sauf l'adresse IP. L'appareil conserve l'adresse IP existante afin de préserver les affectations IP du réseau.

Si votre réseau présente une topologie en chaîne et que les Paramètres de communication activent le traitement multi-thread (multifil), prenez garde au risque d'interruption de communication lors de cette opération.

Remarque

Appareils de sécurité

Si une CPU de sécurité est protégée, vous devez entrer le mot de passe de CPU F de sécurité dans la colonne "Mot de passe dans la CPU" pour restaurer les paramètres d'usine d'un appareil de sécurité.

Vous devez confirmer une invite supplémentaire et sélectionner de nouveau votre appareil si le programme installé dans la CPU F est un programme de sécurité.

Les demandes de restauration des paramètres d'usine pour les appareils de sécurité sont placées dans la file d'attente des opérations relatives à la sécurité et seul un traitement séquentiel à fil unique est autorisé.
Attention

Vérifiez que l'appareil n'est pas en cours d'exécution d'un processus avant de restaurer les paramètres d'usine.

La restauration des paramètres d'usine fait passer la CPU en mode STOP, ce qui peut affecter l'exécution d'un processus ou le fonctionnement d'une machine en ligne. Le démarrage inattendu d'un processus ou d'une machine peut entraîner la mort ou des dommages corporels et/ou matériels.

Pour restaurer les paramètres d'usine des appareils sélectionnés, procédez comme suit :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

    Pour chaque CPU sélectionnée, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU" de l'onglet ouvert. La restauration des paramètres d'usine est liée à la sécurité ; le mot de passe de CPU F de sécurité est donc requis pour un appareil de sécurité protégé par mot de passe.

  2. Sélectionner la commande de menu "Opérations > Restaurer > Restaurer les paramètres d'usine" pour démarrer l'opération. Vous pouvez également cliquer sur le bouton "Restaurer" [image] de la barre d'outils et sélectionner "Restaurer les paramètres d'usine" dans le menu déroulant.

    Pour les CPU de sécurité, SIMATIC Automation Tool affiche la boîte de dialogue "Mise à jour du programme" pour une confirmation supplémentaire. Sélectionnez l'appareil, les appareils ou tous les appareils dont vous souhaitez restaurer les paramètres d'usine.

  3. Cliquez sur le bouton "Continuer" dans la boîte de dialogue "Restaurer les paramètres d'usine".

    SIMATIC Automation Tool restaure les paramètres d'usine des appareils sélectionnés.

Remarque

La restauration des paramètres d'usine ne supprime pas les données de la carte mémoire SD SIMATIC.

Si vous disposez d'une carte mémoire SIMATIC dans une CPU, l'opération "Restaurer les paramètres d'usine" ne supprime pas son contenu. Si vous ne disposez pas d'une carte mémoire SD SIMATIC dans une CPU, l'opération "Restaurer les paramètres d'usine" supprime le programme dans la mémoire de chargement interne de la CPU.

Le journal d'événements (Event Log) sous la table des appareils montre le résultat de cette opération.

Effet de la restauration des paramètres d'usine d'une CPU sur l'adresse IP

Avant la restauration des paramètres d'usine de la CPU, le projet STEP 7 dans la CPU a un réglage dans la configuration de l'appareil indiquant comment l'adresse IP est définie. En résumé, la configuration est l'une des suivantes :

  • Configurer l'adresse IP dans le projet (ou équivalent)

  • Adresse IP définie directement sur l'appareil (ou équivalent)

De plus, un utilisateur peut avoir mis à jour l'adresse IP de l'appareil avec SIMATIC Automation Tool. Dans ce cas, l'adresse IP de l'appareil mise à jour par l'utilisateur est actuellement dans la CPU.

L'adresse IP après une restauration des paramètres d'usine et un redémarrage consécutif de la CPU dépend de plusieurs facteurs. Le tableau suivant décrit les différentes possibilités pour l'adresse IP de l'appareil.

Adresse IP dans la CPU | La CPU possède une carte SD ? | Adresse IP après mise à jour du programme | Adresse IP après le redémarrage de la CPU suite à la restauration des paramètres d'usine
Configuration de l'appareil : Configurer l'adresse IP dans le projet | Oui | L'adresse IP est celle du projet sur la carte mémoire SD. | L'adresse IP est celle du projet sur la carte mémoire SD.
 | Non | L'adresse IP est celle de l'appareil avant la restauration des paramètres d'usine. | L'adresse IP est celle de l'appareil avant la restauration des paramètres d'usine.
Adresse IP temporaire, provenant par exemple de l'opération Définir l'adresse IP | Oui | L'adresse IP est celle du projet sur la carte mémoire SD. | L'adresse IP est celle du projet sur la carte mémoire SD.
 | Non | L'adresse IP est celle de l'appareil avant la restauration des paramètres d'usine. | L'adresse IP est celle de l'appareil avant la restauration des paramètres d'usine.
Configuration de l'appareil : Adresse IP définie directement sur l'appareil | Sans objet | L'adresse IP est celle de l'appareil avant la restauration des paramètres d'usine. | L'adresse IP est celle de l'appareil avant la restauration des paramètres d'usine.


Formatage d'une carte mémoire

Formatage d'une carte mémoire

Les cartes mémoire SD SIMATIC s'insèrent dans les appareils SIMATIC et prennent en charge diverses applications. Selon le type ou la gamme d'appareils, vous pouvez utiliser une carte mémoire aux fins suivantes :

  • Mémoire de chargement d'une CPU

  • Support de stockage pour un projet

  • Sauvegarder et mise à jour du firmware

  • Support de stockage pour le nom d'appareil PROFINET

  • Transfert de projet d'un appareil à un autre

  • Autres fichiers

Remarque

Le formatage des cartes mémoire SIMATIC s'effectue uniquement à l'aide de logiciels Siemens.

Si vous utilisez une carte mémoire SIMATIC à des fins autres que SIMATIC ou si vous ne la formatez pas correctement, la structure interne de la carte SIMATIC est écrasée. La structure n'est pas récupérable et la carte mémoire SIMATIC devient inutilisable pour les appareils SIMATIC.

N'utilisez pas de cartes mémoire SIMATIC dans des contextes différents de SIMATIC et ne formatez pas les cartes mémoire SIMATIC avec des appareils tiers ni des outils Windows.

Si votre réseau présente une topologie en chaîne et que les Paramètres de communication activent le traitement multi-thread (multifil), prenez garde au risque d'interruption de communication lors de cette opération.

Attention

Vérifiez que l'appareil ne soit pas en train d'exécuter un processus avant de formater une carte mémoire.

Le formatage d'une carte mémoire fait passer la CPU en mode STOP, ce qui peut affecter le fonctionnement d'une machine ou d'un processus en ligne Le démarrage inattendu d'un processus ou d'une machine peut entraîner la mort ou des dommages corporels et/ou matériels.

Pour formater les cartes mémoire SIMATIC sur les appareils sélectionnés, procédez comme suit :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Pour chaque CPU sélectionnée, assurez-vous que la carte mémoire est déjà insérée et que la CPU utilise la carte mémoire comme mémoire de chargement externe.

  3. Pour chaque CPU sélectionnée, saisissez un mot de passe, si nécessaire, dans la colonne "Mot de passe dans la CPU".

  4. Sélectionner la commande "Opérations > Restaurer > Formater la carte mémoire" pour démarrer l'opération. Vous pouvez également cliquer sur le bouton " Restaurer" de la barre d'outils et sélectionner "Formater la carte mémoire" dans le menu déroulant.

  5. Cliquez sur le bouton "Continuer" dans la boîte de dialogue "Formater la carte mémoire".

SIMATIC Automation Tool formate la carte mémoire des appareils sélectionnés. Vérifiez les résultats de l'opération dans le journal des événements. Vérifiez, si nécessaire, le tampon de diagnostic de la CPU après le formatage. Pour toute question spécifique à un appareil, reportez-vous à la documentation de l'appareil.

Remarque

Appareils de sécurité

Si une CPU de sécurité est protégée, vous devez entrer le mot de passe de CPU F de sécurité dans la colonne "Mot de passe dans la CPU" pour formater une carte mémoire SIMATIC dans un appareil de sécurité.

Vous devez confirmer une invite supplémentaire et sélectionner de nouveau votre appareil si le programme installé dans la CPU F est un programme de sécurité.

Les demandes de formatage de cartes mémoire pour les appareils de sécurité sont placées dans la file d'attente des opérations relatives à la sécurité et seul un traitement séquentiel à fil unique est autorisé.

Dans cet exemple, SIMATIC Automation Tool formate les cartes mémoire des appareils sélectionnés lorsque vous cliquez sur le bouton "Continuer".

Le journal d'événements sous la table des appareils montre le résultat de cette opération.

Formater une carte mémoire n'a pas d'effet sur l'adresse IP de l'appareil.


Récupération des données de maintenance depuis des CPU

Fichiers de données de maintenance

Récupération des données de maintenance depuis des CPU

En cas de défaillance, une CPU enregistre des informations de défaut que vous pouvez charger dans votre console de programmation. Vous pouvez envoyer ces ces données de maintenance à l'assistance client de Siemens à des fins de diagnostic

Vous pouvez récupérer les données de maintenance lorsque la CPU est en mode STOP ou RUN. Les données de maintenance contiennent plusieurs fichiers qui sont compressés dans un seul fichier .zip dont le nom reprend le nom de l'API et l'adresse MAC. Un chiffre est ajouté au nom du fichier pour éviter tout doublon.

Vous configurez ou acceptez le chemin des données de maintenance (service data) par défaut à partir de Paramètres des données de maintenance.

Pour récupérer les données de maintenance depuis des CPU sélectionnées, procédez comme suit :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Pour chaque CPU sélectionnée, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU" de l'onglet ouvert.

  3. Sélectionner la commande "Opérations > Diagnostic > Récupérer les données de maintenance" pour démarrer l'opération. Vous pouvez également cliquer sur le bouton "Afficher le diagnostic de l'appareil" [image] de la barre d'outils et sélectionner "Récupérer les données de maintenance" dans le menu déroulant.

  4. Cliquez sur le bouton "Continuer" dans la boîte de dialogue "Chargement service data".

L'outil d'automatisation SIMATIC récupère les données de maintenance des CPU sélectionnées et stocke les fichiers dans le dossier de service data.

Exemple :

Une fois que vous avez cliqué sur le bouton "Continuer", l'outil d'automatisation SIMATIC récupère les données de maintenance des appareils sélectionnés.

Le journal d'événements (Event Log) sous la table des appareils montre le résultat de cette opération.

Fichiers de données de maintenance

Remarque

Récupérer les fichiers de données de maintenance dans des CPU protégées par mot de passe

Si une CPU est protégée par mot de passe, vous devez fournir un mot de passe avec accès en lecture ou accès complet pour récupérer les fichiers de données de maintenance. Saisissez les mots de passe de la CPU dans la colonne "Mot de passe dans la CPU" de SIMATIC Automation Tool avant d'exécuter la commande "Récupérer les données de maintenance".

Exemple de fichier de données de maintenance pour S7-1200 : PLC_1 00-1C-06-13-58-10.zip

Contenu du fichier .zip :

  • ResourceStats.txt

  • RAM.img

  • PLCInformation.txt

  • NAND.img

  • General.txt

  • Fault.bin

  • Fault2.bin

  • DNN.txt

  • CommBuffers.txt

  • ASLog.txt

  • Alarms.txt

Les fichiers de données de maintenance S7-1500 sont similaires. Ils contiennent un sous-ensemble des fichiers ci-dessus.

Attention

Les données de maintenance sont affichées en texte clair.

Un utilisateur mal intentionné pourrait lire les fichiers des données de maintenance pour se procurer les états et les détails de la configuration du système de conduite. Les fichiers de données de maintenance sont enregistrés en texte clair non crypté (codage binaire) dans la CPU. Un mot de passe CPU peut contrôler l'accès à ces informations.

Le fait de faire fonctionner un processus ou une machine avec des données corrompues peut affecter l'exécution d'un processus ou le fonctionnement d'une machine en ligne. Le démarrage inattendu d'un processus ou d'une machine peut entraîner la mort ou des dommages corporels et/ou matériels.

Utilisez la configuration de l'appareil dans TIA Portal pour définir une protection CPU à l'aide d'un mot de passe fort. Les mots de passe forts contiennent au moins dix caractères, lettres, chiffres et caractères spéciaux mélangés, ne sont pas des mots du dictionnaire et ne sont pas des noms ou identifiants pouvant être déduits de vos données personnelles. Ne divulguez pas le mot de passe et changez-en fréquemment.


Réglage de l'heure des CPU sur celle de la console de programmation

Réglage de l'heure des CPU sur celle de la console de programmation

Le bouton Heure règle l'heure des CPU sélectionnées sur celle de votre console de programmation. Les informations relatives au fuseau horaire et à l'heure d'été ne sont pas modifiées et doivent être changées dans le projet TIA Portal.

Attention

La modification de l'heure de la CPU peut perturber l'exécution d'un processus.

La modification de l'heure de la CPU peut perturber l'exécution d'un processus pour les programmes STEP 7 qui exécutent une logique de programme basée sur l'heure.

Le démarrage inattendu d'un processus ou d'une machine peut entraîner la mort ou des dommages corporels et/ou matériels.

Assurez-vous que l'heure réglée n'a pas d'effets indésirables dans le programme STEP 7.

Vous devez avoir accès en écriture à une CPU pour en régler l'heure.

Procédez comme suit pour régler l'heure de la CPU sur celle de la console de programmation :

  1. Sélectionnez un ou plusieurs appareils à inclure dans l'opération. Vous pouvez utiliser la case à cocher Appareil située en haut de la table des appareils pour sélectionner ou désélectionner tous les appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou la commande de menu "Modifier > Sélectionner" pour accéder aux commandes "Sélectionner tout" et "Désélectionner tout".

  2. Pour chaque CPU sélectionnée, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU" de l'onglet ouvert.

  3. Sélectionnez la commande de menu "Opérations > Régler l'heure" ou cliquez sur le bouton "Régler l'heure des appareils sélectionnés" [image] de la barre d'outils.

  4. Cliquez sur le bouton "Continuer" dans la boîte de dialogue "Régler l'heure".

SIMATIC Automation Tool règle l'heure système des appareils sélectionnés sur celle de votre console de programmation.

Le journal d'événements sous la table des appareils montre le résultat de cette opération.


Affichage du tampon de diagnostic

Exemple de tampon de diagnostic
Paramètres de communication
Démarrer Précédent Suivant

Affichage du tampon de diagnostic

Un tampon de diagnostic CPU contient une entrée pour chaque événement de diagnostic. Chaque entrée inclut la date et l'heure auxquelles l'événement s'est produit, une catégorie d'événement, ainsi qu'une description de l'événement. Le tampon de diagnostic affiche les entrées par ordre chronologique, l'événement le plus récent se trouvant en haut. Lorsque le journal est plein, l'événement le plus ancien dans le journal est remplacé par un nouvel événement. En cas de coupure de courant, les événements sont sauvegardés.

Vous devez avoir accès en lecture ou l'accès complet à une CPU pour afficher sa mémoire tampon de diagnostic.

Pour afficher le diagnostic de l'appareil, procédez comme suit :

  1. Sélectionnez une ou plusieurs CPU dans la table des appareils. Si vous souhaitez d'abord désélectionner tous les appareils, vous pouvez décocher la case Appareil située en haut de la table des appareils. Vous pouvez également utiliser le menu contextuel (clic droit) ou le menu "Modifier > Sélectionner" pour accéder à la commande "Désélectionner tout".

  2. Pour chaque CPU sélectionnée, entrez un mot de passe, le cas échéant, dans la colonne "Mot de passe dans la CPU" de l'onglet ouvert.

  3. Sélectionner la commande de menu "Opérations > Diagnostic > Afficher le diagnostic". Vous pouvez également cliquer sur le bouton "Afficher le diagnostic de l'appareil" [image] de la barre d'outils et sélectionner "Afficher le diagnostic de CPU" dans le menu déroulant.

SIMATIC Automation Tool affiche alors une boîte de dialogue contenant les tampons de diagnostic des CPU sélectionnées. Vous pouvez sélectionner une CPU à partir de la liste des appareils à gauche pour voir le tampon de diagnostic de cette CPU.

Remarque

La mémoire tampon de diagnostic affiche les événements dans l'ordre où ils se sont produits, indépendamment de la date et de l'heure de l'événement. Régler l'horloge de la CPU à une heure dans le passé n'a aucun effet sur l'ordre des événements.

Exemple de tampon de diagnostic

Le tampon de diagnostic contient les types d'entrées suivants :

  • Événement de diagnostic système (toutes les erreurs de CPU et de module)

  • Changement d'état de la CPU (chaque mise sous tension, passage en mode STOP, passage en mode RUN)

Vous pouvez utiliser la case à cocher "Afficher l'horodatage de l'appareil dans l'heure locale du PG/PC" pour visualiser les horodatages en heure locale ou en heure UTC (Coordinated Universal Time).


Affichage des références aux appareils

Affichage des références aux appareils

Vous pouvez afficher les références aux appareils se situant au niveau supérieur dans le catalogue des appareils ou aux appareils dans un réseau PROFINET IO. SIMATIC Automation Tool fournit une commande Afficher les références. Cette commande est disponible dans le menu Édition ou dans le menu contextuel de la table des appareils lorsque vous sélectionnez un appareil de niveau supérieur ou un appareil dans un réseau PROFINET IO.

Lorsque vous sélectionnez Afficher les références, SIMATIC Automation Tool affiche toutes les références à l'appareil que vous avez sélectionné en se basant sur son numéro de série. SIMATIC Automation Tool développe si nécessaire les lignes d'appareils pour montrer les références à l'appareil :


Copier et coller dans plusieurs cellules de la table des appareils

Comment utiliser la fonction Copier et coller rapide Copier et coller des valeurs incrémentées
Démarrer Précédent Suivant

Copier et coller dans plusieurs cellules de la table des appareils

SIMATIC Automation Tool facilite la copie du contenu d'une cellule dans de nombreuses cellules de la même colonne. Par exemple, si vous voulez mettre à jour le firmware dans de nombreux appareils de même type, vous pouvez sélectionner le fichier Nouvelle version firmware une fois et utiliser une technique de glisser-déposer pour copier ce choix dans la cellule Nouvelle version firmware des autres appareils.

Cette fonction Copier et coller rapide opère comme une opération d'édition unique dans une colonne. Vous n'avez pas besoin de répéter la copie dans plusieurs cellules. Comme dans Microsoft Excel, vous pouvez sélectionner plusieurs cellules à coller en faisant glisser le pointeur de la souris sur une sélection de cellules. SIMATIC Automation Tool reconnaît quelles cellules sont valides pour l'opération Coller et quelles cellules ne le sont pas. Il colle le contenu copié uniquement dans les cellules qui sont valides.

La fonction Copier et coller rapide est disponible pour toutes les colonnes à saisie utilisateur de la table des appareils.

Comment utiliser la fonction Copier et coller rapide

Supposons que vous ayez un grand nombre de CPU du même type (par exemple, beaucoup de CPU S7-1200 1215C DC/DC/DC). Vous voulez mettre à jour toutes ces CPU à la version de firmware V04.02.00 qui est disponible dans votre dossier de mise à jour du firmware. Vous avez également d'autres types de CPU dans votre table des appareils. Vous ne voulez pas copier manuellement la nouvelle version de firmware dans toutes les CPU S7-1200 1215C DC/DC/DC en sautant les autres appareils.

Procédez comme suit pour copier une sélection de cellules dans plusieurs cellules pour cet exemple :

  1. Sélectionnez la nouvelle version de firmware pour l'une de vos CPU S7-1200 1215C DC/DC/DC, peut-être la première dans votre liste.

  2. Lorsque SIMATIC Automation Tool indique que votre sélection est valide, cliquez sur la cellule Nouvelle version firmware. SIMATIC Automation Tool affiche un rectangle de sélection pour la cellule. Il s'agit de la cellule source pour votre opération de copie :

  3. Faites glisser le coin inférieur droit du rectangle de sélection le long de la colonne Nouvelle version firmware. Comme Microsoft Excel, SIMATIC Automation Tool vous montre les cellules que vous incluez dans votre nouveau rectangle de sélection. Vous pouvez sélectionner au choix l'ensemble de la colonne ou juste quelques cellules :

  4. Relâchez le bouton gauche de la souris pour copier votre sélection dans toutes les cellules du nouveau rectangle de sélection pour lesquelles la sélection d'origine est valide. Dans cet exemple, SIMATIC Automation Tool copie la cellule Nouvelle version de firmware V04.02.00 dans les cellules correspondant aux CPU S7-1200 1215C DC/DC/DC. SIMATIC Automation Tool n'effectue la copie que pour les CPU qui ont le même type et pour lesquelles la mise à jour du firmware est valide :

Vous pouvez utiliser la technique Copier et coller rapide pour toutes les colonnes à saisie utilisateur de la table des appareils. Cette technique peut représenter un gain de temps pour beaucoup d'opérations où vous voulez copier un choix à de nombreux endroits, par exemple :

  • Sélection d'appareils

  • Fichiers de sauvegarde

  • Commentaires

  • Mises à jour du firmware

  • Passerelle

  • Mots de passe (CPU et fichier programme)

  • Mises à jour du programme

  • Recettes

  • Sous-réseau

Copier et coller des valeurs incrémentées

Pour les nouvelles adresses IP et les nouveaux noms PROFINET, la fonction Copier et coller incrémente le texte copié lors de l'insertion dans les cellules cibles :

  • Pour les nouvelles adresses IP, chaque adresse est incrémentée de 1 dans les cellules d'insertion.

  • Pour les nouveaux noms PROFINET, SIMATIC Automation Tool copie le nouveau nom PROFINET en ajoutant un incrément numérique à chaque nom dans les cellules d'insertion.

Remarque

Cellules masquées

Si vous avez masqué une ou plusieurs lignes de cellules, l'opération Coller insère la sélection dans les cellules masquées. Lorsque vous réaffichez les lignes masquées, vous pouvez voir le contenu collé.


Ordre d'exécution des opérations

Exemples d'exécution

Ordre d'exécution des opérations

De nombreuses commandes de menu ou opérations de barre d'outils de SIMATIC Automation Tool génèrent des entrées dans le tampon de diagnostic. A chaque pression sur un bouton, SIMATIC Automation Tool ajoute une unique opération à la file d'attente pour chaque ligne d'appareil sélectionnée. Par exemple, si vous sélectionnez 20 CPU différentes et que vous cliquez sur le bouton RUN, SIMATIC Automation Tool ajoute 20 opérations RUN à la file d'attente.

Afin d'améliorer la performance, il est possible de lancer des threads séparés pour lancer et exécuter les opérations de la file d'attente. Vous assignez le nombre d'opérations simultanées sous Paramètres de communication. Il n'est pas permis d'utiliser plusieurs fils (threads) pour lancer des tâches simultanément sur une CPU afin d'éviter toute concurrence entre les tâches. Par exemple, une tâche ne peut pas mettre la CPU en mode STOP alors qu'une autre tente de placer la même CPU en mode RUN.

Exemples d'exécution

Exemple 1 :

Si la file d'attente contient 10 tâches Passer en RUN pour différentes CPU, des threads multiples travaillent en parallèle pour mettre toutes les CPU en mode RUN. Comme les exécutions sont en parallèle, l'ordre dans lequel les CPU opèrent leur transition en RUN n'est pas garanti. Les vitesses de communication peuvent être différentes pour chaque CPU. La durée nécessaire pour effectuer une tâche peut aussi varier d'une CPU à l'autre.

Exemple 2 :

Vous pouvez mettre en file d'attente autant de tâches que vous le souhaitez. Par exemple, vous pouvez mettre 100 CPU en mode STOP en les sélectionnant toutes et en cliquant sur le bouton STOP. SIMATIC Automation Tool affiche une boîte de dialogue contenant une barre de progression jusqu'à ce que les 100 tâches soient terminées. SIMATIC Automation Tool bloque le démarrage d'une autre opération jusqu'à ce que toutes les opérations STOP soient terminées.


Gestion des fichiers de projet

Gestion des fichiers de projet

Ce chapitre contient des informations sur les sujets suivants :
  • Création, sauvegarde et ouverture de fichiers de projet .sat
  • Exporter des informations depuis SIMATIC Automation Tool


Création, sauvegarde et ouverture de fichiers de projet .sat

Créer un nouveau fichier projet Enregistrement d'un fichier projet Ouverture d'un fichier projet Instructions pour la sauvegarde et l'ouverture de fichiers de projet : Éléments à prendre en compte lors du transfert d'un fichier de projet .sat d'une console de programmation à une autre Protection du fichier .sat SIMATIC Automation Tool Validation du mot de passe Compatibilité des fichiers de projet avec les versions précédentes
Démarrer Précédent Suivant

Création, sauvegarde et ouverture de fichiers de projet .sat

Créer un nouveau fichier projet

Pour créer un nouveau fichier projet avec une table des appareils vide, utilisez la commande de menu "Fichier > Nouveau".

Enregistrement d'un fichier projet

Utilisez la commande de menu "Fichier > Enregistrer"ou"Fichier > Enregistrer sous" ou cliquez sur le bouton Enregistrer [image] pour stocker votre projet dans un fichier projet .sat chiffré. Ce fichier de projet contient les informations de votre table des appareils. Le fichier de projet n'enregistre pas le mode de fonctionnement de l'appareil, l'état de sélection ou la confirmation des données d'état de sélection.

Ouverture d'un fichier projet

Une fois que vous avez enregistré un projet SIMATIC Automation Tool, vous pouvez utiliser la commande de menu "Fichier > Ouvrir" ou le bouton Ouvrir [image] pour restaurer les informations de la table des appareils de ce projet. Vous pouvez utiliser la commande Actualiser pour lire les états du mode de fonctionnement.

Instructions pour la sauvegarde et l'ouverture de fichiers de projet :

Tenez compte des instructions suivantes pour la sauvegarde et l'ouverture de fichiers de projet :

  • Les paramètres du projet déterminent le dossier de sauvegarde des fichiers de projet .sat.

  • Vous devez fournir un mot de passe valide pour enregistrer un fichier projet .sat SIMATIC Automation Tool.

  • Vous devez saisir le mot de passe correct pour rouvrir un fichier projet .sat SIMATIC Automation Tool existant.

Éléments à prendre en compte lors du transfert d'un fichier de projet .sat d'une console de programmation à une autre

Vous pouvez sauvegarder un projet SIMATIC Automation Tool sur une console de programmation, puis le transférer pour l'ouvrir sur un autre ordinateur. Le fichier de projet .sat contient toutefois uniquement la table des appareils et les paramètres configurés par le menu Options. Les paramètres du menu Options comprennent les chemins d'accès aux dossiers de fichiers pour plusieurs types d'opérations. Vous devez transférer les fichiers de ces dossiers de la console de programmation source vers la console de programmation cible pour les opérations sur les appareils suivantes :

  • Mises à jour du firmware : Pour avoir les fichiers de mise à jour du firmware sur la console de programmation cible, vous devez transférer le dossier Mise à jour du firmware.

  • Mise à jour du programme : Pour que les fichiers de mise à jour du programme soient disponibles sur la console de programmation cible, vous devez transférer le dossier Mise à jour du programme.

  • Données de maintenance : Pour pouvoir accéder aux données de service que vous avez auparavant récupérées, vous devez transférer le dossier Données de maintenance.

  • Sauvegarde / Restauration : Pour que les fichiers de sauvegarde de la console de programmation source soient disponibles pour une restauration à partir de la console de programmation cible, vous devez transférer le dossier Sauvegarde et restauration.

  • Recettes : Pour que les fichiers de recette soient disponibles au chargement à partir de la console de programmation cible, vous devez transférer le dossier Recette.

  • Data Logs : Pour pouvoir accéder aux data logs que vous avez récupérées, vous devez transférer le Dossier Data Logs.

  • Journal des événements (Event Log) : Si vous avez sauvegardé le journal des événements et que vous voulez qu'il soit disponible sur votre console de programmation cible, vous devez transférer le dossier Event Log.

  • Exporter : pour pouvoir copier depuis la table des appareils les fichiers exportés depuis SIMATIC Automation Tool, vous devez transférer le dossier d'exportation.

  • Profils SNMP : pour disposer des profils SNMP pour les appareils SCALANCE sur la console de programmation cible, vous devez transférer le dossier Profil SNMP.

Protection du fichier .sat SIMATIC Automation Tool

Vous devez protéger votre projet avec un mot de passe. Siemens vous recommande de votre projet SIMATIC Automation Tool à l'aide d'un mot de passe fort. Les mots de passe fiables respectent les règles suivantes :

  • Au moins dix caractères

  • Mélange de lettres, de chiffres et de caractères spéciaux

  • Combinez des caractères majuscules et minuscules

  • Ne correspondent pas à des entrées de dictionnaires.

  • Ce ne sont pas des noms ni des identifiants pouvant être déduits de vos données personnelles.

Ne divulguez pas le mot de passe et changez-en fréquemment.

Vous devez saisir le mot de passe de projet pour ouvrir un fichier .sat.

Validation du mot de passe

Lorsque vous créez un mot de passe de projet, SIMATIC Automation Tool indique que le mot de passe est faible, si l'une des conditions suivantes est présente :

  • Le mot de passe comprend moins de dix caractères

  • Le mot de passe ne comprend pas au moins un des caractères suivants :

    • Caractère majuscule

    • Caractère minuscule

    • Nombre

    • Caractère spécial

Compatibilité des fichiers de projet avec les versions précédentes

Vous pouvez ouvrir un fichier de projet V3.1 ou plus avec SIMATIC Automation Tool V3.1 SP4 sans perte de données.

SIMATIC Automation Tool V3.1 et les versions supérieures prennent en charge les opérations de sécurité qui étaient interdites dans V3.0 et les versions antérieures. Les fichiers de projet .sat de version V3.0 ou antérieure ne contiennent pas de données de sécurité. Lorsque vous ouvrez un fichier de projet V2.x - V3.0, SIMATIC Automation Tool vous informe qu'un scan réseau doit être effectué. Une fois le scan terminé, SIMATIC Automation Tool ouvre le fichier de projet et applique les données du fichier de projet aux appareils identifiés lors de l'analyse du réseau.

L'ouverture des fichiers de projet V1.x n'est pas possible.

Vous ne pouvez pas ouvrir un projet V3.1 SP4 avec une version antérieure de SIMATIC Automation Tool.


Exporter des informations depuis SIMATIC Automation Tool

Exporter des informations depuis SIMATIC Automation Tool

Ce chapitre contient des informations sur les sujets suivants :
  • Exporter des informations depuis SIMATIC Automation Tool
  • Exporter les informations appareil
  • Exporter le diagnostic appareil
  • Exporter les données PC


Exporter des informations depuis SIMATIC Automation Tool

Exporter des informations depuis SIMATIC Automation Tool

SIMATIC Automation Tool fournit des commandes de menu pour exporter les types d'informations suivants :

  • Informations appareil dans la table des appareils

  • Diagnostic appareil

  • Données PC :

    • Informations sur la console de programmation que vous utilisez pour faire fonctionner SIMATIC Automation Tool

    • Informations sur les applications Siemens qui sont installées sur votre console de programmation

Pour les informations appareil et le diagnostic appareil, vous pouvez choisir d'exporter les données pour tous les appareils ou pour une sélection d'appareils. SIMATIC Automation Tool enregistre les données au format .csv.

Contrairement aux versions précédentes de SIMATIC Automation Tool, vous n'avez plus besoin d'une commande d'importation pour remplir la table des appareils à partir d'un fichier exporté. En raison de la flexibilité et de la personnalisation du fichier d'informations appareil exporté, vous pouvez utiliser copier/coller pour restaurer dans la table des appareils les informations appareil exportées.

Les commandes de menu pour l'exportation sont les suivantes :

  • Fichier > Exportation > Informations appareil > Tous les appareils : Enregistre toute la table des appareils dans un fichier .csv.

  • Fichier > Exportation > Informations appareil > Tous les appareils sélectionnés : Enregistre la table des appareils pour les appareils sélectionnés dans un fichier .csv

  • Fichier > Exportation > Diagnostic appareil > Tous les appareils : Enregistre les données tampon de diagnostic pour tous les appareils éligibles dans un fichier .csv Actuellement, les CPU prennent en charge l'exportation des diagnostics d'appareil.

  • Fichier > Exportation > Diagnostic appareil > Tous les appareils sélectionnés : Enregistre les données tampon de diagnostic pour les appareils éligibles sélectionnés dans un fichier .csv

  • Fichier > Exportation > Données PC > PC local : Enregistre les informations sur le système d'exploitation, le processeur, la mémoire, les applications Siemens installées et d'autres informations système dans un fichier .zip.


Exporter les informations appareil

Format du fichier .csv d'informations appareil Utilisation du copier-coller comme mode d'exportation alternatif Exemple d'exportation d'informations appareil Conflits d'adresse IP entre le réseau et le fichier .csv exporté
Démarrer Précédent Suivant

Exporter les informations appareil

Lorsque vous exportez les informations appareil, SIMATIC Automation Tool crée et enregistre un fichier .csv représentant les données actuelles de la table des appareils. SIMATIC Automation Tool n'effectue pas un nouveau scan, ni une actualisation du réseau. L'exportation contient les données actuelles de la table des appareils.

Pour exporter les informations appareil, sélectionnez une des commandes de menu suivantes :

  • Fichier > Exportation > Informations appareil > Tous les appareils

  • Fichier > Exportation > Informations appareil > Tous les appareils sélectionnés

Les lignes du fichier .csv correspondent aux appareils, aux dossiers de modules locaux et aux dossiers de périphérie décentralisée, si ces dossiers existent. Dans chaque type de ligne, les en-têtes de colonnes vous indiquent les types de données contenus dans les lignes.

Les Paramètres d'exportation fournissent le chemin de fichier pour l'exportation de la table des appareils.

Pour des raisons de sécurité, SIMATIC Automation Tool n'exporte pas les mots de passe de CPU.

Vous pouvez ouvrir et éditer le fichier .csv dans Microsoft Excel ou dans un éditeur de texte. Pour copier les contenus de fichier édités dans SIMATIC Automation Tool, vous devez conserver le format de la table des appareils. La table des appareils de SIMATIC Automation Tool contient des données de configuration de la communication. Si vous placez des informations incorrectes dans les cellules d'une table d'appareils, les opérations sur l'appareil peuvent échouer. Corrigez les données de l'appareil et renouvelez l'opération.

Format du fichier .csv d'informations appareil

Le format du fichier .csv d'informations appareil correspond à la structure de la table des appareils. Le fichier informations appareil utilise la structure suivante :

  • Ligne d'en-tête : La première ligne est une ligne d'en-tête qui contient les noms d'en-tête de colonne de la table des appareils.

    • Appareil

    • Emplacement

    • Type d'appareil

    • Référence

    • Numéro de série

    • Version de firmware

    • Matériel

    • Adresse MAC

    • Adresse IP

    • Sous-réseau

    • Passerelle

    • Nom PROFINET

    • Nom PROFINET converti

  • Ligne appareil : Chaque appareil de la table des appareils apparaît dans une ligne du fichier .csv avec ses données d'appareil dans chaque colonne. Toutes les colonnes de la table des appareils SIMATIC Automation Tool se trouvent dans un fichier .csv exporté. Si vous masquez des colonnes dans SIMATIC Automation Tool, les données correspondant aux colonnes masquées apparaissent quand même dans le fichier .csv. Le masquage des colonnes dans SIMATIC Automation Tool n'a aucun effet sur le contenu du fichier .csv.

  • Ligne dossier modules locaux Si un appareil possède des modules locaux, le .csv comprend une ligne Modules Locaux avec les en-têtes de colonnes suivants :

    • Appareil

    • Emplacement

    • Type d'appareil

    • Référence

    • Numéro de série

    • Version de firmware

    • Matériel

  • Ligne modules locaux : Chaque module local apparaît dans le fichier .csv avec ses données de module dans chaque colonne. Les données de module sont disponibles dans le fichier lorsque SIMATIC Automation Tool peut lire les données de module et que les données sont visibles dans la table des appareils.

  • En-tête périphérie décentralisée : Une ligne marquée "Périphérie décentralisée" indique que les lignes suivantes représentent des modules de périphérie décentralisée.

  • En-tête dossier système de périphérie décentralisée : Une ligne pour le système de périphérie décentralisée contient le nom du système de périphérie décentralisée et les noms d'en-têtes de colonnes suivants :

    • Appareil

    • Emplacement

    • Type d'appareil

    • Référence

    • Numéro de série

    • Version de firmware

    • Matériel

  • En-tête de ligne système de périphérie décentralisée : Chaque appareil dans le système de périphérie décentralisée apparaît dans une ligne avec les données appareil dans les colonnes correspondantes. Les données d'appareil de périphérie décentralisée sont disponibles dans le fichier lorsque SIMATIC Automation Tool peut lire les données appareil et que les données sont visibles dans la table des appareils.

  • Ligne module de périphérie décentralisée : Chaque module pour chaque appareil de périphérie décentralisée apparaît dans une ligne avec les données appareil dans les colonnes correspondantes. Les données de module sont disponibles dans le fichier lorsque SIMATIC Automation Tool peut lire les données de module et que les données sont visibles dans la table des appareils.

Une exportation d'informations appareil ne comprend pas les journaux de données ou les recettes qui se trouvent dans la CPU.

Remarque

Protection et mots de passe CPU

Pour les CPU protégées de la table des appareils, SIMATIC Automation Tool exporte uniquement le module local et les informations de périphérie décentralisée pour la CPU, si la table des appareils comprend un mot de passe CPU ayant un accès en lecture ou supérieur.

Utilisation du copier-coller comme mode d'exportation alternatif

Remarque

Copie entre la table des appareils et Microsoft Excel.

Vous pouvez copier/coller des cellules sélectionnées depuis la table des appareils vers un fichier Microsoft Excel :

  1. Développez toutes les lignes dans la table des appareils avec la commande de menu Edition > Développer tous les appareils.

  2. Appuyez sur Ctrl+A pour sélectionner toutes les lignes et colonnes ou tirez pour effectuer une sélection de plusieurs cellules.

  3. Appuyez sur Ctrl+C pour copier les données de la table des appareils dans le presse-papiers Windows.

  4. Appuyez sur Ctrl+V pour coller les données du presse-papiers dans une feuille de calcul Microsoft Excel.

La fonction d'exportation vous permet de copier tous les appareils sélectionnés à un format lisible. La copie depuis la table des appareils n'est pas typiquement nécessaire, mais elle est possible. Vous pouvez par exemple utiliser copier/coller pour modifier des informations appareil saisies par l'utilisateur.

Exemple d'exportation d'informations appareil

Lorsque vous ouvrez un fichier d'informations appareil exporté dans Microsoft Excel, la largeur des colonnes est fixe.

Pour élargir les colonnes à des fins de lecture, procédez comme suit :

  1. Cliquez sur le petit triangle dans le coin supérieur gauche entre la Ligne 1 et la Colonne A pour sélectionner toute la feuille de calcul.

  2. Sur la ligne de colonne de Microsoft Excel, double-cliquez entre deux colonnes au choix pour élargir la colonne. Par exemple, double-cliquez sur le séparateur de colonne entre A et B.

La figure suivante montre une exportation d'informations appareil ouverte dans Microsoft Excel avec des colonnes élargies :

Vous pouvez éditer les données dans le fichier Microsoft Excel. Vous pouvez également zoomer pour rendre le contenu plus lisible. Si vous ajoutez ou supprimez des lignes, assurez-vous de conserver le format et la hiérarchie. Lorsque vous copiez des cellules vers la table des appareils SIMATIC Automation Tool, suivez ces étapes pour afficher tous les appareils et les fichiers :

  1. Copiez et collez les cellules dont vous avez besoin de Microsoft Excel vers la table des appareils.

  2. Dans SIMATIC Automation Tool, saisissez à nouveau les mots de passe pour les CPU protégées.

  3. Sélectionnez tous les appareils dans la table des appareils.

  4. Actualisez la table des appareils à l'aide de la commande de menu Opérations> Scan du réseau> Rafraîchir l'état de tous les appareils sélectionnés. Vous pouvez aussi exécuter cette commande à partir du bouton de la barre d'outils.

Remarque

Affichage de fichiers .csv dans le Bloc-notes Microsoft ou Microsoft Excel

En raison de jeux de caractères différents, le Bloc-notes Microsoft et Microsoft Excel peuvent ne pas afficher correctement les caractères dans votre fichier .csv. Ouvrez le fichier en utilisant le jeu de caractères Unicode (UTF-8) pour visualiser les caractères de votre langue qui ne seraient pas visibles autrement. Indépendamment de la représentation des textes d'en-tête, vous pouvez exporter des fichiers de projet et copier le contenu des fichiers exportés dans SIMATIC Automation Tool.

Conflits d'adresse IP entre le réseau et le fichier .csv exporté

Vous pouvez ouvrir un fichier .csv exporté dans Microsoft Excel. Vous pouvez alors copier/coller les données d'appareil depuis Microsoft Excel dans la table des appareils SIMATIC Automation Tool. Les données copiées peuvent comprendre un appareil avec une adresse IP correspondant à l'adresse IP d'un autre appareil actuellement sur votre réseau. Toutefois la table des appareils montre l'appareil qui se trouve actuellement à cette adresse IP sur votre réseau.

Considérez le scénario suivant :

  • Sur votre réseau, vous avez actuellement une CPU S7-1200 nommée "PLC_1" à l'adresse IP X1 : 192.168.2.202.

  • Vous copiez les données d'appareil depuis un fichier .csv d'informations appareil préalablement exporté qui contient les lignes suivantes :

  • Vous collez les données copiées dans la table des appareils SIMATIC Automation Tool.

  • Le journal d'événements signale une opération terminée avec succès pour l'appareil SCALANCE-202.

  • La table des appareils montre "PLC_1" à l'adresse IP X1 : 192.168.2.202, non "SCALANCE-202". La table des appareils comprend tous les champs correspondant à PLC_1.

Résultat : Le fait de copier/coller depuis un fichier .csv n'écrase pas les données d'appareil pour un appareil actuellement sur le réseau, lorsqu'il existe un conflit d'adresse IP.


Exporter le diagnostic appareil

Format du fichier .csv diagnostic appareil

Exporter le diagnostic appareil

Lorsque vous exportez le diagnostic appareil, SIMATIC Automation Tool crée et enregistre un fichier .csv contenant les tampons de diagnostic de la CPU.

Pour exporter le diagnostic appareil CPU, sélectionnez une des commandes de menu suivantes :

  • Fichier > Exportation > Informations appareil > Tous les appareils

  • Fichier > Exportation > Informations appareil > Tous les appareils sélectionnés

Format du fichier .csv diagnostic appareil

Les tampons de diagnostic pour les appareils exportés se trouvent dans un seul fichier .csv. Des lignes d'en-tête séparent la fin du tampon de diagnostic d'un appareil du début du tampon de diagnostic de l'appareil suivant.

Chaque appareil commence avec une ligne d'en-tête comprenant les en-têtes de colonnes suivants :

  • Appareil

  • Date

  • Heure

  • Type d'événement

  • Événement

  • Description d'événement

Les événements de tampon de diagnostic occupent les lignes suivantes dans le fichier et contiennent tous les événements du tampon de diagnostic actuel de l'appareil.

L'appareil suivant débute avec une nouvelle ligne d'en-tête. Les événements de tampon de diagnostic pour cet appareil se succèdent dans les lignes. Le fichier continue avec tous les appareils ou une sélection d'appareils, en fonction de votre sélection.

Remarque

L'exportation du diagnostic appareil à partir d'une table des appareils de taille importante peut prendre un certain temps. SIMATIC Automation Tool affiche une barre de progression durant l'exportation. Vous pouvez annuler une opération d'exportation en cours.


Exporter les données PC

Exporter les données PC

SIMATIC Automation Tool fournit la capacité d'exporter des données sur votre PC et des fichiers qui peuvent être utiles pour résoudre des problèmes. Lorsque vous exportez des données PC, SIMATIC Automation Tool crée et enregistre un fichier .zip avec des informations sur la console de programmation sur laquelle fonctionne SIMATIC Automation Tool. Vous pouvez fournir ces informations à Siemens à la demande en cas de problèmes.

Pour exporter des données PC, sélectionnez la commande de menu "Fichier > Exportation > Données PC > PC local". SIMATIC Automation Tool sauvegarde le fichier .zip des données PC dans le dossier Exportation.


Menus, barres d'outils, raccourcis clavier et informations de référence

Menus, barres d'outils, raccourcis clavier et informations de référence

Ce chapitre contient des informations sur les sujets suivants :
  • Menu principal
  • Icônes de la barre d'outils
  • Raccourcis clavier
  • Définition du programme de sécurité
  • Défaillances du programme SIMATIC Automation Tool


Menu principal

Menu principal

Ce chapitre contient des informations sur les sujets suivants :
  • Menu principal
  • Menu Fichier
  • Menu Edition
  • Menu Opérations
  • Menu Options
  • Menu Outils
  • Menu Aide


Menu principal

Menu principal

SIMATIC Automation Tool inclut les menus suivants pour effectuer les opérations sur les appareils.

  • Fichier

  • Modifier

  • Opérations

  • Options

  • Outils

  • Aide

Si vous appuyez sur la touche Alt, la lettre soulignée indique la touche Alt que vous pouvez utiliser pour activer une commande de menu ou de sous-menu.

De plus, vous pouvez activer certaines des commandes de menu avec des raccourcis clavier.


Menu Fichier

Menu Fichier

Icône
outil

Commandes de menu

Description

Nouveau

Crée un nouveau projet SIMATIC Automation Tool

Ouvrir

Affiche une boite de dialogue "Ouvrir" permettant de naviguer vers un dossier, de sélectionner un fichier de projet .sat et de saisir un mot de passe pour ouvrir un fichier projet protégé. La boîte de dialogue "Ouvrir" affiche le dossier du projet, mais vous pouvez naviguer vers n'importe quel emplacement pour un projet.

Enregistrer

Enregistrer les données de la table des appareils dans un fichier .sat. En l'absence de nom de fichier, l'opération utilise la commande "Enregistrer sous". Le dossier du projet est le dossier par défaut pour l'enregistrement des projets.

Enregistrer sous

Enregistrer les données de la table des appareils dans un fichier .sat. Vous pouvez parcourir un dossier, donner un nom de fichier .sat et définir un mot de passe pour protéger le fichier projet.

Exporter

  • Informations appareil

    • Tous les appareils sélectionnés

Enregistre la table des appareils pour les appareils sélectionnés, y compris les modules locaux et la périphérie décentralisée dans un fichier .csv

  • Informations appareil

    • Tous les appareils

Enregistre la table des appareils pour tous les appareils, y compris les modules locaux et la périphérie décentralisée dans un fichier .csv

  • Diagnostic appareil

    • Tous les appareils sélectionnés

Enregistre les données tampon de diagnostic pour les appareils sélectionnés dans un fichier .csv

  • Diagnostic appareil

    • Tous les appareils

Enregistre les données tampon de diagnostic pour tous les appareils dans un fichier .csv

  • Données PC

    • PC local

Enregistre les données PC pour la console de programmation locale dans un fichier .zip.

Quitter

Fermer l'application. Si le projet a été modifié depuis la dernière opération d'enregistrement, SIMATIC Automation Tool vous donne l'occasion d'enregistrer le projet.


Menu Edition

Menu Edition

Icône
outil

Commandes
de menu

Description

Couper

Couper les données sélectionnées et les copier dans le presse-papier. Les données du presse-papier sont compatibles avec Microsoft Excel, ce qui permet un échange entre les deux applications. Les cellules en lecture seule ne sont pas supprimées.

Copier

Coller les données sélectionnées à partir du presse-papier dans un format compatible Microsoft Excel.

Coller

Coller les données du presse-papier dans les champs sélectionnés de SIMATIC Automation Tool. Les cellules en lecture seule ne sont pas copiées.

Sélectionner

  • Sélectionner les lignes

Sélectionner les lignes ciblées de la table des appareils.

  • Désélectionner les lignes

Désélectionner les lignes ciblées de la table des appareils.

Développer

  • Appareil

Développer l'appareil actif.

  • Tous les appareils sélectionnés

Développer tous les appareils sélectionnés.

  • Tous les appareils

Développer toutes les lignes des appareils et des modules.

Réduire

  • Appareil

Réduire l'appareil actif.

  • Tous les appareils sélectionnés

Réduire tous les appareils sélectionnés.

  • Tous les appareils

Réduire toutes les lignes des appareils et des modules.

Ajouter

  • Appareil

Ajouter un nouvel appareil sur la ligne sélectionnée et décaler les lignes d'appareil suivantes vers le bas. Vous pouvez utiliser cette commande pour ajouter rapidement un appareil à la table des appareils. Si vous utilisez cette commande pour ajouter un appareil situé derrière un routeur, le nom de cet appareil s'affiche en bleu. Le bleu signifie que les opérations basées sur l'adresse MAC (identifier l'appareil, définir l'adresse IP, définir le nom PROFINET) ne sont pas possibles et les cellules correspondantes de la table des appareils sont désactivées.

Supprimer

  • Texte de la cellule

Supprimer le contenu de la cellule active.

  • Appareil

Supprimer le contenu de la ligne d'appareil active.

  • Tous les appareils sélectionnés

Supprimer le contenu de tous les appareils sélectionnés.

  • Tous les appareils

Supprimer le contenu de toutes les lignes d'appareil.

Rafraîchir

  • Appareil

Actualiser l'appareil actif.

  • Tous les appareils sélectionnés

Actualiser tous les appareils sélectionnés.

  • Tous les appareils

Actualiser tous les appareils.

Afficher les références

Mettre en évidence toutes les références à l'appareil sélectionné dans la table des appareils.

L'appareil sélectionné doit être un appareil de niveau supérieur dans la table des appareils ou un appareil dans un réseau PROFINET IO.


Menu Opérations

Menu Opérations

Icône
outil

Commandes
de menu

Description

Scan du réseau

  • Scan du réseau entier

Recherche d'appareils sur le réseau.

  • Rafraîchir l'état de tous les appareils sélectionnés

Rafraîchir les appareils sélectionnés dans la table des appareils.

MARCHE

Mettre les CPU sélectionnées en mode RUN.

ARRÊT

Mettre les CPU sélectionnées en mode STOP.

Mettre à jour

  • Configurer l'adresse IP

Mettre à jour la CPU avec les informations d'adresse IP du ou des appareils sélectionnés.

  • Définir le nom PROFINET

Mettre à jour la CPU avec le nom PROFINET du ou des appareils sélectionnés.

  • Mise à jour du programme

Mettre à jour le programme CPU ou le système d'exploitation et le logiciel runtime IHM pour le ou les appareils sélectionnés.

  • Mise à jour du firmware

Mettre à jour le firmware du ou des appareils sélectionnés.

Identifier

Faire clignoter les LED des appareils ou les écrans IHM.

Utilisez cette fonctionnalité pour identifier l'emplacement physique d'un appareil.

Réinitialiser

  • Réinitialiser les paramètres de communication

Réinitialiser les paramètres de communication DCP pour les appareils qui prennent en charge la commande de réinitialisation DCP.

  • Effacement général de la mémoire

Réinitialiser la mémoire des appareils sélectionnés.

  • Restaurer les paramètres d'usine

Restaurer les paramètres d'usine des appareils sélectionnés.

  • Formater la carte mémoire

Formater la carte mémoire dans les appareils sélectionnés

Diagnostic

  • Afficher le diagnostic

Afficher le tampon de diagnostic pour une CPU sélectionnée.

  • Récupérer les données de maintenance

Récupérer les données de maintenance des appareils sélectionnés

Régler l'heure

Régler l'heure des CPU sélectionnées sur celle de votre console de programmation.

Sauvegarder l'appareil

  • Sauvegarde complète

Sauvegarder les données de tous les appareils sélectionnés The SIMATIC Automation Tool enregistre un fichier de sauvegarde pour chaque appareil sélectionné.

  • IHM

    • Recettes

Sauvegarder les recettes IHM.

  • IHM

    • Gestion des utilisateurs

Sauvegarder les données de gestion des utilisateurs IHM.

Restaurer l'appareil

Restaurer les données à partir de fichiers de sauvegarde vers le/les appareil(s) correspondant(s).

Opérations sur fichier

Remarque : les opérations sur les fichiers ne s'appliquent qu'aux fichiers de CPU.

  • Charger les Data logs

Charger les fichiers Data log sélectionnés sur votre console de programmation.

  • Supprimer des Data logs

Supprimer les fichiers Data log sélectionnés.

  • Charger les recettes

Charger des fichiers de recette des CPU sélectionnées dans votre console de programmation.

  • Ajouter/remplacer une recette

Ajouter/remplacer des fichiers de recette de la console de programmation vers les CPU sélectionnées.

Cette opération ajoute des recettes si elles n'existent pas et les remplace si elles existent.

  • Supprimer les recettes

Supprimer les recettes sélectionnées des CPU correspondantes.


Menu Options

Menu Options

Ce chapitre contient des informations sur les sujets suivants :
  • Menu Options
  • Noms de chemin de SIMATIC Automation Tool
  • Paramètres généraux
  • Paramètres de communication
  • Paramètres des projets
  • Paramètres de mise à jour du firmware
  • Paramètres de mise à jour du programme
  • Paramètres des données de maintenance
  • Paramètres de sauvegarde/restauration
  • Paramètres des recettes
  • Paramètres des journaux de données (Data logs)
  • Paramètres de l'Event Log
  • Paramètres d'exportation
  • Profils SNMP


Menu Options

Menu Options

Le menu Options contient les commandes de menu suivantes :

Icône
d'outil

Commande
de menu

Description

Paramètres

Ouvre la boîte de dialogue Paramètres, où vous pouvez définir les paramètres par défaut pour les catégories suivantes :

  • Général

  • Communications

  • Projets

  • Mise à jour du firmware

  • Mise à jour du programme

  • Données de maintenance

  • Sauvegarde / Restauration

  • Recettes

  • Data Logs

  • Event Log

  • Exporter

  • Profils SNMP

Pour les opérations d'appareils qui comprennent des opérations de fichier, les paramètres définissent le nom de chemin par défaut pour l'opération.

Démarrer Automation License Manager

Lance l'Automation License Manager avec lequel vous pouvez obtenir une licence pour SIMATIC Automation Tool.


Noms de chemin de SIMATIC Automation Tool

Différence entre le chemin affiché et la navigation vers un dossier Windows 7 Windows 10
Démarrer Précédent Suivant

Noms de chemin de SIMATIC Automation Tool

Les exemples de chemin d'accès dans la boîte de dialogue "Options > Paramètres" montrent les noms de chemin des dossiers dans C:\Users\MyAccount\SIMATIC Automation Tool\, où "MyAccount" représente votre identifiant utilisateur.

Utilisez la commande "Options > Paramètres" afin de fournir des chemins par défaut pour les emplacements de fichier suivants :

  • Projets

  • Mise à jour du firmware

  • Mise à jour du programme

  • Données de maintenance

  • Sauvegarder/Restaurer

  • Recettes

  • Data Logs

  • Event Log

  • Profils SNMP

Différence entre le chemin affiché et la navigation vers un dossier

La boîte de dialogue Paramètres affiche des chemins, par exemple, comme indiqué dans les paramètres de mise à jour du programme :

Si, dans la table des appareils, vous utilisez la fonction Parcourir pour localiser un fichier tel qu'un fichier de mise à jour du firmware ou un fichier de mise à jour du programme, vous ne voyez pas votre identifiant utilisateur apparaître sous forme de dossier sous "Utilisateurs". Vous voyez les dossier "Mes documents" si vous utilisez Windows 7. Vous voyez le dossier "Documents" si vous utilisez Windows 10. Développez ce dossier pour accéder au dossier "SIMATIC Automation Tool".

Le chemin de navigation dans Windows 7 ou Windows 10 est également différent du nom de chemin dans la boîte de dialogue Paramètres.

Windows 7

Depuis l'Explorateur Windows, le dossier Documents sous le dossier Bibliothèques équivaut également au dossier "Mes documents" et au dossier "MyAccount".

Windows 10

Dans l'Explorateur de fichiers, le dossier Documents sous Accès rapide équivaut également au dossier "Documents" et au dossier "MyAccount".


Paramètres généraux

Paramètres généraux

Vous pouvez sélectionner la langue de l'interface utilisateur : anglais, allemand, français, espagnol, italien ou chinois

Sélectionnez la case à cocher pour afficher les appareils non pris en charge dans un scan réseau. SIMATIC Automation Tool affiche les appareils non pris en charge comme désactivés en les grisant dans la table des appareils.

Si vous décochez la case, SIMATIC Automation Tool masque les appareils non pris en charge dans la table des appareils.

Remarque

La modification de la langue de l'interface utilisateur efface l'Event Log.

Lorsque vous modifiez la langue de l'interface utilisateur, SIMATIC Automation Tool efface le journal d'événements (Event Log).

Remarque

Effectuez un scan réseau pour actualiser les noms des dossiers

Lorsque vous changez la langue de l'interface utilisateur, les noms des dossiers dans la table des appareils restent dans la langue précédente. Effectuez un scan réseau pour actualiser les noms des dossiers à la nouvelle langue de l'interface utilisateur.


Paramètres de communication

Utilisation de plusieurs threads pour les opérations Définir le mode de transfert IHM
Démarrer Précédent Suivant

Paramètres de communication

Utilisez les options de communication pour définir les options liées au traitement multifil et à la communication IHM.

Utilisation de plusieurs threads pour les opérations

Si votre réseau présente une topologie en étoile dans laquelle chaque CPU est raccordée directement à la console de programmation par un commutateur Ethernet, vous pouvez utiliser l'option de traitement multifil en toute sécurité.

Si le réseau possède une topologie en chaine, vous devez désactiver cette option, afin d'éviter qu'une CPU entraine une coupure de communication vers les autres appareils. Une topologie en chaîne, par exemple, possède des connexions en chaîne de la console de programmation à la CPU 1, à la CPU 2, à la CPU 3, etc.

Exemple : Topologie en chaîne

Exemple : Topologie en chaîne

Avec le traitement multi-thread, un thread qui fait redémarrer la CPU 1 perturbe une opération en cours sur la CPU 2 ou toute autre CPU de la chaîne. Notez qu'une topologie en chaîne peut aussi être mise en œuvre avec des modules CM ou CP.

Opérations simultanées

Il est possible d'améliorer les performances de SIMATIC Automation Tool en permettant l'exécution simultanée des opérations sur plusieurs appareils sur des threads différents.

Remarque

Problèmes de communication avec SIMATIC Automation Tool

Par exemple, vous envoyez une commande d'opération à plusieurs appareils, mais un appareil n'achève pas l'opération et cette CPU signale une erreur de communication. Cependant, les autres appareils communiquent et exécutent l'opération comme prévu. Si vous rencontrez ce problème, réduisez le nombre de fils/connexions simultanés. Fermez et redémarrez SIMATIC Automation Tool et effectuez à nouveau l'opération groupée.

Timeout pour les communications

Si vous envoyez une commande d'opération à un appareil et que le débit de transfert de données est très bas, une erreur de dépassement de temps de la communication peut être renvoyée. Si vous rencontrez ce problème, augmentez la durée d'expiration affectée aux opérations de communication.

Définir le mode de transfert IHM

SIMATIC Automation Tool peut communiquer avec les appareils IHM par PN/IE ou Ethernet. Sélectionnez dans les paramètres de communication SIMATIC Automation Tool la même valeur que dans les paramètres de transfert de fichiers sur votre appareil IHM. Ethernet permet des vitesses de communication élevées.


Paramètres des projets

Paramètres des projets

Vous pouvez accepter le chemin d'accès par défaut pour l'enregistrement des données de projet SIMATIC Automation Tool ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.


Paramètres de mise à jour du firmware

Paramètres de mise à jour du firmware

Vous pouvez accepter le chemin d'accès par défaut vers les fichiers de mise à jour du firmware ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.

Activez cette case à cocher pour autoriser ou interdire la mise à jour du firmware avec une version identique. Interdire le remplacement d'une version de firmware identique permet d'économiser le temps de traitement en évitant les opérations inutiles.


Paramètres de mise à jour du programme

Paramètres de mise à jour du programme

Vous pouvez accepter le chemin d'accès par défaut vers les fichiers programme ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.


Paramètres des données de maintenance

Paramètres des données de maintenance

Vous pouvez accepter le chemin d'accès par défaut vers les fichiers de données de maintenance ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.


Paramètres de sauvegarde/restauration

Paramètres de sauvegarde/restauration

Vous pouvez accepter le chemin d'accès par défaut vers les fichiers de sauvegarde et de restauration ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.


Paramètres des recettes

Paramètres des recettes

Vous pouvez accepter le chemin d'accès par défaut vers les fichiers recette ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.


Paramètres des journaux de données (Data logs)

Paramètres des journaux de données (Data logs)

Vous pouvez accepter le chemin d'accès par défaut vers les fichiers Data Log ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.


Paramètres de l'Event Log

Paramètres de l'Event Log

Par défaut, SIMATIC Automation Tool efface l'Event Log au démarrage de toute opération d'appareil. Vous pouvez désélectionner "Effacer l'Event Log avant chaque opération" si vous souhaitez désactiver le paramètre par défaut.

Si vous activez la case à cocher "Automatiquement joindre les événements au fichier Event Log et enregistrer", vous pouvez accepter le chemin d'accès par défaut ou en définir un autre.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel. SIMATIC Automation Tool enregistre ensuite chaque message dans la fenêtre Event Log dans le fichier "EventLogFile.csv". Lorsque vous fermez et ouvrez à nouveau SIMATIC Automation Tool, la connexion au fichier Event Log est rétablie automatiquement.

Vous pouvez effacer le contenu du fichier Event Log en cliquant sur le bouton "Effacer le fichier journal". Ceci efface le contenu, mais ne supprime pas le fichier.


Paramètres d'exportation

Paramètres d'exportation

Vous pouvez accepter le chemin d'accès par défaut des fichiers d' exportation ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.


Profils SNMP

Ajout d'un profil SNMP Modification d'un profil SNMP Suppression d'un profil SNMP Accepter tous les ajouts, les modifications et les suppressions
Démarrer Précédent Suivant

Profils SNMP

Pour utiliser SIMATIC Automation Tool pour communiquer avec les appareils SCALANCE sur votre réseau, vous devez configurer les profils SNMP que vous utilisez pour les appareils. Consultez la documentation de vos appareils SCALANCE pour obtenir des informations sur la configuration SNMP. Si vous avez de nombreux appareils SCALANCE dans votre réseau, SIMATIC Automation Tool facilite la sauvegarde des profils SNMP que vous utilisez pour plusieurs appareils.

Vous devez indiquer un serveur TFTP (Trivial File Transfer Protocol) pour installer le firmware dans des appareils SCALANCE.

Vous pouvez accepter le chemin d'accès par défaut du fichier de profil SNMP ou en définir un nouveau.

Votre chemin peut avoir une lettre de lecteur différente et "MyAccount" représente l'identifiant de l'utilisateur actuel.

SIMATIC Automation Tool prend en charge les profils SNMP suivants :

  • Version 1 : Défini dans RFC (Request For Comments) pour SNMPv1 via Internet Engineering Task Force (IETF) et un des deux standards SNMP

  • Version 2 : Défini dans RFC (Request For Comments) pour SNMPv2 via Internet Engineering Task Force (IETF) et le second des deux standards SNMP

  • Version 3 : Défini dans RFC (Request For Comments) pour SNMPv3 via Internet Engineering Task Force (IETF), la version recommandée par l'IETF pour la gestion Internet

Pour plus d'informations sur les protocoles SNMP, reportez-vous à la page Web SNMP Research International, Inc., uniquement en anglais.

Ajout d'un profil SNMP

Pour ajouter un profil SNMP, suivre les étapes suivantes :

  1. Cliquez sur le bouton "Ajouter" des paramètres de profil SNMP pour ajouter un profil SNMP.

  2. Indiquez un nom pour votre profil.

  3. Entrez l'adresse IP du serveur TFTP.

  4. Entrez ou sélectionnez le numéro de port du serveur.

  5. Sélectionnez le numéro de version dans la liste déroulante.

Profil SNMP Version 1 or Version 2 | Profil SNMP Version 3

Pour un profil Version 1 ou Version 2, effectuez les étapes suivantes :

  1. Entrez la communauté lecture ou acceptez le paramètre par défaut.

  2. Entrez la communauté écriture ou acceptez le paramètre par défaut.

Pour un profil Version 3, effectuez les étapes suivantes :

  1. Entrez un nom d'utilisateur.

  2. Entrez un nom de contexte.

  3. Sélectionnez un niveau de sécurité dans la liste déroulante :

    • NoAuth, NoPriv : Communication sans authentification et sans confidentialité

    • Auth, NoPriv : Communication avec authentification et sans confidentialité

    • Auth, Priv : Communication avec authentification et avec confidentialité

Pour un profil Version 3 qui comprend l'authentification, configurez les champs d'authentification suivants :

  • Algorithme d'authentification : Sélectionnez-en un dans la liste déroulante.

  • Mot de passe d'authentification

Pour un profil Version 3 qui comprend la confidentialité, configurez les champs de confidentialité suivants :

  • Algorithme de confidentialité : Sélectionnez-en un dans la liste déroulante.

  • Mot de passe de confidentialité

Après avoir configuré toutes les informations de profil, cliquez sur OK dans la boîte de dialogue Ajouter pour enregistrer le profil. SIMATIC Automation Tool vérifie vos sélections et vous informe si des champs sont manquants ou incomplets. Cliquez sur Annuler si vous ne voulez pas enregistrer le profil.

Remarque

Vous pouvez ajouter jusqu'à 25 profils SNMP.

Modification d'un profil SNMP

Procédez comme suit pour modifier un profil existant :

  1. Sélectionnez le profil SNMP que vous souhaitez modifier.

  2. Cliquez sur le bouton Modifier.

  3. Dans la boîte de dialogue Modifier, modifiez les champs requis.

Après avoir terminé les modifications, cliquez sur OK dans la boîte de dialogue Modifier pour enregistrer le profil. SIMATIC Automation Tool vérifie vos sélections et vous informe si des champs sont manquants ou incomplets. Cliquez sur Annuler si vous ne voulez pas enregistrer le profil modifié.

Suppression d'un profil SNMP

Pour supprimer un profil SNMP, suivre les étapes suivantes :

  1. Sélectionnez le profil SNMP que vous souhaitez supprimer.

  2. Cliquez sur le bouton "Supprimer".

  3. Confirmez que vous voulez supprimer le profil. SIMATIC Automation Tool vous informe si le profil est en cours d'utilisation.

Accepter tous les ajouts, les modifications et les suppressions

Cliquer sur OK dans la boîte de dialogue de paramètres de profil SNMP pour accepter toutes les modifications. SIMATIC Automation Tool sauvegarde les profils dans le fichier dans le dossier Profils SNMP.

Cliquez sur Annuler pour annuler toutes vos modifications.


Menu Outils

Menu Outils

Menu Outils

Menu Outils

Le menu Outils est également accessible à partir de l'icône [image] de la barre d'outils.

Icône outil | Commandes de menu | Description
 | Rechercher des mises à jour du firmware | Rechercher les mises à jour du firmware lorsque vous n'avez sélectionné qu'un appareil. SIMATIC Automation Tool affiche la page Web avec les fichiers de mise à jour du firmware pour l'appareil sélectionné.
 | Précharger les fichiers de mise à jour du firmware | Rechercher des fichiers de mise à jour du firmware dans le dossier de mise à jour du firmware SIMATIC Automation Tool précharge les fichiers de mise à jour du firmware dans la colonne "Nouvelle version firmware" pour tous les appareils. L'outil charge uniquement un fichier de mise à jour si le fichier est une version plus récente que la version dans l'appareil. SIMATIC Automation Tool charge le fichier correspondant le plus récent.


Menu Aide

Menu Aide

Icône
d'outil

Commande
de menu

Description

Voir guide utilisateur

Ouvre le guide de l'utilisateur de SIMATIC Automation Tool.

Voir catalogue des appareils

Visualiser la table des appareils au format Microsoft Excel en lecture seule.

À cet effet, Microsoft Excel doit être installé sur votre appareil.

À propos de SIMATIC Automation Tool

Affiche la boite de dialogue A propos de qui contient les informations suivantes :

  • Nom du produit

  • Version

  • Informations de licence

  • Le bouton Rechercher des mises à jour vous permet de trouver les mises à jour de SIMATIC Automation Tool.


Icônes de la barre d'outils

Icônes de la barre d'outils

Icône
outil

Description

Nouveau: Créer un nouveau projet SIMATIC Automation Tool avec l'extension ".sat".

Ouvrir : Afficher une boite de dialogue "Ouvrir" permettant de naviguer vers un dossier, de sélectionner un fichier de projet et de saisir un mot de passe pour ouvrir le fichier projet crypté.

Enregistrer les données du projet ouvert dans un fichier. En l'absence de nom de fichier et de mot de passe, la boite de dialogue "Enregistrer sous" s'affiche.

Couper les données sélectionnées et les copier dans le presse-papier. Les données du presse-papier sont compatibles avec Microsoft Excel, ce qui permet un échange entre les deux applications.

Couper les données sélectionnées et les copier dans le presse-papier.

Coller les données du presse-papier dans les champs sélectionnés.

Scanner le réseau sélectionné, avec les options suivantes :

  • Scanner l'interface réseau sélectionnée pour rechercher des CPU et des modules accessibles.

  • Actualiser l'état de tous les appareils dans la table des appareils

RUN : Met les CPU sélectionnées en mode RUN.

STOP : Met les CPU sélectionnées en mode STOP.

Mettre à jour les appareils avec les données de SIMATIC Automation Tool à partir de l'une des options suivantes :

  • Configurer l'adresse IP

  • Définir le nom PROFINET

  • Mise à jour du programme

  • Mise à jour du firmware

Vous devez sélectionner les onglets correspondants de la table des appareils pour entrer les données à mettre à jour.

Identifier les appareils avec des LED / écrans HMI clignotants sur les appareils sélectionnés. Permet d'identifier l'emplacement physique d'un appareil.

Fonctions de réinitialisation des appareils sélectionnés :

  • Effacement général de la mémoire

  • Restaurer les paramètres d'usine

  • Formater la carte mémoire

Accéder aux informations de diagnostic :

  • Afficher le diagnostic

  • Récupérer les données de maintenance depuis les appareils sélectionnés

Régler l'heure : Régler l'heure système des CPU sélectionnées sur l'heure en cours de la console de programmation

Fonctions Sauvegarde et Restauration :

  • Créer des fichiers de sauvegarde pour les CPU et les appareils IHM sélectionnés.

  • Restaurer les appareils sélectionnés à partir de fichiers de sauvegarde

Opérations sur fichier :

  • Charger ou supprimer les Data logs

  • Charger, ajouter, remplacer ou supprimer des recettes

Les opérations de suppression nécessitent que la CPU soit en mode STOP.

Rechercher les mises à jour du firmware ou précharger les fichiers de mise à jour du firmware

Liste déroulante de l'interface réseau : Sélectionner l'interface réseau Ethernet qui est connectée au réseau de commande industrielle.


Raccourcis clavier

Raccourcis clavier

SIMATIC Automation Tool prend en charge les raccourcis suivants pour naviguer dans la table des appareils et pour certaines commandes de menu :

CTRL+Haut | Bascule entre les onglets, de droite à gauche
CTRL+Bas | Bascule entre les onglets, de gauche à droite
CTRL+A | Sélectionne toute la table
CTRL+C | Copie la sélection dans le presse-papiers
CTRL+N | Crée un nouveau projet SIMATIC Automation Tool
CTRL+O | Affiche la boite de dialogue ouvrir pour ouvrir un nouveau fichier projet
CTRL+S | Affiche la boîte de dialogue "Enregistrer sous"
CTRL+V | Colle le contenu du presse-papier au point d'insertion et écrase la sélection.
CTRL+X | Coupe les cellules sélectionnées
CTRL+Z | Annuler la dernière modification ou supprimer l'action
FLÈCHE DIRECTIONNELLES | Déplacent les cellules vers le haut, le bas, la gauche ou la droite.
MAJ + FLÈCHE DIRECTIONNELLES | Élargit la sélection
Suppr | Supprime le contenu de la cellule active
Entrée | Termine l'édition de la cellule et valide les données
Échap | Annule l'édition de la cellule et rétablit la valeur d'origine
Origine | Aller au début de la cellule
Ctrl+Début | Aller au début de la table
Fin | Aller à la fin de la cellule
Ctrl+Fin | Aller à la fin de la table
Page suivante | Descendre un écran sur la table
Page haut | Remonter un écran sur la table
BARRE D'ESPACEMENT | Activer ou désactiver la case à cocher de sélection d'appareil
TABULATION | Se déplacer d'une cellule vers la droite
F5 | Actualiser tous les appareils sélectionnés
Alt+F4 | Quitter


Définition du programme de sécurité

Définition du programme de sécurité

Un programme de sécurité est un programme que vous créez dans STEP 7 et qui comprend des blocs de sécurité. Si vous avez installé STEP 7 Safety Advanced, le dossier Blocs programme inclut automatiquement les blocs de sécurité à chaque fois que vous ajoutez une CPU de sécurité à votre projet STEP 7. Lorsque vous chargez ce programme dans une CPU de sécurité, il s'agit d'un programme de sécurité.


Défaillances du programme SIMATIC Automation Tool

Envoi d'informations si vous n'avez pas de client e-mail

Défaillances du programme SIMATIC Automation Tool

Dans de rares cas, le logiciel SIMATIC Automation Tool peut rencontrer des erreurs inattendues. Si une telle erreur se produit, SIMATIC Automation Tool affiche une boîte de dialogue. Siemens vous demande de cliquer sur le bouton "Envoyer le rapport" dans cette boîte de dialogue pour envoyer les données de maintenance de cette erreur à Siemens. SIMATIC Automation Outil utilise le client de messagerie électronique par défaut sur votre console de programmation pour ouvrir un courriel contenant les données de maintenance dans le corps du message. Le destinataire est helpline.sii@siemens.com. Vous pouvez ajouter des informations ou des destinataires supplémentaires dans l'e-mail. Vous devez ensuite cliquer sur "Envoyer" pour envoyer l'e-mail.

Si vous le souhaitez, vous pouvez aussi cliquer sur le bouton "Enregistrer le projet" dans la boîte de dialogue d'erreur pour enregistrer le projet SIMATIC Automation Tool présentant l'erreur sur votre console de programmation.

Envoi d'informations si vous n'avez pas de client e-mail

Si votre console de programmation n'a pas de client de messagerie électronique, vous pouvez copier le fichier de données de maintenance dans un appareil d'où vous pouvez envoyer un courriel. Pour enregistrer, copier et envoyer les données de maintenance à Siemens, suivez ces étapes :

  1. Copiez le fichier "SATServiceData.txt" depuis le dossier des données de maintenance sur un autre appareil.

  2. Envoyez ce fichier à helpline.sii@siemens.com.


API SIMATIC Automation Tool pour architecture .NET

API SIMATIC Automation Tool pour architecture .NET

Ce chapitre contient des informations sur les sujets suivants :
  • Introduction à l'API
  • Licence logicielle API et compatibilité des versions
  • Conception d'une application d'interface utilisateur pour des appareils de sécurité et des opérations relatives à la sécurité
  • Présentation de l'architecture
  • Référencement de l'API dans une application d'interface utilisateur
  • Exigences pour la communication S7
  • Classes de base
  • Interfaces de support communes
  • Classe Network
  • La classe HealthCheck
  • Classe IProfinetDeviceCollection
  • Interface IProfinetDevice
  • Classe IModuleCollection et propriétés des modules
  • Interface ICPU
  • L'interface ICPUClassic
  • Interface IHMI
  • Interface IScalance
  • Interface ISNMPProfile
  • Exemples de code pour mise à jour de firmware IScalance et ISNMP
  • Exceptions
  • Enumérations API
  • Exemple de réseau


Introduction à l'API

Introduction à l'API

L'API SIMATIC Automation Tool vous permet de créer des applications personnalisées grâce à de nombreuses interfaces, classes et méthodes .NET. L'API vous permet de communiquer avec les appareils d'un réseau. Vous pouvez développer une application personnalisée pour combiner les opérations et prendre en charge les workflows utilisateur spécifiques à votre réseau d'automatisation industrielle.


Licence logicielle API et compatibilité des versions

Licence logicielle API et compatibilité des versions

Licence logicielle requise pour V3.0 et versions ultérieures

Vous devez disposer d'une licence SIMATIC Automation Tool valide pour utiliser l'API (Application Programming Interface / Interface de programmation d'application).

Vous pouvez utiliser l'API pour programmer des applications personnalisées après avoir accompli ces tâches :

  • Installer SIMATIC Automation Tool avec licence

  • Accepter tous les termes de licence pendant l'installation

Vous ne pouvez ni copier ni mettre à disposition d'un tiers tout ou partie du logiciel SIMATIC Automation Tool, y compris les fichiers .exe ou .dll de l'API.

Si vous souhaitez mettre votre application d'interface utilisateur personnalisée à disposition d'un tiers, celui-ci doit également disposer d'une licence valide pour SIMATIC Automation Tool.

Compatibilité avec les versions précédentes

L'API pour V3.1 SP4 est compatible avec V3.1 et les versions ultérieures. Vous pouvez faire fonctionner des programmes API que vous avez développés avec l'API V3.1 ou un Service Pack API V3.1. Mettez à jour ou vérifiez vos références de solution et redéveloppez votre application avec l'API V3.1 SP4.

L'API pour V3.1 et les versions supérieures ne sont pas compatibles avec les versions antérieures à V3.1. Vous devez réécrire les programmes écrits avec les versions de l'API antérieures à la version V3.1.


Conception d'une application d'interface utilisateur pour des appareils de sécurité et des opérations relatives à la sécurité

Conception d'une application d'interface utilisateur pour des appareils de sécurité et des opérations relatives à la sécurité

Ce chapitre contient des informations sur les sujets suivants :
  • Prise en charge d'opérations relatives à la sécurité et d'appareils de sécurité par l'API
  • Directives de programmation de l'interface utilisateur pour les opérations relatives à la sécurité
  • Utilisez un code couleurs pour les champs de sécurité dans votre interface utilisateur
  • Codes de Hamming


Prise en charge d'opérations relatives à la sécurité et d'appareils de sécurité par l'API

Caractéristiques de sécurité de l'API

Prise en charge d'opérations relatives à la sécurité et d'appareils de sécurité par l'API

SIMATIC Automation Tool prend en charge les opérations de sécurité suivantes :

  • Mise à jour du programme

  • Restaurer l'appareil à partir d'un fichier de sauvegarde

  • Restaurer les paramètres d'usine

  • Formater la carte mémoire

Remarque

Le manuel "SIMATIC Safety - Configuring and Programming" contient un avertissement identifié comme "S078". Cet avertissement indique que "Lors de l'utilisation d'outils pour l'automatisation ou l'utilisation d'interfaces utilisateur (TIA Portal ou serveur Web) qui permettent de contourner la protection d'accès pour la CPU (par ex. enregistrement ou saisie automatique d'un mot de passe de CPU pour le niveau de protection "Accès complet, y compris failsafe (pas de protection)" ou du mot de passe du serveur Web), les données de sécurité du projet risquent de ne plus être protégées contre des modifications non intentionnelles..."

Cet avertissement S078 ne s'applique pas à l'API SIMATIC Automation Tool. L'API prend en charge la communication avec les CPU F et le stockage des mots de passe CPU pour les CPU F.

Caractéristiques de sécurité de l'API

TÜV SÜD a certifié l'API pour SIMATIC Automation Tool et SIMATIC Automation Tool SDK.

L'API SIMATIC Automation Tool utilise un traitement diversifié et redondant. L'API contribue ainsi à empêcher le code programme de l'application utilisateur d'effectuer des opérations non sûres. L'API offre les caractéristiques suivantes :

  • Processus de connexion et de légitimation indépendant pour chaque opération de sécurité

  • Contrôles d'identité pour opérations relatives à la sécurité d'appareils de sécurité

  • Identification des programmes de sécurité

  • Utilisation requise du mot de passe de CPU F de sécurité pour toute opération de sécurité sur une CPU F protégée par mot de passe

  • Utilisation des totaux de contrôle CRC 32 bits pour comparer les représentations des appareils de sécurité en ligne et hors ligne

  • Utilisation de codes de Hamming pour indiquer les états TRUE et FALSE

  • Comparaison de signatures F après les opérations Mise à jour du programme et Restaurer à partir de la sauvegarde pour vérifier que les opérations se sont déroulées avec succès


Directives de programmation de l'interface utilisateur pour les opérations relatives à la sécurité

Identification et protection des opérations relatives à la sécurité Pratiques de programmation recommandées Exigences relatives à la mise à jour des programmes Exigences relatives à la restauration à partir d'un fichier de sauvegarde Certification
Démarrer Précédent Suivant

Directives de programmation de l'interface utilisateur pour les opérations relatives à la sécurité

Attention

Protéger autant que possible les opérations relatives à la sécurité

Les CPU de sécurité, ainsi que les E/S et les programmes de sécurité, permettent de réaliser un niveau élevé de sécurité opérationnelle.

Lorsque vous utilisez l'API SIMATIC Automation Tool, assurez-vous que les opérations relatives à la sécurité sont aussi sécurisées que possible. Siemens n'assume aucune responsabilité concernant les applications d'interface utilisateur développées avec l'API SIMATIC Automation Tool. L'entière responsabilité incombe au développeur du logiciel.

Le non-respect des pratiques de programmation adéquates peut entraîner la mort ou des dommages corporels lorsque l'utilisateur fait fonctionner votre application d'interface utilisateur.

Identification et protection des opérations relatives à la sécurité

Siemens vous recommande de fournir une boîte de dialogue permettant de confirmer les opérations relatives à la sécurité. Concevez votre application de sorte que l'utilisateur doive sélectionner chaque appareil de sécurité pour l'opération à effectuer, puis cliquer sur "Continuer" avant d'effectuer l'opération.

Lorsque vous développez votre application d'interface utilisateur à l'aide de l'API, déterminez si l'opération à effectuer est l'une des opérations relatives à la sécurité suivantes :

  • Mise à jour du programme

  • Restaurer l'appareil à partir d'un fichier de sauvegarde

  • Restaurer les paramètres d'usine

  • Formater la carte mémoire

Pour les opérations relatives à la sécurité, prévoyez une boîte de dialogue de confirmation pour vos utilisateurs. Utilisez la méthode API DetermineConfirmationMessage pour déterminer le type de boîte de dialogue de confirmation à afficher. Prévoir une boîte de dialogue de confirmation supplémentaire protège les utilisateurs contre l'exécution accidentelle d'une opération relative à la sécurité. La boîte de dialogue suivante est un exemple de boîte de dialogue de confirmation pour une opération de mise à jour de programme :

Pratiques de programmation recommandées

Appliquez les pratiques de programmation suivantes pour vous assurer que vous protégez les opérations relatives à la sécurité et minimisez les risques d'action à risque de la part de l'utilisateur :

  • Prévoyez que toutes les opérations relatives à la sécurité s'effectuent par traitement à thread unique.

  • Demandez la saisie du mot de passe de CPU F de sécurité pour les opérations relatives à la sécurité. Comparez le mot de passe saisi avec le mot de passe de la CPU. Utilisez des astérisques pour masquer les mots de passe au moment de leur saisie par l'utilisateur.

  • Vérifiez les codes de retour de toutes les méthodes. Assurez-vous que la logique de votre programme ne s'appuie que sur des retours de méthodes réussis.

  • Prévoyez une gestion appropriée des exceptions dans votre implémentation. L'API génère des exceptions pour les défaillances internes critiques qu'il détecte. Assurez-vous que votre logiciel gère les exceptions de manière appropriée.

  • Pour toutes les opérations relatives à la sécurité, déterminez si l'opération a pu ou non être terminée avec succès. Affichez un message à l'attention de l'utilisateur après toute mise à jour réussie du programme. Affichez un message d'erreur en cas d'échec de la mise à jour d'un programme.

  • Utilisez des codes de Hamming dans votre application pour implémenter des états booléens.

  • Utilisez un code couleur dans l'application pour identifier les appareils de sécurité, les programmes de sécurité, les mots de passe de CPU F de sécurité et autres données saisies par l'utilisateur.

  • Demandez une confirmation pour tous les changements de mode de fonctionnement (RUN/STOP).

  • Actualisez l'interface utilisateur après chaque opération afin que l'application affiche les dernières données à jour de l'appareil.

Exigences relatives à la mise à jour des programmes

Pour les mises à jour de programmes sur les CPU F sélectionnées, fournissez à l'utilisateur une boîte de dialogue supplémentaire pour sélectionner à nouveau les appareils de sécurité et confirmer les opérations suivantes :

  • Mise à jour d'un programme de sécurité existant avec un autre programme de sécurité

  • Mise à jour d'un programme de sécurité existant avec un programme standard

  • Mise à jour d'un programme standard existant avec un programme de sécurité

  • Mise à jour d'une CPU sans programme avec un programme de sécurité

  • Suppression d'un programme de sécurité existant

Suite à la mise à jour d'un programme de sécurité, vérifiez que la signature de sécurité du programme mis à jour dans la CPU correspond à la signature de sécurité du fichier de mise à jour du programme.

Exigences relatives à la restauration à partir d'un fichier de sauvegarde

Avant de restaurer un fichier de sauvegarde, déterminez si le fichier est un programme de sécurité et demandez la confirmation de l'utilisateur selon les mêmes exigences pour les mises à jour de programmes.

Certification

Remarque

Obtenez une certification pour votre application d'interface utilisateur

Siemens recommande fortement d'utiliser un organisme notifié tel que TÜV SÜD pour certifier la sécurité de votre conception et de votre implémentation.


Utilisez un code couleurs pour les champs de sécurité dans votre interface utilisateur

Utilisez un code couleurs pour les champs de sécurité dans votre interface utilisateur

Ce chapitre contient des informations sur les sujets suivants :
  • Utilisez un code couleurs pour les champs de sécurité dans votre application d'interface utilisateur
  • Appliquer une couleur à une icône d'appareil CPU
  • Appliquer une couleur aux données d'un appareil
  • Appliquer une couleur au mot de passe de la CPU
  • Appliquer une couleur à un dossier de programme
  • Appliquer une couleur à un mot de passe de programme


Utilisez un code couleurs pour les champs de sécurité dans votre application d'interface utilisateur

Conventions des schémas décisionnels

Utilisez un code couleurs pour les champs de sécurité dans votre application d'interface utilisateur

Si vous développez une interface utilisateur avec l'API, Siemens recommande fortement d'utiliser un code couleur pour donner à l'utilisateur une indication visuelle de tout ce qui concerne les CPU et les programmes de sécurité. Les schémas décisionnels indiquent la logique du code couleur recommandé par Siemens pour les champs typiques relatifs à la sécurité. Envisagez d'adopter une approche identique ou similaire lorsque vous concevez votre application.

Conventions des schémas décisionnels

* Sous-processus qui ne peuvent pas échouer, n'incluent pas de traitement des erreurs ou représentent une situation dans laquelle l'application ignore intentionnellement des erreurs.


Appliquer une couleur à une icône d'appareil CPU

Appliquer une couleur à une icône d'appareil CPU


Appliquer une couleur aux données d'un appareil

Appliquer une couleur aux données d'un appareil


Appliquer une couleur au mot de passe de la CPU

Appliquer une couleur au mot de passe de la CPU


Appliquer une couleur à un dossier de programme

Appliquer une couleur à un dossier de programme


Appliquer une couleur à un mot de passe de programme

Appliquer une couleur à un mot de passe de programme


Codes de Hamming

Codes de Hamming

Les codes de Hamming sont des codes binaires. Ils peuvent détecter des erreurs de bits accessoires. L'API SIMATIC Automation Tool utilise des codes de Hamming 32 bits avec une distance de Hamming de 8. L'API utilise des codes de Hamming pour représenter toutes les valeurs booléennes liées aux opérations relatives à la sécurité. Vous pouvez programmer votre application d'interface utilisateur de manière à utiliser les états de valeurs booléennes fournis pour les opérations relatives à la sécurité. Étant donné que l'API implémente ces états avec des codes de Hamming, vous pouvez avoir une grande confiance dans l'intégrité des données des états booléens relatifs à la sécurité.


Présentation de l'architecture

Réseaux Appareils
Méthode FirmwareUpdate Méthode Backup (interface ICPU) Méthode SetOperatingState Propriété de modules et classe IModuleCollection Méthode Restore (interface ICPU) Méthode SetIP Méthode Identify Méthode RefreshStatus Méthode SetProfinetName Méthode GetCurrentDateTime Méthode MemoryReset Méthode ProgramUpdate Méthode ResetToFactoryDefaults Méthode SetCurrentDateTime Méthode UploadServiceData Interface IModule Méthode DeleteDataLog Méthode DeleteRecipe Méthode UploadDataLog Méthode UploadRecipe Méthode Backup (interface IHMI) Méthode ProgramUpdate (interface IHMI) Méthode Restore (interface IHMI) Méthode DownloadRecipe Propriété RemoteInterfaces Événements IProfinetDevice
Démarrer Précédent Suivant

Présentation de l'architecture

L'API fournit des classes, des interfaces et des méthodes permettant la communication avec un réseau d'appareils SIMATIC.

Réseaux

La classe .NET Network représente le réseau industriel dans son ensemble. Cette classe sert à exécuter des fonctions à l'aide d'une carte d'interface réseau (NIC) installée sur une console de programmation. La classe Network permet de rechercher les cartes d'interface disponibles et de choisir la carte NIC à utiliser.

La classe Network comprend le constructeur et la propriété et méthodes suivantes :

  • Constructeur réseau

  • Méthode QueryNetworkInterfaceCards

  • Méthode SetCurrentNetworkInterface

  • Propriété CurrentNetworkInterface

  • Méthode ScanNetworkDevices

  • Méthode SetCommunicationsTimeout

  • Méthode GetCommunicationsTimeout

  • Méthode GetEmptyCollection

Appareils

Les appareils du réseau sont représentés par des interfaces. Chaque classe d'interface fournit des propriétés et des méthodes appropriées pour l'appareil de réseau représenté. Les appareils matériels du réseau sont représentés au mieux par les interfaces suivantes :

IProfinetDevice – tout appareil accessible directement sur le réseau industriel peut être représenté par cette interface.

ICPU – représente les CPU S7 connectées directement au réseau. Une fonctionnalité spécifique est prise en charge pour les CPU.

ICPUClassic – représente les CPU de type classique S7‑300 et S7‑400 connectées directement au réseau.

IHMI – représente les IHM SIMATIC connectées directement au réseau. Une fonctionnalité spécifique est prise en charge pour les IHM.

IBaseDevice – cette interface sert à représenter les appareils qui ne sont pas connectés directement au réseau Ethernet, mais sont accessibles via un autre appareil. Par exemple, une station esclave PROFIBUS raccordée à une CPU du réseau est représentée en tant que IBaseDevice.

IModule – cette interface représente des modules I/O qui sont enfichés sur une CPU, un périphérique PROFINET ou une station PROFIBUS.

IHardware – il s'agit de la classe de base pour toutes les autres interfaces. Cette interface fournit un accès aux propriétés qui sont communes à tous les matériels directement détectés sur le réseau.

Les interfaces sont rassemblées dans des collections qui constituent des groupes d'appareils. Les collections fournies prennent en charge les itérations, les filtres et la recherche.

IProfinetDeviceCollection – une collection de tous les appareils directement accessibles sur le réseau.

IModuleCollection – une collection pouvant représenter tous les modules enfichés sur une CPU ou un module d'interface.

IHardwareCollection – cette collection représente une CPU et tous ses modules.

IScanErrorCollection – cette collection représente un lot d'erreurs retournées par tous les appareils lors d'une opération de scan réseau.

Classes d'appareils, interfaces et méthodes :

  • Classe IProfinetDeviceCollection

  • Interface IProfinetDevice

  • Interface ICPU

  • Interface IHMI

Le diagramme de classes suivant montre la relation d'héritage entre ces classes d'interface :

Remarque

Voir l'exemple de réseau industriel et les classes SIMATIC Automation Tool API utilisées pour représenter chaque constituant du réseau.


Référencement de l'API dans une application d'interface utilisateur

Référencement de l'API dans une application d'interface utilisateur

Siemens fournit l'API avec plusieurs DLL, exécutables et fichiers source :

  • SIMATICAutomationToolAPI.dll

  • DeviceManagerClient.dll (IHM)

  • hmitr.dm.client.proxy.dll (IHM)

  • hmitr.dm.client.stub.exe (IHM)

  • hmitr.ipc.dll (IHM)

  • AsModels dossier et sous-dossiers (modèles d'objets hors-ligne)

Lorsque vous utilisez l'API, les fichiers et le dossier AsModels doivent se trouver dans le même dossier que celui où vous développez votre application.

L'API a été créée avec Microsoft Visual Studio 2015 SP2 Update 3 à l'aide de .NET Framework 4.6.2. Vous pouvez utiliser cette API avec les applications que vous créez avec cette version de Visual Studio. Tous les exemples de code et les captures d'écran du présent document ont été créés en langage de programmation C# sous Visual Studio 2015 SP2 Update 3.

Pour inclure l'API dans votre application, ajoutez SIMATICAutomationToolAPI.dll comme référence dans la solution Visual Studio.

Pour pouvoir exporter des données PC depuis votre application, ajoutez SimaticAutomationToolHealthCheck.dll comme référence.

Dans toutes les applications qui référencent les classes de l'API, vous devez ajouter l'instruction suivante qui référencie l'espace-nom de l'API :

using Siemens.Automation.AutomationTool.API;

Si votre application exporte des données PC, vous devez ajouter l'instruction suivante :

using Siemens.Automation.AutomationTool.HealthCheck;

Pour compiler les exemples de code dans ce document, vous devez placer l'instruction using correcte dans le même fichier source (*.cs) que l'exemple de code. Pour des raisons de simplicité, les exemples de code du présent document ne contiennent pas l'instruction using.


Exigences pour la communication S7

Communication S7 lors du développement de votre application Communication S7 pour les utilisateurs finaux de votre application
Démarrer Précédent Suivant

Exigences pour la communication S7

Communication S7 lors du développement de votre application

Pour exécuter les applications que vous avez développées avec l'API, vous devez avoir installé des composants de communication S7 sur votre console de programmation. Si vous avez installé SIMATIC Automation Tool, les composants de communication S7 requis ont été installés. En présence de la communication S7 sur une console de programmation, vous pouvez placer les fichiers et dossiers mentionnés sous Référencement de l'API dans une application d'interface utilisateur dans n'importe quel dossier sur la console de programmation. Placez le fichier exécutable de votre application personnalisée dans le même dossier. Exécutez l'application à partir de ce dossier et effectuez vos tests.

Communication S7 pour les utilisateurs finaux de votre application

Vos utilisateurs finaux doivent installer une version avec licence de SIMATIC Automation Tool. Votre application personnalisée doit se trouver dans le même dossier que les fichiers et dossiers requis sur la console de programmation de l'utilisateur final.


Classes de base

Classes de base

Ce chapitre contient des informations sur les sujets suivants :
  • Classe EncryptedString
  • Classe Result
  • Classe DiagnosticsItem
  • Classe DataChangedEventArgs
  • Classe ProgressChangedEventArgs


Classe EncryptedString

Classe EncryptedString

De nombreuses opérations API requièrent une connexion légitimée à une CPU S7 protégée. Pour ces opérations, les méthodes requièrent un mot de passe comme paramètre de méthode. La CPU S7 accepte le mot de passe dans un format crypté. Pour effectuer le cryptage du mot de passe, l'API fournit la classe EncryptedString.

Constructeur | Description
EncryptedString() | Une chaîne de caractères chiffrée vide
EncryptedString(string strText) | Une chaîne chiffrée

Nom de la propriété | Type de retour | Description
IsEmpty | bool | Vrai, s'il n'y a pas de mot de passe.
IsEncrypted | bool | Vrai, s'il existe un mot de passe chiffré

Nom de la méthode | Type de retour | Description
ToString() | string | Représentation du mot de passe chiffré sous forme de chaîne hexadécimale
Clear() | void | Supprime le mot de passe chiffré
GetHash() | byte[] | Représentation sous forme de tableau de hachage chiffré par mot de passe
WriteToStream(Stream stream) | void | Sérialiser un mot de passe à partir d'un flux
ReadFromStream(Stream stream) | void | Désérialiser un mot de passe à partir d'un flux

Cette classe fournit un moyen de chiffrer un mot de passe en texte clair pour que vous puissiez ensuite légitimer une connexion CPU. De nombreux exemples de code montrent un usage type de cette classe.

Pour chiffrer un mot de passe à utiliser plusieurs fois dans le code, instanciez le EncryptedString. Vous pouvez alors le transmettre comme paramètre pour des appels multiples, comme ci-dessous :

    EncryptedString pwd = new EncryptedString("password");

    devAsCpu.Selected = true;
    devAsCpu.SetPassword(pwd);

Remarque

Si une CPU n'est pas protégée par mot de passe, transmettez simplement une chaîne vide au constructeur EncryptedString. Par exemple, le code suivant est efficace pour une CPU configurée sans protection :

    devAsCpu.SetPassword(new EncryptedString("Password"));
    devAsCpu.Selected = true;
    Result retVal = devAsCpu.RefreshStatus();

L'objet EncryptedString ne stocke pas le mot de passe défini par l'utilisateur en texte clair. Toutefois, si votre application code les mots de passe en tant que chaînes littérales, vous créez un risque de sécurité.

Par exemple, new EncryptedString("myPassword") compile le texte clair "myPassword"" dans l'application utilisateur. Le mot de passe peut être visible pour quiconque utilise la méthode .NET reflection.


Classe Result

Classe Result

La classe Result encapsule la logique qui détermine si une action API donnée a réussi. La plupart des actions API impliquent des communications réseau. Nombre d'entre elles impliquent l'ouverture d'une connexion à un appareil du réseau. De telles actions peuvent ou non réussir. Inspectez l'objet Result renvoyé par les actions API pour déterminer si l'action a réussi ou échoué.

Constructeur | Description
Result() | Crée un résultat réussi sans avertissement
Result(ErrorCode nCode) | Crée une erreur spécifique sans avertissement
Result(string strCode) | Description d'erreur définie par l'appareil
Result(Result result) | Crée un résultat avec le contenu du paramètre Result

Nom de la propriété | Type de retour | Description
Avertissements | ErrorCode[]{get;} | Renvoie tous les avertissements dans un tableau de codes d'erreurs
Erreur | ErrorCode {get;} | Renvoie un code d'erreur
HasWarnings | Bool {get;} | Vrai, lorsqu'il existe des avertissements
Échec | Bool {get;} | Vrai, lorsque le résultat a échoué
Terminé avec succès | Bool {get;} | Vrai, lorsque le résultat est un succès Succès = contraire d'échec

Nom de la méthode | Type de retour | Description
Clear() | void | Supprime les erreurs et les avertissements
SetError(ErrorCode error) | void | Indique l'erreur actuelle
AddWarning(ErrorCode warning) | void | Ajoute un avertissement
ChangeErrorToWarning() | void | Modifie l'erreur actuelle en avertissement
GetErrorDescription(Language language) | string | Obtient une chaîne d'erreur actuelle dans la langue spécifiée
GetWarningDescription(Language language) | string[] | Obtient une chaîne d'avertissement dans la langue spécifiée

Dans certains cas, l'appareil renvoie une chaîne d'erreur décrivant une erreur spécifique à l'appareil. Dans ce cas, le ErrorCode retourné est DeviceDefinedError. La méthode GetErrorDescription fournit la chaîne de caractères d'erreur spécifique à l'appareil.

Souvent, il peut suffire de savoir si une action donnée a réussi. Dans ce cas, vérifiez la propriété Succeeded :

        ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
//-----------------------------------------------------
//
        L'appareil est une CPU.
//
        L'interface ICPU peut être utilisée pour interagir avec elle.
//-----------------------------------------------------

dev.Selected = true;
Result retVal = dev.RefreshStatus();
if (retVal.Succeeded)
{
//------------------------------------
//
        Poursuivre les opérations
        ....
//------------------------------------
}

Dans les autres cas, il peut être utile d'obtenir plus d'informations sur l'échec. Pour inspecter une erreur donnée, utilisez la propriété ErrorCode de la manière suivante :

            dev.Selected = true;
Result retVal = dev.RefreshStatus();
if (retVal.Succeeded)
{
//------------------------------------
//
        Continuer les opérations
        ....
//------------------------------------
}
else
{
//------------------------------------
//
        Que s'est-il passé ?
//------------------------------------
switch (retVal.Error)
{
case ErrorCode.AccessDenied:
break;
case ErrorCode.TooManySessions:
break;
}
}

Voir la rubrique ErrorCode pour une liste de valeurs d'erreur possibles.

La classe Result fournit également une description de l'erreur dans la langue spécifiée. La méthode GetErrorDescription utilise une valeur Language comme paramètre pour fournir une description d'erreur dans la langue spécifiée.

Par exemple, le code suivant renvoie la description de l'erreur en allemand :

String strError = retVal.GetErrorDescription(Language.German);

Voir la rubrique énumération de la Langue pour une liste de valeurs.

SIMATIC Automation Tool dispose d'une fonction d'avertissement pour vous informer des problèmes survenus. Par exemple, l'actualisation effectuée sur l'appareil à la fin de la mise à jour d'un programme peut créer des avertissements qui ne sont pas directement liés à la fonction d'appel principale. Vous pouvez accéder à ces avertissements par le biais de la classe Result, comme suit :

if (retVal.HasWarnings)
{
foreach (ErrorCode warning in retVal.Warnings)
{
//------------------------------------
//
        Poursuivre le fonctionnement
        ....
//------------------------------------
}
}


Classe DiagnosticsItem

Classe DiagnosticsItem

Un élément de diagnostic contient des informations de diagnostic pour un seul événement. Il est possible de lire le tampon de diagnostic d'une CPU. Voir le chapitre Interface ICPU pour plus de détails.

Constructeur | Description
DiagnosticsItem() | Crée un élément de diagnostic par défaut

Nom de la propriété | Type de retour | Description
TimeStamp | DateTime {get;} | Horodatage de l'événement de diagnostic
State | Byte {get;} | 0 = événement sortant ; 1 = événement entrant
Description1 | String {get;} | Description sommaire
Description2 | String {get;} | Description détaillée


Classe DataChangedEventArgs

Classe DataChangedEventArgs

Un événement lié à une modification de données contient des informations sur les données qui ont changé au sein de l'API. Voir le chapitre Interface IProfinet pour plus de détails.

Constructeur | Description
DataChangedEventArgs(DataChangedType type) | Crée un événement de type spécifique
DataChangedType type | Type de données ayant changé

Nom de la propriété | Type de retour | Description
Type | DataChangedType | Type d'événement

Utilisé avec le gestionnaire d'événements suivant :

public delegate void DataChangedEventHandler(object sender, DataChangedEventArgs e);


Classe ProgressChangedEventArgs

Classe ProgressChangedEventArgs

Un événement lié à une modification de progression contient des informations sur les données qui ont changé dans l'API. Voir le chapitre Interface IProfinet pour plus de détails.

Constructeur | Description
ProgressChangedEventArgs(ProgressAction action, int index, int count, uint hardwareID) | Utilisé pour créer et assigner par défaut une classe ProgressChangedEventArgs
ProgressAction action | Type de progression observée
int index | Index de l'élément actuellement en cours de traitement
int count | Total des éléments à traiter
uint hardwareID | Identité de l'élément en cours de traitement

Nom de la propriété | Type de retour | Description
ID | uint {get;} | Identité de l'élément
Cancel | bool {get;} | Choisir "Vrai" pour terminer l'opération en cours
Count | int {get;} | Valeur maximale
Index | int {get;} | Valeur actuelle
Action | ProgressAction {get;} | Type d'action de cet événement

Utilisé avec le gestionnaire d'événements suivant :

public delegate void ProgressChangedEventHandler(object sender, ProgressChangedEventArgs e);


Interfaces de support communes

Interfaces de support communes

Ce chapitre contient des informations sur les sujets suivants :
  • Interface IRemoteFile
  • Interface IRemoteFolder
  • Interface IRemoteInterface
  • Interface IHardware
  • Interface IBaseDevice
  • Interface IHardwareCollection
  • Interface IModuleCollection
  • Classe IScanErrorCollection
  • Classe IScanErrorEvent


Interface IRemoteFile

Interface IRemoteFile

IRemoteFile est une interface utilisée pour représenter les fichiers utilisés dans les Data Logs et les recettes.

Nom de la propriété | Type de retour | Description
Selected | bool {get; set;} | État sélectionné
FileSize | ulong {get;} | Taille du fichier sur la CPU
Name | string {get;set;} | Nom et extension du fichier sur l'appareil


Interface IRemoteFolder

Interface IRemoteFolder

IRemoteFolder représente les dossiers utilisés dans les datalogs et les recettes.

Nom de la méthode | Type de retour | Description
SetRemoteFile(string strFile) | Result | Définissez le nom du fichier distant
string strFile |  | Nom et chemin d'accès complets du fichier distant

Nom de la propriété | Type de retour | Description
NewFileNameErrorCode | Result {get;} | Code d'erreur enregistré après appel de la méthode SetRemoteFile
NewFileNameIsValid | bool {get;} | Vrai, si le nom du fichier est valide.
FileUpdateAllowed | bool {get;} | Vrai, si le dossier peut ajouter ou remplacer un fichier dans la liste.
SelectedCount | int {get;} | Nombre de fichiers sélectionnés
Files | List<IRemoteFile> {get;} | Liste de fichiers dans ce dossier
FolderType | RemoteFolderType {get;} | Type de dossier (datalog ou recette)
Exists | bool {get;} | Vrai, si ce dossier existe sur l'appareil.
Selected | bool {get;set;} | Vrai, si le dossier est sélectionné.
NewFile | string {get;} | Chemin d'accès complet du fichier à ajouter ou remplacer
NewFileName | string {get;} | Nom du fichier à ajouter ou à remplacer
Name | string {get;} | Nom du dossier


Interface IRemoteInterface

Interface IRemoteInterface

IRemoteInterface est une interface utilisée pour représenter la périphérie décentralisée dans un réseau.

Nom de la propriété | Type de retour | Description
Devices | List<IBaseDevice>{get;} | Liste des interfaces distantes utilisées pour représenter la périphérie décentralisée
InterfaceType | RemoteInterfaceType{get;} | Type d'interface distante comme PROFINET ou PROFIBUS
Name | string {get;} | Nom et extension du fichier sur l'appareil


Interface IHardware

Interface IHardware

IHardware est une interface utilisée pour représenter l'interface matérielle commune de base pour les appareils et les modules. IModule élargit l'interface IHardware.

Nom de la méthode | Type de retour | Description
SetFirmwareFile(string strFile) | Result | Définit le fichier de firmware à mettre à jour sur cet appareil ou ce module.

Nom de la propriété | Type de retour | Description
Comment | string {get;set;} | Commentaire pour chaque appareil et module
Selected | bool {get;set;} | Utilisé pour le stockage externe de l'état sélectionné
NewFirmwareNameErrorCode | Result {get;} | Dernière erreur reçue par la méthode SetFirmwareFile
FirmwareUpdateAllowed | bool {get;} | Vrai, si cet appareil ou ce module prend en charge la mise à jour du firmware.
NewFirmwareNameIsValid | bool {get;} | Vrai, si le fichier de firmware est valide pour cet appareil ou ce module.
Failsafe | bool {get;} | Vrai, s'il s'agit d'un appareil ou module de sécurité.
Supported | bool {get;} | Vrai, si cet appareil ou module est pris en charge.
NewFirmwareFile | string {get;} | Chemin d'accès complet du fichier de firmware
NewFirmwareVersion | string {get;} | Version du fichier de firmware qui s'affiche dans la liste déroulante
Configured | bool {get;} | Vrai si cet appareil ou ce module est configuré.
HardwareNumber | short {get;} | Numéro de révision matérielle de l'appareil ou du module
SlotName | string {get;} | Nom de l'emplacement de l'appareil ou du module
SubSlot | uint {get;} | Numéro de sous-emplacement de l'appareil ou du module
Slot | uint {get;} | Numéro d'emplacement de l'appareil ou du module
StationNumber | uint {get;} | Numéro de station de l'appareil ou du module
SerialNumber | string {get;} | Numéro de série de l'appareil ou du module
FirmwareVersion | string {get;} | Version de firmware de l'appareil ou du module
ArticleNumber | string {get;} | Numéro d'article de l'appareil ou du module
Description | string {get;} | Description du numéro d'article de l'appareil ou du module
Name | string {get;} | Nom de l'appareil ou du module
ID | uint {get;} | Identifiant de l'appareil ou du module


Interface IBaseDevice

Interface IBaseDevice

IBaseDevice est une interface utilisée pour élargir l'interface IHardware, qui représente le type d'appareil le plus basique.

Nom de la méthode | Type de retour | Description
GetHardwareFromID(uint hardwareID) | IHardware | Trouve un appareil ou un module à l'aide d'un identifiant

Nom de la propriété | Type de retour | Description
HardwareInDisplayOrder | IHardwareCollection | Collection d'éléments matériels dans l'ordre d'affichage
HardwareInFirmwareOrder | IHardwareCollection | Collection d'éléments matériels dans l'ordre de mise à jour du firmware
Modules | IModuleCollection | Collection de modules
ThreadNumber | int | Nombre actuel de threads de l'opération
Family | DeviceFamily | Énumération des types de familles

Événements | Type de retour | Description
ProgressChanged | ProgressChangedEventHandler | Appelé pour suivre la progression
DataChanged | DataChangedEventHandler | Appelé lorsque les données changent dans l'API


Interface IHardwareCollection

Interface IHardwareCollection

IHardwareCollection est une interface utilisée pour représenter une liste d'interfaces IHardware. Cette interface élargit une classe de liste .NET.

Nom de la propriété | Type | Description
Aucune |  |


Interface IModuleCollection

Interface IModuleCollection

IModuleCollection est une interface utilisée pour représenter un tableau d'interface IModule. Cette interface élargit une classe de liste .NET. Cette interface est utilisée pour représenter les modules locaux et distants dans le châssis matériel.

Nom de la propriété | Type | Description
Aucune |  |


Classe IScanErrorCollection

Classe IScanErrorCollection

Cette classe d'interface comprend la logique nécessaire pour déterminer si une recherche d'appareils avec un scan réseau a réussi à l'aide de l'appel ScanNetworkDevices. De plus, cette classe fournit des informations d'erreur pour tout appareil sur le réseau pour lequel le scan n'a pas eu de succès en renvoyant un ScanErrorEvent pour l'appareil. L'objet IScanErrorCollection renvoyé par un appel ScanNetworkDevices doit toujours être inspecté pour savoir si l'action a été terminée avec succès ou a échoué. L'interface est ajoutée pour permettre à l'utilisateur d'obtenir des informations de scan d'erreur plus spécifiques à l'appareil utiles au diagnostic des problèmes de scan réseau.

Constructeur | Description
ScanErrorCollection() | Crée un résultat de scan réseau avec succès

Nom de la propriété | Type de retour | Description
Count | Int | Nombre d'événements de scan réseau
ScanErrorEvent[int] | ScanErrorEvent | Renvoie l'événement de scan dans la collection d'événements de scan Renvoie nul s'il y a un élément invalide
Failed | Bool {get;} | Vrai, lorsque le résultat a échoué
Succeeded | Bool {get;} | Vrai, lorsque le résultat est un succès Succeeded = Failed

Les conditions suivantes résultent en un échec du scan :

  • Pas de licence SAT ou d'installation SDK

  • Interface réseau invalide

  • Aucun appareil trouvé par le scan

  • Opération annulée par l'utilisateur

Nom de la méthode | Type de retour | Description
GetEnumerator() | IEnumerator<IScanErrorEvent> | Obtient un énumérateur pour la collection d'événements de scan d'erreur


Classe IScanErrorEvent

Classe IScanErrorEvent

Cette classe fournit des informations relatives à un essai de scan qui a échoué sur un appareil comme résultat de l'appel de la méthode ScanNetworkDevices. Le contenu du ScanErrorEvent fournit des informations disponibles sur l'appareil et précise l'erreur comme information, avertissement, erreur ou invalide.

Constructeur | Description
ScanErrorEvent() | Crée un ScanErrorEvent

Nom de la propriété | Type de retour | Description
Code | ErrorCode {get;} | Erreur de scan
IP | Uint {get;} | Adresse IP de l'appareil
MAC | ulong {get;} | Adresse MAC de l'appareil
Name | string {get;} | Nom de l'appareil
TimeStamp | DateTime {get;} | Horodatage associé à l'erreur
Type | ScanErrorType {get}; | Type de scan où l'erreur s'est produite


Classe Network

Classe Network

Ce chapitre contient des informations sur les sujets suivants :
  • Constructeur réseau
  • Méthode QueryNetworkInterfaceCards
  • Méthode SetCurrentNetworkInterface
  • Propriété CurrentNetworkInterface
  • Méthode ScanNetworkDevices
  • Méthode SetCommunicationsTimeout
  • Méthode GetCommunicationsTimeout
  • Méthode GetEmptyCollection


Constructeur réseau

Constructeur réseau

La classe .NET Network sert à exécuter des fonctions à l'aide d'une carte d'interface réseau (NIC) installée sur la console de programmation. La classe Network sert à rechercher des cartes d'interface disponibles et à choisir la carte qui communique avec le réseau industriel.

Pour interagir avec le réseau industriel, votre programme déclare une variable de type Network comme suit :

Network myNetwork = new Network();

Vous pouvez utiliser cet objet pour rechercher les interfaces réseau disponibles et en sélectionner une.


Méthode QueryNetworkInterfaceCards

Méthode QueryNetworkInterfaceCards

Type de retour | Nom de la méthode
Result | QueryNetworkInterfaceCards

Parameters
Nom | Type de données | Type de paramètre | Description
aInterfaces | List<string> | Out | Collection de toutes les cartes d'interface réseau sur la console de programmation, classées par nom

Pour identifier les cartes d'interface réseau disponibles, utilisez la méthode QueryNetworkInterfaceCards comme indiqué dans l'exemple suivant :

Network myNetwork = new Network();

        List<String> interfaces = new List<String>();
Result retVal = myNetwork.QueryNetworkInterfaceCards(out interfaces);
if (retVal.Succeeded)
{
//-----------------------------------------------------
//
        La méthode renvoie une liste de chaines.
//
        Chaque chaine de la liste représente une carte d'interface réseau disponible.
//
        La liste peut être itérée à l'aide d'une notation array.
//-----------------------------------------------------
for (Int32 index = 0; index < interfaces.Count; index++)
{
String strInterfaceName = interfaces[index];
}
}

Comme le montre l'exemple, la méthode sort une liste de chaines. Chaque élément de la liste représente une carte d'interface réseau disponible, identifiée par son nom.

La méthode QueryNetworkInterfaceCards renvoie un objet Result contenant l'état de l'opération. L'objet Résultat indique si l'opération a réussi (La propriété Succeeded est vraie) ou échoué (La propriété Succeeded est fausse). Des opérations peuvent échouer pour de nombreuses raisons. La classe Résultat contient des propriétés et des méthodes pour obtenir plus d'informations sur l'échec.


Méthode SetCurrentNetworkInterface

Méthode SetCurrentNetworkInterface

Type de retour | Nom de la méthode
Result | SetCurrentNetworkInterface

Paramètres
Nom | Type de données | Type de paramètre | Description
strInterface | string | In | Le nom de l'interface réseau à utiliser. Normalement, il s'agit de l'un des noms renvoyés par la méthode QueryNetworkInterfaceCards.

Pour utiliser une des cartes d'interface réseau identifiées pour accéder au réseau industriel, vous devez la définir ("set"). Le code suivant montre comme définir une des interfaces réseau identifiées pour les opérations API. Dans cet exemple, le code choisit d'utiliser la première carte d'interface réseau identifiée dans l'exemple QueryNetworkInterfaceCards :

Network myNetwork = new Network();

List<String> interfaces = new List<String>();
Result retVal = myNetwork.QueryNetworkInterfaceCards(out interfaces);
if (retVal.Succeeded)
{
retVal = myNetwork.SetCurrentNetworkInterface(interfaces[0]);
if (retVal.Succeeded)
{
//---------------------------------------------------
//
        L'action a été terminée avec succès. Poursuivre les opérations.
//---------------------------------------------------
}
}


Propriété CurrentNetworkInterface

Propriété CurrentNetworkInterface

Cette propriété lecture-seule recherche l'interface réseau actuellement sélectionnée. L'exemple suivant montre comment utiliser cette propriété :

Network myNetwork = new Network();
string currentInterface = myNetwork.CurrentNetworkInterface;

Remarque

Cette propriété renvoie une chaîne vide si aucune interface réseau n'a été sélectionnée par un appel précédent de la méthode SetCurrentNetworkInterface.


Méthode ScanNetworkDevices

Méthode ScanNetworkDevices

Type de retour | Nom de la méthode
IScanErrorCollection | ScanNetworkDevices

Paramètres
Nom | Type de données | Type de paramètre | Description
strFile | IProfinetDeviceCollection | Out | Collection contenant un élément IProfinetDevice pour chaque appareil accessible sur le réseau industriel

Après avoir créé une interface réseau, vous pouvez rechercher les appareils sur le réseau industriel. La méthode ScanNetworkDevices renvoie une collection d'éléments qui représentent chacun un appareil raccordé directement au réseau Industrial Ethernet. Ces appareils peuvent être des CPU, des modules locaux, des stations E/S décentralisées, des IHM et autres appareils.

Scanner un réseau avec de nombreux appareils peut prendre plusieurs minutes. La propriété terminée avec succès dans l'objet IScanErrorCollection retourné indique si le scan a réussi ou s'il a échoué.

L'exemple suivant crée une collection de tous les appareils accessibles sur l'interface réseau sélectionnée :

Network myNetwork = new Network();

        //--------------------------------------------------------------------
//
        Remarque : Cet exemple suppose qu'un appel de la méthode SetCurrentNetworkInterface
//
         a réalisé l'affectation de la carte réseau NIC
//--------------------------------------------------------------------

IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//---------------------------------------------------
//
         L'action a réussi. Poursuivre les opérations.
//---------------------------------------------------
}
else
{
foreach (ScanErrorEvent scanErrorEvent in scanResult)
{
//
        Traiter les événements erreur de scan.
}
}

Cette méthode génère une collection IProfinetDeviceCollection.

Remarque

Conditions requises pour l'utilisation de la méthode ScanNetworkDevices.

Vous devez avoir une licence SAT valide et non expirée ou une installation de SDK pour utiliser avec succès la méthode ScanNetworkDevices. Si le SDK ou une licence SAT valide et non expirée n'est pas présent(e) au runtime, la méthode ScanNetworkDevices renvoie une collection vide. ScanNetworkDevices ne renvoie aucune information sur l'appareil à l'application appelante.


Méthode SetCommunicationsTimeout

Méthode SetCommunicationsTimeout

Type de retour | Nom de la méthode
Result | SetCommunicationsTimeout

Paramètres
Nom | Type de données | Type de paramètre | Description
nTimeout | uint | In | Temps spécifié pour l'expiration des opérations

Vous pouvez définir un délai pour les opérations appelées à l'aide de l'API. SetCommunicationsTimeout vous permet de fixer un délai allant de 180 à 999 secondes. Toute valeur en dehors de cette plage entraîne un échec de l'opération.

L'exemple suivant montre comment utiliser cette méthode pour fixer un délai pour les opérations ScanNetworkDevices :

        Network myNetwork = new Network();

IProfinetDeviceCollection scannedDevices;

Result retVal = Network.SetCommunicationsTimeout(180); //
        Délai d'attente de 3 minutes
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//---------------------------------------------------
//
        L'action a été terminée avec succès. Poursuivre les opérations.
//---------------------------------------------------
}


Méthode GetCommunicationsTimeout

Méthode GetCommunicationsTimeout

Type de retour | Nom de la méthode
uint | GetCommunicationsTimeout

Une fois qu'une valeur de temporisation a été définie pour la communication, vous pouvez récupérer la valeur de temporisation avec l'appel GetCommunicationsTimeout. Cette méthode renvoie la valeur de temporisation actuelle.

L'exemple suivant montre comment récupérer la valeur de temporisation actuelle et définir une nouvelle valeur de temporisation de 180 secondes si la valeur de temporisation actuelle est supérieure à 180 secondes :

uint timeout = Network.GetCommunicationsTimeout();
if (timeout > 180)
{
    Result retVal = Network.SetCommunicationsTimeout(180);
}


Méthode GetEmptyCollection

Méthode GetEmptyCollection

Type de retour | Nom de la méthode
IProfinetDeviceCollection | GetEmptyCollection

La méthode GetEmptyCollection fournit un mécanisme alternatif pour acquérir une collection d'appareils Profinet sans effectuer un scan réseau. Cela est pratique, par exemple, pour permettre à l'utilisateur d'intégrer un appareil dans une IProfinetDeviceCollection sans la nécessité d'un scan réseau complet préalable.

IProfinetDeviceCollection est une interface qui ne peut pas être instanciée. Un scan du réseau retourne la collection. Pour ouvrir un projet sans effectuer de scan, appelez GetEmptyCollection pour renvoyer une collection vide. Vous pouvez alors intégrer un appareil dans la collection vide des appareils Profinet sans effectuer un scan réseau.

L'exemple suivant montre comment utiliser la méthode GetEmptyCollection :

IProfinetDeviceCollection collection = Network.GetEmptyCollection();
MemoryStream stream = new MemoryStream();

Result result = collection.WriteToStream(stream);
if (result.Succeeded)
{
//---------------------------------------------------
//
        La collection a été sérialisée avec succès
//---------------------------------------------------
}


La classe HealthCheck

La classe HealthCheck

Ce chapitre contient des informations sur les sujets suivants :
  • Constructeur HealthCheck
  • Méthode ExportPCData


Constructeur HealthCheck

Constructeur HealthCheck

La classe .NET HealthCheck prend en charge la création du fichier de données PC et elle est définie dans le SimaticAutomationToolHealthCheck.dll.

Pour interagir avec le réseau industriel, votre programme instancie un objet de type HealthCheck comme suit :

HealthCheck myHealthCheck = new HealthCheck();


Méthode ExportPCData

Utilisation de l'événement ProgressChanged pour suivre la progression d'une exportation de données PC.
Démarrer Précédent Suivant

Méthode ExportPCData

Type de retour | Nom de la méthode
HealthCheckResultType | ExportPCData

Paramètres
Nom | Type de données | Type de paramètre | Description
filePath | string | In | Le chemin de fichier complet de la sauvegarde du fichier zip contenant les données PC exportées

La méthode ExportPCData crée un fichier HealhCheck.zip contenant les données sur la console de programmation. L'objet HealthCheckResultType retourné indique le résultat de l'opération. Le fichier HealthCheck.log dans le fichier HealthCheck.zip contient des détails sur les données exportées et sur les erreurs.

        HealthCheck myHealthCheck = new HealthCheck ();
String healthCheckFilePath = @"c:\export\healthcheck.zip";
HealthCheckResultType hcResult = myHealthCheck.ExportPCData(healthCheckFilePath);
if (hcResult == HealthCheckResultType.Success)
{
//---------------------------------------------------
//
        L'action a été terminée avec succès. Poursuivez les opérations.
//
        Le fichier HealthCheck.log dans le fichier HealthCheck.zip
//
        contient des détails sur les données exportées.
//---------------------------------------------------
}
else
{
//---------------------------------------------------
//
         L'action a échoué, elle a généré des avertissements ou a été annulée par l'utilisateur.
//
//
        Si l'opération n'a pas été annulée, le fichier HealthCheck.log
//
         dans le fichier the HealthCheck.zip

        contient des informations
//
         sur l'opération d'exportation.
//---------------------------------------------------
}

Utilisation de l'événement ProgressChanged pour suivre la progression d'une exportation de données PC.

L'API fournit l'événement ProgressChanged pour suivre la progression de méthodes qui nécessitent un temps important. ExportPCData est une méthode qui nécessite un temps important.

Pour utiliser l'événement ProgressChanged pour suivre le progrès de ExportPCData, attachez un gestionnaire d'événement à l'événement. Un changement dans la progression de l'opération appelle alors automatiquement le gestionnaire d'événement.

L'exemple suivant montre comment utiliser l'événement ProgressChanged pour suivre la progression d'une exportation de données PC. Le code exemple définit un gestionnaire d'événement et l'attache à l'événement ProgressChanged. Puis, le code appelle la méthode ExportPCData, ce qui peut prendre un certain temps. Lorsque ExportPCData est terminée, le code en exemple détache le gestionnaire d'événement de l'événement.

        HealthCheck myHealthCheck = new HealthCheck ();

//
         Inscrire pour l'événement de progression
myHealthCheck.ProgressChanged += healthCheck_ProgressChanged;

HealthCheckResultType hcResult = myHealthCheck.ExportPCData(healthCheckFilePath);

//
        Supprimer l'inscription pour l'événement de progression
myHealthCheck.ProgressChanged -= healthCheck_ProgressChanged;

private static void healthCheck_ProgressChanged(object sender,ExportProgressEventArgs e)
{
String strProgress = String.Format("Processing {0} of {1}", e.WorkItem, e.MaxEntries);
//
        Mettre sur vrai pour annuler, pour terminer la progression
e.Cancel = false;
}


Classe IProfinetDeviceCollection

Classe IProfinetDeviceCollection

Ce chapitre contient des informations sur les sujets suivants :
  • Itération des éléments dans la collection
  • Filtrage des éléments dans la collection
  • Rechercher un appareil spécifique dans la collection
  • Sérialisation
  • Ajouter manuellement des éléments à la collection
  • Copie de données depuis une collection
  • Supprimer des appareils de la collection


Itération des éléments dans la collection

Itération des éléments dans la collection

Ce chapitre contient des informations sur les sujets suivants :
  • Itération des éléments dans la collection
  • Méthode GetEnumerator
  • Propriété décompte
  • Propriété [ ]


Itération des éléments dans la collection

Itération des éléments dans la collection

La méthode ScanNetworkDevices renvoie un objet de type IProfinetDeviceCollection. Cette classe offre de multiples façons de réaliser la fonction d'itération des éléments dans la collection. Elle fournit également des méthodes pour filtrer les éléments de la collection en fonction de certains critères.

Scanner un réseau avec de nombreux appareils peut prendre plusieurs minutes. La propriété terminée avec succès dans l'objet IScanErrorCollection retourné indique si le scan a réussi ou s'il a échoué.

L'exemple suivant crée une collection de tous les appareils accessibles sur l'interface réseau sélectionnée :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

Pour les programmateurs qui préfèrent la syntaxe de type array, vous pouvez accéder aux éléments dans scannedDevices comme suit :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

if (scanResult.Succeeded)
{

for (int deviceIdx = 0; deviceIdx < scannedDevices.Count; deviceIdx++)
{
//‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
//
        Chaque élément de la collection est un IProfinetDevice.
//
        Cette interface est décrite en détail dans la partie suivante
//‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
IProfinetDevice dev = scannedDevices[deviceIdx];
}
}

La collection prend également en charge l'itération à l'aide de la syntaxe foreach. L'exemple suivant montre la même itération dans cette syntaxe :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
//‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
//
        La variable "
        dev
        " représente maintenant l'élément suivant dans la collection
//‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐‐
}
}


Méthode GetEnumerator

Méthode GetEnumerator

Type de retour | Nom de la méthode
IEnumerator<IProfinetDevice> | GetEnumerator

Paramètres
Nom | Type de données | Type de paramètre | Description
Aucune |  |  |

Cette méthode permet d'énumérer tous les IProfinetDevices dans la IProfinetDeviceCollection.


Propriété décompte

Propriété décompte

Type de retour | Nom de la propriété
int | Count

Cette propriété renvoie le décompte du nombre de IProfinetDevices dans la IProfinetDeviceCollection.


Propriété [ ]

Propriété [ ]

Type de retour | Nom de la propriété
IProfinetDevice | this[int index]

Cette propriété renvoie le IProfinetDevice à un index spécifique. Voir l'exemple ci-dessous :

IProfinetDeviceCollection collection = Network.GetEmptyCollection();
MemoryStream stream = new MemoryStream();

Result result = collection.WriteToStream(stream);
if (retVal.Succeeded)
{
//---------------------------------------------------
//
        La collection a été sérialisée avec succès
//---------------------------------------------------

IProfinetDevice device = collection[0];
}


Filtrage des éléments dans la collection

Filtrage des éléments dans la collection

Ce chapitre contient des informations sur les sujets suivants :
  • Éléments de la collection
  • Méthode FilterByDeviceFamily
  • Méthode FilterOnlyCPUs


Éléments de la collection

Éléments de la collection

La collection contient un élément pour chaque appareil du réseau Industrial Ethernet. La collection peut contenir des appareils provenant de gammes de produits différentes (par exemple, S7-1200, S7-1500 et ET 200S).

La collection peut aussi contenir différentes "catégories" d'appareils (p. ex. CPU ou stations E/S). Pour différentes catégories d'appareils, des opérations spécifiques sont disponibles. Il peut donc être utile de filtrer la collection pour inclure uniquement certains appareils.


Méthode FilterByDeviceFamily

Méthode FilterByDeviceFamily

Type de retour | Nom de la méthode
List<IProfinetDevice> | FilterByDeviceFamily

Paramètres
Nom | Type de données | Type de paramètre | Description
familiesToInclude | List<DeviceFamily> | In | Types de gammes d'appareils à renvoyer dans la liste

Cette méthode renvoie une collection qui comprend uniquement les appareils des gammes de produit spécifiées. Le filtre est d'abord construit sous forme de liste d'une ou plusieurs gammes d'appareils. Par exemple, cette déclaration crée un filtre uniquement pour les appareils S7-1200 et S7-1500.

Transmettez ce filtre à la méthode FilterByDeviceFamily. Le résultat est une IProfinetDeviceCollection qui contient uniquement les appareils des gammes de produits spécifiées :

Network myNetwork = new Network();
List<DeviceFamily> fams = new List<DeviceFamily> { DeviceFamily.CPU1200, DeviceFamily.CPU1500 };

IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

List<IProfinetDevice> onlyPlus = scannedDevices.FilterByDeviceFamily(fams);

La collection qui en résulte peut être itérée pour exécuter des actions uniquement sur les appareils inclus.

Remarque

La transmission d'une valeur List<DeviceFamily> vide entraîne le renvoi d'une collection vide.


Méthode FilterOnlyCPUs

Méthode FilterOnlyCPUs

Type de retour | Nom de la méthode
List<ICPU> | FilterOnlyCPUs

L'API SIMATIC Automation Tool prend en charge de nombreuses opérations qui sont autorisées uniquement pour les CPU. Il est donc utile de filtrer les collections pour inclure uniquement les CPU détectées sur le réseau.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

if (scanResult.Succeeded)

        {

List<ICPU> cpus = scannedDevices.FilterOnlyCpus();
foreach (ICPU cpu in cpus)
{
//----------------------------------------------------------
//
        Effectuer une itération dans la liste n'incluant que des appareils CPU
//----------------------------------------------------------
}
}

Cette méthode retourne une liste d'ICPU. Des opérations API additionnelles sont prises en charge pour les CPU. L'interface ICPU fournit ces opérations. L'interface ICPU est décrite en détails au chapitre Interface ICPU.


Rechercher un appareil spécifique dans la collection

Rechercher un appareil spécifique dans la collection

Ce chapitre contient des informations sur les sujets suivants :
  • Méthode FinidDeviceByIP
  • Méthode FinidDeviceByMAC


Méthode FinidDeviceByIP

Méthode FinidDeviceByIP

Vous pouvez rechercher un appareil spécifique dans la collection.

Type de retour | Nom de la méthode
IProfinetDevice | FindDeviceByIP

Paramètres
Nom | Type de données | Type de paramètre | Description
ip | uint | In | L'adresse IP recherchée

L'exemple suivant montre la recherche d'un appareil se trouvant à une adresse IP donnée. Si l'appareil est introuvable dans la collection, une référence NULL (zéro) est renvoyée :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
//
         Appareil trouvé
}


Méthode FinidDeviceByMAC

Méthode FinidDeviceByMAC

La méthode FindDeviceByMAC permet de rechercher un appareil avec une adresse MAC spécifique.

Type de retour | Nom de la méthode
IProfinetDevice | FindDeviceByMAC

Paramètres
Nom | Type de données | Type de paramètre | Description
mac | ulong | In | L'adresse MAC recherchée

Dans l'exemple suivant, on recherche un appareil à une adresse MAC donnée. Si l'appareil est introuvable dans la collection, une référence NULL (zéro) est renvoyée :

ulong targetMAC = 0x112233445566; //
        équivalent à la chaîne de caractères 11:22:33:44:55:66
Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMAC);
if (dev != null)
{
//
         Appareil trouvé
}


Sérialisation

Sérialisation

Ce chapitre contient des informations sur les sujets suivants :
  • Transfert d'une collection de/vers un fichier de données externe
  • Méthode WriteToStream
  • Méthode ReadFromStream
  • Méthode ExportDeviceInformation
  • Méthode ExportDeviceDiagnostics


Transfert d'une collection de/vers un fichier de données externe

Transfert d'une collection de/vers un fichier de données externe

Les méthodes de sérialisation permettent de sérialiser et de transférer le contenu d'une collection de/vers un fichier de données externe.


Méthode WriteToStream

Méthode WriteToStream

Type de retour | Nom de la méthode
Result | WriteToStream

Paramètres
Nom | Type de données | Type de paramètre | Description
stream | Stream | In | Cible de la sortie de la sérialisation de la collection.

Cette méthode est utilisée pour stocker en externe les contenus de la collection. L'exemple suivant montre l'utilisation de cette méthode :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
    return;

FileStream f = File.Create("myDataFile.SAT");

Result retVal = scannedDevices.WriteToStream(f);

f.Close();

Cette méthode sérialise en interne l'information de version afin d'assurer la postcompatibilité des données enregistrées.


Méthode ReadFromStream

Méthode ReadFromStream

La méthode ReadFromStream crée la collection à partir d'un fichier de sérialisation précédemment créé. L'exemple suivant montre comment utiliser cette méthode.

Type de retour | Nom de la méthode
Result | ReadFromStream

Paramètres
Nom | Type de données | Type de paramètre | Description
stream | Stream | In | La source de désérialisation de la collection

Cette méthode est utilisée pour créer la collection à partir d'un fichier de sérialisation précédemment créé. L'exemple suivant montre l'utilisation de cette méthode :

IProfinetDeviceCollection devices = Network.GetEmptyCollection();

FileStream f = File.OpenRead("myDataFile.SAT");

Result retVal = devices.ReadFromStream(f);

f.Close();


Méthode ExportDeviceInformation

Méthode ExportDeviceInformation

La méthode ExportDeviceInformation crée un fichier .csv d'exportation contenant les données de collection de l'appareil :

Type de retour | Nom de la méthode
Result | ExportDeviceInformation

Paramètres
Nom | Type de données | Type de paramètre | Description
ExportFilePath | string | In | Chemin de fichier de destination pour le fichier d'exportation généré

L'exemple suivant montre l'utilisation de cette méthode :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

//--------------------------------------------------------------------------
//
        Remarque : cet exemple suppose que l'affectation Network NIC a déjà// été effectuée
//
        comme illustré dans SetCurrentNetworkInterface
//--------------------------------------------------------------------------

//--------------------------------------------------------------------------
// Obtenez le contenu de l'appareil actuel sur le réseau
//--------------------------------------------------------------------------

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

//--------------------------------------------------------------------------
//
        Définissez le mot de passe pour toute CPU nécessitant un mot de passe pour l'accès aux informations d'appareil.
//--------------------------------------------------------------------------
List<ICPU> aCPUs = scannedDevices.FilterOnlyCpus();
foreach (ICPU cpu in aCPUs)
{
if (cpu.Protected == true)
{
cpu.SetPassword(new EncryptedString("Password"));
}
}

String exportFilePath = @"c:\export\DeviceInformation.csv";
Result retVal = scannedDevices.ExportDeviceInformation(exportFilePath);


Méthode ExportDeviceDiagnostics

Utilisation de l'événement ProgressChanged pour suivre la progression d'une exportation de diagnostic d'appareil.
Démarrer Précédent Suivant

Méthode ExportDeviceDiagnostics

La méthode ExportDeviceDiagnostics crée un fichier .csv d'exportation contenant les données de diagnostic pour chaque CPU dans la collection de l'appareil. Les en-têtes de colonne du fichier .csv sont en anglais.

Type de retour | Nom de la méthode
Result | ExportDeviceDiagnostics

Paramètres
Nom | Type de données | Type de paramètre | Description
ExportFilePath | string | In | Chemin de fichier de destination pour le fichier d'exportation généré
Language | Language | In | Langue des entrées du tampon de diagnostic exportées
Format | TimeFormat | In (facultatif) | Format d'affichage de la date et de l'heure pour les entrées de diagnostic

L'exemple suivant montre l'utilisation de cette méthode :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
//--------------------------------------------------------------------
// Note: this example assumes Network NIC assignment has already been made
//
         comme illustré dans
        SetCurrentNetworkInterface
//--------------------------------------------------------------------
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

//--------------------------------------------------------------------------
//
        sélectionnez dans la liste des appareils toutes les CPU à inclure pour les informations de diagnostic
//--------------------------------------------------------------------------
foreach (IProfinetDevice profi in scannedDevices)
{
if((profi.Family == DeviceFamily.CPU1200)||(profi.Family == DeviceFamily.CPU1500)||
(profi.Family == DeviceFamily.CPU300) || profi.Family == DeviceFamily.CPU400))

    profi.Selected = true;
}

//--------------------------------------------------------------------

        //
        Définissez le mot de passe pour toute CPU nécessitant un mot de passe pour l'accès aux informations d'appareil.
//--------------------------------------------------------------------
List<ICPU> aCPUs = deviceCollection.FilterOnlyCpus();
foreach (ICPU cpu in aCPUs)
{
cpu.SetPassword(new EncryptedString("Password"));
}

//  Avec l'API, l'application client détermine le chemin et le nom du fichier

String exportFilePath = @"c:\export\Device\DeviceDiagnostics.csv";

IScanErrorCollection exportResult =
   scannedDevices.ExportDeviceDiagnostics(exportFilePath, Language.English,TimeFormat.Local);

Pour chaque CPU, la collection d'erreurs retournée indique si les données de diagnostic ont été correctement acquises. Si le mot de passe requis n'a pas été fourni ou si une erreur réseau s'est produite, l'erreur est listée pour la CPU. Une erreur a pour effet l'enregistrement d'une entrée nulle pour la CPU.

Utilisation de l'événement ProgressChanged pour suivre la progression d'une exportation de diagnostic d'appareil.

L'API fournit l'événement ProgressChanged pour suivre la progression de méthode qui nécessitent un temps relativement long. ExportDeviceDiagnostics est une méthode qui peut durer assez longtemps.

Pour utiliser l'événement ProgressChanged afin de suivre la progression de ExportDeviceDiagnostics, attachez un gestionnaire d'événement à l'événement. Un changement dans la progression de l'opération appelle alors automatiquement le gestionnaire d'événement.

L'exemple suivant montre comment utiliser l'événement ProgressChanged pour suivre la progression d'une exportation de diagnostic d'appareil. Le code exemple définit un gestionnaire d'événement et l'attache à l'événement ProgressChanged. Puis, le code appelle la méthode ExportDeviceDiagnostics, ce qui peut prendre un certain temps. Lorsque ExportDeviceDiagnostics est terminée, le code en exemple détache le gestionnaire d'événement de l'événement.

        Network myNetwork = new Network();

IProfinetDeviceCollection deviceCollection = null;

//
        Appeler la séquence d'exportation du diagnostic d'appareil
//
         Scanner les appareils sur le réseau
IScanErrorCollection scanErrors = myNetwork.ScanNetworkDevices(out deviceCollection);

// Inscrire pour l'événement de progression
deviceCollection.ProgressChanged += Export_ProgressChanged;

IScanErrorCollection ExportDeviceDiagnosticsErrors = deviceCollection.ExportDeviceDiagnostics(@"C:\MyDocuments\DeviceDiagnostics.csv", Language.English, TimeFormat.UTC);

// Supprimer l'inscription pour l'événement de progression

deviceCollection.ProgressChanged -= Export_ProgressChanged;

private static void Export_ProgressChanged(object sender,ExportProgressEventArgs e)
{
String strProgress = String.Format("Processing {0} of {1}", e.WorkItem, e.MaxEntries);
// Mettre sur vrai pour annuler, pour terminer la progression
e.Cancel = false;
}


Ajouter manuellement des éléments à la collection

Ajouter manuellement des éléments à la collection

Ce chapitre contient des informations sur les sujets suivants :
  • Ajouter manuellement des éléments à la collection
  • Méthode InsertDeviceByIP
  • Méthode InsertDeviceByMAC


Ajouter manuellement des éléments à la collection

Ajouter manuellement des éléments à la collection

Selon la topologie physique du réseau industriel, il se peut qu'il contienne des appareils qui ne peuvent pas répondre à une commande DCP (comme ceux utilisés dans la méthode ScanNetworkDevices), mais qui sont accessibles via leur adresse IP. Les méthodes d'ajout d'un appareil permettent d'ajouter manuellement un appareil à la collection sur la base de son adresse.


Méthode InsertDeviceByIP

Méthode InsertDeviceByIP

Type de retour | Nom de la méthode
Result | InsertDeviceByIP

Paramètres
Nom | Type de données | Type de paramètre | Description
index | int | In | Emplacement où insérer la valeur dans la collection
ip | uint | In | Adresse IP de l'appareil à ajouter à la collection.

Le code suivant scanne le réseau et ajoute manuellement un appareil à une adresse IP donnée à l'index indiqué :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
    return;

UInt32 missingDeviceIPAddress = 0xC0A80001; // 192.168.0.1
Int32 index = 0;

Result retVal = scannedDevices.InsertDeviceByIP(index, missingDeviceIPAddress);


Méthode InsertDeviceByMAC

Méthode InsertDeviceByMAC

Type de retour | Nom de la méthode
Result | InsertDeviceByMAC

Paramètres
Nom | Type de données | Type de paramètre | Description
index | int | In | Emplacement où insérer la valeur dans la collection
mac | ulong | In | Adresse MAC de l'appareil à ajouter à la collection.

Le code suivant scanne le réseau et ajoute manuellement un appareil à une adresse MAC donnée à l'index indiqué :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

UInt64 targetMAC = 0x112233445566; //
         équivalent à la chaîne de caractères 11:22:33:44:55:66
Int32 index = 0;

retVal = scannedDevices.InsertDeviceByMAC(index, targetMAC);


Copie de données depuis une collection

Copie de données depuis une collection

Ce chapitre contient des informations sur les sujets suivants :
  • Méthode CopyUserData


Méthode CopyUserData

Méthode CopyUserData

Il peut être nécessaire de copier les données entrées par l'utilisateur d'un IProfinetDeviceCollection vers un autre. Plutôt que de demander à l'utilisateur d'entrer de nouveau ces informations, l'API fournit la méthode CopyUserData.

Type de retour | Nom de la méthode
Result | CopyUserData

Paramètres
Nom | Type de données | Type de paramètre | Description
oldNetwork | IProfinetDeviceCollection | In | Liste précédente utilisée dans l'application

Le code suivant copie des données saisies par l'utilisateur d'un scan de réseau à un autre.

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
    return;

IProfinetDeviceCollection rescannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out rescannedDevices);
if (!scanResult.Succeeded)
    return;

Result retVal = rescannedDevices.CopyUserData(scannedDevices);
if (!retVal.Succeeded)
    return;


Supprimer des appareils de la collection

Supprimer des appareils de la collection

Ce chapitre contient des informations sur les sujets suivants :
  • Méthode Clear
  • Méthode Remove


Méthode Clear

Méthode Clear

Type de retour | Nom de la méthode
void | Clear

Paramètres
Nom | Type de données | Type de paramètre | Description
Aucun |  |  |

Cette méthode est utilisée pour supprimer le contenu des appareils scannés.


Méthode Remove

Méthode Remove

Type de retour | Nom de la méthode
void | Remove

Paramètres
Nom | Type de données | Type de paramètre | Description
device | IProfinetDevice | In | Appareil à supprimer de la liste

Cette méthode est utilisée pour supprimer un élément spécifique de la collection.


Interface IProfinetDevice

Interface IProfinetDevice

Ce chapitre contient des informations sur les sujets suivants :
  • Propriétés IProfinetDevice
  • Méthode IProfinetDevice
  • Événements IProfinetDevice


Propriétés IProfinetDevice

DeviceFamily Propriété de modules et classe IModuleCollection
Démarrer Précédent Suivant

Propriétés IProfinetDevice

Chaque élément de la collection IProfinetDeviceCollection est représenté par l'interface IProfinetDevice. L'interface fournit un accès aux données et des opérations pour tous les appareils directement connectés sur le réseau industriel.

L'interface IProfinetDevice prend en charge les propriétés suivantes, qui fournissent des informations sur l'appareil du réseau. Ces propriétés sont en lecture seule. Pour être sûr d'obtenir les informations en retour, appeler d'abord la méthode RefreshStatus sur l'appareil avant de lire la propriété.

Nom de la propriété

Type de retour

Description

ArticleNumber

string {get;}

Numéro de commande du module. Également appelé MLFB ou "numéro d'article".

Comment

string {get;set;}

Ceci permet à l'utilisateur de formuler un commentaire sur l'appareil utilisé dans l'interface utilisateur SIMATIC Automation Tool. Le commentaire ne concerne pas les opérations API.

Configured

bool {get;}

Vrai, quand l'appareil a une configuration valide.

DefaultGateway

uint {get;}

L'adresse passerelle par défaut de l'appareil, représentée sous la forme d'un entier non signé. L'adresse passerelle encodée utilise un octet pour représenter chaque décimale dans l'adresse. Par exemple, la valeur encodée 0xC0A80001 est équivalente à la chaine de représentation plus courante 192.168.0.1

DefaultGatewayString

string {get;}

L'adresse passerelle par défaut de l'appareil, représentée sous la forme d'une chaine de caractères de type "xx.xx.xx.xx"
Exemple : 192.168.0.1

Description

string {get;}

Une description du matériel, sur la base du numéro d'article. Il s'agit de la même description que celle affichée dans TIA Portal.

Exemple : CPU 1215 DC/DC/DC

DeviceFound

bool {get;}

L'appareil a-t-il été détecté lors du scan du réseau ?

DuplicateIP

bool {get;}

L'appareil présente-t-il une adresse IP qui existe déjà ?

DuplicateProfinetName

bool {get;}

L'appareil présente-t-il un nom PROFINET qui existe déjà ?

Failsafe

bool {get;}

D'après son ArticleNumber, l'appareil est-il un appareil de sécurité ?

Family

DeviceFamily {get;}

De quelle gamme est cet appareil ? Pour plus d'informations, reportez-vous à la description de l'énumération DeviceFamily.

FirmwareUpdateAllowed

bool {get;}

Cet appareil prend-il en charge la mise à jour du firmware ?

FirmwareVersion

string {get;}

Version de firmware actuelle de l'appareil

ID

uint {get;}

L'identifiant unique de chaque appareil et module dans la station. Il est utilisé comme identifiant unique pour l'exécution d'une FirmwareUpdate.

HardwareNumber

short {get;}

Version matérielle ou "FS" de l'appareil (état fonctionnel)

IP

uint {get;}

L'adresse IP de l'appareil, représentée sous la forme d'un entier non signé. L'adresse IP encodée utilise un octet pour représenter chaque décimale dans l'adresse. Par exemple, la valeur encodée 0xC0A80001 est équivalente à la chaine de représentation plus courante "192.168.0.1"

REMARQUE : SIMATIC Automation Tool prend en charge uniquement les adresses IPv4. L'adressage IPV6 n'est pas pris en charge.

IPString

string {get;}

L'adresse IP de l'appareil, représentée sous la forme d'une chaine de caractères de type "xx.xx.xx.xx" (par ex. 192.168.0.1)

MAC

ulong {get;}

Adresse MAC unique affectée à l'appareil. L'adresse MAC encodée utilise un octet pour représenter chacun des 6 octets définis pour l'adresse. Par exemple, l'adresse MAC encodée 0x112233445566 est équivalente à la chaîne 11:22:33:44:55:66 plus couramment représentée.

MACString

string {get;}

Adresse MAC unique affectée à l'appareil, représentée en tant que chaîne au format 11:22:33:44:55:66

Modules

IModuleCollection {get;}

Une collection de modules raccordés à la station. Cette propriété est décrite ici en détail.

Name

string {get;}

Nom de l'appareil

NewFirmwareFile

string {get;}

Emplacement du fichier de firmware à utiliser dans la mise à jour du firmware.

NewFirmwareNameErrorCode

Result {get;}

ErrorCode associé au nom du nouveau firmware

NewFirmwareNameIsValid

bool {get;}

Le fichier de firmware défini est-il valide ?

NewFirmwareVersion

string {get;}

Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.

NewDefaultGateway

String {get;}

Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.

NewIP

String {get;set;}

Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.

NewProfinetName

String{get;set;}

Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.

NewProgramName

String {get;set;}

Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.

NewRestoreName

String{get;set;}

Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.

ProfinetName

String {get;}

Nom PROFINET de l'appareil

ResetToFactoryAllowed

bool {get;}

La restauration des paramètres d'usine (ResetToFactory) est-elle autorisée sur l'appareil ?

Selected

bool {get;set;}

Marque l'appareil comme étant sélectionné pour permettre l'exécution des opérations.

SerialNumber

string {get;}

Numéro de série unique de l'appareil

Slot

uint {get;}

Numéro d'emplacement du matériel

SlotName

string {get;}

Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.

StationNumber

uint {get;}

Numéro de station de l'appareil

SubSlot

uint {get;}

Le sous-emplacement de l'appareil. Ceci vaut pour les sous-modules enfichables tels que les modules SB S7-1200.

Supported

bool {get;}

Vrai si le numéro d'article existe dans la base de données et que l'appareil est pris en charge par l'API SIMATIC Automation Tool actuelle.

SubnetMask

uint {get;}

L'adresse du masque de sous-réseau, représentée sous la forme d'un entier non signé. Le masque de sous-réseau encodé utilise un octet pour représenter chaque décimale dans l'adresse. Par exemple, la valeur encodée 0xFFFFFF00 est équivalente à la chaîne 255.255.255.0 plus couramment représentée.

SubnetMaskString

string {get;}

Le masque de sous-réseau de l'appareil représenté sous la forme d'une chaine de caractères de type "xx.xx.xx.xx" (par ex. 192.168.0.1)


Méthode IProfinetDevice

Méthode IProfinetDevice

Ce chapitre contient des informations sur les sujets suivants :
  • Méthode RefreshStatus
  • Méthode FirmwareUpdate
  • Méthode Identify
  • ResetCommunicationParameters method
  • Méthode SetIP
  • Méthode SetProfinetName
  • Méthode ValidateIPAddressSubnet
  • Méthode ValidatePROFINETName


Méthode RefreshStatus

Méthode RefreshStatus

Type de retour | Nom de la méthode
Result | RefreshStatus

Lorsque la méthode ScanNetworkDevices crée une ScanNetworkDevices, le scan renvoie une quantité minimale d'informations sur chaque appareil. Pour obtenir toutes les informations disponibles sur l'appareil, appelez la méthode RefreshStatus. Cette méthode établit une connexion à l'appareil, recherche les différentes informations et se déconnecte de l'appareil.

Le code suivant appelle la méthode RefreshStatus pour chaque appareil du réseau :

        Network myNetwork = new Network();
Result retVal = new Result();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded))
{
foreach (IProfinetDevice dev in scannedDevices)
{

retVal = dev.RefreshStatus();
if (retVal.Succeeded)
{
//-------------------------------------------------
//
        Réussite de l'opération. Les données sont fiables.
//-------------------------------------------------
}
}
}

La méthode RefreshStatus se connecte à l'appareil pour lire les informations. Si l'appareil est une CPU, elle peut être protégée par mot de passe. C'est pourquoi la méthode RefreshStatus et toutes celles qui se connectent en interne à la CPU requièrent un paramètre Mot de passe.
L'exemple montre la classe IProfinetDevice. ICPU a besoin d'un mot de passe défini sur l'appareil avant l'appel de la méthode RefreshStatus. Utilisez la méthode SetPassword (EncryptedString) pour définir le mot de passe.


Méthode FirmwareUpdate

Méthode FirmwareUpdate

Type de retour | Nom de la méthode
Result | FirmwareUpdate

Paramètres
Nom | Type de données | Type de paramètre | Description
hardwareID | uint | In | Identification matérielle du module
bUpdateSameVersion | Bool | In | Si vrai, la méthode procède à la mise à jour. La mise à jour est effectuée si le fichier de mise à jour a la même version que la version de firmware sur le module.

Cette méthode met à jour la version de firmware du matériel spécifié (hardwareID) sur l'appareil. L'ID hardwareID peut indiquer l'appareil lui-même ou un module sur le même châssis.

Certains appareils ne prennent pas en charge la fonction de mise à jour du firmware. La propriété FirmwareUpdateAllowed peut être vérifiée pour s'assurer que l'appareil concerné prend en charge cette fonction.

Dans l'exemple suivant, on recherche un appareil à une adresse IP donnée et le firmware de cet appareil est mis à jour :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
    return;

uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string updateFile = @"c:\myUpdates\6ES7 221-1BF32-0XB0 V02.00.00.upd";

IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
    Result retVal = dev.RefreshStatus();

if (!retVal.Succeeded)
        return;

dev.Selected = true;
    dev.SetFirmwareFile(updateFile);
    retVal = dev.FirmwareUpdate(dev.ID, true);
}

Vous pouvez aussi utiliser la méthode FirmwareUpdate pour mettre à jour le firmware d'un module sur une station centrale. Le code suivant montre comment rechercher une CPU à une adresse donnée et comment rechercher ensuite un numéro d'article spécifique parmi les modules de la CPU. Le firmware est ensuite mis à jour dans les modules qui correspondent aux critères de recherche :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string targetModule = @"6ES7 221-1BF32-0XB0";
string updateFile = @"c:\myUpdates\6ES7 221-1BF32-0XB0 V02.00.00.upd";

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);

if (!scanResult.Succeeded)
return;

IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{

Result retVal = dev.RefreshStatus();
if (!retVal.Succeeded)
return;

//----------------------------------
//
        Rechercher les modules sur la CPU.
//----------------------------------
IModuleCollection mods = dev.Modules;
foreach (IModule mod in mods)
{
if (mod.ArticleNumber == targetModule)
{
mod.Selected = true;
mod.SetFirmwareFile(updateFile);

//----------------------------------------
//
        Mettre à jour le firmware pour le(s) module(s) correspondant(s)
//----------------------------------------
dev.FirmwareUpdate(mod.ID, true);
}
}
}

Notez que la méthode FirmwareUpdate est appelée sur la CPU. Le hardwareID transmis à la méthode indique le module à mettre à jour.

Remarque

Fichiers de mise à jour du firmware Classic et Plus

Il existe deux types de fichiers de mise à jour du firmware :

  • Les dossiers de mise à jour du firmware Classic qui renferment la mise à jour du firmware. Le fichier header.upd ou cpu_hd.upd dans ce dossier est le fichier transmis à la méthode FirmwareUpdate.

  • Le fichier de mise à jour de firmware Plus est un fichier de mise à jour unique. Il s'agit du fichier transmis à la méthode FirmwareUpdate.


Méthode Identify

Méthode Identify

Type de retour | Nom de la méthode
Result | Identify

Cette méthode fait clignoter une LED ou l'écran IHM d'un appareil réseau donné. Le voyant clignotant aide à identifier l'emplacement physique de l'appareil.

L'exemple suivant fait clignoter la LED ou l'écran de l'appareil utilisant l'adresse IP 192.168.0.1 :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//-----------------------------------------------------------
//
        Rechercher l'appareil à cette adresse IP et faire clignoter la LED/l'écran IHM
//-----------------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
retVal = dev.Identify();
}
}


ResetCommunicationParameters method

ResetCommunicationParameters method

Type de retour | Nom de la méthode
Result | ResetCommunicationParameters

Utilisez cette méthode pour restaurer les paramètres de communication d'usine d'un appareil PROFINET. Les paramètres suivants sont alors définis comme suit :

  • NameOfStation : chaîne vide ""

  • Paramètre IP suite : 0.0.0.0

  • Paramètres DHCP (le cas échéant) : valeurs d'usine

  • Tous les paramètres P Dev (PD IR Data, PD Port Data Adjust, PD Interface MRP Data Adjust…) : valeurs d'usine

  • Paramètres modifiés par SMNP (sysContact, sysName, sysLocation de MIB-II) : valeurs d'usine

L'exemple suivant appelle la méthode ResetCommunicationParameters pour un appareil se trouvant à une adresse IP donnée :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001;  // 192.168.0.1
IProfinetDeviceCollection scannedDevices;

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//--------------------------------------------------------------------
//
        Rechercher l'appareil à cette adresse IP et le réinitialiser
//--------------------------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
Result retVal = dev.ResetCommunicationParameters();
}
}

Remarque

Vous ne pouvez pas utiliser cette méthode pour réinitialiser une CPU, à moins de l'avoir configurée comme I-Device. L'interface ICPU fournit une méthode ResetToFactoryDefaults pour réinitialiser les CPU.


Méthode SetIP

Conversion des adresses à partir du format string dans un format uint encodé
Démarrer Précédent Suivant

Méthode SetIP

Type de retour | Nom de la méthode
Result | SetIP

Paramètres
Nom | Type de données | Type de paramètre | Description
nIP | uint | In | Nouvelle adresse IP codée
nSubnet | uint | In | Nouvelle adresse de sous-réseau codée
nGateway | uint | In | Nouvelle adresse de passerelle codée

Cette méthode est utilisée pour définir ou modifier l'adresse IP d'un appareil.

Pour que cette opération réussisse, la configuration du port doit être réglée sur l'option "IP address is set directly on the device" (L'adresse IP est définie directement sur l'appareil).

Dans l'exemple suivant, on recherche un appareil à une adresse MAC donnée et on définit son adresse IP :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Rechercher l'appareil à cette adresse MAC et Définir IP
//------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMACAddress);
if (dev != null)
{
Result retVal = dev.SetIP(0xC0A80001, 0xFFFFFF00, 0x0);
}
}

Conversion des adresses à partir du format string dans un format uint encodé

La méthode SetIP suppose que les adresses ont un format encodé (comme indiqué ci-dessus). Vous pouvez convertir les adresses à partir du format string dans un format uint encodé à l'aide du code C# suivant :

string userEnteredAddress = @"192.168.0.1"; // Par exemple

//-------------------------------
// Convertir l'adresse string en uint
//-------------------------------

System.Net.IPAddress ip = System.Net.IPAddress.Parse(userEnteredAddress);
byte[] bytes = ip.GetAddressBytes();
Array.Reverse(bytes);

uint encodedIp = BitConverter.ToUInt32(bytes, 0); // adresse IP encodée disponible


Méthode SetProfinetName

Méthode SetProfinetName

Type de retour | Nom de la méthode
Result | SetProfinetName

Paramètres
Nom | Type de données | Type de paramètre | Description
strName | String | In | Nouveau nom de la station PROFINET

Utilisez cette méthode pour définir ou modifier la station PROFINET pour l'appareil. Pour que cette opération réussisse, le port doit être configuré dans le projet STEP 7 sur l'option "Nom PROFINET défini directement sur l'appareil" :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Rechercher l'appareil à cette adresse MAC et Définir le nom PROFINET
//------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMACAddress);
if (dev != null)
{
Result retVal = dev.SetProfinetName("new name");
}
}


Méthode ValidateIPAddressSubnet

Méthode ValidateIPAddressSubnet

Type de retour | Nom de la méthode
Result | ValidateIPAddressSubnet

Paramètres
Nom | Type de données | Type de paramètre | Description
nIP | uint | In | Adresse IP
nSubnetMask | uint | In | Masque de sous-réseau

Utilisez cette méthode pour valider la compatibilité de la combinaison adresse IP / masque de sous-réseau.

L'exemple suivant recherche un appareil à une adresse MAC donnée et valide la compatibilité de l'adresse IP et du masque de sous-réseau de l'appareil :

        Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Rechercher l'appareil à cette adresse MAC et Définir IP
//------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMACAddress);

if (dev != null)
{
Result retVal = dev.ValidateIPAddressSubnet(dev.IP, dev.SubnetMask);
}
}


Méthode ValidatePROFINETName

Méthode ValidatePROFINETName

Type de retour | Nom de la méthode
Result | ValidatePROFINETName

Paramètres
Nom | Type de données | Type de paramètre | Description
strName | string | In | Nom PROFINET à valider

Cette méthode valide le nom PROFINET.

Dans l'exemple suivant, on recherche un appareil à une adresse MAC donnée et on vérifie la validité du nom PROFINET avant de l'attribuer à l'appareil :

        Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Rechercher l'appareil à cette adresse MAC et Définir IP
//------------------------------------------------
IProfinetDevice dev = scannedDevices.FindDeviceByMAC(targetMACAddress);

if (dev != null)
{
string name = "ValidName";
Result retVal = dev.ValidatePROFINETName(name);
if (retVal.Succeeded)
{
retVal = dev.SetProfinetName(name);
}
}
}


Événements IProfinetDevice

Événements IProfinetDevice

Ce chapitre contient des informations sur les sujets suivants :
  • Événement DataChanged
  • Événement ProgressChanged


Événement DataChanged

La classe DataChangedEventArgs

Événement DataChanged

L'interface IProfinetDevice prend en charge l'événement DataChanged.

Avec cet événement le programme peut voir si des modifications sont intervenues sur un appareil donné du réseau, du fait d'autres opérations sur l'API. Par exemple, si le programme garde une référence pour un IProfinetDevice donné, il peut détecter certaines modifications apportées à l'appareil.

Dans l'exemple suivant, le code est attaché à l'événement DataChanged pour chaque appareil du réseau :

private void AttachEvents(IProfinetDeviceCollection devices)
{
  foreach (IProfinetDevice dev in devices)
  {
    dev.DataChanged += new DataChangedEventHandler(Dev_DataChanged);
  }
}

private void DetachEvents(IProfinetDeviceCollection devices)
{
  foreach (IProfinetDevice dev in devices)
  {
    dev.DataChanged -= new DataChangedEventHandler(Dev_DataChanged);
}
}

        private void Dev_DataChanged(object sender, DataChangedEventArgs e)
{
if (e.Type == DataChangedType.OperatingState)
{
//
        L'état de fonctionnement de l'appareil a été modifié. Réagissez ici aux modifications.
}
}

Désormais, à chaque action de l'API entrainant le changement du mode de fonctionnement d'un appareil, la méthode Dev_DataChanged est appelée.

Remarque

L'événement DataChanged ne surveille pas directement le réseau réel, mais les propriétés de l'IProfinetDevice. L'état de cet objet doit changer pour que l'événement soit déclenché.

La classe DataChangedEventArgs

Le gestionnaire d'événements DataChanged reçoit un objet DataChangedEventArgs. Comme indiqué ci-dessus, cette classe possède une seule propriété "Type" de type de données DataChangedType.


Événement ProgressChanged

La classe ProgressChangedEventArgs

Événement ProgressChanged

L'interface IProfinetDevice prend en charge l'événement ProgressChanged.

Cet événement permet au programme de surveiller la progression de méthodes qui demandent du temps, comme par exemple FirmwareUpdate.

Pour utiliser l'événement, attachez un gestionnaire d'événements à l'événement. Le gestionnaire d'événements est appelé dès qu'il y a un changement dans la progression de l'opération.

L'exemple suivant montre comment vous pouvez surveiller la progression de l'exécution. Cet exemple montre une méthode qui met à jour le firmware d'un appareil du réseau. Cette opération peut prendre un certain temps. Pour suivre la progression de l'action, la méthode définit et attache un gestionnaire d'événements à l'événement ProgressChanged. Lorsque la mise à jour du firmware est terminée, le gestionnaire est détaché de l'événement :

private void UpdateCpuAtAddress(IProfinetDeviceCollection devices,uint targetIPAddress, string updateFile)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        dev.ProgressChanged += new

        ProgressChangedEventHandler(Dev_ProgressChanged);
        dev.SetFirmwareFile(updateFile);
        dev.FirmwareUpdate(dev.ID, true);

        dev.ProgressChanged -= new

        ProgressChangedEventHandler(Dev_ProgressChanged);
    }
}

private void Dev_ProgressChanged(object sender, ProgressChangedEventArgs e)
{
    IProfinetDevice device = sender as IProfinetDevice;
    double percent = 0;
    if (device != null)
    {
        if (e.Count != 0)
        {
            string sPercent = e.Index.ToString() + " %";
        }
    }
}

La classe ProgressChangedEventArgs

Le gestionnaire d'événements ProgressChanged reçoit un objet ProgressChangedEventArgs. L'objet présente les propriétés suivantes :

Nom de la propriété | Type de retour | Description
Action | ProgressAction | Description de l'action en cours
Cancel | bool | L'action a-t-elle été annulée ?
Count | int | Quantité totale de données à transférer
ID | uint | ID matériel
Index | int | Quantité totale de données transférées


Classe IModuleCollection et propriétés des modules

Classe IModuleCollection et propriétés des modules

Ce chapitre contient des informations sur les sujets suivants :
  • Propriété de modules et classe IModuleCollection
  • Interface IModule


Propriété de modules et classe IModuleCollection

Propriété de modules et classe IModuleCollection

L'interface IProfinetDevice fournit des informations sur tous les modules comme les modules d'entrées-sorties, signal boards, CM et CP sur la station. La propriété Modules renvoie une collection de ces modules.

Le code suivant montre comment accéder à ces informations pour un appareil IProfinetDevice déjà existant :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//---------------------------------------------------
//
        Pour s'assurer que les informations sont complètes et à jour,
//
        appeler d'abord
         RefreshStatus()
//---------------------------------------------------
Result retVal = scannedDevices[0].RefreshStatus();
if (retVal.Succeeded)
{
//-----------------------------------------------------
//
        La propriété Modules renvoie une collection de
        IModule
//-----------------------------------------------------
IModuleCollection modules = scannedDevices[0].Modules;
foreach (IModule mod in modules)
{
//---------------------------------------------------
//
        Obtenir le numéro d'article de tous les modules de la station
//---------------------------------------------------
string displayArticleNum = mod.ArticleNumber;
}
}
}


Interface IModule

Interface IModule

Chaque module de la station est représenté sous la forme d'une interface IModule. Cette interface fournit un sous-ensemble de propriétés disponibles pour un appareil.

L'interface IModule ne fournit pas de méthode. Toutes les opérations sur un module doivent être initiées sur l'appareil.
L'interface IModule prend en charge les propriétés suivantes :

Nom de la propriété | Type de retour | Description
ArticleNumber | string | Numéro de commande du module. Également appelé MLFB ou "numéro d'article".
Comment | string | Ceci permet à l'utilisateur de formuler un commentaire sur l'appareil utilisé dans l'interface utilisateur SIMATIC Automation Tool. Le commentaire ne concerne pas les opérations API.
Configured | bool | Vrai, quand l'appareil a une configuration valide.
Description | string | Une description du matériel, sur la base du numéro d'article. Il s'agit de la même description que celle affichée dans TIA Portal. (par ex. "CPU-1215 DC/DC/DC")
Failsafe | bool | D'après son numéro d'article ArticleNumber, l'appareil est-il un appareil de sécurité ?
FirmwareUpdateAllowed | bool | Cet appareil prend-il en charge la mise à jour du firmware ?
FirmwareVersion | string | Version de firmware actuelle de l'appareil
ID | uint | Un identifiant unique pour chaque appareil dans la station. Il est utilisé comme identifiant unique pour l'exécution d'une FirmwareUpdate.
Name | string | Nom de l'appareil
NewFirmwareNameErrorCode | Result | ErrorCode associé au nom du nouveau firmware
NewFirmwareNameIsValid | bool | Vrai si le fichier de firmware est valide pour cet appareil ou ce module.
FirmwareVersion | string | Cette propriété est utilisée dans l'interface graphique de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.
Selected | bool | L'appareil est-il actuellement sélectionné ? Il s'agit de l'état indiqué par la case à cocher dans la GUI.
SerialNumber | string | Numéro de série unique de l'appareil
Slot | uint | Numéro d'emplacement du matériel
SlotName | string | Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.
StationNumber | uint | Numéro de station de l'appareil
SubSlot | uint | Le sous-emplacement de l'appareil. Ceci vaut pour les sous-modules enfichables tels que les modules SB S7-1200.
Supported | FeatureSupport | L'appareil réseau détecté est-il pris en charge par les opérations actuelles de SIMATIC Automation Tool ?


Interface ICPU

Interface ICPU

Ce chapitre contient des informations sur les sujets suivants :
  • Identification de l'appareil CPU dans un IProfinetDeviceCollection
  • Propriétés ICPU
  • Drapeaux ICPU
  • Méthodes ICPU
  • Propriété RemoteInterfaces


Identification de l'appareil CPU dans un IProfinetDeviceCollection

Identification de l'appareil CPU dans un IProfinetDeviceCollection

La méthode ScanNetworkDevices génère une collection IProfinetDeviceCollection. Cette collection contient un élément pour chaque appareil accessible sur le réseau industriel. Ces appareils peuvent être des CPU et des stations d'E/S décentralisées.

L'interface IProfinetDevice fournit les propriétés et les méthodes qui s'appliquent à toutes les catégories d'appareils. Cependant, certaines propriétés et méthodes sont spécifiques à un appareil CPU. Ces propriétés et méthodes sont accessibles à l'aide de l'interface ICPU.

Pour déterminer si une interface IProfinetDevice donnée représente effectivement une CPU, transtypez-la en ICPU. Si le transtypage réussit, l'appareil est bien une CPU, et vous pouvez utiliser les méthodes/propriétés sur l'interface ICPU. L'exemple suivant illustre cette procédure :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
//-----------------------------------------------------
//
        L'appareil est une CPU.
//
        L'interface ICPU peut être utilisée pour interagir avec elle.
//-----------------------------------------------------
}
}
}

Remarque

L'interface ICPU hérite de l'IProfinetDevice. Toutes les propriétés et méthodes prises en charge sur l'appareil IProfinetDevice le sont donc aussi sur l'interface ICPU.
Remarque

Vous devez définir les drapeaux Selected et SelectedConfirmed avant d'exécuter des opérations sur les appareils via l'API. Le drapeau Selected est exigé pour toutes les fonctions rattachées à l'interface ICPU. Vous devez paramétrer SelectedConfirmed si l'ICPU représente une opération de sécurité. Les opérations relatives à la sécurité sont la mise à jour d'un programme, le formatage de la carte mémoire, la restauration des paramètres d'usine et la restauration.


Propriétés ICPU

Propriétés ICPU

L'interface ICPU étend l'IProfinetDevice en ajoutant les propriétés suivantes. Ces propriétés sont en lecture seule. Pour être sûr d'obtenir les informations actuelles, le code doit d'abord appeler la méthode RefreshStatus.

Nom de la propriété | Type de retour | Description
RemoteInterfaces | List<IRemoteInterface> | Une liste de toutes les interfaces E/S décentralisées pour la CPU. L'utilisation de cette propriété est décrite plus loin dans ce document.
DataLogFolder | IRemoteFolder | Informations concernant les Data Logs identifiés sur la carte mémoire SIMATIC de la CPU
RecipeFolder | IRemoteFolder | Informations sur les recettes identifiées sur la carte mémoire SIMATIC de la CPU
OperatingMode | OperatingState | Désigne le mode actuel de la CPU. Cette valeur est en lecture seule.
IdentityCrisis | bool | Vrai lorsque l'appareil ne peut pas être identifié.
LastRefreshSuccessful | bool | Vrai lorsque le dernier appel à RefreshStatus a été exécuté avec succès.
SelectedConfirmed | bool | Les méthodes qui exécutent des opérations relatives à la sécurité doivent régler le drapeau SelectedConfirmed sur TRUE, lorsque l'utilisateur reséléctionne pour l'opération un ou plusieurs appareils à partir d'une boîte de dialogue de confirmation et confirme l'opération. SelectedConfirmed signifie que l'opération est sélectionnée et confirmée.
Initialized | bool | Vrai lorsque la configuration de l'appareil ou du module est valide.
InterfaceNumber | int | Interface par laquelle l'appareil est connecté.
Password | EncryptedString | Mot de passe de la CPU utilisé dans les fonctions exécutées sur l'appareil.
PasswordProtectionLevel | ProtectionLevel | Niveau de protection d'un mot de passe CPU légitimé
Protected | bool | La CPU est-elle actuellement protégée par un mot de passe ? Cela signifie qu'un mot de passe est nécessaire pour accéder à tout ou partie des fonctionnalités, en fonction du niveau d'accès.
PasswordValid | bool | L'appel à SetPassword() est-il valide ?

Voir aussi Propriété RemoteInterfaces


Drapeaux ICPU

Drapeaux ICPU

Ce chapitre contient des informations sur les sujets suivants :
  • Drapeaux relatifs aux mises à jour de programmes
  • Restaurer les drapeaux
  • Drapeaux de fonctionnalités


Drapeaux relatifs aux mises à jour de programmes

Drapeaux relatifs aux mises à jour de programmes

Pour exécuter avec succès des fonctions relatives à la sécurité sur un appareil, il faut obtenir des informations supplémentaires dans l'appareil. Les drapeaux suivants permettent de s'assurer que la fonction Mise à jour du programme peut être effectuée correctement et en toute sécurité sur un appareil de sécurité.

Nom de la propriété | Type de retour | Description
NewProgramNamePassword | EncryptedString | Mot de passe de la CPU utilisé pour une tentative de connexion une fois que la mise à jour du programme est achevée. Cette valeur est définie à l'aide de SetProgramPassword(EncryptedString).
HasSafetyProgram | bool | Valeur booléenne définie si l'appareil contient un programme de sécurité. Elle est déterminée lors de la connexion à une CPU.
NewProgramNameIsValid | bool | Vrai, lorsque la méthode SetProgramFolder est appelée avec un programme valide.
NewProgramNameIsSafety | bool | Vrai, lorsque la méthode SetProgramFolder est appelée avec un programme de sécurité valide.
NewProgramNameHasSafetyPassword | bool | Vrai si la méthode SetProgramFolder est appelée avec un programme de sécurité valide. Faux si un programme standard est ouvert.
NewProgramNamePasswordIsValid | bool | Vrai, lorsque la méthode SetProgramPassword est appelée avec un mot de passe valide.
NewProgramNamePasswordIsSafety | bool | Vrai, lorsque la méthode SetProgramPassword est appelée avec un mot de passe valide et que le nouveau programme présente un mot de passe de CPU F de sécurité.
ProgramUpdateSucceeded | bool | Vrai quand la méthode ProgramUpdate est exécutée avec succès. La mise à jour du programme peut néanmoins retourner une erreur.
NewProgramNamePasswordPresent | bool | Vrai lorsque la méthode SetProgramFolder est appelée et que le programme est protégé par un mot de passe
NewProgramNamePasswordLevel | ProtectionLevel | Quel est le niveau de protection du mot de passe de la CPU pour le nouveau programme ?
NewProgramName | string | Quel est le nom du nouveau programme ?
NewProgramFolder | string | Quel est l'emplacement du dossier pour le nouveau programme ? La valeur est définie via la méthode SetProgramFolder .
NewProgramNameFSignature | uint | Quelle est la signature F du nouveau projet ? Utilisée dans la procédure de comparaison pour déterminer si l'opération ProgramUpdate a été terminée avec succès
NewProgramNameIP | uint | Adresse IP stockée dans le nouveau programme
NewProgramNameSubnetMask | uint | Masque de sous-réseau de l'appareil dans le nouveau programme
NewProgramNameGateway | uint | Passerelle de l'appareil dans le nouveau programme
NewProgramNameErrorCode | Result | Un moyen simple d'identifier les problèmes qui peuvent survenir lors de la validation du nouveau programme, par exemple si le programme est invalide pour l'appareil ou si l'adresse IP trouvée dans le programme existe déjà sur le réseau.
NewProgramNamePasswordErrorCode | Result | Stocke le code d'erreur du dernier appel dans la fonction SetProgramPassword


Restaurer les drapeaux

Restaurer les drapeaux

L'API comprend les drapeaux suivants, de sorte que la fonction Restaurer à partir de la sauvegarde peut être effectuée sur un appareil de sécurité correctement et en toute sécurité. Un fichier de sauvegarde ne contient pas toutes les informations de mise à jour du programme, car le contenu d'un fichier de sauvegarde diffère de celui d'un fichier de programme.

Nom de la propriété | Type de retour | Description
NewRestoreNamePassword | EncryptedString | Mot de passe de la CPU utilisé pour la tentative de connexion une fois que la restauration est achevée. Cette valeur est définie avec SetBackupFilePassword(EncryptedString).
NewRestoreNameIsValid | bool | Vrai lorsque la méthode SetBackupFile est appelée et que le fichier de restauration est valide
NewRestoreNameIsSafety | bool | Vrai lorsque la méthode SetBackupFile est appelée et que le fichier de restauration est un fichier de restauration de sécurité
NewRestoreNamePasswordIsValid | bool | Vrai lorsque l'appel SetBackupFilePassword contient un mot de passe valide.
NewRestoreNamePasswordIsSafety | bool | Vrai lorsque l'appel SetBackupFilePassword contient un mot de passe de sécurité valide.
RestoreSucceeded | bool | L'opération Restore a-t-elle été effectuée avec succès ?
NewRestoreName | string | Quel est le nom du nouveau programme ?
NewRestoreFile | string | Quel est l'emplacement du fichier pour le nouveau programme ? La valeur est définie via la méthode SetBackupFile
NewRestoreNameFSignature | uint | Quelle est la FSignature du nouveau projet ? Utilisée dans la procédure de comparaison pour déterminer si l'opération Restore a été terminée avec succès
NewRestoreNameErrorCode | Result | Un moyen simple d'identifier les problèmes qui peuvent survenir lors de la validation du nouveau programme, par exemple si le programme est invalide ou incompatible avec l'appareil.


Drapeaux de fonctionnalités

Drapeaux de fonctionnalités

SIMATIC Automation Tool inclut les drapeaux de fonctionnalités dans l'interface ICPU et l'interface IHMI. Le type de retour de ces drapeaux est bool.

Nom de la propriété | Type de retour | Description
ChangeModeAllowed | bool | VRAI, si la CPU prend en charge une opération de changement de mode ? (RUN et STOP)
BackupAllowed | bool | VRAI si la CPU prend en charge l'opération de sauvegarde.
MemoryResetAllowed | bool | VRAI si la CPU prend en charge l'opération de restauration des paramètres d'usine.
ProgramUpdateAllowed | bool | VRAI, si la CPU prend en charge l'opération de mise à jour de programme.
RestoreAllowed | bool | VRAI si la CPU prend en charge l'opération de restauration.
FormatMCAllowed | bool | VRAI si la CPU prend en charge l'opération de formatage de la carte mémoire.
PasswordAllowed | bool | VRAI si la CPU prend en charge un mot de passe.
RemoteRecipesAllowed | bool | VRAI si la CPU prend en charge les opérations relatives aux recettes.
RemoteDataLogsAllowed | bool | VRAI si la CPU prend en charge les opérations relatives aux Data logs.
ServiceDataAllowed | bool | VRAI si la CPU prend en charge l'opération de chargement des données de maintenance.
SetTimeAllowed | bool | VRAI si la CPU prend en charge l'opération de réglage et de lecture de l'heure.
DiagBufferAllowed | bool | VRAI si la CPU prend en charge l'opération relative au tampon de diagnostic.


Méthodes ICPU

Méthodes ICPU

Ce chapitre contient des informations sur les sujets suivants :
  • ICPU protégées et mots de passe
  • Méthode SetPassword
  • Méthode SetProgramFolder
  • Méthode SetProgramPassword
  • Méthode ProgramUpdate
  • Méthode SetBackupFile
  • Méthode SetBackupFilePassword
  • Méthode Restore (interface ICPU)
  • Méthode Backup (interface ICPU)
  • Méthode DownloadRecipe
  • Méthode DeleteDataLog
  • Méthode DeleteRecipe
  • Méthode GetCurrentDateTime
  • Méthode GetDiagnosticsBuffer
  • Méthode MemoryReset
  • Méthode ResetToFactoryDefaults
  • Méthode SetOperatingState
  • Méthode SetCurrentDateTime
  • Méthode UploadDataLog
  • Méthode UploadRecipe
  • Méthode UploadServiceData
  • Méthode FormatMemoryCard
  • DetermineConfirmationMessage


ICPU protégées et mots de passe

ICPU protégées et mots de passe

La majorité des actions sur l'interface ICPU demandent une connexion légitimée à la CPU et peuvent nécessiter un mot de passe. Pour cette raison, la plupart des méthodes sur l'interface ICPU requièrent un paramètre mode de passe.


Méthode SetPassword

Méthode SetPassword

Type de retour | Nom de la méthode
Result | SetPassword

Paramètres
Nom | Type de données | Type de paramètre | Description
password | EncryptedString | In | Définit le mot de passe de la CPU pour l'objet utilisé pour effectuer des opérations.

La méthode SetPassword définit le mot de passe d'une CPU. En appelant la méthode SetPassword, vérifiez la propriété dev.Protected avant de tenter de définir le mot de passe. Si l'appareil est protégé, la méthode SetPassword retourne une erreur. L'exemple suivant montre l'utilisation de la méthode SetPassword :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{

            //------------------------------------------------
//
        Rechercher l'appareil à cette adresse MAC et SetPassword
//------------------------------------------------
ICPU dev = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (dev != null)
{
if (dev.Protected)
{
Result retVal = dev.SetPassword(new EncryptedString("Password"));
}
}
}


Méthode SetProgramFolder

Méthode SetProgramFolder

Type de retour | Nom de la méthode
Result | SetProgramFolder

Paramètres
Nom | Type de données | Type de paramètre | Description
strFolder | string | In | Définir l'emplacement du dossier pour le programme téléchargé

La méthode définit les drapeaux suivants pour l'objet ICPU :

  • NewProgramFolder

  • NewProgramName

  • NewProgramNameIP

  • NewProgramNameSubnetMask

  • NewProgramNameGateway

  • NewProgramNameIsValid

Lorsque l'opération est effectuée sur un objet de sécurité, vous pouvez définir les éléments suivants :

  • NewProgramNameIsSafety

  • NewProgramNameHasSafetyPassword

L'exemple suivant montre comment définir le dossier programme sur un appareil :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Rechercher l'appareil à cette adresse MAC et SetProgramFolder
//------------------------------------------------
ICPU dev = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (dev != null)
{
Result retVal = dev.SetProgramFolder(@"C:\MyFolder");
if (retVal.Error == ErrorCode.ProgramPasswordNeeded)
{
retVal = dev.SetProgramPassword(new EncryptedString("Password"));
}
}
}

Remarque

Si vous sélectionnez un programme qui a un mot de passe, SetProgramFolder renvoie une erreur. Si SetProgramFolder renvoie une erreur, appelez SetProgramPassword.


Méthode SetProgramPassword

Méthode SetProgramPassword

Type de retour | Nom de la méthode
Result | SetProgramPassword

Paramètres
Nom | Type de données | Type de paramètre | Description
password | EncryptedString | In | Définit le mot de passe de la CPU pour le projet à transmettre à la CPU pendant la mise à jour du programme (ProgramUpdate).

Après la ProgramUpdate, l'application tente de se reconnecter à l'appareil. Si le programme dans la CPU est protégé par mot de passe, définissez un mot de passe CPU actualisé pour obtenir à nouveau l'accès à l'appareil.

La méthode définit les drapeaux suivants pour l'objet ICPU :

  • NewProgramNamePasswordIsValid

  • NewProgramNamePasswordIsSafety

  • NewProgramNamePasswordLevel

L'exemple suivant montre comment définir un mot de passe CPU actualisé sur un appareil :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Rechercher l'appareil à cette adresse MAC et SetProgramFolder
//------------------------------------------------
ICPU dev = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (dev != null)
{
Result retVal = dev.SetProgramFolder(@"C:\MyFolder");
if (retVal.Error == ErrorCode.ProgramPasswordNeeded)
{
retVal = dev.SetProgramPassword(new EncryptedString("Password"));
}
}
}


Méthode ProgramUpdate

Méthode ProgramUpdate

Type de retour | Nom de la méthode
Result | ProgramUpdate

Cette méthode exécute la mise à jour d'un programme sur la CPU.

Les conditions préalables suivantes doivent être satisfaites pour mettre à jour un programme :

  • L'appareil doit être sélectionné.

  • S'il s'agit d'un appareil de sécurité, SelectedConfirmed doit être vrai.

  • Le NewProgramFolder pour l'objet doit être défini.

  • Si le nouveau programme contient un mot de passe CPU, NewProgramPasswordPresent doit être vrai et avoir la valeur définie par SetProgramPassword.

  • La mise à jour du programme doit être prise en charge par l'appareil (ProgramUpdateAllowed).

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans la collection IProfinetDeviceCollection et le programme de cette CPU est mis à jour :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
ICPU cpu = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (cpu != null && cpu.ProgramUpdateAllowed == true)
{
//
        Sélectionner la CPU à mettre à jour
cpu.Selected = true;

retVal = cpu.SetProgramFolder(@"C:\MyFolder");
if (retVal.Error == ErrorCode.ProgramPasswordNeeded)
{
retVal = cpu.SetProgramPassword(new EncryptedString("Password"));
if (retVal.Failed == true)
return;
}
if (retVal.Failed == true)
return;

//
        Adresse IP unique ?
if (cpu.DuplicateIP == true)
return;

//
        L'appareil est-il pris en charge ?
if (cpu.Supported == false)
return;

//
        L'appareil est-il initialisé ?
if (cpu.Initialized == false)
return;

//
        S'agit-il d'un appareil de sécurité ?
if (cpu.Failsafe == true)
{
ConfirmationType type = cpu.DetermineConfirmationMessage(FailsafeOperation.ProgramUpdateOperation);

//
        Vérifier le type et confirmer
cpu.SelectedConfirmed = true;

//
        Vérifier que la mise à jour est faisable
if (cpu.HasSafetyProgram == true || cpu.Protected == true ||cpu.NewProgramNameIsSafety == true)
{
//
        L'appareil est-il protégé par mot de passe ?
if (cpu.Protected == true)
{
//
        Un mot de passe valide a-t-il été fourni ?
if (cpu.PasswordValid == false)
return;

//
        Sommes-nous légitimés pour le niveau de sécurité ?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe;
if (bSufficientAccess == false)
return;

}
}
}
else
{
//
        Un programme de sécurité est-il sur le point d'être chargé ?
if (cpu.NewProgramNameHasSafetyPassword == true)
return;
}

//
        L'appareil est-il protégé par mot de passe ?
if (cpu.Protected == true)
{
//
        Un mot de passe valide a-t-il été fourni ?
if (cpu.PasswordValid == false)
return;

                    //
        Avons-nous un niveau de légitimation suffisant pour que l'opération réussisse ?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe || cpu.PasswordProtectionLevel == ProtectionLevel.Full;
if (bSufficientAccess == false)
return;
}
//
        Effectuer une mise à jour du programme
retVal = cpu.ProgramUpdate();

//
        Réinitialiser
cpu.SelectedConfirmed = false;
}
}

Remarque

Le nom de dossier transmis à la méthode ProgramUpdate doit contenir un dossier nommé SIMATIC.S7S. Le dossier SIMATIC.S7S contient le programme à charger.


Méthode SetBackupFile

Méthode SetBackupFile

Type de retour | Nom de la méthode
Résultat | SetBackupFile

Paramètres
Nom | Type de données | Type de paramètre | Description
strFile | string | In | Définit le lieu d'archivage du fichier de sauvegarde

La méthode définit les drapeaux suivants pour l'objet ICPU :

  • NewRestoreName

  • NewRestoreFile

  • NewRestoreNameIsValid

  • NewRestoreNameIsSafety

  • NewRestorenameFSignature

L'exemple suivant montre comment définir le chemin du fichier de sauvegarde :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
ICPU cpu = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (cpu != null && cpu.RestoreAllowed == true)
{
//
        Sélectionner la CPU à mettre à jour
cpu.Selected = true;

Result retVal = cpu.SetBackupFile(@"C:\MyFolder\Backup.s7pbkp");

if (retVal.Failed == true)
return;

//
        Adresse IP unique ?
if (cpu.DuplicateIP == true)
return;

//
        L'appareil est-il pris en charge ?
if (cpu.Supported == false)
return;

//
        L'appareil est-il initialisé ?
if (cpu.Initialized == false)
return;

//
         L'appareil est-il de sécurité ?
if (cpu.Failsafe == true)
{
ConfirmationType type =
cpu.DetermineConfirmationMessage(FailsafeOperation.RestoreOperation);

//
        Vérifier le type et confirmer
cpu.SelectedConfirmed = true;

//
        Vérifier pour s'assurer que la mise à jour est faisable
if (cpu.HasSafetyProgram == true || cpu.Protected == true || cpu.NewRestoreNameIsSafety == true)
{
//
        L'appareil est-il protégé par mot de passe ?
if (cpu.Protected == true)
{
//
        Un mot de passe valide a-t-il été fourni ?
if (cpu.PasswordValid == false)
return;

//
         Sommes-nous légitimés pour le niveau de sécurité ?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe;
if (bSufficientAccess == false)
return;
}
}
}
else
{
//
        Un programme de sécurité est-il sur le point d'être chargé ?
if (cpu.NewRestoreNameIsSafety == true)
return;
}

//
        L'appareil est-il protégé par mot de passe ?
if (cpu.Protected == true)
{
//
        Un mot de passe valide a-t-il été fourni ?
if (cpu.PasswordValid == false)
return;

//
        Avons-nous un niveau de légitimation suffisant pour que l'opération réussisse ?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe || cpu.PasswordProtectionLevel == ProtectionLevel.Full;
if (bSufficientAccess == false)
return;
}
//
        Effectuer une restauration
retVal = cpu.Restore();

//
        Réinitialiser
cpu.SelectedConfirmed = false;
}
}

Remarque

Si le fichier de sauvegarde sélectionné possède un mot de passe, le SetBackupFile retourne une erreur. La méthode SetBackupFilePassword doit être appelée et exécutée avec succès avant que vous ne puissiez appeler la méthode Restore.


Méthode SetBackupFilePassword

Méthode SetBackupFilePassword

Type de retour | Nom de la méthode
Result | SetBackupFilePassword

Paramètres
Nom | Type de données | Type de paramètre | Description
password | EncryptedString | In | Définit le mot de passe pour le projet transmis à la CPU durant la restauration

Après la restauration, l'application tente de se reconnecter à l'appareil. Si le programme chargé dans la CPU est protégé par mot de passe, définissez un mot de passe CPU actualisé pour obtenir à nouveau l'accès à l'appareil.

La méthode définit le drapeau suivant pour l'objet ICPU :

  • NewRestoreNamePassword

L'exemple suivant montre comment définir un mot de passe CPU actualisé sur un appareil :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
//------------------------------------------------
//
        Rechercher l'appareil à cette adresse MAC et SetBackupFilePassword
//------------------------------------------------
ICPU dev = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (dev != null)
{
if (dev.Protected)
{
Result retVal = dev.SetBackupFile(@"C:\MyFolder\MyCPUBackupFile.s7pbkup");
retVal = dev.SetBackupFilePassword(new EncryptedString("Password"));
}
}
}


Méthode Restore (interface ICPU)

Méthode Restore (interface ICPU)

Type de retour | Nom de la méthode
Result | Restore

Cette méthode est utilisée pour restaurer les informations d'une sauvegarde précédente de la CPU. Certaines CPU ne prennent pas en charge la fonction Sauvegarde / Restauration.

Les conditions préalables suivantes doivent être satisfaites pour que l'opération puisse être effectuée :

  • L'appareil doit être sélectionné.

  • S'il s'agit d'un appareil de sécurité, SelectedConfirmed doit être vrai.

  • Le NewProgramFolder pour l'objet doit être défini.

  • Si le nouveau programme contient un mot de passe de CPU, le NewProgramPasswordPresent doit être vrai et sa valeur définie par SetProgramPassword

  • Restore doit être pris en charge pour que l'action soit exécutée (RestoreAllowed).

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans l'IProfinetDeviceCollection. Une fois qu'elle a été trouvée, le programme vérifie que la CPU protégée par mot de passe prend en charge la fonction de restauration et appelle la méthode Restore pour un fichier de sauvegarde n'ayant pas de mot de passe CPU :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string bkFile = @"C:\MyCPUBackupFile.s7pbkp";
IProfinetDeviceCollection devices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        ICPU devAsCpu = dev as ICPU;
        if (devAsCpu != null && devAsCpu.RestoreAllowed)
        {
            retVal = devAsCpu.SetPassword(new EncryptedString("Password"));
            retVal = devAsCpu.SetBackupFile(bkFile);
            devAsCpu.Selected = true;
            if (devAsCpu.Failsafe)
                devAsCpu.SelectedConfirmed = true;

            retVal = devAsCpu.Restore();
        }
    }
}


Méthode Backup (interface ICPU)

Méthode Backup (interface ICPU)

Type de retour | Nom de la méthode
Result | Backup

Paramètres
Nom | Type de données | Type de paramètre | Description
strFile | string | In | Chemin d'accès complet et nom sous lequel le fichier de sauvegarde doit être stocké.

Cette méthode est utilisée pour sauvegarder les données dans une CPU. Certaines CPU ne prennent pas en charge la fonction Sauvegarde / Restauration. Vous pouvez vérifier la propriété BackupAllowed pour vous assurer que la CPU concernée prend en charge cette fonction.

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans l'IProfinetDeviceCollection. Une fois qu'elle a été trouvée, le programme vérifie que la CPU prend en charge la fonction de sauvegarde et appelle la méthode Backup :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string bkFile = @"C:\MyCPUBackupFile.s7pbkp";
IProfinetDeviceCollection devices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPU devAsCpu = dev as ICPU;

        if (devAsCpu != null && devAsCpu.IP == targetIPAddress && devAsCpu.BackupAllowed)
        {
            devAsCpu.Selected = true;
            retVal = devAsCpu.Backup(bkFile);
        }
    }
}


Méthode DownloadRecipe

Méthode DownloadRecipe

Type de retour | Nom de la méthode
Result | DownloadRecipe

Paramètres
Nom | Type de données | Type de paramètre | Description
strFile | string | In | Chemin d'accès complet et nom du fichier de recette à charger de la console de programmation dans la carte mémoire de la CPU

Cette méthode est utilisée pour ajouter ou remplacer un fichier CSV sur la carte mémoire de la CPU. Certaines CPU ne prennent pas en charge l'accès distant aux recettes. Vous pouvez vérifier la propriété RemoteRecipesAllowed pour vous assurer que la CPU concernée prend en charge cette fonction. L'exemple de code suivant montre l'écriture d'un fichier recette dans une carte mémoire de la CPU :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string rcpFile = @"C:\NewRecipe.csv";
IProfinetDeviceCollection devices;

Result retVal = myNetwork.ScanNetworkDevices(out devices);
if (retVal.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPU devAsCpu = dev as ICPU;
        if ((devAsCpu != null) &&
            (devAsCpu.IP == targetIPAddress) &&
            (devAsCpu.RemoteRecipesAllowed))
        {
            retVal = devAsCpu.SetPassword(new EncryptedString("Password"));
            IRemoteFolder recipes = devAsCpu.RecipeFolder;
            recipes.Selected = true;
            recipes.SetRemoteFile(rcpFile);
            retVal = devAsCpu.DownloadRecipe(rcpFile);

        }
    }
}

Remarque

Si une recette portant le même nom existe déjà sur la carte mémoire, elle est remplacée.


Méthode DeleteDataLog

Méthode DeleteDataLog

Type de retour | Nom de la méthode
Result | DeleteDataLog

Paramètres
Nom | Type de données | Type de paramètre | Description
strFileName | string | In | Nom du fichier Data log à supprimer de la carte mémoire d'une CPU

Cette méthode est utilisée pour supprimer un fichier Data log de la carte mémoire de la CPU.

Certaines CPU ne prennent pas en charge l'accès distant aux Data logs. Vérifiez la propriété RemoteDataLogsAllowed pour vous assurer que la CPU concernée prend en charge cette fonction.

L'exemple de code suivant utilise la propriété DataLogFolder pour itérer tous les Data logs sur la carte mémoire de la CPU. Tous les Data logs sont supprimés :

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in devices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
if (devAsCpu.RemoteDataLogsAllowed)
{
//------------------------------------------
//
        Vérifier d'abord que la carte mémoire contient des Data logs
//------------------------------------------
if (devAsCpu.DataLogFolder.Exists)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
//------------------------------------------
//
        Rechercher tous les fichiers Data log
//------------------------------------------
foreach (IRemoteFile datalog in
devAsCpu.DataLogFolder.Files)
{
datalog.Selected = true;
//------------------------------------------
//
        Supprimer le Data log
//------------------------------------------
devAsCpu.DeleteDataLog(datalog.Name);
}
}
}
}
}
}


Méthode DeleteRecipe

Méthode DeleteRecipe

Type de retour | Nom de la méthode
Result | DeleteRecipe

Paramètres
Nom | Type de données | Type de paramètre | Description
strFileName | string | In | Nom du fichier recette à supprimer de la carte mémoire.

Cette méthode est utilisée pour supprimer un fichier de recettes de la carte mémoire de la CPU.

Certaines CPU ne prennent pas en charge l'accès distant aux recettes. Vérifiez la propriété RemoteRecipesAllowed pour vous assurer que la CPU concernée prend en charge cette fonction.

L'exemple de code suivant utilise la propriété RecipeFolder pour itérer toutes les recettes sur la carte mémoire de la CPU. Toutes les recettes sont supprimées :

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in devices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
if (devAsCpu.RemoteDataLogsAllowed)
{
//------------------------------------------
//
        First check that recipes are available on the memory card
//------------------------------------------
if (devAsCpu.RecipeFolder.Exists)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
//------------------------------------------
//
        Search for all recipes
//------------------------------------------
foreach (IRemoteFile recipe in devAsCpu.RecipeFolder.Files)
{
recipe.Selected = true;
//------------------------------------------
//
        Delete the recipe
        .
//------------------------------------------
devAsCpu.DeleteRecipe(recipe.Name);
}
}
}
}
}
}


Méthode GetCurrentDateTime

Méthode GetCurrentDateTime

Type de retour | Nom de la méthode
Result | GetCurrentDateTime

Paramètres
Nom | Type de données | Type de paramètre | Description
DateTime | System.DateTime | Out | Date et heure en cours sur la CPU

Cette méthode récupère l'horodatage de la CPU.

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans la collection IProfinetDeviceCollection et on récupère l'heure et la date en cours dans cette CPU :

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

uint targetIPAddress = 0xC0A80001; // 192.168.0.1

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (!scanResult.Succeeded)
    return;

foreach (IProfinetDevice dev in devices)
{
    ICPU devAsCpu = dev as ICPU;
    if ((devAsCpu != null) && (devAsCpu.IP == targetIPAddress))
    {
        devAsCpu.SetPassword(new EncryptedString("Password"));
        devAsCpu.Selected = true;

        DateTime curTime = new DateTime();

        Result retVal = devAsCpu.GetCurrentDateTime(out curTime);
    }
}


Méthode GetDiagnosticsBuffer

Méthode GetDiagnosticsBuffer

Type de retour | Nom de la méthode
Result | GetDiagnosticsBuffer

Paramètres
Nom | Type de données | Type de paramètre | Description
DiagnosticsItems | List<DiagnosticsItem> | Out | Une collection d'éléments de diagnostic : Chaque élément de la collection représente une entrée dans le tampon de diagnostic.
Language | Language | In | Langue requise pour les entrées du tampon de diagnostic.

Cette méthode lit les entrées de diagnostic actuelles provenant de la CPU. La méthode GetDiagnosticsBuffer renvoie une collection d'objets DiagnosticsItem. Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans l'IProfinetDeviceCollection. Une fois qu'elle a été trouvée, les informations de diagnostic y sont lues : Utilisez le paramètre Language enum pour obtenir des entrées de diagnostic dans une langue spécifique :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
List<DiagnosticsItem> aLogs = new List<DiagnosticsItem>();
IProfinetDeviceCollection devices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPU devAsCpu = dev as ICPU;
        if ((devAsCpu != null) && (devAsCpu.IP == targetIPAddress))
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            retVal = devAsCpu.GetDiagnosticsBuffer(out aLogs, Language.English);
            if (retVal.Succeeded)
            {
                for (int idxLog = 0; idxLog < aLogs.Count; idxLog++)
                {
                //get information time stamp
                string descrTimes = aLogs[idxLog].TimeStamp.ToString();

                //get information basic description
                string descrBasic = aLogs[idxLog].Description1;

                //get information detailed description
                string descrDetail = aLogs[idxLog].Description2;

                //get information state (incoming/outgoing)
                string descrState = aLogs[idxLog].State.ToString();

                }
            }
        }
    }
}


Méthode MemoryReset

Méthode MemoryReset

Type de retour | Nom de la méthode
Result | MemoryReset

Cette méthode réinitialise la mémoire sur la CPU

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans la collection IProfinetDeviceCollection et on appelle la méthode MemoryReset pour cette CPU :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        ICPU devAsCpu = dev as ICPU;
        if (devAsCpu != null)
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            Result retVal = devAsCpu.MemoryReset();
        }
    }
}


Méthode ResetToFactoryDefaults

Méthode ResetToFactoryDefaults

Type de retour | Nom de la méthode
Result | ResetToFactoryDefaults

Paramètres
Nom | Type de données | Type de paramètre | Description
password | EncryptedString | In | Cette méthode établit une connexion légitimée à l'appareil. De ce fait, un mot de passe peut être requis.

Cette méthode restaure les paramètres d'usine d'une CPU.

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans la collection IProfinetDeviceCollection et on appelle la méthode ResetToFactoryDefaults. Vous devez donner la valeur TRUE au drapeau SelectedConfirmed pour les appareils de sécurité :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
ICPU cpu = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (cpu != null && cpu.ResetToFactoryAllowed == true)
{
//
        Sélectionner la CPU à mettre à jour
cpu.Selected = true;

//
        Adresse IP unique ?
if (cpu.DuplicateIP == true)
return;

//
        L'appareil est-il pris en charge ?
if (cpu.Supported == false)
return;

//
        L'appareil est-il initialisé ?
if (cpu.Initialized == false)
return;

//
        S'agit-il d'un appareil de sécurité ?
if (cpu.Failsafe == true)  { ConfirmationType type = cpu.DetermineConfirmationMessage(FailsafeOperation.ResetToFactoryOperation);
//
        Vérifier le type et confirmer
cpu.SelectedConfirmed = true;

//
        Vérifier que la mise à jour est faisable
if (cpu.HasSafetyProgram == true || cpu.Protected == true || cpu.NewRestoreNameIsSafety == true)
{
//
        L'appareil est-il protégé par mot de passe ?
if (cpu.Protected == true)
{
//
        Un mot de passe valide a-t-il été fourni ?
if (cpu.PasswordValid == false)
return;

//
        Sommes-nous légitimés pour le niveau de sécurité ?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe;
if (bSufficientAccess == false)
return;
}
}
}
else
{
//
        Un programme de sécurité est-il sur le point d'être chargé ?
if (cpu.NewRestoreNameIsSafety == true)
return;
}
//
        L'appareil est-il protégé par mot de passe ?
if (cpu.Protected == true)
{
//
        Un mot de passe valide a-t-il été fourni ?
if (cpu.PasswordValid == false)
return;

//
        Avons-nous un niveau de légitimation suffisant pour que l'opération réussisse ?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe || cpu.PasswordProtectionLevel == ProtectionLevel.Full;
if (bSufficientAccess == false)
return;
}
//
        Effectuer une restauration des paramètres d'usine
Result retVal = cpu.ResetToFactoryDefaults();

//
        Réinitialiser
cpu.SelectedConfirmed = false;
}
}


Méthode SetOperatingState

Méthode SetOperatingState

Type de retour | Nom de la méthode
Result | SetOperatingState

Paramètres
Nom | Type de données | Type de paramètre | Description
nRequestState | OperatingStateREQ | In | Nouvel état de fonctionnement

Cette méthode est utilisée pour changer l'état de fonctionnement d'une CPU.

Certaines CPU ne prennent pas cette fonction en charge. Vérifiez la propriété ChangeModeAllowed pour vous assurer que la CPU concernée prend en charge cette fonction.

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans l'IProfinetDeviceCollection. Une fois qu'elle a été trouvée, le programme vérifie que la CPU prend en charge la fonction de changement d'état et fait passer la CPU à l'état RUN :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        ICPU devAsCpu = dev as ICPU;
        if ((devAsCpu != null) && (devAsCpu.ChangeModeAllowed))
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            Result retVal = devAsCpu.SetOperatingState(OperatingStateREQ.Run);
        }
    }
}


Méthode SetCurrentDateTime

Méthode SetCurrentDateTime

Type de retour | Nom de la méthode
Result | SetCurrentDateTime

Paramètres
Nom | Type de données | Type de paramètre | Description
password | EncryptedString | In | Cette méthode établit une connexion légitimée à l'appareil. De ce fait, un mot de passe peut être requis.
time | System.DateTime | In | Nouvelle valeur pour l'heure actuelle de la CPU

Cette méthode règle l'heure actuelle de la CPU. Les règles de changement de l'heure configurée ne sont pas affectées par cette action. De ce fait, la valeur DateTime spécifiée est basée sur l'heure UTC, pas sur l'heure locale.

L'exemple suivant concerne l'ensemble du réseau industriel et règle l'heure actuelle de chaque CPU sur l'heure actuelle de la console de programmation :

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPU devAsCpu = dev as ICPU;
        if (devAsCpu != null)
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            retVal = devAsCpu.SetCurrentDateTime(DateTime.UtcNow);
        }
    }
}


Méthode UploadDataLog

Méthode UploadDataLog

Type de retour | Nom de la méthode
Result | UploadDataLog

Paramètres
Nom | Type de données | Type de paramètre | Description
strFileName | string | In | Nom de fichier du Data log à charger à partir de la carte mémoire SIMATIC amovible d'une CPU
strDestinationFolder | string | In | Chemin d'accès complet sous lequel est stocké le fichier Data log chargé.

Cette méthode charge une copie du fichier Data log indiqué de la carte mémoire de la CPU dans votre console de programmation. Certaines CPU ne prennent pas en charge l'accès distant aux Data logs. Vérifiez la propriété RemoteDataLogsAllowed pour vous assurer que la CPU concernée prend en charge cette fonction.
L'exemple de code suivant utilise la propriété DataLogFolder pour itérer tous les Data logs sur la carte mémoire de la CPU. Une copie de chaque Data log est chargée dans le dossier C:\MyDataLogs :

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in devices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
devAsCpu.SetPassword(new EncryptedString("Password"));

if (devAsCpu.RemoteDataLogsAllowed)
{
//------------------------------------------
//
        Vérifier d'abord que la carte mémoire contient des Data logs
//------------------------------------------
if (devAsCpu.DataLogFolder.Exists)
{
//------------------------------------------
//
        Rechercher tous les fichiers Data log
//------------------------------------------
foreach (IRemoteFile datalog in devAsCpu.DataLogFolder.Files)
{
datalog.Selected = true;
//------------------------------------------
//
        Charger une copie de chaque Data log.
//------------------------------------------
devAsCpu.UploadDataLog(datalog.Name, @"C:\MyDataLogs");
}
}
}
}
}
}


Méthode UploadRecipe

Méthode UploadRecipe

Type de retour | Nom de la méthode
Result | UploadRecipe

Paramètres
Nom | Type de données | Type de paramètre | Description
strFileName | string | In | Nom de fichier de la recette à charger à partir de la carte mémoire de la CPU
strDestinationFolder | string | In | Chemin d'accès complet sous lequel est écrit le fichier recette chargé

Cette méthode charge une copie du fichier recette de la carte mémoire de la CPU. Certaines CPU ne prennent pas en charge l'accès distant aux recettes. Vérifiez la propriété RemoteRecipesAllowed pour vous assurer que la CPU concernée prend en charge cette fonction.

L'exemple de code suivant utilise la propriété RecipeFolder pour itérer toutes les recettes sur la carte mémoire de la CPU. Une copie de chaque recette est chargée dans le dossier C:\MyRecipes :

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in devices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
if (devAsCpu.RemoteRecipesAllowed)
{
//------------------------------------------
//
        Vérifier d'abord que la carte mémoire contient des recettes
//------------------------------------------
if (devAsCpu.RecipeFolder.Exists)
{
//------------------------------------------
//
        Rechercher tous les fichiers recette
//------------------------------------------
foreach (IRemoteFile recipe in devAsCpu.RecipeFolder.Files)
{
recipe.Selected = true;
//------------------------------------------
//
        Charger une copie de chaque recette
//------------------------------------------
devAsCpu.UploadRecipe(recipe.Name, @"C:\MyRecipes");
}
}
}
}
}
}


Méthode UploadServiceData

Méthode UploadServiceData

Type de retour | Nom de la méthode
Result | UploadServiceData

Paramètres
Nom | Type de données | Type de paramètre | Description
strPath | string | In | Chemin d'accès complet au dossier regroupant le contenu de la carte programme
format | TimeFormat | In (facultatif) | Format d'affichage de la date et de l'heure. Les valeurs possibles sont UTC et Local. Si aucune valeur n'est fournie, le format est Local.

Cette méthode peut charger les données de maintenance d'une CPU défectueuse.

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans l'IProfinetDeviceCollection. L'OperatingState actuel de la CPU est vérifié. Si la CPU est défaillante, les données de maintenance sont chargées :

Network myNetwork = new Network();
IProfinetDeviceCollection devices;

uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string strDiagFolder = @"c:\Diagnostics";

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
ICPU devAsCpu = dev as ICPU;

if (devAsCpu != null)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
devAsCpu.Selected = true;
if (devAsCpu.OperatingMode == OperatingState.Defective)
{
//
        Obtenir les données de maintenance avec format par défaut horodatage local
Result retVal = devAsCpu.UploadServiceData(strDiagFolder);

//
        Obtenir les données de maintenance avec format horodatage UTC
Result retVal = devAsCpu.UploadServiceData(strDiagFolder, TimeFormat.UTC);
}
}
}
}


Méthode FormatMemoryCard

Méthode FormatMemoryCard

Type de retour | Nom de la méthode
Result | FormatMemoryCard

Cette méthode est utilisée pour formater la carte mémoire amovible SIMATIC enfichée dans une CPU.

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans l'IProfinetDeviceCollection. La carte mémoire de l'appareil est alors formatée. Vous devez donner la valeur TRUE au drapeau SelectedConfirmed pour les appareils de sécurité :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
ICPU cpu = scannedDevices.FindDeviceByMAC(targetMACAddress) as ICPU;
if (cpu != null && cpu.FormatMCAllowed == true)
{
//
        Sélectionner la CPU à mettre à jour
cpu.Selected = true;

//
        Adresse IP unique ?
if (cpu.DuplicateIP == true)
return;

//
        L'appareil est-il pris en charge ?
        ?
if (cpu.Supported == false)
return;

//
        L'appareil est-il initialisé ?
if (cpu.Initialized == false)
return;

//
        S'agit-il d'un appareil de sécurité ?
if (cpu.Failsafe == true)
{
ConfirmationType type = cpu.DetermineConfirmationMessage(FailsafeOperation.ResetToFactoryOperation);

//
        Vérifier le type et confirmer
cpu.SelectedConfirmed = true;

//
        Vérifier que la mise à jour est faisable
if (cpu.HasSafetyProgram == true || cpu.Protected == true || cpu.NewRestoreNameIsSafety == true)
{
// Is the device password protected?if (cpu.Protected == true)
{
//
        Un mot de passe valide a-t-il été fourni ?
if (cpu.PasswordValid == false)
return;

//
        Sommes-nous légitimés pour le niveau de sécurité ?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe;
if (bSufficientAccess == false)
return;
}
}
}
else
{
//
        Un programme de sécurité est-il sur le point d'être chargé ?
if (cpu.NewRestoreNameIsSafety == true)
return;
}

//
        L'appareil est-il protégé par mot de passe ?
if (cpu.Protected == true)
{
//
        Un mot de passe valide a-t-il été fourni ?
if (cpu.PasswordValid == false)
return;

//
        Avons-nous un niveau de légitimation suffisant pour que l'opération réussisse ?
bool bSufficientAccess = cpu.PasswordProtectionLevel == ProtectionLevel.Failsafe || cpu.PasswordProtectionLevel == ProtectionLevel.Full;
if (bSufficientAccess == false)
return;
}
//
        Formater la carte mémoire
Result retVal = cpu.FormatMemoryCard();

//
        Réinitialiser
cpu.SelectedConfirmed = false;
}
}


DetermineConfirmationMessage

DetermineConfirmationMessage

Type de retour | Nom de la méthode
ConfirmationType | DetermineConfirmationMessage

Paramètres
Nom | Type de données | Type de paramètre | Description
operation | FailsafeOperation | In | Opération évaluée

Cette méthode détermine le contenu du message de confirmation lorsque l'utilisateur tente d'effectuer une opération relative à la sécurité.

La classe ConfirmationType comprend une série de codes Hamming qui représentent chacun un message d'erreur affiché comme suit pour l'utilisateur :

ConfirmationType | Message à afficher
SafetyPasswordIsBeingUsed | Une opération sur un programme standard est sur le point d'être initiée à l'aide du mot de passe de sécurité de la CPU.
DeletingExistingSafetyProgram | Un programme de sécurité existant est sur le point d'être supprimé.
ReplacingExistingSafetyProgram | Un programme de sécurité existant est sur le point d'être actualisé avec un autre programme de sécurité.
ReplacingExistingSafetyProgramWithNonSafetyProgram | Un programme de sécurité existant est sur le point d'être remplacé par un programme standard.
LoadingSafetyProgram | Un programme de sécurité est sur le point d'être chargé pour la première fois.

Dans l'exemple suivant, on recherche une CPU à une adresse IP donnée dans l'IProfinetDeviceCollection. Cette méthode est utilisée pour afficher un message sur l'état relatif à la sécurité dans une boîte de dialogue de confirmation utilisateur avant l'exécution d'une opération relative à la sécurité :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        ICPU devAsCpu = dev as ICPU;
        if (devAsCpu != null)
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            if (devAsCpu.Failsafe)
            {
                devAsCpu.SelectedConfirmed = true;
            }
            ConfirmationType confirm = devAsCpu.DetermineConfirmationMessage(FailsafeOperation.FormatMCOperation);

            if (confirm == ConfirmationType.DeletingExistingSafetyProgram)
                devAsCpu.FormatMemoryCard();
        }
    }
}


Propriété RemoteInterfaces

Propriété RemoteInterfaces

Ce chapitre contient des informations sur les sujets suivants :
  • Modules d'E/S décentralisés
  • Propriétés IRemoteInterfaces


Modules d'E/S décentralisés

Modules d'E/S décentralisés

Chaque CPU peut prendre en charge plusieurs interfaces E/S décentralisées. Les informations relatives aux appareils raccordés à ces interfaces distantes sont accessibles via la propriété RemoteInterfaces de l'interface ICPU.

L'exemple suivant montre comment accéder à ces informations pour toutes les CPU d'un réseau :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
ICPU devAsCpu = dev as ICPU;

List<IRemoteInterface> decentalNets = devAsCpu.RemoteInterfaces;
foreach (IRemoteInterface net in decentalNets)
{
//-----------------------------------------------------------
//
        Inspecter l'interface distante
//-----------------------------------------------------------
}
}
}


Propriétés IRemoteInterfaces

Propriétés IRemoteInterfaces

L'interface IRemoteInterface prend en charge les propriétés suivantes. Ces propriétés sont en lecture seule.

Nom de la propriété | Type de retour | Description
Devices | List<IBaseDevice> | Une liste de stations E/S décentralisées raccordées à cette interface distante
InterfaceType | RemoteInterfaceType | Protocole de communication pour cette interface distante Voir aussi Énumération RemoteInterfaceType
Name | string | Nom configuré pour l'interface distante

La propriété Devices peut être utilisée au travers d'un réseau décentralisé. Chaque appareil du réseau décentralisé est représenté par une interface IBaseDevice. Cette interface possède un sous-groupe de propriétés disponibles pour un IProfinetDevice et fournit la fonctionnalité limitée disponible pour ces appareils dans l'API SIMATIC Automation Tool.

Les propriétés suivantes sont disponibles sur l'interface IBaseDevice :

Nom de la propriété | Type de retour | Description
ArticleNumber | string | Numéro de référence du module. Également appelé MLFB ou numéro d'article.
Comment | string | Ceci permet à l'utilisateur de formuler un commentaire sur l'appareil. Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.
Configured | bool | L'appareil possède-t-il une configuration valide ?
Description | string | Description du matériel sur la base du numéro d'article. Il s'agit de la même description que celle affichée dans TIA Portal (par ex. "CPU-1215 DC/DC/DC")
Failsafe | FeatureSupport | Sur la base de ce numéro d'article, s'agit-il d'un appareil de sécurité ?
Family | DeviceFamily | De quelle gamme est cet appareil ? Pour plus d'informations, référez-vous à la description de l'énumération de la DeviceFamily.
FirmwareUpdateAllowed | FeatureSupport | Cet appareil prend-il en charge la mise à jour du firmware ?
FirmwareVersion | string | Version de firmware actuelle de l'appareil
HardwareInFirmwareOrder | IHardwareCollection | Collection matérielle dans la commande de firmware
HardwareInDisplayOrder | IHardwareCollection | Matériel dans la commande affichée
HardwareNumber | short | Identifiant numérique
ID | uint | Un identifiant unique pour chaque appareil dans la station. Il est utilisé comme identificateur unique pour la mise à jour du firmware.
Modules | IModuleCollection | Une collection de modules locaux raccordés à la station. Cette propriété est décrite ici en détail.
Name | string | Nom de l'appareil
NewFirmwareFile | string | Chemin vers le nouveau fichier de firmware
NewFirmwareVersion | string | Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.
NewFirmwareNameIsValid | bool | Le nouveau fichier de firmware est-il valide ?
Selected | bool | L'appareil est-il sélectionné ?
SerialNumber | string | Numéro de série unique de l'appareil
Slot | uint | Numéro d'emplacement du matériel
SlotName | string | Cette propriété est utilisée dans l'interface utilisateur de SIMATIC Automation Tool. Elle ne concerne pas les opérations API.
StationNumber | uint | Numéro de station de l'appareil
SubSlot | uint | Le sous-emplacement de l'appareil. Ceci vaut pour les sous-modules enfichables tels que les SB-1200.
Supported | FeatureSupport | L'appareil réseau détecté est-il pris en charge par les opérations actuelles de l'API SIMATIC Automation Tool ?

En utilisant la propriété Devices de l'IRemoteInterface, il est possible d'inspecter toutes les stations sur le réseau décentralisé.

L'exemple suivant poursuit l'exemple de la rubrique Modules d'E/S décentralisés :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (!scanResult.Succeeded)
return;

foreach (IProfinetDevice dev in scannedDevices)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu == null)
continue;

List<IRemoteInterface> decentalNets = devAsCpu.RemoteInterfaces;
List<string> orderNumbers = new List<string>();

foreach (IRemoteInterface net in decentalNets)
{
//-----------------------------------------------------------
//
        Inspecter l'interface distante
//-----------------------------------------------------------
if (net.InterfaceType == RemoteInterfaceType.Profinet)
{
//-------------------------------------------------------
//
        Examiner chaque station décentralisée
//-------------------------------------------------------
List<IBaseDevice> stations = net.Devices;

foreach (IBaseDevice station in stations)
{
orderNumbers.Add(station.ArticleNumber);
}
}
}
}

L'exemple suivant concerne toutes les interfaces PROFINET distantes et crée une liste des numéros d'article de toutes les stations décentralisées sur le réseau industriel.

Comme IBaseDevice prend également en charge la propriété Modules, il est aisé d'élargir encore l'exemple pour consulter non seulement les stations décentralisées, mais aussi tous les modules enfichés localement sur chaque station.


L'interface ICPUClassic

L'interface ICPUClassic

Ce chapitre contient des informations sur les sujets suivants :
  • Identification des CPU classiques dans une IProfinetDeviceCollection
  • Méthode GetDiagnosticsBuffer


Identification des CPU classiques dans une IProfinetDeviceCollection

Identification des CPU classiques dans une IProfinetDeviceCollection

La méthode ScanNetworkDevices génère une collection IProfinetDeviceCollection. Cette collection contient un élément pour chaque appareil accessible sur le réseau industriel. Ces appareils peuvent comprendre des CPU (classiques) S7‑300 et S7‑400.

L'interface IProfinetDevice fournit les propriétés et les méthodes qui s'appliquent à toutes les catégories d'appareils. Cependant, une méthode est spécifique aux CPU classiques. Cette méthode, GetDiagnosticsBuffer, est accessible avec l'interface ICPUClassic.

Pour déterminer si une interface IProfinetDevice donnée représente effectivement une CPU classique, transtypez-la en ICPUClassic. Si le transtypage réussit, l'appareil est bien une CPU classique, et vous pouvez utiliser la méthode sur l'interface ICPUClassic. L'exemple suivant illustre ce transtypage :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
ICPUClassic devAsClassicCpu = dev as ICPUClassic;
if (devAsClassicCpu != null)
{
//-----------------------------------------------------
//
        L'appareil est une CPU classique.
//
        L'interface ICPUClassic peut être utilisée pour interagir avec elle.
//-----------------------------------------------------
}
}
}

Remarque

L'interface ICPUClassic hérite de IProfinetDevice. Toutes les propriétés et méthodes prises en charge sur l'appareil IProfinetDevice le sont donc aussi sur l'interface ICPUClassic.


Méthode GetDiagnosticsBuffer

Méthode GetDiagnosticsBuffer

Type de retour | Nom de la méthode
Result | GetDiagnosticsBuffer

Paramètres
Nom | Type de données | Type de paramètre | Description
DiagnosticsItems | List<DiagnosticsItem> | Out | Une collection d'éléments de diagnostic : Chaque élément de la collection représente une entrée dans le tampon de diagnostic.
Language | Language | In | Langue requise pour les entrées du tampon de diagnostic.

Cette méthode lit les entrées de diagnostic actuelles provenant de la CPU. La méthode GetDiagnosticsBuffer renvoie une collection d'objets DiagnosticsItem. Dans l'exemple suivant, on recherche une CPU classique à une adresse IP donnée dans IProfinetDeviceCollection. Une fois qu'elle a été trouvée, les informations de diagnostic y sont lues : Le Language enum est utilisé pour obtenir des entrées de diagnostic dans une langue spécifique :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
List<DiagnosticsItem> aLogs = new List<DiagnosticsItem>();
IProfinetDeviceCollection devices;
Result retVal = new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
        ICPUClassic devAsCpu = dev as ICPUClassic;
        if ((devAsCpu != null) && (devAsCpu.IP == targetIPAddress))
        {
            devAsCpu.SetPassword(new EncryptedString("Password"));
            devAsCpu.Selected = true;
            retVal = devAsCpu.GetDiagnosticsBuffer(out aLogs, Language.English);
            if (retVal.Succeeded)
            {
                for (int idxLog = 0; idxLog < aLogs.Count; idxLog++)
                {
                //get information time stamp
                string descrTimes = aLogs[idxLog].TimeStamp.ToString();

                //get information basic description
                string descrBasic = aLogs[idxLog].Description1;

                //get information detailed description
                string descrDetail = aLogs[idxLog].Description2;

                //get information state (incoming/outgoing)
                string descrState = aLogs[idxLog].State.ToString();
                }
            }
        }
    }
}

La méthode GetDiagnosticsBuffer renvoie une collection d'objets DiagnosticsItem.


Interface IHMI

Interface IHMI

Ce chapitre contient des informations sur les sujets suivants :
  • Interface IHMI
  • Propriétés et drapeaux IHMI
  • Méthodes IHMI


Interface IHMI

Interface IHMI

La méthode ScanNetworkDevices est appelée pour générer une IProfinetDeviceCollection. Cette collection contient un élément pour chaque appareil accessible sur le réseau industriel. Ces appareils peuvent être des CPU, des appareils IHM, des stations I/O décentralisées et d'autres appareils Siemens. L'interface IProfinetDevice fournit les propriétés et les méthodes qui s'appliquent à toutes les catégories d'appareils.

Cependant, certaines méthodes sont utilisées uniquement pour les appareils HMI. Ces propriétés et méthodes sont accessibles à l'aide de l'interface IHMI.

Pour déterminer si une interface IProfinetDevice donnée représente effectivement un appareil IHM, placez-la dans un IHMI. Si l'opération réussit, l'appareil est bien un appareil IHM, et vous pouvez utiliser les méthodes sur l'interface IHMI. L'exemple suivant illustre cette procédure :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
IHMI devAsHmi = dev as IHMI;
if (devAsHmi != null)
{
//-----------------------------------------------------
//
        L'appareil est un appareil IHM.
//
        L'interface IHMI peut être utilisée pour interagir avec lui.
//-----------------------------------------------------
}
}

}

Remarque

L'interface IHMI hérite de l'IProfinetDevice. De ce fait, les propriétés et méthodes prises en charge sur le IProfinetDevice le sont aussi sur l'interface IHMI. La rubrique sur les propriétés IHMI suivante décrit seulement les propriétés/méthodes qui appartiennent uniquement à l'interface IHMI.
Remarque

L'interface IHMI prend en charge la méthode FirmwareUpdate. Cependant, cette méthode renvoie toujours l'erreur FirmwareUpdateNotSupported. Pour mettre à jour le firmware pour un appareil HMI, il est nécessaire d'exécuter la méthode de mise à jour du programme.


Propriétés et drapeaux IHMI

Propriétés et drapeaux IHMI

Ce chapitre contient des informations sur les sujets suivants :
  • Propriétés IHMI
  • Drapeaux relatifs aux mises à jour de programmes
  • Restaurer les drapeaux
  • Drapeaux de fonctionnalités


Propriétés IHMI

Propriétés IHMI

L'interface IHMI comprend les propriétés suivantes :

Nom de la propriété | Type de retour | Description
DeviceType | string | Retourne le type d'IHM que l'objet représente
FirmwareDeviceVersion | string | Retourne la version de firmware présente sur l'IHM
RuntimeDeviceVersion | string | Retourne la version de runtime présente sur l'IHM


Drapeaux relatifs aux mises à jour de programmes

Drapeaux relatifs aux mises à jour de programmes

Vous pouvez utiliser ces drapeaux avec l'interface IHMI :

Nom de la propriété | Type de retour | Description
NewProgramNameIsValid | bool | Vrai, lorsque la méthode SetProgramFolder est appelée avec un dossier programme valide. Faux, si le programme n'est pas valide.
ProgramUpdateSucceeded | bool | Vrai, lorsque la mise à jour du programme a réussi, même si une erreur peut être retournée depuis l'état de l'actualisation interne
NewProgramName | string | Nom du nouveau programme
NewProgramFolder | string | Emplacement du dossier pour le nouveau programme : la valeur est définie via la méthode SetProgramFolder
NewProgramNameErrorCode | Result | Code permettant d'identifier les problèmes qui peuvent survenir lors de la validation du nouveau programme, par exemple si le programme est invalide pour l'appareil ou si l'adresse IP affectée dans le programme existe déjà sur le réseau.


Restaurer les drapeaux

Restaurer les drapeaux

Vous pouvez utiliser ces drapeaux avec l'interface IHMI :

Nom de la propriété | Type de retour | Description
NewRestoreNameIsValid | bool | Vrai, lorsque la méthode SetBackupFolder est appelée avec un fichier de sauvegarde valide. Faux, si le fichier de sauvegarde n'est pas valide.
RestoreSucceeded | bool | Vrai lorsque la restauration a réussi, même si une erreur a pu être retournée depuis l'état de l'actualisation interne
NewRestoreName | string | Quel est le nom du nouveau programme ?
NewRestoreFile | string | Quel est l'emplacement du fichier pour le nouveau programme ? La valeur est définie à l'aide de la méthode SetbackupFile.
NewRestoreNameErrorCode | Result | Un moyen simple d'identifier les problèmes qui peuvent survenir lors de la validation du nouveau programme, par exemple si le programme est invalide ou incompatible avec l'appareil.


Drapeaux de fonctionnalités

Drapeaux de fonctionnalités

Vous pouvez utiliser ces drapeaux avec l'interface IHMI :

Nom de la propriété | Type de retour | Description
BackupAllowed | bool | Vrai, si l'appareil autorise des sauvegardes
ProgramUpdateAllowed | bool | Vrai, si l'appareil autorise des mises à jour du programme
RestoreAllowed | bool | Vrai, si l'appareil autorise des restaurations


Méthodes IHMI

Méthodes IHMI

Ce chapitre contient des informations sur les sujets suivants :
  • Méthode Backup (interface IHMI)
  • Méthode ProgramUpdate (interface IHMI)
  • Méthode Restore (interface IHMI)
  • Méthode SetProgramFolder
  • Méthode SetBackupFile
  • Méthode SetTransferChannel


Méthode Backup (interface IHMI)

Méthode Backup (interface IHMI)

Type de retour | Nom de la méthode
Result | Backup

Paramètres

Nom

Type de données

Type de paramètre

Description

strFile

string

In

Chemin d'accès complet et nom sous lequel le fichier de sauvegarde est stocké

type

BackupType

In (facultatif)

Lorsque présent, spécifie les données à sauvegarder :

  • Sauvegarde complète

  • Recettes

  • Données de gestion des utilisateurs

Cette méthode est utilisée pour sauvegarder les données d'une IHM. Certaines IHM ne prennent pas en charge la fonction Sauvegarde / Restauration. La propriété BackupAllowed peut être vérifiée pour s'assurer que l'IHM concernée prend en charge cette fonction. Dans l'exemple suivant, on recherche une IHM à une adresse IP donnée dans la IProfinetDeviceCollection. Une fois qu'elle a été trouvée, le programme vérifie que l'IHM prend en charge la fonction de sauvegarde et appelle la méthode Backup :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
string bkFile = @"C:\MyHMIBackupFile.s7pbkp";
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
    foreach (IProfinetDevice dev in devices)
    {
    IHMI devAsHmi = dev as IHMI;

        if ((devAsHmi != null) &&
            (devAsHmi.IP == targetIPAddress) &&
            (devAsHmi.BackupAllowed)
           )
        {
            devAsHmi.Selected = true;
            // back up only recipes
            retVal = devAsHmi.Backup(bkFile, BackupType.Recipes);

            // or do full HMI backup
            Result retVal = devAsHmi.Backup(bkFile);
        }
    }
}


Méthode ProgramUpdate (interface IHMI)

Méthode ProgramUpdate (interface IHMI)

Type de retour | Nom de la méthode
Result | ProgramUpdate

Cette méthode met à jour le système d'exploitation et le logiciel runtime de l'appareil IHM. Le paramètre strPath attribue un dossier contenant le programme à charger.

Pour exécuter correctement la méthode ProgramUpdate sur l'interface IHM, vous devez vérifier les éléments suivants :

  • L'appareil est sélectionné

  • NewProgramFolder a été défini par SetProgramFolder

Dans l'exemple suivant, on recherche une IHM à une adresse IP donnée dans la collection IProfinetDeviceCollection et le programme de cette IHM est mis à jour :

Network myNetwork = new Network();
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

Result retVal - new Result();

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)
{
    IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
    if (dev != null)
    {
        IHMI devAsHMI = dev as IHMI;
        if (devAsHMI != null)
        {
            devAsHMI.Selected = true;
            devAsHMI.SetProgramFolder( @"c:\myFolder\ProgramUpdate\Simatic.HMI\RT_Projects\Project1");
            retVal = devAsHMI.ProgramUpdate();
        }
    }
}

Le dossier programme doit contenir les fichiers suivants pour que l'opération se termine correctement :
DownloadTask.xml
ProjectCharacteristics.rdf

Ces fichiers se trouvent généralement dans un dossier créé (à l'aide de TIA Portal) au format suivant :
{DeviceName)\Simatic.HMI\RT_Projects\{ProjectName}.{DeviceName}

Par exemple :
"C:\Desktop\hmim14000100a\Simatic.HMI\RT_Projects\DasBasicUndMobilePanelen.hmim14000100a[KTP700 Mobile]"

Remarque

Mises à jour du système d'exploitation et du logiciel runtime d'appareils IHM

ProgramUpdate pour une HMI est différent de la méthode pour une CPU. Cette méthode permet de mettre à jour le système d'exploitation et le logiciel d'exécution pour les appareils IHM. Vous ne pouvez pas choisir une mise à jour partielle. SIMATIC Automation Tool met à jour tous les composants de données nécessaires pour assurer un téléchargement cohérent. Une carte de mise à jour du programme IHM peut comporter plusieurs projets nécessitant la saisie d'un dossier sous \Simatic.HMI\RT_Projects\ pour le téléchargement.


Méthode Restore (interface IHMI)

Méthode Restore (interface IHMI)

Type de retour | Nom de la méthode
Result | Restore

Utilisez cette méthode pour restaurer les données d'appareil IHM d'une sauvegarde précédente de l'appareil. Certaines IHM ne prennent pas en charge la fonction Sauvegarde / Restauration. La propriété RestoreAllowed peut être vérifiée pour s'assurer que l'IHM concernée prend en charge cette fonction.

Pour que la méthode Restore s'exécute avec succès sur l'interface IHMI, l'utilisateur doit vérifier que :

  • L'appareil est sélectionné

  • BackupFile a été défini par SetBackupFile

Dans l'exemple suivant, on recherche une IHM à une adresse IP donnée dans la IProfinetDeviceCollection. Une fois qu'elle a été trouvée, le programme vérifie que l'IHM prend en charge la fonction de restauration et appelle la méthode Restore :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IHMI hmi = scannedDevices.FindDeviceByMAC(targetMACAddress) as IHMI;
if (hmi != null && hmi.RestoreAllowed == true)
{
//
        Sélectionner le pupitre IHM à mettre à jour
hmi.Selected = true;

retVal = hmi.SetBackupFile(@"C:\MyFolder\Backup.s7pbkp");
if (retVal.Failed == true)
return;

//
        Adresse IP unique ?
if (hmi.DuplicateIP == true)
return;

//
        L'appareil est-il pris en charge ?
if (hmi.Supported == false)
return;

//
        Effectuer une restauration
retVal = hmi.Restore();
}
}


Méthode SetProgramFolder

Méthode SetProgramFolder

Type de retour | Nom de la méthode
Result | SetProgramFolder

Paramètres
Nom | Type de données | Type de paramètre | Description
strFolder | string | in | Définit l'emplacement du dossier où la source de téléchargement du programme est stockée.

L'exemple suivant montre comment définir le dossier programme sur un appareil IHM :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IHMI hmi = scannedDevices.FindDeviceByMAC(targetMACAddress) as IHMI;
if (hmi != null && hmi.ProgramUpdateAllowed == true)
{
//
        Sélectionner le pupitre IHM à mettre à jour
hmi.Selected = true;

retVal = hmi.SetProgramFolder(@"C:\MyFolder");
if (retVal.Failed == true)
return;

//
        Adresse IP unique ?
if (hmi.DuplicateIP == true)
return;

//
        L'appareil est-il pris en charge ?
if (hmi.Supported == false)
return;

//
        Effectuer une mise à jour du programme
retVal = hmi.ProgramUpdate();
}
}

Le dossier indiqué pour "strPath" doit contenir les fichiers suivants pour que l'opération s'exécute avec succès :

  • DownloadTask.xml

  • ProjectCharacteristics.rdf

Ces fichiers se trouvent généralement dans un dossier créé (à l'aide de TIA Portal) au format suivant :

{DeviceName)\Simatic.HMI\RT_Projects\{ProjectName}.{DeviceName}

Par exemple :
"C:\Desktop\hmim14000100a\Simatic.HMI\RT_Projects\DasBasicUndMobilePanelen.hmim14000100a[KTP700 Mobile]"

Remarque

ProgramUpdate pour une HMI est différent de la méthode pour une CPU. Pour un appareil IHM, cette méthode met à jour le système d'exploitation et le logiciel runtime. Vous ne pouvez pas choisir une mise à jour partielle. SIMATIC Automation Tool met à jour les composants nécessaires pour assurer un téléchargement cohérent. Une carte de mise à jour du programme IHM peut comporter plusieurs projets nécessitant la saisie d'un dossier sous \Simatic.HMI\RT_Projects\.


Méthode SetBackupFile

Méthode SetBackupFile

Type de retour | Nom de la méthode
Result | SetBackupFile

Paramètres
Nom | Type de données | Type de paramètre | Description
strFile | string | in | Définit l'emplacement du dossier où la source du fichier de sauvegarde est stockée.

La méthode définit les drapeaux suivants pour l'objet IHMI :

  • NewRestoreName

  • NewRestoreFile

  • NewRestoreNameIsValid

L'exemple suivant montre comment définir le chemin du fichier de sauvegarde sur un appareil IHM :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566; // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IHMI hmi = scannedDevices.FindDeviceByMAC(targetMACAddress) as IHMI;
if (hmi != null && hmi.RestoreAllowed == true)
{
//
        Sélectionner le pupitre IHM à mettre à jour
hmi.Selected = true;

retVal = hmi.SetBackupFile(@"C:\MyFolder\Backup.s7pbkp");
if (retVal.Failed == true)
return;

//
        Adresse IP unique ?
if (hmi.DuplicateIP == true)
return;

//
        L'appareil est-il pris en charge ?
if (hmi.Supported == false)
return;

//
        Effectuer une restauration
retVal = hmi.Restore();
}
}


Méthode SetTransferChannel

Méthode SetTransferChannel

Type de retour | Nom de la méthode
Result | SetTransferChannel

Paramètres
Nom | Type de données | Type de paramètre | Description
transferChannel | HMITransferChannel | in | Définit le type de communication (mode de transfert) utilisé pour communiquer avec l'appareil IHM.

Les appareils IHM peuvent prendre en charge plusieurs protocoles pour l'échange de données avec SIMATIC Automation Tool. Les protocoles sont les modes de transfert. La méthode définit le mode de transfert IHM :

Network myNetwork = new Network();
ulong targetMACAddress = 0x112233445566;  // 11:22:33:44:55:66
IProfinetDeviceCollection scannedDevices;

        IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
IHMI hmi = scannedDevices.FindDeviceByMAC(targetMACAddress) as IHMI;
if (hmi != null)
{
//
         Définir PN/IE comme protocole pour la communication avec cet appareil IHM.
Result retVal = hmi.SetTransferChannel(HMITransferChannel.PN_IE);
}
}

Remarque

Le mode de transfert par défaut est HMITransferChannel.PN_IE.


Interface IScalance

Interface IScalance

Ce chapitre contient des informations sur les sujets suivants :
  • Interface IScalance
  • Propriétés IScalance
  • Méthodes IScalance


Interface IScalance

Interface IScalance

Un appareil SCALANCE est l'un des types d'appareil pouvant être détectés par la méthode ScanNetworkDevices. ScanNetworkDevices génère une collection IProfinetDeviceCollection qui contient un élément pour chaque appareil accessible dans le réseau industriel. Les appareils peuvent être des CPU, des HMI, des appareils SCALANCE et des stations I/O décentralisées.

L'interface IProfinetDevice fournit les propriétés et les méthodes qui s'appliquent à tous les appareils. S'il s'agit d'appareils SCALANCE, l'interface IScalance fournit les propriétés et méthodes spécifiques aux appareils SCALANCE.

Pour déterminer si une interface d'appareil représente un appareil SCALANCE, transmettez l'interface IProfinetDevice à une interface IScalance. Si l'opération réussit, l'appareil est bien un appareil SCALANCE et vous pouvez utiliser les méthodes et propriétés IScalance. Comme l'interface IScalance hérite des paramétrages de l'interface IProfinetDevice, un appareil SCALANCE dispose de toutes les méthodes et propriétés IProfinetDevice.

L'exemple suivant montre comment détecter des appareils SCALANCE parmi les appareils de réseau identifiés :

Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
foreach (IProfinetDevice dev in scannedDevices)
{
IScalance devAsScalance = dev as IScalance;
if (devAsScalance != null)
{
//-----------------------------------------------------
//
        L'appareil est un appareil
        SCALANCE
        .
//
        L'interface IScalance peut être utilisée pour interagir avec lui.
//-----------------------------------------------------
}
}
}


Propriétés IScalance

Propriétés IScalance

L'interface IScalance présente les propriétés suivantes :

Nom de la propriété | Type de retour | Description
ProfileName | string | Renvoie le nom du profil SNMP.
ProfileNameisValid | bool | Vrai s'il existe un nom de profil valide.


Méthodes IScalance

Méthodes IScalance

Ce chapitre contient des informations sur les sujets suivants :
  • Méthode SetProfile
  • Méthode FirmwareUpdate


Méthode SetProfile

Méthode SetProfile

L'application d'interface utilisateur appelle la méthode SetProfile pour établir la configuration de profil d'un appareil SCALANCE.

Type de retour | Nom de la méthode
Result | SetProfile

Paramètres
Nom | Type de données | Type de paramètre | Description
Profile | ISNMPProflie | In | Profil SNMP et configuration TFTP (Trivial File Transfer Protocol) pour la mise à jour du firmware de l'appareil SCALANCE

Les exemples suivants contiennent des appels de la méthode SetProfile :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

  • Exemple : configuration SNMP version 3

Dans ces exemples, l'appel SetProfile se situe vers la fin du code.


Méthode FirmwareUpdate

Méthode FirmwareUpdate

L'application d'interface utilisateur appelle la méthode FirmwareUpdate pour mettre à jour le firmware d'un appareil SCALANCE.

Type de retour | Nom de la méthode
Result | FirmwareUpdate

Paramètres
Nom | Type de données | Type de paramètre | Description
Aucun |  |  |

Les exemples suivants contiennent des appels de la méthode FirmwareUpdate :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

  • Exemple : configuration SNMP version 3

Dans ces exemples, l'appel FirmwareUpdate se situe vers la fin du code.


Interface ISNMPProfile

Interface ISNMPProfile

Ce chapitre contient des informations sur les sujets suivants :
  • Propriétés ISNMPProfile
  • Méthodes ISNMPProfile
  • Classe SNMPProfile


Propriétés ISNMPProfile

Propriétés ISNMPProfile

ISNMPProfile est une collection agrégée de propriétés que vous utilisez pour effectuer la mise à jour du firmware d'un appareil SCALANCE avec SNMP. Les propriétés applicables pour la mise à jour du firmware d'un appareil donné dépendent de la version de protocole SNMP configurée sur cet appareil. Les descriptions des propriétés indiquent à quelle version SNMP (V1, V2, V3) une propriété s'applique. Aucune version n'est mentionnée pour les propriétés communes à toutes les versions SNMP.

Nom de la propriété | Type de retour | Description
ProfileName | string | Nom du profil SNMP
Version | SNMPVersion | Version de protocole SNMP utilisée
ServerIP | string | Représentation de l'adresse IP sous forme de chaîne
ServerIPArray | byte[] | Adresse IP du serveur TFTP
ServerPort | UInt16 | Affectation de port TFTP
ReadCommunity | string | V1/V2, ID droits de lecture (mot de passe)
WriteCommunity | string | V1/V2, ID droits d'écriture (mot de passe)
UserName | string | V3, nom d'utilisateur
ContextName | string | V3, ID de contexte (information de gestion)
SecurityLevel | SNMPSecurityLevel | V3, niveau de sécurité
AuthAlgorithm | SNMPAuthAlgorithm | V3, algorithme d'authentification
AuthKey | byte[] | V3, clé d'authentification
PrivAlgorithm | SNMPPrivAlgorithm | V3, algorithme de confidentialité
PrivKey | byte[] | V3, clé de confidentialité


Méthodes ISNMPProfile

Méthodes ISNMPProfile

Ce chapitre contient des informations sur les sujets suivants :
  • Méthode Validate


Méthode Validate

Méthode Validate

La méthode Validate évalue les arguments du profil SNMP pour s'assurer que le jeu de paramètres de mise à jour du firmware requis est cohérent. Le résultat renvoyé identifie les incohérences éventuelles.

Type de retour | Nom de la méthode
Result | Validate

Paramètres
Nom | Type de données | Type de paramètre | Description
Aucun |  |  |

Les exemples suivants contiennent des appels de la méthode Validate :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

  • Exemple : configuration SNMP version 3

Dans ces exemples, l'appel Validate a lieu après la définition des paramètres du profil.


Classe SNMPProfile

Classe SNMPProfile

Ce chapitre contient des informations sur les sujets suivants :
  • Propriétés de la classe SNMPProfile
  • Méthodes de la classe SNMPProfile


Propriétés de la classe SNMPProfile

Propriétés de la classe SNMPProfile

La classe SNMPProfile sert à stocker et éditer les profils SNMP.

Nom de la propriété | Type de retour | Description
ProfileName | string | Nom du profil SNMP
Version | SNMPVersion | Version de protocole SNMP utilisée
ServerIP | string | Représentation de l'adresse IP sous forme de chaîne
ServerIPArray | byte[] | Adresse IP du serveur TFTP
ServerPort | UInt16 | Affectation de port TFTP
ReadCommunity | string | V1/V2, ID droits de lecture
WriteCommunity | string | V1/V2, ID droits d'écriture
UserName | string | V3, nom d'utilisateur
ContextName | string | V3, ID de contexte (information de gestion)
SecurityLevel | SNMPSecurityLevel | V3, niveau de sécurité
AuthAlgorithm | SNMPAuthAlgorithm | V3, algorithme d'authentification
AuthKey | byte[] | V3, clé d'authentification
PrivAlgorithm | SNMPPrivAlgorithm | V3, algorithme de confidentialité
PrivKey | byte[] | V3, clé de confidentialité


Méthodes de la classe SNMPProfile

Méthodes de la classe SNMPProfile

Ce chapitre contient des informations sur les sujets suivants :
  • SetProfileName
  • SetSNMPVersion
  • Méthode SetServerIP
  • Méthode SetServerPort
  • Méthode SetReadCommunity
  • Méthode SetWriteCommunity
  • Méthode SetUserName
  • Méthode SetContextName
  • Méthode SetSecurityLevel
  • Méthode SetAuthAlgorithm
  • Méthode SetPrivAlgorithm


SetProfileName

SetProfileName

La méthode SetProfileName affecte la valeur de la chaîne d'entrée au nom du profil.

Type de retour | Nom de la méthode
Result | SetProfileName

Paramètres
Nom | Type de données | Type de paramètre | Description
strName | string | in | Nom du profil

Les exemples suivants contiennent des appels de la méthode SetProfileName :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

  • Exemple : configuration SNMP version 3

Dans ces exemples, l'appel SetProfileName se situe vers le début du code.


SetSNMPVersion

SetSNMPVersion

La méthode SetSNMPVersion définit la version du protocole SNMP. Le protocole SNMP a la version 1, 2 ou 3.

Type de retour | Nom de la méthode
Result | SetSNMPVersion

Paramètres
Nom | Type de données | Type de paramètre | Description
nVersion | SNMPVersion | in | Version SNMP 1, 2 ou 3

Les exemples suivants contiennent des appels de la méthode SetSNMPVersion :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

  • Exemple : configuration SNMP version 3

Dans ces exemples, l'appel SetSNMPVersion se situe vers le début du code.


Méthode SetServerIP

Méthode SetServerIP

La méthode SetServerIP définit l'adresse IP du serveur TFTP. Cette méthode est applicable à tous les profils SNMP.

Type de retour | Nom de la méthode
Result | SetServerIP

Paramètres
Nom | Type de données | Type de paramètre | Description
strIP | string | in | Affectation IP

Les exemples suivants contiennent des appels de la méthode SetServerIP :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

  • Exemple : configuration SNMP version 3

Dans ces exemples, l'appel SetServerIP se situe vers le début du code.


Méthode SetServerPort

Méthode SetServerPort

La méthode SetServerPort définit l'affectation de port du serveur TFTP. Cette méthode est applicable à tous les profils SNMP.

Type de retour | Nom de la méthode
Result | SetServerPort

Paramètres
Nom | Type de données | Type de paramètre | Description
nVersion | UInt16 | in | Affectation de port TFTP

Les exemples suivants contiennent des appels de la méthode SetServerPort :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

  • Exemple : configuration SNMP version 3

Dans ces exemples, l'appel SetServerPort a lieu juste après l'appel SetServerIP.


Méthode SetReadCommunity

Méthode SetReadCommunity

La méthode SetReadCommunity définit la chaîne d'entrée comme communauté en lecture. La chaîne de communauté en lecture permet à un appareil distant d'obtenir des informations en lecture seule d'un appareil. Cette méthode est applicable à un profil SNMP version 1 ou version 2.

Type de retour | Nom de la méthode
Result | SetReadCommunity

Paramètres
Nom | Type de données | Type de paramètre | Description
strCommunity | string | in | Affectation de la communauté en lecture

Les exemples suivants contiennent des appels de la méthode SetReadCommunity :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

Dans ces exemples, l'appel SetReadCommunity se situe vers le milieu du code.


Méthode SetWriteCommunity

Méthode SetWriteCommunity

La méthode SetWriteCommunity définit la chaîne d'entrée comme communauté en écriture. La chaîne de communauté en écriture permet à un appareil d'effectuer des opérations de lecture et d'écriture. Cette méthode est applicable à un profil SNMP version 1 ou version 2.

Type de retour | Nom de la méthode
Result | SetWriteCommunity

Paramètres
Nom | Type de données | Type de paramètre | Description
strCommunity | string | in | Affectation de la communauté en écriture

Les exemples suivants contiennent des appels de la méthode SetWriteCommunity :

  • Exemple : configuration SNMP version 1

  • Exemple : configuration SNMP version 2

Dans ces exemples, l'appel SetWriteCommunity se situe vers le début du code.


Méthode SetUserName

Méthode SetUserName

La méthode SetUserName définit le nom d'utilisateur pour un profil SNMP de version 3.

Type de retour | Nom de la méthode
Result | SetUserName

Paramètres
Nom | Type de données | Type de paramètre | Description
strName | string | in | Nom d'utilisateur SNMP V3

L'exemple Exemple : configuration SNMP version 3 contient un appel de la méthode SetUserName vers le milieu du code.


Méthode SetContextName

Méthode SetContextName

La méthode SetContextName définit le nom de contexte pour un profil SNMP de version 3.

Type de retour | Nom de la méthode
Result | SetContextName

Paramètres
Nom | Type de données | Type de paramètre | Description
strName | string | in | Contexte d'information de gestion SNMP V3

L'exemple Exemple : configuration SNMP version 3 contient un appel de la méthode SetContextName vers le milieu du code.


Méthode SetSecurityLevel

Méthode SetSecurityLevel

La méthode SetSecurityLevel définit le niveau de sécurité pour un profil SNMP de version 3.

Type de retour | Nom de la méthode
Result | SetSecurityLevel

Paramètres
Nom | Type de données | Type de paramètre | Description
level | SNMPSecurityLevel | in | Niveau de sécurité SNMP V3

L'exemple Exemple : configuration SNMP version 3 contient un appel de la méthode SetSecurityLevel vers le milieu du code.


Méthode SetAuthAlgorithm

Méthode SetAuthAlgorithm

La méthode SetAuthAlgorithm définit l'algorithme d'authentification pour un profil SNMP version 3. L'algorithme d'authentification s'applique lorsque le niveau de sécurité requiert une authentification. Le mot de passe d'authentification s'applique lorsque le niveau de sécurité requiert à la fois confidentialité et authentification.

Type de retour | Nom de la méthode
Result | SetAuthAlgorithm

Paramètres
Nom | Type de données | Type de paramètre | Description
algorithm | SNMPAuthAlgorithm | in | Algorithme d'authentification SNMP V3
strPassword | string | in | Mot de passe d'authentification SNMP V3

L'exemple Exemple : configuration SNMP version 3 contient un appel de la méthode SetAuthAlgorithm vers le milieu du code.


Méthode SetPrivAlgorithm

Méthode SetPrivAlgorithm

La méthode SetPrivAlgorithm définit l'algorithme de confidentialité pour un profil SNMP version 3. L'algorithme de confidentialité s'applique lorsque le niveau de sécurité requiert la confidentialité.

Type de retour | Nom de la méthode
Result | SetPrivAlgorithm

Paramètres
Nom | Type de données | Type de paramètre | Description
algorithm | SNMPPrivAlgorithm | in | Algorithme de confidentialité SNMP V3
strPassword | string | in | Mot de passe de confidentialité SNMP V3

L'exemple Exemple : configuration SNMP version 3 contient un appel de la méthode SetPrivAlgorithm vers le milieu du code.


Exemples de code pour mise à jour de firmware IScalance et ISNMP

Exemples de code pour mise à jour de firmware IScalance et ISNMP

Ce chapitre contient des informations sur les sujets suivants :
  • Exemple : configuration SNMP version 1
  • Exemple : configuration SNMP version 2
  • Exemple : configuration SNMP version 3


Exemple : configuration SNMP version 1

Exemple : configuration SNMP version 1

Cet exemple montre comment configurer et déclencher une mise à jour du firmware pour un appareil SCALANCE. Dans cet exemple, l'appareil SCALANCE utilise SNMP version 1 :

SNMPProfile　profileV1　=　new　SNMPProfile();

//　Créer un profil utilisant SNMP version 1
Result　retVal　=　profileV1.SetSNMPVersion(SNMPVersion.Version1);
if　(retVal.Failed)
      return;

// Donner un nom à ce profil
retVal = profileV1.SetProfileName("Profile_1");
if (retVal.Failed)
      return;
// Définir l'adresse IP du serveur TFTP, obligatoire
retVal　=　profileV1.SetServerIP("192.168.0.1");
if　(retVal.Failed)
      return;
// Définir le port du serveur TFTP, 69 par défaut, facultatif
retVal　=　profileV1.SetServerPort(69);
if　(retVal.Failed)
      return;

// Définir la communauté en lecture SCALANCE, "public" par défaut, facultatif
retVal　=　profileV1.SetReadCommunity("public");
if　(retVal.Failed)
      return;

// Définir la communauté en écriture SCALANCE, "private" par défaut, facultatif
retVal　=　profileV1.SetWriteCommunity("private");
if　(retVal.Failed)
      return;

// Vérifier que le profil est valide, garantit que nous n'avons pas omis un paramètre
retVal　=　profileV1.Validate();
if　(retVal.Failed)
      return;

// Rechercher et actualiser le firmware sur tous les appareils SCALANCE
Network　myNetwork　=　new　Network();
IProfinetDeviceCollection　scannedDevices;
// Rechercher tous les appareils appartenant au réseau
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
{
      // Filtrer les appareils SCALANCE
      List<IProfinetDevice>　onlyScalance　=
       scannedDevices.FilterByDeviceFamily(new　List<DeviceFamily>(1)　{　DeviceFamily.SCALANCE　});
      foreach　(IScalance　scalance　in　onlyScalance)
      {
         // Définir le profil SNMP requis pour communiquer avec cet appareil SCALANCE
         retVal　=　scalance.SetProfile(profileV1);
         if　(retVal.Succeeded)
         {
         // Définir le nouveau fichier de firmware pour mettre à jour SCALANCE
         retVal　=　scalance.SetFirmwareFile(@"C:\Firmware\FirmwareFile.lad");
         if　(retVal.Succeeded)
               retVal　=　scalance.FirmwareUpdate();
         }
      }
}


Exemple : configuration SNMP version 2

Exemple : configuration SNMP version 2

Cet exemple montre comment configurer et déclencher une mise à jour du firmware pour un appareil SCALANCE. Dans cet exemple, l'appareil SCALANCE utilise SNMP version 2 :

SNMPProfile profileV2 = new SNMPProfile();

// Créer un profil utilisant SNMP version 2
Result retVal = profileV2.SetSNMPVersion(SNMPVersion.Version2);
if (retVal.Failed)
      return;

// Donner un nom à ce profil
retVal = profileV2.SetProfileName("Profile_2");
if (retVal.Failed)
      return;

// Définir l'adresse IP du serveur TFTP, obligatoire
retVal = profileV2.SetServerIP("192.168.0.1");
if (retVal.Failed)
      return;

// Définir le port du serveur TFTP, 69 par défaut, facultatif
retVal = profileV2.SetServerPort(69);
if (retVal.Failed)
      return;

// Définir la communauté en lecture SCALANCE, "public" par défaut, facultatif
retVal = profileV2.SetReadCommunity("public");
if (retVal.Failed)
      return;

// Définir la communauté en écriture SCALANCE, "private" par défaut, facultatif
retVal = profileV2.SetWriteCommunity("private");
if (retVal.Failed)
      return;

// Vérifier que le profil est valide, garantit que nous n'avons pas omis un paramètre
retVal = profileV2.Validate();
if (retVal.Failed)
      return;

// Rechercher et actualiser le firmware sur tous les appareils SCALANCE
Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

// Rechercher tous les appareils appartenant au réseau
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
 {

      // Filtrer les appareils SCALANCE
       List<IProfinetDevice> onlyScalance =
       scannedDevices.FilterByDeviceFamily(new List<DeviceFamily>(1) { DeviceFamily.SCALANCE });
       foreach (IScalance scalance in onlyScalance)
      {
            // Définir le profil SNMP requis pour communiquer avec cet appareil SCALANCE
             retVal = scalance.SetProfile(profileV2);
             if (retVal.Succeeded)
            {
                  // Définir le nouveau fichier de firmware pour mettre à jour SCALANCE
                   retVal = scalance.SetFirmwareFile(@"C:\Firmware\FirmwareFile.lad");
                   if (retVal.Succeeded)
                         retVal = scalance.FirmwareUpdate();
            }
      }
}


Exemple : configuration SNMP version 3

Exemple : configuration SNMP version 3

Cet exemple montre comment configurer et déclencher une mise à jour du firmware pour un appareil SCALANCE. Dans cet exemple, l'appareil SCALANCE utilise SNMP version 3 avec authentification et confidentialité :

SNMPProfile profileV3_3 = new SNMPProfile();

// Créer un profil utilisant SNMP version 3
Result retVal = profileV3_3.SetSNMPVersion(SNMPVersion.Version3);
if (retVal.Failed)
      return;

// Donner un nom à ce profil
retVal = profileV3_3.SetProfileName("Profile_3.1");
if (retVal.Failed)
      return;

// Définir l'adresse IP du serveur TFTP, obligatoire
retVal = profileV3_3.SetServerIP("192.168.0.1");
if (retVal.Failed)
      return;

// Définir le port du serveur TFTP, 69 par défaut, facultatif
retVal = profileV3_3.SetServerPort(69);
if (retVal.Failed)
      return;

// Définir le nom d'utilisateur, obligatoire
retVal = profileV3_3.SetUserName("User1");
if (retVal.Failed)
      return;

// Définir le nom de contexte, facultatif
retVal = profileV3_3.SetContextName("Context1");
if (retVal.Failed)
      return;

// Définir le niveau de sécurité SCALANCE : authentification, confidentialité, obligatoire
retVal = profileV3_3.SetSecurityLevel(SNMPSecurityLevel.AuthPriv);

 // Définir l'algorithme d'authentification à MD5 et mot de passe, obligatoire
retVal　=　profileV3_3.SetAuthAlgorithm(SNMPAuthAlgorithm.MD5,　"Password1");
if　(retVal.Failed)
    return;

// Définir l'algorithme de confidentialité à DES et mot de passe, obligatoire
retVal　=　profileV3_3.SetPrivAlgorithm(SNMPPrivAlgorithm.DES,　"Password2");
if　(retVal.Failed)
        return;

if (retVal.Failed)
      return;

// Vérifier que le profil est valide, garantit que nous n'avons pas omis un paramètre
retVal = profileV3_3.Validate();
if (retVal.Failed)
      return;

// Rechercher et actualiser le firmware sur tous les appareils SCALANCE
Network myNetwork = new Network();
IProfinetDeviceCollection scannedDevices;

// Rechercher tous les appareils appartenant au réseau
IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out scannedDevices);
if (scanResult.Succeeded)
       {
            // Filtrer les appareils SCALANCE
            List<IProfinetDevice> onlyScalance =
             scannedDevices.FilterByDeviceFamily(new List<DeviceFamily>(1) { DeviceFamily.SCALANCE });
            foreach (IScalance scalance in onlyScalance)
            {
                  // Définir le profil SNMP requis pour communiquer avec cet appareil SCALANCE
                  retVal = scalance.SetProfile(profileV3_3);
                  if (retVal.Succeeded)
                  {
                        // Définir le nouveau fichier de firmware pour mettre à jour SCALANCE
                        retVal = scalance.SetFirmwareFile(@"C:\Firmware\FirmwareFile.lad");
                        if (retVal.Succeeded)
                              retVal = scalance.FirmwareUpdate();
                   }
               }
      }


Exceptions

Exceptions

Ce chapitre contient des informations sur les sujets suivants :
  • CriticalInternalErrorException


CriticalInternalErrorException

CriticalInternalErrorException

L'interface API comprend une exception en cas de détection d'un état critique.

Lorsque votre application détecte que l'exception CriticalInternalErrorException est déclenchée, fermez l'application utilisant l'API. Une erreur critique s'est produite.

Network myNetwork = new Network();
try
{
uint targetIPAddress = 0xC0A80001; // 192.168.0.1
IProfinetDeviceCollection devices;

IScanErrorCollection scanResult = myNetwork.ScanNetworkDevices(out devices);
if (scanResult.Succeeded)

{
IProfinetDevice dev = devices.FindDeviceByIP(targetIPAddress);
if (dev != null)
{
ICPU devAsCpu = dev as ICPU;
if (devAsCpu != null)
{
devAsCpu.SetPassword(new EncryptedString("Password"));
devAsCpu.Selected = true;
if (devAsCpu.Failsafe)devAsCpu.SelectedConfirmed = true;
Result retVal = devAsCpu.ResetToFactoryDefaults();
}
}
}
}
catch (CriticalInternalErrorException e)
{
//
        Une erreur interne critique s'est produite dans l'API
}
catch (Exception e)
{
//
        Une exception s'est produite dans l'API

}


Enumérations API

Enumérations API

Ce chapitre contient des informations sur les sujets suivants :
  • DataChangedType
  • DeviceFamily
  • ConfirmationType
  • ErrorCode
  • Language
  • OperatingState
  • OperatingStateREQ
  • ProgressAction
  • RemoteInterfaceType
  • ProtectionLevel
  • ConfirmationType
  • FailsafeOperation
  • RemoteFolderType
  • SNMPVersion
  • SNMPSecurityLevel
  • SNMPAuthAlgorithm
  • SNMPPrivAlgorithm
  • ScanErrorType
  • HMITransferChannel
  • BackupType
  • TimeFormat


DataChangedType

DataChangedType

Cette énumération définit les valeurs d'argument possibles pour le DataChangedEventHandler :

Invalid
OperatingState
RackInformation
Folders
File
ProfinetName
IPAddress
Password


DeviceFamily

DeviceFamily

Cette énumération indique la gamme de produits d'un matériel :

None
CPU1200
CPU1500
CPU300
CPU400
ET200SP
ET200MP
ET200AL
ET200PRO
ET200ECO
ET200S
ET200M
HMI
SITOPUPS
SCALANCE
SIMOCODE
Unsupported
SIRIUS_ACT
Gateway
NetworkDevice
MicroDrive
SoftStarter
CommunicationsModule
OpticalReader


ConfirmationType

ConfirmationType

L'énumération précise les types de confirmation utilisateur pour les opérations relatives à la sécurité :

Invalid = 0
SafetyPasswordIsBeingUsed = 0x2f161717
DeletingExistingSafetyProgram = 0x40232122
ReplacingExistingSafetyProgram = 0x492a282b
ReplacingExistingSafetyProgramWithNonSafetyProgram = 0x4a2c2b2d
LoadingSafetyProgram = 0x46292728,


ErrorCode

ErrorCode

Cette énumération indique toutes les valeurs en retour possibles pour un objet Result :

OK
AccessDenied
ServiceTimeout
Disconnected
FailedToDisconnect
ServiceNotConnected
TooManySessions
SessionDelegitimated
NotChangableInRun
InvalidFileName
MultiESNotSupported
ServiceAborted
MultiESLimitExceeded
MultiESIncompatibleOtherESVersion
MultiESConflict
WriteProtected
DiskFull
InvalidVersion
PathNotFound

Failed
CPUFailedToEnterRunMode
MACAddressIsNotValid
IPAddressIsNotValid
SubnetMaskIsNotValid
GatewayIsNotValid
ProfinetNameIsNotValid
NewIPAddressIsNotValid
NewSubnetMaskIsNotValid
NewGatewayIsNotValid
NewProfinetNameIsNotValid
InvalidPointer
SetIPErrorDueProjectSettings
UnsupportedDevice
SetNameErrorDueProjectSettings
OperationNotSupportedByThisDevice
DeviceNotOnNetwork
FirmwareVersionMatch
FirmwareFileNotCompatibleToNew
FirmwareFileNotCompatibleToOld
FirmwareFileNotCompatibleNotSame
FirmwareFileNotCompatibleSame
FirmwareFileNotCompatible
FirmwareModuleNotReachable
FirmwareModuleNotAccepted
FirmwareIDNotFound
WriteBlockFailed
InvalidProjectVersion
DeviceIsNotAcceptingChanges
InvalidSignature
ParmeterOutOfRange
FailedToZipFolderContents
ErrorWritingToFile
ErrorCreatingFile
ErrorCreatingFolder
NoSATLicensePresent
InvalidTimeoutValue
NoDataToBackup
ErrorWritingToStream
ErrorReadingFromStream
InvalidProjectPath
ProjectNotCompatibleWithDevice
FailedToSetProfinetName
FailedToSetIPAddress
DownloadInvalidRecipe
IdentityFailure
DeviceMismatch
InvalidInterface
DeviceNotSelected
FailsafeAccessRequired
InternalApplicationError
InvalidPassword
DuplicateIPAddress
DuplicateProfinetName
SafetyDeviceMustBeConfirmed
NoSDCardPresent
InvalidProgramFolder
FSignaturesDoesNotMatch
FSignaturesMatch
DeviceDoesNotSupportProject
ProjectsUpdateIPNotReachable
RestoreIPNotReachable
ProjectIPNotUnique
SafetyProjectDownloadedToStandardNotAllowed
PasswordDiversityFailed
InvalidBackupFile
InvalidBackupFileExtension
IncompatibleBackupFile
InvalidFirmwareFile
OperationWasNotSuccessful
CouldNotValidatePassword
IPAddressAlreadyExistsOnNetwork
MissingProgramFilePassword
InvalidProgramFilePassword
OperationCancelledByUser
InvalidProgramForDevice
InvalidProgramFilePasswordLegitimizationLevel
DeviceNotFound
DeviceAlreadyExists
IPAddressAlreadyOnNetwork
ProfinetNameAlreadyOnNetwork
FailedToConnect
DeviceNotInitialized
CPUNewerVersionNotSupported
IPSuitNotValid
IPAddressChanged
ScanNoDevicesFound
DeviceCannotBeInserted
InsertDeviceDuplicateIP
IPNotReachable
CouldNotReadFSignature
InvalidNetworkInterface
InsufficientLegitimizationLevel
NoProgramPassword
ProjectVersionV1NotSupported
ProjectOpenCanceled
ProgramPasswordNeeded
RestoreError
IncompatibleProgramFile
UnsupportedProgramFile
ProgramFileFamilyMismatch
DuplicateNewIPAddress
SNMPErrorNoAccess
SNMPErrorReadOnly
SNMPErrorNotWritable
SNMPErrorAuthorizationError
SNMPError
InvalidProfileName
InvalidSNMPVersion
InvalidServerIP
InvalidServerPort
InvalidReadCommunity
InvalidWriteCommunity
InvalidUserName
InvalidContextName
InvalidSecurityLevel
InvalidAuthAlgorithm
InvalidAuthPassword
InvalidPrivAlgorithm
InvalidPrivPassword
InvalidProfile
ProfileNameAlreadyExists
ObsoleteMethod
FailedToInitiateFirmwareTransfer
DeviceDefinedError
ErrorDeletingFile
ErrorDeletingFolder
ErrorInvalidMAC
FailedToUpdateDuplicates
DuplicateNewProfinetName
ErrorBackingupData
FailsafeControlObjectIncorrectType
InvalidIPAddressOrUsedByNIC
FirmwareIntegrityFailed
ExportDiagnosticsBufferError
AlmFailedInitialize
AlmFailedCleanup
AlmFailedSessionInitialize
AlmFailedSessionCleanup
AlmSessionIDMissing
AlmSessionIDUnknown
AlmCouldNotConnect
AlmOutOfMemory
AlmOperationTimeout
AlmFunctionNotFound
AlmAborted
AlmBadfunctionArgument
AlmUnkownOption
AlmSendError
AlmReceiveError
AlmNoConnectionAvailable
AlmOpenSession
AlmResources
AlmService
AlmCryptography
AlmTaskAlreadyRunning
AlmInvalidPointer
AlmResultMismatch
AlmBadResult
AlmBatchWrongArgumentNumber
AlmBatchWrongArgument
AlmBatchWrongInputFile
AlmBatchWrongInputStream
AlmBatchAPILoadFailed
AlmBatchOutputfileExists
AlmBatchWrongOutputParmater
AlmBatchOutputCreationFailure
AlmBatchAccessDenied
AlmUnknownError
PowerCycleRequired

//HMI
UnexpectedOperatingSystemError
ServiceActive
RemoteTransferDisabled
HardwareSoftwareNotComplete
LogicalVolumneMissing
LogicalVolumneOutOfSpace
Abort
FirwareTypeNotSupported
FirwareTypeNotInstalled
StoreReadFailed
StoreWriteFailed
RescueBackupNotPossible
RescueRestoreNotPossible
ConnectionRequired
ObjectNotFound
BufferToSmall
InvalidArguements
AttributeNotFound
InvalidPath
TypeConversionFailed
FileReadFailed
FileWriteFailed
OutOfResources
OutOfSpace
UnknownAddon
IncompatibleAddon
AddonsUnsupported
LicenseFailed
UnknownApp
UnknownAppAddon
UnknownReferenceApp
RuntimeMissing
RuntimeBroken
SignatureRequired
SignatureInvalid
SignatureFailure
CertificateInvalid
CertificateFailure
CertificateNotReady
CertificateExpired
CertificateRevoked
SecurityLib
WrongRuntimeVersion
MajorRuntimeDowngrade
MajorRuntimeUpgrade
MajorImageDowngrade
MajorImageUpgrade
WrongRuntime
NotEnoughMemory
ProjectCharacteristicsMissing
ProjectCharacteristicsInvalid
PanelOrientationIsPortrait
PanelOrientationIsLandscape
WrongDevicetype
NoRuntimeInstalled
RuntimeCorrupt
InvalidTransferChannel
InvalidBackupType


Language

Language

L'énumération Language permet de définir la langue des chaînes de caractères retournées. Elle contient les valeurs suivantes :

English
German
French
Spanish
Italian
Chinese


OperatingState

OperatingState

Cette énumération définit les états possibles de la propriété OperatingState :

NotSupported
StopFwUpdate
StopSelfInitialization
Stop
Startup
Run
RunRedundant
Halt
LinkUp
Update
Defective
ErrorSearch
NoPower
CiR
STOPwithoutODIS
RunODIS


OperatingStateREQ

OperatingStateREQ

Cette énumération définit les transitions d'état qui peuvent être demandées dans un appel de la méthode SetOperatingState :

Stop
Run


ProgressAction

ProgressAction

Cette énumération définit les valeurs d'argument possibles qui peuvent être envoyées à un ProgressChangedEventHandler :

Invalid
Connecting
Reconnecting
Disconnecting
Initializing
Updating
Processing
Downloading
Uploading
Deleting
Reseting
Rebooting
Verifying
Formatting
Refreshing
Finished
UpdatingFirmware
InstallingRuntime
InstallingAddOns
UninstallingAddOns
UpdatingProgram


RemoteInterfaceType

RemoteInterfaceType

Cette énumération définit les états qui peuvent être renvoyés d'un appel de la propriété InterfaceType sur l'interface IRemoteInterfaces :

None
Profinet
Profibus
ASi


ProtectionLevel

ProtectionLevel

L'énumération ProtectionLevel donne le niveau de protection d'un mot de passe de la CPU :

Unknown
Failsafe
Full
Read
HMI
NoAccess
NoPassword


ConfirmationType

ConfirmationType

Cette énumération est utilisée pour indiquer l'état de CPU de sécurité :

Description | Valeur
Invalid | 0
SafetyPasswordIsBeingUsed | 0x2f161717
DeletingExistingSafetyProgram | 0x40232122
ReplacingExistingSafetyProgram | 0x492a282b
ReplacingExistingSafetyProgramWithNonSafetyProgram | 0x4a2c2b2d
LoadingSafetyProgram | 0x46292728


FailsafeOperation

FailsafeOperation

L'énumération FailSafeOperation indique les opérations relatives à la sécurité :

Description | Valeur
Invalid | 0
ResetToFactoryOperation | 0x2f161717
FormatMCOperation | 0x46292728
ProgramUpdateOperation | 0x43252224
RestoreOperation | 0x45262427


RemoteFolderType

RemoteFolderType

L'énumération RemoteFolderType indique le type de dossier distant :

Description | Valeur
None | 0
Recipe | 1
Datalog | 2


SNMPVersion

SNMPVersion

L'énumération SNMPVersion indique le numéro de version SNMP pour les appareils SCALANCE :

Description | Valeur
NotSupported | -1
Version1 | 0
Version2 | 1
Version3 | 2


SNMPSecurityLevel

SNMPSecurityLevel

L'énumération SNMPSecurityLevel indique le niveau de sécurité pour un profil SNMP de version 3. Un appareil SCALANCE qui utilise un profil SNMP de version 3 comporte des paramètres de niveau de sécurité :

Description | Valeur
NotSupported | -1
NoAuthNoPriv | 0
AuthNoPriv | 1
AuthPriv | 2


SNMPAuthAlgorithm

SNMPAuthAlgorithm

L'énumération SNMPAuthAlgorithm indique l'algorithme d'authentification pour un appareil SCALANCE qui utilise un profil SNMP de version 3 :

Description | Valeur
NotSupported | -1
MD5 | 0
SHA | 1


SNMPPrivAlgorithm

SNMPPrivAlgorithm

L'énumération SNMPPrivAlgorithm indique l'algorithme de confidentialité pour un appareil SCALANCE qui utilise un profil SNMP de version 3 :

Description | Valeur
NotSupported | -1
DES | 0
AES | 1


ScanErrorType

ScanErrorType

L'énumération ScanErrorType indique le type d'erreur retournée par un scan d'appareil :

Description | Valeur
Invalid | -1
Success | 0
Error | 1
Warning | 2
Information | 3


HMITransferChannel

HMITransferChannel

L'énumération HMITransferChannel indique le protocole utilisé pour communiquer avec un appareil IHM :

Description | Valeur
Invalid | -1
PN_IE | 0
Ethernet | 1


BackupType

BackupType

L'énumération BackupType indique le protocole utilisé pour communiquer avec un appareil IHM :

Description | Valeur
Invalid | 0
FullBackup | 1
Recipes | 2
UserAdministration | 3


TimeFormat

TimeFormat

TimeFormat spécifie un format de temps pour les chaines temps :

Description | Valeur
Local | 0
UTC | 1

UTC signifie Coordinated Universal Time.


Exemple de réseau

Exemple de réseau

Cet exemple montre une configuration réseau TIA Portal et les interfaces API qui représentent les appareils mis en réseau :

On supposera que tous les appareils de la première ligne (PLC_1, IO device_1 et PLC_2) sont raccordés à un réseau Ethernet externe (non représenté). SIMATIC Automation Tool API peut y accéder directement. On supposera également que le sous-réseau PROFINET raccordé à PLC_2 n'est pas raccordé au réseau externe.

SIMATIC Automation Tool API peut fournir des informations et des opérations pour tous les automates et les stations IO de cette configuration.

Le diagramme suivant montre la même configuration réseau et les appareils physiques du réseau :

Dans le diagramme ci-dessus, l'icône sémaphore montre la classe d'interface SIMATIC Automation Tool API qui représente le mieux chaque constituant du réseau :

  • Les CPU raccordées directement au réseau externe sont représentées par l'interface ICPU.

  • Les stations I/O raccordées directement au réseau externe sont représentées par l'interface IProfinetDevice.

  • Les sous-réseaux provenant d'une CPU sont représentés par l'interface IRemoteInterface.

  • Les stations I/O non raccordées directement au réseau externe (mais accessibles par une CPU) sont représentées par l'interface IBaseDevice.

  • Les modules I/O ou les modules de communication raccordés à une CPU ou une station IO sont représentés par l'interface IModule.


Prise en charge des appareils SIMATIC Automation Tool

Prise en charge des appareils SIMATIC Automation Tool

Ce chapitre contient des informations sur les sujets suivants :
  • Appareils et versions de firmware pris en charge et non pris en charge
  • Prise en charge des CPU de sécurité


Appareils et versions de firmware pris en charge et non pris en charge

Catalogue des appareils Gestion par SIMATIC Automation Tool des appareils et des versions de firmware non pris en charge
Démarrer Précédent Suivant

Appareils et versions de firmware pris en charge et non pris en charge

Catalogue des appareils

Vous pouvez afficher le catalogue des appareils avec la commande de menu "Aide > Voir le catalogue des appareils" de SIMATIC Automation Tool. Le catalogue des appareils montre les appareils Siemens pris en charge et les opérations SIMATIC Automation Tool prises en charge.

Le fichier du catalogue des appareils est un fichier Microsoft Excel. Vous devez disposer au moins de la version 2010 de Microsoft Excel pour pouvoir visualiser le catalogue des appareils correctement et utiliser des fonctions telles que le tri et le filtrage. Le fichier du catalogue des appareils est en lecture seule. Vous ne pouvez pas le modifier dans le but d'activer des fonctionnalités pour un appareil.

Le fichier catalogue des appareils comporte des colonnes dont les cellules sont cochées lorsque la condition est VRAI et vides lorsque la condition est FAUX. Lorsque la colonne "Prise en charge SAT" est cochée pour un appareil signifie que cet appareil est pris en charge par SIMATIC Automation Tool. Si la cellule Prise en charge SAT est vide, SIMATIC Automation Tool ne prend pas en charge l'appareil. La cellule Prise en charge SAT écrase les coches indiquant la prise en charge d'autres fonctions, p. ex. Failsafe.

Gestion par SIMATIC Automation Tool des appareils et des versions de firmware non pris en charge

Si vous connectez un appareil non pris en charge à votre réseau, SIMATIC Automation Tool identifie deux possibilités :

  • L'appareil n'est pas pris en charge

  • L'appareil est pris en charge, mais le firmware de l'appareil n'est pas pris en charge

Firmware non pris en charge

SIMATIC Automation Tool prend en charge l'appareil Siemens, mais la version de firmware est plus récente que la dernière version de firmware prise en charge par SIMATIC Automation Tool. Dans ce cas, SIMATIC Automation Tool exécute les actions suivantes :

  • Affiche l'appareil dans une ligne de la table des appareils

  • Affiche l'icône pour l'icône d'un appareil pris en charge dans la ligne

  • Restreint les opérations de l'outil aux opérations que SIMATIC Automation Tool prend en charge pour les versions de firmware antérieures

Appareil non pris en charge

SIMATIC Automation Tool ne prend pas en charge l'appareil. Dans ce cas, SIMATIC Automation Tool exécute les actions suivantes :

  • L'appareil est affiché dans une ligne de la table des appareils avec une partie de ses informations.

  • L'icône point d'interrogation s'affiche dans la ligne pour indiquer que l'appareil n'est pas pris en charge.

  • Prend en charge uniquement les opérations DCP lorsque l'appareil est connecté au même sous-réseau que la console de programmation qui exécute SIMATIC Automation Tool :

    • Scanner le réseau complet

    • Identifier

    • Configurer l'adresse IP

    • Mettre à jour le nom d'appareil PROFINET

    • Réinitialiser les paramètres de communication


Prise en charge des CPU de sécurité

Prise en charge des CPU de sécurité

Le tableau suivant montre toutes les CPU de sécurité et les versions de firmware prises en charge par SIMATIC Automation Tool :

Référence | Identificateur de type | Version de firmware | Première version de SIMATIC Automation Tool prenant en charge cette CPU
6ES7 212-1AF40-0XB0 | CPU 1212FC DC/DC/DC | V4.2 | V3.1
6ES7 212-1AF40-0XB0 | CPU 1212FC DC/DC/DC | V4.3 | V3.1 SP2
6ES7 212-1AF40-0XB0 | CPU 1212FC CC/CC/CC | V4.4 | V3.1 SP4
6ES7 212-1HF40-0XB0 | CPU 1212FC DC/DC/Rly | V4.2 | V3.1
6ES7 212-1HF40-0XB0 | CPU 1212FC DC/DC/Rly | V4.3 | V3.1 SP2
6ES7 212-1HF40-0XB0 | CPU 1212FC DC/DC/Rly | V4.4 | V3.1 SP4
6ES7 214-1AF40-0XB0 | CPU 1214FC DC/DC/DC | V4.1 | V3.1
6ES7 214-1AF40-0XB0 | CPU 1214FC DC/DC/DC | V4.2 | V3.1
6ES7 214-1AF40-0XB0 | CPU 1214FC DC/DC/DC | V4.3 | V3.1 SP2
6ES7 214-1AF40-0XB0 | CPU 1214FC CC/CC/CC | V4.4 | V3.1 SP4
6ES7 214-1HF40-0XB0 | CPU 1214FC DC/DC/Rly | V4.1 | V3.1
6ES7 214-1HF40-0XB0 | CPU 1214FC DC/DC/Rly | V4.2 | V3.1
6ES7 214-1HF40-0XB0 | CPU 1214FC DC/DC/Rly | V4.3 | V3.1 SP2
6ES7 214-1HF40-0XB0 | CPU 1214FC DC/DC/Rly | V4.4 | V3.1 SP4
6ES7 215-1AF40-0XB0 | CPU 1215FC DC/DC/DC | V4.1 | V3.1
6ES7 215-1AF40-0XB0 | CPU 1215FC DC/DC/DC | V4.2 | V3.1
6ES7 215-1AF40-0XB0 | CPU 1215FC DC/DC/DC | V4.3 | V3.1 SP2
6ES7 215-1AF40-0XB0 | CPU 1215FC DC/DC/DC | V4.4 | V3.1 SP4
6ES7 215-1HF40-0XB0 | CPU 1215FC DC/DC/Rly | V4.1 | V3.1
6ES7 215-1HF40-0XB0 | CPU 1215FC DC/DC/Rly | V4.2 | V3.1
6ES7 215-1HF40-0XB0 | CPU 1215FC DC/DC/Rly | V4.3 | V3.1 SP2
6ES7 215-1HF40-0XB0 | CPU 1215FC DC/DC/Rly | V4.4 | V3.1 SP4
6ES7 510-1SJ00-0AB0 | CPU 1510SP F-1 PN | V1.7 | V3.1
6ES7 510-1SJ00-0AB0 | CPU 1510SP F-1 PN | V1.8 | V3.1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V1.8 | V3.1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.0 | V3.1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.1 | V3.1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.5 | V3.1 SP1
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.6 | V3.1 SP2
6ES7 510-1SJ01-0AB0 | CPU 1510SP F-1 PN | V2.8 | V3.1 SP4
6ES7 511-1FK00-0AB0 | CPU 1511F-1 PN | V1.7 | V3.1
6ES7 511-1FK00-0AB0 | CPU 1511F-1 PN | V1.8 | V3.1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V1.8 | V3.1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.0 | V3.1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.1 | V3.1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.5 | V3.1 SP1
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.6 | V3.1 SP2
6ES7 511-1FK01-0AB0 | CPU 1511F-1 PN | V2.8 | V3.1 SP4
6ES7 511-1FK02-0AB0 | CPU 1511F-1 PN | V2.5 | V3.1 SP1
6ES7 511-1FK02-0AB0 | CPU 1511F-1 PN | V2.6 | V3.1 SP2
6ES7 511-1FK02-0AB0 | CPU 1511F-1 PN | V2.8 | V3.1 SP4
6ES7 511-1UK01-0AB0 | CPU 1511TF-1 PN | V2.1 | V3.1
6ES7 511-1UK01-0AB0 | CPU 1511TF-1 PN | V2.5 | V3.1 SP1
6ES7 511-1UK01-0AB0 | CPU 1511TF-1 PN | V2.6 | V3.1 SP2
6ES7 511-1UK01-0AB0 | CPU 1511TF-1 PN | V2.8 | V3.1 SP4
6ES7 512-1SK00-0AB0 | CPU 1512SP F-1 PN | V1.7 | V3.1
6ES7 512-1SK00-0AB0 | CPU 1512SP F-1 PN | V1.8 | V3.1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V1.8 | V3.1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.0 | V3.1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.1 | V3.1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.5 | V3.1 SP1
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.6 | V3.1 SP2
6ES7 512-1SK01-0AB0 | CPU 1512SP F-1 PN | V2.8 | V3.1 SP4
6ES7 513-1FL00-0AB0 | CPU 1513F-1 PN | V1.7 | V3.1
6ES7 513-1FL00-0AB0 | CPU 1513F-1 PN | V1.8 | V3.1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V1.8 | V3.1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.0 | V3.1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.1 | V3.1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.5 | V3.1 SP1
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.6 | V3.1 SP2
6ES7 513-1FL01-0AB0 | CPU 1513F-1 PN | V2.8 | V3.1 SP4
6ES7 513-1FL02-0AB0 | CPU 1513F-1 PN | V2.5 | V3.1 SP1
6ES7 513-1FL02-0AB0 | CPU 1513F-1 PN | V2.6 | V3.1 SP2
6ES7 513-1FL02-0AB0 | CPU 1513F-1 PN | V2.8 | V3.1 SP4
6ES7 513-2GL00-0AB0 | CPU 1513pro F-2 PN | V2.8 | V3.1 SP4
6ES7 515-2FM00-0AB0 | CPU 1515F-2 PN | V1.6 | V3.1
6ES7 515-2FM00-0AB0 | CPU 1515F-2 PN | V1.7 | V3.1
6ES7 515-2FM00-0AB0 | CPU 1515F-2 PN | V1.8 | V3.1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V1.8 | V3.1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.0 | V3.1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.1 | V3.1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.5 | V3.1 SP1
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.6 | V3.1 SP2
6ES7 515-2FM01-0AB0 | CPU 1515F-2 PN | V2.8 | V3.1 SP4
6ES7 515-2FM02-0AB0 | CPU 1515F-2 PN | V2.8 | V3.1 SP4
6ES7 515-2UM01-0AB0 | CPU 1515TF-2 PN | V2.1 | V3.1
6ES7 515-2UM01-0AB0 | CPU 1515TF-2 PN | V2.5 | V3.1 SP1
6ES7 515-2UM01-0AB0 | CPU 1515TF-2 PN | V2.6 | V3.1 SP2
6ES7 515-2UM01-0AB0 | CPU 1515TF-2 PN | V2.8 | V3.1 SP4
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.0 | V3.1
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.1 | V3.1
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.5 | V3.1 SP1
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.6 | V3.1 SP2
6ES7 516-2GN00-0AB0 | CPU 1516pro F-2 PN | V2.8 | V3.1 SP4
6ES7 516-3FN00-0AB0 | CPU 1516F-3 PN/DP | V1.5 | V3.1
6ES7 516-3FN00-0AB0 | CPU 1516F-3 PN/DP | V1.6 | V3.1
6ES7 516-3FN00-0AB0 | CPU 1516F-3 PN/DP | V1.7 | V3.1
6ES7 516-3FN00-0AB0 | CPU 1516F-3 PN/DP | V1.8 | V3.1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V1.8 | V3.1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.0 | V3.1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.1 | V3.1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.5 | V3.1 SP1
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.6 | V3.1 SP2
6ES7 516-3FN01-0AB0 | CPU 1516F-3 PN/DP | V2.8 | V3.1 SP4
6ES7 516-3FN02-0AB0 | CPU 1516F-3 PN/DP | V2.8 | V3.1 SP4
6ES7 516-3UN00-0AB0 | CPU 1516TF-3 PN/DP | V2.5 | V3.1 SP1
6ES7 516-3UN00-0AB0 | CPU 1516TF-3 PN/DP | V2.6 | V3.1 SP2
6ES7 516-3UN00-0AB0 | CPU 1516TF-3 PN/DP | V2.8 | V3.1 SP4
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V1.6 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V1.7 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V1.8 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.0 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.1 | V3.1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.5 | V3.1 SP1
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.6 | V3.1 SP2
6ES7 517-3FP00-0AB0 | CPU 1517F-3 PN/DP | V2.8 | V3.1 SP4
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.0 | V3.1
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.1 | V3.1
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.5 | V3.1 SP1
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.6 | V3.1 SP2
6ES7 517-3UP00-0AB0 | CPU 1517TF-3 PN/DP | V2.8 | V3.1 SP4
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V1.5 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V1.6 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V1.7 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V1.8 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.0 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.1 | V3.1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.5 | V3.1 SP1
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.6 | V3.1 SP2
6ES7 518-4FP00-0AB0 | CPU 1518F-4 PN/DP | V2.8 | V3.1 SP4
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.0 | V3.1 SP1
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.1 | V3.1 SP1
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.5 | V3.1 SP1
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.6 | V3.1 SP2
6ES7 518-4FP00-3AB0 | CPU 1518F-4 PN/DP ODK | V2.8 | V3.1 SP4
6ES7 518-4FX00-1AB0 | CPU 1518F-4 PN/DP MFP | V2.5 | V3.1 SP1
6ES7 518-4FX00-1AB0 | CPU 1518F-4 PN/DP MFP | V2.6 | V3.1 SP2
6ES7 518-4FX00-1AB0 | CPU 1518F-4 PN/DP MFP | V2.8 | V3.1 SP4
6ES7 672-5SC01-0YA0 | CPU 1505SP F | V2.0 | V3.1 SP2
6ES7 672-5SC01-0YA0 | CPU 1505SP F | V2.1 | V3.1 SP2
6ES7 672-5SC11-0YA0 | CPU 1505SP F | V2.5 | V3.1 SP2
6ES7 672-5SC11-0YA0 | CPU 1505SP F | V2.6 | V3.1 SP2
6ES7 672-5SC11-0YA0 | CPU 1505SP F | V2.7 | V3.1 SP4
6ES7 672-5WC11-0YA0 | CPU 1505SP TF | V2.5 | V3.1 SP2
6ES7 672-5WC11-0YA0 | CPU 1505SP TF | V2.6 | V3.1 SP2
6ES7 672-5WC11-0YA0 | CPU 1505SP TF | V2.7 | V3.1 SP4
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.0 | V3.1 SP2
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.1 | V3.1 SP2
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.5 | V3.1 SP2
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.6 | V3.1 SP2
6ES7 672-7FC01-0YA0 | CPU 1507S F | V2.7 | V3.1 SP4
6ES7 672-8FC01-0YA0 | CPU 1508S F | V2.6 | V3.1 SP2
6ES7 672-8FC01-0YA0 | CPU 1508S F | V2.7 | V3.1 SP4


Traitement des erreurs des messages de journal des événements

Messages spécifiques à l'appareil Messages de l'exportation des données PC
Réglage des CPU en mode RUN ou STOP Méthode SetPassword Exporter des informations depuis SIMATIC Automation Tool
Démarrer Précédent Suivant

Traitement des erreurs des messages de journal des événements

Le tableau suivant fournit des informations supplémentaires pour les messages de journal des événements. Si vous avez besoin de plus d'informations sur un message, copiez le message du journal des événements et recherchez le texte de message dans l'aide en ligne.

Message de journal des événements

Cause probable et action corrective

Le mot de passe CPU saisi n'est pas valide pour cette opération.

Vous avez entré un mot de passe CPU non valide pour l'opération. Entrez un mot de passe valide.

La CPU n'est pas passée en mode RUN.

Causes possibles : le projet TIA Portal n'est peut-être pas valide pour ce type de CPU ou aucun programme n'a été téléchargé sur la CPU. Voir le tampon de diagnostic pour plus de détails.

Voir le tampon de diagnostic pour plus de détails.

Impossible de faire passer la CPU à l'état MARCHE. Le programme utilisateur de la CPU est peut-être invalide. Voir le tampon de diagnostic pour plus de détails.

L'appareil n'accepte pas la nouvelle configuration.

L'appareil a rejeté une commande DCP pour définir l'adresse IP ou pour définir le nom PROFINET. Vérifiez les liaisons de communication réseau. Vérifiez l'adresse IP ou le nom PROFINET entré.

Échec de la connexion à l'appareil. Vérifier si l'adresse MAC est correcte.

SIMATIC Automation Tool n'a pas pu identifier l'appareil sur le réseau avec cette adresse MAC. Vérifiez l'adresse MAC que vous avez entrée et l'adresse MAC de l'appareil.

La connexion à cet appareil a été perdue prématurément.

SIMATIC Automation Tool n'est plus connecté à l'appareil. Vérifiez les liaisons de communication réseau.

Échec de l'opération et erreur renvoyée : ID#

Erreur interne de SIMATIC Automation Tool. Contactez votre représentant Siemens.

Échec de la déconnexion

SIMATIC Automation Tool n'a pas pu se déconnecter de l'appareil. Tentez à nouveau l'opération.

Le fichier de mise à jour du firmware spécifié n'est pas compatible avec l'appareil.

Le fichier de mise à jour du firmware sélectionné n'est pas compatible avec cet appareil. Sélectionnez une version de mise à jour du firmware correspondant à l'appareil spécifique.

Le fichier de mise à jour du firmware spécifié n'est pas compatible avec l'appareil car le matériel a besoin d'une version de firmware différente.

Le matériel de l'appareil requiert que le fichier de mise à jour du firmware soit différent de la version existante. Sélectionnez une version de mise à jour du firmware différente de la version existante.

Le fichier de mise à jour du firmware spécifié n'est pas compatible avec l'appareil car le matériel a besoin d'une version de firmware identique.

Le matériel de l'appareil requiert que le fichier de mise à jour du firmware soit de la même version que la version existante. Sélectionnez une version de mise à jour du firmware identique.

Le fichier de mise à jour du firmware spécifié n'est pas compatible avec l'appareil car le matériel a besoin d'une version de firmware plus récente.

Le fichier de mise à jour du firmware doit être d'une version plus récente que la version dans l'appareil. Sélectionnez une version de mise à jour du firmware plus récente.

Le fichier de mise à jour du firmware spécifié n'est pas compatible avec l'appareil car le matériel a besoin d'une version de firmware plus ancienne.

Le fichier de mise à jour du firmware doit être d'une version plus ancienne que la version dans l'appareil. Sélectionnez une version de mise à jour du firmware plus ancienne.

L'ID du module ID est invalide.

La méthode FirmwareUpdate a reçu une valeur pour le paramètre hardwareID qui ne correspond à aucun module. En appelant la méthode de mise à jour FirmwareUpdate, fournissez l'ID correcte du module.

Le module a refusé le fichier de mise à jour du firmware.

Sélectionnez un fichier de mise à jour du firmware qui est compatible avec le module à mettre à jour.

Le module est inaccessible. Chargez une configuration matérielle valide sur la CPU ou connectez-vous directement à l'appareil.

SIMATIC Automation Tool n'arrive pas à communiquer avec l'appareil. Chargez une configuration d'appareil valide sur l'appareil depuis TIA Portal. Vous pouvez aussi utiliser SIMATIC Automation Tool pour mettre à jour le programme de la CPU.

L'outil ne prend pas en charge la mise à jour du firmware de ce module.

SIMATIC Automation Tool ne prend pas en charge la mise à jour du firmware pour ce type de module. Le firmware de ce module ne peut pas être mis à jour avec SIMATIC Automation Tool

Le fichier de mise à jour du firmware a la même version de firmware que l'appareil.

Le fichier de mise à jour du firmware a la même version de firmware que l'appareil. Aucune mise à jour de firmware effectuée et aucune autre action requise.

Formatage de la carte mémoire non pris en charge sur cet appareil.

Vous ne pouvez pas formater la carte mémoire pour cet appareil.

L'adresse de la passerelle est invalide.

L'adresse de la passerelle est invalide avec le masque de sous-réseau et l'adresse IP. Vérifiez que l'adresse IP, le masque de sous-réseau et l'adresse de la passerelle sont corrects pour votre appareil et votre réseau.

Une erreur interne s'est produite.

Erreur interne de SIMATIC Automation Tool. Contactez votre représentant Siemens.

L'adresse du serveur cible est invalide.

SIMATIC Automation Tool n'a pas pu établir une connexion avec la CPU ou le pupitre IHM. Vérifiez l'adresse MAC ou l'adresse IP de l'appareil.

Impossible d'ouvrir le projet avec cette version de SIMATIC Automation Tool.

SIMATIC Automation Tool ne peut pas ouvrir un projet V1.x. ou un projet d'une version ultérieure. Voir la rubrique "Sauvegarde et ouverture de fichiers de projet .sat".

Signature invalide détectée. Veuillez réparer l'installation.

L'installation de SIMATIC Automation Tool est incomplète ou corrompue. Réinstallez SIMATIC Automation Tool.

L'adresse IP est invalide.

L'adresse IP ne respecte pas les exigences pour les adresses IP. Entrez une adresse IP valide.

L'adresse MAC est invalide.

L'adresse MAC ne respecte pas les exigences pour les adresses MAC. Entrez un adresse MAC valide.

Cette opération est interdite car un autre outil de configuration, par ex. TIA Portal, est déjà connecté.

Un seul outil logiciel peut se connecter à un appareil. Fermez l'autre connexion à l'appareil, p. ex. en commutant hors ligne depuis TIA Portal. Tentez à nouveau l'opération depuis SIMATIC Automation Tool.

Une instance ES déjà active ne prend pas en charge MultiES.

Cet appareil ne prend pas en charge simultanément plus d'une connexion en ligne de SIMATIC Automation Tool, TIA Portal ou d'un autre outil. Commutez hors ligne dans TIA Portal ou un autre outil, puis retentez l'opération depuis SIMATIC Automation Tool.

Le nombre maximal de connexions CPU est dépassé.

Cet appareil prend en charge simultanément un nombre limité de connexions en ligne de SIMATIC Automation Tool, TIA Portal ou d'un autre outil. La limite a été dépassée. Commutez hors ligne dans TIA Portal ou un autre outil, puis retentez l'opération depuis SIMATIC Automation Tool.

Les connexions de plusieurs outils à cette CPU ne sont pas prises en charge.

Cet appareil prend en charge simultanément un nombre limité de connexions en ligne de SIMATIC Automation Tool, TIA Portal ou d'un autre outil. Les connexions depuis des outils multiples ne sont pas prises en charge. Commutez hors ligne dans TIA Portal ou un autre outil, puis retentez l'opération depuis SIMATIC Automation Tool.

Le client veut écrire sur un objet, une variable ou un lien qui ne peut pas être modifié en mode RUN CPU.

La CPU ne peut pas effectuer cette opération en mode MARCHE. Mettre la CPU à l'état ARRET.

Opération exécutée.

Information seulement

L'opération a été annulée par l'utilisateur.

Information seulement

L'appareil ne prend pas en charge l'opération requise.

Vérifiez le catalogue des appareils pour les opérations prises en charge par l'appareil pour la version de firmware actuelle.

Paramètre hors plage.

Une application dénommée méthode API SetOperatingState avec une valeur invalide. Vous devez appeler cette méthode avec "Stop" ou "Run" pour l'état du mode de fonctionnement.

Le nom PROFINET est invalide.

Le nom PROFINET est invalide. Saisissez un nom PROFINET valide et unique (non partagé par d'autres appareils).

Aucune connexion n'a pu être établie avec l'appareil

SIMATIC Automation Tool n'a pas pu se connecter à l'appareil. Vérifiez vos connexions réseau. Vérifiez qu'un autre outil logiciel, tel que TIA Portal, n'a pas de connexion en ligne à l'appareil. Si c'est le cas commutez hors ligne à partir de l'autre outil. Vérifiez que l'appareil se trouve sur le sous-réseau que vous avez spécifié. Vérifiez votre routage, si applicable. Paramétrez votre carte d'interface réseau sur "Auto" si ce n'est pas déjà fait.

L'opération a expiré.

La CPU n'a pas terminé l'opération. Tentez à nouveau l'opération. Si l'opération continue à expirer, contrôlez votre appareil et la communication de réseau.

La connexion n'est plus légitime car le mot de passe a expiré.

Le mot de passe de la CPU a expiré en raison de l'inactivité. Entrez le mot de passe de la CPU et retentez l'opération.

Impossible de configurer l'adresse IP

SIMATIC Automation Tool n'a pas pu définir l'adresse IP. Vérifiez que l'adresse IP est valide et qu'elle est unique. Vérifiez que la configuration de l'appareil dans le projet STEP 7 permet de paramétrer l'adresse IP directement sur l'appareil.

Impossible de configurer le nom PROFINET

SIMATIC Automation Tool n'a pas pu définir le nom PROFINET. Vérifiez que le nom PROFINET est valide et qu'il est unique. Vérifiez que la configuration de l'appareil dans le projet STEP 7 permet de paramétrer l'adresse IP directement sur l'appareil.

Le masque de sous-réseau est invalide.

Le masque de sous-réseau ne répond pas aux exigences pour un masque de sous-réseau valide. Entrez un masque de sous-réseau valide.

Cet appareil n'est pas pris en charge ou n'a pu être initialisé.

SIMATIC Automation Tool ne prend pas en charge cet appareil ou n'a pas pu initialiser l'appareil. Vérifiez le catalogue des appareils pour les appareils et les versions pris en charge.

L'appareil n'accepte pas le fichier de mise à jour du firmware.

L'appareil a rejeté la mise à jour du firmware. Vérifiez que le fichier de mise à jour du firmware est valide pour votre appareil. Si vous mettez à jour depuis l'ancien format, assurez-vous de sélectionner le fichier .upd d'en-tête pour le champ "New Firmware Version". Testez également si l'appareil fonctionne correctement.

Échec de compression du contenu du dossier

SIMATIC Automation Tool n'a pas pu comprimer le contenu du dossier. Vérifiez qu'il y a assez d'espace dans le système de fichiers pour le fichier zip. Vérifiez également les autorisations du dossier de fichier. L'une de ces deux conditions pourrait être la source du problème.

Erreur d'écriture dans le fichier

SIMATIC Automation Tool n'a pas pu sauvegarder le fichier dans la console de programmation. Vérifiez l'espace fichier et les autorisations de fichier sur votre console de programmation.

Erreur de création du fichier

SIMATIC Automation Tool n'a pas pu créer le fichier dans la console de programmation. Vérifiez l'espace fichier et les autorisations de fichier sur votre console de programmation.

Erreur à la suppression du fichier

SIMATIC Automation Tool n'a pas pu supprimer le fichier de la console de programmation. Vérifiez les autorisations de fichier sur votre console de programmation.

Erreur à la suppression du dossier

SIMATIC Automation Tool n'a pas pu supprimer le dossier de la console de programmation. Vérifiez les droits d'accès utilisateur sur votre console de programmation. Assurez-vous que le dossier n'est pas ouvert.

Erreur de création du dossier

SIMATIC Automation Tool n'a pas pu créer un dossier temporaire pour sauvegarder les données de maintenance. Vérifiez l'espace disque sur votre console de programmation.

Vous devez acquérir une licence pour pouvoir utiliser l'API.

Vous n'avez pas de licence valide pour utiliser l'API. Vous pouvez utiliser la licence d'essai gratuite de 21 jours pendant 21 jours. Sinon, acquérez une licence SIMATIC Automation Tool ou le Software Developers Kit (SDK) pour utiliser l'API.

Valeur de délai d'attente invalide. Les valeurs valides sont comprises entre 180 et 999 secondes.

Dans les Options de communication, la valeur d'expiration du délai pour les opérations de communication se situe hors de la plage. Définissez la valeur sur un nombre de 180 à 999 secondes.

Aucune donnée à sauvegarder sur l'appareil

SIMATIC Automation Tool ne peut pas créer une sauvegarde si l'appareil n'a pas de programme utilisateur. Chargez votre projet de STEP 7 sur l'appareil ou mettez à jour le programme depuis SIMATIC Automation Tool. Si vous avez un fichier de sauvegarde préalable pour cet appareil, restaurez-le depuis SIMATIC Automation Tool.

Erreur de lecture du flux

SIMATIC Automation Tool n'a pas pu lire depuis un fichier projet préalablement sauvegardé. Vérifiez que le fichier projet a une version compatible de SIMATIC Automation Tool. Ouvrez un projet valide s'il y en a un de disponible.

Erreur d'écriture vers le flux

SIMATIC Automation Tool n'a pas pu écrire et sauvegarder un fichier projet pour le projet actuel. Vérifiez l'espace disque sur votre console de programmation.

Le fichier de projet HMI est non valide ou incomplet.

Vous tentez d'effectuer une mise à jour du programme IHM. Le fichier de mise à jour du programme est corrompu. Vous ne pouvez pas restaurer ce fichier.

Le projet IHM n'est pas compatible avec l'appareil.

Vous tentez d'effectuer une mise à jour du programme de pupitre IHM qui n'est pas compatible avec le pupitre IHM. Vous pouvez uniquement effectuer une mise à jour du programme qui correspond au matériel de votre pupitre IHM.

Une opération sur fichier n'a pas été terminée à cause d'une protection en écriture.

L'emplacement pour l'opération sur fichier est protégé en écriture. Choisissez un emplacement de dossier sur votre console de programmation qui n'est pas protégé en écriture.

Échec de la modification de l'adresse IP de cet appareil

SIMATIC Automation Tool n'a pas pu définir l'adresse IP. Entrez une adresse IP valide. Vérifiez vos connexions de communication réseau.

Échec de la modification du nom PROFINET de cet appareil

SIMATIC Automation Tool n'a pas pu définir le nom PROFINET. Saisissez un nom PROFINET valide. Vérifiez vos connexions de communication réseau.

Requête annulée

Information seulement

L'appareil ne prend pas encore en charge le transfert de compléments (add-ons).

Le fichier de mise à jour du programme contient des compléments (addons). Le pupitre IHM que vous tentez de mettre à jour ne prend pas en charge les addons. Vous pouvez uniquement mettre à jour ce pupitre IHM avec un programme qui ne possède pas d'add-ons.

Attribut introuvable

Une opération IHM tente de lire ou d'écrire depuis/vers un emplacement qui n'existe pas. Vérifiez que le fichier de mise à jour du programme ou le fichier de sauvegarde sont valides pour l'IHM.

Tampon trop petit pour toutes les données demandées

Le pupitre IHM a signalé qu'un tampon interne était trop petit. Contactez l'Assistance client pour votre pupitre IHM.

Le certificat IHM a expiré.

Le certificat IHM n'est plus valide. Actualisez le certificat dans le pupitre IHM.

Erreur générale lors de la vérification de la signature du certificat

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Le certificat du fichier est invalide.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Certificat pas encore valide

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Le certificat a été annulé.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Connexion client requise pour l'action établie

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Échec lors d'une opération de lecture de fichier.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Échec lors d'une opération d'écriture de fichier.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Firmware du type non installé

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Firmware du type non pris en charge

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Le fichier de firmware n'est pas valide pour cet appareil.

Vous avez sélectionné un fichier de mise à jour du firmware invalide pour l'appareil. Utilisez un fichier de mise à jour du firmware qui corresponde à votre appareil et à sa version.

Le module additionnel n'est pas compatible avec l'appareil/le firmware

Le fichier de mise à jour du programme contient des compléments (addons). L'addon du fichier de mise à jour du programme n'est pas compatible avec le pupitre IHM que vous tentez de mettre à jour. Vous pouvez uniquement mettre à jour un programme qui ne possède pas d'addon ou des addons compatibles.

Arguments invalides vers méthode

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Chemin d'accès au fichier invalide

Le chemin de fichier n'existe pas ou est invalide. Fournissez un chemin d'accès au fichier valide.

Échec du contrôle de licence.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Un volume logique manque.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Un volume logique est plein.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Objet introuvable

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Ressources insuffisantes pour exécuter l'opération requise

L'opération demandée requiert plus de ressources système que celles disponibles. Fermez quelques applications sur votre console de programmation et réessayez.

Espace insuffisant dans le système de fichiers

Le système de fichiers ne dispose pas de suffisamment d'espace pour l'opération demandée. Supprimez des fichiers pour créer de l'espace sur le système de fichiers ou choisissez un autre système de fichiers avec plus d'espace.

Transfert distant désactivé

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Sauvegarde de secours impossible, par exemple en raison d'un état incorrect de l'appareil ou d'un fichier de firmware incorrect.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Restauration de secours impossible, par exemple en raison d'un état incorrect de l'appareil.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

L'installation runtime a été interrompue.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Runtime n'est pas installé.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Problème général de gestion de la bibliothèque de sécurité

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Un autre service est déjà actif.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Échec général de la vérification de la signature du fichier

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

La signature du fichier est invalide.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Le fichier n'est pas signé.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Échec lors d'une opération de lecture d'unité de stockage.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Échec lors d'une opération d'écriture d'unité de stockage.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Échec de la conversion de type

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Erreur inattendue sur système d'exploitation.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Aucun complément (add-on) portant ce nom n'est installé.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Aucune application portant cet ID n'est installée.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Aucun complément d'application portant cet ID n'est installé.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Un complément d'application fait référence à une application qui n'est pas installée.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Le nom de fichier Recette est invalide.

Vérifiez le nom du fichier. Fournissez un nom de fichier valide.

Espace de stockage insuffisant pour cette opération

La carte mémoire SIMATIC SD dans la CPU ne possède pas suffisamment d'espace mémoire pour stocker le fichier. Supprimez le contenu externe de la carte mémoire ou utilisez une carte mémoire avec une capacité supérieure.

Une image du firmware incompatible plus récente existe sur l'appareil cible. Une mise à jour du système d'exploitation pourrait entraîner la suppression des données de recette, des données utilisateur et de certains paramétrages du système, et ce de façon irréversible.

Le firmware sur cet appareil est plus récent que la mise à jour du firmware que vous avez choisie. Si vous effectuez cette mise à jour du firmware, vous risquez de supprimer des données de recette, des données utilisateur et certains paramètres système. Vérifiez qu'il s'agit de la mise à jour de firmware souhaitée avant de l'effectuer.

Une ancienne image incompatible du firmware existe sur l'appareil cible. Une mise à jour du système d'exploitation pourrait causer une suppression irréversible des données recette, des données utilisateur et de certains paramétrages du système.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Un nouveau runtime incompatible existe sur l'appareil cible.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Un ancien runtime incompatible existe sur l'appareil cible.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Aucun runtime installé sur l'appareil cible.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Mémoire insuffisante sur l'appareil cible.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

L'orientation de l'affichage est incorrecte (portrait configuré, paysage sur l'appareil IHM).

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

L'orientation de l'affichage est incorrecte (paysage configuré, portrait sur l'appareil IHM).

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Erreur générale. Compilez à nouveau le projet et recommencez le téléchargement.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Erreur générale. Recommencez le téléchargement.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Aucun runtime installé sur l'appareil cible.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

L'appareil configuré n'est pas compatible avec l'appareil cible.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Un runtime incompatible est installé sur l'appareil cible.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Un runtime invalide a été installé. Le runtime installé ne peut pas traiter le projet. Installez le runtime manuellement sur l'appareil cible.

Erreur interne du pupitre IHM. Contactez l'Assistance client pour votre pupitre IHM.

Une erreur s'est produite et l'identité de l'appareil n'a pas pu être déterminée.

SIMATIC Automation Tool n'a pas pu déterminer l'identité de cette CPU.

L'identité de l'appareil a été modifiée. Veuillez réanalyser l'ensemble du réseau.

L'identité d'appareil de la CPU n'est plus la même que lorsque SIMATIC Automation Tool s'est connecté à la CPU. Scannez à nouveau le réseau pour déterminer l'identité réelle de l'appareil pour SIMATIC Automation Tool.

L'interface connectée est introuvable.

L'interface réseau sélectionnée n'existe plus. Vérifiez les connexions de votre interface réseau et testez son fonctionnement. Une fois établie la validité de l'interface réseau, sélectionnez cette interface réseau depuis SIMATIC Automation Tool.

L'appareil n'est pas sélectionné.

Aucun appareil n'est sélectionné. Vous devez sélectionner un appareil dans la table des appareils.

Les opérations relatives à la sécurité requièrent le mot de passe de sécurité.

Vous devez fournir le mot de passe CPU F pour effectuer l'opération de sécurité.

Erreur d'application interne

Une erreur interne s'est produite lors de la définition d'un mot de passe. Définissez le mot de passe sur un mot de passe valide et vérifiez que l'appareil est protégé.

Le mot de passe entré pour la CPU est invalide.

Entrez un mot de passe CPU valide.

L'adresse IP de l'appareil est un doublon sur le réseau.

SIMATIC Automation Tool a trouvé une adresse IP en double sur le réseau, peut-être en raison d'une modification externe. Triez votre table des appareils selon les adresses IP pour trouver l'adresse en double. Corrigez l'une des adresses pour ne pas avoir d'adresse en double.

L'adresse IP saisie se trouve en double sur le réseau.

Vous avez entré une adresse IP qui est identique à une autre adresse IP. Entrez une adresse IP unique sur le réseau. Triez votre table des appareils selon les adresses IP pour trouver l'adresse en double.

Nom PROFINET en double

Entrez un nom PROFINET unique sur le réseau.

Les opérations de sécurité doivent être confirmées.

Pour effectuer l'une des opérations suivantes pour une CPU F, vous devez confirmer l'opération :

Restaurer les paramètres d'usine
- Restaurer
- Mise à jour du programme
- Formatage de la carte mémoire

Si vous avez obtenu ce message d'une application utilisant l'API, vous devez définir la propriété SelectedConfirmed pour la CPU.

Aucune carte SD n'est présente ou la carte SD est déjà vide.

Le formatage d'une carte mémoire requiert la présence d'une carte mémoire SD SIMATIC. Insérez une carte mémoire SD SIMATIC dans la CPU si aucune ne s'y trouve. Si la carte est présente, mais ne contient aucun fichier, vous pouvez ignorer ce message.

Le fichier de programme est invalide ou ne peut pas être ouvert par cette version de SIMATIC Automation Tool.

SIMATIC Automation Tool ne peut pas accéder au fichier de mise à jour du programme par le chemin indiqué dans la boîte de dialogue Options. Vérifiez le nom de chemin dans les paramètres de mise à jour du programme de la boîte de dialogue Options.

Résultat de la comparaison CRC : les signatures de sécurité globales en ligne et hors ligne ne correspondent pas.

La mise à jour du programme a échoué. Le fichier de mise à jour du programme ne correspond pas au programme dans la CPU après l'opération de mise à jour du programme. Procédez comme suit :

  1. Restaurer les paramètres d'usine de la CPU

  2. Formatez la carte mémoire si vous en utilisez une.

  3. Tentez une nouvelle mise à jour du programme.

Si l'erreur persiste, vous ne pouvez pas utiliser ce fichier de mise à jour du programme.

Le fichier de programme ne peut pas être chargé sur un appareil plus ancien.

La version d'appareil de l'appareil cible est plus ancienne que la version du fichier de programme. Mettez l'appareil à niveau avec une nouvelle version ou choisissez un fichier de mise à jour du programme compatible avec l'ancien appareil.

La suite IP du projet est inaccessible

Vérifiez l'adresse IP, le masque de sous-réseau et l'adresse de la passerelle. Corrigez toutes les valeurs incorrectes pour votre réseau.

La suite IP est inaccessible.

Vérifiez l'adresse IP, le masque de sous-réseau et l'adresse de la passerelle. Corrigez toutes les valeurs incorrectes pour votre réseau.

Le fichier de sauvegarde contient une suite d'IP qui n'est pas accessible via des communications PROFINET.

Après l'opération de restauration, SIMATIC Automation Tool ne peut plus accéder à l'appareil. La suite IP dans le projet restauré (adresse IP, masque de sous-réseau, passerelle) ne correspond pas à l'appareil et au sous-réseau réels. Corrigez et définissez les valeurs de la suite IP pour l'appareil. Paramétrez la carte d'interface réseau sur "Auto" si ce n'est pas déjà fait.

L'adresse IP dans le nouveau fichier de programme n'est pas unique pour le réseau.

Résolvez le conflit d'adresse IP. Paramétrez un des appareils sur une adresse IP différente.

Un programme de sécurité ne peut pas être chargé sur une CPU standard.

Vous ne pouvez pas charger un programme de sécurité sur une CPU standard. Vous pouvez uniquement charger un programme standard sur une CPU standard.

Le contrôle de diversité sur le mot de passe entré de la CPU a échoué.

SIMATIC Automation Tool n'a pas pu établir une connexion avec la CPU. Les données d'identification d'appareil telles que l'adresse MAC ou le numéro de série diffèrent entre la table Appareils SIMATIC Automation Tool et l'appareil réel. Scanner le réseau.

Le fichier de sauvegarde n'est pas valide pour cet appareil.

Le fichier de sauvegarde n'est pas valide pour cette CPU. Sélectionnez un fichier de sauvegarde qui corresponde au type d'appareil de votre CPU.

L'extension du fichier de sauvegarde n'est pas valide pour cet appareil.

L'extension du fichier est invalide. Sélectionnez un fichier de sauvegarde avec l'extension .s7pbkp.

Échec de l'opération.

L'une des opérations suivantes a échoué :

- Restaurer les paramètres d'usine
- RAZ mémoire
- Formatage de la carte mémoire
Si applicable, mettez l'appareil en mode ARRET pour vous assurer que la carte mémoire SIMATIC se trouve dans la CPU. Tentez à nouveau l'opération.

Le fichier de firmware n'est pas valide pour cet appareil.

Sélectionnez un fichier de mise à jour du firmware correspondant à l'appareil.

Impossible de valider le mot de passe du fichier de programme.

Le "mot de passe dans le fichier de programme" que vous avez entré pour un fichier de mise à jour du programme ne correspond à aucun des mots de passe du fichier programme. Pour mettre à jour un programme, vous devez saisir un mot de passe valide contenu dans le fichier programme.

Le fichier de programme contient une adresse IP qui existe déjà sur le réseau.

SIMATIC Automation Tool ne vous autorise pas à restaurer un fichier programme qui génère une adresse IP double. Modifiez l'adresse IP identique de l'appareil concerné ou restaurez un autre fichier programme.

Mot de passe du fichier de programme manquant

Vous devez saisir un mot de passe valide pour le programme.

Mot de passe du fichier de programme invalide

Vous devez saisir un mot de passe valide pour le programme.

L'opération a été annulée par l'utilisateur.

Information seulement

Le fichier de programme n'est pas valide pour cet appareil.

Sélectionnez un fichier de mise à jour du programme qui corresponde à votre appareil.

Le mot de passe du fichier de programme entré est invalide ou insuffisant pour terminer l'opération.

Entrez un mot de passe pour le fichier programme avec un niveau d'accès suffisant pour l'opération.

L'appareil requis est introuvable dans le réseau.

SIMATIC Automation Tool n'a pas pu trouver l'appareil sur le réseau. Vérifiez l'interface réseau, les connexions réseau et l'adresse IP. Fermez S7‑PLCSIM ou tout logiciel de simulation en cours d'exécution.

Vous ne pouvez pas ajouter un appareil qui existe déjà.

Vous avez essayé d'intégrer un appareil qui se trouve déjà dans la table des appareils. Vous pouvez uniquement intégrer un appareil qui ne se trouve pas encore dans la table des appareils.

Impossible de modifier l'adresse IP, car elle existe déjà dans le réseau.

Vous avez essayé de définir une adresse IP à l'aide d'une adresse IP déjà utilisée. Spécifiez une adresse unique pour l'adresse IP de l'appareil.

Le nom PROFINET ne peut pas être modifié car il existe déjà sur le réseau

Vous avez essayé de définir le nom PROFINET à l'aide d'un nom PROFINET déjà utilisé. Sélectionnez un nom PROFINET unique.

Aucune connexion n'a pu être établie avec l'appareil

SIMATIC Automation Tool n'a pas pu établir une connexion avec l'appareil. Vérifiez l'interface réseau, les connexions réseau et l'adresse IP.

L'appareil n'a pas pu être entièrement initialisé.

SIMATIC Automation Tool n'a pas pu initialiser l'appareil. Vérifiez que l'appareil se trouve sur le même réseau que votre console de programmation.

SIMATIC Automation Tool ne prend pas en charge les CPU avec des programmes plus récents.

Vous essayez d'utiliser un programme d'une version plus récente que celle prise en charge par SIMATIC Automation Tool. Vérifiez le catalogue des appareils pour déterminer la prise en charge de version de votre appareil.

La suite IP n'est pas valide.

La combinaison d'adresse IP, de passerelle et de sous-réseau est invalide. Entrez une suite IP valide.

Le fichier de sauvegarde sélectionné n'est pas compatible avec cet appareil

Le fichier de sauvegarde que vous avez choisi n'est pas compatible avec votre appareil. Vérifiez que le fichier de sauvegarde correspond à l'appareil et à sa version.

L'adresse IP a été modifiée ou existe en double dans le réseau.

L'adresse IP de cet appareil a été modifiée depuis le dernier scan réseau ou un autre appareil a la même adresse IP. Scannez le réseau et résolvez les conflits d'adresse IP.

Aucun appareil n'a été trouvé par le scan.

SIMATIC Automation Tool n'a trouvé aucun appareil sur le scan réseau. Vérifiez l'interface réseau et les connexions réseau. Recherchez les appareils dans le sous-réseau. Fermez S7‑PLCSIM ou tout logiciel de simulation en cours d'exécution.

Résultat de la comparaison CRC : les signatures de sécurité globales en ligne et hors ligne correspondent.

Information seulement : L'opération réalisée avec une CPU F a réussi. Vous n'avez pas besoin d'exécuter une autre action.

Impossible d'ajouter l'appareil.

SIMATIC Automation Tool n'a pas pu intégrer l'appareil que vous avez entré dans la table des appareils. Vérifiez que l'adresse IP est unique et que les données entrées correspondent à l'appareil de votre réseau.

Vous ne pouvez pas ajouter un appareil dont l'adresse IP existe déjà sur le réseau.

Vous avez essayé d'intégrer un appareil avec une adresse IP appartenant à un autre appareil. Vous devez saisir une adresse IP unique lorsque vous entrez un appareil.

La nouvelle adresse de la passerelle est invalide.

Vous avez entré une adresse de passerelle invalide. Entrez une adresse de passerelle valide pour votre réseau.

La nouvelle adresse IP est invalide.

Vous avez entré une nouvelle adresse IP invalide. Entrez une adresse IP valide.

Le nouveau nom PROFINET est invalide.

Vous avez entré un nouveau nom PROFINET non valide. Saisissez un nom PROFINET valide.

Le nouveau masque de sous-réseau est invalide.

Vous avez entré un masque de sous-réseau invalide. Entrez un masque de sous-réseau valide pour votre appareil sur le réseau.

Les signatures de sécurité n'ont pas pu être lues

Les CPU F comprennent une signature de sécurité. SIMATIC Automation Tool n'a pas pu lire la signature de sécurité de l'appareil. Votre opération ne peut pas se poursuivre avec cette erreur.

Formatez la carte mémoire si vous en utilisez une. Restaurez l'appareil aux paramètres d'usine. Puis, répétez l'opération.

Interface réseau invalide ou non spécifiée

Sélectionnez une interface réseau valide dans la liste déroulante de votre configuration de communication.

Le mot de passe entré n'est pas suffisant pour terminer l'opération.

Vous avez besoin d'un niveau d'accès supérieur pour effectuer cette opération. Vous définissez les mots de passe pour les niveaux d'accès dans le projet STEP 7. Entrez un mot de passe avec un niveau d'accès suffisant pour l'opération que vous souhaitez effectuer.

Le fichier de programme ne contient pas de mots de passe.

Le fichier de programme ne contient pas de mots de passe. Ce message est informatif et ne requiert aucune action.

Une exception non traitée s'est produite lors du traitement de cette opération.

Une erreur inattendue s'est produite. Scannez à nouveau le réseau et retentez l'opération. Redémarrez SIMATIC Automation Tool si un scan ne corrige pas le problème. Si le problème persiste, contactez votre représentant Siemens.

L'ouverture de projets avec le format de fichier de V1.x n'est pas prise en charge.

Vous ne pouvez pas ouvrir un projet SIMATIC Automation Tool V1.x. Vous pouvez uniquement ouvrir des projets de version V2.0 ou supérieure.

Le projet ouvert a été annulé.

Vous avez commencé à ouvrir un projet et vous avez annulé l'opération. Aucune autre action n'est nécessaire.

Un mot de passe de fichier de programme est nécessaire.

Vous devez saisir le mot de passe pour le fichier programme.

Impossible d'ouvrir, de lire ou de traiter le fichier de sauvegarde.

SIMATIC Automation Tool n'a pas pu ouvrir, lire ou traiter le fichier de sauvegarde. Utilisez un fichier de sauvegarde qui corresponde à votre appareil et à sa version.

Fichier de programme incompatible avec cet appareil.

Le fichier de programme n'est pas compatible avec cet appareil. Utilisez un fichier de programme qui corresponde à votre appareil et à sa version.

SIMATIC Automation Tool ne prend pas en charge la configuration matérielle du projet STEP 7.

SIMATIC Automation Tool ne prend pas en charge la configuration matérielle du programme STEP 7 de l'appareil. Vérifiez la configuration de l'appareil dans le projet STEP 7 et vérifiez la prise en charge de version de votre appareil dans le catalogue des appareils.

La configuration matérielle du programme n'est pas valide pour l'appareil connecté.

La configuration matérielle du programme STEP 7 n'est pas valide pour l'appareil sur le réseau. Vérifiez la configuration de l'appareil dans le projet STEP 7 et vérifiez la prise en charge de version de votre appareil dans le catalogue des appareils.

Impossible de charger le système de fichiers. Tentez une mise hors tension puis sous tension de la CPU.

SIMATIC Automation Tool n'a pas pu charger les fichiers depuis la CPU. Les fichiers de la CPU peuvent être corrompus. Mettez la CPU hors tension, puis sous tension. Si le problème persiste, restaurez les paramètres d'usine de la CPU.

SNMP : Un mot de passe invalide a été saisi.

Vous avez entré un mot de passe invalide dans le profil SNMP version 3. Entrez un mot de passe valide pour l'appareil.

SNMP : La valeur n'existe pas.

Une valeur SNMP est invalide. Vérifiez vos paramètres de profil SNMP.

SNMP : Impossible de modifier la valeur

Dans un profil SNMP, vous avez essayé de modifier une valeur en une valeur invalide. Entrez une valeur valide.

SNMP : Impossible de modifier la valeur qui est en lecture seule.

Vous avez essayé de modifier une valeur en lecture seule dans un profil SNMP. Vous ne pouvez pas modifier cette valeur.

Algorithme d'authentification invalide

L'algorithme d'authentification dans le profil SNMP version 3 est invalide. Sélectionnez un algorithme d'authentification valide dans la liste déroulante de la boîte de dialogue "Ajouter" du profil SNMP .

Mot de passe d'authentification invalide

Le mot de passe d'authentification dans le profil SNMP version 3 est invalide. Entrez un mot de passe d'authentification valide dans la boîte de dialogue "Ajouter" du profil SNMP .

Nom de contexte invalide

Le nom de contexte dans le profil SNMP version 3 est invalide. Entrez un nom de contexte valide dans la boîte de dialogue "Ajouter" du profil SNMP.

Algorithme de confidentialité invalide

L' algorithme de confidentialité dans le profil SNMP version 3 est invalide. Entrez un algorithme de confidentialité valide dans la boîte de dialogue "Ajouter" du profil SNMP .

Mot de passe de confidentialité invalide

Le mot de passe de confidentialité dans le profil SNMP version 3 est invalide. Entrez un mot de passe de confidentialité valide dans la boîte de dialogue "Ajouter" du profil SNMP .

Nom de profil invalide

Le nom de profil dans la version de profil SNMP 1, 2, ou 3 est invalide. Entrez un nom de profil valide dans la boîte de dialogue "Ajouter" du profil SNMP.

Communauté de lecture invalide

La communauté de lecture dans la version de profil SNMP 1 ou 2 est invalide. Entrez une communauté de lecture valide dans la boîte de dialogue "Ajouter du profil SNMP".

Niveau de sécurité invalide

Le niveau de sécurité dans le profil SNMP version 3 est invalide. Entrez un niveau de sécurité valide dans la boîte de dialogue "Ajouter" du profil SNMP.

Adresse IP du serveur invalide

L'adresse IP de serveur dans la version de profil SNMP 1, 2, ou 3 est invalide. Entrez une adresse IP de serveur valide dans la boîte de dialogue "Ajouter" du profil SNMP.

Port du serveur invalide

Le port de serveur dans la version de profil SNMP 1, 2, ou 3 est invalide. Entrez un port de serveur valide dans la boîte de dialogue "Ajouter" du profil SNMP.

Version SNMP invalide

La version SNMP est invalide. Sélectionnez 1, 2, ou 3 pour le numéro de version SNMP dans la boîte de dialogue "Ajouter" du profil SNMP.

Nom d'utilisateur invalide

Le nom d'utilisateur dans le profil SNMP version 3 est invalide. Entrez un nom d'utilisateur valide dans la boîte de dialogue "Ajouter" du profil SNMP.

Communauté d'écriture invalide

La communauté d'écriture dans la version de profil SNMP 1 ou 2 est invalide. Entrez une communauté d'écriture valide dans la boîte de dialogue "Ajouter" du profil SNMP .

Ce nom de profil existe déjà.

Le nom de profil dans la version de profil SNMP 1, 2, ou 3 appartient à un autre profil. Entrez un nom de profil unique dans la boîte de dialogue "Ajouter" du profil SNMP .

Cette méthode est obsolète. Utilisez la nouvelle méthode de même nom.

Sans objet.

Profil invalide

Le profil SNMP est invalide pour l'appareil. Vérifiez la configuration dans la boîte de dialogue "Ajouter" et effectuez les changements nécessaires.

Impossible de déclencher le transfert du firmware

L'opération de mise à jour du firmware a échoué. Vérifiez toutes les connexions réseau. Vérifiez que le fichier de mise à jour du firmware est valide pour l'appareil. Réessayez la mise à jour du firmware.

Une erreur SNMP s'est produite.

Une erreur s'est produite dans les communications SNMP avec l'appareil. Vérifiez vos paramètres de profil SNMP. Si le problème persiste, contactez l'assistance client pour l'appareil.

Canal de transfert invalide

Le canal de transfert IHM sélectionné est invalide. Définissez PN_IE ou Ethernet pour le type de HMITransferChannel pour la méthode API SetTransferChannel.

L'appareil a retourné une adresse MAC invalide

SIMATIC Automation Tool n'a pas pu déterminer l'adresse MAC pour l'adresse IP fournie. Cette erreur ne peut se produire que lorsque vous intégrez un appareil par l'adresse IP. Vérifiez que vous intégrez un appareil disponible sur votre réseau. Vérifiez que l'adresse IP est correcte pour l'appareil. Vous pouvez aussi intégrer l'appareil à l'aide de son adresse MAC.

La mise à jour de noms IP et PROFINET en double a échoué.

SIMATIC Automation Tool connaît une erreur interne. Scanner à nouveau le réseau. Si le problème persiste, contactez votre représentant Siemens.

Le nom PROFINET entré existe en double dans le réseau.

Un autre appareil utilise ce nom PROFINET. Entrez un nom PROFINET unique.

Une erreur s'est produite durant une sauvegarde.

La CPU n'a pas fourni des données de sauvegarde valides à SIMATIC Automation Tool. Mettez la CPU hors tension, puis sous tension et réessayez. Si le problème persiste, contactez votre représentant Siemens.

L'objet Failsafe Control sur la CPU n'a pas le type correct.

Le programme actuel dans la CPU F n'est pas un programme de sécurité ou il est corrompu. Téléchargez le programme de sécurité depuis TIA Portal ou mettez à jour le programme depuis SIMATIC Automation Tool.

L'adresse IP spécifiée est invalide ou déjà utilisée par la NIC.

Vous avez entré une adresse invalide ou utilisée par un autre appareil. Entrez une adresse IP unique valide.

La mise à jour du firmware a échoué en raison de contrôles d'intégrité.

Le fichier .upd de mise à jour du firmware est corrompu. Utilisez un fichier .upd valide pour la mise à jour du firmware.

Type de sauvegarde invalide

La sauvegarde HMI est invalide. Les types de sauvegarde valides pour un IHM sont : complète, recette ou données de gestion des utilisateurs. Fournissez un type de sauvegarde valide.

Un ou plusieurs tampons de diagnostic d'appareil sont inaccessibles

Pendant l' exportation des diagnostics de l'appareil, SIMATIC Automation Tool a été dans l'impossibilité d'accéder à un ou plusieurs tampons de diagnostic. Vérifiez que les appareils de la table des appareils sont connectés au réseau de communication. Vérifiez dans le journal des événements s'il existe d'autres messages concernant des appareils inaccessibles. Le cas échéant, corrigez les connexions réseau et faites un scan du réseau.

Erreur Automation License Manager - erreur d'initialisation, tentez un redémarrage ALM

Une erreur s'est produite pendant l'initialisation. Redémarrez Automation License Manager.

Erreur Automation License Manager - erreur interne, échec de la suppression globale, tentez un redémarrage ALM

Une erreur s'est produite pendant les tâches de suppression générales. Redémarrez Automation License Manager.

Erreur Automation License Manager - erreur interne, échec de l'initialisation de session, tentez un redémarrage ALM

Une erreur s'est produite pendant l'initialisation de la session. Redémarrez Automation License Manager.

Erreur Automation License Manager - erreur interne, échec de la suppression de session, tentez un redémarrage ALM

Une erreur s'est produite pendant les tâches de suppression de la session. Redémarrez Automation License Manager.

Erreur Automation License Manager - erreur interne, ID de session manquante, contactez l'assistance Siemens

Une erreur interne avec l'ID de session s'est produite. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, ID de session inexistante, contactez l'assistance Siemens

Une erreur interne avec l'ID de session s'est produite. Contactez l'assistance Siemens.

Erreur Automation License Manager - échec de la connexion, vérifiez l'accès réseau au server ALM

La connexion à Automation License Manager a échoué. Vérifiez votre accès réseau.

Erreur Automation License Manager - erreur interne, mémoire insuffisante, redémarrez le système ou contactez l'assistance Siemens

Automation License Manager n'a pas pu allouer suffisamment de mémoire pour fonctionner. Redémarrez votre console de programmation et réessayez. Si le problème persiste, contactez l'assistance Siemens.

Erreur Automation License Manager - délai d'expiration atteint, redémarrez le système ou contactez l'assistance Siemens

Automation License Manager a dépassé le temps imparti. Redémarrez votre console de programmation et réessayez. Si le problème persiste, contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, fonction non trouvée, contactez l'assistance Siemens

Une fonction interne à Automation License Manager a connu une erreur. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, tâche annulée, contactez l'assistance Siemens

Une tâche interne à Automation License Manager a connu une erreur. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, Arguments de fonction erronés, contactez l'assistance Siemens

Une fonction interne de l'Automation License Manager a connu une erreur avec les arguments. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, l'utilisateur a spécifié une erreur inconnue, contactez l'assistance Siemens

Les options pour Automation License Manager étaient invalides. Réessayez. Si le problème persiste, contactez l'assistance Siemens.

Erreur Automation License Manager - Échec de l'envoi des données réseau, vérifiez la connexion réseau

Automation License Manager n'a pas pu envoyer les données réseau. Vérifiez la connexion réseau.

Erreur Automation License Manager - Échec de la réception des données réseau, vérifiez la connexion réseau

Automation License Manager n'a pas pu recevoir les données réseau. Vérifiez la connexion réseau.

Erreur Automation License Manager - Pas de connexion disponible, vérifiez la connexion réseau

Automation License Manager n'est pas connecté au réseau. Vérifiez la connexion réseau.

Erreur Automation License Manager - erreur interne, échec de l'ouverture de session, contactez l'assistance Siemens

Automation License Manager n'a pas pu ouvrir de session. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, ressources manquantes, contactez l'assistance Siemens

Automation License Manager ne disposait pas de ressources internes suffisantes. Contactez l'assistance Siemens.

Erreur Automation License Manager - service non activé, redémarrez le service ALM

Redémarrez Automation License Manager pour tenter de démarrer le service. Si le problème persiste, contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, échec de la cryptographie, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de cryptographie. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, tâche déjà en cours, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne, car une tâche était déjà en cours d'exécution. Redémarrez votre console de programmation, puis redémarrez Automation License Manager. Si le problème persiste, contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, pointeur incorrect, contactez l'assistance Siemens

Automation License Manager a connu une erreur de pointeur interne. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, résultat divergeant, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne avec un résultat inattendu. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, résultat incorrect, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne avec un résultat invalide. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, numéro d'argument API Batch erroné, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de l'interface Batch. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, argument API Batch erroné, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de l'interface Batch. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, fichier d'entrée API Batch erroné, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de l'interface Batch. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, flux d'entrée xml API Batch erroné, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de l'interface Batch. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, API Batch, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de l'interface Batch. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, fichier de sortie API Batch existe déjà, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de l'interface Batch. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, paramètre de sortie API Batch erroné, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de l'interface Batch. Contactez l'assistance Siemens.

Erreur Automation License Manager - erreur interne, création fichier de sortie API Batch impossible, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne de l'interface Batch. Contactez l'assistance Siemens.

Erreur Automation License Manager - Vérifiez les droits d'accès utilisateur au dossier

Automation License Manager a connu une erreur en accédant au dossier. Vérifiez les droits d'accès utilisateur du dossier.

Erreur Automation License Manager - erreur interne, erreur inconnue, contactez l'assistance Siemens

Automation License Manager a connu une erreur interne inconnue. Contactez l'assistance Siemens.

Le nombre maximal de connexions PC est dépassé.

SIMATIC Automation Tool ne peut pas établir une autre liaison. Le nombre maximum a été atteint. Vous ne pouvez pas établir une connexion à un autre appareil supplémentaire. Passez en mode hors-ligne dans TIA Portal, si vous êtes en ligne. Déconnectez les autres appareils du PC.

Le nom de fichier est invalide

Le nom de fichier n'est pas valide pour cette opération. Vérifiez que chemin et le nom de fichier pour l'opération sont valides.

La requête de service en cours a été annulée par le client

Information seulement : Le client a annulé un service en cours d'exécution.

La version SNMP est invalide.

La version SNMP est invalide. Sélectionnez 1, 2, ou 3 pour le numéro de version SNMP.

Mettez la CPU hors tension puis sous tension avant d'exécuter cette opération.

Cette opération requiert une mise hors tension, puis sous tension de la CPU. Mettez la CPU hors tension, puis sous tension et réessayez l'opération.

Le fichier projet n'a pas été ouvert, car le bouton "Annuler" a été actionné.

Information seulement : Vous avez annulé le navigateur pour l'ouverture d'un fichier projet.

Le fichier projet <nom de fichier> a été ouvert avec succès.

Information seulement : SIMATIC Automation Tool a ouvert le fichier projet nommé.

Le fichier projet <nom de fichier> n'a pas pu être ouvert.

SIMATIC Automation Tool n'a pas pu ouvrir le fichier projet nommé. Vérifiez que le fichier est un projet .sat valide compatible avec votre version.

Le mot de passe saisi est incorrect.

Vous avez entré un mot de passe de fichier projet invalide. Vous devez saisir le mot de passe correct pour ce fichier projet.

Le fichier projet n'a pas été enregistré, car le bouton "Annuler" a été actionné.

Information seulement : Vous avez annulé le navigateur pour la sauvegarde d'un fichier projet.

Échec de l'exportation des données PC.

L'opération d'exportation des données PC n'a pas pu créer le fichier d'exportation.. Vérifiez que l'espace disque est suffisant et vérifiez les autorisations d'accès au dossier d'exportation.

Le fichier projet <nom de fichier> n'a pas pu être enregistré.

SIMATIC Automation Tool n'a pas pu sauvegarder le fichier projet. Vérifiez les autorisations de dossier et l'espace disque sur votre console de programmation.

L'exportation n'a pas été effectuée, car le bouton "Annuler" a été actionné.

Information seulement : Vous avez commencé une exportation, puis vous avez annulé l'opération.

L'intégration de l'appareil n'a pas été effectuée, car le bouton "Annuler" a été actionné.

Information seulement : Vous avez commencé à intégrer un appareil, puis vous avez annulé l'opération.

Pas de licence produit valide trouvée ; certaines fonctionnalités du produit sont désactivées.

Vous n'avez pas de licence produit valide. Vous pouvez uniquement effectuer des tâches prises en charge par SIMATIC Automation Tool pour une version sans licence. Pour accéder à toutes les fonctionnalités, acquérez une licence comme décrit dans les Notes d'installation.

Une licence produit valide a été trouvée. Toutes les fonctionnalités du produit sont activées.

Information seulement : Avec une licence valide et non expirée, vous pouvez effectuer toutes les tâches SIMATIC Automation Tool.

Des droits administrateur Windows sont requis pour accéder à certaines données d'exportation PC. Redémarrez SIMATIC Automation Tool avec "Exécuter en tant qu'administrateur" pour exporter ces données.

Exécutez l'opération d'exportation des données PC avec les droits administrateur Windows pour accéder à certaines données. Redémarrez SIMATIC Automation Tool avec "Exécuter en tant qu'administrateur" pour exporter ces données.

L'exportation a acquis toutes les données requises. Le fichier-journal contient une liste détaillée des données exportées.

Information seulement : L'opération d'exportation des données PC a réussi. Le fichier journal du fichier .zip d'exportation liste les données exportées.

L'exportation n'a pas pu acquérir toutes les données. Le fichier journal contient des détails sur les données que l'exportation a acquises avec succès et les raisons pour lesquelles elle n'a pas pu obtenir les autres données.

L'opération d'exportation des données PC n'a pas exporté toutes les données. Recherchez la raison dans le fichier journal. Le fichier journal du fichier .zip d'exportation contient les informations suivantes :

  • Informations sur les données que l'opération d'exportation a acquises et exportée avec succès

  • Raisons pour lesquelles l'opération d'exportation n'a pas pu acquérir les autres données

Le fichier projet <nom de fichier> a été enregistré avec succès.

Information seulement : SIMATIC Automation Tool a sauvegardé et nommé avec succès le fichier projet nommé.

Messages spécifiques à l'appareil

Les appareils peuvent aussi retourner des messages spécifiques à l'appareil. Ces messages ne sont pas compris dans la liste ci-dessus. Si un message spécifique à l'appareil n'est pas explicite, contactez le fabricant de votre appareil.

Messages de l'exportation des données PC

Exporter les données PC peut générer des messages qui ne sont pas compris dans la liste ci-dessus. SIMATIC Automation Tool journalise ces messages tels que retournés par le processus d'exportation. Si vous recevez un message de journal d'événements de la classe d'événement "Données d'exportation PC", essayez ces mesures correctives :

  • Vérifiez que l'espace disque est adéquat. Le fichier .zip de données PC exportées peut nécessiter plus d'espace que disponible. Si nécessaire, libérez de l'espace supplémentaire sur le disque.

  • Vérifiez les autorisations pour le dossier Exportation.

Si vous avez d'autres messages de journal d'événements de la classe d'événement "Données d'exportation PC", contactez votre représentant Siemens.