SIMATIC Energy Suite Liesmich

Beispiele Siehe auch Verlauf Extras
SIMATIC Energy Suite Liesmich

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Security-Hinweise
  • Datenschutz
  • Was ist neu in SIMATIC Energy Suite V16?
  • Was ist neu in SIMATIC Energy Suite V15.1
  • Was ist neu in SIMATIC Energy Suite V14 SP1
  • Migration eines Projekts aus Energy Suite V14 SP1
  • Hinweise zur Benutzung


Security-Hinweise

Datenschutz
Security-Hinweise

Siemens bietet Produkte und Lösungen mit Industrial Security-Funktionen an, die den sicheren Betrieb von Anlagen, Systemen, Maschinen und Netzwerken unterstützen.

Um Anlagen, Systeme, Maschinen und Netzwerke gegen Cyber-Bedrohungen zu sichern, ist es erforderlich, ein ganzheitliches Industrial Security-Konzept zu implementieren (und kontinuierlich aufrechtzuerhalten), das dem aktuellen Stand der Technik entspricht. Die Produkte und Lösungen von Siemens formen nur einen Bestandteil eines solchen Konzepts.

Der Kunde ist dafür verantwortlich, unbefugten Zugriff auf seine Anlagen, Systeme, Maschinen und Netzwerke zu verhindern. Systeme, Maschinen und Komponenten sollten nur mit dem Unternehmensnetzwerk oder dem Internet verbunden werden, wenn und soweit dies notwendig ist und entsprechende Schutzmaßnahmen (z.B. Nutzung von Firewalls und Netzwerksegmentierung) ergriffen wurden.

Zusätzlich sollten die Empfehlungen von Siemens zu entsprechenden Schutzmaßnahmen beachtet werden. Weiterführende Informationen über Industrial Security finden Sie unter.

Die Produkte und Lösungen von Siemens werden ständig weiterentwickelt, um sie noch sicherer zu machen. Siemens empfiehlt ausdrücklich, Aktualisierungen durchzuführen, sobald die entsprechenden Updates zur Verfügung stehen und immer nur die aktuellen Produktversionen zu verwenden. Die Verwendung veralteter oder nicht mehr unterstützter Versionen kann das Risiko von Cyber-Bedrohungen erhöhen.

Um stets über Produkt-Updates informiert zu sein, abonnieren Sie den Siemens Industrial Security RSS Feed unter.


Datenschutz

Datenschutz

Siemens beachtet die Grundsätze des Datenschutzes, insbesondere den Grundsatz der Datenminimierung (eingebauter Datenschutz). Das bedeutet für dieses SIMATIC-Produkt, dass keine personenbezogenen Daten verarbeitet/gespeichert werden.


Was ist neu in SIMATIC Energy Suite V16?

Neuheiten in Energy Suite V16 Lastmanagement Verbesserungen
Was ist neu in SIMATIC Energy Suite V16?

Neuheiten in Energy Suite V16

Alle größeren Innovationen von Energy Suite V16 sind nachstehend zusammengefasst.

Lastmanagement

  • Die Lastmanagementkomponente übernimmt in Energy Suite eine Überwachungsfunktion und stellt sicher, dass Leistungsaufnahme und Energieverbrauch nicht den jeweiligen anwenderdefinierten Energiegrenzwert überschreiten. Die Lastmanagementkomponente enthält ein wichtiges anwenderdefiniertes Element, das als Aktoren bezeichnet wird.

    Das Lastmanagementprogramm besteht beispielsweise aus folgenden Bausteinen:

    • Prognosebaustein

    • Steuerungsbaustein

    • Aktorbaustein

    • Sicherungs-/Wiederherstellungsbaustein

    Der Prognosebaustein erhält seine Eingangsdaten von der Einspeisung, d. h. dem Erfassungsobjekt. In einem Kraftwerk beispielsweise ist die Einspeisung die Versorgung aus dem Stromnetz. Der Prognosebaustein berechnet bzw. prognostiziert den durchschnittlichen Leistungs- und Energiewert, wobei die Einspeisung am Ende des festgelegten Zeitraums herangezogen wird.

    Ziehen Sie die Überwachung einer Fertigungsanlage durch eine Lastmanagementkomponente in Betracht. Der Prognosebaustein liest den Leistungswert der Einspeisung und überwacht die Leistungsaufnahme. Die Energienutzung wird gegen einen Grenzwert über einen bestimmten Zeitraum hinweg konstant überwacht. Wenn die Prognose den Grenzwert überschreitet, veranlasst das Lastmanagement die Verbraucher (Aktoren) oder die Erzeuger dazu, sich abzuschalten. Dieser Prozess wird als Eskalation bezeichnet. Nach der Schwellenwertspitze, wenn die Leistungsaufnahme minimal ist oder im Rahmen des Schwellenwerts liegt, wird der Erzeuger (Aktor) eingeschaltet. Dieser Prozess wird als Deeskalation bezeichnet.

  • Die Delta-Generierung für Lastmanagement und Erfassungsobjekte wird unterstützt, wobei neu hinzugefügte oder geänderte Aktorbausteine für Erfassungsobjekte/Lastmanagement nach der Generierung an die vorhandenen Bausteine angehängt werden. Im Fall einer Löschung werden nur die ausgewählten Bausteine nach der Generierung gelöscht, ohne die vorhandenen Bausteine zu ändern.

  • Die automatische Aufstellung von Bildschirmregeln für Bausteine in Energy Suite wird unterstützt.

  • Bildschirmgenerierung

    • Unterstützung der automatischen Bildschirmgenerierung für das Energieerfassungsprogramm mit WinCC Professional-, WinCC Runtime Advanced- und WinCC Comfort-Geräten.

    • Unterstützung der automatischen Bildschirmgenerierung für das Lastmanagementprogramm mit WinCC Professional-Geräten

Verbesserungen

  • Leistungsoptimierungen für den Laufzeitbetrieb zum Verbessern der PLC-Zykluszeitausnutzung bei Langzeiterfassungen.

  • Laufzeitneutrale Delta-Energieprogrammgenerierung für Energieerfassung und Lastmanagement wird unterstützt, wenn es Deltaänderungen wie Hinzufügung oder Änderung bei Erfassungsobjekten oder Aktoren für das Lastmanagement gibt.

  • Wenn Sie bei der Konfiguration eines Energy Suite-Projekts eine neue Erfassungsobjekttabelle hinzufügen, müssen Sie WinCC herunterladen.

  • Wenn Sie Erfassungsobjekte in die Erfassungsobjekttabelle einfügen, müssen Sie WinCC herunterladen.

  • Zur Laufzeit kann die Lastmanagementfunktion mit PLC-Versionen ab V2.5 erreicht werden.

  • Um das Lastmanagement in der Laufzeit zu nutzen, muss der Parameter "Leistungsgrenze" sowohl in Parametersatz 1 als auch in Parametersatz 2 konfiguriert werden.


Was ist neu in SIMATIC Energy Suite V15.1

Neuheiten in Energy Suite V15.1 Optimierung der Anbindung von Messhardware als Energiedatenquelle
Was ist neu in SIMATIC Energy Suite V15.1

Neuheiten in Energy Suite V15.1

Alle wichtigen Neuheiten gegenüber Energy Suite V15 sind hier zusammengefasst aufgeführt.

Optimierung der Anbindung von Messhardware als Energiedatenquelle

  • Energy Suite erkennt folgende, mit in STEP 7 (TIA Portal) integrierter Oberfläche oder mit der Gerätestammdatendatei, konfigurierte Messhardware als Energiedatenquelle:

    • ET 200SP AI Energy Meter 480VAC HF

    • Sanftstarter 3RW55

  • Energy Suite erkennt die Konfiguration der oben benannten Messhardware und legt automatisch während der Generierung des Energieprogramms entsprechende Bausteine an.

  • Die Energy Suite-Bibliothek beinhaltet automatisch installierte Bildbausteine zur Visualisierung des Energieprogramms.

  • Ein in V15.0 angelegtes Energy Suite-Projekt mit PLC-Archivierung generiert eine Daten-Log-Datei. Wenn dasselbe Projekt in V15.1 geöffnet wird, werden Sie vom TIA Portal aufgefordert, das Projekt auf V15.1 hochzurüsten. Bei einer nachträglichen Hochrüstung des Projekts auf V15.1 wird nach der Neugenerierung und dem Laden eine neue Daten-Log-Datei erstellt.


Was ist neu in SIMATIC Energy Suite V14 SP1

Neuheiten in Energy Suite V14 SP1 Generierung des Energieprogramms auch für erweiterte Energiedaten Automatische Erstellung der Berichte mit Energy Suite Export Tool Detaillierte Informationen und Rückmeldungen zum Generierfortschritt Erweiterung der Metadatenstruktur
Was ist neu in SIMATIC Energy Suite V14 SP1

Neuheiten in Energy Suite V14 SP1

Alle wichtigen Neuheiten gegenüber Energy Suite V14 sind hier zusammengefasst aufgeführt.

Generierung des Energieprogramms auch für erweiterte Energiedaten

  • Für die Generierung des Energieprogramms auch für erweiterte Energiedaten (z. B. Ströme, Spannungen, Frequenz, usw.) stehen Ihnen folgende neue Befehle im Kontextmenü des Objekts "Energieobjekte" in der Projektnavigation zur Verfügung:

    • Basisenergiedaten

    • Basis- und erweiterte Energiedaten

    • Basis- und erweiterte Energiedaten (mit Minimal- /Maximalwerte)

  • Energy Suite erkennt, welche Energiedaten die jeweilige Messhardware bereitstellen kann und legt automatisch entsprechende Bausteine während der Generierung des Energieprogramms an.

Weitere Informationen finden Sie im Bedienhandbuch SIMATIC Energy Suite im Abschnitt "Energieprogramm generieren".

Automatische Erstellung der Berichte mit Energy Suite Export Tool

  • Neue automatische Berichtserstellung anhand der konfigurierbaren Berichtsvorlagen.

  • Folgende automatische Berichtszyklen stehen zur Verfügung:

    • Täglich

    • Wöchentlich

    • Monatlich

    • Jährlich

  • Für eine schnelle Analyse der Fehler werden die Fehlermeldungen bei unerwartetem Verhalten lokal unter "C:\Program Files (x86)\Siemens\Automation\SCADA-RT_V11\WinCC\bin\config" gespeichert.

Weitere Informationen finden Sie im Bedienhandbuch SIMATIC Energy Suite im Abschnitt "Energiedaten auswerten mit Energy Suite Export Tool".

Detaillierte Informationen und Rückmeldungen zum Generierfortschritt

  • Zur besseren Nachvollziehbarkeit des Generierprozesses werden die Informationen und Ereignisse zu der Generierung des Energieprogramms angezeigt.

  • Über die Funktion "Gehe zu“ können Sie zur Stelle in der Konfiguration springen, die für das jeweilige Ereignis relevant ist.

Weitere Informationen finden Sie im Bedienhandbuch SIMATIC Energy Suite im Abschnitt "Energieprogramm generieren".

Erweiterung der Metadatenstruktur

Die Metadatenstruktur der Energieobjekte sind zu Kompatibilitäts- und Analysezwecken erweitert.

Weitere Informationen finden Sie im Bedienhandbuch SIMATIC Energy Suite im Abschnitt "Energy Suite-Bausteine".


Migration eines Projekts aus Energy Suite V14 SP1

Voraussetzungen Vorgehen
Migration eines Projekts aus Energy Suite V14 SP1

Für die Migration von Energy Suite-Projekten der Version V14 SP1 auf V16 müssen Sie die STEP 7-Anweisung "Get_IM_Data" manuell auf die aktuelle Version setzen. Andernfalls kommt es zu Übersetzungsfehlern beim Übersetzungsvorgang.

Voraussetzungen

  • Ein Energy Suite-Projekt der Version V14 SP1 ist vorhanden.

  • TIA Portal V16 mit Energy Suite V16 ist installiert.

Vorgehen

Um Übersetzungsfehler bei der Migration eines Energy Suite-Projekts von V14 SP1 nach V16 zu vermeiden, gehen Sie folgendermaßen vor:

  1. Öffnen Sie das in Energy Suite V14 SP1 in V16 angelegte Projekt.

    Daraufhin öffnet sich der Dialog "Projekt öffnen".

  2. Klicken Sie im Dialog "Projekt öffnen" auf die Schaltfläche "Hochrüsten".

  3. Nach der erfolgreichen Migration des Projekts öffnen Sie in der Projektnavigation die konfigurierte SIMATIC S7-1500 CPU.

  4. Öffnen Sie unterhalb des Ordners "Programmbausteine" einen beliebigen Baustein (OB, FB oder FC).

  5. Öffnen Sie in der Task Card "Anweisungen" den Ordner "Erweiterte Anweisungen > Diagnose".

    Die Anweisung "Get_IM_Data" ist mit Version "V1.2" vorbelegt.

  6. Wählen Sie die gewünschte Version "V1.3" in der Klappliste aus.

  7. Setzen Sie anschließend die Generierung Ihres Energieprogramms fort.

  8. Klicken Sie unterhalb der konfigurierten S7-1500 CPU auf das Objekt "Programmbausteine".

  9. Wählen Sie im Kontextmenü den Befehl "Übersetzen > Software (komplett übersetzen)".

    Das Energieprogramm wird übersetzt. Im Inspektorfenster können Sie unter "Info > Übersetzen" prüfen, ob die Übersetzung erfolgreich abgeschlossen wurde.

Um einen Fehler wegen eines Konflikts der Bibliotheksversionen zu vermeiden, gehen Sie bei der Migration von Energy Suite-Projekten der Versionen V15 und niedriger auf Version V16 wie folgt vor:

  • Bei den grundlegenden Anweisungen "Serialize" und "Deserialize" müssen Sie die Version manuell von V2.0 auf V2.1 aktualisieren.

  • Bei der erweiterten Anweisung "GetSMCinfo" müssen Sie die Version manuell von V1.0 auf V1.1 aktualisieren.


Hinweise zur Benutzung

Inhalte Upgrade von Projekten Energy Suite in einem Multiuser-Projekt Energiedaten von einer Messhardware Transfer von Daten zum SCADA-System Generierung des Energieprogramms Energy-Suite-Bausteine Grenzwert für HMI-Variablen
Hinweise zur Benutzung

Inhalte

Die Informationen in diesem Text haben Vorrang gegenüber Angaben aus anderen Dokumenten.

Bitte lesen Sie die folgenden Hinweise sorgfältig durch. Sie enthalten wichtige Informationen zu Installation und Nutzung. Lesen Sie diese Hinweise, bevor Sie mit der Installation beginnen.

Aktuelle Informationen zur Energy Suite finden Sie auch im Infoportal des Siemens Industry Online Support.

Informationen zur Betriebsanleitung für die SIMATIC Energy Support Library finden Sie auf dem Installationsmedium in der Liesmich-Datei "ReadMeEnSLenUS.chm".

Upgrade von Projekten

Ein in älteren Versionen als V16 angelegtes Energy Suite-Projekt mit PLC-Archivierung generiert eine Datenprotokolldatei. Es gelten folgende Szenarien für Datenprotokolldateien:

  • Wenn Sie ein Upgrade eines mit einer älteren Version als V16 angelegten Energy Suite-Projekts auf V16 durchführen und das Projekt ohne Programmgenerierung in die PLC laden, wird dadurch die PLC-Archivierung in derselben Datenprotokolldatei fortgesetzt.

  • Wenn Sie ein Upgrade eines mit einer älteren Version als V16 angelegten Energy Suite-Projekts auf V16 mit Programmgenerierung durchführen und das Projekt in die PLC laden, wird dadurch die PLC-Archivierung in einer neuen Datenprotokolldatei fortgesetzt.

  • Bei einer Delta-Generierung ändern sich durch das Upgrade von Projekten bis V16 die vorhandenen DB-Nummern.

  • Wenn Sie ein Upgrade eines mit einer älteren Version als V15 angelegten Energy Suite-Projekts auf V16 durchführen, müssen Sie die LAcycCOM-Bausteine manuell löschen, sobald das Projekt aktualisiert wurde, und dann das Energieprogramm erneut generieren.

  • Der DB LAcycCom_RequestBuffer ist unter den Bausteinen des Energy Suite-Programms (Präfix "EnS") verfügbar.

  • Projekte der Versionen v14 SP1 oder v15 melden einen Übersetzungsfehler bei Übersetzung des FB Ens_LmgtBackupRestore, wenn sie auf v16 mit Firmwareversionen ab v2.5 aktualisiert werden und in der Erfassungsobjekttabelle die Prognoseoption mit konfigurierten Lastmanagementaktoren aktiviert ist.

  • Bei Projekten der Version v14 SP1 oder v15 schlägt die Generierung eines Programms fehl, wenn sie auf v16 mit Datalognamen über 26 Zeichen aktualisiert werden.

Energy Suite in einem Multiuser-Projekt

Öffnen Sie ein Multiuser-Projekt ausschließlich in der Server-Projektansicht, nicht in der lokalen Sitzung.

Energiedaten von einer Messhardware

Bei der Konfiguration der Messhardware als Energiedatenquelle werden je nach verwendeter Messhardware unterschiedliche Datentyp-Einstellungen ausgewertet.

Die folgende Tabelle zeigt die erforderlichen Einstellungen für die unterstützte Messhardware:

Messhardware | Energiedatentyp | Einheit | Normierungsfaktor | Überlaufwert
AI EnergyMeter 480VAC ST | Energiezählerwert | Wh | 1 | 1.000.000.000.000.000 = 1 * 10^15 (*)
AI EnergyMeter 480VAC HF | Energiezählerwert | Wh | 1 | 1.000.000.000.000.000 = 1 * 10^15 (*)
SENTRON PAC3200/PAC4200 | Energiezählerwert | Wh | 1 | 1 * 10^12
SENTRON 3VA (8er-ETU) | Energiezählerwert | Wh | 1 | 4 * 10^12
SINAMICS AC/AC | Leistungswert | W | 1 | -
SIMOCODE pro V PN | Energiezählerwert | Wh | 1 | 2.147.483.648.000
Motorstarter ET 200SP/M200D | Leistungswert | W | 1 | -
Sanftstarter 3RW44 | Leistungswert | W | 1 | -
Sanftstarter 3RW55 | Leistungswert | W | 1 | -

(*) Achten Sie darauf, dass der Energiezählerwert den Überlaufwert sowohl in den Einstellungen der Energy Suite als auch in der Hardware-Konfiguration des AI EnergyMeter 480VAC ST/HF anzeigt. Sie finden die Hardware-Konfiguration im Inspektorfenster "Eigenschaften" unter "Modulparameter > AI-Konfiguration > Messung > Endwert Energiezähler".

Achten Sie darauf, dass die Parametrierung mit der oben stehenden Tabelle übereinstimmt.

Transfer von Daten zum SCADA-System

Wenn Sie Änderungen am Energieprogramm vornehmen, generieren Sie das Energieprogramm erneut und laden es in die CPU.

Laden Sie die Änderungen nur dann in die CPU, wenn die Pufferblöcke leer sind. Beim Laden in die CPU (vollständig) muss die CPU im Anschluss neu gestartet werden. Beim Laden in die CPU (nur Änderungen) muss eine Neuinitialisierung des Datenbausteins "EnS_BufferWorkDB" durchgeführt werden. Weitere Informationen hierzu finden Sie in der Online-Hilfe des TIA-Portal-Informationssystems.

Generierung des Energieprogramms

Überprüfen Sie die folgenden Einstellungen, wenn die Generierung des Energieprogramms fehlschlägt:

  • Energiedatenquelle: Folgende Aspekte sollten gemäß Handbuch konfiguriert werden:

    • Hardware-Konfiguration der Messhardware (siehe Dokumentation "Messhardware für die SIMATIC Energy Suite im TIA Portal")

    • Datentyp (siehe Abschnitt "Energiedaten aus Datenbausteinen")

    • Benennungsregeln (siehe Abschnitt "Leistungsmerkmale und Konventionen")

  • Archivierungsperiode: Jedem Erfassungsobjekt ist eine Archivierungsperiode zugeordnet.

  • Erfassungsobjektname: Das Erfassungsobjekt kann nicht den gleichen Namen haben wie die folgenden Objekte

    • Programmbaustein

    • Technologieobjekt

    • Externe Quelle

    • PLC-Variable

    • PLC-Datentyp

  • Allgemein: Die Präfixe "EnS_" (außer "EnS_EEm_" für den S7 Energieeffizienz-Monitor), "EnSL_" und "LAcycCom_" sind reservierte System-Präfixe und werden in den Namen der oben genannten Objekte nicht verwendet.

Bevor Sie das Energieprogramm neu generieren, achten Sie darauf, dass die oben genannten Einstellungen zutreffen.

  • Der Wertebereich für den Namen des Lastmanagementsystems umfasst 1 bis 26 Zeichen.

  • Der Wertebereich für einen Prioritätsaktor umfasst 0 bis 1999 Zeichen.

Für die erfolgreiche Übersetzung von WinCC Comfort Panel- und WinCC Runtime Advanced-Geräten, die Energieerfassungsdaten enthalten, mit SiVArc-Generierung ist Folgendes Voraussetzung:

  • Die HMI-Variablen vom Typ LMGT - interne Variablen und EnS_Visu müssen manuell gelöscht werden, da sie bei WinCC Comfort nicht unterstützt werden.

  • Sie müssen die entsprechenden Variablen für die Pop-up-Fensterobjekte verknüpfen.

Für die erfolgreiche Übersetzung von WinCC Runtime Professional-Geräten ist Folgendes Voraussetzung:

  • Um die Navigation in Bildern mit Erfassungsobjekt-Bildbausteinen zur Laufzeit zu ermöglichen, gehen Sie zu project navigation view tree > WinCC RT Professional >Scripts > VB scripts > Acquisition folder >, kopieren Sie das Skript openEnergyBasic, navigieren Sie zu acquisition object faceplate > Properties > Events > openEnergyBasic und fügen Sie das Skript ein.

  • Wenn nur das Energieerfassungsprogramm in der PLC erzeugt wird und die Bilder über die Option "SiVArc-Generierung starten mit Stationsauswahldialog" generiert werden, müssen Sie die Variablentabelle "LMGT - interne Variablen" manuell löschen.

Bei der Konfiguration eines Energy Suite-Projekts gilt:

  • Beim erstmaligen und jedem weiteren Hinzufügen einer Erfassungsobjekttabelle müssen Sie WinCC herunterladen.

  • Beim Einfügen von Erfassungsobjekten in die Acquisition object-Tabelle müssen Sie WinCC herunterladen.

  • Wenn mehrere PLCs an ein gemeinsames HMI-Gerät (WinCC Professional RunTime- oder WinCC Comfort-Gerät) angeschlossen sind und Sie das Bild SiVArc für Energy Suite-Regeln generieren, wird ein Fehler gemeldet:
    “Ein Bildobjekt mit dem Namen ‘EnS_EnergyArchive’ kann von Station ‘PLC_2’ nicht im Bild ‘EnS_EnergyArchive’ erzeugt werden, weil bereits ein Bildobjekt gleichen Namens von Station PLC_1 existiert”.

  • Beim Aus- und Einschalten der PLC muss die Konfiguration der LMGT-Aktoren manuell gesichert und nach dem Neustart der PLC wiederhergestellt werden. Um die Konfiguration beim Hochfahren der PLC wiederherzustellen, rufen Sie die Wiederherstellen-Funktion im PLC-Anlauf-OB auf.

Energy-Suite-Bausteine

EnS_CalcEnergyData: Energiewerte berechnen

Das Rücksetzen des Energiezählerwerts während einer aktiven Archivierungsperiode führt zur Berechnung negativer Energiewerte für diese Archivierungsperiode.

EnSL_DrvBasic_Sina_vx: Energiebasisdaten erfassen

Entgegen der Angaben in der Dokumentation "Messhardware für die SIMATIC Energy Suite im TIA Portal", existiert der Fehlercode "W#16#8011" nicht im Ausgangsparameter "Status".

Grenzwert für HMI-Variablen

In den Runtime-Einstellungen der HMI wird der PLC-Name an den Variablennamen angehängt, wenn das Kontrollkästchen "PLC-Name als Präfix im HMI-Variablennamen" aktiviert ist. Nach der Generierung des SiVArc-Bildschirms, auf den die HMI-Übersetzung folgt, wird ein Fehler angezeigt, wenn der HMI-Variablenname eine Länge von 128 Zeichen überschreitet.

Screens >EnS_WinCCProf_Screen