Energy Support Library

In Section Instructions Examples Basic History Extra

Start Previous Next

Energy Support Library V16

This section contains information on the following topics:

  • Installation instructions

  • User instructions

These instructions have priority over instructions in other documents. Please, read the instructions carefully because they are important for installation and use of the software.

You can find additional information about notes on use and the installation of the SIMATIC Energy Suite in the readme file of Energy Suite on the installation medium


Scope of delivery

Energy Support Library

Scope of delivery

Energy Support Library

The software includes the Engineering Software for an Engineering Station and the Runtime Software for the runtime of the S7 blocks in an automation system S7-1500.

The global library Energy Support Library contains blocks and data types for the product platform SENTRON, SIMATIC, SINAMICS and SIRIUS.


Hardware requirements

General hardware requirements SENTRON SIMATIC SINAMICS SIRIUS

Start Previous Next

Hardware requirements

General hardware requirements

The requirements of STEP 7 Professional Version V16 apply for the installation.

Energy Support Library requires a SIMATIC S7-1500 controller with Firmware V2.0.

SIMATIC S7-1500 Software Controller and SIMATIC S7-1200 are not supported.

In the following the supported devices are listed:

SENTRON

  • PAC3200, V2.4

  • PAC4200, V1.6; V2.0

  • 3VA2:

    • COM100 / COM800, V3.1; V4.0; V4.1; V4.2

    • ETU850, V3.1; V4.1

    • ETU860 / ETU860M, V3.1; V4.1; V4.2

  • 3VA6:

    • COM100 / COM800, V4.0; V4.1; V4.2

    • ETU820 / ETU856 / ETU860, V4.0; V4.2

    • ETU830 / ETU850, V4.0

  • 7KM PAC SWITCHED ETHERNET, V2.1

The PAC3200/PAC4200 and the 3VA (with an 8-series ETU) can also be integrated via the GSDML-V2.3-Siemens-SENTRON-20150421.xml and GSDML-V2.3-Siemens-3VA-20150421.xml. In this case the following firmware versions are required at the least:

  • PAC3200, V2.3.5

  • PAC4200, V1.5.4

  • COM100 / COM800, V3.1

  • 7KM PAC SWITCHED ETHERNET, V2.1

SIMATIC

  • Energy Meter 480VAC ST, V4.0

  • Energy Meter 480VAC/CT HF, V6.0

  • Energy Meter 480VAC/RC HF, V6.0

SINAMICS

The following GSDML files are supported by the SINAMICS blocks:

  • GSDML-V*.**-SIEMENS-SINAMICS_G130G150-********.XML

  • GSDML-V*.**-SIEMENS-SINAMICS_MV-********.XML

  • GSDML-V*.**-SIEMENS-SINAMICS_G120P-********.XML

  • GSDML-V*.**-SIEMENS-SINAMICS_G120C-********.XML

  • GSDML-V*.**-SIEMENS-SINAMICS_G120-********.XML

  • GSDML-V*.**-SIEMENS-SINAMICS_G120D-********.XML

  • GSDML-V*.**-SIEMENS-SINAMICS_G110M-********.XML

  • GSDML-V*.**-SIEMENS-SINAMICS_S_CU3X0-********.XML

For the GSDML files the following firmware versions are supported:

  • SINAMICS G130, V4.7; V4.8; V5.1

  • SINAMICS G150, V4.7; V4.8; V5.1

  • SINAMICS MV, V4.7; V4.8; V5.1

  • SINAMICS G120P, V4.7

  • SINAMICS G120C, V4.7

  • SINAMICS G120, V4.7

  • SINAMICS G120D, V4.7

  • SINAMICS G110M, V4.7

  • SINAMICS S150, V4.7; V4.8; V5.1

The following SINAMICS devices integrated via Startdrive are supported:

  • SINAMICS G110M CU240M PN, V4.7 bis 4.7.9

  • SINAMICS G120 CU240E-2 PN, V4.7 bis 4.7.9

  • SINAMICS G120 CU240E-2 PN-F, V4.7 bis 4.7.9

  • SINAMICS G120 CU250S-2 PN Vector, V4.7 bis 4.7.9

  • SINAMICS G120C, V4.7 bis 4.7.9

  • SINAMICS G120D CU240D-2 PN, V4.7 bis 4.7.9

  • SINAMICS G120D CU240D-2 PN-F FO, V4.7 bis 4.7.9

  • SINAMICS G120D CU240D-2 PN-F, V4.7 bis 4.7.9

  • SINAMICS G120D CU250D-2 PN-F FO, V4.7 bis 4.7.9

  • SINAMICS G120D CU250D-2 PN-F, V4.7 bis 4.7.9

  • SINAMICS G120P CU230P-2 PN, V4.7 bis 4.7.9

  • SINAMICS G130 CU320-2 PN, V4.8, 5.1

  • SINAMICS G150 CU320-2 PN, V4.8, 5.1

  • SINAMICS MV CU320-2 PN, V4.8.2

  • SINAMICS S120 CU320-2 PN, V4.8, 5.1

  • SINAMICS S150 CU320-2 PN, V4.8, 5.1

SIRIUS

  • SIMOCODE pro V PN V1.2, V2.0, V2.1

  • Soft Starter 3RW44 V1.11

  • Soft Starter 3RW55 V1.0

  • Motorstarter M200D V1.0

  • Motorstarter SIMATIC ET 200SP V1.0, V1.1

SIMOCODE pro V PN requires a current/voltage measuring module.


Software requirements

General Software requirements LAcycCom library

Software requirements

General software requirements

The library requires as a minimum TIA Portal V16 with STEP 7 Professional.

The S7 blocks require the following instructions:

  • RD_ADDR V1.2

  • RDREC V1.0

  • WRREC V1.1

  • GETIO V1.1

  • SETIO V1.2

  • GETIO_PART V1.2

  • SETIO_PART V1.2

  • Program_Alarm V1.0

  • Get_AlarmState V1.1

LAcycCom library

The S7 blocks require the LAcycCom library V1.3.1. You can find the required blocks, PLC tags, and data types in the folders LAcycCom_Blocks, LAcycCom_Tags and LAcycCom_Types of the Energy Support Library.

For a description of the LAcycCom library please refer to:

https://support.industry.siemens.com/cs/ww/en/view/109479553


Installing Energy Support Library

Installation Components

Installing Energy Support Library

Installation

The Energy Support Library is located on the installation medium of the Energy Suite.

For information about the installation of the Energy Support Library please refer to the installation notes of the Energy Suite.

Components

The library is copied to the same drive where the STEP 7 basis software has been installed.

The following components will be installed:

  • User documentation in the directory <drive>:\SIEMENS\Automation\Portal V16\EnergySupportLibrary\Manuals

  • Library Energy Support Library in the directory <drive>:\SIEMENS\Automation\Portal V16\lib\Sys\Energy Support Library

  • Configuration files for the library in the directory <drive>:\SIEMENS\Automation\Portal V16\Data\EnergySuite\DriverBlockMeta


Uninstalling Energy Support Library

Uninstallation

Uninstalling Energy Support Library

Uninstallation

The uninstallation of the software must be done in an MS Windows-conform way.

In the Start menu, enter "Control Panel" in the search box and select "Control Panel" from the results. Select Programs > Programs and Features, then select the entry Siemens Totally Integrated Automation Portal V16 and select remove. Then choose the setup language and proceed to remove the software Energy Support Library V16.


Current information on software Energy Support Library

Industry Online Support

Current information on software Energy Support Library

Industry Online Support

For current information on Energy Support Library please refer to https://support.industry.siemens.com/cs/ww/en/


Information on the documentation

Manual

Information on the documentation

Manual

You can find the documentation in the Start menu under Siemens Automation > Energy Support Library > Manuals