Realizar una instalación automatizada

Ejemplos Consulte también Historial Herramientas
Realizar una instalación automatizada

Este capítulo incluye información sobre los siguientes temas:
  • Instalación automatizada mediante el modo Record/Play
  • Instalación automatizada mediante línea de comandos
  • Principios básicos de la instalación automática
  • Lista de parámetros
  • Valores de retorno del proceso de instalación


Instalación automatizada mediante el modo Record/Play

Instalación automatizada mediante el modo Record/Play

Este capítulo incluye información sobre los siguientes temas:
  • Iniciar registro
  • Selección de los ajustes de instalación
  • Ejecutar registro


Iniciar registro

Requisitos Procedimiento Resultado
Iniciar registro

Requisitos

  • El hardware y software de la programadora o PC cumplen los requisitos del sistema.

Procedimiento

Para registrar la instalación, proceda del siguiente modo:

  1. Inicie el prompt de Windows con "Inicio > Ejecutar > cmd".

  2. Vaya al directorio que contiene el archivo "Start.exe".

  3. Introduzca en el prompt el comando siguiente:

    • "Start.exe /record"

  4. Confirme la entrada efectuada con <Intro>.

Resultado

El diálogo de instalación se abre indicando que se encuentra en el modo Record y que el sistema no se modificará.


Selección de los ajustes de instalación

Procedimiento Resultado
Selección de los ajustes de instalación

Procedimiento

Para seleccionar las opciones para la instalación, proceda del siguiente modo:

  1. En el diálogo para elegir el idioma de la instalación, seleccione el idioma en el que desea ver los cuadros de diálogo del programa de instalación y haga clic en el botón "Siguiente".

    Se abre el cuadro de diálogo para seleccionar los idiomas del producto.

  2. Seleccione los idiomas para la interfaz del producto y haga clic en el botón "Siguiente".

    Nota

    El idioma base de instalación del producto es siempre el inglés.

    Se abre el cuadro de diálogo para seleccionar la configuración de producto.

  3. Seleccione los productos que desea instalar:

    • Si solo desea una instalación mínima del programa, haga clic en el botón "Mínima".

    • Si quiere instalar los componentes típicos del programa, haga clic en el botón "Típica".

    • Si desea elegir por sí mismo los productos que deben instalarse, active/desactive la casilla de verificación para aquellos productos que desee instalar. Al hacerlo, se activará automáticamente el botón "Definida por el usuario".

  4. Si desea crear un acceso directo en el escritorio, active la casilla de verificación "Crear acceso directo en el escritorio".

  5. Haga clic en el botón de comando "Examinar" si desea cambiar el directorio de destino para la instalación.

    Nota

    Se recomienda elegir la carpeta "Archivos de programa" como directorio de destino. Si selecciona una unidad fija (p. ej., "D:"), asegúrese de que dicha unidad existe en todos los equipos en los que debe instalarse el programa.

  6. Haga clic en el botón "Siguiente".

    Se abre el cuadro de diálogo correspondiente a las condiciones de licencia.

  7. Para continuar la instalación, lea y acepte todos los acuerdos de licencia y haga clic en "Siguiente".

    En caso de que sea necesario modificar opciones de seguridad y permisos para la instalación del TIA Portal, se abrirá el diálogo para la configuración de seguridad.

  8. Para continuar la instalación, acepte los cambios efectuados en las opciones de seguridad y permisos y haga clic en el botón "Siguiente".

    En el siguiente diálogo aparecen listados los ajustes de instalación.

  9. Compruebe los ajustes de instalación seleccionados. Si desea efectuar cambios, haga clic en el botón "Atrás" hasta acceder al ajuste que desea modificar en el cuadro de diálogo. Una vez efectuados los cambios deseados, regrese a la vista general con "Siguiente".

  10. Haga clic en el botón "Siguiente".

    Se abrirá el diálogo para definir el comportamiento en caso de reinicio y si se producen errores.

  11. Seleccione las opciones deseadas y guarde la configuración.

  12. Haga clic en el botón "Finalizar".

Resultado

El archivo para la instalación automatizada se ha creado y guardado.


Ejecutar registro

Requisitos Procedimiento Resultado
Ejecutar registro

Requisitos

  • El hardware y software de la programadora o PC cumplen los requisitos del sistema.

  • Usted dispone de derechos de administración para su equipo.

  • El archivo previamente registrado ("*.rec") está disponible.

  • Se han cerrado todas las aplicaciones que se estaban ejecutando.

Procedimiento

Para ejecutar la instalación, proceda del siguiente modo:

  1. Inicie el prompt de Windows con "Inicio > Ejecutar > cmd".

  2. Vaya al directorio que contiene el archivo "Start.exe".

  3. Introduzca en el prompt el comando siguiente:

    • "Start.exe /play=<Unidad>:\<Directorio>\<Nombre archivo>", p. ej., "Start.exe /play=c:\siemens configuration\autoinstall.rec"

  4. Confirme la entrada efectuada con <Intro>.

    Nota

    Si durante la instalación no se encuentra ninguna clave de licencia, se omitirá la transferencia de licencia y podrá reintentarla más tarde con el Automation License Manager.

Resultado

La instalación se realiza automáticamente con los ajustes registrados en el archivo de configuración.


Instalación automatizada mediante línea de comandos

Instalación automatizada mediante línea de comandos

Este capítulo incluye información sobre los siguientes temas:
  • Automatizar la instalación
  • Actualización automatizada
  • Reparación automatizada
  • Desinstalación automatizada
  • Ejemplos de instalaciones automatizadas mediante la línea de comandos


Automatizar la instalación

Requisitos Procedimiento
Automatizar la instalación

Requisitos

  • El hardware y software de la programadora o PC cumplen los requisitos del sistema.

  • Usted dispone de derechos de administración para su equipo.

  • Se han cerrado todas las aplicaciones que se estaban ejecutando.

Procedimiento

Para iniciar la instalación con las opciones deseadas directamente a través de la interfaz de comando, proceda del siguiente modo:

  1. Inicie el prompt de Windows con "Inicio > Ejecutar > cmd".

  2. Vaya al directorio que contiene el archivo "Start.exe".

  3. Introduzca en el prompt uno de los comandos siguientes:

    • Instalación con datos de instalación visibles: "Start.exe /qb <parámetro>"

    • Instalación sin datos de instalación visibles: "Start.exe /qn <parámetro>" o "Start.exe /silent <parámetro>"

      Nota

      La instalación con los parámetros /qb o /qn hace que no se muestren ventanas de aviso, ni siquiera en caso de que aparezca un error. Los resultados solo pueden evaluarse a través del valor de retorno.

      En caso de utilizar la opción "REBOOT=Suppress", tenga en cuenta que deberá evaluar Ud. mismo el valor de retorno y, dado el caso, reiniciar el sistema y, después de ello, reiniciar la propia instalación para que sea posible evaluar el valor de retorno.

  4. Confirme la entrada efectuada con <Intro>.


Actualización automatizada

Requisitos Procedimiento
Principios básicos de la instalación automática
Actualización automatizada

Existe la posibilidad de actualizar los productos instalados a una nueva versión (update) de forma automatizada. Para ello se puede iniciar una nueva instalación con las opciones deseadas directamente como línea de comandos.

Requisitos

  • El hardware y software de la programadora o PC cumplen los requisitos del sistema.

  • Usted dispone de derechos de administración para su equipo.

  • Se han cerrado todas las aplicaciones que se estaban ejecutando.

Procedimiento

Para actualizar productos instalados desde la línea de comandos, proceda del siguiente modo:

  1. Inicie el prompt de Windows con "Inicio > Ejecutar > cmd".

  2. Vaya al directorio que contiene el archivo "Start.exe".

  3. Introduzca en el prompt uno de los comandos siguientes:

    • Instalación con informaciones de instalación visibles: "Start.exe /qb <Parámetro>"

    • Instalación sin informaciones de instalación visibles: "Start.exe /qn <Parámetro>" o "Start.exe /silent <Parámetro>"

      Nota

      La instalación con los parámetros /qb o /qn hace que no se muestren ventanas de aviso, ni siquiera en caso de que aparezca un error. Los resultados solo pueden evaluarse a través del valor de retorno.

      En caso de utilizar la opción "REBOOT=Suppress", tenga en cuenta que deberá evaluar Ud. mismo el valor de retorno y, dado el caso, reiniciar el sistema y, después de ello, reiniciar la propia instalación para que sea posible evaluar el valor de retorno.

  4. Confirme la entrada efectuada con <Intro>.


Reparación automatizada

Requisitos Procedimiento
Reparación automatizada

Si, una vez efectuada la instalación, se vuelve a llamar "Start.exe" con el parámetro "REINSTALL=ALL", se reinstalarán todos los componentes, igual que cuando se selecciona "Reparar" en una instalación asistida por el cuadro de diálogo. La reinstalación es idéntica a la instalación original. La reparación automatizada se efectúa igual que la instalación automatizada desde la interfaz de comandos. El comportamiento de reinicio se define con un parámetro.

"REINSTALL" sólo se puede combinar con los parámetros "REBOOT", "/qn" y "/qb". No se permite ningún otro parámetro.

Requisitos

  • El hardware y software de la programadora o PC cumplen los requisitos del sistema.

  • Usted dispone de derechos de administración para su equipo.

  • Se han cerrado todas las aplicaciones que se estaban ejecutando.

Procedimiento

Para reparar una instalación directamente desde la interfaz de comandos, proceda del siguiente modo:

  1. Inicie el prompt de Windows con "Inicio > Ejecutar > cmd".

  2. Vaya al directorio que contiene el archivo "Start.exe".

  3. Introduzca en el prompt uno de los comandos siguientes:

    • Instalación con datos de instalación visibles: "Start.exe /qb REINSTALL=ALL <parámetro REBOOT>"

    • Instalación sin datos de instalación visibles: "Start.exe /qn REINSTALL=ALL <parámetro REBOOT>" o "Start.exe /silent REINSTALL=ALL <parámetro REBOOT>"

      Nota

      El parámetro REBOOT es opcional. Sin embargo, tenga en cuenta que, en caso de utilizar la opción "REBOOT=Suppress", deberá evaluar usted mismo el valor de retorno y reiniciar el sistema si éste se lo solicita.

  4. Confirme la entrada efectuada con <Intro>.


Desinstalación automatizada

Requisitos Procedimiento
Desinstalación automatizada

Para eliminar una instalación ya existente, existe la posibilidad de automatizar la desinstalación. En el proceso se desinstalan los paquetes de software enteros. La desinstalación automatizada se efectúa igual que la instalación automatizada desde la interfaz de comandos. El comportamiento de reinicio se define con un parámetro.

"REMOVE" sólo se puede combinar con los parámetros "REBOOT", "/qn" y "/qb". No se permite ningún otro parámetro.

Requisitos

  • Usted dispone de derechos de administración para su equipo.

  • Se han cerrado todas las aplicaciones que se estaban ejecutando.

Procedimiento

Para iniciar la desinstalación directamente desde la interfaz de comandos, proceda del siguiente modo:

  1. Inicie el prompt de Windows con "Inicio > Ejecutar > cmd".

  2. Vaya al directorio que contiene el archivo "Start.exe".

  3. Introduzca en el prompt uno de los comandos siguientes:

    • Desinstalación con datos de instalación visibles: "Start.exe /qb REMOVE=ALL <parámetro REBOOT>"

    • Desinstalación sin datos de instalación visibles: "Start.exe /qn REMOVE=ALL <parámetro REBOOT>" o "Start.exe /silent REMOVE=ALL <parámetro REBOOT>"

      Nota

      El parámetro REBOOT es opcional. Sin embargo, tenga en cuenta que, en caso de utilizar la opción "REBOOT=Suppress", deberá evaluar usted mismo el valor de retorno y reiniciar el sistema si éste se lo solicita.

  4. Confirme la entrada efectuada con <Intro>.


Ejemplos de instalaciones automatizadas mediante la línea de comandos

Ejemplo de una instalación típica con REBOOT=AUTO Ejemplo de una instalación completa con REBOOT=Suppress Ejemplo de cómo se consulta el valor de retorno con un archivo batch.
Ejemplos de instalaciones automatizadas mediante la línea de comandos

Ejemplo de una instalación típica con REBOOT=AUTO

El ejemplo siguiente muestra una instalación típica desde la línea de comandos:

Start.exe /qb REBOOT=Auto INSTALLLANGUAGE=1031;1033 INSTALLDIR="D:\TIAPortal" INSTALLLEVEL=Typical

En este ejemplo se ejecuta una instalación típica ("INSTALLLEVEL=Typical") con los idiomas alemán e inglés ("INSTALLLANGUAGE=1031;1033"). Al final de la instalación, el sistema se reinicia automáticamente ("REBOOT=Auto"). El directorio utilizado para la instalación es "D:\TIAPortal" ("INSTALLDIR=D:\TIAPortal").

Ejemplo de una instalación completa con REBOOT=Suppress

El ejemplo siguiente muestra una instalación completa desde la línea de comandos:

Start.exe /qb REBOOT=Suppress INSTALLLANGUAGE=1031;1033 INSTALLDIR="D:\TIAPortal" INSTALLLEVEL=Complete

En este ejemplo se ejecuta una instalación completa ("INSTALLLEVEL=Complete") con los idiomas alemán e inglés ("INSTALLLANGUAGE=1031;1033"). Al final de la instalación se suprime el reinicio del sistema ("REBOOT=Suppress"). Esto significa que usted mismo tiene que evaluar el valor de retorno y reiniciar manualmente el sistema si éste se lo solicita.

Ejemplo de cómo se consulta el valor de retorno con un archivo batch.

En el ejemplo siguiente se muestra cómo se consulta el valor de retorno con un archivo batch:

SET SetupSuccess=%ERRORLEVEL%

if '%SetupSuccess%' EQU '0' (

echo Setup successful. Return code: %SetupSuccess%

) else (

if '%SetupSuccess%' EQU '3010' (

echo Setup successful. A reboot is needed! Return code: %SetupSuccess%

) else (

echo "ERROR during Setup! Return code: %SetupSuccess%

)

)

pause

El valor de retorno "1641" refleja igualmente que la instalación ha terminado con éxito y que se ha iniciado el proceso de reinicio. No obstante, éste sólo se ejecuta si se utiliza "/REBOOT=Auto" y, por eso, no ha sido evaluado en el archivo batch del ejemplo.

Todos los valores de retorno posibles se encuentran en Valores de retorno del proceso de instalación.


Principios básicos de la instalación automática

Introducción Particularidades
Principios básicos de la instalación automática

Introducción

Si usted es responsable de administrar los paquetes de software en varios equipos, tiene diferentes posibilidades para automatizar la instalación.

Función Record/Play

Los siguientes procesos de instalación se pueden ejecutar de forma automatizada mediante la función Record/Play:

  • Instalación

    El software se instala de acuerdo con los parámetros utilizados.

  • Modificar o actualizar

    El software se vuelve a instalar de acuerdo con los parámetros utilizados.

Línea de comandos

Es posible automatizar los siguientes procesos de instalación mediante la línea de comandos:

  • Instalación

    El software se instala de acuerdo con los parámetros utilizados.

  • Modificar o actualizar

    El software se vuelve a instalar de acuerdo con los parámetros utilizados.

  • Reparar (REINSTALL)

    Esta opción permite reparar una instalación ya existente del software mediante una nueva instalación (reinstalación). El parámetro "REINSTALL" sólo se puede combinar con los parámetros "REBOOT", "/qn" y "/qb". Es decir, el software se instala con los mismos parámetros que se utilizaron en la instalación original.

  • Desinstalación (REMOVE)

    El software se elimina del sistema. El parámetro "REMOVE" sólo se puede combinar con los parámetros "REBOOT", "/qn" y "/qb".

Nota

Para instalar, modificar o actualizar, reparar o desinstalar de forma automática, es necesario utilizar uno de los dos parámetros "/qn" o "/qb". Si no se especifica ninguno de estos parámetros, se abrirá el diálogo de instalación normal, desde el que se puede efectuar una instalación manual.

Particularidades

  • Mediante la línea de comandos puede realizarse una sola modificación, p. ej. los idiomas del producto.

  • Mediante la línea de comandos se puede actualizar a una versión más actual. Al hacerlo, se actualizan solo las partes ya instaladas.

  • Mediante la línea de comandos no pueden instalarse o desinstalarse componentes individuales de productos. Si desea añadir partes individuales, utilice el modo Record/Play.

  • La desinstalación de componentes individuales no está soportada.

  • Solo puede realizarse una desinstalación completa. Tenga en cuenta que las partes que tengan entradas propias en el panel de control, en "Programas y características" no se desinstalan automáticamente.


Lista de parámetros

Parámetros para la instalación automatizada
Lista de parámetros

Parámetros para la instalación automatizada

La tabla siguiente muestra los parámetros disponibles para una instalación automatizada:

Parámetro

Descripción

Permitido para

Valores posibles

Explicación de los valores

/qb 1)

Con este parámetro se puede ejecutar una instalación automatizada. Durante la instalación se muestra información sobre la instalación en curso.

Notas:

  • Sin los parámetros "qb" o "qn" no se puede ejecutar una instalación automatizada.

  • Los parámetros "qn" y "qb" no se pueden utilizar juntos dentro de una misma llamada.

  • La información proporcionada durante la instalación se muestra en el idioma de instalación configurado. Dicha información concuerda con los textos de los archivos de registro. Estos últimos se necesitan, por ejemplo, cuando se solicita la ayuda del Product Support.

  • Los resultados de la instalación pueden consultarse mediante los valores de retorno.

Instalación

Reinstalación

Desinstalación

-

/qn o /silent 1)

Con este parámetro se puede ejecutar una instalación automatizada. Durante la instalación no se muestra información alguna sobre la instalación en curso.

Notas:

  • Sin los parámetros "qb" o "qn" no se puede ejecutar una instalación automatizada.

  • Los parámetros "qn" y "qb" no se pueden utilizar juntos dentro de una misma llamada.

  • Los resultados de la instalación pueden consultarse mediante los valores de retorno.

Instalación

Reinstalación

Desinstalación

-

/lcid

Con este parámetro se define el idioma que se va a utilizar durante la instalación. Para tal fin, introduzca en formato decimal la siguiente ID local (LCID) del idioma deseado.

Ejemplo:

/lcid=1031

Instalación

Reinstalación

Desinstalación

1031

Alemán

1033

Inglés

1040

Italiano

1036

Francés

3082

Español

2052

Chino

...

Idiomas del producto adicionales

/record

Con ayuda de este parámetro se puede iniciar el modo Record. Este genera el archivo "autoinstall.rec" para la instalación automática.

Instalación

/play

Con ayuda de este parámetro se puede iniciar el modo Play. En este modo necesitará el archivo de configuración que se crea en el modo Record.

Ejemplo:

/play="C:\Siemens Configurations\autoinstall.rec"

Instalación

INSTALLDIR 2)

Con este parámetro se define el directorio de destino de la instalación.

Ejemplo:

INSTALLDIR="D:\TIAPortal"

Instalación

INSTALLLANGUAGE

INSTALLLANGUAGE

Con este parámetro se definen los idiomas del producto que desea instalar. Para tal fin, introduzca en formato decimal las siguientes IDs locales (LCID) de los idiomas deseados.

Ejemplo:

INSTALLLANGUAGE=1031;1033

Instalación

1031

Alemán

1033

Inglés

1040

Italiano

1036

Francés

3082

Español

2052

Chino

...

Idiomas del producto adicionales

REBOOT

Con este parámetro se define el comportamiento de reinicio durante la instalación.

Ejemplo:

REBOOT=Suppress

Instalación

Reinstalación

Desinstalación

Auto

Al final de la instalación se ejecuta un reinicio automático si es necesario.

Suppress 3)

Al final de la instalación se suprime el reinicio. En caso de que fuese necesario un reinicio, el proceso invocante debe originar el reinicio.

Asimismo se inhibe el proseguimiento de la instalación si esta es necesaria después de reiniciar (con valor de retorno 13010).

ONERROR

Este parámetro permite definir el comportamiento en caso de error al final de la instalación.

Ejemplo:

ONERROR=Suppress

Instalación

Reinstalación

Desinstalación

Suppress

Al final de la instalación se suprimirá el diálogo con los errores producidos. Los fallos se pueden evaluar tomando como base los valores de retorno del proceso.

User

En caso de fallo, al final de la instalación se mostrará el diálogo con los errores producidos.

INSTALLLEVEL

Con este parámetro se define la modalidad de instalación.

Ejemplo:

INSTALLLEVEL=Complete

Instalación 4)

Minimal

Instalación mínima

Typical

Instalación típica

Complete

Instalación completa

1) La instalación con los parámetros /qb o /qn hace que no se muestren ventanas de aviso ni siquiera en caso de que aparezca un error. Los resultados solo pueden evaluarse a través del valor de retorno.

2) Tenga en cuenta que aquí debe indicarse la ruta real de Windows ("C:\Program Files\...", y no p. ej. "C:\Programas\...") ni tampoco rutas variables (p. ej. [ProgramFilesFolder]).
Este parámetro no es necesario si desea instalar en el directorio estándar (C:\Program Files\Siemens\Automation).

3) Si la instalación no se ha completado todavía (valor de retorno 13010), primero deberá reiniciar el sistema y después la instalación para que sea posible evaluar el valor de retorno.

4) Este parámetro solo puede utilizarse si se trata de la primera instalación del software.


Valores de retorno del proceso de instalación

Lista de valores de retorno
Valores de retorno del proceso de instalación

Lista de valores de retorno

La tabla siguiente muestra los valores de retorno de una instalación automatizada y su descripción:

Valor de retorno

Denominación técnica del error

Descripción

?

OtherError

Todos los valores de retorno que no aparecen descritos en la tabla por lo general significan que hay un error.

En el informe de la instalación encontrará información detallada sobre todos los errores. Para ello, abra el último archivo de registro (.log) cuyo nombre empiece por "SIA".

0

Success

Instalación ejecutada con éxito. No se ha producido ningún error.

5

AccessDenied

No tiene los derechos necesarios. Para la instalación se requieren derechos de administrador.

112

DiskFull

Capacidad de memoria insuficiente en el medio de destino.

1601

InstallServiceFailure

Se ha producido un error interno durante la fase de inicialización.

1602

UserExit

El usuario ha cancelado la instalación; normalmente esto ocurre por haber seleccionado "Cancelar" en el cuadro de diálogo.

1603

InstallFailure

Se ha producido un error durante la instalación.

1605

UnknownProduct

Se ha producido un error interno en la configuración del producto.

1610

BadConfiguration

Se ha producido un error interno en la configuración del producto.

1618

InstallAlreadyRunning

Ya hay otra instalación en curso. No es posible ejecutar más de una instalación al mismo tiempo.

1622

InstallLogFailure

Se ha producido un error al escribir en el archivo de registro.

1627

FunctionFailed

Se ha producido un error interno.

1633

InstallPlatformUnsupported

El sistema operativo no es compatible.

1639

InvalidCommandline

Existe un error en la línea de comandos indicada.

1641

SuccessRebootInitiated

Instalación ejecutada con éxito. Para terminar definitivamente el proceso, se ha lanzado un reinicio del sistema.

3010

SuccessRebootRequired

Instalación ejecutada con éxito. Para terminar definitivamente el proceso, es imprescindible reiniciar el sistema.

5001

PrerequisitesFailure

No se cumplen los requisitos necesarios para la instalación. Para obtener más información, puede volver a iniciar la instalación haciendo doble clic en start.exe.

5002

InvalidIEVersion

Internet Explorer no está instalado o la versión instalada no es compatible.

5003

ResourcesFailed

Se ha producido un error interno durante la fase de inicialización.

5004

ProductInitFailed

Se ha producido un error interno (es posible que el medio de instalación esté defectuoso).

5005

ProductInitNewerVersionInstalled

Ya hay instalada una versión más moderna del producto.

5006

ProductInitMoreValuableEditionInstalled

Ya está instalada una edición más amplia del producto (p. ej., se intenta instalar una versión básica aunque ya se cuenta con una versión profesional).

5007

ProductInitOptionalWithoutMain

Ha intentado instalar un paquete opcional sin el software principal.

5008

ProductIncompatibility

Ya existe un producto que es incompatible con el producto que se desea instalar.

5009

AutoinstallFileNotFound

No se ha encontrado el archivo para el modo Play.

5010

AutoinstallUnexpectedContent

El archivo para el modo Play no puede leerse (formato erróneo, versión incorrecta o medio de instalación inadecuado)

11641

NotCompleteReboot

La instalación no se ha completado y debe continuar tras el reinicio. El reinicio ya ha comenzado. Tras el reinicio se debe volver a iniciar la instalación.

13010

NotCompleteRebootRequired

La instalación no se ha completado y debe continuar tras el reinicio. Debe efectuar un reinicio y a continuación volver a iniciar la instalación.