Léame de SIMATIC Energy Suite

Ejemplos Consulte también Historial Herramientas
Léame de SIMATIC Energy Suite

Este capítulo incluye información sobre los siguientes temas:
  • Información de seguridad
  • Protección de datos
  • Novedades de SIMATIC Energy Suite V16
  • Novedades de SIMATIC Energy Suite V15.1
  • Novedades de SIMATIC Energy Suite V14 SP1
  • Migración de un proyecto de Energy Suite V14 SP1
  • Notas de uso


Información de seguridad

Protección de datos
Información de seguridad

Siemens ofrece productos y soluciones con funciones de seguridad industrial con el objetivo de hacer más seguro el funcionamiento de instalaciones, sistemas, máquinas y redes.

Para proteger las instalaciones, los sistemas, las máquinas y las redes de amenazas cibernéticas, es necesario implementar (y mantener continuamente) un concepto de seguridad industrial integral que sea conforme a la tecnología más avanzada. Los productos y las soluciones de Siemens constituyen únicamente una parte de este concepto.

El cliente es responsable de impedir el acceso no autorizado a sus instalaciones, sistemas, máquinas y redes. Los sistemas, las máquinas y los componentes solo deben estar conectados a la red corporativa o a Internet cuando y en la medida que sea necesario y siempre que se hayan tomado las medidas de protección adecuadas (p. ej. uso de cortafuegos y segmentación de la red).

Adicionalmente, deberán observarse las recomendaciones de Siemens en cuanto a las medidas de protección correspondientes. Encontrará más información sobre seguridad industrial en.

Los productos y las soluciones de Siemens están sometidos a un desarrollo constante con el fin de mejorar todavía más su seguridad. Siemens recomienda expresamente realizar actualizaciones en cuanto estén disponibles y utilizar únicamente las últimas versiones de los productos. El uso de versiones anteriores o que ya no se soportan puede aumentar el riesgo de amenazas cibernéticas.

Para mantenerse informado de las actualizaciones de productos, recomendamos que se suscriba al Siemens Industrial Security RSS Feed en.


Protección de datos

Protección de datos

Siemens tiene en cuenta los principios de la protección de datos, particularmente el de la minimización de datos (protección de datos integrada). Esto significa para este producto SIMATIC que no se procesan ni almacenan datos personales.


Novedades de SIMATIC Energy Suite V16

Novedades de Energy Suite V16 Gestión de cargas Mejoras
Novedades de SIMATIC Energy Suite V16

Novedades de Energy Suite V16

Todas las novedades importantes de Energy Suite V16 se resumen a continuación.

Gestión de cargas

  • El componente de la gestión de cargas asume una función de vigilancia en Energy Suite y garantiza que el consumo de potencia y energía no exceda el límite de energía definido por el usuario. El componente de la gestión de cargas incluye un elemento importante definido por el usuario: los denominados actuadores.

    Un programa de gestión de cargas consta, por ejemplo, de los siguientes bloques:

    • Bloque de previsión

    • Bloque de control

    • Bloque de actuadores

    • Bloque de copia de seguridad/restauración

    El bloque de previsión recibe los datos de entrada de la alimentación; es decir, del objeto de adquisición. Por ejemplo, en una central eléctrica, la alimentación es el suministro desde la red eléctrica. El bloque de previsión calcula o prevé el valor de potencia y energía medio que determinará la alimentación al final del periodo de tiempo establecido.

    Considere la posibilidad de vigilar una planta de producción mediante un componente de gestión de cargas. El bloque de previsión lee el valor de potencia de la entrada de alimentación y vigila el consumo de potencia. Se vigila constantemente el aprovechamiento de la energía en relación con un valor límite durante un periodo de tiempo determinado. Si la previsión excede el valor límite, la gestión de cargas hace que se desactiven los consumidores (actuadores) o a los productores. Este proceso se denomina "escalada". Tras el pico del valor de umbral, cuando el consumo de potencia es mínimo o se encuentra dentro del valor de umbral, se conecta el generador (actuador). Este proceso se denomina "desescalada".

  • La generación delta para la gestión de cargas y los objetos de adquisición está soportada; los bloques de actuadores agregados o modificados de los objetos de adquisición/gestión de cargas se añaden a los bloques existentes tras la generación. En caso de borrado, solo se borran los bloques seleccionados tras la generación, sin modificar los bloques existentes.

  • La creación automática de reglas de pantalla para bloques en Energy Suite está soportada.

  • Generación de pantalla

    • Soporte de la generación de pantalla automática para el programa de medición del consumo de energía con aparatos WinCC Professional y Comfort

    • Soporte de la generación de pantalla automática para el programa de gestión de cargas con aparatos WinCC Professional

Mejoras

  • Optimizaciones de rendimiento para el modo runtime para mejorar el aprovechamiento del tiempo de ciclo del PLC en mediciones de largo plazo.

  • La generación delta del programa de energía independiente del runtime para la adquisición del consumo de energía y la gestión de cargas es posible cuando hay modificaciones delta, como la agregación o modificación en el caso de los objetos de adquisición para la adquisicón o actuadores para la gestión de cargas.

  • Si al configurar un proyecto de Energy Suite agrega una nueva tabla de objetos de adquisición, deberá descargar WinCC.

  • Si inserta objetos de adquisición en la tabla de objetos de adquisición, deberá descargar WinCC.


Novedades de SIMATIC Energy Suite V15.1

Novedades de Energy Suite V15.1 Optimización de la conexión de hardware de medición como fuente de datos de energía
Novedades de SIMATIC Energy Suite V15.1

Novedades de Energy Suite V15.1

A continuación se resumen todas las novedades importantes de Energy Suite V15.

Optimización de la conexión de hardware de medición como fuente de datos de energía

  • Energy Suite reconoce como fuente de datos de energía el siguiente hardware de medición configurado con la interfaz integrada en STEP 7 (TIA Portal) o con el archivo de datos maestros del aparato:

    • ET 200SP AI Energy Meter 480VAC HF

    • Arrancador suave 3RW55

  • Energy Suite detecta la configuración del hardware de medición antes mencionado y crea automáticamente los respectivos bloques durante la generación del programa de energía.

  • La librería de Energy Suite contiene faceplates instalados automáticamente para la visualización del programa de energía.

  • Un proyecto creado en Energy Suite V15.0 con archivado PLC genera un archivo de registro de datos. Si abre ese mismo proyecto en V15.1, TIA Portal le solicitará que actualice el proyecto a V15.1. Tras actualizar el proyecto a la versión V15.1 y una vez finalizado el nuevo proceso de generación y carga, se crea un nuevo archivo de registro de datos.


Novedades de SIMATIC Energy Suite V14 SP1

Novedades de Energy Suite V14 SP1 Generación del programa de energía también para datos de energía avanzados Creación automática de informes con Energy Suite Export Tool Información detallada y respuestas sobre el progreso de generación Ampliación de la estructura de los metadatos
Novedades de SIMATIC Energy Suite V14 SP1

Novedades de Energy Suite V14 SP1

Todas las novedades importantes con respecto a Energy Suite V14 están resumidas a continuación.

Generación del programa de energía también para datos de energía avanzados

  • Para generar el programa de energía también para datos de energía avanzados (p. ej., intensidades, tensiones, frecuencia, etc.), se ofrecen los siguientes comandos nuevos en el menú contextual del objeto "Objetos de energía" en el árbol del proyecto:

    • Datos de energía básicos

    • Datos de energía básicos y avanzados

    • Datos de energía básicos y avanzados (con valores mínimos/máximos)

  • Energy Suite reconoce qué datos de energía puede proporcionar el hardware de medición correspondiente y crea automáticamente los respectivos bloques durante la generación del programa de energía.

Encontrará más información en el apartado "Generar el programa de energía" del manual del usuario de SIMATIC Energy Suite.

Creación automática de informes con Energy Suite Export Tool

  • Nueva creación automática de informes a partir de plantillas de informe configurables.

  • Se ofrecen las siguientes periodicidades de informe automáticas:

    • Diaria

    • Semanal

    • Mensual

    • Anual

  • Para analizar rápidamente los errores en caso de comportamiento inesperado, los mensajes de error se almacenan localmente en "C:\Program Files (x86)\Siemens\Automation\SCADA-RT_V11\WinCC\bin\config".

Encontrará más información en el apartado "Evaluación de los datos de energía con Energy Suite Export Tool" del manual del usuario de SIMATIC Energy Suite.

Información detallada y respuestas sobre el progreso de generación

  • Para una mejor reproducibilidad del proceso de generación, se muestran información y eventos sobre la generación del programa de energía.

  • Con la función "Ir a" puede saltar hasta la posición de la configuración que sea relevante para el evento en cuestión.

Encontrará más información en el apartado "Generar el programa de energía" del manual del usuario de SIMATIC Energy Suite.

Ampliación de la estructura de los metadatos

La estructura de los metadatos de los objetos de energía se ha ampliado para fines de compatibilidad y análisis.

Encontrará más información en el apartado "Bloques Energy Suite" del manual del usuario de SIMATIC Energy Suite.


Migración de un proyecto de Energy Suite V14 SP1

Requisitos Procedimiento
Migración de un proyecto de Energy Suite V14 SP1

Para migrar proyectos de Energy Suite de la versión V14 SP1 a V16 debe adaptarse manualmente la instrucción "Get_IM_Data" de STEP 7 a la versión actual. De lo contrario, se producirán errores de compilación durante el proceso de compilación.

Requisitos

  • Hay un proyecto de Energy Suite en la versión V14 SP1.

  • TIA Portal V16 con Energy Suite V16 está instalado.

Procedimiento

Para evitar errores de compilación al migrar un proyecto de Energy Suite de V14 SP1 a V16, proceda del modo siguiente:

  1. Abra en V16 el proyecto creado en Energy Suite V14 SP1.

    A continuación, se abre el cuadro de diálogo "Abrir proyecto".

  2. En el cuadro de diálogo "Abrir proyecto", haga clic en el botón "Actualizar".

  3. Tras migrar correctamente el proyecto, abra la CPU SIMATIC S7-1500 configurada en el árbol del proyecto.

  4. Abra un bloque cualquiera (OB, FB o FC) debajo de la carpeta "Bloques de programa".

  5. Abra la carpeta "Instrucciones avanzadas > Diagnóstico" en la Task Card "Instrucciones".

    La instrucción "Get_IM_Data" tiene la versión "V1.2" en el ajuste predeterminado.

  6. Seleccione la versión "V1.3" deseada en la lista desplegable.

  7. A continuación, reanude la generación de su programa de energía.

  8. Debajo de la CPU S7-1500 configurada haga clic en el objeto "Bloques de programa".

  9. Elija el comando "Compilar > Software (compilar todos los bloques)" en el menú contextual.

    El programa de energía se compila. Para comprobar si la compilación se ha llevado a cabo correctamente, seleccione "Información > Compilar" en la ventana de inspección.

Para evitar que se produzca un error debido a un conflicto de las versiones de las librerías, haga lo siguiente cuando migre proyectos Energy Suite de las versiones V15 e inferiores a la versión V16:

  • En las instrucciones básicas "Serialize" y "Deserialize" es preciso actualizar la versión manualmente de V2.0 a V2.1.

  • En la instrucción avanzada "GetSMCinfo" es preciso actualizar la versión manualmente de V1.0 a V1.1.


Notas de uso

Contenidos Upgrade de proyectos Energy Suite en un proyecto multiusuario Datos de energía de un hardware de medición Transferencia de datos al sistema SCADA Generación del programa de energía Bloques Energy Suite Valor límite para variables HMI
Notas de uso

Contenidos

La información de este texto tiene preferencia frente a los datos de otros documentos.

Lea detenidamente las indicaciones siguientes. Contienen información importante para la instalación y el uso. Lea las presentes indicaciones antes de iniciar la instalación.

También encontrará información actualizada sobre Energy Suite en el portal informativo de Siemens Industry Online Support.

Encontrará información sobre las instrucciones de servicio de SIMATIC Energy Support Library en el archivo Léame "ReadMeEnSLenUS.chm" incluido en el soporte de instalación.

Upgrade de proyectos

Un proyecto de Energy Suite creado en versiones anteriores a V16 con archivado de PLC genera un archivo de registro de datos. Se aplican los escenarios siguientes para archivos de registro de datos:

  • Si actualiza (upgrade) a V16 un proyecto de Energy Suite creado con una versión anterior a V16 y luego carga el proyecto en el PLC sin generar el programa, el archivado del PLC continuará en el mismo archivo de registro de datos.

  • Si actualiza (upgrade) a V16 un proyecto de Energy Suite creado con una versión anterior a V16 con generación del programa y luego carga el proyecto en el PLC, el archivado del PLC continuará en un nuevo archivo de registro de datos.

  • Los números de DB existentes cambian al actualizar (upgrade) proyectos hasta la versión V16 durante una generación delta.

  • Si actualiza (upgrade) a V16 un proyecto de Energy Suite creado con una versión anterior a V15, deberá borrar los bloques LAcycCOM manualmente en cuanto se haya actualizado el proyecto y, a continuación, volver a generar el programa de energía.

  • El DB LAcycCom_RequestBuffer está disponible entre los bloques del programa de Energy Suite (prefijo "EnS").

  • Los proyectos de la versión V14 SP1 o V15 notifican errores de compilación al compilar el FB Ens_LmgtBackupRestore, si se actualiza a la V16 con la versión de firmware V2.8 estando activada la opción de pronóstico en la tabla de objetos de adquisición con actuadores de gestión de cargas configurados.

  • En los proyectos de la versión V14 SP1 o V15 falla la generación de un programa cuando se actualiza a la versión V16 con un Datalog de más de 26 caracteres.

Energy Suite en un proyecto multiusuario

Abra un proyecto multiusuario solo en la vista de proyectos de servidor y no en la sesión local.

Datos de energía de un hardware de medición

Al configurar el hardware de medición como fuente de datos de energía, dependiendo del hardware de medición empleado se evaluarán distintos ajustes de tipos de datos.

La tabla siguiente muestra los ajustes necesarios para el hardware de medición soportado:

Hardware de medición | Tipo de datos de energía | Unidad | Factor de normalización | Valor de desbordamiento
AI EnergyMeter 480VAC ST | Valor de contador de energía | Wh | 1 | 1.000.000.000.000.000 = 1 * 10^15 (*)
AI EnergyMeter 480VAC HF | Valor de contador de energía | Wh | 1 | 1.000.000.000.000.000 = 1 * 10^15 (*)
SENTRON PAC3200/PAC4200 | Valor de contador de energía | Wh | 1 | 1 * 10^12
SENTRON 3VA (ETU de 8) | Valor de contador de energía | Wh | 1 | 4 * 10^12
SINAMICS AC/AC | Valor de potencia | W | 1 | -
SIMOCODE pro V PN | Valor de contador de energía | Wh | 1 | 2.147.483.648.000
Arrancador de motor ET 200SP/M200D | Valor de potencia | W | 1 | -
Arrancador suave 3RW44 | Valor de potencia | W | 1 | -
Arrancador suave 3RW55 | Valor de potencia | W | 1 | -

(*) Asegúrese de que el contador de energía muestre el valor de desbordamiento tanto en los ajustes de Energy Suite como en la configuración hardware de AI EnergyMeter 480VAC ST/HF. La configuración hardware se encuentra en la ventana de inspección "Propiedades", en "Parámetros del módulo > Configuración AI > Medición > Valor final del contador de energía".

Asegúrese de que la parametrización coincida con la tabla de arriba.

Transferencia de datos al sistema SCADA

Si hace cambios en el programa de energía, vuelva a generarlo y cárguelo en la CPU.

Cargue las modificaciones en la CPU únicamente si los bloques de búfer están vacíos. Al cargar en la CPU (completa), la CPU se debe reiniciar a continuación. Al cargar en la CPU (solo cambios) se debe reinicializar el bloque de datos "EnS_BufferWorkDB". Encontrará más información al respecto en la ayuda en pantalla del sistema de información de TIA Portal.

Generación del programa de energía

Compruebe los ajustes siguientes si falla la generación del programa de energía:

  • Fuente de datos de energía: los aspectos siguientes se deben configurar según el manual:

    • Configuración hardware del hardware de medición (véase documentación "Hardware de medición para SIMATIC Energy Suite en el TIA Portal")

    • Tipo de datos (véase apartado "Datos de energía procedentes de bloques de datos")

    • Reglas de nomenclatura (véase apartado "Características y convenciones")

  • Período de archivado: Cada objeto de adquisición tiene asignado exactamente un período de archivado.

  • Nombre del objeto de adquisición: El objeto de adquisición no puede tener el mismo nombre que los objetos siguientes:

    • Bloque de programa

    • Objeto tecnológico

    • Fuente externa

    • Variable PLC

    • Tipo de datos PLC

  • General: Los prefijos "EnS_" (salvo "EnS_EEm_" para el monitor de eficiencia energética S7), "EnSL_" y "LAcycCom_" son prefijos del sistema reservados y no se utilizan en el nombre de los objetos arriba mencionados.

Antes de volver a generar el programa de energía, asegúrese de que se cumplan los ajustes arriba mencionados.

  • El rango de valores para la gestión de cargas puede abarcar de 1 a 26 caracteres.

  • El rango de valores para el actuador de prioridades puede abarcar de 1 a 1999 caracteres.

Para compilar correctamente los dispositivos Comfort Panel con gestión de cargas y adquisición de los datos de energía y generación de SiVArc:

  • Es necesario borrar manualmente las variables HMI de tipo LMGT - variables internas y EnS_Visu, ya que no son compatibles con WinCC Comfort.

  • Es necesario vincular las variables correspondientes para los objetos de ventana emergente.

  • Si solamente se crea el programa de adquisición de energía en el PLC y las imágenes con la opción "Iniciar generación SiVArc con diálogo de selección de estaciones" deberá borrar manualmente la tabla de variables "LMGT - variables internas".

En la configuración de un proyecto Energy Suite:

  • Cada vez que agregue una tabla de objetos de adquisición deberá descargar WinCC.

  • Al insertar objetos de adquisición en la tabla de objetos de adquisición, deberá descargar WinCC.

Bloques Energy Suite

EnS_CalcEnergyData: calcular valores de energía

El reset del contador de energía durante un periodo de archivado activo provoca un cálculo de valores de energía negativos para este periodo.

EnSL_DrvBasic_Sina_vx: Registrar datos básicos de energía

Contrariamente a lo expuesto en la documentación "Hardware de medición para SIMATIC Energy Suite en el TIA Portal", el código de error "W#16#8011" no existe en el parámetro de salida "Status".

Valor límite para variables HMI

En la configuración de runtime de la HMI, el nombre del PLC se agrega al nombre de la variable si está activada la casilla de verificación "Nombre de PLC como prefijo del nombre de variable HMI". Tras generar la pantalla de SiVArc, a la que sigue la compilación de la HMI, aparece un mensaje de error si el nombre de la variable HMI excede una longitud de 128 caracteres.