Installation automatisée

Exemples Voir aussi Historique Outils
Installation automatisée

Ce chapitre contient des informations sur les sujets suivants :
  • Installation automatique via le mode Record/Play
  • Installation automatique via la ligne de commande
  • Notions de base de l'installation automatisée
  • Liste des paramètres
  • Valeurs retournées par le processus d'installation


Installation automatique via le mode Record/Play

Installation automatique via le mode Record/Play

Ce chapitre contient des informations sur les sujets suivants :
  • Lancer l'enregistrement
  • Sélection des paramètres de l'installation
  • Lecture de l'enregistrement


Lancer l'enregistrement

Condition requise Marche à suivre Résultat
Lancer l'enregistrement

Condition requise

  • Le matériel et le logiciel de votre PG/PC sont conformes aux exigences du système.

Marche à suivre

Pour enregistrer l'installation, procédez comme suit :

  1. Ouvrez l'invite de commande de Windows par "Démarrer > Exécuter > cmd".

  2. Passez au répertoire contenant le fichier "Start.exe".

  3. Entrez la commande suivante dans l'invite de commande :

    • "Start.exe /record"

  4. Validez votre entrée avec <Return>.

Résultat

La boîte de dialogue de l'installation s'ouvre, vous indiquant que vous vous trouvez en mode Record et que le système n'est pas modifié.


Sélection des paramètres de l'installation

Marche à suivre Résultat
Sélection des paramètres de l'installation

Marche à suivre

Procédez comme suit pour sélectionner les options de l'installation :

  1. Dans la boîte de dialogue de sélection de la langue d'installation, sélectionnez la langue dans laquelle vous souhaitez que le programme d'installation s'affiche et cliquez sur le bouton "Suivant".

    La boîte de dialogue permettant de sélectionner la langue de produit s'ouvre.

  2. Sélectionnez la langue pour la vue du produit et cliquez sur le bouton "Suivant".

    Remarque

    La langue de produit "Anglais" est toujours installée par défaut.

    La boîte de dialogue de sélection de la configuration du produit s'ouvre.

  3. Sélectionnez les produits que vous souhaitez installer :

    • si vous voulez installer le programme avec un nombre minimum de composants, cliquez sur le bouton "minimale".

    • si vous voulez installer le programme avec un nombre de composants typique pour un produit, cliquez sur le bouton "typique".

    • Lorsque vous souhaitez sélectionner vous-même les produits à installer, activez/désactivez les cases à cocher des produits que vous souhaitez installer. Le bouton "Personnalisé" est à cet effet automatiquement activé.

  4. Si vous voulez créer un raccourci sur le bureau, cochez la case "Créer un raccourci sur le bureau".

  5. Cliquez sur le bouton de commande "Parcourir" si vous désirez modifier le répertoire cible pour l'installation.

    Remarque

    Il est recommandé de choisir le dossier "Program Files" comme répertoire cible. Si vous sélectionnez un lecteur de l'ordinateur (par ex. "D:"), assurez-vous qu'il soit présent sur tous les ordinateurs sur lesquels le programme doit être installé.

  6. Cliquez sur le bouton "Suivant".

    La boîte de dialogue relative aux conditions d'octroi de licence s'ouvre.

  7. Afin de poursuivre l'installation, vous devrez lire et accepter toutes les conventions de licence puis cliquer sur "Continuer".

    Si l'installation du portail TIA nécessite une modification des paramètres de sécurité et droits d'accès, la boîte de dialogue des paramètres de sécurité s'ouvre.

  8. Afin de poursuivre l'installation, confirmez les modifications des paramètres de sécurité et des droits puis cliquez sur le bouton "Suivant".

    La boîte de dialogue suivante affiche une vue d'ensemble des paramètres d'installation.

  9. Vérifiez les paramètres d'installation sélectionnés. Si vous souhaitez effectuer des modifications, cliquez sur le bouton "Précédent" jusqu'à parvenir à l'endroit à modifier dans la boîte de dialogue. Après avoir effectué les modifications voulues, retournez à la vue d'ensemble en cliquant sur "Suivant".

  10. Cliquez sur le bouton "Suivant".

    La boîte de dialogue de comportement en cas de redémarrage et d'erreurs s'ouvre.

  11. Sélectionnez les options souhaitées et enregistrez la configuration.

  12. Cliquez sur le bouton "Terminer".

Résultat

Le fichier pour l'installation automatique a été créé et enregistré.


Lecture de l'enregistrement

Condition requise Marche à suivre Résultat
Lecture de l'enregistrement

Condition requise

  • Le matériel et le logiciel de votre PG/PC sont conformes aux exigences du système.

  • Vous disposez des droits d'administrateur sur votre ordinateur.

  • Le fichier ("*.rec") enregistré précédemment est disponible.

  • Vous avez quitté tous les programmes en cours.

Marche à suivre

Pour exécuter l'installation, procédez comme suit :

  1. Ouvrez l'invite de commande de Windows par "Démarrer > Exécuter > cmd".

  2. Passez au répertoire contenant le fichier "Start.exe".

  3. Entrez la commande suivante dans l'invite de commande :

    • "Start.exe /play=<Lecteur>:\<Répertoire>\<Nom du fichier>", par ex. "Start.exe /play=c:\siemens configuration\autoinstall.rec"

  4. Validez votre entrée avec <Return>.

    Remarque

    Si aucune clé de licence n'est trouvée pendant l'installation, l'impasse est faite sur le transfert de licence que vous pouvez effectuer ultérieurement avec Automation License Manager.

Résultat

L'installation est effectuée automatiquement à l'aide des paramètres enregistrés dans le fichier de configuration.


Installation automatique via la ligne de commande

Installation automatique via la ligne de commande

Ce chapitre contient des informations sur les sujets suivants :
  • Automatiser l'installation
  • Automatiser la mise à jour
  • Automatisation d'une réparation
  • Automatisation de la désinstallation
  • Exemples d'installations automatisées via la ligne de commande


Automatiser l'installation

Condition requise Marche à suivre
Automatiser l'installation

Condition requise

  • Le matériel et le logiciel de votre PG/PC sont conformes aux exigences du système.

  • Vous disposez des droits d'administrateur sur votre ordinateur.

  • Vous avez quitté tous les programmes en cours.

Marche à suivre

Pour démarrer l'installation directement via l'interface de commande, avec les options souhaitées, procédez comme suit :

  1. Ouvrez l'invite de commande de Windows par "Démarrer > Exécuter > cmd".

  2. Passez au répertoire contenant le fichier "Start.exe".

  3. Entrez à la suite de l'invite de commande l'une des commandes suivantes :

    • Installation avec affichage des informations sur l'installation : "Start.exe /qb <Paramètre>"

    • Installation sans affichage des informations sur l'installation : "Start.exe /qn <Paramètre>" ou "Start.exe /silent <Paramètre>"

      Remarque

      L'installation avec les paramètres /qb ou /qn a pour effet qu'aucune fenêtre des alarmes n'est affichée, même si une erreur se produit. Vous pouvez exploiter les résultats uniquement via la valeur en retour.

      Notez qu'avec l'utilisation de l'option "REBOOT=Suppress", vous devez exploiter vous-même la valeur de retour et redémarrer le cas échéant le système, puis redémarrer l'installation après redémarrage pour que la lecture de la valeur de retour soit de nouveau possible.

  4. Validez votre entrée avec <Return>.


Automatiser la mise à jour

Condition requise Marche à suivre
Notions de base de l'installation automatisée
Automatiser la mise à jour

Vous pouvez automatiser la mise à jour (update) des produits installés. Lancez pour ce faire une réinstallation avec les options souhaitées directement à partir de la ligne de commande.

Condition requise

  • Le matériel et le logiciel de votre PG/PC sont conformes aux exigences du système.

  • Vous disposez des droits d'administrateur sur votre ordinateur.

  • Vous avez quitté tous les programmes en cours.

Marche à suivre

Pour mettre à jour des produits installés directement à partir de la ligne de commande, procédez comme suit :

  1. Ouvrez l'invite de commande de Windows par "Démarrer > Exécuter > cmd".

  2. Passez au répertoire contenant le fichier "Start.exe".

  3. Entrez à la suite de l'invite de commande l'une des commandes suivantes :

    • Installation avec affichage des informations sur l'installation : "<Paramètre>Start.exe /qb"

    • Installation sans affichage des informations sur l'installation : "<Paramètre>Start.exe /qn" ou "<Paramètre>Start.exe /silent"

      Remarque

      L'installation avec les paramètres /qb ou /qn a pour effet qu'aucune fenêtre des alarmes n'est affichée, même si une erreur se produit. Vous pouvez exploiter les résultats uniquement via la valeur en retour.

      Notez qu'avec l'utilisation de l'option "REBOOT=Suppress", vous devez exploiter vous-même la valeur de retour et redémarrer le cas échéant le système, puis redémarrer l'installation après redémarrage pour que la lecture de la valeur de retour soit de nouveau possible.

  4. Validez votre entrée avec <Return>.


Automatisation d'une réparation

Condition requise Marche à suivre
Automatisation d'une réparation

Si, après avoir installé un logiciel, vous lancez à nouveau "Start.exe" avec le paramètre "REINSTALL=ALL", tous les composants sont réinstallés comme c'est le cas lorsque vous sélectionnez "Réparer" lors d'une installation en mode interactif. L'installation est identique à l'installation initiale. La réparation automatisée s'effectue comme l'installation automatisée via la ligne de commande. Le comportement de redémarrage peut ce faisant être spécifié à l'aide d'un paramètre.

Vous ne pouvez combiner le paramètre "REINSTALL" qu'avec les paramètres "REBOOT", "/qn" et "/qb". Tous les autres paramètres sont interdits.

Condition requise

  • Le matériel et le logiciel de votre PG/PC sont conformes aux exigences du système.

  • Vous disposez des droits d'administrateur sur votre ordinateur.

  • Vous avez quitté tous les programmes en cours.

Marche à suivre

Pour réparer un logiciel installé directement, à partir de la ligne de commande, procédez comme suit :

  1. Ouvrez l'invite de commande de Windows par "Démarrer > Exécuter > cmd".

  2. Passez au répertoire contenant le fichier "Start.exe".

  3. Entrez à la suite de l'invite de commande l'une des commandes suivantes :

    • Installation avec affichage des informations sur l'installation : "Start.exe /qb REINSTALL=ALL <Paramètre REBOOT>"

    • Installation sans affichage des informations sur l'installation : "Start.exe /qn REINSTALL=ALL <Paramètre REBOOT>" ou "Start.exe /silent REINSTALL=ALL <Paramètre REBOOT>"

      Remarque

      Le paramètre REBOOT est facultatif. Veuillez noter cependant qu'en cas d'utilisation de l'option "REBOOT=Suppress", vous devez exploiter vous-même la valeur retournée et éventuellement redémarrer le système.

  4. Validez votre entrée avec <Return>.


Automatisation de la désinstallation

Condition requise Marche à suivre
Automatisation de la désinstallation

Si vous voulez supprimer le logiciel installé, vous pouvez procéder à une désinstallation automatisée. Tous les progiciels seront alors désinstallés en une opération. La désinstallation automatisée s'effectue comme l'installation automatisée via la ligne de commande. Le comportement de redémarrage peut ce faisant être spécifié à l'aide d'un paramètre.

Vous ne pouvez combiner le paramètre "REMOVE" qu'avec les paramètres "REBOOT", "/qn" et "/qb". Tous les autres paramètres sont interdits.

Condition requise

  • Vous disposez des droits d'administrateur sur votre ordinateur.

  • Vous avez quitté tous les programmes en cours.

Marche à suivre

Pour désinstaller un logiciel installé, directement à partir de la ligne de commande, procédez comme suit :

  1. Ouvrez l'invite de commande de Windows par "Démarrer > Exécuter > cmd".

  2. Passez au répertoire contenant le fichier "Start.exe".

  3. Entrez à la suite de l'invite de commande l'une des commandes suivantes :

    • Désinstallation avec informations de désinstallation visibles : "Start.exe /qb REMOVE=ALL <Paramètre REBOOT>"

    • Désinstallation sans informations de désinstallation visibles : "Start.exe /qn REMOVE=ALL <Paramètre REBOOT>" ou "Start.exe /silent REMOVE=ALL <Paramètre REBOOT>"

      Remarque

      Le paramètre REBOOT est facultatif. Veuillez noter cependant qu'en cas d'utilisation de l'option "REBOOT=Suppress", vous devez exploiter vous-même la valeur retournée et éventuellement redémarrer le système.

  4. Validez votre entrée avec <Return>.


Exemples d'installations automatisées via la ligne de commande

Exemple d'une installation typique avec REBOOT=AUTO Exemple d'une installation complète avec REBOOT=Suppress Exemple d'interrogation de la valeur retournée par fichier batch.
Exemples d'installations automatisées via la ligne de commande

Exemple d'une installation typique avec REBOOT=AUTO

L'exemple suivant montre une installation typique via la ligne de commande :

Start.exe /qb REBOOT=Auto INSTALLLANGUAGE=1031;1033 INSTALLDIR="D:\TIAPortal" INSTALLLEVEL=Typical

Dans cet exemple, il s'agit d'une installation typique ("INSTALLLEVEL=Typical") en allemand et en anglais ("INSTALLLANGUAGE=1031;1033"). En fin d'installation, le système est redémarré automatiquement, sans avertissement ("REBOOT=Auto"). Le répertoire d'installation utilisé est "D:\TIAPortal" ("INSTALLDIR=D:\TIAPortal").

Exemple d'une installation complète avec REBOOT=Suppress

L'exemple suivant montre une installation complète via la ligne de commande :

Start.exe /qb REBOOT=Suppress INSTALLLANGUAGE=1031;1033 INSTALLDIR="D:\TIAPortal" INSTALLLEVEL=Complete

Dans cet exemple, il s'agit d'une installation complète ("INSTALLLEVEL=Complete") en allemand et en anglais ("INSTALLLANGUAGE=1031;1033"). A la fin de l'installation, le redémarrage est inhibé ("REBOOT=Suppress"). Vous devez par conséquent exploiter vous-même la valeur retournée et, si nécessaire, redémarrer le système.

Exemple d'interrogation de la valeur retournée par fichier batch.

L'exemple ci-après montre comment interroger la valeur retournée par fichier batch :

SET SetupSuccess=%ERRORLEVEL%

if '%SetupSuccess%' EQU '0' (

echo Setup successful. Return code: %SetupSuccess%

) else (

if '%SetupSuccess%' EQU '3010' (

echo Setup successful. A reboot is needed! Return code: %SetupSuccess%

) else (

echo "ERROR during Setup! Return code: %SetupSuccess%

)

)

pause

La valeur retournée "1641" documente également une installation réussie et la préparation d'un redémarrage. Ce dernier, n'intervenant cependant qu'en cas d'utilisation de "/REBOOT=Auto", il n'a pas été traité dans le fichier batch.

Vous trouverez toutes les valeurs retournées possibles sous Valeurs retournées par le processus d'installation.


Notions de base de l'installation automatisée

Introduction Particularités
Notions de base de l'installation automatisée

Introduction

Si vous êtes responsable de la gestion des progiciels sur plusieurs ordinateurs, vous disposez de différentes possibilités pour automatiser l'installation.

Fonction Record/Play

Vous pouvez laisser s'exécuter automatiquement les processus d'installation suivants via la fonction Record/Play :

  • Installation

    Le logiciel est installé en fonction des paramètres utilisés.

  • Modification ou mise à jour

    Le logiciel est à nouveau installé en fonction des paramètres utilisés.

Ligne de commande

Vous pouvez laisser s'exécuter automatiquement les processus d'installation suivants via la ligne de commande :

  • Installation

    Le logiciel est installé en fonction des paramètres utilisés.

  • Modification ou mise à jour

    Le logiciel est à nouveau installé en fonction des paramètres utilisés.

  • Réparation (REINSTALL)

    Cette option répare un logiciel installé par une réinstallation. Vous ne pouvez combiner le paramètre "REINSTALL" qu'avec les paramètres "REBOOT", "/qn" et "/qb". Le logiciel est alors installé avec les mêmes paramètres que lors de l'installation initiale.

  • Désinstallation (REMOVE)

    Le logiciel est supprimé du système. Vous ne pouvez combiner le paramètre "REMOVE" qu'avec les paramètres "REBOOT", "/qn" et "/qb".

Remarque

Pour automatiser une installation, modification, mise à jour, réparation ou désinstallation, utilisez l'un des deux paramètres "/qn" ou "/qb". Si vous omettez ces paramètres, le dialogue d'installation qui s'ouvre, est le dialogue normal de l'installation manuelle.

Particularités

  • La ligne de commande ne permet qu'une seule modification, par ex. les différentes langues du produit.

  • La ligne de commande permet la mise à niveau à une version plus récente. Seules les parties déjà installées sont alors mises à niveau.

  • La ligne de commande ne permet pas l'installation ou la désinstallation de parties du produit. Si vous souhaitez installer en complément d'autres parties, utilisez le mode Record/Play.

  • La désinstallation de parties du produit n'est pas prise en charge.

  • Seule une désinstallation complète est possible. Veillez cependant, à ce que les parties qui possèdent leurs propres entrées dans le panneau de configuration sous "Programmes et fonctions" ne soient pas supprimées automatiquement.


Liste des paramètres

Paramètres de l'installation automatisée
Liste des paramètres

Paramètres de l'installation automatisée

Le tableau suivant présente les paramètres dont vous disposez pour une installation automatisée :

Paramètres

Description

Utilisable pour

Valeurs possibles

Explication des valeurs

/qb 1)

Ce paramètre permet de réaliser une installation automatisée. Pendant l'installation, vous obtenez des informations sur l'installation en cours.

Nota :

  • Une utilisation automatisée n'est pas possible sans l'emploi des paramètres "qb" ou "qn".

  • Les paramètres "qn" et "qb" ne peuvent pas être utilisés simultanément dans un même appel.

  • Les informations vous sont fournies durant installation dans la langue d'installation paramétrée. Ces informations sont par conséquent en harmonie avec les textes des fichiers de rapport. Les fichiers de rapport sont utiles p. ex. lorsque vous contactez le Support.

  • Vous pouvez consulter les résultats de l'installation dans les valeurs en retour.

Installation

Réinstallation

Désinstallation

-

/qn ou /silent 1)

Ce paramètre permet de réaliser une installation automatisée. Pendant l'installation, aucune information ne vous est fournie sur l'installation en cours.

Nota :

  • Une utilisation automatisée n'est pas possible sans l'emploi des paramètres "qb" ou "qn".

  • Les paramètres "qn" et "qb" ne peuvent pas être utilisés simultanément dans un même appel.

  • Vous pouvez consulter les résultats de l'installation dans les valeurs en retour.

Installation

Réinstallation

Désinstallation

-

/lcid

Ce paramètre vous permet de fixer la langue d'installation que vous souhaitez installer. Pour ce faire, entrez les ID locaux suivants (LCID) de la langue souhaitée au format décimal :

Exemple :

/lcid=1031

Installation

Réinstallation

Désinstallation

1031

Allemand

1033

Anglais

1040

Italien

1036

Français

3082

Espagnol

2052

Chinois

...

Autres langues du produit

/record

Ce paramètre vous permet de lancer le mode Record. Celui-ci génère le fichier "autoinstall.rec" pour l'installation automatique

Installation

/play

Ce paramètre vous permet de lancer le mode Play. Dans ce mode, vous avez besoin du fichier de configuration créé dans le mode Record.

Exemple :

/play="C:\Siemens Configurations\autoinstall.rec"

Installation

INSTALLDIR 2)

Ce paramètre vous permet de fixer le répertoire cible pour l'installation.

Exemple :

INSTALLDIR="D:\TIAPortal"

Installation

INSTALLLANGUAGE

INSTALLLANGUAGE

Ce paramètre vous permet de fixer les langues du produit que vous désirez installer. Pour ce faire, entrez les ID locaux suivants (LCID) des langues souhaitées au format décimal :

Exemple :

INSTALLLANGUAGE=1031;1033

Installation

1031

Allemand

1033

Anglais

1040

Italien

1036

Français

3082

Espagnol

2052

Chinois

...

Autres langues du produit

REBOOT

Ce paramètre vous permet de fixer le comportement de démarrage au cours de l'installation.

Exemple :

REBOOT=Suppress

Installation

Réinstallation

Désinstallation

Auto

A la fin de l'installation, le système redémarre automatiquement, si nécessaire.

Suppress 3)

A la fin de l'installation, le redémarrage est inhibé. Si un nouveau démarrage est indispensable, le processus appelant doit déclencher le nouveau démarrage.

La poursuite de l'installation, si elle est nécessaire après le redémarrage, est également inhibée (pour valeur de retour 13010).

ONERROR

Ce paramètre vous permet de définir le comportement en cas d'erreur à l'issue de l'installation.

Exemple :

ONERROR=Suppress

Installation

Réinstallation

Désinstallation

Suppress

Au terme de l'installation, la boîte de dialogue indiquant les erreurs qui se sont produites est inhibée. L'interprétation de l'erreur peut s'effectuer à l'aide des valeurs retournées du processus.

User

Au terme de l'installation, la boîte de dialogue précisant les erreurs qui se sont produites s'affiche.

INSTALLLEVEL

Ce paramètre vous permet de fixer le type d'installation.

Exemple :

INSTALLLEVEL=Complete

Installation 4)

Minimal

Installation minimale

Typical

Installation typique

Complete

Installation complète

1) L'installation avec les paramètres /qb ou /qn a pour effet qu'aucune fenêtre des alarmes n'est affichée même si une erreur se produit. Vous pouvez exploiter les résultats uniquement via la valeur en retour.

2) Veillez à indiquer ici le chemin Windows réel ("C:\Program Files\...", et pas par ex. "C:\Programme\...") et à ne pas utiliser non plus de variable de chemin (par ex. [ProgramFilesFolder]).
Le paramètre n'est pas nécessaire si vous voulez effectuer l'installation dans le répertoire standard (C:\Program Files\Siemens\Automation).

3) Si l'installation n'est pas encore terminée (valeur en retour 13010), vous devez d'abord redémarrer le système, puis l'installation afin que la lecture de la valeur en retour soit possible.

4) Ce paramètre ne peut être utilisé que lors de la première installation du logiciel.


Valeurs retournées par le processus d'installation

Liste des valeurs retournées
Valeurs retournées par le processus d'installation

Liste des valeurs retournées

Le tableau suivant récapitule les valeurs retournées lors d'une installation automatisée et les décrit :

Valeur retournée

Désignation technique de l'erreur

Description

?

OtherError

Toutes les valeurs retournées qui ne sont pas décrites dans le tableau ci-après, correspondent généralement à une erreur.

Vous trouverez d'une manière générale des informations sur les erreurs dans le rapport d'installation. Ouvrez pour ce faire le fichier journal le plus récent dont le nom commence par "SIA".

0

Success

L'installation a été exécutée avec succès. Aucune erreur ne s'est produite.

5

AccessDenied

Vous ne disposez pas de droits suffisants. L'installation nécessite des droits d'administrateur.

112

DiskFull

Espace mémoire insuffisant sur le support cible.

1601

InstallServiceFailure

Une erreur interne est survenue durant la phase d'initialisation.

1602

UserExit

Abandon par l'utilisateur, généralement à la suite d'une annulation sélectionnée dans un dialogue.

1603

InstallFailure

Une erreur est survenue durant l'installation.

1605

UnknownProduct

Une erreur interne est survenue dans la configuration du produit.

1610

BadConfiguration

Une erreur interne est survenue dans la configuration du produit.

1618

InstallAlreadyRunning

Une autre installation est déjà en cours. Il n'est pas possible d'exécuter des installations simultanément.

1622

InstallLogFailure

Une erreur est survenue durant l'écriture du rapport.

1627

FunctionFailed

Une erreur interne s'est produite.

1633

InstallPlatformUnsupported

Ce système d'exploitation n'est pas pris en charge

1639

InvalidCommandline

Il y a une erreur dans la ligne de commande indiquée.

1641

SuccessRebootInitiated

L'installation a été exécutée avec succès. Un redémarrage a été initialisé pour clore l'opération.

3010

SuccessRebootRequired

L'installation a été exécutée avec succès. Un redémarrage est cependant indispensable pour clore l'opération !

5001

PrerequisitesFailure

Les conditions d'installation ne sont pas remplies. Pour plus d'informations, redémarrez l'installation par un double clic sur start.exe.

5002

InvalidIEVersion

Internet Explorer n'est pas installé ou installé dans une version qui n'est pas prise en charge.

5003

ResourcesFailed

Une erreur interne est survenue durant la phase d'initialisation.

5004

ProductInitFailed

Une erreur interne est survenue (le support d'installation est éventuellement défectueux).

5005

ProductInitNewerVersionInstalled

Une version plus récente du produit est déjà installée.

5006

ProductInitMoreValuableEditionInstalled

Une édition plus complète du produit est déjà installée (le système tente par ex. d'installer une version de base alors qu'une version professionnelle est déjà disponible).

5007

ProductInitOptionalWithoutMain

Vous avez essayé d'installer un logiciel optionnel sans installer le logiciel principal.

5008

ProductIncompatibility

Un produit n'étant pas compatible avec le produit à installer est déjà présent.

5009

AutoinstallFileNotFound

Le fichier pour le mode Play n'a pas été trouvé.

5010

AutoinstallUnexpectedContent

Le fichier pour le mode Play ne peut être lu (mauvais format, mauvaise version ou support d'installation inapproprié)

11641

NotCompleteReboot

L'installation n'est pas complète et doit être poursuivie après un redémarrage. Le redémarrage est déjà lancé. Une fois le redémarrage terminé, vous devez relancer l'installation.

13010

NotCompleteRebootRequired

L'installation n'est pas complète et doit être poursuivie après un redémarrage. Vous devez procéder au redémarrage et relancer l'installation après celui-ci.