Lisezmoi SIMATIC Energy Suite

Exemples Voir aussi Historique Outils
Lisezmoi SIMATIC Energy Suite

Ce chapitre contient des informations sur les sujets suivants :
  • Notes relatives à la sécurité
  • Protection des données
  • Nouveauté de SIMATIC Energy Suite V16
  • Nouveauté de SIMATIC Energy Suite V15.1
  • Nouveauté de SIMATIC Energy Suite V14 SP1
  • Migration d'un projet Energy Suite V14 SP1
  • Remarques sur l'utilisation


Notes relatives à la sécurité

Protection des données
Notes relatives à la sécurité

Siemens commercialise des produits et solutions comprenant des fonctions de sécurité industrielle qui contribuent à une exploitation sûre des installations, solutions, machines, équipements et réseaux.

Pour garantir la sécurité des installations, systèmes, machines et réseaux contre les cybermenaces, il est nécessaire d’implémenter (et de préserver) un concept de sécurité industrielle global et moderne. Les produits et solutions de Siemens ne constituent qu’une partie d’un tel concept.

Il incombe au client d‘empêcher tout accès non autorisé à ses installations, systèmes, machines et réseaux. Les systèmes, machines et composants doivent uniquement être connectés au réseau d’entreprise ou à Internet si et dans la mesure où c’est nécessaire et si des mesures de protection correspondantes (p. ex. utilisation de pare-feux et segmentation du réseau) ont été prises.

En outre, vous devez tenir compte des recommandations de Siemens concernant les mesures de protection correspondantes. Pour plus d’informations sur la sécurité industrielle, rendez-vous sur.

Les produits et solutions Siemens font l’objet de développements continus pour être encore plus sûrs. Siemens vous recommande donc vivement d’effectuer des actualisations dès que les mises à jour correspondantes sont disponibles et de ne toujours utiliser que les versions de produit actuelles. L’utilisation de versions obsolètes ou qui ne sont plus prises en charge peut augmenter le risque de cybermenaces.

Afin d’être informé des mises à jour produit dès qu’elles surviennent, abonnez-vous au flux RSS Siemens Industrial Security sous.


Protection des données

Protection des données

Siemens respecte les principes de protection des données, en particulier le principe de minimisation des données (protection intégrée des données). Pour ce produit SIMATIC, cela signifie qu'aucune donnée personnelle n'est traitée/stockée.


Nouveauté de SIMATIC Energy Suite V16

Nouveautés d'Energy Suite V16 Gestion de la charge Améliorations
Nouveauté de SIMATIC Energy Suite V16

Nouveautés d'Energy Suite V16

Toutes les innovations majeures de Energy SuiteV16 sont résumées ci-dessous.

Gestion de la charge

  • Le composant de gestion de la charge dans Energy Suite assure une fonction de surveillance et garantit que la puissance absorbée et la consommation d'énergie ne dépassent pas la valeur limite personnalisée applicable. Le composant de gestion de la charge contient un élément personnalisé important appelé actionneur.

    Le programme de gestion des charges est par exemple constitué des blocs suivants :

    • Bloc de prévision

    • Bloc de commande

    • Bloc actionneur

    • Bloc de sauvegarde/de restauration

    Le bloc de prévision reçoit ses données d'entrée de l'alimentation, c.-à-d. de l'objet d'acquisition. Dans une centrale électrique, par exemple, l'alimentation est l'énergie fournie par le réseau électrique. Le bloc de prévision calcule ou prévoit la valeur de puissance et énergétique moyenne, l'alimentation à la fin de la période définie étant utilisée.

    Tenez compte de la surveillance d'une installation de production par un composant de gestion de la charge. Le bloc de prévision lit la valeur de puissance de l'alimentation et surveille la puissance absorbée. L'utilisation de l'énergie fait l'objet d'une surveillance constante par rapport à une valeur limite pendant une période donnée. Si la prévision dépasse la valeur limite, la gestion de la charge provoque l'arrêt des consommateurs (actionneurs) ou des producteurs. Ce processus est désigné par le terme d'escalade. Après le pic de la valeur de seuil, quand la puissance absorbée est minimale ou ne dépasse pas la valeur de seuil, le producteur (actionneur) est mis sous tension. Ce processus est désigné par le terme de désescalade.

  • La génération de delta pour la gestion de la charge et des objets d'acquisition est prise en charge, les blocs d'actionneur récemment ajoutés ou modifiés pour les objets d'acquisition / la gestion de la charge étant rattachés aux blocs existants après la génération. En cas de suppression, seuls les blocs sélectionnés sont supprimés après la génération, sans modifier les blocs existants.

  • La configuration automatique des règles de l'écran relatives aux blocs est prise en charge dans Energy Suite .

  • Génération de l'écran

    • Prise en charge de la génération automatique d'écran pour le programme de production d'énergie avec les appareils WinCC Professional et les appareils Comfort.

    • Prise en charge de la génération automatique d'écran pour le programme de gestion de la charge avec les appareils WinCC Professional.

Améliorations

  • Optimisation des performances pour les opérations d'exécution afin d'améliorer l'utilisation du temps de cycle de l'API dans les acquisitions de longue durée.

  • La génération de programmes énergétiques delta neutres à l'exécution pour la production d'énergie et la gestion de la charge est prise en charge en cas de modifications delta telles que l'ajout ou la modification d'objets d'acquisition pour l'acquisition ou d'actionneurs pour la gestion de la charge.

  • Si vous ajoutez une nouvelle table des objets d'acquisition lors de la configuration d'un projet Energy Suite, vous devez télécharger WinCC.

  • Si vous insérez des objets d'acquisition dans la table des objets d'acquisition, vous devez télécharger WinCC.


Nouveauté de SIMATIC Energy Suite V15.1

Nouveauté d'Energy Suite V15.1 Optimisation du couplage d'un matériel de mesure comme source de données énergétiques
Nouveauté de SIMATIC Energy Suite V15.1

Nouveauté d'Energy Suite V15.1

Ce document récapitule toutes les nouveautés importantes par rapport à Energy Suite V15.

Optimisation du couplage d'un matériel de mesure comme source de données énergétiques

  • Energy Suite détecte le matériel de mesure suivant, configuré avec l'interface intégrée dans STEP 7 (TIA Portal) ou avec le fichier GSD comme source de données d'énergie :

    • ET 200SP AI Energy Meter 480VAC HF

    • Démarreur progressif 3RW55

  • Energy Suite détecte la configuration du matériel de mesure susmentionné et crée automatiquement les blocs correspondants pendant la génération du programme énergétique.

  • La bibliothèque Energy Suite contient les blocs d'affichage installés automatiquement pour la visualisation du programme énergétique.

  • Un projet Energy Suite créé dans V15.0 avec un archivage API génère un fichier journal de données. Si le même projet est ouvert dans V15.1, TIA Portal vous demande de mettre le projet à niveau à V15.1. En cas de mise à niveau ultérieure du projet à V15.1, un nouveau fichier journal de données est créé après la nouvelle génération et le chargement.


Nouveauté de SIMATIC Energy Suite V14 SP1

Nouveauté de Energy Suite V14 SP1 Génération du programme énergétique y compris pour les données énergétiques avancées Génération automatique des rapports avec Energy Suite Export Tool Informations et retours détaillés sur la progression de la génération Extension de la structure de métadonnées
Nouveauté de SIMATIC Energy Suite V14 SP1

Nouveauté de Energy Suite V14 SP1

Ce document récapitule toutes les nouveautés importantes par rapport à Energy Suite V14.

Génération du programme énergétique y compris pour les données énergétiques avancées

  • Pour générer le programme énergétique y compris pour les données énergétiques avancées (par ex. flux, tensions, fréquence, etc.), vous disposez des nouvelles commandes suivantes dans le menu contextuel de l'objet "Objets énergétiques" dans le navigateur du projet :

    • Données énergétiques de base

    • Données énergétiques de base et avancées

    • Données énergétiques de base et avancées (avec valeurs minimales et maximales)

  • Energy Suite détecte quelle données énergétiques le matériel de mesure respectif peut fournir et crée automatiquement les blocs correspondants pendant la génération du programme énergétique.

Pour plus d'informations, reportez-vous au manuel d'utilisation SIMATIC Energy Suite au paragraphe "Générer un programme énergétique".

Génération automatique des rapports avec Energy Suite Export Tool

  • Nouvelle génération de rapports automatique à l'aide de modèles de rapport configurables.

  • Les cycles de génération de rapports automatique suivants sont disponibles :

    • Quotidien

    • Hebdomadaire

    • Mensuel

    • Annuel

  • Pour une analyse rapide des erreurs, les messages d'erreur sont enregistrés localement sous "C:\Program Files (x86)\Siemens\Automation\SCADA-RT_V11\WinCC\bin\config" en cas comportement inattendu.

Pour plus d'informations, reportez-vous au manuel d'utilisation SIMATIC Energy Suite au paragraphe "Exploitation des données énergétiques avec Energy Suite Export Tool".

Informations et retours détaillés sur la progression de la génération

  • Pour un meilleur suivi du processus de génération, les informations et événements relatifs à la génération du programme énergétique sont affichés.

  • La fonction "Aller à" vous permet de sauter à l'endroit de la configuration pertinent pour l'événement en cours.

Pour plus d'informations, reportez-vous au manuel d'utilisation SIMATIC Energy Suite au paragraphe "Générer un programme énergétique".

Extension de la structure de métadonnées

La structure de métadonnées des objets énergétiques est étendue à des fins de compatibilité et d'analyse.

Pour plus d'informations, reportez-vous au manuel d'utilisation SIMATIC Energy Suite au paragraphe "Blocs Energy Suite".


Migration d'un projet Energy Suite V14 SP1

Conditions Marche à suivre
Migration d'un projet Energy Suite V14 SP1

Pour migrer des projets Energy Suite de la version V14 SP1 à la version V16, vous devez définir manuellement l'instruction STEP 7 "Get_IM_Data" sur la version actuelle. À défaut, des erreurs de compilation se produisent pendant le processus de compilation.

Conditions

  • Un projet Energy Suite de la version V14 SP1 est disponible.

  • TIA Portal V16 est installé avec Energy Suite V16.

Marche à suivre

Procédez comme suit pour éviter des erreurs de compilation lors de la migration d'un projet Energy Suite de V14 SP1 à V16 :

  1. Ouvrez dans V16 le projet créé dans Energy Suite V14 SP1.

    La boîte de dialogue "Ouvrir le projet" s'ouvre.

  2. Dans la boîte de dialogue "Ouvrir le projet", cliquez sur le bouton "Mise à niveau".

  3. Une fois le projet migré avec succès, ouvrez la CPU SIMATIC S7-1500 configurée dans le navigateur du projet.

  4. Ouvrez sous le dossier "Blocs de programme" un bloc quelconque (OB, FB ou FC).

  5. Dans la Task Card "Instructions", ouvrez le dossier "Instructions étendues > Diagnostic".

    L'instruction "Get_IM_Data" a par défaut la version "V1.2".

  6. Sélectionnez la version "V1.3" souhaitée dans la liste déroulante.

  7. Continuez ensuite à générer votre programme énergétique.

  8. Cliquez sous la CPU S7-1500 configurée sur l'objet "Blocs de programme".

  9. Dans le menu contextuel, sélectionnez la commande "Compiler > Logiciel (compilation complète)".

    Le programme énergétique est compilé. Dans la fenêtre d'inspection sous "Info > Compiler", vous pouvez vérifier si la compilation a été terminée avec succès.

Pour éviter tout défaut dû à un conflit de versions de bibliothèques, procédez comme indiqué ci-après pour la migration de projets Energy Suite des versions V15 et antérieures vers la version V16 :

  • Pour les instructions de base "Serialize" et "Deserialize", vous devez mettre à jour manuellement la version V2.0 vers la version V2.1.

  • Pour l'instruction avancée "GetSMCinfo", vous devez mettre à jour manuellement la version V1.0 vers la version V1.1.


Remarques sur l'utilisation

Contenus Mise à niveau de projets Energy Suite dans un projet multi-utilisateur Données énergétiques d'un matériel de mesure Transfert de données dans le système SCADA Génération du programme énergétique Blocs Energy Suite Valeur-limite pour variables IHM
Remarques sur l'utilisation

Contenus

Les informations contenues dans le présent texte ont la priorité sur d'autres indications figurant dans la documentation.

Veuillez lire attentivement ces remarques, car elles fournissent des informations importantes sur l'installation et l'utilisation. Ne procéder à l'installation qu'après avoir lu les présentes remarques.

Vous trouverez également des informations actuelles sur Energy Suite dans le portail d'information Siemens Industry Online Support.

Vous trouvez des informations concernant les instructions d'utilisation de SIMATIC Energy Support Library dans le fichier Lisezmoi "ReadMeEnSLenUS.chm" sur le support d'installation.

Mise à niveau de projets

Un projet Energy Suite créé dans des versions antérieures à V16 avec un archivage API génère un fichier-journal de données. Les scénarios suivants s'appliquent à un fichier-journal de données :

  • Si vous mettez à niveau vers la version V16 un projet Energy Suite créé avec une version antérieure à la version V16 et que vous chargez le projet sans générer un programme dans l'API, l'archivage API se poursuivra dans le même fichier-journal.

  • Si vous mettez à niveau vers la version V16 un projet Energy Suite créé avec une version antérieure à la version V16 et que vous chargez le projet en générant un programme dans l'API, l'archivage API se poursuivra dans un nouveau fichier-journal.

  • En cas de génération d'un delta, la mise à niveau de projets vers la version V16 entraîne la modification des numéros de DB existants.

  • Quand vous mettez à niveau un projet créé dans une version plus ancienne que V15 vers la version V16 d'Energy Suite, vous devez supprimer manuellement les blocs LAcycCOM dès que le projet a été actualisé et générer à nouveau le programme énergétique.

  • Le bloc de données LAcycCom_RequestBuffer est contenu dans les blocs du programme Energy Suite (préfixe "EnS").

  • Les projets des versions v14 SP1 ou v15 signalent des erreurs de compilation lors de la compilation du FB Ens_LmgtBackupRestore lorsqu'il est mis à jour à la version v16 avec la version de firmware v2.8 et l'option de prévision activée dans la table des objets d'acquisition avec des acteurs de gestion de la charge configurés.

  • Pour les projets des versions v14 SP1 ou v15, la génération d'un programme échoue s'il est mis à jour à la version v16 avec un Datalog de plus de 26 caractères.

Energy Suite dans un projet multi-utilisateur

Ne traitez pas un projet multi-utilisateur dans la session locale, mais uniquement dans la vue de projet de serveur.

Données énergétiques d'un matériel de mesure

Lors de la configuration du matériel de mesure comme source de données énergétiques , des types de données énergétiques différents sont évalués selon le matériel de mesure utilisé.

Le tableau suivant montre les paramètres nécessaires pour le matériel de mesure pris en charge :

Matériel de mesure | Type de données énergétiques | Unité | Facteur de normalisation | Valeur de dépassement
AI EnergyMeter 480VAC ST | Valeur du compteur d'énergie | Wh | 1 | 1.000.000.000.000.000 = 1 * 10^15 (*)
AI EnergyMeter 480VAC HF | Valeur du compteur d'énergie | Wh | 1 | 1.000.000.000.000.000 = 1 * 10^15 (*)
SENTRON PAC3200/PAC4200 | Valeur du compteur d'énergie | Wh | 1 | 1 * 10^12
SENTRON 3VA (8er-ETU) | Valeur du compteur d'énergie | Wh | 1 | 4 * 10^12
SINAMICS AC/AC | Valeur de puissance | W | 1 | -
SIMOCODE pro V PN | Valeur du compteur d'énergie | Wh | 1 | 2.147.483.648.000
Départs-moteurs ET 200SP/M200D | Valeur de puissance | W | 1 | -
Démarreur progressif 3RW44 | Valeur de puissance | W | 1 | -
Démarreur progressif 3RW55 | Valeur de puissance | W | 1 | -

(*) Assurez-vous que la valeur du compteur d'énergie indique la valeur de dépassement aussi bien dans les paramètres Energy Suite que dans la configuration matérielle du AI EnergyMeter 480VAC ST/HF. Vous trouvez la configuration matérielle dans la fenêtre d'inspection "Propriétés" sous "Paramètres du module > Configuration AI > Mesure > Valeur finale compteur d'énergie".

Assurez-vous que le paramétrage correspond au tableau ci-dessus.

Transfert de données dans le système SCADA

Si vous procédez à des modifications dans le programme énergétique, générez à nouveau le programme énergétique et chargez-le sur la CPU.

Chargez les modifications dans la CPU uniquement lorsque les blocs-tampons sont vides. Lors d'un chargement dans la CPU (chargement complet), il faut redémarrer la CPU par la suite. Lors d'un chargement dans la CPU (modifications seules), il faut effectuer une réinitialisation du données "EnS_BufferWorkDB". Vous trouverez de plus amples informations à ce sujet dans l'aide en ligne du système d'information de TIA Portal.

Génération du programme énergétique

En cas d'échec de la génération du programme énergétique, vérifiez les paramètres suivants :

  • Source de données énergétiques : Les points suivants doivent être configurés conformément au manuel :

    • Configuration du matériel de mesure (voir documentation "Matériel de mesure pour SIMATIC Energy Suite dans TIA Portal")

    • Type de données (voir paragraphe "Données énergétiques des blocs de données")

    • Conventions de noms (voir paragraphe "Caractéristiques de service et conventions d'appellation")

  • Période d'archivage : Une période d'archivage est assignée à un seul objet d'acquisition.

  • Nom de l'objet d'acquisition : Le nom de l'objet d'acquisition ne doit pas être identique à celui des objets suivants :

    • Bloc de programme

    • Objet technologique

    • Source externe

    • Variable API

    • Type de données API

  • Généralités : Les préfixes "EnS_" (à l'exception de "EnS_EEm_" pour S7 Energy Efficiency Monitor), "EnSL_" et "LAcycCom_" sont des préfixes système réservés et ne sont pas utilisés dans le nom des objets mentionnés ci-dessus.

Avant de générer le programme énergétique de nouveau, assurez-vous que les paramètres mentionnés ci-dessus sont corrects.

  • La plage de valeurs pour la gestion de la charge peut comprendre 1 à 26 caractères.

  • La plage de valeurs pour l'acteur de priorité peut comprendre 1 à 1999 caractères.

Pour obtenir un rapport de transmission abouti des appareils Comfort Panel avec gestion de la charge et acquisition de données énergétiques, ainsi que la génération SiVArc :

  • Les variables HMI du type LMGT - variables internes et EnS_Visu doivent être supprimées manuellement puisqu'elles ne sont pas prises en charge par WinCC Comfort.

  • Vous devez lier les variables correspondantes pour les objets de fenêtre contextuelle.

  • Si seul le programme de collecte de données énergétiques est généré dans l'API et les images via l'option "Lancer la génération SiVArc avec boîte de dialogue de sélection de la station", vous devez supprimer manuellement la table des variables "LMGT - variables internes".

Lors de la configuration d'un projet Energy Suite :

  • Pour chaque ajout d'une table d'objets d'acquisition, vous devez télécharger WinCC.

  • Pour l'insertion d'objets d'acquisition dans la table des objets d'acquisition, vous devez télécharger WinCC.

Blocs Energy Suite

EnS_CalcEnergyData : calcul des valeurs d'énergie

La réinitialisation de la valeur du compteur d'énergie pendant une période d'archivage en cours entraîne le calcul de valeurs d'énergie négatives pour cette période d'archivage.

EnSL_DrvBasic_Sina_vx : Acquisition des données de base énergétiques

Contrairement aux indications figurant dans la documentation "Matériel de mesure pour SIMATIC Energy Suite dans TIA Portal", le code d'erreur "W#16#8011" n'existe pas pour le paramètre de sortie "Status".

Valeur-limite pour variables IHM

Dans les paramètres Runtime de l'IHM, le nom de l'API est rattaché au nom de la variable si la case "Nom de l'API en tant que préfixe dans le nom de la variable IHM" est cochée. Après avoir généré l'écran SiVArc suivi de la compilation dans l'IHM, une erreur s'affiche si le nom de la variable IHM dépasse 128 caractères.