Leggimi di SIMATIC Energy Suite

Esempi Vedere anche Cronologia Strumenti
Leggimi di SIMATIC Energy Suite

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Indicazioni di sicurezza
  • Protezione dei dati
  • Novità di SIMATIC Energy Suite V16
  • Novità di SIMATIC Energy Suite V15.1
  • Novità di SIMATIC Energy Suite V14 SP1
  • Migrazione di un progetto da Energy Suite V14 SP1
  • Avvertenze d'uso


Indicazioni di sicurezza

Protezione dei dati
Indicazioni di sicurezza

Siemens commercializza prodotti e soluzioni dotati di funzioni Industrial Security che contribuiscono al funzionamento sicuro di impianti, soluzioni, macchine e reti.

La protezione di impianti, sistemi, macchine e reti da minacce cibernetiche, richiede l'implementazione e la gestione continua di un concetto globale di Industrial Security che corrisponda allo stato attuale della tecnica. I prodotti e le soluzioni Siemens costituiscono soltanto una componente imprescindibile di questo concetto.

È responsabilità del cliente prevenire accessi non autorizzati ad impianti, sistemi, macchine e reti. Il collegamento di sistemi, macchine e componenti, se necessario, deve avvenire esclusivamente nell'ambito della rete aziendale o tramite Internet previa adozione di opportune misure (ad es. impiego di firewall e segmentazione della rete).

Attenersi inoltre alle raccomandazione Siemens concernenti misure di sicurezza adeguate. Ulteriori informazioni su Industrial Security sono disponibili al sito.

I prodotti e le soluzioni Siemens vengono costantemente perfezionati per incrementarne la sicurezza. Siemens raccomanda espressamente di eseguire gli aggiornamenti non appena sono disponibili i relativi update e di impiegare sempre le versioni aggiornate dei prodotti. L’uso di prodotti non più attuali o di versioni non più supportate incrementa il rischio di attacchi cibernetici.

Per essere costantemente aggiornati sugli update dei prodotti, abbonarsi a Siemens Industrial Security RSS Feed al sito.


Protezione dei dati

Protezione dei dati

Siemens osserva i principi della protezione dei dati, in particolare il principio della minimizzazione dei dati (protezione dei dati integrata). Per questo progetto SIMATIC ciò sta ad indicare, che i dati personali non vengono elaborati e salvati.


Novità di SIMATIC Energy Suite V16

Novità di Energy Suite V16 Gestione del carico Ottimizzazioni
Novità di SIMATIC Energy Suite V16

Novità di Energy Suite V16

Tutte le innovazioni di rilievo di Energy Suite V16 sono riepilogate nel seguito.

Gestione del carico

  • In Energy Suite il componente di gestione del carico svolge una funzione di controllo e garantisce che l'assorbimento di potenza e il consumo di energia non superino il valore limite di energia definito dall'utente. Il componente di gestione del carico contiene un importante elemento, l'attuatore, che viene definito dall’utente.

    Il programma di gestione del carico può essere ad esempio costituito dai seguenti blocchi:

    • Blocco Pronostico

    • Blocco di comando

    • Blocco attuatore

    • Blocco di backup/ripristino

    Il blocco Pronostico riceve i propri dati di ingresso dall’alimentazione, ovvero dall’oggetto da rilevare. Ad es. in una centrale elettrica l’alimentazione è costituita dall’energia fornita dalla rete. Il blocco Pronostico calcola il valore medio di potenza e di energia considerando l’alimentazione al termine del periodo definito.

    Si consideri il controllo di un impianto di produzione mediante un componente di gestione del carico. Il blocco Pronostico legge il valore di potenza dell'alimentazione e controlla l'assorbimento di potenza. L’utilizzo dell’energia viene controllato ininterrottamente per un periodo definito prendendo come riferimento un valore limite. Quando i pronostici superano il valore limite, la gestione del carico attua la disinserzione di consumatori (attuatori) o generatori. Questo processo è definito “incremento” (escalation). Dopo il picco di soglia, se la potenza assorbita è minima o è compresa entro il valore di soglia, il produttore (attuatore) si accende. Questo processo è definito “decremento” (de-escalation).

  • La generazione delta per la gestione del carico e gli oggetti da rilevare viene supportata, tuttavia, i blocchi attuatore appena aggiunti o modificati per la gestione del carico e degli oggetti da rilevare vengono aggiunti ai blocchi preesistenti dopo la generazione. Nell'eventualità di una cancellazione vengono eliminati soltanto i blocchi selezionati dopo la generazione, senza alcuna modifica a quelli preesistenti.

  • La creazione automatica delle regole della schermata per i blocchi in Energy Suite viene supportata.

  • Generazione della schermata

    • Supporto della generazione automatica della schermata per il programma di rilevazione energia in dispositivi WinCC Professional e Comfort.

    • Supporto della generazione automatica della schermata per il programma di gestione del carico in dispositivi WinCC Professional

Ottimizzazioni

  • Ottimizzazione della performance per il funzionamento in runtime, per un migliore utilizzo del tempo di ciclo PLC durante le rilevazioni a lungo termine.

  • La generazione delta del programma di energia neutrale rispetto al runtime per la rilevazione dell'energia e la gestione del carico, viene supportata se esistono modifiche delta quali l'inserimento o la modifica degli oggetti da rilevare per la rilevazione o di attuatori per la gestione del carico.

  • Per inserire una tabella degli oggetti da rilevare durante la configurazione di un progetto Energy Suite è necessario scaricare WinCC.

  • Per inserire gli oggetti da rilevare nella tabella è necessario scaricare WinCC.


Novità di SIMATIC Energy Suite V15.1

Novità di Energy Suite V15.1 Ottimizzazione del collegamento di hardware di misura come sorgente dei dati di energia
Novità di SIMATIC Energy Suite V15.1

Novità di Energy Suite V15.1

Tutte le principali novità rispetto a Energy Suite V15 sono sintetizzate qui.

Ottimizzazione del collegamento di hardware di misura come sorgente dei dati di energia

  • Energy Suite riconosce come sorgente dei dati di energia il seguente hardware di misura configurato con l’interfaccia utente integrata in STEP 7 (TIA Portal) o con il file contenente i dati di base del dispositivo:

    • ET 200SP AI Energy Meter 480VAC HF

    • Softstarter 3RW55

  • Energy Suite rileva la configurazione dell'hardware di misura sopra indicato e crea automaticamente i blocchi corrispondenti durante la generazione del programma di energia.

  • La biblioteca Energy Suite contiene faceplate installati automaticamente per la visualizzazione del programma di energia.

  • Un progetto creato con Energy Suite V15.0 con archiviazione nel PLC genera un file di log di dati. Se lo stesso progetto viene aperto nella versione V15.1, TIA Portal chiede se lo si vuole aggiornare alla V15.1. In seguito all’aggiornamento del progetto alla versione V15.1, dopo una rigenerazione e il caricamento viene creato un nuovo file di log di dati.


Novità di SIMATIC Energy Suite V14 SP1

Novità di Energy Suite V14 SP1 Generazione del programma di energia anche per dati di energia avanzati Creazione automatica dei report con Energy Suite Export Tool Informazioni dettagliate e conferme dell'avanzamento della generazione Ampliamento della struttura dei metadati
Novità di SIMATIC Energy Suite V14 SP1

Novità di Energy Suite V14 SP1

Tutte le principali novità rispetto a Energy Suite V14 sono sintetizzate qui.

Generazione del programma di energia anche per dati di energia avanzati

  • Per generare il programma di energia anche per i dati di energia avanzati (ad es. correnti, tensioni, frequenza ecc.) sono disponibili nel menu di scelta rapida dell'oggetto "Oggetti di energia" nella navigazione del progetto i nuovi comandi seguenti:

    • Dati di energia di base

    • Dati di energia di base e avanzati

    • Dati di energia di base e avanzati (con valori min./max.)

  • Energy Suite rileva quali dati di energia può rendere disponibili un hardware di misura e crea automaticamente i blocchi corrispondenti durante la generazione del programma di energia.

Ulteriori informazioni sono disponibili nel manuale d'uso SIMATIC Energy Suite nella sezione "Generazione del programma di energia".

Creazione automatica dei report con Energy Suite Export Tool

  • Nuova creazione automatica di report sulla base dei modelli di report configurabili.

  • Sono disponibili i seguenti cicli di report automatici:

    • Ogni giorno

    • Ogni settimana

    • Ogni mese

    • Ogni anno

  • Per un'analisi veloce degli errori, i messaggi di errore in presenza di un comportamento imprevisto vengono salvati nel percorso locale "C:\Program Files (x86)\Siemens\Automation\SCADA-RT_V11\WinCC\bin\config".

Ulteriori informazioni sono disponibili nel manuale d'uso SIMATIC Energy Suite nella sezione "Analisi dei dati di energia con Energy Suite Export Tool".

Informazioni dettagliate e conferme dell'avanzamento della generazione

  • Per una migliore tracciabilità del processo di generazione, vengono visualizzati le informazioni e gli eventi durante la generazione del programma di energia.

  • Con la funzione "Vai a" si può passare al punto della configurazione rilevante per l'evento scelto.

Ulteriori informazioni sono disponibili nel manuale d'uso SIMATIC Energy Suite nella sezione "Generazione del programma di energia".

Ampliamento della struttura dei metadati

La struttura dei metadati degli oggetti di energia è ampliata a fini di compatibilità e di analisi.

Ulteriori informazioni sono disponibili nel manuale d'uso SIMATIC Energy Suite nella sezione "Blocchi Energy Suite".


Migrazione di un progetto da Energy Suite V14 SP1

Presupposti Procedimento
Migrazione di un progetto da Energy Suite V14 SP1

Per la migrazione di progetti Energy Suite dalla versione V14 SP1 alla V16, è necessario impostare manualmente la versione più recente nell'istruzione "Get_IM_Data" di STEP 7. Diversamente si verifica un errore durane la compilazione.

Presupposti

  • È disponibile un progetto creato con Energy Suite V14 SP1.

  • È stato installato TIA Portal V16 con Energy Suite V16.

Procedimento

Per evitare errori di compilazione durante la migrazione dei progetti dalla versione V14 SP1 alla V16 di Energy Suite procedere come indicato di seguito:

  1. Aprire nella versione V16 il progetto creato in Energy Suite V14 SP1.

    Si apre la finestra di dialogo "Apri progetto".

  2. Fare clic sul pulsante "Aggiornamento" della finestra.

  3. Una volta migrato correttamente il progetto aprire la CPU SIMATIC S7-1500 configurata nella navigazione del progetto.

  4. Aprire un blocco qualsiasi (OB, FB o FC) nella cartella "Blocchi di programma".

  5. Aprire la cartella "Istruzioni avanzate>Diagnostica " nella task card "Istruzioni".

    L'istruzione "Get_IM_Data" è impostata con la versione "V1.2".

  6. Selezionare la versione "V1.3" nella casella di riepilogo.

  7. Proseguire infine la generazione del programma di energia.

  8. Fare clic sull'oggetto "Blocchi di programma" sotto la CPU S7-1500 configurata.

  9. Selezionare il comando "Compila > Software (compilazione completa)" nel menu di scelta rapida.

    Il programma di energia viene compilato. Nella finestra di ispezione "Informazioni > Compilazione" è possibile controllare se la compilazione è stata eseguita correttamente.

Per prevenire errori dovuti ad un conflitto tra le versioni delle biblioteche, durante la migrazione dei progetti Energy Suite dalle versioni V15 e inferiori alla versione V16 procedere come segue:

  • Per le istruzioni di base "Serialize" e "Deserialize" occorre aggiornare manualmente la versione da V2.0 a V2.1.

  • Per l'istruzione avanzata "GetSMCinfo" occorre aggiornare manualmente la versione da V1.0 a V1.1.


Avvertenze d'uso

Contenuti Upgrade di progetti Energy Suite in un progetto multiutente Dati di energia da un hardware di misura Trasferimento da dati a sistema SCADA Generazione del programma di energia Blocchi Energy Suite Valori limite per le variabili HMI
Avvertenze d'uso

Contenuti

Le informazioni in questo testo hanno maggiore priorità rispetto ad altri documenti.

Leggere con attenzione le seguenti avvertenze. Sono riportate informazioni rilevanti per l’installazione e l’utilizzo. Leggere le presenti avvertenze prima di iniziare l'installazione.

Le informazioni attuali su Energy Suite sono disponibili nel portale informativo del Siemens Industry Online Support.

Informazioni sulle istruzioni operative per il SIMATIC Energy Support Library sono disponibili nel file Leggimi "ReadMeEnSLenUS.chm" del supporto di installazione.

Upgrade di progetti

Un progetto creato in Energy Suite con una versione precedente alla V16 con archiviazione PLC genera un file di protocollo dati. Per i file di protocollo di dati valgono le seguenti situazioni:

  • Se si esegue l'aggiornamento di un progetto Energy Suite alla versione V16 da una versione precedente, e si carica il progetto senza generazione del programma nel PLC, l’archiviazione PLC viene proseguita nello stesso file di protocollo dei dati.

  • Se si esegue l'aggiornamento di un progetto Energy Suite da una versione precedente alla versione V16 con generazione del programma e si carica il progetto nel PLC, l’archiviazione PLC viene proseguita in un nuovo file di protocollo dei dati

  • In caso di una generazione delta, l’upgrade di progetti fino alla versione V16 modifica i numeri DB esistenti.

  • L'aggiornamento alla versione V16 di un progetto generato in Energy Suite con una versione precedente alla V15, richiede l'eliminazione manuale dei blocchi LAcycCOM non appena il progetto viene aggiornato, e successivamente la generazione del programma di energia.

  • Il DB LAcycCom_RequestBuffer è disponibile nei blocchi del programma Energy Suite (prefisso "EnS").

  • I progetti della versione v14 SP1 o v15 segnalano errori durante la compilazione dell'FB Ens_LmgtBackupRestore, se l'aggiornamento alla versione v16 avviene con la versione firmware v2.8, e se nella tabella degli oggetti da rilevare con attuatori della gestione del carico configurati, l'opzione Pronostico è attivata.

  • Nei progetti della versione V14 SP1 o V15, la generazione di un programma non riesce se l'aggiornamento alla versione V16 avviene con un protocollo dati contenente più di 26 caratteri.

Energy Suite in un progetto multiutente

Aprire un progetto multiutente esclusivamente nella vista del progetto server, non nella sezione locale.

Dati di energia da un hardware di misura

Con la configurazione dell'hardware di misura come sorgente di dati di energia, a seconda dell'hardware di misura utilizzato vengono analizzate diverse impostazioni del tipo di dati.

La seguente tabella mostra le impostazioni necessarie per l’hardware di misura supportato.

Hardware di misura | Tipo di dati di energia | Unità | Fattore di normalizzazione | Valore di overflow
AI EnergyMeter 480VAC ST | Valore di conteggio dell'energia | Wh | 1 | 1.000.000.000.000.000 = 1 * 10^15 (*)
AI EnergyMeter 480VAC HF | Valore di conteggio dell'energia | Wh | 1 | 1.000.000.000.000.000 = 1 * 10^15 (*)
SENTRON PAC3200/PAC4200 | Valore di conteggio dell'energia | Wh | 1 | 1 * 10^12
SENTRON 3VA (ETU da 8) | Valore di conteggio dell'energia | Wh | 1 | 4 * 10^12
SINAMICS AC/AC | Valore di conteggio | W | 1 | -
SIMOCODE pro V PN | Valore di conteggio dell'energia | Wh | 1 | 2.147.483.648.000
Avviatore motore ET 200SP/M200D | valore di potenza | W | 1 | -
Softstarter 3RW44 | valore di potenza | W | 1 | -
Softstarter 3RW55 | Valore di potenza | W | 1 | -

(*) Fare attenzione che il valore di conteggio dell’energia visualizzi il valore di overflow sia nelle impostazioni di Energy Suite sia nella configurazione hardware di AI EnergyMeter 480VAC ST/HF. La Configurazione hardware si trova nella finestra di ispezione "Proprietà", alla voce "Parametri del modulo > Configurazione AI > Misura > Contatore di energia valore finale".

Fare attenzione che la parametrizzazione corrisponda alla tabella riportata sopra.

Trasferimento da dati a sistema SCADA

Se si apportano modifiche al programma di energia, generare quest'ultimo nuovamente e caricarlo nella CPU.

Caricare le modifiche nella CPU solo se i blocchi buffer sono vuoti. Durante il caricamento nella CPU (completo), alla conclusione la CPU deve essere riavviata. In caso di caricamento nella CPU (solo modifiche) occorre eseguire una nuova inizializzazione del blocco dati "EnS_BufferWorkDB" Per maggiori informazioni a riguardo consultare la guida in linea del sistema di informazione TIA Portal.

Generazione del programma di energia

Controllare le seguenti impostazioni se la generazione del programma di energia non riesce:

  • Sorgente dei dati di energia: È necessario configurare i seguenti aspetti secondo il manuale:

    • Configurazione dell'hardware di misura (vedere documentazione "Hardware di misura per SIMATIC Energy Suite in TIA Portal")

    • Tipo di dati (vedere sezione "Dati di energia dai blocchi dati")

    • Regole per i nomi (vedere sezione "Caratteristiche di potenza e convenzioni")

  • Periodo di archiviazione: A ogni oggetto da rilevare viene assegnato esattamente un periodo di archiviazione.

  • Nome dell'oggetto da rilevare: L’oggetto da rilevare non può avere lo stesso nome dei seguenti oggetti:

    • Blocco di programma

    • Oggetto tecnologico

    • Sorgente esterna

    • Variabile PLC:

    • Tipo di dati PLC

  • In generale: I prefissi "EnS_" (tranne "EnS_EEm_" per il monitor dell’efficienza di energia S7), "EnSL_" e "LAcycCom_" sono prefissi di sistema riservati e non vengono utilizzati nei nomi e negli oggetti indicati.

Prima di rigenerare il programma di energia, fare attenzione che le impostazioni indicate sopra corrispondano.

  • Il campo valori per la gestione del carico può comprendere da 1 a 26 caratteri.

  • Il campo valori per l'attuatore prioritario può comprendere da 1 a 1999 caratteri.

Affinché la compilazione dei dispositivi Comfort Panel con gestione del carico, rilevazione dei dati di energia e generazione SiVArc vada a buon fine, procedere come segue:

  • Le variabili HMI del tipo LMGT - variabili interne e EnS_Visu devono essere cancellate manualmente se WinCC Comfort non le supporta.

  • Collegare le variabili corrispondenti per gli oggetti delle finestre pop-up.

  • Se nel PLC si creano solo il programma di rilevazione energia e le immagini con l'opzione "Avvia generazione SiVArc con la finestra di selezione della stazione" la tabella delle variabili "LMGT - variabili interne" deve essere cancellata manualmente.

Durante la configurazione di un progetto Energy Suite:

  • Ogni volta che si inserisce una tabella degli oggetti da rilevare è necessario scaricare WinCC.

  • Per l'inserimento degli oggetti da rilevare nella tabella è necessario scaricare WinCC.

Blocchi Energy Suite

EnS_CalcEnergyData: Calcolo dei valori di energia

Il reset del valore del contatore di energia nel periodo di archiviazione attivo comporta il calcolo di valori energetici negativi per questo periodo.

EnSL_DrvBasic_Sina_vx: Rilevamento dati di base dell'energia

Al contrario di quanto indicato nella documentazione "Hardware di misura per SIMATIC Energy Suite in TIA Portal”, il codice di errore "W#16#8011" non è presente nel parametro di uscita "stato".

Valori limite per le variabili HMI

Nelle impostazioni runtime di HMI il nome del PLC viene aggiunto al nome della variabile se la casella di controllo "Nome PLC come prefisso nel nome della variabile HMI" è attivata. Dopo la generazione della schermata SiVArc sulla quale si svolge la compilazione HMI, viene visualizzato un errore se il nome della variabile HMI ha una lunghezza superiore a 128 caratteri.