Installationshinweise zu S7-PLCSIM Advanced V3.0

Im Abschnitt Anleitungen Beispiele Grundlagen Verlauf Extras
Start Zurück Weiter

Installationshinweise zu S7-PLCSIM Advanced V3.0

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Einleitung
  • S7-PLCSIM Advanced
  • S7-PLCSIM Advanced installieren
  • S7-PLCSIM Advanced ändern
  • S7-PLCSIM Advanced reparieren
  • S7-PLCSIM Advanced deinstallieren


Einleitung

Einleitung

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Systemanforderungen
  • Einschränkungen durch Virenscanner
  • Lizenzen
  • Trial License
  • Funktionen zu Lizenzen
  • Installationsprotokoll


Systemanforderungen

Betriebssysteme (64 Bit-Varianten) Virtualisierungsplattformen
Start Zurück Weiter

Systemanforderungen

PLCSIM Advanced installieren Sie bevorzugt auf einem SIMATIC Field PG M5 Advanced oder einem vergleichbaren PC.

Damit PLCSIM Advanced effizient funktioniert, müssen folgende Mindestvoraussetzungen bei der Computer-Hardware oder einer Virtuellen Maschine gegeben sein.

Systemanforderungen

Hardware

Virtuelle Maschine

Prozessor

  • Ein logischer Intel Core™ i7‑6820EQ Kern pro gestarteter Instanz

  • Mindestens ein weiterer Kern für das Betriebssystem

  • Mindestens ein weiterer Kern für zusätzliche aktive Anwendungen

  • Eine virtuelle CPU pro gestarteter Instanz muss der VM zugewiesen sein

  • Eine entsprechende Anzahl Prozessoren muss physikalisch auf dem Host existieren

  • Mindestens ein weiterer Kern für das Betriebssystem

  • Mindestens ein weiterer Kern für zusätzliche aktive Anwendungen

  • Mindestens zwei Kerne, wenn STEP 7 (TIA Portal) auf der VM installiert wird

RAM

  • 1 GB pro gestarteter Instanz

  • Mindestens 4 GB für das Windows Betriebssystem

  • Zusätzlicher RAM entsprechend den Anforderungen der übrigen aktiven Anwendungen

  • 1 GB pro gestarteter Instanz

  • Mindestens 4 GB für das Windows Betriebssystem

  • Zusätzlicher RAM entsprechend den Anforderungen der übrigen aktiven Anwendungen

  • Mindestens 8 GB, wenn STEP 7 (TIA Portal) auf der VM installiert wird

Freier Festplattenspeicher

5 GB

5 GB

Bildschirmauflösung

Mindestens 1024 x 768

Mindestens 1024 x 768

Betriebssysteme (64 Bit-Varianten)

PLCSIM Advanced V3.0 unterstützt folgende Betriebssysteme:

  • Windows 7 Home Premium

  • Windows 7 Professional SP1

  • Windows 7 Enterprise SP1

  • Windows 7 Ultimate SP1

  • Windows 10 Home Version 1809, 1903

  • Windows 10 Pro Version 1809, 1903

  • Windows 10 Enterprise Version 1809, 1903 (für SIMATIC Field PG M5)

  • Windows 10 (IoT) Enterprise 2016 LTSB

  • Windows 10 (IoT) Enterprise 2019 LTSC

  • Windows Server 2012 R2 StdE (vollständige Installation)

  • Windows Server 2016 Standard (vollständige Installation)

  • Windows Server 2019 Standard (vollständige Installation)

Hinweis

Stellen Sie sicher, dass das eingesetzte Windows Betriebssystem auf dem aktuellsten Stand ist.

Virtualisierungsplattformen

Sie können STEP 7 und PLCSIM Advanced in einer virtuellen Maschine installieren. Verwenden Sie zu diesem Zweck eine der folgenden Virtualisierungsplattformen in der angegebenen oder einer neueren Version:

  • VMware vSphere Hypervisor (ESXi) 6.7

  • VMware Workstation Pro 15.0.2

  • VMware Player 15.0.2

Informationen, die Sie beachten müssen, wenn Sie STEP 7 (TIA Portal) auf einer virtuellen Maschine installieren, finden Sie im Internet.


Einschränkungen durch Virenscanner

Unterstützte Virenscanner Bekannte Probleme und Einschränkungen
Start Zurück Weiter

Einschränkungen durch Virenscanner

Achtung

Einschränkungen durch Virenscanner

Virenscanner, die das Verhalten von Prozessen und die Kommunikation überwachen, können erheblichen Einfluss auf die Performance der Laufzeit und der Kommunikation von PLCSIM Advanced haben.
Hinweis

Liesmich

Aktualisierungen zum Thema erhalten Sie als Download im Internet.

Unterstützte Virenscanner

PLCSIM Advanced unterstützt Trend Micro Office Scan 12.0.

Bekannte Probleme und Einschränkungen

Kaspersky

Beim Einsatz des Virenscanners Anti-Virus von Kaspersky kann es vorkommen, dass während der Installation von PLCSIM Advanced die Netzwerkeinstellungen nicht korrekt gesetzt werden. Dies führt dazu, dass die Kommunikation über TCP/IP nicht genutzt werden kann (Fehlercode -50).

Abhilfe

Kontrollieren Sie Ihre Netzwerkeinstellungen wie im Kapitel "Verteilte Kommunikation aktivieren" beschrieben.


Lizenzen

Floating License

Lizenzen

Floating License

PLCSIM Advanced wird mit einer Lizenz vom Typ Floating ausgeliefert. Diese kann lokal abgelegt und für ein Netzwerk freigegeben werden.

Hinweis

Gültigkeit

Eine Lizenz ist gültig für zwei Instanzen innerhalb einer PLCSIM Advanced Installation.

PLCSIM Advanced V3.0 kann nur mit einer V3.0 Lizenz genutzt werden.

Den Umgang mit Lizenzen finden Sie in der Hilfe zum SIMATIC Automation License Manager (ALM).


Trial License

Trial License aktivieren Timeout Meldung

Trial License

Für S7-PLCSIM Advanced V3.0 steht eine Lizenz zur Verfügung, die auf 21 Tage begrenzt ist. Nach Ablauf diser Trial License wird die Instanz nicht mehr gestartet.

Trial License aktivieren

Sobald Sie im Control Panel eine Instanz starten, sucht der Automation License Manager (ALM) im Netzwerk nach einer gültigen Lizenz. Wenn für S7‑PLCSIM Advanced keine Floating License vorliegt, bietet der ALM die Trial License zur Aktivierung an.

Trial License aktivieren

Trial License aktivieren

Eine Meldung zeigt beim Starten der Instanzen die noch verbleibenden Tage an.

Trial License Meldung

Trial License Meldung

Hinweis

Remote-Zugriff

Bei einem Remote-Zugriff muss die Meldung auf dem PC bestätigt werden, auf dem die Instanz gestartet wurde.

Timeout Meldung

Wenn die Meldung zur Lizenz nicht rechtzeitig bestätigt wird, wird die Instanz nicht gestartet und folgende Meldung erscheint:

Timeout Meldung

Abhilfe

Starten Sie die Instanz erneut und bestätigen Sie die Meldung zur Lizenz.


Funktionen zu Lizenzen

API-Funktionen zu Lizenzen

Funktionen zu Lizenzen

API-Funktionen zu Lizenzen

PLCSIM Advanced überprüft regelmäßig, ob eine Lizenz vorhanden ist. Folgende Rückgabewerte geben dabei Aufschluss über den Status (beispielhaft für C++):

  • Rückgabewerte für die API-Funktion PowerOn() und die Callback-Funktion OnOperatingStateChanged

    • SREC_OK, wenn eine Floating License vorliegt.

    • SREC_WARNING_TRIAL_MODE_ACTIVE, wenn eine Instanz mit der Trial License gestartet ist.

    • SREC_WARNING_RUNNING_ON_TIA_PORTAL_TEST_SUITE, wenn keine gültige Lizenz für PLCSIM Advanced vorhanden ist, jedoch eine "TIA Portal Test Suite" Lizenz.
      PLCSIM Advanced startet mit dieser Lizenz. Ein Download aus dem TIA Portal ist möglich, allerdings beendet sich die Instanz ohne Rückmeldung, wenn der Download nicht aus der TIA Portal Test Suite erfolgt ist.

    • SREC_NOT_EMPTY, wenn keine gültige Lizenz für PLCSIM Advanced vorhanden ist, jedoch eine "TIA Portal Test Suite" Lizenz. In diesem Fall wird der Hochlauf aus der Virtual SIMATIC Memory Card nicht unterstützt.

  • Rückgabewert für die Callback-Funktion OnOperatingStateChanged

    • SREC_LICENSE_NOT_FOUND, wenn die Instanz nach Ablauf der 21 Tage abgeschaltet wird.


Installationsprotokoll

Speicherort des Installationsprotokolls Setup_Report (CAB-Datei)
Start Zurück Weiter

Installationsprotokoll

In Protokolldateien werden automatisch Informationen über die folgenden Installationsprozesse aufgezeichnet:

  • Installation von S7-PLCSIM Advanced

  • Änderung oder Aktualisierung der Installation von S7‑PLCSIM Advanced

  • Reparatur einer vorhandenen Installation von S7‑PLCSIM Advanced

  • Deinstallation von S7-PLCSIM Advanced

Mit den Protokolldateien können Sie Installationsfehler und Warnungen auswerten. Die Fehlerbehebung der Installation können Sie selbst durchführen oder sich an den technischen Support von Siemens wenden. Der Produkt-Support benötigt die Informationen aus dem Installationsprotokoll zur Analyse des Problems. Senden Sie dazu den Ordner mit den Protokolldateien als ZIP-Datei an den Support.

Speicherort des Installationsprotokolls

Der Speicherort der Protokolldatei richtet sich nach dem Betriebssystem. Geben Sie in die Adresszeile im Windows-Explorer die Umgebungsvariable "%autinstlog%" ein, um den Ordner mit den Protokolldateien zu öffnen. Alternativ gelangen Sie zum entsprechenden Verzeichnis, indem Sie in der Befehlszeile "cd %autinstlog%" eingeben.

Die Protokolldateien heißen:

  • "SIA_S7-PLCSIM_Advanced_V03@<DATUM_UHRZEIT>.log"

  • "SIA_S7-PLCSIM_Advanced_V03@<DATUM_UHRZEIT>_summary.log"

Setup_Report (CAB-Datei)

Das Installationsprotokoll und weitere erforderliche Dateien werden in einer Archivdatei gespeichert. Diese finden Sie unter "%autinstlog%\Reports\Setup_report.cab".

Für jede Installation wird eine eigene CAB-Datei mit einer Datums-ID gespeichert.

Wenn Sie Hilfe bei der Installation benötigen, dann senden Sie dem technischen Support von Siemens diese CAB-Datei zur Fehlerbehebung.


S7-PLCSIM Advanced

Setup-Programm

S7-PLCSIM Advanced

Das S7-PLCSIM Advanced Paket enthält folgende Software:

  • S7-PLCSIM Advanced

  • Automation License Manager

  • S7‑PLCSIM V5.4

  • .NET Framework

  • WinPcap

Das Paket steht als Download und auf DVD zur Verfügung:

  • SIMATIC S7-PLCSIM Advanced V3.0 Floating License

  • Upgrade SIMATIC S7‑PLCSIM Advanced V2.0 → V3.0

Bewahren Sie die DVD nach der Installation an einem sicheren, leicht zugänglichen Ort auf.

Setup-Programm

Mit dem Setup-Programm können Sie Ihre Installation bei Bedarf ändern, reparieren oder deinstallieren.


S7-PLCSIM Advanced installieren

Voraussetzung für die Installation S7-PLCSIM Advanced installieren Fehler beim Installieren von S7‑PLCSIM Advanced
Start Zurück Weiter

S7-PLCSIM Advanced installieren

Voraussetzung für die Installation

Das Setup-Programm startet automatisch mit einem Doppelklick auf das Download-Paket oder wenn Sie die DVD in das Laufwerk einlegen. Vergewissern Sie sich, dass die folgenden Bedingungen erfüllt sind, bevor Sie mit dem Installationsvorgang beginnen:

  • Hardware und Software des Computers erfüllen die Systemvoraussetzungen.

  • Sie haben Administratorrechte auf dem Installationscomputer.

  • Keine anderen Programme sind aktiv. Dies gilt auch für den Siemens Automation License Manager und andere Anwendungen von Siemens.

  • Alle S7-PLCSIM Versionen kleiner oder gleich V14 sind deinstalliert.

Hinweis

Sicherheitseinstellungen

Für die Lizenzierung über den ALM müssen Sie bei der Installation zustimmen, dass der Port 4410 für TCP als Ausnahme in der Windows-Firewall eingegeben wird (Schritt 5).
Hinweis

Einsatz von Virenscannern

Beachten Sie die Hinweise im Kapitel Einschränkungen durch Virenscanner .

S7-PLCSIM Advanced installieren

Gehen Sie zur Installation wie folgt vor:

  1. Doppelklicken Sie auf das Download-Paket oder legen Sie das Installationsmedium in das DVD-Laufwerk Ihres Computers ein. Das Setup-Programm startet automatisch, sofern Sie nicht die Autostartfunktion auf dem Computer deaktiviert haben. Wenn das Setup-Programm nicht automatisch startet, starten Sie es manuell durch Doppelklick auf die Datei "Start.exe". Das Fenster "General settings" wird angezeigt.

  2. Klicken Sie auf die Schaltfläche "Installationshinweise lesen". Wenn Sie die Hinweise gelesen haben, schließen Sie die Datei.

  3. Klicken Sie auf die Schaltfläche "Produktinformationen lesen". Wenn Sie die Informationen gelesen haben, schließen Sie die Datei.

  4. Klicken Sie auf die Schaltfläche "Durchsuchen", wenn Sie den Standardinstallationspfad ändern möchten. Der Installationspfad darf maximal 89 Zeichen lang sein. Der Pfadname darf keine UNICODE-Zeichen enthalten. Wenn Sie nicht den Standardinstallationspfad auswählen, wird das Desktop-Symbol möglicherweise nicht richtig angezeigt.

  5. Klicken Sie auf die Schaltfläche "Weiter". Das Fenster mit den Sicherheitseinstellungen wird angezeigt. Zur Fortsetzung der Installation aktivieren Sie das Optionskästchen am unteren Rand des Bildschirms, um Änderungen an den Sicherheits- und Berechtigungseinstellungen Ihres Systems zu akzeptieren.

  6. Klicken Sie auf die Schaltfläche "Weiter". Das Fenster mit den Installationseinstellungen wird angezeigt. Sie können einen Bericht der Einstellungen speichern oder drucken, indem Sie auf "Bericht speichern" oder "Bericht drucken" klicken. Überprüfen Sie die Einstellungen auf ihre Richtigkeit. Wenn Sie Änderungen vornehmen möchten, klicken Sie auf die Schaltfläche "Zurück", bis Sie an die Stelle im Installationsprozess kommen, an der Sie die Änderungen vornehmen können. Nachdem Sie Ihre Änderungen abgeschlossen haben, klicken Sie auf "Weiter".

  7. Der Übersichtsbildschirm zeigt Ihre Installationsdetails an. Klicken Sie auf die Schaltfläche "Installieren". Daraufhin wird die Installation gestartet.

  8. Nach dem Abschluss des Setup-Programms müssen Sie Ihren Computer neu starten. Wählen Sie "Ja, Computer jetzt neu starten", um den Computer sofort neu zu starten oder wählen Sie "Nein, Computer später starten", um den Neustart später durchzuführen.

  9. Klicken Sie auf "Neu starten". Wenn der Computer nicht neu gestartet wird, klicken Sie auf "Beenden".

Fehler beim Installieren von S7‑PLCSIM Advanced

Beim Installieren wird eine vorhandene Installation von S7‑PLCSIM angezeigt.

Eine Voraussetzung für die Installation von S7‑PLCSIM Advanced ist, dass sich keine S7‑PLCSIM Installation kleiner oder gleich V14 auf dem gleichen Computer befindet.

Obwohl in der Liste "Programme und Funktionen" keine Installation von S7‑PLCSIM angezeigt wird, kann diese noch auf dem Computer vorhanden sein.

Abhilfe

Führen Sie für S7‑PLCSIM kleiner oder gleich V14 das Setup durch und deinstallieren Sie dabei das Programm.

Wenn das Setup nicht mehr vorhanden ist, laden Sie die Setup-Dateien von S7‑PLCSIM über die Siemens Mall.


S7-PLCSIM Advanced ändern

Voraussetzungen Vorgehensweise

S7-PLCSIM Advanced ändern

Voraussetzungen

Folgende Bedingungen müssen erfüllt sein, bevor Sie mit dem Ändern der Installation beginnen:

  • Hardware und Software des Computers erfüllen die Systemvoraussetzungen.

  • Sie haben Administratorrechte auf dem Installationscomputer.

  • Keine anderen Programme sind aktiv.

Vorgehensweise

Gehen Sie zum Ändern Ihrer S7-PLCSIM Advanced-Installation wie folgt vor:

  1. Doppelklicken Sie auf das Download-Paket oder legen Sie das Installationsmedium in das Laufwerk ein. Das Setup-Programm startet automatisch, sofern Sie nicht die Autostartfunktion auf dem Computer deaktiviert haben. Wenn das Setup-Programm nicht automatisch startet, starten Sie es manuell durch Doppelklick auf die Datei "Start.exe".

  2. Befolgen Sie die Eingabeaufforderungen, bis Sie in das Fenster "Konfiguration" gelangen.

  3. Wählen Sie das Optionskästchen "Upgrade ändern".

  4. Befolgen Sie die weiteren Eingabeaufforderungen, um Ihre Installation zu ändern.

  5. Um den Installationsvorgang abzuschließen, starten Sie Ihren Computer neu.
Hinweis

Zielverzeichnis

Das Zielverzeichnis können Sie nicht ändern, weil Sie eine bestehende Installation ändern.


S7-PLCSIM Advanced reparieren

Voraussetzungen Vorgehensweise

S7-PLCSIM Advanced reparieren

Voraussetzungen

Folgende Bedingungen müssen erfüllt sein, bevor Sie mit dem Reparieren der Installation beginnen:

  • Hardware und Software erfüllen die Systemvoraussetzungen.

  • Sie haben Administratorrechte auf dem Installationscomputer.

  • Keine anderen Programme sind aktiv.

Vorgehensweise

Gehen Sie zum Reparieren Ihrer Installation wie folgt vor:

  1. Doppelklicken Sie auf das Download-Paket oder legen Sie das Installationsmedium in das Laufwerk ein. Das Setup-Programm startet automatisch, sofern Sie nicht die Autostartfunktion auf dem Computer deaktiviert haben. Wenn das Setup-Programm nicht automatisch startet, starten Sie es manuell durch Doppelklick auf die Datei "Start.exe".

  2. Befolgen Sie die Eingabeaufforderungen, bis Sie in das Fenster "Konfiguration" gelangen. Wählen Sie das Optionskästchen "Reparieren".

  3. Befolgen Sie die weiteren Eingabeaufforderungen, um Ihre Installation zu reparieren.

  4. Um den Reparaturvorgang abzuschließen, starten Sie Ihren Computer neu.


S7-PLCSIM Advanced deinstallieren

S7-PLCSIM Advanced über die Windows-Systemsteuerung deinstallieren S7-PLCSIM Advanced über das Setup-Programm deinstallieren Weitere Software deinstallieren
Start Zurück Weiter

S7-PLCSIM Advanced deinstallieren

Sie haben zwei Möglichkeiten, S7‑PLCSIM Advanced zu deinstallieren:

  • Sie deinstallieren über die Windows-Systemsteuerung das Programm.

  • Sie deinstallieren über das Setup-Programm das gesamte Produkt.

S7-PLCSIM Advanced über die Windows-Systemsteuerung deinstallieren

Gehen Sie wie folgt vor:

  1. Wählen Sie in der Windows-Systemsteuerung die Option "Programme und Funktionen".

  2. Klicken Sie mit der rechten Maustaste auf "Siemens S7‑PLCSIM Advanced V3.0" und wählen Sie "Deinstallieren".

  3. Befolgen Sie zur Deinstallation die Eingabeaufforderungen.

  4. Um den Deinstallationsvorgang abzuschließen, starten Sie Ihren Computer neu.

    Wenn Sie keinen Neustart durchführen, läuft der Runtime Manager weiter.

Wenn beim Deinstallieren über die Windows-Systemsteuerung Probleme auftreten, verwenden Sie zum Deinstallieren der Anwendung das Installationsmedium, sofern vorhanden.

S7-PLCSIM Advanced über das Setup-Programm deinstallieren

Gehen Sie wie folgt vor:

  1. Doppelklicken Sie auf das Download-Paket oder legen Sie das Installationsmedium in das Laufwerk ein. Das Setup-Programm startet automatisch, sofern Sie nicht die Autostartfunktion auf dem Computer deaktiviert haben. Wenn das Setup-Programm nicht automatisch startet, starten Sie es manuell durch Doppelklick auf die Datei "Start.exe".

    Wenn Sie keinen Neustart durchführen, läuft der Runtime Manager weiter.

  2. Befolgen Sie die Eingabeaufforderungen, bis Sie in das Fenster "Konfiguration" gelangen. Ihre vorherige Installation wird erkannt. Wählen Sie das Optionskästchen "Deinstallieren".

  3. Befolgen Sie zur Deinstallation die weiteren Eingabeaufforderungen.

  4. Um den Deinstallationsvorgang abzuschließen, starten Sie Ihren Computer neu.

    Wenn Sie keinen Neustart durchführen, läuft der Runtime Manager weiter.

Weitere Software deinstallieren

Beim Deinstallieren bleibt folgende Software aus dem S7‑PLCSIM Advanced Paket installiert:

  • Automation License Manager

  • S7‑PLCSIM V5.4

  • .NET Framework

  • WinPcap

Wenn Sie auch diese Software deinstallieren möchten, dann nutzen Sie dazu die Windows-Systemsteuerung.