执行自动安装

示例 参见 过程 其它
执行自动安装

该章节包括以下主题的信息:
  • 自动安装的原理
  • 使用记录/播放模式自动安装
  • 通过命令行自动安装
  • 参数列表
  • 从安装过程返回值


自动安装的原理

简介
自动安装的原理

简介

如果您要负责管理多台计算机上的软件包，则可以使用多个选项来自动完成安装。

记录/播放功能

可以使用记录/播放功能来自动完成以下安装过程：

  • 安装

    根据所选参数安装软件。

  • 修改或更新

    根据所选参数重新安装软件。

命令行

可以使用命令行来自动完成以下安装过程：

  • 安装

    根据所选参数安装软件。

  • 修改或更新

    根据所选参数重新安装软件。

  • 修复 (REINSTALL)

    选择该选项后，将通过重新安装来修复当前安装的软件。 只能将“REINSTALL”参数与“REBOOT”、“/qn”和“/qb”参数组合使用。 从而，将使用与原始安装相同的参数来重新安装软件。

  • 卸载 (REMOVE)

    将软件从系统中删除。 只能将“REMOVE”参数与“REBOOT”、“/qn”和“/qb”参数组合使用。

说明

要自动执行安装、修改或更新、修复或卸载命令，必须使用“/qn”或“/qb”参数之一。 如果忽略了这些参数，则会打开正常安装对话框，以执行手动安装。


使用记录/播放模式自动安装

使用记录/播放模式自动安装

该章节包括以下主题的信息:
  • 开始记录
  • 选择安装设置
  • 播放记录


开始记录

要求 步骤 结果
开始记录

要求

  • PG/PC 的硬件和软件满足系统要求。

步骤

要记录安装，请执行下列步骤：

  1. 使用“开始 > 运行 > cmd”(Start > Run > cmd) 打开 Windows 命令提示符。

  2. 切换到包含“Start.exe”文件的目录。

  3. 在命令提示符中，输入以下命令：

    • "Start.exe /record"

  4. 按下 <Return> 键，确认输入。

结果

将打开包含您在“记录”模式下会看到的信息的安装对话框，系统将保持不变。


选择安装设置

步骤 结果
选择安装设置

步骤

请按如下步骤设置安装选项：

  1. 在用于选择安装语言的对话框中，选择要用来显示安装程序对话框的语言，然后单击“下一步”(Next) 按钮。

    将打开用于选择产品语言的对话框。

  2. 选择产品用户界面使用的语言，然后单击“下一步”(Next) 按钮。

    说明

    始终将“英语”(English) 作为默认产品语言安装。

    将打开选择产品组态的对话框。

  3. 选择要安装的产品：

    • 如果需要以最小配置安装程序，则单击“最小”(Minimal) 按钮。

    • 如果需要以典型配置安装程序，则单击“典型”(Typical) 按钮。

    • 如果希望手动选择要安装的产品，请选中/取消选中要安装产品所对应的框。 这将自动激活“用户自定义”(User defined) 按钮。

  4. 如果要在桌面上创建快捷方式，请选中“创建桌面快捷方式”(Create desktop shortcut) 复选框。

  5. 如果要更改安装的目标目录，请单击“浏览”(Browse) 按钮。

    说明

    建议您使用“程序文件”(Program Files) 文件夹作为目标目录。 如果选择硬盘（例如“D:”），请确保要安装该程序的所有计算机上都具有该驱动器。

  6. 单击“下一步”(Next) 按钮。

    将打开许可条款对话框。

  7. 要继续安装，请阅读并接受所有许可协议，并单击“下一步”(Next)。

    如果在安装 TIA Portal 时需要更改安全和权限设置，则会打开安全设置对话框。

  8. 要继续安装，请接受对安全和权限设置的更改，并单击“下一步”(Next) 按钮。

    下一对话框将显示安装设置概览。

  9. 检查所选的安装设置。如果要进行任何更改，请单击“上一步”(Back) 按钮，直到到达想要在其中进行更改的对话框位置。 完成所需更改之后，通过单击“下一步”(Next) 按钮返回概述部分。

  10. 单击“下一步”(Next) 按钮。

    将打开一个对话框，其中包含在重启和发生错误时要遵循的步骤。

  11. 选择期望的选项并保存配置。

  12. 单击“退出”(Exit) 按钮。

结果

已创建并保存了自动安装文件。


播放记录

要求 步骤 结果
播放记录

要求

  • PG/PC 的硬件和软件满足系统要求。

  • 具有计算机的管理员权限。

  • 已存在先前录制的文件 ("*.rec")。

  • 关闭所有正在运行的程序。

步骤

要播放安装，请执行下列步骤：

  1. 使用“开始 > 运行 > cmd”(Start > Run > cmd) 打开 Windows 命令提示符。

  2. 切换到包含“Start.exe”文件的目录。

  3. 在命令提示符中，输入以下命令：

    • "Start.exe /play=<驱动器>:\<目录>\<文件名>"，例如“Start.exe /play=c:\siemens configuration\autoinstall.rec”

  4. 按下 <Return> 键，确认输入。

    说明

    如果在安装期间未找到许可证密钥，则将跳过许可证传送步骤，并稍后通过“自动许可证管理器”来处理。

结果

将使用配置文件中记录的设置自动完成安装。


通过命令行自动安装

通过命令行自动安装

该章节包括以下主题的信息:
  • 自动安装
  • 自动修改或更新
  • 自动修复
  • 自动卸载
  • 通过命令行自动安装示例


自动安装

要求 步骤
自动安装

要求

  • PG/PC 的硬件和软件满足系统要求。

  • 具有计算机的管理员权限。

  • 关闭所有正在运行的程序。

步骤

要直接通过命令界面使用期望的选项启动安装，请执行下列步骤：

  1. 使用“开始 > 运行 > cmd”(Start > Run > cmd) 打开 Windows 命令提示符。

  2. 切换到包含“Start.exe”文件的目录。

  3. 在命令提示符中，输入以下命令之一：

    • 安装时可以看到进度条： "Start.exe /qb <Parameter>”

    • 安装时无法看到进度条： "Start.exe /qn <Parameter>”或“Start.exe /silent <Parameter>”

      说明

      使用“REBOOT=Suppress”选项时，记住必须亲自评估返回值，且有可能需要重启系统。

  4. 按下 <Return> 键，确认输入。


自动修改或更新

要求 步骤
自动修改或更新

可以自动修改已安装的产品或将其更新到新版本。 为此，可以通过将期望的选项直接作为命令行来启动重新安装。

要求

  • PG/PC 的硬件和软件满足系统要求。

  • 具有计算机的管理员权限。

  • 关闭所有正在运行的程序。

步骤

要直接通过命令行修改或更新已安装的产品，请执行下列步骤：

  1. 使用“开始 > 运行 > cmd”(Start > Run > cmd) 打开 Windows 命令提示符。

  2. 切换到包含“Start.exe”文件的目录。

  3. 在命令提示符中，输入以下命令之一：

    • 安装时可以看到进度条： "Start.exe /qb <Parameter>”

    • 安装时无法看到进度条： "Start.exe /qn <Parameter>”或“Start.exe /silent <Parameter>”

      说明

      使用“REBOOT=Suppress”选项时，记住必须亲自评估返回值，且有可能需要重启系统。

  4. 按下 <Return> 键，确认输入。


自动修复

要求 步骤
自动修复

如同在通过对话框引导的安装过程中选择了“修复”一样，如果在执行安装之后使用参数“REINSTALL=ALL”再次调用了“Start.exe”，则会重新安装所有组件。 安装过程与之前描述的完全相同。 通过命令行进行的自动修复与自动安装的调用方法完全相同。 可以输入参数确定重启。

只能将“REINSTALL”与“REBOOT”、“/qn”和“/qb”参数组合使用。 禁止使用其它所有参数。

要求

  • PG/PC 的硬件和软件满足系统要求。

  • 具有计算机的管理员权限。

  • 关闭所有正在运行的程序。

步骤

要直接通过命令行修复安装，请执行下列步骤：

  1. 使用“开始 > 运行 > cmd”(Start > Run > cmd) 打开 Windows 命令提示符。

  2. 切换到包含“Start.exe”文件的目录。

  3. 在命令提示符中，输入以下命令之一：

    • 安装时可以看到进度条： "Start.exe /qb REINSTALL=ALL <REBOOT-参数>”

    • 安装时无法看到进度条： "Start.exe /qn REINSTALL=ALL <REBOOT-参数>”或“Start.exe /silent REINSTALL=ALL <REBOOT-参数>”

      说明

      参数 REBOOT 可选。 使用“REBOOT=Suppress”选项时，记住必须亲自评估返回值，且有可能需要重启系统。

  4. 按下 <Return> 键，确认输入。


自动卸载

要求 步骤
自动卸载

如果需要删除现有安装，可以通过自动卸载完成。 这样会卸载所有软件包。 通过命令行进行的自动卸载与自动安装的调用方法完全相同。 可以输入参数确定重启。

只能将“REMOVE”与“REBOOT”、“/qn”和“/qb”参数组合使用。 禁止使用其它所有参数。

要求

  • 具有计算机的管理员权限。

  • 关闭所有正在运行的程序。

步骤

要直接通过命令行启动卸载，请执行下列步骤：

  1. 使用“开始 > 运行 > cmd”(Start > Run > cmd) 打开 Windows 命令提示符。

  2. 切换到包含“Start.exe”文件的目录。

  3. 在命令提示符中，输入以下命令之一：

    • 卸载时可以看到进度条： "Start.exe /qb REMOVE =ALL <REBOOT-参数>”

    • 卸载时无法看到进度条： "Start.exe /qn REMOVE =ALL <REBOOT-参数>”或“Start.exe /silent REMOVE =ALL <REBOOT-参数>”

      说明

      参数 REBOOT 可选。使用“REBOOT=Suppress”选项时，记住必须亲自评估返回值，且有可能需要重启系统。

  4. 按下 <Return> 键，确认输入。


通过命令行自动安装示例

使用 REBOOT=AUTO 进行典型安装的示例 使用 REBOOT=Suppress 进行完整安装的示例 查询每个批处理文件返回值的示例
通过命令行自动安装示例

使用 REBOOT=AUTO 进行典型安装的示例

下例显示了通过命令行进行的典型安装：

Start.exe /qb REBOOT=Auto INSTALLLANGUAGE=1031;1033 INSTALLDIR="C:\Program Files\Siemens\Automation" INSTALLLEVEL=Typical

在本例中，执行了德语和英语版本的典型安装 ("INSTALLLEVEL=Typical")("INSTALLLANGUAGE=1031;1033")。 在安装结束时，无需确认便会自动重启系统 ("REBOOT=Auto")。 将目录“C:\Program Files\Siemens\Automation”用作安装目录 ("INSTALLDIR=C:\Program Files\Siemens\Automation")。

使用 REBOOT=Suppress 进行完整安装的示例

下例显示了通过命令行进行的完整安装：

Start.exe /qb REBOOT=Suppress INSTALLLANGUAGE=1031;1033 INSTALLDIR="C:\Program Files\Siemens\Automation" INSTALLLEVEL=Complete

在本例中，执行了德语和英语版本的完整安装 ("INSTALLLEVEL=Complete")("INSTALLLANGUAGE=1031;1033")。 在安装结束时，没有重启系统 ("REBOOT=Suppress")。 这意味着必须亲自评估返回值，并可能需手动重启系统。

查询每个批处理文件返回值的示例

以下示例说明了如何查询每个批处理文件的返回值：

SET SetupSuccess=%ERRORLEVEL%

if '%SetupSuccess%' EQU '0' (

echo Setup successful. Return code: %SetupSuccess%

) else (

if '%SetupSuccess%' EQU '3010' (

echo Setup successful. A reboot is needed! Return code: %SetupSuccess%

) else (

echo "ERROR during Setup! Return code: %SetupSuccess%

)

)

Pause

返回代码“1641”同样记录下了成功完成安装，并且已初始化重启。 但是，只有在使用了“/REBOOT=Auto”且因此未在批处理文件中评估时，才会重启。

可以在“从安装过程返回值”下找到所有可能的返回值。


参数列表

用于自动安装的参数
参数列表

用于自动安装的参数

下表列出了自动安装可以使用的参数：

参数

说明

适用范围

可能的值

值的解释

/qb

可以使用该参数执行自动安装。 在安装过程中，将以进度条的形式收到有关当前所执行安装的信息。

注意：

  • 不使用参数“qb”或“qn”，便无法执行自动安装。

  • 无法同时在命令中使用参数“qb”和“qn”。

  • 安装过程中出现的信息仅以英文形式显示。 这意味着该信息与日志文件中的文本相匹配。 例如，如果要联系产品技术支持人员，则需要这些日志文件。

安装

重新安装

卸载

-

/qn 或 /silent

可以使用该参数执行自动安装。 在安装过程中，不会收到有关当前所执行安装的信息。

注意：

  • 不使用参数“qb”或“qn”，便无法执行自动安装。

  • 无法同时在命令中使用参数“qb”和“qn”。

安装

重新安装

卸载

-

/lcid

可以使用该参数指定要用于安装的安装语言。 在此，请输入十进制格式的所需语言本地 ID (LCID)。

示例：

/lcid=1031

安装

重新安装

卸载

1031

德语

1033

英语

1040

意大利语

1036

法语

3082

西班牙语

2052

简体中文

...

更多产品语言

/record

可以使用该参数启动“记录”模式。 将为自动安装创建“autoinstall.rec”文件。

安装

/play

可以使用该参数启动“播放”模式。 在该模式中，需要在“记录”方式中创建的配置文件。

示例：

/play="C:\Siemens Configurations\autoinstall.rec"

安装

INSTALLDIR

可使用此参数指定安装的目标目录。

示例：

INSTALLDIR="C:\Program Files\Siemens\Automation"

安装

INSTALLLANGUAGE

INSTALLLANGUAGE

可使用此参数指定要安装的产品语言。 在此，请输入十进制格式的所需语言本地 ID (LCID)。

示例：

INSTALLLANGUAGE=1031;1033

安装

1031

德语

1033

英语

1040

意大利语

1036

法语

3082

西班牙语

2052

简体中文

...

更多产品语言

REBOOT

可使用此参数在安装期间指定重启特性。

示例：

REBOOT=Suppress

安装

重新安装

卸载

Auto

必要时，将在安装结束时自动执行重启。

Suppress

禁止在安装结束时重启。 如果需要重启，此调用进程必须触发重启。

ONERROR

可以使用该参数指定在安装结束时发生错误的情况下要遵循的步骤。

示例：

ONERROR=Suppress

安装

重新安装

卸载

Suppress

在安装结束时禁止出现报告发生错误的对话框。 可以根据此过程中的返回值来评估错误。

User

如果发生错误，则在安装结束时会显示报告错误的对话框。

INSTALLLEVEL

可使用此参数指定安装类型。

示例：

INSTALLLEVEL=Complete

安装

最小

最小安装

典型

典型安装

完整

完整安装


从安装过程返回值

返回值的列表
从安装过程返回值

返回值的列表

下表显示了自动安装的返回值及其说明：

返回值 | 技术故障说明 | 说明
? | OtherError | 下表中没有说明的返回值通常表示错误。 可以在安装日志中找到所有错误的详细信息。 打开最新的日志文件，文件名以“SIA”开头。
0 | Success | 成功安装。 无错误。
5 | AccessDenied | 没有正确权限。 安装需要管理员权限。
112 | DiskFull | 目标介质上没有足够的可用空间。
1601 | InstallServiceFailure | 初始化过程中发生内部错误。
1602 | UserExit | 被用户取消通常是由于在对话框中选择了“取消”而发生的。
1603 | InstallFailure | 执行安装时出错。
1605 | UnknownProduct | 产品配置过程中发生内部错误。
1610 | BadConfiguration | 产品配置过程中发生内部错误。
1618 | InstallAlreadyRunning | 另一个安装过程正在运行。 不能同时执行多个安装。
1622 | InstallLogFailure | 写入日志时出错。
1627 | FunctionFailed | 发生内部错误。
1633 | InstallPlatformUnsupported | 不支持该操作系统。
1639 | InvalidCommandline | 在指定命令行中出现错误。
1641 | SuccessRebootInitiated | 成功安装。 已初始化重启来完成操作。
3010 | SuccessRebootRequired | 成功安装。 必须进行重启来完成操作！
5001 | PrerequisitesFailure | 未满足安装条件。 更多信息，可以通过双击 start.exe 来重启安装过程。
5002 | InvalidIEVersion | 未安装 Internet Explorer 或安装了不支持的版本。
5003 | ResourcesFailed | 初始化过程中发生内部错误。
5004 | ProductInitFailed | 发生内部错误（安装介质可能有缺陷）。
5005 | ProductInitNewerVersionInstalled | 已安装较新版本的产品。
5006 | ProductInitMoreValuableEditionInstalled | 已安装更完整版本的产品（例如，如果您正尝试安装基本版，但已安装了专业版）。
5007 | ProductInitOptionalWithoutMain | 您正尝试安装不带主软件的可选软件包。
5008 | ProductIncompatibility | 存在与要安装产品不兼容的产品。
5009 | AutoinstallFileNotFound | 找不到“播放”模式所需的文件。
5010 | AutoinstallUnexpectedContent | 无法读取“播放”模式所需的文件（格式错误、版本错误或安装介质不正确）。
11641 | NotCompleteReboot | 安装未完成且必须在重启后继续。 重启已经开始。 重启后，必须重启安装。
13010 | NotCompleteRebootRequired | 安装未完成且必须在重启后继续。 必须启动重启，然后再次重启安装。