S7-PLCSIM V16 自述文件

章节中 说明 示例 基础知识 过程 其它
启动 返回 继续

S7-PLCSIM V16 自述文件

该章节包括以下主题的信息:
  • 在线查看最新产品信息
  • S7-PLCSIM V16 中有哪些新增内容？
  • 已知问题


在线查看最新产品信息

在线查看最新产品信息

西门子会根据需要更新本自述文件，并在 西门子工业在线支持（“SIOS”）网站上发布文件。SIOS 站点中的每个自述文件将包含此自述文件的内容以及发布产品时未提供的 S7‑PLCSIM V16 的其它相关信息。

如果在 S7‑PLCSIM 中发生异常，请检查 SIOS 站点并搜索“S7-PLCSIM V16 自述文件”来查看是否有解决所遇到问题的新版本。


S7-PLCSIM V16 中有哪些新增内容？

S7-PLCSIM V16 中有哪些新增内容？

该章节包括以下主题的信息:
  • 新增功能概述
  • 支持最新版本固件
  • 事件仿真
  • 扫描控制
  • SIM 表扩展


新增功能概述

新增功能概述

S7‑PLCSIM V16 介绍以下新功能或更新的功能：

  • 操作系统支持

  • 支持最新版本固件

  • 事件仿真

  • 扫描控制

  • SIM 表扩展


支持最新版本固件

支持最新版本固件

S7‑PLCSIM V16 支持使用以下固件的 CPU 系列设备：

  • S7‑1200 版本 4.0 至 4.4

  • S7‑1200F 版本 4.1 至 4.4

  • S7‑1500 和 S7‑1500F 版本 2.8 及以下

  • ET 200SP 和 ET 200SPF 版本 2.8 及以下


事件仿真

事件仿真

S7‑PLCSIM V16 提供事件表，可仿真以下中断事件：

  • 机架或站故障

  • 拔出或插入模块

  • 硬件中断

  • 诊断错误中断

在项目树中添加事件表。


扫描控制

扫描控制

S7‑PLCSIM V16 提供以下功能，可用于控制仿真 CPU 的扫描周期：

  • CPU 操作面板

  • 可暂停程序扫描

  • 可在特定时间段或特定扫描数下执行扫描


SIM 表扩展

SIM 表扩展

S7‑PLCSIM V16 为 SIM 表提供以下扩展功能：

  • 浏览功能，可通过 STEP 7 PLC 变量表、监视表或强制表创建 SIM 表

  • 可隐藏或取消隐藏 SIM 表编辑器中的列


已知问题

已知问题

该章节包括以下主题的信息:
  • S7-PLCSIM 无法仿真 V5.2 Modbus TCP 通信
  • High_Speed_Counter 指令返回的错误


S7-PLCSIM 无法仿真 V5.2 Modbus TCP 通信

S7-PLCSIM 无法仿真 V5.2 Modbus TCP 通信

如果 STEP 7 程序使用 Modbus TCP MB_SERVER 和 MB_CLIENT 指令的 V5.2 版本，则 S7-PLCSIM 无法仿真通信。要使用 S7‑PLCSIM 仿真这些指令，请使用这些指令的 V4.0 版本。


High_Speed_Counter 指令返回的错误

通过 SIM 表设置 STS_READY

High_Speed_Counter 指令返回的错误

如果使用 S7-PLCSIM 在 TM Count 模块中仿真高速计数器，则 High_Speed_Counter 指令将返回错误 16#80C7。

High_Speed_Counter 指令期望模块已设置状态就绪 (STS_READY) 位。由于 S7-PLCSIM 不仿真模块行为，因此该指令会返回错误。

STS_READY 位在模块的输入区域中，偏移量为 13.4。例如，如果 TM Count 模块的输入区域从 %I32 开始，则 STS_READY 位从 %I45.4 开始。

可以设置 STS_READY 位以避免出现 High_Speed_Counter 指令返回的错误情况。

通过 SIM 表设置 STS_READY

考虑一个使用带有 TM Count 1x24V 模块的 S7‑1500 的示例，其中 TM Count 1x24V 从 %I.0 开始。请注意，可在工艺模块的设备组态中找到该地址。

要将模块的 STS_READY 位设置为 TRUE，请在 SIM 表中输入偏移量 13.4 的相应 I 地址。将修改值设置为 TRUE。例如，如果模块从 %I0 开始，请按以下方式组态 SIM 表条目：