S7-PLCSIM V16 Liesmich

Im Abschnitt Anleitungen Beispiele Grundlagen Verlauf Extras
Start Zurück Weiter

S7-PLCSIM V16 Liesmich

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Aktuelle Produktinformationen online anzeigen
  • Was ist neu in S7-PLCSIM V16?
  • Bekannte Probleme


Aktuelle Produktinformationen online anzeigen

Aktuelle Produktinformationen online anzeigen

Siemens aktualisiert diese Liesmich-Datei je nach Bedarf und veröffentlicht sie auf der Website von Siemens Industry Online-Support ("SIOS"). Jede Liesmich-Datei auf der SIOS-Seite umfasst den Inhalt dieser Liesmich-Datei sowie weitere Informationen zu S7‑PLCSIM V16, die zum Zeitpunkt der Produktfreigabe noch nicht verfügbar waren.

Wenn Sie in S7‑PLCSIM unerwartetes Verhalten feststellen, suchen Sie auf der SIOS-Seite nach der "S7-PLCSIM V16 Liesmich", um festzustellen, ob Ihr Problem möglicherweise in einer neueren Ausgabe behandelt wird.


Was ist neu in S7-PLCSIM V16?

Was ist neu in S7-PLCSIM V16?

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • Überblick über neue Funktionen
  • Unterstützung der neuesten Firmware
  • Ereignissimulation
  • Scan-Steuerung
  • Erweiterungen der SIM-Tabelle


Überblick über neue Funktionen

Überblick über neue Funktionen

Mit S7‑PLCSIM V16 werden die folgenden neuen oder aktualisierten Funktionen eingeführt:

  • Unterstützte Betriebssysteme

  • Unterstützung der neuesten Firmware

  • Ereignissimulation

  • Scan-Steuerung

  • Erweiterungen der SIM-Tabelle


Unterstützung der neuesten Firmware

Unterstützung der neuesten Firmware

S7‑PLCSIM V16 unterstützt Geräte der CPU-Familien mit der folgenden Firmware:

  • S7-1200, Versionen von 4.0 bis 4.4

  • S7-1200F, Versionen von 4.1 bis 4.4

  • S7-1500 und S7-1500F, Versionen bis 2.8

  • ET 200SP und ET 200SPF, Versionen bis 2.8


Ereignissimulation

Ereignissimulation

S7‑PLCSIM V16 bietet Ereignistabellen zur Simulation der folgenden Alarmereignisse:

  • Baugruppenträger- oder Stationsausfall

  • Ziehen oder Stecken von Modulen

  • Hardwarealarm

  • Diagnosefehleralarm

Ereignistabellen fügen Sie in der Projektnavigation hinzu.


Scan-Steuerung

Scan-Steuerung

S7-PLCSIM V16 bietet die folgenden Funktionen zum Steuern des Zyklus Ihrer simulierten CPU:

  • CPU-Bedienpanel

  • Möglichkeit zum Anhalten des Programmzyklus

  • Möglichkeit zum Ausführen von Zyklen für eine bestimmte Zeitdauer oder für eine bestimmte Anzahl von Zyklen


Erweiterungen der SIM-Tabelle

Erweiterungen der SIM-Tabelle

S7‑PLCSIM V16 bietet die folgenden Erweiterungen für SIM-Tabellen:

  • Durchsuchen-Funktion zum Erstellen von SIM-Tabellen in PLC-Variablentabellen, Beobachtungstabellen oder Forcetabellen in STEP 7

  • Möglichkeit zum Ausblenden und Einblenden von Spalten im SIM-Tabelleneditor


Bekannte Probleme

Bekannte Probleme

Dieses Kapitel enthält Informationen zu folgenden Themen:
  • S7-PLCSIM kann keine Modbus TCP-Kommunikation V5.2 simulieren
  • Fehlermeldung von Anweisung High_Speed_Counter


S7-PLCSIM kann keine Modbus TCP-Kommunikation V5.2 simulieren

S7-PLCSIM kann keine Modbus TCP-Kommunikation V5.2 simulieren

Wenn Ihr STEP 7-Programm V5.2 der Modbus-Anweisungen TCP MB_SERVER und MB_CLIENT verwendet, kann S7-PLCSIM die Kommunikation nicht simulieren. Um diese Anweisungen mit S7-PLCSIM zu simulieren, muss V4.0 der Anweisungen benutzt werden.


Fehlermeldung von Anweisung High_Speed_Counter

Einstellung STS_READY aus einer SIM-Tabelle

Fehlermeldung von Anweisung High_Speed_Counter

Wenn Sie S7-PLCSIM für die Simulation eines schnellen Zählers in einem TM Count-Modul verwenden, meldet die Anweisung High_Speed_Counter einen Fehler 16#80C7.

Die Anweisung High_Speed_Counter erwartet, dass das Modul ein Bit für "Status bereit" (STS_READY) gesetzt hat. Da S7-PLCSIM das Modulverhalten nicht simuliert, meldet die Anweisung einen Fehler.

Bit STS_READY befindet sich im Eingangsbereich des Moduls bei Offset 13.4. Wenn der Eingangsbereich Ihres TM Count-Moduls beispielsweise bei %I32 beginnt, findet sich das Bit STS_READY bei %I45.4.

Um diese Fehlermeldung der Anweisung High_Speed_Counter zu vermeiden, können Sie das Bit STS_READY entsprechend setzen.

Einstellung STS_READY aus einer SIM-Tabelle

Betrachten wir ein Beispiel mit einer S7‑1500 und einem TM Count 1x24V-Modul, wobei TM Count 1x24V bei %I.0 beginnt. Diese Adresse finden Sie in der Gerätekonfiguration für Ihr Technologiemodul.

Um das Bit STS_READY für das Modul auf TRUE zu setzen, geben Sie die entsprechende Eingangsadresse für Offset 13.4 in Ihre SIM-Tabelle ein. Setzen Sie den Änderungswert auf TRUE. Beispiel: Wenn Ihr Modul bei %I0 beginnt, konfigurieren Sie einen Eintrag in Ihrer SIM-Tabelle wie folgt: