S7-PLCSIM V16 Readme

In section Instructions Examples Basics History Extra
Start Previous Next

S7-PLCSIM V16 Readme

This section contains information on the following topics:
  • View the most recent product information online
  • What's new in S7-PLCSIM V16?
  • Known problems


View the most recent product information online

View the most recent product information online

Siemens updates this readme file as needed and publishes it on the Siemens Industry Online Support ("SIOS") website. Each readme file on the SIOS site contains the contents of this readme file as well as additional information about S7‑PLCSIM V16 that was not available when the product was released.

If you encounter unexpected behavior in S7‑PLCSIM, check the SIOS site and search for "S7-PLCSIM V16 readme" to see whether there is a newer version that addresses your issue.


What's new in S7-PLCSIM V16?

What's new in S7-PLCSIM V16?

This section contains information on the following topics:
  • Overview of what's new
  • Support for the latest firmware
  • Event simulation
  • Scan control
  • SIM table enhancements


Overview of what's new

Overview of what's new

S7‑PLCSIM V16 introduces the following new or updated functionality:

  • Operating system support

  • Support for the latest firmware

  • Event simulation

  • Scan control

  • SIM table enhancements


Support for the latest firmware

Support for the latest firmware

S7‑PLCSIM V16 supports CPU device families with the following firmware:

  • S7‑1200 versions from 4.0 to 4.4

  • S7‑1200F versions from 4.1 to 4.4

  • S7‑1500 and S7‑1500F versions 2.8 and lower

  • ET 200SP and ET 200SPF versions 2.8 and lower


Event simulation

Event simulation

S7‑PLCSIM V16 provides Event tables to simulate the following interrupt events:

  • Rack or station failure

  • Pull or plug of modules

  • Hardware interrupt

  • Diagnostic error interrupt

You add Event tables in the project tree.


Scan control

Scan control

S7‑PLCSIM V16 provides the following features for you to control the scan cycle of your simulated CPU:

  • CPU operator panel

  • Ability to pause the program scan

  • Ability to execute scans for a particular period of time or for a specific number of scans


SIM table enhancements

SIM table enhancements

S7‑PLCSIM V16 provides the following enhancements for SIM tables:

  • Browse function for creating a SIM table from STEP 7 PLC tag tables, watch tables, or force tables

  • Ability to hide and unhide columns in the SIM table editor


Known problems

Known problems

This section contains information on the following topics:
  • S7-PLCSIM cannot simulate V5.2 Modbus TCP communication
  • Error returned by High_Speed_Counter instruction


S7-PLCSIM cannot simulate V5.2 Modbus TCP communication

S7-PLCSIM cannot simulate V5.2 Modbus TCP communication

If your STEP 7 program uses V5.2 of the Modbus TCP MB_SERVER and MB_CLIENT instructions, S7-PLCSIM cannot simulate the communication. To simulate these instructions with S7‑PLCSIM, use V4.0 of these instructions.


Error returned by High_Speed_Counter instruction

Setting STS_READY from a SIM table

Error returned by High_Speed_Counter instruction

If you use S7-PLCSIM to simulate a high speed counter in a TM Count module, the High_Speed_Counter instruction returns the error 16#80C7.

The High_Speed_Counter instruction expects that the module has set a status ready (STS_READY) bit. Because S7-PLCSIM does not simulate module behavior, the instruction returns an error.

The STS_READY bit is in the input area of the module at offset 13.4. If the input area of your TM Count module begins at %I32, for example, then the STS_READY bit is at %I45.4.

You can set the STS_READY bit to avoid the error condition that the High_Speed_Counter instruction returns.

Setting STS_READY from a SIM table

Consider an example using an S7‑1500 with a TM Count 1x24V module where the TM Count 1x24V begins at %I.0. Note that you can find this address in the device configuration for your technology module.

To set the STS_READY bit for the module to TRUE, enter the corresponding I address for offset 13.4 in your SIM table. Set the modify value to TRUE. For example, if your module begins at %I0, configure a SIM table entry as follows: