Léame S7-PLCSIM V16

En el apartado Instrucciones Ejemplos Fundamentos Historial Herramientas
Inicio Atrás Siguiente

Léame S7-PLCSIM V16

Este capítulo incluye información sobre los siguientes temas:
  • Consulte la última información del producto online
  • Novedades de S7-PLCSIM V16
  • Problemas conocidos


Consulte la última información del producto online

Consulte la última información del producto online

Siemens actualiza el archivo Léame cuando es necesario y lo publica en el sitio web del Siemens Industry Online Support ("SIOS"). Cada archivo Léame del sitio SIOS incluye los contenidos de este archivo Léame, además de información adicional relacionada con S7‑PLCSIM V16, que no estaba disponible en el momento de publicar el software.

Si observa un comportamiento inesperado en S7‑PLCSIM, consulte el sitio SIOS y busque "Léame S7-PLCSIM V16" para saber si hay una versión más reciente que trate su problema.


Novedades de S7-PLCSIM V16

Novedades de S7-PLCSIM V16

Este capítulo incluye información sobre los siguientes temas:
  • Resumen de las novedades
  • Soporte para la última versión del firmware
  • Simulación de eventos
  • Control de escaneado
  • Mejoras en la tabla SIM


Resumen de las novedades

Resumen de las novedades

S7‑PLCSIM V16 presenta las siguientes funciones nuevas o actualizadas:

  • Soporte de sistemas operativos

  • Soporte de la última versión del firmware

  • Simulación de eventos

  • Control de ciclos

  • Mejoras en la tabla SIM


Soporte para la última versión del firmware

Soporte para la última versión del firmware

S7‑PLCSIM V16 soporta la familia de CPU con el siguiente firmware:

  • S7‑1200 desde la versión 4.0 a la versión 4.4

  • S7‑1200F desde la versión 4.1 a la versión 4.4

  • S7‑1500 y S7‑1500F versión 2.8 y anteriores

  • ET 200SP y ET 200SPF versión 2.8 y anteriores


Simulación de eventos

Simulación de eventos

S7‑PLCSIM V16 proporciona tablas de eventos para simular los siguientes eventos de alarma:

  • Fallo de rack o estación

  • Enchufe o desenchufe de módulos

  • Alarma de proceso

  • Alarma de diagnóstico

Las tablas de eventos se agregan al árbol del proyecto.


Control de escaneado

Control de escaneado

S7‑PLCSIM V16 ofrece las siguientes funciones para controlar el ciclo de la CPU simulada:

  • Panel de mando de la CPU

  • Posibilidad de poner en pausa el ciclo del programa

  • Posibilidad de ejecutar ciclos de un periodo de tiempo concreto o de un número determinado de ciclos


Mejoras en la tabla SIM

Mejoras en la tabla SIM

S7‑PLCSIM V16 ofrece las siguientes mejoras con respecto a las tablas SIM:

  • Función Examinar para crear una tabla SIM a partir de las tablas de observación, de forzado o de variables PLC de STEP 7.

  • Posibilidad de mostrar y ocultar columnas en el editor de tablas SIM


Problemas conocidos

Problemas conocidos

Este capítulo incluye información sobre los siguientes temas:
  • S7-PLCSIM no puede simular la versión V5.2 de la comunicación Modbus TCP
  • La instrucción High_Speed_Counter devuelve un error


S7-PLCSIM no puede simular la versión V5.2 de la comunicación Modbus TCP

S7-PLCSIM no puede simular la versión V5.2 de la comunicación Modbus TCP

Si su programa STEP 7 utiliza la versión V5.2 de las instrucciones MB_SERVER y MB_CLIENT Modbus TCP, S7-PLCSIM no podrá simular la comunicación. Para simular estas instrucciones con S7-PLCSIM, deberá utilizar la versión V4.0 de estas instrucciones.


La instrucción High_Speed_Counter devuelve un error

Activación de STS_READY desde una tabla SIM

La instrucción High_Speed_Counter devuelve un error

Si utiliza S7-PLCSIM para simular un contador rápido en un módulo TM Count, la instrucción High_Speed_Counter devolverá el error 16#80C7.

La instrucción High_Speed_Counter espera que el módulo tenga activado un bit de estado disponible o 'ready' (STS_READY). Como S7-PLCSIM no simula el comportamiento del módulo, la instrucción devuelve un error.

El bit STS_READY se encuentra en el área de entradas del módulo, en el offset 13.4. Si el área de entradas del módulo TM Count empieza por %I32, por ejemplo, el bit STS_READY se encontrará en %I45.4.

Puede activar el bit STS_READY para impedir que aparezca la condición de error que devuelve la instrucción High_Speed_Counter.

Activación de STS_READY desde una tabla SIM

Supongamos un ejemplo en el que se utiliza un S7‑1500 con un módulo TM Count 1x24V, en el que el TM Count 1x24V empiece por %I.0. Tenga en cuenta que encontrará esta dirección en la configuración de dispositivos del módulo tecnológico.

Para ajustar el bit STS_READY del módulo a TRUE, introduzca la dirección de entrada I correspondiente al offset 13.4 en la tabla SIM. Ajuste el valor de forzado a TRUE. Por ejemplo, si el módulo empleado empieza por %I0, configure una entrada de la tabla SIM como se indica a continuación: