Esecuzione dell'installazione automatica

Esempi Vedere anche Storico Strumenti
Esecuzione dell'installazione automatica

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Nozioni di base sull'installazione automatica
  • Installazione automatica con il modo Record/Play
  • Installazione automatica dalla riga di comando
  • Elenco dei parametri
  • Valori di ritorno nel processo di installazione


Nozioni di base sull'installazione automatica

Introduzione
Nozioni di base sull'installazione automatica

Introduzione

Qualora l'utente sia responsabile della gestione dei pacchetti software su più sistemi, sono disponibili diverse opzioni per automatizzare l'installazione.

Funzione record/play

I seguenti processi di installazione possono essere eseguiti automaticamente tramite la funzione Record/Play:

  • Installazione

    L'installazione del software avviene sulla base dei parametri utilizzati.

  • Modifica o aggiornamento

    L'installazione del software avviene nuovamente sulla base dei parametri utilizzati.

Riga di comando

I seguenti processi di installazione possono essere eseguiti automaticamente tramite la riga di comando:

  • Installazione

    L'installazione del software avviene sulla base dei parametri utilizzati.

  • Modifica o aggiornamento

    L'installazione del software avviene nuovamente sulla base dei parametri utilizzati.

  • Riparazione (REINSTALL)

    Tramite quest'opzione il software già installato viene riparato tramite nuova installazione (reinstallazione). Il parametro "REINSTALL" può essere combinato esclusivamente con il parametro "REBOOT", "/qn" und "/qb". Il software viene quindi installato con gli stessi parametri utilizzati per l'installazione iniziale.

  • Disinstallazione (REMOVE)

    Il software viene rimosso dal sistema. Il parametro "REMOVE" può essere combinato esclusivamente con il parametro "REBOOT", "/qn" und "/qb".

Nota

Per l'installazione, la modifica, l'aggiornamento, la riparazione o la disinstallazione automatica, è necessario l'impiego del parametro "/qn" oppure "/qb". Tralasciando questo parametro, si apre la finestra di dialogo per l'installazione standard dove è possibile eseguire l'installazione manuale.


Installazione automatica con il modo Record/Play

Installazione automatica con il modo Record/Play

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Inizia registrazione
  • Selezione delle impostazioni di installazione
  • Esecuzione della registrazione


Inizia registrazione

Presupposti Procedimento Risultato
Inizia registrazione

Presupposti

  • Hardware e software del PG/PC devono essere conformi ai requisiti di sistema.

Procedimento

Per registrare l'installazione procedere nel modo seguente:

  1. Avviare il prompt di Windows mediante "Start > Esegui > cmd".

  2. Spostarsi nella directory che contiene il file "Start.exe".

  3. Digitare nel prompt il seguente comando:

    • "Start.exe /record"

  4. Confermare i dati immessi con <Invio>.

Risultato

Si apre la finestra di installazione; un'avvertenza segnala che ci si trova nel modo Record e che il sistema non viene modificato.


Selezione delle impostazioni di installazione

Procedimento Risultato
Selezione delle impostazioni di installazione

Procedimento

Per selezionare le opzioni di installazione procedere come indicato nel seguito:

  1. Nella finestra di dialogo per la selezione della lingua del setup, selezionare la lingua nella quale si desiderano visualizzare le finestre di dialogo del programma di setup e fare clic sul pulsante "Avanti".

    Si apre la finestra di dialogo per la selezione delle lingue del prodotto.

  2. Selezionare le lingue per l'interfaccia utente del prodotto e fare clic sul pulsante "Avanti".

    Nota

    La lingua "Inglese" viene sempre installata come lingua di base del prodotto.

    Si apre la finestra di dialogo per la selezione della configurazione del prodotto.

  3. Selezionare i prodotti da installare:

    • Per installare il programma con la configurazione minima, selezionare il pulsante "Minimal".

    • Per installare il programma con la configurazione standard del prodotto, selezionare il pulsante "Standard".

    • Per la selezione personalizzata dei programmi, attivare o disattivare le caselle di scelta dei prodotti che si desidera installare. In questo caso il pulsante "Personalizzato" viene attivato automaticamente.

  4. Se si intende creare un link sul desktop, attivare la casella di scelta "Crea un link sul desktop".

  5. Se si desidera modificare la directory di destinazione per l'installazione fare clic sul pulsante "Sfoglia".

    Nota

    Come directory di destinazione selezionare la cartella "Program Files". In caso di selezione di un disco rigido (ad es. "D:") accertarsi che quest'ultimo sia disponibile su tutti i computer sui quali si intende installare il programma.

  6. Fare clic sul pulsante "Avanti".

    Si apre la finestra di dialogo delle condizioni di licenza.

  7. Per proseguire con l'installazione, leggere e accettare tutte le condizioni di licenza e fare clic su "Avanti".

    La finestra di dialogo per le impostazioni di sicurezza si apre nel caso in cui l'installazione del portale TIA richieda la modifica delle impostazioni di sicurezza e dei diritti.

  8. Per proseguire con l'installazione, accettare le modifiche delle impostazioni di sicurezza e dei diritti e fare clic sul pulsante "Avanti".

    Nella finestra di dialogo successiva viene visualizzato un riepilogo delle impostazione di installazione.

  9. Controllare le impostazioni scelte per l'installazione. Per introdurre eventuali modifiche premere il pulsante "Indietro" fino a tornare al punto da modificare nella finestra di dialogo. Dopo aver apportato le modifiche desiderate, tornare alla vista generale con il pulsante "Avanti".

  10. Fare clic sul pulsante "Avanti".

    Si apre la finestra di dialogo del comportamento al riavvio e del comportamento al verificarsi di errori.

  11. Selezionare le opzioni desiderate e salvare la configurazione.

  12. Fare clic sul pulsante "Fine".

Risultato

Viene creato e salvato il file di installazione automatica.


Esecuzione della registrazione

Presupposti Procedimento Risultato
Esecuzione della registrazione

Presupposti

  • Hardware e software del PG/PC devono essere conformi ai requisiti di sistema.

  • È necessario disporre dei diritti di amministratore sul proprio computer.

  • Il file ("*.rec") in precedenza registrato deve essere disponibile.

  • Tutti i programmi attivi devono essere stati chiusi.

Procedimento

Per eseguire l'installazione procedere nel modo seguente:

  1. Avviare il prompt di Windows mediante "Start > Esegui > cmd".

  2. Spostarsi nella directory che contiene il file "Start.exe".

  3. Digitare nel prompt il seguente comando:

    • "Start.exe /play=<Drive>:\<Directory>\<Nome file>", ad es. "Start.exe /play=c:\siemens configuration\autoinstall.rec"

  4. Confermare i dati immessi con <Invio>.

    Nota

    Qualora durante l'installazione non sia possibile rilevare la chiave di licenza, l'operazione di trasferimento della licenza viene saltata e può essere eseguita in un secondo momento con Automation License Manager.

Risultato

L'installazione viene eseguita automaticamente con le impostazioni registrate nel file di configurazione.


Installazione automatica dalla riga di comando

Installazione automatica dalla riga di comando

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Automatizzazione dell'installazione
  • Modifica o aggiornamento automatici
  • Riparazione automatica
  • Disinstallazione automatica
  • Esempi di installazione automatica dalla riga di comando


Automatizzazione dell'installazione

Presupposti Procedimento
Automatizzazione dell'installazione

Presupposti

  • Hardware e software del PG/PC devono essere conformi ai requisiti di sistema.

  • È necessario disporre dei diritti di amministratore sul proprio computer.

  • Tutti i programmi attivi devono essere stati chiusi.

Procedimento

Per avviare direttamente l'installazione con le opzioni desiderate tramite l'interfaccia di comando procedere nel modo seguente:

  1. Avviare il prompt di Windows mediante "Start > Esegui > cmd".

  2. Spostarsi nella directory che contiene il file "Start.exe".

  3. Digitare uno dei seguenti comandi nel prompt:

    • Installazione con barra di avanzamento visibile: "<Parametro> Start.exe /qb"

    • Installazione senza barra di avanzamento visibile: "<Parametro>Start.exe /qn" oppure <Parametro> "Start.exe /silent"

      Nota

      Se viene impiegata l'opzione "REBOOT=Suppress", ricordare di eseguire l'analisi del valore di ritorno ed eventualmente il riavvio del sistema.

  4. Confermare i dati immessi con <Invio>.


Modifica o aggiornamento automatici

Presupposti Procedimento
Modifica o aggiornamento automatici

I prodotti installati possono essere automaticamente modificati o aggiornati ad una nuova versione (update). A tale scopo è possibile avviare direttamente una nuova installazione con le opzioni desiderate come riga di comando.

Presupposti

  • Hardware e software del PG/PC devono essere conformi ai requisiti di sistema.

  • È necessario disporre dei diritti di amministratore sul proprio computer.

  • Tutti i programmi attivi devono essere stati chiusi.

Procedimento

Per eseguire direttamente dalla riga di comando l'aggiornamento o la modifica dei prodotti installati, procedere nel modo seguente:

  1. Avviare il prompt di Windows mediante "Start > Esegui > cmd".

  2. Spostarsi nella directory che contiene il file "Start.exe".

  3. Digitare uno dei seguenti comandi nel prompt:

    • Installazione con barra di avanzamento visibile: "<Parametro> Start.exe /qb"

    • Installazione senza barra di avanzamento visibile: "<Parametro> Start.exe /qn" oppure <Parametro>"Start.exe /silent"

      Nota

      Se viene impiegata l'opzione "REBOOT=Suppress", ricordare di eseguire l'analisi del valore di ritorno ed eventualmente il riavvio del sistema.

  4. Confermare i dati immessi con <Invio>.


Riparazione automatica

Presupposti Procedimento
Riparazione automatica

Richiamando il file "Start.exe" dopo un'installazione riuscita, eseguita con il parametro "REINSTALL=ALL", oppure selezionando "Ripara" nell'installazione guidata, viene eseguita una nuova installazione di tutti i componenti (reinstallazione). L'installazione eseguita è identica alla precedente. Analogamente all'installazione, anche la riparazione automatica si svolge dall'interfaccia di comando. Inserendo un parametro è possibile definire il comportamento di riavvio.

Il parametro "REINSTALL" può essere combinato esclusivamente con il parametro "REBOOT", "/qn" und "/qb". Tutti gli altri parametri non sono ammessi.

Presupposti

  • Hardware e software del PG/PC devono essere conformi ai requisiti di sistema.

  • È necessario disporre dei diritti di amministratore sul proprio computer.

  • Tutti i programmi attivi devono essere stati chiusi.

Procedimento

Per riparare l'installazione direttamente dall'interfaccia di comando, procedere nel modo seguente:

  1. Avviare il prompt di Windows mediante "Start > Esegui > cmd".

  2. Spostarsi nella directory che contiene il file "Start.exe".

  3. Digitare uno dei seguenti comandi nel prompt:

    • Installazione con barra di avanzamento visibile: "Parametro Start.exe /qb REINSTALL=ALL e <parametro REBOOT>"

    • Installazione senza barra di avanzamento visibile: "<Parametro>Start.exe /qn REINSTALL=ALL, <Parametro><REBOOT, oppure <Parametro> "Start.exe /silent REINSTALL=ALL <REBOOT"

      Nota

      Il parametro REBOOT è facoltativo. Se viene impiegata l'opzione "REBOOT=Suppress", ricordare di eseguire l'analisi del valore di ritorno ed eventualmente il riavvio del sistema.

  4. Confermare i dati immessi con <Invio>.


Disinstallazione automatica

Presupposti Procedimento
Disinstallazione automatica

La rimozione di un'installazione preesistente può essere eseguita tramite disinstallazione automatica. Quest'operazione disinstalla il pacchetto software completo. Analogamente all'installazione, anche la disinstallazione automatica si svolge dall'interfaccia di comando. Inserendo un parametro è possibile definire il comportamento di riavvio.

Il parametro "REMOVE" può essere combinato esclusivamente con il parametro "REBOOT", "/qn" und "/qb". Tutti gli altri parametri non sono ammessi.

Presupposti

  • È necessario disporre dei diritti di amministratore sul proprio computer.

  • Tutti i programmi attivi devono essere stati chiusi.

Procedimento

Per avviare la disinstallazione direttamente dall'interfaccia di comando, procedere nel modo seguente:

  1. Avviare il prompt di Windows mediante "Start > Esegui > cmd".

  2. Spostarsi nella directory che contiene il file "Start.exe".

  3. Digitare uno dei seguenti comandi nel prompt:

    • Disinstallazione con barra di avanzamento visibile: "Parametro Start.exe /qb REMOVE =ALL e <parametro REBOOT>"

    • Disinstallazione senza barra di avanzamento visibile: "<Parametro> Start.exe /qn REMOVE =ALL, <Parametro REBOOT>", oppure <Parametro> "Start.exe /silent REMOVE =ALL <REBOOT"

      Nota

      Il parametro REBOOT è facoltativo. Se viene impiegata l'opzione "REBOOT=Suppress", ricordare di eseguire l'analisi del valore di ritorno ed eventualmente il riavvio del sistema.

  4. Confermare i dati immessi con <Invio>.


Esempi di installazione automatica dalla riga di comando

Esempio di installazione automatica standard REBOOT=AUTO Esempio di installazione completa con REBOOT=Suppress Esempio di interrogazione del valore di ritorno tramite file batch
Esempi di installazione automatica dalla riga di comando

Esempio di installazione automatica standard REBOOT=AUTO

Il seguente esempio illustra l'installazione standard dalla riga di comando:

Start.exe /qb REBOOT=Auto INSTALLLANGUAGE=1031;1033 INSTALLDIR="C:\Program Files\Siemens\Automation" INSTALLLEVEL=Typical

Nel presente esempio viene eseguita l'installazione standard ("INSTALLLEVEL=Typical") per la lingua tedesca e per la lingua inglese ("INSTALLLANGUAGE=1031;1033"). Al termine dell'installazione, il sistema viene riavviato automaticamente senza richiesta di conferma ("REBOOT=Auto"). La directory di installazione si trova in "C:\Program Files\Siemens\Automation" ("INSTALLDIR=C:\Program Files\Siemens\Automation").

Esempio di installazione completa con REBOOT=Suppress

Il seguente esempio illustra l'installazione completa dalla riga di comando:

Start.exe /qb REBOOT=Suppress INSTALLLANGUAGE=1031;1033 INSTALLDIR="C:\Program Files\Siemens\Automation" INSTALLLEVEL=Complete

Nel presente esempio viene eseguita l'installazione completa ("INSTALLLEVEL=Complete") per la lingua tedesca e per la lingua inglese ("INSTALLLANGUAGE=1031;1033"). Al termine dell'installazione il riavvio del sistema viene inibito ("REBOOT=Suppress"). Il valore di ritorno deve essere di conseguenza analizzato dall'utente che dovrà eventualmente riavviare il sistema.

Esempio di interrogazione del valore di ritorno tramite file batch

L'esempio seguente riporta l'interrogazione del valore di ritorno tramite file batch:

SET SetupSuccess=%ERRORLEVEL%

if '%SetupSuccess%' EQU '0' (

echo Setup successful. Return code: %SetupSuccess%

) else (

if '%SetupSuccess%' EQU '3010' (

echo Setup successful. A reboot is needed! Return code: %SetupSuccess%

) else (

echo "ERROR during Setup! Return code: %SetupSuccess%

)

)

Pausa

Il valore di ritorno "1641" documenta a sua volta la riuscita dell'installazione e l'inizio del riavvio. Esso si presenta tuttavia soltanto con l'impiego di "/REBOOT=Auto" e non è stato pertanto analizzato nel file batch di quest'esempio.

Tutti i valori di ritorno sono riportati in Valori di ritorno nel processo di installazione.


Elenco dei parametri

Parametri per l'installazione automatica
Elenco dei parametri

Parametri per l'installazione automatica

La seguente tabella mostra i parametri disponibili per l'installazione automatica:

Parametri

Descrizione

Ammessi per

Valori possibili

Spiegazione dei valori

/qb

Con l'ausilio di questi parametri è possibile eseguire l'installazione automatica. Una barra di avanzamento indicherà il procedere dell'operazione di installazione in corso.

Note:

  • In assenza dei parametri "qb" o "qn", l'installazione automatica non è possibile.

  • I parametri "qn" e "qb" non possono essere impiegati congiuntamente in un richiamo.

  • Le informazioni visualizzate durante l'installazione sono soltanto in lingua inglese. Ciò ne consente l'integrazione nei testi dei file di protocollo. I file di protocollo sono ad es. necessari qualora ci si rivolga al Support.

Installazione

Reinstallazione

Disinstallazione

-

/qn oppure /silent

Con l'ausilio di questi parametri è possibile eseguire l'installazione automatica. Durante l'installazione non vengono fornite informazioni sul procedere dell'operazione.

Nota:

  • In assenza dei parametri "qb" o "qn", l'installazione automatica non è possibile.

  • I parametri "qn" e "qb" non possono essere impiegati congiuntamente in un richiamo.

Installazione

Reinstallazione

Disinstallazione

-

/lcid

Con questo parametro è possibile definire la lingua del setup nella quale eseguire l'installazione. A tale scopo inserire i seguenti ID locali (LCID) della lingua desiderata in formato decimale.

Esempio:

/lcid=1031

Installazione

Reinstallazione

Disinstallazione

1031

Tedesco

1033

Inglese

1040

Italiano

1036

Francese

3082

Spagnolo

2052

Cinese

...

Ulteriori lingue del prodotto

/record

Con l'ausilio di questo parametro è possibile avviare il modo Record nel quale viene creato il file "autoinstall.rec" per l'installazione automatica

Installazione

/play

Con l'ausilio di questo parametro è possibile avviare il modo Play che richiede il file di configurazione creato nel modo Record.

Esempio:

/play="C:\Siemens Configurations\autoinstall.rec"

Installazione

INSTALLDIR

Con questo parametro è possibile definire la directory di destinazione per l'installazione.

Esempio:

INSTALLDIR="C:\Program Files\Siemens\Automation"

Installazione

INSTALLLANGUAGE

INSTALLLANGUAGE

Con questo parametro è possibile definire le lingue del prodotto da installare. A tale scopo immettere i seguenti ID locali (LCID) delle lingue desiderate in formato decimale.

Esempio:

INSTALLLANGUAGE=1031;1033

Installazione

1031

Tedesco

1033

Inglese

1040

Italiano

1036

Francese

3082

Spagnolo

2052

Cinese

...

Ulteriori lingue del prodotto

REBOOT

Con questo parametro è possibile definire il comportamento al riavvio durante l'installazione.

Esempio:

REBOOT=Suppress

Installazione

Reinstallazione

Disinstallazione

Auto

Se necessario, al termine dell'installazione viene eseguito un riavvio automatico.

Suppress

Al termine dell'installazione viene inibito il riavvio. Qualora fosse necessario un riavvio, sarà il processo richiamante a dovere provocare il riavvio.

ONERROR

Con questo parametro è possibile definire il comportamento in caso di errore al termine dell'installazione.

Esempio:

ONERROR=Suppress

Installazione

Reinstallazione

Disinstallazione

Suppress

Al termine dell'installazione la finestra di dialogo con gli errori verificatisi viene inibita. L'analisi degli errori può essere eseguita sulla base dei valori di ritorno del processo.

User

Al termine dell'installazione viene visualizzata, in caso di errori, la finestra di dialogo con il riepilogo degli stessi.

INSTALLLEVEL

Con questo parametro è possibile definire il tipo di installazione.

Esempio:

INSTALLLEVEL=Complete

Installazione

Minimal

Installazione minima

Typical

Installazione standard

Complete

Installazione completa


Valori di ritorno nel processo di installazione

Elenco dei valori di ritorno
Valori di ritorno nel processo di installazione

Elenco dei valori di ritorno

La tabella seguente riporta i valori di ritorno dell'l'installazione automatica e il relativo significato:

Valore di ritorno | Descrizione tecnica dell'errore | Descrizione
? | OtherError | Tutti i valori di ritorno non descritti nella tabella sottostante, indicano generalmente un errore. Informazioni dettagliate su tutti gli errori sono normalmente riportate nel protocollo dell'installazione. Aprire a tal fine il file di protocollo più recente il cui nome inizia con "SIA".
0 | Success | Installazione riuscita. Non si sono verificati errori.
5 | AccessDenied | Diritti insufficienti. L'installazione richiede il possesso dei diritti di amministratore.
112 | DiskFull | Spazio di memoria insufficiente sul supporto di destinazione.
1601 | InstallServiceFailure | Durante la fase di inizializzazione si è verificato un errore interno.
1602 | UserExit | Annullamento da parte dell'utente dovuto generalmente ad un'interruzione selezionata nella finestra di dialogo.
1603 | InstallFailure | Durante la fase di installazione si è verificato un errore.
1605 | UnknownProduct | Durante la configurazione del prodotto si è verificato un errore interno.
1610 | BadConfiguration | Durante la configurazione del prodotto si è verificato un errore interno.
1618 | InstallAlreadyRunning | E' già in corso un'altra installazione. Non è possibile effettuare l'esecuzione simultanea.
1622 | InstallLogFailure | Durante la scrittura nel protocollo si è verificato un errore.
1627 | FunctionFailed | Si è verificato un errore interno.
1633 | InstallPlatformUnsupported | Questo sistema operativo non viene supportato.
1639 | InvalidCommandline | Errore nella riga di comando indicata.
1641 | SuccessRebootInitiated | Installazione riuscita. Per terminare completamente l'operazione è già stato iniziato il riavvio.
3010 | SuccessRebootRequired | Installazione riuscita. Per terminare completamente l'operazione è assolutamente necessario il riavvio
5001 | PrerequisitesFailure | Le condizioni di installazione non sono state soddisfatte. Per maggori informazioni, avviare nuovamente l'installazione facendo doppio clic sul file start.exe.
5002 | InvalidIEVersion | Internet Explorer non disponibile oppure in una versione non supportata.
5003 | ResourcesFailed | Durante la fase di inizializzazione si è verificato un errore interno.
5004 | ProductInitFailed | Si è verificato un errore interno (il supporto di installazione potrebbe essere difettoso).
5005 | ProductInitNewerVersionInstalled | E' già installata una nuova versione del prodotto.
5006 | ProductInitMoreValuableEditionInstalled | E' già stata installata una versione integrale del prodotto (si è ad es. cercato di installare la versione di base nonostante sia già installata la versione Professional).
5007 | ProductInitOptionalWithoutMain | E' stato effettuato il tentativo di installare un pacchetto opzionale senza aver in precedenza installato il software principale.
5008 | ProductIncompatibility | Il prodotto da installare è incompatibile con un prodotto preesistente.
5009 | AutoinstallFileNotFound | Impossibile rilevare il file per il modo Play.
5010 | AutoinstallUnexpectedContent | Impossibile leggere il file per il modo Play (formato o versione errati oppure supporto di installazione incompatibile)
11641 | NotCompleteReboot | Il setup è incompleto e deve essere continuato dopo il riavvio. Il riavvio è già stato avviato. Dopo il riavvio è necessario avviare nuovamente l'installazione.
13010 | NotCompleteRebootRequired | Il setup è incompleto e deve essere continuato dopo il riavvio. Attivare il riavvio e, al termine di quest'operazione, avviare nuovamente l'installazione.