Leggimi di S7-PLCSIM V16

Nella sezione Istruzioni Esempi Nozioni di base Cronologia Strumenti
Avvio Indietro Avanti

Leggimi di S7-PLCSIM V16

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Panoramica delle informazioni più recenti sul prodotto disponibili online
  • Quali nuove funzioni sono disponibili in S7-PLCSIM V16?
  • Problemi noti


Panoramica delle informazioni più recenti sul prodotto disponibili online

Panoramica delle informazioni più recenti sul prodotto disponibili online

Siemens aggiorna il presente file Leggimi secondo necessità e lo pubblica nel sito web Siemens Industry Online Support ("SIOS”). I file Leggimi del sito SIOS hanno lo stesso contenuto di questo file Leggimi, ma comprendono anche alcune informazioni su S7‑PLCSIM V16 che non erano disponibili alla data di rilascio del prodotto.

Se si riscontra un comportamento anomalo in S7‑PLCSIM consultare il sito SIOS e cercare il file “Leggimi S7-PLCSIM V16” per verificare se è disponibile una versione più recente che si occupa del problema riscontrato.


Quali nuove funzioni sono disponibili in S7-PLCSIM V16?

Quali nuove funzioni sono disponibili in S7-PLCSIM V16?

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • Riepilogo delle nuove funzioni
  • Supporto del firmware più recente
  • Simulazione di eventi
  • Controllo delle scansioni
  • Ampliamenti alla tabella SIM


Riepilogo delle nuove funzioni

Riepilogo delle nuove funzioni

S7‑PLCSIM V16 ha introdotto le seguenti funzioni nuove o aggiornate:

  • Supporto sistema operativo

  • Supporto del firmware più recente

  • Simulazione di eventi

  • Controllo delle scansioni

  • Ampliamenti alla tabella SIM


Supporto del firmware più recente

Supporto del firmware più recente

S7‑PLCSIM V16 supporta i dispositivi delle famiglie di CPU con il seguente firmware:

  • S7‑1200: versione da 4.0 a 4.4

  • S7‑1200F: versione da 4.1 a 4.4

  • S7‑1500 and S7‑1500F: versione 2.8 e inferiore

  • ET 200SP and ET 200SPF: versione 2.8 e inferiore


Simulazione di eventi

Simulazione di eventi

S7‑PLCSIM V16 fornisce le tabelle degli eventi per simulare i seguenti eventi di interrupt:

  • Guasto del telaio o della stazione

  • Estrazione o inserimento di moduli

  • Interrupt di processo

  • Allarme di errore di diagnostica

Aggiungere le tabelle di eventi nell'albero del progetto.


Controllo delle scansioni

Controllo delle scansioni

S7‑PLCSIM V16 dispone delle seguenti funzioni per controllare il ciclo di scansione della CPU simulata.

  • Pannello operatore CPU

  • È possibile mettere in pausa la scansione del programma

  • È possibile eseguire una scansione per un particolare periodo di tempo o numero di cicli.


Ampliamenti alla tabella SIM

Ampliamenti alla tabella SIM

S7‑PLCSIM V16: fornisce i seguenti miglioramenti per le tabelle SIM:

  • la funzione Sfoglia consente di creare una tabella SIM da una tabella di variabili, tabella di controllo o forzamento PLC di STEP 7.

  • È possibile nascondere e visualizzare le colonne dell’editor di tabelle SIM.


Problemi noti

Problemi noti

Questo capitolo contiene informazioni sugli argomenti seguenti:
  • S7-PLCSIM non può simulare la comunicazione Modbus TCP V5.2
  • Errore restituito dall'istruzione High_Speed_Counter


S7-PLCSIM non può simulare la comunicazione Modbus TCP V5.2

S7-PLCSIM non può simulare la comunicazione Modbus TCP V5.2

Se il programma STEP 7 utilizza la versione V5.2 delle istruzioni Modbus TCP MB_SERVER e MB_CLIENT, S7-PLCSIM non può simulare la comunicazione. Per poter simulare queste istruzioni con S7‑PLCSIM le si deve utilizzare nella versione V4.0.


Errore restituito dall'istruzione High_Speed_Counter

Impostazione di STS_READY da una tabella SIM

Errore restituito dall'istruzione High_Speed_Counter

Se si utilizza S7-PLCSIM per simulare un contatore veloce in un modulo TM Count l'istruzione High_Speed_Counter restituisce l'errore 16#80C7.

L'istruzione High_Speed_Counter si aspetta che il modulo abbia impostato un bit di stato "pronto" (STS_READY). Poiché S7-PLCSIM non simula il comportamento del modulo l'istruzione restituisce un errore.

Il bit STS_READY si trova nell'offset 13.4 dell'area di ingresso del modulo. Se l'area di ingresso del modulo TM Count inizia in %I32, ad esempio, il bit STS_READY viene impostato su %I45.4.

Il bit STS_READY può essere impostato per evitare la condizione di errore restituita dall'istruzione High_Speed_Counter.

Impostazione di STS_READY da una tabella SIM

Si consideri un esempio che utilizza un'S7‑1500 con un modulo TM Count 1x24V che inizia in %I.0. Questo indirizzo è indicato nella configurazione del dispositivo del modulo tecnologico.

Per impostare su TRUE il bit STS_READY per il modulo immettere nella tabella SIM il corrispondente indirizzo I per l'offset 13.4. Impostare il valore modificato su TRUE. Ad esempio, se il modulo inizia in %I0 configurare una voce della tabella SIM nel seguente modo: