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AFTER HOURS

10 advanced formatting tricks for Excel users

Your worksheets will be more polished and easy to read if you learn a few sophisticated
formatting techniques.

By Susan Harkins | in 10 Things, March 7, 2013, 4:28 AM PST

Most Excel users know how to apply basic numeric and text formats. But users who push
beyond the basics will create more readable and effective sheets. In addition, knowing

how to apply just the right formatting to specific cells quickly and easily helps users work
more efficiently. These 10 tips will help users get more out of Excel's formatting features.

1: Use the fill handle to copy formatting

The fill handle is a versatile and powerful tool. Besides copying formulas and creating
series, the fill handle can copy formats with just a few quick clicks:

1. Select the cell that contains the formatting you want to copy. In Figure A, I've selected
A2 to copy the bold font and gray fill color to the remaining cells in column A.

2. Double-click the cell's fill handle. The fill handle's series behavior has kicked into gear
by overwriting the TOTALS label with January. Don't worry about that, you can undo that
next.

3. Click the resulting AutoFill Options control to display the list shown in Figure B.

4. Select the Fill Formatting Only option.

Figure A

A2

f;r January

Saldl Jones Michaels Hancock Totals

2 |January $4,212.64 $6,795.69 $2,148.78 $4,611.14 $17,768.25
3 February ~ $3,194.08 $3,449.36 $9,020.05 $7,401.84 $23,065.33
4 'March $3,000.00 $2,332.71 $8,507.84 $4,224.17 $18,064.72
5 April $2,500.00 $2,804.82 $9,078.84  $7,620.23  $22,003.89
6 May $2,989.75 $2,504.17 $4,263.65 $2,706.73 $12,464.30
7 |June $3,200.34 $5,426.36 $5,325.03 $4,494.94 $18,446.68
8 July $6,912.61 $4,229.14 $6,361.90  $5,936.46 $23,440.11
9 August $4,596.56 $5,936.79 $3,222.88 $3;304.52 $17,060.75
10 September $7,529.99 $7,673.70 $2,862.51 $3,831.45 $21,897.65
11 |October $5,188.08 $9,840.23 $2,489.00 $6,686.40 $24,203.70
12 November $3,085.00 $2,209.72 $5,197.35 $3,495.50 $13,987.57
13 December $3,656.00 $4,578.77 $938.35 $7,961.63  $17,134.76
14 TOTALS S50.065.06 S57.781.45 S59.416.19 S62.275.01 S$229.537.71
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Select the source cell — the cell containing the formats you want to copy.

Figure B

Michaels Hancock
$4,212.64 $6,795.69 $2,148.78 $4,611.14 $17,768.25
$3,194.08 $3,449.36 $9,020.05 $7,401.84 $23,065.33

$3,000.00 $2,332.71 $8,507.84 $4,224.17 $18,064.72
$2,500.00 $2,804.82 $9,078.84 $7,620.23 $22,003.89
$2,989.75 $2,504.17 $4,263.65 $2,706.73 $12,464.30
$3,200.34 $5,426.36 $5,325.03 $4,494.94 $18,446.68
$6,912.61 $4,229.14 $6,361.90 $5,936.46 $23,440.11
$4,596.56 $5,936.79 $3,222.88 $3,304.52 $17,060.75
$7,529.99 $7,673.70 $2,862.51 $3,831.45 $21,897.65

' Copy Cell 84023  $2,489.00  $6,686.40  $24,203.70
| 209.72  $5197.35  $3,495.50  $13,987.57
NG rime PIEIT $938.35 $7,961.63  $17,134.76
810 i ontns 781.45 $59,416.19 $62,275.01 $229,537.71

=

=

Choose the Fill Formatting Only option to cancel the series overwrite and still copy the formats from the source cell.

You can see that the fill handle canceled the series values in Figure C. In addition, the
action reverted to the original data and applied the formats from A3 to the destination
range. This method isn't superior to Format Painter, but you won't have to select the target
range, which can be awkward with a large one.

Figure C
\ : ;

A | B | C D E F G
1 Smith Jones Michaels Hancock Totals
2 January $4,212.64 $6,795.69 $2,148.78 $4,611.14 $17,768.25
3 February $3,194.08  $3,449.36  $9,020.05 $7,401.84  $23,065.33
4 March $3,000.00 $2,332.71  $8,507.84  $4,224.17  $18,064.72
5 April $2,500.00 $2,804.82 $9,078.84  $7,620.23  $22,003.89
6 May $2,989.75  $2,504.17  $4,263.65 $2,706.73  $12,464.30
7 June $3,200.34 $5,426.36 $5,325.03 $4,494.94 $18,446.68
8 July $6,912.61 $4,229.14 $6,361.90 $5,936.46 $23,440.11
9 August $4,596.56 $5,936.79 $3,222.88 $3,304.52 $17,060.75
10 September | $7,52999 $7,673.70 $2,862.51  $3,831.45  $21,897.65
11 October $5,188.08  $9,840.23  $2,489.00 $6,686.40  $24,203.70
12 November $3,085.00 $2,209.72  $5,197.35  $3,49550  $13,987.57
13 December $3,656.00 $4,578.77 $938.35 $7,961.63 $17,134.76
14 TOTALS $50,065.06 $57,781.45 $59,416.19 $62,275.01 $229,537.71
15 B
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Excel's fill handle copied only the source cell's formats.

2: Use Paste to copy formatting

Another quick copy trick utilizes the Paste feature. Again, the Format Painter works great
with a small range, but this trick is helpful when copying formats to an entire column or row:

1. Select the source cell and press [Ctrl]+C.

2. Click anywhere inside the destination column or row.

3. Press [CtrIH[Spacebar] to select the entire column or [Shift[+{Spacebar] to select the
entire row. (This works only with a blank data range.) 2010: With the column or row
selected, choose Formatting from the Paste drop-down (in the Clipboard group). 2007:
Choose Paste Special from the Paste drop-down and click Formats in the Paste section.
2003: Right-click a selected cell and choose Paste Special from the submenu. In the
resulting dialog, click Formats in the Paste section.

4. Using Live Preview, you can see what the applied formats will look like. Click OK if you

decide to apply them.

You can also format a new chart using Paste. Select the source chart and press [CtrI][+C.
Select the destination chart and choose Paste Special from the Paste drop-down. Choose
Formats and click OK.

3: Copy styles between workbooks

If you use the same custom cell styles in multiple workbooks, don't spend time re-creating
each style. Instead, copy the style from one file to another as follows:

1. Open the source workbook and a destination workbook.

2. From the destination workbook, click Cell Styles in the Styles group on the Home tab. In
Excel 2003, choose Styles from the Format menu.

3. Choose Merge Styles at the bottom of the gallery.

4. In the resulting dialog, select the open workbook that contains the styles you want to

copy.
5. Click OK twice.

If you want all new workbooks to share the same custom style, open Excel's default
workbook, book.xItx as the destination. (Open book.xlIt in Excel 2003.) Add the style, then
save and close the template file. All new workbooks based on book.xltx will contain the

merged styles.

4: Create a custom format for readable data
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Numbers with a few digits are easy to read. Once you drop in that second thousands

separator, numbers become less readable, especially if your data contains lots of them.

Fortunately, a custom format can reduce the number of digits, making them easier to read,

but without changing the scale. To illustrate, we'll apply this custom format to the values in

the bottom range (so you can compare):

1. Select B9:E13 and click the Number group's dialog launcher or press [Ctrl]+1 to display

the Format Cells dialog.

2. From the Category list (on the Number tab) choose Custom.

3. In the Type control, enter the $#.##," M"; format string, as shown in Figure D. The

pound sign combined with the two comma characters displays a character in the

millions position, if one exists. The M component displays a literal M character, to

denote millions.

4. Click OK to see the results in Figure E.

Figure D
l Format Cells N 21x]
. Number IAIignment I Font I Border I Fill I Protectionl
Category:
[ General ;l ~Sample
Number
79M
Currency )
Accounting Type:
Date " gt
Time S ##,," M
Percentage General -
Fraction 0 Il
Scientific 0.00
| Text #,##0 —

Special #,##0.00
EETTEE |+ rr0)s, 20
#,##0_);[Red](#, ##0)
[ #,##0.00_);(#,##0.00)
#,##0.00_);[Red](#,##0.00)
‘ 5,420 )i(4#, #£0)
$#,##0 );[Red]($#, ##0)

hZ|

Type the number format code, using one of the existing codes as a sta

=l
Delete l

rting point,

| 0K I Cancel

Add this custom format string.

Figure E
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2 North $1,793,906 $1,941,972 52,949,318 $1,379,624
3 South $141,897 $3,901,525 $3,031,663 $1,791,178
4 East $7,692,284 §763,317 51,366,237 $182,908
5 West $2,643,272 $1,089,000 S$1,559,500 $21,253
6 Totals $12,271,359 $7,695,814 58,906,718 $3,374,963
7
i Smith Jones Michaels Hancock
i North $1.79 M $1.94 M $2.95 M $1.38 M
E_ South S.14 M S3.9M $3.03 M $1.79 M
Ll East S7.69 M S.76 M S1.37 M S.18 M
12 West S2.64 M S1.09M S1.56 M S.02M
14

Compare the results of the custom format to the unformatted values.

Refer to Create or delete a custom number format (http://office.microsoft.com/en-gb/excel-help/create-

or-delete-a-custom-number-format-HP005199500.aspx) for a comprehensive list of formatting codes.

5: Create a cell style that indicates purpose

Using a Cell Style to identify purpose helps users acclimate quicker. It also provides an
easy way to ensure consistency in an organization. For example, you might use color to
distinguish input and label cells. Using a Cell Style is an efficient way to put that convention
to work. Let's illustrate this concept by creating a Cell Style for input cells:

1. Click the Home tab and then click Cell Styles in the Styles group. In Excel 2003, choose
Style from the Format menu and skip to #3.

. Click New Cell Style at the bottom of the list.

. In the resulting dialog box, enter a name for the style, such as /nputCell.

. Click Format. In Excel 2003, click Modify.

. Click the Border tab and choose the Outline option in the Presets section.

6. Click the Fill tab and choose light blue.

7. Click OK to view the selected formats shown in Figure F.

8. Click OK again.

o A W N

Figure F

+ Style name: IInputCeIl
|

I
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LIS A T Uy LGRS
i ¥ Humber  General
IV alignment General, Bottom Aligned
v Font Calibri (Body) 11, Text 1
. ¥ Border Left, Right, Top, Bottom Borders
v Fil Shaded

IV Protection Locked

QK Cancel

We've created a Cell Style using these formats.

Anytime you want to indicate an input cell or range, do the following:

1. Select the cell.

2. On the Home tab, click the Cell Styles option. In Excel 2003, choose Style from the
Format menu.

3. Click InputCell as shown in Figure G and Excel will apply that style to the selected cell
or range. In Excel 2003, choose InputCell from the drop-down list and click Add.

.
Figure G
@: =9~ BElQ&EHEp);- o &= 2132Demo.xlsx - Microsoft Excel
Home Menu Insert Page Layout Formulas Data Review View Developer PDF Architect @ e
= — R =- _] = R | 5= Insert ~ T A 5
Calibri PALLS owmbRs == = Currency > oo \ =4 | Y {
—] A I‘ﬂ ‘ ‘d [ Delete ~ ;j' Z?
Paste B 7 U~ i~ &GyA =E= ey $ ~ 9% o - 0p Candltlonal Forma Cell . . Sort& Find
> ¥ i = - = : % > | Formatting ~ as Tablelr [Styles ~ f2) Format ~ | &7 Filter~ Selec
Clipboard & Font P
B2 - Je | 1793906

A B C | Normal [Bad Good Neutral

1 Smith Nlolsl Data and Model

2 North 1793906 19£|«f_a5r.t:iaiir:w‘ ||» I | Explanatory ... L ‘_ : Note
Warning Text

3 south 141897 39( Titles and Headings

4 East 7692284.184 7¢ HeadinE 1 Heading2 Heading 3 Heading 4 Title Total
Themed Cell Styles

5 West | 2643271.658 10€ 20%- Accent:s  20%-Accent2  20%- Accent3  20%- Accentd  20%- Accents  20% - Acc

6 Totals s 12 271 359 $7 BOF 40%- Accentl  40%-Accent2  40%-Accent3  40%-Accentd  40%- Accents  40% - Acck

8 Smith Jon Number Format

9 North 51 79 M 1 Comma Comma [0] Currency Currency [0] Percent
i) Mew Cell Style...

10 SOUth s-14 M Sé] Merge Styles...

11 Fasat S7 AO M S 7AW ST X771 S TR

You'll find the custom Cell Style in the gallery.

Using a Cell Style is efficient for the workbook's author, but it also helps users quickly

identify a cell or range's purpose.
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6: Copy formats quickly

An efficient copy technique is a good tool, especially if you can choose what to copy on
the fly. To do so, select the destination cell or range. Then, right-click the border and drag
it to the target cell. When you release the mouse, Excel will display the submenu shown in
Figure H. Choose the Copy Here As Formats Only option. That was easy!

Figure H

Move Here
(o

opy Here

Copy Here as Formats Only

Create Hyperlink Here

Cancel

e

This copy trick lets you choose what to copy on the fly.

7: Add a background image

Adding a background image to a sheet is so easy that you might be tempted to spruce up
all your sheets this way. (You'll refrain from doing so, of course.) To add an image to a
sheet's background, do the following:

1. Click the Page Layout tab.
2. Click the Background option in the Page Setup group.
3. Browse to the file and double-click it.

8: Quickly apply table formatting

If you select a range and choose a built-in format from the Format As A Table drop-down,
Excel (2007 and later) converts the range to a Table object. If the format works for you, but
you don't want a Table object, you can keep the format and dump the Table. Doing so
takes a few clicks, but probably fewer than formatting manually. To format the data range
quickly using a built-in Table format, do the following:

1. Click anywhere inside the data range.
2. On the Home tab, click the Format As Table drop-down and choose a format from the
gallery.
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3. Choose appropriately when Excel asks if the range has headers and click OK.

4. Click anywhere inside the table.

5. With the contextual Design tab current, choose Convert To Range in the Tools group.
6. Click Yes to confirm the action.

You'll format a data range with only six clicks (or a few more depending on how many times
you click the thumb in the gallery).

9: Save formats as styles

When you use the Number Formats drop-down in the Number group (on the Home tab),
you're actually applying a style — a style you can control. For instance, the Percent style
displays two decimal values, and you might want to inhibit all decimal values for
percentages. To do so, click the Number group's dialog launcher, click the Number tab,
choose Percentage, change the Decimal Places value to 0, and click OK.

We tend to think of these styles as formats set in stone, but they're not. Modify them to suit
your needs. Styles are available only to the workbook in which you save them, but you can
modify the styles in your templates.

10: Format as you go

For a quick one-time solution, you can format some values as you enter them:

e To enter currency, type a dollar sign ($) before typing the value to apply the Currency
format.

e To enter most fractions, type O. Then, press the spacebar and type the fraction,
including the slash. Excel will display the value as a fraction and store the decimal
value.

e To enter a percentage, simply follow the value with a percent sign. ()

Automatically sign up for TechRepublic's 10 Things newsletter! (http://www.techrepublic.com

/util/newsletter-signup/e042)

About Susan Harkins

Susan Sales Harkins is an IT consultant, specializing in desktop solutions. Previously, she

was editor in chief for The Cobb Group, the world's largest publisher of technical journals.
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